FastReport Namespace

[image]

FastReport.Net Class Reference
FastReport Namespace
Send Feedback

Classes

Class | Description
AfterDatabaseLoginEventArgs | Provides data for the AfterDatabaseLogin event.
AssemblyInitializer | The FastReport.dll assembly initializer.
BandBase | Base class for all bands.
BandCollection | Represents a collection of bands.
BandColumns | This class holds the band columns settings. It is used in the Columns property.
Base | Represents the root class of the FastReport object's hierarhy.
Border | Represents a border around the report object.
BorderLine | Represents a single border line.
BreakableComponent | Base class for report components that can break across pages.
BreakableComponentMenu | This class represents the context menu of the BreakableComponent.
CapSettings | Specifies a start and end line caps.
CellularTextObject | Represents a text object which draws each symbol of text in its own cell.
CheckBoxObject | Represents a check box object.
ChildBand | This class represents a child band.
ColumnFooterBand | This class represents a column footer band.
ColumnHeaderBand | This class represents a column header band.
ComponentBase | Class that implements some object's properties such as location, size and visibility.
ComponentMenuBase | The base class for the context menu of the report component.
ConditionCollection | Represents a collection of highlight conditions used in the Highlight property of the TextObject.
CustomLoadEventArgs | Provides data for the LoadBaseReport event.
DataBand | This class represents the Data band.
DatabaseLoginEventArgs | Provides data for the DatabaseLogin event.
DataColumnSmartTag | Class represent a smart tag that is used to choose a data column.
DataFooterBand | This class represents a data band footer.
DataHeaderBand | This class represents a header of the data band.
DataSourceSmartTag | Represents a smart tag that is used to choose a data source.
EmailSettings | Contains the email settings such as recipient(s) address, name, subject, message body.
EnvironmentSettings | This class contains some global settings that used in the FastReport.Net.
FillBase | Base class for all fills.
FilterPropertiesEventArgs | Provides data for the FilterProperties event.
GetPropertyKindEventArgs | Provides data for the GetPropertyKind event.
GetTypeInstanceEventArgs | Provides data for the GetTypeInstance event.
GlassFill | Class represents the glass fill.
GraphicCache | Represents a cache of graphics objects such as pens, brushes, fonts and text formats.
GroupFooterBand | Represents a group footer band.
GroupHeaderBand | Represents a group header band.
HatchFill | Class represents the hatch fill.
HeaderFooterBandBase | Base class for headers and footers which support the "Keep With Data" and "Repeat on Every Page" features.
HighlightCondition | Represents a single highlight condition used by the Highlight property of the TextObject.
Hyperlink | This class contains a hyperlink settings.
LinearGradientFill | Class represents the linear gradient fill.
LineObject | Represents a line object.
ObjectCollection | Holds the list of objects of Base type.
OverlayBand | Represents an overlay band.
PageBase | Base class for report pages and dialog forms.
PageCollection | Holds the list of objects of PageBase type.
PageColumns | This class contains the page columns settings. It is used in the Columns property.
PageFooterBand | Represents a page footer band.
PageHeaderBand | Represents a page header band.
PathGradientFill | Class represents the path gradient fill.
PictureObject | Represents a Picture object that can display pictures.
PreviewSettings | Contains some settings of the preview window.
PrintSettings | This class contains the printer settings. It is used in the PrintSettings property.
ProgressEventArgs | Provides data for the Progress event.
Report | Represents a report object.
ReportComponentBase | Base class for all report objects.
ReportComponentBaseMenu | The class introduces some menu items specific to the ReportComponentBase.
ReportComponentCollection | Holds the list of objects of ReportComponentBase type.
ReportInfo | This class represents the report information such as name, author, description etc.
ReportPage | Represents a report page.
ReportSettings | This class contains settings that will be applied to the Report component.
ReportSummaryBand | Represents a report summary band.
ReportTitleBand | Represents a report title band.
RichObject | Represents a RichText object that can display formatted text.
SelectedComponents | Holds the list of ComponentBase objects currently selected in the designer.
SelectedObjectCollection | Holds the list of selected objects of Base type. Used by the SelectedObjects.
SelectedReportComponents | Holds the list of ReportComponentBase objects currently selected in the designer.
SelectedTextObjects | Holds the list of TextObject objects currently selected in the designer.
ShapeObject | Represents a shape object.
SmartTagBase | The base class for smart tags.
SolidFill | Class represents the solid fill.
Sort | Represents a sort condition used in the Sort.
SortCollection | Represents a collection of sort conditions used in the Sort.
Style | Represents a style.
StyleBase | Represents the base class for the report style or the highlight condition.
StyleCollection | Represents a collection of styles used in the Styles.
StyleSheet | Represents a collection of the StyleCollection objects.
SubreportObject | Represents a subreport object.
TextObject | Represents the Text object that may display one or several text lines.
TextObjectBase | Base class for text objects such as TextObject and RichObject.
TextObjectBaseMenu | The class introduces some menu items specific to the TextObjectBase.
TextObjectMenu | The class introduces some menu items specific to the TextObject.
Watermark | Represents the report page watermark.
ZipCodeObject | Represents a zip code object.

Structures

Structure | Description
Variant | A strongly typed object that readily casts an intrinsic object to the other intrinsic types when possible.

Interfaces

Interface | Description
IFRSerializable | Provides the serialize/deserialize functionality.
IHasEditor | Implements the object's editor.
IParent | Implement this interface if your object can contain list of child objects.
ISearchable | Provides the "search" functionality in the preview and designer.

Delegates

Delegate | Description
AfterDatabaseLoginEventHandler | Represents the method that will handle the AfterDatabaseLogin event.
CustomLoadEventHandler | Represents the method that will handle the LoadBaseReport event.
DatabaseLoginEventHandler | Represents the method that will handle the DatabaseLogin event.
FilterPropertiesEventHandler | Represents the method that will handle the FilterProperties event.
GetPropertyKindEventHandler | Represents the method that will handle the GetPropertyKind event.
GetTypeInstanceEventHandler | Represents the method that will handle the GetPropertyKind event.
ProgressEventHandler | Represents the method that will handle the Progress event.

Enumerations

Enumeration | Description
AutoShrinkMode | Specifies the behavior of the AutoShrink feature of TextObject.
BorderLines | Specifies the sides of a border.
CapStyle | Specifies a line cap style.
CheckedSymbol | Specifies a symbol that will be displayed when a CheckBoxObject is in the checked state.
ColumnLayout | The layout of the data band columns.
DefaultPaperSize | Specifies the default paper size used when creating a new report.
Duplicates | Specifies how to display the duplicate values.
Flags | Specifies a set of actions that can be performed on the object in the design mode.
HorzAlign | Specifies the horizontal alignment of a text in the TextObject object.
HyperlinkKind | Specifies the hyperlink type.
InsertFrom | Specifies an origin where the new objects inserted from.
Language | Specifies the language of the report's script.
LineStyle | Specifies the style of a border line.
MarkerStyle | The style of the report object markers.
PageRange | Specifies the page range to print.
PagesOnSheet | Specifies the number of report pages printed on one paper sheet.
PathGradientStyle | The style of the path gradient.
PreviewButtons | Specifies the set of buttons available in the preview.
PrintMode | Specifies the report printing mode.
PrintOn | Specifies where to print an object.
PrintPages | Specifies the pages to print.
ProcessAt | Specifies how the report engine processes the text objects.
ReportOperation | Specifies the report operation.
Restrictions | Specifies a set of actions that cannot be performed on the object in the design mode.
ShapeKind | Specifies a kind of the shape.
ShiftMode | The automatic shift mode.
SortOrder | Specifies a sort order.
StylePriority | Specifies the style properties to use when style is applied.
TextQuality | Specifies the quality of text rendering.
UncheckedSymbol | Specifies a symbol that will be displayed when a CheckBoxObject is in the unchecked state.
VertAlign | Specifies the vertical alignment of a text in the TextObject object.
WatermarkImageSize | Specifies the watermark image size mode.
WatermarkTextRotation | Specifies the watermark text rotation.

Send comments on this topic to support@fast-report.com

Copyright 2007-2011 by Fast Reports Inc.


AfterDatabaseLoginEventArgs Class

[image]

FastReport.Net Class Reference
AfterDatabaseLoginEventArgs Class
Members See Also Send Feedback
Provides data for the AfterDatabaseLogin event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AfterDatabaseLoginEventArgs
Visual Basic (Declaration)
Public Class AfterDatabaseLoginEventArgs
Visual C++
public ref class AfterDatabaseLoginEventArgs

Inheritance Hierarchy

System..::.Object
FastReport..::.AfterDatabaseLoginEventArgs

See Also

AfterDatabaseLoginEventArgs Members
FastReport Namespace


AfterDatabaseLoginEventArgs Members

[image] [image]

FastReport.Net Class Reference
AfterDatabaseLoginEventArgs Members
AfterDatabaseLoginEventArgs Class Constructors Methods Properties See Also Send Feedback

The AfterDatabaseLoginEventArgs type exposes the following members.

Constructors

Name | Description
AfterDatabaseLoginEventArgs | Initializes a new instance of the AfterDatabaseLoginEventArgs class using the specified connection.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Connection | Gets the DbConnection object.

See Also

AfterDatabaseLoginEventArgs Class
FastReport Namespace


AfterDatabaseLoginEventArgs Constructor

[image]

FastReport.Net Class Reference
AfterDatabaseLoginEventArgs Constructor
AfterDatabaseLoginEventArgs Class See Also Send Feedback
Initializes a new instance of the AfterDatabaseLoginEventArgs class using the specified connection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AfterDatabaseLoginEventArgs(
    DbConnection connection
)
Visual Basic (Declaration)
Public Sub New ( _
    connection As DbConnection _
)
Visual C++
public:
AfterDatabaseLoginEventArgs(
    DbConnection^ connection
)

Parameters

connection
Type: System.Data.Common..::.DbConnection
The connection object.

See Also

AfterDatabaseLoginEventArgs Class
FastReport Namespace


AfterDatabaseLoginEventArgs Methods

[image] [image]

FastReport.Net Class Reference
AfterDatabaseLoginEventArgs Methods
AfterDatabaseLoginEventArgs Class See Also Send Feedback

The AfterDatabaseLoginEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AfterDatabaseLoginEventArgs Class
FastReport Namespace


AfterDatabaseLoginEventArgs Properties

[image] [image]

FastReport.Net Class Reference
AfterDatabaseLoginEventArgs Properties
AfterDatabaseLoginEventArgs Class See Also Send Feedback

The AfterDatabaseLoginEventArgs type exposes the following members.

Properties

Name | Description
Connection | Gets the DbConnection object.

See Also

AfterDatabaseLoginEventArgs Class
FastReport Namespace


Connection Property

[image]

FastReport.Net Class Reference
AfterDatabaseLoginEventArgs..::.Connection Property
AfterDatabaseLoginEventArgs Class See Also Send Feedback
Gets the DbConnection object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DbConnection Connection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connection As DbConnection
Visual C++
public:
property DbConnection^ Connection {
    DbConnection^ get ();
}

See Also

AfterDatabaseLoginEventArgs Class
FastReport Namespace


AfterDatabaseLoginEventHandler Delegate

[image]

FastReport.Net Class Reference
AfterDatabaseLoginEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the AfterDatabaseLogin event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void AfterDatabaseLoginEventHandler(
    Object sender,
    AfterDatabaseLoginEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub AfterDatabaseLoginEventHandler ( _
    sender As Object, _
    e As AfterDatabaseLoginEventArgs _
)
Visual C++
public delegate void AfterDatabaseLoginEventHandler(
    Object^ sender,
    AfterDatabaseLoginEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.AfterDatabaseLoginEventArgs
The event data.

See Also

FastReport Namespace


AssemblyInitializer Class

[image]

FastReport.Net Class Reference
AssemblyInitializer Class
Members See Also Send Feedback
The FastReport.dll assembly initializer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public sealed class AssemblyInitializer : AssemblyInitializerBase
Visual Basic (Declaration)
Public NotInheritable Class AssemblyInitializer _
    Inherits AssemblyInitializerBase
Visual C++
public ref class AssemblyInitializer sealed : public AssemblyInitializerBase

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.AssemblyInitializerBase
FastReport..::.AssemblyInitializer

See Also

AssemblyInitializer Members
FastReport Namespace


AssemblyInitializer Members

[image] [image]

FastReport.Net Class Reference
AssemblyInitializer Members
AssemblyInitializer Class Constructors Methods See Also Send Feedback

The AssemblyInitializer type exposes the following members.

Constructors

Name | Description
AssemblyInitializer | Registers all standard objects, wizards, export filters.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyInitializer Class
FastReport Namespace


AssemblyInitializer Constructor

[image]

FastReport.Net Class Reference
AssemblyInitializer Constructor
AssemblyInitializer Class See Also Send Feedback
Registers all standard objects, wizards, export filters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AssemblyInitializer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssemblyInitializer()

See Also

AssemblyInitializer Class
FastReport Namespace


AssemblyInitializer Methods

[image] [image]

FastReport.Net Class Reference
AssemblyInitializer Methods
AssemblyInitializer Class See Also Send Feedback

The AssemblyInitializer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyInitializer Class
FastReport Namespace


AutoShrinkMode Enumeration

[image]

FastReport.Net Class Reference
AutoShrinkMode Enumeration
See Also Send Feedback
Specifies the behavior of the AutoShrink feature of TextObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum AutoShrinkMode
Visual Basic (Declaration)
Public Enumeration AutoShrinkMode
Visual C++
public enum class AutoShrinkMode

Members

Member name | Description
None | AutoShrink is disabled.
FontSize | AutoShrink decreases the Font.Size property of the TextObject.
FontWidth | AutoShrink decreases the FontWidthRatio property of the TextObject.

See Also

FastReport Namespace


BandBase Class

[image]

FastReport.Net Class Reference
BandBase Class
Members See Also Send Feedback
Base class for all bands.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class BandBase : BreakableComponent,
    IParent
Visual Basic (Declaration)
Public MustInherit Class BandBase _
    Inherits BreakableComponent _
    Implements IParent
Visual C++
public ref class BandBase abstract : public BreakableComponent,
    IParent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.ChildBand
FastReport..::.ColumnFooterBand
FastReport..::.ColumnHeaderBand
FastReport..::.DataBand
FastReport..::.HeaderFooterBandBase
FastReport..::.OverlayBand
FastReport..::.PageFooterBand
FastReport..::.PageHeaderBand
FastReport..::.ReportTitleBand

See Also

BandBase Members
FastReport Namespace


BandBase Members

[image] [image]

FastReport.Net Class Reference
BandBase Members
BandBase Class Constructors Methods Properties Events See Also Send Feedback

The BandBase type exposes the following members.

Constructors

Name | Description
BandBase | Initializes a new instance of the BandBase class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BreakableComponent..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides Base..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent.
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent.
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Overrides ComponentBase..::.PointInObject(PointF).)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BreakableComponent..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Overrides ComponentBase..::.AbsLeft.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable).
AbsTop | Gets the absolute top coordinate of the object. (Overrides ComponentBase..::.AbsTop.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished.
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects.
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class.
CanBreak | This property is not relevant to this class.
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class.
Guides | Gets or sets collection of guide lines for this band.
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row.
IsLastRow | Gets a value indicating that this is the last data row.
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band.
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Left.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom.
Repeated | Gets a value indicating that band is reprinted on a new page.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable).
ShiftMode | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished.
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects.
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

BandBase Class
FastReport Namespace


BandBase Constructor

[image]

FastReport.Net Class Reference
BandBase Constructor
BandBase Class See Also Send Feedback
Initializes a new instance of the BandBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BandBase()

See Also

BandBase Class
FastReport Namespace


BandBase Methods

[image] [image]

FastReport.Net Class Reference
BandBase Methods
BandBase Class See Also Send Feedback

The BandBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BreakableComponent..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides Base..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent.
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent.
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Overrides ComponentBase..::.PointInObject(PointF).)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BreakableComponent..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

BandBase Class
FastReport Namespace


AddChild Method

[image]

FastReport.Net Class Reference
BandBase..::.AddChild Method
BandBase Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

BandBase Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
BandBase..::.Assign Method
BandBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

BandBase Class
FastReport Namespace
AssignAll Method


Break Method

[image]

FastReport.Net Class Reference
BandBase..::.Break Method
BandBase Class See Also Send Feedback
Breaks the contents of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Break(
    BreakableComponent breakTo
)
Visual Basic (Declaration)
Public Overrides Function Break ( _
    breakTo As BreakableComponent _
) As Boolean
Visual C++
public:
virtual bool Break(
    BreakableComponent^ breakTo
) override

Parameters

breakTo
Type: FastReport..::.BreakableComponent
Object to put the part of content to that does not fit in this object. These two objects must have the same type.

Return Value

true if there is enough space in this object to display at least one text line.

Remarks

Do not call this method directly, it is used by the report engine. You should override it if you are writing a new FastReport object.

This method must break the contents of the object. The part of content that fit in current object's bounds should remain in this object, the part that does not fit should be transferred to breakTo object.

See Also

BandBase Class
FastReport Namespace


CalcHeight Method

[image]

FastReport.Net Class Reference
BandBase..::.CalcHeight Method
BandBase Class See Also Send Feedback
Calculates the object's height.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float CalcHeight()
Visual Basic (Declaration)
Public Overrides Function CalcHeight As Single
Visual C++
public:
virtual float CalcHeight() override

Return Value

Actual object's height, in pixels.

Remarks

Applicable to objects that contain several text lines, such as TextObject. Returns the height needed to display all the text lines.

See Also

BandBase Class
FastReport Namespace


CanContain Method

[image]

FastReport.Net Class Reference
BandBase..::.CanContain Method
BandBase Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

BandBase Class
FastReport Namespace


Delete Method

[image]

FastReport.Net Class Reference
BandBase..::.Delete Method
BandBase Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

BandBase Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
BandBase..::.Dispose Method
BandBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

BandBase Class
BandBase Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
BandBase..::.Draw Method
BandBase Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

BandBase Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
BandBase..::.DrawMarkers Method
BandBase Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

BandBase Class
BandBase Members
FastReport Namespace


DrawSelection Method

[image]

FastReport.Net Class Reference
BandBase..::.DrawSelection Method
BandBase Class See Also Send Feedback
Draw the selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawSelection(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawSelection ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawSelection(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method draws a set of selection points returned by the GetSelectionPoints()()() method.

See Also

BandBase Class
FastReport Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
BandBase..::.GetChildObjects Method
BandBase Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overridable Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

BandBase Class
FastReport Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
BandBase..::.GetChildOrder Method
BandBase Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

BandBase Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
BandBase..::.GetContextMenu Method
BandBase Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

BandBase Class
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
BandBase..::.GetData Method
BandBase Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

BandBase Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
BandBase..::.GetExpressions Method
BandBase Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

BandBase Class
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
BandBase..::.GetPreferredSize Method
BandBase Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

BandBase Class
FastReport Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
BandBase..::.HandleMouseDown Method
BandBase Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

BandBase Class
FastReport Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
BandBase..::.HandleMouseHover Method
BandBase Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

BandBase Class
FastReport Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
BandBase..::.HandleMouseMove Method
BandBase Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

BandBase Class
FastReport Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
BandBase..::.HandleMouseUp Method
BandBase Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

BandBase Class
FastReport Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
BandBase..::.InitializeComponent Method
BandBase Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

BandBase Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BandBase..::.MemberwiseClone Method
BandBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BandBase Class
BandBase Members
FastReport Namespace


OnAfterLayout Method

[image]

FastReport.Net Class Reference
BandBase..::.OnAfterLayout Method
BandBase Class See Also Send Feedback
This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnAfterLayout(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnAfterLayout ( _
    e As EventArgs _
)
Visual C++
public:
void OnAfterLayout(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

BandBase Class
FastReport Namespace


OnBeforeLayout Method

[image]

FastReport.Net Class Reference
BandBase..::.OnBeforeLayout Method
BandBase Class See Also Send Feedback
This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnBeforeLayout(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnBeforeLayout ( _
    e As EventArgs _
)
Visual C++
public:
void OnBeforeLayout(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

BandBase Class
FastReport Namespace


PointInObject Method

[image]

FastReport.Net Class Reference
BandBase..::.PointInObject Method
BandBase Class See Also Send Feedback
Checks if given point is inside the object's bounds.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool PointInObject(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function PointInObject ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool PointInObject(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF
point to check.

Return Value

true if point is inside the object's bounds.

Remarks

You can override this method if your objectis not of rectangular form.

See Also

BandBase Class
FastReport Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
BandBase..::.RemoveChild Method
BandBase Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

BandBase Class
FastReport Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
BandBase..::.RestoreState Method
BandBase Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

BandBase Class
FastReport Namespace


SaveState Method

[image]

FastReport.Net Class Reference
BandBase..::.SaveState Method
BandBase Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

BandBase Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
BandBase..::.Serialize Method
BandBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

BandBase Class
FastReport Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
BandBase..::.SetChildOrder Method
BandBase Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Overridable Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
)

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

BandBase Class
FastReport Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
BandBase..::.UpdateLayout Method
BandBase Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Overridable Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
)

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

BandBase Class
FastReport Namespace


BandBase Properties

[image] [image]

FastReport.Net Class Reference
BandBase Properties
BandBase Class See Also Send Feedback

The BandBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Overrides ComponentBase..::.AbsLeft.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable).
AbsTop | Gets the absolute top coordinate of the object. (Overrides ComponentBase..::.AbsTop.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished.
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects.
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class.
CanBreak | This property is not relevant to this class.
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class.
Guides | Gets or sets collection of guide lines for this band.
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row.
IsLastRow | Gets a value indicating that this is the last data row.
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band.
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Left.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom.
Repeated | Gets a value indicating that band is reprinted on a new page.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable).
ShiftMode | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

BandBase Class
FastReport Namespace


AbsLeft Property

[image]

FastReport.Net Class Reference
BandBase..::.AbsLeft Property
BandBase Class See Also Send Feedback
Gets the absolute left coordinate of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float AbsLeft { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AbsLeft As Single
Visual C++
public:
virtual property float AbsLeft {
    float get () override;
}

See Also

BandBase Class
FastReport Namespace


AbsRowNo Property

[image]

FastReport.Net Class Reference
BandBase..::.AbsRowNo Property
BandBase Class See Also Send Feedback
Gets an absolute row number (the same value returned by the "AbsRow#" system variable).

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int AbsRowNo { get; set; }
Visual Basic (Declaration)
Public Property AbsRowNo As Integer
Visual C++
public:
property int AbsRowNo {
    int get ();
    void set (int value);
}

See Also

BandBase Class
FastReport Namespace


AbsTop Property

[image]

FastReport.Net Class Reference
BandBase..::.AbsTop Property
BandBase Class See Also Send Feedback
Gets the absolute top coordinate of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float AbsTop { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AbsTop As Single
Visual C++
public:
virtual property float AbsTop {
    float get () override;
}

See Also

BandBase Class
FastReport Namespace


AfterLayoutEvent Property

[image]

FastReport.Net Class Reference
BandBase..::.AfterLayoutEvent Property
BandBase Class See Also Send Feedback
Gets or sets a script event name that will be fired after the child objects layout was finished.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AfterLayoutEvent { get; set; }
Visual Basic (Declaration)
Public Property AfterLayoutEvent As String
Visual C++
public:
property String^ AfterLayoutEvent {
    String^ get ();
    void set (String^ value);
}

See Also

BandBase Class
FastReport Namespace


Anchor Property

[image]

FastReport.Net Class Reference
BandBase..::.Anchor Property
BandBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overrides Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get () override;
    void set (AnchorStyles value) override;
}

See Also

BandBase Class
FastReport Namespace


BeforeLayoutEvent Property

[image]

FastReport.Net Class Reference
BandBase..::.BeforeLayoutEvent Property
BandBase Class See Also Send Feedback
Gets or sets a script event name that will be fired before the band layouts its child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BeforeLayoutEvent { get; set; }
Visual Basic (Declaration)
Public Property BeforeLayoutEvent As String
Visual C++
public:
property String^ BeforeLayoutEvent {
    String^ get ();
    void set (String^ value);
}

See Also

BandBase Class
FastReport Namespace


BreakTo Property

[image]

FastReport.Net Class Reference
BandBase..::.BreakTo Property
BandBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BreakableComponent BreakTo { get; set; }
Visual Basic (Declaration)
Public Property BreakTo As BreakableComponent
Visual C++
public:
property BreakableComponent^ BreakTo {
    BreakableComponent^ get ();
    void set (BreakableComponent^ value);
}

See Also

BandBase Class
FastReport Namespace


CanBreak Property

[image]

FastReport.Net Class Reference
BandBase..::.CanBreak Property
BandBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanBreak { get; set; }
Visual Basic (Declaration)
Public Property CanBreak As Boolean
Visual C++
public:
property bool CanBreak {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
FastReport Namespace


Child Property

[image]

FastReport.Net Class Reference
BandBase..::.Child Property
BandBase Class See Also Send Feedback
Gets or sets a child band that will be printed right after this band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ChildBand Child { get; set; }
Visual Basic (Declaration)
Public Property Child As ChildBand
Visual C++
public:
property ChildBand^ Child {
    ChildBand^ get ();
    void set (ChildBand^ value);
}

Remarks

Typical use of child band is to print several objects that can grow or shrink. It also can be done using the shift feature (via ShiftMode property), but in some cases it's not possible.

See Also

BandBase Class
FastReport Namespace


Dock Property

[image]

FastReport.Net Class Reference
BandBase..::.Dock Property
BandBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get () override;
    void set (DockStyle value) override;
}

See Also

BandBase Class
FastReport Namespace


FirstRowStartsNewPage Property

[image]

FastReport.Net Class Reference
BandBase..::.FirstRowStartsNewPage Property
BandBase Class See Also Send Feedback
Gets or sets a value indicating that the first row can start a new report page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FirstRowStartsNewPage { get; set; }
Visual Basic (Declaration)
Public Property FirstRowStartsNewPage As Boolean
Visual C++
public:
property bool FirstRowStartsNewPage {
    bool get ();
    void set (bool value);
}

Remarks

Use this property if StartNewPage is set to true. Normally the new page is not started when printing the first data row, to avoid empty first page.

See Also

BandBase Class
FastReport Namespace


GrowToBottom Property

[image]

FastReport.Net Class Reference
BandBase..::.GrowToBottom Property
BandBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool GrowToBottom { get; set; }
Visual Basic (Declaration)
Public Property GrowToBottom As Boolean
Visual C++
public:
property bool GrowToBottom {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
FastReport Namespace


Guides Property

[image]

FastReport.Net Class Reference
BandBase..::.Guides Property
BandBase Class See Also Send Feedback
Gets or sets collection of guide lines for this band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FloatCollection Guides { get; set; }
Visual Basic (Declaration)
Public Property Guides As FloatCollection
Visual C++
public:
property FloatCollection^ Guides {
    FloatCollection^ get ();
    void set (FloatCollection^ value);
}

See Also

BandBase Class
FastReport Namespace


IsFirstRow Property

[image]

FastReport.Net Class Reference
BandBase..::.IsFirstRow Property
BandBase Class See Also Send Feedback
Gets a value indicating that this is the first data row.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsFirstRow { get; set; }
Visual Basic (Declaration)
Public Property IsFirstRow As Boolean
Visual C++
public:
property bool IsFirstRow {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
FastReport Namespace


IsLastRow Property

[image]

FastReport.Net Class Reference
BandBase..::.IsLastRow Property
BandBase Class See Also Send Feedback
Gets a value indicating that this is the last data row.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsLastRow { get; set; }
Visual Basic (Declaration)
Public Property IsLastRow As Boolean
Visual C++
public:
property bool IsLastRow {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
FastReport Namespace


KeepChild Property

[image]

FastReport.Net Class Reference
BandBase..::.KeepChild Property
BandBase Class See Also Send Feedback
Gets or sets a value indicating that the band should be printed together with its child band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool KeepChild { get; set; }
Visual Basic (Declaration)
Public Property KeepChild As Boolean
Visual C++
public:
property bool KeepChild {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
FastReport Namespace


Left Property

[image]

FastReport.Net Class Reference
BandBase..::.Left Property
BandBase Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

BandBase Class
FastReport Namespace


Objects Property

[image]

FastReport.Net Class Reference
BandBase..::.Objects Property
BandBase Class See Also Send Feedback
Gets a collection of report objects belongs to this band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentCollection Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As ReportComponentCollection
Visual C++
public:
property ReportComponentCollection^ Objects {
    ReportComponentCollection^ get ();
}

See Also

BandBase Class
FastReport Namespace


OutlineExpression Property

[image]

FastReport.Net Class Reference
BandBase..::.OutlineExpression Property
BandBase Class See Also Send Feedback
Gets or sets an outline expression.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string OutlineExpression { get; set; }
Visual Basic (Declaration)
Public Property OutlineExpression As String
Visual C++
public:
property String^ OutlineExpression {
    String^ get ();
    void set (String^ value);
}

Remarks

Outline is a tree control displayed in the preview window. It represents the prepared report structure. Each outline node can be clicked to navigate to the item in the prepared report.

To create the outline, set this property to any valid expression that represents the outline node text. This expression will be calculated when band is about to print, and its value will be added to the outline. Thus, nodes' hierarchy in the outline is similar to the bands' hierarchy in a report. That means there will be the main and subordinate outline nodes, corresponding to the main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point).

See Also

BandBase Class
FastReport Namespace


PrintOnBottom Property

[image]

FastReport.Net Class Reference
BandBase..::.PrintOnBottom Property
BandBase Class See Also Send Feedback
Gets or sets a value indicating that the band should be printed on the page bottom.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnBottom { get; set; }
Visual Basic (Declaration)
Public Property PrintOnBottom As Boolean
Visual C++
public:
property bool PrintOnBottom {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
FastReport Namespace


Repeated Property

[image]

FastReport.Net Class Reference
BandBase..::.Repeated Property
BandBase Class See Also Send Feedback
Gets a value indicating that band is reprinted on a new page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Repeated { get; set; }
Visual Basic (Declaration)
Public Property Repeated As Boolean
Visual C++
public:
property bool Repeated {
    bool get ();
    void set (bool value);
}

Remarks

This property is applicable to the DataHeaderBand and GroupHeaderBand only. It returns true if its RepeatOnAllPages property is true and band is reprinted on a new page.

See Also

BandBase Class
FastReport Namespace


RowNo Property

[image]

FastReport.Net Class Reference
BandBase..::.RowNo Property
BandBase Class See Also Send Feedback
Gets a row number (the same value returned by the "Row#" system variable).

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowNo { get; set; }
Visual Basic (Declaration)
Public Property RowNo As Integer
Visual C++
public:
property int RowNo {
    int get ();
    void set (int value);
}

Remarks

This property can be used when running a report. It may be useful to print hierarchical row numbers in a master-detail report, like this:

1.1

1.2

2.1

2.2

To do this, put the Text object on a detail data band with the following text in it:

[Data1.RowNo].[Data2.RowNo]

See Also

BandBase Class
FastReport Namespace


ShiftMode Property

[image]

FastReport.Net Class Reference
BandBase..::.ShiftMode Property
BandBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShiftMode ShiftMode { get; set; }
Visual Basic (Declaration)
Public Property ShiftMode As ShiftMode
Visual C++
public:
property ShiftMode ShiftMode {
    ShiftMode get ();
    void set (ShiftMode value);
}

See Also

BandBase Class
FastReport Namespace


StartNewPage Property

[image]

FastReport.Net Class Reference
BandBase..::.StartNewPage Property
BandBase Class See Also Send Feedback
Gets or sets a value indicating that the band should be printed from a new page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartNewPage { get; set; }
Visual Basic (Declaration)
Public Property StartNewPage As Boolean
Visual C++
public:
property bool StartNewPage {
    bool get ();
    void set (bool value);
}

Remarks

New page is not generated when printing very first group or data row. This is made to avoid empty first page.

See Also

BandBase Class
FastReport Namespace


Top Property

[image]

FastReport.Net Class Reference
BandBase..::.Top Property
BandBase Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

BandBase Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
BandBase..::.Width Property
BandBase Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

BandBase Class
FastReport Namespace


BandBase Events

[image] [image]

FastReport.Net Class Reference
BandBase Events
BandBase Class See Also Send Feedback

The BandBase type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished.
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects.
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

BandBase Class
FastReport Namespace


AfterLayout Event

[image]

FastReport.Net Class Reference
BandBase..::.AfterLayout Event
BandBase Class See Also Send Feedback
This event occurs after the child objects layout was finished.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler AfterLayout
Visual Basic (Declaration)
Public Event AfterLayout As EventHandler
Visual C++
public:
 event EventHandler^ AfterLayout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

BandBase Class
FastReport Namespace


BeforeLayout Event

[image]

FastReport.Net Class Reference
BandBase..::.BeforeLayout Event
BandBase Class See Also Send Feedback
This event occurs before the band layouts its child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler BeforeLayout
Visual Basic (Declaration)
Public Event BeforeLayout As EventHandler
Visual C++
public:
 event EventHandler^ BeforeLayout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

BandBase Class
FastReport Namespace


BandCollection Class

[image]

FastReport.Net Class Reference
BandCollection Class
Members See Also Send Feedback
Represents a collection of bands.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BandCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class BandCollection _
    Inherits FRCollectionBase
Visual C++
public ref class BandCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport..::.BandCollection

See Also

BandCollection Members
FastReport Namespace


BandCollection Members

[image] [image]

FastReport.Net Class Reference
BandCollection Members
BandCollection Class Constructors Methods Properties See Also Send Feedback

The BandCollection type exposes the following members.

Constructors

Name | Description
BandCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

BandCollection Class
FastReport Namespace


BandCollection Constructor

[image] [image]

FastReport.Net Class Reference
BandCollection Constructor
BandCollection Class See Also Send Feedback

Overload List

Name | Description
BandCollection()()() | Initializes a new instance of the BandCollection class with default settings.
BandCollection(Base) | Initializes a new instance of the BandCollection class with specified owner.

See Also

BandCollection Class
BandCollection Members
FastReport Namespace


BandCollection Constructor

[image]

FastReport.Net Class Reference
BandCollection Constructor
BandCollection Class See Also Send Feedback
Initializes a new instance of the BandCollection class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BandCollection()

See Also

BandCollection Class
BandCollection Overload
FastReport Namespace


BandCollection Constructor (Base)

[image]

FastReport.Net Class Reference
BandCollection Constructor (Base)
BandCollection Class See Also Send Feedback
Initializes a new instance of the BandCollection class with specified owner.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
BandCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
Owner that owns this collection.

See Also

BandCollection Class
BandCollection Overload
FastReport Namespace


BandCollection Methods

[image] [image]

FastReport.Net Class Reference
BandCollection Methods
BandCollection Class See Also Send Feedback

The BandCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BandCollection Class
FastReport Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
BandCollection..::.AddRange Method
BandCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

BandCollection Class
BandCollection Members
FastReport Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
BandCollection..::.Equals Method
BandCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

BandCollection Class
BandCollection Members
FastReport Namespace


BandCollection Properties

[image] [image]

FastReport.Net Class Reference
BandCollection Properties
BandCollection Class See Also Send Feedback

The BandCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

BandCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
BandCollection..::.Item Property
BandCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As BandBase
Visual C++
public:
property BandBase^ default[int index] {
    BandBase^ get (int index);
    void set (int index, BandBase^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

BandCollection Class
FastReport Namespace


BandColumns Class

[image]

FastReport.Net Class Reference
BandColumns Class
Members See Also Send Feedback
This class holds the band columns settings. It is used in the Columns property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BandColumns
Visual Basic (Declaration)
Public Class BandColumns
Visual C++
public ref class BandColumns

Inheritance Hierarchy

System..::.Object
FastReport..::.BandColumns

See Also

BandColumns Members
FastReport Namespace


BandColumns Members

[image] [image]

FastReport.Net Class Reference
BandColumns Members
BandColumns Class Constructors Methods Properties See Also Send Feedback

The BandColumns type exposes the following members.

Constructors

Name | Description
BandColumns | Initializes a new instance of the BandColumns class with default settings.

Methods

Name | Description
Assign | Assigns values from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets or sets the number of columns.
Layout | Gets or sets the layout of the columns.
MinRowCount | Gets or sets the minimum row count that must be printed.
Width | The column width, in pixels.

See Also

BandColumns Class
FastReport Namespace


BandColumns Constructor

[image]

FastReport.Net Class Reference
BandColumns Constructor
BandColumns Class See Also Send Feedback
Initializes a new instance of the BandColumns class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandColumns(
    DataBand band
)
Visual Basic (Declaration)
Public Sub New ( _
    band As DataBand _
)
Visual C++
public:
BandColumns(
    DataBand^ band
)

Parameters

band
Type: FastReport..::.DataBand

See Also

BandColumns Class
FastReport Namespace


BandColumns Methods

[image] [image]

FastReport.Net Class Reference
BandColumns Methods
BandColumns Class See Also Send Feedback

The BandColumns type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BandColumns Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
BandColumns..::.Assign Method
BandColumns Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    BandColumns source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As BandColumns _
)
Visual C++
public:
void Assign(
    BandColumns^ source
)

Parameters

source
Type: FastReport..::.BandColumns
Source to assign from.

See Also

BandColumns Class
FastReport Namespace


BandColumns Properties

[image] [image]

FastReport.Net Class Reference
BandColumns Properties
BandColumns Class See Also Send Feedback

The BandColumns type exposes the following members.

Properties

Name | Description
Count | Gets or sets the number of columns.
Layout | Gets or sets the layout of the columns.
MinRowCount | Gets or sets the minimum row count that must be printed.
Width | The column width, in pixels.

See Also

BandColumns Class
FastReport Namespace


Count Property

[image]

FastReport.Net Class Reference
BandColumns..::.Count Property
BandColumns Class See Also Send Feedback
Gets or sets the number of columns.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; set; }
Visual Basic (Declaration)
Public Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

Remarks

Set this property to 0 or 1 if you don't want to use columns.

See Also

BandColumns Class
FastReport Namespace


Layout Property

[image]

FastReport.Net Class Reference
BandColumns..::.Layout Property
BandColumns Class See Also Send Feedback
Gets or sets the layout of the columns.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnLayout Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As ColumnLayout
Visual C++
public:
property ColumnLayout Layout {
    ColumnLayout get ();
    void set (ColumnLayout value);
}

See Also

BandColumns Class
FastReport Namespace


MinRowCount Property

[image]

FastReport.Net Class Reference
BandColumns..::.MinRowCount Property
BandColumns Class See Also Send Feedback
Gets or sets the minimum row count that must be printed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int MinRowCount { get; set; }
Visual Basic (Declaration)
Public Property MinRowCount As Integer
Visual C++
public:
property int MinRowCount {
    int get ();
    void set (int value);
}

Remarks

This property is used if the Layout property is set to DownThenAcross. 0 means that FastReport should calculate the optimal number of rows.

See Also

BandColumns Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
BandColumns..::.Width Property
BandColumns Class See Also Send Feedback
The column width, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

BandColumns Class
FastReport Namespace


Base Class

[image]

FastReport.Net Class Reference
Base Class
Members See Also Send Feedback
Represents the root class of the FastReport object's hierarhy.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class Base : Component,
    IFRSerializable
Visual Basic (Declaration)
Public MustInherit Class Base _
    Inherits Component _
    Implements IFRSerializable
Visual C++
public ref class Base abstract : public Component,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Data..::.CommandParameter
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Dictionary
FastReport.Data..::.Parameter
FastReport.Data..::.Total
FastReport.Dialog..::.GridControlColumn
FastReport.Export..::.ExportBase
FastReport.Map..::.MapLayer
FastReport.Map..::.ShapeBase
FastReport.MSChart..::.MSChartSeries
FastReport..::.Report

See Also

Base Members
FastReport Namespace


Base Members

[image] [image]

FastReport.Net Class Reference
Base Members
Base Class Constructors Methods Properties Events See Also Send Feedback

The Base type exposes the following members.

Constructors

Name | Description
Base | Initializes a new instance of the Base class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object.
AssignAll | Copies the contents (including children) of another, similar object.
BaseAssign | Assigns values from another source.
Clear | Clears the object's state.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name.
Delete | Deletes the object in the designer.
Deserialize | Deserializes the object.
DeserializeSubItems | Deserializes nested object properties.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string.
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name.
FloatDiff | Checks if two float values are different.
GetContextMenu | Gets the object's context menu.
GetCustomScript | Returns a custom code that will be added to the report script before report is run.
GetExpressions | Gets all expressions contained in the object.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property.
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy.
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event.
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer.
OnAfterLoad | Called after all report objects were loaded.
OnBeforeInsert | Called before inserting a new object in the designer.
SelectionChanged | Called when the user selects another object in the designer.
Serialize | Serializes the object.
SetFlags | Set object's flags.
SetName | Sets the object's name.
SetParent | Sets the object's parent.
SetParentCore | Sets the object's parent.
SetProp | Helper method, helps to set a reference-type value to the property.
SetReport | Sets the reference to a Report.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects.
BaseName | The base part of the object's name.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects.
ClassName | Gets the short type name.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report.
IsDesigning | Gets a value indicating whether the object is in the design state.
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer.
IsPrinting | Gets a value indicating whether the object is currently printing.
IsRunning | Gets a value indicating whether the object is currently processed by the report engine.
IsSelected | Gets a value indicating whether the object is selected in the designer.
Name | Gets or sets the name of the object.
OriginalComponent | Gets an original component for this object.
Page | Gets reference to the parent PageBase object.
Parent | Gets or sets the parent of the object.
Report | Gets reference to the parent Report object.
Restrictions | Gets or sets the flags that restrict some actions in the designer.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Base Class
FastReport Namespace


Base Constructor

[image]

FastReport.Net Class Reference
Base Constructor
Base Class See Also Send Feedback
Initializes a new instance of the Base class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Base()

See Also

Base Class
FastReport Namespace


Base Methods

[image] [image]

FastReport.Net Class Reference
Base Methods
Base Class See Also Send Feedback

The Base type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object.
AssignAll | Copies the contents (including children) of another, similar object.
BaseAssign | Assigns values from another source.
Clear | Clears the object's state.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name.
Delete | Deletes the object in the designer.
Deserialize | Deserializes the object.
DeserializeSubItems | Deserializes nested object properties.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string.
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name.
FloatDiff | Checks if two float values are different.
GetContextMenu | Gets the object's context menu.
GetCustomScript | Returns a custom code that will be added to the report script before report is run.
GetExpressions | Gets all expressions contained in the object.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property.
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy.
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event.
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer.
OnAfterLoad | Called after all report objects were loaded.
OnBeforeInsert | Called before inserting a new object in the designer.
SelectionChanged | Called when the user selects another object in the designer.
Serialize | Serializes the object.
SetFlags | Set object's flags.
SetName | Sets the object's name.
SetParent | Sets the object's parent.
SetParentCore | Sets the object's parent.
SetProp | Helper method, helps to set a reference-type value to the property.
SetReport | Sets the reference to a Report.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Base Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
Base..::.Assign Method
Base Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overridable Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
)

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

Base Class
FastReport Namespace
AssignAll Method


AssignAll Method

[image]

FastReport.Net Class Reference
Base..::.AssignAll Method
Base Class Example See Also Send Feedback
Copies the contents (including children) of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AssignAll(
    Base source
)
Visual Basic (Declaration)
Public Sub AssignAll ( _
    source As Base _
)
Visual C++
public:
void AssignAll(
    Base^ source
)

Parameters

source
Type: FastReport..::.Base
Source object to copy the state from.

Remarks

This method is similar to Assign(Base) method. It copies child objects as well.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings and objects
report2.AssignAll(report1);

See Also

Base Class
FastReport Namespace
Base..::.Assign(Base)


BaseAssign Method

[image]

FastReport.Net Class Reference
Base..::.BaseAssign Method
Base Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void BaseAssign(
    Base source
)
Visual Basic (Declaration)
Public Sub BaseAssign ( _
    source As Base _
)
Visual C++
public:
void BaseAssign(
    Base^ source
)

Parameters

source
Type: FastReport..::.Base
Source to assign from.

Remarks

Note: this method is relatively slow because it serializes an object to the xml and then deserializes it.

See Also

Base Class
FastReport Namespace


Clear Method

[image]

FastReport.Net Class Reference
Base..::.Clear Method
Base Class See Also Send Feedback
Clears the object's state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Remarks

This method also disposes all object's children.

See Also

Base Class
FastReport Namespace


CreateUniqueName Method

[image]

FastReport.Net Class Reference
Base..::.CreateUniqueName Method
Base Class Example See Also Send Feedback
Creates the unique object's name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateUniqueName()
Visual Basic (Declaration)
Public Sub CreateUniqueName
Visual C++
public:
void CreateUniqueName()

Remarks

Note: you have to set object's parent before calling this method. Method uses the BaseName property to create a name.

Note: this method may be very slow on a report that contains lots of objects. Consider using own naming logic in this case.

Examples

CopyC#
TextObject textObj = new TextObject();
dataBand1.Objects.Add(textObj);
textObj.CreateUniqueName();

See Also

Base Class
FastReport Namespace


Delete Method

[image]

FastReport.Net Class Reference
Base..::.Delete Method
Base Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Delete()
Visual Basic (Declaration)
Public Overridable Sub Delete
Visual C++
public:
virtual void Delete()

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

Base Class
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
Base..::.Deserialize Method
Base Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overridable Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
)

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

Base Class
FastReport Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
Base..::.DeserializeSubItems Method
Base Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overridable Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
)

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

Base Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Base..::.Dispose Method
Base Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Component..::.Dispose(Boolean).)

See Also

Base Class
Base Members
FastReport Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
Base..::.Dispose Method (Boolean)
Base Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Base Class
Dispose Overload
FastReport Namespace


ExtractDefaultMacros Method

[image]

FastReport.Net Class Reference
Base..::.ExtractDefaultMacros Method
Base Class See Also Send Feedback
Replaces the macros in the given string and returns the new string.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected string ExtractDefaultMacros(
    string text
)
Visual Basic (Declaration)
Protected Function ExtractDefaultMacros ( _
    text As String _
) As String
Visual C++
protected:
String^ ExtractDefaultMacros(
    String^ text
)

Parameters

text
Type: System..::.String
The text containing macros.

Return Value

The text with macros replaced with its values.

See Also

Base Class
FastReport Namespace


ExtractMacros Method

[image]

FastReport.Net Class Reference
Base..::.ExtractMacros Method
Base Class See Also Send Feedback
Used to extract macros such as "TotalPages#" in the preview mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void ExtractMacros()
Visual Basic (Declaration)
Public Overridable Sub ExtractMacros
Visual C++
public:
virtual void ExtractMacros()

Remarks

This method is used mainly by the TextObject to extract macros and replace it with actual values passed in the pageIndex and totalPages parameters. This method is called automatically when the object is being previewed.

See Also

Base Class
FastReport Namespace


FindObject Method

[image]

FastReport.Net Class Reference
Base..::.FindObject Method
Base Class Example See Also Send Feedback
Searches for an object with given name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Base FindObject(
    string name
)
Visual Basic (Declaration)
Public Overridable Function FindObject ( _
    name As String _
) As Base
Visual C++
public:
virtual Base^ FindObject(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the object to find.

Return Value

Returns a null reference if object is not found

Examples

The following code demonstrates how to find an object by its name:
CopyC#
TextObject text1 = report1.FindObject("Text1") as TextObject;
if (text1 != null)
{
  // object found
}

See Also

Base Class
FastReport Namespace


FloatDiff Method

[image]

FastReport.Net Class Reference
Base..::.FloatDiff Method
Base Class See Also Send Feedback
Checks if two float values are different.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected bool FloatDiff(
    float f1,
    float f2
)
Visual Basic (Declaration)
Protected Function FloatDiff ( _
    f1 As Single, _
    f2 As Single _
) As Boolean
Visual C++
protected:
bool FloatDiff(
    float f1,
    float f2
)

Parameters

f1
Type: System..::.Single
First value.
f2
Type: System..::.Single
Second value.

Return Value

true if values are not equal.

Remarks

This method is needed to compare two float values using some precision (0.001). It is useful to compare objects' locations and sizes for equality.

See Also

Base Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
Base..::.GetContextMenu Method
Base Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overridable Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu()

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

Base Class
FastReport Namespace


GetCustomScript Method

[image]

FastReport.Net Class Reference
Base..::.GetCustomScript Method
Base Class See Also Send Feedback
Returns a custom code that will be added to the report script before report is run.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string GetCustomScript()
Visual Basic (Declaration)
Public Overridable Function GetCustomScript As String
Visual C++
public:
virtual String^ GetCustomScript()

Return Value

A custom script text, if any. Otherwise returns null.

Remarks

This method may return any valid code that may be inserted into the report script. Currently it is used in the TableObject to define the following script methods: Sum, Min, Max, Avg, Count.

Note: you must take into account the current script language - C# or VB.Net. You may check it via Report.ScriptLanguage property.

See Also

Base Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
Base..::.GetExpressions Method
Base Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string[] GetExpressions()
Visual Basic (Declaration)
Public Overridable Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions()

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

Base Class
FastReport Namespace


HasFlag Method

[image]

FastReport.Net Class Reference
Base..::.HasFlag Method
Base Class See Also Send Feedback
Gets a value indicating whether the object has a specified flag in its Flags property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasFlag(
    Flags flag
)
Visual Basic (Declaration)
Public Function HasFlag ( _
    flag As Flags _
) As Boolean
Visual C++
public:
bool HasFlag(
    Flags flag
)

Parameters

flag
Type: FastReport..::.Flags
Flag to check.

Return Value

true if Flags property contains specified flag.

See Also

Base Class
FastReport Namespace


HasParent Method

[image]

FastReport.Net Class Reference
Base..::.HasParent Method
Base Class See Also Send Feedback
Gets a value indicating whether the object has the specified parent in its parent hierarhy.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasParent(
    Base obj
)
Visual Basic (Declaration)
Public Function HasParent ( _
    obj As Base _
) As Boolean
Visual C++
public:
bool HasParent(
    Base^ obj
)

Parameters

obj
Type: FastReport..::.Base
Parent object to check.

Return Value

Returns true if the object has given parent in its parent hierarhy.

See Also

Base Class
FastReport Namespace


HasRestriction Method

[image]

FastReport.Net Class Reference
Base..::.HasRestriction Method
Base Class See Also Send Feedback
Gets a value indicating whether the object has a specified restriction in its Restrictions property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasRestriction(
    Restrictions restriction
)
Visual Basic (Declaration)
Public Function HasRestriction ( _
    restriction As Restrictions _
) As Boolean
Visual C++
public:
bool HasRestriction(
    Restrictions restriction
)

Parameters

restriction
Type: FastReport..::.Restrictions
Restriction to check.

Return Value

true if Restrictions property contains specified restriction.

See Also

Base Class
FastReport Namespace


InvokeEvent Method

[image]

FastReport.Net Class Reference
Base..::.InvokeEvent Method
Base Class Example See Also Send Feedback
Invokes script event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void InvokeEvent(
    string name,
    Object param
)
Visual Basic (Declaration)
Public Sub InvokeEvent ( _
    name As String, _
    param As Object _
)
Visual C++
public:
void InvokeEvent(
    String^ name,
    Object^ param
)

Parameters

name
Type: System..::.String
Name of the event to invoke.
param
Type: System..::.Object
Event parameters.

Remarks

Do not call this method directly. You should use it if you are developing a new component for FastReport.

Use this method to call an event handler that is located in the report's script.

Examples

Example of the OnBeforePrint method:
CopyC#
public void OnBeforePrint(EventArgs e)
{
  if (BeforePrint != null)
    BeforePrint(this, e);
  InvokeEvent(BeforePrintEvent, e);
}

See Also

Base Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Base..::.MemberwiseClone Method
Base Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Base Class
Base Members
FastReport Namespace


OnAfterInsert Method

[image]

FastReport.Net Class Reference
Base..::.OnAfterInsert Method
Base Class See Also Send Feedback
Called after the new object was inserted in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnAfterInsert(
    InsertFrom source
)
Visual Basic (Declaration)
Public Overridable Sub OnAfterInsert ( _
    source As InsertFrom _
)
Visual C++
public:
virtual void OnAfterInsert(
    InsertFrom source
)

Parameters

source
Type: FastReport..::.InsertFrom
The insertion source.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called when new object is inserted, pasted from clipboard or dragged from "Dictionary" window. You may override this method if you need to perform some actions when object is inserted. Typical implementation invokes the object's editor if "Edit after insert" flag is set in the designer options.

See Also

Base Class
FastReport Namespace


OnAfterLoad Method

[image]

FastReport.Net Class Reference
Base..::.OnAfterLoad Method
Base Class See Also Send Feedback
Called after all report objects were loaded.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnAfterLoad()
Visual Basic (Declaration)
Public Overridable Sub OnAfterLoad
Visual C++
public:
virtual void OnAfterLoad()

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

See Also

Base Class
FastReport Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
Base..::.OnBeforeInsert Method
Base Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overridable Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
)

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

Base Class
FastReport Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
Base..::.SelectionChanged Method
Base Class See Also Send Feedback
Called when the user selects another object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SelectionChanged()
Visual Basic (Declaration)
Public Overridable Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged()

Remarks

This method is typically used by the in-place object's editor to check if selection was changed and close the editor.

See Also

Base Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Base..::.Serialize Method
Base Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overridable Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Base Class
FastReport Namespace


SetFlags Method

[image]

FastReport.Net Class Reference
Base..::.SetFlags Method
Base Class See Also Send Feedback
Set object's flags.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetFlags(
    Flags flags,
    bool value
)
Visual Basic (Declaration)
Public Sub SetFlags ( _
    flags As Flags, _
    value As Boolean _
)
Visual C++
public:
void SetFlags(
    Flags flags,
    bool value
)

Parameters

flags
Type: FastReport..::.Flags
Flag to set.
value
Type: System..::.Boolean
true to set the flag, false to reset.

See Also

Base Class
FastReport Namespace


SetName Method

[image]

FastReport.Net Class Reference
Base..::.SetName Method
Base Class See Also Send Feedback
Sets the object's name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetName(
    string value
)
Visual Basic (Declaration)
Public Overridable Sub SetName ( _
    value As String _
)
Visual C++
public:
virtual void SetName(
    String^ value
)

Parameters

value
Type: System..::.String
New name.

Remarks

This method is for internal use only. It just sets a new name without any checks (unlike the Name property setter).

See Also

Base Class
FastReport Namespace
Name Property


SetParent Method

[image]

FastReport.Net Class Reference
Base..::.SetParent Method
Base Class See Also Send Feedback
Sets the object's parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetParent(
    Base value
)
Visual Basic (Declaration)
Public Overridable Sub SetParent ( _
    value As Base _
)
Visual C++
public:
virtual void SetParent(
    Base^ value
)

Parameters

value
Type: FastReport..::.Base
New parent.

Remarks

This method is for internal use only. You can use it if you are developing a new component for FastReport. Override it to perform some actions when the parent of an object is changing. This method checks that parent can contain a child.

Exceptions

Exception | Condition
FastReport.Utils..::.ParentException | Parent object cannot contain this object.

See Also

Base Class
FastReport Namespace


SetParentCore Method

[image]

FastReport.Net Class Reference
Base..::.SetParentCore Method
Base Class See Also Send Feedback
Sets the object's parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetParentCore(
    Base value
)
Visual Basic (Declaration)
Public Sub SetParentCore ( _
    value As Base _
)
Visual C++
public:
void SetParentCore(
    Base^ value
)

Parameters

value
Type: FastReport..::.Base
New parent.

Remarks

This method is for internal use only. You can use it if you are developing a new component for FastReport. This method does not perform any checks, it just sets the new parent.

See Also

Base Class
FastReport Namespace


SetProp Method

[image]

FastReport.Net Class Reference
Base..::.SetProp Method
Base Class Example See Also Send Feedback
Helper method, helps to set a reference-type value to the property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void SetProp(
    Base prop,
    Base value
)
Visual Basic (Declaration)
Protected Sub SetProp ( _
    prop As Base, _
    value As Base _
)
Visual C++
protected:
void SetProp(
    Base^ prop,
    Base^ value
)

Parameters

prop
Type: FastReport..::.Base
Old property value.
value
Type: FastReport..::.Base
New property value.

Remarks

This method is used widely to set a new value to the property that references another FastReport object. Method deals with the Parent property.

Examples

This is example of the DataBand.Header property:
CopyC#
public DataHeaderBand Header
{
  get { return FHeader; }
  set
  {
    SetProp(FHeader, value);
    FHeader = value;
  }
}

See Also

Base Class
FastReport Namespace


SetReport Method

[image]

FastReport.Net Class Reference
Base..::.SetReport Method
Base Class See Also Send Feedback
Sets the reference to a Report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetReport(
    Report value
)
Visual Basic (Declaration)
Public Sub SetReport ( _
    value As Report _
)
Visual C++
public:
void SetReport(
    Report^ value
)

Parameters

value
Type: FastReport..::.Report
Report to set.

See Also

Base Class
FastReport Namespace


Base Properties

[image] [image]

FastReport.Net Class Reference
Base Properties
Base Class See Also Send Feedback

The Base type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects.
BaseName | The base part of the object's name.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects.
ClassName | Gets the short type name.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report.
IsDesigning | Gets a value indicating whether the object is in the design state.
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer.
IsPrinting | Gets a value indicating whether the object is currently printing.
IsRunning | Gets a value indicating whether the object is currently processed by the report engine.
IsSelected | Gets a value indicating whether the object is selected in the designer.
Name | Gets or sets the name of the object.
OriginalComponent | Gets an original component for this object.
Page | Gets reference to the parent PageBase object.
Parent | Gets or sets the parent of the object.
Report | Gets reference to the parent Report object.
Restrictions | Gets or sets the flags that restrict some actions in the designer.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object.

See Also

Base Class
FastReport Namespace


AllObjects Property

[image]

FastReport.Net Class Reference
Base..::.AllObjects Property
Base Class See Also Send Feedback
Gets the collection of all child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ObjectCollection AllObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllObjects As ObjectCollection
Visual C++
public:
property ObjectCollection^ AllObjects {
    ObjectCollection^ get ();
}

Remarks

This property returns child objects that belongs to this object and to child objects of this object. For example, Report.AllObjects will return all objects that contains in the report - such as pages, bands, text objects.

See Also

Base Class
FastReport Namespace


BaseName Property

[image]

FastReport.Net Class Reference
Base..::.BaseName Property
Base Class See Also Send Feedback
The base part of the object's name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BaseName { get; set; }
Visual Basic (Declaration)
Public Property BaseName As String
Visual C++
public:
property String^ BaseName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to automatically create unique object's name. See CreateUniqueName()()()

See Also

Base Class
FastReport Namespace


ChildObjects Property

[image]

FastReport.Net Class Reference
Base..::.ChildObjects Property
Base Class See Also Send Feedback
Gets the collection of this object's child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ObjectCollection ChildObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildObjects As ObjectCollection
Visual C++
public:
property ObjectCollection^ ChildObjects {
    ObjectCollection^ get ();
}

Remarks

This property returns child objects that belongs to this object. For example, Report.ChildObjects will return only pages that contains in the report, but not page childs such as bands. To return all child objects, use AllObjects property.

See Also

Base Class
FastReport Namespace


ClassName Property

[image]

FastReport.Net Class Reference
Base..::.ClassName Property
Base Class See Also Send Feedback
Gets the short type name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ClassName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
}

Remarks

Returns the short type name, such as "TextObject".

See Also

Base Class
FastReport Namespace


Flags Property

[image]

FastReport.Net Class Reference
Base..::.Flags Property
Base Class See Also Send Feedback
Gets the flags that allow some functionality in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Flags Flags { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flags As Flags
Visual C++
public:
property Flags Flags {
    Flags get ();
}

Remarks

Use this property only if you developing a new FastReport object.

See Also

Base Class
FastReport Namespace


IsAncestor Property

[image]

FastReport.Net Class Reference
Base..::.IsAncestor Property
Base Class See Also Send Feedback
Gets a value indicating whether the object was introduced in the ancestor report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsAncestor { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAncestor As Boolean
Visual C++
public:
property bool IsAncestor {
    bool get ();
}

See Also

Base Class
FastReport Namespace


IsDesigning Property

[image]

FastReport.Net Class Reference
Base..::.IsDesigning Property
Base Class See Also Send Feedback
Gets a value indicating whether the object is in the design state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsDesigning { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDesigning As Boolean
Visual C++
public:
property bool IsDesigning {
    bool get ();
}

See Also

Base Class
FastReport Namespace


IsParentSelected Property

[image]

FastReport.Net Class Reference
Base..::.IsParentSelected Property
Base Class See Also Send Feedback
Gets a value indicating whether one of the object's parent is selected in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsParentSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsParentSelected As Boolean
Visual C++
public:
property bool IsParentSelected {
    bool get ();
}

See Also

Base Class
FastReport Namespace


IsPrinting Property

[image]

FastReport.Net Class Reference
Base..::.IsPrinting Property
Base Class See Also Send Feedback
Gets a value indicating whether the object is currently printing.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsPrinting { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrinting As Boolean
Visual C++
public:
property bool IsPrinting {
    bool get ();
}

See Also

Base Class
FastReport Namespace


IsRunning Property

[image]

FastReport.Net Class Reference
Base..::.IsRunning Property
Base Class See Also Send Feedback
Gets a value indicating whether the object is currently processed by the report engine.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsRunning { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRunning As Boolean
Visual C++
public:
property bool IsRunning {
    bool get ();
}

See Also

Base Class
FastReport Namespace


IsSelected Property

[image]

FastReport.Net Class Reference
Base..::.IsSelected Property
Base Class See Also Send Feedback
Gets a value indicating whether the object is selected in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool IsSelected { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsSelected As Boolean
Visual C++
public:
virtual property bool IsSelected {
    bool get ();
}

See Also

Base Class
FastReport Namespace


Name Property

[image]

FastReport.Net Class Reference
Base..::.Name Property
Base Class Example See Also Send Feedback
Gets or sets the name of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

Name of the report object must contain alpha, digit, underscore symbols only. Data objects such as Variable, TableDataSource etc. can have any characters in they names. Each component must have unique name.

Examples

The following code demonstrates how to find an object by its name:
CopyC#
TextObject text1 = report1.FindObject("Text1") as TextObject;

Exceptions

Exception | Condition
FastReport.Utils..::.DuplicateNameException | Another object with such name exists.
FastReport.Utils..::.AncestorException | Rename an object that was introduced in the ancestor report.

See Also

Base Class
FastReport Namespace


OriginalComponent Property

[image]

FastReport.Net Class Reference
Base..::.OriginalComponent Property
Base Class See Also Send Feedback
Gets an original component for this object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base OriginalComponent { get; set; }
Visual Basic (Declaration)
Public Property OriginalComponent As Base
Visual C++
public:
property Base^ OriginalComponent {
    Base^ get ();
    void set (Base^ value);
}

Remarks

This property is used in the preview mode. Each object in the prepared report is bound to its original (from the report template). This technique is used to minimize the prepared report's size.

See Also

Base Class
FastReport Namespace


Page Property

[image]

FastReport.Net Class Reference
Base..::.Page Property
Base Class See Also Send Feedback
Gets reference to the parent PageBase object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageBase Page { get; }
Visual Basic (Declaration)
Public ReadOnly Property Page As PageBase
Visual C++
public:
property PageBase^ Page {
    PageBase^ get ();
}

See Also

Base Class
FastReport Namespace


Parent Property

[image]

FastReport.Net Class Reference
Base..::.Parent Property
Base Class Example See Also Send Feedback
Gets or sets the parent of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Base
Visual C++
public:
property Base^ Parent {
    Base^ get ();
    void set (Base^ value);
}

Remarks

Each report object must have a parent in order to appear in the report. Parent must be able to contain objects of such type.

Another way (preferred) to set a parent is to use specific properties of the parent object. For example, the Report object has the Pages collection. To add a new page to the report, use the following code: report1.Pages.Add(new ReportPage());

Examples

CopyC#
Report report1;
ReportPage page = new ReportPage();
page.Parent = report1;

Exceptions

Exception | Condition
FastReport.Utils..::.ParentException | Parent object cannot contain this object.

See Also

Base Class
FastReport Namespace


Report Property

[image]

FastReport.Net Class Reference
Base..::.Report Property
Base Class See Also Send Feedback
Gets reference to the parent Report object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
}

See Also

Base Class
FastReport Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
Base..::.Restrictions Property
Base Class See Also Send Feedback
Gets or sets the flags that restrict some actions in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

Remarks

Use this property to restrict some user actions like move, resize, edit, delete. For example, if Restriction.DontMove flag is set, user cannot move the object in the designer.

See Also

Base Class
FastReport Namespace


ZOrder Property

[image]

FastReport.Net Class Reference
Base..::.ZOrder Property
Base Class See Also Send Feedback
Gets or sets the Z-order of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ZOrder { get; set; }
Visual Basic (Declaration)
Public Property ZOrder As Integer
Visual C++
public:
property int ZOrder {
    int get ();
    void set (int value);
}

Remarks

The Z-order is also called "creation order". It is the index of an object in the parent's objects list. For example, put two text objects on a band. First object will have ZOrder = 0, second = 1. Setting the second object's ZOrder to 0 will move it to the back of the first text object.

See Also

Base Class
FastReport Namespace


Base Events

[image] [image]

FastReport.Net Class Reference
Base Events
Base Class See Also Send Feedback

The Base type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Base Class
FastReport Namespace


Border Class

[image]

FastReport.Net Class Reference
Border Class
Members See Also Send Feedback
Represents a border around the report object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Border
Visual Basic (Declaration)
Public Class Border
Visual C++
public ref class Border

Remarks

Border consists of four lines. Each line has own color, style and width. Lines are accessible through LeftLine, RightLine, TopLine, BottomLine properties.

To turn on and off the lines, use the Lines property. To set the same color, style or width for each line, use Color, Style, Width properties of the Border.

Inheritance Hierarchy

System..::.Object
FastReport..::.Border

See Also

Border Members
FastReport Namespace


Border Members

[image] [image]

FastReport.Net Class Reference
Border Members
Border Class Constructors Methods Properties See Also Send Feedback

The Border type exposes the following members.

Constructors

Name | Description
Border | Initializes a new instance of the Border class with default settings.

Methods

Name | Description
Clone | Creates the exact copy of this Border.
Draw | Draw the border using draw event arguments and specified bounding rectangle.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the border.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomLine | Gets or sets the bottom line of the border.
Color | Gets or sets a color of the border.
LeftLine | Gets or sets the left line of the border.
Lines | Gets or sets a visible lines of a border.
RightLine | Gets or sets the right line of the border.
Shadow | Gets or sets a value determines whether to draw a shadow.
ShadowColor | Gets or sets a shadow color.
ShadowWidth | Gets or sets a shadow width, in pixels.
SimpleBorder | Gets or sets a value determines that Border must serialize only one line.
Style | Gets or sets a style of the border.
TopLine | Gets or sets the top line of the border.
Width | Gets or sets a width of the border, in pixels.

See Also

Border Class
FastReport Namespace


Border Constructor

[image]

FastReport.Net Class Reference
Border Constructor
Border Class See Also Send Feedback
Initializes a new instance of the Border class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Border()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Border()

See Also

Border Class
FastReport Namespace


Border Methods

[image] [image]

FastReport.Net Class Reference
Border Methods
Border Class See Also Send Feedback

The Border type exposes the following members.

Methods

Name | Description
Clone | Creates the exact copy of this Border.
Draw | Draw the border using draw event arguments and specified bounding rectangle.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the border.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Border Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
Border..::.Clone Method
Border Class See Also Send Feedback
Creates the exact copy of this Border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Border Clone()
Visual Basic (Declaration)
Public Function Clone As Border
Visual C++
public:
Border^ Clone()

Return Value

A copy of this border.

See Also

Border Class
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
Border..::.Draw Method
Border Class See Also Send Feedback
Draw the border using draw event arguments and specified bounding rectangle.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Draw(
    FRPaintEventArgs e,
    RectangleF rect
)
Visual Basic (Declaration)
Public Sub Draw ( _
    e As FRPaintEventArgs, _
    rect As RectangleF _
)
Visual C++
public:
void Draw(
    FRPaintEventArgs^ e,
    RectangleF rect
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
rect
Type: System.Drawing..::.RectangleF
Bounding rectangle.

Remarks

This method is for internal use only.

See Also

Border Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
Border..::.Equals Method
Border Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

Border Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
Border..::.GetHashCode Method
Border Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

Border Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Border..::.Serialize Method
Border Class See Also Send Feedback
Serializes the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer,
    string prefix,
    Border c
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    c As Border _
)
Visual C++
public:
void Serialize(
    FRWriter^ writer,
    String^ prefix,
    Border^ c
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Border property name.
c
Type: FastReport..::.Border
Another Border to compare with.

Remarks

This method is for internal use only.

See Also

Border Class
FastReport Namespace


Border Properties

[image] [image]

FastReport.Net Class Reference
Border Properties
Border Class See Also Send Feedback

The Border type exposes the following members.

Properties

Name | Description
BottomLine | Gets or sets the bottom line of the border.
Color | Gets or sets a color of the border.
LeftLine | Gets or sets the left line of the border.
Lines | Gets or sets a visible lines of a border.
RightLine | Gets or sets the right line of the border.
Shadow | Gets or sets a value determines whether to draw a shadow.
ShadowColor | Gets or sets a shadow color.
ShadowWidth | Gets or sets a shadow width, in pixels.
SimpleBorder | Gets or sets a value determines that Border must serialize only one line.
Style | Gets or sets a style of the border.
TopLine | Gets or sets the top line of the border.
Width | Gets or sets a width of the border, in pixels.

See Also

Border Class
FastReport Namespace


BottomLine Property

[image]

FastReport.Net Class Reference
Border..::.BottomLine Property
Border Class See Also Send Feedback
Gets or sets the bottom line of the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderLine BottomLine { get; set; }
Visual Basic (Declaration)
Public Property BottomLine As BorderLine
Visual C++
public:
property BorderLine^ BottomLine {
    BorderLine^ get ();
    void set (BorderLine^ value);
}

See Also

Border Class
FastReport Namespace


Color Property

[image]

FastReport.Net Class Reference
Border..::.Color Property
Border Class See Also Send Feedback
Gets or sets a color of the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Remarks

This property actually returns a color of the LeftLine. When you assign a value to this property, the value will be set to each border line.

See Also

Border Class
FastReport Namespace


LeftLine Property

[image]

FastReport.Net Class Reference
Border..::.LeftLine Property
Border Class See Also Send Feedback
Gets or sets the left line of the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderLine LeftLine { get; set; }
Visual Basic (Declaration)
Public Property LeftLine As BorderLine
Visual C++
public:
property BorderLine^ LeftLine {
    BorderLine^ get ();
    void set (BorderLine^ value);
}

See Also

Border Class
FastReport Namespace


Lines Property

[image]

FastReport.Net Class Reference
Border..::.Lines Property
Border Class See Also Send Feedback
Gets or sets a visible lines of a border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderLines Lines { get; set; }
Visual Basic (Declaration)
Public Property Lines As BorderLines
Visual C++
public:
property BorderLines Lines {
    BorderLines get ();
    void set (BorderLines value);
}

See Also

Border Class
FastReport Namespace


RightLine Property

[image]

FastReport.Net Class Reference
Border..::.RightLine Property
Border Class See Also Send Feedback
Gets or sets the right line of the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderLine RightLine { get; set; }
Visual Basic (Declaration)
Public Property RightLine As BorderLine
Visual C++
public:
property BorderLine^ RightLine {
    BorderLine^ get ();
    void set (BorderLine^ value);
}

See Also

Border Class
FastReport Namespace


Shadow Property

[image]

FastReport.Net Class Reference
Border..::.Shadow Property
Border Class See Also Send Feedback
Gets or sets a value determines whether to draw a shadow.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Shadow { get; set; }
Visual Basic (Declaration)
Public Property Shadow As Boolean
Visual C++
public:
property bool Shadow {
    bool get ();
    void set (bool value);
}

See Also

Border Class
FastReport Namespace


ShadowColor Property

[image]

FastReport.Net Class Reference
Border..::.ShadowColor Property
Border Class See Also Send Feedback
Gets or sets a shadow color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color ShadowColor { get; set; }
Visual Basic (Declaration)
Public Property ShadowColor As Color
Visual C++
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}

See Also

Border Class
FastReport Namespace


ShadowWidth Property

[image]

FastReport.Net Class Reference
Border..::.ShadowWidth Property
Border Class See Also Send Feedback
Gets or sets a shadow width, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ShadowWidth { get; set; }
Visual Basic (Declaration)
Public Property ShadowWidth As Single
Visual C++
public:
property float ShadowWidth {
    float get ();
    void set (float value);
}

See Also

Border Class
FastReport Namespace


SimpleBorder Property

[image]

FastReport.Net Class Reference
Border..::.SimpleBorder Property
Border Class See Also Send Feedback
Gets or sets a value determines that Border must serialize only one line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SimpleBorder { get; set; }
Visual Basic (Declaration)
Public Property SimpleBorder As Boolean
Visual C++
public:
property bool SimpleBorder {
    bool get ();
    void set (bool value);
}

Remarks

This property is for internal use only.

See Also

Border Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
Border..::.Style Property
Border Class See Also Send Feedback
Gets or sets a style of the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LineStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As LineStyle
Visual C++
public:
property LineStyle Style {
    LineStyle get ();
    void set (LineStyle value);
}

Remarks

This property actually returns a style of the LeftLine. When you assign a value to this property, the value will be set to each border line.

See Also

Border Class
FastReport Namespace


TopLine Property

[image]

FastReport.Net Class Reference
Border..::.TopLine Property
Border Class See Also Send Feedback
Gets or sets the top line of the border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderLine TopLine { get; set; }
Visual Basic (Declaration)
Public Property TopLine As BorderLine
Visual C++
public:
property BorderLine^ TopLine {
    BorderLine^ get ();
    void set (BorderLine^ value);
}

See Also

Border Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
Border..::.Width Property
Border Class See Also Send Feedback
Gets or sets a width of the border, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

Remarks

This property actually returns a width of the LeftLine. When you assign a value to this property, the value will be set to each border line.

See Also

Border Class
FastReport Namespace


BorderLine Class

[image]

FastReport.Net Class Reference
BorderLine Class
Members See Also Send Feedback
Represents a single border line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BorderLine
Visual Basic (Declaration)
Public Class BorderLine
Visual C++
public ref class BorderLine

Inheritance Hierarchy

System..::.Object
FastReport..::.BorderLine

See Also

BorderLine Members
FastReport Namespace


BorderLine Members

[image] [image]

FastReport.Net Class Reference
BorderLine Members
BorderLine Class Methods Properties See Also Send Feedback

The BorderLine type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets a color of the line.
Style | Gets or sets a style of the line.
Width | Gets or sets a width of the line, in pixels.

See Also

BorderLine Class
FastReport Namespace


BorderLine Methods

[image] [image]

FastReport.Net Class Reference
BorderLine Methods
BorderLine Class See Also Send Feedback

The BorderLine type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BorderLine Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
BorderLine..::.Equals Method
BorderLine Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

BorderLine Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
BorderLine..::.GetHashCode Method
BorderLine Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

BorderLine Class
FastReport Namespace


BorderLine Properties

[image] [image]

FastReport.Net Class Reference
BorderLine Properties
BorderLine Class See Also Send Feedback

The BorderLine type exposes the following members.

Properties

Name | Description
Color | Gets or sets a color of the line.
Style | Gets or sets a style of the line.
Width | Gets or sets a width of the line, in pixels.

See Also

BorderLine Class
FastReport Namespace


Color Property

[image]

FastReport.Net Class Reference
BorderLine..::.Color Property
BorderLine Class See Also Send Feedback
Gets or sets a color of the line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

BorderLine Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
BorderLine..::.Style Property
BorderLine Class See Also Send Feedback
Gets or sets a style of the line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LineStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As LineStyle
Visual C++
public:
property LineStyle Style {
    LineStyle get ();
    void set (LineStyle value);
}

See Also

BorderLine Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
BorderLine..::.Width Property
BorderLine Class See Also Send Feedback
Gets or sets a width of the line, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

BorderLine Class
FastReport Namespace


BorderLines Enumeration

[image]

FastReport.Net Class Reference
BorderLines Enumeration
See Also Send Feedback
Specifies the sides of a border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
[FlagsAttribute]
public enum BorderLines
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration BorderLines
Visual C++
[FlagsAttribute]
public enum class BorderLines

Members

Member name | Description
None | Specifies no border lines.
Left | Specifies the left border line.
Right | Specifies the right border line.
Top | Specifies the top border line.
Bottom | Specifies the bottom border line.
All | Specifies all border lines.

See Also

FastReport Namespace


BreakableComponent Class

[image]

FastReport.Net Class Reference
BreakableComponent Class
Members See Also Send Feedback
Base class for report components that can break across pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BreakableComponent : ReportComponentBase
Visual Basic (Declaration)
Public Class BreakableComponent _
    Inherits ReportComponentBase
Visual C++
public ref class BreakableComponent : public ReportComponentBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport.Table..::.TableBase
FastReport..::.TextObjectBase

See Also

BreakableComponent Members
FastReport Namespace


BreakableComponent Members

[image] [image]

FastReport.Net Class Reference
BreakableComponent Members
BreakableComponent Class Constructors Methods Properties Events See Also Send Feedback

The BreakableComponent type exposes the following members.

Constructors

Name | Description
BreakableComponent | Initializes a new instance of the BreakableComponent class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object.
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ReportComponentBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object.
CanBreak | Gets or sets a value that determines if the component can break its contents across pages.
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

BreakableComponent Class
FastReport Namespace


BreakableComponent Constructor

[image]

FastReport.Net Class Reference
BreakableComponent Constructor
BreakableComponent Class See Also Send Feedback
Initializes a new instance of the BreakableComponent class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BreakableComponent()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BreakableComponent()

See Also

BreakableComponent Class
FastReport Namespace


BreakableComponent Methods

[image] [image]

FastReport.Net Class Reference
BreakableComponent Methods
BreakableComponent Class See Also Send Feedback

The BreakableComponent type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object.
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ReportComponentBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

BreakableComponent Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
BreakableComponent..::.Assign Method
BreakableComponent Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

BreakableComponent Class
FastReport Namespace
AssignAll Method


Break Method

[image]

FastReport.Net Class Reference
BreakableComponent..::.Break Method
BreakableComponent Class See Also Send Feedback
Breaks the contents of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool Break(
    BreakableComponent breakTo
)
Visual Basic (Declaration)
Public Overridable Function Break ( _
    breakTo As BreakableComponent _
) As Boolean
Visual C++
public:
virtual bool Break(
    BreakableComponent^ breakTo
)

Parameters

breakTo
Type: FastReport..::.BreakableComponent
Object to put the part of content to that does not fit in this object. These two objects must have the same type.

Return Value

true if there is enough space in this object to display at least one text line.

Remarks

Do not call this method directly, it is used by the report engine. You should override it if you are writing a new FastReport object.

This method must break the contents of the object. The part of content that fit in current object's bounds should remain in this object, the part that does not fit should be transferred to breakTo object.

See Also

BreakableComponent Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
BreakableComponent..::.Dispose Method
BreakableComponent Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

BreakableComponent Class
BreakableComponent Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
BreakableComponent..::.DrawMarkers Method
BreakableComponent Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

BreakableComponent Class
BreakableComponent Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BreakableComponent..::.MemberwiseClone Method
BreakableComponent Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BreakableComponent Class
BreakableComponent Members
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
BreakableComponent..::.Serialize Method
BreakableComponent Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

BreakableComponent Class
FastReport Namespace


BreakableComponent Properties

[image] [image]

FastReport.Net Class Reference
BreakableComponent Properties
BreakableComponent Class See Also Send Feedback

The BreakableComponent type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object.
CanBreak | Gets or sets a value that determines if the component can break its contents across pages.
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

BreakableComponent Class
FastReport Namespace


BreakTo Property

[image]

FastReport.Net Class Reference
BreakableComponent..::.BreakTo Property
BreakableComponent Class See Also Send Feedback
Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BreakableComponent BreakTo { get; set; }
Visual Basic (Declaration)
Public Property BreakTo As BreakableComponent
Visual C++
public:
property BreakableComponent^ BreakTo {
    BreakableComponent^ get ();
    void set (BreakableComponent^ value);
}

See Also

BreakableComponent Class
FastReport Namespace


CanBreak Property

[image]

FastReport.Net Class Reference
BreakableComponent..::.CanBreak Property
BreakableComponent Class See Also Send Feedback
Gets or sets a value that determines if the component can break its contents across pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanBreak { get; set; }
Visual Basic (Declaration)
Public Property CanBreak As Boolean
Visual C++
public:
property bool CanBreak {
    bool get ();
    void set (bool value);
}

See Also

BreakableComponent Class
FastReport Namespace


BreakableComponent Events

[image] [image]

FastReport.Net Class Reference
BreakableComponent Events
BreakableComponent Class See Also Send Feedback

The BreakableComponent type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

BreakableComponent Class
FastReport Namespace


BreakableComponentMenu Class

[image]

FastReport.Net Class Reference
BreakableComponentMenu Class
Members See Also Send Feedback
This class represents the context menu of the BreakableComponent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BreakableComponentMenu : ReportComponentBaseMenu
Visual Basic (Declaration)
Public Class BreakableComponentMenu _
    Inherits ReportComponentBaseMenu
Visual C++
public ref class BreakableComponentMenu : public ReportComponentBaseMenu

Remarks

This class adds the "Can Break" menu item to the component context menu.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
ContextMenuBar
FastReport..::.ComponentMenuBase
FastReport..::.ReportComponentBaseMenu
FastReport..::.BreakableComponentMenu
FastReport..::.TextObjectBaseMenu

See Also

BreakableComponentMenu Members
FastReport Namespace


BreakableComponentMenu Members

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu Members
BreakableComponentMenu Class Constructors Methods Fields Properties Events See Also Send Feedback

The BreakableComponentMenu type exposes the following members.

Constructors

Name | Description
BreakableComponentMenu | Initializes a new instance of the BreakableComponentMenu class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanBreak | The "Can Break" menu item.
miCanGrow | The "Can Grow" menu item. (Inherited from ReportComponentBaseMenu.)
miCanShrink | The "Can Shrink" menu item. (Inherited from ReportComponentBaseMenu.)
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miGrowToBottom | The "Grow to Bottom" menu item. (Inherited from ReportComponentBaseMenu.)
miHyperlink | The "Hyperlink" menu item. (Inherited from ReportComponentBaseMenu.)
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BreakableComponentMenu Class
FastReport Namespace


BreakableComponentMenu Constructor

[image]

FastReport.Net Class Reference
BreakableComponentMenu Constructor
BreakableComponentMenu Class See Also Send Feedback
Initializes a new instance of the BreakableComponentMenu class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BreakableComponentMenu(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
BreakableComponentMenu(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer

See Also

BreakableComponentMenu Class
FastReport Namespace


BreakableComponentMenu Fields

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu Fields
BreakableComponentMenu Class See Also Send Feedback

The BreakableComponentMenu type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanBreak | The "Can Break" menu item.
miCanGrow | The "Can Grow" menu item. (Inherited from ReportComponentBaseMenu.)
miCanShrink | The "Can Shrink" menu item. (Inherited from ReportComponentBaseMenu.)
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miGrowToBottom | The "Grow to Bottom" menu item. (Inherited from ReportComponentBaseMenu.)
miHyperlink | The "Hyperlink" menu item. (Inherited from ReportComponentBaseMenu.)
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)

See Also

BreakableComponentMenu Class
FastReport Namespace


miCanBreak Field

[image]

FastReport.Net Class Reference
BreakableComponentMenu..::.miCanBreak Field
BreakableComponentMenu Class See Also Send Feedback
The "Can Break" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miCanBreak
Visual Basic (Declaration)
Public miCanBreak As ButtonItem
Visual C++
public:
ButtonItem^ miCanBreak

See Also

BreakableComponentMenu Class
FastReport Namespace


BreakableComponentMenu Methods

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu Methods
BreakableComponentMenu Class See Also Send Feedback

The BreakableComponentMenu type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

BreakableComponentMenu Class
FastReport Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.AccessibilityNotifyClients Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.BeginInvoke Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.CloseDockTab Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


CreateMenuItem Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.CreateMenuItem Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
CreateMenuItem(String) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(Image, String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.Dispose Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.GetChildAtPoint Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.GetItems Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.Invalidate Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.Invoke Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.MemberwiseClone Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.PerformLayout Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.ResumeLayout Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.RtlTranslateAlignment Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.Scale Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.Select Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.SetBounds Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.SetSize Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu..::.UpdateBounds Method
BreakableComponentMenu Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BreakableComponentMenu Class
BreakableComponentMenu Members
FastReport Namespace


BreakableComponentMenu Properties

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu Properties
BreakableComponentMenu Class See Also Send Feedback

The BreakableComponentMenu type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

BreakableComponentMenu Class
FastReport Namespace


BreakableComponentMenu Events

[image] [image]

FastReport.Net Class Reference
BreakableComponentMenu Events
BreakableComponentMenu Class See Also Send Feedback

The BreakableComponentMenu type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BreakableComponentMenu Class
FastReport Namespace


CapSettings Class

[image]

FastReport.Net Class Reference
CapSettings Class
Members See Also Send Feedback
Specifies a start and end line caps.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CapSettings
Visual Basic (Declaration)
Public Class CapSettings
Visual C++
public ref class CapSettings

Inheritance Hierarchy

System..::.Object
FastReport..::.CapSettings

See Also

CapSettings Members
FastReport Namespace


CapSettings Members

[image] [image]

FastReport.Net Class Reference
CapSettings Members
CapSettings Class Constructors Methods Properties See Also Send Feedback

The CapSettings type exposes the following members.

Constructors

Name | Description
CapSettings | Initializes a new instance of the CapSettings class with default settings.

Methods

Name | Description
Assign | Assigns values from another source.
Clone | Creates exact copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the cap settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets a height of the cap.
Style | Gets or sets a cap style.
Width | Gets or sets a width of the cap.

See Also

CapSettings Class
FastReport Namespace


CapSettings Constructor

[image]

FastReport.Net Class Reference
CapSettings Constructor
CapSettings Class See Also Send Feedback
Initializes a new instance of the CapSettings class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CapSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CapSettings()

See Also

CapSettings Class
FastReport Namespace


CapSettings Methods

[image] [image]

FastReport.Net Class Reference
CapSettings Methods
CapSettings Class See Also Send Feedback

The CapSettings type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Clone | Creates exact copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the cap settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CapSettings Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
CapSettings..::.Assign Method
CapSettings Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    CapSettings source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As CapSettings _
)
Visual C++
public:
void Assign(
    CapSettings^ source
)

Parameters

source
Type: FastReport..::.CapSettings
Source to assign from.

See Also

CapSettings Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
CapSettings..::.Clone Method
CapSettings Class See Also Send Feedback
Creates exact copy of this object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CapSettings Clone()
Visual Basic (Declaration)
Public Function Clone As CapSettings
Visual C++
public:
CapSettings^ Clone()

Return Value

Copy of this object.

See Also

CapSettings Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
CapSettings..::.Equals Method
CapSettings Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

CapSettings Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
CapSettings..::.GetHashCode Method
CapSettings Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

CapSettings Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CapSettings..::.Serialize Method
CapSettings Class See Also Send Feedback
Serializes the cap settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    string prefix,
    FRWriter writer,
    CapSettings diff
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    prefix As String, _
    writer As FRWriter, _
    diff As CapSettings _
)
Visual C++
public:
void Serialize(
    String^ prefix,
    FRWriter^ writer,
    CapSettings^ diff
)

Parameters

prefix
Type: System..::.String
Name of the cap property.
writer
Type: FastReport.Utils..::.FRWriter
Writer object.
diff
Type: FastReport..::.CapSettings
Another cap to compare with.

Remarks

This method is for internal use only.

See Also

CapSettings Class
FastReport Namespace


CapSettings Properties

[image] [image]

FastReport.Net Class Reference
CapSettings Properties
CapSettings Class See Also Send Feedback

The CapSettings type exposes the following members.

Properties

Name | Description
Height | Gets or sets a height of the cap.
Style | Gets or sets a cap style.
Width | Gets or sets a width of the cap.

See Also

CapSettings Class
FastReport Namespace


Height Property

[image]

FastReport.Net Class Reference
CapSettings..::.Height Property
CapSettings Class See Also Send Feedback
Gets or sets a height of the cap.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Single
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

CapSettings Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
CapSettings..::.Style Property
CapSettings Class See Also Send Feedback
Gets or sets a cap style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CapStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As CapStyle
Visual C++
public:
property CapStyle Style {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

CapSettings Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
CapSettings..::.Width Property
CapSettings Class See Also Send Feedback
Gets or sets a width of the cap.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

CapSettings Class
FastReport Namespace


CapStyle Enumeration

[image]

FastReport.Net Class Reference
CapStyle Enumeration
See Also Send Feedback
Specifies a line cap style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum CapStyle
Visual Basic (Declaration)
Public Enumeration CapStyle
Visual C++
public enum class CapStyle

Members

Member name | Description
None | Specifies a line without a cap.
Circle | Specifies a line with a circle cap.
Square | Specifies a line with a square cap.
Diamond | Specifies a line with a diamond cap.
Arrow | Specifies a line with an arrow cap.

See Also

FastReport Namespace


CellularTextObject Class

[image]

FastReport.Net Class Reference
CellularTextObject Class
Members See Also Send Feedback
Represents a text object which draws each symbol of text in its own cell.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CellularTextObject : TextObject
Visual Basic (Declaration)
Public Class CellularTextObject _
    Inherits TextObject
Visual C++
public ref class CellularTextObject : public TextObject

Remarks

The text may be aligned to left or right side, or centered. Use the HorzAlign property to do this. The "justify" align is not supported now, as well as vertical alignment.

The cell size is defined in the CellWidth and CellHeight properties. These properties are 0 by default, in this case the size of cell is calculated automatically based on the object's Font.

To define a spacing (gap) between cells, use the HorzSpacing and VertSpacing properties.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.TextObjectBase
FastReport..::.TextObject
FastReport..::.CellularTextObject

See Also

CellularTextObject Members
FastReport Namespace


CellularTextObject Members

[image] [image]

FastReport.Net Class Reference
CellularTextObject Members
CellularTextObject Class Constructors Methods Properties Events See Also Send Feedback

The CellularTextObject type exposes the following members.

Constructors

Name | Description
CellularTextObject | Initializes a new instance of the CellularTextObject class with the default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from TextObject.)
Assign | Copies the contents of another, similar object. (Overrides TextObject..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from TextObject.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TextObject.)
CalcHeight | Calculates the object's height. (Overrides TextObject..::.CalcHeight()()().)
CalcWidth | Calculates the object's width. (Inherited from TextObject.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from TextObject.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides TextObject..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Inherited from TextObject.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
DrawText | Draws a text. (Inherited from TextObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from TextObject.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from TextObject.)
GetExpressions | Gets all expressions contained in the object. (Inherited from TextObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from TextObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from TextObject.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from TextObject.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TextObject.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from TextObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from TextObject.)
RestoreStyle | Restores the current style. (Inherited from TextObject.)
SaveState | Saves the object's state before printing it. (Inherited from TextObject.)
SaveStyle | Saves the current style. (Inherited from TextObject.)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from TextObject.)
Serialize | Serializes the object. (Overrides TextObject..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | This property is not relevant to this class.
AutoShrink | This property is not relevant to this class.
AutoShrinkMinSize | This property is not relevant to this class.
AutoWidth | This property is not relevant to this class.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | This property is not relevant to this class.
CanBreak | This property is not relevant to this class.
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
CellHeight | Gets or sets the height of cell, in pixels.
CellWidth | Gets or sets the width of cell, in pixels.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Clip | This property is not relevant to this class.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values. (Inherited from TextObjectBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstTabOffset | This property is not relevant to this class.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Font | Gets or sets the font settings for this object. (Inherited from TextObject.)
FontWidthRatio | This property is not relevant to this class.
ForceJustify | This property is not relevant to this class.
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from TextObject.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
Highlight | Gets the collection of conditional highlight attributes. (Inherited from TextObject.)
HorzAlign | Gets or sets the horizontal alignment of a text in the TextObject object. (Inherited from TextObject.)
HorzSpacing | Gets or sets the horizontal spacing between cells, in pixels.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
HtmlTags | This property is not relevant to this class.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from TextObject.)
LineHeight | This property is not relevant to this class.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | This property is not relevant to this class.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
ParagraphOffset | Gets or sets the paragraph offset, in pixels. (Inherited from TextObject.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | This property is not relevant to this class.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
TabWidth | This property is not relevant to this class.
Text | Gets or sets the object's text. (Inherited from TextObjectBase.)
TextColor | Gets or sets the text color in a simple manner. (Inherited from TextObject.)
TextFill | Gets or sets the fill color used to draw a text. (Inherited from TextObject.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from TextObject.)
Trimming | This property is not relevant to this class.
Underlines | This property is not relevant to this class.
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
VertAlign | Gets or sets the vertical alignment of a text in the TextObject object. (Inherited from TextObject.)
VertSpacing | Gets or sets the vertical spacing between cells, in pixels.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TextObject.)
WordWrap | Gets or sets a value that indicates if lines are automatically word-wrapped. (Inherited from TextObject.)
Wysiwyg | This property is not relevant to this class.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

CellularTextObject Class
FastReport Namespace


CellularTextObject Constructor

[image]

FastReport.Net Class Reference
CellularTextObject Constructor
CellularTextObject Class See Also Send Feedback
Initializes a new instance of the CellularTextObject class with the default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CellularTextObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CellularTextObject()

See Also

CellularTextObject Class
FastReport Namespace


CellularTextObject Methods

[image] [image]

FastReport.Net Class Reference
CellularTextObject Methods
CellularTextObject Class See Also Send Feedback

The CellularTextObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from TextObject.)
Assign | Copies the contents of another, similar object. (Overrides TextObject..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from TextObject.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TextObject.)
CalcHeight | Calculates the object's height. (Overrides TextObject..::.CalcHeight()()().)
CalcWidth | Calculates the object's width. (Inherited from TextObject.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from TextObject.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides TextObject..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Inherited from TextObject.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
DrawText | Draws a text. (Inherited from TextObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from TextObject.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from TextObject.)
GetExpressions | Gets all expressions contained in the object. (Inherited from TextObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from TextObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from TextObject.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from TextObject.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TextObject.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from TextObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from TextObject.)
RestoreStyle | Restores the current style. (Inherited from TextObject.)
SaveState | Saves the object's state before printing it. (Inherited from TextObject.)
SaveStyle | Saves the current style. (Inherited from TextObject.)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from TextObject.)
Serialize | Serializes the object. (Overrides TextObject..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CellularTextObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
CellularTextObject..::.Assign Method
CellularTextObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

CellularTextObject Class
FastReport Namespace
AssignAll Method


CalcHeight Method

[image]

FastReport.Net Class Reference
CellularTextObject..::.CalcHeight Method
CellularTextObject Class See Also Send Feedback
Calculates the object's height.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float CalcHeight()
Visual Basic (Declaration)
Public Overrides Function CalcHeight As Single
Visual C++
public:
virtual float CalcHeight() override

Return Value

Actual object's height, in pixels.

Remarks

Applicable to objects that contain several text lines, such as TextObject. Returns the height needed to display all the text lines.

See Also

CellularTextObject Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CellularTextObject..::.Dispose Method
CellularTextObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

CellularTextObject Class
CellularTextObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
CellularTextObject..::.Draw Method
CellularTextObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

CellularTextObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
CellularTextObject..::.DrawMarkers Method
CellularTextObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

CellularTextObject Class
CellularTextObject Members
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
CellularTextObject..::.GetPreferredSize Method
CellularTextObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

CellularTextObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CellularTextObject..::.MemberwiseClone Method
CellularTextObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CellularTextObject Class
CellularTextObject Members
FastReport Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
CellularTextObject..::.OnBeforeInsert Method
CellularTextObject Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

CellularTextObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CellularTextObject..::.Serialize Method
CellularTextObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

CellularTextObject Class
FastReport Namespace


CellularTextObject Properties

[image] [image]

FastReport.Net Class Reference
CellularTextObject Properties
CellularTextObject Class See Also Send Feedback

The CellularTextObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | This property is not relevant to this class.
AutoShrink | This property is not relevant to this class.
AutoShrinkMinSize | This property is not relevant to this class.
AutoWidth | This property is not relevant to this class.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | This property is not relevant to this class.
CanBreak | This property is not relevant to this class.
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
CellHeight | Gets or sets the height of cell, in pixels.
CellWidth | Gets or sets the width of cell, in pixels.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Clip | This property is not relevant to this class.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values. (Inherited from TextObjectBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstTabOffset | This property is not relevant to this class.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Font | Gets or sets the font settings for this object. (Inherited from TextObject.)
FontWidthRatio | This property is not relevant to this class.
ForceJustify | This property is not relevant to this class.
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from TextObject.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
Highlight | Gets the collection of conditional highlight attributes. (Inherited from TextObject.)
HorzAlign | Gets or sets the horizontal alignment of a text in the TextObject object. (Inherited from TextObject.)
HorzSpacing | Gets or sets the horizontal spacing between cells, in pixels.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
HtmlTags | This property is not relevant to this class.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from TextObject.)
LineHeight | This property is not relevant to this class.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | This property is not relevant to this class.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
ParagraphOffset | Gets or sets the paragraph offset, in pixels. (Inherited from TextObject.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | This property is not relevant to this class.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
TabWidth | This property is not relevant to this class.
Text | Gets or sets the object's text. (Inherited from TextObjectBase.)
TextColor | Gets or sets the text color in a simple manner. (Inherited from TextObject.)
TextFill | Gets or sets the fill color used to draw a text. (Inherited from TextObject.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from TextObject.)
Trimming | This property is not relevant to this class.
Underlines | This property is not relevant to this class.
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
VertAlign | Gets or sets the vertical alignment of a text in the TextObject object. (Inherited from TextObject.)
VertSpacing | Gets or sets the vertical spacing between cells, in pixels.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TextObject.)
WordWrap | Gets or sets a value that indicates if lines are automatically word-wrapped. (Inherited from TextObject.)
Wysiwyg | This property is not relevant to this class.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CellularTextObject Class
FastReport Namespace


Angle Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.Angle Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

CellularTextObject Class
FastReport Namespace


AutoShrink Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.AutoShrink Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AutoShrinkMode AutoShrink { get; set; }
Visual Basic (Declaration)
Public Property AutoShrink As AutoShrinkMode
Visual C++
public:
property AutoShrinkMode AutoShrink {
    AutoShrinkMode get ();
    void set (AutoShrinkMode value);
}

See Also

CellularTextObject Class
FastReport Namespace


AutoShrinkMinSize Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.AutoShrinkMinSize Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float AutoShrinkMinSize { get; set; }
Visual Basic (Declaration)
Public Property AutoShrinkMinSize As Single
Visual C++
public:
property float AutoShrinkMinSize {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


AutoWidth Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.AutoWidth Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoWidth As Boolean
Visual C++
public:
property bool AutoWidth {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


BreakTo Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.BreakTo Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BreakableComponent BreakTo { get; set; }
Visual Basic (Declaration)
Public Property BreakTo As BreakableComponent
Visual C++
public:
property BreakableComponent^ BreakTo {
    BreakableComponent^ get ();
    void set (BreakableComponent^ value);
}

See Also

CellularTextObject Class
FastReport Namespace


CanBreak Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.CanBreak Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanBreak { get; set; }
Visual Basic (Declaration)
Public Property CanBreak As Boolean
Visual C++
public:
property bool CanBreak {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


CellHeight Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.CellHeight Property
CellularTextObject Class See Also Send Feedback
Gets or sets the height of cell, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CellHeight { get; set; }
Visual Basic (Declaration)
Public Property CellHeight As Single
Visual C++
public:
property float CellHeight {
    float get ();
    void set (float value);
}

Remarks

If zero width and/or height specified, the object will calculate the cell size automatically based on its font.

See Also

CellularTextObject Class
FastReport Namespace


CellWidth Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.CellWidth Property
CellularTextObject Class See Also Send Feedback
Gets or sets the width of cell, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CellWidth { get; set; }
Visual Basic (Declaration)
Public Property CellWidth As Single
Visual C++
public:
property float CellWidth {
    float get ();
    void set (float value);
}

Remarks

If zero width and/or height specified, the object will calculate the cell size automatically based on its font.

See Also

CellularTextObject Class
FastReport Namespace


Clip Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.Clip Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Clip { get; set; }
Visual Basic (Declaration)
Public Property Clip As Boolean
Visual C++
public:
property bool Clip {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


FirstTabOffset Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.FirstTabOffset Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float FirstTabOffset { get; set; }
Visual Basic (Declaration)
Public Property FirstTabOffset As Single
Visual C++
public:
property float FirstTabOffset {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


FontWidthRatio Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.FontWidthRatio Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float FontWidthRatio { get; set; }
Visual Basic (Declaration)
Public Property FontWidthRatio As Single
Visual C++
public:
property float FontWidthRatio {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


ForceJustify Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.ForceJustify Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ForceJustify { get; set; }
Visual Basic (Declaration)
Public Property ForceJustify As Boolean
Visual C++
public:
property bool ForceJustify {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


HorzSpacing Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.HorzSpacing Property
CellularTextObject Class See Also Send Feedback
Gets or sets the horizontal spacing between cells, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float HorzSpacing { get; set; }
Visual Basic (Declaration)
Public Property HorzSpacing As Single
Visual C++
public:
property float HorzSpacing {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


HtmlTags Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.HtmlTags Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HtmlTags { get; set; }
Visual Basic (Declaration)
Public Property HtmlTags As Boolean
Visual C++
public:
property bool HtmlTags {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


LineHeight Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.LineHeight Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float LineHeight { get; set; }
Visual Basic (Declaration)
Public Property LineHeight As Single
Visual C++
public:
property float LineHeight {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


Padding Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.Padding Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

CellularTextObject Class
FastReport Namespace


RightToLeft Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.RightToLeft Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


TabWidth Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.TabWidth Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float TabWidth { get; set; }
Visual Basic (Declaration)
Public Property TabWidth As Single
Visual C++
public:
property float TabWidth {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


Trimming Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.Trimming Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StringTrimming Trimming { get; set; }
Visual Basic (Declaration)
Public Property Trimming As StringTrimming
Visual C++
public:
property StringTrimming Trimming {
    StringTrimming get ();
    void set (StringTrimming value);
}

See Also

CellularTextObject Class
FastReport Namespace


Underlines Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.Underlines Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Underlines { get; set; }
Visual Basic (Declaration)
Public Property Underlines As Boolean
Visual C++
public:
property bool Underlines {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


VertSpacing Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.VertSpacing Property
CellularTextObject Class See Also Send Feedback
Gets or sets the vertical spacing between cells, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float VertSpacing { get; set; }
Visual Basic (Declaration)
Public Property VertSpacing As Single
Visual C++
public:
property float VertSpacing {
    float get ();
    void set (float value);
}

See Also

CellularTextObject Class
FastReport Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
CellularTextObject..::.Wysiwyg Property
CellularTextObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

See Also

CellularTextObject Class
FastReport Namespace


CellularTextObject Events

[image] [image]

FastReport.Net Class Reference
CellularTextObject Events
CellularTextObject Class See Also Send Feedback

The CellularTextObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

CellularTextObject Class
FastReport Namespace


CheckBoxObject Class

[image]

FastReport.Net Class Reference
CheckBoxObject Class
Members See Also Send Feedback
Represents a check box object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CheckBoxObject : ReportComponentBase
Visual Basic (Declaration)
Public Class CheckBoxObject _
    Inherits ReportComponentBase
Visual C++
public ref class CheckBoxObject : public ReportComponentBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.CheckBoxObject

See Also

CheckBoxObject Members
FastReport Namespace


CheckBoxObject Members

[image] [image]

FastReport.Net Class Reference
CheckBoxObject Members
CheckBoxObject Class Constructors Methods Properties Events See Also Send Feedback

The CheckBoxObject type exposes the following members.

Constructors

Name | Description
CheckBoxObject | Initializes a new instance of the CheckBoxObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
CheckColor | Gets or sets a color of the check symbol.
Checked | Gets or set a value indicating whether the check box is in the checked state.
CheckedSymbol | Gets or sets a symbol that will be displayed when the check box is in the checked state.
CheckWidthRatio | Gets or sets the check symbol width ratio.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a data column name bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Expression | Gets or sets an expression that determines whether to show a check.
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideIfUnchecked | Gets or sets a value determines whether to hide the checkbox if it is in the unchecked state.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
UncheckedSymbol | Gets or sets a symbol that will be displayed when the check box is in the unchecked state.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

CheckBoxObject Class
FastReport Namespace


CheckBoxObject Constructor

[image]

FastReport.Net Class Reference
CheckBoxObject Constructor
CheckBoxObject Class See Also Send Feedback
Initializes a new instance of the CheckBoxObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckBoxObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CheckBoxObject()

See Also

CheckBoxObject Class
FastReport Namespace


CheckBoxObject Methods

[image] [image]

FastReport.Net Class Reference
CheckBoxObject Methods
CheckBoxObject Class See Also Send Feedback

The CheckBoxObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CheckBoxObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.Assign Method
CheckBoxObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

CheckBoxObject Class
FastReport Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
CheckBoxObject..::.Dispose Method
CheckBoxObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

CheckBoxObject Class
CheckBoxObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.Draw Method
CheckBoxObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

CheckBoxObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
CheckBoxObject..::.DrawMarkers Method
CheckBoxObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

CheckBoxObject Class
CheckBoxObject Members
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.GetData Method
CheckBoxObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

CheckBoxObject Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.GetExpressions Method
CheckBoxObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

CheckBoxObject Class
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.GetPreferredSize Method
CheckBoxObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

CheckBoxObject Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.GetSmartTag Method
CheckBoxObject Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

CheckBoxObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CheckBoxObject..::.MemberwiseClone Method
CheckBoxObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CheckBoxObject Class
CheckBoxObject Members
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CheckBoxObject..::.Serialize Method
CheckBoxObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

CheckBoxObject Class
FastReport Namespace


CheckBoxObject Properties

[image] [image]

FastReport.Net Class Reference
CheckBoxObject Properties
CheckBoxObject Class See Also Send Feedback

The CheckBoxObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
CheckColor | Gets or sets a color of the check symbol.
Checked | Gets or set a value indicating whether the check box is in the checked state.
CheckedSymbol | Gets or sets a symbol that will be displayed when the check box is in the checked state.
CheckWidthRatio | Gets or sets the check symbol width ratio.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a data column name bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Expression | Gets or sets an expression that determines whether to show a check.
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideIfUnchecked | Gets or sets a value determines whether to hide the checkbox if it is in the unchecked state.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
UncheckedSymbol | Gets or sets a symbol that will be displayed when the check box is in the unchecked state.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CheckBoxObject Class
FastReport Namespace


CheckColor Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.CheckColor Property
CheckBoxObject Class See Also Send Feedback
Gets or sets a color of the check symbol.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color CheckColor { get; set; }
Visual Basic (Declaration)
Public Property CheckColor As Color
Visual C++
public:
property Color CheckColor {
    Color get ();
    void set (Color value);
}

See Also

CheckBoxObject Class
FastReport Namespace


Checked Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.Checked Property
CheckBoxObject Class See Also Send Feedback
Gets or set a value indicating whether the check box is in the checked state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

CheckBoxObject Class
FastReport Namespace


CheckedSymbol Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.CheckedSymbol Property
CheckBoxObject Class See Also Send Feedback
Gets or sets a symbol that will be displayed when the check box is in the checked state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckedSymbol CheckedSymbol { get; set; }
Visual Basic (Declaration)
Public Property CheckedSymbol As CheckedSymbol
Visual C++
public:
property CheckedSymbol CheckedSymbol {
    CheckedSymbol get ();
    void set (CheckedSymbol value);
}

See Also

CheckBoxObject Class
FastReport Namespace


CheckWidthRatio Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.CheckWidthRatio Property
CheckBoxObject Class See Also Send Feedback
Gets or sets the check symbol width ratio.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CheckWidthRatio { get; set; }
Visual Basic (Declaration)
Public Property CheckWidthRatio As Single
Visual C++
public:
property float CheckWidthRatio {
    float get ();
    void set (float value);
}

Remarks

Valid values are from 0.2 to 2.

See Also

CheckBoxObject Class
FastReport Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.DataColumn Property
CheckBoxObject Class See Also Send Feedback
Gets or sets a data column name bound to this control.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

Value must be in the form "[Datasource.Column]".

See Also

CheckBoxObject Class
FastReport Namespace


Expression Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.Expression Property
CheckBoxObject Class See Also Send Feedback
Gets or sets an expression that determines whether to show a check.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

CheckBoxObject Class
FastReport Namespace


HideIfUnchecked Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.HideIfUnchecked Property
CheckBoxObject Class See Also Send Feedback
Gets or sets a value determines whether to hide the checkbox if it is in the unchecked state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideIfUnchecked { get; set; }
Visual Basic (Declaration)
Public Property HideIfUnchecked As Boolean
Visual C++
public:
property bool HideIfUnchecked {
    bool get ();
    void set (bool value);
}

See Also

CheckBoxObject Class
FastReport Namespace


UncheckedSymbol Property

[image]

FastReport.Net Class Reference
CheckBoxObject..::.UncheckedSymbol Property
CheckBoxObject Class See Also Send Feedback
Gets or sets a symbol that will be displayed when the check box is in the unchecked state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UncheckedSymbol UncheckedSymbol { get; set; }
Visual Basic (Declaration)
Public Property UncheckedSymbol As UncheckedSymbol
Visual C++
public:
property UncheckedSymbol UncheckedSymbol {
    UncheckedSymbol get ();
    void set (UncheckedSymbol value);
}

See Also

CheckBoxObject Class
FastReport Namespace


CheckBoxObject Events

[image] [image]

FastReport.Net Class Reference
CheckBoxObject Events
CheckBoxObject Class See Also Send Feedback

The CheckBoxObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

CheckBoxObject Class
FastReport Namespace


CheckedSymbol Enumeration

[image]

FastReport.Net Class Reference
CheckedSymbol Enumeration
See Also Send Feedback
Specifies a symbol that will be displayed when a CheckBoxObject is in the checked state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum CheckedSymbol
Visual Basic (Declaration)
Public Enumeration CheckedSymbol
Visual C++
public enum class CheckedSymbol

Members

Member name | Description
Check | Specifies a check symbol.
Cross | Specifies a diagonal cross symbol.
Plus | Specifies a plus symbol.
Fill | Specifies a filled rectangle.

See Also

FastReport Namespace


ChildBand Class

[image]

FastReport.Net Class Reference
ChildBand Class
Members See Also Send Feedback
This class represents a child band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ChildBand : BandBase
Visual Basic (Declaration)
Public Class ChildBand _
    Inherits BandBase
Visual C++
public ref class ChildBand : public BandBase

Remarks

Typical use of child band is to print several objects that can grow or shrink. It also can be done using the shift feature (via ShiftMode property), but in some cases it's not possible.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.ChildBand

See Also

ChildBand Members
FastReport Namespace


ChildBand Members

[image] [image]

FastReport.Net Class Reference
ChildBand Members
ChildBand Class Constructors Methods Properties Events See Also Send Feedback

The ChildBand type exposes the following members.

Constructors

Name | Description
ChildBand | Initializes a new instance of the ChildBand class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides BandBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides BandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
CompleteToNRows | Gets or sets a value that determines the overall number of data rows printed by the data band.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FillUnusedSpace | Gets or sets a value indicating that band will be used to fill unused space on a page.
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintIfDatabandEmpty | Gets or sets a value indicating that the band will be printed if its parent databand is empty.
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ChildBand Class
FastReport Namespace


ChildBand Constructor

[image]

FastReport.Net Class Reference
ChildBand Constructor
ChildBand Class See Also Send Feedback
Initializes a new instance of the ChildBand class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ChildBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChildBand()

See Also

ChildBand Class
FastReport Namespace


ChildBand Methods

[image] [image]

FastReport.Net Class Reference
ChildBand Methods
ChildBand Class See Also Send Feedback

The ChildBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides BandBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides BandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

ChildBand Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ChildBand..::.Assign Method
ChildBand Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ChildBand Class
FastReport Namespace
AssignAll Method


Delete Method

[image]

FastReport.Net Class Reference
ChildBand..::.Delete Method
ChildBand Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

ChildBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ChildBand..::.Dispose Method
ChildBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ChildBand Class
ChildBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ChildBand..::.DrawMarkers Method
ChildBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ChildBand Class
ChildBand Members
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
ChildBand..::.GetContextMenu Method
ChildBand Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

ChildBand Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ChildBand..::.MemberwiseClone Method
ChildBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChildBand Class
ChildBand Members
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ChildBand..::.Serialize Method
ChildBand Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ChildBand Class
FastReport Namespace


ChildBand Properties

[image] [image]

FastReport.Net Class Reference
ChildBand Properties
ChildBand Class See Also Send Feedback

The ChildBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
CompleteToNRows | Gets or sets a value that determines the overall number of data rows printed by the data band.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FillUnusedSpace | Gets or sets a value indicating that band will be used to fill unused space on a page.
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintIfDatabandEmpty | Gets or sets a value indicating that the band will be printed if its parent databand is empty.
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ChildBand Class
FastReport Namespace


CompleteToNRows Property

[image]

FastReport.Net Class Reference
ChildBand..::.CompleteToNRows Property
ChildBand Class See Also Send Feedback
Gets or sets a value that determines the overall number of data rows printed by the data band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CompleteToNRows { get; set; }
Visual Basic (Declaration)
Public Property CompleteToNRows As Integer
Visual C++
public:
property int CompleteToNRows {
    int get ();
    void set (int value);
}

Remarks

Using this property, you may complete the data band upto N data rows. If the data band has less number of rows, this band will be used to print empty rows.

See Also

ChildBand Class
FastReport Namespace


FillUnusedSpace Property

[image]

FastReport.Net Class Reference
ChildBand..::.FillUnusedSpace Property
ChildBand Class See Also Send Feedback
Gets or sets a value indicating that band will be used to fill unused space on a page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FillUnusedSpace { get; set; }
Visual Basic (Declaration)
Public Property FillUnusedSpace As Boolean
Visual C++
public:
property bool FillUnusedSpace {
    bool get ();
    void set (bool value);
}

Remarks

If you set this property to true, the band will be printed several times to fill unused space on a report page.

See Also

ChildBand Class
FastReport Namespace


PrintIfDatabandEmpty Property

[image]

FastReport.Net Class Reference
ChildBand..::.PrintIfDatabandEmpty Property
ChildBand Class See Also Send Feedback
Gets or sets a value indicating that the band will be printed if its parent databand is empty.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintIfDatabandEmpty { get; set; }
Visual Basic (Declaration)
Public Property PrintIfDatabandEmpty As Boolean
Visual C++
public:
property bool PrintIfDatabandEmpty {
    bool get ();
    void set (bool value);
}

Remarks

The child band with this property set to true, connected to a databand can be used to print "No data" text if the databand has no rows.

See Also

ChildBand Class
FastReport Namespace


ChildBand Events

[image] [image]

FastReport.Net Class Reference
ChildBand Events
ChildBand Class See Also Send Feedback

The ChildBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ChildBand Class
FastReport Namespace


ColumnFooterBand Class

[image]

FastReport.Net Class Reference
ColumnFooterBand Class
Members See Also Send Feedback
This class represents a column footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColumnFooterBand : BandBase
Visual Basic (Declaration)
Public Class ColumnFooterBand _
    Inherits BandBase
Visual C++
public ref class ColumnFooterBand : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.ColumnFooterBand

See Also

ColumnFooterBand Members
FastReport Namespace


ColumnFooterBand Members

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand Members
ColumnFooterBand Class Constructors Methods Properties Events See Also Send Feedback

The ColumnFooterBand type exposes the following members.

Constructors

Name | Description
ColumnFooterBand | Initializes a new instance of the ColumnFooterBand class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ColumnFooterBand Class
FastReport Namespace


ColumnFooterBand Constructor

[image]

FastReport.Net Class Reference
ColumnFooterBand Constructor
ColumnFooterBand Class See Also Send Feedback
Initializes a new instance of the ColumnFooterBand class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnFooterBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnFooterBand()

See Also

ColumnFooterBand Class
FastReport Namespace


ColumnFooterBand Methods

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand Methods
ColumnFooterBand Class See Also Send Feedback

The ColumnFooterBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

ColumnFooterBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand..::.Dispose Method
ColumnFooterBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ColumnFooterBand Class
ColumnFooterBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand..::.DrawMarkers Method
ColumnFooterBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ColumnFooterBand Class
ColumnFooterBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand..::.MemberwiseClone Method
ColumnFooterBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColumnFooterBand Class
ColumnFooterBand Members
FastReport Namespace


ColumnFooterBand Properties

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand Properties
ColumnFooterBand Class See Also Send Feedback

The ColumnFooterBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ColumnFooterBand Class
FastReport Namespace


PrintOnBottom Property

[image]

FastReport.Net Class Reference
ColumnFooterBand..::.PrintOnBottom Property
ColumnFooterBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnBottom { get; set; }
Visual Basic (Declaration)
Public Property PrintOnBottom As Boolean
Visual C++
public:
property bool PrintOnBottom {
    bool get ();
    void set (bool value);
}

See Also

ColumnFooterBand Class
FastReport Namespace


StartNewPage Property

[image]

FastReport.Net Class Reference
ColumnFooterBand..::.StartNewPage Property
ColumnFooterBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartNewPage { get; set; }
Visual Basic (Declaration)
Public Property StartNewPage As Boolean
Visual C++
public:
property bool StartNewPage {
    bool get ();
    void set (bool value);
}

See Also

ColumnFooterBand Class
FastReport Namespace


ColumnFooterBand Events

[image] [image]

FastReport.Net Class Reference
ColumnFooterBand Events
ColumnFooterBand Class See Also Send Feedback

The ColumnFooterBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ColumnFooterBand Class
FastReport Namespace


ColumnHeaderBand Class

[image]

FastReport.Net Class Reference
ColumnHeaderBand Class
Members See Also Send Feedback
This class represents a column header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColumnHeaderBand : BandBase
Visual Basic (Declaration)
Public Class ColumnHeaderBand _
    Inherits BandBase
Visual C++
public ref class ColumnHeaderBand : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.ColumnHeaderBand

See Also

ColumnHeaderBand Members
FastReport Namespace


ColumnHeaderBand Members

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand Members
ColumnHeaderBand Class Constructors Methods Properties Events See Also Send Feedback

The ColumnHeaderBand type exposes the following members.

Constructors

Name | Description
ColumnHeaderBand | Initializes a new instance of the ColumnHeaderBand class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ColumnHeaderBand Class
FastReport Namespace


ColumnHeaderBand Constructor

[image]

FastReport.Net Class Reference
ColumnHeaderBand Constructor
ColumnHeaderBand Class See Also Send Feedback
Initializes a new instance of the ColumnHeaderBand class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnHeaderBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnHeaderBand()

See Also

ColumnHeaderBand Class
FastReport Namespace


ColumnHeaderBand Methods

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand Methods
ColumnHeaderBand Class See Also Send Feedback

The ColumnHeaderBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

ColumnHeaderBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand..::.Dispose Method
ColumnHeaderBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ColumnHeaderBand Class
ColumnHeaderBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand..::.DrawMarkers Method
ColumnHeaderBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ColumnHeaderBand Class
ColumnHeaderBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand..::.MemberwiseClone Method
ColumnHeaderBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColumnHeaderBand Class
ColumnHeaderBand Members
FastReport Namespace


ColumnHeaderBand Properties

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand Properties
ColumnHeaderBand Class See Also Send Feedback

The ColumnHeaderBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ColumnHeaderBand Class
FastReport Namespace


PrintOnBottom Property

[image]

FastReport.Net Class Reference
ColumnHeaderBand..::.PrintOnBottom Property
ColumnHeaderBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnBottom { get; set; }
Visual Basic (Declaration)
Public Property PrintOnBottom As Boolean
Visual C++
public:
property bool PrintOnBottom {
    bool get ();
    void set (bool value);
}

See Also

ColumnHeaderBand Class
FastReport Namespace


StartNewPage Property

[image]

FastReport.Net Class Reference
ColumnHeaderBand..::.StartNewPage Property
ColumnHeaderBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartNewPage { get; set; }
Visual Basic (Declaration)
Public Property StartNewPage As Boolean
Visual C++
public:
property bool StartNewPage {
    bool get ();
    void set (bool value);
}

See Also

ColumnHeaderBand Class
FastReport Namespace


ColumnHeaderBand Events

[image] [image]

FastReport.Net Class Reference
ColumnHeaderBand Events
ColumnHeaderBand Class See Also Send Feedback

The ColumnHeaderBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ColumnHeaderBand Class
FastReport Namespace


ColumnLayout Enumeration

[image]

FastReport.Net Class Reference
ColumnLayout Enumeration
See Also Send Feedback
The layout of the data band columns.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ColumnLayout
Visual Basic (Declaration)
Public Enumeration ColumnLayout
Visual C++
public enum class ColumnLayout

Members

Member name | Description
AcrossThenDown | Print columns across then down.
DownThenAcross | Print columns down then across.

See Also

FastReport Namespace


ComponentBase Class

[image]

FastReport.Net Class Reference
ComponentBase Class
Members See Also Send Feedback
Class that implements some object's properties such as location, size and visibility.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class ComponentBase : Base
Visual Basic (Declaration)
Public MustInherit Class ComponentBase _
    Inherits Base
Visual C++
public ref class ComponentBase abstract : public Base

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport..::.PageBase
FastReport..::.ReportComponentBase
FastReport.Table..::.TableColumn
FastReport.Table..::.TableRow

See Also

ComponentBase Members
FastReport Namespace


ComponentBase Members

[image] [image]

FastReport.Net Class Reference
ComponentBase Members
ComponentBase Class Constructors Methods Properties Events See Also Send Feedback

The ComponentBase type exposes the following members.

Constructors

Name | Description
ComponentBase | Initializes a new instance of the ComponentBase class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative.
CheckParent | Checks if the object is inside its parent.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object.
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation.
DrawSelection | Draw the selection points.
DrawSelectionPoint | Draws the selection point.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides Base..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object.
GetSelectionPoints | Gets the object's selection points.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer.
HandleDragDrop | Handles the DragDrop event in the designer.
HandleDragOver | Handles the DragOver event in the designer.
HandleKeyDown | Handles KeyDown event in the designer.
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer.
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer.
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer.
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer.
HandleMouseWheel | Handles mouse wheel event.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds.
PointInSelectionPoint | Gets a value indicating that given point is inside selection point.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object.
AbsBounds | Gets the absolute bounding rectangle of the object.
AbsLeft | Gets the absolute left coordinate of the object.
AbsRight | Gets the absolute right coordinate of the object.
AbsTop | Gets the absolute top coordinate of the object.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container.
Bounds | Gets or sets the bounding rectangle of the object.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index.
Height | Gets or sets the height of the object.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top | Gets or sets the top coordinate of the object in relation to its container.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window.
Width | Gets or sets the width of the object.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ComponentBase Class
FastReport Namespace


ComponentBase Constructor

[image]

FastReport.Net Class Reference
ComponentBase Constructor
ComponentBase Class See Also Send Feedback
Initializes a new instance of the ComponentBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ComponentBase()

See Also

ComponentBase Class
FastReport Namespace


ComponentBase Methods

[image] [image]

FastReport.Net Class Reference
ComponentBase Methods
ComponentBase Class See Also Send Feedback

The ComponentBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative.
CheckParent | Checks if the object is inside its parent.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object.
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation.
DrawSelection | Draw the selection points.
DrawSelectionPoint | Draws the selection point.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides Base..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object.
GetSelectionPoints | Gets the object's selection points.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer.
HandleDragDrop | Handles the DragDrop event in the designer.
HandleDragOver | Handles the DragOver event in the designer.
HandleKeyDown | Handles KeyDown event in the designer.
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer.
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer.
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer.
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer.
HandleMouseWheel | Handles mouse wheel event.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds.
PointInSelectionPoint | Gets a value indicating that given point is inside selection point.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ComponentBase Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ComponentBase..::.Assign Method
ComponentBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ComponentBase Class
FastReport Namespace
AssignAll Method


CheckNegativeSize Method

[image]

FastReport.Net Class Reference
ComponentBase..::.CheckNegativeSize Method
ComponentBase Class See Also Send Feedback
Corrects the object's size and sizing point if the size becomes negative.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void CheckNegativeSize(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub CheckNegativeSize ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void CheckNegativeSize(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

See Also

ComponentBase Class
FastReport Namespace


CheckParent Method

[image]

FastReport.Net Class Reference
ComponentBase..::.CheckParent Method
ComponentBase Class See Also Send Feedback
Checks if the object is inside its parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void CheckParent(
    bool immediately
)
Visual Basic (Declaration)
Public Overridable Sub CheckParent ( _
    immediately As Boolean _
)
Visual C++
public:
virtual void CheckParent(
    bool immediately
)

Parameters

immediately
Type: System..::.Boolean
if true, check now independent of any conditions.

Remarks

Typically you don't need to use or override this method.

When you move an object with the mouse, it may be moved outside its parent. If so, this method must find a new parent for the object and correct it's Left, Top and Parent properties. If immediately parameter is false, you can optimize the method to search for new parent only if the object's bounds are outside parent. If this parameter is true, you must skip any optimizations and search for a parent immediately.

See Also

ComponentBase Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ComponentBase..::.Dispose Method
ComponentBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ComponentBase Class
ComponentBase Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
ComponentBase..::.Draw Method
ComponentBase Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

ComponentBase Class
FastReport Namespace


DrawDragAcceptFrame Method

[image]

FastReport.Net Class Reference
ComponentBase..::.DrawDragAcceptFrame Method
ComponentBase Class See Also Send Feedback
Draw the frame around the object to indicate that it accepts the drag&drop operation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void DrawDragAcceptFrame(
    FRPaintEventArgs e,
    Color color
)
Visual Basic (Declaration)
Public Overridable Sub DrawDragAcceptFrame ( _
    e As FRPaintEventArgs, _
    color As Color _
)
Visual C++
public:
virtual void DrawDragAcceptFrame(
    FRPaintEventArgs^ e,
    Color color
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.
color
Type: System.Drawing..::.Color
The color of frame.

See Also

ComponentBase Class
FastReport Namespace


DrawSelection Method

[image]

FastReport.Net Class Reference
ComponentBase..::.DrawSelection Method
ComponentBase Class See Also Send Feedback
Draw the selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void DrawSelection(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub DrawSelection ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawSelection(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method draws a set of selection points returned by the GetSelectionPoints()()() method.

See Also

ComponentBase Class
FastReport Namespace


DrawSelectionPoint Method

[image]

FastReport.Net Class Reference
ComponentBase..::.DrawSelectionPoint Method
ComponentBase Class See Also Send Feedback
Draws the selection point.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void DrawSelectionPoint(
    FRPaintEventArgs e,
    Pen p,
    Brush b,
    float x,
    float y
)
Visual Basic (Declaration)
Protected Sub DrawSelectionPoint ( _
    e As FRPaintEventArgs, _
    p As Pen, _
    b As Brush, _
    x As Single, _
    y As Single _
)
Visual C++
protected:
void DrawSelectionPoint(
    FRPaintEventArgs^ e,
    Pen^ p,
    Brush^ b,
    float x,
    float y
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.
p
Type: System.Drawing..::.Pen
Pen object.
b
Type: System.Drawing..::.Brush
Brush object.
x
Type: System..::.Single
Left coordinate.
y
Type: System..::.Single
Top coordinate.

See Also

ComponentBase Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
ComponentBase..::.GetContextMenu Method
ComponentBase Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

ComponentBase Class
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
ComponentBase..::.GetPreferredSize Method
ComponentBase Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overridable Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize()

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

ComponentBase Class
FastReport Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
ComponentBase..::.GetSelectionPoints Method
ComponentBase Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overridable Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints()

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

ComponentBase Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
ComponentBase..::.GetSmartTag Method
ComponentBase Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overridable Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag()

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

ComponentBase Class
FastReport Namespace


HandleDoubleClick Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleDoubleClick Method
ComponentBase Class See Also Send Feedback
Handles double click event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleDoubleClick()
Visual Basic (Declaration)
Public Overridable Sub HandleDoubleClick
Visual C++
public:
virtual void HandleDoubleClick()

Remarks

This method is called when the user doubleclicks the object in the designer. Typical implementation invokes the object's editor (calls the InvokeEditor method) and sets the designer's Modified flag.

See Also

ComponentBase Class
FastReport Namespace


HandleDragDrop Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleDragDrop Method
ComponentBase Class See Also Send Feedback
Handles the DragDrop event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleDragDrop(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleDragDrop ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragDrop(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drops an item from the Data Tree window into this object. This method should copy the information from the e.DraggedObject object and set the e.Handled flag to true to complete the drag operation.

See Also

ComponentBase Class
FastReport Namespace


HandleDragOver Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleDragOver Method
ComponentBase Class See Also Send Feedback
Handles the DragOver event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleDragOver(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleDragOver ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragOver(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drags an item from the Data Tree window. This method should check that the mouse (e.X, e.Y) is inside the object, then set the e.Handled flag to true if an item can be dragged into this object.

See Also

ComponentBase Class
FastReport Namespace


HandleKeyDown Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleKeyDown Method
ComponentBase Class See Also Send Feedback
Handles KeyDown event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleKeyDown(
    Control sender,
    KeyEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleKeyDown ( _
    sender As Control, _
    e As KeyEventArgs _
)
Visual C++
public:
virtual void HandleKeyDown(
    Control^ sender,
    KeyEventArgs^ e
)

Parameters

sender
Type: System.Windows.Forms..::.Control
The designer's workspace.
e
Type: System.Windows.Forms..::.KeyEventArgs
Keyboard event parameters.

Remarks

This method is called when the user presses any key in the designer. Typical implementation does nothing.

See Also

ComponentBase Class
FastReport Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleMouseDown Method
ComponentBase Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

ComponentBase Class
FastReport Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleMouseHover Method
ComponentBase Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

ComponentBase Class
FastReport Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleMouseMove Method
ComponentBase Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

ComponentBase Class
FastReport Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleMouseUp Method
ComponentBase Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

ComponentBase Class
FastReport Namespace


HandleMouseWheel Method

[image]

FastReport.Net Class Reference
ComponentBase..::.HandleMouseWheel Method
ComponentBase Class See Also Send Feedback
Handles mouse wheel event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void HandleMouseWheel(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub HandleMouseWheel ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseWheel(
    FRMouseEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

See Also

ComponentBase Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ComponentBase..::.MemberwiseClone Method
ComponentBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ComponentBase Class
ComponentBase Members
FastReport Namespace


PointInObject Method

[image]

FastReport.Net Class Reference
ComponentBase..::.PointInObject Method
ComponentBase Class See Also Send Feedback
Checks if given point is inside the object's bounds.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool PointInObject(
    PointF point
)
Visual Basic (Declaration)
Public Overridable Function PointInObject ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool PointInObject(
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF
point to check.

Return Value

true if point is inside the object's bounds.

Remarks

You can override this method if your objectis not of rectangular form.

See Also

ComponentBase Class
FastReport Namespace


PointInSelectionPoint Method

[image]

FastReport.Net Class Reference
ComponentBase..::.PointInSelectionPoint Method
ComponentBase Class See Also Send Feedback
Gets a value indicating that given point is inside selection point.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected bool PointInSelectionPoint(
    float x,
    float y,
    PointF point
)
Visual Basic (Declaration)
Protected Function PointInSelectionPoint ( _
    x As Single, _
    y As Single, _
    point As PointF _
) As Boolean
Visual C++
protected:
bool PointInSelectionPoint(
    float x,
    float y,
    PointF point
)

Parameters

x
Type: System..::.Single
point's x coordinate.
y
Type: System..::.Single
point's y coordinate.
point
Type: System.Drawing..::.PointF
selection point.

Return Value

true if (x,y) is inside the point

See Also

ComponentBase Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ComponentBase..::.Serialize Method
ComponentBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ComponentBase Class
FastReport Namespace


ComponentBase Properties

[image] [image]

FastReport.Net Class Reference
ComponentBase Properties
ComponentBase Class See Also Send Feedback

The ComponentBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object.
AbsBounds | Gets the absolute bounding rectangle of the object.
AbsLeft | Gets the absolute left coordinate of the object.
AbsRight | Gets the absolute right coordinate of the object.
AbsTop | Gets the absolute top coordinate of the object.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container.
Bounds | Gets or sets the bounding rectangle of the object.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index.
Height | Gets or sets the height of the object.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top | Gets or sets the top coordinate of the object in relation to its container.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window.
Width | Gets or sets the width of the object.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ComponentBase Class
FastReport Namespace


AbsBottom Property

[image]

FastReport.Net Class Reference
ComponentBase..::.AbsBottom Property
ComponentBase Class See Also Send Feedback
Gets the absolute bottom coordinate of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float AbsBottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property AbsBottom As Single
Visual C++
public:
property float AbsBottom {
    float get ();
}

See Also

ComponentBase Class
FastReport Namespace


AbsBounds Property

[image]

FastReport.Net Class Reference
ComponentBase..::.AbsBounds Property
ComponentBase Class See Also Send Feedback
Gets the absolute bounding rectangle of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RectangleF AbsBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property AbsBounds As RectangleF
Visual C++
public:
property RectangleF AbsBounds {
    RectangleF get ();
}

See Also

ComponentBase Class
FastReport Namespace


AbsLeft Property

[image]

FastReport.Net Class Reference
ComponentBase..::.AbsLeft Property
ComponentBase Class See Also Send Feedback
Gets the absolute left coordinate of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float AbsLeft { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property AbsLeft As Single
Visual C++
public:
virtual property float AbsLeft {
    float get ();
}

See Also

ComponentBase Class
FastReport Namespace


AbsRight Property

[image]

FastReport.Net Class Reference
ComponentBase..::.AbsRight Property
ComponentBase Class See Also Send Feedback
Gets the absolute right coordinate of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float AbsRight { get; }
Visual Basic (Declaration)
Public ReadOnly Property AbsRight As Single
Visual C++
public:
property float AbsRight {
    float get ();
}

See Also

ComponentBase Class
FastReport Namespace


AbsTop Property

[image]

FastReport.Net Class Reference
ComponentBase..::.AbsTop Property
ComponentBase Class See Also Send Feedback
Gets the absolute top coordinate of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float AbsTop { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property AbsTop As Single
Visual C++
public:
virtual property float AbsTop {
    float get ();
}

See Also

ComponentBase Class
FastReport Namespace


Anchor Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Anchor Property
ComponentBase Class See Also Send Feedback
Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get ();
    void set (AnchorStyles value);
}

Remarks

Use the Anchor property to define how a control is automatically resized as its parent control is resized. Anchoring a control to its parent control ensures that the anchored edges remain in the same position relative to the edges of the parent control when the parent control is resized.

You can anchor a control to one or more edges of its container. For example, if you have a band with a TextObject whose Anchor property value is set to Top, Bottom, the TextObject is stretched to maintain the anchored distance to the top and bottom edges of the band as the height of the band is increased.

See Also

ComponentBase Class
FastReport Namespace


Bottom Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Bottom Property
ComponentBase Class See Also Send Feedback
Gets the bottom coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Bottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bottom As Single
Visual C++
public:
property float Bottom {
    float get ();
}

Remarks

To change the bottom coordinate, change the Top and/or Height properties.

See Also

ComponentBase Class
FastReport Namespace


Bounds Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Bounds Property
ComponentBase Class See Also Send Feedback
Gets or sets the bounding rectangle of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RectangleF Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As RectangleF
Visual C++
public:
property RectangleF Bounds {
    RectangleF get ();
    void set (RectangleF value);
}

Remarks

Assigning a value to this property is equal to assigning values to the Left, Top, Width, Height properties.

See Also

ComponentBase Class
FastReport Namespace


ClientSize Property

[image]

FastReport.Net Class Reference
ComponentBase..::.ClientSize Property
ComponentBase Class See Also Send Feedback
Gets or sets the size of client area of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual SizeF ClientSize { get; set; }
Visual Basic (Declaration)
Public Overridable Property ClientSize As SizeF
Visual C++
public:
virtual property SizeF ClientSize {
    SizeF get ();
    void set (SizeF value);
}

Remarks

This property is used in the DialogPage class.

See Also

ComponentBase Class
FastReport Namespace


Dock Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Dock Property
ComponentBase Class See Also Send Feedback
Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get ();
    void set (DockStyle value);
}

Remarks

Use the Dock property to define how a control is automatically resized as its parent control is resized. For example, setting Dock to DockStyle.Left causes the control to align itself with the left edges of its parent control and to resize as the parent control is resized.

A control can be docked to one edge of its parent container or can be docked to all edges and fill the parent container.

See Also

ComponentBase Class
FastReport Namespace


GroupIndex Property

[image]

FastReport.Net Class Reference
ComponentBase..::.GroupIndex Property
ComponentBase Class See Also Send Feedback
Gets or sets a group index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GroupIndex { get; set; }
Visual Basic (Declaration)
Public Property GroupIndex As Integer
Visual C++
public:
property int GroupIndex {
    int get ();
    void set (int value);
}

Remarks

Group index is used to group objects in the designer (using "Group" button). When you select any object in a group, entire group becomes selected. To reset a group, set the GroupIndex to 0 (default value).

See Also

ComponentBase Class
FastReport Namespace


Height Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Height Property
ComponentBase Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Single
Visual C++
public:
virtual property float Height {
    float get ();
    void set (float value);
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

ComponentBase Class
FastReport Namespace


Left Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Left Property
ComponentBase Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float Left { get; set; }
Visual Basic (Declaration)
Public Overridable Property Left As Single
Visual C++
public:
virtual property float Left {
    float get ();
    void set (float value);
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

ComponentBase Class
FastReport Namespace


Right Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Right Property
ComponentBase Class See Also Send Feedback
Gets the right coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Right { get; }
Visual Basic (Declaration)
Public ReadOnly Property Right As Single
Visual C++
public:
property float Right {
    float get ();
}

Remarks

To change the right coordinate, change the Left and/or Width properties.

See Also

ComponentBase Class
FastReport Namespace


Top Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Top Property
ComponentBase Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float Top { get; set; }
Visual Basic (Declaration)
Public Overridable Property Top As Single
Visual C++
public:
virtual property float Top {
    float get ();
    void set (float value);
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

ComponentBase Class
FastReport Namespace


Visible Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Visible Property
ComponentBase Class Example See Also Send Feedback
Gets or sets a value indicating whether the object is displayed in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool Visible { get; set; }
Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

Setting this property to false will hide the object in the preview window.

Examples

The following report script will control the Text1 visibility depending on the value of the data column:
CopyC#
private void Data1_BeforePrint(object sender, EventArgs e)
{
  Text1.Visible = [Orders.Shipped] == true;
}

See Also

ComponentBase Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
ComponentBase..::.Width Property
ComponentBase Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Single
Visual C++
public:
virtual property float Width {
    float get ();
    void set (float value);
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

ComponentBase Class
FastReport Namespace


ComponentBase Events

[image] [image]

FastReport.Net Class Reference
ComponentBase Events
ComponentBase Class See Also Send Feedback

The ComponentBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ComponentBase Class
FastReport Namespace


ComponentMenuBase Class

[image]

FastReport.Net Class Reference
ComponentMenuBase Class
Members See Also Send Feedback
The base class for the context menu of the report component.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ComponentMenuBase : ContextMenuBar
Visual Basic (Declaration)
Public Class ComponentMenuBase _
    Inherits ContextMenuBar
Visual C++
public ref class ComponentMenuBase : public ContextMenuBar

Remarks

This class represents a context menu of the report component that is displayed when the object is right-clicked in the designer. This class implements the following actions: Edit, Cut, Copy, Paste, Delete, Bring to Front, Send to Back.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
ContextMenuBar
FastReport..::.ComponentMenuBase
FastReport..::.ReportComponentBaseMenu

See Also

ComponentMenuBase Members
FastReport Namespace


ComponentMenuBase Members

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase Members
ComponentMenuBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The ComponentMenuBase type exposes the following members.

Constructors

Name | Description
ComponentMenuBase | Initializes a new instance of the ComponentMenuBase class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer.
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miBringToFront | The "BringToFront" menu item.
miCopy | The "Copy" menu item.
miCut | The "Cut" menu item.
miDelete | The "Delete" menu item.
miEdit | The "Edit" menu item.
miName | The "Name" menu item.
miPaste | The "Paste" menu item.
miSendToBack | The "SendToBack" menu item.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items.
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ComponentMenuBase Class
FastReport Namespace


ComponentMenuBase Constructor

[image]

FastReport.Net Class Reference
ComponentMenuBase Constructor
ComponentMenuBase Class See Also Send Feedback
Initializes a new instance of the ComponentMenuBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentMenuBase(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ComponentMenuBase(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The reference to a report designer.

See Also

ComponentMenuBase Class
FastReport Namespace


ComponentMenuBase Fields

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase Fields
ComponentMenuBase Class See Also Send Feedback

The ComponentMenuBase type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miBringToFront | The "BringToFront" menu item.
miCopy | The "Copy" menu item.
miCut | The "Cut" menu item.
miDelete | The "Delete" menu item.
miEdit | The "Edit" menu item.
miName | The "Name" menu item.
miPaste | The "Paste" menu item.
miSendToBack | The "SendToBack" menu item.

See Also

ComponentMenuBase Class
FastReport Namespace


miBringToFront Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miBringToFront Field
ComponentMenuBase Class See Also Send Feedback
The "BringToFront" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miBringToFront
Visual Basic (Declaration)
Public miBringToFront As ButtonItem
Visual C++
public:
ButtonItem^ miBringToFront

See Also

ComponentMenuBase Class
FastReport Namespace


miCopy Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miCopy Field
ComponentMenuBase Class See Also Send Feedback
The "Copy" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miCopy
Visual Basic (Declaration)
Public miCopy As ButtonItem
Visual C++
public:
ButtonItem^ miCopy

See Also

ComponentMenuBase Class
FastReport Namespace


miCut Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miCut Field
ComponentMenuBase Class See Also Send Feedback
The "Cut" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miCut
Visual Basic (Declaration)
Public miCut As ButtonItem
Visual C++
public:
ButtonItem^ miCut

See Also

ComponentMenuBase Class
FastReport Namespace


miDelete Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miDelete Field
ComponentMenuBase Class See Also Send Feedback
The "Delete" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miDelete
Visual Basic (Declaration)
Public miDelete As ButtonItem
Visual C++
public:
ButtonItem^ miDelete

See Also

ComponentMenuBase Class
FastReport Namespace


miEdit Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miEdit Field
ComponentMenuBase Class See Also Send Feedback
The "Edit" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEdit
Visual Basic (Declaration)
Public miEdit As ButtonItem
Visual C++
public:
ButtonItem^ miEdit

See Also

ComponentMenuBase Class
FastReport Namespace


miName Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miName Field
ComponentMenuBase Class See Also Send Feedback
The "Name" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miName
Visual Basic (Declaration)
Public miName As ButtonItem
Visual C++
public:
ButtonItem^ miName

See Also

ComponentMenuBase Class
FastReport Namespace


miPaste Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miPaste Field
ComponentMenuBase Class See Also Send Feedback
The "Paste" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miPaste
Visual Basic (Declaration)
Public miPaste As ButtonItem
Visual C++
public:
ButtonItem^ miPaste

See Also

ComponentMenuBase Class
FastReport Namespace


miSendToBack Field

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.miSendToBack Field
ComponentMenuBase Class See Also Send Feedback
The "SendToBack" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miSendToBack
Visual Basic (Declaration)
Public miSendToBack As ButtonItem
Visual C++
public:
ButtonItem^ miSendToBack

See Also

ComponentMenuBase Class
FastReport Namespace


ComponentMenuBase Methods

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase Methods
ComponentMenuBase Class See Also Send Feedback

The ComponentMenuBase type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer.
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

ComponentMenuBase Class
FastReport Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.AccessibilityNotifyClients Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.BeginInvoke Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


Change Method

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.Change Method
ComponentMenuBase Class See Also Send Feedback
This method is called to reflect changes in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void Change()
Visual Basic (Declaration)
Protected Sub Change
Visual C++
protected:
void Change()

See Also

ComponentMenuBase Class
FastReport Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.CloseDockTab Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


CreateMenuItem Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.CreateMenuItem Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
CreateMenuItem(String) | Creates a new menu item.
CreateMenuItem(String, EventHandler) | Creates a new menu item.
CreateMenuItem(Image, String, EventHandler) | Creates a new menu item.

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


CreateMenuItem Method (String)

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.CreateMenuItem Method (String)
ComponentMenuBase Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ButtonItem CreateMenuItem(
    string text
)
Visual Basic (Declaration)
Protected Function CreateMenuItem ( _
    text As String _
) As ButtonItem
Visual C++
protected:
ButtonItem^ CreateMenuItem(
    String^ text
)

Parameters

text
Type: System..::.String
Item's text.

Return Value

New item.

See Also

ComponentMenuBase Class
CreateMenuItem Overload
FastReport Namespace


CreateMenuItem Method (String, EventHandler)

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.CreateMenuItem Method (String, EventHandler)
ComponentMenuBase Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ButtonItem CreateMenuItem(
    string text,
    EventHandler click
)
Visual Basic (Declaration)
Protected Function CreateMenuItem ( _
    text As String, _
    click As EventHandler _
) As ButtonItem
Visual C++
protected:
ButtonItem^ CreateMenuItem(
    String^ text,
    EventHandler^ click
)

Parameters

text
Type: System..::.String
Item's text.
click
Type: System..::.EventHandler
Click handler.

Return Value

New item.

See Also

ComponentMenuBase Class
CreateMenuItem Overload
FastReport Namespace


CreateMenuItem Method (Image, String, EventHandler)

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.CreateMenuItem Method (Image, String, EventHandler)
ComponentMenuBase Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ButtonItem CreateMenuItem(
    Image image,
    string text,
    EventHandler click
)
Visual Basic (Declaration)
Protected Function CreateMenuItem ( _
    image As Image, _
    text As String, _
    click As EventHandler _
) As ButtonItem
Visual C++
protected:
ButtonItem^ CreateMenuItem(
    Image^ image,
    String^ text,
    EventHandler^ click
)

Parameters

image
Type: System.Drawing..::.Image
Item's image.
text
Type: System..::.String
Item's text.
click
Type: System..::.EventHandler
Click handler.

Return Value

New item.

See Also

ComponentMenuBase Class
CreateMenuItem Overload
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.Dispose Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.GetChildAtPoint Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.GetItems Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.Invalidate Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.Invoke Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.MemberwiseClone Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.PerformLayout Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.ResumeLayout Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.RtlTranslateAlignment Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.Scale Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.Select Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.SetBounds Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.SetSize Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase..::.UpdateBounds Method
ComponentMenuBase Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ComponentMenuBase Class
ComponentMenuBase Members
FastReport Namespace


ComponentMenuBase Properties

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase Properties
ComponentMenuBase Class See Also Send Feedback

The ComponentMenuBase type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items.
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

ComponentMenuBase Class
FastReport Namespace


Designer Property

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.Designer Property
ComponentMenuBase Class See Also Send Feedback
The reference to the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
}

See Also

ComponentMenuBase Class
FastReport Namespace


Items Property

[image]

FastReport.Net Class Reference
ComponentMenuBase..::.Items Property
ComponentMenuBase Class See Also Send Feedback
Gets a collection of menu items.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SubItemsCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As SubItemsCollection
Visual C++
public:
property SubItemsCollection^ Items {
    SubItemsCollection^ get ();
}

Remarks

You should add new items to this collection.

See Also

ComponentMenuBase Class
FastReport Namespace


ComponentMenuBase Events

[image] [image]

FastReport.Net Class Reference
ComponentMenuBase Events
ComponentMenuBase Class See Also Send Feedback

The ComponentMenuBase type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ComponentMenuBase Class
FastReport Namespace


ConditionCollection Class

[image]

FastReport.Net Class Reference
ConditionCollection Class
Members See Also Send Feedback
Represents a collection of highlight conditions used in the Highlight property of the TextObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ConditionCollection : CollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class ConditionCollection _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class ConditionCollection : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport..::.ConditionCollection

See Also

ConditionCollection Members
FastReport Namespace


ConditionCollection Members

[image] [image]

FastReport.Net Class Reference
ConditionCollection Members
ConditionCollection Class Constructors Methods Properties See Also Send Feedback

The ConditionCollection type exposes the following members.

Constructors

Name | Description
ConditionCollection | Initializes a new instance of the ConditionCollection class

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Assign | Copies conditions from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ConditionCollection Class
FastReport Namespace


ConditionCollection Constructor

[image]

FastReport.Net Class Reference
ConditionCollection Constructor
ConditionCollection Class See Also Send Feedback
Initializes a new instance of the ConditionCollection class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ConditionCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConditionCollection()

See Also

ConditionCollection Class
FastReport Namespace


ConditionCollection Methods

[image] [image]

FastReport.Net Class Reference
ConditionCollection Methods
ConditionCollection Class See Also Send Feedback

The ConditionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Assign | Copies conditions from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConditionCollection Class
FastReport Namespace


Add Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Add Method
ConditionCollection Class See Also Send Feedback
Adds an object to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    HighlightCondition value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As HighlightCondition _
) As Integer
Visual C++
public:
int Add(
    HighlightCondition^ value
)

Parameters

value
Type: FastReport..::.HighlightCondition
Object to add.

Return Value

Index of the added object.

See Also

ConditionCollection Class
FastReport Namespace


AddRange Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.AddRange Method
ConditionCollection Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    HighlightCondition[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As HighlightCondition() _
)
Visual C++
public:
void AddRange(
    array<HighlightCondition^>^ range
)

Parameters

range
Type: array< FastReport..::.HighlightCondition >[]()[]
Array of elements to add.

See Also

ConditionCollection Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Assign Method
ConditionCollection Class See Also Send Feedback
Copies conditions from another collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    ConditionCollection collection
)
Visual Basic (Declaration)
Public Sub Assign ( _
    collection As ConditionCollection _
)
Visual C++
public:
void Assign(
    ConditionCollection^ collection
)

Parameters

collection
Type: FastReport..::.ConditionCollection
Collection to copy from.

See Also

ConditionCollection Class
FastReport Namespace


Contains Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Contains Method
ConditionCollection Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    HighlightCondition value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As HighlightCondition _
) As Boolean
Visual C++
public:
bool Contains(
    HighlightCondition^ value
)

Parameters

value
Type: FastReport..::.HighlightCondition
The object to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

ConditionCollection Class
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Deserialize Method
ConditionCollection Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

ConditionCollection Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Equals Method
ConditionCollection Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

ConditionCollection Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.GetHashCode Method
ConditionCollection Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

ConditionCollection Class
FastReport Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.IndexOf Method
ConditionCollection Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    HighlightCondition value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As HighlightCondition _
) As Integer
Visual C++
public:
int IndexOf(
    HighlightCondition^ value
)

Parameters

value
Type: FastReport..::.HighlightCondition
The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

ConditionCollection Class
FastReport Namespace


Insert Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Insert Method
ConditionCollection Class See Also Send Feedback
Inserts an object into this collection at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    HighlightCondition value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As HighlightCondition _
)
Visual C++
public:
void Insert(
    int index,
    HighlightCondition^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport..::.HighlightCondition
The object to insert.

See Also

ConditionCollection Class
FastReport Namespace


Remove Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Remove Method
ConditionCollection Class See Also Send Feedback
Removes the specified object from the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    HighlightCondition value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As HighlightCondition _
)
Visual C++
public:
void Remove(
    HighlightCondition^ value
)

Parameters

value
Type: FastReport..::.HighlightCondition
Object to remove.

See Also

ConditionCollection Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ConditionCollection..::.Serialize Method
ConditionCollection Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

ConditionCollection Class
FastReport Namespace


ConditionCollection Properties

[image] [image]

FastReport.Net Class Reference
ConditionCollection Properties
ConditionCollection Class See Also Send Feedback

The ConditionCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ConditionCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
ConditionCollection..::.Item Property
ConditionCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HighlightCondition this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As HighlightCondition
Visual C++
public:
property HighlightCondition^ default[int index] {
    HighlightCondition^ get (int index);
    void set (int index, HighlightCondition^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

ConditionCollection Class
FastReport Namespace


CustomLoadEventArgs Class

[image]

FastReport.Net Class Reference
CustomLoadEventArgs Class
Members See Also Send Feedback
Provides data for the LoadBaseReport event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CustomLoadEventArgs : EventArgs
Visual Basic (Declaration)
Public Class CustomLoadEventArgs _
    Inherits EventArgs
Visual C++
public ref class CustomLoadEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
FastReport..::.CustomLoadEventArgs

See Also

CustomLoadEventArgs Members
FastReport Namespace


CustomLoadEventArgs Members

[image] [image]

FastReport.Net Class Reference
CustomLoadEventArgs Members
CustomLoadEventArgs Class Constructors Methods Properties See Also Send Feedback

The CustomLoadEventArgs type exposes the following members.

Constructors

Name | Description
CustomLoadEventArgs | Initializes a new instance of the CustomLoadEventArgs class using the specified file name and the report.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FileName | Gets a name of the file to load the report from.
Report | The reference to a report.

See Also

CustomLoadEventArgs Class
FastReport Namespace


CustomLoadEventArgs Constructor

[image]

FastReport.Net Class Reference
CustomLoadEventArgs Constructor
CustomLoadEventArgs Class See Also Send Feedback
Initializes a new instance of the CustomLoadEventArgs class using the specified file name and the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CustomLoadEventArgs(
    string fileName,
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    report As Report _
)
Visual C++
public:
CustomLoadEventArgs(
    String^ fileName,
    Report^ report
)

Parameters

fileName
Type: System..::.String
The name of the file to load the report from.
report
Type: FastReport..::.Report
The report.

See Also

CustomLoadEventArgs Class
FastReport Namespace


CustomLoadEventArgs Methods

[image] [image]

FastReport.Net Class Reference
CustomLoadEventArgs Methods
CustomLoadEventArgs Class See Also Send Feedback

The CustomLoadEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLoadEventArgs Class
FastReport Namespace


CustomLoadEventArgs Properties

[image] [image]

FastReport.Net Class Reference
CustomLoadEventArgs Properties
CustomLoadEventArgs Class See Also Send Feedback

The CustomLoadEventArgs type exposes the following members.

Properties

Name | Description
FileName | Gets a name of the file to load the report from.
Report | The reference to a report.

See Also

CustomLoadEventArgs Class
FastReport Namespace


FileName Property

[image]

FastReport.Net Class Reference
CustomLoadEventArgs..::.FileName Property
CustomLoadEventArgs Class See Also Send Feedback
Gets a name of the file to load the report from.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

CustomLoadEventArgs Class
FastReport Namespace


Report Property

[image]

FastReport.Net Class Reference
CustomLoadEventArgs..::.Report Property
CustomLoadEventArgs Class See Also Send Feedback
The reference to a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
}

See Also

CustomLoadEventArgs Class
FastReport Namespace


CustomLoadEventHandler Delegate

[image]

FastReport.Net Class Reference
CustomLoadEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the LoadBaseReport event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void CustomLoadEventHandler(
    Object sender,
    CustomLoadEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CustomLoadEventHandler ( _
    sender As Object, _
    e As CustomLoadEventArgs _
)
Visual C++
public delegate void CustomLoadEventHandler(
    Object^ sender,
    CustomLoadEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.CustomLoadEventArgs
The event data.

See Also

FastReport Namespace


DataBand Class

[image]

FastReport.Net Class Reference
DataBand Class
Members See Also Send Feedback
This class represents the Data band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataBand : BandBase, IHasEditor
Visual Basic (Declaration)
Public Class DataBand _
    Inherits BandBase _
    Implements IHasEditor
Visual C++
public ref class DataBand : public BandBase,
    IHasEditor

Remarks

Use the DataSource property to connect the band to a datasource. Set the Filter property if you want to filter data rows. The Sort property can be used to sort data rows.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.DataBand

See Also

DataBand Members
FastReport Namespace


DataBand Members

[image] [image]

FastReport.Net Class Reference
DataBand Members
DataBand Class Constructors Methods Properties Events See Also Send Feedback

The DataBand type exposes the following members.

Constructors

Name | Description
DataBand | Initializes a new instance of the DataBand class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Overrides BandBase..::.AddChild(Base).)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides BandBase..::.CanContain(Base).)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides BandBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides BandBase..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Overrides BandBase..::.GetChildOrder(Base).)
GetContextMenu | Gets the object's context menu. (Overrides BandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Overrides BandBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitDataSource | Initializes the data source connected to this band.
InitializeComponent | Initializes the object before running a report. (Overrides BandBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Overrides BandBase..::.RemoveChild(Base).)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Overrides BandBase..::.SetChildOrder(Base, Int32).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
Bands | Gets a collection of detail bands.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
CollectChildRows | Gets or sets a value indicating that the databand should collect child data rows.
Columns | Gets the band columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataSource | Gets or sets a data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
Filter | Gets the row filter expression.
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Footer | Gets or sets a footer band.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Header | Gets or sets a header band.
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IdColumn | Gets or sets the key column that identifies the data row.
Indent | Gets or sets the indent that will be used to shift the databand according to its hierarchy level.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepDetail | Gets or sets a value indicating that the band should be printed together with all its detail rows.
KeepTogether | Gets or sets a value indicating that all band rows should be printed together on one page.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MaxRows | Limits the maximum number of rows in a datasource. 0 means no limit.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ParentIdColumn | Gets or sets the column that identifies the parent data row.
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintIfDatasourceEmpty | Gets or sets a value that determines whether to print a band if its datasource is empty.
PrintIfDetailEmpty | Gets or sets a value that determines whether to print a band if all its detail rows are empty.
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Relation | Gets or sets a relation used to establish a master-detail relationship between this band and its parent.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResetPageNumber | Gets or sets a value that determines whether to reset the page numbers when this band starts print.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the virtual data source.
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Sort | Gets the collection of sort conditions.
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

DataBand Class
FastReport Namespace


DataBand Constructor

[image]

FastReport.Net Class Reference
DataBand Constructor
DataBand Class See Also Send Feedback
Initializes a new instance of the DataBand class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataBand()

See Also

DataBand Class
FastReport Namespace


DataBand Methods

[image] [image]

FastReport.Net Class Reference
DataBand Methods
DataBand Class See Also Send Feedback

The DataBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Overrides BandBase..::.AddChild(Base).)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides BandBase..::.CanContain(Base).)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides BandBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides BandBase..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Overrides BandBase..::.GetChildOrder(Base).)
GetContextMenu | Gets the object's context menu. (Overrides BandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Overrides BandBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitDataSource | Initializes the data source connected to this band.
InitializeComponent | Initializes the object before running a report. (Overrides BandBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Overrides BandBase..::.RemoveChild(Base).)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Overrides BandBase..::.SetChildOrder(Base, Int32).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

DataBand Class
FastReport Namespace


AddChild Method

[image]

FastReport.Net Class Reference
DataBand..::.AddChild Method
DataBand Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overrides Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

DataBand Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
DataBand..::.Assign Method
DataBand Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

DataBand Class
FastReport Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
DataBand..::.CanContain Method
DataBand Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overrides Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

DataBand Class
FastReport Namespace


Delete Method

[image]

FastReport.Net Class Reference
DataBand..::.Delete Method
DataBand Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

DataBand Class
FastReport Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
DataBand..::.DeserializeSubItems Method
DataBand Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overrides Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

DataBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataBand..::.Dispose Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DataBand Class
DataBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
DataBand..::.DrawMarkers Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

DataBand Class
DataBand Members
FastReport Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
DataBand..::.GetChildObjects Method
DataBand Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overrides Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) override

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

DataBand Class
FastReport Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
DataBand..::.GetChildOrder Method
DataBand Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Overrides Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

DataBand Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
DataBand..::.GetContextMenu Method
DataBand Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

DataBand Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
DataBand..::.GetExpressions Method
DataBand Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

DataBand Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
DataBand..::.GetSmartTag Method
DataBand Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

DataBand Class
FastReport Namespace


InitDataSource Method

[image]

FastReport.Net Class Reference
DataBand..::.InitDataSource Method
DataBand Class See Also Send Feedback
Initializes the data source connected to this band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void InitDataSource()
Visual Basic (Declaration)
Public Sub InitDataSource
Visual C++
public:
void InitDataSource()

See Also

DataBand Class
FastReport Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
DataBand..::.InitializeComponent Method
DataBand Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

DataBand Class
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
DataBand..::.InvokeEditor Method
DataBand Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

DataBand Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataBand..::.MemberwiseClone Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataBand Class
DataBand Members
FastReport Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
DataBand..::.RemoveChild Method
DataBand Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overrides Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

DataBand Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DataBand..::.Serialize Method
DataBand Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DataBand Class
FastReport Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
DataBand..::.SetChildOrder Method
DataBand Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Overrides Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) override

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

DataBand Class
FastReport Namespace


DataBand Properties

[image] [image]

FastReport.Net Class Reference
DataBand Properties
DataBand Class See Also Send Feedback

The DataBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
Bands | Gets a collection of detail bands.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
CollectChildRows | Gets or sets a value indicating that the databand should collect child data rows.
Columns | Gets the band columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataSource | Gets or sets a data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
Filter | Gets the row filter expression.
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Footer | Gets or sets a footer band.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Header | Gets or sets a header band.
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IdColumn | Gets or sets the key column that identifies the data row.
Indent | Gets or sets the indent that will be used to shift the databand according to its hierarchy level.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepDetail | Gets or sets a value indicating that the band should be printed together with all its detail rows.
KeepTogether | Gets or sets a value indicating that all band rows should be printed together on one page.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MaxRows | Limits the maximum number of rows in a datasource. 0 means no limit.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ParentIdColumn | Gets or sets the column that identifies the parent data row.
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintIfDatasourceEmpty | Gets or sets a value that determines whether to print a band if its datasource is empty.
PrintIfDetailEmpty | Gets or sets a value that determines whether to print a band if all its detail rows are empty.
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Relation | Gets or sets a relation used to establish a master-detail relationship between this band and its parent.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResetPageNumber | Gets or sets a value that determines whether to reset the page numbers when this band starts print.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the virtual data source.
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Sort | Gets the collection of sort conditions.
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataBand Class
FastReport Namespace


Bands Property

[image]

FastReport.Net Class Reference
DataBand..::.Bands Property
DataBand Class See Also Send Feedback
Gets a collection of detail bands.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandCollection Bands { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bands As BandCollection
Visual C++
public:
property BandCollection^ Bands {
    BandCollection^ get ();
}

See Also

DataBand Class
FastReport Namespace


CollectChildRows Property

[image]

FastReport.Net Class Reference
DataBand..::.CollectChildRows Property
DataBand Class See Also Send Feedback
Gets or sets a value indicating that the databand should collect child data rows.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CollectChildRows { get; set; }
Visual Basic (Declaration)
Public Property CollectChildRows As Boolean
Visual C++
public:
property bool CollectChildRows {
    bool get ();
    void set (bool value);
}

Remarks

This property determines how the master-detail report is printed. Default behavior is:

MasterData row1

-- DetailData row1

-- DetailData row2

-- DetailData row3

MasterData row2

-- DetailData row1

-- DetailData row2

When you set this property to true, the master databand will collect all child data rows under a single master data row:

MasterData row1

-- DetailData row1

-- DetailData row2

-- DetailData row3

-- DetailData row4

-- DetailData row5

See Also

DataBand Class
FastReport Namespace


Columns Property

[image]

FastReport.Net Class Reference
DataBand..::.Columns Property
DataBand Class See Also Send Feedback
Gets the band columns.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandColumns Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As BandColumns
Visual C++
public:
property BandColumns^ Columns {
    BandColumns^ get ();
}

See Also

DataBand Class
FastReport Namespace


DataSource Property

[image]

FastReport.Net Class Reference
DataBand..::.DataSource Property
DataBand Class See Also Send Feedback
Gets or sets a data source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

DataBand Class
FastReport Namespace


Filter Property

[image]

FastReport.Net Class Reference
DataBand..::.Filter Property
DataBand Class See Also Send Feedback
Gets the row filter expression.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Remarks

This property can contain any valid boolean expression. If the expression returns false, the corresponding data row will not be printed.

See Also

DataBand Class
FastReport Namespace


Footer Property

[image]

FastReport.Net Class Reference
DataBand..::.Footer Property
DataBand Class See Also Send Feedback
Gets or sets a footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataFooterBand Footer { get; set; }
Visual Basic (Declaration)
Public Property Footer As DataFooterBand
Visual C++
public:
property DataFooterBand^ Footer {
    DataFooterBand^ get ();
    void set (DataFooterBand^ value);
}

See Also

DataBand Class
FastReport Namespace


Header Property

[image]

FastReport.Net Class Reference
DataBand..::.Header Property
DataBand Class See Also Send Feedback
Gets or sets a header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataHeaderBand Header { get; set; }
Visual Basic (Declaration)
Public Property Header As DataHeaderBand
Visual C++
public:
property DataHeaderBand^ Header {
    DataHeaderBand^ get ();
    void set (DataHeaderBand^ value);
}

See Also

DataBand Class
FastReport Namespace


IdColumn Property

[image]

FastReport.Net Class Reference
DataBand..::.IdColumn Property
DataBand Class See Also Send Feedback
Gets or sets the key column that identifies the data row.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string IdColumn { get; set; }
Visual Basic (Declaration)
Public Property IdColumn As String
Visual C++
public:
property String^ IdColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used when printing a hierarchic list.

To print the hierarchic list, you have to setup three properties: IdColumn, ParentIdColumn and Indent. First two properties are used to identify the data row and its parent; the Indent property specifies the indent that will be used to shift the databand according to its hierarchy level.

When printing hierarchy, FastReport shifts the band to the right (by value specified in the Indent property), and also decreases the width of the band by the same value. You may use the Anchor property of the objects on a band to indicate whether the object should move with the band, or stay on its original position, or shrink.

See Also

DataBand Class
FastReport Namespace


Indent Property

[image]

FastReport.Net Class Reference
DataBand..::.Indent Property
DataBand Class See Also Send Feedback
Gets or sets the indent that will be used to shift the databand according to its hierarchy level.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Indent { get; set; }
Visual Basic (Declaration)
Public Property Indent As Single
Visual C++
public:
property float Indent {
    float get ();
    void set (float value);
}

Remarks

This property is used when printing a hierarchic list. See description of the IdColumn property for more details.

See Also

DataBand Class
FastReport Namespace


KeepDetail Property

[image]

FastReport.Net Class Reference
DataBand..::.KeepDetail Property
DataBand Class See Also Send Feedback
Gets or sets a value indicating that the band should be printed together with all its detail rows.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool KeepDetail { get; set; }
Visual Basic (Declaration)
Public Property KeepDetail As Boolean
Visual C++
public:
property bool KeepDetail {
    bool get ();
    void set (bool value);
}

See Also

DataBand Class
FastReport Namespace


KeepTogether Property

[image]

FastReport.Net Class Reference
DataBand..::.KeepTogether Property
DataBand Class See Also Send Feedback
Gets or sets a value indicating that all band rows should be printed together on one page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean
Visual C++
public:
property bool KeepTogether {
    bool get ();
    void set (bool value);
}

See Also

DataBand Class
FastReport Namespace


MaxRows Property

[image]

FastReport.Net Class Reference
DataBand..::.MaxRows Property
DataBand Class See Also Send Feedback
Limits the maximum number of rows in a datasource. 0 means no limit.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int MaxRows { get; set; }
Visual Basic (Declaration)
Public Property MaxRows As Integer
Visual C++
public:
property int MaxRows {
    int get ();
    void set (int value);
}

See Also

DataBand Class
FastReport Namespace


ParentIdColumn Property

[image]

FastReport.Net Class Reference
DataBand..::.ParentIdColumn Property
DataBand Class See Also Send Feedback
Gets or sets the column that identifies the parent data row.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ParentIdColumn { get; set; }
Visual Basic (Declaration)
Public Property ParentIdColumn As String
Visual C++
public:
property String^ ParentIdColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used when printing a hierarchic list. See description of the IdColumn property for more details.

See Also

DataBand Class
FastReport Namespace


PrintIfDatasourceEmpty Property

[image]

FastReport.Net Class Reference
DataBand..::.PrintIfDatasourceEmpty Property
DataBand Class See Also Send Feedback
Gets or sets a value that determines whether to print a band if its datasource is empty.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintIfDatasourceEmpty { get; set; }
Visual Basic (Declaration)
Public Property PrintIfDatasourceEmpty As Boolean
Visual C++
public:
property bool PrintIfDatasourceEmpty {
    bool get ();
    void set (bool value);
}

See Also

DataBand Class
FastReport Namespace


PrintIfDetailEmpty Property

[image]

FastReport.Net Class Reference
DataBand..::.PrintIfDetailEmpty Property
DataBand Class See Also Send Feedback
Gets or sets a value that determines whether to print a band if all its detail rows are empty.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintIfDetailEmpty { get; set; }
Visual Basic (Declaration)
Public Property PrintIfDetailEmpty As Boolean
Visual C++
public:
property bool PrintIfDetailEmpty {
    bool get ();
    void set (bool value);
}

See Also

DataBand Class
FastReport Namespace


Relation Property

[image]

FastReport.Net Class Reference
DataBand..::.Relation Property
DataBand Class See Also Send Feedback
Gets or sets a relation used to establish a master-detail relationship between this band and its parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Relation Relation { get; set; }
Visual Basic (Declaration)
Public Property Relation As Relation
Visual C++
public:
property Relation^ Relation {
    Relation^ get ();
    void set (Relation^ value);
}

Remarks

Use this property if there are several relations exist between two data sources. If there is only one relation (in most cases it is), you can leave this property empty.

See Also

DataBand Class
FastReport Namespace


ResetPageNumber Property

[image]

FastReport.Net Class Reference
DataBand..::.ResetPageNumber Property
DataBand Class See Also Send Feedback
Gets or sets a value that determines whether to reset the page numbers when this band starts print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ResetPageNumber { get; set; }
Visual Basic (Declaration)
Public Property ResetPageNumber As Boolean
Visual C++
public:
property bool ResetPageNumber {
    bool get ();
    void set (bool value);
}

Remarks

Typically you should set the StartNewPage property to true as well.

See Also

DataBand Class
FastReport Namespace


RowCount Property

[image]

FastReport.Net Class Reference
DataBand..::.RowCount Property
DataBand Class See Also Send Feedback
Gets or sets a number of rows in the virtual data source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowCount { get; set; }
Visual Basic (Declaration)
Public Property RowCount As Integer
Visual C++
public:
property int RowCount {
    int get ();
    void set (int value);
}

Remarks

Use this property if your data band is not connected to any data source. In this case the virtual data source with the specified number of rows will be used.

See Also

DataBand Class
FastReport Namespace


Sort Property

[image]

FastReport.Net Class Reference
DataBand..::.Sort Property
DataBand Class See Also Send Feedback
Gets the collection of sort conditions.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SortCollection Sort { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sort As SortCollection
Visual C++
public:
property SortCollection^ Sort {
    SortCollection^ get ();
}

See Also

DataBand Class
FastReport Namespace


DataBand Events

[image] [image]

FastReport.Net Class Reference
DataBand Events
DataBand Class See Also Send Feedback

The DataBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

DataBand Class
FastReport Namespace


DatabaseLoginEventArgs Class

[image]

FastReport.Net Class Reference
DatabaseLoginEventArgs Class
Members See Also Send Feedback
Provides data for the DatabaseLogin event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DatabaseLoginEventArgs
Visual Basic (Declaration)
Public Class DatabaseLoginEventArgs
Visual C++
public ref class DatabaseLoginEventArgs

Inheritance Hierarchy

System..::.Object
FastReport..::.DatabaseLoginEventArgs

See Also

DatabaseLoginEventArgs Members
FastReport Namespace


DatabaseLoginEventArgs Members

[image] [image]

FastReport.Net Class Reference
DatabaseLoginEventArgs Members
DatabaseLoginEventArgs Class Constructors Methods Properties See Also Send Feedback

The DatabaseLoginEventArgs type exposes the following members.

Constructors

Name | Description
DatabaseLoginEventArgs | Initializes a new instance of the DatabaseLoginEventArgs class using the specified connection string.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | Gets or sets the connection string.
Password | Gets or sets a password.
UserName | Gets or sets an user name.

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


DatabaseLoginEventArgs Constructor

[image]

FastReport.Net Class Reference
DatabaseLoginEventArgs Constructor
DatabaseLoginEventArgs Class See Also Send Feedback
Initializes a new instance of the DatabaseLoginEventArgs class using the specified connection string.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DatabaseLoginEventArgs(
    string connectionString
)
Visual Basic (Declaration)
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
DatabaseLoginEventArgs(
    String^ connectionString
)

Parameters

connectionString
Type: System..::.String
The connection string.

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


DatabaseLoginEventArgs Methods

[image] [image]

FastReport.Net Class Reference
DatabaseLoginEventArgs Methods
DatabaseLoginEventArgs Class See Also Send Feedback

The DatabaseLoginEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


DatabaseLoginEventArgs Properties

[image] [image]

FastReport.Net Class Reference
DatabaseLoginEventArgs Properties
DatabaseLoginEventArgs Class See Also Send Feedback

The DatabaseLoginEventArgs type exposes the following members.

Properties

Name | Description
ConnectionString | Gets or sets the connection string.
Password | Gets or sets a password.
UserName | Gets or sets an user name.

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


ConnectionString Property

[image]

FastReport.Net Class Reference
DatabaseLoginEventArgs..::.ConnectionString Property
DatabaseLoginEventArgs Class See Also Send Feedback
Gets or sets the connection string.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


Password Property

[image]

FastReport.Net Class Reference
DatabaseLoginEventArgs..::.Password Property
DatabaseLoginEventArgs Class See Also Send Feedback
Gets or sets a password.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


UserName Property

[image]

FastReport.Net Class Reference
DatabaseLoginEventArgs..::.UserName Property
DatabaseLoginEventArgs Class See Also Send Feedback
Gets or sets an user name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseLoginEventArgs Class
FastReport Namespace


DatabaseLoginEventHandler Delegate

[image]

FastReport.Net Class Reference
DatabaseLoginEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the DatabaseLogin event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void DatabaseLoginEventHandler(
    Object sender,
    DatabaseLoginEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub DatabaseLoginEventHandler ( _
    sender As Object, _
    e As DatabaseLoginEventArgs _
)
Visual C++
public delegate void DatabaseLoginEventHandler(
    Object^ sender,
    DatabaseLoginEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.DatabaseLoginEventArgs
The event data.

See Also

FastReport Namespace


DataColumnSmartTag Class

[image]

FastReport.Net Class Reference
DataColumnSmartTag Class
Members See Also Send Feedback
Class represent a smart tag that is used to choose a data column.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataColumnSmartTag : SmartTagBase
Visual Basic (Declaration)
Public Class DataColumnSmartTag _
    Inherits SmartTagBase
Visual C++
public ref class DataColumnSmartTag : public SmartTagBase

Inheritance Hierarchy

System..::.Object
FastReport..::.SmartTagBase
FastReport..::.DataColumnSmartTag

See Also

DataColumnSmartTag Members
FastReport Namespace


DataColumnSmartTag Members

[image] [image]

FastReport.Net Class Reference
DataColumnSmartTag Members
DataColumnSmartTag Class Constructors Methods Properties See Also Send Feedback

The DataColumnSmartTag type exposes the following members.

Constructors

Name | Description
DataColumnSmartTag | Initializes a new instance of the DataColumnSmartTag class with default settings.

Methods

Name | Description
CreateItems | Creates the smart tag menu items. (Overrides SmartTagBase..::.CreateItems()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindRootDataSource | Gets a root datasource for the object currently edited.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ItemClicked | Called when the menu item is clicked. (Inherited from SmartTagBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Show | Displays a smart tag at the specified screen location. (Inherited from SmartTagBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataColumn | Gets or sets the data column name.
Designer | Gets the report designer. (Inherited from SmartTagBase.)
Menu | Gets the underlying context menu. (Inherited from SmartTagBase.)
Obj | Gets the report object that invokes this smart tag. (Inherited from SmartTagBase.)

See Also

DataColumnSmartTag Class
FastReport Namespace


DataColumnSmartTag Constructor

[image]

FastReport.Net Class Reference
DataColumnSmartTag Constructor
DataColumnSmartTag Class See Also Send Feedback
Initializes a new instance of the DataColumnSmartTag class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataColumnSmartTag(
    ComponentBase obj
)
Visual Basic (Declaration)
Public Sub New ( _
    obj As ComponentBase _
)
Visual C++
public:
DataColumnSmartTag(
    ComponentBase^ obj
)

Parameters

obj
Type: FastReport..::.ComponentBase
Report object that owns this smart tag.

See Also

DataColumnSmartTag Class
FastReport Namespace


DataColumnSmartTag Methods

[image] [image]

FastReport.Net Class Reference
DataColumnSmartTag Methods
DataColumnSmartTag Class See Also Send Feedback

The DataColumnSmartTag type exposes the following members.

Methods

Name | Description
CreateItems | Creates the smart tag menu items. (Overrides SmartTagBase..::.CreateItems()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindRootDataSource | Gets a root datasource for the object currently edited.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ItemClicked | Called when the menu item is clicked. (Inherited from SmartTagBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Show | Displays a smart tag at the specified screen location. (Inherited from SmartTagBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataColumnSmartTag Class
FastReport Namespace


CreateItems Method

[image]

FastReport.Net Class Reference
DataColumnSmartTag..::.CreateItems Method
DataColumnSmartTag Class See Also Send Feedback
Creates the smart tag menu items.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void CreateItems()
Visual Basic (Declaration)
Protected Overrides Sub CreateItems
Visual C++
protected:
virtual void CreateItems() override

Remarks

Override this method to create the smart tag menu.

See Also

DataColumnSmartTag Class
FastReport Namespace


FindRootDataSource Method

[image]

FastReport.Net Class Reference
DataColumnSmartTag..::.FindRootDataSource Method
DataColumnSmartTag Class See Also Send Feedback
Gets a root datasource for the object currently edited.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual DataSourceBase FindRootDataSource()
Visual Basic (Declaration)
Protected Overridable Function FindRootDataSource As DataSourceBase
Visual C++
protected:
virtual DataSourceBase^ FindRootDataSource()

Return Value

The DataSourceBase object if found; null otherwise.

See Also

DataColumnSmartTag Class
FastReport Namespace


DataColumnSmartTag Properties

[image] [image]

FastReport.Net Class Reference
DataColumnSmartTag Properties
DataColumnSmartTag Class See Also Send Feedback

The DataColumnSmartTag type exposes the following members.

Properties

Name | Description
DataColumn | Gets or sets the data column name.
Designer | Gets the report designer. (Inherited from SmartTagBase.)
Menu | Gets the underlying context menu. (Inherited from SmartTagBase.)
Obj | Gets the report object that invokes this smart tag. (Inherited from SmartTagBase.)

See Also

DataColumnSmartTag Class
FastReport Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
DataColumnSmartTag..::.DataColumn Property
DataColumnSmartTag Class See Also Send Feedback
Gets or sets the data column name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

See Also

DataColumnSmartTag Class
FastReport Namespace


DataFooterBand Class

[image]

FastReport.Net Class Reference
DataFooterBand Class
Members See Also Send Feedback
This class represents a data band footer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataFooterBand : HeaderFooterBandBase
Visual Basic (Declaration)
Public Class DataFooterBand _
    Inherits HeaderFooterBandBase
Visual C++
public ref class DataFooterBand : public HeaderFooterBandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.HeaderFooterBandBase
FastReport..::.DataFooterBand

See Also

DataFooterBand Members
FastReport Namespace


DataFooterBand Members

[image] [image]

FastReport.Net Class Reference
DataFooterBand Members
DataFooterBand Class Constructors Methods Properties Events See Also Send Feedback

The DataFooterBand type exposes the following members.

Constructors

Name | Description
DataFooterBand | Initializes a new instance of the DataFooterBand class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from HeaderFooterBandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

DataFooterBand Class
FastReport Namespace


DataFooterBand Constructor

[image]

FastReport.Net Class Reference
DataFooterBand Constructor
DataFooterBand Class See Also Send Feedback
Initializes a new instance of the DataFooterBand class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataFooterBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataFooterBand()

See Also

DataFooterBand Class
FastReport Namespace


DataFooterBand Methods

[image] [image]

FastReport.Net Class Reference
DataFooterBand Methods
DataFooterBand Class See Also Send Feedback

The DataFooterBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from HeaderFooterBandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

DataFooterBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataFooterBand..::.Dispose Method
DataFooterBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DataFooterBand Class
DataFooterBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
DataFooterBand..::.DrawMarkers Method
DataFooterBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

DataFooterBand Class
DataFooterBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataFooterBand..::.MemberwiseClone Method
DataFooterBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataFooterBand Class
DataFooterBand Members
FastReport Namespace


DataFooterBand Properties

[image] [image]

FastReport.Net Class Reference
DataFooterBand Properties
DataFooterBand Class See Also Send Feedback

The DataFooterBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataFooterBand Class
FastReport Namespace


DataFooterBand Events

[image] [image]

FastReport.Net Class Reference
DataFooterBand Events
DataFooterBand Class See Also Send Feedback

The DataFooterBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

DataFooterBand Class
FastReport Namespace


DataHeaderBand Class

[image]

FastReport.Net Class Reference
DataHeaderBand Class
Members See Also Send Feedback
This class represents a header of the data band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataHeaderBand : HeaderFooterBandBase
Visual Basic (Declaration)
Public Class DataHeaderBand _
    Inherits HeaderFooterBandBase
Visual C++
public ref class DataHeaderBand : public HeaderFooterBandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.HeaderFooterBandBase
FastReport..::.DataHeaderBand

See Also

DataHeaderBand Members
FastReport Namespace


DataHeaderBand Members

[image] [image]

FastReport.Net Class Reference
DataHeaderBand Members
DataHeaderBand Class Constructors Methods Properties Events See Also Send Feedback

The DataHeaderBand type exposes the following members.

Constructors

Name | Description
DataHeaderBand | Initializes a new instance of the DataHeaderBand class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from HeaderFooterBandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

DataHeaderBand Class
FastReport Namespace


DataHeaderBand Constructor

[image]

FastReport.Net Class Reference
DataHeaderBand Constructor
DataHeaderBand Class See Also Send Feedback
Initializes a new instance of the DataHeaderBand class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataHeaderBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataHeaderBand()

See Also

DataHeaderBand Class
FastReport Namespace


DataHeaderBand Methods

[image] [image]

FastReport.Net Class Reference
DataHeaderBand Methods
DataHeaderBand Class See Also Send Feedback

The DataHeaderBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from HeaderFooterBandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

DataHeaderBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataHeaderBand..::.Dispose Method
DataHeaderBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DataHeaderBand Class
DataHeaderBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
DataHeaderBand..::.DrawMarkers Method
DataHeaderBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

DataHeaderBand Class
DataHeaderBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataHeaderBand..::.MemberwiseClone Method
DataHeaderBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataHeaderBand Class
DataHeaderBand Members
FastReport Namespace


DataHeaderBand Properties

[image] [image]

FastReport.Net Class Reference
DataHeaderBand Properties
DataHeaderBand Class See Also Send Feedback

The DataHeaderBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataHeaderBand Class
FastReport Namespace


DataHeaderBand Events

[image] [image]

FastReport.Net Class Reference
DataHeaderBand Events
DataHeaderBand Class See Also Send Feedback

The DataHeaderBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

DataHeaderBand Class
FastReport Namespace


DataSourceSmartTag Class

[image]

FastReport.Net Class Reference
DataSourceSmartTag Class
Members See Also Send Feedback
Represents a smart tag that is used to choose a data source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataSourceSmartTag : SmartTagBase
Visual Basic (Declaration)
Public Class DataSourceSmartTag _
    Inherits SmartTagBase
Visual C++
public ref class DataSourceSmartTag : public SmartTagBase

Inheritance Hierarchy

System..::.Object
FastReport..::.SmartTagBase
FastReport..::.DataSourceSmartTag

See Also

DataSourceSmartTag Members
FastReport Namespace


DataSourceSmartTag Members

[image] [image]

FastReport.Net Class Reference
DataSourceSmartTag Members
DataSourceSmartTag Class Constructors Methods Properties See Also Send Feedback

The DataSourceSmartTag type exposes the following members.

Constructors

Name | Description
DataSourceSmartTag | Initializes a new instance of the DataSourceSmartTag class with default settings.

Methods

Name | Description
CreateItems | Creates the smart tag menu items. (Overrides SmartTagBase..::.CreateItems()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ItemClicked | Called when the menu item is clicked. (Inherited from SmartTagBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Show | Displays a smart tag at the specified screen location. (Inherited from SmartTagBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSource | Gets or sets a data source.
Designer | Gets the report designer. (Inherited from SmartTagBase.)
Menu | Gets the underlying context menu. (Inherited from SmartTagBase.)
Obj | Gets the report object that invokes this smart tag. (Inherited from SmartTagBase.)

See Also

DataSourceSmartTag Class
FastReport Namespace


DataSourceSmartTag Constructor

[image]

FastReport.Net Class Reference
DataSourceSmartTag Constructor
DataSourceSmartTag Class See Also Send Feedback
Initializes a new instance of the DataSourceSmartTag class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceSmartTag(
    ComponentBase obj
)
Visual Basic (Declaration)
Public Sub New ( _
    obj As ComponentBase _
)
Visual C++
public:
DataSourceSmartTag(
    ComponentBase^ obj
)

Parameters

obj
Type: FastReport..::.ComponentBase
Report object that owns this smart tag.

See Also

DataSourceSmartTag Class
FastReport Namespace


DataSourceSmartTag Methods

[image] [image]

FastReport.Net Class Reference
DataSourceSmartTag Methods
DataSourceSmartTag Class See Also Send Feedback

The DataSourceSmartTag type exposes the following members.

Methods

Name | Description
CreateItems | Creates the smart tag menu items. (Overrides SmartTagBase..::.CreateItems()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ItemClicked | Called when the menu item is clicked. (Inherited from SmartTagBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Show | Displays a smart tag at the specified screen location. (Inherited from SmartTagBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSourceSmartTag Class
FastReport Namespace


CreateItems Method

[image]

FastReport.Net Class Reference
DataSourceSmartTag..::.CreateItems Method
DataSourceSmartTag Class See Also Send Feedback
Creates the smart tag menu items.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void CreateItems()
Visual Basic (Declaration)
Protected Overrides Sub CreateItems
Visual C++
protected:
virtual void CreateItems() override

Remarks

Override this method to create the smart tag menu.

See Also

DataSourceSmartTag Class
FastReport Namespace


DataSourceSmartTag Properties

[image] [image]

FastReport.Net Class Reference
DataSourceSmartTag Properties
DataSourceSmartTag Class See Also Send Feedback

The DataSourceSmartTag type exposes the following members.

Properties

Name | Description
DataSource | Gets or sets a data source.
Designer | Gets the report designer. (Inherited from SmartTagBase.)
Menu | Gets the underlying context menu. (Inherited from SmartTagBase.)
Obj | Gets the report object that invokes this smart tag. (Inherited from SmartTagBase.)

See Also

DataSourceSmartTag Class
FastReport Namespace


DataSource Property

[image]

FastReport.Net Class Reference
DataSourceSmartTag..::.DataSource Property
DataSourceSmartTag Class See Also Send Feedback
Gets or sets a data source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

DataSourceSmartTag Class
FastReport Namespace


DefaultPaperSize Enumeration

[image]

FastReport.Net Class Reference
DefaultPaperSize Enumeration
See Also Send Feedback
Specifies the default paper size used when creating a new report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum DefaultPaperSize
Visual Basic (Declaration)
Public Enumeration DefaultPaperSize
Visual C++
public enum class DefaultPaperSize

Members

Member name | Description
A4 | A4 paper (210 x 297 mm).
Letter | Letter paper (8.5 x 11 inches, 216 x 279 mm).

See Also

FastReport Namespace


Duplicates Enumeration

[image]

FastReport.Net Class Reference
Duplicates Enumeration
See Also Send Feedback
Specifies how to display the duplicate values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum Duplicates
Visual Basic (Declaration)
Public Enumeration Duplicates
Visual C++
public enum class Duplicates

Members

Member name | Description
Show | The TextObject can show duplicate values.
Hide | The TextObject with duplicate value will be hidden.
Clear | The TextObject with duplicate value will be shown but with no text.
Merge | Several TextObject objects with the same value will be merged into one TextObject object.

See Also

FastReport Namespace


EmailSettings Class

[image]

FastReport.Net Class Reference
EmailSettings Class
Members See Also Send Feedback
Contains the email settings such as recipient(s) address, name, subject, message body.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class EmailSettings
Visual Basic (Declaration)
Public Class EmailSettings
Visual C++
public ref class EmailSettings

Remarks

Inheritance Hierarchy

System..::.Object
FastReport..::.EmailSettings

See Also

EmailSettings Members
FastReport Namespace


EmailSettings Members

[image] [image]

FastReport.Net Class Reference
EmailSettings Members
EmailSettings Class Constructors Methods Properties See Also Send Feedback

The EmailSettings type exposes the following members.

Constructors

Name | Description
EmailSettings | Initializes a new instance of the EmailSettings class with default settings.

Methods

Name | Description
Assign | Copies email settings from another source.
Clear | Resets all settings to its default values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | Gets or sets the message body.
Recipients | Gets or sets the recipient(s) email addresses.
Subject | Gets or sets the message subject.

See Also

EmailSettings Class
FastReport Namespace


EmailSettings Constructor

[image]

FastReport.Net Class Reference
EmailSettings Constructor
EmailSettings Class See Also Send Feedback
Initializes a new instance of the EmailSettings class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailSettings()

See Also

EmailSettings Class
FastReport Namespace


EmailSettings Methods

[image] [image]

FastReport.Net Class Reference
EmailSettings Methods
EmailSettings Class See Also Send Feedback

The EmailSettings type exposes the following members.

Methods

Name | Description
Assign | Copies email settings from another source.
Clear | Resets all settings to its default values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailSettings Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
EmailSettings..::.Assign Method
EmailSettings Class See Also Send Feedback
Copies email settings from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    EmailSettings source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As EmailSettings _
)
Visual C++
public:
void Assign(
    EmailSettings^ source
)

Parameters

source
Type: FastReport..::.EmailSettings
Source to copy settings from.

See Also

EmailSettings Class
FastReport Namespace


Clear Method

[image]

FastReport.Net Class Reference
EmailSettings..::.Clear Method
EmailSettings Class See Also Send Feedback
Resets all settings to its default values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

EmailSettings Class
FastReport Namespace


EmailSettings Properties

[image] [image]

FastReport.Net Class Reference
EmailSettings Properties
EmailSettings Class See Also Send Feedback

The EmailSettings type exposes the following members.

Properties

Name | Description
Message | Gets or sets the message body.
Recipients | Gets or sets the recipient(s) email addresses.
Subject | Gets or sets the message subject.

See Also

EmailSettings Class
FastReport Namespace


Message Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Message Property
EmailSettings Class See Also Send Feedback
Gets or sets the message body.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

EmailSettings Class
FastReport Namespace


Recipients Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Recipients Property
EmailSettings Class See Also Send Feedback
Gets or sets the recipient(s) email addresses.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string[] Recipients { get; set; }
Visual Basic (Declaration)
Public Property Recipients As String()
Visual C++
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

This property contains one or several email addresses in the following form: "john@url.com".

See Also

EmailSettings Class
FastReport Namespace


Subject Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Subject Property
EmailSettings Class See Also Send Feedback
Gets or sets the message subject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

EmailSettings Class
FastReport Namespace


EnvironmentSettings Class

[image]

FastReport.Net Class Reference
EnvironmentSettings Class
Members See Also Send Feedback
This class contains some global settings that used in the FastReport.Net.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class EnvironmentSettings : Component
Visual Basic (Declaration)
Public Class EnvironmentSettings _
    Inherits Component
Visual C++
public ref class EnvironmentSettings : public Component

Remarks

This component is intended for use in the Visual Studio IDE to quickly configure FastReport global settings. To use it, drop the component on your Form and set up its properties and events.

Here are some common actions that can be performed with this object:

  • To define own open/save dialogs that will be used in the report designer, use the CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport events;
  • To pass connection string to the connection object defined in a report, or to define own database login dialog, use the DatabaseLogin event;
  • To adjust the connection object after it is opened, use the AfterDatabaseLogin event;
  • To define own progress window, use the StartProgress, FinishProgress and Progress events;
  • To setup some common properties of the report, designer and preview, use properties defined in this class;
  • To set UI style of the designer and preview window, use UIStyle property.

This component actually uses the Config static class which contains ReportSettings, DesignerSettings and PreviewSettings properties. You can use Config class as well.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.EnvironmentSettings

See Also

EnvironmentSettings Members
FastReport Namespace


EnvironmentSettings Members

[image] [image]

FastReport.Net Class Reference
EnvironmentSettings Members
EnvironmentSettings Class Constructors Methods Properties Events See Also Send Feedback

The EnvironmentSettings type exposes the following members.

Constructors

Name | Description
EnvironmentSettings | Initializes a new instance of the EnvironmentSettings class

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignerSettings | Gets or sets the designer settings.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EmailSettings | Gets or sets the email settings.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreviewSettings | Gets or sets the preview settings.
ReportSettings | Gets or sets the report settings.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
UIStyle | Gets or sets the UI style of the designer and preview windows.
UseOffice2007Form | Gets or sets a value indicating whether the Office2007-style window should be used instead of standard Form when Office2007 color scheme is selected.

Events

Name | Description
AfterDatabaseLogin | Occurs after the database connection is established.
CustomOpenDialog | Occurs when the report designer is about to show the "Open" dialog.
CustomOpenReport | Occurs when the report designer is about to load the report.
CustomPreviewReport | Occurs when previewing a report from the designer.
CustomSaveDialog | Occurs when the report designer is about to show the "Save" dialog.
CustomSaveReport | Occurs when the report designer is about to save the report.
DatabaseLogin | Occurs when database connection is about to open.
DesignerLoaded | Occurs when the designer is loaded.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FilterBusinessObjectProperties | Occurs when discovering the business object's structure.
FilterConnectionTables | Occurs when getting available table names from the connection.
FinishProgress | Occurs after closing a progress window.
GetBusinessObjectPropertyKind | Occurs when determining the kind of business object's property.
ObjectInserted | Occurs when object is inserted in the designer.
Progress | Occurs when progress state is changed.
ReportLoaded | Occurs when report is loaded in the designer.
StartProgress | Occurs before displaying a progress window.

See Also

EnvironmentSettings Class
FastReport Namespace


EnvironmentSettings Constructor

[image]

FastReport.Net Class Reference
EnvironmentSettings Constructor
EnvironmentSettings Class See Also Send Feedback
Initializes a new instance of the EnvironmentSettings class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EnvironmentSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EnvironmentSettings()

See Also

EnvironmentSettings Class
FastReport Namespace


EnvironmentSettings Methods

[image] [image]

FastReport.Net Class Reference
EnvironmentSettings Methods
EnvironmentSettings Class See Also Send Feedback

The EnvironmentSettings type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

EnvironmentSettings Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
EnvironmentSettings..::.Dispose Method
EnvironmentSettings Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

EnvironmentSettings Class
EnvironmentSettings Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
EnvironmentSettings..::.MemberwiseClone Method
EnvironmentSettings Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EnvironmentSettings Class
EnvironmentSettings Members
FastReport Namespace


EnvironmentSettings Properties

[image] [image]

FastReport.Net Class Reference
EnvironmentSettings Properties
EnvironmentSettings Class See Also Send Feedback

The EnvironmentSettings type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignerSettings | Gets or sets the designer settings.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EmailSettings | Gets or sets the email settings.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreviewSettings | Gets or sets the preview settings.
ReportSettings | Gets or sets the report settings.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
UIStyle | Gets or sets the UI style of the designer and preview windows.
UseOffice2007Form | Gets or sets a value indicating whether the Office2007-style window should be used instead of standard Form when Office2007 color scheme is selected.

See Also

EnvironmentSettings Class
FastReport Namespace


DesignerSettings Property

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.DesignerSettings Property
EnvironmentSettings Class See Also Send Feedback
Gets or sets the designer settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerSettings DesignerSettings { get; set; }
Visual Basic (Declaration)
Public Property DesignerSettings As DesignerSettings
Visual C++
public:
property DesignerSettings^ DesignerSettings {
    DesignerSettings^ get ();
    void set (DesignerSettings^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


EmailSettings Property

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.EmailSettings Property
EnvironmentSettings Class See Also Send Feedback
Gets or sets the email settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailSettings EmailSettings { get; set; }
Visual Basic (Declaration)
Public Property EmailSettings As EmailSettings
Visual C++
public:
property EmailSettings^ EmailSettings {
    EmailSettings^ get ();
    void set (EmailSettings^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


PreviewSettings Property

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.PreviewSettings Property
EnvironmentSettings Class See Also Send Feedback
Gets or sets the preview settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewSettings PreviewSettings { get; set; }
Visual Basic (Declaration)
Public Property PreviewSettings As PreviewSettings
Visual C++
public:
property PreviewSettings^ PreviewSettings {
    PreviewSettings^ get ();
    void set (PreviewSettings^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


ReportSettings Property

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.ReportSettings Property
EnvironmentSettings Class See Also Send Feedback
Gets or sets the report settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportSettings ReportSettings { get; set; }
Visual Basic (Declaration)
Public Property ReportSettings As ReportSettings
Visual C++
public:
property ReportSettings^ ReportSettings {
    ReportSettings^ get ();
    void set (ReportSettings^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


UIStyle Property

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.UIStyle Property
EnvironmentSettings Class See Also Send Feedback
Gets or sets the UI style of the designer and preview windows.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UIStyle UIStyle { get; set; }
Visual Basic (Declaration)
Public Property UIStyle As UIStyle
Visual C++
public:
property UIStyle UIStyle {
    UIStyle get ();
    void set (UIStyle value);
}

Remarks

This property affects both designer and preview windows.

See Also

EnvironmentSettings Class
FastReport Namespace


UseOffice2007Form Property

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.UseOffice2007Form Property
EnvironmentSettings Class See Also Send Feedback
Gets or sets a value indicating whether the Office2007-style window should be used instead of standard Form when Office2007 color scheme is selected.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseOffice2007Form { get; set; }
Visual Basic (Declaration)
Public Property UseOffice2007Form As Boolean
Visual C++
public:
property bool UseOffice2007Form {
    bool get ();
    void set (bool value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


EnvironmentSettings Events

[image] [image]

FastReport.Net Class Reference
EnvironmentSettings Events
EnvironmentSettings Class See Also Send Feedback

The EnvironmentSettings type exposes the following members.

Events

Name | Description
AfterDatabaseLogin | Occurs after the database connection is established.
CustomOpenDialog | Occurs when the report designer is about to show the "Open" dialog.
CustomOpenReport | Occurs when the report designer is about to load the report.
CustomPreviewReport | Occurs when previewing a report from the designer.
CustomSaveDialog | Occurs when the report designer is about to show the "Save" dialog.
CustomSaveReport | Occurs when the report designer is about to save the report.
DatabaseLogin | Occurs when database connection is about to open.
DesignerLoaded | Occurs when the designer is loaded.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FilterBusinessObjectProperties | Occurs when discovering the business object's structure.
FilterConnectionTables | Occurs when getting available table names from the connection.
FinishProgress | Occurs after closing a progress window.
GetBusinessObjectPropertyKind | Occurs when determining the kind of business object's property.
ObjectInserted | Occurs when object is inserted in the designer.
Progress | Occurs when progress state is changed.
ReportLoaded | Occurs when report is loaded in the designer.
StartProgress | Occurs before displaying a progress window.

See Also

EnvironmentSettings Class
FastReport Namespace


AfterDatabaseLogin Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.AfterDatabaseLogin Event
EnvironmentSettings Class See Also Send Feedback
Occurs after the database connection is established.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event AfterDatabaseLoginEventHandler AfterDatabaseLogin
Visual Basic (Declaration)
Public Event AfterDatabaseLogin As AfterDatabaseLoginEventHandler
Visual C++
public:
 event AfterDatabaseLoginEventHandler^ AfterDatabaseLogin {
    void add (AfterDatabaseLoginEventHandler^ value);
    void remove (AfterDatabaseLoginEventHandler^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


CustomOpenDialog Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.CustomOpenDialog Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when the report designer is about to show the "Open" dialog.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveDialogEventHandler CustomOpenDialog
Visual Basic (Declaration)
Public Event CustomOpenDialog As OpenSaveDialogEventHandler
Visual C++
public:
 event OpenSaveDialogEventHandler^ CustomOpenDialog {
    void add (OpenSaveDialogEventHandler^ value);
    void remove (OpenSaveDialogEventHandler^ value);
}

Remarks

Use this event to attach own "Open" dialog to the designer. In the event handler, you must display a dialog window to allow user to choose a report file. If dialog was executed successfully, you must return e.Cancel = false and set the e.FileName to the selected file name.

You also need to use CustomOpenReport event to provide code that will open the report.

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

EnvironmentSettings Class
FastReport Namespace


CustomOpenReport Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.CustomOpenReport Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when the report designer is about to load the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveReportEventHandler CustomOpenReport
Visual Basic (Declaration)
Public Event CustomOpenReport As OpenSaveReportEventHandler
Visual C++
public:
 event OpenSaveReportEventHandler^ CustomOpenReport {
    void add (OpenSaveReportEventHandler^ value);
    void remove (OpenSaveReportEventHandler^ value);
}

Remarks

This event is used together with the CustomOpenDialog event.

Use this event to attach own "Open" dialog to the designer. In the event handler, you must load the e.Report from the location specified in the e.FileName property. For example, if you work with files: e.Report.Load(e.FileName);

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

EnvironmentSettings Class
FastReport Namespace


CustomPreviewReport Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.CustomPreviewReport Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when previewing a report from the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler CustomPreviewReport
Visual Basic (Declaration)
Public Event CustomPreviewReport As EventHandler
Visual C++
public:
 event EventHandler^ CustomPreviewReport {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event to show own preview window.

Examples

CopyC#
environmentSettings1.CustomPreviewReport += new EventHandler(MyPreviewHandler);

private void MyPreviewHandler(object sender, EventArgs e)
{
  Report report = sender as Report;
  using (MyPreviewForm form = new MyPreviewForm())
  {
    report.Preview = form.previewControl1;
    report.ShowPreparedReport();
    form.ShowDialog();
  }
}

See Also

EnvironmentSettings Class
FastReport Namespace


CustomSaveDialog Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.CustomSaveDialog Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when the report designer is about to show the "Save" dialog.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveDialogEventHandler CustomSaveDialog
Visual Basic (Declaration)
Public Event CustomSaveDialog As OpenSaveDialogEventHandler
Visual C++
public:
 event OpenSaveDialogEventHandler^ CustomSaveDialog {
    void add (OpenSaveDialogEventHandler^ value);
    void remove (OpenSaveDialogEventHandler^ value);
}

Remarks

Use this event to attach own "Save" dialog to the designer. In the event handler, you must display a dialog window to allow user to choose a report file. If dialog was executed successfully, you must return e.Cancel = false and set the e.FileName to the selected file name.

You also need to use CustomSaveReport event to provide code that will save the report.

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

EnvironmentSettings Class
FastReport Namespace


CustomSaveReport Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.CustomSaveReport Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when the report designer is about to save the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveReportEventHandler CustomSaveReport
Visual Basic (Declaration)
Public Event CustomSaveReport As OpenSaveReportEventHandler
Visual C++
public:
 event OpenSaveReportEventHandler^ CustomSaveReport {
    void add (OpenSaveReportEventHandler^ value);
    void remove (OpenSaveReportEventHandler^ value);
}

Remarks

This event is used together with the CustomSaveDialog event.

Use this event to attach own "Save" dialog to the designer. In the event handler, you must save the e.Report to the location specified in the e.FileName property. For example, if you work with files: e.Report.Save(e.FileName);

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

EnvironmentSettings Class
FastReport Namespace


DatabaseLogin Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.DatabaseLogin Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when database connection is about to open.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event DatabaseLoginEventHandler DatabaseLogin
Visual Basic (Declaration)
Public Event DatabaseLogin As DatabaseLoginEventHandler
Visual C++
public:
 event DatabaseLoginEventHandler^ DatabaseLogin {
    void add (DatabaseLoginEventHandler^ value);
    void remove (DatabaseLoginEventHandler^ value);
}

Remarks

Use this event to provide own connection string or user name/password to the connection object that is about to open.

To provide own connection string, set the e.ConnectionString property. In this case the new connection string will be used.

To provide own user name/password, set the e.UserName and e.Password properties. You may ask these values in own login dialog.

Examples

This example shows how to provide username/password using own login dialog.
CopyC#
private void report1_DatabaseLogin(object sender, DatabaseLoginEventArgs e)
{
  using (MyLoginDialog dialog = new MyLoginDialog())
  {
    if (dialog.ShowDialog() == DialogResult.OK)
    {
      e.UserName = dialog.UserName;
      e.Password = dialog.Password;
    }
  }
}

Examples

This example shows how to provide own connection string.
CopyC#
private void report1_DatabaseLogin(object sender, DatabaseLoginEventArgs e)
{
  e.ConnectionString = my_connection_string;
}

See Also

EnvironmentSettings Class
FastReport Namespace


DesignerLoaded Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.DesignerLoaded Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when the designer is loaded.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler DesignerLoaded
Visual Basic (Declaration)
Public Event DesignerLoaded As EventHandler
Visual C++
public:
 event EventHandler^ DesignerLoaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event if you want to customize some aspects of the designer, for example, to hide some menu items.

Examples

This example demonstrates how to hide the "File|Select Language..." menu item.
CopyC#
environmentSettings1.DesignerLoaded += new EventHandler(DesignerSettings_DesignerLoaded);

void DesignerSettings_DesignerLoaded(object sender, EventArgs e)
{
  (sender as DesignerControl).MainMenu.miFileSelectLanguage.Visible = false;
}

See Also

EnvironmentSettings Class
FastReport Namespace


FilterBusinessObjectProperties Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.FilterBusinessObjectProperties Event
EnvironmentSettings Class See Also Send Feedback
Occurs when discovering the business object's structure.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event FilterPropertiesEventHandler FilterBusinessObjectProperties
Visual Basic (Declaration)
Public Event FilterBusinessObjectProperties As FilterPropertiesEventHandler
Visual C++
public:
 event FilterPropertiesEventHandler^ FilterBusinessObjectProperties {
    void add (FilterPropertiesEventHandler^ value);
    void remove (FilterPropertiesEventHandler^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


FilterConnectionTables Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.FilterConnectionTables Event
EnvironmentSettings Class Example See Also Send Feedback
Occurs when getting available table names from the connection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event FilterConnectionTablesEventHandler FilterConnectionTables
Visual Basic (Declaration)
Public Event FilterConnectionTables As FilterConnectionTablesEventHandler
Visual C++
public:
 event FilterConnectionTablesEventHandler^ FilterConnectionTables {
    void add (FilterConnectionTablesEventHandler^ value);
    void remove (FilterConnectionTablesEventHandler^ value);
}

Remarks

Use this handler to filter the list of tables returned by the connection object.

Examples

This example demonstrates how to hide the table with "Table 1" name from the Data Wizard.
CopyC#
environmentSettings1.FilterConnectionTables += DesignerSettings_FilterConnectionTables;

private void DesignerSettings_FilterConnectionTables(object sender, FilterConnectionTablesEventArgs e)
{
  if (e.TableName == "Table 1")
    e.Skip = true;
}

See Also

EnvironmentSettings Class
FastReport Namespace


FinishProgress Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.FinishProgress Event
EnvironmentSettings Class See Also Send Feedback
Occurs after closing a progress window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler FinishProgress
Visual Basic (Declaration)
Public Event FinishProgress As EventHandler
Visual C++
public:
 event EventHandler^ FinishProgress {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


GetBusinessObjectPropertyKind Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.GetBusinessObjectPropertyKind Event
EnvironmentSettings Class See Also Send Feedback
Occurs when determining the kind of business object's property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event GetPropertyKindEventHandler GetBusinessObjectPropertyKind
Visual Basic (Declaration)
Public Event GetBusinessObjectPropertyKind As GetPropertyKindEventHandler
Visual C++
public:
 event GetPropertyKindEventHandler^ GetBusinessObjectPropertyKind {
    void add (GetPropertyKindEventHandler^ value);
    void remove (GetPropertyKindEventHandler^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


ObjectInserted Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.ObjectInserted Event
EnvironmentSettings Class See Also Send Feedback
Occurs when object is inserted in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ObjectInsertedEventHandler ObjectInserted
Visual Basic (Declaration)
Public Event ObjectInserted As ObjectInsertedEventHandler
Visual C++
public:
 event ObjectInsertedEventHandler^ ObjectInserted {
    void add (ObjectInsertedEventHandler^ value);
    void remove (ObjectInsertedEventHandler^ value);
}

Remarks

Use this event handler to set some object's properties when it is inserted.

See Also

EnvironmentSettings Class
FastReport Namespace


Progress Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.Progress Event
EnvironmentSettings Class See Also Send Feedback
Occurs when progress state is changed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ProgressEventHandler Progress
Visual Basic (Declaration)
Public Event Progress As ProgressEventHandler
Visual C++
public:
 event ProgressEventHandler^ Progress {
    void add (ProgressEventHandler^ value);
    void remove (ProgressEventHandler^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


ReportLoaded Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.ReportLoaded Event
EnvironmentSettings Class See Also Send Feedback
Occurs when report is loaded in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ReportLoadedEventHandler ReportLoaded
Visual Basic (Declaration)
Public Event ReportLoaded As ReportLoadedEventHandler
Visual C++
public:
 event ReportLoadedEventHandler^ ReportLoaded {
    void add (ReportLoadedEventHandler^ value);
    void remove (ReportLoadedEventHandler^ value);
}

Remarks

Use this event handler to register application data in a report.

See Also

EnvironmentSettings Class
FastReport Namespace


StartProgress Event

[image]

FastReport.Net Class Reference
EnvironmentSettings..::.StartProgress Event
EnvironmentSettings Class See Also Send Feedback
Occurs before displaying a progress window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler StartProgress
Visual Basic (Declaration)
Public Event StartProgress As EventHandler
Visual C++
public:
 event EventHandler^ StartProgress {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

EnvironmentSettings Class
FastReport Namespace


FillBase Class

[image]

FastReport.Net Class Reference
FillBase Class
Members See Also Send Feedback
Base class for all fills.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class FillBase
Visual Basic (Declaration)
Public MustInherit Class FillBase
Visual C++
public ref class FillBase abstract

Inheritance Hierarchy

System..::.Object
FastReport..::.FillBase
FastReport..::.GlassFill
FastReport..::.HatchFill
FastReport..::.LinearGradientFill
FastReport..::.PathGradientFill
FastReport..::.SolidFill

See Also

FillBase Members
FastReport Namespace


FillBase Members

[image] [image]

FastReport.Net Class Reference
FillBase Members
FillBase Class Constructors Methods See Also Send Feedback

The FillBase type exposes the following members.

Constructors

Name | Description
FillBase | Initializes a new instance of the FillBase class

Methods

Name | Description
Clone | Creates exact copy of this fill.
CreateBrush | Creates the GDI+ Brush object.
Draw | Fills the specified rectangle.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillBase Class
FastReport Namespace


FillBase Constructor

[image]

FastReport.Net Class Reference
FillBase Constructor
FillBase Class See Also Send Feedback
Initializes a new instance of the FillBase class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected FillBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
FillBase()

See Also

FillBase Class
FastReport Namespace


FillBase Methods

[image] [image]

FastReport.Net Class Reference
FillBase Methods
FillBase Class See Also Send Feedback

The FillBase type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this fill.
CreateBrush | Creates the GDI+ Brush object.
Draw | Fills the specified rectangle.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillBase Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
FillBase..::.Clone Method
FillBase Class See Also Send Feedback
Creates exact copy of this fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract FillBase Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As FillBase
Visual C++
public:
virtual FillBase^ Clone() abstract

Return Value

Copy of this object.

See Also

FillBase Class
FastReport Namespace


CreateBrush Method

[image]

FastReport.Net Class Reference
FillBase..::.CreateBrush Method
FillBase Class See Also Send Feedback
Creates the GDI+ Brush object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract Brush CreateBrush(
    RectangleF rect
)
Visual Basic (Declaration)
Public MustOverride Function CreateBrush ( _
    rect As RectangleF _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    RectangleF rect
) abstract

Parameters

rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

Return Value

Brush object.

See Also

FillBase Class
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
FillBase..::.Draw Method
FillBase Class See Also Send Feedback
Fills the specified rectangle.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Draw(
    FRPaintEventArgs e,
    RectangleF rect
)
Visual Basic (Declaration)
Public Overridable Sub Draw ( _
    e As FRPaintEventArgs, _
    rect As RectangleF _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e,
    RectangleF rect
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

See Also

FillBase Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
FillBase..::.Serialize Method
FillBase Class See Also Send Feedback
Serializes the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Serialize(
    FRWriter writer,
    string prefix,
    FillBase fill
)
Visual Basic (Declaration)
Public Overridable Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    fill As FillBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    FillBase^ fill
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Name of the fill property.
fill
Type: FastReport..::.FillBase
Fill object to compare with.

Remarks

This method is for internal use only.

See Also

FillBase Class
FastReport Namespace


FilterPropertiesEventArgs Class

[image]

FastReport.Net Class Reference
FilterPropertiesEventArgs Class
Members See Also Send Feedback
Provides data for the FilterProperties event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FilterPropertiesEventArgs
Visual Basic (Declaration)
Public Class FilterPropertiesEventArgs
Visual C++
public ref class FilterPropertiesEventArgs

Inheritance Hierarchy

System..::.Object
FastReport..::.FilterPropertiesEventArgs

See Also

FilterPropertiesEventArgs Members
FastReport Namespace


FilterPropertiesEventArgs Members

[image] [image]

FastReport.Net Class Reference
FilterPropertiesEventArgs Members
FilterPropertiesEventArgs Class Methods Properties See Also Send Feedback

The FilterPropertiesEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Property | Gets the property descriptor.
Skip | Gets or sets a value that indicates whether this property should be skipped.

See Also

FilterPropertiesEventArgs Class
FastReport Namespace


FilterPropertiesEventArgs Methods

[image] [image]

FastReport.Net Class Reference
FilterPropertiesEventArgs Methods
FilterPropertiesEventArgs Class See Also Send Feedback

The FilterPropertiesEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterPropertiesEventArgs Class
FastReport Namespace


FilterPropertiesEventArgs Properties

[image] [image]

FastReport.Net Class Reference
FilterPropertiesEventArgs Properties
FilterPropertiesEventArgs Class See Also Send Feedback

The FilterPropertiesEventArgs type exposes the following members.

Properties

Name | Description
Property | Gets the property descriptor.
Skip | Gets or sets a value that indicates whether this property should be skipped.

See Also

FilterPropertiesEventArgs Class
FastReport Namespace


Property Property

[image]

FastReport.Net Class Reference
FilterPropertiesEventArgs..::.Property Property
FilterPropertiesEventArgs Class See Also Send Feedback
Gets the property descriptor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptor Property { get; set; }
Visual Basic (Declaration)
Public Property Property As PropertyDescriptor
Visual C++
public:
property PropertyDescriptor^ Property {
    PropertyDescriptor^ get ();
    void set (PropertyDescriptor^ value);
}

See Also

FilterPropertiesEventArgs Class
FastReport Namespace


Skip Property

[image]

FastReport.Net Class Reference
FilterPropertiesEventArgs..::.Skip Property
FilterPropertiesEventArgs Class See Also Send Feedback
Gets or sets a value that indicates whether this property should be skipped.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Skip { get; set; }
Visual Basic (Declaration)
Public Property Skip As Boolean
Visual C++
public:
property bool Skip {
    bool get ();
    void set (bool value);
}

See Also

FilterPropertiesEventArgs Class
FastReport Namespace


FilterPropertiesEventHandler Delegate

[image]

FastReport.Net Class Reference
FilterPropertiesEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the FilterProperties event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void FilterPropertiesEventHandler(
    Object sender,
    FilterPropertiesEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub FilterPropertiesEventHandler ( _
    sender As Object, _
    e As FilterPropertiesEventArgs _
)
Visual C++
public delegate void FilterPropertiesEventHandler(
    Object^ sender,
    FilterPropertiesEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.FilterPropertiesEventArgs
The event data.

See Also

FastReport Namespace


Flags Enumeration

[image]

FastReport.Net Class Reference
Flags Enumeration
See Also Send Feedback
Specifies a set of actions that can be performed on the object in the design mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
[FlagsAttribute]
public enum Flags
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration Flags
Visual C++
[FlagsAttribute]
public enum class Flags

Members

Member name | Description
None | Specifies no actions.
CanMove | Allows moving the object.
CanResize | Allows resizing the object.
CanDelete | Allows deleting the object.
CanEdit | Allows editing the object.
CanChangeOrder | Allows changing the Z-order of an object.
CanChangeParent | Allows moving the object to another parent.
CanCopy | Allows copying the object to the clipboard.
CanDraw | Allows drawing the object.
CanGroup | Allows grouping the object.
CanWriteChildren | Allows write children in the preview mode by itself.
CanWriteBounds | Allows write object's bounds into the report stream.
HasSmartTag | Allows the "smart tag" functionality.
HasGlobalName | Specifies that the object's name is global (this is true for all report objects such as Text, Picture and so on).
CanShowChildrenInReportTree | Specifies that the object can display children in the designer's Report Tree window.
InterceptsPreviewMouseEvents | Specifies that the object supports mouse wheel in the preview window.

See Also

FastReport Namespace


GetPropertyKindEventArgs Class

[image]

FastReport.Net Class Reference
GetPropertyKindEventArgs Class
Members See Also Send Feedback
Provides data for the GetPropertyKind event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GetPropertyKindEventArgs
Visual Basic (Declaration)
Public Class GetPropertyKindEventArgs
Visual C++
public ref class GetPropertyKindEventArgs

Inheritance Hierarchy

System..::.Object
FastReport..::.GetPropertyKindEventArgs

See Also

GetPropertyKindEventArgs Members
FastReport Namespace


GetPropertyKindEventArgs Members

[image] [image]

FastReport.Net Class Reference
GetPropertyKindEventArgs Members
GetPropertyKindEventArgs Class Methods Properties See Also Send Feedback

The GetPropertyKindEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PropertyKind | Gets or sets the kind of property.
PropertyName | Gets the property name.
PropertyType | Gets the property type.

See Also

GetPropertyKindEventArgs Class
FastReport Namespace


GetPropertyKindEventArgs Methods

[image] [image]

FastReport.Net Class Reference
GetPropertyKindEventArgs Methods
GetPropertyKindEventArgs Class See Also Send Feedback

The GetPropertyKindEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPropertyKindEventArgs Class
FastReport Namespace


GetPropertyKindEventArgs Properties

[image] [image]

FastReport.Net Class Reference
GetPropertyKindEventArgs Properties
GetPropertyKindEventArgs Class See Also Send Feedback

The GetPropertyKindEventArgs type exposes the following members.

Properties

Name | Description
PropertyKind | Gets or sets the kind of property.
PropertyName | Gets the property name.
PropertyType | Gets the property type.

See Also

GetPropertyKindEventArgs Class
FastReport Namespace


PropertyKind Property

[image]

FastReport.Net Class Reference
GetPropertyKindEventArgs..::.PropertyKind Property
GetPropertyKindEventArgs Class See Also Send Feedback
Gets or sets the kind of property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyKind PropertyKind { get; set; }
Visual Basic (Declaration)
Public Property PropertyKind As PropertyKind
Visual C++
public:
property PropertyKind PropertyKind {
    PropertyKind get ();
    void set (PropertyKind value);
}

See Also

GetPropertyKindEventArgs Class
FastReport Namespace


PropertyName Property

[image]

FastReport.Net Class Reference
GetPropertyKindEventArgs..::.PropertyName Property
GetPropertyKindEventArgs Class See Also Send Feedback
Gets the property name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PropertyName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PropertyName As String
Visual C++
public:
property String^ PropertyName {
    String^ get ();
}

See Also

GetPropertyKindEventArgs Class
FastReport Namespace


PropertyType Property

[image]

FastReport.Net Class Reference
GetPropertyKindEventArgs..::.PropertyType Property
GetPropertyKindEventArgs Class See Also Send Feedback
Gets the property type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type PropertyType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PropertyType As Type
Visual C++
public:
property Type^ PropertyType {
    Type^ get ();
}

See Also

GetPropertyKindEventArgs Class
FastReport Namespace


GetPropertyKindEventHandler Delegate

[image]

FastReport.Net Class Reference
GetPropertyKindEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the GetPropertyKind event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void GetPropertyKindEventHandler(
    Object sender,
    GetPropertyKindEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub GetPropertyKindEventHandler ( _
    sender As Object, _
    e As GetPropertyKindEventArgs _
)
Visual C++
public delegate void GetPropertyKindEventHandler(
    Object^ sender,
    GetPropertyKindEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.GetPropertyKindEventArgs
The event data.

See Also

FastReport Namespace


GetTypeInstanceEventArgs Class

[image]

FastReport.Net Class Reference
GetTypeInstanceEventArgs Class
Members See Also Send Feedback
Provides data for the GetTypeInstance event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GetTypeInstanceEventArgs
Visual Basic (Declaration)
Public Class GetTypeInstanceEventArgs
Visual C++
public ref class GetTypeInstanceEventArgs

Inheritance Hierarchy

System..::.Object
FastReport..::.GetTypeInstanceEventArgs

See Also

GetTypeInstanceEventArgs Members
FastReport Namespace


GetTypeInstanceEventArgs Members

[image] [image]

FastReport.Net Class Reference
GetTypeInstanceEventArgs Members
GetTypeInstanceEventArgs Class Methods Properties See Also Send Feedback

The GetTypeInstanceEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Instance | Gets or sets the instance of type.
Type | Gets the type.

See Also

GetTypeInstanceEventArgs Class
FastReport Namespace


GetTypeInstanceEventArgs Methods

[image] [image]

FastReport.Net Class Reference
GetTypeInstanceEventArgs Methods
GetTypeInstanceEventArgs Class See Also Send Feedback

The GetTypeInstanceEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetTypeInstanceEventArgs Class
FastReport Namespace


GetTypeInstanceEventArgs Properties

[image] [image]

FastReport.Net Class Reference
GetTypeInstanceEventArgs Properties
GetTypeInstanceEventArgs Class See Also Send Feedback

The GetTypeInstanceEventArgs type exposes the following members.

Properties

Name | Description
Instance | Gets or sets the instance of type.
Type | Gets the type.

See Also

GetTypeInstanceEventArgs Class
FastReport Namespace


Instance Property

[image]

FastReport.Net Class Reference
GetTypeInstanceEventArgs..::.Instance Property
GetTypeInstanceEventArgs Class See Also Send Feedback
Gets or sets the instance of type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Instance { get; set; }
Visual Basic (Declaration)
Public Property Instance As Object
Visual C++
public:
property Object^ Instance {
    Object^ get ();
    void set (Object^ value);
}

See Also

GetTypeInstanceEventArgs Class
FastReport Namespace


Type Property

[image]

FastReport.Net Class Reference
GetTypeInstanceEventArgs..::.Type Property
GetTypeInstanceEventArgs Class See Also Send Feedback
Gets the type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As Type
Visual C++
public:
property Type^ Type {
    Type^ get ();
}

See Also

GetTypeInstanceEventArgs Class
FastReport Namespace


GetTypeInstanceEventHandler Delegate

[image]

FastReport.Net Class Reference
GetTypeInstanceEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the GetPropertyKind event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void GetTypeInstanceEventHandler(
    Object sender,
    GetTypeInstanceEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub GetTypeInstanceEventHandler ( _
    sender As Object, _
    e As GetTypeInstanceEventArgs _
)
Visual C++
public delegate void GetTypeInstanceEventHandler(
    Object^ sender,
    GetTypeInstanceEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.GetTypeInstanceEventArgs
The event data.

See Also

FastReport Namespace


GlassFill Class

[image]

FastReport.Net Class Reference
GlassFill Class
Members See Also Send Feedback
Class represents the glass fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GlassFill : FillBase
Visual Basic (Declaration)
Public Class GlassFill _
    Inherits FillBase
Visual C++
public ref class GlassFill : public FillBase

Inheritance Hierarchy

System..::.Object
FastReport..::.FillBase
FastReport..::.GlassFill

See Also

GlassFill Members
FastReport Namespace


GlassFill Members

[image] [image]

FastReport.Net Class Reference
GlassFill Members
GlassFill Class Constructors Methods Properties See Also Send Feedback

The GlassFill type exposes the following members.

Constructors

Name | Description
GlassFill | Overloaded.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Overrides FillBase..::.Draw(FRPaintEventArgs, RectangleF).)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Blend | Gets or sets the blend value.
Color | Gets or sets the fill color.
Hatch | Gets or sets a value determines whether to draw a hatch or not.

See Also

GlassFill Class
FastReport Namespace


GlassFill Constructor

[image] [image]

FastReport.Net Class Reference
GlassFill Constructor
GlassFill Class See Also Send Feedback

Overload List

Name | Description
GlassFill()()() | Initializes the GlassFill class with default settings.
GlassFill(Color, Single, Boolean) | Initializes the GlassFill class with given color, blend ratio and hatch style.

See Also

GlassFill Class
GlassFill Members
FastReport Namespace


GlassFill Constructor

[image]

FastReport.Net Class Reference
GlassFill Constructor
GlassFill Class See Also Send Feedback
Initializes the GlassFill class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GlassFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GlassFill()

See Also

GlassFill Class
GlassFill Overload
FastReport Namespace


GlassFill Constructor (Color, Single, Boolean)

[image]

FastReport.Net Class Reference
GlassFill Constructor (Color, Single, Boolean)
GlassFill Class See Also Send Feedback
Initializes the GlassFill class with given color, blend ratio and hatch style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GlassFill(
    Color color,
    float blend,
    bool hatch
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    blend As Single, _
    hatch As Boolean _
)
Visual C++
public:
GlassFill(
    Color color,
    float blend,
    bool hatch
)

Parameters

color
Type: System.Drawing..::.Color
Color.
blend
Type: System..::.Single
Blend ratio (0..1).
hatch
Type: System..::.Boolean
Display the hatch.

See Also

GlassFill Class
GlassFill Overload
FastReport Namespace


GlassFill Methods

[image] [image]

FastReport.Net Class Reference
GlassFill Methods
GlassFill Class See Also Send Feedback

The GlassFill type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Overrides FillBase..::.Draw(FRPaintEventArgs, RectangleF).)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlassFill Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
GlassFill..::.Clone Method
GlassFill Class See Also Send Feedback
Creates exact copy of this fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FillBase
Visual C++
public:
virtual FillBase^ Clone() override

Return Value

Copy of this object.

See Also

GlassFill Class
FastReport Namespace


CreateBrush Method

[image]

FastReport.Net Class Reference
GlassFill..::.CreateBrush Method
GlassFill Class See Also Send Feedback
Creates the GDI+ Brush object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Brush CreateBrush(
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As RectangleF _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    RectangleF rect
) override

Parameters

rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

Return Value

Brush object.

See Also

GlassFill Class
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
GlassFill..::.Draw Method
GlassFill Class See Also Send Feedback
Fills the specified rectangle.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e,
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs, _
    rect As RectangleF _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e,
    RectangleF rect
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

See Also

GlassFill Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
GlassFill..::.Equals Method
GlassFill Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

GlassFill Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
GlassFill..::.GetHashCode Method
GlassFill Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

GlassFill Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
GlassFill..::.Serialize Method
GlassFill Class See Also Send Feedback
Serializes the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer,
    string prefix,
    FillBase fill
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    fill As FillBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    FillBase^ fill
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Name of the fill property.
fill
Type: FastReport..::.FillBase
Fill object to compare with.

Remarks

This method is for internal use only.

See Also

GlassFill Class
FastReport Namespace


GlassFill Properties

[image] [image]

FastReport.Net Class Reference
GlassFill Properties
GlassFill Class See Also Send Feedback

The GlassFill type exposes the following members.

Properties

Name | Description
Blend | Gets or sets the blend value.
Color | Gets or sets the fill color.
Hatch | Gets or sets a value determines whether to draw a hatch or not.

See Also

GlassFill Class
FastReport Namespace


Blend Property

[image]

FastReport.Net Class Reference
GlassFill..::.Blend Property
GlassFill Class See Also Send Feedback
Gets or sets the blend value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Blend { get; set; }
Visual Basic (Declaration)
Public Property Blend As Single
Visual C++
public:
property float Blend {
    float get ();
    void set (float value);
}

Remarks

Value must be between 0 and 1.

See Also

GlassFill Class
FastReport Namespace


Color Property

[image]

FastReport.Net Class Reference
GlassFill..::.Color Property
GlassFill Class See Also Send Feedback
Gets or sets the fill color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

GlassFill Class
FastReport Namespace


Hatch Property

[image]

FastReport.Net Class Reference
GlassFill..::.Hatch Property
GlassFill Class See Also Send Feedback
Gets or sets a value determines whether to draw a hatch or not.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Hatch { get; set; }
Visual Basic (Declaration)
Public Property Hatch As Boolean
Visual C++
public:
property bool Hatch {
    bool get ();
    void set (bool value);
}

See Also

GlassFill Class
FastReport Namespace


GraphicCache Class

[image]

FastReport.Net Class Reference
GraphicCache Class
Members Example See Also Send Feedback
Represents a cache of graphics objects such as pens, brushes, fonts and text formats.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GraphicCache : IDisposable
Visual Basic (Declaration)
Public Class GraphicCache _
    Implements IDisposable
Visual C++
public ref class GraphicCache : IDisposable

Remarks

Cache holds all used graphics objects. There is no need to dispose objects returned by GetXXX calls.

Examples

This example demonstrates how to use graphic cache.
CopyC#
public void Draw(FRPaintEventArgs e)
{
  Brush brush = e.Cache.GetBrush(BackColor);
  Pen pen = e.Cache.GetPen(BorderColor, 1, BorderStyle);
  e.Graphics.FillRectangle(brush, Bounds);
  e.Graphics.DrawRectangle(pen, Bounds);
}

Inheritance Hierarchy

System..::.Object
FastReport..::.GraphicCache

See Also

GraphicCache Members
FastReport Namespace


GraphicCache Members

[image] [image]

FastReport.Net Class Reference
GraphicCache Members
GraphicCache Class Constructors Methods See Also Send Feedback

The GraphicCache type exposes the following members.

Constructors

Name | Description
GraphicCache | Initializes a new instance of the GraphicCache class with default settings.

Methods

Name | Description
Dispose | Disposes resources used by this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBrush | Gets a brush with specified color.
GetFont | Gets a font with specified settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPen | Overloaded.
GetStringFormat | Gets a string format with specified settings.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicCache Class
FastReport Namespace


GraphicCache Constructor

[image]

FastReport.Net Class Reference
GraphicCache Constructor
GraphicCache Class See Also Send Feedback
Initializes a new instance of the GraphicCache class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GraphicCache()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GraphicCache()

See Also

GraphicCache Class
FastReport Namespace


GraphicCache Methods

[image] [image]

FastReport.Net Class Reference
GraphicCache Methods
GraphicCache Class See Also Send Feedback

The GraphicCache type exposes the following members.

Methods

Name | Description
Dispose | Disposes resources used by this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBrush | Gets a brush with specified color.
GetFont | Gets a font with specified settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPen | Overloaded.
GetStringFormat | Gets a string format with specified settings.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicCache Class
FastReport Namespace


Dispose Method

[image]

FastReport.Net Class Reference
GraphicCache..::.Dispose Method
GraphicCache Class See Also Send Feedback
Disposes resources used by this object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

GraphicCache Class
FastReport Namespace


GetBrush Method

[image]

FastReport.Net Class Reference
GraphicCache..::.GetBrush Method
GraphicCache Class See Also Send Feedback
Gets a brush with specified color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SolidBrush GetBrush(
    Color color
)
Visual Basic (Declaration)
Public Function GetBrush ( _
    color As Color _
) As SolidBrush
Visual C++
public:
SolidBrush^ GetBrush(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color of a brush.

Return Value

The SolidBrush object.

See Also

GraphicCache Class
FastReport Namespace


GetFont Method

[image]

FastReport.Net Class Reference
GraphicCache..::.GetFont Method
GraphicCache Class See Also Send Feedback
Gets a font with specified settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font GetFont(
    string name,
    float size,
    FontStyle style
)
Visual Basic (Declaration)
Public Function GetFont ( _
    name As String, _
    size As Single, _
    style As FontStyle _
) As Font
Visual C++
public:
Font^ GetFont(
    String^ name,
    float size,
    FontStyle style
)

Parameters

name
Type: System..::.String
Name of a font.
size
Type: System..::.Single
Size of a font.
style
Type: System.Drawing..::.FontStyle
Style of a font.

Return Value

The Font object.

See Also

GraphicCache Class
FastReport Namespace


GetPen Method

[image] [image]

FastReport.Net Class Reference
GraphicCache..::.GetPen Method
GraphicCache Class See Also Send Feedback

Overload List

Name | Description
GetPen(Color, Single, DashStyle) | Gets a pen with specified settings.
GetPen(Color, Single, DashStyle, LineJoin) | Gets a pen with specified settings.

See Also

GraphicCache Class
GraphicCache Members
FastReport Namespace


GetPen Method (Color, Single, DashStyle)

[image]

FastReport.Net Class Reference
GraphicCache..::.GetPen Method (Color, Single, DashStyle)
GraphicCache Class See Also Send Feedback
Gets a pen with specified settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Pen GetPen(
    Color color,
    float width,
    DashStyle style
)
Visual Basic (Declaration)
Public Function GetPen ( _
    color As Color, _
    width As Single, _
    style As DashStyle _
) As Pen
Visual C++
public:
Pen^ GetPen(
    Color color,
    float width,
    DashStyle style
)

Parameters

color
Type: System.Drawing..::.Color
Color of a pen.
width
Type: System..::.Single
Width of a pen.
style
Type: System.Drawing.Drawing2D..::.DashStyle
Dash style of a pen.

Return Value

The Pen object.

See Also

GraphicCache Class
GetPen Overload
FastReport Namespace


GetPen Method (Color, Single, DashStyle, LineJoin)

[image]

FastReport.Net Class Reference
GraphicCache..::.GetPen Method (Color, Single, DashStyle, LineJoin)
GraphicCache Class See Also Send Feedback
Gets a pen with specified settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Pen GetPen(
    Color color,
    float width,
    DashStyle style,
    LineJoin lineJoin
)
Visual Basic (Declaration)
Public Function GetPen ( _
    color As Color, _
    width As Single, _
    style As DashStyle, _
    lineJoin As LineJoin _
) As Pen
Visual C++
public:
Pen^ GetPen(
    Color color,
    float width,
    DashStyle style,
    LineJoin lineJoin
)

Parameters

color
Type: System.Drawing..::.Color
Color of a pen.
width
Type: System..::.Single
Width of a pen.
style
Type: System.Drawing.Drawing2D..::.DashStyle
Dash style of a pen.
lineJoin
Type: System.Drawing.Drawing2D..::.LineJoin
Line join of a pen.

Return Value

The Pen object.

See Also

GraphicCache Class
GetPen Overload
FastReport Namespace


GetStringFormat Method

[image]

FastReport.Net Class Reference
GraphicCache..::.GetStringFormat Method
GraphicCache Class See Also Send Feedback
Gets a string format with specified settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StringFormat GetStringFormat(
    StringAlignment align,
    StringAlignment lineAlign,
    StringTrimming trimming,
    StringFormatFlags flags,
    float firstTab,
    float tabWidth
)
Visual Basic (Declaration)
Public Function GetStringFormat ( _
    align As StringAlignment, _
    lineAlign As StringAlignment, _
    trimming As StringTrimming, _
    flags As StringFormatFlags, _
    firstTab As Single, _
    tabWidth As Single _
) As StringFormat
Visual C++
public:
StringFormat^ GetStringFormat(
    StringAlignment align,
    StringAlignment lineAlign,
    StringTrimming trimming,
    StringFormatFlags flags,
    float firstTab,
    float tabWidth
)

Parameters

align
Type: System.Drawing..::.StringAlignment
Text alignment information on the vertical plane.
lineAlign
Type: System.Drawing..::.StringAlignment
Line alignment on the horizontal plane.
trimming
Type: System.Drawing..::.StringTrimming
StringTrimming enumeration.
flags
Type: System.Drawing..::.StringFormatFlags
StringFormatFlags enumeration that contains formatting information.
firstTab
Type: System..::.Single
The number of spaces between the beginning of a line of text and the first tab stop.
tabWidth
Type: System..::.Single
Distance between tab stops.

Return Value

The StringFormat object.

See Also

GraphicCache Class
FastReport Namespace


GroupFooterBand Class

[image]

FastReport.Net Class Reference
GroupFooterBand Class
Members See Also Send Feedback
Represents a group footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GroupFooterBand : HeaderFooterBandBase
Visual Basic (Declaration)
Public Class GroupFooterBand _
    Inherits HeaderFooterBandBase
Visual C++
public ref class GroupFooterBand : public HeaderFooterBandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.HeaderFooterBandBase
FastReport..::.GroupFooterBand

See Also

GroupFooterBand Members
FastReport Namespace


GroupFooterBand Members

[image] [image]

FastReport.Net Class Reference
GroupFooterBand Members
GroupFooterBand Class Constructors Methods Properties Events See Also Send Feedback

The GroupFooterBand type exposes the following members.

Constructors

Name | Description
GroupFooterBand | Initializes a new instance of the GroupFooterBand class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from HeaderFooterBandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

GroupFooterBand Class
FastReport Namespace


GroupFooterBand Constructor

[image]

FastReport.Net Class Reference
GroupFooterBand Constructor
GroupFooterBand Class See Also Send Feedback
Initializes a new instance of the GroupFooterBand class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupFooterBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupFooterBand()

See Also

GroupFooterBand Class
FastReport Namespace


GroupFooterBand Methods

[image] [image]

FastReport.Net Class Reference
GroupFooterBand Methods
GroupFooterBand Class See Also Send Feedback

The GroupFooterBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from HeaderFooterBandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

GroupFooterBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
GroupFooterBand..::.Dispose Method
GroupFooterBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

GroupFooterBand Class
GroupFooterBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
GroupFooterBand..::.DrawMarkers Method
GroupFooterBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

GroupFooterBand Class
GroupFooterBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
GroupFooterBand..::.MemberwiseClone Method
GroupFooterBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GroupFooterBand Class
GroupFooterBand Members
FastReport Namespace


GroupFooterBand Properties

[image] [image]

FastReport.Net Class Reference
GroupFooterBand Properties
GroupFooterBand Class See Also Send Feedback

The GroupFooterBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

GroupFooterBand Class
FastReport Namespace


GroupFooterBand Events

[image] [image]

FastReport.Net Class Reference
GroupFooterBand Events
GroupFooterBand Class See Also Send Feedback

The GroupFooterBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

GroupFooterBand Class
FastReport Namespace


GroupHeaderBand Class

[image]

FastReport.Net Class Reference
GroupHeaderBand Class
Members Example See Also Send Feedback
Represents a group header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GroupHeaderBand : HeaderFooterBandBase,
    IHasEditor
Visual Basic (Declaration)
Public Class GroupHeaderBand _
    Inherits HeaderFooterBandBase _
    Implements IHasEditor
Visual C++
public ref class GroupHeaderBand : public HeaderFooterBandBase,
    IHasEditor

Remarks

A simple group consists of one GroupHeaderBand and the DataBand that is set to the Data property. To create the nested groups, use the NestedGroup property.
Note: Only the last nested group can have data band.

Use the Condition property to set the group condition. The SortOrder property can be used to set the sort order for group's data rows. You can also use the Sort property of the group's DataBand to specify additional sort.

Examples

This example shows how to create nested groups.
CopyC#
ReportPage page = report.Pages[0] as ReportPage;

// create the main group
GroupHeaderBand mainGroup = new GroupHeaderBand();
mainGroup.Height = Units.Millimeters * 10;
mainGroup.Name = "MainGroup";
mainGroup.Condition = "[Orders.CustomerName]";
// add a group to the page
page.Bands.Add(mainGroup);

// create the nested group
GroupHeaderBand nestedGroup = new GroupHeaderBand();
nestedGroup.Height = Units.Millimeters * 10;
nestedGroup.Name = "NestedGroup";
nestedGroup.Condition = "[Orders.OrderDate]";
// add it to the main group
mainGroup.NestedGroup = nestedGroup;

// create a data band
DataBand dataBand = new DataBand();
dataBand.Height = Units.Millimeters * 10;
dataBand.Name = "GroupData";
dataBand.DataSource = report.GetDataSource("Orders");
// connect the databand to the nested group
nestedGroup.Data = dataBand;

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.HeaderFooterBandBase
FastReport..::.GroupHeaderBand

See Also

GroupHeaderBand Members
FastReport Namespace


GroupHeaderBand Members

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand Members
GroupHeaderBand Class Constructors Methods Properties Events See Also Send Feedback

The GroupHeaderBand type exposes the following members.

Constructors

Name | Description
GroupHeaderBand | Initializes a new instance of the GroupHeaderBand class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Overrides BandBase..::.AddChild(Base).)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides HeaderFooterBandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides BandBase..::.CanContain(Base).)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides BandBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides BandBase..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides HeaderFooterBandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Overrides BandBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Overrides BandBase..::.RemoveChild(Base).)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides HeaderFooterBandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Condition | Gets or sets the group condition.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
Data | Gets or sets the group data band.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Footer | Gets or sets a footer band.
GroupFooter | Gets or sets a group footer.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Header | Gets or sets a header band.
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepTogether | Gets or sets a value indicating that the group should be printed together on one page.
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NestedGroup | Gets or sets a nested group.
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResetPageNumber | Gets or sets a value that determines whether to reset the page numbers when this group starts print.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SortOrder | Gets or sets the sort order.
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

GroupHeaderBand Class
FastReport Namespace


GroupHeaderBand Constructor

[image]

FastReport.Net Class Reference
GroupHeaderBand Constructor
GroupHeaderBand Class See Also Send Feedback
Initializes a new instance of the GroupHeaderBand class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupHeaderBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupHeaderBand()

See Also

GroupHeaderBand Class
FastReport Namespace


GroupHeaderBand Methods

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand Methods
GroupHeaderBand Class See Also Send Feedback

The GroupHeaderBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Overrides BandBase..::.AddChild(Base).)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides HeaderFooterBandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides BandBase..::.CanContain(Base).)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides BandBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides BandBase..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides HeaderFooterBandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Overrides BandBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Overrides BandBase..::.RemoveChild(Base).)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides HeaderFooterBandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

GroupHeaderBand Class
FastReport Namespace


AddChild Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.AddChild Method
GroupHeaderBand Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overrides Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

GroupHeaderBand Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Assign Method
GroupHeaderBand Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

GroupHeaderBand Class
FastReport Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.CanContain Method
GroupHeaderBand Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overrides Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

GroupHeaderBand Class
FastReport Namespace


Delete Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Delete Method
GroupHeaderBand Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

GroupHeaderBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand..::.Dispose Method
GroupHeaderBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

GroupHeaderBand Class
GroupHeaderBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand..::.DrawMarkers Method
GroupHeaderBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

GroupHeaderBand Class
GroupHeaderBand Members
FastReport Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.GetChildObjects Method
GroupHeaderBand Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overrides Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) override

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

GroupHeaderBand Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.GetContextMenu Method
GroupHeaderBand Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

GroupHeaderBand Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.GetExpressions Method
GroupHeaderBand Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

GroupHeaderBand Class
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.InvokeEditor Method
GroupHeaderBand Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

GroupHeaderBand Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand..::.MemberwiseClone Method
GroupHeaderBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GroupHeaderBand Class
GroupHeaderBand Members
FastReport Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.RemoveChild Method
GroupHeaderBand Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overrides Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

GroupHeaderBand Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Serialize Method
GroupHeaderBand Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

GroupHeaderBand Class
FastReport Namespace


GroupHeaderBand Properties

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand Properties
GroupHeaderBand Class See Also Send Feedback

The GroupHeaderBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Condition | Gets or sets the group condition.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
Data | Gets or sets the group data band.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Footer | Gets or sets a footer band.
GroupFooter | Gets or sets a group footer.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Header | Gets or sets a header band.
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepTogether | Gets or sets a value indicating that the group should be printed together on one page.
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NestedGroup | Gets or sets a nested group.
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page. (Inherited from HeaderFooterBandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResetPageNumber | Gets or sets a value that determines whether to reset the page numbers when this group starts print.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SortOrder | Gets or sets the sort order.
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

GroupHeaderBand Class
FastReport Namespace


Condition Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Condition Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets the group condition.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Condition { get; set; }
Visual Basic (Declaration)
Public Property Condition As String
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Remarks

This property can contain any valid expression. When running a report, this expression is calculated for each data row. When the value of this condition is changed, FastReport starts a new group.

See Also

GroupHeaderBand Class
FastReport Namespace


Data Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Data Property
GroupHeaderBand Class Example See Also Send Feedback
Gets or sets the group data band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataBand Data { get; set; }
Visual Basic (Declaration)
Public Property Data As DataBand
Visual C++
public:
property DataBand^ Data {
    DataBand^ get ();
    void set (DataBand^ value);
}

Remarks

Use this property to add a data band to a group. Note: only the last nested group can have Data band.

Examples

This example demonstrates how to add a data band to a group.
CopyC#
ReportPage page;
GroupHeaderBand group = new GroupHeaderBand();
group.Data = new DataBand();
page.Bands.Add(group);

See Also

GroupHeaderBand Class
FastReport Namespace


Footer Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Footer Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets a footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataFooterBand Footer { get; set; }
Visual Basic (Declaration)
Public Property Footer As DataFooterBand
Visual C++
public:
property DataFooterBand^ Footer {
    DataFooterBand^ get ();
    void set (DataFooterBand^ value);
}

Remarks

To access a group footer band, use the GroupFooter property.

See Also

GroupHeaderBand Class
FastReport Namespace


GroupFooter Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.GroupFooter Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets a group footer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupFooterBand GroupFooter { get; set; }
Visual Basic (Declaration)
Public Property GroupFooter As GroupFooterBand
Visual C++
public:
property GroupFooterBand^ GroupFooter {
    GroupFooterBand^ get ();
    void set (GroupFooterBand^ value);
}

See Also

GroupHeaderBand Class
FastReport Namespace


Header Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.Header Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets a header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataHeaderBand Header { get; set; }
Visual Basic (Declaration)
Public Property Header As DataHeaderBand
Visual C++
public:
property DataHeaderBand^ Header {
    DataHeaderBand^ get ();
    void set (DataHeaderBand^ value);
}

See Also

GroupHeaderBand Class
FastReport Namespace


KeepTogether Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.KeepTogether Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets a value indicating that the group should be printed together on one page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean
Visual C++
public:
property bool KeepTogether {
    bool get ();
    void set (bool value);
}

See Also

GroupHeaderBand Class
FastReport Namespace


NestedGroup Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.NestedGroup Property
GroupHeaderBand Class Example See Also Send Feedback
Gets or sets a nested group.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupHeaderBand NestedGroup { get; set; }
Visual Basic (Declaration)
Public Property NestedGroup As GroupHeaderBand
Visual C++
public:
property GroupHeaderBand^ NestedGroup {
    GroupHeaderBand^ get ();
    void set (GroupHeaderBand^ value);
}

Remarks

Use this property to create nested groups.
Note: Only the last nested group can have data band.

Examples

This example demonstrates how to create a group with nested group.
CopyC#
ReportPage page;
GroupHeaderBand group = new GroupHeaderBand();
group.NestedGroup = new GroupHeaderBand();
group.NestedGroup.Data = new DataBand();
page.Bands.Add(group);

See Also

GroupHeaderBand Class
FastReport Namespace


ResetPageNumber Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.ResetPageNumber Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets a value that determines whether to reset the page numbers when this group starts print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ResetPageNumber { get; set; }
Visual Basic (Declaration)
Public Property ResetPageNumber As Boolean
Visual C++
public:
property bool ResetPageNumber {
    bool get ();
    void set (bool value);
}

Remarks

Typically you should set the StartNewPage property to true as well.

See Also

GroupHeaderBand Class
FastReport Namespace


SortOrder Property

[image]

FastReport.Net Class Reference
GroupHeaderBand..::.SortOrder Property
GroupHeaderBand Class See Also Send Feedback
Gets or sets the sort order.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SortOrder SortOrder { get; set; }
Visual Basic (Declaration)
Public Property SortOrder As SortOrder
Visual C++
public:
property SortOrder SortOrder {
    SortOrder get ();
    void set (SortOrder value);
}

Remarks

FastReport can sort data rows automatically using the Condition value.

See Also

GroupHeaderBand Class
FastReport Namespace


GroupHeaderBand Events

[image] [image]

FastReport.Net Class Reference
GroupHeaderBand Events
GroupHeaderBand Class See Also Send Feedback

The GroupHeaderBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

GroupHeaderBand Class
FastReport Namespace


HatchFill Class

[image]

FastReport.Net Class Reference
HatchFill Class
Members See Also Send Feedback
Class represents the hatch fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HatchFill : FillBase
Visual Basic (Declaration)
Public Class HatchFill _
    Inherits FillBase
Visual C++
public ref class HatchFill : public FillBase

Inheritance Hierarchy

System..::.Object
FastReport..::.FillBase
FastReport..::.HatchFill

See Also

HatchFill Members
FastReport Namespace


HatchFill Members

[image] [image]

FastReport.Net Class Reference
HatchFill Members
HatchFill Class Constructors Methods Properties See Also Send Feedback

The HatchFill type exposes the following members.

Constructors

Name | Description
HatchFill | Overloaded.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Inherited from FillBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackColor | Gets or sets the background color.
ForeColor | Gets or sets the foreground color.
Style | Gets or sets the hatch style.

See Also

HatchFill Class
FastReport Namespace


HatchFill Constructor

[image] [image]

FastReport.Net Class Reference
HatchFill Constructor
HatchFill Class See Also Send Feedback

Overload List

Name | Description
HatchFill()()() | Initializes the HatchFill class with default settings.
HatchFill(Color, Color, HatchStyle) | Initializes the HatchFill class with foreground, background colors and hatch style.

See Also

HatchFill Class
HatchFill Members
FastReport Namespace


HatchFill Constructor

[image]

FastReport.Net Class Reference
HatchFill Constructor
HatchFill Class See Also Send Feedback
Initializes the HatchFill class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HatchFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HatchFill()

See Also

HatchFill Class
HatchFill Overload
FastReport Namespace


HatchFill Constructor (Color, Color, HatchStyle)

[image]

FastReport.Net Class Reference
HatchFill Constructor (Color, Color, HatchStyle)
HatchFill Class See Also Send Feedback
Initializes the HatchFill class with foreground, background colors and hatch style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HatchFill(
    Color foreColor,
    Color backColor,
    HatchStyle style
)
Visual Basic (Declaration)
Public Sub New ( _
    foreColor As Color, _
    backColor As Color, _
    style As HatchStyle _
)
Visual C++
public:
HatchFill(
    Color foreColor,
    Color backColor,
    HatchStyle style
)

Parameters

foreColor
Type: System.Drawing..::.Color
Foreground color.
backColor
Type: System.Drawing..::.Color
Background color.
style
Type: System.Drawing.Drawing2D..::.HatchStyle
Hatch style.

See Also

HatchFill Class
HatchFill Overload
FastReport Namespace


HatchFill Methods

[image] [image]

FastReport.Net Class Reference
HatchFill Methods
HatchFill Class See Also Send Feedback

The HatchFill type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Inherited from FillBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HatchFill Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
HatchFill..::.Clone Method
HatchFill Class See Also Send Feedback
Creates exact copy of this fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FillBase
Visual C++
public:
virtual FillBase^ Clone() override

Return Value

Copy of this object.

See Also

HatchFill Class
FastReport Namespace


CreateBrush Method

[image]

FastReport.Net Class Reference
HatchFill..::.CreateBrush Method
HatchFill Class See Also Send Feedback
Creates the GDI+ Brush object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Brush CreateBrush(
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As RectangleF _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    RectangleF rect
) override

Parameters

rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

Return Value

Brush object.

See Also

HatchFill Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
HatchFill..::.Equals Method
HatchFill Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

HatchFill Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
HatchFill..::.GetHashCode Method
HatchFill Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

HatchFill Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
HatchFill..::.Serialize Method
HatchFill Class See Also Send Feedback
Serializes the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer,
    string prefix,
    FillBase fill
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    fill As FillBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    FillBase^ fill
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Name of the fill property.
fill
Type: FastReport..::.FillBase
Fill object to compare with.

Remarks

This method is for internal use only.

See Also

HatchFill Class
FastReport Namespace


HatchFill Properties

[image] [image]

FastReport.Net Class Reference
HatchFill Properties
HatchFill Class See Also Send Feedback

The HatchFill type exposes the following members.

Properties

Name | Description
BackColor | Gets or sets the background color.
ForeColor | Gets or sets the foreground color.
Style | Gets or sets the hatch style.

See Also

HatchFill Class
FastReport Namespace


BackColor Property

[image]

FastReport.Net Class Reference
HatchFill..::.BackColor Property
HatchFill Class See Also Send Feedback
Gets or sets the background color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

HatchFill Class
FastReport Namespace


ForeColor Property

[image]

FastReport.Net Class Reference
HatchFill..::.ForeColor Property
HatchFill Class See Also Send Feedback
Gets or sets the foreground color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Property ForeColor As Color
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

HatchFill Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
HatchFill..::.Style Property
HatchFill Class See Also Send Feedback
Gets or sets the hatch style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HatchStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As HatchStyle
Visual C++
public:
property HatchStyle Style {
    HatchStyle get ();
    void set (HatchStyle value);
}

See Also

HatchFill Class
FastReport Namespace


HeaderFooterBandBase Class

[image]

FastReport.Net Class Reference
HeaderFooterBandBase Class
Members See Also Send Feedback
Base class for headers and footers which support the "Keep With Data" and "Repeat on Every Page" features.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HeaderFooterBandBase : BandBase
Visual Basic (Declaration)
Public Class HeaderFooterBandBase _
    Inherits BandBase
Visual C++
public ref class HeaderFooterBandBase : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.HeaderFooterBandBase
FastReport..::.DataFooterBand
FastReport..::.DataHeaderBand
FastReport..::.GroupFooterBand
FastReport..::.GroupHeaderBand
FastReport..::.ReportSummaryBand

See Also

HeaderFooterBandBase Members
FastReport Namespace


HeaderFooterBandBase Members

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase Members
HeaderFooterBandBase Class Constructors Methods Properties Events See Also Send Feedback

The HeaderFooterBandBase type exposes the following members.

Constructors

Name | Description
HeaderFooterBandBase | Initializes a new instance of the HeaderFooterBandBase class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides BandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

HeaderFooterBandBase Class
FastReport Namespace


HeaderFooterBandBase Constructor

[image]

FastReport.Net Class Reference
HeaderFooterBandBase Constructor
HeaderFooterBandBase Class See Also Send Feedback
Initializes a new instance of the HeaderFooterBandBase class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HeaderFooterBandBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HeaderFooterBandBase()

See Also

HeaderFooterBandBase Class
FastReport Namespace


HeaderFooterBandBase Methods

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase Methods
HeaderFooterBandBase Class See Also Send Feedback

The HeaderFooterBandBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BandBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides BandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BandBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

HeaderFooterBandBase Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.Assign Method
HeaderFooterBandBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

HeaderFooterBandBase Class
FastReport Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.Dispose Method
HeaderFooterBandBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

HeaderFooterBandBase Class
HeaderFooterBandBase Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.DrawMarkers Method
HeaderFooterBandBase Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

HeaderFooterBandBase Class
HeaderFooterBandBase Members
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.GetContextMenu Method
HeaderFooterBandBase Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

HeaderFooterBandBase Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.MemberwiseClone Method
HeaderFooterBandBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

HeaderFooterBandBase Class
HeaderFooterBandBase Members
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.Serialize Method
HeaderFooterBandBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

HeaderFooterBandBase Class
FastReport Namespace


HeaderFooterBandBase Properties

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase Properties
HeaderFooterBandBase Class See Also Send Feedback

The HeaderFooterBandBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | Gets or sets a value that determines whether to repeat this band on every page.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

HeaderFooterBandBase Class
FastReport Namespace


KeepWithData Property

[image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.KeepWithData Property
HeaderFooterBandBase Class See Also Send Feedback
Gets or sets a value indicating that the band should be printed together with data band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool KeepWithData { get; set; }
Visual Basic (Declaration)
Public Property KeepWithData As Boolean
Visual C++
public:
property bool KeepWithData {
    bool get ();
    void set (bool value);
}

See Also

HeaderFooterBandBase Class
FastReport Namespace


RepeatOnEveryPage Property

[image]

FastReport.Net Class Reference
HeaderFooterBandBase..::.RepeatOnEveryPage Property
HeaderFooterBandBase Class See Also Send Feedback
Gets or sets a value that determines whether to repeat this band on every page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool RepeatOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property RepeatOnEveryPage As Boolean
Visual C++
public:
property bool RepeatOnEveryPage {
    bool get ();
    void set (bool value);
}

Remarks

When band is repeated, its Repeated property is set to true. You can use it to show any additional information on the band. To do this, use the PrintOn property which can be set to "Rpeeated". In that case the object will be printed only on the repeated band.

See Also

HeaderFooterBandBase Class
FastReport Namespace


HeaderFooterBandBase Events

[image] [image]

FastReport.Net Class Reference
HeaderFooterBandBase Events
HeaderFooterBandBase Class See Also Send Feedback

The HeaderFooterBandBase type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

HeaderFooterBandBase Class
FastReport Namespace


HighlightCondition Class

[image]

FastReport.Net Class Reference
HighlightCondition Class
Members See Also Send Feedback
Represents a single highlight condition used by the Highlight property of the TextObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HighlightCondition : StyleBase
Visual Basic (Declaration)
Public Class HighlightCondition _
    Inherits StyleBase
Visual C++
public ref class HighlightCondition : public StyleBase

Inheritance Hierarchy

System..::.Object
FastReport..::.StyleBase
FastReport..::.HighlightCondition

See Also

HighlightCondition Members
FastReport Namespace


HighlightCondition Members

[image] [image]

FastReport.Net Class Reference
HighlightCondition Members
HighlightCondition Class Constructors Methods Properties See Also Send Feedback

The HighlightCondition type exposes the following members.

Constructors

Name | Description
HighlightCondition | Initializes a new instance of the HighlightCondition class with default settings.

Methods

Name | Description
Assign | Assigns values from another source. (Overrides StyleBase..::.Assign(StyleBase).)
Clone | Creates exact copy of this condition.
Deserialize | Deserializes the style. (Inherited from StyleBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the style. (Overrides StyleBase..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplyBorder | Gets or sets a value determines that the border must be applied. (Inherited from StyleBase.)
ApplyFill | Gets or sets a value determines that the fill must be applied. (Inherited from StyleBase.)
ApplyFont | Gets or sets a value determines that the font must be applied. (Inherited from StyleBase.)
ApplyTextFill | Gets or sets a value determines that the text fill must be applied. (Inherited from StyleBase.)
Border | Gets or sets a border. (Inherited from StyleBase.)
Expression | Gets or sets a highlight expression.
Fill | Gets or sets a fill. (Inherited from StyleBase.)
Font | Gets or sets a font. (Inherited from StyleBase.)
TextFill | Gets or sets a text fill. (Inherited from StyleBase.)
Visible | Gets or sets the visibility flag.

See Also

HighlightCondition Class
FastReport Namespace


HighlightCondition Constructor

[image]

FastReport.Net Class Reference
HighlightCondition Constructor
HighlightCondition Class See Also Send Feedback
Initializes a new instance of the HighlightCondition class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HighlightCondition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HighlightCondition()

See Also

HighlightCondition Class
FastReport Namespace


HighlightCondition Methods

[image] [image]

FastReport.Net Class Reference
HighlightCondition Methods
HighlightCondition Class See Also Send Feedback

The HighlightCondition type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source. (Overrides StyleBase..::.Assign(StyleBase).)
Clone | Creates exact copy of this condition.
Deserialize | Deserializes the style. (Inherited from StyleBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the style. (Overrides StyleBase..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HighlightCondition Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
HighlightCondition..::.Assign Method
HighlightCondition Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    StyleBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As StyleBase _
)
Visual C++
public:
virtual void Assign(
    StyleBase^ source
) override

Parameters

source
Type: FastReport..::.StyleBase
Source to assign from.

See Also

HighlightCondition Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
HighlightCondition..::.Clone Method
HighlightCondition Class See Also Send Feedback
Creates exact copy of this condition.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HighlightCondition Clone()
Visual Basic (Declaration)
Public Function Clone As HighlightCondition
Visual C++
public:
HighlightCondition^ Clone()

Return Value

A copy of this condition.

See Also

HighlightCondition Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
HighlightCondition..::.Equals Method
HighlightCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

HighlightCondition Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
HighlightCondition..::.GetHashCode Method
HighlightCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

HighlightCondition Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
HighlightCondition..::.Serialize Method
HighlightCondition Class See Also Send Feedback
Serializes the style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

This method is for internal use only.

See Also

HighlightCondition Class
FastReport Namespace


HighlightCondition Properties

[image] [image]

FastReport.Net Class Reference
HighlightCondition Properties
HighlightCondition Class See Also Send Feedback

The HighlightCondition type exposes the following members.

Properties

Name | Description
ApplyBorder | Gets or sets a value determines that the border must be applied. (Inherited from StyleBase.)
ApplyFill | Gets or sets a value determines that the fill must be applied. (Inherited from StyleBase.)
ApplyFont | Gets or sets a value determines that the font must be applied. (Inherited from StyleBase.)
ApplyTextFill | Gets or sets a value determines that the text fill must be applied. (Inherited from StyleBase.)
Border | Gets or sets a border. (Inherited from StyleBase.)
Expression | Gets or sets a highlight expression.
Fill | Gets or sets a fill. (Inherited from StyleBase.)
Font | Gets or sets a font. (Inherited from StyleBase.)
TextFill | Gets or sets a text fill. (Inherited from StyleBase.)
Visible | Gets or sets the visibility flag.

See Also

HighlightCondition Class
FastReport Namespace


Expression Property

[image]

FastReport.Net Class Reference
HighlightCondition..::.Expression Property
HighlightCondition Class See Also Send Feedback
Gets or sets a highlight expression.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

This property can contain any valid boolean expression. If value of this expression is true, the fill and font settings will be applied to the TextObject.

See Also

HighlightCondition Class
FastReport Namespace


Visible Property

[image]

FastReport.Net Class Reference
HighlightCondition..::.Visible Property
HighlightCondition Class See Also Send Feedback
Gets or sets the visibility flag.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

If this property is set to false, the Text object will be hidden if the condition is met.

See Also

HighlightCondition Class
FastReport Namespace


HorzAlign Enumeration

[image]

FastReport.Net Class Reference
HorzAlign Enumeration
See Also Send Feedback
Specifies the horizontal alignment of a text in the TextObject object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum HorzAlign
Visual Basic (Declaration)
Public Enumeration HorzAlign
Visual C++
public enum class HorzAlign

Members

Member name | Description
Left | Specifies that text is aligned in the left of the layout rectangle.
Center | Specifies that text is aligned in the center of the layout rectangle.
Right | Specifies that text is aligned in the right of the layout rectangle.
Justify | Specifies that text is aligned in the left and right sides of the layout rectangle.

See Also

FastReport Namespace


Hyperlink Class

[image]

FastReport.Net Class Reference
Hyperlink Class
Members See Also Send Feedback
This class contains a hyperlink settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Hyperlink
Visual Basic (Declaration)
Public Class Hyperlink
Visual C++
public ref class Hyperlink

Inheritance Hierarchy

System..::.Object
FastReport..::.Hyperlink

See Also

Hyperlink Members
FastReport Namespace


Hyperlink Members

[image] [image]

FastReport.Net Class Reference
Hyperlink Members
Hyperlink Class Methods Properties See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DetailPageName | Gets or sets the name of this report's page.
DetailReportName | Gets or sets an external report file name.
Expression | Gets or sets the expression which value will be used for navigation.
Kind | Gets or sets the kind of hyperlink.
ReportParameter | Gets or sets a parameter's name that will be set to hyperlink's value.
Value | Gets or sets a value that will be used for navigation.
ValuesSeparator | Gets or sets a string that will be used as a separator to pass several values to the external report parameters.

See Also

Hyperlink Class
FastReport Namespace


Hyperlink Methods

[image] [image]

FastReport.Net Class Reference
Hyperlink Methods
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Hyperlink Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
Hyperlink..::.Assign Method
Hyperlink Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    Hyperlink source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As Hyperlink _
)
Visual C++
public:
void Assign(
    Hyperlink^ source
)

Parameters

source
Type: FastReport..::.Hyperlink
Source to assign from.

See Also

Hyperlink Class
FastReport Namespace


Hyperlink Properties

[image] [image]

FastReport.Net Class Reference
Hyperlink Properties
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Properties

Name | Description
DetailPageName | Gets or sets the name of this report's page.
DetailReportName | Gets or sets an external report file name.
Expression | Gets or sets the expression which value will be used for navigation.
Kind | Gets or sets the kind of hyperlink.
ReportParameter | Gets or sets a parameter's name that will be set to hyperlink's value.
Value | Gets or sets a value that will be used for navigation.
ValuesSeparator | Gets or sets a string that will be used as a separator to pass several values to the external report parameters.

See Also

Hyperlink Class
FastReport Namespace


DetailPageName Property

[image]

FastReport.Net Class Reference
Hyperlink..::.DetailPageName Property
Hyperlink Class See Also Send Feedback
Gets or sets the name of this report's page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DetailPageName { get; set; }
Visual Basic (Declaration)
Public Property DetailPageName As String
Visual C++
public:
property String^ DetailPageName {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property if Kind is set to DetailPage.

When you follow the hyperlink, the specified page will be executed. It may contain the detailed report. You also may specify the report's parameter in the ReportParameter property.

See Also

Hyperlink Class
FastReport Namespace


DetailReportName Property

[image]

FastReport.Net Class Reference
Hyperlink..::.DetailReportName Property
Hyperlink Class See Also Send Feedback
Gets or sets an external report file name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DetailReportName { get; set; }
Visual Basic (Declaration)
Public Property DetailReportName As String
Visual C++
public:
property String^ DetailReportName {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property if Kind is set to DetailReport.

When you follow the hyperlink, this report will be loaded and run. You also may specify the report's parameter in the ReportParameter property.

See Also

Hyperlink Class
FastReport Namespace


Expression Property

[image]

FastReport.Net Class Reference
Hyperlink..::.Expression Property
Hyperlink Class See Also Send Feedback
Gets or sets the expression which value will be used for navigation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

Normally you should set the Expression property to any valid expression that will be calculated when this object is about to print. The value of an expression will be used for navigation.

If you want to navigate to some fixed data (URL or page number, for example), use the Value property instead.

See Also

Hyperlink Class
FastReport Namespace


Kind Property

[image]

FastReport.Net Class Reference
Hyperlink..::.Kind Property
Hyperlink Class See Also Send Feedback
Gets or sets the kind of hyperlink.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HyperlinkKind Kind { get; set; }
Visual Basic (Declaration)
Public Property Kind As HyperlinkKind
Visual C++
public:
property HyperlinkKind Kind {
    HyperlinkKind get ();
    void set (HyperlinkKind value);
}

Remarks

Use the Kind property to define hyperlink's behavior. The hyperlink may be used to navigate to the external url, the page number, the bookmark defined by other report object, the external report, the other page of this report, and custom hyperlink.

See Also

Hyperlink Class
FastReport Namespace


ReportParameter Property

[image]

FastReport.Net Class Reference
Hyperlink..::.ReportParameter Property
Hyperlink Class See Also Send Feedback
Gets or sets a parameter's name that will be set to hyperlink's value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportParameter { get; set; }
Visual Basic (Declaration)
Public Property ReportParameter As String
Visual C++
public:
property String^ ReportParameter {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property if Kind is set to DetailReport or DetailPage.

If you want to pass the hyperlink's value to the report's parameter, specify the parameter name in this property. This parameter will be set to the hyperlink's value before running a report. It may be used to display detailed information about clicked item.

It is also possible to pass multiple values to several parameters. If hyperlink's value contains separators (the separator string can be set in the ValuesSeparator property), it will be splitted to several values. That values will be passed to nested parameters of the ReportParameter (you should create nested parameters by youself). For example, you have the ReportParameter called "SelectedValue" which has two nested parameters: the first one is "Employee" and the second is "Category". The hyperlink's value is "Andrew Fuller;Beverages". It will be splitted to two values: "Andrew Fuller" and "Beverages". The first nested parameter of the ReportParameter that is "Employee" in our case will be set to "Andrew Fuller"; the second nested parameter ("Category") will be set to "Beverages".

Note: when you create a parameter in the detailed report, don't forget to set its DataType property. It is used to convert string values to actual data type.

See Also

Hyperlink Class
FastReport Namespace


Value Property

[image]

FastReport.Net Class Reference
Hyperlink..::.Value Property
Hyperlink Class See Also Send Feedback
Gets or sets a value that will be used for navigation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property to specify the fixed data (such as URL, page number etc). If you want to navigate to some dynamically calculated value, use the Expression property instead.

See Also

Hyperlink Class
FastReport Namespace


ValuesSeparator Property

[image]

FastReport.Net Class Reference
Hyperlink..::.ValuesSeparator Property
Hyperlink Class See Also Send Feedback
Gets or sets a string that will be used as a separator to pass several values to the external report parameters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ValuesSeparator { get; set; }
Visual Basic (Declaration)
Public Property ValuesSeparator As String
Visual C++
public:
property String^ ValuesSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

Hyperlink Class
FastReport Namespace


HyperlinkKind Enumeration

[image]

FastReport.Net Class Reference
HyperlinkKind Enumeration
See Also Send Feedback
Specifies the hyperlink type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum HyperlinkKind
Visual Basic (Declaration)
Public Enumeration HyperlinkKind
Visual C++
public enum class HyperlinkKind

Members

Member name | Description
URL | Specifies the hyperlink to external URL such as "http://www.fast-report.com", "mailto:" or any other system command.
PageNumber | Specifies hyperlink to a given page number.
Bookmark | Specifies hyperlink to a bookmark.
DetailReport | Specifies hyperlink to external report. This report will be run when you follow the hyperlink.
DetailPage | Specifies hyperlink to this report's page. The page will be run when you follow the hyperlink.
Custom | Specifies a custom hyperlink. No actions performed when you click it, you should handle it in the object's Click event handler.

See Also

FastReport Namespace


IFRSerializable Interface

[image]

FastReport.Net Class Reference
IFRSerializable Interface
Members See Also Send Feedback
Provides the serialize/deserialize functionality.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public interface IFRSerializable
Visual Basic (Declaration)
Public Interface IFRSerializable
Visual C++
public interface class IFRSerializable

See Also

IFRSerializable Members
FastReport Namespace


IFRSerializable Members

[image] [image]

FastReport.Net Class Reference
IFRSerializable Members
IFRSerializable Interface Methods See Also Send Feedback

The IFRSerializable type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the object.
Serialize | Serializes the object.

See Also

IFRSerializable Interface
FastReport Namespace


IFRSerializable Methods

[image] [image]

FastReport.Net Class Reference
IFRSerializable Methods
IFRSerializable Interface See Also Send Feedback

The IFRSerializable type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the object.
Serialize | Serializes the object.

See Also

IFRSerializable Interface
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
IFRSerializable..::.Deserialize Method
IFRSerializable Interface See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
void Deserialize(
    FRReader^ reader
)

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

See Also

IFRSerializable Interface
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
IFRSerializable..::.Serialize Method
IFRSerializable Interface See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
void Serialize(
    FRWriter^ writer
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

See Also

IFRSerializable Interface
FastReport Namespace


IHasEditor Interface

[image]

FastReport.Net Class Reference
IHasEditor Interface
Members See Also Send Feedback
Implements the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public interface IHasEditor
Visual Basic (Declaration)
Public Interface IHasEditor
Visual C++
public interface class IHasEditor

See Also

IHasEditor Members
FastReport Namespace


IHasEditor Members

[image] [image]

FastReport.Net Class Reference
IHasEditor Members
IHasEditor Interface Methods See Also Send Feedback

The IHasEditor type exposes the following members.

Methods

Name | Description
InvokeEditor | Invokes the object's editor.

See Also

IHasEditor Interface
FastReport Namespace


IHasEditor Methods

[image] [image]

FastReport.Net Class Reference
IHasEditor Methods
IHasEditor Interface See Also Send Feedback

The IHasEditor type exposes the following members.

Methods

Name | Description
InvokeEditor | Invokes the object's editor.

See Also

IHasEditor Interface
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
IHasEditor..::.InvokeEditor Method
IHasEditor Interface See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
bool InvokeEditor()
Visual Basic (Declaration)
Function InvokeEditor As Boolean
Visual C++
bool InvokeEditor()

Return Value

true if object was succesfully edited.

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

IHasEditor Interface
FastReport Namespace


InsertFrom Enumeration

[image]

FastReport.Net Class Reference
InsertFrom Enumeration
See Also Send Feedback
Specifies an origin where the new objects inserted from.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum InsertFrom
Visual Basic (Declaration)
Public Enumeration InsertFrom
Visual C++
public enum class InsertFrom

Members

Member name | Description
NewObject | Specifies that a new object was inserted from the "Objects" toolbar or "Insert" menu.
Dictionary | Specifies that a new object was dragged from the "Dictionary" window.
Clipboard | Specifies that a new object was pasted from the clipboard.

See Also

FastReport Namespace


IParent Interface

[image]

FastReport.Net Class Reference
IParent Interface
Members See Also Send Feedback
Implement this interface if your object can contain list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public interface IParent
Visual Basic (Declaration)
Public Interface IParent
Visual C++
public interface class IParent

See Also

IParent Members
FastReport Namespace


IParent Members

[image] [image]

FastReport.Net Class Reference
IParent Members
IParent Interface Methods See Also Send Feedback

The IParent type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
CanContain | Gets a value indicating that this object can contain the specified child object.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
RemoveChild | Removes a specified object from this object's childs.
SetChildOrder | Sets the z-order of the specified object.
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

IParent Interface
FastReport Namespace


IParent Methods

[image] [image]

FastReport.Net Class Reference
IParent Methods
IParent Interface See Also Send Feedback

The IParent type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
CanContain | Gets a value indicating that this object can contain the specified child object.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
RemoveChild | Removes a specified object from this object's childs.
SetChildOrder | Sets the z-order of the specified object.
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

IParent Interface
FastReport Namespace


AddChild Method

[image]

FastReport.Net Class Reference
IParent..::.AddChild Method
IParent Interface See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void AddChild(
    Base child
)
Visual Basic (Declaration)
Sub AddChild ( _
    child As Base _
)
Visual C++
void AddChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Object to add.

See Also

IParent Interface
FastReport Namespace


CanContain Method

[image]

FastReport.Net Class Reference
IParent..::.CanContain Method
IParent Interface See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
bool CanContain(
    Base child
)
Visual Basic (Declaration)
Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

See Also

IParent Interface
FastReport Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
IParent..::.GetChildObjects Method
IParent Interface See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

See Also

IParent Interface
FastReport Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
IParent..::.GetChildOrder Method
IParent Interface See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
int GetChildOrder(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

IParent Interface
FastReport Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
IParent..::.RemoveChild Method
IParent Interface See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Sub RemoveChild ( _
    child As Base _
)
Visual C++
void RemoveChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base

See Also

IParent Interface
FastReport Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
IParent..::.SetChildOrder Method
IParent Interface See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
void SetChildOrder(
    Base^ child,
    int order
)

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

IParent Interface
FastReport Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
IParent..::.UpdateLayout Method
IParent Interface See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
void UpdateLayout(
    float dx,
    float dy
)

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

IParent Interface
FastReport Namespace


ISearchable Interface

[image]

FastReport.Net Class Reference
ISearchable Interface
Members See Also Send Feedback
Provides the "search" functionality in the preview and designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public interface ISearchable
Visual Basic (Declaration)
Public Interface ISearchable
Visual C++
public interface class ISearchable

See Also

ISearchable Members
FastReport Namespace


ISearchable Members

[image] [image]

FastReport.Net Class Reference
ISearchable Members
ISearchable Interface Methods See Also Send Feedback

The ISearchable type exposes the following members.

Methods

Name | Description
DrawSearchHighlight | Draws the highlight to show the text found.
SearchText | Finds the specified text inside the object.

See Also

ISearchable Interface
FastReport Namespace


ISearchable Methods

[image] [image]

FastReport.Net Class Reference
ISearchable Methods
ISearchable Interface See Also Send Feedback

The ISearchable type exposes the following members.

Methods

Name | Description
DrawSearchHighlight | Draws the highlight to show the text found.
SearchText | Finds the specified text inside the object.

See Also

ISearchable Interface
FastReport Namespace


DrawSearchHighlight Method

[image]

FastReport.Net Class Reference
ISearchable..::.DrawSearchHighlight Method
ISearchable Interface See Also Send Feedback
Draws the highlight to show the text found.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void DrawSearchHighlight(
    FRPaintEventArgs e,
    CharacterRange range
)
Visual Basic (Declaration)
Sub DrawSearchHighlight ( _
    e As FRPaintEventArgs, _
    range As CharacterRange _
)
Visual C++
void DrawSearchHighlight(
    FRPaintEventArgs^ e,
    CharacterRange range
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
range
Type: System.Drawing..::.CharacterRange
Range of characters to highlight.

See Also

ISearchable Interface
FastReport Namespace


SearchText Method

[image]

FastReport.Net Class Reference
ISearchable..::.SearchText Method
ISearchable Interface See Also Send Feedback
Finds the specified text inside the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
CharacterRange[] SearchText(
    string text,
    bool matchCase,
    bool wholeWord
)
Visual Basic (Declaration)
Function SearchText ( _
    text As String, _
    matchCase As Boolean, _
    wholeWord As Boolean _
) As CharacterRange()
Visual C++
array<CharacterRange>^ SearchText(
    String^ text,
    bool matchCase,
    bool wholeWord
)

Parameters

text
Type: System..::.String
Text to find.
matchCase
Type: System..::.Boolean
true to perform case-sensitive search.
wholeWord
Type: System..::.Boolean
true to find whole words only.

Return Value

Array of character ranges that describes the occurences of text found; null if text not found.

See Also

ISearchable Interface
FastReport Namespace


Language Enumeration

[image]

FastReport.Net Class Reference
Language Enumeration
See Also Send Feedback
Specifies the language of the report's script.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum Language
Visual Basic (Declaration)
Public Enumeration Language
Visual C++
public enum class Language

Members

Member name | Description
CSharp | The C# language.
Vb | The VisualBasic.Net language.

See Also

FastReport Namespace


LinearGradientFill Class

[image]

FastReport.Net Class Reference
LinearGradientFill Class
Members See Also Send Feedback
Class represents the linear gradient fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LinearGradientFill : FillBase
Visual Basic (Declaration)
Public Class LinearGradientFill _
    Inherits FillBase
Visual C++
public ref class LinearGradientFill : public FillBase

Inheritance Hierarchy

System..::.Object
FastReport..::.FillBase
FastReport..::.LinearGradientFill

See Also

LinearGradientFill Members
FastReport Namespace


LinearGradientFill Members

[image] [image]

FastReport.Net Class Reference
LinearGradientFill Members
LinearGradientFill Class Constructors Methods Properties See Also Send Feedback

The LinearGradientFill type exposes the following members.

Constructors

Name | Description
LinearGradientFill | Overloaded.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Inherited from FillBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of the gradient.
Contrast | Gets or sets the gradient contrast.
EndColor | Gets or sets the end color of the gradient.
Focus | Gets or sets the focus point of the gradient.
StartColor | Gets or sets the start color of the gradient.

See Also

LinearGradientFill Class
FastReport Namespace


LinearGradientFill Constructor

[image] [image]

FastReport.Net Class Reference
LinearGradientFill Constructor
LinearGradientFill Class See Also Send Feedback

Overload List

Name | Description
LinearGradientFill()()() | Initializes the LinearGradientFill class with default settings.
LinearGradientFill(Color, Color) | Initializes the LinearGradientFill class with start and end colors.
LinearGradientFill(Color, Color, Int32) | Initializes the LinearGradientFill class with start, end colors and angle.
LinearGradientFill(Color, Color, Int32, Single, Single) | Initializes the LinearGradientFill class with start and end colors, angle, focus and contrast.

See Also

LinearGradientFill Class
LinearGradientFill Members
FastReport Namespace


LinearGradientFill Constructor

[image]

FastReport.Net Class Reference
LinearGradientFill Constructor
LinearGradientFill Class See Also Send Feedback
Initializes the LinearGradientFill class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LinearGradientFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearGradientFill()

See Also

LinearGradientFill Class
LinearGradientFill Overload
FastReport Namespace


LinearGradientFill Constructor (Color, Color)

[image]

FastReport.Net Class Reference
LinearGradientFill Constructor (Color, Color)
LinearGradientFill Class See Also Send Feedback
Initializes the LinearGradientFill class with start and end colors.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LinearGradientFill(
    Color startColor,
    Color endColor
)
Visual Basic (Declaration)
Public Sub New ( _
    startColor As Color, _
    endColor As Color _
)
Visual C++
public:
LinearGradientFill(
    Color startColor,
    Color endColor
)

Parameters

startColor
Type: System.Drawing..::.Color
Start color.
endColor
Type: System.Drawing..::.Color
End color.

See Also

LinearGradientFill Class
LinearGradientFill Overload
FastReport Namespace


LinearGradientFill Constructor (Color, Color, Int32)

[image]

FastReport.Net Class Reference
LinearGradientFill Constructor (Color, Color, Int32)
LinearGradientFill Class See Also Send Feedback
Initializes the LinearGradientFill class with start, end colors and angle.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LinearGradientFill(
    Color startColor,
    Color endColor,
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    startColor As Color, _
    endColor As Color, _
    angle As Integer _
)
Visual C++
public:
LinearGradientFill(
    Color startColor,
    Color endColor,
    int angle
)

Parameters

startColor
Type: System.Drawing..::.Color
Start color.
endColor
Type: System.Drawing..::.Color
End color.
angle
Type: System..::.Int32
Angle.

See Also

LinearGradientFill Class
LinearGradientFill Overload
FastReport Namespace


LinearGradientFill Constructor (Color, Color, Int32, Single, Single)

[image]

FastReport.Net Class Reference
LinearGradientFill Constructor (Color, Color, Int32, Single, Single)
LinearGradientFill Class See Also Send Feedback
Initializes the LinearGradientFill class with start and end colors, angle, focus and contrast.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LinearGradientFill(
    Color startColor,
    Color endColor,
    int angle,
    float focus,
    float contrast
)
Visual Basic (Declaration)
Public Sub New ( _
    startColor As Color, _
    endColor As Color, _
    angle As Integer, _
    focus As Single, _
    contrast As Single _
)
Visual C++
public:
LinearGradientFill(
    Color startColor,
    Color endColor,
    int angle,
    float focus,
    float contrast
)

Parameters

startColor
Type: System.Drawing..::.Color
Start color.
endColor
Type: System.Drawing..::.Color
End color.
angle
Type: System..::.Int32
Angle.
focus
Type: System..::.Single
Focus.
contrast
Type: System..::.Single
Contrast.

See Also

LinearGradientFill Class
LinearGradientFill Overload
FastReport Namespace


LinearGradientFill Methods

[image] [image]

FastReport.Net Class Reference
LinearGradientFill Methods
LinearGradientFill Class See Also Send Feedback

The LinearGradientFill type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Inherited from FillBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearGradientFill Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
LinearGradientFill..::.Clone Method
LinearGradientFill Class See Also Send Feedback
Creates exact copy of this fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FillBase
Visual C++
public:
virtual FillBase^ Clone() override

Return Value

Copy of this object.

See Also

LinearGradientFill Class
FastReport Namespace


CreateBrush Method

[image]

FastReport.Net Class Reference
LinearGradientFill..::.CreateBrush Method
LinearGradientFill Class See Also Send Feedback
Creates the GDI+ Brush object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Brush CreateBrush(
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As RectangleF _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    RectangleF rect
) override

Parameters

rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

Return Value

Brush object.

See Also

LinearGradientFill Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
LinearGradientFill..::.Equals Method
LinearGradientFill Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

LinearGradientFill Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
LinearGradientFill..::.GetHashCode Method
LinearGradientFill Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

LinearGradientFill Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
LinearGradientFill..::.Serialize Method
LinearGradientFill Class See Also Send Feedback
Serializes the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer,
    string prefix,
    FillBase fill
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    fill As FillBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    FillBase^ fill
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Name of the fill property.
fill
Type: FastReport..::.FillBase
Fill object to compare with.

Remarks

This method is for internal use only.

See Also

LinearGradientFill Class
FastReport Namespace


LinearGradientFill Properties

[image] [image]

FastReport.Net Class Reference
LinearGradientFill Properties
LinearGradientFill Class See Also Send Feedback

The LinearGradientFill type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of the gradient.
Contrast | Gets or sets the gradient contrast.
EndColor | Gets or sets the end color of the gradient.
Focus | Gets or sets the focus point of the gradient.
StartColor | Gets or sets the start color of the gradient.

See Also

LinearGradientFill Class
FastReport Namespace


Angle Property

[image]

FastReport.Net Class Reference
LinearGradientFill..::.Angle Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the angle of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

LinearGradientFill Class
FastReport Namespace


Contrast Property

[image]

FastReport.Net Class Reference
LinearGradientFill..::.Contrast Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the gradient contrast.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Contrast { get; set; }
Visual Basic (Declaration)
Public Property Contrast As Single
Visual C++
public:
property float Contrast {
    float get ();
    void set (float value);
}

Remarks

Value is a floating point value from 0 to 1.

See Also

LinearGradientFill Class
FastReport Namespace


EndColor Property

[image]

FastReport.Net Class Reference
LinearGradientFill..::.EndColor Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the end color of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color EndColor { get; set; }
Visual Basic (Declaration)
Public Property EndColor As Color
Visual C++
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}

See Also

LinearGradientFill Class
FastReport Namespace


Focus Property

[image]

FastReport.Net Class Reference
LinearGradientFill..::.Focus Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the focus point of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Focus { get; set; }
Visual Basic (Declaration)
Public Property Focus As Single
Visual C++
public:
property float Focus {
    float get ();
    void set (float value);
}

Remarks

Value is a floating point value from 0 to 1.

See Also

LinearGradientFill Class
FastReport Namespace


StartColor Property

[image]

FastReport.Net Class Reference
LinearGradientFill..::.StartColor Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the start color of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color StartColor { get; set; }
Visual Basic (Declaration)
Public Property StartColor As Color
Visual C++
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}

See Also

LinearGradientFill Class
FastReport Namespace


LineObject Class

[image]

FastReport.Net Class Reference
LineObject Class
Members See Also Send Feedback
Represents a line object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LineObject : ReportComponentBase
Visual Basic (Declaration)
Public Class LineObject _
    Inherits ReportComponentBase
Visual C++
public ref class LineObject : public ReportComponentBase

Remarks

Use the Border.Width, Border.Style and Border.Color properties to set the line width, style and color. Set the Diagonal property to true if you want to show a diagonal line.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.LineObject

See Also

LineObject Members
FastReport Namespace


LineObject Members

[image] [image]

FastReport.Net Class Reference
LineObject Members
LineObject Class Constructors Methods Properties Events See Also Send Feedback

The LineObject type exposes the following members.

Constructors

Name | Description
LineObject | Initializes a new instance of the LineObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Overrides ComponentBase..::.CheckNegativeSize(FRMouseEventArgs).)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Overrides ComponentBase..::.PointInObject(PointF).)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Diagonal | Gets or sets a value indicating that the line is diagonal.
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EndCap | Gets or sets the end cap settings.
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | This property is not relevant to this class. (Overrides ReportComponentBase..::.Fill.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartCap | Gets or sets the start cap settings.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

LineObject Class
FastReport Namespace


LineObject Constructor

[image]

FastReport.Net Class Reference
LineObject Constructor
LineObject Class See Also Send Feedback
Initializes a new instance of the LineObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LineObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineObject()

See Also

LineObject Class
FastReport Namespace


LineObject Methods

[image] [image]

FastReport.Net Class Reference
LineObject Methods
LineObject Class See Also Send Feedback

The LineObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Overrides ComponentBase..::.CheckNegativeSize(FRMouseEventArgs).)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Overrides ComponentBase..::.PointInObject(PointF).)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

LineObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
LineObject..::.Assign Method
LineObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

LineObject Class
FastReport Namespace
AssignAll Method


CheckNegativeSize Method

[image]

FastReport.Net Class Reference
LineObject..::.CheckNegativeSize Method
LineObject Class See Also Send Feedback
Corrects the object's size and sizing point if the size becomes negative.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void CheckNegativeSize(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub CheckNegativeSize ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void CheckNegativeSize(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

See Also

LineObject Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
LineObject..::.Dispose Method
LineObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

LineObject Class
LineObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
LineObject..::.Draw Method
LineObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

LineObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
LineObject..::.DrawMarkers Method
LineObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

LineObject Class
LineObject Members
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
LineObject..::.GetPreferredSize Method
LineObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

LineObject Class
FastReport Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
LineObject..::.GetSelectionPoints Method
LineObject Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

LineObject Class
FastReport Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
LineObject..::.HandleMouseMove Method
LineObject Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

LineObject Class
FastReport Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
LineObject..::.HandleMouseUp Method
LineObject Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

LineObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
LineObject..::.MemberwiseClone Method
LineObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

LineObject Class
LineObject Members
FastReport Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
LineObject..::.OnBeforeInsert Method
LineObject Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

LineObject Class
FastReport Namespace


PointInObject Method

[image]

FastReport.Net Class Reference
LineObject..::.PointInObject Method
LineObject Class See Also Send Feedback
Checks if given point is inside the object's bounds.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool PointInObject(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function PointInObject ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool PointInObject(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF
point to check.

Return Value

true if point is inside the object's bounds.

Remarks

You can override this method if your objectis not of rectangular form.

See Also

LineObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
LineObject..::.Serialize Method
LineObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

LineObject Class
FastReport Namespace


LineObject Properties

[image] [image]

FastReport.Net Class Reference
LineObject Properties
LineObject Class See Also Send Feedback

The LineObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Diagonal | Gets or sets a value indicating that the line is diagonal.
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EndCap | Gets or sets the end cap settings.
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | This property is not relevant to this class. (Overrides ReportComponentBase..::.Fill.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartCap | Gets or sets the start cap settings.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

LineObject Class
FastReport Namespace


Diagonal Property

[image]

FastReport.Net Class Reference
LineObject..::.Diagonal Property
LineObject Class See Also Send Feedback
Gets or sets a value indicating that the line is diagonal.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Diagonal { get; set; }
Visual Basic (Declaration)
Public Property Diagonal As Boolean
Visual C++
public:
property bool Diagonal {
    bool get ();
    void set (bool value);
}

Remarks

If this property is false, the line can be only horizontal or vertical.

See Also

LineObject Class
FastReport Namespace


EndCap Property

[image]

FastReport.Net Class Reference
LineObject..::.EndCap Property
LineObject Class See Also Send Feedback
Gets or sets the end cap settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CapSettings EndCap { get; set; }
Visual Basic (Declaration)
Public Property EndCap As CapSettings
Visual C++
public:
property CapSettings^ EndCap {
    CapSettings^ get ();
    void set (CapSettings^ value);
}

See Also

LineObject Class
FastReport Namespace


Fill Property

[image]

FastReport.Net Class Reference
LineObject..::.Fill Property
LineObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Overrides Property Fill As FillBase
Visual C++
public:
virtual property FillBase^ Fill {
    FillBase^ get () override;
    void set (FillBase^ value) override;
}

See Also

LineObject Class
FastReport Namespace


StartCap Property

[image]

FastReport.Net Class Reference
LineObject..::.StartCap Property
LineObject Class See Also Send Feedback
Gets or sets the start cap settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CapSettings StartCap { get; set; }
Visual Basic (Declaration)
Public Property StartCap As CapSettings
Visual C++
public:
property CapSettings^ StartCap {
    CapSettings^ get ();
    void set (CapSettings^ value);
}

See Also

LineObject Class
FastReport Namespace


LineObject Events

[image] [image]

FastReport.Net Class Reference
LineObject Events
LineObject Class See Also Send Feedback

The LineObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

LineObject Class
FastReport Namespace


LineStyle Enumeration

[image]

FastReport.Net Class Reference
LineStyle Enumeration
See Also Send Feedback
Specifies the style of a border line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum LineStyle
Visual Basic (Declaration)
Public Enumeration LineStyle
Visual C++
public enum class LineStyle

Members

Member name | Description
Solid | Specifies a solid line.
Dash | Specifies a line consisting of dashes.
Dot | Specifies a line consisting of dots.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot.
Double | Specifies a double line.

See Also

FastReport Namespace


MarkerStyle Enumeration

[image]

FastReport.Net Class Reference
MarkerStyle Enumeration
See Also Send Feedback
The style of the report object markers.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum MarkerStyle
Visual Basic (Declaration)
Public Enumeration MarkerStyle
Visual C++
public enum class MarkerStyle

Members

Member name | Description
Rectangle | Rectangle marker.
Corners | Small markers at the object's corners.

See Also

FastReport Namespace


ObjectCollection Class

[image]

FastReport.Net Class Reference
ObjectCollection Class
Members See Also Send Feedback
Holds the list of objects of Base type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ObjectCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class ObjectCollection _
    Inherits FRCollectionBase
Visual C++
public ref class ObjectCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport..::.ObjectCollection
FastReport..::.SelectedObjectCollection

See Also

ObjectCollection Members
FastReport Namespace


ObjectCollection Members

[image] [image]

FastReport.Net Class Reference
ObjectCollection Members
ObjectCollection Class Constructors Methods Properties See Also Send Feedback

The ObjectCollection type exposes the following members.

Constructors

Name | Description
ObjectCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ObjectCollection Class
FastReport Namespace


ObjectCollection Constructor

[image] [image]

FastReport.Net Class Reference
ObjectCollection Constructor
ObjectCollection Class See Also Send Feedback

Overload List

Name | Description
ObjectCollection()()() | Initializes a new instance of the ObjectCollection class with default settings.
ObjectCollection(Base) | Initializes a new instance of the ObjectCollection class with specified owner.

See Also

ObjectCollection Class
ObjectCollection Members
FastReport Namespace


ObjectCollection Constructor

[image]

FastReport.Net Class Reference
ObjectCollection Constructor
ObjectCollection Class See Also Send Feedback
Initializes a new instance of the ObjectCollection class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ObjectCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectCollection()

See Also

ObjectCollection Class
ObjectCollection Overload
FastReport Namespace


ObjectCollection Constructor (Base)

[image]

FastReport.Net Class Reference
ObjectCollection Constructor (Base)
ObjectCollection Class See Also Send Feedback
Initializes a new instance of the ObjectCollection class with specified owner.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ObjectCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
ObjectCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base

See Also

ObjectCollection Class
ObjectCollection Overload
FastReport Namespace


ObjectCollection Methods

[image] [image]

FastReport.Net Class Reference
ObjectCollection Methods
ObjectCollection Class See Also Send Feedback

The ObjectCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectCollection Class
FastReport Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
ObjectCollection..::.AddRange Method
ObjectCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

ObjectCollection Class
ObjectCollection Members
FastReport Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
ObjectCollection..::.Equals Method
ObjectCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

ObjectCollection Class
ObjectCollection Members
FastReport Namespace


ObjectCollection Properties

[image] [image]

FastReport.Net Class Reference
ObjectCollection Properties
ObjectCollection Class See Also Send Feedback

The ObjectCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ObjectCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
ObjectCollection..::.Item Property
ObjectCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Base
Visual C++
public:
property Base^ default[int index] {
    Base^ get (int index);
    void set (int index, Base^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

ObjectCollection Class
FastReport Namespace


OverlayBand Class

[image]

FastReport.Net Class Reference
OverlayBand Class
Members See Also Send Feedback
Represents an overlay band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OverlayBand : BandBase
Visual Basic (Declaration)
Public Class OverlayBand _
    Inherits BandBase
Visual C++
public ref class OverlayBand : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.OverlayBand

See Also

OverlayBand Members
FastReport Namespace


OverlayBand Members

[image] [image]

FastReport.Net Class Reference
OverlayBand Members
OverlayBand Class Constructors Methods Properties Events See Also Send Feedback

The OverlayBand type exposes the following members.

Constructors

Name | Description
OverlayBand | Initializes a new instance of the OverlayBand class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

OverlayBand Class
FastReport Namespace


OverlayBand Constructor

[image]

FastReport.Net Class Reference
OverlayBand Constructor
OverlayBand Class See Also Send Feedback
Initializes a new instance of the OverlayBand class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OverlayBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OverlayBand()

See Also

OverlayBand Class
FastReport Namespace


OverlayBand Methods

[image] [image]

FastReport.Net Class Reference
OverlayBand Methods
OverlayBand Class See Also Send Feedback

The OverlayBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

OverlayBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
OverlayBand..::.Dispose Method
OverlayBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

OverlayBand Class
OverlayBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
OverlayBand..::.DrawMarkers Method
OverlayBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

OverlayBand Class
OverlayBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
OverlayBand..::.MemberwiseClone Method
OverlayBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OverlayBand Class
OverlayBand Members
FastReport Namespace


OverlayBand Properties

[image] [image]

FastReport.Net Class Reference
OverlayBand Properties
OverlayBand Class See Also Send Feedback

The OverlayBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

OverlayBand Class
FastReport Namespace


PrintOnBottom Property

[image]

FastReport.Net Class Reference
OverlayBand..::.PrintOnBottom Property
OverlayBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnBottom { get; set; }
Visual Basic (Declaration)
Public Property PrintOnBottom As Boolean
Visual C++
public:
property bool PrintOnBottom {
    bool get ();
    void set (bool value);
}

See Also

OverlayBand Class
FastReport Namespace


StartNewPage Property

[image]

FastReport.Net Class Reference
OverlayBand..::.StartNewPage Property
OverlayBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartNewPage { get; set; }
Visual Basic (Declaration)
Public Property StartNewPage As Boolean
Visual C++
public:
property bool StartNewPage {
    bool get ();
    void set (bool value);
}

See Also

OverlayBand Class
FastReport Namespace


OverlayBand Events

[image] [image]

FastReport.Net Class Reference
OverlayBand Events
OverlayBand Class See Also Send Feedback

The OverlayBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

OverlayBand Class
FastReport Namespace


PageBase Class

[image]

FastReport.Net Class Reference
PageBase Class
Members See Also Send Feedback
Base class for report pages and dialog forms.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class PageBase : ComponentBase
Visual Basic (Declaration)
Public MustInherit Class PageBase _
    Inherits ComponentBase
Visual C++
public ref class PageBase abstract : public ComponentBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.PageBase
FastReport.Dialog..::.DialogPage
FastReport..::.ReportPage

See Also

PageBase Members
FastReport Namespace


PageBase Members

[image] [image]

FastReport.Net Class Reference
PageBase Members
PageBase Class Constructors Methods Properties Events See Also Send Feedback

The PageBase type exposes the following members.

Constructors

Name | Description
PageBase | Initializes a new instance of the PageBase class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageDesignerType | Gets a page designer for this page type.
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
Modify | Modifies the page content and refresh it in the preview window.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
Refresh | Causes the page to refresh in the preview window.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ComponentBase.)
SetDefaults | This method is called by the designer when you create a new page.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SnapSize | Gets the snap size for this page.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageBase Class
FastReport Namespace


PageBase Constructor

[image]

FastReport.Net Class Reference
PageBase Constructor
PageBase Class See Also Send Feedback
Initializes a new instance of the PageBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageBase()

See Also

PageBase Class
FastReport Namespace


PageBase Methods

[image] [image]

FastReport.Net Class Reference
PageBase Methods
PageBase Class See Also Send Feedback

The PageBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageDesignerType | Gets a page designer for this page type.
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
Modify | Modifies the page content and refresh it in the preview window.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
Refresh | Causes the page to refresh in the preview window.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ComponentBase.)
SetDefaults | This method is called by the designer when you create a new page.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PageBase Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageBase..::.Dispose Method
PageBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageBase Class
PageBase Members
FastReport Namespace


GetPageDesignerType Method

[image]

FastReport.Net Class Reference
PageBase..::.GetPageDesignerType Method
PageBase Class See Also Send Feedback
Gets a page designer for this page type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract Type GetPageDesignerType()
Visual Basic (Declaration)
Public MustOverride Function GetPageDesignerType As Type
Visual C++
public:
virtual Type^ GetPageDesignerType() abstract

Return Value

The page designer.

See Also

PageBase Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageBase..::.MemberwiseClone Method
PageBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageBase Class
PageBase Members
FastReport Namespace


Modify Method

[image]

FastReport.Net Class Reference
PageBase..::.Modify Method
PageBase Class See Also Send Feedback
Modifies the page content and refresh it in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Modify()
Visual Basic (Declaration)
Public Sub Modify
Visual C++
public:
void Modify()

Remarks

Call this method when you handle object's Click, MouseDown or MouseUp events and want to modify an object and refresh the preview window.

See Also

PageBase Class
FastReport Namespace


Refresh Method

[image]

FastReport.Net Class Reference
PageBase..::.Refresh Method
PageBase Class See Also Send Feedback
Causes the page to refresh in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
void Refresh()

Remarks

Call this method when you handle object's MouseMove, MouseDown, MouseUp, MouseEnter, MouseLeave events and want to refresh the preview window.
Note: If you have changed some objects on a page, the Refresh method will not save the changes. This means when you print or export the page, you will see original (unmodified) page content. If you want to save the changes, you have to use the Modify()()() method instead.

See Also

PageBase Class
FastReport Namespace


SetDefaults Method

[image]

FastReport.Net Class Reference
PageBase..::.SetDefaults Method
PageBase Class See Also Send Feedback
This method is called by the designer when you create a new page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetDefaults()
Visual Basic (Declaration)
Public Overridable Sub SetDefaults
Visual C++
public:
virtual void SetDefaults()

Remarks

You may create the default page layout (add default bands, set default page size, etc).

See Also

PageBase Class
FastReport Namespace


PageBase Properties

[image] [image]

FastReport.Net Class Reference
PageBase Properties
PageBase Class See Also Send Feedback

The PageBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SnapSize | Gets the snap size for this page.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageBase Class
FastReport Namespace


Anchor Property

[image]

FastReport.Net Class Reference
PageBase..::.Anchor Property
PageBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overrides Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get () override;
    void set (AnchorStyles value) override;
}

See Also

PageBase Class
FastReport Namespace


Dock Property

[image]

FastReport.Net Class Reference
PageBase..::.Dock Property
PageBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get () override;
    void set (DockStyle value) override;
}

See Also

PageBase Class
FastReport Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
PageBase..::.Restrictions Property
PageBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

PageBase Class
FastReport Namespace


SnapSize Property

[image]

FastReport.Net Class Reference
PageBase..::.SnapSize Property
PageBase Class See Also Send Feedback
Gets the snap size for this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual SizeF SnapSize { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property SnapSize As SizeF
Visual C++
public:
virtual property SizeF SnapSize {
    SizeF get ();
}

See Also

PageBase Class
FastReport Namespace


PageBase Events

[image] [image]

FastReport.Net Class Reference
PageBase Events
PageBase Class See Also Send Feedback

The PageBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageBase Class
FastReport Namespace


PageCollection Class

[image]

FastReport.Net Class Reference
PageCollection Class
Members See Also Send Feedback
Holds the list of objects of PageBase type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class PageCollection _
    Inherits FRCollectionBase
Visual C++
public ref class PageCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport..::.PageCollection

See Also

PageCollection Members
FastReport Namespace


PageCollection Members

[image] [image]

FastReport.Net Class Reference
PageCollection Members
PageCollection Class Constructors Methods Properties See Also Send Feedback

The PageCollection type exposes the following members.

Constructors

Name | Description
PageCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

PageCollection Class
FastReport Namespace


PageCollection Constructor

[image] [image]

FastReport.Net Class Reference
PageCollection Constructor
PageCollection Class See Also Send Feedback

Overload List

Name | Description
PageCollection()()() | Initializes a new instance of the PageCollection class with default settings.
PageCollection(Base) | Initializes a new instance of the PageCollection class with specified owner.

See Also

PageCollection Class
PageCollection Members
FastReport Namespace


PageCollection Constructor

[image]

FastReport.Net Class Reference
PageCollection Constructor
PageCollection Class See Also Send Feedback
Initializes a new instance of the PageCollection class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageCollection()

See Also

PageCollection Class
PageCollection Overload
FastReport Namespace


PageCollection Constructor (Base)

[image]

FastReport.Net Class Reference
PageCollection Constructor (Base)
PageCollection Class See Also Send Feedback
Initializes a new instance of the PageCollection class with specified owner.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
PageCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base

See Also

PageCollection Class
PageCollection Overload
FastReport Namespace


PageCollection Methods

[image] [image]

FastReport.Net Class Reference
PageCollection Methods
PageCollection Class See Also Send Feedback

The PageCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageCollection Class
FastReport Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
PageCollection..::.AddRange Method
PageCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

PageCollection Class
PageCollection Members
FastReport Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
PageCollection..::.Equals Method
PageCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

PageCollection Class
PageCollection Members
FastReport Namespace


PageCollection Properties

[image] [image]

FastReport.Net Class Reference
PageCollection Properties
PageCollection Class See Also Send Feedback

The PageCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

PageCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
PageCollection..::.Item Property
PageCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As PageBase
Visual C++
public:
property PageBase^ default[int index] {
    PageBase^ get (int index);
    void set (int index, PageBase^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

PageCollection Class
FastReport Namespace


PageColumns Class

[image]

FastReport.Net Class Reference
PageColumns Class
Members See Also Send Feedback
This class contains the page columns settings. It is used in the Columns property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageColumns
Visual Basic (Declaration)
Public Class PageColumns
Visual C++
public ref class PageColumns

Inheritance Hierarchy

System..::.Object
FastReport..::.PageColumns

See Also

PageColumns Members
FastReport Namespace


PageColumns Members

[image] [image]

FastReport.Net Class Reference
PageColumns Members
PageColumns Class Methods Properties See Also Send Feedback

The PageColumns type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets or sets the number of columns.
Positions | Gets or sets a list of column starting positions.
Width | Gets or sets the column width.

See Also

PageColumns Class
FastReport Namespace


PageColumns Methods

[image] [image]

FastReport.Net Class Reference
PageColumns Methods
PageColumns Class See Also Send Feedback

The PageColumns type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageColumns Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
PageColumns..::.Assign Method
PageColumns Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    PageColumns source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As PageColumns _
)
Visual C++
public:
void Assign(
    PageColumns^ source
)

Parameters

source
Type: FastReport..::.PageColumns
Source to assign from.

See Also

PageColumns Class
FastReport Namespace


PageColumns Properties

[image] [image]

FastReport.Net Class Reference
PageColumns Properties
PageColumns Class See Also Send Feedback

The PageColumns type exposes the following members.

Properties

Name | Description
Count | Gets or sets the number of columns.
Positions | Gets or sets a list of column starting positions.
Width | Gets or sets the column width.

See Also

PageColumns Class
FastReport Namespace


Count Property

[image]

FastReport.Net Class Reference
PageColumns..::.Count Property
PageColumns Class See Also Send Feedback
Gets or sets the number of columns.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; set; }
Visual Basic (Declaration)
Public Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

Remarks

Set this property to 0 or 1 if you don't want to use columns.

See Also

PageColumns Class
FastReport Namespace


Positions Property

[image]

FastReport.Net Class Reference
PageColumns..::.Positions Property
PageColumns Class See Also Send Feedback
Gets or sets a list of column starting positions.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FloatCollection Positions { get; set; }
Visual Basic (Declaration)
Public Property Positions As FloatCollection
Visual C++
public:
property FloatCollection^ Positions {
    FloatCollection^ get ();
    void set (FloatCollection^ value);
}

Remarks

Each value represents a column starting position measured in the millimeters.

See Also

PageColumns Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
PageColumns..::.Width Property
PageColumns Class See Also Send Feedback
Gets or sets the column width.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

PageColumns Class
FastReport Namespace


PageFooterBand Class

[image]

FastReport.Net Class Reference
PageFooterBand Class
Members See Also Send Feedback
Represents a page footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageFooterBand : BandBase
Visual Basic (Declaration)
Public Class PageFooterBand _
    Inherits BandBase
Visual C++
public ref class PageFooterBand : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.PageFooterBand

See Also

PageFooterBand Members
FastReport Namespace


PageFooterBand Members

[image] [image]

FastReport.Net Class Reference
PageFooterBand Members
PageFooterBand Class Constructors Methods Properties Events See Also Send Feedback

The PageFooterBand type exposes the following members.

Constructors

Name | Description
PageFooterBand | Initializes a new instance of the PageFooterBand class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

PageFooterBand Class
FastReport Namespace


PageFooterBand Constructor

[image]

FastReport.Net Class Reference
PageFooterBand Constructor
PageFooterBand Class See Also Send Feedback
Initializes a new instance of the PageFooterBand class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageFooterBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageFooterBand()

See Also

PageFooterBand Class
FastReport Namespace


PageFooterBand Methods

[image] [image]

FastReport.Net Class Reference
PageFooterBand Methods
PageFooterBand Class See Also Send Feedback

The PageFooterBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

PageFooterBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageFooterBand..::.Dispose Method
PageFooterBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageFooterBand Class
PageFooterBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
PageFooterBand..::.DrawMarkers Method
PageFooterBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

PageFooterBand Class
PageFooterBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageFooterBand..::.MemberwiseClone Method
PageFooterBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageFooterBand Class
PageFooterBand Members
FastReport Namespace


PageFooterBand Properties

[image] [image]

FastReport.Net Class Reference
PageFooterBand Properties
PageFooterBand Class See Also Send Feedback

The PageFooterBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageFooterBand Class
FastReport Namespace


PrintOnBottom Property

[image]

FastReport.Net Class Reference
PageFooterBand..::.PrintOnBottom Property
PageFooterBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnBottom { get; set; }
Visual Basic (Declaration)
Public Property PrintOnBottom As Boolean
Visual C++
public:
property bool PrintOnBottom {
    bool get ();
    void set (bool value);
}

See Also

PageFooterBand Class
FastReport Namespace


StartNewPage Property

[image]

FastReport.Net Class Reference
PageFooterBand..::.StartNewPage Property
PageFooterBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartNewPage { get; set; }
Visual Basic (Declaration)
Public Property StartNewPage As Boolean
Visual C++
public:
property bool StartNewPage {
    bool get ();
    void set (bool value);
}

See Also

PageFooterBand Class
FastReport Namespace


PageFooterBand Events

[image] [image]

FastReport.Net Class Reference
PageFooterBand Events
PageFooterBand Class See Also Send Feedback

The PageFooterBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

PageFooterBand Class
FastReport Namespace


PageHeaderBand Class

[image]

FastReport.Net Class Reference
PageHeaderBand Class
Members See Also Send Feedback
Represents a page header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageHeaderBand : BandBase
Visual Basic (Declaration)
Public Class PageHeaderBand _
    Inherits BandBase
Visual C++
public ref class PageHeaderBand : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.PageHeaderBand

See Also

PageHeaderBand Members
FastReport Namespace


PageHeaderBand Members

[image] [image]

FastReport.Net Class Reference
PageHeaderBand Members
PageHeaderBand Class Constructors Methods Properties Events See Also Send Feedback

The PageHeaderBand type exposes the following members.

Constructors

Name | Description
PageHeaderBand | Initializes a new instance of the PageHeaderBand class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

PageHeaderBand Class
FastReport Namespace


PageHeaderBand Constructor

[image]

FastReport.Net Class Reference
PageHeaderBand Constructor
PageHeaderBand Class See Also Send Feedback
Initializes a new instance of the PageHeaderBand class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageHeaderBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageHeaderBand()

See Also

PageHeaderBand Class
FastReport Namespace


PageHeaderBand Methods

[image] [image]

FastReport.Net Class Reference
PageHeaderBand Methods
PageHeaderBand Class See Also Send Feedback

The PageHeaderBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

PageHeaderBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageHeaderBand..::.Dispose Method
PageHeaderBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageHeaderBand Class
PageHeaderBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
PageHeaderBand..::.DrawMarkers Method
PageHeaderBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

PageHeaderBand Class
PageHeaderBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageHeaderBand..::.MemberwiseClone Method
PageHeaderBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageHeaderBand Class
PageHeaderBand Members
FastReport Namespace


PageHeaderBand Properties

[image] [image]

FastReport.Net Class Reference
PageHeaderBand Properties
PageHeaderBand Class See Also Send Feedback

The PageHeaderBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | This property is not relevant to this class.
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | This property is not relevant to this class.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageHeaderBand Class
FastReport Namespace


PrintOnBottom Property

[image]

FastReport.Net Class Reference
PageHeaderBand..::.PrintOnBottom Property
PageHeaderBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnBottom { get; set; }
Visual Basic (Declaration)
Public Property PrintOnBottom As Boolean
Visual C++
public:
property bool PrintOnBottom {
    bool get ();
    void set (bool value);
}

See Also

PageHeaderBand Class
FastReport Namespace


StartNewPage Property

[image]

FastReport.Net Class Reference
PageHeaderBand..::.StartNewPage Property
PageHeaderBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartNewPage { get; set; }
Visual Basic (Declaration)
Public Property StartNewPage As Boolean
Visual C++
public:
property bool StartNewPage {
    bool get ();
    void set (bool value);
}

See Also

PageHeaderBand Class
FastReport Namespace


PageHeaderBand Events

[image] [image]

FastReport.Net Class Reference
PageHeaderBand Events
PageHeaderBand Class See Also Send Feedback

The PageHeaderBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

PageHeaderBand Class
FastReport Namespace


PageRange Enumeration

[image]

FastReport.Net Class Reference
PageRange Enumeration
See Also Send Feedback
Specifies the page range to print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PageRange
Visual Basic (Declaration)
Public Enumeration PageRange
Visual C++
public enum class PageRange

Members

Member name | Description
All | Print all pages.
Current | Print current page.
PageNumbers | Print pages specified in the PageNumbers property of the PrintSettings.

See Also

FastReport Namespace


PagesOnSheet Enumeration

[image]

FastReport.Net Class Reference
PagesOnSheet Enumeration
See Also Send Feedback
Specifies the number of report pages printed on one paper sheet.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PagesOnSheet
Visual Basic (Declaration)
Public Enumeration PagesOnSheet
Visual C++
public enum class PagesOnSheet

Members

Member name | Description
One | Specifies one report page per sheet.
Two | Specifies two report pages per sheet.
Four | Specifies four report pages per sheet.
Eight | Specifies eight report pages per sheet.

See Also

FastReport Namespace


PathGradientFill Class

[image]

FastReport.Net Class Reference
PathGradientFill Class
Members See Also Send Feedback
Class represents the path gradient fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PathGradientFill : FillBase
Visual Basic (Declaration)
Public Class PathGradientFill _
    Inherits FillBase
Visual C++
public ref class PathGradientFill : public FillBase

Inheritance Hierarchy

System..::.Object
FastReport..::.FillBase
FastReport..::.PathGradientFill

See Also

PathGradientFill Members
FastReport Namespace


PathGradientFill Members

[image] [image]

FastReport.Net Class Reference
PathGradientFill Members
PathGradientFill Class Constructors Methods Properties See Also Send Feedback

The PathGradientFill type exposes the following members.

Constructors

Name | Description
PathGradientFill | Overloaded.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Inherited from FillBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CenterColor | Gets or sets the center color of the gradient.
EdgeColor | Gets or sets the edge color of the gradient.
Style | Gets or sets the style of the gradient.

See Also

PathGradientFill Class
FastReport Namespace


PathGradientFill Constructor

[image] [image]

FastReport.Net Class Reference
PathGradientFill Constructor
PathGradientFill Class See Also Send Feedback

Overload List

Name | Description
PathGradientFill()()() | Initializes the PathGradientFill class with default settings.
PathGradientFill(Color, Color, PathGradientStyle) | Initializes the PathGradientFill class with center, edge colors and style.

See Also

PathGradientFill Class
PathGradientFill Members
FastReport Namespace


PathGradientFill Constructor

[image]

FastReport.Net Class Reference
PathGradientFill Constructor
PathGradientFill Class See Also Send Feedback
Initializes the PathGradientFill class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PathGradientFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PathGradientFill()

See Also

PathGradientFill Class
PathGradientFill Overload
FastReport Namespace


PathGradientFill Constructor (Color, Color, PathGradientStyle)

[image]

FastReport.Net Class Reference
PathGradientFill Constructor (Color, Color, PathGradientStyle)
PathGradientFill Class See Also Send Feedback
Initializes the PathGradientFill class with center, edge colors and style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PathGradientFill(
    Color centerColor,
    Color edgeColor,
    PathGradientStyle style
)
Visual Basic (Declaration)
Public Sub New ( _
    centerColor As Color, _
    edgeColor As Color, _
    style As PathGradientStyle _
)
Visual C++
public:
PathGradientFill(
    Color centerColor,
    Color edgeColor,
    PathGradientStyle style
)

Parameters

centerColor
Type: System.Drawing..::.Color
Center color.
edgeColor
Type: System.Drawing..::.Color
Edge color.
style
Type: FastReport..::.PathGradientStyle
Gradient style.

See Also

PathGradientFill Class
PathGradientFill Overload
FastReport Namespace


PathGradientFill Methods

[image] [image]

FastReport.Net Class Reference
PathGradientFill Methods
PathGradientFill Class See Also Send Feedback

The PathGradientFill type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Inherited from FillBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathGradientFill Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
PathGradientFill..::.Clone Method
PathGradientFill Class See Also Send Feedback
Creates exact copy of this fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FillBase
Visual C++
public:
virtual FillBase^ Clone() override

Return Value

Copy of this object.

See Also

PathGradientFill Class
FastReport Namespace


CreateBrush Method

[image]

FastReport.Net Class Reference
PathGradientFill..::.CreateBrush Method
PathGradientFill Class See Also Send Feedback
Creates the GDI+ Brush object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Brush CreateBrush(
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As RectangleF _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    RectangleF rect
) override

Parameters

rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

Return Value

Brush object.

See Also

PathGradientFill Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
PathGradientFill..::.Equals Method
PathGradientFill Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

PathGradientFill Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
PathGradientFill..::.GetHashCode Method
PathGradientFill Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

PathGradientFill Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
PathGradientFill..::.Serialize Method
PathGradientFill Class See Also Send Feedback
Serializes the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer,
    string prefix,
    FillBase fill
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    fill As FillBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    FillBase^ fill
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Name of the fill property.
fill
Type: FastReport..::.FillBase
Fill object to compare with.

Remarks

This method is for internal use only.

See Also

PathGradientFill Class
FastReport Namespace


PathGradientFill Properties

[image] [image]

FastReport.Net Class Reference
PathGradientFill Properties
PathGradientFill Class See Also Send Feedback

The PathGradientFill type exposes the following members.

Properties

Name | Description
CenterColor | Gets or sets the center color of the gradient.
EdgeColor | Gets or sets the edge color of the gradient.
Style | Gets or sets the style of the gradient.

See Also

PathGradientFill Class
FastReport Namespace


CenterColor Property

[image]

FastReport.Net Class Reference
PathGradientFill..::.CenterColor Property
PathGradientFill Class See Also Send Feedback
Gets or sets the center color of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color CenterColor { get; set; }
Visual Basic (Declaration)
Public Property CenterColor As Color
Visual C++
public:
property Color CenterColor {
    Color get ();
    void set (Color value);
}

See Also

PathGradientFill Class
FastReport Namespace


EdgeColor Property

[image]

FastReport.Net Class Reference
PathGradientFill..::.EdgeColor Property
PathGradientFill Class See Also Send Feedback
Gets or sets the edge color of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color EdgeColor { get; set; }
Visual Basic (Declaration)
Public Property EdgeColor As Color
Visual C++
public:
property Color EdgeColor {
    Color get ();
    void set (Color value);
}

See Also

PathGradientFill Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
PathGradientFill..::.Style Property
PathGradientFill Class See Also Send Feedback
Gets or sets the style of the gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PathGradientStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As PathGradientStyle
Visual C++
public:
property PathGradientStyle Style {
    PathGradientStyle get ();
    void set (PathGradientStyle value);
}

See Also

PathGradientFill Class
FastReport Namespace


PathGradientStyle Enumeration

[image]

FastReport.Net Class Reference
PathGradientStyle Enumeration
See Also Send Feedback
The style of the path gradient.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PathGradientStyle
Visual Basic (Declaration)
Public Enumeration PathGradientStyle
Visual C++
public enum class PathGradientStyle

Members

Member name | Description
Elliptic | Elliptic gradient.
Rectangular | Rectangular gradient.

See Also

FastReport Namespace


PictureObject Class

[image]

FastReport.Net Class Reference
PictureObject Class
Members See Also Send Feedback
Represents a Picture object that can display pictures.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PictureObject : ReportComponentBase,
    IHasEditor
Visual Basic (Declaration)
Public Class PictureObject _
    Inherits ReportComponentBase _
    Implements IHasEditor
Visual C++
public ref class PictureObject : public ReportComponentBase,
    IHasEditor

Remarks

The Picture object can display the following kind of pictures:
  • picture that is embedded in the report file. Use the Image property to do this;
  • picture that is stored in the database BLOb field. Use the DataColumn property to specify the name of data column you want to show;
  • picture that is stored in the local disk file. Use the ImageLocation property to specify the name of the file;
  • picture that is stored in the Web. Use the ImageLocation property to specify the picture's URL.

Use the SizeMode property to specify a size mode. The MaxWidth and MaxHeight properties can be used to restrict the image size if SizeMode is set to AutoSize.

The TransparentColor property can be used to display an image with transparent background. Use the Transparency property if you want to display semi-transparent image.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.PictureObject

See Also

PictureObject Members
FastReport Namespace


PictureObject Members

[image] [image]

FastReport.Net Class Reference
PictureObject Members
PictureObject Class Constructors Methods Properties Events See Also Send Feedback

The PictureObject type exposes the following members.

Constructors

Name | Description
PictureObject | Initializes a new instance of the PictureObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawImage | Draws the image.
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
ForceLoadImage | Forces loading the image from a data column.
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | Gets or sets the image rotation angle, in degrees. Possible values are 0, 90, 180, 270.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets the data column name to get the image from.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Overrides ReportComponentBase..::.Height.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
Image | Gets or sets the image.
ImageLocation | Gets or sets the path for the image to display in the PictureObject.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MaxHeight | Gets or sets the maximum height of a Picture object, in pixels.
MaxWidth | Gets or sets the maximum width of a Picture object, in pixels.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the PictureObject.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShouldDisposeImage | Gets or sets a value indicating that the image stored in the Image property should be disposed when this object is disposed.
ShowErrorImage | Gets or sets a value indicating whether the PictureObject should display the error indicator if there is no image in it.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SizeMode | Gets or sets a value that specifies how an image is positioned within a PictureObject.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Tile | Gets or sets a value indicating that the image should be tiled.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Transparency | Gets or sets the transparency of the PictureObject.
TransparentColor | Gets or sets the color of the image that will be treated as transparent.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

PictureObject Class
FastReport Namespace


PictureObject Constructor

[image]

FastReport.Net Class Reference
PictureObject Constructor
PictureObject Class See Also Send Feedback
Initializes a new instance of the PictureObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PictureObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureObject()

See Also

PictureObject Class
FastReport Namespace


PictureObject Methods

[image] [image]

FastReport.Net Class Reference
PictureObject Methods
PictureObject Class See Also Send Feedback

The PictureObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawImage | Draws the image.
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
ForceLoadImage | Forces loading the image from a data column.
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PictureObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
PictureObject..::.Assign Method
PictureObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

PictureObject Class
FastReport Namespace
AssignAll Method


Deserialize Method

[image]

FastReport.Net Class Reference
PictureObject..::.Deserialize Method
PictureObject Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

PictureObject Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PictureObject..::.Dispose Method
PictureObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

PictureObject Class
PictureObject Members
FastReport Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
PictureObject..::.Dispose Method (Boolean)
PictureObject Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

PictureObject Class
Dispose Overload
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
PictureObject..::.Draw Method
PictureObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

PictureObject Class
FastReport Namespace


DrawImage Method

[image]

FastReport.Net Class Reference
PictureObject..::.DrawImage Method
PictureObject Class See Also Send Feedback
Draws the image.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DrawImage(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
void DrawImage(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

See Also

PictureObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
PictureObject..::.DrawMarkers Method
PictureObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

PictureObject Class
PictureObject Members
FastReport Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
PictureObject..::.FinalizeComponent Method
PictureObject Class See Also Send Feedback
Performs a finalization after the report is finished.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FinalizeComponent()
Visual Basic (Declaration)
Public Overrides Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

PictureObject Class
FastReport Namespace


ForceLoadImage Method

[image]

FastReport.Net Class Reference
PictureObject..::.ForceLoadImage Method
PictureObject Class See Also Send Feedback
Forces loading the image from a data column.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ForceLoadImage()
Visual Basic (Declaration)
Public Sub ForceLoadImage
Visual C++
public:
void ForceLoadImage()

Remarks

Call this method in the AfterData event handler to force loading an image into the Image property. Normally, the image is stored internally as byte[] array and never loaded into the Image property, to save the time. The side effect is that you can't analyze the image properties such as width and height. If you need this, call this method before you access the Image property. Note that this will significantly slow down the report.

See Also

PictureObject Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
PictureObject..::.GetContextMenu Method
PictureObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

PictureObject Class
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
PictureObject..::.GetData Method
PictureObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

PictureObject Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
PictureObject..::.GetExpressions Method
PictureObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

PictureObject Class
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
PictureObject..::.GetPreferredSize Method
PictureObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

PictureObject Class
FastReport Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
PictureObject..::.GetSelectionPoints Method
PictureObject Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

PictureObject Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
PictureObject..::.GetSmartTag Method
PictureObject Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

PictureObject Class
FastReport Namespace


HandleDragDrop Method

[image]

FastReport.Net Class Reference
PictureObject..::.HandleDragDrop Method
PictureObject Class See Also Send Feedback
Handles the DragDrop event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragDrop(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragDrop ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragDrop(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drops an item from the Data Tree window into this object. This method should copy the information from the e.DraggedObject object and set the e.Handled flag to true to complete the drag operation.

See Also

PictureObject Class
FastReport Namespace


HandleDragOver Method

[image]

FastReport.Net Class Reference
PictureObject..::.HandleDragOver Method
PictureObject Class See Also Send Feedback
Handles the DragOver event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragOver(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragOver ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragOver(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drags an item from the Data Tree window. This method should check that the mouse (e.X, e.Y) is inside the object, then set the e.Handled flag to true if an item can be dragged into this object.

See Also

PictureObject Class
FastReport Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
PictureObject..::.InitializeComponent Method
PictureObject Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

PictureObject Class
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
PictureObject..::.InvokeEditor Method
PictureObject Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was edited succesfully.

Implements

IHasEditor..::.InvokeEditor()()()

See Also

PictureObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PictureObject..::.MemberwiseClone Method
PictureObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PictureObject Class
PictureObject Members
FastReport Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
PictureObject..::.RestoreState Method
PictureObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

PictureObject Class
FastReport Namespace


SaveState Method

[image]

FastReport.Net Class Reference
PictureObject..::.SaveState Method
PictureObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

PictureObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
PictureObject..::.Serialize Method
PictureObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

PictureObject Class
FastReport Namespace


PictureObject Properties

[image] [image]

FastReport.Net Class Reference
PictureObject Properties
PictureObject Class See Also Send Feedback

The PictureObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | Gets or sets the image rotation angle, in degrees. Possible values are 0, 90, 180, 270.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets the data column name to get the image from.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Overrides ReportComponentBase..::.Height.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
Image | Gets or sets the image.
ImageLocation | Gets or sets the path for the image to display in the PictureObject.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MaxHeight | Gets or sets the maximum height of a Picture object, in pixels.
MaxWidth | Gets or sets the maximum width of a Picture object, in pixels.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the PictureObject.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShouldDisposeImage | Gets or sets a value indicating that the image stored in the Image property should be disposed when this object is disposed.
ShowErrorImage | Gets or sets a value indicating whether the PictureObject should display the error indicator if there is no image in it.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SizeMode | Gets or sets a value that specifies how an image is positioned within a PictureObject.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Tile | Gets or sets a value indicating that the image should be tiled.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Transparency | Gets or sets the transparency of the PictureObject.
TransparentColor | Gets or sets the color of the image that will be treated as transparent.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PictureObject Class
FastReport Namespace


Angle Property

[image]

FastReport.Net Class Reference
PictureObject..::.Angle Property
PictureObject Class See Also Send Feedback
Gets or sets the image rotation angle, in degrees. Possible values are 0, 90, 180, 270.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

PictureObject Class
FastReport Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
PictureObject..::.DataColumn Property
PictureObject Class See Also Send Feedback
Gets or sets the data column name to get the image from.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

See Also

PictureObject Class
FastReport Namespace


Height Property

[image]

FastReport.Net Class Reference
PictureObject..::.Height Property
PictureObject Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

PictureObject Class
FastReport Namespace


Image Property

[image]

FastReport.Net Class Reference
PictureObject..::.Image Property
PictureObject Class See Also Send Feedback
Gets or sets the image.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

Remarks

By default, image that you assign to this property is never disposed - you should take care about it. If you want to dispose the image when this PictureObject is disposed, set the ShouldDisposeImage property to true right after you assign an image:
CopyC#
myPictureObject.Image = new Bitmap("file.bmp");
myPictureObject.ShouldDisposeImage = true;

See Also

PictureObject Class
FastReport Namespace


ImageLocation Property

[image]

FastReport.Net Class Reference
PictureObject..::.ImageLocation Property
PictureObject Class See Also Send Feedback
Gets or sets the path for the image to display in the PictureObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ImageLocation { get; set; }
Visual Basic (Declaration)
Public Property ImageLocation As String
Visual C++
public:
property String^ ImageLocation {
    String^ get ();
    void set (String^ value);
}

Remarks

This property may contain the path to the image file as well as external URL.

See Also

PictureObject Class
FastReport Namespace


MaxHeight Property

[image]

FastReport.Net Class Reference
PictureObject..::.MaxHeight Property
PictureObject Class See Also Send Feedback
Gets or sets the maximum height of a Picture object, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MaxHeight { get; set; }
Visual Basic (Declaration)
Public Property MaxHeight As Single
Visual C++
public:
property float MaxHeight {
    float get ();
    void set (float value);
}

Remarks

Use this property to restrict the object size if the SizeMode property is set to AutoSize.

See Also

PictureObject Class
FastReport Namespace


MaxWidth Property

[image]

FastReport.Net Class Reference
PictureObject..::.MaxWidth Property
PictureObject Class See Also Send Feedback
Gets or sets the maximum width of a Picture object, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MaxWidth { get; set; }
Visual Basic (Declaration)
Public Property MaxWidth As Single
Visual C++
public:
property float MaxWidth {
    float get ();
    void set (float value);
}

Remarks

Use this property to restrict the object size if the SizeMode property is set to AutoSize.

See Also

PictureObject Class
FastReport Namespace


Padding Property

[image]

FastReport.Net Class Reference
PictureObject..::.Padding Property
PictureObject Class See Also Send Feedback
Gets or sets padding within the PictureObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

PictureObject Class
FastReport Namespace


ShouldDisposeImage Property

[image]

FastReport.Net Class Reference
PictureObject..::.ShouldDisposeImage Property
PictureObject Class See Also Send Feedback
Gets or sets a value indicating that the image stored in the Image property should be disposed when this object is disposed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShouldDisposeImage { get; set; }
Visual Basic (Declaration)
Public Property ShouldDisposeImage As Boolean
Visual C++
public:
property bool ShouldDisposeImage {
    bool get ();
    void set (bool value);
}

Remarks

By default, image assigned to the Image property is never disposed - you should take care about it. If you want to dispose the image when this PictureObject is disposed, set this property to true right after you assign an image to the Image property.

See Also

PictureObject Class
FastReport Namespace


ShowErrorImage Property

[image]

FastReport.Net Class Reference
PictureObject..::.ShowErrorImage Property
PictureObject Class See Also Send Feedback
Gets or sets a value indicating whether the PictureObject should display the error indicator if there is no image in it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowErrorImage { get; set; }
Visual Basic (Declaration)
Public Property ShowErrorImage As Boolean
Visual C++
public:
property bool ShowErrorImage {
    bool get ();
    void set (bool value);
}

See Also

PictureObject Class
FastReport Namespace


SizeMode Property

[image]

FastReport.Net Class Reference
PictureObject..::.SizeMode Property
PictureObject Class See Also Send Feedback
Gets or sets a value that specifies how an image is positioned within a PictureObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PictureBoxSizeMode SizeMode { get; set; }
Visual Basic (Declaration)
Public Property SizeMode As PictureBoxSizeMode
Visual C++
public:
property PictureBoxSizeMode SizeMode {
    PictureBoxSizeMode get ();
    void set (PictureBoxSizeMode value);
}

See Also

PictureObject Class
FastReport Namespace


Tile Property

[image]

FastReport.Net Class Reference
PictureObject..::.Tile Property
PictureObject Class See Also Send Feedback
Gets or sets a value indicating that the image should be tiled.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Tile { get; set; }
Visual Basic (Declaration)
Public Property Tile As Boolean
Visual C++
public:
property bool Tile {
    bool get ();
    void set (bool value);
}

See Also

PictureObject Class
FastReport Namespace


Transparency Property

[image]

FastReport.Net Class Reference
PictureObject..::.Transparency Property
PictureObject Class See Also Send Feedback
Gets or sets the transparency of the PictureObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Transparency { get; set; }
Visual Basic (Declaration)
Public Property Transparency As Single
Visual C++
public:
property float Transparency {
    float get ();
    void set (float value);
}

Remarks

Valid range of values is 0..1. Default value is 0.

See Also

PictureObject Class
FastReport Namespace


TransparentColor Property

[image]

FastReport.Net Class Reference
PictureObject..::.TransparentColor Property
PictureObject Class See Also Send Feedback
Gets or sets the color of the image that will be treated as transparent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color TransparentColor { get; set; }
Visual Basic (Declaration)
Public Property TransparentColor As Color
Visual C++
public:
property Color TransparentColor {
    Color get ();
    void set (Color value);
}

See Also

PictureObject Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
PictureObject..::.Width Property
PictureObject Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

PictureObject Class
FastReport Namespace


PictureObject Events

[image] [image]

FastReport.Net Class Reference
PictureObject Events
PictureObject Class See Also Send Feedback

The PictureObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

PictureObject Class
FastReport Namespace


PreviewButtons Enumeration

[image]

FastReport.Net Class Reference
PreviewButtons Enumeration
See Also Send Feedback
Specifies the set of buttons available in the preview.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
[FlagsAttribute]
public enum PreviewButtons
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration PreviewButtons
Visual C++
[FlagsAttribute]
public enum class PreviewButtons

Members

Member name | Description
None | No buttons visible.
Print | The "Print" button is visible.
Open | The "Open" button is visible.
Save | The "Save" button is visible.
Email | The "Email" button is visible.
Find | The "Find" button is visible.
Zoom | The zoom buttons are visible.
Outline | The "Outline" button is visible.
PageSetup | The "Page setup" button is visible.
Edit | The "Edit" button is visible.
Watermark | The "Watermark" button is visible.
Navigator | The page navigator buttons are visible.
Close | The "Close" button is visible.
SaveToCloud | The "Save to Cloud" button is visible.
All | All buttons are visible.

See Also

FastReport Namespace


PreviewSettings Class

[image]

FastReport.Net Class Reference
PreviewSettings Class
Members See Also Send Feedback
Contains some settings of the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PreviewSettings
Visual Basic (Declaration)
Public Class PreviewSettings
Visual C++
public ref class PreviewSettings

Inheritance Hierarchy

System..::.Object
FastReport..::.PreviewSettings

See Also

PreviewSettings Members
FastReport Namespace


PreviewSettings Members

[image] [image]

FastReport.Net Class Reference
PreviewSettings Members
PreviewSettings Class Constructors Methods Properties Events See Also Send Feedback

The PreviewSettings type exposes the following members.

Constructors

Name | Description
PreviewSettings | Initializes a new instance of the PreviewSettings class with default settings.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPrintToFile | Enables or disables the "Print to file" feature in the print dialog.
Buttons | Gets or sets a set of buttons that will be visible in the preview's toolbar.
FastScrolling | Gets or sets a value indicating whether the fast scrolling method should be used.
Icon | Gets or sets the icon for the preview window.
PagesInCache | Gets or sets the number of prepared pages that can be stored in the memory cache during preview.
ShowInTaskbar | Gets or sets a value indicating whether the preview window is displayed in the Windows taskbar.
Text | Gets or sets the text for the preview window.
TopMost | Gets or sets a value indicating whether the preview window should be displayed as a topmost form.

Events

Name | Description
PreviewOpened | Occurs when the standard preview window opened.

See Also

PreviewSettings Class
FastReport Namespace


PreviewSettings Constructor

[image]

FastReport.Net Class Reference
PreviewSettings Constructor
PreviewSettings Class See Also Send Feedback
Initializes a new instance of the PreviewSettings class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PreviewSettings()

See Also

PreviewSettings Class
FastReport Namespace


PreviewSettings Methods

[image] [image]

FastReport.Net Class Reference
PreviewSettings Methods
PreviewSettings Class See Also Send Feedback

The PreviewSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewSettings Class
FastReport Namespace


PreviewSettings Properties

[image] [image]

FastReport.Net Class Reference
PreviewSettings Properties
PreviewSettings Class See Also Send Feedback

The PreviewSettings type exposes the following members.

Properties

Name | Description
AllowPrintToFile | Enables or disables the "Print to file" feature in the print dialog.
Buttons | Gets or sets a set of buttons that will be visible in the preview's toolbar.
FastScrolling | Gets or sets a value indicating whether the fast scrolling method should be used.
Icon | Gets or sets the icon for the preview window.
PagesInCache | Gets or sets the number of prepared pages that can be stored in the memory cache during preview.
ShowInTaskbar | Gets or sets a value indicating whether the preview window is displayed in the Windows taskbar.
Text | Gets or sets the text for the preview window.
TopMost | Gets or sets a value indicating whether the preview window should be displayed as a topmost form.

See Also

PreviewSettings Class
FastReport Namespace


AllowPrintToFile Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.AllowPrintToFile Property
PreviewSettings Class See Also Send Feedback
Enables or disables the "Print to file" feature in the print dialog.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowPrintToFile { get; set; }
Visual Basic (Declaration)
Public Property AllowPrintToFile As Boolean
Visual C++
public:
property bool AllowPrintToFile {
    bool get ();
    void set (bool value);
}

See Also

PreviewSettings Class
FastReport Namespace


Buttons Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.Buttons Property
PreviewSettings Class See Also Send Feedback
Gets or sets a set of buttons that will be visible in the preview's toolbar.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewButtons Buttons { get; set; }
Visual Basic (Declaration)
Public Property Buttons As PreviewButtons
Visual C++
public:
property PreviewButtons Buttons {
    PreviewButtons get ();
    void set (PreviewButtons value);
}

Remarks

Here is an example how you can disable the "Print" and "EMail" buttons: Config.PreviewSettings.Buttons = PreviewButtons.Open | PreviewButtons.Save | PreviewButtons.Find | PreviewButtons.Zoom | PreviewButtons.Outline | PreviewButtons.PageSetup | PreviewButtons.Edit | PreviewButtons.Watermark | PreviewButtons.Navigator | PreviewButtons.Close;

See Also

PreviewSettings Class
FastReport Namespace


FastScrolling Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.FastScrolling Property
PreviewSettings Class See Also Send Feedback
Gets or sets a value indicating whether the fast scrolling method should be used.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FastScrolling { get; set; }
Visual Basic (Declaration)
Public Property FastScrolling As Boolean
Visual C++
public:
property bool FastScrolling {
    bool get ();
    void set (bool value);
}

Remarks

If you enable this property, the gradient background will be disabled.

See Also

PreviewSettings Class
FastReport Namespace


Icon Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.Icon Property
PreviewSettings Class See Also Send Feedback
Gets or sets the icon for the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Icon Icon { get; set; }
Visual Basic (Declaration)
Public Property Icon As Icon
Visual C++
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}

See Also

PreviewSettings Class
FastReport Namespace


PagesInCache Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.PagesInCache Property
PreviewSettings Class See Also Send Feedback
Gets or sets the number of prepared pages that can be stored in the memory cache during preview.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PagesInCache { get; set; }
Visual Basic (Declaration)
Public Property PagesInCache As Integer
Visual C++
public:
property int PagesInCache {
    int get ();
    void set (int value);
}

Remarks

Decrease this value if your prepared report contains a lot of pictures. This will save the RAM memory.

See Also

PreviewSettings Class
FastReport Namespace


ShowInTaskbar Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.ShowInTaskbar Property
PreviewSettings Class See Also Send Feedback
Gets or sets a value indicating whether the preview window is displayed in the Windows taskbar.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowInTaskbar { get; set; }
Visual Basic (Declaration)
Public Property ShowInTaskbar As Boolean
Visual C++
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}

See Also

PreviewSettings Class
FastReport Namespace


Text Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.Text Property
PreviewSettings Class See Also Send Feedback
Gets or sets the text for the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

If no text is set, the default text "Preview" will be used.

See Also

PreviewSettings Class
FastReport Namespace


TopMost Property

[image]

FastReport.Net Class Reference
PreviewSettings..::.TopMost Property
PreviewSettings Class See Also Send Feedback
Gets or sets a value indicating whether the preview window should be displayed as a topmost form.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool TopMost { get; set; }
Visual Basic (Declaration)
Public Property TopMost As Boolean
Visual C++
public:
property bool TopMost {
    bool get ();
    void set (bool value);
}

See Also

PreviewSettings Class
FastReport Namespace


PreviewSettings Events

[image] [image]

FastReport.Net Class Reference
PreviewSettings Events
PreviewSettings Class See Also Send Feedback

The PreviewSettings type exposes the following members.

Events

Name | Description
PreviewOpened | Occurs when the standard preview window opened.

See Also

PreviewSettings Class
FastReport Namespace


PreviewOpened Event

[image]

FastReport.Net Class Reference
PreviewSettings..::.PreviewOpened Event
PreviewSettings Class See Also Send Feedback
Occurs when the standard preview window opened.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler PreviewOpened
Visual Basic (Declaration)
Public Event PreviewOpened As EventHandler
Visual C++
public:
 event EventHandler^ PreviewOpened {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

You may use this event to change the standard preview window, for example, add an own button to it. The sender parameter in this event is the PreviewControl.

See Also

PreviewSettings Class
FastReport Namespace


PrintMode Enumeration

[image]

FastReport.Net Class Reference
PrintMode Enumeration
See Also Send Feedback
Specifies the report printing mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PrintMode
Visual Basic (Declaration)
Public Enumeration PrintMode
Visual C++
public enum class PrintMode

Members

Member name | Description
Default | Specifies the default printing mode. One report page produces one printed paper sheet of the same size.
Split | Specifies the split mode. Big report page produces several smaller paper sheets. Use this mode to print A3 report on A4 printer.
Scale | Specifies the scale mode. One or several report pages produce one bigger paper sheet. Use this mode to print A5 report on A4 printer.

See Also

FastReport Namespace


PrintOn Enumeration

[image]

FastReport.Net Class Reference
PrintOn Enumeration
See Also Send Feedback
Specifies where to print an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
[FlagsAttribute]
public enum PrintOn
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration PrintOn
Visual C++
[FlagsAttribute]
public enum class PrintOn

Members

Member name | Description
None | Do not print the object.
FirstPage | Print the object on the first page. If this flag is not set, the object will not be printed on the first page.
LastPage | Print the object on the last page. If this flag is not set, the object will not be printed on the last page. You should set the report's double pass option to make it work correctly.
OddPages | Print the object on odd pages only.
EvenPages | Print the object on even pages only.
RepeatedBand | Print the object on band with "Repeat on Every Page" flag when that band is repeated.
SinglePage | Print the object if the report has single page only.

See Also

FastReport Namespace


PrintPages Enumeration

[image]

FastReport.Net Class Reference
PrintPages Enumeration
See Also Send Feedback
Specifies the pages to print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PrintPages
Visual Basic (Declaration)
Public Enumeration PrintPages
Visual C++
public enum class PrintPages

Members

Member name | Description
All | Print all report pages.
Odd | Print odd pages only.
Even | Print even pages only.

See Also

FastReport Namespace


PrintSettings Class

[image]

FastReport.Net Class Reference
PrintSettings Class
Members See Also Send Feedback
This class contains the printer settings. It is used in the PrintSettings property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PrintSettings : IDisposable
Visual Basic (Declaration)
Public Class PrintSettings _
    Implements IDisposable
Visual C++
public ref class PrintSettings : IDisposable

Remarks

Typical use of this class is to setup a printer properties without using the "Print" dialog. In this case, setup necessary properties and turn off the dialog via the ShowDialog property.

Inheritance Hierarchy

System..::.Object
FastReport..::.PrintSettings

See Also

PrintSettings Members
FastReport Namespace


PrintSettings Members

[image] [image]

FastReport.Net Class Reference
PrintSettings Members
PrintSettings Class Constructors Methods Properties See Also Send Feedback

The PrintSettings type exposes the following members.

Constructors

Name | Description
PrintSettings | Initializes a new instance of the PrintSettings class with default settings.

Methods

Name | Description
Assign | Assigns values from another source.
Clear | Resets all settings to its default values.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collate | Gets or sets a value indicating whether the printed document should be collated.
Copies | Gets or sets the number of copies to print.
CopyNames | Gets or sets an array of printed copy names, such as "Original", "Copy", etc.
Duplex | Gets or sets the duplex mode.
PageNumbers | Gets or sets the page number(s) to print.
PageRange | Gets or sets a value specifies the page range to print.
PagesOnSheet | Gets or sets the number of pages per printed sheet.
PaperSource | Gets or sets the paper source.
Printer | Gets or sets the printer name.
PrintMode | Gets or sets the print mode.
PrintOnSheetHeight | Gets or sets the height of the paper sheet to print on.
PrintOnSheetRawPaperSize | Gets or sets the raw index of a paper size.
PrintOnSheetWidth | Gets or sets the width of the paper sheet to print on.
PrintPages | Gets or sets a value specifies the pages to print.
PrintToFile | Gets or sets a value indicating that the printing output should be send to a file instead of a printer.
PrintToFileName | The name of a file to print the report to.
Reverse | Gets or sets a value determines whether to print pages in reverse order.
SavePrinterWithReport | Gets or sets a value indicating that the printer name should be saved in a report file.
ShowDialog | Specifies whether to display the "Print" dialog.

See Also

PrintSettings Class
FastReport Namespace


PrintSettings Constructor

[image]

FastReport.Net Class Reference
PrintSettings Constructor
PrintSettings Class See Also Send Feedback
Initializes a new instance of the PrintSettings class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PrintSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintSettings()

See Also

PrintSettings Class
FastReport Namespace


PrintSettings Methods

[image] [image]

FastReport.Net Class Reference
PrintSettings Methods
PrintSettings Class See Also Send Feedback

The PrintSettings type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Clear | Resets all settings to its default values.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSettings Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
PrintSettings..::.Assign Method
PrintSettings Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    PrintSettings source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As PrintSettings _
)
Visual C++
public:
void Assign(
    PrintSettings^ source
)

Parameters

source
Type: FastReport..::.PrintSettings
Source to assign from.

See Also

PrintSettings Class
FastReport Namespace


Clear Method

[image]

FastReport.Net Class Reference
PrintSettings..::.Clear Method
PrintSettings Class See Also Send Feedback
Resets all settings to its default values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

PrintSettings Class
FastReport Namespace


Dispose Method

[image]

FastReport.Net Class Reference
PrintSettings..::.Dispose Method
PrintSettings Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

PrintSettings Class
FastReport Namespace


PrintSettings Properties

[image] [image]

FastReport.Net Class Reference
PrintSettings Properties
PrintSettings Class See Also Send Feedback

The PrintSettings type exposes the following members.

Properties

Name | Description
Collate | Gets or sets a value indicating whether the printed document should be collated.
Copies | Gets or sets the number of copies to print.
CopyNames | Gets or sets an array of printed copy names, such as "Original", "Copy", etc.
Duplex | Gets or sets the duplex mode.
PageNumbers | Gets or sets the page number(s) to print.
PageRange | Gets or sets a value specifies the page range to print.
PagesOnSheet | Gets or sets the number of pages per printed sheet.
PaperSource | Gets or sets the paper source.
Printer | Gets or sets the printer name.
PrintMode | Gets or sets the print mode.
PrintOnSheetHeight | Gets or sets the height of the paper sheet to print on.
PrintOnSheetRawPaperSize | Gets or sets the raw index of a paper size.
PrintOnSheetWidth | Gets or sets the width of the paper sheet to print on.
PrintPages | Gets or sets a value specifies the pages to print.
PrintToFile | Gets or sets a value indicating that the printing output should be send to a file instead of a printer.
PrintToFileName | The name of a file to print the report to.
Reverse | Gets or sets a value determines whether to print pages in reverse order.
SavePrinterWithReport | Gets or sets a value indicating that the printer name should be saved in a report file.
ShowDialog | Specifies whether to display the "Print" dialog.

See Also

PrintSettings Class
FastReport Namespace


Collate Property

[image]

FastReport.Net Class Reference
PrintSettings..::.Collate Property
PrintSettings Class See Also Send Feedback
Gets or sets a value indicating whether the printed document should be collated.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Collate { get; set; }
Visual Basic (Declaration)
Public Property Collate As Boolean
Visual C++
public:
property bool Collate {
    bool get ();
    void set (bool value);
}

See Also

PrintSettings Class
FastReport Namespace


Copies Property

[image]

FastReport.Net Class Reference
PrintSettings..::.Copies Property
PrintSettings Class See Also Send Feedback
Gets or sets the number of copies to print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Copies { get; set; }
Visual Basic (Declaration)
Public Property Copies As Integer
Visual C++
public:
property int Copies {
    int get ();
    void set (int value);
}

See Also

PrintSettings Class
FastReport Namespace


CopyNames Property

[image]

FastReport.Net Class Reference
PrintSettings..::.CopyNames Property
PrintSettings Class See Also Send Feedback
Gets or sets an array of printed copy names, such as "Original", "Copy", etc.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string[] CopyNames { get; set; }
Visual Basic (Declaration)
Public Property CopyNames As String()
Visual C++
public:
property array<String^>^ CopyNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

PrintSettings Class
FastReport Namespace


Duplex Property

[image]

FastReport.Net Class Reference
PrintSettings..::.Duplex Property
PrintSettings Class See Also Send Feedback
Gets or sets the duplex mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Duplex Duplex { get; set; }
Visual Basic (Declaration)
Public Property Duplex As Duplex
Visual C++
public:
property Duplex Duplex {
    Duplex get ();
    void set (Duplex value);
}

See Also

PrintSettings Class
FastReport Namespace


PageNumbers Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PageNumbers Property
PrintSettings Class See Also Send Feedback
Gets or sets the page number(s) to print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageNumbers { get; set; }
Visual Basic (Declaration)
Public Property PageNumbers As String
Visual C++
public:
property String^ PageNumbers {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if PageRange property is set to PageNumbers. You can specify the page numbers, separated by commas, or the page ranges. For example: "1,3,5-12".

See Also

PrintSettings Class
FastReport Namespace


PageRange Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PageRange Property
PrintSettings Class See Also Send Feedback
Gets or sets a value specifies the page range to print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageRange PageRange { get; set; }
Visual Basic (Declaration)
Public Property PageRange As PageRange
Visual C++
public:
property PageRange PageRange {
    PageRange get ();
    void set (PageRange value);
}

See Also

PrintSettings Class
FastReport Namespace


PagesOnSheet Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PagesOnSheet Property
PrintSettings Class See Also Send Feedback
Gets or sets the number of pages per printed sheet.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PagesOnSheet PagesOnSheet { get; set; }
Visual Basic (Declaration)
Public Property PagesOnSheet As PagesOnSheet
Visual C++
public:
property PagesOnSheet PagesOnSheet {
    PagesOnSheet get ();
    void set (PagesOnSheet value);
}

Remarks

This property is used if the PrintMode property is set to Scale.

See Also

PrintSettings Class
FastReport Namespace


PaperSource Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PaperSource Property
PrintSettings Class See Also Send Feedback
Gets or sets the paper source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PaperSource { get; set; }
Visual Basic (Declaration)
Public Property PaperSource As Integer
Visual C++
public:
property int PaperSource {
    int get ();
    void set (int value);
}

Remarks

This property corresponds to the RAW source number. Default value is 7 which corresponds to DMBIN_AUTO.

See Also

PrintSettings Class
FastReport Namespace


Printer Property

[image]

FastReport.Net Class Reference
PrintSettings..::.Printer Property
PrintSettings Class See Also Send Feedback
Gets or sets the printer name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Printer { get; set; }
Visual Basic (Declaration)
Public Property Printer As String
Visual C++
public:
property String^ Printer {
    String^ get ();
    void set (String^ value);
}

See Also

PrintSettings Class
FastReport Namespace


PrintMode Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintMode Property
PrintSettings Class See Also Send Feedback
Gets or sets the print mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PrintMode PrintMode { get; set; }
Visual Basic (Declaration)
Public Property PrintMode As PrintMode
Visual C++
public:
property PrintMode PrintMode {
    PrintMode get ();
    void set (PrintMode value);
}

Remarks

See the PrintMode enumeration for details. If you use the mode other than Default, you must specify the sheet size in the PrintOnSheetWidth, PrintOnSheetHeight properties.

See Also

PrintSettings Class
FastReport Namespace


PrintOnSheetHeight Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintOnSheetHeight Property
PrintSettings Class See Also Send Feedback
Gets or sets the height of the paper sheet to print on.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PrintOnSheetHeight { get; set; }
Visual Basic (Declaration)
Public Property PrintOnSheetHeight As Single
Visual C++
public:
property float PrintOnSheetHeight {
    float get ();
    void set (float value);
}

Remarks

This property is used if the PrintMode property is not Default. Specify the paper height in millimeters.

See Also

PrintSettings Class
FastReport Namespace


PrintOnSheetRawPaperSize Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintOnSheetRawPaperSize Property
PrintSettings Class See Also Send Feedback
Gets or sets the raw index of a paper size.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PrintOnSheetRawPaperSize { get; set; }
Visual Basic (Declaration)
Public Property PrintOnSheetRawPaperSize As Integer
Visual C++
public:
property int PrintOnSheetRawPaperSize {
    int get ();
    void set (int value);
}

See Also

PrintSettings Class
FastReport Namespace


PrintOnSheetWidth Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintOnSheetWidth Property
PrintSettings Class See Also Send Feedback
Gets or sets the width of the paper sheet to print on.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PrintOnSheetWidth { get; set; }
Visual Basic (Declaration)
Public Property PrintOnSheetWidth As Single
Visual C++
public:
property float PrintOnSheetWidth {
    float get ();
    void set (float value);
}

Remarks

This property is used if the PrintMode property is not Default. Specify the paper width in millimeters.

See Also

PrintSettings Class
FastReport Namespace


PrintPages Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintPages Property
PrintSettings Class See Also Send Feedback
Gets or sets a value specifies the pages to print.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PrintPages PrintPages { get; set; }
Visual Basic (Declaration)
Public Property PrintPages As PrintPages
Visual C++
public:
property PrintPages PrintPages {
    PrintPages get ();
    void set (PrintPages value);
}

See Also

PrintSettings Class
FastReport Namespace


PrintToFile Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintToFile Property
PrintSettings Class See Also Send Feedback
Gets or sets a value indicating that the printing output should be send to a file instead of a printer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintToFile { get; set; }
Visual Basic (Declaration)
Public Property PrintToFile As Boolean
Visual C++
public:
property bool PrintToFile {
    bool get ();
    void set (bool value);
}

Remarks

Also set the PrintToFileName property.

See Also

PrintSettings Class
FastReport Namespace


PrintToFileName Property

[image]

FastReport.Net Class Reference
PrintSettings..::.PrintToFileName Property
PrintSettings Class See Also Send Feedback
The name of a file to print the report to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PrintToFileName { get; set; }
Visual Basic (Declaration)
Public Property PrintToFileName As String
Visual C++
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if PrintToFile property is true.

See Also

PrintSettings Class
FastReport Namespace


Reverse Property

[image]

FastReport.Net Class Reference
PrintSettings..::.Reverse Property
PrintSettings Class See Also Send Feedback
Gets or sets a value determines whether to print pages in reverse order.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Reverse { get; set; }
Visual Basic (Declaration)
Public Property Reverse As Boolean
Visual C++
public:
property bool Reverse {
    bool get ();
    void set (bool value);
}

See Also

PrintSettings Class
FastReport Namespace


SavePrinterWithReport Property

[image]

FastReport.Net Class Reference
PrintSettings..::.SavePrinterWithReport Property
PrintSettings Class See Also Send Feedback
Gets or sets a value indicating that the printer name should be saved in a report file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SavePrinterWithReport { get; set; }
Visual Basic (Declaration)
Public Property SavePrinterWithReport As Boolean
Visual C++
public:
property bool SavePrinterWithReport {
    bool get ();
    void set (bool value);
}

Remarks

If this property is set to true, the printer name will be saved in a report file. Next time when you open the report, the printer will be automatically selected.

See Also

PrintSettings Class
FastReport Namespace


ShowDialog Property

[image]

FastReport.Net Class Reference
PrintSettings..::.ShowDialog Property
PrintSettings Class See Also Send Feedback
Specifies whether to display the "Print" dialog.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowDialog { get; set; }
Visual Basic (Declaration)
Public Property ShowDialog As Boolean
Visual C++
public:
property bool ShowDialog {
    bool get ();
    void set (bool value);
}

See Also

PrintSettings Class
FastReport Namespace


ProcessAt Enumeration

[image]

FastReport.Net Class Reference
ProcessAt Enumeration
See Also Send Feedback
Specifies how the report engine processes the text objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ProcessAt
Visual Basic (Declaration)
Public Enumeration ProcessAt
Visual C++
public enum class ProcessAt

Members

Member name | Description
Default | Specifies the default process mode. The text object is processed just-in-time.
ReportFinished | Specifies that the text object must be processed when the entire report is finished. This mode can be used to print grand total value (which is normally calculated at the end of report) in the report title band.
ReportPageFinished | Specifies that the text object must be processed when the entire report page is finished. This mode can be used if the report template consists of several report pages.
PageFinished | Specifies that the text object must be processed when any report page is finished. This mode can be used to print the page total (which is normally calculated at the page footer) in the page header band.
ColumnFinished | Specifies that the text object must be processed when the column is finished. This mode can be used to print the column total (which is normally calculated at the column footer) in the column header band.
DataFinished | Specifies that the text object must be processed when the data block is finished. This mode can be used to print a total value in the data header (which is normally available in the data footer only).
GroupFinished | Specifies that the text object must be processed when the group is finished. This mode can be used to print a total value in the group header (which is normally available in the group footer only).
Custom | Specifies that the text object is processed manually when you call the Engine.ProcessObject method in the report script.

See Also

FastReport Namespace


ProgressEventArgs Class

[image]

FastReport.Net Class Reference
ProgressEventArgs Class
Members See Also Send Feedback
Provides data for the Progress event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ProgressEventArgs
Visual Basic (Declaration)
Public Class ProgressEventArgs
Visual C++
public ref class ProgressEventArgs

Inheritance Hierarchy

System..::.Object
FastReport..::.ProgressEventArgs

See Also

ProgressEventArgs Members
FastReport Namespace


ProgressEventArgs Members

[image] [image]

FastReport.Net Class Reference
ProgressEventArgs Members
ProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

The ProgressEventArgs type exposes the following members.

Constructors

Name | Description
ProgressEventArgs | Initializes a new instance of the ProgressEventArgs class using the specified message, page number and total number of pages.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | Gets a progress message.
Progress | Gets the current page number.
Total | Gets the number of total pages.

See Also

ProgressEventArgs Class
FastReport Namespace


ProgressEventArgs Constructor

[image]

FastReport.Net Class Reference
ProgressEventArgs Constructor
ProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the ProgressEventArgs class using the specified message, page number and total number of pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ProgressEventArgs(
    string message,
    int progress,
    int total
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    progress As Integer, _
    total As Integer _
)
Visual C++
public:
ProgressEventArgs(
    String^ message,
    int progress,
    int total
)

Parameters

message
Type: System..::.String
The progress message.
progress
Type: System..::.Int32
Current page number.
total
Type: System..::.Int32
Number of total pages.

See Also

ProgressEventArgs Class
FastReport Namespace


ProgressEventArgs Methods

[image] [image]

FastReport.Net Class Reference
ProgressEventArgs Methods
ProgressEventArgs Class See Also Send Feedback

The ProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressEventArgs Class
FastReport Namespace


ProgressEventArgs Properties

[image] [image]

FastReport.Net Class Reference
ProgressEventArgs Properties
ProgressEventArgs Class See Also Send Feedback

The ProgressEventArgs type exposes the following members.

Properties

Name | Description
Message | Gets a progress message.
Progress | Gets the current page number.
Total | Gets the number of total pages.

See Also

ProgressEventArgs Class
FastReport Namespace


Message Property

[image]

FastReport.Net Class Reference
ProgressEventArgs..::.Message Property
ProgressEventArgs Class See Also Send Feedback
Gets a progress message.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

ProgressEventArgs Class
FastReport Namespace


Progress Property

[image]

FastReport.Net Class Reference
ProgressEventArgs..::.Progress Property
ProgressEventArgs Class See Also Send Feedback
Gets the current page number.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Progress { get; }
Visual Basic (Declaration)
Public ReadOnly Property Progress As Integer
Visual C++
public:
property int Progress {
    int get ();
}

See Also

ProgressEventArgs Class
FastReport Namespace


Total Property

[image]

FastReport.Net Class Reference
ProgressEventArgs..::.Total Property
ProgressEventArgs Class See Also Send Feedback
Gets the number of total pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Total { get; }
Visual Basic (Declaration)
Public ReadOnly Property Total As Integer
Visual C++
public:
property int Total {
    int get ();
}

See Also

ProgressEventArgs Class
FastReport Namespace


ProgressEventHandler Delegate

[image]

FastReport.Net Class Reference
ProgressEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the Progress event.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void ProgressEventHandler(
    Object sender,
    ProgressEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ProgressEventHandler ( _
    sender As Object, _
    e As ProgressEventArgs _
)
Visual C++
public delegate void ProgressEventHandler(
    Object^ sender,
    ProgressEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport..::.ProgressEventArgs
The event data.

See Also

FastReport Namespace


Report Class

[image]

FastReport.Net Class Reference
Report Class
Members Example See Also Send Feedback
Represents a report object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Report : Base, IParent,
    ISupportInitialize
Visual Basic (Declaration)
Public Class Report _
    Inherits Base _
    Implements IParent, ISupportInitialize
Visual C++
public ref class Report : public Base,
    IParent, ISupportInitialize

Remarks

The instance of this class contains a report. Here are some common actions that can be performed with this object:

  • To load a report, use the Load(String) method or call static FromFile(String) method.
  • To save a report, call the Save(String) method.
  • To register application dataset for use it in a report, call one of the RegisterData methods.
  • To pass some parameter to a report, use the SetParameterValue(String, Object) method.
  • To design a report, call the Design()()() method.
  • To run a report and preview it, call the Show()()() method. Another way is to call the Prepare()()() method, then call the ShowPrepared()()() method.
  • To run a report and print it, call the Print()()() method. Another way is to call the Prepare()()() method, then call the PrintPrepared()()() method.
  • To load/save prepared report, use one of the LoadPrepared and SavePrepared methods.
  • To set up some global properties, use the Config static class or EnvironmentSettings component that you can use in the Visual Studio IDE.

The report consists of one or several report pages (pages of the ReportPage type) and/or dialog forms (pages of the DialogPage type). They are stored in the Pages collection. In turn, each page may contain report objects. See the example below how to create a simple report in code.

Examples

This example shows how to create a report instance, load it from a file, register the application data, run and preview.
CopyC#
Report report = new Report();
report.Load("reportfile.frx");
report.RegisterData(application_dataset);
report.Show();

This example shows how to create simple report in code.

CopyC#
Report report = new Report();
// create the report page
ReportPage page = new ReportPage();
page.Name = "ReportPage1";
// set paper width and height. Note: these properties are measured in millimeters.
page.PaperWidth = 210;
page.PaperHeight = 297;
// add a page to the report
report.Pages.Add(page);
// create report title
page.ReportTitle = new ReportTitleBand();
page.ReportTitle.Name = "ReportTitle1";
page.ReportTitle.Height = Units.Millimeters * 10;
// create Text object and put it to the title
TextObject text = new TextObject();
text.Name = "Text1";
text.Bounds = new RectangleF(0, 0, Units.Millimeters * 100, Units.Millimeters * 5);
page.ReportTitle.Objects.Add(text);
// create data band
DataBand data = new DataBand();
data.Name = "Data1";
data.Height = Units.Millimeters * 10;
// add data band to a page
page.Bands.Add(data);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.Report

See Also

Report Members
FastReport Namespace


Report Members

[image] [image]

FastReport.Net Class Reference
Report Members
Report Class Constructors Methods Properties Events See Also Send Feedback

The Report type exposes the following members.

Constructors

Name | Description
Report | Initializes a new instance of the Report class with default settings.

Methods

Name | Description
Abort | Aborts the report execution.
AddChild | Adds a child object to this object's childs.
ApplyStyles | Updates the report component's styles.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
BeginInit | Signals the object that initialization is starting.
Calc | Overloaded.
CalcExpression | Returns an expression value.
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Design | Overloaded.
Dispose | Overloaded.
EndInit | Signals the object that initialization is complete.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Overrides Base..::.FindObject(String).)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
FromFile | Creates the report instance and loads the report from a file.
FromStream | Creates the report instance and loads the report from a stream.
FromString | Creates the report instance and loads the report from a string.
GenerateReportAssembly | Generates the file (.cs or .vb) that contains the report source code.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetColumnValue | Gets the data column's value. Automatically converts null value to 0, false or "" depending on the column type.
GetColumnValueNullable | Gets the data column's value. This method does not convert null values.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDataSource | Gets the datasource with specified name.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameter | Gets the report parameter with given name.
GetParameterValue | Gets a value of the parameter with given name.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTotalValue | Gets a value of the total with specified name.
GetTotalValueNullable | Gets a value of the total with specified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariableValue | Gets a value of the system variable with specified name.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InternalInit | Initializes the report's fields.
InvokeEvent | Overloaded.
Load | Overloaded.
LoadFromString | Loads the report from a string.
LoadPrepared | Overloaded.
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnFinishReport | This method fires the FinishReport event and the script code connected to the FinishReportEvent.
OnStartReport | This method fires the StartReport event and the script code connected to the StartReportEvent.
Prepare | Overloaded.
PreparePhase1 | For internal use only.
PreparePhase2 | For internal use only.
Print | Prepares the report and prints it.
PrintPrepared | Overloaded.
Refresh | Refresh the current report.
RegisterData | Overloaded.
RemoveChild | Removes a specified object from this object's childs.
Save | Overloaded.
SavePrepared | Overloaded.
SaveToString | Saves the report to a string.
SaveToStringBase64 | Saves the report to a string using the Base64 encoding.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParameterValue | Sets the parameter's value.
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Show | Overloaded.
ShowPrepared | Overloaded.
ShowPrintDialog | Shows the "Print" dialog.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
Aborted | Gets a value indicating that report execution was aborted.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AutoFillDataSet | Gets or sets a value indicating whether it is necessary to automatically fill DataSet registered with RegisterData call.
BaseName | The base part of the object's name. (Inherited from Base.)
BaseReport | Gets or sets the base report file name.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Compressed | Gets or sets a value that specifies whether to compress the report file.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ConvertNulls | Gets or sets a value indicating whether the null DB value must be converted to zero, false or empty string depending on the data column type.
Designer | Gets a reference to the report designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dictionary | Gets the report's data.
DoublePass | Gets or sets a value that specifies whether the report engine should perform the second pass.
EmailSettings | Gets the email settings such as recipients, subject, message body.
Engine | Gets a reference to the report engine.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileName | Gets or sets the name of a file the report was loaded from.
FinishReportEvent | Gets or sets a script event name that will be fired when the report is finished.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GraphicCache | Gets a reference to the graphics cache for this report.
HasDialogs | Gets a value indicating that this report contains dialog forms.
InitialPageNumber | Gets or sets the initial page number for PageN/PageNofM system variables.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
MaxPages | Gets or sets the maximum number of generated pages in a prepared report.
Name | This property is not relevant to this class.
Operation | Gets the report operation that is currently performed.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Pages | Gets the pages contained in this report.
Parameters | Gets the collection of report parameters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Password | Gets or sets the report password.
PreparedPages | Gets a pages of the prepared report.
Preview | Gets or sets the report preview control.
PrintSettings | Gets the print settings such as printer name, copies, pages to print etc.
ReferencedAssemblies | Gets or sets an array of assembly names that will be used to compile the report script.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportInfo | Gets or sets the report information such as report name, author, description etc.
ReportResourceString | Gets or sets the resource string that contains the report.
Restrictions | This property is not relevant to this class.
ScriptLanguage | Gets or sets the script language of this report.
ScriptRestrictions | Gets or sets a set of permissions that will be restricted for the script code.
ScriptText | Gets or sets the report script.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SmoothGraphics | Gets or sets a value that specifies if the graphic objects such as bitmaps and shapes should be displayed smoothly.
StartReportEvent | Gets or sets a script event name that will be fired when the report starts.
StoreInResources | Gets or sets a value that determines whether to store the report in the application resources. Use this property in the MS Visual Studio IDE only.
Styles | Gets or sets the collection of styles used in this report.
TextQuality | Gets or sets a value that specifies the quality of text rendering.
UseFileCache | Gets or sets a value that specifies whether to use the file cache rather than memory to store the prepared report pages.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FinishReport | Occurs when report execution is finished.
LoadBaseReport | Occurs when report is inherited and trying to load a base report.
StartReport | Occurs when report execution is started.

See Also

Report Class
FastReport Namespace


Report Constructor

[image]

FastReport.Net Class Reference
Report Constructor
Report Class See Also Send Feedback
Initializes a new instance of the Report class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Report()

See Also

Report Class
FastReport Namespace


Report Methods

[image] [image]

FastReport.Net Class Reference
Report Methods
Report Class See Also Send Feedback

The Report type exposes the following members.

Methods

Name | Description
Abort | Aborts the report execution.
AddChild | Adds a child object to this object's childs.
ApplyStyles | Updates the report component's styles.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
BeginInit | Signals the object that initialization is starting.
Calc | Overloaded.
CalcExpression | Returns an expression value.
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Design | Overloaded.
Dispose | Overloaded.
EndInit | Signals the object that initialization is complete.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Overrides Base..::.FindObject(String).)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
FromFile | Creates the report instance and loads the report from a file.
FromStream | Creates the report instance and loads the report from a stream.
FromString | Creates the report instance and loads the report from a string.
GenerateReportAssembly | Generates the file (.cs or .vb) that contains the report source code.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetColumnValue | Gets the data column's value. Automatically converts null value to 0, false or "" depending on the column type.
GetColumnValueNullable | Gets the data column's value. This method does not convert null values.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDataSource | Gets the datasource with specified name.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameter | Gets the report parameter with given name.
GetParameterValue | Gets a value of the parameter with given name.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTotalValue | Gets a value of the total with specified name.
GetTotalValueNullable | Gets a value of the total with specified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariableValue | Gets a value of the system variable with specified name.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InternalInit | Initializes the report's fields.
InvokeEvent | Overloaded.
Load | Overloaded.
LoadFromString | Loads the report from a string.
LoadPrepared | Overloaded.
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnFinishReport | This method fires the FinishReport event and the script code connected to the FinishReportEvent.
OnStartReport | This method fires the StartReport event and the script code connected to the StartReportEvent.
Prepare | Overloaded.
PreparePhase1 | For internal use only.
PreparePhase2 | For internal use only.
Print | Prepares the report and prints it.
PrintPrepared | Overloaded.
Refresh | Refresh the current report.
RegisterData | Overloaded.
RemoveChild | Removes a specified object from this object's childs.
Save | Overloaded.
SavePrepared | Overloaded.
SaveToString | Saves the report to a string.
SaveToStringBase64 | Saves the report to a string using the Base64 encoding.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParameterValue | Sets the parameter's value.
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Show | Overloaded.
ShowPrepared | Overloaded.
ShowPrintDialog | Shows the "Print" dialog.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

Report Class
FastReport Namespace


Abort Method

[image]

FastReport.Net Class Reference
Report..::.Abort Method
Report Class See Also Send Feedback
Aborts the report execution.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Abort()
Visual Basic (Declaration)
Public Sub Abort
Visual C++
public:
void Abort()

See Also

Report Class
FastReport Namespace


AddChild Method

[image]

FastReport.Net Class Reference
Report..::.AddChild Method
Report Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base obj
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    obj As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ obj
) sealed

Parameters

obj
Type: FastReport..::.Base

Implements

IParent..::.AddChild(Base)

See Also

Report Class
FastReport Namespace


ApplyStyles Method

[image]

FastReport.Net Class Reference
Report..::.ApplyStyles Method
Report Class See Also Send Feedback
Updates the report component's styles.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ApplyStyles()
Visual Basic (Declaration)
Public Sub ApplyStyles
Visual C++
public:
void ApplyStyles()

Remarks

Call this method if you change the Styles collection.

See Also

Report Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
Report..::.Assign Method
Report Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

Report Class
FastReport Namespace
AssignAll Method


BeginInit Method

[image]

FastReport.Net Class Reference
Report..::.BeginInit Method
Report Class See Also Send Feedback
Signals the object that initialization is starting.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void BeginInit()
Visual Basic (Declaration)
Public Sub BeginInit
Visual C++
public:
virtual void BeginInit() sealed

Implements

ISupportInitialize..::.BeginInit()()()

See Also

Report Class
FastReport Namespace


Calc Method

[image] [image]

FastReport.Net Class Reference
Report..::.Calc Method
Report Class See Also Send Feedback

Overload List

Name | Description
Calc(String) | Calculates an expression and returns the result.
Calc(String, Variant) | Calculates an expression and returns the result.

See Also

Report Class
Report Members
FastReport Namespace


Calc Method (String)

[image]

FastReport.Net Class Reference
Report..::.Calc Method (String)
Report Class See Also Send Feedback
Calculates an expression and returns the result.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Calc(
    string expression
)
Visual Basic (Declaration)
Public Function Calc ( _
    expression As String _
) As Object
Visual C++
public:
Object^ Calc(
    String^ expression
)

Parameters

expression
Type: System..::.String
The expression to calculate.

Return Value

If report is running, returns the result of calculation. Otherwise returns null.

Remarks

The expression may be any valid expression such as "1 + 2". The expression is calculated in the report script's ReportScript class instance context, so you may refer to any objects available in this context: private fields, methods, report objects.

See Also

Report Class
Calc Overload
FastReport Namespace


Calc Method (String, Variant)

[image]

FastReport.Net Class Reference
Report..::.Calc Method (String, Variant)
Report Class See Also Send Feedback
Calculates an expression and returns the result.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Calc(
    string expression,
    Variant value
)
Visual Basic (Declaration)
Public Function Calc ( _
    expression As String, _
    value As Variant _
) As Object
Visual C++
public:
Object^ Calc(
    String^ expression,
    Variant value
)

Parameters

expression
Type: System..::.String
The expression to calculate.
value
Type: FastReport..::.Variant
The value of currently printing object.

Return Value

If report is running, returns the result of calculation. Otherwise returns null.

Remarks

Do not call this method directly. Use the Calc(string expression) method instead.

See Also

Report Class
Calc Overload
FastReport Namespace


CalcExpression Method

[image]

FastReport.Net Class Reference
Report..::.CalcExpression Method
Report Class See Also Send Feedback
Returns an expression value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual Object CalcExpression(
    string expression,
    Variant value
)
Visual Basic (Declaration)
Protected Overridable Function CalcExpression ( _
    expression As String, _
    value As Variant _
) As Object
Visual C++
protected:
virtual Object^ CalcExpression(
    String^ expression,
    Variant value
)

Parameters

expression
Type: System..::.String
The expression.
value
Type: FastReport..::.Variant
The value of currently printing object.

Return Value

Returns the result of calculation.

Remarks

This method is for internal use only, do not call it directly.

See Also

Report Class
FastReport Namespace


CanContain Method

[image]

FastReport.Net Class Reference
Report..::.CanContain Method
Report Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

Report Class
FastReport Namespace


Clear Method

[image]

FastReport.Net Class Reference
Report..::.Clear Method
Report Class See Also Send Feedback
Clears the object's state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

This method also disposes all object's children.

See Also

Report Class
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
Report..::.Deserialize Method
Report Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

Report Class
FastReport Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
Report..::.DeserializeSubItems Method
Report Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overrides Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

Report Class
FastReport Namespace


Design Method

[image] [image]

FastReport.Net Class Reference
Report..::.Design Method
Report Class See Also Send Feedback

Overload List

Name | Description
Design()()() | Runs the report designer.
Design(Boolean) | Runs the report designer.
Design(Form) | Runs the report designer.

See Also

Report Class
Report Members
FastReport Namespace


Design Method

[image]

FastReport.Net Class Reference
Report..::.Design Method
Report Class See Also Send Feedback
Runs the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Design()
Visual Basic (Declaration)
Public Function Design As Boolean
Visual C++
public:
bool Design()

Return Value

true if report was modified, otherwise false.

See Also

Report Class
Design Overload
FastReport Namespace


Design Method (Boolean)

[image]

FastReport.Net Class Reference
Report..::.Design Method (Boolean)
Report Class See Also Send Feedback
Runs the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Design(
    bool modal
)
Visual Basic (Declaration)
Public Function Design ( _
    modal As Boolean _
) As Boolean
Visual C++
public:
bool Design(
    bool modal
)

Parameters

modal
Type: System..::.Boolean
A value indicates whether the designer should run modally.

Return Value

true if report was modified, otherwise false.

See Also

Report Class
Design Overload
FastReport Namespace


Design Method (Form)

[image]

FastReport.Net Class Reference
Report..::.Design Method (Form)
Report Class See Also Send Feedback
Runs the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Design(
    Form mdiParent
)
Visual Basic (Declaration)
Public Function Design ( _
    mdiParent As Form _
) As Boolean
Visual C++
public:
bool Design(
    Form^ mdiParent
)

Parameters

mdiParent
Type: System.Windows.Forms..::.Form
The main MDI form which will be a parent for the designer.

Return Value

true if report was modified, otherwise false.

See Also

Report Class
Design Overload
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Report..::.Dispose Method
Report Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

Report Class
Report Members
FastReport Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
Report..::.Dispose Method (Boolean)
Report Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Report Class
Dispose Overload
FastReport Namespace


EndInit Method

[image]

FastReport.Net Class Reference
Report..::.EndInit Method
Report Class See Also Send Feedback
Signals the object that initialization is complete.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EndInit()
Visual Basic (Declaration)
Public Sub EndInit
Visual C++
public:
virtual void EndInit() sealed

Implements

ISupportInitialize..::.EndInit()()()

See Also

Report Class
FastReport Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
Report..::.Export Method
Report Class See Also Send Feedback

Overload List

Name | Description
Export(ExportBase, Stream) | Exports a report. Report should be prepared using the Prepare()()() method.
Export(ExportBase, String) | Exports a report. Report should be prepared using the Prepare()()() method.

See Also

Report Class
Report Members
FastReport Namespace


Export Method (ExportBase, Stream)

[image]

FastReport.Net Class Reference
Report..::.Export Method (ExportBase, Stream)
Report Class See Also Send Feedback
Exports a report. Report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Export(
    ExportBase export,
    Stream stream
)
Visual Basic (Declaration)
Public Sub Export ( _
    export As ExportBase, _
    stream As Stream _
)
Visual C++
public:
void Export(
    ExportBase^ export,
    Stream^ stream
)

Parameters

export
Type: FastReport.Export..::.ExportBase
The export filter.
stream
Type: System.IO..::.Stream
Stream to save export result to.

See Also

Report Class
Export Overload
FastReport Namespace


Export Method (ExportBase, String)

[image]

FastReport.Net Class Reference
Report..::.Export Method (ExportBase, String)
Report Class See Also Send Feedback
Exports a report. Report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Export(
    ExportBase export,
    string fileName
)
Visual Basic (Declaration)
Public Sub Export ( _
    export As ExportBase, _
    fileName As String _
)
Visual C++
public:
void Export(
    ExportBase^ export,
    String^ fileName
)

Parameters

export
Type: FastReport.Export..::.ExportBase
The export filter.
fileName
Type: System..::.String
File name to save export result to.

See Also

Report Class
Export Overload
FastReport Namespace


FindObject Method

[image]

FastReport.Net Class Reference
Report..::.FindObject Method
Report Class Example See Also Send Feedback
Searches for an object with given name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Base FindObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function FindObject ( _
    name As String _
) As Base
Visual C++
public:
virtual Base^ FindObject(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the object to find.

Return Value

Returns a null reference if object is not found

Examples

The following code demonstrates how to find an object by its name:
CopyC#
TextObject text1 = report1.FindObject("Text1") as TextObject;
if (text1 != null)
{
  // object found
}

See Also

Report Class
FastReport Namespace


FromFile Method

[image]

FastReport.Net Class Reference
Report..::.FromFile Method
Report Class See Also Send Feedback
Creates the report instance and loads the report from a file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Report FromFile(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function FromFile ( _
    fileName As String _
) As Report
Visual C++
public:
static Report^ FromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file to load from.

Return Value

The new report instance.

See Also

Report Class
FastReport Namespace


FromStream Method

[image]

FastReport.Net Class Reference
Report..::.FromStream Method
Report Class See Also Send Feedback
Creates the report instance and loads the report from a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Report FromStream(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function FromStream ( _
    stream As Stream _
) As Report
Visual C++
public:
static Report^ FromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

Return Value

The new report instance.

See Also

Report Class
FastReport Namespace


FromString Method

[image]

FastReport.Net Class Reference
Report..::.FromString Method
Report Class See Also Send Feedback
Creates the report instance and loads the report from a string.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Report FromString(
    string utf8String
)
Visual Basic (Declaration)
Public Shared Function FromString ( _
    utf8String As String _
) As Report
Visual C++
public:
static Report^ FromString(
    String^ utf8String
)

Parameters

utf8String
Type: System..::.String
The string that contains a stream in UTF8 encoding.

Return Value

The new report instance.

See Also

Report Class
FastReport Namespace


GenerateReportAssembly Method

[image]

FastReport.Net Class Reference
Report..::.GenerateReportAssembly Method
Report Class See Also Send Feedback
Generates the file (.cs or .vb) that contains the report source code.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GenerateReportAssembly(
    string fileName
)
Visual Basic (Declaration)
Public Sub GenerateReportAssembly ( _
    fileName As String _
)
Visual C++
public:
void GenerateReportAssembly(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of the file.

Remarks

Use this method to generate the report source code. This code can be attached to your project. In this case, you will need to call the following code to run a report:
CopyC#
SimpleListReport report = new SimpleListReport();
report.RegisterData(your_dataset);
report.Show();

See Also

Report Class
FastReport Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
Report..::.GetChildObjects Method
Report Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

Report Class
FastReport Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
Report..::.GetChildOrder Method
Report Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

Report Class
FastReport Namespace


GetColumnValue Method

[image]

FastReport.Net Class Reference
Report..::.GetColumnValue Method
Report Class Example See Also Send Feedback
Gets the data column's value. Automatically converts null value to 0, false or "" depending on the column type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetColumnValue(
    string complexName
)
Visual Basic (Declaration)
Public Function GetColumnValue ( _
    complexName As String _
) As Object
Visual C++
public:
Object^ GetColumnValue(
    String^ complexName
)

Parameters

complexName
Type: System..::.String
The name of the data column including the datasource name.

Return Value

If report is running, returns the column value. Otherwise returns null.

Remarks

The return value of this method does not depend on the ConvertNulls property.

Examples

CopyC#
string employeeName = (string)report.GetColumnValue("Employees.FirstName");

See Also

Report Class
FastReport Namespace


GetColumnValueNullable Method

[image]

FastReport.Net Class Reference
Report..::.GetColumnValueNullable Method
Report Class See Also Send Feedback
Gets the data column's value. This method does not convert null values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetColumnValueNullable(
    string complexName
)
Visual Basic (Declaration)
Public Function GetColumnValueNullable ( _
    complexName As String _
) As Object
Visual C++
public:
Object^ GetColumnValueNullable(
    String^ complexName
)

Parameters

complexName
Type: System..::.String
The name of the data column including the datasource name.

Return Value

If report is running, returns the column value. Otherwise returns null.

See Also

Report Class
FastReport Namespace


GetDataSource Method

[image]

FastReport.Net Class Reference
Report..::.GetDataSource Method
Report Class See Also Send Feedback
Gets the datasource with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase GetDataSource(
    string alias
)
Visual Basic (Declaration)
Public Function GetDataSource ( _
    alias As String _
) As DataSourceBase
Visual C++
public:
DataSourceBase^ GetDataSource(
    String^ alias
)

Parameters

alias
Type: System..::.String
Alias name of a datasource.

Return Value

The datasource object if found, otherwise null.

See Also

Report Class
FastReport Namespace


GetParameter Method

[image]

FastReport.Net Class Reference
Report..::.GetParameter Method
Report Class See Also Send Feedback
Gets the report parameter with given name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Parameter GetParameter(
    string complexName
)
Visual Basic (Declaration)
Public Function GetParameter ( _
    complexName As String _
) As Parameter
Visual C++
public:
Parameter^ GetParameter(
    String^ complexName
)

Parameters

complexName
Type: System..::.String
The name of the parameter.

Return Value

The Parameter object if found, otherwise null.

Remarks

To find nested parameter, use the "." separator: "MainParameter.NestedParameter"

See Also

Report Class
FastReport Namespace


GetParameterValue Method

[image]

FastReport.Net Class Reference
Report..::.GetParameterValue Method
Report Class See Also Send Feedback
Gets a value of the parameter with given name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetParameterValue(
    string complexName
)
Visual Basic (Declaration)
Public Function GetParameterValue ( _
    complexName As String _
) As Object
Visual C++
public:
Object^ GetParameterValue(
    String^ complexName
)

Parameters

complexName
Type: System..::.String
The name of the parameter.

Return Value

The parameter's value if found, otherwise null.

Remarks

To find nested parameter, use the "." separator: "MainParameter.NestedParameter"

See Also

Report Class
FastReport Namespace


GetTotalValue Method

[image]

FastReport.Net Class Reference
Report..::.GetTotalValue Method
Report Class See Also Send Feedback
Gets a value of the total with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Variant GetTotalValue(
    string name
)
Visual Basic (Declaration)
Public Function GetTotalValue ( _
    name As String _
) As Variant
Visual C++
public:
Variant GetTotalValue(
    String^ name
)

Parameters

name
Type: System..::.String
Name of total.

Return Value

The total's value if found, otherwise 0.

Remarks

This method converts null values to 0 if the ConvertNulls property is set to true. Use the GetTotalValueNullable(String) method if you don't want the null conversion.

See Also

Report Class
FastReport Namespace


GetTotalValueNullable Method

[image]

FastReport.Net Class Reference
Report..::.GetTotalValueNullable Method
Report Class See Also Send Feedback
Gets a value of the total with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Variant GetTotalValueNullable(
    string name
)
Visual Basic (Declaration)
Public Function GetTotalValueNullable ( _
    name As String _
) As Variant
Visual C++
public:
Variant GetTotalValueNullable(
    String^ name
)

Parameters

name
Type: System..::.String
Name of total.

Return Value

The total's value if found, otherwise null.

See Also

Report Class
FastReport Namespace


GetVariableValue Method

[image]

FastReport.Net Class Reference
Report..::.GetVariableValue Method
Report Class See Also Send Feedback
Gets a value of the system variable with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetVariableValue(
    string complexName
)
Visual Basic (Declaration)
Public Function GetVariableValue ( _
    complexName As String _
) As Object
Visual C++
public:
Object^ GetVariableValue(
    String^ complexName
)

Parameters

complexName
Type: System..::.String
Name of a variable.

Return Value

The variable's value if found, otherwise null.

See Also

Report Class
FastReport Namespace


InternalInit Method

[image]

FastReport.Net Class Reference
Report..::.InternalInit Method
Report Class See Also Send Feedback
Initializes the report's fields.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void InternalInit()
Visual Basic (Declaration)
Protected Sub InternalInit
Visual C++
protected:
void InternalInit()

Remarks

This method is for internal use only.

See Also

Report Class
FastReport Namespace


InvokeEvent Method

[image] [image]

FastReport.Net Class Reference
Report..::.InvokeEvent Method
Report Class See Also Send Feedback

Overload List

Name | Description
InvokeEvent(String, Object) | Invokes script event. (Inherited from Base.)
InvokeEvent(String, array<Object>[]()[]) | Invokes the script event handler with given name.

See Also

Report Class
Report Members
FastReport Namespace


InvokeEvent Method (String, Object[])

[image]

FastReport.Net Class Reference
Report..::.InvokeEvent Method (String, array<Object>[]()[])
Report Class See Also Send Feedback
Invokes the script event handler with given name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void InvokeEvent(
    string name,
    Object[] parms
)
Visual Basic (Declaration)
Public Sub InvokeEvent ( _
    name As String, _
    parms As Object() _
)
Visual C++
public:
void InvokeEvent(
    String^ name,
    array<Object^>^ parms
)

Parameters

name
Type: System..::.String
The name of the script method.
parms
Type: array< System..::.Object >[]()[]
The method parameters.

See Also

Report Class
InvokeEvent Overload
FastReport Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
Report..::.Load Method
Report Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads report from a stream.
Load(String) | Loads the report from a file.

See Also

Report Class
Report Members
FastReport Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
Report..::.Load Method (Stream)
Report Class See Also Send Feedback
Loads report from a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

Remarks

When you try to load the password-protected report, you will be asked for a password. You also may specify the password in the Password property before loading the report. In this case the report will load silently.

See Also

Report Class
Load Overload
FastReport Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
Report..::.Load Method (String)
Report Class See Also Send Feedback
Loads the report from a file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file to load from.

Remarks

When you try to load the password-protected report, you will be asked for a password. You also may specify the password in the Password property before loading the report. In this case the report will load silently.

See Also

Report Class
Load Overload
FastReport Namespace


LoadFromString Method

[image]

FastReport.Net Class Reference
Report..::.LoadFromString Method
Report Class See Also Send Feedback
Loads the report from a string.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadFromString(
    string s
)
Visual Basic (Declaration)
Public Sub LoadFromString ( _
    s As String _
)
Visual C++
public:
void LoadFromString(
    String^ s
)

Parameters

s
Type: System..::.String
The string that contains a stream in UTF8 or Base64 encoding.

See Also

Report Class
FastReport Namespace


LoadPrepared Method

[image] [image]

FastReport.Net Class Reference
Report..::.LoadPrepared Method
Report Class See Also Send Feedback

Overload List

Name | Description
LoadPrepared(Stream) | Loads the prepared report from a .fpx file.
LoadPrepared(String) | Loads the prepared report from a .fpx file.

See Also

Report Class
Report Members
FastReport Namespace


LoadPrepared Method (Stream)

[image]

FastReport.Net Class Reference
Report..::.LoadPrepared Method (Stream)
Report Class See Also Send Feedback
Loads the prepared report from a .fpx file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadPrepared(
    Stream stream
)
Visual Basic (Declaration)
Public Sub LoadPrepared ( _
    stream As Stream _
)
Visual C++
public:
void LoadPrepared(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to load from.

See Also

Report Class
LoadPrepared Overload
FastReport Namespace


LoadPrepared Method (String)

[image]

FastReport.Net Class Reference
Report..::.LoadPrepared Method (String)
Report Class See Also Send Feedback
Loads the prepared report from a .fpx file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadPrepared(
    string fileName
)
Visual Basic (Declaration)
Public Sub LoadPrepared ( _
    fileName As String _
)
Visual C++
public:
void LoadPrepared(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to load form.

See Also

Report Class
LoadPrepared Overload
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Report..::.MemberwiseClone Method
Report Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Report Class
Report Members
FastReport Namespace


OnFinishReport Method

[image]

FastReport.Net Class Reference
Report..::.OnFinishReport Method
Report Class See Also Send Feedback
This method fires the FinishReport event and the script code connected to the FinishReportEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnFinishReport(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnFinishReport ( _
    e As EventArgs _
)
Visual C++
public:
void OnFinishReport(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

Report Class
FastReport Namespace


OnStartReport Method

[image]

FastReport.Net Class Reference
Report..::.OnStartReport Method
Report Class See Also Send Feedback
This method fires the StartReport event and the script code connected to the StartReportEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnStartReport(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnStartReport ( _
    e As EventArgs _
)
Visual C++
public:
void OnStartReport(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

Report Class
FastReport Namespace


Prepare Method

[image] [image]

FastReport.Net Class Reference
Report..::.Prepare Method
Report Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Prepares the report.
Prepare(Boolean) | Prepares the report.

See Also

Report Class
Report Members
FastReport Namespace


Prepare Method

[image]

FastReport.Net Class Reference
Report..::.Prepare Method
Report Class See Also Send Feedback
Prepares the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Prepare()
Visual Basic (Declaration)
Public Function Prepare As Boolean
Visual C++
public:
bool Prepare()

Return Value

true if report was prepared succesfully.

See Also

Report Class
Prepare Overload
FastReport Namespace


Prepare Method (Boolean)

[image]

FastReport.Net Class Reference
Report..::.Prepare Method (Boolean)
Report Class Example See Also Send Feedback
Prepares the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Prepare(
    bool append
)
Visual Basic (Declaration)
Public Function Prepare ( _
    append As Boolean _
) As Boolean
Visual C++
public:
bool Prepare(
    bool append
)

Parameters

append
Type: System..::.Boolean
Specifies whether the new report should be added to a report that was prepared before.

Return Value

true if report was prepared succesfully.

Remarks

Use this method to merge prepared reports.

Examples

This example shows how to merge two reports and preview the result:
CopyC#
Report report = new Report();
report.Load("report1.frx");
report.Prepare();
report.Load("report2.frx");
report.Prepare(true);
report.ShowPrepared();

See Also

Report Class
Prepare Overload
FastReport Namespace


PreparePhase1 Method

[image]

FastReport.Net Class Reference
Report..::.PreparePhase1 Method
Report Class See Also Send Feedback
For internal use only.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PreparePhase1()
Visual Basic (Declaration)
Public Sub PreparePhase1
Visual C++
public:
void PreparePhase1()

See Also

Report Class
FastReport Namespace


PreparePhase2 Method

[image]

FastReport.Net Class Reference
Report..::.PreparePhase2 Method
Report Class See Also Send Feedback
For internal use only.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PreparePhase2()
Visual Basic (Declaration)
Public Sub PreparePhase2
Visual C++
public:
void PreparePhase2()

See Also

Report Class
FastReport Namespace


Print Method

[image]

FastReport.Net Class Reference
Report..::.Print Method
Report Class See Also Send Feedback
Prepares the report and prints it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Print()
Visual Basic (Declaration)
Public Sub Print
Visual C++
public:
void Print()

See Also

Report Class
FastReport Namespace


PrintPrepared Method

[image] [image]

FastReport.Net Class Reference
Report..::.PrintPrepared Method
Report Class See Also Send Feedback

Overload List

Name | Description
PrintPrepared()()() | Prints the report with the "Print" dialog. Report should be prepared using the Prepare()()() method.
PrintPrepared(PrinterSettings) | Prints the report without the "Print" dialog. Report should be prepared using the Prepare()()() method.

See Also

Report Class
Report Members
FastReport Namespace


PrintPrepared Method

[image]

FastReport.Net Class Reference
Report..::.PrintPrepared Method
Report Class See Also Send Feedback
Prints the report with the "Print" dialog. Report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintPrepared()
Visual Basic (Declaration)
Public Sub PrintPrepared
Visual C++
public:
void PrintPrepared()

See Also

Report Class
PrintPrepared Overload
FastReport Namespace


PrintPrepared Method (PrinterSettings)

[image]

FastReport.Net Class Reference
Report..::.PrintPrepared Method (PrinterSettings)
Report Class Example See Also Send Feedback
Prints the report without the "Print" dialog. Report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintPrepared(
    PrinterSettings printerSettings
)
Visual Basic (Declaration)
Public Sub PrintPrepared ( _
    printerSettings As PrinterSettings _
)
Visual C++
public:
void PrintPrepared(
    PrinterSettings^ printerSettings
)

Parameters

printerSettings
Type: System.Drawing.Printing..::.PrinterSettings
Printer-specific settings.

Examples

Use the following code if you want to show the "Print" dialog, then print:
CopyC#
if (report.Prepare())
{
  PrinterSettings printerSettings = null;
  if (report.ShowPrintDialog(out printerSettings))
  {
    report.PrintPrepared(printerSettings);
  }
}

See Also

Report Class
PrintPrepared Overload
FastReport Namespace


Refresh Method

[image]

FastReport.Net Class Reference
Report..::.Refresh Method
Report Class See Also Send Feedback
Refresh the current report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
void Refresh()

Remarks

Call this method in the Click or MouseUp event handler of a report object to refresh the currently previewed report. Report will be generated again, but without dialog forms.

See Also

Report Class
FastReport Namespace


RegisterData Method

[image] [image]

FastReport.Net Class Reference
Report..::.RegisterData Method
Report Class See Also Send Feedback

Overload List

Name | Description
RegisterData(DataSet) | Registers the application dataset with all its tables and relations to use it in the report.
RegisterData(IEnumerable, String) | Registers the application business object to use it in the report.
RegisterData(DataRelation, String) | Registers the application data relation to use it in the report.
RegisterData(DataSet, String) | Registers the application dataset with specified name.
RegisterData(DataTable, String) | Registers the application data table to use it in the report.
RegisterData(DataView, String) | Registers the application data view to use it in the report.
RegisterData(IEnumerable, String, Int32) | Registers the application business object to use it in the report.
RegisterData(IEnumerable, String, BOConverterFlags, Int32) | Obsolete. Registers the application business object to use it in the report.

See Also

Report Class
Report Members
FastReport Namespace


RegisterData Method (DataSet)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (DataSet)
Report Class Example See Also Send Feedback
Registers the application dataset with all its tables and relations to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    DataSet data
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As DataSet _
)
Visual C++
public:
void RegisterData(
    DataSet^ data
)

Parameters

data
Type: System.Data..::.DataSet
The application data.

Remarks

If you register more than one dataset, use the RegisterData(DataSet, String) method.

Examples

CopyC#
report1.Load("report.frx");
report1.RegisterData(dataSet1);

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (IEnumerable, String)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (IEnumerable, String)
Report Class Example See Also Send Feedback
Registers the application business object to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    IEnumerable data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As IEnumerable, _
    name As String _
)
Visual C++
public:
void RegisterData(
    IEnumerable^ data,
    String^ name
)

Parameters

data
Type: System.Collections..::.IEnumerable
Application data.
name
Type: System..::.String
Name of the data.

Examples

CopyC#
report1.Load("report.frx");
report1.RegisterData(myBusinessObject, "Customers");

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (DataRelation, String)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (DataRelation, String)
Report Class Example See Also Send Feedback
Registers the application data relation to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    DataRelation data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As DataRelation, _
    name As String _
)
Visual C++
public:
void RegisterData(
    DataRelation^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataRelation
The application data.
name
Type: System..::.String
The name of the data.

Remarks

You may specify any value for the name parameter: it is not displayed anywhere in the designer and used only to load/save a report. The name must be persistent and unique for each registered relation.

Examples

CopyC#
report1.Load("report.frx");
report1.RegisterData(myDataRelation, "myRelation");

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (DataSet, String)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (DataSet, String)
Report Class Example See Also Send Feedback
Registers the application dataset with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    DataSet data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As DataSet, _
    name As String _
)
Visual C++
public:
void RegisterData(
    DataSet^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataSet
The application data.
name
Type: System..::.String
The name of the data.

Remarks

Use this method if you register more than one dataset. You may specify any value for the name parameter: it is not displayed anywhere in the designer and used only to load/save a report. The name must be persistent and unique for each registered dataset.

Examples

CopyC#
report1.Load("report.frx");
report1.RegisterData(dataSet1, "NorthWind");

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (DataTable, String)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (DataTable, String)
Report Class Example See Also Send Feedback
Registers the application data table to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    DataTable data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As DataTable, _
    name As String _
)
Visual C++
public:
void RegisterData(
    DataTable^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataTable
The application data.
name
Type: System..::.String
The name of the data.

Examples

CopyC#
report1.Load("report.frx");
report1.RegisterData(dataSet1.Tables["Orders"], "Orders");

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (DataView, String)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (DataView, String)
Report Class Example See Also Send Feedback
Registers the application data view to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    DataView data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As DataView, _
    name As String _
)
Visual C++
public:
void RegisterData(
    DataView^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataView
The application data.
name
Type: System..::.String
The name of the data.

Examples

CopyC#
report1.Load("report.frx");
report1.RegisterData(myDataView, "OrdersView");

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (IEnumerable, String, Int32)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (IEnumerable, String, Int32)
Report Class See Also Send Feedback
Registers the application business object to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    IEnumerable data,
    string name,
    int maxNestingLevel
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As IEnumerable, _
    name As String, _
    maxNestingLevel As Integer _
)
Visual C++
public:
void RegisterData(
    IEnumerable^ data,
    String^ name,
    int maxNestingLevel
)

Parameters

data
Type: System.Collections..::.IEnumerable
Application data.
name
Type: System..::.String
Name of the data.
maxNestingLevel
Type: System..::.Int32
Maximum nesting level of business objects.

Remarks

This method creates initial datasource with specified nesting level. It is useful if you create a report in code. In most cases, you don't need to specify the nesting level because it may be selected in the designer's "Choose Report Data" dialog.

See Also

Report Class
RegisterData Overload
FastReport Namespace


RegisterData Method (IEnumerable, String, BOConverterFlags, Int32)

[image]

FastReport.Net Class Reference
Report..::.RegisterData Method (IEnumerable, String, BOConverterFlags, Int32)
Report Class See Also Send Feedback
Obsolete. Registers the application business object to use it in the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    IEnumerable data,
    string name,
    BOConverterFlags flags,
    int maxNestingLevel
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As IEnumerable, _
    name As String, _
    flags As BOConverterFlags, _
    maxNestingLevel As Integer _
)
Visual C++
public:
void RegisterData(
    IEnumerable^ data,
    String^ name,
    BOConverterFlags flags,
    int maxNestingLevel
)

Parameters

data
Type: System.Collections..::.IEnumerable
Application data.
name
Type: System..::.String
Name of the data.
flags
Type: FastReport.Data..::.BOConverterFlags
Not used.
maxNestingLevel
Type: System..::.Int32
Maximum nesting level of business objects.

Remarks

This method is obsolete. Use the RegisterData(IEnumerable, String) method instead.

See Also

Report Class
RegisterData Overload
FastReport Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
Report..::.RemoveChild Method
Report Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base obj
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    obj As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ obj
) sealed

Parameters

obj
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

Report Class
FastReport Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
Report..::.Save Method
Report Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves the report to a stream.
Save(String) | Saves the report to a file.

See Also

Report Class
Report Members
FastReport Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
Report..::.Save Method (Stream)
Report Class See Also Send Feedback
Saves the report to a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to save to.

See Also

Report Class
Save Overload
FastReport Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
Report..::.Save Method (String)
Report Class See Also Send Feedback
Saves the report to a file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file to save to.

See Also

Report Class
Save Overload
FastReport Namespace


SavePrepared Method

[image] [image]

FastReport.Net Class Reference
Report..::.SavePrepared Method
Report Class See Also Send Feedback

Overload List

Name | Description
SavePrepared(Stream) | Saves the prepared report. Report should be prepared using the Prepare()()() method.
SavePrepared(String) | Saves the prepared report. Report should be prepared using the Prepare()()() method.

See Also

Report Class
Report Members
FastReport Namespace


SavePrepared Method (Stream)

[image]

FastReport.Net Class Reference
Report..::.SavePrepared Method (Stream)
Report Class See Also Send Feedback
Saves the prepared report. Report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SavePrepared(
    Stream stream
)
Visual Basic (Declaration)
Public Sub SavePrepared ( _
    stream As Stream _
)
Visual C++
public:
void SavePrepared(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to save to.

See Also

Report Class
SavePrepared Overload
FastReport Namespace


SavePrepared Method (String)

[image]

FastReport.Net Class Reference
Report..::.SavePrepared Method (String)
Report Class See Also Send Feedback
Saves the prepared report. Report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SavePrepared(
    string fileName
)
Visual Basic (Declaration)
Public Sub SavePrepared ( _
    fileName As String _
)
Visual C++
public:
void SavePrepared(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to save to.

See Also

Report Class
SavePrepared Overload
FastReport Namespace


SaveToString Method

[image]

FastReport.Net Class Reference
Report..::.SaveToString Method
Report Class See Also Send Feedback
Saves the report to a string.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SaveToString()
Visual Basic (Declaration)
Public Function SaveToString As String
Visual C++
public:
String^ SaveToString()

Return Value

The string that contains a stream.

See Also

Report Class
FastReport Namespace


SaveToStringBase64 Method

[image]

FastReport.Net Class Reference
Report..::.SaveToStringBase64 Method
Report Class See Also Send Feedback
Saves the report to a string using the Base64 encoding.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SaveToStringBase64()
Visual Basic (Declaration)
Public Function SaveToStringBase64 As String
Visual C++
public:
String^ SaveToStringBase64()

Return Value

The string that contains a stream.

See Also

Report Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Report..::.Serialize Method
Report Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Report Class
FastReport Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
Report..::.SetChildOrder Method
Report Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Overridable Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
)

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

Report Class
FastReport Namespace


SetParameterValue Method

[image]

FastReport.Net Class Reference
Report..::.SetParameterValue Method
Report Class Example See Also Send Feedback
Sets the parameter's value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetParameterValue(
    string complexName,
    Object value
)
Visual Basic (Declaration)
Public Sub SetParameterValue ( _
    complexName As String, _
    value As Object _
)
Visual C++
public:
void SetParameterValue(
    String^ complexName,
    Object^ value
)

Parameters

complexName
Type: System..::.String
The name of the parameter.
value
Type: System..::.Object
Value to set.

Remarks

Use this method to pass a value to the parameter that you've created in the "Data" window. Such parameter may be used everythere in a report; for example, you can print its value or use it in expressions.

You should call this method after the report was loaded and before you run it.

To access a nested parameter, use the "." separator: "MainParameter.NestedParameter"

Note: This method will create the parameter if it does not exist.

Examples

This example shows how to pass a value to the parameter with "MyParam" name:
CopyC#
// load the report
report1.Load("report.frx");
// setup the parameter
report1.SetParameterValue("MyParam", 10);
// show the report
report1.Show();

See Also

Report Class
FastReport Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
Report..::.Show Method
Report Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Prepares the report and shows it in the preview window.
Show(Boolean) | Prepares the report and shows it in the preview window.
Show(Form) | Prepares the report and shows it in the preview window.
Show(Boolean, IWin32Window) | Prepares the report and shows it in the preview window.

See Also

Report Class
Report Members
FastReport Namespace


Show Method

[image]

FastReport.Net Class Reference
Report..::.Show Method
Report Class See Also Send Feedback
Prepares the report and shows it in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

Report Class
Show Overload
FastReport Namespace


Show Method (Boolean)

[image]

FastReport.Net Class Reference
Report..::.Show Method (Boolean)
Report Class See Also Send Feedback
Prepares the report and shows it in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    bool modal
)
Visual Basic (Declaration)
Public Sub Show ( _
    modal As Boolean _
)
Visual C++
public:
void Show(
    bool modal
)

Parameters

modal
Type: System..::.Boolean
A value that specifies whether the preview window should be modal.

See Also

Report Class
Show Overload
FastReport Namespace


Show Method (Form)

[image]

FastReport.Net Class Reference
Report..::.Show Method (Form)
Report Class See Also Send Feedback
Prepares the report and shows it in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    Form mdiParent
)
Visual Basic (Declaration)
Public Sub Show ( _
    mdiParent As Form _
)
Visual C++
public:
void Show(
    Form^ mdiParent
)

Parameters

mdiParent
Type: System.Windows.Forms..::.Form
The main MDI form which will be a parent for the preview window.

See Also

Report Class
Show Overload
FastReport Namespace


Show Method (Boolean, IWin32Window)

[image]

FastReport.Net Class Reference
Report..::.Show Method (Boolean, IWin32Window)
Report Class See Also Send Feedback
Prepares the report and shows it in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    bool modal,
    IWin32Window owner
)
Visual Basic (Declaration)
Public Sub Show ( _
    modal As Boolean, _
    owner As IWin32Window _
)
Visual C++
public:
void Show(
    bool modal,
    IWin32Window^ owner
)

Parameters

modal
Type: System..::.Boolean
A value that specifies whether the preview window should be modal.
owner
Type: System.Windows.Forms..::.IWin32Window
The owner of the preview window.

See Also

Report Class
Show Overload
FastReport Namespace


ShowPrepared Method

[image] [image]

FastReport.Net Class Reference
Report..::.ShowPrepared Method
Report Class See Also Send Feedback

Overload List

Name | Description
ShowPrepared()()() | Previews the report. The report should be prepared using the Prepare()()() method.
ShowPrepared(Boolean) | Previews the prepared report.
ShowPrepared(Form) | Previews the prepared report.
ShowPrepared(Boolean, IWin32Window) | Previews the prepared report.

See Also

Report Class
Report Members
FastReport Namespace


ShowPrepared Method

[image]

FastReport.Net Class Reference
Report..::.ShowPrepared Method
Report Class See Also Send Feedback
Previews the report. The report should be prepared using the Prepare()()() method.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowPrepared()
Visual Basic (Declaration)
Public Sub ShowPrepared
Visual C++
public:
void ShowPrepared()

See Also

Report Class
ShowPrepared Overload
FastReport Namespace


ShowPrepared Method (Boolean)

[image]

FastReport.Net Class Reference
Report..::.ShowPrepared Method (Boolean)
Report Class See Also Send Feedback
Previews the prepared report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowPrepared(
    bool modal
)
Visual Basic (Declaration)
Public Sub ShowPrepared ( _
    modal As Boolean _
)
Visual C++
public:
void ShowPrepared(
    bool modal
)

Parameters

modal
Type: System..::.Boolean
A value that specifies whether the preview window should be modal.

See Also

Report Class
ShowPrepared Overload
FastReport Namespace


ShowPrepared Method (Form)

[image]

FastReport.Net Class Reference
Report..::.ShowPrepared Method (Form)
Report Class See Also Send Feedback
Previews the prepared report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowPrepared(
    Form mdiParent
)
Visual Basic (Declaration)
Public Sub ShowPrepared ( _
    mdiParent As Form _
)
Visual C++
public:
void ShowPrepared(
    Form^ mdiParent
)

Parameters

mdiParent
Type: System.Windows.Forms..::.Form
The main MDI form which will be a parent for the preview window.

See Also

Report Class
ShowPrepared Overload
FastReport Namespace


ShowPrepared Method (Boolean, IWin32Window)

[image]

FastReport.Net Class Reference
Report..::.ShowPrepared Method (Boolean, IWin32Window)
Report Class See Also Send Feedback
Previews the prepared report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowPrepared(
    bool modal,
    IWin32Window owner
)
Visual Basic (Declaration)
Public Sub ShowPrepared ( _
    modal As Boolean, _
    owner As IWin32Window _
)
Visual C++
public:
void ShowPrepared(
    bool modal,
    IWin32Window^ owner
)

Parameters

modal
Type: System..::.Boolean
A value that specifies whether the preview window should be modal.
owner
Type: System.Windows.Forms..::.IWin32Window
The owner of the preview window.

See Also

Report Class
ShowPrepared Overload
FastReport Namespace


ShowPrintDialog Method

[image]

FastReport.Net Class Reference
Report..::.ShowPrintDialog Method
Report Class Example See Also Send Feedback
Shows the "Print" dialog.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPrintDialog(
    out PrinterSettings printerSettings
)
Visual Basic (Declaration)
Public Function ShowPrintDialog ( _
    <OutAttribute> ByRef printerSettings As PrinterSettings _
) As Boolean
Visual C++
public:
bool ShowPrintDialog(
    [OutAttribute] PrinterSettings^% printerSettings
)

Parameters

printerSettings
Type: System.Drawing.Printing..::.PrinterSettings %
Printer-specific settings.

Return Value

true if the dialog was closed by "Print" button.

Examples

Use the following code if you want to show the "Print" dialog, then print:
CopyC#
if (report.Prepare())
{
  PrinterSettings printerSettings = null;
  if (report.ShowPrintDialog(out printerSettings))
  {
    report.PrintPrepared(printerSettings);
  }
}

See Also

Report Class
FastReport Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
Report..::.UpdateLayout Method
Report Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Overridable Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
)

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

Report Class
FastReport Namespace


Report Properties

[image] [image]

FastReport.Net Class Reference
Report Properties
Report Class See Also Send Feedback

The Report type exposes the following members.

Properties

Name | Description
Aborted | Gets a value indicating that report execution was aborted.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AutoFillDataSet | Gets or sets a value indicating whether it is necessary to automatically fill DataSet registered with RegisterData call.
BaseName | The base part of the object's name. (Inherited from Base.)
BaseReport | Gets or sets the base report file name.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Compressed | Gets or sets a value that specifies whether to compress the report file.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ConvertNulls | Gets or sets a value indicating whether the null DB value must be converted to zero, false or empty string depending on the data column type.
Designer | Gets a reference to the report designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dictionary | Gets the report's data.
DoublePass | Gets or sets a value that specifies whether the report engine should perform the second pass.
EmailSettings | Gets the email settings such as recipients, subject, message body.
Engine | Gets a reference to the report engine.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileName | Gets or sets the name of a file the report was loaded from.
FinishReportEvent | Gets or sets a script event name that will be fired when the report is finished.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GraphicCache | Gets a reference to the graphics cache for this report.
HasDialogs | Gets a value indicating that this report contains dialog forms.
InitialPageNumber | Gets or sets the initial page number for PageN/PageNofM system variables.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
MaxPages | Gets or sets the maximum number of generated pages in a prepared report.
Name | This property is not relevant to this class.
Operation | Gets the report operation that is currently performed.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Pages | Gets the pages contained in this report.
Parameters | Gets the collection of report parameters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Password | Gets or sets the report password.
PreparedPages | Gets a pages of the prepared report.
Preview | Gets or sets the report preview control.
PrintSettings | Gets the print settings such as printer name, copies, pages to print etc.
ReferencedAssemblies | Gets or sets an array of assembly names that will be used to compile the report script.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportInfo | Gets or sets the report information such as report name, author, description etc.
ReportResourceString | Gets or sets the resource string that contains the report.
Restrictions | This property is not relevant to this class.
ScriptLanguage | Gets or sets the script language of this report.
ScriptRestrictions | Gets or sets a set of permissions that will be restricted for the script code.
ScriptText | Gets or sets the report script.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SmoothGraphics | Gets or sets a value that specifies if the graphic objects such as bitmaps and shapes should be displayed smoothly.
StartReportEvent | Gets or sets a script event name that will be fired when the report starts.
StoreInResources | Gets or sets a value that determines whether to store the report in the application resources. Use this property in the MS Visual Studio IDE only.
Styles | Gets or sets the collection of styles used in this report.
TextQuality | Gets or sets a value that specifies the quality of text rendering.
UseFileCache | Gets or sets a value that specifies whether to use the file cache rather than memory to store the prepared report pages.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Report Class
FastReport Namespace


Aborted Property

[image]

FastReport.Net Class Reference
Report..::.Aborted Property
Report Class See Also Send Feedback
Gets a value indicating that report execution was aborted.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Aborted { get; }
Visual Basic (Declaration)
Public ReadOnly Property Aborted As Boolean
Visual C++
public:
property bool Aborted {
    bool get ();
}

See Also

Report Class
FastReport Namespace


AutoFillDataSet Property

[image]

FastReport.Net Class Reference
Report..::.AutoFillDataSet Property
Report Class See Also Send Feedback
Gets or sets a value indicating whether it is necessary to automatically fill DataSet registered with RegisterData call.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFillDataSet { get; set; }
Visual Basic (Declaration)
Public Property AutoFillDataSet As Boolean
Visual C++
public:
property bool AutoFillDataSet {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true (by default), FastReport will automatically fill the DataSet with data when you trying to run a report. Set it to false if you want to fill the DataSet by yourself.

See Also

Report Class
FastReport Namespace


BaseReport Property

[image]

FastReport.Net Class Reference
Report..::.BaseReport Property
Report Class See Also Send Feedback
Gets or sets the base report file name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BaseReport { get; set; }
Visual Basic (Declaration)
Public Property BaseReport As String
Visual C++
public:
property String^ BaseReport {
    String^ get ();
    void set (String^ value);
}

Remarks

This property contains the name of a report file this report is inherited from. Note: setting this property to non-empty value will clear the report and load the base file into it.

See Also

Report Class
FastReport Namespace


Compressed Property

[image]

FastReport.Net Class Reference
Report..::.Compressed Property
Report Class See Also Send Feedback
Gets or sets a value that specifies whether to compress the report file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Compressed { get; set; }
Visual Basic (Declaration)
Public Property Compressed As Boolean
Visual C++
public:
property bool Compressed {
    bool get ();
    void set (bool value);
}

Remarks

The report file is compressed using the Gzip algorithm. So you can open the compressed report in any zip-compatible archiver.

See Also

Report Class
FastReport Namespace


ConvertNulls Property

[image]

FastReport.Net Class Reference
Report..::.ConvertNulls Property
Report Class See Also Send Feedback
Gets or sets a value indicating whether the null DB value must be converted to zero, false or empty string depending on the data column type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ConvertNulls { get; set; }
Visual Basic (Declaration)
Public Property ConvertNulls As Boolean
Visual C++
public:
property bool ConvertNulls {
    bool get ();
    void set (bool value);
}

Remarks

This property is true by default. If you set it to false, you should check the DB value before you do something with it (for example, typecast it to any type, use it in a expression etc.)

See Also

Report Class
FastReport Namespace


Designer Property

[image]

FastReport.Net Class Reference
Report..::.Designer Property
Report Class See Also Send Feedback
Gets a reference to the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; set; }
Visual Basic (Declaration)
Public Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
    void set (Designer^ value);
}

Remarks

This property can be used when report is designing. In other cases it returns null.

See Also

Report Class
FastReport Namespace


Dictionary Property

[image]

FastReport.Net Class Reference
Report..::.Dictionary Property
Report Class See Also Send Feedback
Gets the report's data.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Dictionary Dictionary { get; set; }
Visual Basic (Declaration)
Public Property Dictionary As Dictionary
Visual C++
public:
property Dictionary^ Dictionary {
    Dictionary^ get ();
    void set (Dictionary^ value);
}

Remarks

The dictionary contains all data items such as connections, data sources, parameters, system variables.

See Also

Report Class
FastReport Namespace


DoublePass Property

[image]

FastReport.Net Class Reference
Report..::.DoublePass Property
Report Class See Also Send Feedback
Gets or sets a value that specifies whether the report engine should perform the second pass.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DoublePass { get; set; }
Visual Basic (Declaration)
Public Property DoublePass As Boolean
Visual C++
public:
property bool DoublePass {
    bool get ();
    void set (bool value);
}

Remarks

Typically the second pass is necessary to print the number of total pages. It also may be used to perform some calculations on the first pass and print its results on the second pass.

Use the Engine.FirstPass, Engine.FinalPass properties to determine which pass the engine is performing now.

See Also

Report Class
FastReport Namespace


EmailSettings Property

[image]

FastReport.Net Class Reference
Report..::.EmailSettings Property
Report Class See Also Send Feedback
Gets the email settings such as recipients, subject, message body.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailSettings EmailSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmailSettings As EmailSettings
Visual C++
public:
property EmailSettings^ EmailSettings {
    EmailSettings^ get ();
}

See Also

Report Class
FastReport Namespace


Engine Property

[image]

FastReport.Net Class Reference
Report..::.Engine Property
Report Class See Also Send Feedback
Gets a reference to the report engine.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportEngine Engine { get; }
Visual Basic (Declaration)
Public ReadOnly Property Engine As ReportEngine
Visual C++
public:
property ReportEngine^ Engine {
    ReportEngine^ get ();
}

Remarks

This property can be used when report is running. In other cases it returns null.

See Also

Report Class
FastReport Namespace


FileName Property

[image]

FastReport.Net Class Reference
Report..::.FileName Property
Report Class See Also Send Feedback
Gets or sets the name of a file the report was loaded from.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FileName { get; set; }
Visual Basic (Declaration)
Public Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to support the FastReport.Net infrastructure; typically you don't need to use it.

See Also

Report Class
FastReport Namespace


FinishReportEvent Property

[image]

FastReport.Net Class Reference
Report..::.FinishReportEvent Property
Report Class See Also Send Feedback
Gets or sets a script event name that will be fired when the report is finished.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FinishReportEvent { get; set; }
Visual Basic (Declaration)
Public Property FinishReportEvent As String
Visual C++
public:
property String^ FinishReportEvent {
    String^ get ();
    void set (String^ value);
}

See Also

Report Class
FastReport Namespace


GraphicCache Property

[image]

FastReport.Net Class Reference
Report..::.GraphicCache Property
Report Class See Also Send Feedback
Gets a reference to the graphics cache for this report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GraphicCache GraphicCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property GraphicCache As GraphicCache
Visual C++
public:
property GraphicCache^ GraphicCache {
    GraphicCache^ get ();
}

Remarks

This property is used to support the FastReport.Net infrastructure. Do not use it directly.

See Also

Report Class
FastReport Namespace


HasDialogs Property

[image]

FastReport.Net Class Reference
Report..::.HasDialogs Property
Report Class See Also Send Feedback
Gets a value indicating that this report contains dialog forms.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasDialogs { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasDialogs As Boolean
Visual C++
public:
property bool HasDialogs {
    bool get ();
}

See Also

Report Class
FastReport Namespace


InitialPageNumber Property

[image]

FastReport.Net Class Reference
Report..::.InitialPageNumber Property
Report Class See Also Send Feedback
Gets or sets the initial page number for PageN/PageNofM system variables.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int InitialPageNumber { get; set; }
Visual Basic (Declaration)
Public Property InitialPageNumber As Integer
Visual C++
public:
property int InitialPageNumber {
    int get ();
    void set (int value);
}

See Also

Report Class
FastReport Namespace


MaxPages Property

[image]

FastReport.Net Class Reference
Report..::.MaxPages Property
Report Class See Also Send Feedback
Gets or sets the maximum number of generated pages in a prepared report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int MaxPages { get; set; }
Visual Basic (Declaration)
Public Property MaxPages As Integer
Visual C++
public:
property int MaxPages {
    int get ();
    void set (int value);
}

Remarks

Use this property to limit the number of pages in a prepared report.

See Also

Report Class
FastReport Namespace


Name Property

[image]

FastReport.Net Class Reference
Report..::.Name Property
Report Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Report Class
FastReport Namespace


Operation Property

[image]

FastReport.Net Class Reference
Report..::.Operation Property
Report Class See Also Send Feedback
Gets the report operation that is currently performed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportOperation Operation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Operation As ReportOperation
Visual C++
public:
property ReportOperation Operation {
    ReportOperation get ();
}

See Also

Report Class
FastReport Namespace


Pages Property

[image]

FastReport.Net Class Reference
Report..::.Pages Property
Report Class Example See Also Send Feedback
Gets the pages contained in this report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageCollection Pages { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pages As PageCollection
Visual C++
public:
property PageCollection^ Pages {
    PageCollection^ get ();
}

Remarks

This property contains pages of all types (report and dialog). Use the is/as operators if you want to work with pages of ReportPage type.

Examples

The following code demonstrates how to access the first report page:
CopyC#
ReportPage page1 = report1.Pages[0] as ReportPage;

See Also

Report Class
FastReport Namespace


Parameters Property

[image]

FastReport.Net Class Reference
Report..::.Parameters Property
Report Class See Also Send Feedback
Gets the collection of report parameters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

Remarks

Parameters are displayed in the "Data" window under the "Parameters" node.

Typical use of parameters is to pass some static data from the application to the report. You can print such data, use it in the data row filter, script etc.

Another way to use parameters is to define some reusable piece of code, for example, to define an expression that will return the concatenation of first and second employee name. In this case, you set the parameter's Expression property to something like this: [Employees.FirstName] + " " + [Employees.LastName]. Now this parameter may be used in the report to print full employee name. Each time you access such parameter, it will calculate the expression and return its value.

You can create nested parameters. To do this, add the new Parameter to the Parameters collection of the root parameter. To access the nested parameter, you may use the GetParameter(String) method.

To get or set the parameter's value, use the GetParameterValue(String) and SetParameterValue(String, Object) methods. To set the parameter's expression, use the GetParameter(String) method that returns a Parameter object and set its Expression property.

See Also

Report Class
FastReport Namespace


Password Property

[image]

FastReport.Net Class Reference
Report..::.Password Property
Report Class See Also Send Feedback
Gets or sets the report password.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Remarks

When you try to load the password-protected report, you will be asked for a password. You also may specify the password in this property before loading the report. In this case the report will load silently.

Password-protected report file is crypted using Rijndael algorithm. Do not forget your password! It will be hard or even impossible to open the protected file in this case.

See Also

Report Class
FastReport Namespace


PreparedPages Property

[image]

FastReport.Net Class Reference
Report..::.PreparedPages Property
Report Class See Also Send Feedback
Gets a pages of the prepared report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreparedPages PreparedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreparedPages As PreparedPages
Visual C++
public:
property PreparedPages^ PreparedPages {
    PreparedPages^ get ();
}

See Also

Report Class
FastReport Namespace


Preview Property

[image]

FastReport.Net Class Reference
Report..::.Preview Property
Report Class See Also Send Feedback
Gets or sets the report preview control.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewControl Preview { get; set; }
Visual Basic (Declaration)
Public Property Preview As PreviewControl
Visual C++
public:
property PreviewControl^ Preview {
    PreviewControl^ get ();
    void set (PreviewControl^ value);
}

Remarks

Use this property to attach a custom preview to your report. To do this, place the PreviewControl control to your form and set the report's Preview property to this control.

See Also

Report Class
FastReport Namespace


PrintSettings Property

[image]

FastReport.Net Class Reference
Report..::.PrintSettings Property
Report Class See Also Send Feedback
Gets the print settings such as printer name, copies, pages to print etc.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PrintSettings PrintSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSettings As PrintSettings
Visual C++
public:
property PrintSettings^ PrintSettings {
    PrintSettings^ get ();
}

See Also

Report Class
FastReport Namespace


ReferencedAssemblies Property

[image]

FastReport.Net Class Reference
Report..::.ReferencedAssemblies Property
Report Class See Also Send Feedback
Gets or sets an array of assembly names that will be used to compile the report script.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string[] ReferencedAssemblies { get; set; }
Visual Basic (Declaration)
Public Property ReferencedAssemblies As String()
Visual C++
public:
property array<String^>^ ReferencedAssemblies {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

By default this property contains the following assemblies: "System.dll", "System.Drawing.dll", "System.Windows.Forms.dll", "System.Data.dll", "System.Xml.dll". If your script uses some types from another assemblies, you have to add them to this property.

See Also

Report Class
FastReport Namespace


ReportInfo Property

[image]

FastReport.Net Class Reference
Report..::.ReportInfo Property
Report Class See Also Send Feedback
Gets or sets the report information such as report name, author, description etc.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportInfo ReportInfo { get; set; }
Visual Basic (Declaration)
Public Property ReportInfo As ReportInfo
Visual C++
public:
property ReportInfo^ ReportInfo {
    ReportInfo^ get ();
    void set (ReportInfo^ value);
}

See Also

Report Class
FastReport Namespace


ReportResourceString Property

[image]

FastReport.Net Class Reference
Report..::.ReportResourceString Property
Report Class See Also Send Feedback
Gets or sets the resource string that contains the report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportResourceString { get; set; }
Visual Basic (Declaration)
Public Property ReportResourceString As String
Visual C++
public:
property String^ ReportResourceString {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used by the MS Visual Studio to store the report. Do not use it directly.

See Also

Report Class
FastReport Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
Report..::.Restrictions Property
Report Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

Report Class
FastReport Namespace


ScriptLanguage Property

[image]

FastReport.Net Class Reference
Report..::.ScriptLanguage Property
Report Class See Also Send Feedback
Gets or sets the script language of this report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Language ScriptLanguage { get; set; }
Visual Basic (Declaration)
Public Property ScriptLanguage As Language
Visual C++
public:
property Language ScriptLanguage {
    Language get ();
    void set (Language value);
}

Remarks

Note: changing this property will reset the report script to default empty script.

See Also

Report Class
FastReport Namespace


ScriptRestrictions Property

[image]

FastReport.Net Class Reference
Report..::.ScriptRestrictions Property
Report Class See Also Send Feedback
Gets or sets a set of permissions that will be restricted for the script code.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PermissionSet ScriptRestrictions { get; set; }
Visual Basic (Declaration)
Public Property ScriptRestrictions As PermissionSet
Visual C++
public:
property PermissionSet^ ScriptRestrictions {
    PermissionSet^ get ();
    void set (PermissionSet^ value);
}

Remarks

Since the report script is compiled into .NET assembly, it allows you to do ANYTHING. For example, you may create a script that will read/write files from/to a disk. This property is used to restrict such operations.

Examples

This example shows how to restrict the file IO operations in a script:
CopyC#
using System.Security;
using System.Security.Permissions;
...
PermissionSet ps = new PermissionSet(PermissionState.None);
ps.AddPermission(new FileIOPermission(PermissionState.Unrestricted));
report1.ScriptRestrictions = ps;
report1.Prepare();

See Also

Report Class
FastReport Namespace


ScriptText Property

[image]

FastReport.Net Class Reference
Report..::.ScriptText Property
Report Class See Also Send Feedback
Gets or sets the report script.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ScriptText { get; set; }
Visual Basic (Declaration)
Public Property ScriptText As String
Visual C++
public:
property String^ ScriptText {
    String^ get ();
    void set (String^ value);
}

Remarks

The script contains the ReportScript class that contains all report objects' event handlers and own items such as private fields, properties, methods etc. The script contains only items written by you. Unlike other report generators, the script does not contain report objects declarations, initialization code. It is added automatically when you run the report.

By default this property contains an empty script text. You may see it in the designer when you switch to the Code window.

If you set this property programmatically, you have to declare the FastReport namespace and the ReportScript class in it. Do not declare report items (such as bands, objects, etc) in the ReportScript class: the report engine does this automatically when you run the report.

Security note: since the report script is compiled into .NET assembly, it allows you to do ANYTHING. For example, you may create a script that will read/write files from/to a disk. To restrict such operations, use the ScriptRestrictions property.

See Also

Report Class
FastReport Namespace


SmoothGraphics Property

[image]

FastReport.Net Class Reference
Report..::.SmoothGraphics Property
Report Class See Also Send Feedback
Gets or sets a value that specifies if the graphic objects such as bitmaps and shapes should be displayed smoothly.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SmoothGraphics { get; set; }
Visual Basic (Declaration)
Public Property SmoothGraphics As Boolean
Visual C++
public:
property bool SmoothGraphics {
    bool get ();
    void set (bool value);
}

See Also

Report Class
FastReport Namespace


StartReportEvent Property

[image]

FastReport.Net Class Reference
Report..::.StartReportEvent Property
Report Class See Also Send Feedback
Gets or sets a script event name that will be fired when the report starts.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string StartReportEvent { get; set; }
Visual Basic (Declaration)
Public Property StartReportEvent As String
Visual C++
public:
property String^ StartReportEvent {
    String^ get ();
    void set (String^ value);
}

See Also

Report Class
FastReport Namespace


StoreInResources Property

[image]

FastReport.Net Class Reference
Report..::.StoreInResources Property
Report Class See Also Send Feedback
Gets or sets a value that determines whether to store the report in the application resources. Use this property in the MS Visual Studio IDE only.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StoreInResources { get; set; }
Visual Basic (Declaration)
Public Property StoreInResources As Boolean
Visual C++
public:
property bool StoreInResources {
    bool get ();
    void set (bool value);
}

Remarks

By default this property is true. When set to false, you should store your report in a file.

See Also

Report Class
FastReport Namespace


Styles Property

[image]

FastReport.Net Class Reference
Report..::.Styles Property
Report Class See Also Send Feedback
Gets or sets the collection of styles used in this report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StyleCollection Styles { get; set; }
Visual Basic (Declaration)
Public Property Styles As StyleCollection
Visual C++
public:
property StyleCollection^ Styles {
    StyleCollection^ get ();
    void set (StyleCollection^ value);
}

See Also

Report Class
FastReport Namespace


TextQuality Property

[image]

FastReport.Net Class Reference
Report..::.TextQuality Property
Report Class See Also Send Feedback
Gets or sets a value that specifies the quality of text rendering.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextQuality TextQuality { get; set; }
Visual Basic (Declaration)
Public Property TextQuality As TextQuality
Visual C++
public:
property TextQuality TextQuality {
    TextQuality get ();
    void set (TextQuality value);
}

Remarks

Note: the default property value is TextQuality.Default. That means the report may look different depending on OS settings. This property does not affect the printout.

See Also

Report Class
FastReport Namespace


UseFileCache Property

[image]

FastReport.Net Class Reference
Report..::.UseFileCache Property
Report Class See Also Send Feedback
Gets or sets a value that specifies whether to use the file cache rather than memory to store the prepared report pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseFileCache { get; set; }
Visual Basic (Declaration)
Public Property UseFileCache As Boolean
Visual C++
public:
property bool UseFileCache {
    bool get ();
    void set (bool value);
}

See Also

Report Class
FastReport Namespace


Report Events

[image] [image]

FastReport.Net Class Reference
Report Events
Report Class See Also Send Feedback

The Report type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FinishReport | Occurs when report execution is finished.
LoadBaseReport | Occurs when report is inherited and trying to load a base report.
StartReport | Occurs when report execution is started.

See Also

Report Class
FastReport Namespace


FinishReport Event

[image]

FastReport.Net Class Reference
Report..::.FinishReport Event
Report Class See Also Send Feedback
Occurs when report execution is finished.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler FinishReport
Visual Basic (Declaration)
Public Event FinishReport As EventHandler
Visual C++
public:
 event EventHandler^ FinishReport {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Report Class
FastReport Namespace


LoadBaseReport Event

[image]

FastReport.Net Class Reference
Report..::.LoadBaseReport Event
Report Class See Also Send Feedback
Occurs when report is inherited and trying to load a base report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event CustomLoadEventHandler LoadBaseReport
Visual Basic (Declaration)
Public Event LoadBaseReport As CustomLoadEventHandler
Visual C++
public:
 event CustomLoadEventHandler^ LoadBaseReport {
    void add (CustomLoadEventHandler^ value);
    void remove (CustomLoadEventHandler^ value);
}

Remarks

Typical use of this event is to load the base report from a database instead of a file.

See Also

Report Class
FastReport Namespace


StartReport Event

[image]

FastReport.Net Class Reference
Report..::.StartReport Event
Report Class See Also Send Feedback
Occurs when report execution is started.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler StartReport
Visual Basic (Declaration)
Public Event StartReport As EventHandler
Visual C++
public:
 event EventHandler^ StartReport {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Report Class
FastReport Namespace


ReportComponentBase Class

[image]

FastReport.Net Class Reference
ReportComponentBase Class
Members See Also Send Feedback
Base class for all report objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class ReportComponentBase : ComponentBase
Visual Basic (Declaration)
Public MustInherit Class ReportComponentBase _
    Inherits ComponentBase
Visual C++
public ref class ReportComponentBase abstract : public ComponentBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport.Barcode..::.BarcodeObject
FastReport..::.BreakableComponent
FastReport..::.CheckBoxObject
FastReport..::.LineObject
FastReport.Map..::.MapObject
FastReport.MSChart..::.MSChartObject
FastReport..::.PictureObject
FastReport..::.ShapeObject
FastReport..::.SubreportObject
FastReport..::.ZipCodeObject

See Also

ReportComponentBase Members
FastReport Namespace


ReportComponentBase Members

[image] [image]

FastReport.Net Class Reference
ReportComponentBase Members
ReportComponentBase Class Constructors Methods Properties Events See Also Send Feedback

The ReportComponentBase type exposes the following members.

Constructors

Name | Description
ReportComponentBase | Initializes a new instance of the ReportComponentBase class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object.
AssignPreviewEvents | Copies event handlers from another similar object.
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Overrides ComponentBase..::.CheckParent(Boolean).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background.
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to.
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface.
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent.
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides Base..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Overrides Base..::.OnAfterLoad()()().)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent.
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent.
OnClick | This method fires the Click event and the script code connected to the ClickEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent.
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent.
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent.
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it.
RestoreStyle | Restores the current style.
SaveState | Saves the object's state before printing it.
SaveStyle | Saves the current style.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data.
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page.
Bookmark | Gets or sets a bookmark expression.
Border | Gets or sets an object's border.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window.
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows.
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported.
Fill | Gets or sets an object's fill.
FillColor | Gets or sets the fill color in a simple manner.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview.
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed.
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties.
FlagUseBorder | Determines if the object uses the Border.
FlagUseFill | Determines if the object uses the fill.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side.
Height | Gets or sets the height of the object. (Overrides ComponentBase..::.Height.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it.
Hyperlink | Gets or sets a hyperlink.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window.
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window.
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window.
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window.
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer.
PrintOn | Gets or sets a value that determines where to print the object.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data.
AfterPrint | This event occurs after the object was added to the preview pages.
BeforePrint | This event occurs before the object is added to the preview pages.
Click | This event occurs when the user clicks the object in the preview window.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window.
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window.
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window.
MouseMove | This event occurs when the user moves the mouse over the object in the preview window.
MouseUp | This event occurs when the user releases the mouse button in the preview window.

See Also

ReportComponentBase Class
FastReport Namespace


ReportComponentBase Constructor

[image]

FastReport.Net Class Reference
ReportComponentBase Constructor
ReportComponentBase Class See Also Send Feedback
Initializes a new instance of the ReportComponentBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportComponentBase()

See Also

ReportComponentBase Class
FastReport Namespace


ReportComponentBase Methods

[image] [image]

FastReport.Net Class Reference
ReportComponentBase Methods
ReportComponentBase Class See Also Send Feedback

The ReportComponentBase type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object.
AssignPreviewEvents | Copies event handlers from another similar object.
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Overrides ComponentBase..::.CheckParent(Boolean).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background.
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to.
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface.
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent.
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides Base..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Overrides Base..::.OnAfterLoad()()().)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent.
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent.
OnClick | This method fires the Click event and the script code connected to the ClickEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent.
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent.
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent.
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it.
RestoreStyle | Restores the current style.
SaveState | Saves the object's state before printing it.
SaveStyle | Saves the current style.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportComponentBase Class
FastReport Namespace


ApplyStyle Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.ApplyStyle Method
ReportComponentBase Class See Also Send Feedback
Applies the style settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void ApplyStyle(
    Style style
)
Visual Basic (Declaration)
Public Overridable Sub ApplyStyle ( _
    style As Style _
)
Visual C++
public:
virtual void ApplyStyle(
    Style^ style
)

Parameters

style
Type: FastReport..::.Style
Style to apply.

See Also

ReportComponentBase Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Assign Method
ReportComponentBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ReportComponentBase Class
FastReport Namespace
AssignAll Method


AssignFormat Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.AssignFormat Method
ReportComponentBase Class See Also Send Feedback
Assigns a format from another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AssignFormat(
    ReportComponentBase source
)
Visual Basic (Declaration)
Public Overridable Sub AssignFormat ( _
    source As ReportComponentBase _
)
Visual C++
public:
virtual void AssignFormat(
    ReportComponentBase^ source
)

Parameters

source
Type: FastReport..::.ReportComponentBase
Source object to assign a format from.

See Also

ReportComponentBase Class
FastReport Namespace


AssignPreviewEvents Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.AssignPreviewEvents Method
ReportComponentBase Class See Also Send Feedback
Copies event handlers from another similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AssignPreviewEvents(
    Base source
)
Visual Basic (Declaration)
Public Overridable Sub AssignPreviewEvents ( _
    source As Base _
)
Visual C++
public:
virtual void AssignPreviewEvents(
    Base^ source
)

Parameters

source
Type: FastReport..::.Base
The object to copy handlers from.

See Also

ReportComponentBase Class
FastReport Namespace


CalcHeight Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.CalcHeight Method
ReportComponentBase Class See Also Send Feedback
Calculates the object's height.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual float CalcHeight()
Visual Basic (Declaration)
Public Overridable Function CalcHeight As Single
Visual C++
public:
virtual float CalcHeight()

Return Value

Actual object's height, in pixels.

Remarks

Applicable to objects that contain several text lines, such as TextObject. Returns the height needed to display all the text lines.

See Also

ReportComponentBase Class
FastReport Namespace


CheckParent Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.CheckParent Method
ReportComponentBase Class See Also Send Feedback
Checks if the object is inside its parent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void CheckParent(
    bool immediately
)
Visual Basic (Declaration)
Public Overrides Sub CheckParent ( _
    immediately As Boolean _
)
Visual C++
public:
virtual void CheckParent(
    bool immediately
) override

Parameters

immediately
Type: System..::.Boolean
if true, check now independent of any conditions.

Remarks

Typically you don't need to use or override this method.

When you move an object with the mouse, it may be moved outside its parent. If so, this method must find a new parent for the object and correct it's Left, Top and Parent properties. If immediately parameter is false, you can optimize the method to search for new parent only if the object's bounds are outside parent. If this parameter is true, you must skip any optimizations and search for a parent immediately.

See Also

ReportComponentBase Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBase..::.Dispose Method
ReportComponentBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ReportComponentBase Class
ReportComponentBase Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Draw Method
ReportComponentBase Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

ReportComponentBase Class
FastReport Namespace


DrawBackground Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.DrawBackground Method
ReportComponentBase Class See Also Send Feedback
Draws the object's background.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DrawBackground(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Sub DrawBackground ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
void DrawBackground(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.

See Also

ReportComponentBase Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBase..::.DrawMarkers Method
ReportComponentBase Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers.
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers.

See Also

ReportComponentBase Class
ReportComponentBase Members
FastReport Namespace


DrawMarkers Method (FRPaintEventArgs)

[image]

FastReport.Net Class Reference
ReportComponentBase..::.DrawMarkers Method (FRPaintEventArgs)
ReportComponentBase Class See Also Send Feedback
Draws the object's markers.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DrawMarkers(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Sub DrawMarkers ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
void DrawMarkers(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.

See Also

ReportComponentBase Class
DrawMarkers Overload
FastReport Namespace


DrawMarkers Method (FRPaintEventArgs, MarkerStyle)

[image]

FastReport.Net Class Reference
ReportComponentBase..::.DrawMarkers Method (FRPaintEventArgs, MarkerStyle)
ReportComponentBase Class See Also Send Feedback
Draws the object's markers.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DrawMarkers(
    FRPaintEventArgs e,
    MarkerStyle style
)
Visual Basic (Declaration)
Public Sub DrawMarkers ( _
    e As FRPaintEventArgs, _
    style As MarkerStyle _
)
Visual C++
public:
void DrawMarkers(
    FRPaintEventArgs^ e,
    MarkerStyle style
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
style
Type: FastReport..::.MarkerStyle
Marker style

See Also

ReportComponentBase Class
DrawMarkers Overload
FastReport Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FinalizeComponent Method
ReportComponentBase Class See Also Send Feedback
Performs a finalization after the report is finished.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void FinalizeComponent()
Visual Basic (Declaration)
Public Overridable Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent()

Remarks

This method is used by the report engine, do not call it directly.

See Also

ReportComponentBase Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.GetContextMenu Method
ReportComponentBase Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

ReportComponentBase Class
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.GetData Method
ReportComponentBase Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetData()
Visual Basic (Declaration)
Public Overridable Sub GetData
Visual C++
public:
virtual void GetData()

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

ReportComponentBase Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.GetExpressions Method
ReportComponentBase Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

ReportComponentBase Class
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.GetPreferredSize Method
ReportComponentBase Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

ReportComponentBase Class
FastReport Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.HandleMouseDown Method
ReportComponentBase Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

ReportComponentBase Class
FastReport Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.InitializeComponent Method
ReportComponentBase Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void InitializeComponent()
Visual Basic (Declaration)
Public Overridable Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent()

Remarks

This method is used by the report engine, do not call it directly.

See Also

ReportComponentBase Class
FastReport Namespace


IsVisible Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.IsVisible Method
ReportComponentBase Class See Also Send Feedback
Determines if the object is visible on current drawing surface.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool IsVisible(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overridable Function IsVisible ( _
    e As FRPaintEventArgs _
) As Boolean
Visual C++
public:
virtual bool IsVisible(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.

See Also

ReportComponentBase Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBase..::.MemberwiseClone Method
ReportComponentBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportComponentBase Class
ReportComponentBase Members
FastReport Namespace


OnAfterData Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnAfterData Method
ReportComponentBase Class See Also Send Feedback
This method fires the AfterData event and the script code connected to the AfterDataEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnAfterData(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnAfterData ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnAfterData(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnAfterInsert Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnAfterInsert Method
ReportComponentBase Class See Also Send Feedback
Called after the new object was inserted in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterInsert(
    InsertFrom source
)
Visual Basic (Declaration)
Public Overrides Sub OnAfterInsert ( _
    source As InsertFrom _
)
Visual C++
public:
virtual void OnAfterInsert(
    InsertFrom source
) override

Parameters

source
Type: FastReport..::.InsertFrom
The insertion source.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called when new object is inserted, pasted from clipboard or dragged from "Dictionary" window. You may override this method if you need to perform some actions when object is inserted. Typical implementation invokes the object's editor if "Edit after insert" flag is set in the designer options.

See Also

ReportComponentBase Class
FastReport Namespace


OnAfterLoad Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnAfterLoad Method
ReportComponentBase Class See Also Send Feedback
Called after all report objects were loaded.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterLoad()
Visual Basic (Declaration)
Public Overrides Sub OnAfterLoad
Visual C++
public:
virtual void OnAfterLoad() override

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

See Also

ReportComponentBase Class
FastReport Namespace


OnAfterPrint Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnAfterPrint Method
ReportComponentBase Class See Also Send Feedback
This method fires the AfterPrint event and the script code connected to the AfterPrintEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnAfterPrint(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnAfterPrint ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnAfterPrint(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnBeforePrint Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnBeforePrint Method
ReportComponentBase Class See Also Send Feedback
This method fires the BeforePrint event and the script code connected to the BeforePrintEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnBeforePrint(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnBeforePrint ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnBeforePrint(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnClick Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnClick Method
ReportComponentBase Class See Also Send Feedback
This method fires the Click event and the script code connected to the ClickEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnClick(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnClick ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnClick(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnMouseDown Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnMouseDown Method
ReportComponentBase Class See Also Send Feedback
This method fires the MouseDown event and the script code connected to the MouseDownEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseDown(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnMouseEnter Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnMouseEnter Method
ReportComponentBase Class See Also Send Feedback
This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseEnter(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseEnter(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnMouseLeave Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnMouseLeave Method
ReportComponentBase Class See Also Send Feedback
This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseLeave(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnMouseMove Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnMouseMove Method
ReportComponentBase Class See Also Send Feedback
This method fires the MouseMove event and the script code connected to the MouseMoveEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnMouseUp Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnMouseUp Method
ReportComponentBase Class See Also Send Feedback
This method fires the MouseUp event and the script code connected to the MouseUpEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseUp(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


OnMouseWheel Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.OnMouseWheel Method
ReportComponentBase Class See Also Send Feedback
This method is fired when the user scrolls the mouse in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseWheel(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

ReportComponentBase Class
FastReport Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.RestoreState Method
ReportComponentBase Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RestoreState()
Visual Basic (Declaration)
Public Overridable Sub RestoreState
Visual C++
public:
virtual void RestoreState()

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

ReportComponentBase Class
FastReport Namespace


RestoreStyle Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.RestoreStyle Method
ReportComponentBase Class See Also Send Feedback
Restores the current style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RestoreStyle()
Visual Basic (Declaration)
Public Overridable Sub RestoreStyle
Visual C++
public:
virtual void RestoreStyle()

See Also

ReportComponentBase Class
FastReport Namespace


SaveState Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.SaveState Method
ReportComponentBase Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SaveState()
Visual Basic (Declaration)
Public Overridable Sub SaveState
Visual C++
public:
virtual void SaveState()

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

ReportComponentBase Class
FastReport Namespace


SaveStyle Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.SaveStyle Method
ReportComponentBase Class See Also Send Feedback
Saves the current style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SaveStyle()
Visual Basic (Declaration)
Public Overridable Sub SaveStyle
Visual C++
public:
virtual void SaveStyle()

See Also

ReportComponentBase Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Serialize Method
ReportComponentBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ReportComponentBase Class
FastReport Namespace


ReportComponentBase Properties

[image] [image]

FastReport.Net Class Reference
ReportComponentBase Properties
ReportComponentBase Class See Also Send Feedback

The ReportComponentBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data.
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page.
Bookmark | Gets or sets a bookmark expression.
Border | Gets or sets an object's border.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window.
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows.
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported.
Fill | Gets or sets an object's fill.
FillColor | Gets or sets the fill color in a simple manner.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview.
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed.
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties.
FlagUseBorder | Determines if the object uses the Border.
FlagUseFill | Determines if the object uses the fill.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side.
Height | Gets or sets the height of the object. (Overrides ComponentBase..::.Height.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it.
Hyperlink | Gets or sets a hyperlink.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window.
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window.
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window.
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window.
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer.
PrintOn | Gets or sets a value that determines where to print the object.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ReportComponentBase Class
FastReport Namespace


AfterDataEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.AfterDataEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired after the object was filled with data.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AfterDataEvent { get; set; }
Visual Basic (Declaration)
Public Property AfterDataEvent As String
Visual C++
public:
property String^ AfterDataEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


AfterPrintEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.AfterPrintEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired after the object was printed in the preview page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AfterPrintEvent { get; set; }
Visual Basic (Declaration)
Public Property AfterPrintEvent As String
Visual C++
public:
property String^ AfterPrintEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


BeforePrintEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.BeforePrintEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired before the object will be printed in the preview page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BeforePrintEvent { get; set; }
Visual Basic (Declaration)
Public Property BeforePrintEvent As String
Visual C++
public:
property String^ BeforePrintEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


Bookmark Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Bookmark Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a bookmark expression.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Bookmark { get; set; }
Visual Basic (Declaration)
Public Property Bookmark As String
Visual C++
public:
property String^ Bookmark {
    String^ get ();
    void set (String^ value);
}

Remarks

This property can contain any valid expression that returns a bookmark name. This can be, for example, a data column. To navigate to a bookmark, you have to use the Hyperlink property.

See Also

ReportComponentBase Class
FastReport Namespace


Border Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Border Property
ReportComponentBase Class See Also Send Feedback
Gets or sets an object's border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Border Border { get; set; }
Visual Basic (Declaration)
Public Overridable Property Border As Border
Visual C++
public:
virtual property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


CanGrow Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.CanGrow Property
ReportComponentBase Class See Also Send Feedback
Determines if the object can grow.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

Remarks

This property is applicable to the bands or text objects that can contain several text lines. If the property is set to true, object will grow to display all the information that it contains.

See Also

ReportComponentBase Class
FastReport Namespace


CanShrink Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.CanShrink Property
ReportComponentBase Class See Also Send Feedback
Determines if the object can shrink.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

Remarks

This property is applicable to the bands or text objects that can contain several text lines. If the property is set to true, object can shrink to remove the unused space.

See Also

ReportComponentBase Class
FastReport Namespace


ClickEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.ClickEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired when the user click the object in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ClickEvent { get; set; }
Visual Basic (Declaration)
Public Property ClickEvent As String
Visual C++
public:
property String^ ClickEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


Cursor Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Cursor Property
ReportComponentBase Class See Also Send Feedback
Gets or sets an object's cursor shape.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Cursor Cursor { get; set; }
Visual Basic (Declaration)
Public Property Cursor As Cursor
Visual C++
public:
property Cursor^ Cursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Remarks

This property is used in the preview mode.

See Also

ReportComponentBase Class
FastReport Namespace


EvenStyle Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.EvenStyle Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a style name that will be applied to even band rows.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string EvenStyle { get; set; }
Visual Basic (Declaration)
Public Property EvenStyle As String
Visual C++
public:
property String^ EvenStyle {
    String^ get ();
    void set (String^ value);
}

Remarks

Style with this name must exist in the Styles collection.

See Also

ReportComponentBase Class
FastReport Namespace


EvenStylePriority Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.EvenStylePriority Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a value that determines which properties of the even style to use.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StylePriority EvenStylePriority { get; set; }
Visual Basic (Declaration)
Public Property EvenStylePriority As StylePriority
Visual C++
public:
property StylePriority EvenStylePriority {
    StylePriority get ();
    void set (StylePriority value);
}

Remarks

Usually you will need only the Fill property of the even style to be applied. If you want to apply all style settings, set this property to StylePriority.UseAll.

See Also

ReportComponentBase Class
FastReport Namespace


Exportable Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Exportable Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a value that determines if the object can be exported.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Exportable { get; set; }
Visual Basic (Declaration)
Public Property Exportable As Boolean
Visual C++
public:
property bool Exportable {
    bool get ();
    void set (bool value);
}

See Also

ReportComponentBase Class
FastReport Namespace


Fill Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Fill Property
ReportComponentBase Class Example See Also Send Feedback
Gets or sets an object's fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Overridable Property Fill As FillBase
Visual C++
public:
virtual property FillBase^ Fill {
    FillBase^ get ();
    void set (FillBase^ value);
}

Remarks

The fill can be one of the following types: SolidFill, LinearGradientFill, PathGradientFill, HatchFill.

To set the solid fill color, use the simpler FillColor property.

Examples

This example shows how to set the new fill and change its properties:
CopyC#
textObject1.Fill = new SolidFill(Color.Green);
(textObject1.Fill as SolidFill).Color = Color.Red;

See Also

ReportComponentBase Class
FastReport Namespace


FillColor Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FillColor Property
ReportComponentBase Class See Also Send Feedback
Gets or sets the fill color in a simple manner.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color FillColor { get; set; }
Visual Basic (Declaration)
Public Property FillColor As Color
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

Remarks

This property can be used in a report script to change the fill color of the object. It is equivalent to:
CopyC#
reportComponent1.Fill = new SolidFill(color);

See Also

ReportComponentBase Class
FastReport Namespace


FlagPreviewVisible Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FlagPreviewVisible Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a value indicates that object should not be added to the preview.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FlagPreviewVisible { get; set; }
Visual Basic (Declaration)
Public Property FlagPreviewVisible As Boolean
Visual C++
public:
property bool FlagPreviewVisible {
    bool get ();
    void set (bool value);
}

See Also

ReportComponentBase Class
FastReport Namespace


FlagProvidesHyperlinkValue Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FlagProvidesHyperlinkValue Property
ReportComponentBase Class See Also Send Feedback
Determines if an object can provide the hyperlink value automatically.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FlagProvidesHyperlinkValue { get; set; }
Visual Basic (Declaration)
Public Property FlagProvidesHyperlinkValue As Boolean
Visual C++
public:
property bool FlagProvidesHyperlinkValue {
    bool get ();
    void set (bool value);
}

Remarks

This flag is used in complex objects such as Matrix or Chart. These objects can provide a hyperlink value automatically, depending on where you click.

See Also

ReportComponentBase Class
FastReport Namespace


FlagSerializeStyle Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FlagSerializeStyle Property
ReportComponentBase Class See Also Send Feedback
Determines if serializing the Style property is needed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FlagSerializeStyle { get; set; }
Visual Basic (Declaration)
Public Property FlagSerializeStyle As Boolean
Visual C++
public:
property bool FlagSerializeStyle {
    bool get ();
    void set (bool value);
}

Remarks

The Style property must be serialized last. Some ancestor classes may turn off the standard Style serialization and serialize it by themselves.

See Also

ReportComponentBase Class
FastReport Namespace


FlagSimpleBorder Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FlagSimpleBorder Property
ReportComponentBase Class See Also Send Feedback
Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FlagSimpleBorder { get; set; }
Visual Basic (Declaration)
Public Property FlagSimpleBorder As Boolean
Visual C++
public:
property bool FlagSimpleBorder {
    bool get ();
    void set (bool value);
}

Remarks

This flag is used to disable some toolbar buttons when such object is selected. Applicable to the ShapeObject and LineObject.

See Also

ReportComponentBase Class
FastReport Namespace


FlagUseBorder Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FlagUseBorder Property
ReportComponentBase Class See Also Send Feedback
Determines if the object uses the Border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FlagUseBorder { get; set; }
Visual Basic (Declaration)
Public Property FlagUseBorder As Boolean
Visual C++
public:
property bool FlagUseBorder {
    bool get ();
    void set (bool value);
}

Remarks

This flag is used to disable some toolbar buttons when such object is selected.

See Also

ReportComponentBase Class
FastReport Namespace


FlagUseFill Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.FlagUseFill Property
ReportComponentBase Class See Also Send Feedback
Determines if the object uses the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FlagUseFill { get; set; }
Visual Basic (Declaration)
Public Property FlagUseFill As Boolean
Visual C++
public:
property bool FlagUseFill {
    bool get ();
    void set (bool value);
}

Remarks

This flag is used to disable some toolbar buttons when such object is selected.

See Also

ReportComponentBase Class
FastReport Namespace


GrowToBottom Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.GrowToBottom Property
ReportComponentBase Class See Also Send Feedback
Determines if the object must grow to the band's bottom side.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool GrowToBottom { get; set; }
Visual Basic (Declaration)
Public Property GrowToBottom As Boolean
Visual C++
public:
property bool GrowToBottom {
    bool get ();
    void set (bool value);
}

Remarks

If the property is set to true, object grows to the bottom side of its parent. This is useful if you have several objects on a band, and some of them can grow or shrink.

See Also

ReportComponentBase Class
FastReport Namespace


Height Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Height Property
ReportComponentBase Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

ReportComponentBase Class
FastReport Namespace


HoverStyle Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.HoverStyle Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a style name that will be applied to this object when the mouse pointer is over it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string HoverStyle { get; set; }
Visual Basic (Declaration)
Public Property HoverStyle As String
Visual C++
public:
property String^ HoverStyle {
    String^ get ();
    void set (String^ value);
}

Remarks

Style with this name must exist in the Styles collection.

See Also

ReportComponentBase Class
FastReport Namespace


Hyperlink Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Hyperlink Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a hyperlink.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Hyperlink Hyperlink { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hyperlink As Hyperlink
Visual C++
public:
property Hyperlink^ Hyperlink {
    Hyperlink^ get ();
}

Remarks

The hyperlink is used to define clickable objects in the preview. When you click such object, you may navigate to the external url, the page number, the bookmark defined by other report object, or display the external report. Set the Kind property of the hyperlink to select appropriate behavior.

Usually you should set the Expression property of the hyperlink to any valid expression that will be calculated when this object is about to print. The value of an expression will be used for navigation.

If you want to navigate to something fixed (URL or page number, for example) you also may set the Value property instead of Expression.

See Also

ReportComponentBase Class
FastReport Namespace


Left Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Left Property
ReportComponentBase Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

ReportComponentBase Class
FastReport Namespace


MouseDownEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseDownEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseDownEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseDownEvent As String
Visual C++
public:
property String^ MouseDownEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseEnterEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseEnterEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseEnterEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseEnterEvent As String
Visual C++
public:
property String^ MouseEnterEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseLeaveEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseLeaveEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseLeaveEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseLeaveEvent As String
Visual C++
public:
property String^ MouseLeaveEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseMoveEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseMoveEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseMoveEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseMoveEvent As String
Visual C++
public:
property String^ MouseMoveEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseUpEvent Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseUpEvent Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseUpEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseUpEvent As String
Visual C++
public:
property String^ MouseUpEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


Printable Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Printable Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a value that determines if the object can be printed on the printer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Printable { get; set; }
Visual Basic (Declaration)
Public Property Printable As Boolean
Visual C++
public:
property bool Printable {
    bool get ();
    void set (bool value);
}

Remarks

Object with Printable = false is still visible in the preview window, but not on the prinout. If you want to hide an object in the preview, set the Visible property to false.

See Also

ReportComponentBase Class
FastReport Namespace


PrintOn Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.PrintOn Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a value that determines where to print the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PrintOn PrintOn { get; set; }
Visual Basic (Declaration)
Public Property PrintOn As PrintOn
Visual C++
public:
property PrintOn PrintOn {
    PrintOn get ();
    void set (PrintOn value);
}

Remarks

See the PrintOn enumeration for details.

See Also

ReportComponentBase Class
FastReport Namespace


ShiftMode Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.ShiftMode Property
ReportComponentBase Class See Also Send Feedback
Gets or sets a shift mode of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShiftMode ShiftMode { get; set; }
Visual Basic (Declaration)
Public Property ShiftMode As ShiftMode
Visual C++
public:
property ShiftMode ShiftMode {
    ShiftMode get ();
    void set (ShiftMode value);
}

Remarks

See ShiftMode enumeration for details.

See Also

ReportComponentBase Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Style Property
ReportComponentBase Class See Also Send Feedback
Gets or sets the style name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

Remarks

Style is a set of common properties such as border, fill, font, text color. The Report has a set of styles in the Styles property.

See Also

ReportComponentBase Class
FastReport Namespace


Top Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Top Property
ReportComponentBase Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

ReportComponentBase Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Width Property
ReportComponentBase Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

ReportComponentBase Class
FastReport Namespace


ReportComponentBase Events

[image] [image]

FastReport.Net Class Reference
ReportComponentBase Events
ReportComponentBase Class See Also Send Feedback

The ReportComponentBase type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data.
AfterPrint | This event occurs after the object was added to the preview pages.
BeforePrint | This event occurs before the object is added to the preview pages.
Click | This event occurs when the user clicks the object in the preview window.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window.
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window.
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window.
MouseMove | This event occurs when the user moves the mouse over the object in the preview window.
MouseUp | This event occurs when the user releases the mouse button in the preview window.

See Also

ReportComponentBase Class
FastReport Namespace


AfterData Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.AfterData Event
ReportComponentBase Class See Also Send Feedback
This event occurs after the object was filled with data.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler AfterData
Visual Basic (Declaration)
Public Event AfterData As EventHandler
Visual C++
public:
 event EventHandler^ AfterData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


AfterPrint Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.AfterPrint Event
ReportComponentBase Class See Also Send Feedback
This event occurs after the object was added to the preview pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler AfterPrint
Visual Basic (Declaration)
Public Event AfterPrint As EventHandler
Visual C++
public:
 event EventHandler^ AfterPrint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


BeforePrint Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.BeforePrint Event
ReportComponentBase Class See Also Send Feedback
This event occurs before the object is added to the preview pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler BeforePrint
Visual Basic (Declaration)
Public Event BeforePrint As EventHandler
Visual C++
public:
 event EventHandler^ BeforePrint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


Click Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.Click Event
ReportComponentBase Class See Also Send Feedback
This event occurs when the user clicks the object in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Click
Visual Basic (Declaration)
Public Event Click As EventHandler
Visual C++
public:
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseDown Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseDown Event
ReportComponentBase Class See Also Send Feedback
This event occurs when the user clicks the mouse button in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MouseEventHandler MouseDown
Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseEnter Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseEnter Event
ReportComponentBase Class See Also Send Feedback
This event occurs when the mouse enters the object's bounds in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler MouseEnter
Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
Visual C++
public:
 event EventHandler^ MouseEnter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseLeave Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseLeave Event
ReportComponentBase Class See Also Send Feedback
This event occurs when the mouse leaves the object's bounds in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler MouseLeave
Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
Visual C++
public:
 event EventHandler^ MouseLeave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseMove Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseMove Event
ReportComponentBase Class See Also Send Feedback
This event occurs when the user moves the mouse over the object in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MouseEventHandler MouseMove
Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


MouseUp Event

[image]

FastReport.Net Class Reference
ReportComponentBase..::.MouseUp Event
ReportComponentBase Class See Also Send Feedback
This event occurs when the user releases the mouse button in the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MouseEventHandler MouseUp
Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

ReportComponentBase Class
FastReport Namespace


ReportComponentBaseMenu Class

[image]

FastReport.Net Class Reference
ReportComponentBaseMenu Class
Members See Also Send Feedback
The class introduces some menu items specific to the ReportComponentBase.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportComponentBaseMenu : ComponentMenuBase
Visual Basic (Declaration)
Public Class ReportComponentBaseMenu _
    Inherits ComponentMenuBase
Visual C++
public ref class ReportComponentBaseMenu : public ComponentMenuBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
ContextMenuBar
FastReport..::.ComponentMenuBase
FastReport..::.ReportComponentBaseMenu
FastReport..::.BreakableComponentMenu

See Also

ReportComponentBaseMenu Members
FastReport Namespace


ReportComponentBaseMenu Members

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu Members
ReportComponentBaseMenu Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportComponentBaseMenu type exposes the following members.

Constructors

Name | Description
ReportComponentBaseMenu | Initializes a new instance of the ReportComponentMenuBase class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanGrow | The "Can Grow" menu item.
miCanShrink | The "Can Shrink" menu item.
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miGrowToBottom | The "Grow to Bottom" menu item.
miHyperlink | The "Hyperlink" menu item.
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
FastReport Namespace


ReportComponentBaseMenu Constructor

[image]

FastReport.Net Class Reference
ReportComponentBaseMenu Constructor
ReportComponentBaseMenu Class See Also Send Feedback
Initializes a new instance of the ReportComponentMenuBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentBaseMenu(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ReportComponentBaseMenu(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The reference to a report designer.

See Also

ReportComponentBaseMenu Class
FastReport Namespace


ReportComponentBaseMenu Fields

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu Fields
ReportComponentBaseMenu Class See Also Send Feedback

The ReportComponentBaseMenu type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanGrow | The "Can Grow" menu item.
miCanShrink | The "Can Shrink" menu item.
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miGrowToBottom | The "Grow to Bottom" menu item.
miHyperlink | The "Hyperlink" menu item.
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)

See Also

ReportComponentBaseMenu Class
FastReport Namespace


miCanGrow Field

[image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.miCanGrow Field
ReportComponentBaseMenu Class See Also Send Feedback
The "Can Grow" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miCanGrow
Visual Basic (Declaration)
Public miCanGrow As ButtonItem
Visual C++
public:
ButtonItem^ miCanGrow

See Also

ReportComponentBaseMenu Class
FastReport Namespace


miCanShrink Field

[image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.miCanShrink Field
ReportComponentBaseMenu Class See Also Send Feedback
The "Can Shrink" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miCanShrink
Visual Basic (Declaration)
Public miCanShrink As ButtonItem
Visual C++
public:
ButtonItem^ miCanShrink

See Also

ReportComponentBaseMenu Class
FastReport Namespace


miGrowToBottom Field

[image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.miGrowToBottom Field
ReportComponentBaseMenu Class See Also Send Feedback
The "Grow to Bottom" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miGrowToBottom
Visual Basic (Declaration)
Public miGrowToBottom As ButtonItem
Visual C++
public:
ButtonItem^ miGrowToBottom

See Also

ReportComponentBaseMenu Class
FastReport Namespace


miHyperlink Field

[image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.miHyperlink Field
ReportComponentBaseMenu Class See Also Send Feedback
The "Hyperlink" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miHyperlink
Visual Basic (Declaration)
Public miHyperlink As ButtonItem
Visual C++
public:
ButtonItem^ miHyperlink

See Also

ReportComponentBaseMenu Class
FastReport Namespace


ReportComponentBaseMenu Methods

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu Methods
ReportComponentBaseMenu Class See Also Send Feedback

The ReportComponentBaseMenu type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
FastReport Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.AccessibilityNotifyClients Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.BeginInvoke Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.CloseDockTab Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


CreateMenuItem Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.CreateMenuItem Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
CreateMenuItem(String) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(Image, String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.Dispose Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.GetChildAtPoint Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.GetItems Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.Invalidate Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.Invoke Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.MemberwiseClone Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.PerformLayout Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.ResumeLayout Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.RtlTranslateAlignment Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.Scale Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.Select Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.SetBounds Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.SetSize Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu..::.UpdateBounds Method
ReportComponentBaseMenu Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
ReportComponentBaseMenu Members
FastReport Namespace


ReportComponentBaseMenu Properties

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu Properties
ReportComponentBaseMenu Class See Also Send Feedback

The ReportComponentBaseMenu type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

ReportComponentBaseMenu Class
FastReport Namespace


ReportComponentBaseMenu Events

[image] [image]

FastReport.Net Class Reference
ReportComponentBaseMenu Events
ReportComponentBaseMenu Class See Also Send Feedback

The ReportComponentBaseMenu type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ReportComponentBaseMenu Class
FastReport Namespace


ReportComponentCollection Class

[image]

FastReport.Net Class Reference
ReportComponentCollection Class
Members See Also Send Feedback
Holds the list of objects of ReportComponentBase type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportComponentCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class ReportComponentCollection _
    Inherits FRCollectionBase
Visual C++
public ref class ReportComponentCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport..::.ReportComponentCollection

See Also

ReportComponentCollection Members
FastReport Namespace


ReportComponentCollection Members

[image] [image]

FastReport.Net Class Reference
ReportComponentCollection Members
ReportComponentCollection Class Constructors Methods Properties See Also Send Feedback

The ReportComponentCollection type exposes the following members.

Constructors

Name | Description
ReportComponentCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ReportComponentCollection Class
FastReport Namespace


ReportComponentCollection Constructor

[image] [image]

FastReport.Net Class Reference
ReportComponentCollection Constructor
ReportComponentCollection Class See Also Send Feedback

Overload List

Name | Description
ReportComponentCollection()()() | Initializes a new instance of the ReportComponentCollection class with default settings.
ReportComponentCollection(Base) | Initializes a new instance of the ReportComponentCollection class with specified owner.

See Also

ReportComponentCollection Class
ReportComponentCollection Members
FastReport Namespace


ReportComponentCollection Constructor

[image]

FastReport.Net Class Reference
ReportComponentCollection Constructor
ReportComponentCollection Class See Also Send Feedback
Initializes a new instance of the ReportComponentCollection class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportComponentCollection()

See Also

ReportComponentCollection Class
ReportComponentCollection Overload
FastReport Namespace


ReportComponentCollection Constructor (Base)

[image]

FastReport.Net Class Reference
ReportComponentCollection Constructor (Base)
ReportComponentCollection Class See Also Send Feedback
Initializes a new instance of the ReportComponentCollection class with specified owner.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
ReportComponentCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base

See Also

ReportComponentCollection Class
ReportComponentCollection Overload
FastReport Namespace


ReportComponentCollection Methods

[image] [image]

FastReport.Net Class Reference
ReportComponentCollection Methods
ReportComponentCollection Class See Also Send Feedback

The ReportComponentCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportComponentCollection Class
FastReport Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
ReportComponentCollection..::.AddRange Method
ReportComponentCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

ReportComponentCollection Class
ReportComponentCollection Members
FastReport Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
ReportComponentCollection..::.Equals Method
ReportComponentCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

ReportComponentCollection Class
ReportComponentCollection Members
FastReport Namespace


ReportComponentCollection Properties

[image] [image]

FastReport.Net Class Reference
ReportComponentCollection Properties
ReportComponentCollection Class See Also Send Feedback

The ReportComponentCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ReportComponentCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
ReportComponentCollection..::.Item Property
ReportComponentCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ReportComponentBase
Visual C++
public:
property ReportComponentBase^ default[int index] {
    ReportComponentBase^ get (int index);
    void set (int index, ReportComponentBase^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

ReportComponentCollection Class
FastReport Namespace


ReportInfo Class

[image]

FastReport.Net Class Reference
ReportInfo Class
Members See Also Send Feedback
This class represents the report information such as name, author, description etc.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportInfo
Visual Basic (Declaration)
Public Class ReportInfo
Visual C++
public ref class ReportInfo

Inheritance Hierarchy

System..::.Object
FastReport..::.ReportInfo

See Also

ReportInfo Members
FastReport Namespace


ReportInfo Members

[image] [image]

FastReport.Net Class Reference
ReportInfo Members
ReportInfo Class Constructors Methods Properties See Also Send Feedback

The ReportInfo type exposes the following members.

Constructors

Name | Description
ReportInfo | Initializes a new instance of the ReportInfo class with default settings.

Methods

Name | Description
Clear | Resets all properties to its default values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Author | Gets or sets the author of a report.
Created | Gets or sets the report creation date and time.
CreatorVersion | Gets the version of FastReport that was created this report file.
Description | Gets or sets the report description.
Modified | Gets or sets a value indicating that report was modified in the designer.
Name | Gets or sets the name of a report.
Picture | Gets or sets the picture associated with a report.
PreviewPictureRatio | Gets or sets the ratio that will be used when generating a preview picture.
SavePreviewPicture | Gets or sets a value that determines whether to fill the Picture property automatically.
Version | Gets or sets the report version.

See Also

ReportInfo Class
FastReport Namespace


ReportInfo Constructor

[image]

FastReport.Net Class Reference
ReportInfo Constructor
ReportInfo Class See Also Send Feedback
Initializes a new instance of the ReportInfo class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportInfo()

See Also

ReportInfo Class
FastReport Namespace


ReportInfo Methods

[image] [image]

FastReport.Net Class Reference
ReportInfo Methods
ReportInfo Class See Also Send Feedback

The ReportInfo type exposes the following members.

Methods

Name | Description
Clear | Resets all properties to its default values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportInfo Class
FastReport Namespace


Clear Method

[image]

FastReport.Net Class Reference
ReportInfo..::.Clear Method
ReportInfo Class See Also Send Feedback
Resets all properties to its default values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ReportInfo Class
FastReport Namespace


ReportInfo Properties

[image] [image]

FastReport.Net Class Reference
ReportInfo Properties
ReportInfo Class See Also Send Feedback

The ReportInfo type exposes the following members.

Properties

Name | Description
Author | Gets or sets the author of a report.
Created | Gets or sets the report creation date and time.
CreatorVersion | Gets the version of FastReport that was created this report file.
Description | Gets or sets the report description.
Modified | Gets or sets a value indicating that report was modified in the designer.
Name | Gets or sets the name of a report.
Picture | Gets or sets the picture associated with a report.
PreviewPictureRatio | Gets or sets the ratio that will be used when generating a preview picture.
SavePreviewPicture | Gets or sets a value that determines whether to fill the Picture property automatically.
Version | Gets or sets the report version.

See Also

ReportInfo Class
FastReport Namespace


Author Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Author Property
ReportInfo Class See Also Send Feedback
Gets or sets the author of a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Author { get; set; }
Visual Basic (Declaration)
Public Property Author As String
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

See Also

ReportInfo Class
FastReport Namespace


Created Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Created Property
ReportInfo Class See Also Send Feedback
Gets or sets the report creation date and time.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime Created { get; set; }
Visual Basic (Declaration)
Public Property Created As DateTime
Visual C++
public:
property DateTime Created {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReportInfo Class
FastReport Namespace


CreatorVersion Property

[image]

FastReport.Net Class Reference
ReportInfo..::.CreatorVersion Property
ReportInfo Class See Also Send Feedback
Gets the version of FastReport that was created this report file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreatorVersion { get; set; }
Visual Basic (Declaration)
Public Property CreatorVersion As String
Visual C++
public:
property String^ CreatorVersion {
    String^ get ();
    void set (String^ value);
}

See Also

ReportInfo Class
FastReport Namespace


Description Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Description Property
ReportInfo Class See Also Send Feedback
Gets or sets the report description.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

ReportInfo Class
FastReport Namespace


Modified Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Modified Property
ReportInfo Class See Also Send Feedback
Gets or sets a value indicating that report was modified in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime Modified { get; set; }
Visual Basic (Declaration)
Public Property Modified As DateTime
Visual C++
public:
property DateTime Modified {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReportInfo Class
FastReport Namespace


Name Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Name Property
ReportInfo Class See Also Send Feedback
Gets or sets the name of a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportInfo Class
FastReport Namespace


Picture Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Picture Property
ReportInfo Class See Also Send Feedback
Gets or sets the picture associated with a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Image Picture { get; set; }
Visual Basic (Declaration)
Public Property Picture As Image
Visual C++
public:
property Image^ Picture {
    Image^ get ();
    void set (Image^ value);
}

See Also

ReportInfo Class
FastReport Namespace


PreviewPictureRatio Property

[image]

FastReport.Net Class Reference
ReportInfo..::.PreviewPictureRatio Property
ReportInfo Class See Also Send Feedback
Gets or sets the ratio that will be used when generating a preview picture.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PreviewPictureRatio { get; set; }
Visual Basic (Declaration)
Public Property PreviewPictureRatio As Single
Visual C++
public:
property float PreviewPictureRatio {
    float get ();
    void set (float value);
}

See Also

ReportInfo Class
FastReport Namespace


SavePreviewPicture Property

[image]

FastReport.Net Class Reference
ReportInfo..::.SavePreviewPicture Property
ReportInfo Class See Also Send Feedback
Gets or sets a value that determines whether to fill the Picture property automatically.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SavePreviewPicture { get; set; }
Visual Basic (Declaration)
Public Property SavePreviewPicture As Boolean
Visual C++
public:
property bool SavePreviewPicture {
    bool get ();
    void set (bool value);
}

See Also

ReportInfo Class
FastReport Namespace


Version Property

[image]

FastReport.Net Class Reference
ReportInfo..::.Version Property
ReportInfo Class See Also Send Feedback
Gets or sets the report version.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

ReportInfo Class
FastReport Namespace


ReportOperation Enumeration

[image]

FastReport.Net Class Reference
ReportOperation Enumeration
See Also Send Feedback
Specifies the report operation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ReportOperation
Visual Basic (Declaration)
Public Enumeration ReportOperation
Visual C++
public enum class ReportOperation

Members

Member name | Description
None | Specifies no operation.
Running | The report is running.
Printing | The report is printing.
Exporting | The report is exporting.

See Also

FastReport Namespace


ReportPage Class

[image]

FastReport.Net Class Reference
ReportPage Class
Members Example See Also Send Feedback
Represents a report page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportPage : PageBase, IParent,
    IHasEditor
Visual Basic (Declaration)
Public Class ReportPage _
    Inherits PageBase _
    Implements IParent, IHasEditor
Visual C++
public ref class ReportPage : public PageBase,
    IParent, IHasEditor

Remarks

To get/set a paper size and orientation, use the PaperWidth, PaperHeight and Landscape properties. Note that paper size is measured in millimeters.

Report page can contain one or several bands with report objects. Use the ReportTitle, ReportSummary, PageHeader, PageFooter, ColumnHeader, ColumnFooter, Overlay properties to get/set the page bands. The Bands property holds the list of data bands or groups. Thus you may add several databands to this property to create master-master reports, for example.

Note: Report page can contain bands only. You cannot place report objects such as TextObject on a page.

Examples

This example shows how to create a page with one ReportTitleBand and DataBand bands and add it to the report.
CopyC#
ReportPage page = new ReportPage();
// set the paper in millimeters
page.PaperWidth = 210;
page.PaperHeight = 297;
// create report title
page.ReportTitle = new ReportTitleBand();
page.ReportTitle.Name = "ReportTitle1";
page.ReportTitle.Height = Units.Millimeters * 10;
// create data band
DataBand data = new DataBand();
data.Name = "Data1";
data.Height = Units.Millimeters * 10;
// add data band to the page
page.Bands.Add(data);
// add page to the report
report.Pages.Add(page);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.PageBase
FastReport..::.ReportPage

See Also

ReportPage Members
FastReport Namespace


ReportPage Members

[image] [image]

FastReport.Net Class Reference
ReportPage Members
ReportPage Class Constructors Methods Properties Events See Also Send Feedback

The ReportPage type exposes the following members.

Constructors

Name | Description
ReportPage | Initializes a new instance of the ReportPage class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ComponentBase..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Overrides Base..::.ExtractMacros()()().)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageDesignerType | Gets a page designer for this page type. (Overrides PageBase..::.GetPageDesignerType()()().)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
Modify | Modifies the page content and refresh it in the preview window. (Inherited from PageBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnFinishPage | This method fires the FinishPage event and the script code connected to the FinishPageEvent.
OnManualBuild | This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.
OnStartPage | This method fires the StartPage event and the script code connected to the StartPageEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
Refresh | Causes the page to refresh in the preview window. (Inherited from PageBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetDefaults | This method is called by the designer when you create a new page. (Overrides PageBase..::.SetDefaults()()().)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from PageBase.)
BackPage | Uses this page as a back page for previously printed pages.
Bands | Gets the collection of data bands or group header bands.
BaseName | The base part of the object's name. (Inherited from Base.)
Border | Gets or sets the page border that will be printed inside the page printing area.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
BottomMargin | Gets or sets the bottom page margin, in millimeters.
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnFooter | Gets or sets a column footer band.
ColumnHeader | Gets or sets a column header band.
Columns | Gets the page columns settings.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from PageBase.)
Duplex | Gets or sets the printer duplex mode that will be used when printing this page.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExtraDesignWidth | Gets or sets a value indicating whether the page has extra width in the report designer.
Fill | Gets or sets the page background fill.
FinishPageEvent | Gets or sets a script event name that will be fired when the report engine finished this page.
FirstPageSource | Gets or sets the paper source for the first printed page.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Guides | Gets or sets the page guidelines.
Height | This property is not relevant to this class. (Overrides ComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsImperialUnitsUsed | Gets a value indicating that imperial units (inches, hundreths of inches) are used.
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Landscape | Gets or sets a value indicating that page should be in landscape orientation.
Left | This property is not relevant to this class. (Overrides ComponentBase..::.Left.)
LeftMargin | Gets or sets the left page margin, in millimeters.
ManualBuildEvent | Gets or sets a script event name that will be fired when the report engine is about to print databands in this page.
MirrorMargins | Gets or sets a value indicating that even pages should swap its left and right margins when previewed or printed.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OtherPagesSource | Gets or sets the paper source for all printed pages except the first one.
OutlineExpression | Gets or sets an outline expression.
Overlay | Gets or sets an overlay band.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageFooter | Gets or sets a page footer band.
PageHeader | Gets or sets a page header band.
PaperHeight | Gets or sets a height of the paper, in millimeters.
PaperWidth | Gets or sets a width of the paper, in millimeters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintOnPreviousPage | Gets or sets a value indicating whether to start to print this page on a free space of the previous page.
RawPaperSize | Gets or sets the raw index of a paper size.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportSummary | Gets or sets a report summary band.
ReportTitle | Gets or sets a report title band.
ResetPageNumber | Gets or sets a value indicating that FastReport engine must reset page numbers before printing this page.
Restrictions | This property is not relevant to this class. (Inherited from PageBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightMargin | Gets or sets the right page margin, in millimeters.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SnapSize | Gets the snap size for this page. (Overrides PageBase..::.SnapSize.)
StartOnOddPage | Gets or sets a value indicating whether this page will start on an odd page only.
StartPageEvent | Gets or sets a script event name that will be fired when the report engine starts this page.
Subreport | Gets or sets the reference to a parent SubreportObject that owns this page.
TitleBeforeHeader | Gets or sets a value indicating that ReportTitle band should be printed before the PageHeader band.
Top | This property is not relevant to this class. (Overrides ComponentBase..::.Top.)
TopMargin | Gets or sets the top page margin, in millimeters.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Watermark | Gets or sets the page watermark.
Width | This property is not relevant to this class. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FinishPage | This event occurs when the report engine finished this page.
ManualBuild | This event occurs when the report engine is about to print databands in this page.
StartPage | This event occurs when the report engine starts this page.

See Also

ReportPage Class
FastReport Namespace


ReportPage Constructor

[image]

FastReport.Net Class Reference
ReportPage Constructor
ReportPage Class See Also Send Feedback
Initializes a new instance of the ReportPage class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportPage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportPage()

See Also

ReportPage Class
FastReport Namespace


ReportPage Methods

[image] [image]

FastReport.Net Class Reference
ReportPage Methods
ReportPage Class See Also Send Feedback

The ReportPage type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ComponentBase..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Overrides Base..::.ExtractMacros()()().)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageDesignerType | Gets a page designer for this page type. (Overrides PageBase..::.GetPageDesignerType()()().)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
Modify | Modifies the page content and refresh it in the preview window. (Inherited from PageBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnFinishPage | This method fires the FinishPage event and the script code connected to the FinishPageEvent.
OnManualBuild | This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.
OnStartPage | This method fires the StartPage event and the script code connected to the StartPageEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
Refresh | Causes the page to refresh in the preview window. (Inherited from PageBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetDefaults | This method is called by the designer when you create a new page. (Overrides PageBase..::.SetDefaults()()().)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

ReportPage Class
FastReport Namespace


AddChild Method

[image]

FastReport.Net Class Reference
ReportPage..::.AddChild Method
ReportPage Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

ReportPage Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ReportPage..::.Assign Method
ReportPage Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ReportPage Class
FastReport Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
ReportPage..::.CanContain Method
ReportPage Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

ReportPage Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ReportPage..::.Dispose Method
ReportPage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

ReportPage Class
ReportPage Members
FastReport Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
ReportPage..::.Dispose Method (Boolean)
ReportPage Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ReportPage Class
Dispose Overload
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
ReportPage..::.Draw Method
ReportPage Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

ReportPage Class
FastReport Namespace


DrawSelection Method

[image]

FastReport.Net Class Reference
ReportPage..::.DrawSelection Method
ReportPage Class See Also Send Feedback
Draw the selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawSelection(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawSelection ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawSelection(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method draws a set of selection points returned by the GetSelectionPoints()()() method.

See Also

ReportPage Class
FastReport Namespace


ExtractMacros Method

[image]

FastReport.Net Class Reference
ReportPage..::.ExtractMacros Method
ReportPage Class See Also Send Feedback
Used to extract macros such as "TotalPages#" in the preview mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void ExtractMacros()
Visual Basic (Declaration)
Public Overrides Sub ExtractMacros
Visual C++
public:
virtual void ExtractMacros() override

Remarks

This method is used mainly by the TextObject to extract macros and replace it with actual values passed in the pageIndex and totalPages parameters. This method is called automatically when the object is being previewed.

See Also

ReportPage Class
FastReport Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
ReportPage..::.GetChildObjects Method
ReportPage Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overridable Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

ReportPage Class
FastReport Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
ReportPage..::.GetChildOrder Method
ReportPage Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

ReportPage Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
ReportPage..::.GetExpressions Method
ReportPage Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

ReportPage Class
FastReport Namespace


GetPageDesignerType Method

[image]

FastReport.Net Class Reference
ReportPage..::.GetPageDesignerType Method
ReportPage Class See Also Send Feedback
Gets a page designer for this page type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetPageDesignerType()
Visual Basic (Declaration)
Public Overrides Function GetPageDesignerType As Type
Visual C++
public:
virtual Type^ GetPageDesignerType() override

Return Value

The page designer.

See Also

ReportPage Class
FastReport Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
ReportPage..::.HandleMouseDown Method
ReportPage Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

ReportPage Class
FastReport Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
ReportPage..::.HandleMouseHover Method
ReportPage Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

ReportPage Class
FastReport Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
ReportPage..::.HandleMouseMove Method
ReportPage Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

ReportPage Class
FastReport Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
ReportPage..::.HandleMouseUp Method
ReportPage Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

ReportPage Class
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
ReportPage..::.InvokeEditor Method
ReportPage Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Implements

IHasEditor..::.InvokeEditor()()()

See Also

ReportPage Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ReportPage..::.MemberwiseClone Method
ReportPage Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportPage Class
ReportPage Members
FastReport Namespace


OnFinishPage Method

[image]

FastReport.Net Class Reference
ReportPage..::.OnFinishPage Method
ReportPage Class See Also Send Feedback
This method fires the FinishPage event and the script code connected to the FinishPageEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnFinishPage(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnFinishPage ( _
    e As EventArgs _
)
Visual C++
public:
void OnFinishPage(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportPage Class
FastReport Namespace


OnManualBuild Method

[image]

FastReport.Net Class Reference
ReportPage..::.OnManualBuild Method
ReportPage Class See Also Send Feedback
This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnManualBuild(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnManualBuild ( _
    e As EventArgs _
)
Visual C++
public:
void OnManualBuild(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportPage Class
FastReport Namespace


OnStartPage Method

[image]

FastReport.Net Class Reference
ReportPage..::.OnStartPage Method
ReportPage Class See Also Send Feedback
This method fires the StartPage event and the script code connected to the StartPageEvent.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnStartPage(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnStartPage ( _
    e As EventArgs _
)
Visual C++
public:
void OnStartPage(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportPage Class
FastReport Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
ReportPage..::.RemoveChild Method
ReportPage Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

ReportPage Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ReportPage..::.Serialize Method
ReportPage Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ReportPage Class
FastReport Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
ReportPage..::.SetChildOrder Method
ReportPage Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Overridable Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
)

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

ReportPage Class
FastReport Namespace


SetDefaults Method

[image]

FastReport.Net Class Reference
ReportPage..::.SetDefaults Method
ReportPage Class See Also Send Feedback
This method is called by the designer when you create a new page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetDefaults()
Visual Basic (Declaration)
Public Overrides Sub SetDefaults
Visual C++
public:
virtual void SetDefaults() override

Remarks

You may create the default page layout (add default bands, set default page size, etc).

See Also

ReportPage Class
FastReport Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
ReportPage..::.UpdateLayout Method
ReportPage Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Overridable Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
)

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

ReportPage Class
FastReport Namespace


ReportPage Properties

[image] [image]

FastReport.Net Class Reference
ReportPage Properties
ReportPage Class See Also Send Feedback

The ReportPage type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from PageBase.)
BackPage | Uses this page as a back page for previously printed pages.
Bands | Gets the collection of data bands or group header bands.
BaseName | The base part of the object's name. (Inherited from Base.)
Border | Gets or sets the page border that will be printed inside the page printing area.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
BottomMargin | Gets or sets the bottom page margin, in millimeters.
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnFooter | Gets or sets a column footer band.
ColumnHeader | Gets or sets a column header band.
Columns | Gets the page columns settings.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from PageBase.)
Duplex | Gets or sets the printer duplex mode that will be used when printing this page.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExtraDesignWidth | Gets or sets a value indicating whether the page has extra width in the report designer.
Fill | Gets or sets the page background fill.
FinishPageEvent | Gets or sets a script event name that will be fired when the report engine finished this page.
FirstPageSource | Gets or sets the paper source for the first printed page.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Guides | Gets or sets the page guidelines.
Height | This property is not relevant to this class. (Overrides ComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsImperialUnitsUsed | Gets a value indicating that imperial units (inches, hundreths of inches) are used.
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Landscape | Gets or sets a value indicating that page should be in landscape orientation.
Left | This property is not relevant to this class. (Overrides ComponentBase..::.Left.)
LeftMargin | Gets or sets the left page margin, in millimeters.
ManualBuildEvent | Gets or sets a script event name that will be fired when the report engine is about to print databands in this page.
MirrorMargins | Gets or sets a value indicating that even pages should swap its left and right margins when previewed or printed.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OtherPagesSource | Gets or sets the paper source for all printed pages except the first one.
OutlineExpression | Gets or sets an outline expression.
Overlay | Gets or sets an overlay band.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageFooter | Gets or sets a page footer band.
PageHeader | Gets or sets a page header band.
PaperHeight | Gets or sets a height of the paper, in millimeters.
PaperWidth | Gets or sets a width of the paper, in millimeters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintOnPreviousPage | Gets or sets a value indicating whether to start to print this page on a free space of the previous page.
RawPaperSize | Gets or sets the raw index of a paper size.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportSummary | Gets or sets a report summary band.
ReportTitle | Gets or sets a report title band.
ResetPageNumber | Gets or sets a value indicating that FastReport engine must reset page numbers before printing this page.
Restrictions | This property is not relevant to this class. (Inherited from PageBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightMargin | Gets or sets the right page margin, in millimeters.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SnapSize | Gets the snap size for this page. (Overrides PageBase..::.SnapSize.)
StartOnOddPage | Gets or sets a value indicating whether this page will start on an odd page only.
StartPageEvent | Gets or sets a script event name that will be fired when the report engine starts this page.
Subreport | Gets or sets the reference to a parent SubreportObject that owns this page.
TitleBeforeHeader | Gets or sets a value indicating that ReportTitle band should be printed before the PageHeader band.
Top | This property is not relevant to this class. (Overrides ComponentBase..::.Top.)
TopMargin | Gets or sets the top page margin, in millimeters.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Watermark | Gets or sets the page watermark.
Width | This property is not relevant to this class. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ReportPage Class
FastReport Namespace


BackPage Property

[image]

FastReport.Net Class Reference
ReportPage..::.BackPage Property
ReportPage Class See Also Send Feedback
Uses this page as a back page for previously printed pages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool BackPage { get; set; }
Visual Basic (Declaration)
Public Property BackPage As Boolean
Visual C++
public:
property bool BackPage {
    bool get ();
    void set (bool value);
}

See Also

ReportPage Class
FastReport Namespace


Bands Property

[image]

FastReport.Net Class Reference
ReportPage..::.Bands Property
ReportPage Class See Also Send Feedback
Gets the collection of data bands or group header bands.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandCollection Bands { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bands As BandCollection
Visual C++
public:
property BandCollection^ Bands {
    BandCollection^ get ();
}

Remarks

The Bands property holds the list of data bands or group headers. Thus you may add several databands to this property to create master-master reports, for example.

See Also

ReportPage Class
FastReport Namespace


Border Property

[image]

FastReport.Net Class Reference
ReportPage..::.Border Property
ReportPage Class See Also Send Feedback
Gets or sets the page border that will be printed inside the page printing area.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

ReportPage Class
FastReport Namespace


BottomMargin Property

[image]

FastReport.Net Class Reference
ReportPage..::.BottomMargin Property
ReportPage Class See Also Send Feedback
Gets or sets the bottom page margin, in millimeters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float BottomMargin { get; set; }
Visual Basic (Declaration)
Public Property BottomMargin As Single
Visual C++
public:
property float BottomMargin {
    float get ();
    void set (float value);
}

See Also

ReportPage Class
FastReport Namespace


ColumnFooter Property

[image]

FastReport.Net Class Reference
ReportPage..::.ColumnFooter Property
ReportPage Class See Also Send Feedback
Gets or sets a column footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnFooterBand ColumnFooter { get; set; }
Visual Basic (Declaration)
Public Property ColumnFooter As ColumnFooterBand
Visual C++
public:
property ColumnFooterBand^ ColumnFooter {
    ColumnFooterBand^ get ();
    void set (ColumnFooterBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


ColumnHeader Property

[image]

FastReport.Net Class Reference
ReportPage..::.ColumnHeader Property
ReportPage Class See Also Send Feedback
Gets or sets a column header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnHeaderBand ColumnHeader { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeader As ColumnHeaderBand
Visual C++
public:
property ColumnHeaderBand^ ColumnHeader {
    ColumnHeaderBand^ get ();
    void set (ColumnHeaderBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


Columns Property

[image]

FastReport.Net Class Reference
ReportPage..::.Columns Property
ReportPage Class See Also Send Feedback
Gets the page columns settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageColumns Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As PageColumns
Visual C++
public:
property PageColumns^ Columns {
    PageColumns^ get ();
}

See Also

ReportPage Class
FastReport Namespace


Duplex Property

[image]

FastReport.Net Class Reference
ReportPage..::.Duplex Property
ReportPage Class See Also Send Feedback
Gets or sets the printer duplex mode that will be used when printing this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Duplex Duplex { get; set; }
Visual Basic (Declaration)
Public Property Duplex As Duplex
Visual C++
public:
property Duplex Duplex {
    Duplex get ();
    void set (Duplex value);
}

See Also

ReportPage Class
FastReport Namespace


ExtraDesignWidth Property

[image]

FastReport.Net Class Reference
ReportPage..::.ExtraDesignWidth Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating whether the page has extra width in the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ExtraDesignWidth { get; set; }
Visual Basic (Declaration)
Public Property ExtraDesignWidth As Boolean
Visual C++
public:
property bool ExtraDesignWidth {
    bool get ();
    void set (bool value);
}

Remarks

This property may be useful if you work with such objects as Matrix and Table.

See Also

ReportPage Class
FastReport Namespace


Fill Property

[image]

FastReport.Net Class Reference
ReportPage..::.Fill Property
ReportPage Class See Also Send Feedback
Gets or sets the page background fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As FillBase
Visual C++
public:
property FillBase^ Fill {
    FillBase^ get ();
    void set (FillBase^ value);
}

See Also

ReportPage Class
FastReport Namespace


FinishPageEvent Property

[image]

FastReport.Net Class Reference
ReportPage..::.FinishPageEvent Property
ReportPage Class See Also Send Feedback
Gets or sets a script event name that will be fired when the report engine finished this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FinishPageEvent { get; set; }
Visual Basic (Declaration)
Public Property FinishPageEvent As String
Visual C++
public:
property String^ FinishPageEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportPage Class
FastReport Namespace


FirstPageSource Property

[image]

FastReport.Net Class Reference
ReportPage..::.FirstPageSource Property
ReportPage Class See Also Send Feedback
Gets or sets the paper source for the first printed page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int FirstPageSource { get; set; }
Visual Basic (Declaration)
Public Property FirstPageSource As Integer
Visual C++
public:
property int FirstPageSource {
    int get ();
    void set (int value);
}

Remarks

This property represents the paper source (printer tray) that will be used when printing the first page. To set the source for other pages, use the OtherPagesSource property.

Note: This property uses the raw number of the paper source.

See Also

ReportPage Class
FastReport Namespace


Guides Property

[image]

FastReport.Net Class Reference
ReportPage..::.Guides Property
ReportPage Class See Also Send Feedback
Gets or sets the page guidelines.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FloatCollection Guides { get; set; }
Visual Basic (Declaration)
Public Property Guides As FloatCollection
Visual C++
public:
property FloatCollection^ Guides {
    FloatCollection^ get ();
    void set (FloatCollection^ value);
}

Remarks

This property hold all vertical guidelines. The horizontal guidelines are owned by the bands (see Guides property).

See Also

ReportPage Class
FastReport Namespace


Height Property

[image]

FastReport.Net Class Reference
ReportPage..::.Height Property
ReportPage Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

See Also

ReportPage Class
FastReport Namespace


IsImperialUnitsUsed Property

[image]

FastReport.Net Class Reference
ReportPage..::.IsImperialUnitsUsed Property
ReportPage Class See Also Send Feedback
Gets a value indicating that imperial units (inches, hundreths of inches) are used.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsImperialUnitsUsed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsImperialUnitsUsed As Boolean
Visual C++
public:
property bool IsImperialUnitsUsed {
    bool get ();
}

See Also

ReportPage Class
FastReport Namespace


Landscape Property

[image]

FastReport.Net Class Reference
ReportPage..::.Landscape Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating that page should be in landscape orientation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Landscape { get; set; }
Visual Basic (Declaration)
Public Property Landscape As Boolean
Visual C++
public:
property bool Landscape {
    bool get ();
    void set (bool value);
}

Remarks

When you change this property, it will automatically swap paper width and height, as well as paper margins.

See Also

ReportPage Class
FastReport Namespace


Left Property

[image]

FastReport.Net Class Reference
ReportPage..::.Left Property
ReportPage Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

See Also

ReportPage Class
FastReport Namespace


LeftMargin Property

[image]

FastReport.Net Class Reference
ReportPage..::.LeftMargin Property
ReportPage Class See Also Send Feedback
Gets or sets the left page margin, in millimeters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float LeftMargin { get; set; }
Visual Basic (Declaration)
Public Property LeftMargin As Single
Visual C++
public:
property float LeftMargin {
    float get ();
    void set (float value);
}

See Also

ReportPage Class
FastReport Namespace


ManualBuildEvent Property

[image]

FastReport.Net Class Reference
ReportPage..::.ManualBuildEvent Property
ReportPage Class See Also Send Feedback
Gets or sets a script event name that will be fired when the report engine is about to print databands in this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ManualBuildEvent { get; set; }
Visual Basic (Declaration)
Public Property ManualBuildEvent As String
Visual C++
public:
property String^ ManualBuildEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportPage Class
FastReport Namespace


MirrorMargins Property

[image]

FastReport.Net Class Reference
ReportPage..::.MirrorMargins Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating that even pages should swap its left and right margins when previewed or printed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MirrorMargins { get; set; }
Visual Basic (Declaration)
Public Property MirrorMargins As Boolean
Visual C++
public:
property bool MirrorMargins {
    bool get ();
    void set (bool value);
}

See Also

ReportPage Class
FastReport Namespace


OtherPagesSource Property

[image]

FastReport.Net Class Reference
ReportPage..::.OtherPagesSource Property
ReportPage Class See Also Send Feedback
Gets or sets the paper source for all printed pages except the first one.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int OtherPagesSource { get; set; }
Visual Basic (Declaration)
Public Property OtherPagesSource As Integer
Visual C++
public:
property int OtherPagesSource {
    int get ();
    void set (int value);
}

Remarks

This property represents the paper source (printer tray) that will be used when printing all pages except the first one. To set source for the first page, use the FirstPageSource property.

Note: This property uses the raw number of the paper source.

See Also

ReportPage Class
FastReport Namespace


OutlineExpression Property

[image]

FastReport.Net Class Reference
ReportPage..::.OutlineExpression Property
ReportPage Class See Also Send Feedback
Gets or sets an outline expression.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string OutlineExpression { get; set; }
Visual Basic (Declaration)
Public Property OutlineExpression As String
Visual C++
public:
property String^ OutlineExpression {
    String^ get ();
    void set (String^ value);
}

Remarks

For more information, see OutlineExpression property.

See Also

ReportPage Class
FastReport Namespace


Overlay Property

[image]

FastReport.Net Class Reference
ReportPage..::.Overlay Property
ReportPage Class See Also Send Feedback
Gets or sets an overlay band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OverlayBand Overlay { get; set; }
Visual Basic (Declaration)
Public Property Overlay As OverlayBand
Visual C++
public:
property OverlayBand^ Overlay {
    OverlayBand^ get ();
    void set (OverlayBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


PageFooter Property

[image]

FastReport.Net Class Reference
ReportPage..::.PageFooter Property
ReportPage Class See Also Send Feedback
Gets or sets a page footer band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageFooterBand PageFooter { get; set; }
Visual Basic (Declaration)
Public Property PageFooter As PageFooterBand
Visual C++
public:
property PageFooterBand^ PageFooter {
    PageFooterBand^ get ();
    void set (PageFooterBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


PageHeader Property

[image]

FastReport.Net Class Reference
ReportPage..::.PageHeader Property
ReportPage Class See Also Send Feedback
Gets or sets a page header band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageHeaderBand PageHeader { get; set; }
Visual Basic (Declaration)
Public Property PageHeader As PageHeaderBand
Visual C++
public:
property PageHeaderBand^ PageHeader {
    PageHeaderBand^ get ();
    void set (PageHeaderBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


PaperHeight Property

[image]

FastReport.Net Class Reference
ReportPage..::.PaperHeight Property
ReportPage Class See Also Send Feedback
Gets or sets a height of the paper, in millimeters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PaperHeight { get; set; }
Visual Basic (Declaration)
Public Property PaperHeight As Single
Visual C++
public:
property float PaperHeight {
    float get ();
    void set (float value);
}

See Also

ReportPage Class
FastReport Namespace


PaperWidth Property

[image]

FastReport.Net Class Reference
ReportPage..::.PaperWidth Property
ReportPage Class See Also Send Feedback
Gets or sets a width of the paper, in millimeters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PaperWidth { get; set; }
Visual Basic (Declaration)
Public Property PaperWidth As Single
Visual C++
public:
property float PaperWidth {
    float get ();
    void set (float value);
}

See Also

ReportPage Class
FastReport Namespace


PrintOnPreviousPage Property

[image]

FastReport.Net Class Reference
ReportPage..::.PrintOnPreviousPage Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating whether to start to print this page on a free space of the previous page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnPreviousPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnPreviousPage As Boolean
Visual C++
public:
property bool PrintOnPreviousPage {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used if you have two or more pages in the report template.

See Also

ReportPage Class
FastReport Namespace


RawPaperSize Property

[image]

FastReport.Net Class Reference
ReportPage..::.RawPaperSize Property
ReportPage Class See Also Send Feedback
Gets or sets the raw index of a paper size.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RawPaperSize { get; set; }
Visual Basic (Declaration)
Public Property RawPaperSize As Integer
Visual C++
public:
property int RawPaperSize {
    int get ();
    void set (int value);
}

Remarks

This property stores the RawKind value of a selected papersize. It is used to distiguish between several papers with the same size (for ex. "A3" and "A3 with no margins") used in some printer drivers.

It is not obligatory to set this property. FastReport will select the necessary paper using the PaperWidth and PaperHeight values.

See Also

ReportPage Class
FastReport Namespace


ReportSummary Property

[image]

FastReport.Net Class Reference
ReportPage..::.ReportSummary Property
ReportPage Class See Also Send Feedback
Gets or sets a report summary band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportSummaryBand ReportSummary { get; set; }
Visual Basic (Declaration)
Public Property ReportSummary As ReportSummaryBand
Visual C++
public:
property ReportSummaryBand^ ReportSummary {
    ReportSummaryBand^ get ();
    void set (ReportSummaryBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


ReportTitle Property

[image]

FastReport.Net Class Reference
ReportPage..::.ReportTitle Property
ReportPage Class See Also Send Feedback
Gets or sets a report title band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportTitleBand ReportTitle { get; set; }
Visual Basic (Declaration)
Public Property ReportTitle As ReportTitleBand
Visual C++
public:
property ReportTitleBand^ ReportTitle {
    ReportTitleBand^ get ();
    void set (ReportTitleBand^ value);
}

See Also

ReportPage Class
FastReport Namespace


ResetPageNumber Property

[image]

FastReport.Net Class Reference
ReportPage..::.ResetPageNumber Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating that FastReport engine must reset page numbers before printing this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ResetPageNumber { get; set; }
Visual Basic (Declaration)
Public Property ResetPageNumber As Boolean
Visual C++
public:
property bool ResetPageNumber {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used if you have two or more pages in the report template.

See Also

ReportPage Class
FastReport Namespace


RightMargin Property

[image]

FastReport.Net Class Reference
ReportPage..::.RightMargin Property
ReportPage Class See Also Send Feedback
Gets or sets the right page margin, in millimeters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float RightMargin { get; set; }
Visual Basic (Declaration)
Public Property RightMargin As Single
Visual C++
public:
property float RightMargin {
    float get ();
    void set (float value);
}

See Also

ReportPage Class
FastReport Namespace


SnapSize Property

[image]

FastReport.Net Class Reference
ReportPage..::.SnapSize Property
ReportPage Class See Also Send Feedback
Gets the snap size for this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF SnapSize { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SnapSize As SizeF
Visual C++
public:
virtual property SizeF SnapSize {
    SizeF get () override;
}

See Also

ReportPage Class
FastReport Namespace


StartOnOddPage Property

[image]

FastReport.Net Class Reference
ReportPage..::.StartOnOddPage Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating whether this page will start on an odd page only.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StartOnOddPage { get; set; }
Visual Basic (Declaration)
Public Property StartOnOddPage As Boolean
Visual C++
public:
property bool StartOnOddPage {
    bool get ();
    void set (bool value);
}

Remarks

This property is useful to print booklet-type reports. Setting this property to true means that this page will start to print on an odd page only. If necessary, an empty page will be added to the prepared report before this page will be printed.

See Also

ReportPage Class
FastReport Namespace


StartPageEvent Property

[image]

FastReport.Net Class Reference
ReportPage..::.StartPageEvent Property
ReportPage Class See Also Send Feedback
Gets or sets a script event name that will be fired when the report engine starts this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string StartPageEvent { get; set; }
Visual Basic (Declaration)
Public Property StartPageEvent As String
Visual C++
public:
property String^ StartPageEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ReportPage Class
FastReport Namespace


Subreport Property

[image]

FastReport.Net Class Reference
ReportPage..::.Subreport Property
ReportPage Class See Also Send Feedback
Gets or sets the reference to a parent SubreportObject that owns this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SubreportObject Subreport { get; set; }
Visual Basic (Declaration)
Public Property Subreport As SubreportObject
Visual C++
public:
property SubreportObject^ Subreport {
    SubreportObject^ get ();
    void set (SubreportObject^ value);
}

Remarks

This property is null for regular report pages. See the SubreportObject for details.

See Also

ReportPage Class
FastReport Namespace


TitleBeforeHeader Property

[image]

FastReport.Net Class Reference
ReportPage..::.TitleBeforeHeader Property
ReportPage Class See Also Send Feedback
Gets or sets a value indicating that ReportTitle band should be printed before the PageHeader band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool TitleBeforeHeader { get; set; }
Visual Basic (Declaration)
Public Property TitleBeforeHeader As Boolean
Visual C++
public:
property bool TitleBeforeHeader {
    bool get ();
    void set (bool value);
}

See Also

ReportPage Class
FastReport Namespace


Top Property

[image]

FastReport.Net Class Reference
ReportPage..::.Top Property
ReportPage Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

See Also

ReportPage Class
FastReport Namespace


TopMargin Property

[image]

FastReport.Net Class Reference
ReportPage..::.TopMargin Property
ReportPage Class See Also Send Feedback
Gets or sets the top page margin, in millimeters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float TopMargin { get; set; }
Visual Basic (Declaration)
Public Property TopMargin As Single
Visual C++
public:
property float TopMargin {
    float get ();
    void set (float value);
}

See Also

ReportPage Class
FastReport Namespace


Watermark Property

[image]

FastReport.Net Class Reference
ReportPage..::.Watermark Property
ReportPage Class See Also Send Feedback
Gets or sets the page watermark.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Watermark Watermark { get; set; }
Visual Basic (Declaration)
Public Property Watermark As Watermark
Visual C++
public:
property Watermark^ Watermark {
    Watermark^ get ();
    void set (Watermark^ value);
}

Remarks

To enabled watermark, set its Enabled property to true.

See Also

ReportPage Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
ReportPage..::.Width Property
ReportPage Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

See Also

ReportPage Class
FastReport Namespace


ReportPage Events

[image] [image]

FastReport.Net Class Reference
ReportPage Events
ReportPage Class See Also Send Feedback

The ReportPage type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FinishPage | This event occurs when the report engine finished this page.
ManualBuild | This event occurs when the report engine is about to print databands in this page.
StartPage | This event occurs when the report engine starts this page.

See Also

ReportPage Class
FastReport Namespace


FinishPage Event

[image]

FastReport.Net Class Reference
ReportPage..::.FinishPage Event
ReportPage Class See Also Send Feedback
This event occurs when the report engine finished this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler FinishPage
Visual Basic (Declaration)
Public Event FinishPage As EventHandler
Visual C++
public:
 event EventHandler^ FinishPage {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportPage Class
FastReport Namespace


ManualBuild Event

[image]

FastReport.Net Class Reference
ReportPage..::.ManualBuild Event
ReportPage Class See Also Send Feedback
This event occurs when the report engine is about to print databands in this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ManualBuild
Visual Basic (Declaration)
Public Event ManualBuild As EventHandler
Visual C++
public:
 event EventHandler^ ManualBuild {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportPage Class
FastReport Namespace


StartPage Event

[image]

FastReport.Net Class Reference
ReportPage..::.StartPage Event
ReportPage Class See Also Send Feedback
This event occurs when the report engine starts this page.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler StartPage
Visual Basic (Declaration)
Public Event StartPage As EventHandler
Visual C++
public:
 event EventHandler^ StartPage {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportPage Class
FastReport Namespace


ReportSettings Class

[image]

FastReport.Net Class Reference
ReportSettings Class
Members See Also Send Feedback
This class contains settings that will be applied to the Report component.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportSettings
Visual Basic (Declaration)
Public Class ReportSettings
Visual C++
public ref class ReportSettings

Inheritance Hierarchy

System..::.Object
FastReport..::.ReportSettings

See Also

ReportSettings Members
FastReport Namespace


ReportSettings Members

[image] [image]

FastReport.Net Class Reference
ReportSettings Members
ReportSettings Class Constructors Methods Properties Events See Also Send Feedback

The ReportSettings type exposes the following members.

Constructors

Name | Description
ReportSettings | Initializes a new instance of the ReportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultLanguage | Gets or sets the default script language.
DefaultPaperSize | Gets or sets the default paper size used when creating a new report.
ShowPerformance | Gets or sets a value that determines whether to show the information about the report performance (report generation time, memory consumed) in the lower right corner of the preview window.
ShowProgress | Gets or sets a value that determines whether to show the progress window when perform time-consuming operations such as run, print, export.
UsePropValuesToDiscoverBO | Gets or sets a value indicating that the business object engine will use property values when possible to discover the BO structure.

Events

Name | Description
AfterDatabaseLogin | Occurs after the database connection is established.
DatabaseLogin | Occurs when database connection is about to open.
FilterBusinessObjectProperties | Occurs when discovering the business object's structure.
FinishProgress | Occurs after closing a progress window.
GetBusinessObjectPropertyKind | Occurs when determining the kind of business object's property.
GetBusinessObjectTypeInstance | Occurs when discovering the structure of business object of ICustomTypeDescriptor type with no instance specified.
Progress | Occurs when progress state is changed.
ReportPrinted | Occurs after printing a report.
StartProgress | Occurs before displaying a progress window.

See Also

ReportSettings Class
FastReport Namespace


ReportSettings Constructor

[image]

FastReport.Net Class Reference
ReportSettings Constructor
ReportSettings Class See Also Send Feedback
Initializes a new instance of the ReportSettings class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportSettings()

See Also

ReportSettings Class
FastReport Namespace


ReportSettings Methods

[image] [image]

FastReport.Net Class Reference
ReportSettings Methods
ReportSettings Class See Also Send Feedback

The ReportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportSettings Class
FastReport Namespace


ReportSettings Properties

[image] [image]

FastReport.Net Class Reference
ReportSettings Properties
ReportSettings Class See Also Send Feedback

The ReportSettings type exposes the following members.

Properties

Name | Description
DefaultLanguage | Gets or sets the default script language.
DefaultPaperSize | Gets or sets the default paper size used when creating a new report.
ShowPerformance | Gets or sets a value that determines whether to show the information about the report performance (report generation time, memory consumed) in the lower right corner of the preview window.
ShowProgress | Gets or sets a value that determines whether to show the progress window when perform time-consuming operations such as run, print, export.
UsePropValuesToDiscoverBO | Gets or sets a value indicating that the business object engine will use property values when possible to discover the BO structure.

See Also

ReportSettings Class
FastReport Namespace


DefaultLanguage Property

[image]

FastReport.Net Class Reference
ReportSettings..::.DefaultLanguage Property
ReportSettings Class See Also Send Feedback
Gets or sets the default script language.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Language DefaultLanguage { get; set; }
Visual Basic (Declaration)
Public Property DefaultLanguage As Language
Visual C++
public:
property Language DefaultLanguage {
    Language get ();
    void set (Language value);
}

See Also

ReportSettings Class
FastReport Namespace


DefaultPaperSize Property

[image]

FastReport.Net Class Reference
ReportSettings..::.DefaultPaperSize Property
ReportSettings Class See Also Send Feedback
Gets or sets the default paper size used when creating a new report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DefaultPaperSize DefaultPaperSize { get; set; }
Visual Basic (Declaration)
Public Property DefaultPaperSize As DefaultPaperSize
Visual C++
public:
property DefaultPaperSize DefaultPaperSize {
    DefaultPaperSize get ();
    void set (DefaultPaperSize value);
}

See Also

ReportSettings Class
FastReport Namespace


ShowPerformance Property

[image]

FastReport.Net Class Reference
ReportSettings..::.ShowPerformance Property
ReportSettings Class See Also Send Feedback
Gets or sets a value that determines whether to show the information about the report performance (report generation time, memory consumed) in the lower right corner of the preview window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPerformance { get; set; }
Visual Basic (Declaration)
Public Property ShowPerformance As Boolean
Visual C++
public:
property bool ShowPerformance {
    bool get ();
    void set (bool value);
}

See Also

ReportSettings Class
FastReport Namespace


ShowProgress Property

[image]

FastReport.Net Class Reference
ReportSettings..::.ShowProgress Property
ReportSettings Class See Also Send Feedback
Gets or sets a value that determines whether to show the progress window when perform time-consuming operations such as run, print, export.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowProgress { get; set; }
Visual Basic (Declaration)
Public Property ShowProgress As Boolean
Visual C++
public:
property bool ShowProgress {
    bool get ();
    void set (bool value);
}

See Also

ReportSettings Class
FastReport Namespace


UsePropValuesToDiscoverBO Property

[image]

FastReport.Net Class Reference
ReportSettings..::.UsePropValuesToDiscoverBO Property
ReportSettings Class See Also Send Feedback
Gets or sets a value indicating that the business object engine will use property values when possible to discover the BO structure.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UsePropValuesToDiscoverBO { get; set; }
Visual Basic (Declaration)
Public Property UsePropValuesToDiscoverBO As Boolean
Visual C++
public:
property bool UsePropValuesToDiscoverBO {
    bool get ();
    void set (bool value);
}

See Also

ReportSettings Class
FastReport Namespace


ReportSettings Events

[image] [image]

FastReport.Net Class Reference
ReportSettings Events
ReportSettings Class See Also Send Feedback

The ReportSettings type exposes the following members.

Events

Name | Description
AfterDatabaseLogin | Occurs after the database connection is established.
DatabaseLogin | Occurs when database connection is about to open.
FilterBusinessObjectProperties | Occurs when discovering the business object's structure.
FinishProgress | Occurs after closing a progress window.
GetBusinessObjectPropertyKind | Occurs when determining the kind of business object's property.
GetBusinessObjectTypeInstance | Occurs when discovering the structure of business object of ICustomTypeDescriptor type with no instance specified.
Progress | Occurs when progress state is changed.
ReportPrinted | Occurs after printing a report.
StartProgress | Occurs before displaying a progress window.

See Also

ReportSettings Class
FastReport Namespace


AfterDatabaseLogin Event

[image]

FastReport.Net Class Reference
ReportSettings..::.AfterDatabaseLogin Event
ReportSettings Class See Also Send Feedback
Occurs after the database connection is established.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event AfterDatabaseLoginEventHandler AfterDatabaseLogin
Visual Basic (Declaration)
Public Event AfterDatabaseLogin As AfterDatabaseLoginEventHandler
Visual C++
public:
 event AfterDatabaseLoginEventHandler^ AfterDatabaseLogin {
    void add (AfterDatabaseLoginEventHandler^ value);
    void remove (AfterDatabaseLoginEventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


DatabaseLogin Event

[image]

FastReport.Net Class Reference
ReportSettings..::.DatabaseLogin Event
ReportSettings Class Example See Also Send Feedback
Occurs when database connection is about to open.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event DatabaseLoginEventHandler DatabaseLogin
Visual Basic (Declaration)
Public Event DatabaseLogin As DatabaseLoginEventHandler
Visual C++
public:
 event DatabaseLoginEventHandler^ DatabaseLogin {
    void add (DatabaseLoginEventHandler^ value);
    void remove (DatabaseLoginEventHandler^ value);
}

Remarks

Use this event to provide own connection string or user name/password to the connection object that is about to open.

To provide own connection string, set the e.ConnectionString property. In this case the new connection string will be used.

To provide own user name/password, set the e.UserName and e.Password properties. You may ask these values in own login dialog.

Examples

This example shows how to provide username/password using own login dialog.
CopyC#
private void report1_DatabaseLogin(object sender, DatabaseLoginEventArgs e)
{
  using (MyLoginDialog dialog = new MyLoginDialog())
  {
    if (dialog.ShowDialog() == DialogResult.OK)
    {
      e.UserName = dialog.UserName;
      e.Password = dialog.Password;
    }
  }
}

Examples

This example shows how to provide own connection string.
CopyC#
private void report1_DatabaseLogin(object sender, DatabaseLoginEventArgs e)
{
  e.ConnectionString = my_connection_string;
}

See Also

ReportSettings Class
FastReport Namespace


FilterBusinessObjectProperties Event

[image]

FastReport.Net Class Reference
ReportSettings..::.FilterBusinessObjectProperties Event
ReportSettings Class See Also Send Feedback
Occurs when discovering the business object's structure.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event FilterPropertiesEventHandler FilterBusinessObjectProperties
Visual Basic (Declaration)
Public Event FilterBusinessObjectProperties As FilterPropertiesEventHandler
Visual C++
public:
 event FilterPropertiesEventHandler^ FilterBusinessObjectProperties {
    void add (FilterPropertiesEventHandler^ value);
    void remove (FilterPropertiesEventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


FinishProgress Event

[image]

FastReport.Net Class Reference
ReportSettings..::.FinishProgress Event
ReportSettings Class See Also Send Feedback
Occurs after closing a progress window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler FinishProgress
Visual Basic (Declaration)
Public Event FinishProgress As EventHandler
Visual C++
public:
 event EventHandler^ FinishProgress {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


GetBusinessObjectPropertyKind Event

[image]

FastReport.Net Class Reference
ReportSettings..::.GetBusinessObjectPropertyKind Event
ReportSettings Class See Also Send Feedback
Occurs when determining the kind of business object's property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event GetPropertyKindEventHandler GetBusinessObjectPropertyKind
Visual Basic (Declaration)
Public Event GetBusinessObjectPropertyKind As GetPropertyKindEventHandler
Visual C++
public:
 event GetPropertyKindEventHandler^ GetBusinessObjectPropertyKind {
    void add (GetPropertyKindEventHandler^ value);
    void remove (GetPropertyKindEventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


GetBusinessObjectTypeInstance Event

[image]

FastReport.Net Class Reference
ReportSettings..::.GetBusinessObjectTypeInstance Event
ReportSettings Class See Also Send Feedback
Occurs when discovering the structure of business object of ICustomTypeDescriptor type with no instance specified.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event GetTypeInstanceEventHandler GetBusinessObjectTypeInstance
Visual Basic (Declaration)
Public Event GetBusinessObjectTypeInstance As GetTypeInstanceEventHandler
Visual C++
public:
 event GetTypeInstanceEventHandler^ GetBusinessObjectTypeInstance {
    void add (GetTypeInstanceEventHandler^ value);
    void remove (GetTypeInstanceEventHandler^ value);
}

Remarks

The event handler must return an instance of that type.

See Also

ReportSettings Class
FastReport Namespace


Progress Event

[image]

FastReport.Net Class Reference
ReportSettings..::.Progress Event
ReportSettings Class See Also Send Feedback
Occurs when progress state is changed.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ProgressEventHandler Progress
Visual Basic (Declaration)
Public Event Progress As ProgressEventHandler
Visual C++
public:
 event ProgressEventHandler^ Progress {
    void add (ProgressEventHandler^ value);
    void remove (ProgressEventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


ReportPrinted Event

[image]

FastReport.Net Class Reference
ReportSettings..::.ReportPrinted Event
ReportSettings Class See Also Send Feedback
Occurs after printing a report.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ReportPrinted
Visual Basic (Declaration)
Public Event ReportPrinted As EventHandler
Visual C++
public:
 event EventHandler^ ReportPrinted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


StartProgress Event

[image]

FastReport.Net Class Reference
ReportSettings..::.StartProgress Event
ReportSettings Class See Also Send Feedback
Occurs before displaying a progress window.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler StartProgress
Visual Basic (Declaration)
Public Event StartProgress As EventHandler
Visual C++
public:
 event EventHandler^ StartProgress {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportSettings Class
FastReport Namespace


ReportSummaryBand Class

[image]

FastReport.Net Class Reference
ReportSummaryBand Class
Members See Also Send Feedback
Represents a report summary band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportSummaryBand : HeaderFooterBandBase
Visual Basic (Declaration)
Public Class ReportSummaryBand _
    Inherits HeaderFooterBandBase
Visual C++
public ref class ReportSummaryBand : public HeaderFooterBandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.HeaderFooterBandBase
FastReport..::.ReportSummaryBand

See Also

ReportSummaryBand Members
FastReport Namespace


ReportSummaryBand Members

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand Members
ReportSummaryBand Class Constructors Methods Properties Events See Also Send Feedback

The ReportSummaryBand type exposes the following members.

Constructors

Name | Description
ReportSummaryBand | Initializes a new instance of the ReportSummaryBand class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides HeaderFooterBandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | This property is not relevant to this class.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ReportSummaryBand Class
FastReport Namespace


ReportSummaryBand Constructor

[image]

FastReport.Net Class Reference
ReportSummaryBand Constructor
ReportSummaryBand Class See Also Send Feedback
Initializes a new instance of the ReportSummaryBand class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportSummaryBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportSummaryBand()

See Also

ReportSummaryBand Class
FastReport Namespace


ReportSummaryBand Methods

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand Methods
ReportSummaryBand Class See Also Send Feedback

The ReportSummaryBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from HeaderFooterBandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Overrides HeaderFooterBandBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from HeaderFooterBandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

ReportSummaryBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand..::.Dispose Method
ReportSummaryBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ReportSummaryBand Class
ReportSummaryBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand..::.DrawMarkers Method
ReportSummaryBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ReportSummaryBand Class
ReportSummaryBand Members
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
ReportSummaryBand..::.GetContextMenu Method
ReportSummaryBand Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

ReportSummaryBand Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand..::.MemberwiseClone Method
ReportSummaryBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportSummaryBand Class
ReportSummaryBand Members
FastReport Namespace


ReportSummaryBand Properties

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand Properties
ReportSummaryBand Class See Also Send Feedback

The ReportSummaryBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
KeepWithData | Gets or sets a value indicating that the band should be printed together with data band. (Inherited from HeaderFooterBandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
RepeatOnEveryPage | This property is not relevant to this class.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ReportSummaryBand Class
FastReport Namespace


RepeatOnEveryPage Property

[image]

FastReport.Net Class Reference
ReportSummaryBand..::.RepeatOnEveryPage Property
ReportSummaryBand Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool RepeatOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property RepeatOnEveryPage As Boolean
Visual C++
public:
property bool RepeatOnEveryPage {
    bool get ();
    void set (bool value);
}

See Also

ReportSummaryBand Class
FastReport Namespace


ReportSummaryBand Events

[image] [image]

FastReport.Net Class Reference
ReportSummaryBand Events
ReportSummaryBand Class See Also Send Feedback

The ReportSummaryBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ReportSummaryBand Class
FastReport Namespace


ReportTitleBand Class

[image]

FastReport.Net Class Reference
ReportTitleBand Class
Members See Also Send Feedback
Represents a report title band.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportTitleBand : BandBase
Visual Basic (Declaration)
Public Class ReportTitleBand _
    Inherits BandBase
Visual C++
public ref class ReportTitleBand : public BandBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.BandBase
FastReport..::.ReportTitleBand

See Also

ReportTitleBand Members
FastReport Namespace


ReportTitleBand Members

[image] [image]

FastReport.Net Class Reference
ReportTitleBand Members
ReportTitleBand Class Constructors Methods Properties Events See Also Send Feedback

The ReportTitleBand type exposes the following members.

Constructors

Name | Description
ReportTitleBand | Initializes a new instance of the ReportTitleBand class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ReportTitleBand Class
FastReport Namespace


ReportTitleBand Constructor

[image]

FastReport.Net Class Reference
ReportTitleBand Constructor
ReportTitleBand Class See Also Send Feedback
Initializes a new instance of the ReportTitleBand class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportTitleBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportTitleBand()

See Also

ReportTitleBand Class
FastReport Namespace


ReportTitleBand Methods

[image] [image]

FastReport.Net Class Reference
ReportTitleBand Methods
ReportTitleBand Class See Also Send Feedback

The ReportTitleBand type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from BandBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from BandBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BandBase.)
CalcHeight | Calculates the object's height. (Inherited from BandBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from BandBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from BandBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from BandBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from BandBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from BandBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from BandBase.)
GetContextMenu | Gets the object's context menu. (Inherited from BandBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from BandBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from BandBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from BandBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from BandBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from BandBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from BandBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from BandBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLayout | This method fires the AfterLayout event and the script code connected to the AfterLayoutEvent. (Inherited from BandBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforeLayout | This method fires the BeforeLayout event and the script code connected to the BeforeLayoutEvent. (Inherited from BandBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from BandBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from BandBase.)
RestoreState | Restores the object's state after printing it. (Inherited from BandBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from BandBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from BandBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from BandBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from BandBase.)

See Also

ReportTitleBand Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ReportTitleBand..::.Dispose Method
ReportTitleBand Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ReportTitleBand Class
ReportTitleBand Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ReportTitleBand..::.DrawMarkers Method
ReportTitleBand Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ReportTitleBand Class
ReportTitleBand Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ReportTitleBand..::.MemberwiseClone Method
ReportTitleBand Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportTitleBand Class
ReportTitleBand Members
FastReport Namespace


ReportTitleBand Properties

[image] [image]

FastReport.Net Class Reference
ReportTitleBand Properties
ReportTitleBand Class See Also Send Feedback

The ReportTitleBand type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from BandBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsRowNo | Gets an absolute row number (the same value returned by the "AbsRow#" system variable). (Inherited from BandBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from BandBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayoutEvent | Gets or sets a script event name that will be fired after the child objects layout was finished. (Inherited from BandBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from BandBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforeLayoutEvent | Gets or sets a script event name that will be fired before the band layouts its child objects. (Inherited from BandBase.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from BandBase.)
CanBreak | This property is not relevant to this class. (Inherited from BandBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Child | Gets or sets a child band that will be printed right after this band. (Inherited from BandBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from BandBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstRowStartsNewPage | Gets or sets a value indicating that the first row can start a new report page. (Inherited from BandBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class. (Inherited from BandBase.)
Guides | Gets or sets collection of guide lines for this band. (Inherited from BandBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsFirstRow | Gets a value indicating that this is the first data row. (Inherited from BandBase.)
IsLastRow | Gets a value indicating that this is the last data row. (Inherited from BandBase.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepChild | Gets or sets a value indicating that the band should be printed together with its child band. (Inherited from BandBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from BandBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Objects | Gets a collection of report objects belongs to this band. (Inherited from BandBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
OutlineExpression | Gets or sets an outline expression. (Inherited from BandBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnBottom | Gets or sets a value indicating that the band should be printed on the page bottom. (Inherited from BandBase.)
Repeated | Gets a value indicating that band is reprinted on a new page. (Inherited from BandBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowNo | Gets a row number (the same value returned by the "Row#" system variable). (Inherited from BandBase.)
ShiftMode | This property is not relevant to this class. (Inherited from BandBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StartNewPage | Gets or sets a value indicating that the band should be printed from a new page. (Inherited from BandBase.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from BandBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from BandBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ReportTitleBand Class
FastReport Namespace


ReportTitleBand Events

[image] [image]

FastReport.Net Class Reference
ReportTitleBand Events
ReportTitleBand Class See Also Send Feedback

The ReportTitleBand type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterLayout | This event occurs after the child objects layout was finished. (Inherited from BandBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforeLayout | This event occurs before the band layouts its child objects. (Inherited from BandBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ReportTitleBand Class
FastReport Namespace


Restrictions Enumeration

[image]

FastReport.Net Class Reference
Restrictions Enumeration
See Also Send Feedback
Specifies a set of actions that cannot be performed on the object in the design mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
[FlagsAttribute]
public enum Restrictions
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration Restrictions
Visual C++
[FlagsAttribute]
public enum class Restrictions

Members

Member name | Description
None | Specifies no restrictions.
DontMove | Restricts moving the object.
DontResize | Restricts resizing the object.
DontModify | Restricts modifying the object's properties.
DontEdit | Restricts editing the object.
DontDelete | Restricts deleting the object.
HideAllProperties | Hides all properties of the object.

See Also

FastReport Namespace


RichObject Class

[image]

FastReport.Net Class Reference
RichObject Class
Members See Also Send Feedback
Represents a RichText object that can display formatted text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RichObject : TextObjectBase, IHasEditor
Visual Basic (Declaration)
Public Class RichObject _
    Inherits TextObjectBase _
    Implements IHasEditor
Visual C++
public ref class RichObject : public TextObjectBase,
    IHasEditor

Remarks

Use the Text property to set the object's text. The text may include the RTF formatting tags.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.TextObjectBase
FastReport..::.RichObject

See Also

RichObject Members
FastReport Namespace


RichObject Members

[image] [image]

FastReport.Net Class Reference
RichObject Members
RichObject Class Constructors Methods Properties Events See Also Send Feedback

The RichObject type exposes the following members.

Constructors

Name | Description
RichObject | Initializes a new instance of the RichObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides TextObjectBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from TextObjectBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from TextObjectBase.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Inherited from TextObjectBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides TextObjectBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
ActualTextLength | Gets the actual text length.
ActualTextStart | Gets the actual text start.
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a name of the data column bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values. (Inherited from TextObjectBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
OldBreakStyle | Gets or sets the break style.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object. (Inherited from TextObjectBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Text | Gets or sets the object's text. (Overrides TextObjectBase..::.Text.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

RichObject Class
FastReport Namespace


RichObject Constructor

[image]

FastReport.Net Class Reference
RichObject Constructor
RichObject Class See Also Send Feedback
Initializes a new instance of the RichObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RichObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichObject()

See Also

RichObject Class
FastReport Namespace


RichObject Methods

[image] [image]

FastReport.Net Class Reference
RichObject Methods
RichObject Class See Also Send Feedback

The RichObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides TextObjectBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from TextObjectBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from TextObjectBase.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Inherited from TextObjectBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides TextObjectBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RichObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
RichObject..::.Assign Method
RichObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

RichObject Class
FastReport Namespace
AssignAll Method


Break Method

[image]

FastReport.Net Class Reference
RichObject..::.Break Method
RichObject Class See Also Send Feedback
Breaks the contents of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Break(
    BreakableComponent breakTo
)
Visual Basic (Declaration)
Public Overrides Function Break ( _
    breakTo As BreakableComponent _
) As Boolean
Visual C++
public:
virtual bool Break(
    BreakableComponent^ breakTo
) override

Parameters

breakTo
Type: FastReport..::.BreakableComponent
Object to put the part of content to that does not fit in this object. These two objects must have the same type.

Return Value

true if there is enough space in this object to display at least one text line.

Remarks

Do not call this method directly, it is used by the report engine. You should override it if you are writing a new FastReport object.

This method must break the contents of the object. The part of content that fit in current object's bounds should remain in this object, the part that does not fit should be transferred to breakTo object.

See Also

RichObject Class
FastReport Namespace


CalcHeight Method

[image]

FastReport.Net Class Reference
RichObject..::.CalcHeight Method
RichObject Class See Also Send Feedback
Calculates the object's height.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float CalcHeight()
Visual Basic (Declaration)
Public Overrides Function CalcHeight As Single
Visual C++
public:
virtual float CalcHeight() override

Return Value

Actual object's height, in pixels.

Remarks

Applicable to objects that contain several text lines, such as TextObject. Returns the height needed to display all the text lines.

See Also

RichObject Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
RichObject..::.Dispose Method
RichObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

RichObject Class
RichObject Members
FastReport Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
RichObject..::.Dispose Method (Boolean)
RichObject Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

RichObject Class
Dispose Overload
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
RichObject..::.Draw Method
RichObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

RichObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
RichObject..::.DrawMarkers Method
RichObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

RichObject Class
RichObject Members
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
RichObject..::.GetContextMenu Method
RichObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

RichObject Class
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
RichObject..::.GetData Method
RichObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

RichObject Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
RichObject..::.GetExpressions Method
RichObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

RichObject Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
RichObject..::.GetSmartTag Method
RichObject Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

RichObject Class
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
RichObject..::.InvokeEditor Method
RichObject Class See Also Send Feedback
Invokes object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

Implements

IHasEditor..::.InvokeEditor()()()

See Also

RichObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
RichObject..::.MemberwiseClone Method
RichObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RichObject Class
RichObject Members
FastReport Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
RichObject..::.RestoreState Method
RichObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

RichObject Class
FastReport Namespace


SaveState Method

[image]

FastReport.Net Class Reference
RichObject..::.SaveState Method
RichObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

RichObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
RichObject..::.Serialize Method
RichObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

RichObject Class
FastReport Namespace


RichObject Properties

[image] [image]

FastReport.Net Class Reference
RichObject Properties
RichObject Class See Also Send Feedback

The RichObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
ActualTextLength | Gets the actual text length.
ActualTextStart | Gets the actual text start.
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a name of the data column bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values. (Inherited from TextObjectBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
OldBreakStyle | Gets or sets the break style.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object. (Inherited from TextObjectBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Text | Gets or sets the object's text. (Overrides TextObjectBase..::.Text.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

RichObject Class
FastReport Namespace


ActualTextLength Property

[image]

FastReport.Net Class Reference
RichObject..::.ActualTextLength Property
RichObject Class See Also Send Feedback
Gets the actual text length.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ActualTextLength { get; set; }
Visual Basic (Declaration)
Public Property ActualTextLength As Integer
Visual C++
public:
property int ActualTextLength {
    int get ();
    void set (int value);
}

Remarks

This property is for internal use only; you should not use it in your code.

See Also

RichObject Class
FastReport Namespace


ActualTextStart Property

[image]

FastReport.Net Class Reference
RichObject..::.ActualTextStart Property
RichObject Class See Also Send Feedback
Gets the actual text start.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ActualTextStart { get; set; }
Visual Basic (Declaration)
Public Property ActualTextStart As Integer
Visual C++
public:
property int ActualTextStart {
    int get ();
    void set (int value);
}

Remarks

This property is for internal use only; you should not use it in your code.

See Also

RichObject Class
FastReport Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
RichObject..::.DataColumn Property
RichObject Class See Also Send Feedback
Gets or sets a name of the data column bound to this control.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

Value must contain the datasource name, for example: "Datasource.Column".

See Also

RichObject Class
FastReport Namespace


OldBreakStyle Property

[image]

FastReport.Net Class Reference
RichObject..::.OldBreakStyle Property
RichObject Class See Also Send Feedback
Gets or sets the break style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool OldBreakStyle { get; set; }
Visual Basic (Declaration)
Public Property OldBreakStyle As Boolean
Visual C++
public:
property bool OldBreakStyle {
    bool get ();
    void set (bool value);
}

Remarks

Set this property to true if you want editable rich text when you edit the prepared report page.

See Also

RichObject Class
FastReport Namespace


Text Property

[image]

FastReport.Net Class Reference
RichObject..::.Text Property
RichObject Class See Also Send Feedback
Gets or sets the object's text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

This property returns the formatted text with rtf tags.

See Also

RichObject Class
FastReport Namespace


RichObject Events

[image] [image]

FastReport.Net Class Reference
RichObject Events
RichObject Class See Also Send Feedback

The RichObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

RichObject Class
FastReport Namespace


SelectedComponents Class

[image]

FastReport.Net Class Reference
SelectedComponents Class
Members See Also Send Feedback
Holds the list of ComponentBase objects currently selected in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectedComponents
Visual Basic (Declaration)
Public Class SelectedComponents
Visual C++
public ref class SelectedComponents

Remarks

This class is used by the "Alignment" toolbar. Use methods of this class to perform some operations on the selected objects.

Note: after calling any method in this class, call the Designer.SetModified method to reflect changes.

Note: this list contains only objects of ComponentBase type. If you want to access all selected objects, use the SelectedObjects property.

Inheritance Hierarchy

System..::.Object
FastReport..::.SelectedComponents

See Also

SelectedComponents Members
FastReport Namespace


SelectedComponents Members

[image] [image]

FastReport.Net Class Reference
SelectedComponents Members
SelectedComponents Class Methods Properties See Also Send Feedback

The SelectedComponents type exposes the following members.

Methods

Name | Description
AlignBottom | Aligns bottom edges of the selected objects.
AlignCenter | Aligns centers of the selected objects.
AlignLeft | Aligns left edges of the selected objects.
AlignMiddle | Aligns middles of the selected objects.
AlignRight | Aligns right edges of the selected objects.
AlignToGrid | Aligns the selected objects to the grid.
AlignTop | Aligns top edges of the selected objects.
CenterHorizontally | Centers the selected objects horizontally.
CenterVertically | Centers the selected objects vertically.
DecreaseHorizontalSpacing | Decreases horizontal spacing between the selected objects.
DecreaseVerticalSpacing | Decreases vertical spacing between the selected objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IncreaseHorizontalSpacing | Increases horizontal spacing between the selected objects.
IncreaseVerticalSpacing | Increases vertical spacing between the selected objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveHorizontalSpacing | Removes horizontal spacing between the selected objects.
RemoveVerticalSpacing | Removes vertical spacing between the selected objects.
SameHeight | Makes the selected objects the same height as the first object.
SameSize | Makes the selected objects the same size as the first object.
SameWidth | Makes the selected objects the same width as the first object.
SizeToGrid | Adjusts the size of selected objects to the grid.
SpaceHorizontally | Spaces the selected objects horizontally.
SpaceVertically | Spaces the selected objects vertically.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of selected objects.
First | Gets the first selected object.

See Also

SelectedComponents Class
FastReport Namespace


SelectedComponents Methods

[image] [image]

FastReport.Net Class Reference
SelectedComponents Methods
SelectedComponents Class See Also Send Feedback

The SelectedComponents type exposes the following members.

Methods

Name | Description
AlignBottom | Aligns bottom edges of the selected objects.
AlignCenter | Aligns centers of the selected objects.
AlignLeft | Aligns left edges of the selected objects.
AlignMiddle | Aligns middles of the selected objects.
AlignRight | Aligns right edges of the selected objects.
AlignToGrid | Aligns the selected objects to the grid.
AlignTop | Aligns top edges of the selected objects.
CenterHorizontally | Centers the selected objects horizontally.
CenterVertically | Centers the selected objects vertically.
DecreaseHorizontalSpacing | Decreases horizontal spacing between the selected objects.
DecreaseVerticalSpacing | Decreases vertical spacing between the selected objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IncreaseHorizontalSpacing | Increases horizontal spacing between the selected objects.
IncreaseVerticalSpacing | Increases vertical spacing between the selected objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveHorizontalSpacing | Removes horizontal spacing between the selected objects.
RemoveVerticalSpacing | Removes vertical spacing between the selected objects.
SameHeight | Makes the selected objects the same height as the first object.
SameSize | Makes the selected objects the same size as the first object.
SameWidth | Makes the selected objects the same width as the first object.
SizeToGrid | Adjusts the size of selected objects to the grid.
SpaceHorizontally | Spaces the selected objects horizontally.
SpaceVertically | Spaces the selected objects vertically.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedComponents Class
FastReport Namespace


AlignBottom Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignBottom Method
SelectedComponents Class See Also Send Feedback
Aligns bottom edges of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignBottom()
Visual Basic (Declaration)
Public Sub AlignBottom
Visual C++
public:
void AlignBottom()

See Also

SelectedComponents Class
FastReport Namespace


AlignCenter Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignCenter Method
SelectedComponents Class See Also Send Feedback
Aligns centers of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignCenter()
Visual Basic (Declaration)
Public Sub AlignCenter
Visual C++
public:
void AlignCenter()

See Also

SelectedComponents Class
FastReport Namespace


AlignLeft Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignLeft Method
SelectedComponents Class See Also Send Feedback
Aligns left edges of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignLeft()
Visual Basic (Declaration)
Public Sub AlignLeft
Visual C++
public:
void AlignLeft()

See Also

SelectedComponents Class
FastReport Namespace


AlignMiddle Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignMiddle Method
SelectedComponents Class See Also Send Feedback
Aligns middles of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignMiddle()
Visual Basic (Declaration)
Public Sub AlignMiddle
Visual C++
public:
void AlignMiddle()

See Also

SelectedComponents Class
FastReport Namespace


AlignRight Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignRight Method
SelectedComponents Class See Also Send Feedback
Aligns right edges of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignRight()
Visual Basic (Declaration)
Public Sub AlignRight
Visual C++
public:
void AlignRight()

See Also

SelectedComponents Class
FastReport Namespace


AlignToGrid Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignToGrid Method
SelectedComponents Class See Also Send Feedback
Aligns the selected objects to the grid.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignToGrid()
Visual Basic (Declaration)
Public Sub AlignToGrid
Visual C++
public:
void AlignToGrid()

See Also

SelectedComponents Class
FastReport Namespace


AlignTop Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.AlignTop Method
SelectedComponents Class See Also Send Feedback
Aligns top edges of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AlignTop()
Visual Basic (Declaration)
Public Sub AlignTop
Visual C++
public:
void AlignTop()

See Also

SelectedComponents Class
FastReport Namespace


CenterHorizontally Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.CenterHorizontally Method
SelectedComponents Class See Also Send Feedback
Centers the selected objects horizontally.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CenterHorizontally()
Visual Basic (Declaration)
Public Sub CenterHorizontally
Visual C++
public:
void CenterHorizontally()

See Also

SelectedComponents Class
FastReport Namespace


CenterVertically Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.CenterVertically Method
SelectedComponents Class See Also Send Feedback
Centers the selected objects vertically.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CenterVertically()
Visual Basic (Declaration)
Public Sub CenterVertically
Visual C++
public:
void CenterVertically()

See Also

SelectedComponents Class
FastReport Namespace


DecreaseHorizontalSpacing Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.DecreaseHorizontalSpacing Method
SelectedComponents Class See Also Send Feedback
Decreases horizontal spacing between the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DecreaseHorizontalSpacing()
Visual Basic (Declaration)
Public Sub DecreaseHorizontalSpacing
Visual C++
public:
void DecreaseHorizontalSpacing()

See Also

SelectedComponents Class
FastReport Namespace


DecreaseVerticalSpacing Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.DecreaseVerticalSpacing Method
SelectedComponents Class See Also Send Feedback
Decreases vertical spacing between the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DecreaseVerticalSpacing()
Visual Basic (Declaration)
Public Sub DecreaseVerticalSpacing
Visual C++
public:
void DecreaseVerticalSpacing()

See Also

SelectedComponents Class
FastReport Namespace


IncreaseHorizontalSpacing Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.IncreaseHorizontalSpacing Method
SelectedComponents Class See Also Send Feedback
Increases horizontal spacing between the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void IncreaseHorizontalSpacing()
Visual Basic (Declaration)
Public Sub IncreaseHorizontalSpacing
Visual C++
public:
void IncreaseHorizontalSpacing()

See Also

SelectedComponents Class
FastReport Namespace


IncreaseVerticalSpacing Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.IncreaseVerticalSpacing Method
SelectedComponents Class See Also Send Feedback
Increases vertical spacing between the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void IncreaseVerticalSpacing()
Visual Basic (Declaration)
Public Sub IncreaseVerticalSpacing
Visual C++
public:
void IncreaseVerticalSpacing()

See Also

SelectedComponents Class
FastReport Namespace


RemoveHorizontalSpacing Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.RemoveHorizontalSpacing Method
SelectedComponents Class See Also Send Feedback
Removes horizontal spacing between the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveHorizontalSpacing()
Visual Basic (Declaration)
Public Sub RemoveHorizontalSpacing
Visual C++
public:
void RemoveHorizontalSpacing()

See Also

SelectedComponents Class
FastReport Namespace


RemoveVerticalSpacing Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.RemoveVerticalSpacing Method
SelectedComponents Class See Also Send Feedback
Removes vertical spacing between the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveVerticalSpacing()
Visual Basic (Declaration)
Public Sub RemoveVerticalSpacing
Visual C++
public:
void RemoveVerticalSpacing()

See Also

SelectedComponents Class
FastReport Namespace


SameHeight Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.SameHeight Method
SelectedComponents Class See Also Send Feedback
Makes the selected objects the same height as the first object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SameHeight()
Visual Basic (Declaration)
Public Sub SameHeight
Visual C++
public:
void SameHeight()

See Also

SelectedComponents Class
FastReport Namespace


SameSize Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.SameSize Method
SelectedComponents Class See Also Send Feedback
Makes the selected objects the same size as the first object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SameSize()
Visual Basic (Declaration)
Public Sub SameSize
Visual C++
public:
void SameSize()

See Also

SelectedComponents Class
FastReport Namespace


SameWidth Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.SameWidth Method
SelectedComponents Class See Also Send Feedback
Makes the selected objects the same width as the first object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SameWidth()
Visual Basic (Declaration)
Public Sub SameWidth
Visual C++
public:
void SameWidth()

See Also

SelectedComponents Class
FastReport Namespace


SizeToGrid Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.SizeToGrid Method
SelectedComponents Class See Also Send Feedback
Adjusts the size of selected objects to the grid.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SizeToGrid()
Visual Basic (Declaration)
Public Sub SizeToGrid
Visual C++
public:
void SizeToGrid()

See Also

SelectedComponents Class
FastReport Namespace


SpaceHorizontally Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.SpaceHorizontally Method
SelectedComponents Class See Also Send Feedback
Spaces the selected objects horizontally.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SpaceHorizontally()
Visual Basic (Declaration)
Public Sub SpaceHorizontally
Visual C++
public:
void SpaceHorizontally()

See Also

SelectedComponents Class
FastReport Namespace


SpaceVertically Method

[image]

FastReport.Net Class Reference
SelectedComponents..::.SpaceVertically Method
SelectedComponents Class See Also Send Feedback
Spaces the selected objects vertically.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SpaceVertically()
Visual Basic (Declaration)
Public Sub SpaceVertically
Visual C++
public:
void SpaceVertically()

See Also

SelectedComponents Class
FastReport Namespace


SelectedComponents Properties

[image] [image]

FastReport.Net Class Reference
SelectedComponents Properties
SelectedComponents Class See Also Send Feedback

The SelectedComponents type exposes the following members.

Properties

Name | Description
Count | Gets the number of selected objects.
First | Gets the first selected object.

See Also

SelectedComponents Class
FastReport Namespace


Count Property

[image]

FastReport.Net Class Reference
SelectedComponents..::.Count Property
SelectedComponents Class See Also Send Feedback
Gets the number of selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

SelectedComponents Class
FastReport Namespace


First Property

[image]

FastReport.Net Class Reference
SelectedComponents..::.First Property
SelectedComponents Class See Also Send Feedback
Gets the first selected object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentBase First { get; }
Visual Basic (Declaration)
Public ReadOnly Property First As ComponentBase
Visual C++
public:
property ComponentBase^ First {
    ComponentBase^ get ();
}

See Also

SelectedComponents Class
FastReport Namespace


SelectedObjectCollection Class

[image]

FastReport.Net Class Reference
SelectedObjectCollection Class
Members See Also Send Feedback
Holds the list of selected objects of Base type. Used by the SelectedObjects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectedObjectCollection : ObjectCollection
Visual Basic (Declaration)
Public Class SelectedObjectCollection _
    Inherits ObjectCollection
Visual C++
public ref class SelectedObjectCollection : public ObjectCollection

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport..::.ObjectCollection
FastReport..::.SelectedObjectCollection

See Also

SelectedObjectCollection Members
FastReport Namespace


SelectedObjectCollection Members

[image] [image]

FastReport.Net Class Reference
SelectedObjectCollection Members
SelectedObjectCollection Class Constructors Methods Properties See Also Send Feedback

The SelectedObjectCollection type exposes the following members.

Constructors

Name | Description
SelectedObjectCollection | Initializes a new instance of the SelectedObjectCollection class

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
IsPageSelected | Gets a value indicating that report page is selected.
IsReportSelected | Gets a value indicating that report is selected.
Item | Gets or sets the element at the specified index. (Inherited from ObjectCollection.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

SelectedObjectCollection Class
FastReport Namespace


SelectedObjectCollection Constructor

[image]

FastReport.Net Class Reference
SelectedObjectCollection Constructor
SelectedObjectCollection Class See Also Send Feedback
Initializes a new instance of the SelectedObjectCollection class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectedObjectCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectedObjectCollection()

See Also

SelectedObjectCollection Class
FastReport Namespace


SelectedObjectCollection Methods

[image] [image]

FastReport.Net Class Reference
SelectedObjectCollection Methods
SelectedObjectCollection Class See Also Send Feedback

The SelectedObjectCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedObjectCollection Class
FastReport Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
SelectedObjectCollection..::.AddRange Method
SelectedObjectCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

SelectedObjectCollection Class
SelectedObjectCollection Members
FastReport Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
SelectedObjectCollection..::.Equals Method
SelectedObjectCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

SelectedObjectCollection Class
SelectedObjectCollection Members
FastReport Namespace


SelectedObjectCollection Properties

[image] [image]

FastReport.Net Class Reference
SelectedObjectCollection Properties
SelectedObjectCollection Class See Also Send Feedback

The SelectedObjectCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
IsPageSelected | Gets a value indicating that report page is selected.
IsReportSelected | Gets a value indicating that report is selected.
Item | Gets or sets the element at the specified index. (Inherited from ObjectCollection.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

SelectedObjectCollection Class
FastReport Namespace


IsPageSelected Property

[image]

FastReport.Net Class Reference
SelectedObjectCollection..::.IsPageSelected Property
SelectedObjectCollection Class See Also Send Feedback
Gets a value indicating that report page is selected.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsPageSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPageSelected As Boolean
Visual C++
public:
property bool IsPageSelected {
    bool get ();
}

See Also

SelectedObjectCollection Class
FastReport Namespace


IsReportSelected Property

[image]

FastReport.Net Class Reference
SelectedObjectCollection..::.IsReportSelected Property
SelectedObjectCollection Class See Also Send Feedback
Gets a value indicating that report is selected.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsReportSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReportSelected As Boolean
Visual C++
public:
property bool IsReportSelected {
    bool get ();
}

See Also

SelectedObjectCollection Class
FastReport Namespace


SelectedReportComponents Class

[image]

FastReport.Net Class Reference
SelectedReportComponents Class
Members See Also Send Feedback
Holds the list of ReportComponentBase objects currently selected in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectedReportComponents
Visual Basic (Declaration)
Public Class SelectedReportComponents
Visual C++
public ref class SelectedReportComponents

Remarks

This class is used by the "Border and Fill" toolbar. Use methods of this class to perform some operations on the selected objects.

Note: after calling any method in this class, call the Designer.SetModified method to reflect changes.

Note: this list contains only objects of ReportComponentBase type. If you want to access all selected objects, use the SelectedObjects property.

Inheritance Hierarchy

System..::.Object
FastReport..::.SelectedReportComponents

See Also

SelectedReportComponents Members
FastReport Namespace


SelectedReportComponents Members

[image] [image]

FastReport.Net Class Reference
SelectedReportComponents Members
SelectedReportComponents Class Methods Properties See Also Send Feedback

The SelectedReportComponents type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeBorderEditor | Invokes the border editor for the selected objects.
InvokeFillEditor | Invokes the fill editor for the selected objects.
InvokeHyperlinkEditor | Invokes the hyperlink editor for the selected objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Sets the border for the selected objects.
SetCanGrow | Sets the CanGrow flag for the selected objects.
SetCanShrink | Sets the CanShrink flag for the selected objects.
SetColor | Sets the solid fill color for the selected objects.
SetFill | Sets the fill for the selected objects.
SetGrowToBottom | Sets the GrowToBottom flag for the selected objects.
SetHyperlink | Sets the hyperlink for the selected objects.
SetLineColor | Sets the border color for the selected objects.
SetLineStyle | Sets the border style for the selected objects.
SetStyle | Sets the style for the selected objects.
SetWidth | Sets the border width for the selected objects.
ToggleLine | Toggles the specified border line for the selected objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BorderEnabled | Gets a value indicating whether the border operations are enabled.
Count | Gets the number of selected objects.
Enabled | Gets a value indicating whether the operations are enabled.
FillEnabled | Gets a value indicating whether the fill operations are enabled.
First | Gets the first selected object.
SimpleBorder | Gets a value indicating whether the object with simple border is selected.

See Also

SelectedReportComponents Class
FastReport Namespace


SelectedReportComponents Methods

[image] [image]

FastReport.Net Class Reference
SelectedReportComponents Methods
SelectedReportComponents Class See Also Send Feedback

The SelectedReportComponents type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeBorderEditor | Invokes the border editor for the selected objects.
InvokeFillEditor | Invokes the fill editor for the selected objects.
InvokeHyperlinkEditor | Invokes the hyperlink editor for the selected objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Sets the border for the selected objects.
SetCanGrow | Sets the CanGrow flag for the selected objects.
SetCanShrink | Sets the CanShrink flag for the selected objects.
SetColor | Sets the solid fill color for the selected objects.
SetFill | Sets the fill for the selected objects.
SetGrowToBottom | Sets the GrowToBottom flag for the selected objects.
SetHyperlink | Sets the hyperlink for the selected objects.
SetLineColor | Sets the border color for the selected objects.
SetLineStyle | Sets the border style for the selected objects.
SetStyle | Sets the style for the selected objects.
SetWidth | Sets the border width for the selected objects.
ToggleLine | Toggles the specified border line for the selected objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedReportComponents Class
FastReport Namespace


InvokeBorderEditor Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.InvokeBorderEditor Method
SelectedReportComponents Class See Also Send Feedback
Invokes the border editor for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeBorderEditor()
Visual Basic (Declaration)
Public Function InvokeBorderEditor As Boolean
Visual C++
public:
bool InvokeBorderEditor()

Return Value

true if editor was closed by the OK button.

See Also

SelectedReportComponents Class
FastReport Namespace


InvokeFillEditor Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.InvokeFillEditor Method
SelectedReportComponents Class See Also Send Feedback
Invokes the fill editor for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeFillEditor()
Visual Basic (Declaration)
Public Function InvokeFillEditor As Boolean
Visual C++
public:
bool InvokeFillEditor()

Return Value

true if editor was closed by the OK button.

See Also

SelectedReportComponents Class
FastReport Namespace


InvokeHyperlinkEditor Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.InvokeHyperlinkEditor Method
SelectedReportComponents Class See Also Send Feedback
Invokes the hyperlink editor for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeHyperlinkEditor()
Visual Basic (Declaration)
Public Function InvokeHyperlinkEditor As Boolean
Visual C++
public:
bool InvokeHyperlinkEditor()

Return Value

true if editor was closed by the OK button.

See Also

SelectedReportComponents Class
FastReport Namespace


SetBorder Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetBorder Method
SelectedReportComponents Class See Also Send Feedback
Sets the border for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetBorder(
    Border border
)
Visual Basic (Declaration)
Public Sub SetBorder ( _
    border As Border _
)
Visual C++
public:
void SetBorder(
    Border^ border
)

Parameters

border
Type: FastReport..::.Border
Border.

See Also

SelectedReportComponents Class
FastReport Namespace


SetCanGrow Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetCanGrow Method
SelectedReportComponents Class See Also Send Feedback
Sets the CanGrow flag for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetCanGrow(
    bool value
)
Visual Basic (Declaration)
Public Sub SetCanGrow ( _
    value As Boolean _
)
Visual C++
public:
void SetCanGrow(
    bool value
)

Parameters

value
Type: System..::.Boolean
Flag value.

See Also

SelectedReportComponents Class
FastReport Namespace


SetCanShrink Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetCanShrink Method
SelectedReportComponents Class See Also Send Feedback
Sets the CanShrink flag for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetCanShrink(
    bool value
)
Visual Basic (Declaration)
Public Sub SetCanShrink ( _
    value As Boolean _
)
Visual C++
public:
void SetCanShrink(
    bool value
)

Parameters

value
Type: System..::.Boolean
Flag value.

See Also

SelectedReportComponents Class
FastReport Namespace


SetColor Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetColor Method
SelectedReportComponents Class See Also Send Feedback
Sets the solid fill color for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetColor(
    Color color
)
Visual Basic (Declaration)
Public Sub SetColor ( _
    color As Color _
)
Visual C++
public:
void SetColor(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Fill color.

See Also

SelectedReportComponents Class
FastReport Namespace


SetFill Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetFill Method
SelectedReportComponents Class See Also Send Feedback
Sets the fill for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetFill(
    FillBase fill
)
Visual Basic (Declaration)
Public Sub SetFill ( _
    fill As FillBase _
)
Visual C++
public:
void SetFill(
    FillBase^ fill
)

Parameters

fill
Type: FastReport..::.FillBase
Fill.

See Also

SelectedReportComponents Class
FastReport Namespace


SetGrowToBottom Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetGrowToBottom Method
SelectedReportComponents Class See Also Send Feedback
Sets the GrowToBottom flag for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetGrowToBottom(
    bool value
)
Visual Basic (Declaration)
Public Sub SetGrowToBottom ( _
    value As Boolean _
)
Visual C++
public:
void SetGrowToBottom(
    bool value
)

Parameters

value
Type: System..::.Boolean
Flag value.

See Also

SelectedReportComponents Class
FastReport Namespace


SetHyperlink Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetHyperlink Method
SelectedReportComponents Class See Also Send Feedback
Sets the hyperlink for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetHyperlink(
    Hyperlink hyperlink,
    bool modifyAppearance,
    bool setModified
)
Visual Basic (Declaration)
Public Sub SetHyperlink ( _
    hyperlink As Hyperlink, _
    modifyAppearance As Boolean, _
    setModified As Boolean _
)
Visual C++
public:
void SetHyperlink(
    Hyperlink^ hyperlink,
    bool modifyAppearance,
    bool setModified
)

Parameters

hyperlink
Type: FastReport..::.Hyperlink
Hyperlink.
modifyAppearance
Type: System..::.Boolean
Indicates whether to modify the object's appearance.
setModified
Type: System..::.Boolean
Indicates whether it is necessary to change designer's modified state.

See Also

SelectedReportComponents Class
FastReport Namespace


SetLineColor Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetLineColor Method
SelectedReportComponents Class See Also Send Feedback
Sets the border color for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetLineColor(
    Color color
)
Visual Basic (Declaration)
Public Sub SetLineColor ( _
    color As Color _
)
Visual C++
public:
void SetLineColor(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Border color.

See Also

SelectedReportComponents Class
FastReport Namespace


SetLineStyle Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetLineStyle Method
SelectedReportComponents Class See Also Send Feedback
Sets the border style for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetLineStyle(
    LineStyle style
)
Visual Basic (Declaration)
Public Sub SetLineStyle ( _
    style As LineStyle _
)
Visual C++
public:
void SetLineStyle(
    LineStyle style
)

Parameters

style
Type: FastReport..::.LineStyle
Border style.

See Also

SelectedReportComponents Class
FastReport Namespace


SetStyle Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetStyle Method
SelectedReportComponents Class See Also Send Feedback
Sets the style for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetStyle(
    string style
)
Visual Basic (Declaration)
Public Sub SetStyle ( _
    style As String _
)
Visual C++
public:
void SetStyle(
    String^ style
)

Parameters

style
Type: System..::.String
Style name.

See Also

SelectedReportComponents Class
FastReport Namespace


SetWidth Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SetWidth Method
SelectedReportComponents Class See Also Send Feedback
Sets the border width for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetWidth(
    float width
)
Visual Basic (Declaration)
Public Sub SetWidth ( _
    width As Single _
)
Visual C++
public:
void SetWidth(
    float width
)

Parameters

width
Type: System..::.Single
Border width.

See Also

SelectedReportComponents Class
FastReport Namespace


ToggleLine Method

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.ToggleLine Method
SelectedReportComponents Class See Also Send Feedback
Toggles the specified border line for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ToggleLine(
    BorderLines line,
    bool toggle
)
Visual Basic (Declaration)
Public Sub ToggleLine ( _
    line As BorderLines, _
    toggle As Boolean _
)
Visual C++
public:
void ToggleLine(
    BorderLines line,
    bool toggle
)

Parameters

line
Type: FastReport..::.BorderLines
Border line.
toggle
Type: System..::.Boolean
Toggle value.

See Also

SelectedReportComponents Class
FastReport Namespace


SelectedReportComponents Properties

[image] [image]

FastReport.Net Class Reference
SelectedReportComponents Properties
SelectedReportComponents Class See Also Send Feedback

The SelectedReportComponents type exposes the following members.

Properties

Name | Description
BorderEnabled | Gets a value indicating whether the border operations are enabled.
Count | Gets the number of selected objects.
Enabled | Gets a value indicating whether the operations are enabled.
FillEnabled | Gets a value indicating whether the fill operations are enabled.
First | Gets the first selected object.
SimpleBorder | Gets a value indicating whether the object with simple border is selected.

See Also

SelectedReportComponents Class
FastReport Namespace


BorderEnabled Property

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.BorderEnabled Property
SelectedReportComponents Class See Also Send Feedback
Gets a value indicating whether the border operations are enabled.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool BorderEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property BorderEnabled As Boolean
Visual C++
public:
property bool BorderEnabled {
    bool get ();
}

See Also

SelectedReportComponents Class
FastReport Namespace


Count Property

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.Count Property
SelectedReportComponents Class See Also Send Feedback
Gets the number of selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

SelectedReportComponents Class
FastReport Namespace


Enabled Property

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.Enabled Property
SelectedReportComponents Class See Also Send Feedback
Gets a value indicating whether the operations are enabled.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

SelectedReportComponents Class
FastReport Namespace


FillEnabled Property

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.FillEnabled Property
SelectedReportComponents Class See Also Send Feedback
Gets a value indicating whether the fill operations are enabled.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FillEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillEnabled As Boolean
Visual C++
public:
property bool FillEnabled {
    bool get ();
}

See Also

SelectedReportComponents Class
FastReport Namespace


First Property

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.First Property
SelectedReportComponents Class See Also Send Feedback
Gets the first selected object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentBase First { get; }
Visual Basic (Declaration)
Public ReadOnly Property First As ReportComponentBase
Visual C++
public:
property ReportComponentBase^ First {
    ReportComponentBase^ get ();
}

See Also

SelectedReportComponents Class
FastReport Namespace


SimpleBorder Property

[image]

FastReport.Net Class Reference
SelectedReportComponents..::.SimpleBorder Property
SelectedReportComponents Class See Also Send Feedback
Gets a value indicating whether the object with simple border is selected.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SimpleBorder { get; }
Visual Basic (Declaration)
Public ReadOnly Property SimpleBorder As Boolean
Visual C++
public:
property bool SimpleBorder {
    bool get ();
}

Remarks

When the object has a simple border, you cannot change individual border lines. Example of such an object is the "Shape" and "Line" objects.

See Also

SelectedReportComponents Class
FastReport Namespace


SelectedTextObjects Class

[image]

FastReport.Net Class Reference
SelectedTextObjects Class
Members See Also Send Feedback
Holds the list of TextObject objects currently selected in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectedTextObjects
Visual Basic (Declaration)
Public Class SelectedTextObjects
Visual C++
public ref class SelectedTextObjects

Remarks

This class is used by the "Text" toolbar. Use methods of this class to perform some operations on the selected objects.

Note: after calling any method in this class, call the Designer.SetModified method to reflect changes.

Note: this list contains only objects of TextObject type. If you want to access all selected objects, use the SelectedObjects property.

Inheritance Hierarchy

System..::.Object
FastReport..::.SelectedTextObjects

See Also

SelectedTextObjects Members
FastReport Namespace


SelectedTextObjects Members

[image] [image]

FastReport.Net Class Reference
SelectedTextObjects Members
SelectedTextObjects Class Methods Properties See Also Send Feedback

The SelectedTextObjects type exposes the following members.

Methods

Name | Description
ClearText | Clears the text of the selected objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeHighlightEditor | Invokes the highlight editor for the selected objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetAngle | Sets the angle for the selected objects.
SetAutoWidth | Sets the AutoWidth property value for the selected objects.
SetConditions | Sets the highlight conditions for the selected objects.
SetFontName | Sets the font name for the selected objects.
SetFontSize | Sets the font size for the selected objects.
SetHAlign | Sets the horizontal text alignment for tthe selected objects.
SetTextColor | Sets the text color for the selected objects.
SetVAlign | Sets the vertical text alignment for tthe selected objects.
SetWordWrap | Sets the WordWrap property value for the selected objects.
ToggleFontStyle | Toggles the specified font style for the selected objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of selected objects.
Enabled | Gets a value indicating whether the operations are enabled.
First | Gets the first selected object.

See Also

SelectedTextObjects Class
FastReport Namespace


SelectedTextObjects Methods

[image] [image]

FastReport.Net Class Reference
SelectedTextObjects Methods
SelectedTextObjects Class See Also Send Feedback

The SelectedTextObjects type exposes the following members.

Methods

Name | Description
ClearText | Clears the text of the selected objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeHighlightEditor | Invokes the highlight editor for the selected objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetAngle | Sets the angle for the selected objects.
SetAutoWidth | Sets the AutoWidth property value for the selected objects.
SetConditions | Sets the highlight conditions for the selected objects.
SetFontName | Sets the font name for the selected objects.
SetFontSize | Sets the font size for the selected objects.
SetHAlign | Sets the horizontal text alignment for tthe selected objects.
SetTextColor | Sets the text color for the selected objects.
SetVAlign | Sets the vertical text alignment for tthe selected objects.
SetWordWrap | Sets the WordWrap property value for the selected objects.
ToggleFontStyle | Toggles the specified font style for the selected objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedTextObjects Class
FastReport Namespace


ClearText Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.ClearText Method
SelectedTextObjects Class See Also Send Feedback
Clears the text of the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ClearText()
Visual Basic (Declaration)
Public Sub ClearText
Visual C++
public:
void ClearText()

See Also

SelectedTextObjects Class
FastReport Namespace


InvokeHighlightEditor Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.InvokeHighlightEditor Method
SelectedTextObjects Class See Also Send Feedback
Invokes the highlight editor for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeHighlightEditor()
Visual Basic (Declaration)
Public Function InvokeHighlightEditor As Boolean
Visual C++
public:
bool InvokeHighlightEditor()

Return Value

true if editor was closed with the OK button.

See Also

SelectedTextObjects Class
FastReport Namespace


SetAngle Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetAngle Method
SelectedTextObjects Class See Also Send Feedback
Sets the angle for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetAngle(
    int angle
)
Visual Basic (Declaration)
Public Sub SetAngle ( _
    angle As Integer _
)
Visual C++
public:
void SetAngle(
    int angle
)

Parameters

angle
Type: System..::.Int32
Angle to set.

See Also

SelectedTextObjects Class
FastReport Namespace


SetAutoWidth Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetAutoWidth Method
SelectedTextObjects Class See Also Send Feedback
Sets the AutoWidth property value for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetAutoWidth(
    bool value
)
Visual Basic (Declaration)
Public Sub SetAutoWidth ( _
    value As Boolean _
)
Visual C++
public:
void SetAutoWidth(
    bool value
)

Parameters

value
Type: System..::.Boolean
Value to set.

See Also

SelectedTextObjects Class
FastReport Namespace


SetConditions Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetConditions Method
SelectedTextObjects Class See Also Send Feedback
Sets the highlight conditions for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetConditions(
    ConditionCollection value
)
Visual Basic (Declaration)
Public Sub SetConditions ( _
    value As ConditionCollection _
)
Visual C++
public:
void SetConditions(
    ConditionCollection^ value
)

Parameters

value
Type: FastReport..::.ConditionCollection
Highlight conditions.

See Also

SelectedTextObjects Class
FastReport Namespace


SetFontName Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetFontName Method
SelectedTextObjects Class See Also Send Feedback
Sets the font name for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetFontName(
    string name
)
Visual Basic (Declaration)
Public Sub SetFontName ( _
    name As String _
)
Visual C++
public:
void SetFontName(
    String^ name
)

Parameters

name
Type: System..::.String
Font name.

See Also

SelectedTextObjects Class
FastReport Namespace


SetFontSize Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetFontSize Method
SelectedTextObjects Class See Also Send Feedback
Sets the font size for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetFontSize(
    float size
)
Visual Basic (Declaration)
Public Sub SetFontSize ( _
    size As Single _
)
Visual C++
public:
void SetFontSize(
    float size
)

Parameters

size
Type: System..::.Single
Font size.

See Also

SelectedTextObjects Class
FastReport Namespace


SetHAlign Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetHAlign Method
SelectedTextObjects Class See Also Send Feedback
Sets the horizontal text alignment for tthe selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetHAlign(
    HorzAlign align
)
Visual Basic (Declaration)
Public Sub SetHAlign ( _
    align As HorzAlign _
)
Visual C++
public:
void SetHAlign(
    HorzAlign align
)

Parameters

align
Type: FastReport..::.HorzAlign
Alignment to set.

See Also

SelectedTextObjects Class
FastReport Namespace


SetTextColor Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetTextColor Method
SelectedTextObjects Class See Also Send Feedback
Sets the text color for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetTextColor(
    Color color
)
Visual Basic (Declaration)
Public Sub SetTextColor ( _
    color As Color _
)
Visual C++
public:
void SetTextColor(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Text color.

See Also

SelectedTextObjects Class
FastReport Namespace


SetVAlign Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetVAlign Method
SelectedTextObjects Class See Also Send Feedback
Sets the vertical text alignment for tthe selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetVAlign(
    VertAlign align
)
Visual Basic (Declaration)
Public Sub SetVAlign ( _
    align As VertAlign _
)
Visual C++
public:
void SetVAlign(
    VertAlign align
)

Parameters

align
Type: FastReport..::.VertAlign
Alignment to set.

See Also

SelectedTextObjects Class
FastReport Namespace


SetWordWrap Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.SetWordWrap Method
SelectedTextObjects Class See Also Send Feedback
Sets the WordWrap property value for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetWordWrap(
    bool value
)
Visual Basic (Declaration)
Public Sub SetWordWrap ( _
    value As Boolean _
)
Visual C++
public:
void SetWordWrap(
    bool value
)

Parameters

value
Type: System..::.Boolean
Value to set.

See Also

SelectedTextObjects Class
FastReport Namespace


ToggleFontStyle Method

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.ToggleFontStyle Method
SelectedTextObjects Class See Also Send Feedback
Toggles the specified font style for the selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ToggleFontStyle(
    FontStyle style,
    bool toggle
)
Visual Basic (Declaration)
Public Sub ToggleFontStyle ( _
    style As FontStyle, _
    toggle As Boolean _
)
Visual C++
public:
void ToggleFontStyle(
    FontStyle style,
    bool toggle
)

Parameters

style
Type: System.Drawing..::.FontStyle
Font style.
toggle
Type: System..::.Boolean
Toggle value.

See Also

SelectedTextObjects Class
FastReport Namespace


SelectedTextObjects Properties

[image] [image]

FastReport.Net Class Reference
SelectedTextObjects Properties
SelectedTextObjects Class See Also Send Feedback

The SelectedTextObjects type exposes the following members.

Properties

Name | Description
Count | Gets the number of selected objects.
Enabled | Gets a value indicating whether the operations are enabled.
First | Gets the first selected object.

See Also

SelectedTextObjects Class
FastReport Namespace


Count Property

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.Count Property
SelectedTextObjects Class See Also Send Feedback
Gets the number of selected objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

SelectedTextObjects Class
FastReport Namespace


Enabled Property

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.Enabled Property
SelectedTextObjects Class See Also Send Feedback
Gets a value indicating whether the operations are enabled.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

SelectedTextObjects Class
FastReport Namespace


First Property

[image]

FastReport.Net Class Reference
SelectedTextObjects..::.First Property
SelectedTextObjects Class See Also Send Feedback
Gets the first selected object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextObject First { get; }
Visual Basic (Declaration)
Public ReadOnly Property First As TextObject
Visual C++
public:
property TextObject^ First {
    TextObject^ get ();
}

See Also

SelectedTextObjects Class
FastReport Namespace


ShapeKind Enumeration

[image]

FastReport.Net Class Reference
ShapeKind Enumeration
See Also Send Feedback
Specifies a kind of the shape.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ShapeKind
Visual Basic (Declaration)
Public Enumeration ShapeKind
Visual C++
public enum class ShapeKind

Members

Member name | Description
Rectangle | Specifies a rectangle shape.
RoundRectangle | Specifies a round rectangle shape.
Ellipse | Specifies an ellipse shape.
Triangle | Specifies a triangle shape.
Diamond | Specifies a diamond shape.

See Also

FastReport Namespace


ShapeObject Class

[image]

FastReport.Net Class Reference
ShapeObject Class
Members See Also Send Feedback
Represents a shape object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapeObject : ReportComponentBase,
    IHasEditor
Visual Basic (Declaration)
Public Class ShapeObject _
    Inherits ReportComponentBase _
    Implements IHasEditor
Visual C++
public ref class ShapeObject : public ReportComponentBase,
    IHasEditor

Remarks

Use the ShapeKind property to specify a shape. To set the width, style and color of the shape's border, use the Border.Width, Border.Style and Border.Color properties.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.ShapeObject

See Also

ShapeObject Members
FastReport Namespace


ShapeObject Members

[image] [image]

FastReport.Net Class Reference
ShapeObject Members
ShapeObject Class Constructors Methods Properties Events See Also Send Feedback

The ShapeObject type exposes the following members.

Constructors

Name | Description
ShapeObject | Initializes a new instance of the ShapeObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
Curve | Gets or sets a shape curvature if ShapeKind is RoundRectangle.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Shape | Gets or sets a shape kind.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ShapeObject Class
FastReport Namespace


ShapeObject Constructor

[image]

FastReport.Net Class Reference
ShapeObject Constructor
ShapeObject Class See Also Send Feedback
Initializes a new instance of the ShapeObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeObject()

See Also

ShapeObject Class
FastReport Namespace


ShapeObject Methods

[image] [image]

FastReport.Net Class Reference
ShapeObject Methods
ShapeObject Class See Also Send Feedback

The ShapeObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ShapeObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ShapeObject..::.Assign Method
ShapeObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ShapeObject Class
FastReport Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
ShapeObject..::.Dispose Method
ShapeObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ShapeObject Class
ShapeObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
ShapeObject..::.Draw Method
ShapeObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

ShapeObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ShapeObject..::.DrawMarkers Method
ShapeObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ShapeObject Class
ShapeObject Members
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
ShapeObject..::.InvokeEditor Method
ShapeObject Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

ShapeObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ShapeObject..::.MemberwiseClone Method
ShapeObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ShapeObject Class
ShapeObject Members
FastReport Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
ShapeObject..::.OnBeforeInsert Method
ShapeObject Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

ShapeObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ShapeObject..::.Serialize Method
ShapeObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ShapeObject Class
FastReport Namespace


ShapeObject Properties

[image] [image]

FastReport.Net Class Reference
ShapeObject Properties
ShapeObject Class See Also Send Feedback

The ShapeObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
Curve | Gets or sets a shape curvature if ShapeKind is RoundRectangle.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Shape | Gets or sets a shape kind.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ShapeObject Class
FastReport Namespace


Curve Property

[image]

FastReport.Net Class Reference
ShapeObject..::.Curve Property
ShapeObject Class See Also Send Feedback
Gets or sets a shape curvature if ShapeKind is RoundRectangle.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Curve { get; set; }
Visual Basic (Declaration)
Public Property Curve As Single
Visual C++
public:
property float Curve {
    float get ();
    void set (float value);
}

Remarks

0 value means automatic curvature.

See Also

ShapeObject Class
FastReport Namespace


Shape Property

[image]

FastReport.Net Class Reference
ShapeObject..::.Shape Property
ShapeObject Class See Also Send Feedback
Gets or sets a shape kind.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeKind Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As ShapeKind
Visual C++
public:
property ShapeKind Shape {
    ShapeKind get ();
    void set (ShapeKind value);
}

See Also

ShapeObject Class
FastReport Namespace


ShapeObject Events

[image] [image]

FastReport.Net Class Reference
ShapeObject Events
ShapeObject Class See Also Send Feedback

The ShapeObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ShapeObject Class
FastReport Namespace


ShiftMode Enumeration

[image]

FastReport.Net Class Reference
ShiftMode Enumeration
See Also Send Feedback
The automatic shift mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ShiftMode
Visual Basic (Declaration)
Public Enumeration ShiftMode
Visual C++
public enum class ShiftMode

Members

Member name | Description
Never | Do not shift the object.
Always | Shift the object up or down if any object above it shrinks or grows.
WhenOverlapped | Shift the object up or down if any object above it shrinks or grows. Objects must have overlapped x-coordinates.

See Also

FastReport Namespace


SmartTagBase Class

[image]

FastReport.Net Class Reference
SmartTagBase Class
Members See Also Send Feedback
The base class for smart tags.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SmartTagBase
Visual Basic (Declaration)
Public Class SmartTagBase
Visual C++
public ref class SmartTagBase

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

Smart tag is internally a ContextMenuStrip.

Inheritance Hierarchy

System..::.Object
FastReport..::.SmartTagBase
FastReport..::.DataColumnSmartTag
FastReport..::.DataSourceSmartTag

See Also

SmartTagBase Members
FastReport Namespace


SmartTagBase Members

[image] [image]

FastReport.Net Class Reference
SmartTagBase Members
SmartTagBase Class Constructors Methods Properties See Also Send Feedback

The SmartTagBase type exposes the following members.

Constructors

Name | Description
SmartTagBase | Initializes a new instance of the SmartTagBase class with default settings.

Methods

Name | Description
CreateItems | Creates the smart tag menu items.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ItemClicked | Called when the menu item is clicked.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Show | Displays a smart tag at the specified screen location.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Designer | Gets the report designer.
Menu | Gets the underlying context menu.
Obj | Gets the report object that invokes this smart tag.

See Also

SmartTagBase Class
FastReport Namespace


SmartTagBase Constructor

[image]

FastReport.Net Class Reference
SmartTagBase Constructor
SmartTagBase Class See Also Send Feedback
Initializes a new instance of the SmartTagBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SmartTagBase(
    ComponentBase obj
)
Visual Basic (Declaration)
Public Sub New ( _
    obj As ComponentBase _
)
Visual C++
public:
SmartTagBase(
    ComponentBase^ obj
)

Parameters

obj
Type: FastReport..::.ComponentBase
Report object that owns this smart tag.

See Also

SmartTagBase Class
FastReport Namespace


SmartTagBase Methods

[image] [image]

FastReport.Net Class Reference
SmartTagBase Methods
SmartTagBase Class See Also Send Feedback

The SmartTagBase type exposes the following members.

Methods

Name | Description
CreateItems | Creates the smart tag menu items.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ItemClicked | Called when the menu item is clicked.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Show | Displays a smart tag at the specified screen location.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmartTagBase Class
FastReport Namespace


CreateItems Method

[image]

FastReport.Net Class Reference
SmartTagBase..::.CreateItems Method
SmartTagBase Class See Also Send Feedback
Creates the smart tag menu items.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void CreateItems()
Visual Basic (Declaration)
Protected Overridable Sub CreateItems
Visual C++
protected:
virtual void CreateItems()

Remarks

Override this method to create the smart tag menu.

See Also

SmartTagBase Class
FastReport Namespace


ItemClicked Method

[image]

FastReport.Net Class Reference
SmartTagBase..::.ItemClicked Method
SmartTagBase Class See Also Send Feedback
Called when the menu item is clicked.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void ItemClicked()
Visual Basic (Declaration)
Protected Overridable Sub ItemClicked
Visual C++
protected:
virtual void ItemClicked()

Remarks

Override this method to define a reaction on the menu item click.

See Also

SmartTagBase Class
FastReport Namespace


Show Method

[image]

FastReport.Net Class Reference
SmartTagBase..::.Show Method
SmartTagBase Class See Also Send Feedback
Displays a smart tag at the specified screen location.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    Point pt
)
Visual Basic (Declaration)
Public Sub Show ( _
    pt As Point _
)
Visual C++
public:
void Show(
    Point pt
)

Parameters

pt
Type: System.Drawing..::.Point
Screen location.

Remarks

Do not call this method directly. It is called automatically when click on smart tag button.

See Also

SmartTagBase Class
FastReport Namespace


SmartTagBase Properties

[image] [image]

FastReport.Net Class Reference
SmartTagBase Properties
SmartTagBase Class See Also Send Feedback

The SmartTagBase type exposes the following members.

Properties

Name | Description
Designer | Gets the report designer.
Menu | Gets the underlying context menu.
Obj | Gets the report object that invokes this smart tag.

See Also

SmartTagBase Class
FastReport Namespace


Designer Property

[image]

FastReport.Net Class Reference
SmartTagBase..::.Designer Property
SmartTagBase Class See Also Send Feedback
Gets the report designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
}

See Also

SmartTagBase Class
FastReport Namespace


Menu Property

[image]

FastReport.Net Class Reference
SmartTagBase..::.Menu Property
SmartTagBase Class See Also Send Feedback
Gets the underlying context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ContextMenuStrip Menu { get; }
Visual Basic (Declaration)
Public ReadOnly Property Menu As ContextMenuStrip
Visual C++
public:
property ContextMenuStrip^ Menu {
    ContextMenuStrip^ get ();
}

See Also

SmartTagBase Class
FastReport Namespace


Obj Property

[image]

FastReport.Net Class Reference
SmartTagBase..::.Obj Property
SmartTagBase Class See Also Send Feedback
Gets the report object that invokes this smart tag.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentBase Obj { get; }
Visual Basic (Declaration)
Public ReadOnly Property Obj As ComponentBase
Visual C++
public:
property ComponentBase^ Obj {
    ComponentBase^ get ();
}

See Also

SmartTagBase Class
FastReport Namespace


SolidFill Class

[image]

FastReport.Net Class Reference
SolidFill Class
Members See Also Send Feedback
Class represents the solid fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SolidFill : FillBase
Visual Basic (Declaration)
Public Class SolidFill _
    Inherits FillBase
Visual C++
public ref class SolidFill : public FillBase

Inheritance Hierarchy

System..::.Object
FastReport..::.FillBase
FastReport..::.SolidFill

See Also

SolidFill Members
FastReport Namespace


SolidFill Members

[image] [image]

FastReport.Net Class Reference
SolidFill Members
SolidFill Class Constructors Methods Properties See Also Send Feedback

The SolidFill type exposes the following members.

Constructors

Name | Description
SolidFill | Overloaded.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Overrides FillBase..::.Draw(FRPaintEventArgs, RectangleF).)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the fill color.

See Also

SolidFill Class
FastReport Namespace


SolidFill Constructor

[image] [image]

FastReport.Net Class Reference
SolidFill Constructor
SolidFill Class See Also Send Feedback

Overload List

Name | Description
SolidFill()()() | Initializes the SolidFill class with Transparent color.
SolidFill(Color) | Initializes the SolidFill class with specified color.

See Also

SolidFill Class
SolidFill Members
FastReport Namespace


SolidFill Constructor

[image]

FastReport.Net Class Reference
SolidFill Constructor
SolidFill Class See Also Send Feedback
Initializes the SolidFill class with Transparent color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SolidFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidFill()

See Also

SolidFill Class
SolidFill Overload
FastReport Namespace


SolidFill Constructor (Color)

[image]

FastReport.Net Class Reference
SolidFill Constructor (Color)
SolidFill Class See Also Send Feedback
Initializes the SolidFill class with specified color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SolidFill(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
SolidFill(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color

See Also

SolidFill Class
SolidFill Overload
FastReport Namespace


SolidFill Methods

[image] [image]

FastReport.Net Class Reference
SolidFill Methods
SolidFill Class See Also Send Feedback

The SolidFill type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this fill. (Overrides FillBase..::.Clone()()().)
CreateBrush | Creates the GDI+ Brush object. (Overrides FillBase..::.CreateBrush(RectangleF).)
Draw | Fills the specified rectangle. (Overrides FillBase..::.Draw(FRPaintEventArgs, RectangleF).)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the fill. (Overrides FillBase..::.Serialize(FRWriter, String, FillBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidFill Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
SolidFill..::.Clone Method
SolidFill Class See Also Send Feedback
Creates exact copy of this fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FillBase
Visual C++
public:
virtual FillBase^ Clone() override

Return Value

Copy of this object.

See Also

SolidFill Class
FastReport Namespace


CreateBrush Method

[image]

FastReport.Net Class Reference
SolidFill..::.CreateBrush Method
SolidFill Class See Also Send Feedback
Creates the GDI+ Brush object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Brush CreateBrush(
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As RectangleF _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    RectangleF rect
) override

Parameters

rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

Return Value

Brush object.

See Also

SolidFill Class
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
SolidFill..::.Draw Method
SolidFill Class See Also Send Feedback
Fills the specified rectangle.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e,
    RectangleF rect
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs, _
    rect As RectangleF _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e,
    RectangleF rect
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
rect
Type: System.Drawing..::.RectangleF
Drawing rectangle.

See Also

SolidFill Class
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
SolidFill..::.Equals Method
SolidFill Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

SolidFill Class
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
SolidFill..::.GetHashCode Method
SolidFill Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

SolidFill Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
SolidFill..::.Serialize Method
SolidFill Class See Also Send Feedback
Serializes the fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer,
    string prefix,
    FillBase fill
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    fill As FillBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    FillBase^ fill
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Name of the fill property.
fill
Type: FastReport..::.FillBase
Fill object to compare with.

Remarks

This method is for internal use only.

See Also

SolidFill Class
FastReport Namespace


SolidFill Properties

[image] [image]

FastReport.Net Class Reference
SolidFill Properties
SolidFill Class See Also Send Feedback

The SolidFill type exposes the following members.

Properties

Name | Description
Color | Gets or sets the fill color.

See Also

SolidFill Class
FastReport Namespace


Color Property

[image]

FastReport.Net Class Reference
SolidFill..::.Color Property
SolidFill Class See Also Send Feedback
Gets or sets the fill color.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

SolidFill Class
FastReport Namespace


Sort Class

[image]

FastReport.Net Class Reference
Sort Class
Members See Also Send Feedback
Represents a sort condition used in the Sort.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Sort : IFRSerializable
Visual Basic (Declaration)
Public Class Sort _
    Implements IFRSerializable
Visual C++
public ref class Sort : IFRSerializable

Inheritance Hierarchy

System..::.Object
FastReport..::.Sort

See Also

Sort Members
FastReport Namespace


Sort Members

[image] [image]

FastReport.Net Class Reference
Sort Members
Sort Class Constructors Methods Properties See Also Send Feedback

The Sort type exposes the following members.

Constructors

Name | Description
Sort | Overloaded.

Methods

Name | Description
Deserialize | Deserializes the class.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the class.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Descending | Gets or sets a value indicating that sort must be performed in descending order.
Expression | Gets or sets an expression used to sort data band rows.

See Also

Sort Class
FastReport Namespace


Sort Constructor

[image] [image]

FastReport.Net Class Reference
Sort Constructor
Sort Class See Also Send Feedback

Overload List

Name | Description
Sort()()() | Initializes a new instance of the Sort class with default settings.
Sort(String) | Initializes a new instance of the Sort class with specified expression.
Sort(String, Boolean) | Initializes a new instance of the Sort class with specified expression and sort order.

See Also

Sort Class
Sort Members
FastReport Namespace


Sort Constructor

[image]

FastReport.Net Class Reference
Sort Constructor
Sort Class See Also Send Feedback
Initializes a new instance of the Sort class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Sort()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sort()

See Also

Sort Class
Sort Overload
FastReport Namespace


Sort Constructor (String)

[image]

FastReport.Net Class Reference
Sort Constructor (String)
Sort Class See Also Send Feedback
Initializes a new instance of the Sort class with specified expression.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Sort(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)
Visual C++
public:
Sort(
    String^ expression
)

Parameters

expression
Type: System..::.String

See Also

Sort Class
Sort Overload
FastReport Namespace


Sort Constructor (String, Boolean)

[image]

FastReport.Net Class Reference
Sort Constructor (String, Boolean)
Sort Class See Also Send Feedback
Initializes a new instance of the Sort class with specified expression and sort order.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Sort(
    string expression,
    bool descending
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    descending As Boolean _
)
Visual C++
public:
Sort(
    String^ expression,
    bool descending
)

Parameters

expression
Type: System..::.String
descending
Type: System..::.Boolean

See Also

Sort Class
Sort Overload
FastReport Namespace


Sort Methods

[image] [image]

FastReport.Net Class Reference
Sort Methods
Sort Class See Also Send Feedback

The Sort type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the class.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the class.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sort Class
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
Sort..::.Deserialize Method
Sort Class See Also Send Feedback
Deserializes the class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

This method is for internal use only.

See Also

Sort Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Sort..::.Serialize Method
Sort Class See Also Send Feedback
Serializes the class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

This method is for internal use only.

See Also

Sort Class
FastReport Namespace


Sort Properties

[image] [image]

FastReport.Net Class Reference
Sort Properties
Sort Class See Also Send Feedback

The Sort type exposes the following members.

Properties

Name | Description
Descending | Gets or sets a value indicating that sort must be performed in descending order.
Expression | Gets or sets an expression used to sort data band rows.

See Also

Sort Class
FastReport Namespace


Descending Property

[image]

FastReport.Net Class Reference
Sort..::.Descending Property
Sort Class See Also Send Feedback
Gets or sets a value indicating that sort must be performed in descending order.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Descending { get; set; }
Visual Basic (Declaration)
Public Property Descending As Boolean
Visual C++
public:
property bool Descending {
    bool get ();
    void set (bool value);
}

See Also

Sort Class
FastReport Namespace


Expression Property

[image]

FastReport.Net Class Reference
Sort..::.Expression Property
Sort Class See Also Send Feedback
Gets or sets an expression used to sort data band rows.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

This property can contain any valid expression.

See Also

Sort Class
FastReport Namespace


SortCollection Class

[image]

FastReport.Net Class Reference
SortCollection Class
Members See Also Send Feedback
Represents a collection of sort conditions used in the Sort.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SortCollection : CollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class SortCollection _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class SortCollection : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport..::.SortCollection

See Also

SortCollection Members
FastReport Namespace


SortCollection Members

[image] [image]

FastReport.Net Class Reference
SortCollection Members
SortCollection Class Constructors Methods Properties See Also Send Feedback

The SortCollection type exposes the following members.

Constructors

Name | Description
SortCollection | Initializes a new instance of the SortCollection class

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Assign | Assigns values from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SortCollection Class
FastReport Namespace


SortCollection Constructor

[image]

FastReport.Net Class Reference
SortCollection Constructor
SortCollection Class See Also Send Feedback
Initializes a new instance of the SortCollection class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SortCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SortCollection()

See Also

SortCollection Class
FastReport Namespace


SortCollection Methods

[image] [image]

FastReport.Net Class Reference
SortCollection Methods
SortCollection Class See Also Send Feedback

The SortCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Assign | Assigns values from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortCollection Class
FastReport Namespace


Add Method

[image]

FastReport.Net Class Reference
SortCollection..::.Add Method
SortCollection Class See Also Send Feedback
Adds an object to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    Sort value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Sort _
) As Integer
Visual C++
public:
int Add(
    Sort^ value
)

Parameters

value
Type: FastReport..::.Sort
Object to add.

Return Value

Index of the added object.

See Also

SortCollection Class
FastReport Namespace


AddRange Method

[image]

FastReport.Net Class Reference
SortCollection..::.AddRange Method
SortCollection Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    Sort[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As Sort() _
)
Visual C++
public:
void AddRange(
    array<Sort^>^ range
)

Parameters

range
Type: array< FastReport..::.Sort >[]()[]

See Also

SortCollection Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
SortCollection..::.Assign Method
SortCollection Class See Also Send Feedback
Assigns values from another collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    SortCollection source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As SortCollection _
)
Visual C++
public:
void Assign(
    SortCollection^ source
)

Parameters

source
Type: FastReport..::.SortCollection
Collection to assign from.

See Also

SortCollection Class
FastReport Namespace


Contains Method

[image]

FastReport.Net Class Reference
SortCollection..::.Contains Method
SortCollection Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    Sort value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Sort _
) As Boolean
Visual C++
public:
bool Contains(
    Sort^ value
)

Parameters

value
Type: FastReport..::.Sort
The object to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

SortCollection Class
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
SortCollection..::.Deserialize Method
SortCollection Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

SortCollection Class
FastReport Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
SortCollection..::.IndexOf Method
SortCollection Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    Sort value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Sort _
) As Integer
Visual C++
public:
int IndexOf(
    Sort^ value
)

Parameters

value
Type: FastReport..::.Sort
The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

SortCollection Class
FastReport Namespace


Insert Method

[image]

FastReport.Net Class Reference
SortCollection..::.Insert Method
SortCollection Class See Also Send Feedback
Inserts an object into this collection at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    Sort value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Sort _
)
Visual C++
public:
void Insert(
    int index,
    Sort^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport..::.Sort
The object to insert.

See Also

SortCollection Class
FastReport Namespace


Remove Method

[image]

FastReport.Net Class Reference
SortCollection..::.Remove Method
SortCollection Class See Also Send Feedback
Removes the specified object from the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    Sort value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Sort _
)
Visual C++
public:
void Remove(
    Sort^ value
)

Parameters

value
Type: FastReport..::.Sort
Object to remove.

See Also

SortCollection Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
SortCollection..::.Serialize Method
SortCollection Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

SortCollection Class
FastReport Namespace


SortCollection Properties

[image] [image]

FastReport.Net Class Reference
SortCollection Properties
SortCollection Class See Also Send Feedback

The SortCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SortCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
SortCollection..::.Item Property
SortCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Sort this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Sort
Visual C++
public:
property Sort^ default[int index] {
    Sort^ get (int index);
    void set (int index, Sort^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

SortCollection Class
FastReport Namespace


SortOrder Enumeration

[image]

FastReport.Net Class Reference
SortOrder Enumeration
See Also Send Feedback
Specifies a sort order.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum SortOrder
Visual Basic (Declaration)
Public Enumeration SortOrder
Visual C++
public enum class SortOrder

Members

Member name | Description
None | Specifies no sort (natural order).
Ascending | Specifies an ascending sort order.
Descending | Specifies a descending sort order.

Remarks

This enumeration is used in the group header and in the "Matrix" object.

See Also

FastReport Namespace


Style Class

[image]

FastReport.Net Class Reference
Style Class
Members See Also Send Feedback
Represents a style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Style : StyleBase
Visual Basic (Declaration)
Public Class Style _
    Inherits StyleBase
Visual C++
public ref class Style : public StyleBase

Remarks

Style class holds border, fill, text fill and font settings. It can be applied to any report object of ReportComponentBase type.

The Report object holds list of styles in its Styles property. Each style has unique name. To apply a style to the report component, set its Style property to the style name.

Inheritance Hierarchy

System..::.Object
FastReport..::.StyleBase
FastReport..::.Style

See Also

Style Members
FastReport Namespace


Style Members

[image] [image]

FastReport.Net Class Reference
Style Members
Style Class Constructors Methods Properties See Also Send Feedback

The Style type exposes the following members.

Constructors

Name | Description
Style | Initializes a new instance of the Style class with default settings.

Methods

Name | Description
Assign | Assigns values from another source. (Overrides StyleBase..::.Assign(StyleBase).)
Clone | Creates exact copy of this Style.
Deserialize | Deserializes the style. (Inherited from StyleBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the style. (Overrides StyleBase..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplyBorder | Gets or sets a value determines that the border must be applied. (Inherited from StyleBase.)
ApplyFill | Gets or sets a value determines that the fill must be applied. (Inherited from StyleBase.)
ApplyFont | Gets or sets a value determines that the font must be applied. (Inherited from StyleBase.)
ApplyTextFill | Gets or sets a value determines that the text fill must be applied. (Inherited from StyleBase.)
Border | Gets or sets a border. (Inherited from StyleBase.)
Fill | Gets or sets a fill. (Inherited from StyleBase.)
Font | Gets or sets a font. (Inherited from StyleBase.)
Name | Gets or sets a name of the style.
TextFill | Gets or sets a text fill. (Inherited from StyleBase.)

See Also

Style Class
FastReport Namespace


Style Constructor

[image]

FastReport.Net Class Reference
Style Constructor
Style Class See Also Send Feedback
Initializes a new instance of the Style class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Style()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Style()

See Also

Style Class
FastReport Namespace


Style Methods

[image] [image]

FastReport.Net Class Reference
Style Methods
Style Class See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source. (Overrides StyleBase..::.Assign(StyleBase).)
Clone | Creates exact copy of this Style.
Deserialize | Deserializes the style. (Inherited from StyleBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the style. (Overrides StyleBase..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Style Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
Style..::.Assign Method
Style Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    StyleBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As StyleBase _
)
Visual C++
public:
virtual void Assign(
    StyleBase^ source
) override

Parameters

source
Type: FastReport..::.StyleBase
Source to assign from.

See Also

Style Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
Style..::.Clone Method
Style Class See Also Send Feedback
Creates exact copy of this Style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Style Clone()
Visual Basic (Declaration)
Public Function Clone As Style
Visual C++
public:
Style^ Clone()

Return Value

Copy of this style.

See Also

Style Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Style..::.Serialize Method
Style Class See Also Send Feedback
Serializes the style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

This method is for internal use only.

See Also

Style Class
FastReport Namespace


Style Properties

[image] [image]

FastReport.Net Class Reference
Style Properties
Style Class See Also Send Feedback

The Style type exposes the following members.

Properties

Name | Description
ApplyBorder | Gets or sets a value determines that the border must be applied. (Inherited from StyleBase.)
ApplyFill | Gets or sets a value determines that the fill must be applied. (Inherited from StyleBase.)
ApplyFont | Gets or sets a value determines that the font must be applied. (Inherited from StyleBase.)
ApplyTextFill | Gets or sets a value determines that the text fill must be applied. (Inherited from StyleBase.)
Border | Gets or sets a border. (Inherited from StyleBase.)
Fill | Gets or sets a fill. (Inherited from StyleBase.)
Font | Gets or sets a font. (Inherited from StyleBase.)
Name | Gets or sets a name of the style.
TextFill | Gets or sets a text fill. (Inherited from StyleBase.)

See Also

Style Class
FastReport Namespace


Name Property

[image]

FastReport.Net Class Reference
Style..::.Name Property
Style Class See Also Send Feedback
Gets or sets a name of the style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The name must be unique.

See Also

Style Class
FastReport Namespace


StyleBase Class

[image]

FastReport.Net Class Reference
StyleBase Class
Members See Also Send Feedback
Represents the base class for the report style or the highlight condition.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class StyleBase : IFRSerializable
Visual Basic (Declaration)
Public Class StyleBase _
    Implements IFRSerializable
Visual C++
public ref class StyleBase : IFRSerializable

Inheritance Hierarchy

System..::.Object
FastReport..::.StyleBase
FastReport..::.HighlightCondition
FastReport..::.Style

See Also

StyleBase Members
FastReport Namespace


StyleBase Members

[image] [image]

FastReport.Net Class Reference
StyleBase Members
StyleBase Class Constructors Methods Properties See Also Send Feedback

The StyleBase type exposes the following members.

Constructors

Name | Description
StyleBase | Initializes a new instance of the StyleBase class with default settings.

Methods

Name | Description
Assign | Assigns values from another source.
Deserialize | Deserializes the style.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the style.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplyBorder | Gets or sets a value determines that the border must be applied.
ApplyFill | Gets or sets a value determines that the fill must be applied.
ApplyFont | Gets or sets a value determines that the font must be applied.
ApplyTextFill | Gets or sets a value determines that the text fill must be applied.
Border | Gets or sets a border.
Fill | Gets or sets a fill.
Font | Gets or sets a font.
TextFill | Gets or sets a text fill.

See Also

StyleBase Class
FastReport Namespace


StyleBase Constructor

[image]

FastReport.Net Class Reference
StyleBase Constructor
StyleBase Class See Also Send Feedback
Initializes a new instance of the StyleBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StyleBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleBase()

See Also

StyleBase Class
FastReport Namespace


StyleBase Methods

[image] [image]

FastReport.Net Class Reference
StyleBase Methods
StyleBase Class See Also Send Feedback

The StyleBase type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Deserialize | Deserializes the style.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the style.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StyleBase Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
StyleBase..::.Assign Method
StyleBase Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Assign(
    StyleBase source
)
Visual Basic (Declaration)
Public Overridable Sub Assign ( _
    source As StyleBase _
)
Visual C++
public:
virtual void Assign(
    StyleBase^ source
)

Parameters

source
Type: FastReport..::.StyleBase
Source to assign from.

See Also

StyleBase Class
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
StyleBase..::.Deserialize Method
StyleBase Class See Also Send Feedback
Deserializes the style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

This method is for internal use only.

See Also

StyleBase Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
StyleBase..::.Serialize Method
StyleBase Class See Also Send Feedback
Serializes the style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overridable Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

This method is for internal use only.

See Also

StyleBase Class
FastReport Namespace


StyleBase Properties

[image] [image]

FastReport.Net Class Reference
StyleBase Properties
StyleBase Class See Also Send Feedback

The StyleBase type exposes the following members.

Properties

Name | Description
ApplyBorder | Gets or sets a value determines that the border must be applied.
ApplyFill | Gets or sets a value determines that the fill must be applied.
ApplyFont | Gets or sets a value determines that the font must be applied.
ApplyTextFill | Gets or sets a value determines that the text fill must be applied.
Border | Gets or sets a border.
Fill | Gets or sets a fill.
Font | Gets or sets a font.
TextFill | Gets or sets a text fill.

See Also

StyleBase Class
FastReport Namespace


ApplyBorder Property

[image]

FastReport.Net Class Reference
StyleBase..::.ApplyBorder Property
StyleBase Class See Also Send Feedback
Gets or sets a value determines that the border must be applied.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ApplyBorder { get; set; }
Visual Basic (Declaration)
Public Property ApplyBorder As Boolean
Visual C++
public:
property bool ApplyBorder {
    bool get ();
    void set (bool value);
}

See Also

StyleBase Class
FastReport Namespace


ApplyFill Property

[image]

FastReport.Net Class Reference
StyleBase..::.ApplyFill Property
StyleBase Class See Also Send Feedback
Gets or sets a value determines that the fill must be applied.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ApplyFill { get; set; }
Visual Basic (Declaration)
Public Property ApplyFill As Boolean
Visual C++
public:
property bool ApplyFill {
    bool get ();
    void set (bool value);
}

See Also

StyleBase Class
FastReport Namespace


ApplyFont Property

[image]

FastReport.Net Class Reference
StyleBase..::.ApplyFont Property
StyleBase Class See Also Send Feedback
Gets or sets a value determines that the font must be applied.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ApplyFont { get; set; }
Visual Basic (Declaration)
Public Property ApplyFont As Boolean
Visual C++
public:
property bool ApplyFont {
    bool get ();
    void set (bool value);
}

See Also

StyleBase Class
FastReport Namespace


ApplyTextFill Property

[image]

FastReport.Net Class Reference
StyleBase..::.ApplyTextFill Property
StyleBase Class See Also Send Feedback
Gets or sets a value determines that the text fill must be applied.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ApplyTextFill { get; set; }
Visual Basic (Declaration)
Public Property ApplyTextFill As Boolean
Visual C++
public:
property bool ApplyTextFill {
    bool get ();
    void set (bool value);
}

See Also

StyleBase Class
FastReport Namespace


Border Property

[image]

FastReport.Net Class Reference
StyleBase..::.Border Property
StyleBase Class See Also Send Feedback
Gets or sets a border.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

StyleBase Class
FastReport Namespace


Fill Property

[image]

FastReport.Net Class Reference
StyleBase..::.Fill Property
StyleBase Class See Also Send Feedback
Gets or sets a fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As FillBase
Visual C++
public:
property FillBase^ Fill {
    FillBase^ get ();
    void set (FillBase^ value);
}

See Also

StyleBase Class
FastReport Namespace


Font Property

[image]

FastReport.Net Class Reference
StyleBase..::.Font Property
StyleBase Class See Also Send Feedback
Gets or sets a font.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

StyleBase Class
FastReport Namespace


TextFill Property

[image]

FastReport.Net Class Reference
StyleBase..::.TextFill Property
StyleBase Class See Also Send Feedback
Gets or sets a text fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillBase TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As FillBase
Visual C++
public:
property FillBase^ TextFill {
    FillBase^ get ();
    void set (FillBase^ value);
}

See Also

StyleBase Class
FastReport Namespace


StyleCollection Class

[image]

FastReport.Net Class Reference
StyleCollection Class
Members See Also Send Feedback
Represents a collection of styles used in the Styles.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class StyleCollection : CollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class StyleCollection _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class StyleCollection : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport..::.StyleCollection

See Also

StyleCollection Members
FastReport Namespace


StyleCollection Members

[image] [image]

FastReport.Net Class Reference
StyleCollection Members
StyleCollection Class Constructors Methods Properties See Also Send Feedback

The StyleCollection type exposes the following members.

Constructors

Name | Description
StyleCollection | Initializes a new instance of the StyleCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Clone | Creates exact copy of this collection.
Contains | Overloaded.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an object into this collection at the specified index.
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Save | Overloaded.
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Name | Gets or sets the name of the style.

See Also

StyleCollection Class
FastReport Namespace


StyleCollection Constructor

[image]

FastReport.Net Class Reference
StyleCollection Constructor
StyleCollection Class See Also Send Feedback
Initializes a new instance of the StyleCollection class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StyleCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleCollection()

See Also

StyleCollection Class
FastReport Namespace


StyleCollection Methods

[image] [image]

FastReport.Net Class Reference
StyleCollection Methods
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Clone | Creates exact copy of this collection.
Contains | Overloaded.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an object into this collection at the specified index.
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Save | Overloaded.
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StyleCollection Class
FastReport Namespace


Add Method

[image]

FastReport.Net Class Reference
StyleCollection..::.Add Method
StyleCollection Class See Also Send Feedback
Adds an object to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    Style value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Style _
) As Integer
Visual C++
public:
int Add(
    Style^ value
)

Parameters

value
Type: FastReport..::.Style
Object to add.

Return Value

Index of the added object.

See Also

StyleCollection Class
FastReport Namespace


AddRange Method

[image]

FastReport.Net Class Reference
StyleCollection..::.AddRange Method
StyleCollection Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    Style[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As Style() _
)
Visual C++
public:
void AddRange(
    array<Style^>^ range
)

Parameters

range
Type: array< FastReport..::.Style >[]()[]

See Also

StyleCollection Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
StyleCollection..::.Clone Method
StyleCollection Class See Also Send Feedback
Creates exact copy of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StyleCollection Clone()
Visual Basic (Declaration)
Public Function Clone As StyleCollection
Visual C++
public:
StyleCollection^ Clone()

Return Value

The copy of this collection.

See Also

StyleCollection Class
FastReport Namespace


Contains Method

[image] [image]

FastReport.Net Class Reference
StyleCollection..::.Contains Method
StyleCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Style) | Determines whether an element is in the collection.
Contains(String) | Determines whether a style with specified name is in the collection.

See Also

StyleCollection Class
StyleCollection Members
FastReport Namespace


Contains Method (Style)

[image]

FastReport.Net Class Reference
StyleCollection..::.Contains Method (Style)
StyleCollection Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    Style value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Style _
) As Boolean
Visual C++
public:
bool Contains(
    Style^ value
)

Parameters

value
Type: FastReport..::.Style
The object to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

StyleCollection Class
Contains Overload
FastReport Namespace


Contains Method (String)

[image]

FastReport.Net Class Reference
StyleCollection..::.Contains Method (String)
StyleCollection Class See Also Send Feedback
Determines whether a style with specified name is in the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    string value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ value
)

Parameters

value
Type: System..::.String
The style name to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

StyleCollection Class
Contains Overload
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
StyleCollection..::.Deserialize Method
StyleCollection Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

StyleCollection Class
FastReport Namespace


IndexOf Method

[image] [image]

FastReport.Net Class Reference
StyleCollection..::.IndexOf Method
StyleCollection Class See Also Send Feedback

Overload List

Name | Description
IndexOf(Style) | Returns the zero-based index of the first occurrence of an object.
IndexOf(String) | Returns the zero-based index of the first occurrence of a style with specified name.

See Also

StyleCollection Class
StyleCollection Members
FastReport Namespace


IndexOf Method (Style)

[image]

FastReport.Net Class Reference
StyleCollection..::.IndexOf Method (Style)
StyleCollection Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    Style value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Style _
) As Integer
Visual C++
public:
int IndexOf(
    Style^ value
)

Parameters

value
Type: FastReport..::.Style
The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

StyleCollection Class
IndexOf Overload
FastReport Namespace


IndexOf Method (String)

[image]

FastReport.Net Class Reference
StyleCollection..::.IndexOf Method (String)
StyleCollection Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a style with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    string value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As String _
) As Integer
Visual C++
public:
int IndexOf(
    String^ value
)

Parameters

value
Type: System..::.String
The name to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

StyleCollection Class
IndexOf Overload
FastReport Namespace


Insert Method

[image]

FastReport.Net Class Reference
StyleCollection..::.Insert Method
StyleCollection Class See Also Send Feedback
Inserts an object into this collection at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    Style value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Style _
)
Visual C++
public:
void Insert(
    int index,
    Style^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport..::.Style
The object to insert.

See Also

StyleCollection Class
FastReport Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
StyleCollection..::.Load Method
StyleCollection Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads the collection from a stream.
Load(String) | Loads the collection from a file.

See Also

StyleCollection Class
StyleCollection Members
FastReport Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
StyleCollection..::.Load Method (Stream)
StyleCollection Class See Also Send Feedback
Loads the collection from a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to load from.

See Also

StyleCollection Class
Load Overload
FastReport Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
StyleCollection..::.Load Method (String)
StyleCollection Class See Also Send Feedback
Loads the collection from a file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file.

See Also

StyleCollection Class
Load Overload
FastReport Namespace


Remove Method

[image]

FastReport.Net Class Reference
StyleCollection..::.Remove Method
StyleCollection Class See Also Send Feedback
Removes the specified object from the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    Style value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Style _
)
Visual C++
public:
void Remove(
    Style^ value
)

Parameters

value
Type: FastReport..::.Style
Object to remove.

See Also

StyleCollection Class
FastReport Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
StyleCollection..::.Save Method
StyleCollection Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves the collection to a stream.
Save(String) | Saves the collection to a file.

See Also

StyleCollection Class
StyleCollection Members
FastReport Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
StyleCollection..::.Save Method (Stream)
StyleCollection Class See Also Send Feedback
Saves the collection to a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to save to.

See Also

StyleCollection Class
Save Overload
FastReport Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
StyleCollection..::.Save Method (String)
StyleCollection Class See Also Send Feedback
Saves the collection to a file.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file.

See Also

StyleCollection Class
Save Overload
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
StyleCollection..::.Serialize Method
StyleCollection Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

StyleCollection Class
FastReport Namespace


StyleCollection Properties

[image] [image]

FastReport.Net Class Reference
StyleCollection Properties
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Name | Gets or sets the name of the style.

See Also

StyleCollection Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
StyleCollection..::.Item Property
StyleCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Style this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Style
Visual C++
public:
property Style^ default[int index] {
    Style^ get (int index);
    void set (int index, Style^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

StyleCollection Class
FastReport Namespace


Name Property

[image]

FastReport.Net Class Reference
StyleCollection..::.Name Property
StyleCollection Class See Also Send Feedback
Gets or sets the name of the style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

StyleCollection Class
FastReport Namespace


StylePriority Enumeration

[image]

FastReport.Net Class Reference
StylePriority Enumeration
See Also Send Feedback
Specifies the style properties to use when style is applied.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum StylePriority
Visual Basic (Declaration)
Public Enumeration StylePriority
Visual C++
public enum class StylePriority

Members

Member name | Description
UseFill | Use the fill property of the style.
UseAll | Use all style properties.

See Also

FastReport Namespace


StyleSheet Class

[image]

FastReport.Net Class Reference
StyleSheet Class
Members See Also Send Feedback
Represents a collection of the StyleCollection objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class StyleSheet : CollectionBase, IFRSerializable
Visual Basic (Declaration)
Public Class StyleSheet _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class StyleSheet : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport..::.StyleSheet

See Also

StyleSheet Members
FastReport Namespace


StyleSheet Members

[image] [image]

FastReport.Net Class Reference
StyleSheet Members
StyleSheet Class Constructors Methods Properties See Also Send Feedback

The StyleSheet type exposes the following members.

Constructors

Name | Description
StyleSheet | Initializes a new instance of the StyleSheet class

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Overloaded.
Deserialize | Deserializes the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an object into this collection at the specified index.
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Save | Overloaded.
Serialize | Serializes the collection.
ToArray | Gets an array containing all collection items.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

StyleSheet Class
FastReport Namespace


StyleSheet Constructor

[image]

FastReport.Net Class Reference
StyleSheet Constructor
StyleSheet Class See Also Send Feedback
Initializes a new instance of the StyleSheet class

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StyleSheet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleSheet()

See Also

StyleSheet Class
FastReport Namespace


StyleSheet Methods

[image] [image]

FastReport.Net Class Reference
StyleSheet Methods
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Overloaded.
Deserialize | Deserializes the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an object into this collection at the specified index.
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Save | Overloaded.
Serialize | Serializes the collection.
ToArray | Gets an array containing all collection items.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StyleSheet Class
FastReport Namespace


Add Method

[image]

FastReport.Net Class Reference
StyleSheet..::.Add Method
StyleSheet Class See Also Send Feedback
Adds an object to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    StyleCollection value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As StyleCollection _
) As Integer
Visual C++
public:
int Add(
    StyleCollection^ value
)

Parameters

value
Type: FastReport..::.StyleCollection
Object to add.

Return Value

Index of the added object.

See Also

StyleSheet Class
FastReport Namespace


AddRange Method

[image]

FastReport.Net Class Reference
StyleSheet..::.AddRange Method
StyleSheet Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    StyleCollection[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As StyleCollection() _
)
Visual C++
public:
void AddRange(
    array<StyleCollection^>^ range
)

Parameters

range
Type: array< FastReport..::.StyleCollection >[]()[]

See Also

StyleSheet Class
FastReport Namespace


Contains Method

[image] [image]

FastReport.Net Class Reference
StyleSheet..::.Contains Method
StyleSheet Class See Also Send Feedback

Overload List

Name | Description
Contains(StyleCollection) | Determines whether an element is in the collection.
Contains(String) | Determines whether a style collection with specified name is in the collection.

See Also

StyleSheet Class
StyleSheet Members
FastReport Namespace


Contains Method (StyleCollection)

[image]

FastReport.Net Class Reference
StyleSheet..::.Contains Method (StyleCollection)
StyleSheet Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    StyleCollection value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As StyleCollection _
) As Boolean
Visual C++
public:
bool Contains(
    StyleCollection^ value
)

Parameters

value
Type: FastReport..::.StyleCollection
The object to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

StyleSheet Class
Contains Overload
FastReport Namespace


Contains Method (String)

[image]

FastReport.Net Class Reference
StyleSheet..::.Contains Method (String)
StyleSheet Class See Also Send Feedback
Determines whether a style collection with specified name is in the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    string value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ value
)

Parameters

value
Type: System..::.String
The style collection name to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

StyleSheet Class
Contains Overload
FastReport Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
StyleSheet..::.Deserialize Method
StyleSheet Class See Also Send Feedback
Deserializes the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

This method is for internal use only.

See Also

StyleSheet Class
FastReport Namespace


IndexOf Method

[image] [image]

FastReport.Net Class Reference
StyleSheet..::.IndexOf Method
StyleSheet Class See Also Send Feedback

Overload List

Name | Description
IndexOf(StyleCollection) | Returns the zero-based index of the first occurrence of an object.
IndexOf(String) | Returns the zero-based index of the first occurrence of a style collection with specified name.

See Also

StyleSheet Class
StyleSheet Members
FastReport Namespace


IndexOf Method (StyleCollection)

[image]

FastReport.Net Class Reference
StyleSheet..::.IndexOf Method (StyleCollection)
StyleSheet Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    StyleCollection value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As StyleCollection _
) As Integer
Visual C++
public:
int IndexOf(
    StyleCollection^ value
)

Parameters

value
Type: FastReport..::.StyleCollection
The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

StyleSheet Class
IndexOf Overload
FastReport Namespace


IndexOf Method (String)

[image]

FastReport.Net Class Reference
StyleSheet..::.IndexOf Method (String)
StyleSheet Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a style collection with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    string value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As String _
) As Integer
Visual C++
public:
int IndexOf(
    String^ value
)

Parameters

value
Type: System..::.String
The style collection name to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

StyleSheet Class
IndexOf Overload
FastReport Namespace


Insert Method

[image]

FastReport.Net Class Reference
StyleSheet..::.Insert Method
StyleSheet Class See Also Send Feedback
Inserts an object into this collection at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    StyleCollection value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As StyleCollection _
)
Visual C++
public:
void Insert(
    int index,
    StyleCollection^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport..::.StyleCollection
The object to insert.

See Also

StyleSheet Class
FastReport Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
StyleSheet..::.Load Method
StyleSheet Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads the collection from a stream.
Load(String) | Loads the collection from a file with specified name.

See Also

StyleSheet Class
StyleSheet Members
FastReport Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
StyleSheet..::.Load Method (Stream)
StyleSheet Class See Also Send Feedback
Loads the collection from a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to load from.

See Also

StyleSheet Class
Load Overload
FastReport Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
StyleSheet..::.Load Method (String)
StyleSheet Class See Also Send Feedback
Loads the collection from a file with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of a file.

See Also

StyleSheet Class
Load Overload
FastReport Namespace


Remove Method

[image]

FastReport.Net Class Reference
StyleSheet..::.Remove Method
StyleSheet Class See Also Send Feedback
Removes the specified object from the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    StyleCollection value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As StyleCollection _
)
Visual C++
public:
void Remove(
    StyleCollection^ value
)

Parameters

value
Type: FastReport..::.StyleCollection
Object to remove.

See Also

StyleSheet Class
FastReport Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
StyleSheet..::.Save Method
StyleSheet Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves the collection to a stream.
Save(String) | Saves the collection to a file with specified name.

See Also

StyleSheet Class
StyleSheet Members
FastReport Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
StyleSheet..::.Save Method (Stream)
StyleSheet Class See Also Send Feedback
Saves the collection to a stream.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to save to.

See Also

StyleSheet Class
Save Overload
FastReport Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
StyleSheet..::.Save Method (String)
StyleSheet Class See Also Send Feedback
Saves the collection to a file with specified name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to save to.

See Also

StyleSheet Class
Save Overload
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
StyleSheet..::.Serialize Method
StyleSheet Class See Also Send Feedback
Serializes the collection.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

This method is for internal use only.

See Also

StyleSheet Class
FastReport Namespace


ToArray Method

[image]

FastReport.Net Class Reference
StyleSheet..::.ToArray Method
StyleSheet Class See Also Send Feedback
Gets an array containing all collection items.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As Object()
Visual C++
public:
array<Object^>^ ToArray()

Return Value

An array containing all collection items.

See Also

StyleSheet Class
FastReport Namespace


StyleSheet Properties

[image] [image]

FastReport.Net Class Reference
StyleSheet Properties
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

StyleSheet Class
FastReport Namespace


Item Property

[image]

FastReport.Net Class Reference
StyleSheet..::.Item Property
StyleSheet Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StyleCollection this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As StyleCollection
Visual C++
public:
property StyleCollection^ default[int index] {
    StyleCollection^ get (int index);
    void set (int index, StyleCollection^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

StyleSheet Class
FastReport Namespace


SubreportObject Class

[image]

FastReport.Net Class Reference
SubreportObject Class
Members Example See Also Send Feedback
Represents a subreport object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SubreportObject : ReportComponentBase
Visual Basic (Declaration)
Public Class SubreportObject _
    Inherits ReportComponentBase
Visual C++
public ref class SubreportObject : public ReportComponentBase

Remarks

To create a subreport in code, you should create the report page first and connect it to the subreport using the ReportPage property.

Examples

The following example shows how to create a subreport object in code.
CopyC#
// create the main report page
ReportPage reportPage = new ReportPage();
reportPage.Name = "Page1";
report.Pages.Add(reportPage);
// create report title band
reportPage.ReportTitle = new ReportTitleBand();
reportPage.ReportTitle.Name = "ReportTitle1";
reportPage.ReportTitle.Height = Units.Millimeters * 10;
// add subreport on it
SubreportObject subreport = new SubreportObject();
subreport.Name = "Subreport1";
subreport.Bounds = new RectangleF(0, 0, Units.Millimeters * 25, Units.Millimeters * 5);
reportPage.ReportTitle.Objects.Add(subreport);
// create subreport page
ReportPage subreportPage = new ReportPage();
subreportPage.Name = "SubreportPage1";
report.Pages.Add(subreportPage);
// connect the subreport to the subreport page
subreport.ReportPage = subreportPage;

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.SubreportObject

See Also

SubreportObject Members
FastReport Namespace


SubreportObject Members

[image] [image]

FastReport.Net Class Reference
SubreportObject Members
SubreportObject Class Constructors Methods Properties Events See Also Send Feedback

The SubreportObject type exposes the following members.

Constructors

Name | Description
SubreportObject | Initializes a new instance of the SubreportObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides Base..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Overrides Base..::.SetName(String).)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | This property is not relevant to this class.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | This property is not relevant to this class.
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | This property is not relevant to this class. (Overrides ReportComponentBase..::.Border.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | This property is not relevant to this class.
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | This property is not relevant to this class.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | This property is not relevant to this class.
Fill | This property is not relevant to this class. (Overrides ReportComponentBase..::.Fill.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | This property is not relevant to this class.
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnParent | Gets or sets a value indicating that subreport must print its objects on a parent band to which it belongs.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportPage | Gets or sets a report page that contains the subreport bands and objects.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | This property is not relevant to this class.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

SubreportObject Class
FastReport Namespace


SubreportObject Constructor

[image]

FastReport.Net Class Reference
SubreportObject Constructor
SubreportObject Class See Also Send Feedback
Initializes a new instance of the SubreportObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SubreportObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SubreportObject()

See Also

SubreportObject Class
FastReport Namespace


SubreportObject Methods

[image] [image]

FastReport.Net Class Reference
SubreportObject Methods
SubreportObject Class See Also Send Feedback

The SubreportObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides Base..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Overrides Base..::.SetName(String).)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

SubreportObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
SubreportObject..::.Assign Method
SubreportObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

SubreportObject Class
FastReport Namespace
AssignAll Method


Delete Method

[image]

FastReport.Net Class Reference
SubreportObject..::.Delete Method
SubreportObject Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

SubreportObject Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
SubreportObject..::.Dispose Method
SubreportObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

SubreportObject Class
SubreportObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
SubreportObject..::.Draw Method
SubreportObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

SubreportObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
SubreportObject..::.DrawMarkers Method
SubreportObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

SubreportObject Class
SubreportObject Members
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
SubreportObject..::.GetContextMenu Method
SubreportObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

SubreportObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
SubreportObject..::.MemberwiseClone Method
SubreportObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SubreportObject Class
SubreportObject Members
FastReport Namespace


OnAfterInsert Method

[image]

FastReport.Net Class Reference
SubreportObject..::.OnAfterInsert Method
SubreportObject Class See Also Send Feedback
Called after the new object was inserted in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterInsert(
    InsertFrom source
)
Visual Basic (Declaration)
Public Overrides Sub OnAfterInsert ( _
    source As InsertFrom _
)
Visual C++
public:
virtual void OnAfterInsert(
    InsertFrom source
) override

Parameters

source
Type: FastReport..::.InsertFrom
The insertion source.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called when new object is inserted, pasted from clipboard or dragged from "Dictionary" window. You may override this method if you need to perform some actions when object is inserted. Typical implementation invokes the object's editor if "Edit after insert" flag is set in the designer options.

See Also

SubreportObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
SubreportObject..::.Serialize Method
SubreportObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

SubreportObject Class
FastReport Namespace


SetName Method

[image]

FastReport.Net Class Reference
SubreportObject..::.SetName Method
SubreportObject Class See Also Send Feedback
Sets the object's name.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetName(
    string value
)
Visual Basic (Declaration)
Public Overrides Sub SetName ( _
    value As String _
)
Visual C++
public:
virtual void SetName(
    String^ value
) override

Parameters

value
Type: System..::.String
New name.

Remarks

This method is for internal use only. It just sets a new name without any checks (unlike the Name property setter).

See Also

SubreportObject Class
FastReport Namespace
Name Property


SubreportObject Properties

[image] [image]

FastReport.Net Class Reference
SubreportObject Properties
SubreportObject Class See Also Send Feedback

The SubreportObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | This property is not relevant to this class.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | This property is not relevant to this class.
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | This property is not relevant to this class. (Overrides ReportComponentBase..::.Border.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | This property is not relevant to this class.
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | This property is not relevant to this class.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | This property is not relevant to this class.
Fill | This property is not relevant to this class. (Overrides ReportComponentBase..::.Fill.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | This property is not relevant to this class.
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
PrintOnParent | Gets or sets a value indicating that subreport must print its objects on a parent band to which it belongs.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportPage | Gets or sets a report page that contains the subreport bands and objects.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | This property is not relevant to this class.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

SubreportObject Class
FastReport Namespace


AfterPrintEvent Property

[image]

FastReport.Net Class Reference
SubreportObject..::.AfterPrintEvent Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AfterPrintEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property AfterPrintEvent As String
Visual C++
public:
property String^ AfterPrintEvent {
    String^ get ();
}

See Also

SubreportObject Class
FastReport Namespace


BeforePrintEvent Property

[image]

FastReport.Net Class Reference
SubreportObject..::.BeforePrintEvent Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BeforePrintEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property BeforePrintEvent As String
Visual C++
public:
property String^ BeforePrintEvent {
    String^ get ();
}

See Also

SubreportObject Class
FastReport Namespace


Border Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Border Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Border Border { get; set; }
Visual Basic (Declaration)
Public Overrides Property Border As Border
Visual C++
public:
virtual property Border^ Border {
    Border^ get () override;
    void set (Border^ value) override;
}

See Also

SubreportObject Class
FastReport Namespace


CanGrow Property

[image]

FastReport.Net Class Reference
SubreportObject..::.CanGrow Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanGrow { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
}

See Also

SubreportObject Class
FastReport Namespace


CanShrink Property

[image]

FastReport.Net Class Reference
SubreportObject..::.CanShrink Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanShrink { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
}

See Also

SubreportObject Class
FastReport Namespace


ClickEvent Property

[image]

FastReport.Net Class Reference
SubreportObject..::.ClickEvent Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ClickEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClickEvent As String
Visual C++
public:
property String^ ClickEvent {
    String^ get ();
}

See Also

SubreportObject Class
FastReport Namespace


Cursor Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Cursor Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Cursor Cursor { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cursor As Cursor
Visual C++
public:
property Cursor^ Cursor {
    Cursor^ get ();
}

See Also

SubreportObject Class
FastReport Namespace


Exportable Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Exportable Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Exportable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Exportable As Boolean
Visual C++
public:
property bool Exportable {
    bool get ();
}

See Also

SubreportObject Class
FastReport Namespace


Fill Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Fill Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Overrides Property Fill As FillBase
Visual C++
public:
virtual property FillBase^ Fill {
    FillBase^ get () override;
    void set (FillBase^ value) override;
}

See Also

SubreportObject Class
FastReport Namespace


Hyperlink Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Hyperlink Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Hyperlink Hyperlink { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hyperlink As Hyperlink
Visual C++
public:
property Hyperlink^ Hyperlink {
    Hyperlink^ get ();
}

See Also

SubreportObject Class
FastReport Namespace


Printable Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Printable Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Printable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Printable As Boolean
Visual C++
public:
property bool Printable {
    bool get ();
}

See Also

SubreportObject Class
FastReport Namespace


PrintOnParent Property

[image]

FastReport.Net Class Reference
SubreportObject..::.PrintOnParent Property
SubreportObject Class See Also Send Feedback
Gets or sets a value indicating that subreport must print its objects on a parent band to which it belongs.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOnParent { get; set; }
Visual Basic (Declaration)
Public Property PrintOnParent As Boolean
Visual C++
public:
property bool PrintOnParent {
    bool get ();
    void set (bool value);
}

Remarks

Default behavior of the subreport is to print subreport objects they own separate bands.

See Also

SubreportObject Class
FastReport Namespace


ReportPage Property

[image]

FastReport.Net Class Reference
SubreportObject..::.ReportPage Property
SubreportObject Class See Also Send Feedback
Gets or sets a report page that contains the subreport bands and objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportPage ReportPage { get; set; }
Visual Basic (Declaration)
Public Property ReportPage As ReportPage
Visual C++
public:
property ReportPage^ ReportPage {
    ReportPage^ get ();
    void set (ReportPage^ value);
}

See Also

SubreportObject Class
FastReport Namespace


Style Property

[image]

FastReport.Net Class Reference
SubreportObject..::.Style Property
SubreportObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Style { get; }
Visual Basic (Declaration)
Public ReadOnly Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
}

See Also

SubreportObject Class
FastReport Namespace


SubreportObject Events

[image] [image]

FastReport.Net Class Reference
SubreportObject Events
SubreportObject Class See Also Send Feedback

The SubreportObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

SubreportObject Class
FastReport Namespace


TextObject Class

[image]

FastReport.Net Class Reference
TextObject Class
Members See Also Send Feedback
Represents the Text object that may display one or several text lines.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextObject : TextObjectBase, IHasEditor
Visual Basic (Declaration)
Public Class TextObject _
    Inherits TextObjectBase _
    Implements IHasEditor
Visual C++
public ref class TextObject : public TextObjectBase,
    IHasEditor

Remarks

Specify the object's text in the Text property. Text may contain expressions and data items, for example: "Today is [Date]". When report is running, all expressions are calculated and replaced with actual values, so the text would be "Today is 01.01.2008".

The symbols used to find expressions in a text are set in the Brackets property. You also may disable expressions using the AllowExpressions property.

To format an expression value, use the FastReport.Format property.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.TextObjectBase
FastReport..::.TextObject
FastReport..::.CellularTextObject
FastReport.Table..::.TableCell

See Also

TextObject Members
FastReport Namespace


TextObject Members

[image] [image]

FastReport.Net Class Reference
TextObject Members
TextObject Class Constructors Methods Properties Events See Also Send Feedback

The TextObject type exposes the following members.

Constructors

Name | Description
TextObject | Initializes a new instance of the TextObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Overrides ReportComponentBase..::.ApplyStyle(Style).)
Assign | Copies the contents of another, similar object. (Overrides TextObjectBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Overrides TextObjectBase..::.AssignFormat(ReportComponentBase).)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CalcWidth | Calculates the object's width.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides TextObjectBase..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Overrides TextObjectBase..::.DrawSearchHighlight(FRPaintEventArgs, CharacterRange).)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
DrawText | Draws a text.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Overrides ComponentBase..::.HandleKeyDown(Control, KeyEventArgs).)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Overrides ReportComponentBase..::.RestoreStyle()()().)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Overrides ReportComponentBase..::.SaveStyle()()().)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides TextObjectBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | Gets or sets the text angle, in degrees.
AutoShrink | Gets or sets a value that indicates whether the font size should shrink to display the longest text line without word wrap.
AutoShrinkMinSize | Gets or sets the minimum size of font (or minimum width ratio) if the AutoShrink mode is on.
AutoWidth | Gets or sets a value that determines if the text object should handle its width automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Clip | Gets or sets a value that indicates if text should be clipped inside the object's bounds.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values. (Inherited from TextObjectBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstTabOffset | Gets or sets the offset, in pixels, of the first TAB symbol.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Font | Gets or sets the font settings for this object.
FontWidthRatio | Gets or sets the width ratio of the font.
ForceJustify | Forces justify for the last text line.
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Overrides ReportComponentBase..::.Height.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
Highlight | Gets the collection of conditional highlight attributes.
HorzAlign | Gets or sets the horizontal alignment of a text in the TextObject object.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
HtmlTags | Allows handling html tags in the text.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Left.)
LineHeight | Gets or sets the height of single text line, in pixels.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object. (Inherited from TextObjectBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
ParagraphOffset | Gets or sets the paragraph offset, in pixels.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value that indicates whether the component should draw right-to-left for RTL languages.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
TabWidth | Gets or sets the width of TAB symbol, in pixels.
Text | Gets or sets the object's text. (Inherited from TextObjectBase.)
TextColor | Gets or sets the text color in a simple manner.
TextFill | Gets or sets the fill color used to draw a text.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Top.)
Trimming | Gets or sets the string trimming options.
Underlines | Gets or sets a value that determines if the text object will underline each text line.
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
VertAlign | Gets or sets the vertical alignment of a text in the TextObject object.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
WordWrap | Gets or sets a value that indicates if lines are automatically word-wrapped.
Wysiwyg | Gets or sets a value that indicates if the text object should display its contents similar to the printout.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TextObject Class
FastReport Namespace


TextObject Constructor

[image]

FastReport.Net Class Reference
TextObject Constructor
TextObject Class See Also Send Feedback
Initializes a new instance of the TextObject class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextObject()

See Also

TextObject Class
FastReport Namespace


TextObject Methods

[image] [image]

FastReport.Net Class Reference
TextObject Methods
TextObject Class See Also Send Feedback

The TextObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Overrides ReportComponentBase..::.ApplyStyle(Style).)
Assign | Copies the contents of another, similar object. (Overrides TextObjectBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Overrides TextObjectBase..::.AssignFormat(ReportComponentBase).)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CalcWidth | Calculates the object's width.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides TextObjectBase..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Overrides TextObjectBase..::.DrawSearchHighlight(FRPaintEventArgs, CharacterRange).)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
DrawText | Draws a text.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Overrides ComponentBase..::.HandleKeyDown(Control, KeyEventArgs).)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Overrides ReportComponentBase..::.RestoreStyle()()().)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Overrides ReportComponentBase..::.SaveStyle()()().)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides TextObjectBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TextObject Class
FastReport Namespace


ApplyStyle Method

[image]

FastReport.Net Class Reference
TextObject..::.ApplyStyle Method
TextObject Class See Also Send Feedback
Applies the style settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void ApplyStyle(
    Style style
)
Visual Basic (Declaration)
Public Overrides Sub ApplyStyle ( _
    style As Style _
)
Visual C++
public:
virtual void ApplyStyle(
    Style^ style
) override

Parameters

style
Type: FastReport..::.Style
Style to apply.

See Also

TextObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
TextObject..::.Assign Method
TextObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TextObject Class
FastReport Namespace
AssignAll Method


AssignFormat Method

[image]

FastReport.Net Class Reference
TextObject..::.AssignFormat Method
TextObject Class See Also Send Feedback
Assigns a format from another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void AssignFormat(
    ReportComponentBase source
)
Visual Basic (Declaration)
Public Overrides Sub AssignFormat ( _
    source As ReportComponentBase _
)
Visual C++
public:
virtual void AssignFormat(
    ReportComponentBase^ source
) override

Parameters

source
Type: FastReport..::.ReportComponentBase
Source object to assign a format from.

See Also

TextObject Class
FastReport Namespace


Break Method

[image]

FastReport.Net Class Reference
TextObject..::.Break Method
TextObject Class See Also Send Feedback
Breaks the contents of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Break(
    BreakableComponent breakTo
)
Visual Basic (Declaration)
Public Overrides Function Break ( _
    breakTo As BreakableComponent _
) As Boolean
Visual C++
public:
virtual bool Break(
    BreakableComponent^ breakTo
) override

Parameters

breakTo
Type: FastReport..::.BreakableComponent
Object to put the part of content to that does not fit in this object. These two objects must have the same type.

Return Value

true if there is enough space in this object to display at least one text line.

Remarks

Do not call this method directly, it is used by the report engine. You should override it if you are writing a new FastReport object.

This method must break the contents of the object. The part of content that fit in current object's bounds should remain in this object, the part that does not fit should be transferred to breakTo object.

See Also

TextObject Class
FastReport Namespace


CalcHeight Method

[image]

FastReport.Net Class Reference
TextObject..::.CalcHeight Method
TextObject Class See Also Send Feedback
Calculates the object's height.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float CalcHeight()
Visual Basic (Declaration)
Public Overrides Function CalcHeight As Single
Visual C++
public:
virtual float CalcHeight() override

Return Value

Actual object's height, in pixels.

Remarks

Applicable to objects that contain several text lines, such as TextObject. Returns the height needed to display all the text lines.

See Also

TextObject Class
FastReport Namespace


CalcWidth Method

[image]

FastReport.Net Class Reference
TextObject..::.CalcWidth Method
TextObject Class See Also Send Feedback
Calculates the object's width.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CalcWidth()
Visual Basic (Declaration)
Public Function CalcWidth As Single
Visual C++
public:
float CalcWidth()

Return Value

The width, in pixels.

See Also

TextObject Class
FastReport Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
TextObject..::.DeserializeSubItems Method
TextObject Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overrides Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

TextObject Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextObject..::.Dispose Method
TextObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TextObject Class
TextObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
TextObject..::.Draw Method
TextObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

TextObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
TextObject..::.DrawMarkers Method
TextObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

TextObject Class
TextObject Members
FastReport Namespace


DrawSearchHighlight Method

[image]

FastReport.Net Class Reference
TextObject..::.DrawSearchHighlight Method
TextObject Class See Also Send Feedback
Draws the highlight to show the text found.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawSearchHighlight(
    FRPaintEventArgs e,
    CharacterRange range
)
Visual Basic (Declaration)
Public Overrides Sub DrawSearchHighlight ( _
    e As FRPaintEventArgs, _
    range As CharacterRange _
)
Visual C++
public:
virtual void DrawSearchHighlight(
    FRPaintEventArgs^ e,
    CharacterRange range
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
range
Type: System.Drawing..::.CharacterRange
Range of characters to highlight.

Implements

ISearchable..::.DrawSearchHighlight(FRPaintEventArgs, CharacterRange)

See Also

TextObject Class
FastReport Namespace


DrawText Method

[image]

FastReport.Net Class Reference
TextObject..::.DrawText Method
TextObject Class See Also Send Feedback
Draws a text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DrawText(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
void DrawText(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event data.

See Also

TextObject Class
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
TextObject..::.GetContextMenu Method
TextObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

TextObject Class
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
TextObject..::.GetData Method
TextObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

TextObject Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
TextObject..::.GetExpressions Method
TextObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

TextObject Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
TextObject..::.GetSmartTag Method
TextObject Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

TextObject Class
FastReport Namespace


HandleDragDrop Method

[image]

FastReport.Net Class Reference
TextObject..::.HandleDragDrop Method
TextObject Class See Also Send Feedback
Handles the DragDrop event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragDrop(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragDrop ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragDrop(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drops an item from the Data Tree window into this object. This method should copy the information from the e.DraggedObject object and set the e.Handled flag to true to complete the drag operation.

See Also

TextObject Class
FastReport Namespace


HandleDragOver Method

[image]

FastReport.Net Class Reference
TextObject..::.HandleDragOver Method
TextObject Class See Also Send Feedback
Handles the DragOver event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragOver(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragOver ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragOver(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drags an item from the Data Tree window. This method should check that the mouse (e.X, e.Y) is inside the object, then set the e.Handled flag to true if an item can be dragged into this object.

See Also

TextObject Class
FastReport Namespace


HandleKeyDown Method

[image]

FastReport.Net Class Reference
TextObject..::.HandleKeyDown Method
TextObject Class See Also Send Feedback
Handles KeyDown event in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleKeyDown(
    Control sender,
    KeyEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleKeyDown ( _
    sender As Control, _
    e As KeyEventArgs _
)
Visual C++
public:
virtual void HandleKeyDown(
    Control^ sender,
    KeyEventArgs^ e
) override

Parameters

sender
Type: System.Windows.Forms..::.Control
The designer's workspace.
e
Type: System.Windows.Forms..::.KeyEventArgs
Keyboard event parameters.

Remarks

This method is called when the user presses any key in the designer. Typical implementation does nothing.

See Also

TextObject Class
FastReport Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
TextObject..::.InvokeEditor Method
TextObject Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool InvokeEditor()
Visual Basic (Declaration)
Public Overridable Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor()

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

TextObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextObject..::.MemberwiseClone Method
TextObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextObject Class
TextObject Members
FastReport Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
TextObject..::.RestoreState Method
TextObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

TextObject Class
FastReport Namespace


RestoreStyle Method

[image]

FastReport.Net Class Reference
TextObject..::.RestoreStyle Method
TextObject Class See Also Send Feedback
Restores the current style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreStyle()
Visual Basic (Declaration)
Public Overrides Sub RestoreStyle
Visual C++
public:
virtual void RestoreStyle() override

See Also

TextObject Class
FastReport Namespace


SaveState Method

[image]

FastReport.Net Class Reference
TextObject..::.SaveState Method
TextObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

TextObject Class
FastReport Namespace


SaveStyle Method

[image]

FastReport.Net Class Reference
TextObject..::.SaveStyle Method
TextObject Class See Also Send Feedback
Saves the current style.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveStyle()
Visual Basic (Declaration)
Public Overrides Sub SaveStyle
Visual C++
public:
virtual void SaveStyle() override

See Also

TextObject Class
FastReport Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
TextObject..::.SelectionChanged Method
TextObject Class See Also Send Feedback
Called when the user selects another object in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Remarks

This method is typically used by the in-place object's editor to check if selection was changed and close the editor.

See Also

TextObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TextObject..::.Serialize Method
TextObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TextObject Class
FastReport Namespace


TextObject Properties

[image] [image]

FastReport.Net Class Reference
TextObject Properties
TextObject Class See Also Send Feedback

The TextObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | Gets or sets the text angle, in degrees.
AutoShrink | Gets or sets a value that indicates whether the font size should shrink to display the longest text line without word wrap.
AutoShrinkMinSize | Gets or sets the minimum size of font (or minimum width ratio) if the AutoShrink mode is on.
AutoWidth | Gets or sets a value that determines if the text object should handle its width automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Clip | Gets or sets a value that indicates if text should be clipped inside the object's bounds.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values. (Inherited from TextObjectBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstTabOffset | Gets or sets the offset, in pixels, of the first TAB symbol.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Font | Gets or sets the font settings for this object.
FontWidthRatio | Gets or sets the width ratio of the font.
ForceJustify | Forces justify for the last text line.
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Overrides ReportComponentBase..::.Height.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
Highlight | Gets the collection of conditional highlight attributes.
HorzAlign | Gets or sets the horizontal alignment of a text in the TextObject object.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
HtmlTags | Allows handling html tags in the text.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Left.)
LineHeight | Gets or sets the height of single text line, in pixels.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object. (Inherited from TextObjectBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
ParagraphOffset | Gets or sets the paragraph offset, in pixels.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value that indicates whether the component should draw right-to-left for RTL languages.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
TabWidth | Gets or sets the width of TAB symbol, in pixels.
Text | Gets or sets the object's text. (Inherited from TextObjectBase.)
TextColor | Gets or sets the text color in a simple manner.
TextFill | Gets or sets the fill color used to draw a text.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ReportComponentBase..::.Top.)
Trimming | Gets or sets the string trimming options.
Underlines | Gets or sets a value that determines if the text object will underline each text line.
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
VertAlign | Gets or sets the vertical alignment of a text in the TextObject object.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
WordWrap | Gets or sets a value that indicates if lines are automatically word-wrapped.
Wysiwyg | Gets or sets a value that indicates if the text object should display its contents similar to the printout.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TextObject Class
FastReport Namespace


Angle Property

[image]

FastReport.Net Class Reference
TextObject..::.Angle Property
TextObject Class See Also Send Feedback
Gets or sets the text angle, in degrees.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

TextObject Class
FastReport Namespace


AutoShrink Property

[image]

FastReport.Net Class Reference
TextObject..::.AutoShrink Property
TextObject Class See Also Send Feedback
Gets or sets a value that indicates whether the font size should shrink to display the longest text line without word wrap.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AutoShrinkMode AutoShrink { get; set; }
Visual Basic (Declaration)
Public Property AutoShrink As AutoShrinkMode
Visual C++
public:
property AutoShrinkMode AutoShrink {
    AutoShrinkMode get ();
    void set (AutoShrinkMode value);
}

Remarks

To limit the minimum size, use the AutoShrinkMinSize property.

See Also

TextObject Class
FastReport Namespace


AutoShrinkMinSize Property

[image]

FastReport.Net Class Reference
TextObject..::.AutoShrinkMinSize Property
TextObject Class See Also Send Feedback
Gets or sets the minimum size of font (or minimum width ratio) if the AutoShrink mode is on.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float AutoShrinkMinSize { get; set; }
Visual Basic (Declaration)
Public Property AutoShrinkMinSize As Single
Visual C++
public:
property float AutoShrinkMinSize {
    float get ();
    void set (float value);
}

Remarks

This property determines the minimum font size (in case the AutoShrink property is set to FontSize), or the minimum font width ratio (if AutoShrink is set to FontWidth).

The default value is 0, that means no limits.

See Also

TextObject Class
FastReport Namespace


AutoWidth Property

[image]

FastReport.Net Class Reference
TextObject..::.AutoWidth Property
TextObject Class See Also Send Feedback
Gets or sets a value that determines if the text object should handle its width automatically.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoWidth As Boolean
Visual C++
public:
property bool AutoWidth {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


Clip Property

[image]

FastReport.Net Class Reference
TextObject..::.Clip Property
TextObject Class See Also Send Feedback
Gets or sets a value that indicates if text should be clipped inside the object's bounds.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Clip { get; set; }
Visual Basic (Declaration)
Public Property Clip As Boolean
Visual C++
public:
property bool Clip {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


FirstTabOffset Property

[image]

FastReport.Net Class Reference
TextObject..::.FirstTabOffset Property
TextObject Class See Also Send Feedback
Gets or sets the offset, in pixels, of the first TAB symbol.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float FirstTabOffset { get; set; }
Visual Basic (Declaration)
Public Property FirstTabOffset As Single
Visual C++
public:
property float FirstTabOffset {
    float get ();
    void set (float value);
}

See Also

TextObject Class
FastReport Namespace


Font Property

[image]

FastReport.Net Class Reference
TextObject..::.Font Property
TextObject Class See Also Send Feedback
Gets or sets the font settings for this object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

TextObject Class
FastReport Namespace


FontWidthRatio Property

[image]

FastReport.Net Class Reference
TextObject..::.FontWidthRatio Property
TextObject Class See Also Send Feedback
Gets or sets the width ratio of the font.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float FontWidthRatio { get; set; }
Visual Basic (Declaration)
Public Property FontWidthRatio As Single
Visual C++
public:
property float FontWidthRatio {
    float get ();
    void set (float value);
}

Remarks

Default value is 1. To make a font wider, set a value grether than 1; to make a font narrower, set a value less than 1.

See Also

TextObject Class
FastReport Namespace


ForceJustify Property

[image]

FastReport.Net Class Reference
TextObject..::.ForceJustify Property
TextObject Class See Also Send Feedback
Forces justify for the last text line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ForceJustify { get; set; }
Visual Basic (Declaration)
Public Property ForceJustify As Boolean
Visual C++
public:
property bool ForceJustify {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


Height Property

[image]

FastReport.Net Class Reference
TextObject..::.Height Property
TextObject Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

TextObject Class
FastReport Namespace


Highlight Property

[image]

FastReport.Net Class Reference
TextObject..::.Highlight Property
TextObject Class See Also Send Feedback
Gets the collection of conditional highlight attributes.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ConditionCollection Highlight { get; }
Visual Basic (Declaration)
Public ReadOnly Property Highlight As ConditionCollection
Visual C++
public:
property ConditionCollection^ Highlight {
    ConditionCollection^ get ();
}

Remarks

Conditional highlight is used to change the visual appearance of the Text object depending on some condition(s). For example, you may highlight negative values displayed by the Text object with red color. To do this, add the highlight condition:
CopyC#
TextObject text1;
HighlightCondition highlight = new HighlightCondition();
highlight.Expression = "Value < 0";
highlight.Fill = new SolidFill(Color.Red);
highlight.ApplyFill = true;
text1.Highlight.Add(highlight);

See Also

TextObject Class
FastReport Namespace


HorzAlign Property

[image]

FastReport.Net Class Reference
TextObject..::.HorzAlign Property
TextObject Class See Also Send Feedback
Gets or sets the horizontal alignment of a text in the TextObject object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HorzAlign HorzAlign { get; set; }
Visual Basic (Declaration)
Public Property HorzAlign As HorzAlign
Visual C++
public:
property HorzAlign HorzAlign {
    HorzAlign get ();
    void set (HorzAlign value);
}

See Also

TextObject Class
FastReport Namespace


HtmlTags Property

[image]

FastReport.Net Class Reference
TextObject..::.HtmlTags Property
TextObject Class See Also Send Feedback
Allows handling html tags in the text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HtmlTags { get; set; }
Visual Basic (Declaration)
Public Property HtmlTags As Boolean
Visual C++
public:
property bool HtmlTags {
    bool get ();
    void set (bool value);
}

Remarks

The following html tags can be used in the object's text: <b>, <i>, <u>, <strike>, <sub>, <sup>, </b>, </i>, </u>, </strike>, </sub>, </sup>, <font color=&...&>, </font>. Font size cannot be changed due to limitations in the rendering engine.

See Also

TextObject Class
FastReport Namespace


Left Property

[image]

FastReport.Net Class Reference
TextObject..::.Left Property
TextObject Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

TextObject Class
FastReport Namespace


LineHeight Property

[image]

FastReport.Net Class Reference
TextObject..::.LineHeight Property
TextObject Class See Also Send Feedback
Gets or sets the height of single text line, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float LineHeight { get; set; }
Visual Basic (Declaration)
Public Property LineHeight As Single
Visual C++
public:
property float LineHeight {
    float get ();
    void set (float value);
}

See Also

TextObject Class
FastReport Namespace


ParagraphOffset Property

[image]

FastReport.Net Class Reference
TextObject..::.ParagraphOffset Property
TextObject Class See Also Send Feedback
Gets or sets the paragraph offset, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ParagraphOffset { get; set; }
Visual Basic (Declaration)
Public Property ParagraphOffset As Single
Visual C++
public:
property float ParagraphOffset {
    float get ();
    void set (float value);
}

See Also

TextObject Class
FastReport Namespace


RightToLeft Property

[image]

FastReport.Net Class Reference
TextObject..::.RightToLeft Property
TextObject Class See Also Send Feedback
Gets or sets a value that indicates whether the component should draw right-to-left for RTL languages.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


TabWidth Property

[image]

FastReport.Net Class Reference
TextObject..::.TabWidth Property
TextObject Class See Also Send Feedback
Gets or sets the width of TAB symbol, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float TabWidth { get; set; }
Visual Basic (Declaration)
Public Property TabWidth As Single
Visual C++
public:
property float TabWidth {
    float get ();
    void set (float value);
}

See Also

TextObject Class
FastReport Namespace


TextColor Property

[image]

FastReport.Net Class Reference
TextObject..::.TextColor Property
TextObject Class See Also Send Feedback
Gets or sets the text color in a simple manner.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Remarks

This property can be used in a report script to change the text color of the object. It is equivalent to:
CopyC#
textObject1.TextFill = new SolidFill(color);

See Also

TextObject Class
FastReport Namespace


TextFill Property

[image]

FastReport.Net Class Reference
TextObject..::.TextFill Property
TextObject Class See Also Send Feedback
Gets or sets the fill color used to draw a text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillBase TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As FillBase
Visual C++
public:
property FillBase^ TextFill {
    FillBase^ get ();
    void set (FillBase^ value);
}

Remarks

Default fill is SolidFill. You may specify other fill types, for example:
CopyC#
text1.TextFill = new HatchFill(Color.Black, Color.White, HatchStyle.Cross);
 Use the TextColor property to set the solid text color.

See Also

TextObject Class
FastReport Namespace


Top Property

[image]

FastReport.Net Class Reference
TextObject..::.Top Property
TextObject Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

TextObject Class
FastReport Namespace


Trimming Property

[image]

FastReport.Net Class Reference
TextObject..::.Trimming Property
TextObject Class See Also Send Feedback
Gets or sets the string trimming options.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StringTrimming Trimming { get; set; }
Visual Basic (Declaration)
Public Property Trimming As StringTrimming
Visual C++
public:
property StringTrimming Trimming {
    StringTrimming get ();
    void set (StringTrimming value);
}

See Also

TextObject Class
FastReport Namespace


Underlines Property

[image]

FastReport.Net Class Reference
TextObject..::.Underlines Property
TextObject Class See Also Send Feedback
Gets or sets a value that determines if the text object will underline each text line.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Underlines { get; set; }
Visual Basic (Declaration)
Public Property Underlines As Boolean
Visual C++
public:
property bool Underlines {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


VertAlign Property

[image]

FastReport.Net Class Reference
TextObject..::.VertAlign Property
TextObject Class See Also Send Feedback
Gets or sets the vertical alignment of a text in the TextObject object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public VertAlign VertAlign { get; set; }
Visual Basic (Declaration)
Public Property VertAlign As VertAlign
Visual C++
public:
property VertAlign VertAlign {
    VertAlign get ();
    void set (VertAlign value);
}

See Also

TextObject Class
FastReport Namespace


Width Property

[image]

FastReport.Net Class Reference
TextObject..::.Width Property
TextObject Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

TextObject Class
FastReport Namespace


WordWrap Property

[image]

FastReport.Net Class Reference
TextObject..::.WordWrap Property
TextObject Class See Also Send Feedback
Gets or sets a value that indicates if lines are automatically word-wrapped.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool WordWrap { get; set; }
Visual Basic (Declaration)
Public Property WordWrap As Boolean
Visual C++
public:
property bool WordWrap {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
TextObject..::.Wysiwyg Property
TextObject Class See Also Send Feedback
Gets or sets a value that indicates if the text object should display its contents similar to the printout.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

See Also

TextObject Class
FastReport Namespace


TextObject Events

[image] [image]

FastReport.Net Class Reference
TextObject Events
TextObject Class See Also Send Feedback

The TextObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TextObject Class
FastReport Namespace


TextObjectBase Class

[image]

FastReport.Net Class Reference
TextObjectBase Class
Members See Also Send Feedback
Base class for text objects such as TextObject and RichObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextObjectBase : BreakableComponent,
    ISearchable
Visual Basic (Declaration)
Public Class TextObjectBase _
    Inherits BreakableComponent _
    Implements ISearchable
Visual C++
public ref class TextObjectBase : public BreakableComponent,
    ISearchable

Remarks

This class implements common functionality of the text objects.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.TextObjectBase
FastReport..::.RichObject
FastReport..::.TextObject

See Also

TextObjectBase Members
FastReport Namespace


TextObjectBase Members

[image] [image]

FastReport.Net Class Reference
TextObjectBase Members
TextObjectBase Class Constructors Methods Properties Events See Also Send Feedback

The TextObjectBase type exposes the following members.

Constructors

Name | Description
TextObjectBase | Initializes a new instance of the TextObjectBase class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BreakableComponent..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Overrides ReportComponentBase..::.AssignFormat(ReportComponentBase).)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BreakableComponent.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ReportComponentBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Overrides Base..::.ExtractMacros()()().)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SearchText | Finds the specified text inside the object.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BreakableComponent..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions.
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text.
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values.
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Format | Gets or sets the formatter that will be used to format data in the Text object.
Formats | Gets the collection of formatters.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideValue | Gets or sets a value that will be hidden.
HideZeros | Gets or sets a value indicating that zero values must be hidden.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Text | Gets or sets the object's text.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Value | Gets a value of expression contained in the object's text.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TextObjectBase Class
FastReport Namespace


TextObjectBase Constructor

[image]

FastReport.Net Class Reference
TextObjectBase Constructor
TextObjectBase Class See Also Send Feedback
Initializes a new instance of the TextObjectBase class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextObjectBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextObjectBase()

See Also

TextObjectBase Class
FastReport Namespace


TextObjectBase Methods

[image] [image]

FastReport.Net Class Reference
TextObjectBase Methods
TextObjectBase Class See Also Send Feedback

The TextObjectBase type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BreakableComponent..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Overrides ReportComponentBase..::.AssignFormat(ReportComponentBase).)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from BreakableComponent.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ReportComponentBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Overrides Base..::.ExtractMacros()()().)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SearchText | Finds the specified text inside the object.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BreakableComponent..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TextObjectBase Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.Assign Method
TextObjectBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TextObjectBase Class
FastReport Namespace
AssignAll Method


AssignFormat Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.AssignFormat Method
TextObjectBase Class See Also Send Feedback
Assigns a format from another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void AssignFormat(
    ReportComponentBase source
)
Visual Basic (Declaration)
Public Overrides Sub AssignFormat ( _
    source As ReportComponentBase _
)
Visual C++
public:
virtual void AssignFormat(
    ReportComponentBase^ source
) override

Parameters

source
Type: FastReport..::.ReportComponentBase
Source object to assign a format from.

See Also

TextObjectBase Class
FastReport Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.DeserializeSubItems Method
TextObjectBase Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overrides Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

TextObjectBase Class
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextObjectBase..::.Dispose Method
TextObjectBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TextObjectBase Class
TextObjectBase Members
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
TextObjectBase..::.DrawMarkers Method
TextObjectBase Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

TextObjectBase Class
TextObjectBase Members
FastReport Namespace


DrawSearchHighlight Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.DrawSearchHighlight Method
TextObjectBase Class See Also Send Feedback
Draws the highlight to show the text found.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void DrawSearchHighlight(
    FRPaintEventArgs e,
    CharacterRange range
)
Visual Basic (Declaration)
Public Overridable Sub DrawSearchHighlight ( _
    e As FRPaintEventArgs, _
    range As CharacterRange _
)
Visual C++
public:
virtual void DrawSearchHighlight(
    FRPaintEventArgs^ e,
    CharacterRange range
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.
range
Type: System.Drawing..::.CharacterRange
Range of characters to highlight.

Implements

ISearchable..::.DrawSearchHighlight(FRPaintEventArgs, CharacterRange)

See Also

TextObjectBase Class
FastReport Namespace


ExtractMacros Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.ExtractMacros Method
TextObjectBase Class See Also Send Feedback
Used to extract macros such as "TotalPages#" in the preview mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void ExtractMacros()
Visual Basic (Declaration)
Public Overrides Sub ExtractMacros
Visual C++
public:
virtual void ExtractMacros() override

Remarks

This method is used mainly by the TextObject to extract macros and replace it with actual values passed in the pageIndex and totalPages parameters. This method is called automatically when the object is being previewed.

See Also

TextObjectBase Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextObjectBase..::.MemberwiseClone Method
TextObjectBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextObjectBase Class
TextObjectBase Members
FastReport Namespace


SearchText Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.SearchText Method
TextObjectBase Class See Also Send Feedback
Finds the specified text inside the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CharacterRange[] SearchText(
    string text,
    bool matchCase,
    bool wholeWord
)
Visual Basic (Declaration)
Public Function SearchText ( _
    text As String, _
    matchCase As Boolean, _
    wholeWord As Boolean _
) As CharacterRange()
Visual C++
public:
virtual array<CharacterRange>^ SearchText(
    String^ text,
    bool matchCase,
    bool wholeWord
) sealed

Parameters

text
Type: System..::.String
Text to find.
matchCase
Type: System..::.Boolean
true to perform case-sensitive search.
wholeWord
Type: System..::.Boolean
true to find whole words only.

Return Value

Array of character ranges that describes the occurences of text found; null if text not found.

Implements

ISearchable..::.SearchText(String, Boolean, Boolean)

See Also

TextObjectBase Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TextObjectBase..::.Serialize Method
TextObjectBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TextObjectBase Class
FastReport Namespace


TextObjectBase Properties

[image] [image]

FastReport.Net Class Reference
TextObjectBase Properties
TextObjectBase Class See Also Send Feedback

The TextObjectBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions.
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text.
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Duplicates | Gets or sets a value that determines how to display duplicate values.
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Format | Gets or sets the formatter that will be used to format data in the Text object.
Formats | Gets the collection of formatters.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideValue | Gets or sets a value that will be hidden.
HideZeros | Gets or sets a value indicating that zero values must be hidden.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Text | Gets or sets the object's text.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Value | Gets a value of expression contained in the object's text.
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TextObjectBase Class
FastReport Namespace


AllowExpressions Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.AllowExpressions Property
TextObjectBase Class See Also Send Feedback
Gets or sets a value indicating that the object's text may contain expressions.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowExpressions { get; set; }
Visual Basic (Declaration)
Public Property AllowExpressions As Boolean
Visual C++
public:
property bool AllowExpressions {
    bool get ();
    void set (bool value);
}

See Also

TextObjectBase Class
FastReport Namespace


Brackets Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Brackets Property
TextObjectBase Class See Also Send Feedback
Gets or sets the symbols that will be used to find expressions in the object's text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Brackets { get; set; }
Visual Basic (Declaration)
Public Property Brackets As String
Visual C++
public:
property String^ Brackets {
    String^ get ();
    void set (String^ value);
}

Remarks

The default property value is "[,]". As you can see, the open and close symbols are separated by the comma. You may use another symbols, for example: "<,>" or "<%,%>". You should use different open and close symbols.

See Also

TextObjectBase Class
FastReport Namespace


Duplicates Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Duplicates Property
TextObjectBase Class See Also Send Feedback
Gets or sets a value that determines how to display duplicate values.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Duplicates Duplicates { get; set; }
Visual Basic (Declaration)
Public Property Duplicates As Duplicates
Visual C++
public:
property Duplicates Duplicates {
    Duplicates get ();
    void set (Duplicates value);
}

See Also

TextObjectBase Class
FastReport Namespace


Format Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Format Property
TextObjectBase Class Example See Also Send Feedback
Gets or sets the formatter that will be used to format data in the Text object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FormatBase Format { get; set; }
Visual Basic (Declaration)
Public Property Format As FormatBase
Visual C++
public:
property FormatBase^ Format {
    FormatBase^ get ();
    void set (FormatBase^ value);
}

Remarks

The default formatter does nothing, i.e. it shows expression values with no formatting. To set another formatting, create a new formatter and assign it to this property.

If there are several expressions in the text, use the Formats property to format each expression value.

Examples

This example shows how to set currency formatter.
CopyC#
TextObject text1;
text1.Format = new CurrencyFormat();

See Also

TextObjectBase Class
FastReport Namespace


Formats Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Formats Property
TextObjectBase Class See Also Send Feedback
Gets the collection of formatters.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FormatCollection Formats { get; }
Visual Basic (Declaration)
Public ReadOnly Property Formats As FormatCollection
Visual C++
public:
property FormatCollection^ Formats {
    FormatCollection^ get ();
}

Remarks

This property is used to set format for each expression contained in the text. For example, if the TextObject contains two expressions:

Today is [Date]; Page [PageN]

you can use the following code to format these expressions separately:

CopyC#
text1.Formats.Clear();
text1.Formats.Add(new DateFormat());
text1.Formats.Add(new NumberFormat());

See Also

TextObjectBase Class
FastReport Namespace


HideValue Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.HideValue Property
TextObjectBase Class See Also Send Feedback
Gets or sets a value that will be hidden.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string HideValue { get; set; }
Visual Basic (Declaration)
Public Property HideValue As String
Visual C++
public:
property String^ HideValue {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property to specify a value that you would like to hide. For example, specify "0" if you want to hide zero values, or use HideZeros property to do this.

You also may use this property to hide default DateTime values (such as 1/1/1900). In this case you need to specify a string containing both date and time, for example: "1/1/1900 0:00:00".

Note: FastReport uses the ToString conversion to compare the expression value with this property. This conversion depends on regional settings selected in the Control Panel, so be aware of this if you going to distribute your report worldwide.

See Also

TextObjectBase Class
FastReport Namespace


HideZeros Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.HideZeros Property
TextObjectBase Class See Also Send Feedback
Gets or sets a value indicating that zero values must be hidden.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideZeros { get; set; }
Visual Basic (Declaration)
Public Property HideZeros As Boolean
Visual C++
public:
property bool HideZeros {
    bool get ();
    void set (bool value);
}

See Also

TextObjectBase Class
FastReport Namespace


NullValue Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.NullValue Property
TextObjectBase Class See Also Send Feedback
Gets or sets a string that will be displayed instead of a null value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string NullValue { get; set; }
Visual Basic (Declaration)
Public Property NullValue As String
Visual C++
public:
property String^ NullValue {
    String^ get ();
    void set (String^ value);
}

See Also

TextObjectBase Class
FastReport Namespace


Padding Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Padding Property
TextObjectBase Class See Also Send Feedback
Gets or sets padding within the text object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

TextObjectBase Class
FastReport Namespace


ProcessAt Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.ProcessAt Property
TextObjectBase Class See Also Send Feedback
Gets or sets a value that specifies how the report engine processes this text object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ProcessAt ProcessAt { get; set; }
Visual Basic (Declaration)
Public Property ProcessAt As ProcessAt
Visual C++
public:
property ProcessAt ProcessAt {
    ProcessAt get ();
    void set (ProcessAt value);
}

Remarks

Use this property to perform such task as "print a total value in the group header". Normally, all total values are calculated in the footers (for example, in a group footer). If you try to print a total value in the group header, you will get 0. If you set this property to ProcessAt.DataFinished, FastReport will do the following:
  • print the object (with wrong value);
  • print all related data rows;
  • calculate the correct object's value and replace old (wrong) value with the new one.
Note: This option will not work if you set the UseFileCache to true.

See Also

TextObjectBase Class
FastReport Namespace


Text Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Text Property
TextObjectBase Class See Also Send Feedback
Gets or sets the object's text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string Text { get; set; }
Visual Basic (Declaration)
Public Overridable Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

Text may contain expressions and data items, for example: "Today is [Date]". When report is running, all expressions are calculated and replaced with actual values, so the text would be "Today is 01.01.2008".

See Also

TextObjectBase Class
FastReport Namespace


Value Property

[image]

FastReport.Net Class Reference
TextObjectBase..::.Value Property
TextObjectBase Class See Also Send Feedback
Gets a value of expression contained in the object's text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

TextObjectBase Class
FastReport Namespace


TextObjectBase Events

[image] [image]

FastReport.Net Class Reference
TextObjectBase Events
TextObjectBase Class See Also Send Feedback

The TextObjectBase type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TextObjectBase Class
FastReport Namespace


TextObjectBaseMenu Class

[image]

FastReport.Net Class Reference
TextObjectBaseMenu Class
Members See Also Send Feedback
The class introduces some menu items specific to the TextObjectBase.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextObjectBaseMenu : BreakableComponentMenu
Visual Basic (Declaration)
Public Class TextObjectBaseMenu _
    Inherits BreakableComponentMenu
Visual C++
public ref class TextObjectBaseMenu : public BreakableComponentMenu

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
ContextMenuBar
FastReport..::.ComponentMenuBase
FastReport..::.ReportComponentBaseMenu
FastReport..::.BreakableComponentMenu
FastReport..::.TextObjectBaseMenu
FastReport..::.TextObjectMenu

See Also

TextObjectBaseMenu Members
FastReport Namespace


TextObjectBaseMenu Members

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu Members
TextObjectBaseMenu Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextObjectBaseMenu type exposes the following members.

Constructors

Name | Description
TextObjectBaseMenu | Initializes a new instance of the TextObjectBaseMenu class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miAllowExpressions | The "Allow Expressions" menu item.
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanBreak | The "Can Break" menu item. (Inherited from BreakableComponentMenu.)
miCanGrow | The "Can Grow" menu item. (Inherited from ReportComponentBaseMenu.)
miCanShrink | The "Can Shrink" menu item. (Inherited from ReportComponentBaseMenu.)
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miFormat | The "Format" menu item.
miGrowToBottom | The "Grow to Bottom" menu item. (Inherited from ReportComponentBaseMenu.)
miHyperlink | The "Hyperlink" menu item. (Inherited from ReportComponentBaseMenu.)
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
FastReport Namespace


TextObjectBaseMenu Constructor

[image]

FastReport.Net Class Reference
TextObjectBaseMenu Constructor
TextObjectBaseMenu Class See Also Send Feedback
Initializes a new instance of the TextObjectBaseMenu class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextObjectBaseMenu(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
TextObjectBaseMenu(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The reference to a report designer.

See Also

TextObjectBaseMenu Class
FastReport Namespace


TextObjectBaseMenu Fields

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu Fields
TextObjectBaseMenu Class See Also Send Feedback

The TextObjectBaseMenu type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miAllowExpressions | The "Allow Expressions" menu item.
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanBreak | The "Can Break" menu item. (Inherited from BreakableComponentMenu.)
miCanGrow | The "Can Grow" menu item. (Inherited from ReportComponentBaseMenu.)
miCanShrink | The "Can Shrink" menu item. (Inherited from ReportComponentBaseMenu.)
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miFormat | The "Format" menu item.
miGrowToBottom | The "Grow to Bottom" menu item. (Inherited from ReportComponentBaseMenu.)
miHyperlink | The "Hyperlink" menu item. (Inherited from ReportComponentBaseMenu.)
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)

See Also

TextObjectBaseMenu Class
FastReport Namespace


miAllowExpressions Field

[image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.miAllowExpressions Field
TextObjectBaseMenu Class See Also Send Feedback
The "Allow Expressions" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miAllowExpressions
Visual Basic (Declaration)
Public miAllowExpressions As ButtonItem
Visual C++
public:
ButtonItem^ miAllowExpressions

See Also

TextObjectBaseMenu Class
FastReport Namespace


miFormat Field

[image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.miFormat Field
TextObjectBaseMenu Class See Also Send Feedback
The "Format" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFormat
Visual Basic (Declaration)
Public miFormat As ButtonItem
Visual C++
public:
ButtonItem^ miFormat

See Also

TextObjectBaseMenu Class
FastReport Namespace


TextObjectBaseMenu Methods

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu Methods
TextObjectBaseMenu Class See Also Send Feedback

The TextObjectBaseMenu type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
FastReport Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.AccessibilityNotifyClients Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.BeginInvoke Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.CloseDockTab Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


CreateMenuItem Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.CreateMenuItem Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
CreateMenuItem(String) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(Image, String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.Dispose Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.GetChildAtPoint Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.GetItems Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.Invalidate Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.Invoke Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.MemberwiseClone Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.PerformLayout Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.ResumeLayout Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.RtlTranslateAlignment Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.Scale Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.Select Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.SetBounds Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.SetSize Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu..::.UpdateBounds Method
TextObjectBaseMenu Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
TextObjectBaseMenu Members
FastReport Namespace


TextObjectBaseMenu Properties

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu Properties
TextObjectBaseMenu Class See Also Send Feedback

The TextObjectBaseMenu type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

TextObjectBaseMenu Class
FastReport Namespace


TextObjectBaseMenu Events

[image] [image]

FastReport.Net Class Reference
TextObjectBaseMenu Events
TextObjectBaseMenu Class See Also Send Feedback

The TextObjectBaseMenu type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextObjectBaseMenu Class
FastReport Namespace


TextObjectMenu Class

[image]

FastReport.Net Class Reference
TextObjectMenu Class
Members See Also Send Feedback
The class introduces some menu items specific to the TextObject.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextObjectMenu : TextObjectBaseMenu
Visual Basic (Declaration)
Public Class TextObjectMenu _
    Inherits TextObjectBaseMenu
Visual C++
public ref class TextObjectMenu : public TextObjectBaseMenu

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
ContextMenuBar
FastReport..::.ComponentMenuBase
FastReport..::.ReportComponentBaseMenu
FastReport..::.BreakableComponentMenu
FastReport..::.TextObjectBaseMenu
FastReport..::.TextObjectMenu

See Also

TextObjectMenu Members
FastReport Namespace


TextObjectMenu Members

[image] [image]

FastReport.Net Class Reference
TextObjectMenu Members
TextObjectMenu Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextObjectMenu type exposes the following members.

Constructors

Name | Description
TextObjectMenu | Initializes a new instance of the TextObjectMenu class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miAllowExpressions | The "Allow Expressions" menu item. (Inherited from TextObjectBaseMenu.)
miAutoWidth | The "Auto Width" menu item.
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanBreak | The "Can Break" menu item. (Inherited from BreakableComponentMenu.)
miCanGrow | The "Can Grow" menu item. (Inherited from ReportComponentBaseMenu.)
miCanShrink | The "Can Shrink" menu item. (Inherited from ReportComponentBaseMenu.)
miClear | The "Clear" menu item.
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miFormat | The "Format" menu item. (Inherited from TextObjectBaseMenu.)
miGrowToBottom | The "Grow to Bottom" menu item. (Inherited from ReportComponentBaseMenu.)
miHyperlink | The "Hyperlink" menu item. (Inherited from ReportComponentBaseMenu.)
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)
miWordWrap | The "Word Wrap" menu item.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextObjectMenu Class
FastReport Namespace


TextObjectMenu Constructor

[image]

FastReport.Net Class Reference
TextObjectMenu Constructor
TextObjectMenu Class See Also Send Feedback
Initializes a new instance of the TextObjectMenu class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextObjectMenu(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
TextObjectMenu(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The reference to a report designer.

See Also

TextObjectMenu Class
FastReport Namespace


TextObjectMenu Fields

[image] [image]

FastReport.Net Class Reference
TextObjectMenu Fields
TextObjectMenu Class See Also Send Feedback

The TextObjectMenu type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miAllowExpressions | The "Allow Expressions" menu item. (Inherited from TextObjectBaseMenu.)
miAutoWidth | The "Auto Width" menu item.
miBringToFront | The "BringToFront" menu item. (Inherited from ComponentMenuBase.)
miCanBreak | The "Can Break" menu item. (Inherited from BreakableComponentMenu.)
miCanGrow | The "Can Grow" menu item. (Inherited from ReportComponentBaseMenu.)
miCanShrink | The "Can Shrink" menu item. (Inherited from ReportComponentBaseMenu.)
miClear | The "Clear" menu item.
miCopy | The "Copy" menu item. (Inherited from ComponentMenuBase.)
miCut | The "Cut" menu item. (Inherited from ComponentMenuBase.)
miDelete | The "Delete" menu item. (Inherited from ComponentMenuBase.)
miEdit | The "Edit" menu item. (Inherited from ComponentMenuBase.)
miFormat | The "Format" menu item. (Inherited from TextObjectBaseMenu.)
miGrowToBottom | The "Grow to Bottom" menu item. (Inherited from ReportComponentBaseMenu.)
miHyperlink | The "Hyperlink" menu item. (Inherited from ReportComponentBaseMenu.)
miName | The "Name" menu item. (Inherited from ComponentMenuBase.)
miPaste | The "Paste" menu item. (Inherited from ComponentMenuBase.)
miSendToBack | The "SendToBack" menu item. (Inherited from ComponentMenuBase.)
miWordWrap | The "Word Wrap" menu item.

See Also

TextObjectMenu Class
FastReport Namespace


miAutoWidth Field

[image]

FastReport.Net Class Reference
TextObjectMenu..::.miAutoWidth Field
TextObjectMenu Class See Also Send Feedback
The "Auto Width" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miAutoWidth
Visual Basic (Declaration)
Public miAutoWidth As ButtonItem
Visual C++
public:
ButtonItem^ miAutoWidth

See Also

TextObjectMenu Class
FastReport Namespace


miClear Field

[image]

FastReport.Net Class Reference
TextObjectMenu..::.miClear Field
TextObjectMenu Class See Also Send Feedback
The "Clear" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miClear
Visual Basic (Declaration)
Public miClear As ButtonItem
Visual C++
public:
ButtonItem^ miClear

See Also

TextObjectMenu Class
FastReport Namespace


miWordWrap Field

[image]

FastReport.Net Class Reference
TextObjectMenu..::.miWordWrap Field
TextObjectMenu Class See Also Send Feedback
The "Word Wrap" menu item.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miWordWrap
Visual Basic (Declaration)
Public miWordWrap As ButtonItem
Visual C++
public:
ButtonItem^ miWordWrap

See Also

TextObjectMenu Class
FastReport Namespace


TextObjectMenu Methods

[image] [image]

FastReport.Net Class Reference
TextObjectMenu Methods
TextObjectMenu Class See Also Send Feedback

The TextObjectMenu type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Change | This method is called to reflect changes in the designer. (Inherited from ComponentMenuBase.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetContextMenuEx | (Inherited from ContextMenuBar.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from ContextMenuBar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenuEx | (Inherited from ContextMenuBar.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

TextObjectMenu Class
FastReport Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.AccessibilityNotifyClients Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.BeginInvoke Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.CloseDockTab Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


CreateMenuItem Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.CreateMenuItem Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
CreateMenuItem(String) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)
CreateMenuItem(Image, String, EventHandler) | Creates a new menu item. (Inherited from ComponentMenuBase.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.Dispose Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.GetChildAtPoint Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.GetItems Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.Invalidate Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.Invoke Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.MemberwiseClone Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.PerformLayout Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.ResumeLayout Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.RtlTranslateAlignment Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.Scale Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.Select Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.SetBounds Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.SetSize Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
TextObjectMenu..::.UpdateBounds Method
TextObjectMenu Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TextObjectMenu Class
TextObjectMenu Members
FastReport Namespace


TextObjectMenu Properties

[image] [image]

FastReport.Net Class Reference
TextObjectMenu Properties
TextObjectMenu Class See Also Send Feedback

The TextObjectMenu type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | The reference to the report designer. (Inherited from ComponentMenuBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | Gets a collection of menu items. (Inherited from ComponentMenuBase.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from ContextMenuBar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

TextObjectMenu Class
FastReport Namespace


TextObjectMenu Events

[image] [image]

FastReport.Net Class Reference
TextObjectMenu Events
TextObjectMenu Class See Also Send Feedback

The TextObjectMenu type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextObjectMenu Class
FastReport Namespace


TextQuality Enumeration

[image]

FastReport.Net Class Reference
TextQuality Enumeration
See Also Send Feedback
Specifies the quality of text rendering.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum TextQuality
Visual Basic (Declaration)
Public Enumeration TextQuality
Visual C++
public enum class TextQuality

Members

Member name | Description
Default | The default text quality, depends on system settings.
Regular | The regular quality.
ClearType | The "ClearType" quality.
AntiAlias | The AntiAlias quality. This mode may be used to produce the WYSIWYG text.

See Also

FastReport Namespace


UncheckedSymbol Enumeration

[image]

FastReport.Net Class Reference
UncheckedSymbol Enumeration
See Also Send Feedback
Specifies a symbol that will be displayed when a CheckBoxObject is in the unchecked state.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum UncheckedSymbol
Visual Basic (Declaration)
Public Enumeration UncheckedSymbol
Visual C++
public enum class UncheckedSymbol

Members

Member name | Description
None | Specifies no symbol.
Cross | Specifies a diagonal cross symbol.
Minus | Specifies a minus symbol.

See Also

FastReport Namespace


Variant Structure

[image]

FastReport.Net Class Reference
Variant Structure
Members See Also Send Feedback
A strongly typed object that readily casts an intrinsic object to the other intrinsic types when possible.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public struct Variant : IConvertible
Visual Basic (Declaration)
Public Structure Variant _
    Implements IConvertible
Visual C++
public value class Variant : IConvertible

Remarks

The Variant class is an intrinsic object container structure inspired by Visual Basic 6.0's Variant. The key features of a Variant class include the ability to perform typecasts and arithmetic between types that are not normally considered compatible. For example, if a Variant class contains a string describing a number, such as "1.1", then floating point arithmetic can be performed on it.

Variants are normally considered dangerous because they strip away the effectiveness of type safety, which is the reason why the Visual Basic 6.0 Variant was left out of Visual Basic .NET. However, this implementation restores the Variant structure, both as a proof of concept and as a restoration of the utility and positive merits of the Variant where it can be used responsibly.

See Also

Variant Members
FastReport Namespace


Variant Members

[image] [image]

FastReport.Net Class Reference
Variant Members
Variant Structure Constructors Methods Properties See Also Send Feedback

The Variant type exposes the following members.

Constructors

Name | Description
Variant | Creates a strongly typed object that readily casts a primitive object to the other primitive types when possible.

Methods

Name | Description
CBln | Converts an object to a boolean. For any type, if null, returns false. For Boolean: true/false. For String: "", "false", "0", etc. == false; "1", "true", etc. == true, else true. For numeric intrinsics: 0 == false, else true. For any other non-null object, returns true.
Equals | See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeCode | Returns the TypeCode for this instance.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToBoolean | Overloaded.
ToByte | Overloaded.
ToChar | Overloaded.
ToDateTime | Overloaded.
ToDecimal | Overloaded.
ToDouble | Overloaded.
ToInt16 | Overloaded.
ToInt32 | Overloaded.
ToInt64 | Overloaded.
ToSByte | Overloaded.
ToSingle | Overloaded.
ToString | Overloaded.
ToTimeSpan | Overloaded.
ToType | Overloaded.
ToUInt16 | Overloaded.
ToUInt32 | Overloaded.
ToUInt64 | Overloaded.

Operators

Name | Description
Addition | Addition operator.
BitwiseAnd | Bitwise And operator.
BitwiseOr | Bitwise Or operator.
Division | Division operator.
Equality | Overloaded.
GreaterThan | Greater than operator.
GreaterThanOrEqual | Greater than or equal operator.
Implicit | Overloaded.
Inequality | Overloaded.
LessThan | Less than operator.
LessThanOrEqual | Less than or equal operator.
Modulus | Modulus operator.
Multiply | Multiplication operator.
Subtraction | Subtraction operator.
UnaryNegation | Unary minus operator.

Properties

Name | Description
ImplementsIConvertible | Returns true if the Value property implements IConvertible
IsDate | Returns true if the value is a date or can be parsed into a date.
IsNumberable | Returns true if the Value property is a numeric intrinsic value or else can be parsed into a numeric intrinsic value.
IsNumeric | Returns true if the Value property is a numeric intrinsic value.
IsTimeSpan | Returns true if the value is a TimeSpan.
Type | The Type of the Value property.
Value | The actual value being stored in its original Type, returned as an Object.

See Also

Variant Structure
FastReport Namespace


Variant Constructor

[image]

FastReport.Net Class Reference
Variant Constructor
Variant Structure See Also Send Feedback
Creates a strongly typed object that readily casts a primitive object to the other primitive types when possible.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Variant(
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object _
)
Visual C++
public:
Variant(
    Object^ value
)

Parameters

value
Type: System..::.Object

See Also

Variant Structure
FastReport Namespace


Variant Methods

[image] [image]

FastReport.Net Class Reference
Variant Methods
Variant Structure See Also Send Feedback

The Variant type exposes the following members.

Methods

Name | Description
CBln | Converts an object to a boolean. For any type, if null, returns false. For Boolean: true/false. For String: "", "false", "0", etc. == false; "1", "true", etc. == true, else true. For numeric intrinsics: 0 == false, else true. For any other non-null object, returns true.
Equals | See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeCode | Returns the TypeCode for this instance.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToBoolean | Overloaded.
ToByte | Overloaded.
ToChar | Overloaded.
ToDateTime | Overloaded.
ToDecimal | Overloaded.
ToDouble | Overloaded.
ToInt16 | Overloaded.
ToInt32 | Overloaded.
ToInt64 | Overloaded.
ToSByte | Overloaded.
ToSingle | Overloaded.
ToString | Overloaded.
ToTimeSpan | Overloaded.
ToType | Overloaded.
ToUInt16 | Overloaded.
ToUInt32 | Overloaded.
ToUInt64 | Overloaded.

Operators

Name | Description
Addition | Addition operator.
BitwiseAnd | Bitwise And operator.
BitwiseOr | Bitwise Or operator.
Division | Division operator.
Equality | Overloaded.
GreaterThan | Greater than operator.
GreaterThanOrEqual | Greater than or equal operator.
Implicit | Overloaded.
Inequality | Overloaded.
LessThan | Less than operator.
LessThanOrEqual | Less than or equal operator.
Modulus | Modulus operator.
Multiply | Multiplication operator.
Subtraction | Subtraction operator.
UnaryNegation | Unary minus operator.

See Also

Variant Structure
FastReport Namespace


Addition Operator

[image]

FastReport.Net Class Reference
Variant..::.Addition Operator
Variant Structure See Also Send Feedback
Addition operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator +(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator +(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right is a String or a Char, the Variant is converted to a string and appended. If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


BitwiseAnd Operator

[image]

FastReport.Net Class Reference
Variant..::.BitwiseAnd Operator
Variant Structure See Also Send Feedback
Bitwise And operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator &(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator And ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator &(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


BitwiseOr Operator

[image]

FastReport.Net Class Reference
Variant..::.BitwiseOr Operator
Variant Structure See Also Send Feedback
Bitwise Or operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator |(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator Or ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator |(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


CBln Method

[image]

FastReport.Net Class Reference
Variant..::.CBln Method
Variant Structure See Also Send Feedback
Converts an object to a boolean. For any type, if null, returns false. For Boolean: true/false. For String: "", "false", "0", etc. == false; "1", "true", etc. == true, else true. For numeric intrinsics: 0 == false, else true. For any other non-null object, returns true.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool CBln(
    Object bln
)
Visual Basic (Declaration)
Public Shared Function CBln ( _
    bln As Object _
) As Boolean
Visual C++
public:
static bool CBln(
    Object^ bln
)

Parameters

bln
Type: System..::.Object
The string to be converted

Return Value

The boolean value of this string.

See Also

Variant Structure
FastReport Namespace


Division Operator

[image]

FastReport.Net Class Reference
Variant..::.Division Operator
Variant Structure See Also Send Feedback
Division operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator /(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator /(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


Equality Method

[image] [image]

FastReport.Net Class Reference
Variant..::.Equality Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
Equality(Variant, Object) | Equality operator. First attempts to compare the left value after temporarily converting it to the type of the right value. If the conversion cannot occur, such as if the value is not an intrinsic value type, the comparison occurs at the Object level using Object.Equals.
Equality(Variant, String) | Equality operator.

See Also

Variant Structure
Variant Members
FastReport Namespace


Equality Operator

[image]

FastReport.Net Class Reference
Variant..::.Equality Operator
Variant Structure See Also Send Feedback

Equality operator.

First attempts to compare the left value after temporarily converting it to the type of the right value. If the conversion cannot occur, such as if the value is not an intrinsic value type, the comparison occurs at the Object level using Object.Equals.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator ==(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    subjectVariant As Variant, _
    value As Object _
) As Boolean
Visual C++
public:
static bool operator ==(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

See Also

Variant Structure
Equality Overload
FastReport Namespace


Equality Operator

[image]

FastReport.Net Class Reference
Variant..::.Equality Operator
Variant Structure See Also Send Feedback

Equality operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator ==(
    Variant subjectVariant,
    string value
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    subjectVariant As Variant, _
    value As String _
) As Boolean
Visual C++
public:
static bool operator ==(
    Variant subjectVariant,
    String^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.String

Return Value

See Also

Variant Structure
Equality Overload
FastReport Namespace


Equals Method

[image]

FastReport.Net Class Reference
Variant..::.Equals Method
Variant Structure See Also Send Feedback
See Equals(Object).

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

Return Value

See Also

Variant Structure
FastReport Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
Variant..::.GetHashCode Method
Variant Structure See Also Send Feedback
See GetHashCode()()().

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

See Also

Variant Structure
FastReport Namespace


GetTypeCode Method

[image]

FastReport.Net Class Reference
Variant..::.GetTypeCode Method
Variant Structure See Also Send Feedback
Returns the TypeCode for this instance.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TypeCode GetTypeCode()
Visual Basic (Declaration)
Public Function GetTypeCode As TypeCode
Visual C++
public:
virtual TypeCode GetTypeCode() sealed

Return Value

The enumerated constant that is the TypeCode of the class or value type that implements this interface.

Implements

IConvertible..::.GetTypeCode()()()

See Also

Variant Structure
FastReport Namespace


GreaterThan Operator

[image]

FastReport.Net Class Reference
Variant..::.GreaterThan Operator
Variant Structure See Also Send Feedback
Greater than operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator >(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    subjectVariant As Variant, _
    value As Object _
) As Boolean
Visual C++
public:
static bool operator >(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

See Also

Variant Structure
FastReport Namespace


GreaterThanOrEqual Operator

[image]

FastReport.Net Class Reference
Variant..::.GreaterThanOrEqual Operator
Variant Structure See Also Send Feedback
Greater than or equal operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator >=(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    subjectVariant As Variant, _
    value As Object _
) As Boolean
Visual C++
public:
static bool operator >=(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

See Also

Variant Structure
FastReport Namespace


Implicit Method

[image] [image]

FastReport.Net Class Reference
Variant..::.Implicit Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Variant) |
Implicit(Boolean) |
Implicit(Byte) |
Implicit(Char) |
Implicit(DateTime) |
Implicit(Decimal) |
Implicit(Double) |
Implicit(Int16) |
Implicit(Int32) |
Implicit(Int64) |
Implicit(SByte) |
Implicit(Single) |
Implicit(String) |
Implicit(UInt16) |
Implicit(UInt32) |
Implicit(UInt64) |

See Also

Variant Structure
Variant Members
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator short (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Short
Visual C++
static implicit operator short (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator double (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Double
Visual C++
static implicit operator double (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator ushort (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As UShort
Visual C++
static implicit operator unsigned short (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator DateTime (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As DateTime
Visual C++
static implicit operator DateTime (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator char (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Char
Visual C++
static implicit operator wchar_t (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator byte (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Byte
Visual C++
static implicit operator unsigned char (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator sbyte (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As SByte
Visual C++
static implicit operator signed char (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator bool (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Boolean
Visual C++
static implicit operator bool (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator long (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Long
Visual C++
static implicit operator long long (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator decimal (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Decimal
Visual C++
static implicit operator Decimal (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator ulong (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As ULong
Visual C++
static implicit operator unsigned long long (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator float (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Single
Visual C++
static implicit operator float (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator string (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As String
Visual C++
static implicit operator String^ (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator int (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As Integer
Visual C++
static implicit operator int (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator uint (
    Variant v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Variant _
) As UInteger
Visual C++
static implicit operator unsigned int (
    Variant v
)

Parameters

v
Type: FastReport..::.Variant

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    bool v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Boolean _
) As Variant
Visual C++
static implicit operator Variant (
    bool v
)

Parameters

v
Type: System..::.Boolean

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    byte v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Byte _
) As Variant
Visual C++
static implicit operator Variant (
    unsigned char v
)

Parameters

v
Type: System..::.Byte

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    char v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Char _
) As Variant
Visual C++
static implicit operator Variant (
    wchar_t v
)

Parameters

v
Type: System..::.Char

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    DateTime v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As DateTime _
) As Variant
Visual C++
static implicit operator Variant (
    DateTime v
)

Parameters

v
Type: System..::.DateTime

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    decimal v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Decimal _
) As Variant
Visual C++
static implicit operator Variant (
    Decimal v
)

Parameters

v
Type: System..::.Decimal

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    double v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Double _
) As Variant
Visual C++
static implicit operator Variant (
    double v
)

Parameters

v
Type: System..::.Double

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    short v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Short _
) As Variant
Visual C++
static implicit operator Variant (
    short v
)

Parameters

v
Type: System..::.Int16

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    int v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Integer _
) As Variant
Visual C++
static implicit operator Variant (
    int v
)

Parameters

v
Type: System..::.Int32

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    long v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Long _
) As Variant
Visual C++
static implicit operator Variant (
    long long v
)

Parameters

v
Type: System..::.Int64

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    sbyte v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As SByte _
) As Variant
Visual C++
static implicit operator Variant (
    signed char v
)

Parameters

v
Type: System..::.SByte

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    float v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As Single _
) As Variant
Visual C++
static implicit operator Variant (
    float v
)

Parameters

v
Type: System..::.Single

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    string v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As String _
) As Variant
Visual C++
static implicit operator Variant (
    String^ v
)

Parameters

v
Type: System..::.String

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    ushort v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As UShort _
) As Variant
Visual C++
static implicit operator Variant (
    unsigned short v
)

Parameters

v
Type: System..::.UInt16

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    uint v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As UInteger _
) As Variant
Visual C++
static implicit operator Variant (
    unsigned int v
)

Parameters

v
Type: System..::.UInt32

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Implicit Operator

[image]

FastReport.Net Class Reference
Variant..::.Implicit Operator
Variant Structure See Also Send Feedback

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static implicit operator Variant (
    ulong v
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    v As ULong _
) As Variant
Visual C++
static implicit operator Variant (
    unsigned long long v
)

Parameters

v
Type: System..::.UInt64

See Also

Variant Structure
Implicit Overload
FastReport Namespace


Inequality Method

[image] [image]

FastReport.Net Class Reference
Variant..::.Inequality Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
Inequality(Variant, Object) | Inequality operator.
Inequality(Variant, String) | Equality operator.

See Also

Variant Structure
Variant Members
FastReport Namespace


Inequality Operator

[image]

FastReport.Net Class Reference
Variant..::.Inequality Operator
Variant Structure See Also Send Feedback
Inequality operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator !=(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    subjectVariant As Variant, _
    value As Object _
) As Boolean
Visual C++
public:
static bool operator !=(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

The opposite of ==

See Also

Variant Structure
Inequality Overload
FastReport Namespace


Inequality Operator

[image]

FastReport.Net Class Reference
Variant..::.Inequality Operator
Variant Structure See Also Send Feedback

Equality operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator !=(
    Variant subjectVariant,
    string value
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    subjectVariant As Variant, _
    value As String _
) As Boolean
Visual C++
public:
static bool operator !=(
    Variant subjectVariant,
    String^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.String

Return Value

See Also

Variant Structure
Inequality Overload
FastReport Namespace


LessThan Operator

[image]

FastReport.Net Class Reference
Variant..::.LessThan Operator
Variant Structure See Also Send Feedback
Less than operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator <(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    subjectVariant As Variant, _
    value As Object _
) As Boolean
Visual C++
public:
static bool operator <(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

See Also

Variant Structure
FastReport Namespace


LessThanOrEqual Operator

[image]

FastReport.Net Class Reference
Variant..::.LessThanOrEqual Operator
Variant Structure See Also Send Feedback
Less than or equal operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool operator <=(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    subjectVariant As Variant, _
    value As Object _
) As Boolean
Visual C++
public:
static bool operator <=(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

See Also

Variant Structure
FastReport Namespace


Modulus Operator

[image]

FastReport.Net Class Reference
Variant..::.Modulus Operator
Variant Structure See Also Send Feedback
Modulus operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator %(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator Mod ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator %(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


Multiply Operator

[image]

FastReport.Net Class Reference
Variant..::.Multiply Operator
Variant Structure See Also Send Feedback
Multiplication operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator *(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator *(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


Subtraction Operator

[image]

FastReport.Net Class Reference
Variant..::.Subtraction Operator
Variant Structure See Also Send Feedback
Subtraction operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator -(
    Variant subjectVariant,
    Object value
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    subjectVariant As Variant, _
    value As Object _
) As Variant
Visual C++
public:
static Variant operator -(
    Variant subjectVariant,
    Object^ value
)

Parameters

subjectVariant
Type: FastReport..::.Variant
value
Type: System..::.Object

Return Value

A new Variant containing the resulting value.

Remarks

If the value on the right or the Variant is a DateTime, arithmetic is performed on the Ticks property and the resulting value is set to the DateTime type. Otherwise, if the value on the right is a number, both the Variant and the value on the right are converted to a Double, the arithmetic is performed, and the resulting value is converted back to the original type that the Variant previously represented. If the type that the Variant previously represented cannot contain the resulting value--such as if the type is a UInt32 and the value is -12--then the type will be converted to a type that can contain the value, such as Int32.

See Also

Variant Structure
FastReport Namespace


ToBoolean Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToBoolean Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToBoolean()()() | If Value is a Boolean, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Boolean value.
ToBoolean(IFormatProvider) | If Value is a Boolean, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Boolean value using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToBoolean Method

[image]

FastReport.Net Class Reference
Variant..::.ToBoolean Method
Variant Structure See Also Send Feedback
If Value is a Boolean, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Boolean value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ToBoolean()
Visual Basic (Declaration)
Public Function ToBoolean As Boolean
Visual C++
public:
bool ToBoolean()

See Also

Variant Structure
ToBoolean Overload
FastReport Namespace


ToBoolean Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToBoolean Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Boolean, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Boolean value using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ToBoolean(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToBoolean ( _
    formatProvider As IFormatProvider _
) As Boolean
Visual C++
public:
virtual bool ToBoolean(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToBoolean(IFormatProvider)

See Also

Variant Structure
ToBoolean Overload
FastReport Namespace


ToByte Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToByte Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToByte()()() | If Value is a Byte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit unsigned integer.
ToByte(IFormatProvider) | If Value is a Byte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit unsigned integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToByte Method

[image]

FastReport.Net Class Reference
Variant..::.ToByte Method
Variant Structure See Also Send Feedback
If Value is a Byte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit unsigned integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public byte ToByte()
Visual Basic (Declaration)
Public Function ToByte As Byte
Visual C++
public:
unsigned char ToByte()

See Also

Variant Structure
ToByte Overload
FastReport Namespace


ToByte Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToByte Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Byte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit unsigned integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public byte ToByte(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToByte ( _
    formatProvider As IFormatProvider _
) As Byte
Visual C++
public:
virtual unsigned char ToByte(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToByte(IFormatProvider)

See Also

Variant Structure
ToByte Overload
FastReport Namespace


ToChar Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToChar Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToChar()()() | If Value is a Char, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Unicode character.
ToChar(IFormatProvider) | If Value is a Char, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Unicode character using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToChar Method

[image]

FastReport.Net Class Reference
Variant..::.ToChar Method
Variant Structure See Also Send Feedback
If Value is a Char, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Unicode character.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public char ToChar()
Visual Basic (Declaration)
Public Function ToChar As Char
Visual C++
public:
wchar_t ToChar()

See Also

Variant Structure
ToChar Overload
FastReport Namespace


ToChar Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToChar Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Char, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Unicode character using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public char ToChar(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToChar ( _
    formatProvider As IFormatProvider _
) As Char
Visual C++
public:
virtual wchar_t ToChar(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToChar(IFormatProvider)

See Also

Variant Structure
ToChar Overload
FastReport Namespace


ToDateTime Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToDateTime Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToDateTime()()() | If Value is a DateTime, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent DateTime.
ToDateTime(IFormatProvider) | If Value is a DateTime, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent DateTime using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToDateTime Method

[image]

FastReport.Net Class Reference
Variant..::.ToDateTime Method
Variant Structure See Also Send Feedback
If Value is a DateTime, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent DateTime.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime ToDateTime()
Visual Basic (Declaration)
Public Function ToDateTime As DateTime
Visual C++
public:
DateTime ToDateTime()

See Also

Variant Structure
ToDateTime Overload
FastReport Namespace


ToDateTime Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToDateTime Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a DateTime, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent DateTime using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime ToDateTime(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToDateTime ( _
    formatProvider As IFormatProvider _
) As DateTime
Visual C++
public:
virtual DateTime ToDateTime(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToDateTime(IFormatProvider)

See Also

Variant Structure
ToDateTime Overload
FastReport Namespace


ToDecimal Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToDecimal Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToDecimal()()() | If Value is a Decimal, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Decimal number.
ToDecimal(IFormatProvider) | If Value is a Decimal, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Decimal number using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToDecimal Method

[image]

FastReport.Net Class Reference
Variant..::.ToDecimal Method
Variant Structure See Also Send Feedback
If Value is a Decimal, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Decimal number.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public decimal ToDecimal()
Visual Basic (Declaration)
Public Function ToDecimal As Decimal
Visual C++
public:
Decimal ToDecimal()

See Also

Variant Structure
ToDecimal Overload
FastReport Namespace


ToDecimal Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToDecimal Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Decimal, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent Decimal number using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public decimal ToDecimal(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToDecimal ( _
    formatProvider As IFormatProvider _
) As Decimal
Visual C++
public:
virtual Decimal ToDecimal(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToDecimal(IFormatProvider)

See Also

Variant Structure
ToDecimal Overload
FastReport Namespace


ToDouble Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToDouble Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToDouble()()() | If Value is a Double, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent double-precision floating-point number.
ToDouble(IFormatProvider) | If Value is a Double, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent double-precision floating-point number using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToDouble Method

[image]

FastReport.Net Class Reference
Variant..::.ToDouble Method
Variant Structure See Also Send Feedback
If Value is a Double, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent double-precision floating-point number.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double ToDouble()
Visual Basic (Declaration)
Public Function ToDouble As Double
Visual C++
public:
double ToDouble()

See Also

Variant Structure
ToDouble Overload
FastReport Namespace


ToDouble Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToDouble Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Double, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent double-precision floating-point number using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double ToDouble(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToDouble ( _
    formatProvider As IFormatProvider _
) As Double
Visual C++
public:
virtual double ToDouble(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToDouble(IFormatProvider)

See Also

Variant Structure
ToDouble Overload
FastReport Namespace


ToInt16 Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToInt16 Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToInt16()()() | If Value is a Int16, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit signed integer.
ToInt16(IFormatProvider) | If Value is a Boolean, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit signed integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToInt16 Method

[image]

FastReport.Net Class Reference
Variant..::.ToInt16 Method
Variant Structure See Also Send Feedback
If Value is a Int16, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit signed integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public short ToInt16()
Visual Basic (Declaration)
Public Function ToInt16 As Short
Visual C++
public:
short ToInt16()

See Also

Variant Structure
ToInt16 Overload
FastReport Namespace


ToInt16 Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToInt16 Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Boolean, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit signed integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public short ToInt16(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToInt16 ( _
    formatProvider As IFormatProvider _
) As Short
Visual C++
public:
virtual short ToInt16(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToInt16(IFormatProvider)

See Also

Variant Structure
ToInt16 Overload
FastReport Namespace


ToInt32 Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToInt32 Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToInt32()()() | If Value is a Int32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit signed integer.
ToInt32(IFormatProvider) | If Value is a Int32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit signed integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToInt32 Method

[image]

FastReport.Net Class Reference
Variant..::.ToInt32 Method
Variant Structure See Also Send Feedback
If Value is a Int32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit signed integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ToInt32()
Visual Basic (Declaration)
Public Function ToInt32 As Integer
Visual C++
public:
int ToInt32()

See Also

Variant Structure
ToInt32 Overload
FastReport Namespace


ToInt32 Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToInt32 Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Int32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit signed integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ToInt32(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToInt32 ( _
    formatProvider As IFormatProvider _
) As Integer
Visual C++
public:
virtual int ToInt32(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToInt32(IFormatProvider)

See Also

Variant Structure
ToInt32 Overload
FastReport Namespace


ToInt64 Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToInt64 Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToInt64()()() | If Value is a Int64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit signed integer.
ToInt64(IFormatProvider) | If Value is a Int64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit signed integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToInt64 Method

[image]

FastReport.Net Class Reference
Variant..::.ToInt64 Method
Variant Structure See Also Send Feedback
If Value is a Int64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit signed integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public long ToInt64()
Visual Basic (Declaration)
Public Function ToInt64 As Long
Visual C++
public:
long long ToInt64()

See Also

Variant Structure
ToInt64 Overload
FastReport Namespace


ToInt64 Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToInt64 Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Int64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit signed integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public long ToInt64(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToInt64 ( _
    formatProvider As IFormatProvider _
) As Long
Visual C++
public:
virtual long long ToInt64(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToInt64(IFormatProvider)

See Also

Variant Structure
ToInt64 Overload
FastReport Namespace


ToSByte Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToSByte Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToSByte()()() | If Value is a SByte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit signed integer.
ToSByte(IFormatProvider) | If Value is a SByte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit signed integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToSByte Method

[image]

FastReport.Net Class Reference
Variant..::.ToSByte Method
Variant Structure See Also Send Feedback
If Value is a SByte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit signed integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public sbyte ToSByte()
Visual Basic (Declaration)
Public Function ToSByte As SByte
Visual C++
public:
signed char ToSByte()

See Also

Variant Structure
ToSByte Overload
FastReport Namespace


ToSByte Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToSByte Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a SByte, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 8-bit signed integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public sbyte ToSByte(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToSByte ( _
    formatProvider As IFormatProvider _
) As SByte
Visual C++
public:
virtual signed char ToSByte(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToSByte(IFormatProvider)

See Also

Variant Structure
ToSByte Overload
FastReport Namespace


ToSingle Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToSingle Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToSingle()()() | If Value is a Single, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent single-precision floating-point number.
ToSingle(IFormatProvider) | If Value is a Single, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent single-precision floating-point number using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToSingle Method

[image]

FastReport.Net Class Reference
Variant..::.ToSingle Method
Variant Structure See Also Send Feedback
If Value is a Single, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent single-precision floating-point number.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ToSingle()
Visual Basic (Declaration)
Public Function ToSingle As Single
Visual C++
public:
float ToSingle()

See Also

Variant Structure
ToSingle Overload
FastReport Namespace


ToSingle Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToSingle Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a Single, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent single-precision floating-point number using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ToSingle(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToSingle ( _
    formatProvider As IFormatProvider _
) As Single
Visual C++
public:
virtual float ToSingle(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToSingle(IFormatProvider)

See Also

Variant Structure
ToSingle Overload
FastReport Namespace


ToString Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToString Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns String()()() property unless the value on the right is null. If the value on the right is null, returns "". (Overrides ValueType..::.ToString()()().)
ToString(IFormatProvider) | Converts the value of this instance to an equivalent String()()() using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToString Method

[image]

FastReport.Net Class Reference
Variant..::.ToString Method
Variant Structure See Also Send Feedback
Returns String()()() property unless the value on the right is null. If the value on the right is null, returns "".

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Variant Structure
ToString Overload
FastReport Namespace


ToString Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToString Method (IFormatProvider)
Variant Structure See Also Send Feedback
Converts the value of this instance to an equivalent String()()() using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ToString(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToString ( _
    formatProvider As IFormatProvider _
) As String
Visual C++
public:
virtual String^ ToString(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider

Return Value

Implements

IConvertible..::.ToString(IFormatProvider)

See Also

Variant Structure
ToString Overload
FastReport Namespace


ToTimeSpan Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToTimeSpan Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToTimeSpan()()() | If Value is a TimeSpan, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent TimeSpan.
ToTimeSpan(IFormatProvider) | If Value is a TimeSpan, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent TimeSpan using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToTimeSpan Method

[image]

FastReport.Net Class Reference
Variant..::.ToTimeSpan Method
Variant Structure See Also Send Feedback
If Value is a TimeSpan, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent TimeSpan.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TimeSpan ToTimeSpan()
Visual Basic (Declaration)
Public Function ToTimeSpan As TimeSpan
Visual C++
public:
TimeSpan ToTimeSpan()

See Also

Variant Structure
ToTimeSpan Overload
FastReport Namespace


ToTimeSpan Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToTimeSpan Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a TimeSpan, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent TimeSpan using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TimeSpan ToTimeSpan(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToTimeSpan ( _
    formatProvider As IFormatProvider _
) As TimeSpan
Visual C++
public:
TimeSpan ToTimeSpan(
    IFormatProvider^ formatProvider
)

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

See Also

Variant Structure
ToTimeSpan Overload
FastReport Namespace


ToType Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToType Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToType(Type) | Attempts to convert or typecast to the specified type.
ToType(Type, IFormatProvider) | Attempts to convert or typecast to the specified type.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToType Method (Type)

[image]

FastReport.Net Class Reference
Variant..::.ToType Method (Type)
Variant Structure See Also Send Feedback
Attempts to convert or typecast to the specified type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object ToType(
    Type type
)
Visual Basic (Declaration)
Public Function ToType ( _
    type As Type _
) As Object
Visual C++
public:
Object^ ToType(
    Type^ type
)

Parameters

type
Type: System..::.Type
The type to convert or cast to.

Return Value

The object after typecasting.

See Also

Variant Structure
ToType Overload
FastReport Namespace


ToType Method (Type, IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToType Method (Type, IFormatProvider)
Variant Structure See Also Send Feedback
Attempts to convert or typecast to the specified type.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object ToType(
    Type type,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToType ( _
    type As Type, _
    provider As IFormatProvider _
) As Object
Visual C++
public:
virtual Object^ ToType(
    Type^ type,
    IFormatProvider^ provider
) sealed

Parameters

type
Type: System..::.Type
The type to convert or cast to.
provider
Type: System..::.IFormatProvider
An IFormatProvider interface implementation that supplies culture-specific formatting information.

Return Value

The object after typecasting.

Implements

IConvertible..::.ToType(Type, IFormatProvider)

See Also

Variant Structure
ToType Overload
FastReport Namespace


ToUInt16 Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToUInt16 Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToUInt16()()() | If Value is a UInt16, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit unsigned integer.
ToUInt16(IFormatProvider) | If Value is a UInt16, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit unsigned integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToUInt16 Method

[image]

FastReport.Net Class Reference
Variant..::.ToUInt16 Method
Variant Structure See Also Send Feedback
If Value is a UInt16, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit unsigned integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ushort ToUInt16()
Visual Basic (Declaration)
Public Function ToUInt16 As UShort
Visual C++
public:
unsigned short ToUInt16()

See Also

Variant Structure
ToUInt16 Overload
FastReport Namespace


ToUInt16 Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToUInt16 Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a UInt16, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 16-bit unsigned integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ushort ToUInt16(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToUInt16 ( _
    formatProvider As IFormatProvider _
) As UShort
Visual C++
public:
virtual unsigned short ToUInt16(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToUInt16(IFormatProvider)

See Also

Variant Structure
ToUInt16 Overload
FastReport Namespace


ToUInt32 Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToUInt32 Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToUInt32()()() | If Value is a UInt32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit unsigned integer.
ToUInt32(IFormatProvider) | If Value is a UInt32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit unsigned integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToUInt32 Method

[image]

FastReport.Net Class Reference
Variant..::.ToUInt32 Method
Variant Structure See Also Send Feedback
If Value is a UInt32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit unsigned integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public uint ToUInt32()
Visual Basic (Declaration)
Public Function ToUInt32 As UInteger
Visual C++
public:
unsigned int ToUInt32()

See Also

Variant Structure
ToUInt32 Overload
FastReport Namespace


ToUInt32 Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToUInt32 Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a UInt32, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 32-bit unsigned integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public uint ToUInt32(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToUInt32 ( _
    formatProvider As IFormatProvider _
) As UInteger
Visual C++
public:
virtual unsigned int ToUInt32(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToUInt32(IFormatProvider)

See Also

Variant Structure
ToUInt32 Overload
FastReport Namespace


ToUInt64 Method

[image] [image]

FastReport.Net Class Reference
Variant..::.ToUInt64 Method
Variant Structure See Also Send Feedback

Overload List

Name | Description
ToUInt64()()() | If Value is a UInt64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit unsigned integer.
ToUInt64(IFormatProvider) | If Value is a UInt64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit unsigned integer using the specified culture-specific formatting information.

See Also

Variant Structure
Variant Members
FastReport Namespace


ToUInt64 Method

[image]

FastReport.Net Class Reference
Variant..::.ToUInt64 Method
Variant Structure See Also Send Feedback
If Value is a UInt64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit unsigned integer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ulong ToUInt64()
Visual Basic (Declaration)
Public Function ToUInt64 As ULong
Visual C++
public:
unsigned long long ToUInt64()

See Also

Variant Structure
ToUInt64 Overload
FastReport Namespace


ToUInt64 Method (IFormatProvider)

[image]

FastReport.Net Class Reference
Variant..::.ToUInt64 Method (IFormatProvider)
Variant Structure See Also Send Feedback
If Value is a UInt64, returns as-is. Otherwise, attempts to convert the value of this instance to an equivalent 64-bit unsigned integer using the specified culture-specific formatting information.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ulong ToUInt64(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToUInt64 ( _
    formatProvider As IFormatProvider _
) As ULong
Visual C++
public:
virtual unsigned long long ToUInt64(
    IFormatProvider^ formatProvider
) sealed

Parameters

formatProvider
Type: System..::.IFormatProvider
The culture-specific formatting information.

Implements

IConvertible..::.ToUInt64(IFormatProvider)

See Also

Variant Structure
ToUInt64 Overload
FastReport Namespace


UnaryNegation Operator

[image]

FastReport.Net Class Reference
Variant..::.UnaryNegation Operator
Variant Structure See Also Send Feedback
Unary minus operator.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Variant operator -(
    Variant subjectVariant
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    subjectVariant As Variant _
) As Variant
Visual C++
public:
static Variant operator -(
    Variant subjectVariant
)

Parameters

subjectVariant
Type: FastReport..::.Variant

See Also

Variant Structure
FastReport Namespace


Variant Properties

[image] [image]

FastReport.Net Class Reference
Variant Properties
Variant Structure See Also Send Feedback

The Variant type exposes the following members.

Properties

Name | Description
ImplementsIConvertible | Returns true if the Value property implements IConvertible
IsDate | Returns true if the value is a date or can be parsed into a date.
IsNumberable | Returns true if the Value property is a numeric intrinsic value or else can be parsed into a numeric intrinsic value.
IsNumeric | Returns true if the Value property is a numeric intrinsic value.
IsTimeSpan | Returns true if the value is a TimeSpan.
Type | The Type of the Value property.
Value | The actual value being stored in its original Type, returned as an Object.

See Also

Variant Structure
FastReport Namespace


ImplementsIConvertible Property

[image]

FastReport.Net Class Reference
Variant..::.ImplementsIConvertible Property
Variant Structure See Also Send Feedback
Returns true if the Value property implements IConvertible

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ImplementsIConvertible { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImplementsIConvertible As Boolean
Visual C++
public:
property bool ImplementsIConvertible {
    bool get ();
}

See Also

Variant Structure
FastReport Namespace


IsDate Property

[image]

FastReport.Net Class Reference
Variant..::.IsDate Property
Variant Structure See Also Send Feedback
Returns true if the value is a date or can be parsed into a date.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDate As Boolean
Visual C++
public:
property bool IsDate {
    bool get ();
}

See Also

Variant Structure
FastReport Namespace


IsNumberable Property

[image]

FastReport.Net Class Reference
Variant..::.IsNumberable Property
Variant Structure See Also Send Feedback
Returns true if the Value property is a numeric intrinsic value or else can be parsed into a numeric intrinsic value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsNumberable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNumberable As Boolean
Visual C++
public:
property bool IsNumberable {
    bool get ();
}

See Also

Variant Structure
FastReport Namespace


IsNumeric Property

[image]

FastReport.Net Class Reference
Variant..::.IsNumeric Property
Variant Structure See Also Send Feedback
Returns true if the Value property is a numeric intrinsic value.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsNumeric { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNumeric As Boolean
Visual C++
public:
property bool IsNumeric {
    bool get ();
}

See Also

Variant Structure
FastReport Namespace


IsTimeSpan Property

[image]

FastReport.Net Class Reference
Variant..::.IsTimeSpan Property
Variant Structure See Also Send Feedback
Returns true if the value is a TimeSpan.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsTimeSpan { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTimeSpan As Boolean
Visual C++
public:
property bool IsTimeSpan {
    bool get ();
}

See Also

Variant Structure
FastReport Namespace


Type Property

[image]

FastReport.Net Class Reference
Variant..::.Type Property
Variant Structure See Also Send Feedback
The Type of the Value property.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As Type
Visual C++
public:
property Type^ Type {
    Type^ get ();
}

See Also

Variant Structure
FastReport Namespace


Value Property

[image]

FastReport.Net Class Reference
Variant..::.Value Property
Variant Structure See Also Send Feedback
The actual value being stored in its original Type, returned as an Object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

Variant Structure
FastReport Namespace


VertAlign Enumeration

[image]

FastReport.Net Class Reference
VertAlign Enumeration
See Also Send Feedback
Specifies the vertical alignment of a text in the TextObject object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum VertAlign
Visual Basic (Declaration)
Public Enumeration VertAlign
Visual C++
public enum class VertAlign

Members

Member name | Description
Top | Specifies that text is aligned in the top of the layout rectangle.
Center | Specifies that text is aligned in the center of the layout rectangle.
Bottom | Specifies that text is aligned in the bottom of the layout rectangle.

See Also

FastReport Namespace


Watermark Class

[image]

FastReport.Net Class Reference
Watermark Class
Members See Also Send Feedback
Represents the report page watermark.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Watermark : IDisposable
Visual Basic (Declaration)
Public Class Watermark _
    Implements IDisposable
Visual C++
public ref class Watermark : IDisposable

Remarks

Watermark can draw text and/or image behind the page objects on in front of them. To enable watermark, set its Enabled property to true.

Inheritance Hierarchy

System..::.Object
FastReport..::.Watermark

See Also

Watermark Members
FastReport Namespace


Watermark Members

[image] [image]

FastReport.Net Class Reference
Watermark Members
Watermark Class Constructors Methods Properties See Also Send Feedback

The Watermark type exposes the following members.

Constructors

Name | Description
Watermark | Initializes a new instance of the Watermark class with default settings.

Methods

Name | Description
Assign | Assigns values from another source.
Clone | Creates exact copy of this Watermark.
Dispose | Disposes resources used by the watermark.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the watermark.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets avalue indicating that watermark is enabled.
Font | Gets or sets a font of the watermark text.
Image | Gets or sets the watermark image.
ImageSize | Gets or sets the watermark image size mode.
ImageTransparency | Gets or sets an image transparency.
ShowImageOnTop | Gets or sets a value indicates that the image should be displayed on top of all page objects.
ShowTextOnTop | Gets or sets a value indicates that the text should be displayed on top of all page objects.
Text | Gets or sets the watermark text.
TextFill | Gets or sets a text fill.
TextRotation | Gets or sets a text rotation.

See Also

Watermark Class
FastReport Namespace


Watermark Constructor

[image]

FastReport.Net Class Reference
Watermark Constructor
Watermark Class See Also Send Feedback
Initializes a new instance of the Watermark class with default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Watermark()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Watermark()

See Also

Watermark Class
FastReport Namespace


Watermark Methods

[image] [image]

FastReport.Net Class Reference
Watermark Methods
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another source.
Clone | Creates exact copy of this Watermark.
Dispose | Disposes resources used by the watermark.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the watermark.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Watermark Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
Watermark..::.Assign Method
Watermark Class See Also Send Feedback
Assigns values from another source.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    Watermark source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As Watermark _
)
Visual C++
public:
void Assign(
    Watermark^ source
)

Parameters

source
Type: FastReport..::.Watermark
Source to assign from.

See Also

Watermark Class
FastReport Namespace


Clone Method

[image]

FastReport.Net Class Reference
Watermark..::.Clone Method
Watermark Class See Also Send Feedback
Creates exact copy of this Watermark.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Watermark Clone()
Visual Basic (Declaration)
Public Function Clone As Watermark
Visual C++
public:
Watermark^ Clone()

Return Value

Copy of this watermark.

See Also

Watermark Class
FastReport Namespace


Dispose Method

[image]

FastReport.Net Class Reference
Watermark..::.Dispose Method
Watermark Class See Also Send Feedback
Disposes resources used by the watermark.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Watermark Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Watermark..::.Serialize Method
Watermark Class See Also Send Feedback
Serializes the watermark.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer,
    string prefix,
    Watermark c
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    c As Watermark _
)
Visual C++
public:
void Serialize(
    FRWriter^ writer,
    String^ prefix,
    Watermark^ c
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
The watermark property name.
c
Type: FastReport..::.Watermark
Another Watermark object to compare with.

Remarks

This method is for internal use only.

See Also

Watermark Class
FastReport Namespace


Watermark Properties

[image] [image]

FastReport.Net Class Reference
Watermark Properties
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets avalue indicating that watermark is enabled.
Font | Gets or sets a font of the watermark text.
Image | Gets or sets the watermark image.
ImageSize | Gets or sets the watermark image size mode.
ImageTransparency | Gets or sets an image transparency.
ShowImageOnTop | Gets or sets a value indicates that the image should be displayed on top of all page objects.
ShowTextOnTop | Gets or sets a value indicates that the text should be displayed on top of all page objects.
Text | Gets or sets the watermark text.
TextFill | Gets or sets a text fill.
TextRotation | Gets or sets a text rotation.

See Also

Watermark Class
FastReport Namespace


Enabled Property

[image]

FastReport.Net Class Reference
Watermark..::.Enabled Property
Watermark Class See Also Send Feedback
Gets or sets avalue indicating that watermark is enabled.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

Watermark Class
FastReport Namespace


Font Property

[image]

FastReport.Net Class Reference
Watermark..::.Font Property
Watermark Class See Also Send Feedback
Gets or sets a font of the watermark text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

Watermark Class
FastReport Namespace


Image Property

[image]

FastReport.Net Class Reference
Watermark..::.Image Property
Watermark Class See Also Send Feedback
Gets or sets the watermark image.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

Watermark Class
FastReport Namespace


ImageSize Property

[image]

FastReport.Net Class Reference
Watermark..::.ImageSize Property
Watermark Class See Also Send Feedback
Gets or sets the watermark image size mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WatermarkImageSize ImageSize { get; set; }
Visual Basic (Declaration)
Public Property ImageSize As WatermarkImageSize
Visual C++
public:
property WatermarkImageSize ImageSize {
    WatermarkImageSize get ();
    void set (WatermarkImageSize value);
}

See Also

Watermark Class
FastReport Namespace


ImageTransparency Property

[image]

FastReport.Net Class Reference
Watermark..::.ImageTransparency Property
Watermark Class See Also Send Feedback
Gets or sets an image transparency.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ImageTransparency { get; set; }
Visual Basic (Declaration)
Public Property ImageTransparency As Single
Visual C++
public:
property float ImageTransparency {
    float get ();
    void set (float value);
}

Remarks

Valid values are 0..1. 1 means totally transparent image.

See Also

Watermark Class
FastReport Namespace


ShowImageOnTop Property

[image]

FastReport.Net Class Reference
Watermark..::.ShowImageOnTop Property
Watermark Class See Also Send Feedback
Gets or sets a value indicates that the image should be displayed on top of all page objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowImageOnTop { get; set; }
Visual Basic (Declaration)
Public Property ShowImageOnTop As Boolean
Visual C++
public:
property bool ShowImageOnTop {
    bool get ();
    void set (bool value);
}

See Also

Watermark Class
FastReport Namespace


ShowTextOnTop Property

[image]

FastReport.Net Class Reference
Watermark..::.ShowTextOnTop Property
Watermark Class See Also Send Feedback
Gets or sets a value indicates that the text should be displayed on top of all page objects.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowTextOnTop { get; set; }
Visual Basic (Declaration)
Public Property ShowTextOnTop As Boolean
Visual C++
public:
property bool ShowTextOnTop {
    bool get ();
    void set (bool value);
}

See Also

Watermark Class
FastReport Namespace


Text Property

[image]

FastReport.Net Class Reference
Watermark..::.Text Property
Watermark Class See Also Send Feedback
Gets or sets the watermark text.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Watermark Class
FastReport Namespace


TextFill Property

[image]

FastReport.Net Class Reference
Watermark..::.TextFill Property
Watermark Class See Also Send Feedback
Gets or sets a text fill.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillBase TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As FillBase
Visual C++
public:
property FillBase^ TextFill {
    FillBase^ get ();
    void set (FillBase^ value);
}

See Also

Watermark Class
FastReport Namespace


TextRotation Property

[image]

FastReport.Net Class Reference
Watermark..::.TextRotation Property
Watermark Class See Also Send Feedback
Gets or sets a text rotation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WatermarkTextRotation TextRotation { get; set; }
Visual Basic (Declaration)
Public Property TextRotation As WatermarkTextRotation
Visual C++
public:
property WatermarkTextRotation TextRotation {
    WatermarkTextRotation get ();
    void set (WatermarkTextRotation value);
}

See Also

Watermark Class
FastReport Namespace


WatermarkImageSize Enumeration

[image]

FastReport.Net Class Reference
WatermarkImageSize Enumeration
See Also Send Feedback
Specifies the watermark image size mode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum WatermarkImageSize
Visual Basic (Declaration)
Public Enumeration WatermarkImageSize
Visual C++
public enum class WatermarkImageSize

Members

Member name | Description
Normal | Specifies the normal (original) size.
Center | Specifies the centered image.
Stretch | Specifies the stretched image.
Zoom | Specifies the stretched image that keeps its aspect ratio.
Tile | Specifies the tiled image.

See Also

FastReport Namespace


WatermarkTextRotation Enumeration

[image]

FastReport.Net Class Reference
WatermarkTextRotation Enumeration
See Also Send Feedback
Specifies the watermark text rotation.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum WatermarkTextRotation
Visual Basic (Declaration)
Public Enumeration WatermarkTextRotation
Visual C++
public enum class WatermarkTextRotation

Members

Member name | Description
Horizontal | Specifies a horizontal text.
Vertical | Specifies a vertical text.
ForwardDiagonal | Specifies a diagonal text.
BackwardDiagonal | Specifies a backward diagonal text.

See Also

FastReport Namespace


ZipCodeObject Class

[image]

FastReport.Net Class Reference
ZipCodeObject Class
Members See Also Send Feedback
Represents a zip code object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ZipCodeObject : ReportComponentBase
Visual Basic (Declaration)
Public Class ZipCodeObject _
    Inherits ReportComponentBase
Visual C++
public ref class ZipCodeObject : public ReportComponentBase

Remarks

This object is mainly used in Russia to print postal index on envelopes. It complies with the GOST R 51506-99.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.ZipCodeObject

See Also

ZipCodeObject Members
FastReport Namespace


ZipCodeObject Members

[image] [image]

FastReport.Net Class Reference
ZipCodeObject Members
ZipCodeObject Class Constructors Methods Properties Events See Also Send Feedback

The ZipCodeObject type exposes the following members.

Constructors

Name | Description
ZipCodeObject | Initializes a new instance of the ZipCodeObject with the default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a data column name bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Expression | Gets or sets an expression that contains the zip code.
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
SegmentCount | Gets or sets the number of segments in zipcode.
SegmentHeight | Gets or sets the height of a single zipcode segment, in pixels.
SegmentWidth | Gets or sets the width of a single zipcode segment, in pixels.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShowGrid | Gets or sets a value indicating whether the segment grid should be drawn.
ShowMarkers | Gets or sets a value indicating whether the reference markers should be drawn.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Spacing | Gets or sets the spacing between origins of segments, in pixels.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Text | Gets or sets the zip code.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ZipCodeObject Class
FastReport Namespace


ZipCodeObject Constructor

[image]

FastReport.Net Class Reference
ZipCodeObject Constructor
ZipCodeObject Class See Also Send Feedback
Initializes a new instance of the ZipCodeObject with the default settings.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ZipCodeObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ZipCodeObject()

See Also

ZipCodeObject Class
FastReport Namespace


ZipCodeObject Methods

[image] [image]

FastReport.Net Class Reference
ZipCodeObject Methods
ZipCodeObject Class See Also Send Feedback

The ZipCodeObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ZipCodeObject Class
FastReport Namespace


Assign Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.Assign Method
ZipCodeObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ZipCodeObject Class
FastReport Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
ZipCodeObject..::.Dispose Method
ZipCodeObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ZipCodeObject Class
ZipCodeObject Members
FastReport Namespace


Draw Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.Draw Method
ZipCodeObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

ZipCodeObject Class
FastReport Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
ZipCodeObject..::.DrawMarkers Method
ZipCodeObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

ZipCodeObject Class
ZipCodeObject Members
FastReport Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.GetContextMenu Method
ZipCodeObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

ZipCodeObject Class
FastReport Namespace


GetData Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.GetData Method
ZipCodeObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

ZipCodeObject Class
FastReport Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.GetExpressions Method
ZipCodeObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

ZipCodeObject Class
FastReport Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.GetPreferredSize Method
ZipCodeObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

ZipCodeObject Class
FastReport Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.GetSelectionPoints Method
ZipCodeObject Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

ZipCodeObject Class
FastReport Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.GetSmartTag Method
ZipCodeObject Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

ZipCodeObject Class
FastReport Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ZipCodeObject..::.MemberwiseClone Method
ZipCodeObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ZipCodeObject Class
ZipCodeObject Members
FastReport Namespace


OnAfterInsert Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.OnAfterInsert Method
ZipCodeObject Class See Also Send Feedback
Called after the new object was inserted in the designer.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterInsert(
    InsertFrom source
)
Visual Basic (Declaration)
Public Overrides Sub OnAfterInsert ( _
    source As InsertFrom _
)
Visual C++
public:
virtual void OnAfterInsert(
    InsertFrom source
) override

Parameters

source
Type: FastReport..::.InsertFrom
The insertion source.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called when new object is inserted, pasted from clipboard or dragged from "Dictionary" window. You may override this method if you need to perform some actions when object is inserted. Typical implementation invokes the object's editor if "Edit after insert" flag is set in the designer options.

See Also

ZipCodeObject Class
FastReport Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ZipCodeObject..::.Serialize Method
ZipCodeObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ZipCodeObject Class
FastReport Namespace


ZipCodeObject Properties

[image] [image]

FastReport.Net Class Reference
ZipCodeObject Properties
ZipCodeObject Class See Also Send Feedback

The ZipCodeObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a data column name bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Expression | Gets or sets an expression that contains the zip code.
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
SegmentCount | Gets or sets the number of segments in zipcode.
SegmentHeight | Gets or sets the height of a single zipcode segment, in pixels.
SegmentWidth | Gets or sets the width of a single zipcode segment, in pixels.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShowGrid | Gets or sets a value indicating whether the segment grid should be drawn.
ShowMarkers | Gets or sets a value indicating whether the reference markers should be drawn.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Spacing | Gets or sets the spacing between origins of segments, in pixels.
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Text | Gets or sets the zip code.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ZipCodeObject Class
FastReport Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.DataColumn Property
ZipCodeObject Class See Also Send Feedback
Gets or sets a data column name bound to this control.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

Value must be in the form "Datasource.Column".

See Also

ZipCodeObject Class
FastReport Namespace


Expression Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.Expression Property
ZipCodeObject Class See Also Send Feedback
Gets or sets an expression that contains the zip code.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

ZipCodeObject Class
FastReport Namespace


SegmentCount Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.SegmentCount Property
ZipCodeObject Class See Also Send Feedback
Gets or sets the number of segments in zipcode.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int SegmentCount { get; set; }
Visual Basic (Declaration)
Public Property SegmentCount As Integer
Visual C++
public:
property int SegmentCount {
    int get ();
    void set (int value);
}

See Also

ZipCodeObject Class
FastReport Namespace


SegmentHeight Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.SegmentHeight Property
ZipCodeObject Class See Also Send Feedback
Gets or sets the height of a single zipcode segment, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float SegmentHeight { get; set; }
Visual Basic (Declaration)
Public Property SegmentHeight As Single
Visual C++
public:
property float SegmentHeight {
    float get ();
    void set (float value);
}

See Also

ZipCodeObject Class
FastReport Namespace


SegmentWidth Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.SegmentWidth Property
ZipCodeObject Class See Also Send Feedback
Gets or sets the width of a single zipcode segment, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float SegmentWidth { get; set; }
Visual Basic (Declaration)
Public Property SegmentWidth As Single
Visual C++
public:
property float SegmentWidth {
    float get ();
    void set (float value);
}

See Also

ZipCodeObject Class
FastReport Namespace


ShowGrid Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.ShowGrid Property
ZipCodeObject Class See Also Send Feedback
Gets or sets a value indicating whether the segment grid should be drawn.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowGrid { get; set; }
Visual Basic (Declaration)
Public Property ShowGrid As Boolean
Visual C++
public:
property bool ShowGrid {
    bool get ();
    void set (bool value);
}

See Also

ZipCodeObject Class
FastReport Namespace


ShowMarkers Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.ShowMarkers Property
ZipCodeObject Class See Also Send Feedback
Gets or sets a value indicating whether the reference markers should be drawn.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowMarkers { get; set; }
Visual Basic (Declaration)
Public Property ShowMarkers As Boolean
Visual C++
public:
property bool ShowMarkers {
    bool get ();
    void set (bool value);
}

Remarks

Reference markers are used by postal service to automatically read the zipcode.

See Also

ZipCodeObject Class
FastReport Namespace


Spacing Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.Spacing Property
ZipCodeObject Class See Also Send Feedback
Gets or sets the spacing between origins of segments, in pixels.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Single
Visual C++
public:
property float Spacing {
    float get ();
    void set (float value);
}

See Also

ZipCodeObject Class
FastReport Namespace


Text Property

[image]

FastReport.Net Class Reference
ZipCodeObject..::.Text Property
ZipCodeObject Class See Also Send Feedback
Gets or sets the zip code.

Namespace: FastReport
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ZipCodeObject Class
FastReport Namespace


ZipCodeObject Events

[image] [image]

FastReport.Net Class Reference
ZipCodeObject Events
ZipCodeObject Class See Also Send Feedback

The ZipCodeObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

ZipCodeObject Class
FastReport Namespace


FastReport.Barcode Namespace

[image]

FastReport.Net Class Reference
FastReport.Barcode Namespace
Send Feedback

Classes

Class | Description
Barcode128 | Generates the Code128 barcode.
Barcode2DBase | The base class for 2D-barcodes such as PDF417 and Datamatrix.
Barcode2of5Industrial | Generates the "2/5 Industrial" barcode.
Barcode2of5Interleaved | Generates the "2/5 Interleaved" barcode.
Barcode2of5Matrix | Generates the "2/5 Matrix" barcode.
Barcode39 | Generates the Code39 barcode.
Barcode39Extended | Generates the Code39 extended barcode.
Barcode93 | Generates the Code93 barcode.
Barcode93Extended | Generates the Code93 extended barcode.
BarcodeBase | The base class for all barcodes.
BarcodeCodabar | Generates the Codabar barcode.
BarcodeDatamatrix | Generates the 2D Data Matrix barcode.
BarcodeEAN | The base class for EAN barcodes.
BarcodeEAN13 | Generates the EAN13 barcode.
BarcodeEAN8 | Generates the EAN8 barcode.
BarcodeMSI | Generates the MSI barcode.
BarcodeObject | Represents a barcode object.
BarcodePDF417 | Generates the 2D PDF417 barcode.
BarcodePostNet | Generates the PostNet barcode.
BarcodeQR | Generates the 2D QR code barcode.
BarcodeSupplement2 | Generates the 2-digit supplement barcode.
BarcodeUPC_A | Generates the UPC A barcode.
BarcodeUPC_E0 | Generates the UPC E0 barcode.
BarcodeUPC_E1 | Generates the UPC E1 barcode.
LinearBarcodeBase | The base class for linear (1D) barcodes.

Enumerations

Enumeration | Description
DatamatrixEncoding | Specifies the Datamatrix encoding.
DatamatrixSymbolSize | Specifies the Datamatrix symbol size.
PDF417CompactionMode | Specifies the compaction mode used for PDF417 barcode.
PDF417ErrorCorrection | Specifies the error correction level used for PDF417 barcode.
QRCodeEncoding | Specifies the QR Code encoding.
QRCodeErrorCorrection | Specifies the QR code error correction level.


Barcode128 Class

[image]

FastReport.Net Class Reference
Barcode128 Class
Members Example See Also Send Feedback
Generates the Code128 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode128 : LinearBarcodeBase
Visual Basic (Declaration)
Public Class Barcode128 _
    Inherits LinearBarcodeBase
Visual C++
public ref class Barcode128 : public LinearBarcodeBase

Remarks

This barcode supports three code pages: A, B and C. You need to set appropriate code page in the barcode text, or use the auto encode feature. See the AutoEncode property for more details.

Examples

This example shows how to configure the BarcodeObject to display Code128 barcode.
CopyC#
BarcodeObject barcode;
...
barcode.Barcode = new Barcode128();
(barcode.Barcode as Barcode128).AutoEncode = false;

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode128

See Also

Barcode128 Members
FastReport.Barcode Namespace


Barcode128 Members

[image] [image]

FastReport.Net Class Reference
Barcode128 Members
Barcode128 Class Constructors Methods Properties See Also Send Feedback

The Barcode128 type exposes the following members.

Constructors

Name | Description
Barcode128 | Initializes a new instance of the Barcode128 class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides LinearBarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoEncode | Gets or sets a value that determines whether the barcode should automatically use appropriate encoding.
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode128 Class
FastReport.Barcode Namespace


Barcode128 Constructor

[image]

FastReport.Net Class Reference
Barcode128 Constructor
Barcode128 Class See Also Send Feedback
Initializes a new instance of the Barcode128 class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode128()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode128()

See Also

Barcode128 Class
FastReport.Barcode Namespace


Barcode128 Methods

[image] [image]

FastReport.Net Class Reference
Barcode128 Methods
Barcode128 Class See Also Send Feedback

The Barcode128 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides LinearBarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode128 Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
Barcode128..::.Assign Method
Barcode128 Class See Also Send Feedback
Assigns properties from other, similar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    BarcodeBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As BarcodeBase _
)
Visual C++
public:
virtual void Assign(
    BarcodeBase^ source
) override

Parameters

source
Type: FastReport.Barcode..::.BarcodeBase
Barcode object to assign properties from.

See Also

Barcode128 Class
FastReport.Barcode Namespace


Barcode128 Properties

[image] [image]

FastReport.Net Class Reference
Barcode128 Properties
Barcode128 Class See Also Send Feedback

The Barcode128 type exposes the following members.

Properties

Name | Description
AutoEncode | Gets or sets a value that determines whether the barcode should automatically use appropriate encoding.
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode128 Class
FastReport.Barcode Namespace


AutoEncode Property

[image]

FastReport.Net Class Reference
Barcode128..::.AutoEncode Property
Barcode128 Class Example See Also Send Feedback
Gets or sets a value that determines whether the barcode should automatically use appropriate encoding.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoEncode { get; set; }
Visual Basic (Declaration)
Public Property AutoEncode As Boolean
Visual C++
public:
property bool AutoEncode {
    bool get ();
    void set (bool value);
}

Remarks

You may use this property to encode data automatically. If you set it to false, you must specify the code page inside the data string. The following control codes are available:
Sequence | Code128 control code
&A; | START A / CODE A
&B; | START B / CODE B
&C; | START C / CODE C
&S;SHIFT&1;FNC1&2;FNC2&3;FNC3&4;FNC4

Examples

The following example shows how to specify control codes:
CopyC#
BarcodeObject barcode;
barcode.Barcode = new Barcode128();
(barcode.Barcode as Barcode128).AutoEncode = false;
barcode.Text = "&C;1234&A;ABC";

See Also

Barcode128 Class
FastReport.Barcode Namespace


IsNumeric Property

[image]

FastReport.Net Class Reference
Barcode128..::.IsNumeric Property
Barcode128 Class See Also Send Feedback
Gets the value indicating that the barcode is numeric.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsNumeric { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsNumeric As Boolean
Visual C++
public:
virtual property bool IsNumeric {
    bool get () override;
}

See Also

Barcode128 Class
FastReport.Barcode Namespace


Barcode2DBase Class

[image]

FastReport.Net Class Reference
Barcode2DBase Class
Members See Also Send Feedback
The base class for 2D-barcodes such as PDF417 and Datamatrix.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class Barcode2DBase : BarcodeBase
Visual Basic (Declaration)
Public MustInherit Class Barcode2DBase _
    Inherits BarcodeBase
Visual C++
public ref class Barcode2DBase abstract : public BarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.Barcode2DBase
FastReport.Barcode..::.BarcodeDatamatrix
FastReport.Barcode..::.BarcodePDF417
FastReport.Barcode..::.BarcodeQR

See Also

Barcode2DBase Members
FastReport.Barcode Namespace


Barcode2DBase Members

[image] [image]

FastReport.Net Class Reference
Barcode2DBase Members
Barcode2DBase Class Constructors Methods Properties See Also Send Feedback

The Barcode2DBase type exposes the following members.

Constructors

Name | Description
Barcode2DBase | Initializes a new instance of the Barcode2DBase class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from BarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the name of barcode. (Inherited from BarcodeBase.)

See Also

Barcode2DBase Class
FastReport.Barcode Namespace


Barcode2DBase Constructor

[image]

FastReport.Net Class Reference
Barcode2DBase Constructor
Barcode2DBase Class See Also Send Feedback
Initializes a new instance of the Barcode2DBase class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Barcode2DBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Barcode2DBase()

See Also

Barcode2DBase Class
FastReport.Barcode Namespace


Barcode2DBase Methods

[image] [image]

FastReport.Net Class Reference
Barcode2DBase Methods
Barcode2DBase Class See Also Send Feedback

The Barcode2DBase type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from BarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode2DBase Class
FastReport.Barcode Namespace


Barcode2DBase Properties

[image] [image]

FastReport.Net Class Reference
Barcode2DBase Properties
Barcode2DBase Class See Also Send Feedback

The Barcode2DBase type exposes the following members.

Properties

Name | Description
Name | Gets the name of barcode. (Inherited from BarcodeBase.)

See Also

Barcode2DBase Class
FastReport.Barcode Namespace


Barcode2of5Industrial Class

[image]

FastReport.Net Class Reference
Barcode2of5Industrial Class
Members See Also Send Feedback
Generates the "2/5 Industrial" barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode2of5Industrial : Barcode2of5Interleaved
Visual Basic (Declaration)
Public Class Barcode2of5Industrial _
    Inherits Barcode2of5Interleaved
Visual C++
public ref class Barcode2of5Industrial : public Barcode2of5Interleaved

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode2of5Interleaved
FastReport.Barcode..::.Barcode2of5Industrial

See Also

Barcode2of5Industrial Members
FastReport.Barcode Namespace


Barcode2of5Industrial Members

[image] [image]

FastReport.Net Class Reference
Barcode2of5Industrial Members
Barcode2of5Industrial Class Constructors Methods Properties See Also Send Feedback

The Barcode2of5Industrial type exposes the following members.

Constructors

Name | Description
Barcode2of5Industrial | Initializes a new instance of the Barcode2of5Industrial class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode2of5Industrial Class
FastReport.Barcode Namespace


Barcode2of5Industrial Constructor

[image]

FastReport.Net Class Reference
Barcode2of5Industrial Constructor
Barcode2of5Industrial Class See Also Send Feedback
Initializes a new instance of the Barcode2of5Industrial class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode2of5Industrial()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode2of5Industrial()

See Also

Barcode2of5Industrial Class
FastReport.Barcode Namespace


Barcode2of5Industrial Methods

[image] [image]

FastReport.Net Class Reference
Barcode2of5Industrial Methods
Barcode2of5Industrial Class See Also Send Feedback

The Barcode2of5Industrial type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode2of5Industrial Class
FastReport.Barcode Namespace


Barcode2of5Industrial Properties

[image] [image]

FastReport.Net Class Reference
Barcode2of5Industrial Properties
Barcode2of5Industrial Class See Also Send Feedback

The Barcode2of5Industrial type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode2of5Industrial Class
FastReport.Barcode Namespace


Barcode2of5Interleaved Class

[image]

FastReport.Net Class Reference
Barcode2of5Interleaved Class
Members See Also Send Feedback
Generates the "2/5 Interleaved" barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode2of5Interleaved : LinearBarcodeBase
Visual Basic (Declaration)
Public Class Barcode2of5Interleaved _
    Inherits LinearBarcodeBase
Visual C++
public ref class Barcode2of5Interleaved : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode2of5Interleaved
FastReport.Barcode..::.Barcode2of5Industrial
FastReport.Barcode..::.Barcode2of5Matrix

See Also

Barcode2of5Interleaved Members
FastReport.Barcode Namespace


Barcode2of5Interleaved Members

[image] [image]

FastReport.Net Class Reference
Barcode2of5Interleaved Members
Barcode2of5Interleaved Class Constructors Methods Properties See Also Send Feedback

The Barcode2of5Interleaved type exposes the following members.

Constructors

Name | Description
Barcode2of5Interleaved | Initializes a new instance of the Barcode2of5Interleaved class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode2of5Interleaved Class
FastReport.Barcode Namespace


Barcode2of5Interleaved Constructor

[image]

FastReport.Net Class Reference
Barcode2of5Interleaved Constructor
Barcode2of5Interleaved Class See Also Send Feedback
Initializes a new instance of the Barcode2of5Interleaved class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode2of5Interleaved()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode2of5Interleaved()

See Also

Barcode2of5Interleaved Class
FastReport.Barcode Namespace


Barcode2of5Interleaved Methods

[image] [image]

FastReport.Net Class Reference
Barcode2of5Interleaved Methods
Barcode2of5Interleaved Class See Also Send Feedback

The Barcode2of5Interleaved type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode2of5Interleaved Class
FastReport.Barcode Namespace


Barcode2of5Interleaved Properties

[image] [image]

FastReport.Net Class Reference
Barcode2of5Interleaved Properties
Barcode2of5Interleaved Class See Also Send Feedback

The Barcode2of5Interleaved type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode2of5Interleaved Class
FastReport.Barcode Namespace


Barcode2of5Matrix Class

[image]

FastReport.Net Class Reference
Barcode2of5Matrix Class
Members See Also Send Feedback
Generates the "2/5 Matrix" barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode2of5Matrix : Barcode2of5Interleaved
Visual Basic (Declaration)
Public Class Barcode2of5Matrix _
    Inherits Barcode2of5Interleaved
Visual C++
public ref class Barcode2of5Matrix : public Barcode2of5Interleaved

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode2of5Interleaved
FastReport.Barcode..::.Barcode2of5Matrix

See Also

Barcode2of5Matrix Members
FastReport.Barcode Namespace


Barcode2of5Matrix Members

[image] [image]

FastReport.Net Class Reference
Barcode2of5Matrix Members
Barcode2of5Matrix Class Constructors Methods Properties See Also Send Feedback

The Barcode2of5Matrix type exposes the following members.

Constructors

Name | Description
Barcode2of5Matrix | Initializes a new instance of the Barcode2of5Matrix class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode2of5Matrix Class
FastReport.Barcode Namespace


Barcode2of5Matrix Constructor

[image]

FastReport.Net Class Reference
Barcode2of5Matrix Constructor
Barcode2of5Matrix Class See Also Send Feedback
Initializes a new instance of the Barcode2of5Matrix class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode2of5Matrix()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode2of5Matrix()

See Also

Barcode2of5Matrix Class
FastReport.Barcode Namespace


Barcode2of5Matrix Methods

[image] [image]

FastReport.Net Class Reference
Barcode2of5Matrix Methods
Barcode2of5Matrix Class See Also Send Feedback

The Barcode2of5Matrix type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode2of5Matrix Class
FastReport.Barcode Namespace


Barcode2of5Matrix Properties

[image] [image]

FastReport.Net Class Reference
Barcode2of5Matrix Properties
Barcode2of5Matrix Class See Also Send Feedback

The Barcode2of5Matrix type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode2of5Matrix Class
FastReport.Barcode Namespace


Barcode39 Class

[image]

FastReport.Net Class Reference
Barcode39 Class
Members See Also Send Feedback
Generates the Code39 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode39 : LinearBarcodeBase
Visual Basic (Declaration)
Public Class Barcode39 _
    Inherits LinearBarcodeBase
Visual C++
public ref class Barcode39 : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode39
FastReport.Barcode..::.Barcode39Extended

See Also

Barcode39 Members
FastReport.Barcode Namespace


Barcode39 Members

[image] [image]

FastReport.Net Class Reference
Barcode39 Members
Barcode39 Class Constructors Methods Properties See Also Send Feedback

The Barcode39 type exposes the following members.

Constructors

Name | Description
Barcode39 | Initializes a new instance of the Barcode39 class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode39 Class
FastReport.Barcode Namespace


Barcode39 Constructor

[image]

FastReport.Net Class Reference
Barcode39 Constructor
Barcode39 Class See Also Send Feedback
Initializes a new instance of the Barcode39 class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode39()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode39()

See Also

Barcode39 Class
FastReport.Barcode Namespace


Barcode39 Methods

[image] [image]

FastReport.Net Class Reference
Barcode39 Methods
Barcode39 Class See Also Send Feedback

The Barcode39 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode39 Class
FastReport.Barcode Namespace


Barcode39 Properties

[image] [image]

FastReport.Net Class Reference
Barcode39 Properties
Barcode39 Class See Also Send Feedback

The Barcode39 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode39 Class
FastReport.Barcode Namespace


IsNumeric Property

[image]

FastReport.Net Class Reference
Barcode39..::.IsNumeric Property
Barcode39 Class See Also Send Feedback
Gets the value indicating that the barcode is numeric.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsNumeric { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsNumeric As Boolean
Visual C++
public:
virtual property bool IsNumeric {
    bool get () override;
}

See Also

Barcode39 Class
FastReport.Barcode Namespace


Barcode39Extended Class

[image]

FastReport.Net Class Reference
Barcode39Extended Class
Members See Also Send Feedback
Generates the Code39 extended barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode39Extended : Barcode39
Visual Basic (Declaration)
Public Class Barcode39Extended _
    Inherits Barcode39
Visual C++
public ref class Barcode39Extended : public Barcode39

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode39
FastReport.Barcode..::.Barcode39Extended

See Also

Barcode39Extended Members
FastReport.Barcode Namespace


Barcode39Extended Members

[image] [image]

FastReport.Net Class Reference
Barcode39Extended Members
Barcode39Extended Class Constructors Methods Properties See Also Send Feedback

The Barcode39Extended type exposes the following members.

Constructors

Name | Description
Barcode39Extended | Initializes a new instance of the Barcode39Extended class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from Barcode39.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode39Extended Class
FastReport.Barcode Namespace


Barcode39Extended Constructor

[image]

FastReport.Net Class Reference
Barcode39Extended Constructor
Barcode39Extended Class See Also Send Feedback
Initializes a new instance of the Barcode39Extended class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode39Extended()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode39Extended()

See Also

Barcode39Extended Class
FastReport.Barcode Namespace


Barcode39Extended Methods

[image] [image]

FastReport.Net Class Reference
Barcode39Extended Methods
Barcode39Extended Class See Also Send Feedback

The Barcode39Extended type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode39Extended Class
FastReport.Barcode Namespace


Barcode39Extended Properties

[image] [image]

FastReport.Net Class Reference
Barcode39Extended Properties
Barcode39Extended Class See Also Send Feedback

The Barcode39Extended type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from Barcode39.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode39Extended Class
FastReport.Barcode Namespace


Barcode93 Class

[image]

FastReport.Net Class Reference
Barcode93 Class
Members See Also Send Feedback
Generates the Code93 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode93 : LinearBarcodeBase
Visual Basic (Declaration)
Public Class Barcode93 _
    Inherits LinearBarcodeBase
Visual C++
public ref class Barcode93 : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode93
FastReport.Barcode..::.Barcode93Extended

See Also

Barcode93 Members
FastReport.Barcode Namespace


Barcode93 Members

[image] [image]

FastReport.Net Class Reference
Barcode93 Members
Barcode93 Class Constructors Methods Properties See Also Send Feedback

The Barcode93 type exposes the following members.

Constructors

Name | Description
Barcode93 | Initializes a new instance of the Barcode93 class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode93 Class
FastReport.Barcode Namespace


Barcode93 Constructor

[image]

FastReport.Net Class Reference
Barcode93 Constructor
Barcode93 Class See Also Send Feedback
Initializes a new instance of the Barcode93 class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode93()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode93()

See Also

Barcode93 Class
FastReport.Barcode Namespace


Barcode93 Methods

[image] [image]

FastReport.Net Class Reference
Barcode93 Methods
Barcode93 Class See Also Send Feedback

The Barcode93 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode93 Class
FastReport.Barcode Namespace


Barcode93 Properties

[image] [image]

FastReport.Net Class Reference
Barcode93 Properties
Barcode93 Class See Also Send Feedback

The Barcode93 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode93 Class
FastReport.Barcode Namespace


IsNumeric Property

[image]

FastReport.Net Class Reference
Barcode93..::.IsNumeric Property
Barcode93 Class See Also Send Feedback
Gets the value indicating that the barcode is numeric.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsNumeric { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsNumeric As Boolean
Visual C++
public:
virtual property bool IsNumeric {
    bool get () override;
}

See Also

Barcode93 Class
FastReport.Barcode Namespace


Barcode93Extended Class

[image]

FastReport.Net Class Reference
Barcode93Extended Class
Members See Also Send Feedback
Generates the Code93 extended barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Barcode93Extended : Barcode93
Visual Basic (Declaration)
Public Class Barcode93Extended _
    Inherits Barcode93
Visual C++
public ref class Barcode93Extended : public Barcode93

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode93
FastReport.Barcode..::.Barcode93Extended

See Also

Barcode93Extended Members
FastReport.Barcode Namespace


Barcode93Extended Members

[image] [image]

FastReport.Net Class Reference
Barcode93Extended Members
Barcode93Extended Class Constructors Methods Properties See Also Send Feedback

The Barcode93Extended type exposes the following members.

Constructors

Name | Description
Barcode93Extended | Initializes a new instance of the Barcode93Extended class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from Barcode93.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode93Extended Class
FastReport.Barcode Namespace


Barcode93Extended Constructor

[image]

FastReport.Net Class Reference
Barcode93Extended Constructor
Barcode93Extended Class See Also Send Feedback
Initializes a new instance of the Barcode93Extended class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Barcode93Extended()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Barcode93Extended()

See Also

Barcode93Extended Class
FastReport.Barcode Namespace


Barcode93Extended Methods

[image] [image]

FastReport.Net Class Reference
Barcode93Extended Methods
Barcode93Extended Class See Also Send Feedback

The Barcode93Extended type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Barcode93Extended Class
FastReport.Barcode Namespace


Barcode93Extended Properties

[image] [image]

FastReport.Net Class Reference
Barcode93Extended Properties
Barcode93Extended Class See Also Send Feedback

The Barcode93Extended type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from Barcode93.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

Barcode93Extended Class
FastReport.Barcode Namespace


BarcodeBase Class

[image]

FastReport.Net Class Reference
BarcodeBase Class
Members See Also Send Feedback
The base class for all barcodes.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class BarcodeBase
Visual Basic (Declaration)
Public MustInherit Class BarcodeBase
Visual C++
public ref class BarcodeBase abstract

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.Barcode2DBase
FastReport.Barcode..::.LinearBarcodeBase

See Also

BarcodeBase Members
FastReport.Barcode Namespace


BarcodeBase Members

[image] [image]

FastReport.Net Class Reference
BarcodeBase Members
BarcodeBase Class Constructors Methods Properties See Also Send Feedback

The BarcodeBase type exposes the following members.

Constructors

Name | Description
BarcodeBase | Initializes a new instance of the BarcodeBase class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode.
Clone | Creates the exact copy of this barcode.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the name of barcode.

See Also

BarcodeBase Class
FastReport.Barcode Namespace


BarcodeBase Constructor

[image]

FastReport.Net Class Reference
BarcodeBase Constructor
BarcodeBase Class See Also Send Feedback
Initializes a new instance of the BarcodeBase class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeBase()

See Also

BarcodeBase Class
FastReport.Barcode Namespace


BarcodeBase Methods

[image] [image]

FastReport.Net Class Reference
BarcodeBase Methods
BarcodeBase Class See Also Send Feedback

The BarcodeBase type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode.
Clone | Creates the exact copy of this barcode.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeBase Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
BarcodeBase..::.Assign Method
BarcodeBase Class See Also Send Feedback
Assigns properties from other, similar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Assign(
    BarcodeBase source
)
Visual Basic (Declaration)
Public Overridable Sub Assign ( _
    source As BarcodeBase _
)
Visual C++
public:
virtual void Assign(
    BarcodeBase^ source
)

Parameters

source
Type: FastReport.Barcode..::.BarcodeBase
Barcode object to assign properties from.

See Also

BarcodeBase Class
FastReport.Barcode Namespace


Clone Method

[image]

FastReport.Net Class Reference
BarcodeBase..::.Clone Method
BarcodeBase Class See Also Send Feedback
Creates the exact copy of this barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeBase Clone()
Visual Basic (Declaration)
Public Function Clone As BarcodeBase
Visual C++
public:
BarcodeBase^ Clone()

Return Value

The copy of this barcode.

See Also

BarcodeBase Class
FastReport.Barcode Namespace


BarcodeBase Properties

[image] [image]

FastReport.Net Class Reference
BarcodeBase Properties
BarcodeBase Class See Also Send Feedback

The BarcodeBase type exposes the following members.

Properties

Name | Description
Name | Gets the name of barcode.

See Also

BarcodeBase Class
FastReport.Barcode Namespace


Name Property

[image]

FastReport.Net Class Reference
BarcodeBase..::.Name Property
BarcodeBase Class See Also Send Feedback
Gets the name of barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

BarcodeBase Class
FastReport.Barcode Namespace


BarcodeCodabar Class

[image]

FastReport.Net Class Reference
BarcodeCodabar Class
Members See Also Send Feedback
Generates the Codabar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeCodabar : LinearBarcodeBase
Visual Basic (Declaration)
Public Class BarcodeCodabar _
    Inherits LinearBarcodeBase
Visual C++
public ref class BarcodeCodabar : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeCodabar

See Also

BarcodeCodabar Members
FastReport.Barcode Namespace


BarcodeCodabar Members

[image] [image]

FastReport.Net Class Reference
BarcodeCodabar Members
BarcodeCodabar Class Constructors Methods Properties See Also Send Feedback

The BarcodeCodabar type exposes the following members.

Constructors

Name | Description
BarcodeCodabar | Initializes a new instance of the BarcodeCodabar class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeCodabar Class
FastReport.Barcode Namespace


BarcodeCodabar Constructor

[image]

FastReport.Net Class Reference
BarcodeCodabar Constructor
BarcodeCodabar Class See Also Send Feedback
Initializes a new instance of the BarcodeCodabar class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeCodabar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeCodabar()

See Also

BarcodeCodabar Class
FastReport.Barcode Namespace


BarcodeCodabar Methods

[image] [image]

FastReport.Net Class Reference
BarcodeCodabar Methods
BarcodeCodabar Class See Also Send Feedback

The BarcodeCodabar type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeCodabar Class
FastReport.Barcode Namespace


BarcodeCodabar Properties

[image] [image]

FastReport.Net Class Reference
BarcodeCodabar Properties
BarcodeCodabar Class See Also Send Feedback

The BarcodeCodabar type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Overrides LinearBarcodeBase..::.IsNumeric.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeCodabar Class
FastReport.Barcode Namespace


IsNumeric Property

[image]

FastReport.Net Class Reference
BarcodeCodabar..::.IsNumeric Property
BarcodeCodabar Class See Also Send Feedback
Gets the value indicating that the barcode is numeric.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsNumeric { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsNumeric As Boolean
Visual C++
public:
virtual property bool IsNumeric {
    bool get () override;
}

See Also

BarcodeCodabar Class
FastReport.Barcode Namespace


BarcodeDatamatrix Class

[image]

FastReport.Net Class Reference
BarcodeDatamatrix Class
Members See Also Send Feedback
Generates the 2D Data Matrix barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeDatamatrix : Barcode2DBase
Visual Basic (Declaration)
Public Class BarcodeDatamatrix _
    Inherits Barcode2DBase
Visual C++
public ref class BarcodeDatamatrix : public Barcode2DBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.Barcode2DBase
FastReport.Barcode..::.BarcodeDatamatrix

See Also

BarcodeDatamatrix Members
FastReport.Barcode Namespace


BarcodeDatamatrix Members

[image] [image]

FastReport.Net Class Reference
BarcodeDatamatrix Members
BarcodeDatamatrix Class Constructors Methods Properties See Also Send Feedback

The BarcodeDatamatrix type exposes the following members.

Constructors

Name | Description
BarcodeDatamatrix | Initializes a new instance of the BarcodeDatamatrix class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CodePage | Gets or sets the code page used for text conversion.
Encoding | Gets or sets the encoding mode.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
PixelSize | Gets or sets the size of the pixel.
SymbolSize | Gets or sets the symbol size.

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


BarcodeDatamatrix Constructor

[image]

FastReport.Net Class Reference
BarcodeDatamatrix Constructor
BarcodeDatamatrix Class See Also Send Feedback
Initializes a new instance of the BarcodeDatamatrix class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeDatamatrix()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeDatamatrix()

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


BarcodeDatamatrix Methods

[image] [image]

FastReport.Net Class Reference
BarcodeDatamatrix Methods
BarcodeDatamatrix Class See Also Send Feedback

The BarcodeDatamatrix type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
BarcodeDatamatrix..::.Assign Method
BarcodeDatamatrix Class See Also Send Feedback
Assigns properties from other, similar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    BarcodeBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As BarcodeBase _
)
Visual C++
public:
virtual void Assign(
    BarcodeBase^ source
) override

Parameters

source
Type: FastReport.Barcode..::.BarcodeBase
Barcode object to assign properties from.

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


BarcodeDatamatrix Properties

[image] [image]

FastReport.Net Class Reference
BarcodeDatamatrix Properties
BarcodeDatamatrix Class See Also Send Feedback

The BarcodeDatamatrix type exposes the following members.

Properties

Name | Description
CodePage | Gets or sets the code page used for text conversion.
Encoding | Gets or sets the encoding mode.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
PixelSize | Gets or sets the size of the pixel.
SymbolSize | Gets or sets the symbol size.

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


CodePage Property

[image]

FastReport.Net Class Reference
BarcodeDatamatrix..::.CodePage Property
BarcodeDatamatrix Class See Also Send Feedback
Gets or sets the code page used for text conversion.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CodePage { get; set; }
Visual Basic (Declaration)
Public Property CodePage As Integer
Visual C++
public:
property int CodePage {
    int get ();
    void set (int value);
}

Remarks

Use this property to encode non-ASCII characters. For example, set this property to 1251 to use Window CP1251.

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


Encoding Property

[image]

FastReport.Net Class Reference
BarcodeDatamatrix..::.Encoding Property
BarcodeDatamatrix Class See Also Send Feedback
Gets or sets the encoding mode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DatamatrixEncoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As DatamatrixEncoding
Visual C++
public:
property DatamatrixEncoding Encoding {
    DatamatrixEncoding get ();
    void set (DatamatrixEncoding value);
}

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


PixelSize Property

[image]

FastReport.Net Class Reference
BarcodeDatamatrix..::.PixelSize Property
BarcodeDatamatrix Class See Also Send Feedback
Gets or sets the size of the pixel.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PixelSize { get; set; }
Visual Basic (Declaration)
Public Property PixelSize As Integer
Visual C++
public:
property int PixelSize {
    int get ();
    void set (int value);
}

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


SymbolSize Property

[image]

FastReport.Net Class Reference
BarcodeDatamatrix..::.SymbolSize Property
BarcodeDatamatrix Class See Also Send Feedback
Gets or sets the symbol size.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DatamatrixSymbolSize SymbolSize { get; set; }
Visual Basic (Declaration)
Public Property SymbolSize As DatamatrixSymbolSize
Visual C++
public:
property DatamatrixSymbolSize SymbolSize {
    DatamatrixSymbolSize get ();
    void set (DatamatrixSymbolSize value);
}

See Also

BarcodeDatamatrix Class
FastReport.Barcode Namespace


BarcodeEAN Class

[image]

FastReport.Net Class Reference
BarcodeEAN Class
Members See Also Send Feedback
The base class for EAN barcodes.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class BarcodeEAN : LinearBarcodeBase
Visual Basic (Declaration)
Public MustInherit Class BarcodeEAN _
    Inherits LinearBarcodeBase
Visual C++
public ref class BarcodeEAN abstract : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeEAN13
FastReport.Barcode..::.BarcodeEAN8
FastReport.Barcode..::.BarcodeUPC_E0

See Also

BarcodeEAN Members
FastReport.Barcode Namespace


BarcodeEAN Members

[image] [image]

FastReport.Net Class Reference
BarcodeEAN Members
BarcodeEAN Class Constructors Methods Properties See Also Send Feedback

The BarcodeEAN type exposes the following members.

Constructors

Name | Description
BarcodeEAN | Initializes a new instance of the BarcodeEAN class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeEAN Class
FastReport.Barcode Namespace


BarcodeEAN Constructor

[image]

FastReport.Net Class Reference
BarcodeEAN Constructor
BarcodeEAN Class See Also Send Feedback
Initializes a new instance of the BarcodeEAN class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeEAN()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeEAN()

See Also

BarcodeEAN Class
FastReport.Barcode Namespace


BarcodeEAN Methods

[image] [image]

FastReport.Net Class Reference
BarcodeEAN Methods
BarcodeEAN Class See Also Send Feedback

The BarcodeEAN type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeEAN Class
FastReport.Barcode Namespace


BarcodeEAN Properties

[image] [image]

FastReport.Net Class Reference
BarcodeEAN Properties
BarcodeEAN Class See Also Send Feedback

The BarcodeEAN type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeEAN Class
FastReport.Barcode Namespace


BarcodeEAN13 Class

[image]

FastReport.Net Class Reference
BarcodeEAN13 Class
Members See Also Send Feedback
Generates the EAN13 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeEAN13 : BarcodeEAN
Visual Basic (Declaration)
Public Class BarcodeEAN13 _
    Inherits BarcodeEAN
Visual C++
public ref class BarcodeEAN13 : public BarcodeEAN

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeEAN13

See Also

BarcodeEAN13 Members
FastReport.Barcode Namespace


BarcodeEAN13 Members

[image] [image]

FastReport.Net Class Reference
BarcodeEAN13 Members
BarcodeEAN13 Class Constructors Methods Properties See Also Send Feedback

The BarcodeEAN13 type exposes the following members.

Constructors

Name | Description
BarcodeEAN13 | Initializes a new instance of the BarcodeEAN13 class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeEAN13 Class
FastReport.Barcode Namespace


BarcodeEAN13 Constructor

[image]

FastReport.Net Class Reference
BarcodeEAN13 Constructor
BarcodeEAN13 Class See Also Send Feedback
Initializes a new instance of the BarcodeEAN13 class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeEAN13()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeEAN13()

See Also

BarcodeEAN13 Class
FastReport.Barcode Namespace


BarcodeEAN13 Methods

[image] [image]

FastReport.Net Class Reference
BarcodeEAN13 Methods
BarcodeEAN13 Class See Also Send Feedback

The BarcodeEAN13 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeEAN13 Class
FastReport.Barcode Namespace


BarcodeEAN13 Properties

[image] [image]

FastReport.Net Class Reference
BarcodeEAN13 Properties
BarcodeEAN13 Class See Also Send Feedback

The BarcodeEAN13 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeEAN13 Class
FastReport.Barcode Namespace


BarcodeEAN8 Class

[image]

FastReport.Net Class Reference
BarcodeEAN8 Class
Members See Also Send Feedback
Generates the EAN8 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeEAN8 : BarcodeEAN
Visual Basic (Declaration)
Public Class BarcodeEAN8 _
    Inherits BarcodeEAN
Visual C++
public ref class BarcodeEAN8 : public BarcodeEAN

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeEAN8

See Also

BarcodeEAN8 Members
FastReport.Barcode Namespace


BarcodeEAN8 Members

[image] [image]

FastReport.Net Class Reference
BarcodeEAN8 Members
BarcodeEAN8 Class Constructors Methods Properties See Also Send Feedback

The BarcodeEAN8 type exposes the following members.

Constructors

Name | Description
BarcodeEAN8 | Initializes a new instance of the BarcodeEAN8 class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeEAN8 Class
FastReport.Barcode Namespace


BarcodeEAN8 Constructor

[image]

FastReport.Net Class Reference
BarcodeEAN8 Constructor
BarcodeEAN8 Class See Also Send Feedback
Initializes a new instance of the BarcodeEAN8 class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeEAN8()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeEAN8()

See Also

BarcodeEAN8 Class
FastReport.Barcode Namespace


BarcodeEAN8 Methods

[image] [image]

FastReport.Net Class Reference
BarcodeEAN8 Methods
BarcodeEAN8 Class See Also Send Feedback

The BarcodeEAN8 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeEAN8 Class
FastReport.Barcode Namespace


BarcodeEAN8 Properties

[image] [image]

FastReport.Net Class Reference
BarcodeEAN8 Properties
BarcodeEAN8 Class See Also Send Feedback

The BarcodeEAN8 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeEAN8 Class
FastReport.Barcode Namespace


BarcodeMSI Class

[image]

FastReport.Net Class Reference
BarcodeMSI Class
Members See Also Send Feedback
Generates the MSI barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeMSI : LinearBarcodeBase
Visual Basic (Declaration)
Public Class BarcodeMSI _
    Inherits LinearBarcodeBase
Visual C++
public ref class BarcodeMSI : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeMSI

See Also

BarcodeMSI Members
FastReport.Barcode Namespace


BarcodeMSI Members

[image] [image]

FastReport.Net Class Reference
BarcodeMSI Members
BarcodeMSI Class Constructors Methods Properties See Also Send Feedback

The BarcodeMSI type exposes the following members.

Constructors

Name | Description
BarcodeMSI | Initializes a new instance of the BarcodeMSI class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeMSI Class
FastReport.Barcode Namespace


BarcodeMSI Constructor

[image]

FastReport.Net Class Reference
BarcodeMSI Constructor
BarcodeMSI Class See Also Send Feedback
Initializes a new instance of the BarcodeMSI class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeMSI()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeMSI()

See Also

BarcodeMSI Class
FastReport.Barcode Namespace


BarcodeMSI Methods

[image] [image]

FastReport.Net Class Reference
BarcodeMSI Methods
BarcodeMSI Class See Also Send Feedback

The BarcodeMSI type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeMSI Class
FastReport.Barcode Namespace


BarcodeMSI Properties

[image] [image]

FastReport.Net Class Reference
BarcodeMSI Properties
BarcodeMSI Class See Also Send Feedback

The BarcodeMSI type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeMSI Class
FastReport.Barcode Namespace


BarcodeObject Class

[image]

FastReport.Net Class Reference
BarcodeObject Class
Members Example See Also Send Feedback
Represents a barcode object.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeObject : ReportComponentBase
Visual Basic (Declaration)
Public Class BarcodeObject _
    Inherits ReportComponentBase
Visual C++
public ref class BarcodeObject : public ReportComponentBase

Remarks

The instance of this class represents a barcode. Here are some common actions that can be performed with this object:
  • To select the type of barcode, use the Barcode property.
  • To specify a static barcode data, use the Text property. You also may use the DataColumn or Expression properties to specify dynamic value for a barcode.
  • To set a barcode orientation, use the Angle property.
  • To specify the size of barcode, set the AutoSize property to true and use the Zoom property to zoom the barcode. If AutoSize property is set to false, you need to specify the size using the Width and Height properties.

Examples

This example shows how to configure the BarcodeObject to display PDF417 barcode.
CopyC#
BarcodeObject barcode;
...
barcode.Barcode = new BarcodePDF417();
(barcode.Barcode as BarcodePDF417).CompactionMode = CompactionMode.Text;

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport.Barcode..::.BarcodeObject

See Also

BarcodeObject Members
FastReport.Barcode Namespace


BarcodeObject Members

[image] [image]

FastReport.Net Class Reference
BarcodeObject Members
BarcodeObject Class Constructors Methods Properties Events See Also Send Feedback

The BarcodeObject type exposes the following members.

Constructors

Name | Description
BarcodeObject | Initializes a new instance of the BarcodeObject class with default settings.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | Gets or sets the angle of barcode, in degrees.
AutoSize | Gets or sets a value that determines whether the barcode should handle its width automatically.
Barcode | Gets or sets the barcode type.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a data column name bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Expression | Gets or sets an expression that contains the barcode data.
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideIfNoData | Gets or sets a value that determines whether it is necessary to hide the object if the barcode data is empty.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NoDataText | Gets or sets the text that will be displayed if the barcode data is empty.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the BarcodeObject.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShowText | Gets or sets a value that indicates if the barcode should display a human-readable text.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
SymbologyName | Gets or sets the symbology name.
Text | Gets or sets the barcode data.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
Zoom | Gets or sets a zoom of the barcode.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

BarcodeObject Class
FastReport.Barcode Namespace


BarcodeObject Constructor

[image]

FastReport.Net Class Reference
BarcodeObject Constructor
BarcodeObject Class See Also Send Feedback
Initializes a new instance of the BarcodeObject class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeObject()

See Also

BarcodeObject Class
FastReport.Barcode Namespace


BarcodeObject Methods

[image] [image]

FastReport.Net Class Reference
BarcodeObject Methods
BarcodeObject Class See Also Send Feedback

The BarcodeObject type exposes the following members.

Methods

Name | Description
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides ComponentBase..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RestoreState | Restores the object's state after printing it. (Inherited from ReportComponentBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from ReportComponentBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.Assign Method
BarcodeObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

BarcodeObject Class
FastReport.Barcode Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
BarcodeObject..::.Dispose Method
BarcodeObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

BarcodeObject Class
BarcodeObject Members
FastReport.Barcode Namespace


Draw Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.Draw Method
BarcodeObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

BarcodeObject Class
FastReport.Barcode Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
BarcodeObject..::.DrawMarkers Method
BarcodeObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

BarcodeObject Class
BarcodeObject Members
FastReport.Barcode Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.GetContextMenu Method
BarcodeObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

BarcodeObject Class
FastReport.Barcode Namespace


GetData Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.GetData Method
BarcodeObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

BarcodeObject Class
FastReport.Barcode Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.GetExpressions Method
BarcodeObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

BarcodeObject Class
FastReport.Barcode Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.GetPreferredSize Method
BarcodeObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

BarcodeObject Class
FastReport.Barcode Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.GetSmartTag Method
BarcodeObject Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

BarcodeObject Class
FastReport.Barcode Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BarcodeObject..::.MemberwiseClone Method
BarcodeObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BarcodeObject Class
BarcodeObject Members
FastReport.Barcode Namespace


Serialize Method

[image]

FastReport.Net Class Reference
BarcodeObject..::.Serialize Method
BarcodeObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

BarcodeObject Class
FastReport.Barcode Namespace


BarcodeObject Properties

[image] [image]

FastReport.Net Class Reference
BarcodeObject Properties
BarcodeObject Class See Also Send Feedback

The BarcodeObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Angle | Gets or sets the angle of barcode, in degrees.
AutoSize | Gets or sets a value that determines whether the barcode should handle its width automatically.
Barcode | Gets or sets the barcode type.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataColumn | Gets or sets a data column name bound to this control.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Expression | Gets or sets an expression that contains the barcode data.
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HideIfNoData | Gets or sets a value that determines whether it is necessary to hide the object if the barcode data is empty.
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NoDataText | Gets or sets the text that will be displayed if the barcode data is empty.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the BarcodeObject.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShowText | Gets or sets a value that indicates if the barcode should display a human-readable text.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
SymbologyName | Gets or sets the symbology name.
Text | Gets or sets the barcode data.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
Zoom | Gets or sets a zoom of the barcode.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Angle Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.Angle Property
BarcodeObject Class See Also Send Feedback
Gets or sets the angle of barcode, in degrees.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.AutoSize Property
BarcodeObject Class See Also Send Feedback
Gets or sets a value that determines whether the barcode should handle its width automatically.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Barcode Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.Barcode Property
BarcodeObject Class See Also Send Feedback
Gets or sets the barcode type.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeBase Barcode { get; set; }
Visual Basic (Declaration)
Public Property Barcode As BarcodeBase
Visual C++
public:
property BarcodeBase^ Barcode {
    BarcodeBase^ get ();
    void set (BarcodeBase^ value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.DataColumn Property
BarcodeObject Class See Also Send Feedback
Gets or sets a data column name bound to this control.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

Value must be in the form "Datasource.Column".

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Expression Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.Expression Property
BarcodeObject Class See Also Send Feedback
Gets or sets an expression that contains the barcode data.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


HideIfNoData Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.HideIfNoData Property
BarcodeObject Class See Also Send Feedback
Gets or sets a value that determines whether it is necessary to hide the object if the barcode data is empty.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideIfNoData { get; set; }
Visual Basic (Declaration)
Public Property HideIfNoData As Boolean
Visual C++
public:
property bool HideIfNoData {
    bool get ();
    void set (bool value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


NoDataText Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.NoDataText Property
BarcodeObject Class See Also Send Feedback
Gets or sets the text that will be displayed if the barcode data is empty.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string NoDataText { get; set; }
Visual Basic (Declaration)
Public Property NoDataText As String
Visual C++
public:
property String^ NoDataText {
    String^ get ();
    void set (String^ value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Padding Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.Padding Property
BarcodeObject Class See Also Send Feedback
Gets or sets padding within the BarcodeObject.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


ShowText Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.ShowText Property
BarcodeObject Class See Also Send Feedback
Gets or sets a value that indicates if the barcode should display a human-readable text.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowText { get; set; }
Visual Basic (Declaration)
Public Property ShowText As Boolean
Visual C++
public:
property bool ShowText {
    bool get ();
    void set (bool value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


SymbologyName Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.SymbologyName Property
BarcodeObject Class Example See Also Send Feedback
Gets or sets the symbology name.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SymbologyName { get; set; }
Visual Basic (Declaration)
Public Property SymbologyName As String
Visual C++
public:
property String^ SymbologyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The following symbology names are supported:
  • "2/5 Interleaved"
  • "2/5 Industrial"
  • "2/5 Matrix"
  • "Codabar"
  • "Code128"
  • "Code39"
  • "Code39 Extended"
  • "Code93"
  • "Code93 Extended"
  • "EAN8"
  • "EAN13"
  • "MSI"
  • "PostNet"
  • "UPC-A"
  • "UPC-E0"
  • "UPC-E1"
  • "Supplement 2"
  • "Supplement 5"
  • "PDF417"
  • "Datamatrix"
  • "QRCode"

Examples

CopyC#
barcode.SymbologyName = "PDF417";
(barcode.Barcode as BarcodePDF417).CompactionMode = CompactionMode.Text;

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Text Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.Text Property
BarcodeObject Class See Also Send Feedback
Gets or sets the barcode data.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


Zoom Property

[image]

FastReport.Net Class Reference
BarcodeObject..::.Zoom Property
BarcodeObject Class See Also Send Feedback
Gets or sets a zoom of the barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Single
Visual C++
public:
property float Zoom {
    float get ();
    void set (float value);
}

See Also

BarcodeObject Class
FastReport.Barcode Namespace


BarcodeObject Events

[image] [image]

FastReport.Net Class Reference
BarcodeObject Events
BarcodeObject Class See Also Send Feedback

The BarcodeObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

BarcodeObject Class
FastReport.Barcode Namespace


BarcodePDF417 Class

[image]

FastReport.Net Class Reference
BarcodePDF417 Class
Members Example See Also Send Feedback
Generates the 2D PDF417 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodePDF417 : Barcode2DBase
Visual Basic (Declaration)
Public Class BarcodePDF417 _
    Inherits Barcode2DBase
Visual C++
public ref class BarcodePDF417 : public Barcode2DBase

Examples

This example shows how to configure the BarcodeObject to display PDF417 barcode.
CopyC#
BarcodeObject barcode;
...
barcode.Barcode = new BarcodePDF417();
(barcode.Barcode as BarcodePDF417).CompactionMode = PDF417CompactionMode.Text;

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.Barcode2DBase
FastReport.Barcode..::.BarcodePDF417

See Also

BarcodePDF417 Members
FastReport.Barcode Namespace


BarcodePDF417 Members

[image] [image]

FastReport.Net Class Reference
BarcodePDF417 Members
BarcodePDF417 Class Constructors Methods Properties See Also Send Feedback

The BarcodePDF417 type exposes the following members.

Constructors

Name | Description
BarcodePDF417 | Initializes a new instance of the BarcodePDF417 class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AspectRatio | Gets or sets the barcode aspect ratio.
CodePage | Gets or sets the code page used for text conversion.
Columns | Gets or sets the number of barcode data columns.
CompactionMode | Gets or sets the compaction mode.
ErrorCorrection | Gets or sets the error level correction used for the barcode.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
PixelSize | Gets or sets the size of the pixel.
Rows | Gets or sets the number of barcode data rows.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


BarcodePDF417 Constructor

[image]

FastReport.Net Class Reference
BarcodePDF417 Constructor
BarcodePDF417 Class See Also Send Feedback
Initializes a new instance of the BarcodePDF417 class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodePDF417()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodePDF417()

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


BarcodePDF417 Methods

[image] [image]

FastReport.Net Class Reference
BarcodePDF417 Methods
BarcodePDF417 Class See Also Send Feedback

The BarcodePDF417 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
BarcodePDF417..::.Assign Method
BarcodePDF417 Class See Also Send Feedback
Assigns properties from other, similar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    BarcodeBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As BarcodeBase _
)
Visual C++
public:
virtual void Assign(
    BarcodeBase^ source
) override

Parameters

source
Type: FastReport.Barcode..::.BarcodeBase
Barcode object to assign properties from.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


BarcodePDF417 Properties

[image] [image]

FastReport.Net Class Reference
BarcodePDF417 Properties
BarcodePDF417 Class See Also Send Feedback

The BarcodePDF417 type exposes the following members.

Properties

Name | Description
AspectRatio | Gets or sets the barcode aspect ratio.
CodePage | Gets or sets the code page used for text conversion.
Columns | Gets or sets the number of barcode data columns.
CompactionMode | Gets or sets the compaction mode.
ErrorCorrection | Gets or sets the error level correction used for the barcode.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
PixelSize | Gets or sets the size of the pixel.
Rows | Gets or sets the number of barcode data rows.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


AspectRatio Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.AspectRatio Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the barcode aspect ratio.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float AspectRatio { get; set; }
Visual Basic (Declaration)
Public Property AspectRatio As Single
Visual C++
public:
property float AspectRatio {
    float get ();
    void set (float value);
}

Remarks

A ratio or 0.5 will make the barcode width twice as large as the height.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


CodePage Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.CodePage Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the code page used for text conversion.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CodePage { get; set; }
Visual Basic (Declaration)
Public Property CodePage As Integer
Visual C++
public:
property int CodePage {
    int get ();
    void set (int value);
}

Remarks

Use this property to encode non-ASCII characters. For example, set this property to 1251 to use Window CP1251.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


Columns Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.Columns Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the number of barcode data columns.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Columns { get; set; }
Visual Basic (Declaration)
Public Property Columns As Integer
Visual C++
public:
property int Columns {
    int get ();
    void set (int value);
}

Remarks

To calculate the necessary number of columns and rows, set the Columns and Rows properties to 0. In this case, the AspectRatio property should be set to desired aspect ratio.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


CompactionMode Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.CompactionMode Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the compaction mode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PDF417CompactionMode CompactionMode { get; set; }
Visual Basic (Declaration)
Public Property CompactionMode As PDF417CompactionMode
Visual C++
public:
property PDF417CompactionMode CompactionMode {
    PDF417CompactionMode get ();
    void set (PDF417CompactionMode value);
}

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


ErrorCorrection Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.ErrorCorrection Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the error level correction used for the barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PDF417ErrorCorrection ErrorCorrection { get; set; }
Visual Basic (Declaration)
Public Property ErrorCorrection As PDF417ErrorCorrection
Visual C++
public:
property PDF417ErrorCorrection ErrorCorrection {
    PDF417ErrorCorrection get ();
    void set (PDF417ErrorCorrection value);
}

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


PixelSize Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.PixelSize Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the size of the pixel.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Size PixelSize { get; set; }
Visual Basic (Declaration)
Public Property PixelSize As Size
Visual C++
public:
property Size PixelSize {
    Size get ();
    void set (Size value);
}

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


Rows Property

[image]

FastReport.Net Class Reference
BarcodePDF417..::.Rows Property
BarcodePDF417 Class See Also Send Feedback
Gets or sets the number of barcode data rows.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Rows { get; set; }
Visual Basic (Declaration)
Public Property Rows As Integer
Visual C++
public:
property int Rows {
    int get ();
    void set (int value);
}

Remarks

To calculate the necessary number of columns and rows, set the Columns and Rows properties to 0. In this case, the AspectRatio property should be set to desired aspect ratio.

See Also

BarcodePDF417 Class
FastReport.Barcode Namespace


BarcodePostNet Class

[image]

FastReport.Net Class Reference
BarcodePostNet Class
Members See Also Send Feedback
Generates the PostNet barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodePostNet : LinearBarcodeBase
Visual Basic (Declaration)
Public Class BarcodePostNet _
    Inherits LinearBarcodeBase
Visual C++
public ref class BarcodePostNet : public LinearBarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodePostNet

See Also

BarcodePostNet Members
FastReport.Barcode Namespace


BarcodePostNet Members

[image] [image]

FastReport.Net Class Reference
BarcodePostNet Members
BarcodePostNet Class Constructors Methods Properties See Also Send Feedback

The BarcodePostNet type exposes the following members.

Constructors

Name | Description
BarcodePostNet | Initializes a new instance of the BarcodePostNet class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodePostNet Class
FastReport.Barcode Namespace


BarcodePostNet Constructor

[image]

FastReport.Net Class Reference
BarcodePostNet Constructor
BarcodePostNet Class See Also Send Feedback
Initializes a new instance of the BarcodePostNet class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodePostNet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodePostNet()

See Also

BarcodePostNet Class
FastReport.Barcode Namespace


BarcodePostNet Methods

[image] [image]

FastReport.Net Class Reference
BarcodePostNet Methods
BarcodePostNet Class See Also Send Feedback

The BarcodePostNet type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodePostNet Class
FastReport.Barcode Namespace


BarcodePostNet Properties

[image] [image]

FastReport.Net Class Reference
BarcodePostNet Properties
BarcodePostNet Class See Also Send Feedback

The BarcodePostNet type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodePostNet Class
FastReport.Barcode Namespace


BarcodeQR Class

[image]

FastReport.Net Class Reference
BarcodeQR Class
Members See Also Send Feedback
Generates the 2D QR code barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeQR : Barcode2DBase
Visual Basic (Declaration)
Public Class BarcodeQR _
    Inherits Barcode2DBase
Visual C++
public ref class BarcodeQR : public Barcode2DBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.Barcode2DBase
FastReport.Barcode..::.BarcodeQR

See Also

BarcodeQR Members
FastReport.Barcode Namespace


BarcodeQR Members

[image] [image]

FastReport.Net Class Reference
BarcodeQR Members
BarcodeQR Class Constructors Methods Properties See Also Send Feedback

The BarcodeQR type exposes the following members.

Constructors

Name | Description
BarcodeQR | Initializes a new instance of the BarcodeQR class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Encoding | Gets or sets the encoding used for text conversion.
ErrorCorrection | Gets or sets the error correction.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
QuietZone | Gets or sets the value indicating that quiet zone must be shown.

See Also

BarcodeQR Class
FastReport.Barcode Namespace


BarcodeQR Constructor

[image]

FastReport.Net Class Reference
BarcodeQR Constructor
BarcodeQR Class See Also Send Feedback
Initializes a new instance of the BarcodeQR class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeQR()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeQR()

See Also

BarcodeQR Class
FastReport.Barcode Namespace


BarcodeQR Methods

[image] [image]

FastReport.Net Class Reference
BarcodeQR Methods
BarcodeQR Class See Also Send Feedback

The BarcodeQR type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeQR Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
BarcodeQR..::.Assign Method
BarcodeQR Class See Also Send Feedback
Assigns properties from other, similar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    BarcodeBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As BarcodeBase _
)
Visual C++
public:
virtual void Assign(
    BarcodeBase^ source
) override

Parameters

source
Type: FastReport.Barcode..::.BarcodeBase
Barcode object to assign properties from.

See Also

BarcodeQR Class
FastReport.Barcode Namespace


BarcodeQR Properties

[image] [image]

FastReport.Net Class Reference
BarcodeQR Properties
BarcodeQR Class See Also Send Feedback

The BarcodeQR type exposes the following members.

Properties

Name | Description
Encoding | Gets or sets the encoding used for text conversion.
ErrorCorrection | Gets or sets the error correction.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
QuietZone | Gets or sets the value indicating that quiet zone must be shown.

See Also

BarcodeQR Class
FastReport.Barcode Namespace


Encoding Property

[image]

FastReport.Net Class Reference
BarcodeQR..::.Encoding Property
BarcodeQR Class See Also Send Feedback
Gets or sets the encoding used for text conversion.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public QRCodeEncoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As QRCodeEncoding
Visual C++
public:
property QRCodeEncoding Encoding {
    QRCodeEncoding get ();
    void set (QRCodeEncoding value);
}

See Also

BarcodeQR Class
FastReport.Barcode Namespace


ErrorCorrection Property

[image]

FastReport.Net Class Reference
BarcodeQR..::.ErrorCorrection Property
BarcodeQR Class See Also Send Feedback
Gets or sets the error correction.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public QRCodeErrorCorrection ErrorCorrection { get; set; }
Visual Basic (Declaration)
Public Property ErrorCorrection As QRCodeErrorCorrection
Visual C++
public:
property QRCodeErrorCorrection ErrorCorrection {
    QRCodeErrorCorrection get ();
    void set (QRCodeErrorCorrection value);
}

See Also

BarcodeQR Class
FastReport.Barcode Namespace


QuietZone Property

[image]

FastReport.Net Class Reference
BarcodeQR..::.QuietZone Property
BarcodeQR Class See Also Send Feedback
Gets or sets the value indicating that quiet zone must be shown.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool QuietZone { get; set; }
Visual Basic (Declaration)
Public Property QuietZone As Boolean
Visual C++
public:
property bool QuietZone {
    bool get ();
    void set (bool value);
}

See Also

BarcodeQR Class
FastReport.Barcode Namespace


BarcodeSupplement2 Class

[image]

FastReport.Net Class Reference
BarcodeSupplement2 Class
Members See Also Send Feedback
Generates the 2-digit supplement barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeSupplement2 : BarcodeUPC_E0
Visual Basic (Declaration)
Public Class BarcodeSupplement2 _
    Inherits BarcodeUPC_E0
Visual C++
public ref class BarcodeSupplement2 : public BarcodeUPC_E0

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeUPC_E0
FastReport.Barcode..::.BarcodeSupplement2

See Also

BarcodeSupplement2 Members
FastReport.Barcode Namespace


BarcodeSupplement2 Members

[image] [image]

FastReport.Net Class Reference
BarcodeSupplement2 Members
BarcodeSupplement2 Class Constructors Methods Properties See Also Send Feedback

The BarcodeSupplement2 type exposes the following members.

Constructors

Name | Description
BarcodeSupplement2 | Initializes a new instance of the BarcodeSupplement2 class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeSupplement2 Class
FastReport.Barcode Namespace


BarcodeSupplement2 Constructor

[image]

FastReport.Net Class Reference
BarcodeSupplement2 Constructor
BarcodeSupplement2 Class See Also Send Feedback
Initializes a new instance of the BarcodeSupplement2 class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeSupplement2()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeSupplement2()

See Also

BarcodeSupplement2 Class
FastReport.Barcode Namespace


BarcodeSupplement2 Methods

[image] [image]

FastReport.Net Class Reference
BarcodeSupplement2 Methods
BarcodeSupplement2 Class See Also Send Feedback

The BarcodeSupplement2 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeSupplement2 Class
FastReport.Barcode Namespace


BarcodeSupplement2 Properties

[image] [image]

FastReport.Net Class Reference
BarcodeSupplement2 Properties
BarcodeSupplement2 Class See Also Send Feedback

The BarcodeSupplement2 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeSupplement2 Class
FastReport.Barcode Namespace


BarcodeUPC_A Class

[image]

FastReport.Net Class Reference
BarcodeUPC_A Class
Members See Also Send Feedback
Generates the UPC A barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeUPC_A : BarcodeUPC_E0
Visual Basic (Declaration)
Public Class BarcodeUPC_A _
    Inherits BarcodeUPC_E0
Visual C++
public ref class BarcodeUPC_A : public BarcodeUPC_E0

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeUPC_E0
FastReport.Barcode..::.BarcodeUPC_A

See Also

BarcodeUPC_A Members
FastReport.Barcode Namespace


BarcodeUPC_A Members

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_A Members
BarcodeUPC_A Class Constructors Methods Properties See Also Send Feedback

The BarcodeUPC_A type exposes the following members.

Constructors

Name | Description
BarcodeUPC_A | Initializes a new instance of the BarcodeUPC_A class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeUPC_A Class
FastReport.Barcode Namespace


BarcodeUPC_A Constructor

[image]

FastReport.Net Class Reference
BarcodeUPC_A Constructor
BarcodeUPC_A Class See Also Send Feedback
Initializes a new instance of the BarcodeUPC_A class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeUPC_A()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeUPC_A()

See Also

BarcodeUPC_A Class
FastReport.Barcode Namespace


BarcodeUPC_A Methods

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_A Methods
BarcodeUPC_A Class See Also Send Feedback

The BarcodeUPC_A type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeUPC_A Class
FastReport.Barcode Namespace


BarcodeUPC_A Properties

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_A Properties
BarcodeUPC_A Class See Also Send Feedback

The BarcodeUPC_A type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeUPC_A Class
FastReport.Barcode Namespace


BarcodeUPC_E0 Class

[image]

FastReport.Net Class Reference
BarcodeUPC_E0 Class
Members See Also Send Feedback
Generates the UPC E0 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeUPC_E0 : BarcodeEAN
Visual Basic (Declaration)
Public Class BarcodeUPC_E0 _
    Inherits BarcodeEAN
Visual C++
public ref class BarcodeUPC_E0 : public BarcodeEAN

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeUPC_E0
FastReport.Barcode..::.BarcodeSupplement2
FastReport.Barcode..::.BarcodeUPC_A
FastReport.Barcode..::.BarcodeUPC_E1

See Also

BarcodeUPC_E0 Members
FastReport.Barcode Namespace


BarcodeUPC_E0 Members

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_E0 Members
BarcodeUPC_E0 Class Constructors Methods Properties See Also Send Feedback

The BarcodeUPC_E0 type exposes the following members.

Constructors

Name | Description
BarcodeUPC_E0 | Initializes a new instance of the BarcodeUPC_E0 class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeUPC_E0 Class
FastReport.Barcode Namespace


BarcodeUPC_E0 Constructor

[image]

FastReport.Net Class Reference
BarcodeUPC_E0 Constructor
BarcodeUPC_E0 Class See Also Send Feedback
Initializes a new instance of the BarcodeUPC_E0 class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeUPC_E0()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeUPC_E0()

See Also

BarcodeUPC_E0 Class
FastReport.Barcode Namespace


BarcodeUPC_E0 Methods

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_E0 Methods
BarcodeUPC_E0 Class See Also Send Feedback

The BarcodeUPC_E0 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeUPC_E0 Class
FastReport.Barcode Namespace


BarcodeUPC_E0 Properties

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_E0 Properties
BarcodeUPC_E0 Class See Also Send Feedback

The BarcodeUPC_E0 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeUPC_E0 Class
FastReport.Barcode Namespace


BarcodeUPC_E1 Class

[image]

FastReport.Net Class Reference
BarcodeUPC_E1 Class
Members See Also Send Feedback
Generates the UPC E1 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BarcodeUPC_E1 : BarcodeUPC_E0
Visual Basic (Declaration)
Public Class BarcodeUPC_E1 _
    Inherits BarcodeUPC_E0
Visual C++
public ref class BarcodeUPC_E1 : public BarcodeUPC_E0

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeUPC_E0
FastReport.Barcode..::.BarcodeUPC_E1

See Also

BarcodeUPC_E1 Members
FastReport.Barcode Namespace


BarcodeUPC_E1 Members

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_E1 Members
BarcodeUPC_E1 Class Constructors Methods Properties See Also Send Feedback

The BarcodeUPC_E1 type exposes the following members.

Constructors

Name | Description
BarcodeUPC_E1 | Initializes a new instance of the BarcodeUPC_E1 class

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeUPC_E1 Class
FastReport.Barcode Namespace


BarcodeUPC_E1 Constructor

[image]

FastReport.Net Class Reference
BarcodeUPC_E1 Constructor
BarcodeUPC_E1 Class See Also Send Feedback
Initializes a new instance of the BarcodeUPC_E1 class

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BarcodeUPC_E1()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarcodeUPC_E1()

See Also

BarcodeUPC_E1 Class
FastReport.Barcode Namespace


BarcodeUPC_E1 Methods

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_E1 Methods
BarcodeUPC_E1 Class See Also Send Feedback

The BarcodeUPC_E1 type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Inherited from LinearBarcodeBase.)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeUPC_E1 Class
FastReport.Barcode Namespace


BarcodeUPC_E1 Properties

[image] [image]

FastReport.Net Class Reference
BarcodeUPC_E1 Properties
BarcodeUPC_E1 Class See Also Send Feedback

The BarcodeUPC_E1 type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically. (Inherited from LinearBarcodeBase.)
IsNumeric | Gets the value indicating that the barcode is numeric. (Inherited from LinearBarcodeBase.)
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode. (Inherited from LinearBarcodeBase.)

See Also

BarcodeUPC_E1 Class
FastReport.Barcode Namespace


DatamatrixEncoding Enumeration

[image]

FastReport.Net Class Reference
DatamatrixEncoding Enumeration
See Also Send Feedback
Specifies the Datamatrix encoding.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum DatamatrixEncoding
Visual Basic (Declaration)
Public Enumeration DatamatrixEncoding
Visual C++
public enum class DatamatrixEncoding

Members

Member name | Description
Auto | Specifies the auto encoding.
Ascii | Specifies the ASCII encoding.
C40 | Specifies the C40 encoding.
Text | Specifies the text encoding.
Base256 | Specifies the binary encoding.
X12 | Specifies the X12 encoding.
Edifact | Specifies the Edifact encoding.

See Also

FastReport.Barcode Namespace


DatamatrixSymbolSize Enumeration

[image]

FastReport.Net Class Reference
DatamatrixSymbolSize Enumeration
See Also Send Feedback
Specifies the Datamatrix symbol size.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum DatamatrixSymbolSize
Visual Basic (Declaration)
Public Enumeration DatamatrixSymbolSize
Visual C++
public enum class DatamatrixSymbolSize

Members

Member name | Description
Auto | Specifies the auto size.
Size10x10 | Specifies the 10x10 size.
Size12x12 | Specifies the 12x12 size.
Size8x18 | Specifies the 8x8 size.
Size14x14 | Specifies the 14x14 size.
Size8x32 | Specifies the 8x32 size.
Size16x16 | Specifies the 16x16 size.
Size12x26 | Specifies the 12x26 size.
Size18x18 | Specifies the 18x18 size.
Size20x20 | Specifies the 20x20 size.
Size12x36 | Specifies the 12x36 size.
Size22x22 | Specifies the 22x22 size.
Size16x36 | Specifies the 16x36 size.
Size24x24 | Specifies the 24x24 size.
Size26x26 | Specifies the 26x26 size.
Size16x48 | Specifies the 16x48 size.
Size32x32 | Specifies the 32x32 size.
Size36x36 | Specifies the 36x36 size.
Size40x40 | Specifies the 40x40 size.
Size44x44 | Specifies the 44x44 size.
Size48x48 | Specifies the 48x48 size.
Size52x52 | Specifies the 52x52 size.
Size64x64 | Specifies the 64x64 size.
Size72x72 | Specifies the 72x72 size.
Size80x80 | Specifies the 80x80 size.
Size88x88 | Specifies the 88x88 size.
Size96x96 | Specifies the 96x96 size.
Size104x104 | Specifies the 104x104 size.
Size120x120 | Specifies the 120x120 size.
Size132x132 | Specifies the 132x132 size.
Size144x144 | Specifies the 144x144 size.

See Also

FastReport.Barcode Namespace


LinearBarcodeBase Class

[image]

FastReport.Net Class Reference
LinearBarcodeBase Class
Members See Also Send Feedback
The base class for linear (1D) barcodes.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LinearBarcodeBase : BarcodeBase
Visual Basic (Declaration)
Public Class LinearBarcodeBase _
    Inherits BarcodeBase
Visual C++
public ref class LinearBarcodeBase : public BarcodeBase

Inheritance Hierarchy

System..::.Object
FastReport.Barcode..::.BarcodeBase
FastReport.Barcode..::.LinearBarcodeBase
FastReport.Barcode..::.Barcode128
FastReport.Barcode..::.Barcode2of5Interleaved
FastReport.Barcode..::.Barcode39
FastReport.Barcode..::.Barcode93
FastReport.Barcode..::.BarcodeCodabar
FastReport.Barcode..::.BarcodeEAN
FastReport.Barcode..::.BarcodeMSI
FastReport.Barcode..::.BarcodePostNet

See Also

LinearBarcodeBase Members
FastReport.Barcode Namespace


LinearBarcodeBase Members

[image] [image]

FastReport.Net Class Reference
LinearBarcodeBase Members
LinearBarcodeBase Class Constructors Methods Properties See Also Send Feedback

The LinearBarcodeBase type exposes the following members.

Constructors

Name | Description
LinearBarcodeBase | Initializes a new instance of the LinearBarcodeBase class with default settings.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically.
IsNumeric | Gets the value indicating that the barcode is numeric.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode.

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


LinearBarcodeBase Constructor

[image]

FastReport.Net Class Reference
LinearBarcodeBase Constructor
LinearBarcodeBase Class See Also Send Feedback
Initializes a new instance of the LinearBarcodeBase class with default settings.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LinearBarcodeBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearBarcodeBase()

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


LinearBarcodeBase Methods

[image] [image]

FastReport.Net Class Reference
LinearBarcodeBase Methods
LinearBarcodeBase Class See Also Send Feedback

The LinearBarcodeBase type exposes the following members.

Methods

Name | Description
Assign | Assigns properties from other, similar barcode. (Overrides BarcodeBase..::.Assign(BarcodeBase).)
Clone | Creates the exact copy of this barcode. (Inherited from BarcodeBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


Assign Method

[image]

FastReport.Net Class Reference
LinearBarcodeBase..::.Assign Method
LinearBarcodeBase Class See Also Send Feedback
Assigns properties from other, similar barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    BarcodeBase source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As BarcodeBase _
)
Visual C++
public:
virtual void Assign(
    BarcodeBase^ source
) override

Parameters

source
Type: FastReport.Barcode..::.BarcodeBase
Barcode object to assign properties from.

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


LinearBarcodeBase Properties

[image] [image]

FastReport.Net Class Reference
LinearBarcodeBase Properties
LinearBarcodeBase Class See Also Send Feedback

The LinearBarcodeBase type exposes the following members.

Properties

Name | Description
CalcCheckSum | Gets or sets a value that determines if the barcode object should calculate the check digit automatically.
IsNumeric | Gets the value indicating that the barcode is numeric.
Name | Gets the name of barcode. (Inherited from BarcodeBase.)
WideBarRatio | Gets or sets a relative width of wide bars in the barcode.

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


CalcCheckSum Property

[image]

FastReport.Net Class Reference
LinearBarcodeBase..::.CalcCheckSum Property
LinearBarcodeBase Class See Also Send Feedback
Gets or sets a value that determines if the barcode object should calculate the check digit automatically.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CalcCheckSum { get; set; }
Visual Basic (Declaration)
Public Property CalcCheckSum As Boolean
Visual C++
public:
property bool CalcCheckSum {
    bool get ();
    void set (bool value);
}

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


IsNumeric Property

[image]

FastReport.Net Class Reference
LinearBarcodeBase..::.IsNumeric Property
LinearBarcodeBase Class See Also Send Feedback
Gets the value indicating that the barcode is numeric.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool IsNumeric { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsNumeric As Boolean
Visual C++
public:
virtual property bool IsNumeric {
    bool get ();
}

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


WideBarRatio Property

[image]

FastReport.Net Class Reference
LinearBarcodeBase..::.WideBarRatio Property
LinearBarcodeBase Class See Also Send Feedback
Gets or sets a relative width of wide bars in the barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float WideBarRatio { get; set; }
Visual Basic (Declaration)
Public Property WideBarRatio As Single
Visual C++
public:
property float WideBarRatio {
    float get ();
    void set (float value);
}

See Also

LinearBarcodeBase Class
FastReport.Barcode Namespace


PDF417CompactionMode Enumeration

[image]

FastReport.Net Class Reference
PDF417CompactionMode Enumeration
See Also Send Feedback
Specifies the compaction mode used for PDF417 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PDF417CompactionMode
Visual Basic (Declaration)
Public Enumeration PDF417CompactionMode
Visual C++
public enum class PDF417CompactionMode

Members

Member name | Description
Auto | Indicates that compaction mode should be calculated automatically.
Text | Specifies the text compaction mode.
Numeric | Specifies the numeric compaction mode.
Binary | Specifies the binary compaction mode.

See Also

FastReport.Barcode Namespace


PDF417ErrorCorrection Enumeration

[image]

FastReport.Net Class Reference
PDF417ErrorCorrection Enumeration
See Also Send Feedback
Specifies the error correction level used for PDF417 barcode.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PDF417ErrorCorrection
Visual Basic (Declaration)
Public Enumeration PDF417ErrorCorrection
Visual C++
public enum class PDF417ErrorCorrection

Members

Member name | Description
Auto | Indicates that correction level should be calculated automatically.
Level0 | Specifies level 0.
Level1 | Specifies level 1.
Level2 | Specifies level 2.
Level3 | Specifies level 3.
Level4 | Specifies level 4.
Level5 | Specifies level 5.
Level6 | Specifies level 6.
Level7 | Specifies level 7.
Level8 | Specifies level 8.

See Also

FastReport.Barcode Namespace


QRCodeEncoding Enumeration

[image]

FastReport.Net Class Reference
QRCodeEncoding Enumeration
See Also Send Feedback
Specifies the QR Code encoding.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum QRCodeEncoding
Visual Basic (Declaration)
Public Enumeration QRCodeEncoding
Visual C++
public enum class QRCodeEncoding

Members

Member name | Description
UTF8 | UTF-8 encoding.
ISO8859_1 | ISO 8859-1 encoding.
Shift_JIS | Shift_JIS encoding.

See Also

FastReport.Barcode Namespace


QRCodeErrorCorrection Enumeration

[image]

FastReport.Net Class Reference
QRCodeErrorCorrection Enumeration
See Also Send Feedback
Specifies the QR code error correction level.

Namespace: FastReport.Barcode
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum QRCodeErrorCorrection
Visual Basic (Declaration)
Public Enumeration QRCodeErrorCorrection
Visual C++
public enum class QRCodeErrorCorrection

Members

Member name | Description
L | L = ~7% correction.
M | M = ~15% correction.
Q | Q = ~25% correction.
H | H = ~30% correction.

See Also

FastReport.Barcode Namespace


FastReport.Cloud Namespace

[image]

FastReport.Net Class Reference
FastReport.Cloud Namespace
Send Feedback

Classes

Class | Description
CloudProxySettings | Represents proxy settings of the cloud storage.
HttpMethod | Represents an HTTP request method.
RequestParameter | Represents the parameter of http request.
RequestParameterComparer | Comparer class for comparing request parameters.
RequestUtils | Provides utils for the web request.

Enumerations

Enumeration | Description
ProxyType | Represents the type of rpoxy.


CloudProxySettings Class

[image]

FastReport.Net Class Reference
CloudProxySettings Class
Members See Also Send Feedback
Represents proxy settings of the cloud storage.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CloudProxySettings
Visual Basic (Declaration)
Public Class CloudProxySettings
Visual C++
public ref class CloudProxySettings

Inheritance Hierarchy

System..::.Object
FastReport.Cloud..::.CloudProxySettings

See Also

CloudProxySettings Members
FastReport.Cloud Namespace


CloudProxySettings Members

[image] [image]

FastReport.Net Class Reference
CloudProxySettings Members
CloudProxySettings Class Constructors Methods Properties See Also Send Feedback

The CloudProxySettings type exposes the following members.

Constructors

Name | Description
CloudProxySettings | Initializes a new instance of the CloudProxySettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Password | Getst or sets the user's password.
Port | Gets or sets the port number of proxy server.
ProxyType | Gets or sert the type of proxy.
Server | Gets or sert the proxy server.
Username | Gets or sets the username.

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


CloudProxySettings Constructor

[image]

FastReport.Net Class Reference
CloudProxySettings Constructor
CloudProxySettings Class See Also Send Feedback
Initializes a new instance of the CloudProxySettings class.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloudProxySettings(
    ProxyType proxyType,
    string server,
    int port,
    string username,
    string password
)
Visual Basic (Declaration)
Public Sub New ( _
    proxyType As ProxyType, _
    server As String, _
    port As Integer, _
    username As String, _
    password As String _
)
Visual C++
public:
CloudProxySettings(
    ProxyType proxyType,
    String^ server,
    int port,
    String^ username,
    String^ password
)

Parameters

proxyType
Type: FastReport.Cloud..::.ProxyType
The type of proxy.
server
Type: System..::.String
The proxy server.
port
Type: System..::.Int32
The port number of server.
username
Type: System..::.String
The username.
password
Type: System..::.String
The user's password.

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


CloudProxySettings Methods

[image] [image]

FastReport.Net Class Reference
CloudProxySettings Methods
CloudProxySettings Class See Also Send Feedback

The CloudProxySettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


CloudProxySettings Properties

[image] [image]

FastReport.Net Class Reference
CloudProxySettings Properties
CloudProxySettings Class See Also Send Feedback

The CloudProxySettings type exposes the following members.

Properties

Name | Description
Password | Getst or sets the user's password.
Port | Gets or sets the port number of proxy server.
ProxyType | Gets or sert the type of proxy.
Server | Gets or sert the proxy server.
Username | Gets or sets the username.

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


Password Property

[image]

FastReport.Net Class Reference
CloudProxySettings..::.Password Property
CloudProxySettings Class See Also Send Feedback
Getst or sets the user's password.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


Port Property

[image]

FastReport.Net Class Reference
CloudProxySettings..::.Port Property
CloudProxySettings Class See Also Send Feedback
Gets or sets the port number of proxy server.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Port { get; set; }
Visual Basic (Declaration)
Public Property Port As Integer
Visual C++
public:
property int Port {
    int get ();
    void set (int value);
}

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


ProxyType Property

[image]

FastReport.Net Class Reference
CloudProxySettings..::.ProxyType Property
CloudProxySettings Class See Also Send Feedback
Gets or sert the type of proxy.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ProxyType ProxyType { get; set; }
Visual Basic (Declaration)
Public Property ProxyType As ProxyType
Visual C++
public:
property ProxyType ProxyType {
    ProxyType get ();
    void set (ProxyType value);
}

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


Server Property

[image]

FastReport.Net Class Reference
CloudProxySettings..::.Server Property
CloudProxySettings Class See Also Send Feedback
Gets or sert the proxy server.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Server { get; set; }
Visual Basic (Declaration)
Public Property Server As String
Visual C++
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


Username Property

[image]

FastReport.Net Class Reference
CloudProxySettings..::.Username Property
CloudProxySettings Class See Also Send Feedback
Gets or sets the username.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Username { get; set; }
Visual Basic (Declaration)
Public Property Username As String
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

See Also

CloudProxySettings Class
FastReport.Cloud Namespace


HttpMethod Class

[image]

FastReport.Net Class Reference
HttpMethod Class
Members See Also Send Feedback
Represents an HTTP request method.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class HttpMethod
Visual Basic (Declaration)
Public NotInheritable Class HttpMethod
Visual C++
public ref class HttpMethod abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Cloud..::.HttpMethod

See Also

HttpMethod Members
FastReport.Cloud Namespace


HttpMethod Members

[image] [image]

FastReport.Net Class Reference
HttpMethod Members
HttpMethod Class Fields See Also Send Feedback

The HttpMethod type exposes the following members.

Fields

Name | Description
Get | GET request method.
Post | POST request method.
Put | PUT request method.

See Also

HttpMethod Class
FastReport.Cloud Namespace


HttpMethod Fields

[image] [image]

FastReport.Net Class Reference
HttpMethod Fields
HttpMethod Class See Also Send Feedback

The HttpMethod type exposes the following members.

Fields

Name | Description
Get | GET request method.
Post | POST request method.
Put | PUT request method.

See Also

HttpMethod Class
FastReport.Cloud Namespace


Get Field

[image]

FastReport.Net Class Reference
HttpMethod..::.Get Field
HttpMethod Class See Also Send Feedback
GET request method.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string Get
Visual Basic (Declaration)
Public Const Get As String
Visual C++
public:
literal String^ Get

See Also

HttpMethod Class
FastReport.Cloud Namespace


Post Field

[image]

FastReport.Net Class Reference
HttpMethod..::.Post Field
HttpMethod Class See Also Send Feedback
POST request method.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string Post
Visual Basic (Declaration)
Public Const Post As String
Visual C++
public:
literal String^ Post

See Also

HttpMethod Class
FastReport.Cloud Namespace


Put Field

[image]

FastReport.Net Class Reference
HttpMethod..::.Put Field
HttpMethod Class See Also Send Feedback
PUT request method.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string Put
Visual Basic (Declaration)
Public Const Put As String
Visual C++
public:
literal String^ Put

See Also

HttpMethod Class
FastReport.Cloud Namespace


ProxyType Enumeration

[image]

FastReport.Net Class Reference
ProxyType Enumeration
See Also Send Feedback
Represents the type of rpoxy.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ProxyType
Visual Basic (Declaration)
Public Enumeration ProxyType
Visual C++
public enum class ProxyType

Members

Member name | Description
Http | The HTTP proxy type.
Socks4 | The SOCKS4 proxy type.
Socks5 | The SOCKS5 proxy type.

See Also

FastReport.Cloud Namespace


RequestParameter Class

[image]

FastReport.Net Class Reference
RequestParameter Class
Members See Also Send Feedback
Represents the parameter of http request.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RequestParameter
Visual Basic (Declaration)
Public Class RequestParameter
Visual C++
public ref class RequestParameter

Inheritance Hierarchy

System..::.Object
FastReport.Cloud..::.RequestParameter

See Also

RequestParameter Members
FastReport.Cloud Namespace


RequestParameter Members

[image] [image]

FastReport.Net Class Reference
RequestParameter Members
RequestParameter Class Constructors Methods Properties See Also Send Feedback

The RequestParameter type exposes the following members.

Constructors

Name | Description
RequestParameter | Initializes a naw instance of the RequestParameter class with a specified parameters.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the name of a request parameter.
Value | Gets the value of a request parameter.

See Also

RequestParameter Class
FastReport.Cloud Namespace


RequestParameter Constructor

[image]

FastReport.Net Class Reference
RequestParameter Constructor
RequestParameter Class See Also Send Feedback
Initializes a naw instance of the RequestParameter class with a specified parameters.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RequestParameter(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
RequestParameter(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
The name of a request parameter.
value
Type: System..::.String
The value of a request paramter.

See Also

RequestParameter Class
FastReport.Cloud Namespace


RequestParameter Methods

[image] [image]

FastReport.Net Class Reference
RequestParameter Methods
RequestParameter Class See Also Send Feedback

The RequestParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestParameter Class
FastReport.Cloud Namespace


RequestParameter Properties

[image] [image]

FastReport.Net Class Reference
RequestParameter Properties
RequestParameter Class See Also Send Feedback

The RequestParameter type exposes the following members.

Properties

Name | Description
Name | Gets the name of a request parameter.
Value | Gets the value of a request parameter.

See Also

RequestParameter Class
FastReport.Cloud Namespace


Name Property

[image]

FastReport.Net Class Reference
RequestParameter..::.Name Property
RequestParameter Class See Also Send Feedback
Gets the name of a request parameter.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RequestParameter Class
FastReport.Cloud Namespace


Value Property

[image]

FastReport.Net Class Reference
RequestParameter..::.Value Property
RequestParameter Class See Also Send Feedback
Gets the value of a request parameter.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

RequestParameter Class
FastReport.Cloud Namespace


RequestParameterComparer Class

[image]

FastReport.Net Class Reference
RequestParameterComparer Class
Members See Also Send Feedback
Comparer class for comparing request parameters.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RequestParameterComparer : IComparer<RequestParameter>
Visual Basic (Declaration)
Public Class RequestParameterComparer _
    Implements IComparer(Of RequestParameter)
Visual C++
public ref class RequestParameterComparer : IComparer<RequestParameter^>

Inheritance Hierarchy

System..::.Object
FastReport.Cloud..::.RequestParameterComparer

See Also

RequestParameterComparer Members
FastReport.Cloud Namespace


RequestParameterComparer Members

[image] [image]

FastReport.Net Class Reference
RequestParameterComparer Members
RequestParameterComparer Class Constructors Methods See Also Send Feedback

The RequestParameterComparer type exposes the following members.

Constructors

Name | Description
RequestParameterComparer | Initializes a new instance of the RequestParameterComparer class

Methods

Name | Description
Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestParameterComparer Class
FastReport.Cloud Namespace


RequestParameterComparer Constructor

[image]

FastReport.Net Class Reference
RequestParameterComparer Constructor
RequestParameterComparer Class See Also Send Feedback
Initializes a new instance of the RequestParameterComparer class

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RequestParameterComparer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RequestParameterComparer()

See Also

RequestParameterComparer Class
FastReport.Cloud Namespace


RequestParameterComparer Methods

[image] [image]

FastReport.Net Class Reference
RequestParameterComparer Methods
RequestParameterComparer Class See Also Send Feedback

The RequestParameterComparer type exposes the following members.

Methods

Name | Description
Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestParameterComparer Class
FastReport.Cloud Namespace


Compare Method

[image]

FastReport.Net Class Reference
RequestParameterComparer..::.Compare Method
RequestParameterComparer Class See Also Send Feedback
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Compare(
    RequestParameter x,
    RequestParameter y
)
Visual Basic (Declaration)
Public Function Compare ( _
    x As RequestParameter, _
    y As RequestParameter _
) As Integer
Visual C++
public:
virtual int Compare(
    RequestParameter^ x,
    RequestParameter^ y
) sealed

Parameters

x
Type: FastReport.Cloud..::.RequestParameter
The first object to compare.
y
Type: FastReport.Cloud..::.RequestParameter
The second object to compare.

Return Value

Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.

Implements

IComparer<(Of <(T>)>)..::.Compare(T, T)

See Also

RequestParameterComparer Class
FastReport.Cloud Namespace


RequestUtils Class

[image]

FastReport.Net Class Reference
RequestUtils Class
Members See Also Send Feedback
Provides utils for the web request.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class RequestUtils
Visual Basic (Declaration)
Public NotInheritable Class RequestUtils
Visual C++
public ref class RequestUtils abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Cloud..::.RequestUtils

See Also

RequestUtils Members
FastReport.Cloud Namespace


RequestUtils Members

[image] [image]

FastReport.Net Class Reference
RequestUtils Members
RequestUtils Class Methods See Also Send Feedback

The RequestUtils type exposes the following members.

Methods

Name | Description
SetProxySettings | Sets proxy settings for web request.

See Also

RequestUtils Class
FastReport.Cloud Namespace


RequestUtils Methods

[image] [image]

FastReport.Net Class Reference
RequestUtils Methods
RequestUtils Class See Also Send Feedback

The RequestUtils type exposes the following members.

Methods

Name | Description
SetProxySettings | Sets proxy settings for web request.

See Also

RequestUtils Class
FastReport.Cloud Namespace


SetProxySettings Method

[image]

FastReport.Net Class Reference
RequestUtils..::.SetProxySettings Method
RequestUtils Class See Also Send Feedback
Sets proxy settings for web request.

Namespace: FastReport.Cloud
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void SetProxySettings(
    WebRequest request,
    CloudProxySettings settings
)
Visual Basic (Declaration)
Public Shared Sub SetProxySettings ( _
    request As WebRequest, _
    settings As CloudProxySettings _
)
Visual C++
public:
static void SetProxySettings(
    WebRequest^ request,
    CloudProxySettings^ settings
)

Parameters

request
Type: System.Net..::.WebRequest
The web request.
settings
Type: FastReport.Cloud..::.CloudProxySettings
The cloud proxy settings.

See Also

RequestUtils Class
FastReport.Cloud Namespace


FastReport.Cloud.OAuth Namespace

[image]

FastReport.Net Class Reference
FastReport.Cloud.OAuth Namespace
Send Feedback

Classes

Class | Description
Auth | API for OAuth protocol.
ConsumerContext | Represents the consumer.
Parser | Represents parser for parse OAuth responses.
ServiceContext | Represents the service provider.
SignatureMethod | Represents the signature method.
Token | Represents the OAuth token credentials.
UserContext | Represents the user.


Auth Class

[image]

FastReport.Net Class Reference
Auth Class
Members See Also Send Feedback
API for OAuth protocol.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Auth
Visual Basic (Declaration)
Public Class Auth
Visual C++
public ref class Auth

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.Auth

See Also

Auth Members
FastReport.Cloud.OAuth Namespace


Auth Members

[image] [image]

FastReport.Net Class Reference
Auth Members
Auth Class Constructors Methods See Also Send Feedback

The Auth type exposes the following members.

Constructors

Name | Description
Auth | Initializes a new instance of the Auth class

Methods

Name | Description
BuildSignedUrl | Builds signed URL.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Auth Class
FastReport.Cloud.OAuth Namespace


Auth Constructor

[image]

FastReport.Net Class Reference
Auth Constructor
Auth Class See Also Send Feedback
Initializes a new instance of the Auth class

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Auth()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Auth()

See Also

Auth Class
FastReport.Cloud.OAuth Namespace


Auth Methods

[image] [image]

FastReport.Net Class Reference
Auth Methods
Auth Class See Also Send Feedback

The Auth type exposes the following members.

Methods

Name | Description
BuildSignedUrl | Builds signed URL.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Auth Class
FastReport.Cloud.OAuth Namespace


BuildSignedUrl Method

[image]

FastReport.Net Class Reference
Auth..::.BuildSignedUrl Method
Auth Class See Also Send Feedback
Builds signed URL.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BuildSignedUrl(
    string baseTokenUrl,
    string method,
    ConsumerContext consumer,
    Token token
)
Visual Basic (Declaration)
Public Function BuildSignedUrl ( _
    baseTokenUrl As String, _
    method As String, _
    consumer As ConsumerContext, _
    token As Token _
) As String
Visual C++
public:
String^ BuildSignedUrl(
    String^ baseTokenUrl,
    String^ method,
    ConsumerContext^ consumer,
    Token^ token
)

Parameters

baseTokenUrl
Type: System..::.String
The base token URL.
method
Type: System..::.String
The HTTP method.
consumer
Type: FastReport.Cloud.OAuth..::.ConsumerContext
The consumer context.
token
Type: FastReport.Cloud.OAuth..::.Token
The request token.

Return Value

Signed URL.

See Also

Auth Class
FastReport.Cloud.OAuth Namespace


ConsumerContext Class

[image]

FastReport.Net Class Reference
ConsumerContext Class
Members See Also Send Feedback
Represents the consumer.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ConsumerContext
Visual Basic (Declaration)
Public Class ConsumerContext
Visual C++
public ref class ConsumerContext

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.ConsumerContext

See Also

ConsumerContext Members
FastReport.Cloud.OAuth Namespace


ConsumerContext Members

[image] [image]

FastReport.Net Class Reference
ConsumerContext Members
ConsumerContext Class Constructors Methods Properties See Also Send Feedback

The ConsumerContext type exposes the following members.

Constructors

Name | Description
ConsumerContext | Initializes a new instance of the ConsumerContext class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConsumerKey | Gets the consumer key.
ConsumerSecret | Gest the consumer secret.
SignatureMethod | Gets the consumer's signature method.

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


ConsumerContext Constructor

[image]

FastReport.Net Class Reference
ConsumerContext Constructor
ConsumerContext Class See Also Send Feedback
Initializes a new instance of the ConsumerContext class.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ConsumerContext(
    string consumerKey,
    string consumerSecret
)
Visual Basic (Declaration)
Public Sub New ( _
    consumerKey As String, _
    consumerSecret As String _
)
Visual C++
public:
ConsumerContext(
    String^ consumerKey,
    String^ consumerSecret
)

Parameters

consumerKey
Type: System..::.String
The consumer key.
consumerSecret
Type: System..::.String
The consumer secret.

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


ConsumerContext Methods

[image] [image]

FastReport.Net Class Reference
ConsumerContext Methods
ConsumerContext Class See Also Send Feedback

The ConsumerContext type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


ConsumerContext Properties

[image] [image]

FastReport.Net Class Reference
ConsumerContext Properties
ConsumerContext Class See Also Send Feedback

The ConsumerContext type exposes the following members.

Properties

Name | Description
ConsumerKey | Gets the consumer key.
ConsumerSecret | Gest the consumer secret.
SignatureMethod | Gets the consumer's signature method.

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


ConsumerKey Property

[image]

FastReport.Net Class Reference
ConsumerContext..::.ConsumerKey Property
ConsumerContext Class See Also Send Feedback
Gets the consumer key.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ConsumerKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConsumerKey As String
Visual C++
public:
property String^ ConsumerKey {
    String^ get ();
}

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


ConsumerSecret Property

[image]

FastReport.Net Class Reference
ConsumerContext..::.ConsumerSecret Property
ConsumerContext Class See Also Send Feedback
Gest the consumer secret.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ConsumerSecret { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConsumerSecret As String
Visual C++
public:
property String^ ConsumerSecret {
    String^ get ();
}

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


SignatureMethod Property

[image]

FastReport.Net Class Reference
ConsumerContext..::.SignatureMethod Property
ConsumerContext Class See Also Send Feedback
Gets the consumer's signature method.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SignatureMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property SignatureMethod As String
Visual C++
public:
property String^ SignatureMethod {
    String^ get ();
}

See Also

ConsumerContext Class
FastReport.Cloud.OAuth Namespace


Parser Class

[image]

FastReport.Net Class Reference
Parser Class
Members See Also Send Feedback
Represents parser for parse OAuth responses.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Parser
Visual Basic (Declaration)
Public NotInheritable Class Parser
Visual C++
public ref class Parser abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.Parser

See Also

Parser Members
FastReport.Cloud.OAuth Namespace


Parser Members

[image] [image]

FastReport.Net Class Reference
Parser Members
Parser Class Methods See Also Send Feedback

The Parser type exposes the following members.

Methods

Name | Description
ParseGoogleDriveToken | Parses token information in stream for Google Drive.
ParseSkyDriveToken | Parses token information in stream for SkyDrive.
ParseToken | Parses token information in stream.

See Also

Parser Class
FastReport.Cloud.OAuth Namespace


Parser Methods

[image] [image]

FastReport.Net Class Reference
Parser Methods
Parser Class See Also Send Feedback

The Parser type exposes the following members.

Methods

Name | Description
ParseGoogleDriveToken | Parses token information in stream for Google Drive.
ParseSkyDriveToken | Parses token information in stream for SkyDrive.
ParseToken | Parses token information in stream.

See Also

Parser Class
FastReport.Cloud.OAuth Namespace


ParseGoogleDriveToken Method

[image]

FastReport.Net Class Reference
Parser..::.ParseGoogleDriveToken Method
Parser Class See Also Send Feedback
Parses token information in stream for Google Drive.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ParseGoogleDriveToken(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function ParseGoogleDriveToken ( _
    stream As Stream _
) As String
Visual C++
public:
static String^ ParseGoogleDriveToken(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream for parse.

Return Value

The Google Drive access token.

See Also

Parser Class
FastReport.Cloud.OAuth Namespace


ParseSkyDriveToken Method

[image]

FastReport.Net Class Reference
Parser..::.ParseSkyDriveToken Method
Parser Class See Also Send Feedback
Parses token information in stream for SkyDrive.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ParseSkyDriveToken(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function ParseSkyDriveToken ( _
    stream As Stream _
) As String
Visual C++
public:
static String^ ParseSkyDriveToken(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream for parse.

Return Value

The SkyDrive access token.

See Also

Parser Class
FastReport.Cloud.OAuth Namespace


ParseToken Method

[image]

FastReport.Net Class Reference
Parser..::.ParseToken Method
Parser Class See Also Send Feedback
Parses token information in stream.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Token ParseToken(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function ParseToken ( _
    stream As Stream _
) As Token
Visual C++
public:
static Token^ ParseToken(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream for parse.

Return Value

The OAuth token.

See Also

Parser Class
FastReport.Cloud.OAuth Namespace


ServiceContext Class

[image]

FastReport.Net Class Reference
ServiceContext Class
Members See Also Send Feedback
Represents the service provider.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ServiceContext
Visual Basic (Declaration)
Public Class ServiceContext
Visual C++
public ref class ServiceContext

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.ServiceContext

See Also

ServiceContext Members
FastReport.Cloud.OAuth Namespace


ServiceContext Members

[image] [image]

FastReport.Net Class Reference
ServiceContext Members
ServiceContext Class Constructors Methods Properties See Also Send Feedback

The ServiceContext type exposes the following members.

Constructors

Name | Description
ServiceContext | Initializes a new instance of the ServiceContext class with a specified parameters.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccessTokenUrl | Gets the access token URL.
CallbackUrl | Gets the callback URL.
RequestTokenUrl | Gets the request token URL.
UserAuthorizationUrl | Gets the user authorization URL.

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


ServiceContext Constructor

[image]

FastReport.Net Class Reference
ServiceContext Constructor
ServiceContext Class See Also Send Feedback
Initializes a new instance of the ServiceContext class with a specified parameters.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ServiceContext(
    string requestTokenUrl,
    string userAuthorizationUrl,
    string callbackUrl,
    string accessTokenUrl
)
Visual Basic (Declaration)
Public Sub New ( _
    requestTokenUrl As String, _
    userAuthorizationUrl As String, _
    callbackUrl As String, _
    accessTokenUrl As String _
)
Visual C++
public:
ServiceContext(
    String^ requestTokenUrl,
    String^ userAuthorizationUrl,
    String^ callbackUrl,
    String^ accessTokenUrl
)

Parameters

requestTokenUrl
Type: System..::.String
The request token URL.
userAuthorizationUrl
Type: System..::.String
The user authorization URL.
callbackUrl
Type: System..::.String
The callback URL.
accessTokenUrl
Type: System..::.String
The access token URL.

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


ServiceContext Methods

[image] [image]

FastReport.Net Class Reference
ServiceContext Methods
ServiceContext Class See Also Send Feedback

The ServiceContext type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


ServiceContext Properties

[image] [image]

FastReport.Net Class Reference
ServiceContext Properties
ServiceContext Class See Also Send Feedback

The ServiceContext type exposes the following members.

Properties

Name | Description
AccessTokenUrl | Gets the access token URL.
CallbackUrl | Gets the callback URL.
RequestTokenUrl | Gets the request token URL.
UserAuthorizationUrl | Gets the user authorization URL.

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


AccessTokenUrl Property

[image]

FastReport.Net Class Reference
ServiceContext..::.AccessTokenUrl Property
ServiceContext Class See Also Send Feedback
Gets the access token URL.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AccessTokenUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessTokenUrl As String
Visual C++
public:
property String^ AccessTokenUrl {
    String^ get ();
}

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


CallbackUrl Property

[image]

FastReport.Net Class Reference
ServiceContext..::.CallbackUrl Property
ServiceContext Class See Also Send Feedback
Gets the callback URL.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CallbackUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property CallbackUrl As String
Visual C++
public:
property String^ CallbackUrl {
    String^ get ();
}

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


RequestTokenUrl Property

[image]

FastReport.Net Class Reference
ServiceContext..::.RequestTokenUrl Property
ServiceContext Class See Also Send Feedback
Gets the request token URL.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string RequestTokenUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property RequestTokenUrl As String
Visual C++
public:
property String^ RequestTokenUrl {
    String^ get ();
}

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


UserAuthorizationUrl Property

[image]

FastReport.Net Class Reference
ServiceContext..::.UserAuthorizationUrl Property
ServiceContext Class See Also Send Feedback
Gets the user authorization URL.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string UserAuthorizationUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserAuthorizationUrl As String
Visual C++
public:
property String^ UserAuthorizationUrl {
    String^ get ();
}

See Also

ServiceContext Class
FastReport.Cloud.OAuth Namespace


SignatureMethod Class

[image]

FastReport.Net Class Reference
SignatureMethod Class
Members See Also Send Feedback
Represents the signature method.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class SignatureMethod
Visual Basic (Declaration)
Public NotInheritable Class SignatureMethod
Visual C++
public ref class SignatureMethod abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.SignatureMethod

See Also

SignatureMethod Members
FastReport.Cloud.OAuth Namespace


SignatureMethod Members

[image] [image]

FastReport.Net Class Reference
SignatureMethod Members
SignatureMethod Class Fields See Also Send Feedback

The SignatureMethod type exposes the following members.

Fields

Name | Description
HmacSha1 | Signature method HMAC-SHA1.
Plaintext | Signature method PLAINTEXT.
RsaSha1 | Signature method RSA-SHA1.

See Also

SignatureMethod Class
FastReport.Cloud.OAuth Namespace


SignatureMethod Fields

[image] [image]

FastReport.Net Class Reference
SignatureMethod Fields
SignatureMethod Class See Also Send Feedback

The SignatureMethod type exposes the following members.

Fields

Name | Description
HmacSha1 | Signature method HMAC-SHA1.
Plaintext | Signature method PLAINTEXT.
RsaSha1 | Signature method RSA-SHA1.

See Also

SignatureMethod Class
FastReport.Cloud.OAuth Namespace


HmacSha1 Field

[image]

FastReport.Net Class Reference
SignatureMethod..::.HmacSha1 Field
SignatureMethod Class See Also Send Feedback
Signature method HMAC-SHA1.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string HmacSha1
Visual Basic (Declaration)
Public Const HmacSha1 As String
Visual C++
public:
literal String^ HmacSha1

See Also

SignatureMethod Class
FastReport.Cloud.OAuth Namespace


Plaintext Field

[image]

FastReport.Net Class Reference
SignatureMethod..::.Plaintext Field
SignatureMethod Class See Also Send Feedback
Signature method PLAINTEXT.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string Plaintext
Visual Basic (Declaration)
Public Const Plaintext As String
Visual C++
public:
literal String^ Plaintext

See Also

SignatureMethod Class
FastReport.Cloud.OAuth Namespace


RsaSha1 Field

[image]

FastReport.Net Class Reference
SignatureMethod..::.RsaSha1 Field
SignatureMethod Class See Also Send Feedback
Signature method RSA-SHA1.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string RsaSha1
Visual Basic (Declaration)
Public Const RsaSha1 As String
Visual C++
public:
literal String^ RsaSha1

See Also

SignatureMethod Class
FastReport.Cloud.OAuth Namespace


Token Class

[image]

FastReport.Net Class Reference
Token Class
Members See Also Send Feedback
Represents the OAuth token credentials.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Token
Visual Basic (Declaration)
Public Class Token
Visual C++
public ref class Token

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.Token

See Also

Token Members
FastReport.Cloud.OAuth Namespace


Token Members

[image] [image]

FastReport.Net Class Reference
Token Members
Token Class Constructors Methods Properties See Also Send Feedback

The Token type exposes the following members.

Constructors

Name | Description
Token | Initializes a new instance of the Token class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TokenKey | Gets the token key.
TokenSecret | Gets the token secret.

See Also

Token Class
FastReport.Cloud.OAuth Namespace


Token Constructor

[image]

FastReport.Net Class Reference
Token Constructor
Token Class See Also Send Feedback
Initializes a new instance of the Token class.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Token(
    string tokenKey,
    string tokenSecret
)
Visual Basic (Declaration)
Public Sub New ( _
    tokenKey As String, _
    tokenSecret As String _
)
Visual C++
public:
Token(
    String^ tokenKey,
    String^ tokenSecret
)

Parameters

tokenKey
Type: System..::.String
The token key.
tokenSecret
Type: System..::.String
The token secret.

See Also

Token Class
FastReport.Cloud.OAuth Namespace


Token Methods

[image] [image]

FastReport.Net Class Reference
Token Methods
Token Class See Also Send Feedback

The Token type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Token Class
FastReport.Cloud.OAuth Namespace


Token Properties

[image] [image]

FastReport.Net Class Reference
Token Properties
Token Class See Also Send Feedback

The Token type exposes the following members.

Properties

Name | Description
TokenKey | Gets the token key.
TokenSecret | Gets the token secret.

See Also

Token Class
FastReport.Cloud.OAuth Namespace


TokenKey Property

[image]

FastReport.Net Class Reference
Token..::.TokenKey Property
Token Class See Also Send Feedback
Gets the token key.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TokenKey { get; set; }
Visual Basic (Declaration)
Public Property TokenKey As String
Visual C++
public:
property String^ TokenKey {
    String^ get ();
    void set (String^ value);
}

See Also

Token Class
FastReport.Cloud.OAuth Namespace


TokenSecret Property

[image]

FastReport.Net Class Reference
Token..::.TokenSecret Property
Token Class See Also Send Feedback
Gets the token secret.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TokenSecret { get; set; }
Visual Basic (Declaration)
Public Property TokenSecret As String
Visual C++
public:
property String^ TokenSecret {
    String^ get ();
    void set (String^ value);
}

See Also

Token Class
FastReport.Cloud.OAuth Namespace


UserContext Class

[image]

FastReport.Net Class Reference
UserContext Class
Members See Also Send Feedback
Represents the user.

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class UserContext
Visual Basic (Declaration)
Public Class UserContext
Visual C++
public ref class UserContext

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.OAuth..::.UserContext

See Also

UserContext Members
FastReport.Cloud.OAuth Namespace


UserContext Members

[image] [image]

FastReport.Net Class Reference
UserContext Members
UserContext Class Constructors Methods See Also Send Feedback

The UserContext type exposes the following members.

Constructors

Name | Description
UserContext | Initializes a new instance of the UserContext class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserContext Class
FastReport.Cloud.OAuth Namespace


UserContext Constructor

[image]

FastReport.Net Class Reference
UserContext Constructor
UserContext Class See Also Send Feedback
Initializes a new instance of the UserContext class

Namespace: FastReport.Cloud.OAuth
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UserContext()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserContext()

See Also

UserContext Class
FastReport.Cloud.OAuth Namespace


UserContext Methods

[image] [image]

FastReport.Net Class Reference
UserContext Methods
UserContext Class See Also Send Feedback

The UserContext type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserContext Class
FastReport.Cloud.OAuth Namespace


FastReport.Cloud.StorageClient Namespace

[image]

FastReport.Net Class Reference
FastReport.Cloud.StorageClient Namespace
Send Feedback

Classes

Class | Description
CloudStorageClient | The base class for all cloud storage clients.
CloudStorageClientForm | Represents form of Dropbox storage client.
WebBrowserFormBase | Represents the base form for cloud storage web browsers.


CloudStorageClient Class

[image]

FastReport.Net Class Reference
CloudStorageClient Class
Members See Also Send Feedback
The base class for all cloud storage clients.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CloudStorageClient
Visual Basic (Declaration)
Public Class CloudStorageClient
Visual C++
public ref class CloudStorageClient

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient..::.CloudStorageClient
FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageClient
FastReport.Cloud.StorageClient.GoogleDrive..::.GoogleDriveStorageClient
FastReport.Cloud.StorageClient.SkyDrive..::.SkyDriveStorageClient

See Also

CloudStorageClient Members
FastReport.Cloud.StorageClient Namespace


CloudStorageClient Members

[image] [image]

FastReport.Net Class Reference
CloudStorageClient Members
CloudStorageClient Class Constructors Methods Properties See Also Send Feedback

The CloudStorageClient type exposes the following members.

Constructors

Name | Description
CloudStorageClient | Initializes a new instance of the CloudStorageClient class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage.
SaveReport | Saves the report to cloud storage.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filename | Gets or sets the filename.
IsUserAuthorized | Gets or set the information is user authorized or not.
ProxySettings | Gets or sets the proxy settings of a client.

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClient Constructor

[image]

FastReport.Net Class Reference
CloudStorageClient Constructor
CloudStorageClient Class See Also Send Feedback
Initializes a new instance of the CloudStorageClient class.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloudStorageClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CloudStorageClient()

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClient Methods

[image] [image]

FastReport.Net Class Reference
CloudStorageClient Methods
CloudStorageClient Class See Also Send Feedback

The CloudStorageClient type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage.
SaveReport | Saves the report to cloud storage.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


PrepareToSave Method

[image]

FastReport.Net Class Reference
CloudStorageClient..::.PrepareToSave Method
CloudStorageClient Class See Also Send Feedback
Prepares report before it will be saved to cloud storage.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected MemoryStream PrepareToSave(
    Report report,
    ExportBase export
)
Visual Basic (Declaration)
Protected Function PrepareToSave ( _
    report As Report, _
    export As ExportBase _
) As MemoryStream
Visual C++
protected:
MemoryStream^ PrepareToSave(
    Report^ report,
    ExportBase^ export
)

Parameters

report
Type: FastReport..::.Report
The report template.
export
Type: FastReport.Export..::.ExportBase
The export filter.

Return Value

Memory stream that contains prepared report.

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


SaveReport Method

[image]

FastReport.Net Class Reference
CloudStorageClient..::.SaveReport Method
CloudStorageClient Class See Also Send Feedback
Saves the report to cloud storage.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool SaveReport(
    Report report,
    ExportBase export
)
Visual Basic (Declaration)
Public Overridable Function SaveReport ( _
    report As Report, _
    export As ExportBase _
) As Boolean
Visual C++
public:
virtual bool SaveReport(
    Report^ report,
    ExportBase^ export
)

Parameters

report
Type: FastReport..::.Report
The report template that should be saved.
export
Type: FastReport.Export..::.ExportBase
The export filter that should export template before.

Return Value

True if report has been successfully saved.

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClient Properties

[image] [image]

FastReport.Net Class Reference
CloudStorageClient Properties
CloudStorageClient Class See Also Send Feedback

The CloudStorageClient type exposes the following members.

Properties

Name | Description
Filename | Gets or sets the filename.
IsUserAuthorized | Gets or set the information is user authorized or not.
ProxySettings | Gets or sets the proxy settings of a client.

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


Filename Property

[image]

FastReport.Net Class Reference
CloudStorageClient..::.Filename Property
CloudStorageClient Class See Also Send Feedback
Gets or sets the filename.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected string Filename { get; set; }
Visual Basic (Declaration)
Protected Property Filename As String
Visual C++
protected:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


IsUserAuthorized Property

[image]

FastReport.Net Class Reference
CloudStorageClient..::.IsUserAuthorized Property
CloudStorageClient Class See Also Send Feedback
Gets or set the information is user authorized or not.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsUserAuthorized { get; set; }
Visual Basic (Declaration)
Public Property IsUserAuthorized As Boolean
Visual C++
public:
property bool IsUserAuthorized {
    bool get ();
    void set (bool value);
}

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


ProxySettings Property

[image]

FastReport.Net Class Reference
CloudStorageClient..::.ProxySettings Property
CloudStorageClient Class See Also Send Feedback
Gets or sets the proxy settings of a client.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloudProxySettings ProxySettings { get; set; }
Visual Basic (Declaration)
Public Property ProxySettings As CloudProxySettings
Visual C++
public:
property CloudProxySettings^ ProxySettings {
    CloudProxySettings^ get ();
    void set (CloudProxySettings^ value);
}

See Also

CloudStorageClient Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Class

[image]

FastReport.Net Class Reference
CloudStorageClientForm Class
Members See Also Send Feedback
Represents form of Dropbox storage client.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CloudStorageClientForm : BaseDialogForm
Visual Basic (Declaration)
Public Class CloudStorageClientForm _
    Inherits BaseDialogForm
Visual C++
public ref class CloudStorageClientForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient..::.CloudStorageClientForm
FastReport.Cloud.StorageClient.GoogleDrive..::.GoogleDriveStorageClientForm

See Also

CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Members

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm Members
CloudStorageClientForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The CloudStorageClientForm type exposes the following members.

Constructors

Name | Description
CloudStorageClientForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
btnOk_Click | Click event handler for button OK.
buttonSettings_Click | Click event handler for Button Settings.
cbFileType_SelectedIndexChanged | SelectedIndexChanged event handler for ComboBox File Type.
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
CloudStorageClientForm_FormClosing | FormClosing event handler for CloudStorageClientForm.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Finishes the form work.
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes the component.
InitExports | Initializes the list of exports.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
IsNumeric | Checks is the string numeric.
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
buttonSettings | Buttons Settings.
cbFileType | ComboBox File Type.
labelColon | Label Colon.
labelFileType | Label File Type.
labelPassword | Label Password.
labelServer | Label Server.
labelUsername | Label Username.
pageControl1 | PageControl.
pgFile | Page File.
pgProxy | Page Proxy.
tbPassword | TextBox Password.
tbPort | TextBox Port.
tbServer | TextBox Server.
tbUsername | TextBox Username.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exports | Gets or sets the list of exports.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the report template.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Constructor

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm Constructor
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
CloudStorageClientForm()()() | Initializes a new instance of the CloudStorageClientForm class.
CloudStorageClientForm(Report) | Initializes a new instance of the CloudStorageClientForm class.

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Constructor

[image]

FastReport.Net Class Reference
CloudStorageClientForm Constructor
CloudStorageClientForm Class See Also Send Feedback
Initializes a new instance of the CloudStorageClientForm class.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloudStorageClientForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CloudStorageClientForm()

See Also

CloudStorageClientForm Class
CloudStorageClientForm Overload
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Constructor (Report)

[image]

FastReport.Net Class Reference
CloudStorageClientForm Constructor (Report)
CloudStorageClientForm Class See Also Send Feedback
Initializes a new instance of the CloudStorageClientForm class.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloudStorageClientForm(
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    report As Report _
)
Visual C++
public:
CloudStorageClientForm(
    Report^ report
)

Parameters

report
Type: FastReport..::.Report
The report template.

See Also

CloudStorageClientForm Class
CloudStorageClientForm Overload
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Fields

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm Fields
CloudStorageClientForm Class See Also Send Feedback

The CloudStorageClientForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
buttonSettings | Buttons Settings.
cbFileType | ComboBox File Type.
labelColon | Label Colon.
labelFileType | Label File Type.
labelPassword | Label Password.
labelServer | Label Server.
labelUsername | Label Username.
pageControl1 | PageControl.
pgFile | Page File.
pgProxy | Page Proxy.
tbPassword | TextBox Password.
tbPort | TextBox Port.
tbServer | TextBox Server.
tbUsername | TextBox Username.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


buttonSettings Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.buttonSettings Field
CloudStorageClientForm Class See Also Send Feedback
Buttons Settings.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Button buttonSettings
Visual Basic (Declaration)
Protected buttonSettings As Button
Visual C++
protected:
Button^ buttonSettings

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


cbFileType Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.cbFileType Field
CloudStorageClientForm Class See Also Send Feedback
ComboBox File Type.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ComboBox cbFileType
Visual Basic (Declaration)
Protected cbFileType As ComboBox
Visual C++
protected:
ComboBox^ cbFileType

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


labelColon Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.labelColon Field
CloudStorageClientForm Class See Also Send Feedback
Label Colon.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Label labelColon
Visual Basic (Declaration)
Protected labelColon As Label
Visual C++
protected:
Label^ labelColon

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


labelFileType Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.labelFileType Field
CloudStorageClientForm Class See Also Send Feedback
Label File Type.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Label labelFileType
Visual Basic (Declaration)
Protected labelFileType As Label
Visual C++
protected:
Label^ labelFileType

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


labelPassword Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.labelPassword Field
CloudStorageClientForm Class See Also Send Feedback
Label Password.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Label labelPassword
Visual Basic (Declaration)
Protected labelPassword As Label
Visual C++
protected:
Label^ labelPassword

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


labelServer Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.labelServer Field
CloudStorageClientForm Class See Also Send Feedback
Label Server.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Label labelServer
Visual Basic (Declaration)
Protected labelServer As Label
Visual C++
protected:
Label^ labelServer

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


labelUsername Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.labelUsername Field
CloudStorageClientForm Class See Also Send Feedback
Label Username.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Label labelUsername
Visual Basic (Declaration)
Protected labelUsername As Label
Visual C++
protected:
Label^ labelUsername

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


pageControl1 Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.pageControl1 Field
CloudStorageClientForm Class See Also Send Feedback
PageControl.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected PageControl pageControl1
Visual Basic (Declaration)
Protected pageControl1 As PageControl
Visual C++
protected:
PageControl^ pageControl1

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


pgFile Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.pgFile Field
CloudStorageClientForm Class See Also Send Feedback
Page File.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected PageControlPage pgFile
Visual Basic (Declaration)
Protected pgFile As PageControlPage
Visual C++
protected:
PageControlPage^ pgFile

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


pgProxy Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.pgProxy Field
CloudStorageClientForm Class See Also Send Feedback
Page Proxy.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected PageControlPage pgProxy
Visual Basic (Declaration)
Protected pgProxy As PageControlPage
Visual C++
protected:
PageControlPage^ pgProxy

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


tbPassword Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.tbPassword Field
CloudStorageClientForm Class See Also Send Feedback
TextBox Password.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected TextBox tbPassword
Visual Basic (Declaration)
Protected tbPassword As TextBox
Visual C++
protected:
TextBox^ tbPassword

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


tbPort Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.tbPort Field
CloudStorageClientForm Class See Also Send Feedback
TextBox Port.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected TextBox tbPort
Visual Basic (Declaration)
Protected tbPort As TextBox
Visual C++
protected:
TextBox^ tbPort

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


tbServer Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.tbServer Field
CloudStorageClientForm Class See Also Send Feedback
TextBox Server.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected TextBox tbServer
Visual Basic (Declaration)
Protected tbServer As TextBox
Visual C++
protected:
TextBox^ tbServer

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


tbUsername Field

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.tbUsername Field
CloudStorageClientForm Class See Also Send Feedback
TextBox Username.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected TextBox tbUsername
Visual Basic (Declaration)
Protected tbUsername As TextBox
Visual C++
protected:
TextBox^ tbUsername

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Methods

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm Methods
CloudStorageClientForm Class See Also Send Feedback

The CloudStorageClientForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
btnOk_Click | Click event handler for button OK.
buttonSettings_Click | Click event handler for Button Settings.
cbFileType_SelectedIndexChanged | SelectedIndexChanged event handler for ComboBox File Type.
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
CloudStorageClientForm_FormClosing | FormClosing event handler for CloudStorageClientForm.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Finishes the form work.
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes the component.
InitExports | Initializes the list of exports.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
IsNumeric | Checks is the string numeric.
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.AccessibilityNotifyClients Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.BeginInvoke Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


btnOk_Click Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.btnOk_Click Method
CloudStorageClientForm Class See Also Send Feedback
Click event handler for button OK.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void btnOk_Click(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub btnOk_Click ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
virtual void btnOk_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System..::.EventArgs
Event args.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


buttonSettings_Click Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.buttonSettings_Click Method
CloudStorageClientForm Class See Also Send Feedback
Click event handler for Button Settings.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void buttonSettings_Click(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub buttonSettings_Click ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void buttonSettings_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System..::.EventArgs
Event args.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


cbFileType_SelectedIndexChanged Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.cbFileType_SelectedIndexChanged Method
CloudStorageClientForm Class See Also Send Feedback
SelectedIndexChanged event handler for ComboBox File Type.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void cbFileType_SelectedIndexChanged(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub cbFileType_SelectedIndexChanged ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void cbFileType_SelectedIndexChanged(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System..::.EventArgs
Event args.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm_FormClosing Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.CloudStorageClientForm_FormClosing Method
CloudStorageClientForm Class See Also Send Feedback
FormClosing event handler for CloudStorageClientForm.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void CloudStorageClientForm_FormClosing(
    Object sender,
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Protected Sub CloudStorageClientForm_FormClosing ( _
    sender As Object, _
    e As FormClosingEventArgs _
)
Visual C++
protected:
void CloudStorageClientForm_FormClosing(
    Object^ sender,
    FormClosingEventArgs^ e
)

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System.Windows.Forms..::.FormClosingEventArgs
Event args.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Dispose Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Dispose Method (Boolean)
CloudStorageClientForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

CloudStorageClientForm Class
Dispose Overload
FastReport.Cloud.StorageClient Namespace


Done Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Done Method
CloudStorageClientForm Class See Also Send Feedback
Finishes the form work.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual bool Done()
Visual Basic (Declaration)
Protected Overridable Function Done As Boolean
Visual C++
protected:
virtual bool Done()

Return Value

Returns true if work has been successfully finished, otherwise false.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.GetChildAtPoint Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Init Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Init Method
CloudStorageClientForm Class See Also Send Feedback
Initializes the component.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void Init()
Visual Basic (Declaration)
Protected Overridable Sub Init
Visual C++
protected:
virtual void Init()

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


InitExports Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.InitExports Method
CloudStorageClientForm Class See Also Send Feedback
Initializes the list of exports.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void InitExports()
Visual Basic (Declaration)
Protected Sub InitExports
Visual C++
protected:
void InitExports()

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Invalidate Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Invoke Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


IsNumeric Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.IsNumeric Method
CloudStorageClientForm Class See Also Send Feedback
Checks is the string numeric.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected bool IsNumeric(
    string str
)
Visual Basic (Declaration)
Protected Function IsNumeric ( _
    str As String _
) As Boolean
Visual C++
protected:
bool IsNumeric(
    String^ str
)

Parameters

str
Type: System..::.String
The checking string.

Return Value

True if string is numeric, otherwise false.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


Localize Method

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Localize Method
CloudStorageClientForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.MemberwiseClone Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.PerformLayout Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.ResumeLayout Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.RtlTranslateAlignment Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Scale Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Select Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.SetBounds Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Show Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.ShowDialog Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.UpdateBounds Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Validate Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm..::.ValidateChildren Method
CloudStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

CloudStorageClientForm Class
CloudStorageClientForm Members
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Properties

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm Properties
CloudStorageClientForm Class See Also Send Feedback

The CloudStorageClientForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exports | Gets or sets the list of exports.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the report template.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


Exports Property

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Exports Property
CloudStorageClientForm Class See Also Send Feedback
Gets or sets the list of exports.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<ExportBase> Exports { get; set; }
Visual Basic (Declaration)
Public Property Exports As List(Of ExportBase)
Visual C++
public:
property List<ExportBase^>^ Exports {
    List<ExportBase^>^ get ();
    void set (List<ExportBase^>^ value);
}

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


Report Property

[image]

FastReport.Net Class Reference
CloudStorageClientForm..::.Report Property
CloudStorageClientForm Class See Also Send Feedback
Gets or sets the report template.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; set; }
Visual Basic (Declaration)
Public Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


CloudStorageClientForm Events

[image] [image]

FastReport.Net Class Reference
CloudStorageClientForm Events
CloudStorageClientForm Class See Also Send Feedback

The CloudStorageClientForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CloudStorageClientForm Class
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Class

[image]

FastReport.Net Class Reference
WebBrowserFormBase Class
Members See Also Send Feedback
Represents the base form for cloud storage web browsers.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class WebBrowserFormBase : BaseDialogForm
Visual Basic (Declaration)
Public Class WebBrowserFormBase _
    Inherits BaseDialogForm
Visual C++
public ref class WebBrowserFormBase : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient..::.WebBrowserFormBase

See Also

WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Members

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase Members
WebBrowserFormBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The WebBrowserFormBase type exposes the following members.

Constructors

Name | Description
WebBrowserFormBase | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WebBrowserFormBase_Shown | Handle the web browser form shown event.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
wbBrowser | The web browser component.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Url | Gets or sets the url string.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Constructor

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase Constructor
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
WebBrowserFormBase()()() | Initizlizes a new instance of the WebBrowserFormBase class.
WebBrowserFormBase(String) | Initializes a new instance of the WebBrowserFormBase class.

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Constructor

[image]

FastReport.Net Class Reference
WebBrowserFormBase Constructor
WebBrowserFormBase Class See Also Send Feedback
Initizlizes a new instance of the WebBrowserFormBase class.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WebBrowserFormBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebBrowserFormBase()

See Also

WebBrowserFormBase Class
WebBrowserFormBase Overload
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Constructor (String)

[image]

FastReport.Net Class Reference
WebBrowserFormBase Constructor (String)
WebBrowserFormBase Class See Also Send Feedback
Initializes a new instance of the WebBrowserFormBase class.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WebBrowserFormBase(
    string url
)
Visual Basic (Declaration)
Public Sub New ( _
    url As String _
)
Visual C++
public:
WebBrowserFormBase(
    String^ url
)

Parameters

url
Type: System..::.String
The url string.

See Also

WebBrowserFormBase Class
WebBrowserFormBase Overload
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Fields

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase Fields
WebBrowserFormBase Class See Also Send Feedback

The WebBrowserFormBase type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
wbBrowser | The web browser component.

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


wbBrowser Field

[image]

FastReport.Net Class Reference
WebBrowserFormBase..::.wbBrowser Field
WebBrowserFormBase Class See Also Send Feedback
The web browser component.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WebBrowser wbBrowser
Visual Basic (Declaration)
Public wbBrowser As WebBrowser
Visual C++
public:
WebBrowser^ wbBrowser

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Methods

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase Methods
WebBrowserFormBase Class See Also Send Feedback

The WebBrowserFormBase type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WebBrowserFormBase_Shown | Handle the web browser form shown event.
WndProc | (Inherited from Form.)

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.AccessibilityNotifyClients Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.BeginInvoke Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Dispose Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Dispose Method (Boolean)
WebBrowserFormBase Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

WebBrowserFormBase Class
Dispose Overload
FastReport.Cloud.StorageClient Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.GetChildAtPoint Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Invalidate Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Invoke Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.MemberwiseClone Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.PerformLayout Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.ResumeLayout Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.RtlTranslateAlignment Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Scale Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Select Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.SetBounds Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Show Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.ShowDialog Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.UpdateBounds Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Validate Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase..::.ValidateChildren Method
WebBrowserFormBase Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

WebBrowserFormBase Class
WebBrowserFormBase Members
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase_Shown Method

[image]

FastReport.Net Class Reference
WebBrowserFormBase..::.WebBrowserFormBase_Shown Method
WebBrowserFormBase Class See Also Send Feedback
Handle the web browser form shown event.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void WebBrowserFormBase_Shown(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub WebBrowserFormBase_Shown ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void WebBrowserFormBase_Shown(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
The event sender.
e
Type: System..::.EventArgs
The event args.

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Properties

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase Properties
WebBrowserFormBase Class See Also Send Feedback

The WebBrowserFormBase type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Url | Gets or sets the url string.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


Url Property

[image]

FastReport.Net Class Reference
WebBrowserFormBase..::.Url Property
WebBrowserFormBase Class See Also Send Feedback
Gets or sets the url string.

Namespace: FastReport.Cloud.StorageClient
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


WebBrowserFormBase Events

[image] [image]

FastReport.Net Class Reference
WebBrowserFormBase Events
WebBrowserFormBase Class See Also Send Feedback

The WebBrowserFormBase type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserFormBase Class
FastReport.Cloud.StorageClient Namespace


FastReport.Cloud.StorageClient.Dropbox Namespace

[image]

FastReport.Net Class Reference
FastReport.Cloud.StorageClient.Dropbox Namespace
Send Feedback

Classes

Class | Description
AccessType | Represents the access type of application.
AccountInfo | Represents the information about dropbox storage account.
AppInfo | Represents the information about Dropbox application.
ApplicationInfoForm | Represents the Application Info diabolg form.
DropboxStorageClient | Dropbox cloud storage client.
DropboxStorageClientForm | Represents form of Dropbox storage client.
DropboxStorageConfig | Contains information needed to access the Dropbox storage.
Session | Represents the Dropbox session.
WebBrowserForm | Represents form of the web browser.


AccessType Class

[image]

FastReport.Net Class Reference
AccessType Class
Members See Also Send Feedback
Represents the access type of application.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class AccessType
Visual Basic (Declaration)
Public NotInheritable Class AccessType
Visual C++
public ref class AccessType abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient.Dropbox..::.AccessType

See Also

AccessType Members
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessType Members

[image] [image]

FastReport.Net Class Reference
AccessType Members
AccessType Class Fields See Also Send Feedback

The AccessType type exposes the following members.

Fields

Name | Description
Dropbox | Full access to all the files and folders in a user's Dropbox.
Sandbox | Access to app folder only (sandbox).

See Also

AccessType Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessType Fields

[image] [image]

FastReport.Net Class Reference
AccessType Fields
AccessType Class See Also Send Feedback

The AccessType type exposes the following members.

Fields

Name | Description
Dropbox | Full access to all the files and folders in a user's Dropbox.
Sandbox | Access to app folder only (sandbox).

See Also

AccessType Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Dropbox Field

[image]

FastReport.Net Class Reference
AccessType..::.Dropbox Field
AccessType Class See Also Send Feedback
Full access to all the files and folders in a user's Dropbox.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string Dropbox
Visual Basic (Declaration)
Public Const Dropbox As String
Visual C++
public:
literal String^ Dropbox

See Also

AccessType Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Sandbox Field

[image]

FastReport.Net Class Reference
AccessType..::.Sandbox Field
AccessType Class See Also Send Feedback
Access to app folder only (sandbox).

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string Sandbox
Visual Basic (Declaration)
Public Const Sandbox As String
Visual C++
public:
literal String^ Sandbox

See Also

AccessType Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccountInfo Class

[image]

FastReport.Net Class Reference
AccountInfo Class
Members See Also Send Feedback
Represents the information about dropbox storage account.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AccountInfo
Visual Basic (Declaration)
Public Class AccountInfo
Visual C++
public ref class AccountInfo

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient.Dropbox..::.AccountInfo

See Also

AccountInfo Members
FastReport.Cloud.StorageClient.Dropbox Namespace


AccountInfo Members

[image] [image]

FastReport.Net Class Reference
AccountInfo Members
AccountInfo Class Constructors Methods Properties See Also Send Feedback

The AccountInfo type exposes the following members.

Constructors

Name | Description
AccountInfo | Initializes a new instance of the AccountInfo class with a specified parameters.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Login | Gets or sets the user login.
Password | Gets or sets the user password.

See Also

AccountInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccountInfo Constructor

[image]

FastReport.Net Class Reference
AccountInfo Constructor
AccountInfo Class See Also Send Feedback
Initializes a new instance of the AccountInfo class with a specified parameters.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AccountInfo(
    string login,
    string password
)
Visual Basic (Declaration)
Public Sub New ( _
    login As String, _
    password As String _
)
Visual C++
public:
AccountInfo(
    String^ login,
    String^ password
)

Parameters

login
Type: System..::.String
The user login.
password
Type: System..::.String
The user password.

See Also

AccountInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccountInfo Methods

[image] [image]

FastReport.Net Class Reference
AccountInfo Methods
AccountInfo Class See Also Send Feedback

The AccountInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccountInfo Properties

[image] [image]

FastReport.Net Class Reference
AccountInfo Properties
AccountInfo Class See Also Send Feedback

The AccountInfo type exposes the following members.

Properties

Name | Description
Login | Gets or sets the user login.
Password | Gets or sets the user password.

See Also

AccountInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Login Property

[image]

FastReport.Net Class Reference
AccountInfo..::.Login Property
AccountInfo Class See Also Send Feedback
Gets or sets the user login.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Login { get; set; }
Visual Basic (Declaration)
Public Property Login As String
Visual C++
public:
property String^ Login {
    String^ get ();
    void set (String^ value);
}

See Also

AccountInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Password Property

[image]

FastReport.Net Class Reference
AccountInfo..::.Password Property
AccountInfo Class See Also Send Feedback
Gets or sets the user password.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

AccountInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AppInfo Class

[image]

FastReport.Net Class Reference
AppInfo Class
Members See Also Send Feedback
Represents the information about Dropbox application.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AppInfo
Visual Basic (Declaration)
Public Class AppInfo
Visual C++
public ref class AppInfo

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient.Dropbox..::.AppInfo

See Also

AppInfo Members
FastReport.Cloud.StorageClient.Dropbox Namespace


AppInfo Members

[image] [image]

FastReport.Net Class Reference
AppInfo Members
AppInfo Class Constructors Methods Properties See Also Send Feedback

The AppInfo type exposes the following members.

Constructors

Name | Description
AppInfo | Initializes a new instance of the class with a specified properties.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccessType | Gets or sets the access type.
Folder | Gets or sets the name of app folder.
Key | Gets or sets the app key.
Name | Gets or sets the app name.
Secret | Gets or sets the app secret.

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AppInfo Constructor

[image]

FastReport.Net Class Reference
AppInfo Constructor
AppInfo Class See Also Send Feedback
Initializes a new instance of the class with a specified properties.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AppInfo(
    string name,
    string key,
    string secret,
    string folder
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    key As String, _
    secret As String, _
    folder As String _
)
Visual C++
public:
AppInfo(
    String^ name,
    String^ key,
    String^ secret,
    String^ folder
)

Parameters

name
Type: System..::.String
The app name.
key
Type: System..::.String
The app key.
secret
Type: System..::.String
The app secret.
folder
Type: System..::.String
The name of app folder.

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AppInfo Methods

[image] [image]

FastReport.Net Class Reference
AppInfo Methods
AppInfo Class See Also Send Feedback

The AppInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AppInfo Properties

[image] [image]

FastReport.Net Class Reference
AppInfo Properties
AppInfo Class See Also Send Feedback

The AppInfo type exposes the following members.

Properties

Name | Description
AccessType | Gets or sets the access type.
Folder | Gets or sets the name of app folder.
Key | Gets or sets the app key.
Name | Gets or sets the app name.
Secret | Gets or sets the app secret.

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessType Property

[image]

FastReport.Net Class Reference
AppInfo..::.AccessType Property
AppInfo Class See Also Send Feedback
Gets or sets the access type.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AccessType { get; set; }
Visual Basic (Declaration)
Public Property AccessType As String
Visual C++
public:
property String^ AccessType {
    String^ get ();
    void set (String^ value);
}

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Folder Property

[image]

FastReport.Net Class Reference
AppInfo..::.Folder Property
AppInfo Class See Also Send Feedback
Gets or sets the name of app folder.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Folder { get; set; }
Visual Basic (Declaration)
Public Property Folder As String
Visual C++
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Key Property

[image]

FastReport.Net Class Reference
AppInfo..::.Key Property
AppInfo Class See Also Send Feedback
Gets or sets the app key.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Key { get; set; }
Visual Basic (Declaration)
Public Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Name Property

[image]

FastReport.Net Class Reference
AppInfo..::.Name Property
AppInfo Class See Also Send Feedback
Gets or sets the app name.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Secret Property

[image]

FastReport.Net Class Reference
AppInfo..::.Secret Property
AppInfo Class See Also Send Feedback
Gets or sets the app secret.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Secret { get; set; }
Visual Basic (Declaration)
Public Property Secret As String
Visual C++
public:
property String^ Secret {
    String^ get ();
    void set (String^ value);
}

See Also

AppInfo Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Class

[image]

FastReport.Net Class Reference
ApplicationInfoForm Class
Members See Also Send Feedback
Represents the Application Info diabolg form.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ApplicationInfoForm : BaseDialogForm
Visual Basic (Declaration)
Public Class ApplicationInfoForm _
    Inherits BaseDialogForm
Visual C++
public ref class ApplicationInfoForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.Dropbox..::.ApplicationInfoForm

See Also

ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Members

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm Members
ApplicationInfoForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The ApplicationInfoForm type exposes the following members.

Constructors

Name | Description
ApplicationInfoForm | Initializes a new instance of the ApplicationInfoForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Key | Gets the application key.
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Secret | Gets the application secret.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Constructor

[image]

FastReport.Net Class Reference
ApplicationInfoForm Constructor
ApplicationInfoForm Class See Also Send Feedback
Initializes a new instance of the ApplicationInfoForm class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ApplicationInfoForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ApplicationInfoForm()

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Fields

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm Fields
ApplicationInfoForm Class See Also Send Feedback

The ApplicationInfoForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Methods

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm Methods
ApplicationInfoForm Class See Also Send Feedback

The ApplicationInfoForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.AccessibilityNotifyClients Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.BeginInvoke Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Dispose Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Dispose Method (Boolean)
ApplicationInfoForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ApplicationInfoForm Class
Dispose Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.GetChildAtPoint Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Invalidate Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Invoke Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Localize Method

[image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Localize Method
ApplicationInfoForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.MemberwiseClone Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.PerformLayout Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.ResumeLayout Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.RtlTranslateAlignment Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Scale Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Select Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.SetBounds Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Show Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.ShowDialog Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.UpdateBounds Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Validate Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm..::.ValidateChildren Method
ApplicationInfoForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ApplicationInfoForm Class
ApplicationInfoForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Properties

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm Properties
ApplicationInfoForm Class See Also Send Feedback

The ApplicationInfoForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Key | Gets the application key.
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Secret | Gets the application secret.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Key Property

[image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Key Property
ApplicationInfoForm Class See Also Send Feedback
Gets the application key.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Key { get; }
Visual Basic (Declaration)
Public ReadOnly Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
}

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Secret Property

[image]

FastReport.Net Class Reference
ApplicationInfoForm..::.Secret Property
ApplicationInfoForm Class See Also Send Feedback
Gets the application secret.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Secret { get; }
Visual Basic (Declaration)
Public ReadOnly Property Secret As String
Visual C++
public:
property String^ Secret {
    String^ get ();
}

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ApplicationInfoForm Events

[image] [image]

FastReport.Net Class Reference
ApplicationInfoForm Events
ApplicationInfoForm Class See Also Send Feedback

The ApplicationInfoForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ApplicationInfoForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Class

[image]

FastReport.Net Class Reference
DropboxStorageClient Class
Members See Also Send Feedback
Dropbox cloud storage client.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DropboxStorageClient : CloudStorageClient
Visual Basic (Declaration)
Public Class DropboxStorageClient _
    Inherits CloudStorageClient
Visual C++
public ref class DropboxStorageClient : public CloudStorageClient

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient..::.CloudStorageClient
FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageClient

See Also

DropboxStorageClient Members
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Members

[image] [image]

FastReport.Net Class Reference
DropboxStorageClient Members
DropboxStorageClient Class Constructors Methods Fields Properties See Also Send Feedback

The DropboxStorageClient type exposes the following members.

Constructors

Name | Description
DropboxStorageClient | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAccessToken | Gets the access token.
GetAuthorizationUrl | Gets the authorization URL.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage. (Inherited from CloudStorageClient.)
SaveReport | Saves the report to cloud storage. (Overrides CloudStorageClient..::.SaveReport(Report, ExportBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AccessTokenUrlBase | The base URL for access token.
DropboxUrlBase | The base URL for Dropbox API.
FilesPutUrlBase | The base URL for files_put command.
RequestTokenUrlBase | The base URL for request token.
UserAuthorizationUrlBase | The base URL for user authorization.

Properties

Name | Description
AccessToken | Gets or sets the access token.
AppInfo | Gets or sets the application info.
Filename | Gets or sets the filename. (Inherited from CloudStorageClient.)
IsUserAuthorized | Gets or set the information is user authorized or not. (Inherited from CloudStorageClient.)
ProxySettings | Gets or sets the proxy settings of a client. (Inherited from CloudStorageClient.)
StorageConfig | Gets or sets the storage configuration.

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Constructor

[image] [image]

FastReport.Net Class Reference
DropboxStorageClient Constructor
DropboxStorageClient Class See Also Send Feedback

Overload List

Name | Description
DropboxStorageClient()()() | Initializes a new instance of the DropboxStorageClient class.
DropboxStorageClient(AppInfo, DropboxStorageConfig) | Initializes a new instance of the DropboxStorageClient class.

See Also

DropboxStorageClient Class
DropboxStorageClient Members
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Constructor

[image]

FastReport.Net Class Reference
DropboxStorageClient Constructor
DropboxStorageClient Class See Also Send Feedback
Initializes a new instance of the DropboxStorageClient class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DropboxStorageClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DropboxStorageClient()

See Also

DropboxStorageClient Class
DropboxStorageClient Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Constructor (AppInfo, DropboxStorageConfig)

[image]

FastReport.Net Class Reference
DropboxStorageClient Constructor (AppInfo, DropboxStorageConfig)
DropboxStorageClient Class See Also Send Feedback
Initializes a new instance of the DropboxStorageClient class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DropboxStorageClient(
    AppInfo appInfo,
    DropboxStorageConfig storageConfig
)
Visual Basic (Declaration)
Public Sub New ( _
    appInfo As AppInfo, _
    storageConfig As DropboxStorageConfig _
)
Visual C++
public:
DropboxStorageClient(
    AppInfo^ appInfo,
    DropboxStorageConfig^ storageConfig
)

Parameters

appInfo
Type: FastReport.Cloud.StorageClient.Dropbox..::.AppInfo
The Dropbox application info.
storageConfig
Type: FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageConfig
The Dropbox storage configuration.

See Also

DropboxStorageClient Class
DropboxStorageClient Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Fields

[image] [image]

FastReport.Net Class Reference
DropboxStorageClient Fields
DropboxStorageClient Class See Also Send Feedback

The DropboxStorageClient type exposes the following members.

Fields

Name | Description
AccessTokenUrlBase | The base URL for access token.
DropboxUrlBase | The base URL for Dropbox API.
FilesPutUrlBase | The base URL for files_put command.
RequestTokenUrlBase | The base URL for request token.
UserAuthorizationUrlBase | The base URL for user authorization.

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessTokenUrlBase Field

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.AccessTokenUrlBase Field
DropboxStorageClient Class See Also Send Feedback
The base URL for access token.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string AccessTokenUrlBase
Visual Basic (Declaration)
Public Const AccessTokenUrlBase As String
Visual C++
public:
literal String^ AccessTokenUrlBase

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxUrlBase Field

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.DropboxUrlBase Field
DropboxStorageClient Class See Also Send Feedback
The base URL for Dropbox API.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string DropboxUrlBase
Visual Basic (Declaration)
Public Const DropboxUrlBase As String
Visual C++
public:
literal String^ DropboxUrlBase

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


FilesPutUrlBase Field

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.FilesPutUrlBase Field
DropboxStorageClient Class See Also Send Feedback
The base URL for files_put command.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string FilesPutUrlBase
Visual Basic (Declaration)
Public Const FilesPutUrlBase As String
Visual C++
public:
literal String^ FilesPutUrlBase

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


RequestTokenUrlBase Field

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.RequestTokenUrlBase Field
DropboxStorageClient Class See Also Send Feedback
The base URL for request token.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string RequestTokenUrlBase
Visual Basic (Declaration)
Public Const RequestTokenUrlBase As String
Visual C++
public:
literal String^ RequestTokenUrlBase

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


UserAuthorizationUrlBase Field

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.UserAuthorizationUrlBase Field
DropboxStorageClient Class See Also Send Feedback
The base URL for user authorization.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public const string UserAuthorizationUrlBase
Visual Basic (Declaration)
Public Const UserAuthorizationUrlBase As String
Visual C++
public:
literal String^ UserAuthorizationUrlBase

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Methods

[image] [image]

FastReport.Net Class Reference
DropboxStorageClient Methods
DropboxStorageClient Class See Also Send Feedback

The DropboxStorageClient type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAccessToken | Gets the access token.
GetAuthorizationUrl | Gets the authorization URL.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage. (Inherited from CloudStorageClient.)
SaveReport | Saves the report to cloud storage. (Overrides CloudStorageClient..::.SaveReport(Report, ExportBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


GetAccessToken Method

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.GetAccessToken Method
DropboxStorageClient Class See Also Send Feedback
Gets the access token.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Token GetAccessToken()
Visual Basic (Declaration)
Public Function GetAccessToken As Token
Visual C++
public:
Token^ GetAccessToken()

Return Value

The access token.

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


GetAuthorizationUrl Method

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.GetAuthorizationUrl Method
DropboxStorageClient Class See Also Send Feedback
Gets the authorization URL.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetAuthorizationUrl()
Visual Basic (Declaration)
Public Function GetAuthorizationUrl As String
Visual C++
public:
String^ GetAuthorizationUrl()

Return Value

The authorization URL string.

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


SaveReport Method

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.SaveReport Method
DropboxStorageClient Class See Also Send Feedback
Saves the report to cloud storage.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool SaveReport(
    Report report,
    ExportBase export
)
Visual Basic (Declaration)
Public Overrides Function SaveReport ( _
    report As Report, _
    export As ExportBase _
) As Boolean
Visual C++
public:
virtual bool SaveReport(
    Report^ report,
    ExportBase^ export
) override

Parameters

report
Type: FastReport..::.Report
The report template that should be saved.
export
Type: FastReport.Export..::.ExportBase
The export filter that should export template before.

Return Value

True if report has been successfully saved.

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClient Properties

[image] [image]

FastReport.Net Class Reference
DropboxStorageClient Properties
DropboxStorageClient Class See Also Send Feedback

The DropboxStorageClient type exposes the following members.

Properties

Name | Description
AccessToken | Gets or sets the access token.
AppInfo | Gets or sets the application info.
Filename | Gets or sets the filename. (Inherited from CloudStorageClient.)
IsUserAuthorized | Gets or set the information is user authorized or not. (Inherited from CloudStorageClient.)
ProxySettings | Gets or sets the proxy settings of a client. (Inherited from CloudStorageClient.)
StorageConfig | Gets or sets the storage configuration.

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessToken Property

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.AccessToken Property
DropboxStorageClient Class See Also Send Feedback
Gets or sets the access token.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Token AccessToken { get; set; }
Visual Basic (Declaration)
Public Property AccessToken As Token
Visual C++
public:
property Token^ AccessToken {
    Token^ get ();
    void set (Token^ value);
}

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AppInfo Property

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.AppInfo Property
DropboxStorageClient Class See Also Send Feedback
Gets or sets the application info.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AppInfo AppInfo { get; set; }
Visual Basic (Declaration)
Public Property AppInfo As AppInfo
Visual C++
public:
property AppInfo^ AppInfo {
    AppInfo^ get ();
    void set (AppInfo^ value);
}

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


StorageConfig Property

[image]

FastReport.Net Class Reference
DropboxStorageClient..::.StorageConfig Property
DropboxStorageClient Class See Also Send Feedback
Gets or sets the storage configuration.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DropboxStorageConfig StorageConfig { get; set; }
Visual Basic (Declaration)
Public Property StorageConfig As DropboxStorageConfig
Visual C++
public:
property DropboxStorageConfig^ StorageConfig {
    DropboxStorageConfig^ get ();
    void set (DropboxStorageConfig^ value);
}

See Also

DropboxStorageClient Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Class

[image]

FastReport.Net Class Reference
DropboxStorageClientForm Class
Members See Also Send Feedback
Represents form of Dropbox storage client.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DropboxStorageClientForm : BaseDialogForm
Visual Basic (Declaration)
Public Class DropboxStorageClientForm _
    Inherits BaseDialogForm
Visual C++
public ref class DropboxStorageClientForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageClientForm

See Also

DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Members

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm Members
DropboxStorageClientForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The DropboxStorageClientForm type exposes the following members.

Constructors

Name | Description
DropboxStorageClientForm | Initializes a new instance of the DropboxStorageClientForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Constructor

[image]

FastReport.Net Class Reference
DropboxStorageClientForm Constructor
DropboxStorageClientForm Class See Also Send Feedback
Initializes a new instance of the DropboxStorageClientForm class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DropboxStorageClientForm(
    AppInfo appInfo,
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    appInfo As AppInfo, _
    report As Report _
)
Visual C++
public:
DropboxStorageClientForm(
    AppInfo^ appInfo,
    Report^ report
)

Parameters

appInfo
Type: FastReport.Cloud.StorageClient.Dropbox..::.AppInfo
The Dropbox application info.
report
Type: FastReport..::.Report
The report template.

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Fields

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm Fields
DropboxStorageClientForm Class See Also Send Feedback

The DropboxStorageClientForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Methods

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm Methods
DropboxStorageClientForm Class See Also Send Feedback

The DropboxStorageClientForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.AccessibilityNotifyClients Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.BeginInvoke Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Dispose Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Dispose Method (Boolean)
DropboxStorageClientForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DropboxStorageClientForm Class
Dispose Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.GetChildAtPoint Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Invalidate Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Invoke Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Localize Method

[image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Localize Method
DropboxStorageClientForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.MemberwiseClone Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.PerformLayout Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.ResumeLayout Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.RtlTranslateAlignment Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Scale Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Select Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.SetBounds Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Show Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.ShowDialog Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.UpdateBounds Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.Validate Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm..::.ValidateChildren Method
DropboxStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DropboxStorageClientForm Class
DropboxStorageClientForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Properties

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm Properties
DropboxStorageClientForm Class See Also Send Feedback

The DropboxStorageClientForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageClientForm Events

[image] [image]

FastReport.Net Class Reference
DropboxStorageClientForm Events
DropboxStorageClientForm Class See Also Send Feedback

The DropboxStorageClientForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DropboxStorageClientForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Class

[image]

FastReport.Net Class Reference
DropboxStorageConfig Class
Members See Also Send Feedback
Contains information needed to access the Dropbox storage.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DropboxStorageConfig
Visual Basic (Declaration)
Public Class DropboxStorageConfig
Visual C++
public ref class DropboxStorageConfig

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageConfig

See Also

DropboxStorageConfig Members
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Members

[image] [image]

FastReport.Net Class Reference
DropboxStorageConfig Members
DropboxStorageConfig Class Constructors Methods Properties See Also Send Feedback

The DropboxStorageConfig type exposes the following members.

Constructors

Name | Description
DropboxStorageConfig | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccessTokenUrl | Gets the access token URL.
CallbackUrl | Gets the callback URL;
RequestTokenUrl | Gets the request token URL.
UserAuthorizationUrl | Gets the user authorization URL.

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Constructor

[image] [image]

FastReport.Net Class Reference
DropboxStorageConfig Constructor
DropboxStorageConfig Class See Also Send Feedback

Overload List

Name | Description
DropboxStorageConfig(String) | Initializes a new instance of the DropboxStorageConfig class.
DropboxStorageConfig(String, String, String, String) | Initializes a new instance of the DropboxStorageConfig class.

See Also

DropboxStorageConfig Class
DropboxStorageConfig Members
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Constructor (String)

[image]

FastReport.Net Class Reference
DropboxStorageConfig Constructor (String)
DropboxStorageConfig Class See Also Send Feedback
Initializes a new instance of the DropboxStorageConfig class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DropboxStorageConfig(
    string callbackUrl
)
Visual Basic (Declaration)
Public Sub New ( _
    callbackUrl As String _
)
Visual C++
public:
DropboxStorageConfig(
    String^ callbackUrl
)

Parameters

callbackUrl
Type: System..::.String
The callback URL.

See Also

DropboxStorageConfig Class
DropboxStorageConfig Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Constructor (String, String, String, String)

[image]

FastReport.Net Class Reference
DropboxStorageConfig Constructor (String, String, String, String)
DropboxStorageConfig Class See Also Send Feedback
Initializes a new instance of the DropboxStorageConfig class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DropboxStorageConfig(
    string requestTokenUrl,
    string userAuthorizationUrl,
    string callbackUrl,
    string accessTokenUrl
)
Visual Basic (Declaration)
Public Sub New ( _
    requestTokenUrl As String, _
    userAuthorizationUrl As String, _
    callbackUrl As String, _
    accessTokenUrl As String _
)
Visual C++
public:
DropboxStorageConfig(
    String^ requestTokenUrl,
    String^ userAuthorizationUrl,
    String^ callbackUrl,
    String^ accessTokenUrl
)

Parameters

requestTokenUrl
Type: System..::.String
The request token URL.
userAuthorizationUrl
Type: System..::.String
The user authorization URL.
callbackUrl
Type: System..::.String
The callback URL.
accessTokenUrl
Type: System..::.String
The access token URL.

See Also

DropboxStorageConfig Class
DropboxStorageConfig Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Methods

[image] [image]

FastReport.Net Class Reference
DropboxStorageConfig Methods
DropboxStorageConfig Class See Also Send Feedback

The DropboxStorageConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


DropboxStorageConfig Properties

[image] [image]

FastReport.Net Class Reference
DropboxStorageConfig Properties
DropboxStorageConfig Class See Also Send Feedback

The DropboxStorageConfig type exposes the following members.

Properties

Name | Description
AccessTokenUrl | Gets the access token URL.
CallbackUrl | Gets the callback URL;
RequestTokenUrl | Gets the request token URL.
UserAuthorizationUrl | Gets the user authorization URL.

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessTokenUrl Property

[image]

FastReport.Net Class Reference
DropboxStorageConfig..::.AccessTokenUrl Property
DropboxStorageConfig Class See Also Send Feedback
Gets the access token URL.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AccessTokenUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessTokenUrl As String
Visual C++
public:
property String^ AccessTokenUrl {
    String^ get ();
}

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


CallbackUrl Property

[image]

FastReport.Net Class Reference
DropboxStorageConfig..::.CallbackUrl Property
DropboxStorageConfig Class See Also Send Feedback
Gets the callback URL;

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CallbackUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property CallbackUrl As String
Visual C++
public:
property String^ CallbackUrl {
    String^ get ();
}

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


RequestTokenUrl Property

[image]

FastReport.Net Class Reference
DropboxStorageConfig..::.RequestTokenUrl Property
DropboxStorageConfig Class See Also Send Feedback
Gets the request token URL.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string RequestTokenUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property RequestTokenUrl As String
Visual C++
public:
property String^ RequestTokenUrl {
    String^ get ();
}

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


UserAuthorizationUrl Property

[image]

FastReport.Net Class Reference
DropboxStorageConfig..::.UserAuthorizationUrl Property
DropboxStorageConfig Class See Also Send Feedback
Gets the user authorization URL.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string UserAuthorizationUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserAuthorizationUrl As String
Visual C++
public:
property String^ UserAuthorizationUrl {
    String^ get ();
}

See Also

DropboxStorageConfig Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Session Class

[image]

FastReport.Net Class Reference
Session Class
Members See Also Send Feedback
Represents the Dropbox session.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Session
Visual Basic (Declaration)
Public Class Session
Visual C++
public ref class Session

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient.Dropbox..::.Session

See Also

Session Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Session Members

[image] [image]

FastReport.Net Class Reference
Session Members
Session Class Constructors Methods See Also Send Feedback

The Session type exposes the following members.

Constructors

Name | Description
Session | Initializes a new instance of the Session class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObtainAuthorizationUrl | Obtains the authorization URL.
ObtainDropboxAccessToken | Obtains the access token.
ObtainDropboxRequestToken | Obtains the request token.
ObtainFilesPutUrl | Obtains the URL for uploading a file using PUT semantics.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Session Constructor

[image]

FastReport.Net Class Reference
Session Constructor
Session Class See Also Send Feedback
Initializes a new instance of the Session class.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Session(
    CloudProxySettings proxySettings
)
Visual Basic (Declaration)
Public Sub New ( _
    proxySettings As CloudProxySettings _
)
Visual C++
public:
Session(
    CloudProxySettings^ proxySettings
)

Parameters

proxySettings
Type: FastReport.Cloud..::.CloudProxySettings

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


Session Methods

[image] [image]

FastReport.Net Class Reference
Session Methods
Session Class See Also Send Feedback

The Session type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ObtainAuthorizationUrl | Obtains the authorization URL.
ObtainDropboxAccessToken | Obtains the access token.
ObtainDropboxRequestToken | Obtains the request token.
ObtainFilesPutUrl | Obtains the URL for uploading a file using PUT semantics.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ObtainAuthorizationUrl Method

[image]

FastReport.Net Class Reference
Session..::.ObtainAuthorizationUrl Method
Session Class See Also Send Feedback
Obtains the authorization URL.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ObtainAuthorizationUrl(
    DropboxStorageConfig config,
    Token requestToken
)
Visual Basic (Declaration)
Public Function ObtainAuthorizationUrl ( _
    config As DropboxStorageConfig, _
    requestToken As Token _
) As String
Visual C++
public:
String^ ObtainAuthorizationUrl(
    DropboxStorageConfig^ config,
    Token^ requestToken
)

Parameters

config
Type: FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageConfig
The Dropbox storage configuration.
requestToken
Type: FastReport.Cloud.OAuth..::.Token
The request token.

Return Value

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ObtainDropboxAccessToken Method

[image]

FastReport.Net Class Reference
Session..::.ObtainDropboxAccessToken Method
Session Class See Also Send Feedback
Obtains the access token.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Token ObtainDropboxAccessToken(
    DropboxStorageConfig config,
    ConsumerContext consumer,
    Token requestToken
)
Visual Basic (Declaration)
Public Function ObtainDropboxAccessToken ( _
    config As DropboxStorageConfig, _
    consumer As ConsumerContext, _
    requestToken As Token _
) As Token
Visual C++
public:
Token^ ObtainDropboxAccessToken(
    DropboxStorageConfig^ config,
    ConsumerContext^ consumer,
    Token^ requestToken
)

Parameters

config
Type: FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageConfig
The Dropbox storage configuration.
consumer
Type: FastReport.Cloud.OAuth..::.ConsumerContext
The consumer.
requestToken
Type: FastReport.Cloud.OAuth..::.Token
The request token string.

Return Value

The access token.

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ObtainDropboxRequestToken Method

[image]

FastReport.Net Class Reference
Session..::.ObtainDropboxRequestToken Method
Session Class See Also Send Feedback
Obtains the request token.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Token ObtainDropboxRequestToken(
    DropboxStorageConfig config,
    ConsumerContext consumer
)
Visual Basic (Declaration)
Public Function ObtainDropboxRequestToken ( _
    config As DropboxStorageConfig, _
    consumer As ConsumerContext _
) As Token
Visual C++
public:
Token^ ObtainDropboxRequestToken(
    DropboxStorageConfig^ config,
    ConsumerContext^ consumer
)

Parameters

config
Type: FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageConfig
The Dropbox storage configuration.
consumer
Type: FastReport.Cloud.OAuth..::.ConsumerContext
The consumer context.

Return Value

The request token.

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


ObtainFilesPutUrl Method

[image]

FastReport.Net Class Reference
Session..::.ObtainFilesPutUrl Method
Session Class See Also Send Feedback
Obtains the URL for uploading a file using PUT semantics.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ObtainFilesPutUrl(
    string baseFilesPutUrl,
    string root,
    string filename,
    ConsumerContext consumer,
    Token accessToken
)
Visual Basic (Declaration)
Public Function ObtainFilesPutUrl ( _
    baseFilesPutUrl As String, _
    root As String, _
    filename As String, _
    consumer As ConsumerContext, _
    accessToken As Token _
) As String
Visual C++
public:
String^ ObtainFilesPutUrl(
    String^ baseFilesPutUrl,
    String^ root,
    String^ filename,
    ConsumerContext^ consumer,
    Token^ accessToken
)

Parameters

baseFilesPutUrl
Type: System..::.String
The base URL for files_put command.
root
Type: System..::.String
The root relative to which path is specified.
filename
Type: System..::.String
The name of file you want to write to.
consumer
Type: FastReport.Cloud.OAuth..::.ConsumerContext
The consumer.
accessToken
Type: FastReport.Cloud.OAuth..::.Token
The access token.

Return Value

The URL for uploading a file.

See Also

Session Class
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Class

[image]

FastReport.Net Class Reference
WebBrowserForm Class
Members See Also Send Feedback
Represents form of the web browser.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class WebBrowserForm : BaseDialogForm
Visual Basic (Declaration)
Public Class WebBrowserForm _
    Inherits BaseDialogForm
Visual C++
public ref class WebBrowserForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.Dropbox..::.WebBrowserForm

See Also

WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Members

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Members
WebBrowserForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The WebBrowserForm type exposes the following members.

Constructors

Name | Description
WebBrowserForm | Initializes a new instance of the Control class with specific text.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Constructor

[image]

FastReport.Net Class Reference
WebBrowserForm Constructor
WebBrowserForm Class See Also Send Feedback
Initializes a new instance of the Control class with specific text.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WebBrowserForm(
    string url
)
Visual Basic (Declaration)
Public Sub New ( _
    url As String _
)
Visual C++
public:
WebBrowserForm(
    String^ url
)

Parameters

url
Type: System..::.String

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Fields

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Fields
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Methods

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Methods
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.AccessibilityNotifyClients Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.BeginInvoke Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Dispose Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
WebBrowserForm..::.Dispose Method (Boolean)
WebBrowserForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.Dropbox
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

WebBrowserForm Class
Dispose Overload
FastReport.Cloud.StorageClient.Dropbox Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.GetChildAtPoint Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Invalidate Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Invoke Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.MemberwiseClone Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.PerformLayout Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ResumeLayout Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.RtlTranslateAlignment Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Scale Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Select Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.SetBounds Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Show Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ShowDialog Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.UpdateBounds Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Validate Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ValidateChildren Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Properties

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Properties
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


WebBrowserForm Events

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Events
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.Dropbox Namespace


FastReport.Cloud.StorageClient.GoogleDrive Namespace

[image]

FastReport.Net Class Reference
FastReport.Cloud.StorageClient.GoogleDrive Namespace
Send Feedback

Classes

Class | Description
ClientInfoForm | Represents the Client Info diabolg form.
GoogleDriveStorageClient | Google Drive cloud storage client.
GoogleDriveStorageClientForm | Represents form of Google Drive storage client.
WebBrowserForm | Represents form of the web browser.


ClientInfoForm Class

[image]

FastReport.Net Class Reference
ClientInfoForm Class
Members See Also Send Feedback
Represents the Client Info diabolg form.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ClientInfoForm : BaseDialogForm
Visual Basic (Declaration)
Public Class ClientInfoForm _
    Inherits BaseDialogForm
Visual C++
public ref class ClientInfoForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.GoogleDrive..::.ClientInfoForm

See Also

ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfoForm Members

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Members
ClientInfoForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The ClientInfoForm type exposes the following members.

Constructors

Name | Description
ClientInfoForm | Initializes a new instance of the ClientInfoForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
Id | Gets the client ID.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Secret | Gets the client secret.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfoForm Constructor

[image]

FastReport.Net Class Reference
ClientInfoForm Constructor
ClientInfoForm Class See Also Send Feedback
Initializes a new instance of the ClientInfoForm class.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ClientInfoForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ClientInfoForm()

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfoForm Fields

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Fields
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfoForm Methods

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Methods
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.AccessibilityNotifyClients Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.BeginInvoke Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Dispose Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Dispose Method (Boolean)
ClientInfoForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ClientInfoForm Class
Dispose Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.GetChildAtPoint Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Invalidate Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Invoke Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Localize Method

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Localize Method
ClientInfoForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.MemberwiseClone Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.PerformLayout Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.ResumeLayout Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.RtlTranslateAlignment Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Scale Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Select Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.SetBounds Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Show Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.ShowDialog Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.UpdateBounds Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Validate Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.ValidateChildren Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfoForm Properties

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Properties
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
Id | Gets the client ID.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Secret | Gets the client secret.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Id Property

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Id Property
ClientInfoForm Class See Also Send Feedback
Gets the client ID.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
}

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Secret Property

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Secret Property
ClientInfoForm Class See Also Send Feedback
Gets the client secret.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Secret { get; }
Visual Basic (Declaration)
Public ReadOnly Property Secret As String
Visual C++
public:
property String^ Secret {
    String^ get ();
}

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfoForm Events

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Events
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Class

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient Class
Members See Also Send Feedback
Google Drive cloud storage client.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GoogleDriveStorageClient : CloudStorageClient
Visual Basic (Declaration)
Public Class GoogleDriveStorageClient _
    Inherits CloudStorageClient
Visual C++
public ref class GoogleDriveStorageClient : public CloudStorageClient

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient..::.CloudStorageClient
FastReport.Cloud.StorageClient.GoogleDrive..::.GoogleDriveStorageClient

See Also

GoogleDriveStorageClient Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Members

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClient Members
GoogleDriveStorageClient Class Constructors Methods Properties See Also Send Feedback

The GoogleDriveStorageClient type exposes the following members.

Constructors

Name | Description
GoogleDriveStorageClient | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAccessToken | Gets the access token.
GetAuthorizationUrl | Gets the authorization URL.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage. (Inherited from CloudStorageClient.)
SaveReport | Saves the report to cloud storage. (Overrides CloudStorageClient..::.SaveReport(Report, ExportBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccessToken | Gets or sets the access token.
AuthCode | Gets or sets the authorization code.
ClientInfo | Gets or sets the client info.
Filename | Gets or sets the filename. (Inherited from CloudStorageClient.)
IsUserAuthorized | Gets or set the information is user authorized or not. (Inherited from CloudStorageClient.)
ProxySettings | Gets or sets the proxy settings of a client. (Inherited from CloudStorageClient.)

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Constructor

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClient Constructor
GoogleDriveStorageClient Class See Also Send Feedback

Overload List

Name | Description
GoogleDriveStorageClient()()() | Initializes a new instance of the GoogleDriveStorageClient class.
GoogleDriveStorageClient(ClientInfo) | Initializes a new instance of the GoogleDriveStorageClient class.

See Also

GoogleDriveStorageClient Class
GoogleDriveStorageClient Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Constructor

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient Constructor
GoogleDriveStorageClient Class See Also Send Feedback
Initializes a new instance of the GoogleDriveStorageClient class.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GoogleDriveStorageClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GoogleDriveStorageClient()

See Also

GoogleDriveStorageClient Class
GoogleDriveStorageClient Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Constructor (ClientInfo)

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient Constructor (ClientInfo)
GoogleDriveStorageClient Class See Also Send Feedback
Initializes a new instance of the GoogleDriveStorageClient class.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GoogleDriveStorageClient(
    ClientInfo clientInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    clientInfo As ClientInfo _
)
Visual C++
public:
GoogleDriveStorageClient(
    ClientInfo^ clientInfo
)

Parameters

clientInfo
Type: FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfo
The storage client info.

See Also

GoogleDriveStorageClient Class
GoogleDriveStorageClient Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Methods

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClient Methods
GoogleDriveStorageClient Class See Also Send Feedback

The GoogleDriveStorageClient type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAccessToken | Gets the access token.
GetAuthorizationUrl | Gets the authorization URL.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage. (Inherited from CloudStorageClient.)
SaveReport | Saves the report to cloud storage. (Overrides CloudStorageClient..::.SaveReport(Report, ExportBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GetAccessToken Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient..::.GetAccessToken Method
GoogleDriveStorageClient Class See Also Send Feedback
Gets the access token.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetAccessToken()
Visual Basic (Declaration)
Public Function GetAccessToken As String
Visual C++
public:
String^ GetAccessToken()

Return Value

The access token string.

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GetAuthorizationUrl Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient..::.GetAuthorizationUrl Method
GoogleDriveStorageClient Class See Also Send Feedback
Gets the authorization URL.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetAuthorizationUrl()
Visual Basic (Declaration)
Public Function GetAuthorizationUrl As String
Visual C++
public:
String^ GetAuthorizationUrl()

Return Value

The authorization URL stirng.

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


SaveReport Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient..::.SaveReport Method
GoogleDriveStorageClient Class See Also Send Feedback
Saves the report to cloud storage.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool SaveReport(
    Report report,
    ExportBase export
)
Visual Basic (Declaration)
Public Overrides Function SaveReport ( _
    report As Report, _
    export As ExportBase _
) As Boolean
Visual C++
public:
virtual bool SaveReport(
    Report^ report,
    ExportBase^ export
) override

Parameters

report
Type: FastReport..::.Report
The report template that should be saved.
export
Type: FastReport.Export..::.ExportBase
The export filter that should export template before.

Return Value

True if report has been successfully saved.

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClient Properties

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClient Properties
GoogleDriveStorageClient Class See Also Send Feedback

The GoogleDriveStorageClient type exposes the following members.

Properties

Name | Description
AccessToken | Gets or sets the access token.
AuthCode | Gets or sets the authorization code.
ClientInfo | Gets or sets the client info.
Filename | Gets or sets the filename. (Inherited from CloudStorageClient.)
IsUserAuthorized | Gets or set the information is user authorized or not. (Inherited from CloudStorageClient.)
ProxySettings | Gets or sets the proxy settings of a client. (Inherited from CloudStorageClient.)

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


AccessToken Property

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient..::.AccessToken Property
GoogleDriveStorageClient Class See Also Send Feedback
Gets or sets the access token.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AccessToken { get; set; }
Visual Basic (Declaration)
Public Property AccessToken As String
Visual C++
public:
property String^ AccessToken {
    String^ get ();
    void set (String^ value);
}

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


AuthCode Property

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient..::.AuthCode Property
GoogleDriveStorageClient Class See Also Send Feedback
Gets or sets the authorization code.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AuthCode { get; set; }
Visual Basic (Declaration)
Public Property AuthCode As String
Visual C++
public:
property String^ AuthCode {
    String^ get ();
    void set (String^ value);
}

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ClientInfo Property

[image]

FastReport.Net Class Reference
GoogleDriveStorageClient..::.ClientInfo Property
GoogleDriveStorageClient Class See Also Send Feedback
Gets or sets the client info.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ClientInfo ClientInfo { get; set; }
Visual Basic (Declaration)
Public Property ClientInfo As ClientInfo
Visual C++
public:
property ClientInfo^ ClientInfo {
    ClientInfo^ get ();
    void set (ClientInfo^ value);
}

See Also

GoogleDriveStorageClient Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Class

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Class
Members See Also Send Feedback
Represents form of Google Drive storage client.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GoogleDriveStorageClientForm : CloudStorageClientForm
Visual Basic (Declaration)
Public Class GoogleDriveStorageClientForm _
    Inherits CloudStorageClientForm
Visual C++
public ref class GoogleDriveStorageClientForm : public CloudStorageClientForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient..::.CloudStorageClientForm
FastReport.Cloud.StorageClient.GoogleDrive..::.GoogleDriveStorageClientForm

See Also

GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Members

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Members
GoogleDriveStorageClientForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The GoogleDriveStorageClientForm type exposes the following members.

Constructors

Name | Description
GoogleDriveStorageClientForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
btnOk_Click | Click event handler for button OK. (Overrides CloudStorageClientForm..::.btnOk_Click(Object, EventArgs).)
buttonSettings_Click | Click event handler for Button Settings. (Inherited from CloudStorageClientForm.)
cbFileType_SelectedIndexChanged | SelectedIndexChanged event handler for ComboBox File Type. (Inherited from CloudStorageClientForm.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
CloudStorageClientForm_FormClosing | FormClosing event handler for CloudStorageClientForm. (Inherited from CloudStorageClientForm.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Finishes the form work. (Overrides CloudStorageClientForm..::.Done()()().)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes the component. (Overrides CloudStorageClientForm..::.Init()()().)
InitExports | Initializes the list of exports. (Inherited from CloudStorageClientForm.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
IsNumeric | Checks is the string numeric. (Inherited from CloudStorageClientForm.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides CloudStorageClientForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
buttonSettings | Buttons Settings. (Inherited from CloudStorageClientForm.)
cbFileType | ComboBox File Type. (Inherited from CloudStorageClientForm.)
labelColon | Label Colon. (Inherited from CloudStorageClientForm.)
labelFileType | Label File Type. (Inherited from CloudStorageClientForm.)
labelPassword | Label Password. (Inherited from CloudStorageClientForm.)
labelServer | Label Server. (Inherited from CloudStorageClientForm.)
labelUsername | Label Username. (Inherited from CloudStorageClientForm.)
pageControl1 | PageControl. (Inherited from CloudStorageClientForm.)
pgFile | Page File. (Inherited from CloudStorageClientForm.)
pgProxy | Page Proxy. (Inherited from CloudStorageClientForm.)
tbPassword | TextBox Password. (Inherited from CloudStorageClientForm.)
tbPort | TextBox Port. (Inherited from CloudStorageClientForm.)
tbServer | TextBox Server. (Inherited from CloudStorageClientForm.)
tbUsername | TextBox Username. (Inherited from CloudStorageClientForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exports | Gets or sets the list of exports. (Inherited from CloudStorageClientForm.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the report template. (Inherited from CloudStorageClientForm.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Constructor

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Constructor
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
GoogleDriveStorageClientForm()()() | Initializes a new instance of the GoogleDriveStorageClientForm class.
GoogleDriveStorageClientForm(ClientInfo, Report) | Initializes a new instance of the GoogleDriveStorageClientForm class.

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Constructor

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Constructor
GoogleDriveStorageClientForm Class See Also Send Feedback
Initializes a new instance of the GoogleDriveStorageClientForm class.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GoogleDriveStorageClientForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GoogleDriveStorageClientForm()

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Constructor (ClientInfo, Report)

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Constructor (ClientInfo, Report)
GoogleDriveStorageClientForm Class See Also Send Feedback
Initializes a new instance of the GoogleDriveStorageClientForm class.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GoogleDriveStorageClientForm(
    ClientInfo clientInfo,
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    clientInfo As ClientInfo, _
    report As Report _
)
Visual C++
public:
GoogleDriveStorageClientForm(
    ClientInfo^ clientInfo,
    Report^ report
)

Parameters

clientInfo
Type: FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfo
The information about Google Drive client application.
report
Type: FastReport..::.Report
The report template.

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Fields

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Fields
GoogleDriveStorageClientForm Class See Also Send Feedback

The GoogleDriveStorageClientForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
buttonSettings | Buttons Settings. (Inherited from CloudStorageClientForm.)
cbFileType | ComboBox File Type. (Inherited from CloudStorageClientForm.)
labelColon | Label Colon. (Inherited from CloudStorageClientForm.)
labelFileType | Label File Type. (Inherited from CloudStorageClientForm.)
labelPassword | Label Password. (Inherited from CloudStorageClientForm.)
labelServer | Label Server. (Inherited from CloudStorageClientForm.)
labelUsername | Label Username. (Inherited from CloudStorageClientForm.)
pageControl1 | PageControl. (Inherited from CloudStorageClientForm.)
pgFile | Page File. (Inherited from CloudStorageClientForm.)
pgProxy | Page Proxy. (Inherited from CloudStorageClientForm.)
tbPassword | TextBox Password. (Inherited from CloudStorageClientForm.)
tbPort | TextBox Port. (Inherited from CloudStorageClientForm.)
tbServer | TextBox Server. (Inherited from CloudStorageClientForm.)
tbUsername | TextBox Username. (Inherited from CloudStorageClientForm.)

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Methods

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Methods
GoogleDriveStorageClientForm Class See Also Send Feedback

The GoogleDriveStorageClientForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
btnOk_Click | Click event handler for button OK. (Overrides CloudStorageClientForm..::.btnOk_Click(Object, EventArgs).)
buttonSettings_Click | Click event handler for Button Settings. (Inherited from CloudStorageClientForm.)
cbFileType_SelectedIndexChanged | SelectedIndexChanged event handler for ComboBox File Type. (Inherited from CloudStorageClientForm.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
CloudStorageClientForm_FormClosing | FormClosing event handler for CloudStorageClientForm. (Inherited from CloudStorageClientForm.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Finishes the form work. (Overrides CloudStorageClientForm..::.Done()()().)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes the component. (Overrides CloudStorageClientForm..::.Init()()().)
InitExports | Initializes the list of exports. (Inherited from CloudStorageClientForm.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
IsNumeric | Checks is the string numeric. (Inherited from CloudStorageClientForm.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides CloudStorageClientForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.AccessibilityNotifyClients Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.BeginInvoke Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


btnOk_Click Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.btnOk_Click Method
GoogleDriveStorageClientForm Class See Also Send Feedback
Click event handler for button OK.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void btnOk_Click(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub btnOk_Click ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
virtual void btnOk_Click(
    Object^ sender,
    EventArgs^ e
) override

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System..::.EventArgs
Event args.

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Dispose Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides CloudStorageClientForm..::.Dispose(Boolean).)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Dispose Method (Boolean)
GoogleDriveStorageClientForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GoogleDriveStorageClientForm Class
Dispose Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Done Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Done Method
GoogleDriveStorageClientForm Class See Also Send Feedback
Finishes the form work.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool Done()
Visual Basic (Declaration)
Protected Overrides Function Done As Boolean
Visual C++
protected:
virtual bool Done() override

Return Value

Returns true if work has been successfully finished, otherwise false.

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.GetChildAtPoint Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Init Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Init Method
GoogleDriveStorageClientForm Class See Also Send Feedback
Initializes the component.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Init()
Visual Basic (Declaration)
Protected Overrides Sub Init
Visual C++
protected:
virtual void Init() override

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Invalidate Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Invoke Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Localize Method

[image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Localize Method
GoogleDriveStorageClientForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.MemberwiseClone Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.PerformLayout Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.ResumeLayout Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.RtlTranslateAlignment Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Scale Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Select Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.SetBounds Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Show Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.ShowDialog Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.UpdateBounds Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.Validate Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm..::.ValidateChildren Method
GoogleDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

GoogleDriveStorageClientForm Class
GoogleDriveStorageClientForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Properties

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Properties
GoogleDriveStorageClientForm Class See Also Send Feedback

The GoogleDriveStorageClientForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exports | Gets or sets the list of exports. (Inherited from CloudStorageClientForm.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the report template. (Inherited from CloudStorageClientForm.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GoogleDriveStorageClientForm Events

[image] [image]

FastReport.Net Class Reference
GoogleDriveStorageClientForm Events
GoogleDriveStorageClientForm Class See Also Send Feedback

The GoogleDriveStorageClientForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GoogleDriveStorageClientForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Class

[image]

FastReport.Net Class Reference
WebBrowserForm Class
Members See Also Send Feedback
Represents form of the web browser.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class WebBrowserForm : BaseDialogForm
Visual Basic (Declaration)
Public Class WebBrowserForm _
    Inherits BaseDialogForm
Visual C++
public ref class WebBrowserForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.GoogleDrive..::.WebBrowserForm

See Also

WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Members

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Members
WebBrowserForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The WebBrowserForm type exposes the following members.

Constructors

Name | Description
WebBrowserForm | Initializes a new instance of the Control class with specific text.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AuthCode | Gets obtained authorization code.
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Constructor

[image]

FastReport.Net Class Reference
WebBrowserForm Constructor
WebBrowserForm Class See Also Send Feedback
Initializes a new instance of the Control class with specific text.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WebBrowserForm(
    string url
)
Visual Basic (Declaration)
Public Sub New ( _
    url As String _
)
Visual C++
public:
WebBrowserForm(
    String^ url
)

Parameters

url
Type: System..::.String

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Fields

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Fields
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Methods

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Methods
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.AccessibilityNotifyClients Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.BeginInvoke Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Dispose Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
WebBrowserForm..::.Dispose Method (Boolean)
WebBrowserForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

WebBrowserForm Class
Dispose Overload
FastReport.Cloud.StorageClient.GoogleDrive Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.GetChildAtPoint Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Invalidate Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Invoke Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.MemberwiseClone Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.PerformLayout Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ResumeLayout Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.RtlTranslateAlignment Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Scale Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Select Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.SetBounds Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Show Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ShowDialog Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.UpdateBounds Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Validate Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ValidateChildren Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Properties

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Properties
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AuthCode | Gets obtained authorization code.
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


AuthCode Property

[image]

FastReport.Net Class Reference
WebBrowserForm..::.AuthCode Property
WebBrowserForm Class See Also Send Feedback
Gets obtained authorization code.

Namespace: FastReport.Cloud.StorageClient.GoogleDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AuthCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property AuthCode As String
Visual C++
public:
property String^ AuthCode {
    String^ get ();
}

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


WebBrowserForm Events

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Events
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.GoogleDrive Namespace


FastReport.Cloud.StorageClient.SkyDrive Namespace

[image]

FastReport.Net Class Reference
FastReport.Cloud.StorageClient.SkyDrive Namespace
Send Feedback

Classes

Class | Description
ClientInfo | Represents the information about SkyDrive application.
ClientInfoForm | Represents the Client Info diabolg form.
SkyDriveStorageClient | SkyDrive cloud storage client.
SkyDriveStorageClientForm | Represents form of SkyDrive storage client.
WebBrowserForm | Represents form of the web browser.


ClientInfo Class

[image]

FastReport.Net Class Reference
ClientInfo Class
Members See Also Send Feedback
Represents the information about SkyDrive application.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ClientInfo
Visual Basic (Declaration)
Public Class ClientInfo
Visual C++
public ref class ClientInfo

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfo

See Also

ClientInfo Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfo Members

[image] [image]

FastReport.Net Class Reference
ClientInfo Members
ClientInfo Class Constructors Methods Properties See Also Send Feedback

The ClientInfo type exposes the following members.

Constructors

Name | Description
ClientInfo | Initializes a new instance of the ClientInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | Gets or sets the client ID.
Name | Gets or sets the client name.
Secret | Gets or sets the client secret.

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfo Constructor

[image]

FastReport.Net Class Reference
ClientInfo Constructor
ClientInfo Class See Also Send Feedback
Initializes a new instance of the ClientInfo class.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ClientInfo(
    string name,
    string id,
    string secret
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    id As String, _
    secret As String _
)
Visual C++
public:
ClientInfo(
    String^ name,
    String^ id,
    String^ secret
)

Parameters

name
Type: System..::.String
The client name.
id
Type: System..::.String
The client ID.
secret
Type: System..::.String
The client secret.

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfo Methods

[image] [image]

FastReport.Net Class Reference
ClientInfo Methods
ClientInfo Class See Also Send Feedback

The ClientInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfo Properties

[image] [image]

FastReport.Net Class Reference
ClientInfo Properties
ClientInfo Class See Also Send Feedback

The ClientInfo type exposes the following members.

Properties

Name | Description
Id | Gets or sets the client ID.
Name | Gets or sets the client name.
Secret | Gets or sets the client secret.

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


Id Property

[image]

FastReport.Net Class Reference
ClientInfo..::.Id Property
ClientInfo Class See Also Send Feedback
Gets or sets the client ID.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


Name Property

[image]

FastReport.Net Class Reference
ClientInfo..::.Name Property
ClientInfo Class See Also Send Feedback
Gets or sets the client name.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


Secret Property

[image]

FastReport.Net Class Reference
ClientInfo..::.Secret Property
ClientInfo Class See Also Send Feedback
Gets or sets the client secret.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Secret { get; set; }
Visual Basic (Declaration)
Public Property Secret As String
Visual C++
public:
property String^ Secret {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Class

[image]

FastReport.Net Class Reference
ClientInfoForm Class
Members See Also Send Feedback
Represents the Client Info diabolg form.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ClientInfoForm : BaseDialogForm
Visual Basic (Declaration)
Public Class ClientInfoForm _
    Inherits BaseDialogForm
Visual C++
public ref class ClientInfoForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfoForm

See Also

ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Members

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Members
ClientInfoForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The ClientInfoForm type exposes the following members.

Constructors

Name | Description
ClientInfoForm | Initializes a new instance of the ClientInfoForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
Id | Gets the client ID.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Secret | Gets the client secret.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Constructor

[image]

FastReport.Net Class Reference
ClientInfoForm Constructor
ClientInfoForm Class See Also Send Feedback
Initializes a new instance of the ClientInfoForm class.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ClientInfoForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ClientInfoForm()

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Fields

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Fields
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Methods

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Methods
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.AccessibilityNotifyClients Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.BeginInvoke Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Dispose Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Dispose Method (Boolean)
ClientInfoForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ClientInfoForm Class
Dispose Overload
FastReport.Cloud.StorageClient.SkyDrive Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.GetChildAtPoint Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Invalidate Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Invoke Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Localize Method

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Localize Method
ClientInfoForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.MemberwiseClone Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.PerformLayout Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.ResumeLayout Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.RtlTranslateAlignment Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Scale Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Select Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.SetBounds Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Show Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.ShowDialog Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.UpdateBounds Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.Validate Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ClientInfoForm..::.ValidateChildren Method
ClientInfoForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ClientInfoForm Class
ClientInfoForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Properties

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Properties
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
Id | Gets the client ID.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Secret | Gets the client secret.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


Id Property

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Id Property
ClientInfoForm Class See Also Send Feedback
Gets the client ID.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
}

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


Secret Property

[image]

FastReport.Net Class Reference
ClientInfoForm..::.Secret Property
ClientInfoForm Class See Also Send Feedback
Gets the client secret.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Secret { get; }
Visual Basic (Declaration)
Public ReadOnly Property Secret As String
Visual C++
public:
property String^ Secret {
    String^ get ();
}

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfoForm Events

[image] [image]

FastReport.Net Class Reference
ClientInfoForm Events
ClientInfoForm Class See Also Send Feedback

The ClientInfoForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ClientInfoForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Class

[image]

FastReport.Net Class Reference
SkyDriveStorageClient Class
Members See Also Send Feedback
SkyDrive cloud storage client.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SkyDriveStorageClient : CloudStorageClient
Visual Basic (Declaration)
Public Class SkyDriveStorageClient _
    Inherits CloudStorageClient
Visual C++
public ref class SkyDriveStorageClient : public CloudStorageClient

Inheritance Hierarchy

System..::.Object
FastReport.Cloud.StorageClient..::.CloudStorageClient
FastReport.Cloud.StorageClient.SkyDrive..::.SkyDriveStorageClient

See Also

SkyDriveStorageClient Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Members

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClient Members
SkyDriveStorageClient Class Constructors Methods Properties See Also Send Feedback

The SkyDriveStorageClient type exposes the following members.

Constructors

Name | Description
SkyDriveStorageClient | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAccessToken | Gets the access token.
GetAuthorizationUrl | Gets the authorization URL.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage. (Inherited from CloudStorageClient.)
SaveReport | Saves the report to cloud storage. (Overrides CloudStorageClient..::.SaveReport(Report, ExportBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccessToken | Gets or sets the access token.
AuthCode | Gets or sets the authorization code.
ClientInfo | Gets or sets the client info.
Filename | Gets or sets the filename. (Inherited from CloudStorageClient.)
IsUserAuthorized | Gets or set the information is user authorized or not. (Inherited from CloudStorageClient.)
ProxySettings | Gets or sets the proxy settings of a client. (Inherited from CloudStorageClient.)

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Constructor

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClient Constructor
SkyDriveStorageClient Class See Also Send Feedback

Overload List

Name | Description
SkyDriveStorageClient()()() | Initializes a new instance of the SkyDriveStorageClient class.
SkyDriveStorageClient(ClientInfo) | Initializes a new instance of the SkyDriveStorageClient class.

See Also

SkyDriveStorageClient Class
SkyDriveStorageClient Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Constructor

[image]

FastReport.Net Class Reference
SkyDriveStorageClient Constructor
SkyDriveStorageClient Class See Also Send Feedback
Initializes a new instance of the SkyDriveStorageClient class.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SkyDriveStorageClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SkyDriveStorageClient()

See Also

SkyDriveStorageClient Class
SkyDriveStorageClient Overload
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Constructor (ClientInfo)

[image]

FastReport.Net Class Reference
SkyDriveStorageClient Constructor (ClientInfo)
SkyDriveStorageClient Class See Also Send Feedback
Initializes a new instance of the SkyDriveStorageClient class.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SkyDriveStorageClient(
    ClientInfo clientInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    clientInfo As ClientInfo _
)
Visual C++
public:
SkyDriveStorageClient(
    ClientInfo^ clientInfo
)

Parameters

clientInfo
Type: FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfo
The client info.

See Also

SkyDriveStorageClient Class
SkyDriveStorageClient Overload
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Methods

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClient Methods
SkyDriveStorageClient Class See Also Send Feedback

The SkyDriveStorageClient type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAccessToken | Gets the access token.
GetAuthorizationUrl | Gets the authorization URL.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareToSave | Prepares report before it will be saved to cloud storage. (Inherited from CloudStorageClient.)
SaveReport | Saves the report to cloud storage. (Overrides CloudStorageClient..::.SaveReport(Report, ExportBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


GetAccessToken Method

[image]

FastReport.Net Class Reference
SkyDriveStorageClient..::.GetAccessToken Method
SkyDriveStorageClient Class See Also Send Feedback
Gets the access token.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetAccessToken()
Visual Basic (Declaration)
Public Function GetAccessToken As String
Visual C++
public:
String^ GetAccessToken()

Return Value

The access token value.

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


GetAuthorizationUrl Method

[image]

FastReport.Net Class Reference
SkyDriveStorageClient..::.GetAuthorizationUrl Method
SkyDriveStorageClient Class See Also Send Feedback
Gets the authorization URL.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetAuthorizationUrl()
Visual Basic (Declaration)
Public Function GetAuthorizationUrl As String
Visual C++
public:
String^ GetAuthorizationUrl()

Return Value

The authorization URL string.

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SaveReport Method

[image]

FastReport.Net Class Reference
SkyDriveStorageClient..::.SaveReport Method
SkyDriveStorageClient Class See Also Send Feedback
Saves the report to cloud storage.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool SaveReport(
    Report report,
    ExportBase export
)
Visual Basic (Declaration)
Public Overrides Function SaveReport ( _
    report As Report, _
    export As ExportBase _
) As Boolean
Visual C++
public:
virtual bool SaveReport(
    Report^ report,
    ExportBase^ export
) override

Parameters

report
Type: FastReport..::.Report
The report template that should be saved.
export
Type: FastReport.Export..::.ExportBase
The export filter that should export template before.

Return Value

True if report has been successfully saved.

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClient Properties

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClient Properties
SkyDriveStorageClient Class See Also Send Feedback

The SkyDriveStorageClient type exposes the following members.

Properties

Name | Description
AccessToken | Gets or sets the access token.
AuthCode | Gets or sets the authorization code.
ClientInfo | Gets or sets the client info.
Filename | Gets or sets the filename. (Inherited from CloudStorageClient.)
IsUserAuthorized | Gets or set the information is user authorized or not. (Inherited from CloudStorageClient.)
ProxySettings | Gets or sets the proxy settings of a client. (Inherited from CloudStorageClient.)

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


AccessToken Property

[image]

FastReport.Net Class Reference
SkyDriveStorageClient..::.AccessToken Property
SkyDriveStorageClient Class See Also Send Feedback
Gets or sets the access token.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AccessToken { get; set; }
Visual Basic (Declaration)
Public Property AccessToken As String
Visual C++
public:
property String^ AccessToken {
    String^ get ();
    void set (String^ value);
}

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


AuthCode Property

[image]

FastReport.Net Class Reference
SkyDriveStorageClient..::.AuthCode Property
SkyDriveStorageClient Class See Also Send Feedback
Gets or sets the authorization code.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AuthCode { get; set; }
Visual Basic (Declaration)
Public Property AuthCode As String
Visual C++
public:
property String^ AuthCode {
    String^ get ();
    void set (String^ value);
}

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


ClientInfo Property

[image]

FastReport.Net Class Reference
SkyDriveStorageClient..::.ClientInfo Property
SkyDriveStorageClient Class See Also Send Feedback
Gets or sets the client info.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ClientInfo ClientInfo { get; set; }
Visual Basic (Declaration)
Public Property ClientInfo As ClientInfo
Visual C++
public:
property ClientInfo^ ClientInfo {
    ClientInfo^ get ();
    void set (ClientInfo^ value);
}

See Also

SkyDriveStorageClient Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Class

[image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Class
Members See Also Send Feedback
Represents form of SkyDrive storage client.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SkyDriveStorageClientForm : BaseDialogForm
Visual Basic (Declaration)
Public Class SkyDriveStorageClientForm _
    Inherits BaseDialogForm
Visual C++
public ref class SkyDriveStorageClientForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.SkyDrive..::.SkyDriveStorageClientForm

See Also

SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Members

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Members
SkyDriveStorageClientForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The SkyDriveStorageClientForm type exposes the following members.

Constructors

Name | Description
SkyDriveStorageClientForm | Initializes a new instance of the SkyDriveStorageClientForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Constructor

[image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Constructor
SkyDriveStorageClientForm Class See Also Send Feedback
Initializes a new instance of the SkyDriveStorageClientForm class.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SkyDriveStorageClientForm(
    ClientInfo clientInfo,
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    clientInfo As ClientInfo, _
    report As Report _
)
Visual C++
public:
SkyDriveStorageClientForm(
    ClientInfo^ clientInfo,
    Report^ report
)

Parameters

clientInfo
Type: FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfo
The SkyDrive client info.
report
Type: FastReport..::.Report
The report template.

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Fields

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Fields
SkyDriveStorageClientForm Class See Also Send Feedback

The SkyDriveStorageClientForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Methods

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Methods
SkyDriveStorageClientForm Class See Also Send Feedback

The SkyDriveStorageClientForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.AccessibilityNotifyClients Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.BeginInvoke Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Dispose Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Dispose Method (Boolean)
SkyDriveStorageClientForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SkyDriveStorageClientForm Class
Dispose Overload
FastReport.Cloud.StorageClient.SkyDrive Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.GetChildAtPoint Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Invalidate Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Invoke Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Localize Method

[image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Localize Method
SkyDriveStorageClientForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.MemberwiseClone Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.PerformLayout Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.ResumeLayout Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.RtlTranslateAlignment Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Scale Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Select Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.SetBounds Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Show Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.ShowDialog Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.UpdateBounds Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.Validate Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm..::.ValidateChildren Method
SkyDriveStorageClientForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SkyDriveStorageClientForm Class
SkyDriveStorageClientForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Properties

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Properties
SkyDriveStorageClientForm Class See Also Send Feedback

The SkyDriveStorageClientForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


SkyDriveStorageClientForm Events

[image] [image]

FastReport.Net Class Reference
SkyDriveStorageClientForm Events
SkyDriveStorageClientForm Class See Also Send Feedback

The SkyDriveStorageClientForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SkyDriveStorageClientForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Class

[image]

FastReport.Net Class Reference
WebBrowserForm Class
Members See Also Send Feedback
Represents form of the web browser.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class WebBrowserForm : BaseDialogForm
Visual Basic (Declaration)
Public Class WebBrowserForm _
    Inherits BaseDialogForm
Visual C++
public ref class WebBrowserForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient.SkyDrive..::.WebBrowserForm

See Also

WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Members

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Members
WebBrowserForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The WebBrowserForm type exposes the following members.

Constructors

Name | Description
WebBrowserForm | Initializes a new instance of the Control class with specific text.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AuthCode | Gets obtained authorization code.
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Constructor

[image]

FastReport.Net Class Reference
WebBrowserForm Constructor
WebBrowserForm Class See Also Send Feedback
Initializes a new instance of the Control class with specific text.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WebBrowserForm(
    string url
)
Visual Basic (Declaration)
Public Sub New ( _
    url As String _
)
Visual C++
public:
WebBrowserForm(
    String^ url
)

Parameters

url
Type: System..::.String

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Fields

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Fields
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Methods

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Methods
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.AccessibilityNotifyClients Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.BeginInvoke Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Dispose Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
WebBrowserForm..::.Dispose Method (Boolean)
WebBrowserForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

WebBrowserForm Class
Dispose Overload
FastReport.Cloud.StorageClient.SkyDrive Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.GetChildAtPoint Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Invalidate Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Invoke Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.MemberwiseClone Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.PerformLayout Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ResumeLayout Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.RtlTranslateAlignment Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Scale Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Select Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.SetBounds Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Show Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ShowDialog Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.UpdateBounds Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.Validate Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
WebBrowserForm..::.ValidateChildren Method
WebBrowserForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

WebBrowserForm Class
WebBrowserForm Members
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Properties

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Properties
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AuthCode | Gets obtained authorization code.
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


AuthCode Property

[image]

FastReport.Net Class Reference
WebBrowserForm..::.AuthCode Property
WebBrowserForm Class See Also Send Feedback
Gets obtained authorization code.

Namespace: FastReport.Cloud.StorageClient.SkyDrive
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AuthCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property AuthCode As String
Visual C++
public:
property String^ AuthCode {
    String^ get ();
}

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


WebBrowserForm Events

[image] [image]

FastReport.Net Class Reference
WebBrowserForm Events
WebBrowserForm Class See Also Send Feedback

The WebBrowserForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WebBrowserForm Class
FastReport.Cloud.StorageClient.SkyDrive Namespace


FastReport.Code Namespace

[image]

FastReport.Net Class Reference
FastReport.Code Namespace
Send Feedback

Classes

Class | Description
CodeUtils | This static class contains methods that may be used to find expressions embedded in the object's text.
FindTextArgs | This class is used to pass find arguments to some methods of the CodeUtils class.


CodeUtils Class

[image]

FastReport.Net Class Reference
CodeUtils Class
Members See Also Send Feedback
This static class contains methods that may be used to find expressions embedded in the object's text.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class CodeUtils
Visual Basic (Declaration)
Public NotInheritable Class CodeUtils
Visual C++
public ref class CodeUtils abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Code..::.CodeUtils

See Also

CodeUtils Members
FastReport.Code Namespace


CodeUtils Members

[image] [image]

FastReport.Net Class Reference
CodeUtils Members
CodeUtils Class Methods See Also Send Feedback

The CodeUtils type exposes the following members.

Methods

Name | Description
GetExpression | Gets first expression found in the text.
GetExpressions | Returns expressions found in the text.

See Also

CodeUtils Class
FastReport.Code Namespace


CodeUtils Methods

[image] [image]

FastReport.Net Class Reference
CodeUtils Methods
CodeUtils Class See Also Send Feedback

The CodeUtils type exposes the following members.

Methods

Name | Description
GetExpression | Gets first expression found in the text.
GetExpressions | Returns expressions found in the text.

See Also

CodeUtils Class
FastReport.Code Namespace


GetExpression Method

[image]

FastReport.Net Class Reference
CodeUtils..::.GetExpression Method
CodeUtils Class See Also Send Feedback
Gets first expression found in the text.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string GetExpression(
    FindTextArgs args,
    bool skipStrings
)
Visual Basic (Declaration)
Public Shared Function GetExpression ( _
    args As FindTextArgs, _
    skipStrings As Boolean _
) As String
Visual C++
public:
static String^ GetExpression(
    FindTextArgs^ args,
    bool skipStrings
)

Parameters

args
Type: FastReport.Code..::.FindTextArgs
Object with find arguments.
skipStrings
Type: System..::.Boolean
Indicates whether to skip strings.

Return Value

The expression if found; otherwise, returns an empty string.

See Also

CodeUtils Class
FastReport.Code Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
CodeUtils..::.GetExpressions Method
CodeUtils Class See Also Send Feedback
Returns expressions found in the text.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string[] GetExpressions(
    string text,
    string openBracket,
    string closeBracket
)
Visual Basic (Declaration)
Public Shared Function GetExpressions ( _
    text As String, _
    openBracket As String, _
    closeBracket As String _
) As String()
Visual C++
public:
static array<String^>^ GetExpressions(
    String^ text,
    String^ openBracket,
    String^ closeBracket
)

Parameters

text
Type: System..::.String
Text that may contain expressions.
openBracket
Type: System..::.String
The char sequence used to find the start of expression.
closeBracket
Type: System..::.String
The char sequence used to find the end of expression.

Return Value

Array of expressions if found; otherwise return an empty array.

See Also

CodeUtils Class
FastReport.Code Namespace


FindTextArgs Class

[image]

FastReport.Net Class Reference
FindTextArgs Class
Members See Also Send Feedback
This class is used to pass find arguments to some methods of the CodeUtils class.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FindTextArgs
Visual Basic (Declaration)
Public Class FindTextArgs
Visual C++
public ref class FindTextArgs

Inheritance Hierarchy

System..::.Object
FastReport.Code..::.FindTextArgs

See Also

FindTextArgs Members
FastReport.Code Namespace


FindTextArgs Members

[image] [image]

FastReport.Net Class Reference
FindTextArgs Members
FindTextArgs Class Constructors Methods Fields See Also Send Feedback

The FindTextArgs type exposes the following members.

Constructors

Name | Description
FindTextArgs | Initializes a new instance of the FindTextArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CloseBracket | The char sequence used to find the expression's end.
EndIndex | After the search, this property points to the end of an expression.
FoundText | The last found expression.
OpenBracket | The char sequence used to find the expression's begin.
StartIndex | The start position of the search. After the search, this property points to the begin of an expression.
Text | The text with embedded expressions.

See Also

FindTextArgs Class
FastReport.Code Namespace


FindTextArgs Constructor

[image]

FastReport.Net Class Reference
FindTextArgs Constructor
FindTextArgs Class See Also Send Feedback
Initializes a new instance of the FindTextArgs class

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FindTextArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FindTextArgs()

See Also

FindTextArgs Class
FastReport.Code Namespace


FindTextArgs Fields

[image] [image]

FastReport.Net Class Reference
FindTextArgs Fields
FindTextArgs Class See Also Send Feedback

The FindTextArgs type exposes the following members.

Fields

Name | Description
CloseBracket | The char sequence used to find the expression's end.
EndIndex | After the search, this property points to the end of an expression.
FoundText | The last found expression.
OpenBracket | The char sequence used to find the expression's begin.
StartIndex | The start position of the search. After the search, this property points to the begin of an expression.
Text | The text with embedded expressions.

See Also

FindTextArgs Class
FastReport.Code Namespace


CloseBracket Field

[image]

FastReport.Net Class Reference
FindTextArgs..::.CloseBracket Field
FindTextArgs Class See Also Send Feedback
The char sequence used to find the expression's end.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CloseBracket
Visual Basic (Declaration)
Public CloseBracket As String
Visual C++
public:
String^ CloseBracket

See Also

FindTextArgs Class
FastReport.Code Namespace


EndIndex Field

[image]

FastReport.Net Class Reference
FindTextArgs..::.EndIndex Field
FindTextArgs Class See Also Send Feedback
After the search, this property points to the end of an expression.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int EndIndex
Visual Basic (Declaration)
Public EndIndex As Integer
Visual C++
public:
int EndIndex

See Also

FindTextArgs Class
FastReport.Code Namespace


FoundText Field

[image]

FastReport.Net Class Reference
FindTextArgs..::.FoundText Field
FindTextArgs Class See Also Send Feedback
The last found expression.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FoundText
Visual Basic (Declaration)
Public FoundText As String
Visual C++
public:
String^ FoundText

See Also

FindTextArgs Class
FastReport.Code Namespace


OpenBracket Field

[image]

FastReport.Net Class Reference
FindTextArgs..::.OpenBracket Field
FindTextArgs Class See Also Send Feedback
The char sequence used to find the expression's begin.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string OpenBracket
Visual Basic (Declaration)
Public OpenBracket As String
Visual C++
public:
String^ OpenBracket

See Also

FindTextArgs Class
FastReport.Code Namespace


StartIndex Field

[image]

FastReport.Net Class Reference
FindTextArgs..::.StartIndex Field
FindTextArgs Class See Also Send Feedback
The start position of the search. After the search, this property points to the begin of an expression.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int StartIndex
Visual Basic (Declaration)
Public StartIndex As Integer
Visual C++
public:
int StartIndex

See Also

FindTextArgs Class
FastReport.Code Namespace


Text Field

[image]

FastReport.Net Class Reference
FindTextArgs..::.Text Field
FindTextArgs Class See Also Send Feedback
The text with embedded expressions.

Namespace: FastReport.Code
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text
Visual Basic (Declaration)
Public Text As String
Visual C++
public:
String^ Text

See Also

FindTextArgs Class
FastReport.Code Namespace


FindTextArgs Methods

[image] [image]

FastReport.Net Class Reference
FindTextArgs Methods
FindTextArgs Class See Also Send Feedback

The FindTextArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindTextArgs Class
FastReport.Code Namespace


FastReport.Controls Namespace

[image]

FastReport.Net Class Reference
FastReport.Controls Namespace
Send Feedback

Classes

Class | Description
ColorComboBox | Represents a combobox that allows to choose a color.
ColorDropDown | Represents a drop-down control that allows to choose a color.
ColorPopup | Represents a popup window that alows to choose a color.
DataColumnComboBox | Represents the combobox used to select a data column.
DataTreeView | This is an internal control that represents the data tree.
LabelLine | Represents the label with line.
PageControl | Represents a control that may contain several pages. It is similar to the TabControl but contains no tabs. This control is widely used in wizards.
PageControlPage | This class represents a single page of the PageControl control.
PopupWindow | Represents a popup form.
TextBoxButton | Represents the control that combines a textbox and a button.

Enumerations

Enumeration | Description
DataTreeSelectedItemType | This is an internal enum that represents the selected datatree item type.


ColorComboBox Class

[image]

FastReport.Net Class Reference
ColorComboBox Class
Members See Also Send Feedback
Represents a combobox that allows to choose a color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorComboBox : UserControl
Visual Basic (Declaration)
Public Class ColorComboBox _
    Inherits UserControl
Visual C++
public ref class ColorComboBox : public UserControl

Remarks

This control may be useful if you write own components for FastReport.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Controls..::.ColorComboBox

See Also

ColorComboBox Members
FastReport.Controls Namespace


ColorComboBox Members

[image] [image]

FastReport.Net Class Reference
ColorComboBox Members
ColorComboBox Class Constructors Methods Properties Events See Also Send Feedback

The ColorComboBox type exposes the following members.

Constructors

Name | Description
ColorComboBox | Initializes a new instance of the ColorComboBox class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Overrides Control..::.SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified).)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Color | Gets or sets the selected color.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowColorName | Gets or sets value indicating whether it is necessary to show a color name in a combobox.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ColorSelected | This event is raised when you select a color.
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorComboBox Class
FastReport.Controls Namespace


ColorComboBox Constructor

[image]

FastReport.Net Class Reference
ColorComboBox Constructor
ColorComboBox Class See Also Send Feedback
Initializes a new instance of the ColorComboBox class with default settings.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorComboBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorComboBox()

See Also

ColorComboBox Class
FastReport.Controls Namespace


ColorComboBox Methods

[image] [image]

FastReport.Net Class Reference
ColorComboBox Methods
ColorComboBox Class See Also Send Feedback

The ColorComboBox type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Overrides Control..::.SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified).)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ColorComboBox Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.AccessibilityNotifyClients Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.BeginInvoke Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.Dispose Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.GetChildAtPoint Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.Invalidate Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.Invoke Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.MemberwiseClone Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


OnMouseUp Method

[image]

FastReport.Net Class Reference
ColorComboBox..::.OnMouseUp Method
ColorComboBox Class See Also Send Feedback
Raises the MouseUp event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

ColorComboBox Class
FastReport.Controls Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
ColorComboBox..::.OnPaint Method
ColorComboBox Class See Also Send Feedback
Raises the Paint event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

ColorComboBox Class
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.PerformLayout Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.ResumeLayout Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.RtlTranslateAlignment Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.Scale Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.Select Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.SetBounds Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


SetBoundsCore Method

[image]

FastReport.Net Class Reference
ColorComboBox..::.SetBoundsCore Method
ColorComboBox Class See Also Send Feedback
Performs the work of setting the specified bounds of this control.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void SetBoundsCore(
    int x,
    int y,
    int width,
    int height,
    BoundsSpecified specified
)
Visual Basic (Declaration)
Protected Overrides Sub SetBoundsCore ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer, _
    specified As BoundsSpecified _
)
Visual C++
protected:
virtual void SetBoundsCore(
    int x,
    int y,
    int width,
    int height,
    BoundsSpecified specified
) override

Parameters

x
Type: System..::.Int32
The new Left property value of the control.
y
Type: System..::.Int32
The new Top property value of the control.
width
Type: System..::.Int32
The new Width property value of the control.
height
Type: System..::.Int32
The new Height property value of the control.
specified
Type: System.Windows.Forms..::.BoundsSpecified
A bitwise combination of the BoundsSpecified values.

See Also

ColorComboBox Class
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.UpdateBounds Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.Validate Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ColorComboBox..::.ValidateChildren Method
ColorComboBox Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ColorComboBox Class
ColorComboBox Members
FastReport.Controls Namespace


ColorComboBox Properties

[image] [image]

FastReport.Net Class Reference
ColorComboBox Properties
ColorComboBox Class See Also Send Feedback

The ColorComboBox type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Color | Gets or sets the selected color.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowColorName | Gets or sets value indicating whether it is necessary to show a color name in a combobox.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ColorComboBox Class
FastReport.Controls Namespace


Color Property

[image]

FastReport.Net Class Reference
ColorComboBox..::.Color Property
ColorComboBox Class See Also Send Feedback
Gets or sets the selected color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ColorComboBox Class
FastReport.Controls Namespace


ShowColorName Property

[image]

FastReport.Net Class Reference
ColorComboBox..::.ShowColorName Property
ColorComboBox Class See Also Send Feedback
Gets or sets value indicating whether it is necessary to show a color name in a combobox.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowColorName { get; set; }
Visual Basic (Declaration)
Public Property ShowColorName As Boolean
Visual C++
public:
property bool ShowColorName {
    bool get ();
    void set (bool value);
}

See Also

ColorComboBox Class
FastReport.Controls Namespace


ColorComboBox Events

[image] [image]

FastReport.Net Class Reference
ColorComboBox Events
ColorComboBox Class See Also Send Feedback

The ColorComboBox type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ColorSelected | This event is raised when you select a color.
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorComboBox Class
FastReport.Controls Namespace


ColorSelected Event

[image]

FastReport.Net Class Reference
ColorComboBox..::.ColorSelected Event
ColorComboBox Class See Also Send Feedback
This event is raised when you select a color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ColorSelected
Visual Basic (Declaration)
Public Event ColorSelected As EventHandler
Visual C++
public:
 event EventHandler^ ColorSelected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ColorComboBox Class
FastReport.Controls Namespace


ColorDropDown Class

[image]

FastReport.Net Class Reference
ColorDropDown Class
Members See Also Send Feedback
Represents a drop-down control that allows to choose a color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorDropDown : ToolStripDropDown
Visual Basic (Declaration)
Public Class ColorDropDown _
    Inherits ToolStripDropDown
Visual C++
public ref class ColorDropDown : public ToolStripDropDown

Remarks

This control may be useful if you write own components for FastReport.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ToolStrip
System.Windows.Forms..::.ToolStripDropDown
FastReport.Controls..::.ColorDropDown

See Also

ColorDropDown Members
FastReport.Controls Namespace


ColorDropDown Members

[image] [image]

FastReport.Net Class Reference
ColorDropDown Members
ColorDropDown Class Constructors Methods Properties Events See Also Send Feedback

The ColorDropDown type exposes the following members.

Constructors

Name | Description
ColorDropDown | Initializes a new instance of the ColorDropDown class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Close | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the ToolStripDropDown. (Inherited from ToolStripDropDown.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from ToolStrip.)
CreateDefaultItem | Creates a default ToolStripItem with the specified text, image, and event handler on a new ToolStrip instance. (Inherited from ToolStrip.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from ToolStripDropDown.)
CreateLayoutSettings | Applies various layout options to the ToolStripDropDown. (Inherited from ToolStripDropDown.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemAt | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines whether a character is an input character that the item recognizes. (Inherited from ToolStrip.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from ToolStrip.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeginDrag | Raises the BeginDrag event. (Inherited from ToolStrip.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from ToolStripDropDown.)
OnClosing | Raises the Closing event. (Inherited from ToolStripDropDown.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from ToolStrip.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the Enabled event. (Inherited from ToolStrip.)
OnEndDrag | Raises the EndDrag event. (Inherited from ToolStrip.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from ToolStrip.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from ToolStripDropDown.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from ToolStrip.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | (Inherited from ToolStrip.)
OnItemAdded | Raises the ItemAdded event. (Inherited from ToolStrip.)
OnItemClicked | Raises the ItemClicked event. (Inherited from ToolStripDropDown.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from ToolStrip.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from ToolStripDropDown.)
OnLayoutCompleted | Raises the LayoutCompleted event. (Inherited from ToolStrip.)
OnLayoutStyleChanged | Raises the LayoutStyleChanged event. (Inherited from ToolStrip.)
OnLeave | Raises the Leave event. (Inherited from ToolStrip.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from ToolStrip.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | (Inherited from ToolStrip.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from ToolStrip.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from ToolStrip.)
OnMouseMove | Raises the MouseMove event. (Inherited from ToolStrip.)
OnMouseUp | Raises the MouseUp event. (Inherited from ToolStripDropDown.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnOpened | Raises the Opened event. (Inherited from ToolStripDropDown.)
OnOpening | Raises the Opening event. (Inherited from ToolStripDropDown.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from ToolStrip.)
OnPaintBackground | Raises the Paint event for the ToolStrip background. (Inherited from ToolStrip.)
OnPaintGrip | Raises the PaintGrip event. (Inherited from ToolStrip.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from ToolStripDropDown.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnRendererChanged | Raises the RendererChanged event. (Inherited from ToolStrip.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ToolStrip.)
OnScroll | (Inherited from ToolStrip.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from ToolStrip.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from ToolStripDropDown.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ToolStrip.)
ProcessDialogChar | Processes a dialog box character. (Inherited from ToolStripDropDown.)
ProcessDialogKey | Processes a dialog box key. (Inherited from ToolStripDropDown.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from ToolStripDropDown.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreFocus | Controls the return location of the focus. (Inherited from ToolStrip.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ToolStripDropDown.)
ScaleCore | This method is not relevant to this class. (Inherited from ToolStripDropDown.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from ToolStripDropDown.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayedItems | Resets the collection of displayed and overflow items after a layout is done. (Inherited from ToolStrip.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetItemLocation | Anchors a ToolStripItem to a particular place on a ToolStrip. (Inherited from ToolStrip.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Adjusts the size of the owner ToolStrip to accommodate the ToolStripDropDown if the owner ToolStrip is currently displayed, or clears and resets active ToolStripDropDown child controls of the ToolStrip if the ToolStrip is not currently displayed. (Inherited from ToolStripDropDown.)
Show | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from ToolStrip.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from ToolStripDropDown.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Color | Gets or sets the selected color.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Gets parameters of a new window. (Inherited from ToolStripDropDown.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultDock | (Inherited from ToolStripDropDown.)
DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
DefaultGripMargin | Gets the default spacing, in pixels, between the sizing grip and the edges of the ToolStrip. (Inherited from ToolStrip.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the spacing, in pixels, between the ToolStrip and the ToolStripContainer. (Inherited from ToolStrip.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | (Inherited from ToolStripDropDown.)
DefaultShowItemToolTips | (Inherited from ToolStripDropDown.)
DefaultSize | Gets the default size of the ToolStrip. (Inherited from ToolStrip.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayedItems | Gets the subset of items that are currently displayed on the ToolStrip, including items that are automatically added into the ToolStrip. (Inherited from ToolStrip.)
DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MaxItemSize | Gets the maximum height and width, in pixels, of the ToolStripDropDown. (Inherited from ToolStripDropDown.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
RenderMode | Gets or sets the painting styles to be applied to the ToolStrip. (Inherited from ToolStrip.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from ToolStripDropDown.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from ToolStripDropDown.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
ColorSelected | This event is raised when you select a color.
ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorDropDown Class
FastReport.Controls Namespace


ColorDropDown Constructor

[image]

FastReport.Net Class Reference
ColorDropDown Constructor
ColorDropDown Class See Also Send Feedback
Initializes a new instance of the ColorDropDown class with default settings.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorDropDown()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorDropDown()

See Also

ColorDropDown Class
FastReport.Controls Namespace


ColorDropDown Methods

[image] [image]

FastReport.Net Class Reference
ColorDropDown Methods
ColorDropDown Class See Also Send Feedback

The ColorDropDown type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Close | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the ToolStripDropDown. (Inherited from ToolStripDropDown.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from ToolStrip.)
CreateDefaultItem | Creates a default ToolStripItem with the specified text, image, and event handler on a new ToolStrip instance. (Inherited from ToolStrip.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from ToolStripDropDown.)
CreateLayoutSettings | Applies various layout options to the ToolStripDropDown. (Inherited from ToolStripDropDown.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemAt | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines whether a character is an input character that the item recognizes. (Inherited from ToolStrip.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from ToolStrip.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeginDrag | Raises the BeginDrag event. (Inherited from ToolStrip.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from ToolStripDropDown.)
OnClosing | Raises the Closing event. (Inherited from ToolStripDropDown.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from ToolStrip.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the Enabled event. (Inherited from ToolStrip.)
OnEndDrag | Raises the EndDrag event. (Inherited from ToolStrip.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from ToolStrip.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from ToolStripDropDown.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from ToolStrip.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | (Inherited from ToolStrip.)
OnItemAdded | Raises the ItemAdded event. (Inherited from ToolStrip.)
OnItemClicked | Raises the ItemClicked event. (Inherited from ToolStripDropDown.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from ToolStrip.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from ToolStripDropDown.)
OnLayoutCompleted | Raises the LayoutCompleted event. (Inherited from ToolStrip.)
OnLayoutStyleChanged | Raises the LayoutStyleChanged event. (Inherited from ToolStrip.)
OnLeave | Raises the Leave event. (Inherited from ToolStrip.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from ToolStrip.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | (Inherited from ToolStrip.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from ToolStrip.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from ToolStrip.)
OnMouseMove | Raises the MouseMove event. (Inherited from ToolStrip.)
OnMouseUp | Raises the MouseUp event. (Inherited from ToolStripDropDown.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnOpened | Raises the Opened event. (Inherited from ToolStripDropDown.)
OnOpening | Raises the Opening event. (Inherited from ToolStripDropDown.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from ToolStrip.)
OnPaintBackground | Raises the Paint event for the ToolStrip background. (Inherited from ToolStrip.)
OnPaintGrip | Raises the PaintGrip event. (Inherited from ToolStrip.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from ToolStripDropDown.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnRendererChanged | Raises the RendererChanged event. (Inherited from ToolStrip.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ToolStrip.)
OnScroll | (Inherited from ToolStrip.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from ToolStrip.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from ToolStripDropDown.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ToolStrip.)
ProcessDialogChar | Processes a dialog box character. (Inherited from ToolStripDropDown.)
ProcessDialogKey | Processes a dialog box key. (Inherited from ToolStripDropDown.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from ToolStripDropDown.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreFocus | Controls the return location of the focus. (Inherited from ToolStrip.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ToolStripDropDown.)
ScaleCore | This method is not relevant to this class. (Inherited from ToolStripDropDown.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from ToolStripDropDown.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayedItems | Resets the collection of displayed and overflow items after a layout is done. (Inherited from ToolStrip.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetItemLocation | Anchors a ToolStripItem to a particular place on a ToolStrip. (Inherited from ToolStrip.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Adjusts the size of the owner ToolStrip to accommodate the ToolStripDropDown if the owner ToolStrip is currently displayed, or clears and resets active ToolStripDropDown child controls of the ToolStrip if the ToolStrip is not currently displayed. (Inherited from ToolStripDropDown.)
Show | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from ToolStrip.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from ToolStripDropDown.)

See Also

ColorDropDown Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.AccessibilityNotifyClients Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.BeginInvoke Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Close Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Close Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Close()()() | Closes the ToolStripDropDown control. (Inherited from ToolStripDropDown.)
Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Dispose Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the ToolStripDropDown and optionally releases the managed resources. (Inherited from ToolStripDropDown.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.GetChildAtPoint Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


GetItemAt Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.GetItemAt Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Invalidate Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Invoke Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.MemberwiseClone Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.PerformLayout Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.ResumeLayout Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.RtlTranslateAlignment Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Scale Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Select Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from ToolStrip.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.SetBounds Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.Show Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ColorDropDown..::.UpdateBounds Method
ColorDropDown Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ColorDropDown Class
ColorDropDown Members
FastReport.Controls Namespace


ColorDropDown Properties

[image] [image]

FastReport.Net Class Reference
ColorDropDown Properties
ColorDropDown Class See Also Send Feedback

The ColorDropDown type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Color | Gets or sets the selected color.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Gets parameters of a new window. (Inherited from ToolStripDropDown.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultDock | (Inherited from ToolStripDropDown.)
DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
DefaultGripMargin | Gets the default spacing, in pixels, between the sizing grip and the edges of the ToolStrip. (Inherited from ToolStrip.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the spacing, in pixels, between the ToolStrip and the ToolStripContainer. (Inherited from ToolStrip.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | (Inherited from ToolStripDropDown.)
DefaultShowItemToolTips | (Inherited from ToolStripDropDown.)
DefaultSize | Gets the default size of the ToolStrip. (Inherited from ToolStrip.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayedItems | Gets the subset of items that are currently displayed on the ToolStrip, including items that are automatically added into the ToolStrip. (Inherited from ToolStrip.)
DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MaxItemSize | Gets the maximum height and width, in pixels, of the ToolStripDropDown. (Inherited from ToolStripDropDown.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
RenderMode | Gets or sets the painting styles to be applied to the ToolStrip. (Inherited from ToolStrip.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from ToolStripDropDown.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from ToolStripDropDown.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ColorDropDown Class
FastReport.Controls Namespace


Color Property

[image]

FastReport.Net Class Reference
ColorDropDown..::.Color Property
ColorDropDown Class See Also Send Feedback
Gets or sets the selected color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ColorDropDown Class
FastReport.Controls Namespace


ColorDropDown Events

[image] [image]

FastReport.Net Class Reference
ColorDropDown Events
ColorDropDown Class See Also Send Feedback

The ColorDropDown type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
ColorSelected | This event is raised when you select a color.
ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorDropDown Class
FastReport.Controls Namespace


ColorSelected Event

[image]

FastReport.Net Class Reference
ColorDropDown..::.ColorSelected Event
ColorDropDown Class See Also Send Feedback
This event is raised when you select a color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ColorSelected
Visual Basic (Declaration)
Public Event ColorSelected As EventHandler
Visual C++
public:
 event EventHandler^ ColorSelected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ColorDropDown Class
FastReport.Controls Namespace


ColorPopup Class

[image]

FastReport.Net Class Reference
ColorPopup Class
Members See Also Send Feedback
Represents a popup window that alows to choose a color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorPopup : PopupWindow
Visual Basic (Declaration)
Public Class ColorPopup _
    Inherits PopupWindow
Visual C++
public ref class ColorPopup : public PopupWindow

Remarks

This control may be useful if you write own components for FastReport.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Controls..::.PopupWindow
FastReport.Controls..::.ColorPopup

See Also

ColorPopup Members
FastReport.Controls Namespace


ColorPopup Members

[image] [image]

FastReport.Net Class Reference
ColorPopup Members
ColorPopup Class Constructors Methods Properties Events See Also Send Feedback

The ColorPopup type exposes the following members.

Constructors

Name | Description
ColorPopup | Initializes a new instance of the ColorPopup class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Color | Gets or sets the selected color.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ColorSelected | This event is raised when you select a color.
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorPopup Class
FastReport.Controls Namespace


ColorPopup Constructor

[image]

FastReport.Net Class Reference
ColorPopup Constructor
ColorPopup Class See Also Send Feedback
Initializes a new instance of the ColorPopup class with default settings.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorPopup(
    Form ownerForm
)
Visual Basic (Declaration)
Public Sub New ( _
    ownerForm As Form _
)
Visual C++
public:
ColorPopup(
    Form^ ownerForm
)

Parameters

ownerForm
Type: System.Windows.Forms..::.Form
The main form that owns this popup control.

See Also

ColorPopup Class
FastReport.Controls Namespace


ColorPopup Methods

[image] [image]

FastReport.Net Class Reference
ColorPopup Methods
ColorPopup Class See Also Send Feedback

The ColorPopup type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ColorPopup Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.AccessibilityNotifyClients Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.BeginInvoke Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Dispose Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.GetChildAtPoint Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Invalidate Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Invoke Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.MemberwiseClone Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.PerformLayout Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.ResumeLayout Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.RtlTranslateAlignment Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Scale Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Select Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.SetBounds Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Show Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(Point) | Shows the form. (Inherited from PopupWindow.)
Show(Control, Point) | Shows the form. (Inherited from PopupWindow.)
Show(Control, Int32, Int32) | Shows the form. (Inherited from PopupWindow.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.ShowDialog Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.UpdateBounds Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.Validate Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ColorPopup..::.ValidateChildren Method
ColorPopup Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ColorPopup Class
ColorPopup Members
FastReport.Controls Namespace


ColorPopup Properties

[image] [image]

FastReport.Net Class Reference
ColorPopup Properties
ColorPopup Class See Also Send Feedback

The ColorPopup type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Color | Gets or sets the selected color.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ColorPopup Class
FastReport.Controls Namespace


Color Property

[image]

FastReport.Net Class Reference
ColorPopup..::.Color Property
ColorPopup Class See Also Send Feedback
Gets or sets the selected color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ColorPopup Class
FastReport.Controls Namespace


ColorPopup Events

[image] [image]

FastReport.Net Class Reference
ColorPopup Events
ColorPopup Class See Also Send Feedback

The ColorPopup type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ColorSelected | This event is raised when you select a color.
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorPopup Class
FastReport.Controls Namespace


ColorSelected Event

[image]

FastReport.Net Class Reference
ColorPopup..::.ColorSelected Event
ColorPopup Class See Also Send Feedback
This event is raised when you select a color.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ColorSelected
Visual Basic (Declaration)
Public Event ColorSelected As EventHandler
Visual C++
public:
 event EventHandler^ ColorSelected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ColorPopup Class
FastReport.Controls Namespace


DataColumnComboBox Class

[image]

FastReport.Net Class Reference
DataColumnComboBox Class
Members See Also Send Feedback
Represents the combobox used to select a data column.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataColumnComboBox : UserControl
Visual Basic (Declaration)
Public Class DataColumnComboBox _
    Inherits UserControl
Visual C++
public ref class DataColumnComboBox : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Controls..::.DataColumnComboBox

See Also

DataColumnComboBox Members
FastReport.Controls Namespace


DataColumnComboBox Members

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox Members
DataColumnComboBox Class Constructors Methods Properties Events See Also Send Feedback

The DataColumnComboBox type exposes the following members.

Constructors

Name | Description
DataColumnComboBox | Initializes a new instance of the DataColumnComboBox class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Overrides ContainerControl..::.OnLayout(LayoutEventArgs).)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Overrides Control..::.SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified).)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | Gets or sets the data source.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the Report.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Overrides UserControl..::.Text.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the text portion of the combobox is changed.
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


DataColumnComboBox Constructor

[image]

FastReport.Net Class Reference
DataColumnComboBox Constructor
DataColumnComboBox Class See Also Send Feedback
Initializes a new instance of the DataColumnComboBox class.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataColumnComboBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataColumnComboBox()

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


DataColumnComboBox Methods

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox Methods
DataColumnComboBox Class See Also Send Feedback

The DataColumnComboBox type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Overrides ContainerControl..::.OnLayout(LayoutEventArgs).)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Overrides Control..::.SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified).)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.AccessibilityNotifyClients Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.BeginInvoke Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.Dispose Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.Dispose Method (Boolean)
DataColumnComboBox Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

DataColumnComboBox Class
Dispose Overload
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.GetChildAtPoint Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.Invalidate Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.Invoke Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.MemberwiseClone Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


OnLayout Method

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.OnLayout Method
DataColumnComboBox Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLayout ( _
    e As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.LayoutEventArgs

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.OnPaint Method
DataColumnComboBox Class See Also Send Feedback
Raises the Paint event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.PerformLayout Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.ResumeLayout Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.RtlTranslateAlignment Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.Scale Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.Select Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.SetBounds Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


SetBoundsCore Method

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.SetBoundsCore Method
DataColumnComboBox Class See Also Send Feedback
Performs the work of setting the specified bounds of this control.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void SetBoundsCore(
    int x,
    int y,
    int width,
    int height,
    BoundsSpecified specified
)
Visual Basic (Declaration)
Protected Overrides Sub SetBoundsCore ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer, _
    specified As BoundsSpecified _
)
Visual C++
protected:
virtual void SetBoundsCore(
    int x,
    int y,
    int width,
    int height,
    BoundsSpecified specified
) override

Parameters

x
Type: System..::.Int32
The new Left property value of the control.
y
Type: System..::.Int32
The new Top property value of the control.
width
Type: System..::.Int32
The new Width property value of the control.
height
Type: System..::.Int32
The new Height property value of the control.
specified
Type: System.Windows.Forms..::.BoundsSpecified
A bitwise combination of the BoundsSpecified values.

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.UpdateBounds Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.Validate Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox..::.ValidateChildren Method
DataColumnComboBox Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DataColumnComboBox Class
DataColumnComboBox Members
FastReport.Controls Namespace


DataColumnComboBox Properties

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox Properties
DataColumnComboBox Class See Also Send Feedback

The DataColumnComboBox type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | Gets or sets the data source.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the Report.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Overrides UserControl..::.Text.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


DataSource Property

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.DataSource Property
DataColumnComboBox Class See Also Send Feedback
Gets or sets the data source.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


Report Property

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.Report Property
DataColumnComboBox Class See Also Send Feedback
Gets or sets the Report.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; set; }
Visual Basic (Declaration)
Public Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


Text Property

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.Text Property
DataColumnComboBox Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

Return Value

The text associated with this control.

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


DataColumnComboBox Events

[image] [image]

FastReport.Net Class Reference
DataColumnComboBox Events
DataColumnComboBox Class See Also Send Feedback

The DataColumnComboBox type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the text portion of the combobox is changed.
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


TextChanged Event

[image]

FastReport.Net Class Reference
DataColumnComboBox..::.TextChanged Event
DataColumnComboBox Class See Also Send Feedback
Occurs when the text portion of the combobox is changed.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler TextChanged
Visual Basic (Declaration)
Public Event TextChanged As EventHandler
Visual C++
public:
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataColumnComboBox Class
FastReport.Controls Namespace


DataTreeSelectedItemType Enumeration

[image]

FastReport.Net Class Reference
DataTreeSelectedItemType Enumeration
See Also Send Feedback
This is an internal enum that represents the selected datatree item type.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum DataTreeSelectedItemType
Visual Basic (Declaration)
Public Enumeration DataTreeSelectedItemType
Visual C++
public enum class DataTreeSelectedItemType

Members

Member name | Description
None | Nothing selected.
DataColumn | Data column selected.
Total | Total selected.
Parameter | Parameter selected.
Function | Function selected.
DialogControl | Dialog control selected.

See Also

FastReport.Controls Namespace


DataTreeView Class

[image]

FastReport.Net Class Reference
DataTreeView Class
Members See Also Send Feedback
This is an internal control that represents the data tree.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataTreeView : TreeView
Visual Basic (Declaration)
Public Class DataTreeView _
    Inherits TreeView
Visual C++
public ref class DataTreeView : public TreeView

Remarks

This control is for internal use only.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.TreeView
FastReport.Controls..::.DataTreeView

See Also

DataTreeView Members
FastReport.Controls Namespace


DataTreeView Members

[image] [image]

FastReport.Net Class Reference
DataTreeView Members
DataTreeView Class Constructors Methods Properties Events See Also Send Feedback

The DataTreeView type exposes the following members.

Constructors

Name | Description
DataTreeView | Creates a new instance of the DataTreeView control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from TreeView.)
CreateNodes |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemRenderStyles | Returns an OwnerDrawPropertyBag for the specified TreeNode. (Inherited from TreeView.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetNodeAt | Overloaded.
GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HitTest | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from TreeView.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAfterCheck | Raises the AfterCheck event. (Inherited from TreeView.)
OnAfterCollapse | Raises the AfterCollapse event. (Inherited from TreeView.)
OnAfterExpand | Raises the AfterExpand event. (Inherited from TreeView.)
OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from TreeView.)
OnAfterSelect | Raises the AfterSelect event. (Inherited from TreeView.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeforeCheck | Raises the BeforeCheck event. (Inherited from TreeView.)
OnBeforeCollapse | Raises the BeforeCollapse event. (Inherited from TreeView.)
OnBeforeExpand | Raises the BeforeExpand event. (Inherited from TreeView.)
OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from TreeView.)
OnBeforeSelect | Raises the BeforeSelect event. (Inherited from TreeView.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawNode | Raises the DrawNode event. (Inherited from TreeView.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Overrides OnHandleCreated(EventArgs). (Inherited from TreeView.)
OnHandleDestroyed | Overrides OnHandleDestroyed(EventArgs). (Inherited from TreeView.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemDrag | Raises the ItemDrag event. (Inherited from TreeView.)
OnKeyDown | Raises the KeyDown event. (Inherited from TreeView.)
OnKeyPress | Raises the KeyPress event. (Inherited from TreeView.)
OnKeyUp | Overrides OnKeyUp(KeyEventArgs). (Inherited from TreeView.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from TreeView.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from TreeView.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNodeMouseClick | Raises the NodeMouseClick event. (Inherited from TreeView.)
OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event. (Inherited from TreeView.)
OnNodeMouseHover | Raises the NodeMouseHover event. (Inherited from TreeView.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from TreeView.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Overrides ToString()()(). (Inherited from TreeView.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Overrides WndProc(Message%). (Inherited from TreeView.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | (Inherited from TreeView.)
BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Overrides CreateParams. (Inherited from TreeView.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | DataSource property
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TreeView.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer. The DoubleBuffered property has no effect on the TreeView control. (Inherited from TreeView.)
DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExpandedNodes |
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes. (Inherited from TreeView.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
Indent | Gets or sets the distance to indent each of the child tree node levels. (Inherited from TreeView.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
SelectedItem | SelectedItem property
SelectedItemType | SelectedItemType property
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
ShowColumns |
ShowDataSources |
ShowDialogs |
ShowEnabledOnly |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowFunctions |
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
ShowNone |
ShowParameters |
ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
ShowRelations |
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
ShowTotals |
ShowVariables |
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
StateImageList | Gets or sets the image list used for indicating the state of the TreeView and its nodes. (Inherited from TreeView.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataTreeView Class
FastReport.Controls Namespace


DataTreeView Constructor

[image]

FastReport.Net Class Reference
DataTreeView Constructor
DataTreeView Class See Also Send Feedback
Creates a new instance of the DataTreeView control.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataTreeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataTreeView()

See Also

DataTreeView Class
FastReport.Controls Namespace


DataTreeView Methods

[image] [image]

FastReport.Net Class Reference
DataTreeView Methods
DataTreeView Class See Also Send Feedback

The DataTreeView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from TreeView.)
CreateNodes |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemRenderStyles | Returns an OwnerDrawPropertyBag for the specified TreeNode. (Inherited from TreeView.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetNodeAt | Overloaded.
GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HitTest | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from TreeView.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAfterCheck | Raises the AfterCheck event. (Inherited from TreeView.)
OnAfterCollapse | Raises the AfterCollapse event. (Inherited from TreeView.)
OnAfterExpand | Raises the AfterExpand event. (Inherited from TreeView.)
OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from TreeView.)
OnAfterSelect | Raises the AfterSelect event. (Inherited from TreeView.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeforeCheck | Raises the BeforeCheck event. (Inherited from TreeView.)
OnBeforeCollapse | Raises the BeforeCollapse event. (Inherited from TreeView.)
OnBeforeExpand | Raises the BeforeExpand event. (Inherited from TreeView.)
OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from TreeView.)
OnBeforeSelect | Raises the BeforeSelect event. (Inherited from TreeView.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawNode | Raises the DrawNode event. (Inherited from TreeView.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Overrides OnHandleCreated(EventArgs). (Inherited from TreeView.)
OnHandleDestroyed | Overrides OnHandleDestroyed(EventArgs). (Inherited from TreeView.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemDrag | Raises the ItemDrag event. (Inherited from TreeView.)
OnKeyDown | Raises the KeyDown event. (Inherited from TreeView.)
OnKeyPress | Raises the KeyPress event. (Inherited from TreeView.)
OnKeyUp | Overrides OnKeyUp(KeyEventArgs). (Inherited from TreeView.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from TreeView.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from TreeView.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNodeMouseClick | Raises the NodeMouseClick event. (Inherited from TreeView.)
OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event. (Inherited from TreeView.)
OnNodeMouseHover | Raises the NodeMouseHover event. (Inherited from TreeView.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from TreeView.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Overrides ToString()()(). (Inherited from TreeView.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Overrides WndProc(Message%). (Inherited from TreeView.)

See Also

DataTreeView Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.AccessibilityNotifyClients Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.BeginInvoke Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


CreateNodes Method

[image]

FastReport.Net Class Reference
DataTreeView..::.CreateNodes Method
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateNodes(
    Dictionary dictionary
)
Visual Basic (Declaration)
Public Sub CreateNodes ( _
    dictionary As Dictionary _
)
Visual C++
public:
void CreateNodes(
    Dictionary^ dictionary
)

Parameters

dictionary
Type: FastReport.Data..::.Dictionary

See Also

DataTreeView Class
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.Dispose Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the TreeView and optionally releases the managed resources. (Inherited from TreeView.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.GetChildAtPoint Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


GetNodeAt Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.GetNodeAt Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


HitTest Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.HitTest Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.Invalidate Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.Invoke Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.MemberwiseClone Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.PerformLayout Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.ResumeLayout Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.RtlTranslateAlignment Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.Scale Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.Select Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.SetBounds Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DataTreeView..::.UpdateBounds Method
DataTreeView Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DataTreeView Class
DataTreeView Members
FastReport.Controls Namespace


DataTreeView Properties

[image] [image]

FastReport.Net Class Reference
DataTreeView Properties
DataTreeView Class See Also Send Feedback

The DataTreeView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | (Inherited from TreeView.)
BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Overrides CreateParams. (Inherited from TreeView.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | DataSource property
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TreeView.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer. The DoubleBuffered property has no effect on the TreeView control. (Inherited from TreeView.)
DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExpandedNodes |
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes. (Inherited from TreeView.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
Indent | Gets or sets the distance to indent each of the child tree node levels. (Inherited from TreeView.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
SelectedItem | SelectedItem property
SelectedItemType | SelectedItemType property
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
ShowColumns |
ShowDataSources |
ShowDialogs |
ShowEnabledOnly |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowFunctions |
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
ShowNone |
ShowParameters |
ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
ShowRelations |
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
ShowTotals |
ShowVariables |
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
StateImageList | Gets or sets the image list used for indicating the state of the TreeView and its nodes. (Inherited from TreeView.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DataTreeView Class
FastReport.Controls Namespace


DataSource Property

[image]

FastReport.Net Class Reference
DataTreeView..::.DataSource Property
DataTreeView Class See Also Send Feedback
DataSource property

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ExpandedNodes Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ExpandedNodes Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<string> ExpandedNodes { get; set; }
Visual Basic (Declaration)
Public Property ExpandedNodes As List(Of String)
Visual C++
public:
property List<String^>^ ExpandedNodes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


SelectedItem Property

[image]

FastReport.Net Class Reference
DataTreeView..::.SelectedItem Property
DataTreeView Class See Also Send Feedback
SelectedItem property

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As String
Visual C++
public:
property String^ SelectedItem {
    String^ get ();
    void set (String^ value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


SelectedItemType Property

[image]

FastReport.Net Class Reference
DataTreeView..::.SelectedItemType Property
DataTreeView Class See Also Send Feedback
SelectedItemType property

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataTreeSelectedItemType SelectedItemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItemType As DataTreeSelectedItemType
Visual C++
public:
property DataTreeSelectedItemType SelectedItemType {
    DataTreeSelectedItemType get ();
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowColumns Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowColumns Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowColumns { get; set; }
Visual Basic (Declaration)
Public Property ShowColumns As Boolean
Visual C++
public:
property bool ShowColumns {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowDataSources Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowDataSources Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowDataSources { get; set; }
Visual Basic (Declaration)
Public Property ShowDataSources As Boolean
Visual C++
public:
property bool ShowDataSources {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowDialogs Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowDialogs Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowDialogs { get; set; }
Visual Basic (Declaration)
Public Property ShowDialogs As Boolean
Visual C++
public:
property bool ShowDialogs {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowEnabledOnly Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowEnabledOnly Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowEnabledOnly { get; set; }
Visual Basic (Declaration)
Public Property ShowEnabledOnly As Boolean
Visual C++
public:
property bool ShowEnabledOnly {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowFunctions Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowFunctions Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowFunctions { get; set; }
Visual Basic (Declaration)
Public Property ShowFunctions As Boolean
Visual C++
public:
property bool ShowFunctions {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowNone Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowNone Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowNone { get; set; }
Visual Basic (Declaration)
Public Property ShowNone As Boolean
Visual C++
public:
property bool ShowNone {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowParameters Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowParameters Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowParameters { get; set; }
Visual Basic (Declaration)
Public Property ShowParameters As Boolean
Visual C++
public:
property bool ShowParameters {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowRelations Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowRelations Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowRelations { get; set; }
Visual Basic (Declaration)
Public Property ShowRelations As Boolean
Visual C++
public:
property bool ShowRelations {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowTotals Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowTotals Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowTotals { get; set; }
Visual Basic (Declaration)
Public Property ShowTotals As Boolean
Visual C++
public:
property bool ShowTotals {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


ShowVariables Property

[image]

FastReport.Net Class Reference
DataTreeView..::.ShowVariables Property
DataTreeView Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowVariables { get; set; }
Visual Basic (Declaration)
Public Property ShowVariables As Boolean
Visual C++
public:
property bool ShowVariables {
    bool get ();
    void set (bool value);
}

See Also

DataTreeView Class
FastReport.Controls Namespace


DataTreeView Events

[image] [image]

FastReport.Net Class Reference
DataTreeView Events
DataTreeView Class See Also Send Feedback

The DataTreeView type exposes the following members.

Events

Name | Description
AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataTreeView Class
FastReport.Controls Namespace


LabelLine Class

[image]

FastReport.Net Class Reference
LabelLine Class
Members See Also Send Feedback
Represents the label with line.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LabelLine : Control
Visual Basic (Declaration)
Public Class LabelLine _
    Inherits Control
Visual C++
public ref class LabelLine : public Control

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
FastReport.Controls..::.LabelLine

See Also

LabelLine Members
FastReport.Controls Namespace


LabelLine Members

[image] [image]

FastReport.Net Class Reference
LabelLine Members
LabelLine Class Constructors Methods Properties Events See Also Send Feedback

The LabelLine type exposes the following members.

Constructors

Name | Description
LabelLine | Initializes a new instance of the LabelLine class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Processes Windows messages. (Inherited from Control.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

LabelLine Class
FastReport.Controls Namespace


LabelLine Constructor

[image]

FastReport.Net Class Reference
LabelLine Constructor
LabelLine Class See Also Send Feedback
Initializes a new instance of the LabelLine class.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LabelLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LabelLine()

See Also

LabelLine Class
FastReport.Controls Namespace


LabelLine Methods

[image] [image]

FastReport.Net Class Reference
LabelLine Methods
LabelLine Class See Also Send Feedback

The LabelLine type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Processes Windows messages. (Inherited from Control.)

See Also

LabelLine Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.AccessibilityNotifyClients Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.BeginInvoke Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.Dispose Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.GetChildAtPoint Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.Invalidate Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.Invoke Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.MemberwiseClone Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
LabelLine..::.OnPaint Method
LabelLine Class See Also Send Feedback
Raises the Paint event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

LabelLine Class
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.PerformLayout Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.ResumeLayout Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.RtlTranslateAlignment Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.Scale Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.Select Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.SetBounds Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
LabelLine..::.UpdateBounds Method
LabelLine Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

LabelLine Class
LabelLine Members
FastReport.Controls Namespace


LabelLine Properties

[image] [image]

FastReport.Net Class Reference
LabelLine Properties
LabelLine Class See Also Send Feedback

The LabelLine type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

LabelLine Class
FastReport.Controls Namespace


LabelLine Events

[image] [image]

FastReport.Net Class Reference
LabelLine Events
LabelLine Class See Also Send Feedback

The LabelLine type exposes the following members.

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

LabelLine Class
FastReport.Controls Namespace


PageControl Class

[image]

FastReport.Net Class Reference
PageControl Class
Members See Also Send Feedback
Represents a control that may contain several pages. It is similar to the TabControl but contains no tabs. This control is widely used in wizards.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageControl : ContainerControl
Visual Basic (Declaration)
Public Class PageControl _
    Inherits ContainerControl
Visual C++
public ref class PageControl : public ContainerControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
FastReport.Controls..::.PageControl

See Also

PageControl Members
FastReport.Controls Namespace


PageControl Members

[image] [image]

FastReport.Net Class Reference
PageControl Members
PageControl Class Constructors Methods Properties Events See Also Send Feedback

The PageControl type exposes the following members.

Constructors

Name | Description
PageControl | Initializes a new instance of the PageControl class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTabAt | Gets tab at specified mouse point.
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | (Inherited from ContainerControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::.OnMouseLeave(EventArgs).)
OnMouseMove | Raises the MouseMove event. (Overrides Control..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | Raises the MouseUp event. (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SelectNextPage | Selects the next page.
SelectPrevPage | Selects the previous page.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from ContainerControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActivePage | Gets or sets the active page.
ActivePageIndex | Gets or sets the index of active page.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from ContainerControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HighlightPageIndex | Gets or sets the highlighted page index.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant to this class
Pages | Gets the collection of pages.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectorTabHeight | Gets or sets the height of selector tab.
SelectorWidth | Gets or sets a value that determines whether the selector area is visible or not.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
PageSelected | Occurs when page is selected.
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageControl Class
FastReport.Controls Namespace


PageControl Constructor

[image]

FastReport.Net Class Reference
PageControl Constructor
PageControl Class See Also Send Feedback
Initializes a new instance of the PageControl class with default settings.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageControl()

See Also

PageControl Class
FastReport.Controls Namespace


PageControl Methods

[image] [image]

FastReport.Net Class Reference
PageControl Methods
PageControl Class See Also Send Feedback

The PageControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTabAt | Gets tab at specified mouse point.
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | (Inherited from ContainerControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::.OnMouseLeave(EventArgs).)
OnMouseMove | Raises the MouseMove event. (Overrides Control..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | Raises the MouseUp event. (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SelectNextPage | Selects the next page.
SelectPrevPage | Selects the previous page.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from ContainerControl.)

See Also

PageControl Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.AccessibilityNotifyClients Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.BeginInvoke Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.Dispose Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.GetChildAtPoint Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


GetTabAt Method

[image]

FastReport.Net Class Reference
PageControl..::.GetTabAt Method
PageControl Class See Also Send Feedback
Gets tab at specified mouse point.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetTabAt(
    Point pt
)
Visual Basic (Declaration)
Public Function GetTabAt ( _
    pt As Point _
) As Integer
Visual C++
public:
int GetTabAt(
    Point pt
)

Parameters

pt
Type: System.Drawing..::.Point
The mouse point.

Return Value

Index of tab under mouse; -1 if mouse is outside tab area.

See Also

PageControl Class
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.Invalidate Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.Invoke Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.MemberwiseClone Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


OnMouseLeave Method

[image]

FastReport.Net Class Reference
PageControl..::.OnMouseLeave Method
PageControl Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
An EventArgs that contains the event data.

See Also

PageControl Class
FastReport.Controls Namespace


OnMouseMove Method

[image]

FastReport.Net Class Reference
PageControl..::.OnMouseMove Method
PageControl Class See Also Send Feedback
Raises the MouseMove event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

PageControl Class
FastReport.Controls Namespace


OnMouseUp Method

[image]

FastReport.Net Class Reference
PageControl..::.OnMouseUp Method
PageControl Class See Also Send Feedback
Raises the MouseUp event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

PageControl Class
FastReport.Controls Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
PageControl..::.OnPaint Method
PageControl Class See Also Send Feedback
Raises the Paint event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

PageControl Class
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.PerformLayout Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.ResumeLayout Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.RtlTranslateAlignment Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.Scale Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.Select Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


SelectNextPage Method

[image]

FastReport.Net Class Reference
PageControl..::.SelectNextPage Method
PageControl Class See Also Send Feedback
Selects the next page.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectNextPage()
Visual Basic (Declaration)
Public Sub SelectNextPage
Visual C++
public:
void SelectNextPage()

See Also

PageControl Class
FastReport.Controls Namespace


SelectPrevPage Method

[image]

FastReport.Net Class Reference
PageControl..::.SelectPrevPage Method
PageControl Class See Also Send Feedback
Selects the previous page.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectPrevPage()
Visual Basic (Declaration)
Public Sub SelectPrevPage
Visual C++
public:
void SelectPrevPage()

See Also

PageControl Class
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.SetBounds Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.UpdateBounds Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.Validate Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
PageControl..::.ValidateChildren Method
PageControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)

See Also

PageControl Class
PageControl Members
FastReport.Controls Namespace


PageControl Properties

[image] [image]

FastReport.Net Class Reference
PageControl Properties
PageControl Class See Also Send Feedback

The PageControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActivePage | Gets or sets the active page.
ActivePageIndex | Gets or sets the index of active page.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from ContainerControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HighlightPageIndex | Gets or sets the highlighted page index.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant to this class
Pages | Gets the collection of pages.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectorTabHeight | Gets or sets the height of selector tab.
SelectorWidth | Gets or sets a value that determines whether the selector area is visible or not.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PageControl Class
FastReport.Controls Namespace


ActivePage Property

[image]

FastReport.Net Class Reference
PageControl..::.ActivePage Property
PageControl Class See Also Send Feedback
Gets or sets the active page.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Panel ActivePage { get; set; }
Visual Basic (Declaration)
Public Property ActivePage As Panel
Visual C++
public:
property Panel^ ActivePage {
    Panel^ get ();
    void set (Panel^ value);
}

See Also

PageControl Class
FastReport.Controls Namespace


ActivePageIndex Property

[image]

FastReport.Net Class Reference
PageControl..::.ActivePageIndex Property
PageControl Class See Also Send Feedback
Gets or sets the index of active page.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ActivePageIndex { get; set; }
Visual Basic (Declaration)
Public Property ActivePageIndex As Integer
Visual C++
public:
property int ActivePageIndex {
    int get ();
    void set (int value);
}

See Also

PageControl Class
FastReport.Controls Namespace


HighlightPageIndex Property

[image]

FastReport.Net Class Reference
PageControl..::.HighlightPageIndex Property
PageControl Class See Also Send Feedback
Gets or sets the highlighted page index.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int HighlightPageIndex { get; set; }
Visual Basic (Declaration)
Public Property HighlightPageIndex As Integer
Visual C++
public:
property int HighlightPageIndex {
    int get ();
    void set (int value);
}

See Also

PageControl Class
FastReport.Controls Namespace


Padding Property

[image]

FastReport.Net Class Reference
PageControl..::.Padding Property
PageControl Class See Also Send Feedback
This property is not relevant to this class

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

PageControl Class
FastReport.Controls Namespace


Pages Property

[image]

FastReport.Net Class Reference
PageControl..::.Pages Property
PageControl Class See Also Send Feedback
Gets the collection of pages.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Control..::.ControlCollection Pages { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pages As Control..::.ControlCollection
Visual C++
public:
property Control..::.ControlCollection^ Pages {
    Control..::.ControlCollection^ get ();
}

See Also

PageControl Class
FastReport.Controls Namespace


SelectorTabHeight Property

[image]

FastReport.Net Class Reference
PageControl..::.SelectorTabHeight Property
PageControl Class See Also Send Feedback
Gets or sets the height of selector tab.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int SelectorTabHeight { get; set; }
Visual Basic (Declaration)
Public Property SelectorTabHeight As Integer
Visual C++
public:
property int SelectorTabHeight {
    int get ();
    void set (int value);
}

See Also

PageControl Class
FastReport.Controls Namespace


SelectorWidth Property

[image]

FastReport.Net Class Reference
PageControl..::.SelectorWidth Property
PageControl Class See Also Send Feedback
Gets or sets a value that determines whether the selector area is visible or not.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int SelectorWidth { get; set; }
Visual Basic (Declaration)
Public Property SelectorWidth As Integer
Visual C++
public:
property int SelectorWidth {
    int get ();
    void set (int value);
}

See Also

PageControl Class
FastReport.Controls Namespace


PageControl Events

[image] [image]

FastReport.Net Class Reference
PageControl Events
PageControl Class See Also Send Feedback

The PageControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
PageSelected | Occurs when page is selected.
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageControl Class
FastReport.Controls Namespace


PageSelected Event

[image]

FastReport.Net Class Reference
PageControl..::.PageSelected Event
PageControl Class See Also Send Feedback
Occurs when page is selected.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler PageSelected
Visual Basic (Declaration)
Public Event PageSelected As EventHandler
Visual C++
public:
 event EventHandler^ PageSelected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

PageControl Class
FastReport.Controls Namespace


PageControlPage Class

[image]

FastReport.Net Class Reference
PageControlPage Class
Members See Also Send Feedback
This class represents a single page of the PageControl control.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageControlPage : Panel
Visual Basic (Declaration)
Public Class PageControlPage _
    Inherits Panel
Visual C++
public ref class PageControlPage : public Panel

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.Panel
FastReport.Controls..::.PageControlPage

See Also

PageControlPage Members
FastReport.Controls Namespace


PageControlPage Members

[image] [image]

FastReport.Net Class Reference
PageControlPage Members
PageControlPage Class Constructors Methods Properties Events See Also Send Feedback

The PageControlPage type exposes the following members.

Constructors

Name | Description
PageControlPage | Initializes a new instance of the PageControlPage class

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ScrollableControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string representation for this control. (Inherited from Panel.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from ScrollableControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Panel.)
AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Panel.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Panel.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the page caption text. (Overrides Panel..::.Text.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageControlPage Class
FastReport.Controls Namespace


PageControlPage Constructor

[image]

FastReport.Net Class Reference
PageControlPage Constructor
PageControlPage Class See Also Send Feedback
Initializes a new instance of the PageControlPage class

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageControlPage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageControlPage()

See Also

PageControlPage Class
FastReport.Controls Namespace


PageControlPage Methods

[image] [image]

FastReport.Net Class Reference
PageControlPage Methods
PageControlPage Class See Also Send Feedback

The PageControlPage type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ScrollableControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string representation for this control. (Inherited from Panel.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from ScrollableControl.)

See Also

PageControlPage Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.AccessibilityNotifyClients Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.BeginInvoke Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.Dispose Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.GetChildAtPoint Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.Invalidate Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.Invoke Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.MemberwiseClone Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.PerformLayout Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.ResumeLayout Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.RtlTranslateAlignment Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.Scale Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.Select Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.SetBounds Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
PageControlPage..::.UpdateBounds Method
PageControlPage Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PageControlPage Class
PageControlPage Members
FastReport.Controls Namespace


PageControlPage Properties

[image] [image]

FastReport.Net Class Reference
PageControlPage Properties
PageControlPage Class See Also Send Feedback

The PageControlPage type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Panel.)
AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Panel.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Panel.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the page caption text. (Overrides Panel..::.Text.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PageControlPage Class
FastReport.Controls Namespace


Text Property

[image]

FastReport.Net Class Reference
PageControlPage..::.Text Property
PageControlPage Class See Also Send Feedback
Gets or sets the page caption text.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

PageControlPage Class
FastReport.Controls Namespace


PageControlPage Events

[image] [image]

FastReport.Net Class Reference
PageControlPage Events
PageControlPage Class See Also Send Feedback

The PageControlPage type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageControlPage Class
FastReport.Controls Namespace


PopupWindow Class

[image]

FastReport.Net Class Reference
PopupWindow Class
Members See Also Send Feedback
Represents a popup form.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PopupWindow : Form
Visual Basic (Declaration)
Public Class PopupWindow _
    Inherits Form
Visual C++
public ref class PopupWindow : public Form

Remarks

Use this form if you want to show some controls in non-modal borderless form that behaves like other standard popup controls such as context menu. This form does not move a focus from the parent form.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Controls..::.PopupWindow
FastReport.Controls..::.ColorPopup

See Also

PopupWindow Members
FastReport.Controls Namespace


PopupWindow Members

[image] [image]

FastReport.Net Class Reference
PopupWindow Members
PopupWindow Class Constructors Methods Properties Events See Also Send Feedback

The PopupWindow type exposes the following members.

Constructors

Name | Description
PopupWindow | Initializes a new instance of the PopupWindow class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PopupWindow Class
FastReport.Controls Namespace


PopupWindow Constructor

[image]

FastReport.Net Class Reference
PopupWindow Constructor
PopupWindow Class See Also Send Feedback
Initializes a new instance of the PopupWindow class with default settings.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PopupWindow(
    Form ownerForm
)
Visual Basic (Declaration)
Public Sub New ( _
    ownerForm As Form _
)
Visual C++
public:
PopupWindow(
    Form^ ownerForm
)

Parameters

ownerForm
Type: System.Windows.Forms..::.Form
The main form that owns this popup form.

See Also

PopupWindow Class
FastReport.Controls Namespace


PopupWindow Methods

[image] [image]

FastReport.Net Class Reference
PopupWindow Methods
PopupWindow Class See Also Send Feedback

The PopupWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PopupWindow Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.AccessibilityNotifyClients Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.BeginInvoke Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Dispose Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.GetChildAtPoint Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Invalidate Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Invoke Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.MemberwiseClone Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.PerformLayout Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.ResumeLayout Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.RtlTranslateAlignment Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Scale Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Select Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.SetBounds Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Show Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(Point) | Shows the form.
Show(Control, Point) | Shows the form.
Show(Control, Int32, Int32) | Shows the form.

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Show Method (Point)

[image]

FastReport.Net Class Reference
PopupWindow..::.Show Method (Point)
PopupWindow Class See Also Send Feedback
Shows the form.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    Point pt
)
Visual Basic (Declaration)
Public Sub Show ( _
    pt As Point _
)
Visual C++
public:
void Show(
    Point pt
)

Parameters

pt
Type: System.Drawing..::.Point
The absolute screen location.

See Also

PopupWindow Class
Show Overload
FastReport.Controls Namespace


Show Method (Control, Point)

[image]

FastReport.Net Class Reference
PopupWindow..::.Show Method (Control, Point)
PopupWindow Class See Also Send Feedback
Shows the form.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    Control ctl,
    Point pt
)
Visual Basic (Declaration)
Public Sub Show ( _
    ctl As Control, _
    pt As Point _
)
Visual C++
public:
void Show(
    Control^ ctl,
    Point pt
)

Parameters

ctl
Type: System.Windows.Forms..::.Control
The control which location is used as a reference for pt parameter.
pt
Type: System.Drawing..::.Point
The location relative to the ctl control.

See Also

PopupWindow Class
Show Overload
FastReport.Controls Namespace


Show Method (Control, Int32, Int32)

[image]

FastReport.Net Class Reference
PopupWindow..::.Show Method (Control, Int32, Int32)
PopupWindow Class See Also Send Feedback
Shows the form.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show(
    Control ctl,
    int x,
    int y
)
Visual Basic (Declaration)
Public Sub Show ( _
    ctl As Control, _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
void Show(
    Control^ ctl,
    int x,
    int y
)

Parameters

ctl
Type: System.Windows.Forms..::.Control
The control which location is used as a reference for x, y parameters.
x
Type: System..::.Int32
The x position relative to the ctl control.
y
Type: System..::.Int32
The y position relative to the ctl control.

See Also

PopupWindow Class
Show Overload
FastReport.Controls Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.ShowDialog Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.UpdateBounds Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.Validate Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
PopupWindow..::.ValidateChildren Method
PopupWindow Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PopupWindow Class
PopupWindow Members
FastReport.Controls Namespace


PopupWindow Properties

[image] [image]

FastReport.Net Class Reference
PopupWindow Properties
PopupWindow Class See Also Send Feedback

The PopupWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PopupWindow Class
FastReport.Controls Namespace


PopupWindow Events

[image] [image]

FastReport.Net Class Reference
PopupWindow Events
PopupWindow Class See Also Send Feedback

The PopupWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PopupWindow Class
FastReport.Controls Namespace


TextBoxButton Class

[image]

FastReport.Net Class Reference
TextBoxButton Class
Members See Also Send Feedback
Represents the control that combines a textbox and a button.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextBoxButton : UserControl
Visual Basic (Declaration)
Public Class TextBoxButton _
    Inherits UserControl
Visual C++
public ref class TextBoxButton : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Controls..::.TextBoxButton

See Also

TextBoxButton Members
FastReport.Controls Namespace


TextBoxButton Members

[image] [image]

FastReport.Net Class Reference
TextBoxButton Members
TextBoxButton Class Constructors Methods Properties Events See Also Send Feedback

The TextBoxButton type exposes the following members.

Constructors

Name | Description
TextBoxButton | Initializes a new instance of the TextBoxButton class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Overrides ContainerControl..::.OnLayout(LayoutEventArgs).)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Overrides Control..::.SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified).)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Image | Gets or sets the button's image.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Overrides UserControl..::.Text.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
ButtonClick | Occurs when the button is clicked.
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextBoxChanged | Occurs when the textbox is changed.
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextBoxButton Class
FastReport.Controls Namespace


TextBoxButton Constructor

[image]

FastReport.Net Class Reference
TextBoxButton Constructor
TextBoxButton Class See Also Send Feedback
Initializes a new instance of the TextBoxButton class.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextBoxButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxButton()

See Also

TextBoxButton Class
FastReport.Controls Namespace


TextBoxButton Methods

[image] [image]

FastReport.Net Class Reference
TextBoxButton Methods
TextBoxButton Class See Also Send Feedback

The TextBoxButton type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Overrides ContainerControl..::.OnLayout(LayoutEventArgs).)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Overrides Control..::.SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified).)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

TextBoxButton Class
FastReport.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.AccessibilityNotifyClients Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.BeginInvoke Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.Dispose Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.GetChildAtPoint Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.Invalidate Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.Invoke Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.MemberwiseClone Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


OnLayout Method

[image]

FastReport.Net Class Reference
TextBoxButton..::.OnLayout Method
TextBoxButton Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLayout ( _
    e As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.LayoutEventArgs

See Also

TextBoxButton Class
FastReport.Controls Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
TextBoxButton..::.OnPaint Method
TextBoxButton Class See Also Send Feedback
Raises the Paint event.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

TextBoxButton Class
FastReport.Controls Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.PerformLayout Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.ResumeLayout Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.RtlTranslateAlignment Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.Scale Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.Select Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.SetBounds Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


SetBoundsCore Method

[image]

FastReport.Net Class Reference
TextBoxButton..::.SetBoundsCore Method
TextBoxButton Class See Also Send Feedback
Performs the work of setting the specified bounds of this control.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void SetBoundsCore(
    int x,
    int y,
    int width,
    int height,
    BoundsSpecified specified
)
Visual Basic (Declaration)
Protected Overrides Sub SetBoundsCore ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer, _
    specified As BoundsSpecified _
)
Visual C++
protected:
virtual void SetBoundsCore(
    int x,
    int y,
    int width,
    int height,
    BoundsSpecified specified
) override

Parameters

x
Type: System..::.Int32
The new Left property value of the control.
y
Type: System..::.Int32
The new Top property value of the control.
width
Type: System..::.Int32
The new Width property value of the control.
height
Type: System..::.Int32
The new Height property value of the control.
specified
Type: System.Windows.Forms..::.BoundsSpecified
A bitwise combination of the BoundsSpecified values.

See Also

TextBoxButton Class
FastReport.Controls Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.UpdateBounds Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.Validate Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
TextBoxButton..::.ValidateChildren Method
TextBoxButton Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

TextBoxButton Class
TextBoxButton Members
FastReport.Controls Namespace


TextBoxButton Properties

[image] [image]

FastReport.Net Class Reference
TextBoxButton Properties
TextBoxButton Class See Also Send Feedback

The TextBoxButton type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Image | Gets or sets the button's image.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Overrides UserControl..::.Text.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

TextBoxButton Class
FastReport.Controls Namespace


Image Property

[image]

FastReport.Net Class Reference
TextBoxButton..::.Image Property
TextBoxButton Class See Also Send Feedback
Gets or sets the button's image.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

TextBoxButton Class
FastReport.Controls Namespace


Text Property

[image]

FastReport.Net Class Reference
TextBoxButton..::.Text Property
TextBoxButton Class See Also Send Feedback

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

Return Value

The text associated with this control.

See Also

TextBoxButton Class
FastReport.Controls Namespace


TextBoxButton Events

[image] [image]

FastReport.Net Class Reference
TextBoxButton Events
TextBoxButton Class See Also Send Feedback

The TextBoxButton type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
ButtonClick | Occurs when the button is clicked.
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextBoxChanged | Occurs when the textbox is changed.
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextBoxButton Class
FastReport.Controls Namespace


ButtonClick Event

[image]

FastReport.Net Class Reference
TextBoxButton..::.ButtonClick Event
TextBoxButton Class See Also Send Feedback
Occurs when the button is clicked.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ButtonClick
Visual Basic (Declaration)
Public Event ButtonClick As EventHandler
Visual C++
public:
 event EventHandler^ ButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

TextBoxButton Class
FastReport.Controls Namespace


TextBoxChanged Event

[image]

FastReport.Net Class Reference
TextBoxButton..::.TextBoxChanged Event
TextBoxButton Class See Also Send Feedback
Occurs when the textbox is changed.

Namespace: FastReport.Controls
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler TextBoxChanged
Visual Basic (Declaration)
Public Event TextBoxChanged As EventHandler
Visual C++
public:
 event EventHandler^ TextBoxChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

TextBoxButton Class
FastReport.Controls Namespace


FastReport.Data Namespace

[image]

FastReport.Net Class Reference
FastReport.Data Namespace
Send Feedback

Classes

Class | Description
AbsRowVariable | Returns absolute number of data row. This value is never reset at the start of a new group.
BusinessObjectDataSource | Represents a datasource based on business object of IEnumerable type.
Column | This class represents a single data column in a DataSourceBase.
ColumnCollection | Represents the collection of Column objects.
CommandParameter | This class represents a single parameter to use in the "select" command.
CommandParameterCollection | Represents the collection of CommandParameter objects.
ConnectionCollection | Represents the collection of DataConnectionBase objects.
CopyNameMacroVariable | Returns the name of the printed copy. This variable is actually a macro. Its value is substituted when the component is viewed in the preview window. That means you cannot use it in an expression.
DataComponentBase | The base class for all data components such as data sources, columns.
DataConnectionBase | The base class for all data connection components such as MsSqlDataConnection.
DataSourceBase | Base class for all datasources such as TableDataSource.
DataSourceCollection | Represents the collection of DataSourceBase objects.
DateVariable | Returns date and time of the report's start.
Dictionary | This class stores all report data items such as datasources, connections, relations, parameters, system variables.
Dictionary..::.RegDataItem | Represents the item registered in a dictionary.
HierarchyLevelVariable | Returns a level of hierarchy in the hierarchical report.
HierarchyRowNoVariable | Returns the row number like "1.2.1" in the hierarchical report.
LoadBusinessObjectEventArgs | Provides data for LoadBusinessObjectEventHandler event.
MsAccessDataConnection | Represents a connection to MS Access database (.mdb file).
MsSqlDataConnection | Represents a connection to MS SQL database.
OdbcDataConnection | Represents a connection to any database through ODBC.
OleDbDataConnection | Represents a connection to any OLE DB database.
PageMacroVariable | Returns current page number. This variable is actually a macro. Its value is substituted when the component is viewed in the preview window. That means you cannot use it in an expression.
PageNofMVariable | Returns a string containing the current page number and total pages in a form "Page N of M". To use this variable, you need to enable the report's double pass.
PageNVariable | Returns a string containing the current page number in a form "Page N".
PageVariable | Returns current page number.
Parameter | Represents a report parameter that is used to pass user data to a report.
ParameterCollection | Represents the collection of Parameter objects.
Relation | Represents a master-detail relation between two data sources.
RelationCollection | Represents the collection of Relation objects.
RowVariable | Returns data row number inside the group. This value is reset at the start of a new group.
SystemVariable | Represents the base class for system variables.
SystemVariables | Represents the collection of system variables.
TableCollection | Represents the collection of TableDataSource objects.
TableDataSource | Represents a datasource based on DataTable class.
Total | Represents a total that is used to calculate aggregates such as Sum, Min, Max, Avg, Count.
TotalCollection | Represents the collection of Total objects.
TotalPagesMacroVariable | Returns the number of total pages in the report. This variable is actually a macro. Its value is substituted when the component is viewed in the preview window. That means you cannot use it in an expression.
TotalPagesVariable | Returns total number of pages in the report. To use this variable, you need to enable the report's double pass.
ViewDataSource | Represents a datasource based on DataView class.
XmlConnectionStringBuilder | Represents the XmlDataConnection connection string builder.
XmlDataConnection | Represents a connection to xml file-based database.

Delegates

Delegate | Description
LoadBusinessObjectEventHandler | Represents the method that will handle the LoadBusinessObject event.

Enumerations

Enumeration | Description
BOConverterFlags | Obsolete. Specifies a set of flags used to convert business objects into datasources.
ColumnBindableControl | Specifies the type of an object that will be created when you drop the data column on a report page.
ColumnFormat | Specifies the format for the column value.
FilterOperation | Determines how to filter the data value.
PropertyKind | Specifies a kind of property.
TotalType | Specifies the total type.


AbsRowVariable Class

[image]

FastReport.Net Class Reference
AbsRowVariable Class
Members See Also Send Feedback
Returns absolute number of data row. This value is never reset at the start of a new group.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AbsRowVariable : SystemVariable
Visual Basic (Declaration)
Public Class AbsRowVariable _
    Inherits SystemVariable
Visual C++
public ref class AbsRowVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.AbsRowVariable

See Also

AbsRowVariable Members
FastReport.Data Namespace


AbsRowVariable Members

[image] [image]

FastReport.Net Class Reference
AbsRowVariable Members
AbsRowVariable Class Methods Properties Events See Also Send Feedback

The AbsRowVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

AbsRowVariable Class
FastReport.Data Namespace


AbsRowVariable Methods

[image] [image]

FastReport.Net Class Reference
AbsRowVariable Methods
AbsRowVariable Class See Also Send Feedback

The AbsRowVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

AbsRowVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
AbsRowVariable..::.Dispose Method
AbsRowVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

AbsRowVariable Class
AbsRowVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
AbsRowVariable..::.MemberwiseClone Method
AbsRowVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AbsRowVariable Class
AbsRowVariable Members
FastReport.Data Namespace


AbsRowVariable Properties

[image] [image]

FastReport.Net Class Reference
AbsRowVariable Properties
AbsRowVariable Class See Also Send Feedback

The AbsRowVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

AbsRowVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
AbsRowVariable..::.Value Property
AbsRowVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

AbsRowVariable Class
FastReport.Data Namespace


AbsRowVariable Events

[image] [image]

FastReport.Net Class Reference
AbsRowVariable Events
AbsRowVariable Class See Also Send Feedback

The AbsRowVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

AbsRowVariable Class
FastReport.Data Namespace


BOConverterFlags Enumeration

[image]

FastReport.Net Class Reference
BOConverterFlags Enumeration
See Also Send Feedback
Obsolete. Specifies a set of flags used to convert business objects into datasources.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
[FlagsAttribute]
public enum BOConverterFlags
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration BOConverterFlags
Visual C++
[FlagsAttribute]
public enum class BOConverterFlags

Members

Member name | Description
None | Specifies no actions.
AllowFields | Allows using the fields of a business object.
BrowsableOnly | Allows using properties of a business object with BrowsableAttribute only.

See Also

FastReport.Data Namespace


BusinessObjectDataSource Class

[image]

FastReport.Net Class Reference
BusinessObjectDataSource Class
Members See Also Send Feedback
Represents a datasource based on business object of IEnumerable type.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BusinessObjectDataSource : DataSourceBase
Visual Basic (Declaration)
Public Class BusinessObjectDataSource _
    Inherits DataSourceBase
Visual C++
public ref class BusinessObjectDataSource : public DataSourceBase

Remarks

Do not use this class directly. To register a business object, use the Report.RegisterData method.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Column
FastReport.Data..::.DataSourceBase
FastReport.Data..::.BusinessObjectDataSource

See Also

BusinessObjectDataSource Members
FastReport.Data Namespace


BusinessObjectDataSource Members

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource Members
BusinessObjectDataSource Class Constructors Methods Properties Events See Also Send Feedback

The BusinessObjectDataSource type exposes the following members.

Constructors

Name | Description
BusinessObjectDataSource | Initializes a new instance of the BusinessObjectDataSource class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Column.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from Column.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Overrides DataSourceBase..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet. (Inherited from DataSourceBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row. (Inherited from DataSourceBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Column.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Inherited from DataSourceBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema. (Overrides DataSourceBase..::.InitSchema()()().)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data. (Overrides DataSourceBase..::.LoadData(ArrayList).)
MemberwiseClone | Overloaded.
Next | Navigates to the next row. (Inherited from DataSourceBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row. (Inherited from DataSourceBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Column.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataSourceBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
Calculated | This property is not relevant to this class. (Inherited from DataSourceBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row. (Inherited from DataSourceBase.)
CurrentRowNo | Gets an index of current data row. (Inherited from DataSourceBase.)
CustomBindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
DataType | This property is not relevant to this class. (Inherited from DataSourceBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from DataSourceBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource. (Inherited from DataSourceBase.)
Format | This property is not relevant to this class. (Inherited from DataSourceBase.)
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount. (Inherited from DataSourceBase.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource. (Inherited from DataSourceBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data. (Inherited from DataSourceBase.)
LoadBusinessObject | Occurs when FastReport engine loads data source with data from a business object.

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


BusinessObjectDataSource Constructor

[image]

FastReport.Net Class Reference
BusinessObjectDataSource Constructor
BusinessObjectDataSource Class See Also Send Feedback
Initializes a new instance of the BusinessObjectDataSource class

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BusinessObjectDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BusinessObjectDataSource()

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


BusinessObjectDataSource Methods

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource Methods
BusinessObjectDataSource Class See Also Send Feedback

The BusinessObjectDataSource type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Column.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from Column.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Overrides DataSourceBase..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet. (Inherited from DataSourceBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row. (Inherited from DataSourceBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Column.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Inherited from DataSourceBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema. (Overrides DataSourceBase..::.InitSchema()()().)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data. (Overrides DataSourceBase..::.LoadData(ArrayList).)
MemberwiseClone | Overloaded.
Next | Navigates to the next row. (Inherited from DataSourceBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row. (Inherited from DataSourceBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Column.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataSourceBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.Deserialize Method
BusinessObjectDataSource Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.Dispose Method
BusinessObjectDataSource Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

BusinessObjectDataSource Class
BusinessObjectDataSource Members
FastReport.Data Namespace


GetValue Method

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.GetValue Method
BusinessObjectDataSource Class See Also Send Feedback

Overload List

Name | Description
GetValue(Column) | Gets data stored in a specified column. (Overrides DataSourceBase..::.GetValue(Column).)
GetValue(String) | Gets data stored in a specified column. (Overrides DataSourceBase..::.GetValue(String).)

See Also

BusinessObjectDataSource Class
BusinessObjectDataSource Members
FastReport.Data Namespace


GetValue Method (Column)

[image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.GetValue Method (Column)
BusinessObjectDataSource Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue(
    Column column
)
Visual Basic (Declaration)
Protected Overrides Function GetValue ( _
    column As Column _
) As Object
Visual C++
protected:
virtual Object^ GetValue(
    Column^ column
) override

Parameters

column
Type: FastReport.Data..::.Column
The column.

Return Value

An object that contains the data.

See Also

BusinessObjectDataSource Class
GetValue Overload
FastReport.Data Namespace


GetValue Method (String)

[image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.GetValue Method (String)
BusinessObjectDataSource Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue(
    string alias
)
Visual Basic (Declaration)
Protected Overrides Function GetValue ( _
    alias As String _
) As Object
Visual C++
protected:
virtual Object^ GetValue(
    String^ alias
) override

Parameters

alias
Type: System..::.String
The column alias.

Return Value

An object that contains the data.

See Also

BusinessObjectDataSource Class
GetValue Overload
FastReport.Data Namespace


Init Method

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.Init Method
BusinessObjectDataSource Class See Also Send Feedback

Overload List

Name | Description
Init()()() | Initializes this datasource. (Inherited from DataSourceBase.)
Init(DataSourceBase) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. (Inherited from DataSourceBase.)
Init(String) | Initializes this datasource and applies the specified filter. (Inherited from DataSourceBase.)
Init(String, SortCollection) | Initializes this datasource, applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)
Init(DataSourceBase, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. Also applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)
Init(Relation, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation. Also applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)

See Also

BusinessObjectDataSource Class
BusinessObjectDataSource Members
FastReport.Data Namespace


InitSchema Method

[image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.InitSchema Method
BusinessObjectDataSource Class See Also Send Feedback
Initializes the datasource schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitSchema()
Visual Basic (Declaration)
Public Overrides Sub InitSchema
Visual C++
public:
virtual void InitSchema() override

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


LoadData Method

[image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.LoadData Method
BusinessObjectDataSource Class See Also Send Feedback
Loads the datasource with data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void LoadData(
    ArrayList rows
)
Visual Basic (Declaration)
Public Overrides Sub LoadData ( _
    rows As ArrayList _
)
Visual C++
public:
virtual void LoadData(
    ArrayList^ rows
) override

Parameters

rows
Type: System.Collections..::.ArrayList
Rows to fill with data.

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.MemberwiseClone Method
BusinessObjectDataSource Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BusinessObjectDataSource Class
BusinessObjectDataSource Members
FastReport.Data Namespace


BusinessObjectDataSource Properties

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource Properties
BusinessObjectDataSource Class See Also Send Feedback

The BusinessObjectDataSource type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
Calculated | This property is not relevant to this class. (Inherited from DataSourceBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row. (Inherited from DataSourceBase.)
CurrentRowNo | Gets an index of current data row. (Inherited from DataSourceBase.)
CustomBindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
DataType | This property is not relevant to this class. (Inherited from DataSourceBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from DataSourceBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource. (Inherited from DataSourceBase.)
Format | This property is not relevant to this class. (Inherited from DataSourceBase.)
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount. (Inherited from DataSourceBase.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource. (Inherited from DataSourceBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


Item Property

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.Item Property
BusinessObjectDataSource Class See Also Send Feedback

Overload List

Name | Description
Item[([(Column])]) | Gets data stored in a specified column. (Inherited from DataSourceBase.)
Item[([(String])]) | Gets data stored in a specified column. (Inherited from DataSourceBase.)

See Also

BusinessObjectDataSource Class
BusinessObjectDataSource Members
FastReport.Data Namespace


BusinessObjectDataSource Events

[image] [image]

FastReport.Net Class Reference
BusinessObjectDataSource Events
BusinessObjectDataSource Class See Also Send Feedback

The BusinessObjectDataSource type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data. (Inherited from DataSourceBase.)
LoadBusinessObject | Occurs when FastReport engine loads data source with data from a business object.

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


LoadBusinessObject Event

[image]

FastReport.Net Class Reference
BusinessObjectDataSource..::.LoadBusinessObject Event
BusinessObjectDataSource Class See Also Send Feedback
Occurs when FastReport engine loads data source with data from a business object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event LoadBusinessObjectEventHandler LoadBusinessObject
Visual Basic (Declaration)
Public Event LoadBusinessObject As LoadBusinessObjectEventHandler
Visual C++
public:
 event LoadBusinessObjectEventHandler^ LoadBusinessObject {
    void add (LoadBusinessObjectEventHandler^ value);
    void remove (LoadBusinessObjectEventHandler^ value);
}

Remarks

Use this event if you want to implement load-on-demand. Event handler must load the data into your business object.

See Also

BusinessObjectDataSource Class
FastReport.Data Namespace


Column Class

[image]

FastReport.Net Class Reference
Column Class
Members See Also Send Feedback
This class represents a single data column in a DataSourceBase.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Column : DataComponentBase, IParent
Visual Basic (Declaration)
Public Class Column _
    Inherits DataComponentBase _
    Implements IParent
Visual C++
public ref class Column : public DataComponentBase,
    IParent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Column
FastReport.Data..::.DataSourceBase

See Also

Column Members
FastReport.Data Namespace


Column Members

[image] [image]

FastReport.Net Class Reference
Column Members
Column Class Constructors Methods Properties Events See Also Send Feedback

The Column type exposes the following members.

Constructors

Name | Description
Column | Initializes a new instance of the Column class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides DataComponentBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Overrides DataComponentBase..::.SetName(String).)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | Gets or sets a value that specifies the type of a control that will be created when you drop this column on a report page.
Calculated | Gets or sets a value that indicates whether this column is calculated.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomBindableControl | Gets or sets a name of custom bindable control.
DataType | Gets or sets the type of data supplied by this column.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets expression of the calculated column.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Format | Gets or sets the format of this column.
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to.
PropName | Gets or sets the business object property name which this column is bound to.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Column Class
FastReport.Data Namespace


Column Constructor

[image]

FastReport.Net Class Reference
Column Constructor
Column Class See Also Send Feedback
Initializes a new instance of the Column class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Column()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Column()

See Also

Column Class
FastReport.Data Namespace


Column Methods

[image] [image]

FastReport.Net Class Reference
Column Methods
Column Class See Also Send Feedback

The Column type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides DataComponentBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Overrides DataComponentBase..::.SetName(String).)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

Column Class
FastReport.Data Namespace


AddChild Method

[image]

FastReport.Net Class Reference
Column..::.AddChild Method
Column Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

Column Class
FastReport.Data Namespace


CanContain Method

[image]

FastReport.Net Class Reference
Column..::.CanContain Method
Column Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

Column Class
FastReport.Data Namespace


Delete Method

[image]

FastReport.Net Class Reference
Column..::.Delete Method
Column Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

Column Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Column..::.Dispose Method
Column Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Column Class
Column Members
FastReport.Data Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
Column..::.GetChildObjects Method
Column Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overridable Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

Column Class
FastReport.Data Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
Column..::.GetChildOrder Method
Column Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

Column Class
FastReport.Data Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
Column..::.GetExpressions Method
Column Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

Column Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Column..::.MemberwiseClone Method
Column Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Column Class
Column Members
FastReport.Data Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
Column..::.RemoveChild Method
Column Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

Column Class
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Column..::.Serialize Method
Column Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Column Class
FastReport.Data Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
Column..::.SetChildOrder Method
Column Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

Column Class
FastReport.Data Namespace


SetName Method

[image]

FastReport.Net Class Reference
Column..::.SetName Method
Column Class See Also Send Feedback
Sets the object's name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetName(
    string value
)
Visual Basic (Declaration)
Public Overrides Sub SetName ( _
    value As String _
)
Visual C++
public:
virtual void SetName(
    String^ value
) override

Parameters

value
Type: System..::.String
New name.

Remarks

This method is for internal use only. It just sets a new name without any checks (unlike the Name property setter).

See Also

Column Class
FastReport.Data Namespace
Name Property


UpdateLayout Method

[image]

FastReport.Net Class Reference
Column..::.UpdateLayout Method
Column Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

Column Class
FastReport.Data Namespace


Column Properties

[image] [image]

FastReport.Net Class Reference
Column Properties
Column Class See Also Send Feedback

The Column type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | Gets or sets a value that specifies the type of a control that will be created when you drop this column on a report page.
Calculated | Gets or sets a value that indicates whether this column is calculated.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomBindableControl | Gets or sets a name of custom bindable control.
DataType | Gets or sets the type of data supplied by this column.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets expression of the calculated column.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Format | Gets or sets the format of this column.
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to.
PropName | Gets or sets the business object property name which this column is bound to.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Column Class
FastReport.Data Namespace


BindableControl Property

[image]

FastReport.Net Class Reference
Column..::.BindableControl Property
Column Class See Also Send Feedback
Gets or sets a value that specifies the type of a control that will be created when you drop this column on a report page.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnBindableControl BindableControl { get; set; }
Visual Basic (Declaration)
Public Property BindableControl As ColumnBindableControl
Visual C++
public:
property ColumnBindableControl BindableControl {
    ColumnBindableControl get ();
    void set (ColumnBindableControl value);
}

Remarks

If you need to specify the custom type, use the CustomBindableControl property instead.

See Also

Column Class
FastReport.Data Namespace


Calculated Property

[image]

FastReport.Net Class Reference
Column..::.Calculated Property
Column Class See Also Send Feedback
Gets or sets a value that indicates whether this column is calculated.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Calculated { get; set; }
Visual Basic (Declaration)
Public Property Calculated As Boolean
Visual C++
public:
property bool Calculated {
    bool get ();
    void set (bool value);
}

Remarks

You should specify the Expression property for calculated columns.

See Also

Column Class
FastReport.Data Namespace


Columns Property

[image]

FastReport.Net Class Reference
Column..::.Columns Property
Column Class See Also Send Feedback
Gets the collection of child columns.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As ColumnCollection
Visual C++
public:
property ColumnCollection^ Columns {
    ColumnCollection^ get ();
}

See Also

Column Class
FastReport.Data Namespace


CustomBindableControl Property

[image]

FastReport.Net Class Reference
Column..::.CustomBindableControl Property
Column Class See Also Send Feedback
Gets or sets a name of custom bindable control.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CustomBindableControl { get; set; }
Visual Basic (Declaration)
Public Property CustomBindableControl As String
Visual C++
public:
property String^ CustomBindableControl {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property if you want to bind a column to custom object type. You need to specify the type name of your object; that object must be registered in FastReport using the RegisteredObjects.Add method.

See Also

Column Class
FastReport.Data Namespace


DataType Property

[image]

FastReport.Net Class Reference
Column..::.DataType Property
Column Class See Also Send Feedback
Gets or sets the type of data supplied by this column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    void set (Type^ value);
}

See Also

Column Class
FastReport.Data Namespace


Expression Property

[image]

FastReport.Net Class Reference
Column..::.Expression Property
Column Class See Also Send Feedback
Gets or sets expression of the calculated column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if the Calculated property is true.

See Also

Column Class
FastReport.Data Namespace


Format Property

[image]

FastReport.Net Class Reference
Column..::.Format Property
Column Class See Also Send Feedback
Gets or sets the format of this column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As ColumnFormat
Visual C++
public:
property ColumnFormat Format {
    ColumnFormat get ();
    void set (ColumnFormat value);
}

Remarks

This property is used when you drag a column from the Data window to the report page. FastReport will create a "Text" object and set its "Format" property to the corresponding format. By default, this property is set to Auto. It means that the format will be determined automatically depending on the DataType property.

See Also

Column Class
FastReport.Data Namespace


PropDescriptor Property

[image]

FastReport.Net Class Reference
Column..::.PropDescriptor Property
Column Class See Also Send Feedback
Gets or sets the business object property descriptor which this column is bound to.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptor PropDescriptor { get; set; }
Visual Basic (Declaration)
Public Property PropDescriptor As PropertyDescriptor
Visual C++
public:
property PropertyDescriptor^ PropDescriptor {
    PropertyDescriptor^ get ();
    void set (PropertyDescriptor^ value);
}

See Also

Column Class
FastReport.Data Namespace


PropName Property

[image]

FastReport.Net Class Reference
Column..::.PropName Property
Column Class See Also Send Feedback
Gets or sets the business object property name which this column is bound to.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PropName { get; set; }
Visual Basic (Declaration)
Public Property PropName As String
Visual C++
public:
property String^ PropName {
    String^ get ();
    void set (String^ value);
}

See Also

Column Class
FastReport.Data Namespace


Column Events

[image] [image]

FastReport.Net Class Reference
Column Events
Column Class See Also Send Feedback

The Column type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Column Class
FastReport.Data Namespace


ColumnBindableControl Enumeration

[image]

FastReport.Net Class Reference
ColumnBindableControl Enumeration
See Also Send Feedback
Specifies the type of an object that will be created when you drop the data column on a report page.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ColumnBindableControl
Visual Basic (Declaration)
Public Enumeration ColumnBindableControl
Visual C++
public enum class ColumnBindableControl

Members

Member name | Description
Text | The column will create the TextObject object.
RichText | The column will create the RichObject object.
Picture | The column will create the PictureObject object.
CheckBox | The column will create the CheckBoxObject object.
Custom | The column will create the custom object, specified in the CustomBindableControl property.

See Also

FastReport.Data Namespace


ColumnCollection Class

[image]

FastReport.Net Class Reference
ColumnCollection Class
Members See Also Send Feedback
Represents the collection of Column objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColumnCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class ColumnCollection _
    Inherits FRCollectionBase
Visual C++
public ref class ColumnCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.ColumnCollection

See Also

ColumnCollection Members
FastReport.Data Namespace


ColumnCollection Members

[image] [image]

FastReport.Net Class Reference
ColumnCollection Members
ColumnCollection Class Constructors Methods Properties See Also Send Feedback

The ColumnCollection type exposes the following members.

Constructors

Name | Description
ColumnCollection | Initializes a new instance of the ColumnCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueAlias | Returns an unique column alias based on given alias.
CreateUniqueName | Returns an unique column name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByAlias | Finds a column by its alias.
FindByName | Finds a column by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a column.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ColumnCollection Class
FastReport.Data Namespace


ColumnCollection Constructor

[image]

FastReport.Net Class Reference
ColumnCollection Constructor
ColumnCollection Class See Also Send Feedback
Initializes a new instance of the ColumnCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
ColumnCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

ColumnCollection Class
FastReport.Data Namespace


ColumnCollection Methods

[image] [image]

FastReport.Net Class Reference
ColumnCollection Methods
ColumnCollection Class See Also Send Feedback

The ColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueAlias | Returns an unique column alias based on given alias.
CreateUniqueName | Returns an unique column name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByAlias | Finds a column by its alias.
FindByName | Finds a column by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
ColumnCollection..::.AddRange Method
ColumnCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

ColumnCollection Class
ColumnCollection Members
FastReport.Data Namespace


CreateUniqueAlias Method

[image]

FastReport.Net Class Reference
ColumnCollection..::.CreateUniqueAlias Method
ColumnCollection Class See Also Send Feedback
Returns an unique column alias based on given alias.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueAlias(
    string alias
)
Visual Basic (Declaration)
Public Function CreateUniqueAlias ( _
    alias As String _
) As String
Visual C++
public:
String^ CreateUniqueAlias(
    String^ alias
)

Parameters

alias
Type: System..::.String
The base alias.

Return Value

The unique alias.

See Also

ColumnCollection Class
FastReport.Data Namespace


CreateUniqueName Method

[image]

FastReport.Net Class Reference
ColumnCollection..::.CreateUniqueName Method
ColumnCollection Class See Also Send Feedback
Returns an unique column name based on given name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueName(
    string name
)
Visual Basic (Declaration)
Public Function CreateUniqueName ( _
    name As String _
) As String
Visual C++
public:
String^ CreateUniqueName(
    String^ name
)

Parameters

name
Type: System..::.String
The base name.

Return Value

The unique name.

See Also

ColumnCollection Class
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
ColumnCollection..::.Equals Method
ColumnCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

ColumnCollection Class
ColumnCollection Members
FastReport.Data Namespace


FindByAlias Method

[image]

FastReport.Net Class Reference
ColumnCollection..::.FindByAlias Method
ColumnCollection Class See Also Send Feedback
Finds a column by its alias.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Column FindByAlias(
    string alias
)
Visual Basic (Declaration)
Public Function FindByAlias ( _
    alias As String _
) As Column
Visual C++
public:
Column^ FindByAlias(
    String^ alias
)

Parameters

alias
Type: System..::.String
The alias of a column.

Return Value

The Column object if found; otherwise null.

See Also

ColumnCollection Class
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
ColumnCollection..::.FindByName Method
ColumnCollection Class See Also Send Feedback
Finds a column by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Column FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As Column
Visual C++
public:
Column^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The name of a column.

Return Value

The Column object if found; otherwise null.

See Also

ColumnCollection Class
FastReport.Data Namespace


ColumnCollection Properties

[image] [image]

FastReport.Net Class Reference
ColumnCollection Properties
ColumnCollection Class See Also Send Feedback

The ColumnCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a column.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ColumnCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
ColumnCollection..::.Item Property
ColumnCollection Class See Also Send Feedback
Gets or sets a column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Column this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Column
Visual C++
public:
property Column^ default[int index] {
    Column^ get (int index);
    void set (int index, Column^ value);
}

Parameters

index
Type: System..::.Int32
The index of a column in this collection.

Return Value

The column with specified index.

See Also

ColumnCollection Class
FastReport.Data Namespace


ColumnFormat Enumeration

[image]

FastReport.Net Class Reference
ColumnFormat Enumeration
See Also Send Feedback
Specifies the format for the column value.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ColumnFormat
Visual Basic (Declaration)
Public Enumeration ColumnFormat
Visual C++
public enum class ColumnFormat

Members

Member name | Description
Auto | The format will be determined automatically depending on the column's DataType.
General | Specifies the General format (no formatting).
Number | Specifies the Number format.
Currency | Specifies the Currency format.
Date | Specifies the Date format.
Time | Specifies the Time format.
Percent | Specifies the Percent format.
Boolean | Specifies the Boolean format.

See Also

FastReport.Data Namespace


CommandParameter Class

[image]

FastReport.Net Class Reference
CommandParameter Class
Members See Also Send Feedback
This class represents a single parameter to use in the "select" command.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CommandParameter : Base
Visual Basic (Declaration)
Public Class CommandParameter _
    Inherits Base
Visual C++
public ref class CommandParameter : public Base

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.CommandParameter

See Also

CommandParameter Members
FastReport.Data Namespace


CommandParameter Members

[image] [image]

FastReport.Net Class Reference
CommandParameter Members
CommandParameter Class Constructors Methods Properties Events See Also Send Feedback

The CommandParameter type exposes the following members.

Constructors

Name | Description
CommandParameter | Initializes a new instance of the CommandParameter class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from Base.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the parameter's data type.
DefaultValue | Gets or sets a default value for this parameter.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets an expression that returns the parameter's value.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the size of parameter's data.
Value | Gets or sets the parameter's value.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CommandParameter Class
FastReport.Data Namespace


CommandParameter Constructor

[image]

FastReport.Net Class Reference
CommandParameter Constructor
CommandParameter Class See Also Send Feedback
Initializes a new instance of the CommandParameter class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CommandParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommandParameter()

See Also

CommandParameter Class
FastReport.Data Namespace


CommandParameter Methods

[image] [image]

FastReport.Net Class Reference
CommandParameter Methods
CommandParameter Class See Also Send Feedback

The CommandParameter type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from Base.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CommandParameter Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CommandParameter..::.Dispose Method
CommandParameter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

CommandParameter Class
CommandParameter Members
FastReport.Data Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
CommandParameter..::.GetExpressions Method
CommandParameter Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

CommandParameter Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CommandParameter..::.MemberwiseClone Method
CommandParameter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CommandParameter Class
CommandParameter Members
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CommandParameter..::.Serialize Method
CommandParameter Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

CommandParameter Class
FastReport.Data Namespace


CommandParameter Properties

[image] [image]

FastReport.Net Class Reference
CommandParameter Properties
CommandParameter Class See Also Send Feedback

The CommandParameter type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the parameter's data type.
DefaultValue | Gets or sets a default value for this parameter.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets an expression that returns the parameter's value.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the size of parameter's data.
Value | Gets or sets the parameter's value.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CommandParameter Class
FastReport.Data Namespace


DataType Property

[image]

FastReport.Net Class Reference
CommandParameter..::.DataType Property
CommandParameter Class See Also Send Feedback
Gets or sets the parameter's data type.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Integer
Visual C++
public:
property int DataType {
    int get ();
    void set (int value);
}

See Also

CommandParameter Class
FastReport.Data Namespace


DefaultValue Property

[image]

FastReport.Net Class Reference
CommandParameter..::.DefaultValue Property
CommandParameter Class See Also Send Feedback
Gets or sets a default value for this parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As String
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This value is used when you designing a report. Also it is used when report is running in case if you don't provide a value for the Expression property.

See Also

CommandParameter Class
FastReport.Data Namespace


Expression Property

[image]

FastReport.Net Class Reference
CommandParameter..::.Expression Property
CommandParameter Class See Also Send Feedback
Gets or sets an expression that returns the parameter's value.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

If this property is not set, the DefaultValue property will be used to obtain a parameter's value.

See Also

CommandParameter Class
FastReport.Data Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
CommandParameter..::.Restrictions Property
CommandParameter Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

CommandParameter Class
FastReport.Data Namespace


Size Property

[image]

FastReport.Net Class Reference
CommandParameter..::.Size Property
CommandParameter Class See Also Send Feedback
Gets or sets the size of parameter's data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Integer
Visual C++
public:
property int Size {
    int get ();
    void set (int value);
}

Remarks

This property is used if the DataType property is set to String.

See Also

CommandParameter Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
CommandParameter..::.Value Property
CommandParameter Class See Also Send Feedback
Gets or sets the parameter's value.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

CommandParameter Class
FastReport.Data Namespace


CommandParameter Events

[image] [image]

FastReport.Net Class Reference
CommandParameter Events
CommandParameter Class See Also Send Feedback

The CommandParameter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CommandParameter Class
FastReport.Data Namespace


CommandParameterCollection Class

[image]

FastReport.Net Class Reference
CommandParameterCollection Class
Members See Also Send Feedback
Represents the collection of CommandParameter objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CommandParameterCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class CommandParameterCollection _
    Inherits FRCollectionBase
Visual C++
public ref class CommandParameterCollection : public FRCollectionBase

Remarks

This class is used to store the list of parameters defined in the datasource. See the Parameters property for more details.

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.CommandParameterCollection

See Also

CommandParameterCollection Members
FastReport.Data Namespace


CommandParameterCollection Members

[image] [image]

FastReport.Net Class Reference
CommandParameterCollection Members
CommandParameterCollection Class Constructors Methods Properties See Also Send Feedback

The CommandParameterCollection type exposes the following members.

Constructors

Name | Description
CommandParameterCollection | Initializes a new instance of the CommandParameterCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique parameter name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a parameter by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a parameter.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

CommandParameterCollection Class
FastReport.Data Namespace


CommandParameterCollection Constructor

[image]

FastReport.Net Class Reference
CommandParameterCollection Constructor
CommandParameterCollection Class See Also Send Feedback
Initializes a new instance of the CommandParameterCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CommandParameterCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
CommandParameterCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

CommandParameterCollection Class
FastReport.Data Namespace


CommandParameterCollection Methods

[image] [image]

FastReport.Net Class Reference
CommandParameterCollection Methods
CommandParameterCollection Class See Also Send Feedback

The CommandParameterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique parameter name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a parameter by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommandParameterCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
CommandParameterCollection..::.AddRange Method
CommandParameterCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

CommandParameterCollection Class
CommandParameterCollection Members
FastReport.Data Namespace


CreateUniqueName Method

[image]

FastReport.Net Class Reference
CommandParameterCollection..::.CreateUniqueName Method
CommandParameterCollection Class See Also Send Feedback
Returns an unique parameter name based on given name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueName(
    string name
)
Visual Basic (Declaration)
Public Function CreateUniqueName ( _
    name As String _
) As String
Visual C++
public:
String^ CreateUniqueName(
    String^ name
)

Parameters

name
Type: System..::.String
The base name.

Return Value

The unique name.

See Also

CommandParameterCollection Class
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
CommandParameterCollection..::.Equals Method
CommandParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

CommandParameterCollection Class
CommandParameterCollection Members
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
CommandParameterCollection..::.FindByName Method
CommandParameterCollection Class See Also Send Feedback
Finds a parameter by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CommandParameter FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As CommandParameter
Visual C++
public:
CommandParameter^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The name of a parameter.

Return Value

The CommandParameter object if found; otherwise null.

See Also

CommandParameterCollection Class
FastReport.Data Namespace


CommandParameterCollection Properties

[image] [image]

FastReport.Net Class Reference
CommandParameterCollection Properties
CommandParameterCollection Class See Also Send Feedback

The CommandParameterCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a parameter.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

CommandParameterCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
CommandParameterCollection..::.Item Property
CommandParameterCollection Class See Also Send Feedback
Gets or sets a parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CommandParameter this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As CommandParameter
Visual C++
public:
property CommandParameter^ default[int index] {
    CommandParameter^ get (int index);
    void set (int index, CommandParameter^ value);
}

Parameters

index
Type: System..::.Int32
The index of a parameter in this collection.

Return Value

The parameter with specified index.

See Also

CommandParameterCollection Class
FastReport.Data Namespace


ConnectionCollection Class

[image]

FastReport.Net Class Reference
ConnectionCollection Class
Members See Also Send Feedback
Represents the collection of DataConnectionBase objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ConnectionCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class ConnectionCollection _
    Inherits FRCollectionBase
Visual C++
public ref class ConnectionCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.ConnectionCollection

See Also

ConnectionCollection Members
FastReport.Data Namespace


ConnectionCollection Members

[image] [image]

FastReport.Net Class Reference
ConnectionCollection Members
ConnectionCollection Class Constructors Methods Properties See Also Send Feedback

The ConnectionCollection type exposes the following members.

Constructors

Name | Description
ConnectionCollection | Initializes a new instance of the ConnectionCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a data connection.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ConnectionCollection Class
FastReport.Data Namespace


ConnectionCollection Constructor

[image]

FastReport.Net Class Reference
ConnectionCollection Constructor
ConnectionCollection Class See Also Send Feedback
Initializes a new instance of the ConnectionCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ConnectionCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
ConnectionCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

ConnectionCollection Class
FastReport.Data Namespace


ConnectionCollection Methods

[image] [image]

FastReport.Net Class Reference
ConnectionCollection Methods
ConnectionCollection Class See Also Send Feedback

The ConnectionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectionCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
ConnectionCollection..::.AddRange Method
ConnectionCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

ConnectionCollection Class
ConnectionCollection Members
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
ConnectionCollection..::.Equals Method
ConnectionCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

ConnectionCollection Class
ConnectionCollection Members
FastReport.Data Namespace


ConnectionCollection Properties

[image] [image]

FastReport.Net Class Reference
ConnectionCollection Properties
ConnectionCollection Class See Also Send Feedback

The ConnectionCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a data connection.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ConnectionCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
ConnectionCollection..::.Item Property
ConnectionCollection Class See Also Send Feedback
Gets or sets a data connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataConnectionBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As DataConnectionBase
Visual C++
public:
property DataConnectionBase^ default[int index] {
    DataConnectionBase^ get (int index);
    void set (int index, DataConnectionBase^ value);
}

Parameters

index
Type: System..::.Int32
The index of a data connection in this collection.

Return Value

The data connection with specified index.

See Also

ConnectionCollection Class
FastReport.Data Namespace


CopyNameMacroVariable Class

[image]

FastReport.Net Class Reference
CopyNameMacroVariable Class
Members See Also Send Feedback
Returns the name of the printed copy.

This variable is actually a macro. Its value is substituted when the component is viewed in the preview window. That means you cannot use it in an expression.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CopyNameMacroVariable : SystemVariable
Visual Basic (Declaration)
Public Class CopyNameMacroVariable _
    Inherits SystemVariable
Visual C++
public ref class CopyNameMacroVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.CopyNameMacroVariable

See Also

CopyNameMacroVariable Members
FastReport.Data Namespace


CopyNameMacroVariable Members

[image] [image]

FastReport.Net Class Reference
CopyNameMacroVariable Members
CopyNameMacroVariable Class Methods Properties Events See Also Send Feedback

The CopyNameMacroVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CopyNameMacroVariable Class
FastReport.Data Namespace


CopyNameMacroVariable Methods

[image] [image]

FastReport.Net Class Reference
CopyNameMacroVariable Methods
CopyNameMacroVariable Class See Also Send Feedback

The CopyNameMacroVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

CopyNameMacroVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CopyNameMacroVariable..::.Dispose Method
CopyNameMacroVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

CopyNameMacroVariable Class
CopyNameMacroVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CopyNameMacroVariable..::.MemberwiseClone Method
CopyNameMacroVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CopyNameMacroVariable Class
CopyNameMacroVariable Members
FastReport.Data Namespace


CopyNameMacroVariable Properties

[image] [image]

FastReport.Net Class Reference
CopyNameMacroVariable Properties
CopyNameMacroVariable Class See Also Send Feedback

The CopyNameMacroVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CopyNameMacroVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
CopyNameMacroVariable..::.Value Property
CopyNameMacroVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

CopyNameMacroVariable Class
FastReport.Data Namespace


CopyNameMacroVariable Events

[image] [image]

FastReport.Net Class Reference
CopyNameMacroVariable Events
CopyNameMacroVariable Class See Also Send Feedback

The CopyNameMacroVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CopyNameMacroVariable Class
FastReport.Data Namespace


DataComponentBase Class

[image]

FastReport.Net Class Reference
DataComponentBase Class
Members See Also Send Feedback
The base class for all data components such as data sources, columns.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataComponentBase : Base
Visual Basic (Declaration)
Public Class DataComponentBase _
    Inherits Base
Visual C++
public ref class DataComponentBase : public Base

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Column
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.Relation

See Also

DataComponentBase Members
FastReport.Data Namespace


DataComponentBase Members

[image] [image]

FastReport.Net Class Reference
DataComponentBase Members
DataComponentBase Class Constructors Methods Properties Events See Also Send Feedback

The DataComponentBase type exposes the following members.

Constructors

Name | Description
DataComponentBase | Initializes a new instance of the DataComponentBase class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides Base..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Overrides Base..::.SetName(String).)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
Alias | Gets or sets alias of this object.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object.
ReferenceName | Gets or sets a name of the data object.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DataComponentBase Class
FastReport.Data Namespace


DataComponentBase Constructor

[image]

FastReport.Net Class Reference
DataComponentBase Constructor
DataComponentBase Class See Also Send Feedback
Initializes a new instance of the DataComponentBase class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataComponentBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataComponentBase()

See Also

DataComponentBase Class
FastReport.Data Namespace


DataComponentBase Methods

[image] [image]

FastReport.Net Class Reference
DataComponentBase Methods
DataComponentBase Class See Also Send Feedback

The DataComponentBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides Base..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Overrides Base..::.SetName(String).)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DataComponentBase Class
FastReport.Data Namespace


Assign Method

[image]

FastReport.Net Class Reference
DataComponentBase..::.Assign Method
DataComponentBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

DataComponentBase Class
FastReport.Data Namespace
AssignAll Method


Delete Method

[image]

FastReport.Net Class Reference
DataComponentBase..::.Delete Method
DataComponentBase Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

DataComponentBase Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataComponentBase..::.Dispose Method
DataComponentBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DataComponentBase Class
DataComponentBase Members
FastReport.Data Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
DataComponentBase..::.InitializeComponent Method
DataComponentBase Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void InitializeComponent()
Visual Basic (Declaration)
Public Overridable Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent()

Remarks

This method is used by the report engine, do not call it directly.

See Also

DataComponentBase Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataComponentBase..::.MemberwiseClone Method
DataComponentBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataComponentBase Class
DataComponentBase Members
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DataComponentBase..::.Serialize Method
DataComponentBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DataComponentBase Class
FastReport.Data Namespace


SetName Method

[image]

FastReport.Net Class Reference
DataComponentBase..::.SetName Method
DataComponentBase Class See Also Send Feedback
Sets the object's name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetName(
    string value
)
Visual Basic (Declaration)
Public Overrides Sub SetName ( _
    value As String _
)
Visual C++
public:
virtual void SetName(
    String^ value
) override

Parameters

value
Type: System..::.String
New name.

Remarks

This method is for internal use only. It just sets a new name without any checks (unlike the Name property setter).

See Also

DataComponentBase Class
FastReport.Data Namespace
Name Property


DataComponentBase Properties

[image] [image]

FastReport.Net Class Reference
DataComponentBase Properties
DataComponentBase Class See Also Send Feedback

The DataComponentBase type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object.
ReferenceName | Gets or sets a name of the data object.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataComponentBase Class
FastReport.Data Namespace


Alias Property

[image]

FastReport.Net Class Reference
DataComponentBase..::.Alias Property
DataComponentBase Class See Also Send Feedback
Gets or sets alias of this object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Alias { get; set; }
Visual Basic (Declaration)
Public Property Alias As String
Visual C++
public:
property String^ Alias {
    String^ get ();
    void set (String^ value);
}

Remarks

Alias is a human-friendly name of this object. It may contain any symbols (including spaces and national symbols).

See Also

DataComponentBase Class
FastReport.Data Namespace


Enabled Property

[image]

FastReport.Net Class Reference
DataComponentBase..::.Enabled Property
DataComponentBase Class See Also Send Feedback
Gets or sets a value indicates that object is enabled and thus can be used in a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to hide an object from the Data Dictionary window. Hidden objects are still accessible in the "Data|Choose Data Source..." menu.

See Also

DataComponentBase Class
FastReport.Data Namespace


IsAliased Property

[image]

FastReport.Net Class Reference
DataComponentBase..::.IsAliased Property
DataComponentBase Class See Also Send Feedback
Gets a value indicates that this object has an alias.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsAliased { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAliased As Boolean
Visual C++
public:
property bool IsAliased {
    bool get ();
}

See Also

DataComponentBase Class
FastReport.Data Namespace


Reference Property

[image]

FastReport.Net Class Reference
DataComponentBase..::.Reference Property
DataComponentBase Class See Also Send Feedback
Gets or sets a reference to the data object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Reference { get; set; }
Visual Basic (Declaration)
Public Property Reference As Object
Visual C++
public:
property Object^ Reference {
    Object^ get ();
    void set (Object^ value);
}

Remarks

This property is used to support FastReport.Net infrastructure. Do not use it directly.

See Also

DataComponentBase Class
FastReport.Data Namespace


ReferenceName Property

[image]

FastReport.Net Class Reference
DataComponentBase..::.ReferenceName Property
DataComponentBase Class See Also Send Feedback
Gets or sets a name of the data object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReferenceName { get; set; }
Visual Basic (Declaration)
Public Property ReferenceName As String
Visual C++
public:
property String^ ReferenceName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to support FastReport.Net infrastructure. Do not use it directly.

See Also

DataComponentBase Class
FastReport.Data Namespace


DataComponentBase Events

[image] [image]

FastReport.Net Class Reference
DataComponentBase Events
DataComponentBase Class See Also Send Feedback

The DataComponentBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DataComponentBase Class
FastReport.Data Namespace


DataConnectionBase Class

[image]

FastReport.Net Class Reference
DataConnectionBase Class
Members Example See Also Send Feedback
The base class for all data connection components such as MsSqlDataConnection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class DataConnectionBase : DataComponentBase,
    IParent, IHasEditor
Visual Basic (Declaration)
Public MustInherit Class DataConnectionBase _
    Inherits DataComponentBase _
    Implements IParent, IHasEditor
Visual C++
public ref class DataConnectionBase abstract : public DataComponentBase,
    IParent, IHasEditor

Examples

This example shows how to add a new MS Access connection to the report.
CopyC#
Report report1;
MsAccessDataConnection conn = new MsAccessDataConnection();
conn.DataSource = @"c:\data.mdb";
report1.Dictionary.Connections.Add(conn);
conn.CreateAllTables();

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.MsAccessDataConnection
FastReport.Data..::.MsSqlDataConnection
FastReport.Data..::.OdbcDataConnection
FastReport.Data..::.OleDbDataConnection
FastReport.Data..::.XmlDataConnection

See Also

DataConnectionBase Members
FastReport.Data Namespace


DataConnectionBase Members

[image] [image]

FastReport.Net Class Reference
DataConnectionBase Members
DataConnectionBase Class Constructors Methods Properties Events See Also Send Feedback

The DataConnectionBase type exposes the following members.

Constructors

Name | Description
DataConnectionBase | Initializes a new instance of the DataConnectionBase class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only.
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides DataComponentBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection.
DisposeDataSet | Disposes a DataSet.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data.
FillTableSchema | Fills the table schema.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetConnection | Returns a connection object.
GetConnectionId | Gets a string that will identify a connection in the Data Wizard.
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified.
GetConnectionType | Returns a type of connection.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter.
GetEditor | Gets a control that will be used to edit the connection properties.
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object.
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name.
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetConnectionString | Sets the connection string.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds.
ConnectionString | Gets or sets a connection string that contains all connection parameters.
ConnectionStringExpression | Gets or sets an expression that returns a connection string.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based.
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DataConnectionBase Class
FastReport.Data Namespace


DataConnectionBase Constructor

[image]

FastReport.Net Class Reference
DataConnectionBase Constructor
DataConnectionBase Class See Also Send Feedback
Initializes a new instance of the DataConnectionBase class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataConnectionBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataConnectionBase()

See Also

DataConnectionBase Class
FastReport.Data Namespace


DataConnectionBase Methods

[image] [image]

FastReport.Net Class Reference
DataConnectionBase Methods
DataConnectionBase Class See Also Send Feedback

The DataConnectionBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only.
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Overrides DataComponentBase..::.Delete()()().)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection.
DisposeDataSet | Disposes a DataSet.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data.
FillTableSchema | Fills the table schema.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetConnection | Returns a connection object.
GetConnectionId | Gets a string that will identify a connection in the Data Wizard.
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified.
GetConnectionType | Returns a type of connection.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter.
GetEditor | Gets a control that will be used to edit the connection properties.
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object.
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name.
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetConnectionString | Sets the connection string.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

DataConnectionBase Class
FastReport.Data Namespace


AddChild Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.AddChild Method
DataConnectionBase Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

DataConnectionBase Class
FastReport.Data Namespace


CanContain Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.CanContain Method
DataConnectionBase Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

DataConnectionBase Class
FastReport.Data Namespace


CreateAllTables Method

[image] [image]

FastReport.Net Class Reference
DataConnectionBase..::.CreateAllTables Method
DataConnectionBase Class See Also Send Feedback

Overload List

Name | Description
CreateAllTables()()() | Fills the Tables collection with all tables available in the database.
CreateAllTables(Boolean) | Fills the Tables collection with all tables available in the database.

See Also

DataConnectionBase Class
DataConnectionBase Members
FastReport.Data Namespace


CreateAllTables Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.CreateAllTables Method
DataConnectionBase Class See Also Send Feedback
Fills the Tables collection with all tables available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateAllTables()
Visual Basic (Declaration)
Public Sub CreateAllTables
Visual C++
public:
void CreateAllTables()

Remarks

This method does not read the table data; to do this, call the LoadData(ArrayList) method of each table.

See Also

DataConnectionBase Class
CreateAllTables Overload
FastReport.Data Namespace


CreateAllTables Method (Boolean)

[image]

FastReport.Net Class Reference
DataConnectionBase..::.CreateAllTables Method (Boolean)
DataConnectionBase Class See Also Send Feedback
Fills the Tables collection with all tables available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateAllTables(
    bool initSchema
)
Visual Basic (Declaration)
Public Sub CreateAllTables ( _
    initSchema As Boolean _
)
Visual C++
public:
void CreateAllTables(
    bool initSchema
)

Parameters

initSchema
Type: System..::.Boolean
Set to true to initialize each table's schema.

See Also

DataConnectionBase Class
CreateAllTables Overload
FastReport.Data Namespace


CreateDataSet Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.CreateDataSet Method
DataConnectionBase Class See Also Send Feedback
Initializes a DataSet instance.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual DataSet CreateDataSet()
Visual Basic (Declaration)
Protected Overridable Function CreateDataSet As DataSet
Visual C++
protected:
virtual DataSet^ CreateDataSet()

Return Value

The DataSet object.

Remarks

This method is used to support FastReport infrastructure. You don't need to use it.

See Also

DataConnectionBase Class
FastReport.Data Namespace


CreateRelations Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.CreateRelations Method
DataConnectionBase Class See Also Send Feedback
Creates the relations between tables. Applies to XmlDataConnection only.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateRelations()
Visual Basic (Declaration)
Public Sub CreateRelations
Visual C++
public:
void CreateRelations()

See Also

DataConnectionBase Class
FastReport.Data Namespace


Delete Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.Delete Method
DataConnectionBase Class See Also Send Feedback
Deletes the object in the designer.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Delete()
Visual Basic (Declaration)
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

Remarks

This method is called when you delete the object in the designer.

Typically this method calls the Dispose(Boolean) method to delete the object and all its children. You may override it to delete the object only, and keep children.

See Also

DataConnectionBase Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataConnectionBase..::.Dispose Method
DataConnectionBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

DataConnectionBase Class
DataConnectionBase Members
FastReport.Data Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DataConnectionBase..::.Dispose Method (Boolean)
DataConnectionBase Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

DataConnectionBase Class
Dispose Overload
FastReport.Data Namespace


DisposeConnection Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.DisposeConnection Method
DataConnectionBase Class See Also Send Feedback
Disposes a connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DisposeConnection(
    DbConnection connection
)
Visual Basic (Declaration)
Public Sub DisposeConnection ( _
    connection As DbConnection _
)
Visual C++
public:
void DisposeConnection(
    DbConnection^ connection
)

Parameters

connection
Type: System.Data.Common..::.DbConnection
The connection to dispose.

See Also

DataConnectionBase Class
FastReport.Data Namespace


DisposeDataSet Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.DisposeDataSet Method
DataConnectionBase Class See Also Send Feedback
Disposes a DataSet.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void DisposeDataSet()
Visual Basic (Declaration)
Protected Sub DisposeDataSet
Visual C++
protected:
void DisposeDataSet()

Remarks

This method is used to support FastReport infrastructure. You don't need to use it.

See Also

DataConnectionBase Class
FastReport.Data Namespace


FillTableData Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.FillTableData Method
DataConnectionBase Class See Also Send Feedback
Fills the table data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void FillTableData(
    DataTable table,
    string selectCommand,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overridable Sub FillTableData ( _
    table As DataTable, _
    selectCommand As String, _
    parameters As CommandParameterCollection _
)
Visual C++
public:
virtual void FillTableData(
    DataTable^ table,
    String^ selectCommand,
    CommandParameterCollection^ parameters
)

Parameters

table
Type: System.Data..::.DataTable
DataTable to fill.
selectCommand
Type: System..::.String
The SQL select command.
parameters
Type: FastReport.Data..::.CommandParameterCollection
SQL parameters.

Remarks

Usually you don't need to use this method. Internally it uses the GetConnection()()() and GetAdapter(String, DbConnection, CommandParameterCollection) methods to fill the table data. If you create own connection component that does not use nor connection or adapter, then you need to override this method.

See Also

DataConnectionBase Class
FastReport.Data Namespace


FillTableSchema Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.FillTableSchema Method
DataConnectionBase Class See Also Send Feedback
Fills the table schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void FillTableSchema(
    DataTable table,
    string selectCommand,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overridable Sub FillTableSchema ( _
    table As DataTable, _
    selectCommand As String, _
    parameters As CommandParameterCollection _
)
Visual C++
public:
virtual void FillTableSchema(
    DataTable^ table,
    String^ selectCommand,
    CommandParameterCollection^ parameters
)

Parameters

table
Type: System.Data..::.DataTable
DataTable to fill.
selectCommand
Type: System..::.String
The SQL select command.
parameters
Type: FastReport.Data..::.CommandParameterCollection
SQL parameters.

Remarks

Usually you don't need to use this method. Internally it uses the GetConnection()()() and GetAdapter(String, DbConnection, CommandParameterCollection) methods to fill the table schema. If you create own connection component that does not use nor connection or adapter, then you need to override this method.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetAdapter Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetAdapter Method
DataConnectionBase Class Example See Also Send Feedback
Returns a DbDataAdapter object that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual DbDataAdapter GetAdapter(
    string selectCommand,
    DbConnection connection,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overridable Function GetAdapter ( _
    selectCommand As String, _
    connection As DbConnection, _
    parameters As CommandParameterCollection _
) As DbDataAdapter
Visual C++
public:
virtual DbDataAdapter^ GetAdapter(
    String^ selectCommand,
    DbConnection^ connection,
    CommandParameterCollection^ parameters
)

Parameters

selectCommand
Type: System..::.String
The SQL command used to fetch a table data rows.
connection
Type: System.Data.Common..::.DbConnection
The connection object.
parameters
Type: FastReport.Data..::.CommandParameterCollection
The select command parameters.

Return Value

The DbDataAdapter object.

Remarks

You should override this method if you are developing a new connection component. In this method, you need to create the adapter and set its SelectCommand's parameters.

If your connection does not use data adapter, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override DbDataAdapter GetAdapter(string selectCommand, DbConnection connection,
  CommandParameterCollection parameters)
{
  OleDbDataAdapter adapter = new OleDbDataAdapter(selectCommand, connection as OleDbConnection);
  foreach (CommandParameter p in parameters)
  {
    OleDbParameter parameter = adapter.SelectCommand.Parameters.Add(p.Name, (OleDbType)p.DataType, p.Size);
    parameter.Value = p.Value;
  }
  return adapter;
}

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetChildObjects Method
DataConnectionBase Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetChildOrder Method
DataConnectionBase Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetConnection Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetConnection Method
DataConnectionBase Class See Also Send Feedback
Returns a connection object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DbConnection GetConnection()
Visual Basic (Declaration)
Public Function GetConnection As DbConnection
Visual C++
public:
DbConnection^ GetConnection()

Return Value

The DbConnection instance.

Remarks

Either creates a new DbConnection instance of type provided by the GetConnectionType()()() method, or returns the application connection if set in the Config.DesignerSettings.ApplicationConnection.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetConnectionId Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetConnectionId Method
DataConnectionBase Class See Also Send Feedback
Gets a string that will identify a connection in the Data Wizard.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string GetConnectionId()
Visual Basic (Declaration)
Public Overridable Function GetConnectionId As String
Visual C++
public:
virtual String^ GetConnectionId()

Return Value

The string that contains the connection type and some meaningful information.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetConnectionStringWithLoginInfo Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetConnectionStringWithLoginInfo Method
DataConnectionBase Class See Also Send Feedback
Gets a connection string that contains username and password specified.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual string GetConnectionStringWithLoginInfo(
    string userName,
    string password
)
Visual Basic (Declaration)
Protected Overridable Function GetConnectionStringWithLoginInfo ( _
    userName As String, _
    password As String _
) As String
Visual C++
protected:
virtual String^ GetConnectionStringWithLoginInfo(
    String^ userName,
    String^ password
)

Parameters

userName
Type: System..::.String
User name.
password
Type: System..::.String
Password.

Remarks

Override this method to pass login information to the connection. Typical implementation must get the existing ConnectionString, merge specified login information into it and return the new value.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetConnectionType Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetConnectionType Method
DataConnectionBase Class Example See Also Send Feedback
Returns a type of connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Type GetConnectionType()
Visual Basic (Declaration)
Public Overridable Function GetConnectionType As Type
Visual C++
public:
virtual Type^ GetConnectionType()

Return Value

Type instance.

Remarks

You should override this method if you developing a new connection component.

If your connection component does not use data connection, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override Type GetConnectionType()
{
  return typeof(OleDbConnection);
}

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetDefaultParameterType Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetDefaultParameterType Method
DataConnectionBase Class See Also Send Feedback
Gets the default type for a new parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int GetDefaultParameterType()
Visual Basic (Declaration)
Public Overridable Function GetDefaultParameterType As Integer
Visual C++
public:
virtual int GetDefaultParameterType()

Return Value

The integer representation of a parameter type.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetEditor Method
DataConnectionBase Class See Also Send Feedback
Gets a control that will be used to edit the connection properties.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual ConnectionEditorBase GetEditor()
Visual Basic (Declaration)
Public Overridable Function GetEditor As ConnectionEditorBase
Visual C++
public:
virtual ConnectionEditorBase^ GetEditor()

Return Value

The editor's control.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetExpressions Method
DataConnectionBase Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetParameterType Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetParameterType Method
DataConnectionBase Class See Also Send Feedback
Gets the type of parameter that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Type GetParameterType()
Visual Basic (Declaration)
Public Overridable Function GetParameterType As Type
Visual C++
public:
virtual Type^ GetParameterType()

Return Value

The parameter's type.

Remarks

This property is used in the report designer to display available data types when you edit the connection parameters. For example, the type of OleDbConnection parameter is a OleDbType.

See Also

DataConnectionBase Class
FastReport.Data Namespace


GetTableNames Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.GetTableNames Method
DataConnectionBase Class See Also Send Feedback
Gets an array of table names available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string[] GetTableNames()
Visual Basic (Declaration)
Public Overridable Function GetTableNames As String()
Visual C++
public:
virtual array<String^>^ GetTableNames()

Return Value

An array of strings.

See Also

DataConnectionBase Class
FastReport.Data Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.InvokeEditor Method
DataConnectionBase Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

DataConnectionBase Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataConnectionBase..::.MemberwiseClone Method
DataConnectionBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataConnectionBase Class
DataConnectionBase Members
FastReport.Data Namespace


OpenConnection Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.OpenConnection Method
DataConnectionBase Class See Also Send Feedback
Opens a specified connection object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OpenConnection(
    DbConnection connection
)
Visual Basic (Declaration)
Public Sub OpenConnection ( _
    connection As DbConnection _
)
Visual C++
public:
void OpenConnection(
    DbConnection^ connection
)

Parameters

connection
Type: System.Data.Common..::.DbConnection
Connection to open.

Remarks

Use this method to open a connection returned by the GetConnection()()() method.

This method displays a login dialog if your connection has the LoginPrompt property set to true. Once you have entered an user name and password in this dialog, it will remeber the entered values and will not used anymore in this report session.

See Also

DataConnectionBase Class
FastReport.Data Namespace


QuoteIdentifier Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.QuoteIdentifier Method
DataConnectionBase Class See Also Send Feedback
Quotes the specified DB identifier such as table name or column name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract string QuoteIdentifier(
    string value,
    DbConnection connection
)
Visual Basic (Declaration)
Public MustOverride Function QuoteIdentifier ( _
    value As String, _
    connection As DbConnection _
) As String
Visual C++
public:
virtual String^ QuoteIdentifier(
    String^ value,
    DbConnection^ connection
) abstract

Parameters

value
Type: System..::.String
Identifier to quote.
connection
Type: System.Data.Common..::.DbConnection
The opened DB connection.

Return Value

The quoted identifier.

See Also

DataConnectionBase Class
FastReport.Data Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.RemoveChild Method
DataConnectionBase Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

DataConnectionBase Class
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.Serialize Method
DataConnectionBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DataConnectionBase Class
FastReport.Data Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.SetChildOrder Method
DataConnectionBase Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

DataConnectionBase Class
FastReport.Data Namespace


SetConnectionString Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.SetConnectionString Method
DataConnectionBase Class See Also Send Feedback
Sets the connection string.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void SetConnectionString(
    string value
)
Visual Basic (Declaration)
Protected Overridable Sub SetConnectionString ( _
    value As String _
)
Visual C++
protected:
virtual void SetConnectionString(
    String^ value
)

Parameters

value
Type: System..::.String
New connection string.

Remarks

Use this method if you need to perform some actions when the connection string is set.

See Also

DataConnectionBase Class
FastReport.Data Namespace


TestConnection Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.TestConnection Method
DataConnectionBase Class See Also Send Feedback
Tests the connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void TestConnection()
Visual Basic (Declaration)
Public Overridable Sub TestConnection
Visual C++
public:
virtual void TestConnection()

Remarks

If test connection is not successful, this method throws an exception. Catch this exception to show an error message.

See Also

DataConnectionBase Class
FastReport.Data Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
DataConnectionBase..::.UpdateLayout Method
DataConnectionBase Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

DataConnectionBase Class
FastReport.Data Namespace


DataConnectionBase Properties

[image] [image]

FastReport.Net Class Reference
DataConnectionBase Properties
DataConnectionBase Class See Also Send Feedback

The DataConnectionBase type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds.
ConnectionString | Gets or sets a connection string that contains all connection parameters.
ConnectionStringExpression | Gets or sets an expression that returns a connection string.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based.
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataConnectionBase Class
FastReport.Data Namespace


CommandTimeout Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.CommandTimeout Property
DataConnectionBase Class See Also Send Feedback
Gets or sets the command timeout, in seconds.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CommandTimeout { get; set; }
Visual Basic (Declaration)
Public Property CommandTimeout As Integer
Visual C++
public:
property int CommandTimeout {
    int get ();
    void set (int value);
}

See Also

DataConnectionBase Class
FastReport.Data Namespace


ConnectionString Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.ConnectionString Property
DataConnectionBase Class Example See Also Send Feedback
Gets or sets a connection string that contains all connection parameters.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Remarks

To modify some parameter of the connection, use respective ConnectionStringBuilder class.

Security note: the connection string may contain a user name/password. This information is stored in a report file. By default, it is crypted using the standard FastReport's password. Since FastReport's source code is available to anyone who paid for it, it may be insecure to use the standard password. For more security, you should use own password. To do this, specify it in the Crypter.DefaultPassword property.

Examples

This example demonstrates how to change a connection string:
CopyC#
OleDbConnectionStringBuilder builder = new OleDbConnectionStringBuilder(oleDbConnection1.ConnectionString);
builder.PersistSecurityInfo = false;
oleDbConnection1.ConnectionString = builder.ToString();

See Also

DataConnectionBase Class
FastReport.Data Namespace


ConnectionStringExpression Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.ConnectionStringExpression Property
DataConnectionBase Class See Also Send Feedback
Gets or sets an expression that returns a connection string.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ConnectionStringExpression { get; set; }
Visual Basic (Declaration)
Public Property ConnectionStringExpression As String
Visual C++
public:
property String^ ConnectionStringExpression {
    String^ get ();
    void set (String^ value);
}

Remarks

Use this property to set the connection string dynamically.

The recommended way to do this is to define a report parameter. You can do this in the "Data" window. Once you have defined the parameter, you can use it to pass a value to the connection. Set the ConnectionStringExpression property of the connection object to the report parameter's name (so it will look like [myReportParam]). To pass a value to the report parameter from your application, use the SetParameterValue(String, Object) method.

Note: Once you set value for this property, the ConnectionString property will be ignored when report is run.

See Also

DataConnectionBase Class
FastReport.Data Namespace


DataSet Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.DataSet Property
DataConnectionBase Class See Also Send Feedback
Gets an internal DataSet object that contains all data tables.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSet DataSet { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSet As DataSet
Visual C++
public:
property DataSet^ DataSet {
    DataSet^ get ();
}

See Also

DataConnectionBase Class
FastReport.Data Namespace


IsSqlBased Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.IsSqlBased Property
DataConnectionBase Class See Also Send Feedback
Gets or sets a value indicates if this connection is SQL-based.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsSqlBased { get; set; }
Visual Basic (Declaration)
Public Property IsSqlBased As Boolean
Visual C++
public:
property bool IsSqlBased {
    bool get ();
    void set (bool value);
}

See Also

DataConnectionBase Class
FastReport.Data Namespace


LoginPrompt Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.LoginPrompt Property
DataConnectionBase Class See Also Send Feedback
Gets or sets a value indicating whether a login dialog appears immediately before opening a connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool LoginPrompt { get; set; }
Visual Basic (Declaration)
Public Property LoginPrompt As Boolean
Visual C++
public:
property bool LoginPrompt {
    bool get ();
    void set (bool value);
}

Remarks

Set LoginPrompt to true to provide login dialog when establishing a connection. If this property is false (by default), you should provide login information (user name and password) in the ConnectionString property. Though that property is stored in a crypted form, this may be insecure.

Another way to pass login information to the connection is to use ConnectionStringExpression property that is bound to the report parameter. In that case you supply the entire connection string from your application.

See Also

DataConnectionBase Class
FastReport.Data Namespace


Tables Property

[image]

FastReport.Net Class Reference
DataConnectionBase..::.Tables Property
DataConnectionBase Class See Also Send Feedback
Gets a collection of data tables in this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCollection Tables { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tables As TableCollection
Visual C++
public:
property TableCollection^ Tables {
    TableCollection^ get ();
}

Remarks

To add a table to the connection, you must either create a new TableDataSource and add it to this collection or call the CreateAllTables()()() method which will add all tables available in the database.

See Also

DataConnectionBase Class
FastReport.Data Namespace


DataConnectionBase Events

[image] [image]

FastReport.Net Class Reference
DataConnectionBase Events
DataConnectionBase Class See Also Send Feedback

The DataConnectionBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DataConnectionBase Class
FastReport.Data Namespace


DataSourceBase Class

[image]

FastReport.Net Class Reference
DataSourceBase Class
Members See Also Send Feedback
Base class for all datasources such as TableDataSource.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class DataSourceBase : Column
Visual Basic (Declaration)
Public MustInherit Class DataSourceBase _
    Inherits Column
Visual C++
public ref class DataSourceBase abstract : public Column

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Column
FastReport.Data..::.DataSourceBase
FastReport.Data..::.BusinessObjectDataSource
FastReport.Data..::.TableDataSource
FastReport.Data..::.ViewDataSource

See Also

DataSourceBase Members
FastReport.Data Namespace


DataSourceBase Members

[image] [image]

FastReport.Net Class Reference
DataSourceBase Members
DataSourceBase Class Constructors Methods Properties Events See Also Send Feedback

The DataSourceBase type exposes the following members.

Constructors

Name | Description
DataSourceBase | Initializes a new instance of the DataSourceBase class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Column.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from Column.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row.
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Column.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Overrides DataComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema.
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data.
MemberwiseClone | Overloaded.
Next | Navigates to the next row.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row.
RemoveChild | Removes a specified object from this object's childs. (Inherited from Column.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Column..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class.
Calculated | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row.
CurrentRowNo | Gets an index of current data row.
CustomBindableControl | This property is not relevant to this class.
DataType | This property is not relevant to this class.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource.
Format | This property is not relevant to this class.
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount.
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data.

See Also

DataSourceBase Class
FastReport.Data Namespace


DataSourceBase Constructor

[image]

FastReport.Net Class Reference
DataSourceBase Constructor
DataSourceBase Class See Also Send Feedback
Initializes a new instance of the DataSourceBase class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataSourceBase()

See Also

DataSourceBase Class
FastReport.Data Namespace


DataSourceBase Methods

[image] [image]

FastReport.Net Class Reference
DataSourceBase Methods
DataSourceBase Class See Also Send Feedback

The DataSourceBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Column.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from Column.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row.
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Column.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Overrides DataComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema.
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data.
MemberwiseClone | Overloaded.
Next | Navigates to the next row.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row.
RemoveChild | Removes a specified object from this object's childs. (Inherited from Column.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Column..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

See Also

DataSourceBase Class
FastReport.Data Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.Deserialize Method
DataSourceBase Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

DataSourceBase Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataSourceBase..::.Dispose Method
DataSourceBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DataSourceBase Class
DataSourceBase Members
FastReport.Data Namespace


EnsureInit Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.EnsureInit Method
DataSourceBase Class See Also Send Feedback
Initializes the data source if it is not initialized yet.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EnsureInit()
Visual Basic (Declaration)
Public Sub EnsureInit
Visual C++
public:
void EnsureInit()

See Also

DataSourceBase Class
FastReport.Data Namespace


First Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.First Method
DataSourceBase Class See Also Send Feedback
Navigates to the first row.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void First()
Visual Basic (Declaration)
Public Sub First
Visual C++
public:
void First()

Remarks

You should initialize the datasource by the Init method before using this method.

See Also

DataSourceBase Class
FastReport.Data Namespace


GetValue Method

[image] [image]

FastReport.Net Class Reference
DataSourceBase..::.GetValue Method
DataSourceBase Class See Also Send Feedback

Overload List

Name | Description
GetValue(Column) | Gets data stored in a specified column.
GetValue(String) | Gets data stored in a specified column.

See Also

DataSourceBase Class
DataSourceBase Members
FastReport.Data Namespace


GetValue Method (Column)

[image]

FastReport.Net Class Reference
DataSourceBase..::.GetValue Method (Column)
DataSourceBase Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected abstract Object GetValue(
    Column column
)
Visual Basic (Declaration)
Protected MustOverride Function GetValue ( _
    column As Column _
) As Object
Visual C++
protected:
virtual Object^ GetValue(
    Column^ column
) abstract

Parameters

column
Type: FastReport.Data..::.Column
The column.

Return Value

An object that contains the data.

See Also

DataSourceBase Class
GetValue Overload
FastReport.Data Namespace


GetValue Method (String)

[image]

FastReport.Net Class Reference
DataSourceBase..::.GetValue Method (String)
DataSourceBase Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual Object GetValue(
    string alias
)
Visual Basic (Declaration)
Protected Overridable Function GetValue ( _
    alias As String _
) As Object
Visual C++
protected:
virtual Object^ GetValue(
    String^ alias
)

Parameters

alias
Type: System..::.String
The column alias.

Return Value

An object that contains the data.

See Also

DataSourceBase Class
GetValue Overload
FastReport.Data Namespace


Init Method

[image] [image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method
DataSourceBase Class See Also Send Feedback

Overload List

Name | Description
Init()()() | Initializes this datasource.
Init(DataSourceBase) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData.
Init(String) | Initializes this datasource and applies the specified filter.
Init(String, SortCollection) | Initializes this datasource, applies the specified filter and sorts the rows.
Init(DataSourceBase, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. Also applies the specified filter and sorts the rows.
Init(Relation, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation. Also applies the specified filter and sorts the rows.

See Also

DataSourceBase Class
DataSourceBase Members
FastReport.Data Namespace


Init Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method
DataSourceBase Class See Also Send Feedback
Initializes this datasource.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init()
Visual Basic (Declaration)
Public Sub Init
Visual C++
public:
void Init()

Remarks

This method fills the table with data. You should always call it before using most of datasource properties.

See Also

DataSourceBase Class
Init Overload
FastReport.Data Namespace


Init Method (DataSourceBase)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method (DataSourceBase)
DataSourceBase Class See Also Send Feedback
Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init(
    DataSourceBase parentData
)
Visual Basic (Declaration)
Public Sub Init ( _
    parentData As DataSourceBase _
)
Visual C++
public:
void Init(
    DataSourceBase^ parentData
)

Parameters

parentData
Type: FastReport.Data..::.DataSourceBase
Parent datasource.

Remarks

To use master-detail relation, you must define the Relation object that describes the relation, and add it to the Report.Dictionary.Relations collection.

See Also

DataSourceBase Class
Init Overload
FastReport.Data Namespace


Init Method (String)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method (String)
DataSourceBase Class See Also Send Feedback
Initializes this datasource and applies the specified filter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init(
    string filter
)
Visual Basic (Declaration)
Public Sub Init ( _
    filter As String _
)
Visual C++
public:
void Init(
    String^ filter
)

Parameters

filter
Type: System..::.String
The filter expression.

See Also

DataSourceBase Class
Init Overload
FastReport.Data Namespace


Init Method (String, SortCollection)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method (String, SortCollection)
DataSourceBase Class See Also Send Feedback
Initializes this datasource, applies the specified filter and sorts the rows.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init(
    string filter,
    SortCollection sort
)
Visual Basic (Declaration)
Public Sub Init ( _
    filter As String, _
    sort As SortCollection _
)
Visual C++
public:
void Init(
    String^ filter,
    SortCollection^ sort
)

Parameters

filter
Type: System..::.String
The filter expression.
sort
Type: FastReport..::.SortCollection
The collection of sort descriptors.

See Also

DataSourceBase Class
Init Overload
FastReport.Data Namespace


Init Method (DataSourceBase, String, SortCollection)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method (DataSourceBase, String, SortCollection)
DataSourceBase Class See Also Send Feedback
Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. Also applies the specified filter and sorts the rows.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init(
    DataSourceBase parentData,
    string filter,
    SortCollection sort
)
Visual Basic (Declaration)
Public Sub Init ( _
    parentData As DataSourceBase, _
    filter As String, _
    sort As SortCollection _
)
Visual C++
public:
void Init(
    DataSourceBase^ parentData,
    String^ filter,
    SortCollection^ sort
)

Parameters

parentData
Type: FastReport.Data..::.DataSourceBase
Parent datasource.
filter
Type: System..::.String
The filter expression.
sort
Type: FastReport..::.SortCollection
The collection of sort descriptors.

Remarks

To use master-detail relation, you must define the Relation object that describes the relation, and add it to the Report.Dictionary.Relations collection.

See Also

DataSourceBase Class
Init Overload
FastReport.Data Namespace


Init Method (Relation, String, SortCollection)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Init Method (Relation, String, SortCollection)
DataSourceBase Class See Also Send Feedback
Initializes this datasource and filters data rows according to the master-detail relation. Also applies the specified filter and sorts the rows.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init(
    Relation relation,
    string filter,
    SortCollection sort
)
Visual Basic (Declaration)
Public Sub Init ( _
    relation As Relation, _
    filter As String, _
    sort As SortCollection _
)
Visual C++
public:
void Init(
    Relation^ relation,
    String^ filter,
    SortCollection^ sort
)

Parameters

relation
Type: FastReport.Data..::.Relation
The master-detail relation.
filter
Type: System..::.String
The filter expression.
sort
Type: FastReport..::.SortCollection
The collection of sort descriptors.

Remarks

To use master-detail relation, you must define the Relation object that describes the relation, and add it to the Report.Dictionary.Relations collection.

See Also

DataSourceBase Class
Init Overload
FastReport.Data Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.InitializeComponent Method
DataSourceBase Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

DataSourceBase Class
FastReport.Data Namespace


InitSchema Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.InitSchema Method
DataSourceBase Class See Also Send Feedback
Initializes the datasource schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract void InitSchema()
Visual Basic (Declaration)
Public MustOverride Sub InitSchema
Visual C++
public:
virtual void InitSchema() abstract

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

DataSourceBase Class
FastReport.Data Namespace


LoadData Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.LoadData Method
DataSourceBase Class See Also Send Feedback
Loads the datasource with data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract void LoadData(
    ArrayList rows
)
Visual Basic (Declaration)
Public MustOverride Sub LoadData ( _
    rows As ArrayList _
)
Visual C++
public:
virtual void LoadData(
    ArrayList^ rows
) abstract

Parameters

rows
Type: System.Collections..::.ArrayList
Rows to fill with data.

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

DataSourceBase Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataSourceBase..::.MemberwiseClone Method
DataSourceBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataSourceBase Class
DataSourceBase Members
FastReport.Data Namespace


Next Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.Next Method
DataSourceBase Class See Also Send Feedback
Navigates to the next row.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Next()
Visual Basic (Declaration)
Public Sub Next
Visual C++
public:
void Next()

Remarks

You should initialize the datasource by the Init method before using this method.

See Also

DataSourceBase Class
FastReport.Data Namespace


Prior Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.Prior Method
DataSourceBase Class See Also Send Feedback
Navigates to the prior row.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Prior()
Visual Basic (Declaration)
Public Sub Prior
Visual C++
public:
void Prior()

Remarks

You should initialize the datasource by the Init method before using this method.

See Also

DataSourceBase Class
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DataSourceBase..::.Serialize Method
DataSourceBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DataSourceBase Class
FastReport.Data Namespace


DataSourceBase Properties

[image] [image]

FastReport.Net Class Reference
DataSourceBase Properties
DataSourceBase Class See Also Send Feedback

The DataSourceBase type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class.
Calculated | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row.
CurrentRowNo | Gets an index of current data row.
CustomBindableControl | This property is not relevant to this class.
DataType | This property is not relevant to this class.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource.
Format | This property is not relevant to this class.
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount.
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataSourceBase Class
FastReport.Data Namespace


BindableControl Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.BindableControl Property
DataSourceBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnBindableControl BindableControl { get; set; }
Visual Basic (Declaration)
Public Property BindableControl As ColumnBindableControl
Visual C++
public:
property ColumnBindableControl BindableControl {
    ColumnBindableControl get ();
    void set (ColumnBindableControl value);
}

See Also

DataSourceBase Class
FastReport.Data Namespace


Calculated Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.Calculated Property
DataSourceBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Calculated { get; set; }
Visual Basic (Declaration)
Public Property Calculated As Boolean
Visual C++
public:
property bool Calculated {
    bool get ();
    void set (bool value);
}

See Also

DataSourceBase Class
FastReport.Data Namespace


CurrentRow Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.CurrentRow Property
DataSourceBase Class See Also Send Feedback
Gets the current data row.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object CurrentRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentRow As Object
Visual C++
public:
property Object^ CurrentRow {
    Object^ get ();
}

Remarks

This property is updated when you call the Next()()() method.

See Also

DataSourceBase Class
FastReport.Data Namespace


CurrentRowNo Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.CurrentRowNo Property
DataSourceBase Class See Also Send Feedback
Gets an index of current data row.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CurrentRowNo { get; set; }
Visual Basic (Declaration)
Public Property CurrentRowNo As Integer
Visual C++
public:
property int CurrentRowNo {
    int get ();
    void set (int value);
}

Remarks

You should initialize the datasource by the Init method before using this property.

This property is updated when you call the Next()()() method.

See Also

DataSourceBase Class
FastReport.Data Namespace


CustomBindableControl Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.CustomBindableControl Property
DataSourceBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CustomBindableControl { get; set; }
Visual Basic (Declaration)
Public Property CustomBindableControl As String
Visual C++
public:
property String^ CustomBindableControl {
    String^ get ();
    void set (String^ value);
}

See Also

DataSourceBase Class
FastReport.Data Namespace


DataType Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.DataType Property
DataSourceBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    void set (Type^ value);
}

See Also

DataSourceBase Class
FastReport.Data Namespace


Expression Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.Expression Property
DataSourceBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

DataSourceBase Class
FastReport.Data Namespace


ForceLoadData Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.ForceLoadData Property
DataSourceBase Class See Also Send Feedback
Forces loading of data for this datasource.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ForceLoadData { get; set; }
Visual Basic (Declaration)
Public Property ForceLoadData As Boolean
Visual C++
public:
property bool ForceLoadData {
    bool get ();
    void set (bool value);
}

Remarks

This property is false by default. Set it to true if you need to reload data each time when the datasource initialized. Note that this may slow down the performance.

See Also

DataSourceBase Class
FastReport.Data Namespace


Format Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.Format Property
DataSourceBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColumnFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As ColumnFormat
Visual C++
public:
property ColumnFormat Format {
    ColumnFormat get ();
    void set (ColumnFormat value);
}

See Also

DataSourceBase Class
FastReport.Data Namespace


HasMoreRows Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.HasMoreRows Property
DataSourceBase Class See Also Send Feedback
Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasMoreRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasMoreRows As Boolean
Visual C++
public:
property bool HasMoreRows {
    bool get ();
}

Remarks

You should initialize the datasource by the Init method before using this property.

Usually this property is used with the following code block:

CopyC#
dataSource.Init();
while (dataSource.HasMoreRows)
{
  // do something...
  dataSource.Next();
}

See Also

DataSourceBase Class
FastReport.Data Namespace


Item Property

[image] [image]

FastReport.Net Class Reference
DataSourceBase..::.Item Property
DataSourceBase Class See Also Send Feedback

Overload List

Name | Description
Item[([(Column])]) | Gets data stored in a specified column.
Item[([(String])]) | Gets data stored in a specified column.

See Also

DataSourceBase Class
DataSourceBase Members
FastReport.Data Namespace


Item Property (Column)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Item Property (Column)
DataSourceBase Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object this[
    Column column
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    column As Column _
) As Object
Visual C++
public:
property Object^ default[Column^ column] {
    Object^ get (Column^ column);
}

Parameters

column
Type: FastReport.Data..::.Column
The column.

Return Value

The column's value.

Remarks

You should initialize the datasource by the Init method before using this property.

See Also

DataSourceBase Class
Item Overload
FastReport.Data Namespace


Item Property (String)

[image]

FastReport.Net Class Reference
DataSourceBase..::.Item Property (String)
DataSourceBase Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object this[
    string columnAlias
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    columnAlias As String _
) As Object
Visual C++
public:
property Object^ default[String^ columnAlias] {
    Object^ get (String^ columnAlias);
}

Parameters

columnAlias
Type: System..::.String
Alias of a column.

Return Value

The column's value.

Remarks

You should initialize the datasource by the Init method before using this property.

See Also

DataSourceBase Class
Item Overload
FastReport.Data Namespace


RowCount Property

[image]

FastReport.Net Class Reference
DataSourceBase..::.RowCount Property
DataSourceBase Class See Also Send Feedback
Gets a number of data rows in this datasource.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
Visual C++
public:
property int RowCount {
    int get ();
}

Remarks

You should initialize the datasource by the Init method before using this property.

See Also

DataSourceBase Class
FastReport.Data Namespace


DataSourceBase Events

[image] [image]

FastReport.Net Class Reference
DataSourceBase Events
DataSourceBase Class See Also Send Feedback

The DataSourceBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data.

See Also

DataSourceBase Class
FastReport.Data Namespace


Load Event

[image]

FastReport.Net Class Reference
DataSourceBase..::.Load Event
DataSourceBase Class See Also Send Feedback
Occurs when the FastReport engine loads data source with data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Load
Visual Basic (Declaration)
Public Event Load As EventHandler
Visual C++
public:
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event if you want to implement load-on-demand. Event handler must load the data into the data object which this datasource is bound to (for example, the TableDataSource uses data from the DataTable object bound to the Table property).

See Also

DataSourceBase Class
FastReport.Data Namespace


DataSourceCollection Class

[image]

FastReport.Net Class Reference
DataSourceCollection Class
Members See Also Send Feedback
Represents the collection of DataSourceBase objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataSourceCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class DataSourceCollection _
    Inherits FRCollectionBase
Visual C++
public ref class DataSourceCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.DataSourceCollection

See Also

DataSourceCollection Members
FastReport.Data Namespace


DataSourceCollection Members

[image] [image]

FastReport.Net Class Reference
DataSourceCollection Members
DataSourceCollection Class Constructors Methods Properties See Also Send Feedback

The DataSourceCollection type exposes the following members.

Constructors

Name | Description
DataSourceCollection | Initializes a new instance of the DataSourceCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByAlias | Finds a datasource by its alias.
FindByName | Finds a datasource by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a data source.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

DataSourceCollection Class
FastReport.Data Namespace


DataSourceCollection Constructor

[image]

FastReport.Net Class Reference
DataSourceCollection Constructor
DataSourceCollection Class See Also Send Feedback
Initializes a new instance of the DataSourceCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
DataSourceCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

DataSourceCollection Class
FastReport.Data Namespace


DataSourceCollection Methods

[image] [image]

FastReport.Net Class Reference
DataSourceCollection Methods
DataSourceCollection Class See Also Send Feedback

The DataSourceCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByAlias | Finds a datasource by its alias.
FindByName | Finds a datasource by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSourceCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
DataSourceCollection..::.AddRange Method
DataSourceCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

DataSourceCollection Class
DataSourceCollection Members
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
DataSourceCollection..::.Equals Method
DataSourceCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

DataSourceCollection Class
DataSourceCollection Members
FastReport.Data Namespace


FindByAlias Method

[image]

FastReport.Net Class Reference
DataSourceCollection..::.FindByAlias Method
DataSourceCollection Class See Also Send Feedback
Finds a datasource by its alias.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase FindByAlias(
    string alias
)
Visual Basic (Declaration)
Public Function FindByAlias ( _
    alias As String _
) As DataSourceBase
Visual C++
public:
DataSourceBase^ FindByAlias(
    String^ alias
)

Parameters

alias
Type: System..::.String
The alias of a datasource.

Return Value

The DataSourceBase object if found; otherwise null.

See Also

DataSourceCollection Class
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
DataSourceCollection..::.FindByName Method
DataSourceCollection Class See Also Send Feedback
Finds a datasource by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As DataSourceBase
Visual C++
public:
DataSourceBase^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The name of a datasource.

Return Value

The DataSourceBase object if found; otherwise null.

See Also

DataSourceCollection Class
FastReport.Data Namespace


DataSourceCollection Properties

[image] [image]

FastReport.Net Class Reference
DataSourceCollection Properties
DataSourceCollection Class See Also Send Feedback

The DataSourceCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a data source.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

DataSourceCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
DataSourceCollection..::.Item Property
DataSourceCollection Class See Also Send Feedback
Gets or sets a data source.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As DataSourceBase
Visual C++
public:
property DataSourceBase^ default[int index] {
    DataSourceBase^ get (int index);
    void set (int index, DataSourceBase^ value);
}

Parameters

index
Type: System..::.Int32
The index of a data source in this collection.

Return Value

The data source with specified index.

See Also

DataSourceCollection Class
FastReport.Data Namespace


DateVariable Class

[image]

FastReport.Net Class Reference
DateVariable Class
Members See Also Send Feedback
Returns date and time of the report's start.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DateVariable : SystemVariable
Visual Basic (Declaration)
Public Class DateVariable _
    Inherits SystemVariable
Visual C++
public ref class DateVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.DateVariable

See Also

DateVariable Members
FastReport.Data Namespace


DateVariable Members

[image] [image]

FastReport.Net Class Reference
DateVariable Members
DateVariable Class Methods Properties Events See Also Send Feedback

The DateVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DateVariable Class
FastReport.Data Namespace


DateVariable Methods

[image] [image]

FastReport.Net Class Reference
DateVariable Methods
DateVariable Class See Also Send Feedback

The DateVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

DateVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DateVariable..::.Dispose Method
DateVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DateVariable Class
DateVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DateVariable..::.MemberwiseClone Method
DateVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DateVariable Class
DateVariable Members
FastReport.Data Namespace


DateVariable Properties

[image] [image]

FastReport.Net Class Reference
DateVariable Properties
DateVariable Class See Also Send Feedback

The DateVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DateVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
DateVariable..::.Value Property
DateVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

DateVariable Class
FastReport.Data Namespace


DateVariable Events

[image] [image]

FastReport.Net Class Reference
DateVariable Events
DateVariable Class See Also Send Feedback

The DateVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DateVariable Class
FastReport.Data Namespace


Dictionary Class

[image]

FastReport.Net Class Reference
Dictionary Class
Members See Also Send Feedback
This class stores all report data items such as datasources, connections, relations, parameters, system variables.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Dictionary : Base, IParent
Visual Basic (Declaration)
Public Class Dictionary _
    Inherits Base _
    Implements IParent
Visual C++
public ref class Dictionary : public Base,
    IParent

Remarks

You can access the report dictionary via Report.Dictionary property.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Dictionary

See Also

Dictionary Members
FastReport.Data Namespace


Dictionary Members

[image] [image]

FastReport.Net Class Reference
Dictionary Members
Dictionary Class Constructors Methods Properties Events See Also Send Feedback

The Dictionary type exposes the following members.

Constructors

Name | Description
Dictionary | Initializes a new instance of the Dictionary class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
ClearRegisteredData | Clears all registered data.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueAlias | Creates unique alias for data item such as connection, datasource or relation.
CreateUniqueName | Overloaded.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindByAlias | Finds a data item such as connection, datasource or relation by its alias.
FindByName | Finds a data item such as connection, datasource, relation, parameter or total by its name.
FindDataComponent | Finds a data component that matches the specified reference name.
FindDataTableSource | Finds a datasource that matches the specified DataTable.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
Load | Overloaded.
MemberwiseClone | Overloaded.
Merge | Merges this dictionary with another Dictionary.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RegisterBusinessObject | Registers a business object.
RegisterData | Registers a data object.
RegisterDataView | Registers a DataView.
RemoveChild | Removes a specified object from this object's childs.
ReRegisterData | Re-registers the data registered before.
Save | Overloaded.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnregisterData | Overloaded.
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.
UpdateRelations | Enables or disables relations between data tables.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Connections | Gets a collection of connection objects available in a report.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSources | Gets a collection of datasources available in a report.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of parameters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
RegisteredItems | Gets a list of registered items.
Relations | Gets a collection of relations.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SystemVariables | Gets a collection of system variables like Date, PageNofM etc.
Totals | Gets a collection of totals.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Dictionary Class
FastReport.Data Namespace


Dictionary Constructor

[image]

FastReport.Net Class Reference
Dictionary Constructor
Dictionary Class See Also Send Feedback
Initializes a new instance of the Dictionary class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Dictionary()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Dictionary()

See Also

Dictionary Class
FastReport.Data Namespace


Dictionary Methods

[image] [image]

FastReport.Net Class Reference
Dictionary Methods
Dictionary Class See Also Send Feedback

The Dictionary type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
ClearRegisteredData | Clears all registered data.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueAlias | Creates unique alias for data item such as connection, datasource or relation.
CreateUniqueName | Overloaded.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindByAlias | Finds a data item such as connection, datasource or relation by its alias.
FindByName | Finds a data item such as connection, datasource, relation, parameter or total by its name.
FindDataComponent | Finds a data component that matches the specified reference name.
FindDataTableSource | Finds a datasource that matches the specified DataTable.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
Load | Overloaded.
MemberwiseClone | Overloaded.
Merge | Merges this dictionary with another Dictionary.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RegisterBusinessObject | Registers a business object.
RegisterData | Registers a data object.
RegisterDataView | Registers a DataView.
RemoveChild | Removes a specified object from this object's childs.
ReRegisterData | Re-registers the data registered before.
Save | Overloaded.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnregisterData | Overloaded.
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.
UpdateRelations | Enables or disables relations between data tables.

See Also

Dictionary Class
FastReport.Data Namespace


AddChild Method

[image]

FastReport.Net Class Reference
Dictionary..::.AddChild Method
Dictionary Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

Dictionary Class
FastReport.Data Namespace


Assign Method

[image]

FastReport.Net Class Reference
Dictionary..::.Assign Method
Dictionary Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

Dictionary Class
FastReport.Data Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
Dictionary..::.CanContain Method
Dictionary Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

Dictionary Class
FastReport.Data Namespace


ClearRegisteredData Method

[image]

FastReport.Net Class Reference
Dictionary..::.ClearRegisteredData Method
Dictionary Class See Also Send Feedback
Clears all registered data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ClearRegisteredData()
Visual Basic (Declaration)
Public Sub ClearRegisteredData
Visual C++
public:
void ClearRegisteredData()

See Also

Dictionary Class
FastReport.Data Namespace


CreateUniqueAlias Method

[image]

FastReport.Net Class Reference
Dictionary..::.CreateUniqueAlias Method
Dictionary Class See Also Send Feedback
Creates unique alias for data item such as connection, datasource or relation.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueAlias(
    string alias
)
Visual Basic (Declaration)
Public Function CreateUniqueAlias ( _
    alias As String _
) As String
Visual C++
public:
String^ CreateUniqueAlias(
    String^ alias
)

Parameters

alias
Type: System..::.String
The base alias.

Return Value

The new unique alias.

Remarks

Use this method to create unique alias of the data item. It is necessary when you create new items in code to avoid conflicts with existing report items.

Examples

This example show how to add a new table:
CopyC#
Report report1;
DataConnectionBase conn = report1.Dictionary.Connections.FindByName("Connection1");
TableDataSource table = new TableDataSource();
table.TableName = "Employees";
table.Name = report1.Dictionary.CreateUniqueName("EmployeesTable");
table.Alias = report1.Dictionary.CreateUniqueAlias("Employees");
conn.Tables.Add(table);

See Also

Dictionary Class
FastReport.Data Namespace


CreateUniqueName Method

[image] [image]

FastReport.Net Class Reference
Dictionary..::.CreateUniqueName Method
Dictionary Class See Also Send Feedback

Overload List

Name | Description
CreateUniqueName()()() | Creates the unique object's name. (Inherited from Base.)
CreateUniqueName(String) | Creates unique name for data item such as connection, datasource, relation, parameter or total.

See Also

Dictionary Class
Dictionary Members
FastReport.Data Namespace


CreateUniqueName Method (String)

[image]

FastReport.Net Class Reference
Dictionary..::.CreateUniqueName Method (String)
Dictionary Class See Also Send Feedback
Creates unique name for data item such as connection, datasource, relation, parameter or total.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueName(
    string name
)
Visual Basic (Declaration)
Public Function CreateUniqueName ( _
    name As String _
) As String
Visual C++
public:
String^ CreateUniqueName(
    String^ name
)

Parameters

name
Type: System..::.String
The base name.

Return Value

The new unique name.

Remarks

Use this method to create unique name of the data item. It is necessary when you create new items in code to avoid conflicts with existing report items.

Examples

This example show how to add a new parameter:
CopyC#
Report report1;
Parameter par = new Parameter();
par.Name = report1.Dictionary.CreateUniqueName("Parameter");
report1.Parameters.Add(par);

See Also

Dictionary Class
CreateUniqueName Overload
FastReport.Data Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
Dictionary..::.Deserialize Method
Dictionary Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

Dictionary Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Dictionary..::.Dispose Method
Dictionary Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Dictionary Class
Dictionary Members
FastReport.Data Namespace


FindByAlias Method

[image]

FastReport.Net Class Reference
Dictionary..::.FindByAlias Method
Dictionary Class See Also Send Feedback
Finds a data item such as connection, datasource or relation by its alias.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataComponentBase FindByAlias(
    string alias
)
Visual Basic (Declaration)
Public Function FindByAlias ( _
    alias As String _
) As DataComponentBase
Visual C++
public:
DataComponentBase^ FindByAlias(
    String^ alias
)

Parameters

alias
Type: System..::.String
The item's alias.

Return Value

The data item if found; otherwise, null.

See Also

Dictionary Class
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
Dictionary..::.FindByName Method
Dictionary Class See Also Send Feedback
Finds a data item such as connection, datasource, relation, parameter or total by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As Base
Visual C++
public:
Base^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The item's name.

Return Value

The data item if found; otherwise, null.

See Also

Dictionary Class
FastReport.Data Namespace


FindDataComponent Method

[image]

FastReport.Net Class Reference
Dictionary..::.FindDataComponent Method
Dictionary Class See Also Send Feedback
Finds a data component that matches the specified reference name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataComponentBase FindDataComponent(
    string referenceName
)
Visual Basic (Declaration)
Public Function FindDataComponent ( _
    referenceName As String _
) As DataComponentBase
Visual C++
public:
DataComponentBase^ FindDataComponent(
    String^ referenceName
)

Parameters

referenceName
Type: System..::.String
The name to check.

Return Value

The DataComponentBase object if found.

Remarks

This method is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


FindDataTableSource Method

[image]

FastReport.Net Class Reference
Dictionary..::.FindDataTableSource Method
Dictionary Class See Also Send Feedback
Finds a datasource that matches the specified DataTable.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase FindDataTableSource(
    DataTable table
)
Visual Basic (Declaration)
Public Function FindDataTableSource ( _
    table As DataTable _
) As DataSourceBase
Visual C++
public:
DataSourceBase^ FindDataTableSource(
    DataTable^ table
)

Parameters

table
Type: System.Data..::.DataTable
The DataTable object to check.

Return Value

The DataSourceBase object if found.

Remarks

This method is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
Dictionary..::.GetChildObjects Method
Dictionary Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

Dictionary Class
FastReport.Data Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
Dictionary..::.GetChildOrder Method
Dictionary Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

Dictionary Class
FastReport.Data Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
Dictionary..::.Load Method
Dictionary Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads the dictionary from a stream.
Load(String) | Loads the dictionary from a file.

See Also

Dictionary Class
Dictionary Members
FastReport.Data Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
Dictionary..::.Load Method (Stream)
Dictionary Class See Also Send Feedback
Loads the dictionary from a stream.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

See Also

Dictionary Class
Load Overload
FastReport.Data Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
Dictionary..::.Load Method (String)
Dictionary Class See Also Send Feedback
Loads the dictionary from a file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of a file to load from.

See Also

Dictionary Class
Load Overload
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Dictionary..::.MemberwiseClone Method
Dictionary Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Dictionary Class
Dictionary Members
FastReport.Data Namespace


Merge Method

[image]

FastReport.Net Class Reference
Dictionary..::.Merge Method
Dictionary Class See Also Send Feedback
Merges this dictionary with another Dictionary.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Merge(
    Dictionary source
)
Visual Basic (Declaration)
Public Sub Merge ( _
    source As Dictionary _
)
Visual C++
public:
void Merge(
    Dictionary^ source
)

Parameters

source
Type: FastReport.Data..::.Dictionary
Another dictionary to merge the data from.

See Also

Dictionary Class
FastReport.Data Namespace


RegisterBusinessObject Method

[image]

FastReport.Net Class Reference
Dictionary..::.RegisterBusinessObject Method
Dictionary Class See Also Send Feedback
Registers a business object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterBusinessObject(
    IEnumerable data,
    string referenceName,
    int maxNestingLevel,
    bool enabled
)
Visual Basic (Declaration)
Public Sub RegisterBusinessObject ( _
    data As IEnumerable, _
    referenceName As String, _
    maxNestingLevel As Integer, _
    enabled As Boolean _
)
Visual C++
public:
void RegisterBusinessObject(
    IEnumerable^ data,
    String^ referenceName,
    int maxNestingLevel,
    bool enabled
)

Parameters

data
Type: System.Collections..::.IEnumerable
The business object.
referenceName
Type: System..::.String
The name of the object.
maxNestingLevel
Type: System..::.Int32
Maximum level of data nesting.
enabled
Type: System..::.Boolean
Determines wheter to enable the object or not.

Remarks

This method is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


RegisterData Method

[image]

FastReport.Net Class Reference
Dictionary..::.RegisterData Method
Dictionary Class See Also Send Feedback
Registers a data object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterData(
    Object data,
    string name,
    bool enabled
)
Visual Basic (Declaration)
Public Sub RegisterData ( _
    data As Object, _
    name As String, _
    enabled As Boolean _
)
Visual C++
public:
void RegisterData(
    Object^ data,
    String^ name,
    bool enabled
)

Parameters

data
Type: System..::.Object
The object to register.
name
Type: System..::.String
The name of the object.
enabled
Type: System..::.Boolean
Determines wheter to enable the object or not.

Remarks

This method is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


RegisterDataView Method

[image]

FastReport.Net Class Reference
Dictionary..::.RegisterDataView Method
Dictionary Class See Also Send Feedback
Registers a DataView.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterDataView(
    DataView view,
    string referenceName,
    bool enabled
)
Visual Basic (Declaration)
Public Sub RegisterDataView ( _
    view As DataView, _
    referenceName As String, _
    enabled As Boolean _
)
Visual C++
public:
void RegisterDataView(
    DataView^ view,
    String^ referenceName,
    bool enabled
)

Parameters

view
Type: System.Data..::.DataView
The DataView to register.
referenceName
Type: System..::.String
The name of the data object.
enabled
Type: System..::.Boolean
Determines wheter to enable the object or not.

Remarks

This method is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
Dictionary..::.RemoveChild Method
Dictionary Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

Dictionary Class
FastReport.Data Namespace


ReRegisterData Method

[image]

FastReport.Net Class Reference
Dictionary..::.ReRegisterData Method
Dictionary Class See Also Send Feedback
Re-registers the data registered before.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ReRegisterData()
Visual Basic (Declaration)
Public Sub ReRegisterData
Visual C++
public:
void ReRegisterData()

Remarks

This method is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
Dictionary..::.Save Method
Dictionary Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves the dictionary to a stream.
Save(String) | Saves the dictionary to a file.

See Also

Dictionary Class
Dictionary Members
FastReport.Data Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
Dictionary..::.Save Method (Stream)
Dictionary Class See Also Send Feedback
Saves the dictionary to a stream.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to save to.

See Also

Dictionary Class
Save Overload
FastReport.Data Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
Dictionary..::.Save Method (String)
Dictionary Class See Also Send Feedback
Saves the dictionary to a file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of a file to save to.

See Also

Dictionary Class
Save Overload
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Dictionary..::.Serialize Method
Dictionary Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Dictionary Class
FastReport.Data Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
Dictionary..::.SetChildOrder Method
Dictionary Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

Dictionary Class
FastReport.Data Namespace


UnregisterData Method

[image] [image]

FastReport.Net Class Reference
Dictionary..::.UnregisterData Method
Dictionary Class See Also Send Feedback

Overload List

Name | Description
UnregisterData(Object) | Unregisters the previously registered data.
UnregisterData(Object, String) | Unregisters the previously registered data.

See Also

Dictionary Class
Dictionary Members
FastReport.Data Namespace


UnregisterData Method (Object)

[image]

FastReport.Net Class Reference
Dictionary..::.UnregisterData Method (Object)
Dictionary Class See Also Send Feedback
Unregisters the previously registered data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UnregisterData(
    Object data
)
Visual Basic (Declaration)
Public Sub UnregisterData ( _
    data As Object _
)
Visual C++
public:
void UnregisterData(
    Object^ data
)

Parameters

data
Type: System..::.Object
The application data.

See Also

Dictionary Class
UnregisterData Overload
FastReport.Data Namespace


UnregisterData Method (Object, String)

[image]

FastReport.Net Class Reference
Dictionary..::.UnregisterData Method (Object, String)
Dictionary Class See Also Send Feedback
Unregisters the previously registered data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UnregisterData(
    Object data,
    string name
)
Visual Basic (Declaration)
Public Sub UnregisterData ( _
    data As Object, _
    name As String _
)
Visual C++
public:
void UnregisterData(
    Object^ data,
    String^ name
)

Parameters

data
Type: System..::.Object
The application data.
name
Type: System..::.String
The name of the data.

Remarks

You must specify the same data and name as when you call RegisterData.

See Also

Dictionary Class
UnregisterData Overload
FastReport.Data Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
Dictionary..::.UpdateLayout Method
Dictionary Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

Dictionary Class
FastReport.Data Namespace


UpdateRelations Method

[image]

FastReport.Net Class Reference
Dictionary..::.UpdateRelations Method
Dictionary Class See Also Send Feedback
Enables or disables relations between data tables.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateRelations()
Visual Basic (Declaration)
Public Sub UpdateRelations
Visual C++
public:
void UpdateRelations()

Remarks

Call this method if you create master-detail report from code. This method enables relation between two data tables which Enabled flag is set to true. Relations whose parent and child tables are disabled, gets disabled too.

See Also

Dictionary Class
FastReport.Data Namespace


Dictionary Properties

[image] [image]

FastReport.Net Class Reference
Dictionary Properties
Dictionary Class See Also Send Feedback

The Dictionary type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Connections | Gets a collection of connection objects available in a report.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSources | Gets a collection of datasources available in a report.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of parameters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
RegisteredItems | Gets a list of registered items.
Relations | Gets a collection of relations.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SystemVariables | Gets a collection of system variables like Date, PageNofM etc.
Totals | Gets a collection of totals.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Dictionary Class
FastReport.Data Namespace


Connections Property

[image]

FastReport.Net Class Reference
Dictionary..::.Connections Property
Dictionary Class See Also Send Feedback
Gets a collection of connection objects available in a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ConnectionCollection Connections { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connections As ConnectionCollection
Visual C++
public:
property ConnectionCollection^ Connections {
    ConnectionCollection^ get ();
}

See Also

Dictionary Class
FastReport.Data Namespace


DataSources Property

[image]

FastReport.Net Class Reference
Dictionary..::.DataSources Property
Dictionary Class See Also Send Feedback
Gets a collection of datasources available in a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceCollection DataSources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSources As DataSourceCollection
Visual C++
public:
property DataSourceCollection^ DataSources {
    DataSourceCollection^ get ();
}

Remarks

Usually you don't need to use this property. It contains only datasources registered using the RegisterData method. All other datasources are contained in connection objects and may be accessed via Connections property.

See Also

Dictionary Class
FastReport.Data Namespace


Parameters Property

[image]

FastReport.Net Class Reference
Dictionary..::.Parameters Property
Dictionary Class See Also Send Feedback
Gets a collection of parameters.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

Remarks

Another way to access parameters is to use the Report.Parameters property which is actually a shortcut to this property. You also may use the Report.GetParameter and Report.GetParameterValue methods.

See Also

Dictionary Class
FastReport.Data Namespace


RegisteredItems Property

[image]

FastReport.Net Class Reference
Dictionary..::.RegisteredItems Property
Dictionary Class See Also Send Feedback
Gets a list of registered items.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<Dictionary..::.RegDataItem> RegisteredItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegisteredItems As List(Of Dictionary..::.RegDataItem)
Visual C++
public:
property List<Dictionary..::.RegDataItem^>^ RegisteredItems {
    List<Dictionary..::.RegDataItem^>^ get ();
}

Remarks

This property is for internal use only.

See Also

Dictionary Class
FastReport.Data Namespace


Relations Property

[image]

FastReport.Net Class Reference
Dictionary..::.Relations Property
Dictionary Class See Also Send Feedback
Gets a collection of relations.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RelationCollection Relations { get; }
Visual Basic (Declaration)
Public ReadOnly Property Relations As RelationCollection
Visual C++
public:
property RelationCollection^ Relations {
    RelationCollection^ get ();
}

See Also

Dictionary Class
FastReport.Data Namespace


SystemVariables Property

[image]

FastReport.Net Class Reference
Dictionary..::.SystemVariables Property
Dictionary Class See Also Send Feedback
Gets a collection of system variables like Date, PageNofM etc.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SystemVariables SystemVariables { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemVariables As SystemVariables
Visual C++
public:
property SystemVariables^ SystemVariables {
    SystemVariables^ get ();
}

Remarks

Another way to access a system variable is to use the Report.GetVariableValue method.

See Also

Dictionary Class
FastReport.Data Namespace


Totals Property

[image]

FastReport.Net Class Reference
Dictionary..::.Totals Property
Dictionary Class See Also Send Feedback
Gets a collection of totals.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TotalCollection Totals { get; }
Visual Basic (Declaration)
Public ReadOnly Property Totals As TotalCollection
Visual C++
public:
property TotalCollection^ Totals {
    TotalCollection^ get ();
}

Remarks

Another way to get a total value is to use the Report.GetTotalValue method.

See Also

Dictionary Class
FastReport.Data Namespace


Dictionary Events

[image] [image]

FastReport.Net Class Reference
Dictionary Events
Dictionary Class See Also Send Feedback

The Dictionary type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Dictionary Class
FastReport.Data Namespace


Dictionary.RegDataItem Class

[image]

FastReport.Net Class Reference
Dictionary..::.RegDataItem Class
Dictionary Class Members See Also Send Feedback
Represents the item registered in a dictionary.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RegDataItem
Visual Basic (Declaration)
Public Class RegDataItem
Visual C++
public ref class RegDataItem

Inheritance Hierarchy

System..::.Object
FastReport.Data..::.Dictionary..::.RegDataItem

See Also

Dictionary..::.RegDataItem Members
FastReport.Data Namespace


Dictionary.RegDataItem Members

[image] [image]

FastReport.Net Class Reference
Dictionary..::.RegDataItem Members
Dictionary..::.RegDataItem Class Methods Fields See Also Send Feedback

This class stores all report data items such as datasources, connections, relations, parameters, system variables.

The Dictionary..::.RegDataItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Data | Gets the item data.
Name | Gets the item name.

See Also

Dictionary..::.RegDataItem Class
FastReport.Data Namespace


Dictionary.RegDataItem Fields

[image] [image]

FastReport.Net Class Reference
Dictionary..::.RegDataItem Fields
Dictionary..::.RegDataItem Class See Also Send Feedback

The Dictionary..::.RegDataItem type exposes the following members.

Fields

Name | Description
Data | Gets the item data.
Name | Gets the item name.

See Also

Dictionary..::.RegDataItem Class
FastReport.Data Namespace


Data Field

[image]

FastReport.Net Class Reference
Dictionary..::.RegDataItem..::.Data Field
Dictionary..::.RegDataItem Class See Also Send Feedback
Gets the item data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Data
Visual Basic (Declaration)
Public Data As Object
Visual C++
public:
Object^ Data

See Also

Dictionary..::.RegDataItem Class
FastReport.Data Namespace


Name Field

[image]

FastReport.Net Class Reference
Dictionary..::.RegDataItem..::.Name Field
Dictionary..::.RegDataItem Class See Also Send Feedback
Gets the item name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

Dictionary..::.RegDataItem Class
FastReport.Data Namespace


Dictionary.RegDataItem Methods

[image] [image]

FastReport.Net Class Reference
Dictionary..::.RegDataItem Methods
Dictionary..::.RegDataItem Class See Also Send Feedback

The Dictionary..::.RegDataItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dictionary..::.RegDataItem Class
FastReport.Data Namespace


FilterOperation Enumeration

[image]

FastReport.Net Class Reference
FilterOperation Enumeration
See Also Send Feedback
Determines how to filter the data value.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum FilterOperation
Visual Basic (Declaration)
Public Enumeration FilterOperation
Visual C++
public enum class FilterOperation

Members

Member name | Description
Equal | Data value is equal to selected value.
NotEqual | Data value is not equal to selected value.
LessThan | Data value is less than selected value.
LessThanOrEqual | Data value is less than or equal to selected value.
GreaterThan | Data value is greater than selected value.
GreaterThanOrEqual | Data value is greater than or equal to selected value.
Contains | Data string contains selected value.
NotContains | Data string does not contain selected value.
StartsWith | Data string starts with selected value.
NotStartsWith | Data string does not start with selected value.
EndsWith | Data string ends with selected value.
NotEndsWith | Data string does not end with selected value.

Remarks

The "Data value" is a value contained in the datasource which you filter. The "Selected value" is a value you have entered or selected in the dialog control.

See Also

FastReport.Data Namespace


HierarchyLevelVariable Class

[image]

FastReport.Net Class Reference
HierarchyLevelVariable Class
Members See Also Send Feedback
Returns a level of hierarchy in the hierarchical report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HierarchyLevelVariable : SystemVariable
Visual Basic (Declaration)
Public Class HierarchyLevelVariable _
    Inherits SystemVariable
Visual C++
public ref class HierarchyLevelVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.HierarchyLevelVariable

See Also

HierarchyLevelVariable Members
FastReport.Data Namespace


HierarchyLevelVariable Members

[image] [image]

FastReport.Net Class Reference
HierarchyLevelVariable Members
HierarchyLevelVariable Class Methods Properties Events See Also Send Feedback

The HierarchyLevelVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HierarchyLevelVariable Class
FastReport.Data Namespace


HierarchyLevelVariable Methods

[image] [image]

FastReport.Net Class Reference
HierarchyLevelVariable Methods
HierarchyLevelVariable Class See Also Send Feedback

The HierarchyLevelVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

HierarchyLevelVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
HierarchyLevelVariable..::.Dispose Method
HierarchyLevelVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

HierarchyLevelVariable Class
HierarchyLevelVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
HierarchyLevelVariable..::.MemberwiseClone Method
HierarchyLevelVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

HierarchyLevelVariable Class
HierarchyLevelVariable Members
FastReport.Data Namespace


HierarchyLevelVariable Properties

[image] [image]

FastReport.Net Class Reference
HierarchyLevelVariable Properties
HierarchyLevelVariable Class See Also Send Feedback

The HierarchyLevelVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

HierarchyLevelVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
HierarchyLevelVariable..::.Value Property
HierarchyLevelVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

HierarchyLevelVariable Class
FastReport.Data Namespace


HierarchyLevelVariable Events

[image] [image]

FastReport.Net Class Reference
HierarchyLevelVariable Events
HierarchyLevelVariable Class See Also Send Feedback

The HierarchyLevelVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HierarchyLevelVariable Class
FastReport.Data Namespace


HierarchyRowNoVariable Class

[image]

FastReport.Net Class Reference
HierarchyRowNoVariable Class
Members See Also Send Feedback
Returns the row number like "1.2.1" in the hierarchical report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HierarchyRowNoVariable : SystemVariable
Visual Basic (Declaration)
Public Class HierarchyRowNoVariable _
    Inherits SystemVariable
Visual C++
public ref class HierarchyRowNoVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.HierarchyRowNoVariable

See Also

HierarchyRowNoVariable Members
FastReport.Data Namespace


HierarchyRowNoVariable Members

[image] [image]

FastReport.Net Class Reference
HierarchyRowNoVariable Members
HierarchyRowNoVariable Class Methods Properties Events See Also Send Feedback

The HierarchyRowNoVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HierarchyRowNoVariable Class
FastReport.Data Namespace


HierarchyRowNoVariable Methods

[image] [image]

FastReport.Net Class Reference
HierarchyRowNoVariable Methods
HierarchyRowNoVariable Class See Also Send Feedback

The HierarchyRowNoVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

HierarchyRowNoVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
HierarchyRowNoVariable..::.Dispose Method
HierarchyRowNoVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

HierarchyRowNoVariable Class
HierarchyRowNoVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
HierarchyRowNoVariable..::.MemberwiseClone Method
HierarchyRowNoVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

HierarchyRowNoVariable Class
HierarchyRowNoVariable Members
FastReport.Data Namespace


HierarchyRowNoVariable Properties

[image] [image]

FastReport.Net Class Reference
HierarchyRowNoVariable Properties
HierarchyRowNoVariable Class See Also Send Feedback

The HierarchyRowNoVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

HierarchyRowNoVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
HierarchyRowNoVariable..::.Value Property
HierarchyRowNoVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

HierarchyRowNoVariable Class
FastReport.Data Namespace


HierarchyRowNoVariable Events

[image] [image]

FastReport.Net Class Reference
HierarchyRowNoVariable Events
HierarchyRowNoVariable Class See Also Send Feedback

The HierarchyRowNoVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HierarchyRowNoVariable Class
FastReport.Data Namespace


LoadBusinessObjectEventArgs Class

[image]

FastReport.Net Class Reference
LoadBusinessObjectEventArgs Class
Members See Also Send Feedback
Provides data for LoadBusinessObjectEventHandler event.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LoadBusinessObjectEventArgs
Visual Basic (Declaration)
Public Class LoadBusinessObjectEventArgs
Visual C++
public ref class LoadBusinessObjectEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Data..::.LoadBusinessObjectEventArgs

See Also

LoadBusinessObjectEventArgs Members
FastReport.Data Namespace


LoadBusinessObjectEventArgs Members

[image] [image]

FastReport.Net Class Reference
LoadBusinessObjectEventArgs Members
LoadBusinessObjectEventArgs Class Methods Fields See Also Send Feedback

The LoadBusinessObjectEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Parent | Parent object for this data source.

See Also

LoadBusinessObjectEventArgs Class
FastReport.Data Namespace


LoadBusinessObjectEventArgs Fields

[image] [image]

FastReport.Net Class Reference
LoadBusinessObjectEventArgs Fields
LoadBusinessObjectEventArgs Class See Also Send Feedback

The LoadBusinessObjectEventArgs type exposes the following members.

Fields

Name | Description
Parent | Parent object for this data source.

See Also

LoadBusinessObjectEventArgs Class
FastReport.Data Namespace


Parent Field

[image]

FastReport.Net Class Reference
LoadBusinessObjectEventArgs..::.Parent Field
LoadBusinessObjectEventArgs Class See Also Send Feedback
Parent object for this data source.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Parent
Visual Basic (Declaration)
Public Parent As Object
Visual C++
public:
Object^ Parent

See Also

LoadBusinessObjectEventArgs Class
FastReport.Data Namespace


LoadBusinessObjectEventArgs Methods

[image] [image]

FastReport.Net Class Reference
LoadBusinessObjectEventArgs Methods
LoadBusinessObjectEventArgs Class See Also Send Feedback

The LoadBusinessObjectEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadBusinessObjectEventArgs Class
FastReport.Data Namespace


LoadBusinessObjectEventHandler Delegate

[image]

FastReport.Net Class Reference
LoadBusinessObjectEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the LoadBusinessObject event.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void LoadBusinessObjectEventHandler(
    Object sender,
    LoadBusinessObjectEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub LoadBusinessObjectEventHandler ( _
    sender As Object, _
    e As LoadBusinessObjectEventArgs _
)
Visual C++
public delegate void LoadBusinessObjectEventHandler(
    Object^ sender,
    LoadBusinessObjectEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Data..::.LoadBusinessObjectEventArgs
The event data.

See Also

FastReport.Data Namespace


MsAccessDataConnection Class

[image]

FastReport.Net Class Reference
MsAccessDataConnection Class
Members Example See Also Send Feedback
Represents a connection to MS Access database (.mdb file).

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MsAccessDataConnection : DataConnectionBase
Visual Basic (Declaration)
Public Class MsAccessDataConnection _
    Inherits DataConnectionBase
Visual C++
public ref class MsAccessDataConnection : public DataConnectionBase

Examples

This example shows how to add a new connection to the report.
CopyC#
Report report1;
MsAccessDataConnection conn = new MsAccessDataConnection();
conn.DataSource = @"c:\data.mdb";
report1.Dictionary.Connections.Add(conn);
conn.CreateAllTables();

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.MsAccessDataConnection

See Also

MsAccessDataConnection Members
FastReport.Data Namespace


MsAccessDataConnection Members

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection Members
MsAccessDataConnection Class Constructors Methods Properties Events See Also Send Feedback

The MsAccessDataConnection type exposes the following members.

Constructors

Name | Description
MsAccessDataConnection | Initializes a new instance of the MsAccessDataConnection class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Inherited from DataConnectionBase.)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Inherited from DataConnectionBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Overrides DataConnectionBase..::.SetConnectionString(String).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DataSource | Gets or sets the datasource file name.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Password | Gets or sets the password.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
UserName | Gets or sets the user name.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


MsAccessDataConnection Constructor

[image]

FastReport.Net Class Reference
MsAccessDataConnection Constructor
MsAccessDataConnection Class See Also Send Feedback
Initializes a new instance of the MsAccessDataConnection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MsAccessDataConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MsAccessDataConnection()

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


MsAccessDataConnection Methods

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection Methods
MsAccessDataConnection Class See Also Send Feedback

The MsAccessDataConnection type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Inherited from DataConnectionBase.)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Inherited from DataConnectionBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Overrides DataConnectionBase..::.SetConnectionString(String).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


CreateAllTables Method

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection..::.CreateAllTables Method
MsAccessDataConnection Class See Also Send Feedback

Overload List

Name | Description
CreateAllTables()()() | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)
CreateAllTables(Boolean) | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)

See Also

MsAccessDataConnection Class
MsAccessDataConnection Members
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection..::.Dispose Method
MsAccessDataConnection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DataConnectionBase.)

See Also

MsAccessDataConnection Class
MsAccessDataConnection Members
FastReport.Data Namespace


GetAdapter Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.GetAdapter Method
MsAccessDataConnection Class Example See Also Send Feedback
Returns a DbDataAdapter object that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DbDataAdapter GetAdapter(
    string selectCommand,
    DbConnection connection,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overrides Function GetAdapter ( _
    selectCommand As String, _
    connection As DbConnection, _
    parameters As CommandParameterCollection _
) As DbDataAdapter
Visual C++
public:
virtual DbDataAdapter^ GetAdapter(
    String^ selectCommand,
    DbConnection^ connection,
    CommandParameterCollection^ parameters
) override

Parameters

selectCommand
Type: System..::.String
The SQL command used to fetch a table data rows.
connection
Type: System.Data.Common..::.DbConnection
The connection object.
parameters
Type: FastReport.Data..::.CommandParameterCollection
The select command parameters.

Return Value

The DbDataAdapter object.

Remarks

You should override this method if you are developing a new connection component. In this method, you need to create the adapter and set its SelectCommand's parameters.

If your connection does not use data adapter, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override DbDataAdapter GetAdapter(string selectCommand, DbConnection connection,
  CommandParameterCollection parameters)
{
  OleDbDataAdapter adapter = new OleDbDataAdapter(selectCommand, connection as OleDbConnection);
  foreach (CommandParameter p in parameters)
  {
    OleDbParameter parameter = adapter.SelectCommand.Parameters.Add(p.Name, (OleDbType)p.DataType, p.Size);
    parameter.Value = p.Value;
  }
  return adapter;
}

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


GetConnectionId Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.GetConnectionId Method
MsAccessDataConnection Class See Also Send Feedback
Gets a string that will identify a connection in the Data Wizard.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string GetConnectionId()
Visual Basic (Declaration)
Public Overrides Function GetConnectionId As String
Visual C++
public:
virtual String^ GetConnectionId() override

Return Value

The string that contains the connection type and some meaningful information.

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


GetConnectionStringWithLoginInfo Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.GetConnectionStringWithLoginInfo Method
MsAccessDataConnection Class See Also Send Feedback
Gets a connection string that contains username and password specified.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetConnectionStringWithLoginInfo(
    string userName,
    string password
)
Visual Basic (Declaration)
Protected Overrides Function GetConnectionStringWithLoginInfo ( _
    userName As String, _
    password As String _
) As String
Visual C++
protected:
virtual String^ GetConnectionStringWithLoginInfo(
    String^ userName,
    String^ password
) override

Parameters

userName
Type: System..::.String
User name.
password
Type: System..::.String
Password.

Remarks

Override this method to pass login information to the connection. Typical implementation must get the existing ConnectionString, merge specified login information into it and return the new value.

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


GetConnectionType Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.GetConnectionType Method
MsAccessDataConnection Class Example See Also Send Feedback
Returns a type of connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetConnectionType()
Visual Basic (Declaration)
Public Overrides Function GetConnectionType As Type
Visual C++
public:
virtual Type^ GetConnectionType() override

Return Value

Type instance.

Remarks

You should override this method if you developing a new connection component.

If your connection component does not use data connection, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override Type GetConnectionType()
{
  return typeof(OleDbConnection);
}

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.GetEditor Method
MsAccessDataConnection Class See Also Send Feedback
Gets a control that will be used to edit the connection properties.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ConnectionEditorBase GetEditor()
Visual Basic (Declaration)
Public Overrides Function GetEditor As ConnectionEditorBase
Visual C++
public:
virtual ConnectionEditorBase^ GetEditor() override

Return Value

The editor's control.

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


GetParameterType Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.GetParameterType Method
MsAccessDataConnection Class See Also Send Feedback
Gets the type of parameter that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetParameterType()
Visual Basic (Declaration)
Public Overrides Function GetParameterType As Type
Visual C++
public:
virtual Type^ GetParameterType() override

Return Value

The parameter's type.

Remarks

This property is used in the report designer to display available data types when you edit the connection parameters. For example, the type of OleDbConnection parameter is a OleDbType.

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection..::.MemberwiseClone Method
MsAccessDataConnection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MsAccessDataConnection Class
MsAccessDataConnection Members
FastReport.Data Namespace


QuoteIdentifier Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.QuoteIdentifier Method
MsAccessDataConnection Class See Also Send Feedback
Quotes the specified DB identifier such as table name or column name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string QuoteIdentifier(
    string value,
    DbConnection connection
)
Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier ( _
    value As String, _
    connection As DbConnection _
) As String
Visual C++
public:
virtual String^ QuoteIdentifier(
    String^ value,
    DbConnection^ connection
) override

Parameters

value
Type: System..::.String
Identifier to quote.
connection
Type: System.Data.Common..::.DbConnection
The opened DB connection.

Return Value

The quoted identifier.

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


SetConnectionString Method

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.SetConnectionString Method
MsAccessDataConnection Class See Also Send Feedback
Sets the connection string.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void SetConnectionString(
    string value
)
Visual Basic (Declaration)
Protected Overrides Sub SetConnectionString ( _
    value As String _
)
Visual C++
protected:
virtual void SetConnectionString(
    String^ value
) override

Parameters

value
Type: System..::.String
New connection string.

Remarks

Use this method if you need to perform some actions when the connection string is set.

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


MsAccessDataConnection Properties

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection Properties
MsAccessDataConnection Class See Also Send Feedback

The MsAccessDataConnection type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DataSource | Gets or sets the datasource file name.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Password | Gets or sets the password.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
UserName | Gets or sets the user name.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


DataSource Property

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.DataSource Property
MsAccessDataConnection Class See Also Send Feedback
Gets or sets the datasource file name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


Password Property

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.Password Property
MsAccessDataConnection Class See Also Send Feedback
Gets or sets the password.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


UserName Property

[image]

FastReport.Net Class Reference
MsAccessDataConnection..::.UserName Property
MsAccessDataConnection Class See Also Send Feedback
Gets or sets the user name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


MsAccessDataConnection Events

[image] [image]

FastReport.Net Class Reference
MsAccessDataConnection Events
MsAccessDataConnection Class See Also Send Feedback

The MsAccessDataConnection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MsAccessDataConnection Class
FastReport.Data Namespace


MsSqlDataConnection Class

[image]

FastReport.Net Class Reference
MsSqlDataConnection Class
Members Example See Also Send Feedback
Represents a connection to MS SQL database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MsSqlDataConnection : DataConnectionBase
Visual Basic (Declaration)
Public Class MsSqlDataConnection _
    Inherits DataConnectionBase
Visual C++
public ref class MsSqlDataConnection : public DataConnectionBase

Examples

This example shows how to add a new connection to the report.
CopyC#
Report report1;
MsSqlDataConnection conn = new MsSqlDataConnection();
conn.ConnectionString = "your_connection_string";
report1.Dictionary.Connections.Add(conn);
conn.CreateAllTables();

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.MsSqlDataConnection

See Also

MsSqlDataConnection Members
FastReport.Data Namespace


MsSqlDataConnection Members

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection Members
MsSqlDataConnection Class Constructors Methods Properties Events See Also Send Feedback

The MsSqlDataConnection type exposes the following members.

Constructors

Name | Description
MsSqlDataConnection | Initializes a new instance of the MsSqlDataConnection class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Overrides DataConnectionBase..::.GetDefaultParameterType()()().)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Inherited from DataConnectionBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


MsSqlDataConnection Constructor

[image]

FastReport.Net Class Reference
MsSqlDataConnection Constructor
MsSqlDataConnection Class See Also Send Feedback
Initializes a new instance of the MsSqlDataConnection class

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MsSqlDataConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MsSqlDataConnection()

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


MsSqlDataConnection Methods

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection Methods
MsSqlDataConnection Class See Also Send Feedback

The MsSqlDataConnection type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Overrides DataConnectionBase..::.GetDefaultParameterType()()().)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Inherited from DataConnectionBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


CreateAllTables Method

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection..::.CreateAllTables Method
MsSqlDataConnection Class See Also Send Feedback

Overload List

Name | Description
CreateAllTables()()() | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)
CreateAllTables(Boolean) | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)

See Also

MsSqlDataConnection Class
MsSqlDataConnection Members
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection..::.Dispose Method
MsSqlDataConnection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DataConnectionBase.)

See Also

MsSqlDataConnection Class
MsSqlDataConnection Members
FastReport.Data Namespace


GetAdapter Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetAdapter Method
MsSqlDataConnection Class Example See Also Send Feedback
Returns a DbDataAdapter object that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DbDataAdapter GetAdapter(
    string selectCommand,
    DbConnection connection,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overrides Function GetAdapter ( _
    selectCommand As String, _
    connection As DbConnection, _
    parameters As CommandParameterCollection _
) As DbDataAdapter
Visual C++
public:
virtual DbDataAdapter^ GetAdapter(
    String^ selectCommand,
    DbConnection^ connection,
    CommandParameterCollection^ parameters
) override

Parameters

selectCommand
Type: System..::.String
The SQL command used to fetch a table data rows.
connection
Type: System.Data.Common..::.DbConnection
The connection object.
parameters
Type: FastReport.Data..::.CommandParameterCollection
The select command parameters.

Return Value

The DbDataAdapter object.

Remarks

You should override this method if you are developing a new connection component. In this method, you need to create the adapter and set its SelectCommand's parameters.

If your connection does not use data adapter, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override DbDataAdapter GetAdapter(string selectCommand, DbConnection connection,
  CommandParameterCollection parameters)
{
  OleDbDataAdapter adapter = new OleDbDataAdapter(selectCommand, connection as OleDbConnection);
  foreach (CommandParameter p in parameters)
  {
    OleDbParameter parameter = adapter.SelectCommand.Parameters.Add(p.Name, (OleDbType)p.DataType, p.Size);
    parameter.Value = p.Value;
  }
  return adapter;
}

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetConnectionId Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetConnectionId Method
MsSqlDataConnection Class See Also Send Feedback
Gets a string that will identify a connection in the Data Wizard.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string GetConnectionId()
Visual Basic (Declaration)
Public Overrides Function GetConnectionId As String
Visual C++
public:
virtual String^ GetConnectionId() override

Return Value

The string that contains the connection type and some meaningful information.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetConnectionStringWithLoginInfo Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetConnectionStringWithLoginInfo Method
MsSqlDataConnection Class See Also Send Feedback
Gets a connection string that contains username and password specified.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetConnectionStringWithLoginInfo(
    string userName,
    string password
)
Visual Basic (Declaration)
Protected Overrides Function GetConnectionStringWithLoginInfo ( _
    userName As String, _
    password As String _
) As String
Visual C++
protected:
virtual String^ GetConnectionStringWithLoginInfo(
    String^ userName,
    String^ password
) override

Parameters

userName
Type: System..::.String
User name.
password
Type: System..::.String
Password.

Remarks

Override this method to pass login information to the connection. Typical implementation must get the existing ConnectionString, merge specified login information into it and return the new value.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetConnectionType Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetConnectionType Method
MsSqlDataConnection Class Example See Also Send Feedback
Returns a type of connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetConnectionType()
Visual Basic (Declaration)
Public Overrides Function GetConnectionType As Type
Visual C++
public:
virtual Type^ GetConnectionType() override

Return Value

Type instance.

Remarks

You should override this method if you developing a new connection component.

If your connection component does not use data connection, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override Type GetConnectionType()
{
  return typeof(OleDbConnection);
}

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetDefaultParameterType Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetDefaultParameterType Method
MsSqlDataConnection Class See Also Send Feedback
Gets the default type for a new parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetDefaultParameterType()
Visual Basic (Declaration)
Public Overrides Function GetDefaultParameterType As Integer
Visual C++
public:
virtual int GetDefaultParameterType() override

Return Value

The integer representation of a parameter type.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetEditor Method
MsSqlDataConnection Class See Also Send Feedback
Gets a control that will be used to edit the connection properties.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ConnectionEditorBase GetEditor()
Visual Basic (Declaration)
Public Overrides Function GetEditor As ConnectionEditorBase
Visual C++
public:
virtual ConnectionEditorBase^ GetEditor() override

Return Value

The editor's control.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetParameterType Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetParameterType Method
MsSqlDataConnection Class See Also Send Feedback
Gets the type of parameter that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetParameterType()
Visual Basic (Declaration)
Public Overrides Function GetParameterType As Type
Visual C++
public:
virtual Type^ GetParameterType() override

Return Value

The parameter's type.

Remarks

This property is used in the report designer to display available data types when you edit the connection parameters. For example, the type of OleDbConnection parameter is a OleDbType.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


GetTableNames Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.GetTableNames Method
MsSqlDataConnection Class See Also Send Feedback
Gets an array of table names available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetTableNames()
Visual Basic (Declaration)
Public Overrides Function GetTableNames As String()
Visual C++
public:
virtual array<String^>^ GetTableNames() override

Return Value

An array of strings.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection..::.MemberwiseClone Method
MsSqlDataConnection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MsSqlDataConnection Class
MsSqlDataConnection Members
FastReport.Data Namespace


QuoteIdentifier Method

[image]

FastReport.Net Class Reference
MsSqlDataConnection..::.QuoteIdentifier Method
MsSqlDataConnection Class See Also Send Feedback
Quotes the specified DB identifier such as table name or column name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string QuoteIdentifier(
    string value,
    DbConnection connection
)
Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier ( _
    value As String, _
    connection As DbConnection _
) As String
Visual C++
public:
virtual String^ QuoteIdentifier(
    String^ value,
    DbConnection^ connection
) override

Parameters

value
Type: System..::.String
Identifier to quote.
connection
Type: System.Data.Common..::.DbConnection
The opened DB connection.

Return Value

The quoted identifier.

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


MsSqlDataConnection Properties

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection Properties
MsSqlDataConnection Class See Also Send Feedback

The MsSqlDataConnection type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


MsSqlDataConnection Events

[image] [image]

FastReport.Net Class Reference
MsSqlDataConnection Events
MsSqlDataConnection Class See Also Send Feedback

The MsSqlDataConnection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MsSqlDataConnection Class
FastReport.Data Namespace


OdbcDataConnection Class

[image]

FastReport.Net Class Reference
OdbcDataConnection Class
Members Example See Also Send Feedback
Represents a connection to any database through ODBC.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OdbcDataConnection : DataConnectionBase
Visual Basic (Declaration)
Public Class OdbcDataConnection _
    Inherits DataConnectionBase
Visual C++
public ref class OdbcDataConnection : public DataConnectionBase

Examples

This example shows how to add a new connection to the report.
CopyC#
Report report1;
OdbcDataConnection conn = new OdbcDataConnection();
conn.ConnectionString = "your_connection_string";
report1.Dictionary.Connections.Add(conn);
conn.CreateAllTables();

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.OdbcDataConnection

See Also

OdbcDataConnection Members
FastReport.Data Namespace


OdbcDataConnection Members

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection Members
OdbcDataConnection Class Constructors Methods Properties Events See Also Send Feedback

The OdbcDataConnection type exposes the following members.

Constructors

Name | Description
OdbcDataConnection | Initializes a new instance of the OdbcDataConnection class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Overrides DataConnectionBase..::.GetDefaultParameterType()()().)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Inherited from DataConnectionBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OdbcDataConnection Class
FastReport.Data Namespace


OdbcDataConnection Constructor

[image]

FastReport.Net Class Reference
OdbcDataConnection Constructor
OdbcDataConnection Class See Also Send Feedback
Initializes a new instance of the OdbcDataConnection class

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OdbcDataConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OdbcDataConnection()

See Also

OdbcDataConnection Class
FastReport.Data Namespace


OdbcDataConnection Methods

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection Methods
OdbcDataConnection Class See Also Send Feedback

The OdbcDataConnection type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Overrides DataConnectionBase..::.GetDefaultParameterType()()().)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Inherited from DataConnectionBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

See Also

OdbcDataConnection Class
FastReport.Data Namespace


CreateAllTables Method

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection..::.CreateAllTables Method
OdbcDataConnection Class See Also Send Feedback

Overload List

Name | Description
CreateAllTables()()() | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)
CreateAllTables(Boolean) | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)

See Also

OdbcDataConnection Class
OdbcDataConnection Members
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection..::.Dispose Method
OdbcDataConnection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DataConnectionBase.)

See Also

OdbcDataConnection Class
OdbcDataConnection Members
FastReport.Data Namespace


GetAdapter Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetAdapter Method
OdbcDataConnection Class Example See Also Send Feedback
Returns a DbDataAdapter object that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DbDataAdapter GetAdapter(
    string selectCommand,
    DbConnection connection,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overrides Function GetAdapter ( _
    selectCommand As String, _
    connection As DbConnection, _
    parameters As CommandParameterCollection _
) As DbDataAdapter
Visual C++
public:
virtual DbDataAdapter^ GetAdapter(
    String^ selectCommand,
    DbConnection^ connection,
    CommandParameterCollection^ parameters
) override

Parameters

selectCommand
Type: System..::.String
The SQL command used to fetch a table data rows.
connection
Type: System.Data.Common..::.DbConnection
The connection object.
parameters
Type: FastReport.Data..::.CommandParameterCollection
The select command parameters.

Return Value

The DbDataAdapter object.

Remarks

You should override this method if you are developing a new connection component. In this method, you need to create the adapter and set its SelectCommand's parameters.

If your connection does not use data adapter, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override DbDataAdapter GetAdapter(string selectCommand, DbConnection connection,
  CommandParameterCollection parameters)
{
  OleDbDataAdapter adapter = new OleDbDataAdapter(selectCommand, connection as OleDbConnection);
  foreach (CommandParameter p in parameters)
  {
    OleDbParameter parameter = adapter.SelectCommand.Parameters.Add(p.Name, (OleDbType)p.DataType, p.Size);
    parameter.Value = p.Value;
  }
  return adapter;
}

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetConnectionId Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetConnectionId Method
OdbcDataConnection Class See Also Send Feedback
Gets a string that will identify a connection in the Data Wizard.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string GetConnectionId()
Visual Basic (Declaration)
Public Overrides Function GetConnectionId As String
Visual C++
public:
virtual String^ GetConnectionId() override

Return Value

The string that contains the connection type and some meaningful information.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetConnectionStringWithLoginInfo Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetConnectionStringWithLoginInfo Method
OdbcDataConnection Class See Also Send Feedback
Gets a connection string that contains username and password specified.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetConnectionStringWithLoginInfo(
    string userName,
    string password
)
Visual Basic (Declaration)
Protected Overrides Function GetConnectionStringWithLoginInfo ( _
    userName As String, _
    password As String _
) As String
Visual C++
protected:
virtual String^ GetConnectionStringWithLoginInfo(
    String^ userName,
    String^ password
) override

Parameters

userName
Type: System..::.String
User name.
password
Type: System..::.String
Password.

Remarks

Override this method to pass login information to the connection. Typical implementation must get the existing ConnectionString, merge specified login information into it and return the new value.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetConnectionType Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetConnectionType Method
OdbcDataConnection Class Example See Also Send Feedback
Returns a type of connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetConnectionType()
Visual Basic (Declaration)
Public Overrides Function GetConnectionType As Type
Visual C++
public:
virtual Type^ GetConnectionType() override

Return Value

Type instance.

Remarks

You should override this method if you developing a new connection component.

If your connection component does not use data connection, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override Type GetConnectionType()
{
  return typeof(OleDbConnection);
}

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetDefaultParameterType Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetDefaultParameterType Method
OdbcDataConnection Class See Also Send Feedback
Gets the default type for a new parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetDefaultParameterType()
Visual Basic (Declaration)
Public Overrides Function GetDefaultParameterType As Integer
Visual C++
public:
virtual int GetDefaultParameterType() override

Return Value

The integer representation of a parameter type.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetEditor Method
OdbcDataConnection Class See Also Send Feedback
Gets a control that will be used to edit the connection properties.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ConnectionEditorBase GetEditor()
Visual Basic (Declaration)
Public Overrides Function GetEditor As ConnectionEditorBase
Visual C++
public:
virtual ConnectionEditorBase^ GetEditor() override

Return Value

The editor's control.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetParameterType Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetParameterType Method
OdbcDataConnection Class See Also Send Feedback
Gets the type of parameter that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetParameterType()
Visual Basic (Declaration)
Public Overrides Function GetParameterType As Type
Visual C++
public:
virtual Type^ GetParameterType() override

Return Value

The parameter's type.

Remarks

This property is used in the report designer to display available data types when you edit the connection parameters. For example, the type of OleDbConnection parameter is a OleDbType.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


GetTableNames Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.GetTableNames Method
OdbcDataConnection Class See Also Send Feedback
Gets an array of table names available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetTableNames()
Visual Basic (Declaration)
Public Overrides Function GetTableNames As String()
Visual C++
public:
virtual array<String^>^ GetTableNames() override

Return Value

An array of strings.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection..::.MemberwiseClone Method
OdbcDataConnection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OdbcDataConnection Class
OdbcDataConnection Members
FastReport.Data Namespace


QuoteIdentifier Method

[image]

FastReport.Net Class Reference
OdbcDataConnection..::.QuoteIdentifier Method
OdbcDataConnection Class See Also Send Feedback
Quotes the specified DB identifier such as table name or column name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string QuoteIdentifier(
    string value,
    DbConnection connection
)
Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier ( _
    value As String, _
    connection As DbConnection _
) As String
Visual C++
public:
virtual String^ QuoteIdentifier(
    String^ value,
    DbConnection^ connection
) override

Parameters

value
Type: System..::.String
Identifier to quote.
connection
Type: System.Data.Common..::.DbConnection
The opened DB connection.

Return Value

The quoted identifier.

See Also

OdbcDataConnection Class
FastReport.Data Namespace


OdbcDataConnection Properties

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection Properties
OdbcDataConnection Class See Also Send Feedback

The OdbcDataConnection type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

OdbcDataConnection Class
FastReport.Data Namespace


OdbcDataConnection Events

[image] [image]

FastReport.Net Class Reference
OdbcDataConnection Events
OdbcDataConnection Class See Also Send Feedback

The OdbcDataConnection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OdbcDataConnection Class
FastReport.Data Namespace


OleDbDataConnection Class

[image]

FastReport.Net Class Reference
OleDbDataConnection Class
Members Example See Also Send Feedback
Represents a connection to any OLE DB database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OleDbDataConnection : DataConnectionBase
Visual Basic (Declaration)
Public Class OleDbDataConnection _
    Inherits DataConnectionBase
Visual C++
public ref class OleDbDataConnection : public DataConnectionBase

Examples

This example shows how to add a new connection to the report.
CopyC#
Report report1;
OleDbDataConnection conn = new OleDbDataConnection();
conn.ConnectionString = "your_connection_string";
report1.Dictionary.Connections.Add(conn);
conn.CreateAllTables();

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.OleDbDataConnection

See Also

OleDbDataConnection Members
FastReport.Data Namespace


OleDbDataConnection Members

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection Members
OleDbDataConnection Class Constructors Methods Properties Events See Also Send Feedback

The OleDbDataConnection type exposes the following members.

Constructors

Name | Description
OleDbDataConnection | Initializes a new instance of the OleDbDataConnection class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Overrides DataConnectionBase..::.GetDefaultParameterType()()().)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Inherited from DataConnectionBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OleDbDataConnection Class
FastReport.Data Namespace


OleDbDataConnection Constructor

[image]

FastReport.Net Class Reference
OleDbDataConnection Constructor
OleDbDataConnection Class See Also Send Feedback
Initializes a new instance of the OleDbDataConnection class

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OleDbDataConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OleDbDataConnection()

See Also

OleDbDataConnection Class
FastReport.Data Namespace


OleDbDataConnection Methods

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection Methods
OleDbDataConnection Class See Also Send Feedback

The OleDbDataConnection type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Inherited from DataConnectionBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Inherited from DataConnectionBase.)
FillTableSchema | Fills the table schema. (Inherited from DataConnectionBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Overrides DataConnectionBase..::.GetAdapter(String, DbConnection, CommandParameterCollection).)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Overrides DataConnectionBase..::.GetConnectionStringWithLoginInfo(String, String).)
GetConnectionType | Returns a type of connection. (Overrides DataConnectionBase..::.GetConnectionType()()().)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Overrides DataConnectionBase..::.GetDefaultParameterType()()().)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Overrides DataConnectionBase..::.GetParameterType()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Inherited from DataConnectionBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Inherited from DataConnectionBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

See Also

OleDbDataConnection Class
FastReport.Data Namespace


CreateAllTables Method

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection..::.CreateAllTables Method
OleDbDataConnection Class See Also Send Feedback

Overload List

Name | Description
CreateAllTables()()() | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)
CreateAllTables(Boolean) | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)

See Also

OleDbDataConnection Class
OleDbDataConnection Members
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection..::.Dispose Method
OleDbDataConnection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DataConnectionBase.)

See Also

OleDbDataConnection Class
OleDbDataConnection Members
FastReport.Data Namespace


GetAdapter Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetAdapter Method
OleDbDataConnection Class Example See Also Send Feedback
Returns a DbDataAdapter object that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DbDataAdapter GetAdapter(
    string selectCommand,
    DbConnection connection,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overrides Function GetAdapter ( _
    selectCommand As String, _
    connection As DbConnection, _
    parameters As CommandParameterCollection _
) As DbDataAdapter
Visual C++
public:
virtual DbDataAdapter^ GetAdapter(
    String^ selectCommand,
    DbConnection^ connection,
    CommandParameterCollection^ parameters
) override

Parameters

selectCommand
Type: System..::.String
The SQL command used to fetch a table data rows.
connection
Type: System.Data.Common..::.DbConnection
The connection object.
parameters
Type: FastReport.Data..::.CommandParameterCollection
The select command parameters.

Return Value

The DbDataAdapter object.

Remarks

You should override this method if you are developing a new connection component. In this method, you need to create the adapter and set its SelectCommand's parameters.

If your connection does not use data adapter, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override DbDataAdapter GetAdapter(string selectCommand, DbConnection connection,
  CommandParameterCollection parameters)
{
  OleDbDataAdapter adapter = new OleDbDataAdapter(selectCommand, connection as OleDbConnection);
  foreach (CommandParameter p in parameters)
  {
    OleDbParameter parameter = adapter.SelectCommand.Parameters.Add(p.Name, (OleDbType)p.DataType, p.Size);
    parameter.Value = p.Value;
  }
  return adapter;
}

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetConnectionId Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetConnectionId Method
OleDbDataConnection Class See Also Send Feedback
Gets a string that will identify a connection in the Data Wizard.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string GetConnectionId()
Visual Basic (Declaration)
Public Overrides Function GetConnectionId As String
Visual C++
public:
virtual String^ GetConnectionId() override

Return Value

The string that contains the connection type and some meaningful information.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetConnectionStringWithLoginInfo Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetConnectionStringWithLoginInfo Method
OleDbDataConnection Class See Also Send Feedback
Gets a connection string that contains username and password specified.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetConnectionStringWithLoginInfo(
    string userName,
    string password
)
Visual Basic (Declaration)
Protected Overrides Function GetConnectionStringWithLoginInfo ( _
    userName As String, _
    password As String _
) As String
Visual C++
protected:
virtual String^ GetConnectionStringWithLoginInfo(
    String^ userName,
    String^ password
) override

Parameters

userName
Type: System..::.String
User name.
password
Type: System..::.String
Password.

Remarks

Override this method to pass login information to the connection. Typical implementation must get the existing ConnectionString, merge specified login information into it and return the new value.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetConnectionType Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetConnectionType Method
OleDbDataConnection Class Example See Also Send Feedback
Returns a type of connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetConnectionType()
Visual Basic (Declaration)
Public Overrides Function GetConnectionType As Type
Visual C++
public:
virtual Type^ GetConnectionType() override

Return Value

Type instance.

Remarks

You should override this method if you developing a new connection component.

If your connection component does not use data connection, you need to override the FillTableSchema(DataTable, String, CommandParameterCollection) and FillTableData(DataTable, String, CommandParameterCollection) methods instead.

Examples

Here is the example of this method implementation:
CopyC#
public override Type GetConnectionType()
{
  return typeof(OleDbConnection);
}

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetDefaultParameterType Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetDefaultParameterType Method
OleDbDataConnection Class See Also Send Feedback
Gets the default type for a new parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetDefaultParameterType()
Visual Basic (Declaration)
Public Overrides Function GetDefaultParameterType As Integer
Visual C++
public:
virtual int GetDefaultParameterType() override

Return Value

The integer representation of a parameter type.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetEditor Method
OleDbDataConnection Class See Also Send Feedback
Gets a control that will be used to edit the connection properties.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ConnectionEditorBase GetEditor()
Visual Basic (Declaration)
Public Overrides Function GetEditor As ConnectionEditorBase
Visual C++
public:
virtual ConnectionEditorBase^ GetEditor() override

Return Value

The editor's control.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetParameterType Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetParameterType Method
OleDbDataConnection Class See Also Send Feedback
Gets the type of parameter that is specific to this connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetParameterType()
Visual Basic (Declaration)
Public Overrides Function GetParameterType As Type
Visual C++
public:
virtual Type^ GetParameterType() override

Return Value

The parameter's type.

Remarks

This property is used in the report designer to display available data types when you edit the connection parameters. For example, the type of OleDbConnection parameter is a OleDbType.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


GetTableNames Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.GetTableNames Method
OleDbDataConnection Class See Also Send Feedback
Gets an array of table names available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetTableNames()
Visual Basic (Declaration)
Public Overrides Function GetTableNames As String()
Visual C++
public:
virtual array<String^>^ GetTableNames() override

Return Value

An array of strings.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection..::.MemberwiseClone Method
OleDbDataConnection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OleDbDataConnection Class
OleDbDataConnection Members
FastReport.Data Namespace


QuoteIdentifier Method

[image]

FastReport.Net Class Reference
OleDbDataConnection..::.QuoteIdentifier Method
OleDbDataConnection Class See Also Send Feedback
Quotes the specified DB identifier such as table name or column name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string QuoteIdentifier(
    string value,
    DbConnection connection
)
Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier ( _
    value As String, _
    connection As DbConnection _
) As String
Visual C++
public:
virtual String^ QuoteIdentifier(
    String^ value,
    DbConnection^ connection
) override

Parameters

value
Type: System..::.String
Identifier to quote.
connection
Type: System.Data.Common..::.DbConnection
The opened DB connection.

Return Value

The quoted identifier.

See Also

OleDbDataConnection Class
FastReport.Data Namespace


OleDbDataConnection Properties

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection Properties
OleDbDataConnection Class See Also Send Feedback

The OleDbDataConnection type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

OleDbDataConnection Class
FastReport.Data Namespace


OleDbDataConnection Events

[image] [image]

FastReport.Net Class Reference
OleDbDataConnection Events
OleDbDataConnection Class See Also Send Feedback

The OleDbDataConnection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OleDbDataConnection Class
FastReport.Data Namespace


PageMacroVariable Class

[image]

FastReport.Net Class Reference
PageMacroVariable Class
Members See Also Send Feedback
Returns current page number.

This variable is actually a macro. Its value is substituted when the component is viewed in the preview window. That means you cannot use it in an expression.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageMacroVariable : SystemVariable
Visual Basic (Declaration)
Public Class PageMacroVariable _
    Inherits SystemVariable
Visual C++
public ref class PageMacroVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.PageMacroVariable

See Also

PageMacroVariable Members
FastReport.Data Namespace


PageMacroVariable Members

[image] [image]

FastReport.Net Class Reference
PageMacroVariable Members
PageMacroVariable Class Methods Properties Events See Also Send Feedback

The PageMacroVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageMacroVariable Class
FastReport.Data Namespace


PageMacroVariable Methods

[image] [image]

FastReport.Net Class Reference
PageMacroVariable Methods
PageMacroVariable Class See Also Send Feedback

The PageMacroVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

PageMacroVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageMacroVariable..::.Dispose Method
PageMacroVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageMacroVariable Class
PageMacroVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageMacroVariable..::.MemberwiseClone Method
PageMacroVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageMacroVariable Class
PageMacroVariable Members
FastReport.Data Namespace


PageMacroVariable Properties

[image] [image]

FastReport.Net Class Reference
PageMacroVariable Properties
PageMacroVariable Class See Also Send Feedback

The PageMacroVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageMacroVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
PageMacroVariable..::.Value Property
PageMacroVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

PageMacroVariable Class
FastReport.Data Namespace


PageMacroVariable Events

[image] [image]

FastReport.Net Class Reference
PageMacroVariable Events
PageMacroVariable Class See Also Send Feedback

The PageMacroVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageMacroVariable Class
FastReport.Data Namespace


PageNofMVariable Class

[image]

FastReport.Net Class Reference
PageNofMVariable Class
Members See Also Send Feedback
Returns a string containing the current page number and total pages in a form "Page N of M". To use this variable, you need to enable the report's double pass.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageNofMVariable : SystemVariable
Visual Basic (Declaration)
Public Class PageNofMVariable _
    Inherits SystemVariable
Visual C++
public ref class PageNofMVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.PageNofMVariable

See Also

PageNofMVariable Members
FastReport.Data Namespace


PageNofMVariable Members

[image] [image]

FastReport.Net Class Reference
PageNofMVariable Members
PageNofMVariable Class Methods Properties Events See Also Send Feedback

The PageNofMVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageNofMVariable Class
FastReport.Data Namespace


PageNofMVariable Methods

[image] [image]

FastReport.Net Class Reference
PageNofMVariable Methods
PageNofMVariable Class See Also Send Feedback

The PageNofMVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

PageNofMVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageNofMVariable..::.Dispose Method
PageNofMVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageNofMVariable Class
PageNofMVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageNofMVariable..::.MemberwiseClone Method
PageNofMVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageNofMVariable Class
PageNofMVariable Members
FastReport.Data Namespace


PageNofMVariable Properties

[image] [image]

FastReport.Net Class Reference
PageNofMVariable Properties
PageNofMVariable Class See Also Send Feedback

The PageNofMVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageNofMVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
PageNofMVariable..::.Value Property
PageNofMVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

PageNofMVariable Class
FastReport.Data Namespace


PageNofMVariable Events

[image] [image]

FastReport.Net Class Reference
PageNofMVariable Events
PageNofMVariable Class See Also Send Feedback

The PageNofMVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageNofMVariable Class
FastReport.Data Namespace


PageNVariable Class

[image]

FastReport.Net Class Reference
PageNVariable Class
Members See Also Send Feedback
Returns a string containing the current page number in a form "Page N".

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageNVariable : SystemVariable
Visual Basic (Declaration)
Public Class PageNVariable _
    Inherits SystemVariable
Visual C++
public ref class PageNVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.PageNVariable

See Also

PageNVariable Members
FastReport.Data Namespace


PageNVariable Members

[image] [image]

FastReport.Net Class Reference
PageNVariable Members
PageNVariable Class Methods Properties Events See Also Send Feedback

The PageNVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageNVariable Class
FastReport.Data Namespace


PageNVariable Methods

[image] [image]

FastReport.Net Class Reference
PageNVariable Methods
PageNVariable Class See Also Send Feedback

The PageNVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

PageNVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageNVariable..::.Dispose Method
PageNVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageNVariable Class
PageNVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageNVariable..::.MemberwiseClone Method
PageNVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageNVariable Class
PageNVariable Members
FastReport.Data Namespace


PageNVariable Properties

[image] [image]

FastReport.Net Class Reference
PageNVariable Properties
PageNVariable Class See Also Send Feedback

The PageNVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageNVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
PageNVariable..::.Value Property
PageNVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

PageNVariable Class
FastReport.Data Namespace


PageNVariable Events

[image] [image]

FastReport.Net Class Reference
PageNVariable Events
PageNVariable Class See Also Send Feedback

The PageNVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageNVariable Class
FastReport.Data Namespace


PageVariable Class

[image]

FastReport.Net Class Reference
PageVariable Class
Members See Also Send Feedback
Returns current page number.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageVariable : SystemVariable
Visual Basic (Declaration)
Public Class PageVariable _
    Inherits SystemVariable
Visual C++
public ref class PageVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.PageVariable

See Also

PageVariable Members
FastReport.Data Namespace


PageVariable Members

[image] [image]

FastReport.Net Class Reference
PageVariable Members
PageVariable Class Methods Properties Events See Also Send Feedback

The PageVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageVariable Class
FastReport.Data Namespace


PageVariable Methods

[image] [image]

FastReport.Net Class Reference
PageVariable Methods
PageVariable Class See Also Send Feedback

The PageVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

PageVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PageVariable..::.Dispose Method
PageVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PageVariable Class
PageVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PageVariable..::.MemberwiseClone Method
PageVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageVariable Class
PageVariable Members
FastReport.Data Namespace


PageVariable Properties

[image] [image]

FastReport.Net Class Reference
PageVariable Properties
PageVariable Class See Also Send Feedback

The PageVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PageVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
PageVariable..::.Value Property
PageVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

PageVariable Class
FastReport.Data Namespace


PageVariable Events

[image] [image]

FastReport.Net Class Reference
PageVariable Events
PageVariable Class See Also Send Feedback

The PageVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PageVariable Class
FastReport.Data Namespace


Parameter Class

[image]

FastReport.Net Class Reference
Parameter Class
Members See Also Send Feedback
Represents a report parameter that is used to pass user data to a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Parameter : Base, IParent
Visual Basic (Declaration)
Public Class Parameter _
    Inherits Base _
    Implements IParent
Visual C++
public ref class Parameter : public Base,
    IParent

Remarks

See Parameters for details about using parameters.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable

See Also

Parameter Members
FastReport.Data Namespace


Parameter Members

[image] [image]

FastReport.Net Class Reference
Parameter Members
Parameter Class Constructors Methods Properties Events See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Overloaded.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter.
Description | Gets or sets the description of a parameter.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets an expression of the parameter.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Parameter Class
FastReport.Data Namespace


Parameter Constructor

[image] [image]

FastReport.Net Class Reference
Parameter Constructor
Parameter Class See Also Send Feedback

Overload List

Name | Description
Parameter()()() | Initializes a new instance of the Parameter class with default settings.
Parameter(String) | Initializes a new instance of the Parameter class with specified name.

See Also

Parameter Class
Parameter Members
FastReport.Data Namespace


Parameter Constructor

[image]

FastReport.Net Class Reference
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parameter()

See Also

Parameter Class
Parameter Overload
FastReport.Data Namespace


Parameter Constructor (String)

[image]

FastReport.Net Class Reference
Parameter Constructor (String)
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class with specified name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Parameter(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Parameter(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Parameter Class
Parameter Overload
FastReport.Data Namespace


Parameter Methods

[image] [image]

FastReport.Net Class Reference
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

Parameter Class
FastReport.Data Namespace


AddChild Method

[image]

FastReport.Net Class Reference
Parameter..::.AddChild Method
Parameter Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

Parameter Class
FastReport.Data Namespace


Assign Method

[image]

FastReport.Net Class Reference
Parameter..::.Assign Method
Parameter Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

Parameter Class
FastReport.Data Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
Parameter..::.CanContain Method
Parameter Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

Parameter Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Parameter..::.Dispose Method
Parameter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Parameter Class
Parameter Members
FastReport.Data Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
Parameter..::.GetChildObjects Method
Parameter Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

Parameter Class
FastReport.Data Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
Parameter..::.GetChildOrder Method
Parameter Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

Parameter Class
FastReport.Data Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
Parameter..::.GetExpressions Method
Parameter Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

Parameter Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Parameter..::.MemberwiseClone Method
Parameter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Parameter Class
Parameter Members
FastReport.Data Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
Parameter..::.RemoveChild Method
Parameter Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

Parameter Class
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Parameter..::.Serialize Method
Parameter Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Parameter Class
FastReport.Data Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
Parameter..::.SetChildOrder Method
Parameter Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

Parameter Class
FastReport.Data Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
Parameter..::.UpdateLayout Method
Parameter Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

Parameter Class
FastReport.Data Namespace


Parameter Properties

[image] [image]

FastReport.Net Class Reference
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter.
Description | Gets or sets the description of a parameter.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets an expression of the parameter.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Parameter Class
FastReport.Data Namespace


AsString Property

[image]

FastReport.Net Class Reference
Parameter..::.AsString Property
Parameter Class See Also Send Feedback
Gets or sets value of the parameter as a string.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AsString { get; set; }
Visual Basic (Declaration)
Public Property AsString As String
Visual C++
public:
property String^ AsString {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
FastReport.Data Namespace


DataType Property

[image]

FastReport.Net Class Reference
Parameter..::.DataType Property
Parameter Class See Also Send Feedback
Gets or sets the type of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    void set (Type^ value);
}

See Also

Parameter Class
FastReport.Data Namespace


Description Property

[image]

FastReport.Net Class Reference
Parameter..::.Description Property
Parameter Class See Also Send Feedback
Gets or sets the description of a parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
FastReport.Data Namespace


Expression Property

[image]

FastReport.Net Class Reference
Parameter..::.Expression Property
Parameter Class See Also Send Feedback
Gets or sets an expression of the parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

This expression will be calculated each time you access a parameter's Value.

See Also

Parameter Class
FastReport.Data Namespace


FullName Property

[image]

FastReport.Net Class Reference
Parameter..::.FullName Property
Parameter Class See Also Send Feedback
Gets the full name of the parameter. This is useful to get the nested parameter's full name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FullName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullName As String
Visual C++
public:
property String^ FullName {
    String^ get ();
}

See Also

Parameter Class
FastReport.Data Namespace


Parameters Property

[image]

FastReport.Net Class Reference
Parameter..::.Parameters Property
Parameter Class See Also Send Feedback
Gets a collection of nested parameters.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

Remarks

Parameters can have child (nested) parameters. To get or set a nested parameter's value, use the GetParameter(String) method.

See Also

Parameter Class
FastReport.Data Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
Parameter..::.Restrictions Property
Parameter Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

Parameter Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
Parameter..::.Value Property
Parameter Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Object Value { get; set; }
Visual Basic (Declaration)
Public Overridable Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

Parameter Class
FastReport.Data Namespace


Parameter Events

[image] [image]

FastReport.Net Class Reference
Parameter Events
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Parameter Class
FastReport.Data Namespace


ParameterCollection Class

[image]

FastReport.Net Class Reference
ParameterCollection Class
Members See Also Send Feedback
Represents the collection of Parameter objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ParameterCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class ParameterCollection _
    Inherits FRCollectionBase
Visual C++
public ref class ParameterCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.ParameterCollection
FastReport.Data..::.SystemVariables

See Also

ParameterCollection Members
FastReport.Data Namespace


ParameterCollection Members

[image] [image]

FastReport.Net Class Reference
ParameterCollection Members
ParameterCollection Class Constructors Methods Properties See Also Send Feedback

The ParameterCollection type exposes the following members.

Constructors

Name | Description
ParameterCollection | Initializes a new instance of the ParameterCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Assign | Copies the parameters from other collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique parameter name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a parameter by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a parameter.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ParameterCollection Class
FastReport.Data Namespace


ParameterCollection Constructor

[image]

FastReport.Net Class Reference
ParameterCollection Constructor
ParameterCollection Class See Also Send Feedback
Initializes a new instance of the ParameterCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ParameterCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
ParameterCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

ParameterCollection Class
FastReport.Data Namespace


ParameterCollection Methods

[image] [image]

FastReport.Net Class Reference
ParameterCollection Methods
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Assign | Copies the parameters from other collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique parameter name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a parameter by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
ParameterCollection..::.AddRange Method
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

ParameterCollection Class
ParameterCollection Members
FastReport.Data Namespace


Assign Method

[image]

FastReport.Net Class Reference
ParameterCollection..::.Assign Method
ParameterCollection Class See Also Send Feedback
Copies the parameters from other collection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    ParameterCollection source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As ParameterCollection _
)
Visual C++
public:
void Assign(
    ParameterCollection^ source
)

Parameters

source
Type: FastReport.Data..::.ParameterCollection
Parameters to copy from.

See Also

ParameterCollection Class
FastReport.Data Namespace


CreateUniqueName Method

[image]

FastReport.Net Class Reference
ParameterCollection..::.CreateUniqueName Method
ParameterCollection Class See Also Send Feedback
Returns an unique parameter name based on given name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueName(
    string name
)
Visual Basic (Declaration)
Public Function CreateUniqueName ( _
    name As String _
) As String
Visual C++
public:
String^ CreateUniqueName(
    String^ name
)

Parameters

name
Type: System..::.String
The base name.

Return Value

The unique name.

See Also

ParameterCollection Class
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
ParameterCollection..::.Equals Method
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

ParameterCollection Class
ParameterCollection Members
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
ParameterCollection..::.FindByName Method
ParameterCollection Class See Also Send Feedback
Finds a parameter by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Parameter FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As Parameter
Visual C++
public:
Parameter^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The name of a parameter.

Return Value

The Parameter object if found; otherwise null.

See Also

ParameterCollection Class
FastReport.Data Namespace


ParameterCollection Properties

[image] [image]

FastReport.Net Class Reference
ParameterCollection Properties
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a parameter.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ParameterCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
ParameterCollection..::.Item Property
ParameterCollection Class See Also Send Feedback
Gets or sets a parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Parameter this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Parameter
Visual C++
public:
property Parameter^ default[int index] {
    Parameter^ get (int index);
    void set (int index, Parameter^ value);
}

Parameters

index
Type: System..::.Int32
The index of a parameter in this collection.

Return Value

The parameter with specified index.

See Also

ParameterCollection Class
FastReport.Data Namespace


PropertyKind Enumeration

[image]

FastReport.Net Class Reference
PropertyKind Enumeration
See Also Send Feedback
Specifies a kind of property.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PropertyKind
Visual Basic (Declaration)
Public Enumeration PropertyKind
Visual C++
public enum class PropertyKind

Members

Member name | Description
Simple | Specifies the property of a simple type (such as integer).
Complex | Specifies the complex property such as class with own properties.
Enumerable | Specifies the property which is a list of objects (is of IEnumerable type).

See Also

FastReport.Data Namespace


Relation Class

[image]

FastReport.Net Class Reference
Relation Class
Members See Also Send Feedback
Represents a master-detail relation between two data sources.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Relation : DataComponentBase, IHasEditor
Visual Basic (Declaration)
Public Class Relation _
    Inherits DataComponentBase _
    Implements IHasEditor
Visual C++
public ref class Relation : public DataComponentBase,
    IHasEditor

Remarks

To setup a relation, you must specify parent and child datasources. For a parent datasource, you must specify set of key columns; for child datasource, you must specify set of columns that relate to the parent key columns.

Examples

This example shows how to create relation between Customers and Orders tables:
CopyC#
Report report1;
DataSourceBase customersTable = report1.Dictionary.DataSources.FindByAlias("Customers");
DataSourceBase ordersTable = report1.Dictionary.DataSources.FindByAlias("Orders");
Relation rel = new Relation();
rel.Name = "customersOrders";
rel.ParentDataSource = customersTable;
rel.ChildDataSource = ordersTable;
rel.ParentColumns = new string[] { "CustomerID" };
rel.ChildColumns = new string[] { "CustomerID" };
report1.Dictionary.Relations.Add(rel);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Relation

See Also

Relation Members
FastReport.Data Namespace


Relation Members

[image] [image]

FastReport.Net Class Reference
Relation Members
Relation Class Constructors Methods Properties Events See Also Send Feedback

The Relation type exposes the following members.

Constructors

Name | Description
Relation | Initializes a new instance of the Relation class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataComponentBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Overloaded.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the relation editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildColumns | Gets or sets an array of child datasource columns.
ChildDataSource | Gets or sets the child datasource.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ParentColumns | Gets or sets an array of parent datasource columns.
ParentDataSource | Gets or sets the parent datasource.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Relation Class
FastReport.Data Namespace


Relation Constructor

[image]

FastReport.Net Class Reference
Relation Constructor
Relation Class See Also Send Feedback
Initializes a new instance of the Relation class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Relation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Relation()

See Also

Relation Class
FastReport.Data Namespace


Relation Methods

[image] [image]

FastReport.Net Class Reference
Relation Methods
Relation Class See Also Send Feedback

The Relation type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataComponentBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Overloaded.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the relation editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Relation Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Relation..::.Dispose Method
Relation Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Relation Class
Relation Members
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
Relation..::.Equals Method
Relation Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Relation) | Compares this relation with another one.

See Also

Relation Class
Relation Members
FastReport.Data Namespace


Equals Method (Relation)

[image]

FastReport.Net Class Reference
Relation..::.Equals Method (Relation)
Relation Class See Also Send Feedback
Compares this relation with another one.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Equals(
    Relation rel
)
Visual Basic (Declaration)
Public Function Equals ( _
    rel As Relation _
) As Boolean
Visual C++
public:
bool Equals(
    Relation^ rel
)

Parameters

rel
Type: FastReport.Data..::.Relation
Another relation to compare with.

Return Value

true if both relations are equal; false otherwise.

See Also

Relation Class
Equals Overload
FastReport.Data Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
Relation..::.InvokeEditor Method
Relation Class See Also Send Feedback
Invokes the relation editor.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if relation was modified.

Implements

IHasEditor..::.InvokeEditor()()()

See Also

Relation Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Relation..::.MemberwiseClone Method
Relation Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Relation Class
Relation Members
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Relation..::.Serialize Method
Relation Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Relation Class
FastReport.Data Namespace


Relation Properties

[image] [image]

FastReport.Net Class Reference
Relation Properties
Relation Class See Also Send Feedback

The Relation type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildColumns | Gets or sets an array of child datasource columns.
ChildDataSource | Gets or sets the child datasource.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ParentColumns | Gets or sets an array of parent datasource columns.
ParentDataSource | Gets or sets the parent datasource.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Relation Class
FastReport.Data Namespace


ChildColumns Property

[image]

FastReport.Net Class Reference
Relation..::.ChildColumns Property
Relation Class See Also Send Feedback
Gets or sets an array of child datasource columns.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string[] ChildColumns { get; set; }
Visual Basic (Declaration)
Public Property ChildColumns As String()
Visual C++
public:
property array<String^>^ ChildColumns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

Note: both ParentColumns and ChildColumns must have the same number of elements.

See Also

Relation Class
FastReport.Data Namespace


ChildDataSource Property

[image]

FastReport.Net Class Reference
Relation..::.ChildDataSource Property
Relation Class See Also Send Feedback
Gets or sets the child datasource.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase ChildDataSource { get; set; }
Visual Basic (Declaration)
Public Property ChildDataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ ChildDataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

Relation Class
FastReport.Data Namespace


ParentColumns Property

[image]

FastReport.Net Class Reference
Relation..::.ParentColumns Property
Relation Class See Also Send Feedback
Gets or sets an array of parent datasource columns.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string[] ParentColumns { get; set; }
Visual Basic (Declaration)
Public Property ParentColumns As String()
Visual C++
public:
property array<String^>^ ParentColumns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

Note: both ParentColumns and ChildColumns must have the same number of elements.

See Also

Relation Class
FastReport.Data Namespace


ParentDataSource Property

[image]

FastReport.Net Class Reference
Relation..::.ParentDataSource Property
Relation Class See Also Send Feedback
Gets or sets the parent datasource.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase ParentDataSource { get; set; }
Visual Basic (Declaration)
Public Property ParentDataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ ParentDataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

Relation Class
FastReport.Data Namespace


Relation Events

[image] [image]

FastReport.Net Class Reference
Relation Events
Relation Class See Also Send Feedback

The Relation type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Relation Class
FastReport.Data Namespace


RelationCollection Class

[image]

FastReport.Net Class Reference
RelationCollection Class
Members See Also Send Feedback
Represents the collection of Relation objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RelationCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class RelationCollection _
    Inherits FRCollectionBase
Visual C++
public ref class RelationCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.RelationCollection

See Also

RelationCollection Members
FastReport.Data Namespace


RelationCollection Members

[image] [image]

FastReport.Net Class Reference
RelationCollection Members
RelationCollection Class Constructors Methods Properties See Also Send Feedback

The RelationCollection type exposes the following members.

Constructors

Name | Description
RelationCollection | Initializes a new instance of the RelationCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByAlias | Finds a relation by its alias.
FindByName | Finds a relation by its name.
FindEqual | Finds a relation that is equal to specified one.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a relation.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

RelationCollection Class
FastReport.Data Namespace


RelationCollection Constructor

[image]

FastReport.Net Class Reference
RelationCollection Constructor
RelationCollection Class See Also Send Feedback
Initializes a new instance of the RelationCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RelationCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
RelationCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

RelationCollection Class
FastReport.Data Namespace


RelationCollection Methods

[image] [image]

FastReport.Net Class Reference
RelationCollection Methods
RelationCollection Class See Also Send Feedback

The RelationCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByAlias | Finds a relation by its alias.
FindByName | Finds a relation by its name.
FindEqual | Finds a relation that is equal to specified one.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RelationCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
RelationCollection..::.AddRange Method
RelationCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

RelationCollection Class
RelationCollection Members
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
RelationCollection..::.Equals Method
RelationCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

RelationCollection Class
RelationCollection Members
FastReport.Data Namespace


FindByAlias Method

[image]

FastReport.Net Class Reference
RelationCollection..::.FindByAlias Method
RelationCollection Class See Also Send Feedback
Finds a relation by its alias.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Relation FindByAlias(
    string alias
)
Visual Basic (Declaration)
Public Function FindByAlias ( _
    alias As String _
) As Relation
Visual C++
public:
Relation^ FindByAlias(
    String^ alias
)

Parameters

alias
Type: System..::.String
The alias of a relation.

Return Value

The Relation object if found; otherwise null.

See Also

RelationCollection Class
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
RelationCollection..::.FindByName Method
RelationCollection Class See Also Send Feedback
Finds a relation by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Relation FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As Relation
Visual C++
public:
Relation^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The name of a relation.

Return Value

The Relation object if found; otherwise null.

See Also

RelationCollection Class
FastReport.Data Namespace


FindEqual Method

[image]

FastReport.Net Class Reference
RelationCollection..::.FindEqual Method
RelationCollection Class See Also Send Feedback
Finds a relation that is equal to specified one.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Relation FindEqual(
    Relation rel
)
Visual Basic (Declaration)
Public Function FindEqual ( _
    rel As Relation _
) As Relation
Visual C++
public:
Relation^ FindEqual(
    Relation^ rel
)

Parameters

rel
Type: FastReport.Data..::.Relation
Another relation to compare with.

Return Value

The Relation object if found; otherwise null.

See Also

RelationCollection Class
FastReport.Data Namespace


RelationCollection Properties

[image] [image]

FastReport.Net Class Reference
RelationCollection Properties
RelationCollection Class See Also Send Feedback

The RelationCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a relation.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

RelationCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
RelationCollection..::.Item Property
RelationCollection Class See Also Send Feedback
Gets or sets a relation.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Relation this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Relation
Visual C++
public:
property Relation^ default[int index] {
    Relation^ get (int index);
    void set (int index, Relation^ value);
}

Parameters

index
Type: System..::.Int32
The index of a relation in this collection.

Return Value

The relation with specified index.

See Also

RelationCollection Class
FastReport.Data Namespace


RowVariable Class

[image]

FastReport.Net Class Reference
RowVariable Class
Members See Also Send Feedback
Returns data row number inside the group. This value is reset at the start of a new group.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RowVariable : SystemVariable
Visual Basic (Declaration)
Public Class RowVariable _
    Inherits SystemVariable
Visual C++
public ref class RowVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.RowVariable

See Also

RowVariable Members
FastReport.Data Namespace


RowVariable Members

[image] [image]

FastReport.Net Class Reference
RowVariable Members
RowVariable Class Methods Properties Events See Also Send Feedback

The RowVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

RowVariable Class
FastReport.Data Namespace


RowVariable Methods

[image] [image]

FastReport.Net Class Reference
RowVariable Methods
RowVariable Class See Also Send Feedback

The RowVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

RowVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
RowVariable..::.Dispose Method
RowVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

RowVariable Class
RowVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
RowVariable..::.MemberwiseClone Method
RowVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RowVariable Class
RowVariable Members
FastReport.Data Namespace


RowVariable Properties

[image] [image]

FastReport.Net Class Reference
RowVariable Properties
RowVariable Class See Also Send Feedback

The RowVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

RowVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
RowVariable..::.Value Property
RowVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

RowVariable Class
FastReport.Data Namespace


RowVariable Events

[image] [image]

FastReport.Net Class Reference
RowVariable Events
RowVariable Class See Also Send Feedback

The RowVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

RowVariable Class
FastReport.Data Namespace


SystemVariable Class

[image]

FastReport.Net Class Reference
SystemVariable Class
Members See Also Send Feedback
Represents the base class for system variables.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SystemVariable : Parameter
Visual Basic (Declaration)
Public Class SystemVariable _
    Inherits Parameter
Visual C++
public ref class SystemVariable : public Parameter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.AbsRowVariable
FastReport.Data..::.CopyNameMacroVariable
FastReport.Data..::.DateVariable
FastReport.Data..::.HierarchyLevelVariable
FastReport.Data..::.HierarchyRowNoVariable
FastReport.Data..::.PageMacroVariable
FastReport.Data..::.PageNofMVariable
FastReport.Data..::.PageNVariable
FastReport.Data..::.PageVariable
FastReport.Data..::.RowVariable
FastReport.Data..::.TotalPagesMacroVariable
FastReport.Data..::.TotalPagesVariable

See Also

SystemVariable Members
FastReport.Data Namespace


SystemVariable Members

[image] [image]

FastReport.Net Class Reference
SystemVariable Members
SystemVariable Class Constructors Methods Properties Events See Also Send Feedback

The SystemVariable type exposes the following members.

Constructors

Name | Description
SystemVariable | Initializes a new instance of the SystemVariable class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides Parameter..::.CanContain(Base).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Inherited from Parameter.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

SystemVariable Class
FastReport.Data Namespace


SystemVariable Constructor

[image]

FastReport.Net Class Reference
SystemVariable Constructor
SystemVariable Class See Also Send Feedback
Initializes a new instance of the SystemVariable class

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SystemVariable()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SystemVariable()

See Also

SystemVariable Class
FastReport.Data Namespace


SystemVariable Methods

[image] [image]

FastReport.Net Class Reference
SystemVariable Methods
SystemVariable Class See Also Send Feedback

The SystemVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides Parameter..::.CanContain(Base).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

SystemVariable Class
FastReport.Data Namespace


CanContain Method

[image]

FastReport.Net Class Reference
SystemVariable..::.CanContain Method
SystemVariable Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overrides Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

SystemVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
SystemVariable..::.Dispose Method
SystemVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

SystemVariable Class
SystemVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
SystemVariable..::.MemberwiseClone Method
SystemVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SystemVariable Class
SystemVariable Members
FastReport.Data Namespace


SystemVariable Properties

[image] [image]

FastReport.Net Class Reference
SystemVariable Properties
SystemVariable Class See Also Send Feedback

The SystemVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Inherited from Parameter.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

SystemVariable Class
FastReport.Data Namespace


Description Property

[image]

FastReport.Net Class Reference
SystemVariable..::.Description Property
SystemVariable Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SystemVariable Class
FastReport.Data Namespace


Expression Property

[image]

FastReport.Net Class Reference
SystemVariable..::.Expression Property
SystemVariable Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

SystemVariable Class
FastReport.Data Namespace


SystemVariable Events

[image] [image]

FastReport.Net Class Reference
SystemVariable Events
SystemVariable Class See Also Send Feedback

The SystemVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

SystemVariable Class
FastReport.Data Namespace


SystemVariables Class

[image]

FastReport.Net Class Reference
SystemVariables Class
Members See Also Send Feedback
Represents the collection of system variables.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SystemVariables : ParameterCollection
Visual Basic (Declaration)
Public Class SystemVariables _
    Inherits ParameterCollection
Visual C++
public ref class SystemVariables : public ParameterCollection

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.ParameterCollection
FastReport.Data..::.SystemVariables

See Also

SystemVariables Members
FastReport.Data Namespace


SystemVariables Members

[image] [image]

FastReport.Net Class Reference
SystemVariables Members
SystemVariables Class Methods Properties See Also Send Feedback

The SystemVariables type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Assign | Copies the parameters from other collection. (Inherited from ParameterCollection.)
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique parameter name based on given name. (Inherited from ParameterCollection.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a parameter by its name. (Inherited from ParameterCollection.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a parameter. (Inherited from ParameterCollection.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

SystemVariables Class
FastReport.Data Namespace


SystemVariables Methods

[image] [image]

FastReport.Net Class Reference
SystemVariables Methods
SystemVariables Class See Also Send Feedback

The SystemVariables type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Assign | Copies the parameters from other collection. (Inherited from ParameterCollection.)
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique parameter name based on given name. (Inherited from ParameterCollection.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a parameter by its name. (Inherited from ParameterCollection.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemVariables Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
SystemVariables..::.AddRange Method
SystemVariables Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

SystemVariables Class
SystemVariables Members
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
SystemVariables..::.Equals Method
SystemVariables Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

SystemVariables Class
SystemVariables Members
FastReport.Data Namespace


SystemVariables Properties

[image] [image]

FastReport.Net Class Reference
SystemVariables Properties
SystemVariables Class See Also Send Feedback

The SystemVariables type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a parameter. (Inherited from ParameterCollection.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

SystemVariables Class
FastReport.Data Namespace


TableCollection Class

[image]

FastReport.Net Class Reference
TableCollection Class
Members See Also Send Feedback
Represents the collection of TableDataSource objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class TableCollection _
    Inherits FRCollectionBase
Visual C++
public ref class TableCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.TableCollection

See Also

TableCollection Members
FastReport.Data Namespace


TableCollection Members

[image] [image]

FastReport.Net Class Reference
TableCollection Members
TableCollection Class Constructors Methods Properties See Also Send Feedback

The TableCollection type exposes the following members.

Constructors

Name | Description
TableCollection | Initializes a new instance of the TableCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a data table.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TableCollection Class
FastReport.Data Namespace


TableCollection Constructor

[image]

FastReport.Net Class Reference
TableCollection Constructor
TableCollection Class See Also Send Feedback
Initializes a new instance of the TableCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
TableCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

TableCollection Class
FastReport.Data Namespace


TableCollection Methods

[image] [image]

FastReport.Net Class Reference
TableCollection Methods
TableCollection Class See Also Send Feedback

The TableCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
TableCollection..::.AddRange Method
TableCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

TableCollection Class
TableCollection Members
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
TableCollection..::.Equals Method
TableCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

TableCollection Class
TableCollection Members
FastReport.Data Namespace


TableCollection Properties

[image] [image]

FastReport.Net Class Reference
TableCollection Properties
TableCollection Class See Also Send Feedback

The TableCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a data table.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TableCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
TableCollection..::.Item Property
TableCollection Class See Also Send Feedback
Gets or sets a data table.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableDataSource this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As TableDataSource
Visual C++
public:
property TableDataSource^ default[int index] {
    TableDataSource^ get (int index);
    void set (int index, TableDataSource^ value);
}

Parameters

index
Type: System..::.Int32
The index of a data table in this collection.

Return Value

The data table with specified index.

See Also

TableCollection Class
FastReport.Data Namespace


TableDataSource Class

[image]

FastReport.Net Class Reference
TableDataSource Class
Members Example See Also Send Feedback
Represents a datasource based on DataTable class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableDataSource : DataSourceBase,
    IHasEditor
Visual Basic (Declaration)
Public Class TableDataSource _
    Inherits DataSourceBase _
    Implements IHasEditor
Visual C++
public ref class TableDataSource : public DataSourceBase,
    IHasEditor

Examples

This example shows how to add a new table to the existing connection:
CopyC#
Report report1;
DataConnectionBase conn = report1.Dictionary.Connections.FindByName("Connection1");
TableDataSource table = new TableDataSource();
table.TableName = "Employees";
table.Name = "Table1";
conn.Tables.Add(table);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Column
FastReport.Data..::.DataSourceBase
FastReport.Data..::.TableDataSource

See Also

TableDataSource Members
FastReport.Data Namespace


TableDataSource Members

[image] [image]

FastReport.Net Class Reference
TableDataSource Members
TableDataSource Class Constructors Methods Properties Events See Also Send Feedback

The TableDataSource type exposes the following members.

Constructors

Name | Description
TableDataSource | Initializes a new instance of the TableDataSource class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Overrides Column..::.AddChild(Base).)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides Column..::.CanContain(Base).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Inherited from DataSourceBase.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet. (Inherited from DataSourceBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row. (Inherited from DataSourceBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides Column..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Overrides DataSourceBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema. (Overrides DataSourceBase..::.InitSchema()()().)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data. (Overrides DataSourceBase..::.LoadData(ArrayList).)
MemberwiseClone | Overloaded.
Next | Navigates to the next row. (Inherited from DataSourceBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row. (Inherited from DataSourceBase.)
RefreshTable | Refresh the table schema.
RemoveChild | Removes a specified object from this object's childs. (Overrides Column..::.RemoveChild(Base).)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataSourceBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Overrides Base..::.SetParent(Base).)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
Calculated | This property is not relevant to this class. (Inherited from DataSourceBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Connection | Gets or sets the parent DataConnectionBase object.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row. (Inherited from DataSourceBase.)
CurrentRowNo | Gets an index of current data row. (Inherited from DataSourceBase.)
CustomBindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
DataType | This property is not relevant to this class. (Inherited from DataSourceBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from DataSourceBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource. (Inherited from DataSourceBase.)
Format | This property is not relevant to this class. (Inherited from DataSourceBase.)
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount. (Inherited from DataSourceBase.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of parameters used by "select" command.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
QbSchema | Gets or sets the query builder schema.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource. (Inherited from DataSourceBase.)
SelectCommand | Gets or sets SQL "select" command.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StoreData | Gets or sets a value that determines whether it is necessary to store table data in a report file.
Table | Gets or sets the underlying DataTable object.
TableData | Gets or sets the table data.
TableName | Gets or sets the table name.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data. (Inherited from DataSourceBase.)

See Also

TableDataSource Class
FastReport.Data Namespace


TableDataSource Constructor

[image]

FastReport.Net Class Reference
TableDataSource Constructor
TableDataSource Class See Also Send Feedback
Initializes a new instance of the TableDataSource class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableDataSource()

See Also

TableDataSource Class
FastReport.Data Namespace


TableDataSource Methods

[image] [image]

FastReport.Net Class Reference
TableDataSource Methods
TableDataSource Class See Also Send Feedback

The TableDataSource type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Overrides Column..::.AddChild(Base).)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Overrides Column..::.CanContain(Base).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Inherited from DataSourceBase.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet. (Inherited from DataSourceBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row. (Inherited from DataSourceBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides Column..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Overrides DataSourceBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema. (Overrides DataSourceBase..::.InitSchema()()().)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data. (Overrides DataSourceBase..::.LoadData(ArrayList).)
MemberwiseClone | Overloaded.
Next | Navigates to the next row. (Inherited from DataSourceBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row. (Inherited from DataSourceBase.)
RefreshTable | Refresh the table schema.
RemoveChild | Removes a specified object from this object's childs. (Overrides Column..::.RemoveChild(Base).)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataSourceBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Overrides Base..::.SetParent(Base).)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

See Also

TableDataSource Class
FastReport.Data Namespace


AddChild Method

[image]

FastReport.Net Class Reference
TableDataSource..::.AddChild Method
TableDataSource Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overrides Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

TableDataSource Class
FastReport.Data Namespace


CanContain Method

[image]

FastReport.Net Class Reference
TableDataSource..::.CanContain Method
TableDataSource Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overrides Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

TableDataSource Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableDataSource..::.Dispose Method
TableDataSource Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

TableDataSource Class
TableDataSource Members
FastReport.Data Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
TableDataSource..::.Dispose Method (Boolean)
TableDataSource Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

TableDataSource Class
Dispose Overload
FastReport.Data Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
TableDataSource..::.GetChildObjects Method
TableDataSource Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overrides Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) override

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

TableDataSource Class
FastReport.Data Namespace


GetValue Method

[image] [image]

FastReport.Net Class Reference
TableDataSource..::.GetValue Method
TableDataSource Class See Also Send Feedback

Overload List

Name | Description
GetValue(String) | Gets data stored in a specified column. (Inherited from DataSourceBase.)
GetValue(Column) | Gets data stored in a specified column. (Overrides DataSourceBase..::.GetValue(Column).)

See Also

TableDataSource Class
TableDataSource Members
FastReport.Data Namespace


GetValue Method (Column)

[image]

FastReport.Net Class Reference
TableDataSource..::.GetValue Method (Column)
TableDataSource Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue(
    Column column
)
Visual Basic (Declaration)
Protected Overrides Function GetValue ( _
    column As Column _
) As Object
Visual C++
protected:
virtual Object^ GetValue(
    Column^ column
) override

Parameters

column
Type: FastReport.Data..::.Column
The column.

Return Value

An object that contains the data.

See Also

TableDataSource Class
GetValue Overload
FastReport.Data Namespace


Init Method

[image] [image]

FastReport.Net Class Reference
TableDataSource..::.Init Method
TableDataSource Class See Also Send Feedback

Overload List

Name | Description
Init()()() | Initializes this datasource. (Inherited from DataSourceBase.)
Init(DataSourceBase) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. (Inherited from DataSourceBase.)
Init(String) | Initializes this datasource and applies the specified filter. (Inherited from DataSourceBase.)
Init(String, SortCollection) | Initializes this datasource, applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)
Init(DataSourceBase, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. Also applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)
Init(Relation, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation. Also applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)

See Also

TableDataSource Class
TableDataSource Members
FastReport.Data Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
TableDataSource..::.InitializeComponent Method
TableDataSource Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

TableDataSource Class
FastReport.Data Namespace


InitSchema Method

[image]

FastReport.Net Class Reference
TableDataSource..::.InitSchema Method
TableDataSource Class See Also Send Feedback
Initializes the datasource schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitSchema()
Visual Basic (Declaration)
Public Overrides Sub InitSchema
Visual C++
public:
virtual void InitSchema() override

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

TableDataSource Class
FastReport.Data Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
TableDataSource..::.InvokeEditor Method
TableDataSource Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

TableDataSource Class
FastReport.Data Namespace


LoadData Method

[image]

FastReport.Net Class Reference
TableDataSource..::.LoadData Method
TableDataSource Class See Also Send Feedback
Loads the datasource with data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void LoadData(
    ArrayList rows
)
Visual Basic (Declaration)
Public Overrides Sub LoadData ( _
    rows As ArrayList _
)
Visual C++
public:
virtual void LoadData(
    ArrayList^ rows
) override

Parameters

rows
Type: System.Collections..::.ArrayList
Rows to fill with data.

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

TableDataSource Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableDataSource..::.MemberwiseClone Method
TableDataSource Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableDataSource Class
TableDataSource Members
FastReport.Data Namespace


RefreshTable Method

[image]

FastReport.Net Class Reference
TableDataSource..::.RefreshTable Method
TableDataSource Class See Also Send Feedback
Refresh the table schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RefreshTable()
Visual Basic (Declaration)
Public Sub RefreshTable
Visual C++
public:
void RefreshTable()

See Also

TableDataSource Class
FastReport.Data Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
TableDataSource..::.RemoveChild Method
TableDataSource Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overrides Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) override

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

TableDataSource Class
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TableDataSource..::.Serialize Method
TableDataSource Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TableDataSource Class
FastReport.Data Namespace


SetParent Method

[image]

FastReport.Net Class Reference
TableDataSource..::.SetParent Method
TableDataSource Class See Also Send Feedback
Sets the object's parent.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetParent(
    Base value
)
Visual Basic (Declaration)
Public Overrides Sub SetParent ( _
    value As Base _
)
Visual C++
public:
virtual void SetParent(
    Base^ value
) override

Parameters

value
Type: FastReport..::.Base
New parent.

Remarks

This method is for internal use only. You can use it if you are developing a new component for FastReport. Override it to perform some actions when the parent of an object is changing. This method checks that parent can contain a child.

Exceptions

Exception | Condition
FastReport.Utils..::.ParentException | Parent object cannot contain this object.

See Also

TableDataSource Class
FastReport.Data Namespace


TableDataSource Properties

[image] [image]

FastReport.Net Class Reference
TableDataSource Properties
TableDataSource Class See Also Send Feedback

The TableDataSource type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
Calculated | This property is not relevant to this class. (Inherited from DataSourceBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Connection | Gets or sets the parent DataConnectionBase object.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row. (Inherited from DataSourceBase.)
CurrentRowNo | Gets an index of current data row. (Inherited from DataSourceBase.)
CustomBindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
DataType | This property is not relevant to this class. (Inherited from DataSourceBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from DataSourceBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource. (Inherited from DataSourceBase.)
Format | This property is not relevant to this class. (Inherited from DataSourceBase.)
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount. (Inherited from DataSourceBase.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of parameters used by "select" command.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
QbSchema | Gets or sets the query builder schema.
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource. (Inherited from DataSourceBase.)
SelectCommand | Gets or sets SQL "select" command.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StoreData | Gets or sets a value that determines whether it is necessary to store table data in a report file.
Table | Gets or sets the underlying DataTable object.
TableData | Gets or sets the table data.
TableName | Gets or sets the table name.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableDataSource Class
FastReport.Data Namespace


Connection Property

[image]

FastReport.Net Class Reference
TableDataSource..::.Connection Property
TableDataSource Class See Also Send Feedback
Gets or sets the parent DataConnectionBase object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataConnectionBase Connection { get; set; }
Visual Basic (Declaration)
Public Property Connection As DataConnectionBase
Visual C++
public:
property DataConnectionBase^ Connection {
    DataConnectionBase^ get ();
    void set (DataConnectionBase^ value);
}

See Also

TableDataSource Class
FastReport.Data Namespace


Item Property

[image] [image]

FastReport.Net Class Reference
TableDataSource..::.Item Property
TableDataSource Class See Also Send Feedback

Overload List

Name | Description
Item[([(Column])]) | Gets data stored in a specified column. (Inherited from DataSourceBase.)
Item[([(String])]) | Gets data stored in a specified column. (Inherited from DataSourceBase.)

See Also

TableDataSource Class
TableDataSource Members
FastReport.Data Namespace


Parameters Property

[image]

FastReport.Net Class Reference
TableDataSource..::.Parameters Property
TableDataSource Class See Also Send Feedback
Gets a collection of parameters used by "select" command.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CommandParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As CommandParameterCollection
Visual C++
public:
property CommandParameterCollection^ Parameters {
    CommandParameterCollection^ get ();
}

Remarks

You must set up this property if the SQL query that you've specified in the SelectCommand property contains parameters.

You can pass a value to the SQL parameter in two ways.

The right way is to define a report parameter. You can do this in the "Data" window. Once you have defined the parameter, you can use it to pass a value to the SQL parameter. To do this, set the SQL parameter's Expression property to the report parameter's name (so it will look like [myReportParam]). To pass a value to the report parameter from your application, use the SetParameterValue(String, Object) method.

The other way (unrecommended) is to find a datasource object and set its parameter from a code:

CopyC#
TableDataSource ds = report.GetDataSource("My DataSource Name") as TableDataSource;
ds.Parameters[0].Value = 10;
This way is not good because you hardcode the report object's name.

See Also

TableDataSource Class
FastReport.Data Namespace


QbSchema Property

[image]

FastReport.Net Class Reference
TableDataSource..::.QbSchema Property
TableDataSource Class See Also Send Feedback
Gets or sets the query builder schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string QbSchema { get; set; }
Visual Basic (Declaration)
Public Property QbSchema As String
Visual C++
public:
property String^ QbSchema {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for internal use only.

See Also

TableDataSource Class
FastReport.Data Namespace


SelectCommand Property

[image]

FastReport.Net Class Reference
TableDataSource..::.SelectCommand Property
TableDataSource Class See Also Send Feedback
Gets or sets SQL "select" command.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectCommand { get; set; }
Visual Basic (Declaration)
Public Property SelectCommand As String
Visual C++
public:
property String^ SelectCommand {
    String^ get ();
    void set (String^ value);
}

Remarks

If this command contains parameters, you should specify them in the Parameters property.

See Also

TableDataSource Class
FastReport.Data Namespace


StoreData Property

[image]

FastReport.Net Class Reference
TableDataSource..::.StoreData Property
TableDataSource Class See Also Send Feedback
Gets or sets a value that determines whether it is necessary to store table data in a report file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StoreData { get; set; }
Visual Basic (Declaration)
Public Property StoreData As Boolean
Visual C++
public:
property bool StoreData {
    bool get ();
    void set (bool value);
}

See Also

TableDataSource Class
FastReport.Data Namespace


Table Property

[image]

FastReport.Net Class Reference
TableDataSource..::.Table Property
TableDataSource Class See Also Send Feedback
Gets or sets the underlying DataTable object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataTable Table { get; set; }
Visual Basic (Declaration)
Public Property Table As DataTable
Visual C++
public:
property DataTable^ Table {
    DataTable^ get ();
    void set (DataTable^ value);
}

See Also

TableDataSource Class
FastReport.Data Namespace


TableData Property

[image]

FastReport.Net Class Reference
TableDataSource..::.TableData Property
TableDataSource Class See Also Send Feedback
Gets or sets the table data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TableData { get; set; }
Visual Basic (Declaration)
Public Property TableData As String
Visual C++
public:
property String^ TableData {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for internal use only.

See Also

TableDataSource Class
FastReport.Data Namespace


TableName Property

[image]

FastReport.Net Class Reference
TableDataSource..::.TableName Property
TableDataSource Class See Also Send Feedback
Gets or sets the table name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TableName { get; set; }
Visual Basic (Declaration)
Public Property TableName As String
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

See Also

TableDataSource Class
FastReport.Data Namespace


TableDataSource Events

[image] [image]

FastReport.Net Class Reference
TableDataSource Events
TableDataSource Class See Also Send Feedback

The TableDataSource type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data. (Inherited from DataSourceBase.)

See Also

TableDataSource Class
FastReport.Data Namespace


Total Class

[image]

FastReport.Net Class Reference
Total Class
Members See Also Send Feedback
Represents a total that is used to calculate aggregates such as Sum, Min, Max, Avg, Count.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Total : Base, IHasEditor
Visual Basic (Declaration)
Public Class Total _
    Inherits Base _
    Implements IHasEditor
Visual C++
public ref class Total : public Base,
    IHasEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Total

See Also

Total Members
FastReport.Data Namespace


Total Members

[image] [image]

FastReport.Net Class Reference
Total Members
Total Class Constructors Methods Properties Events See Also Send Feedback

The Total type exposes the following members.

Constructors

Name | Description
Total | Initializes a new instance of the Total class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EvaluateCondition | Gets or sets the condition which tells the total to evaluate.
Evaluator | Gets or sets the evaluator databand.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets the expression used to calculate the total.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IncludeInvisibleRows | Gets or sets a value that determines if invisible rows of the Evaluator should be included into the total's value.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintOn | Gets or sets the band to print the total on.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResetAfterPrint | Gets or sets a value that determines whether the total should be resetted after print.
ResetOnReprint | Gets or sets a value that determines whether the total should be resetted if printed on repeated band (i.e. band with "RepeatOnEveryPage" flag).
Resetter | This property is kept for compatibility only.
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
TotalType | Gets or sets the total type.
Value | Gets the value of total.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Total Class
FastReport.Data Namespace


Total Constructor

[image]

FastReport.Net Class Reference
Total Constructor
Total Class See Also Send Feedback
Initializes a new instance of the Total class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Total()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Total()

See Also

Total Class
FastReport.Data Namespace


Total Methods

[image] [image]

FastReport.Net Class Reference
Total Methods
Total Class See Also Send Feedback

The Total type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Total Class
FastReport.Data Namespace


Assign Method

[image]

FastReport.Net Class Reference
Total..::.Assign Method
Total Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

Total Class
FastReport.Data Namespace
AssignAll Method


Clear Method

[image]

FastReport.Net Class Reference
Total..::.Clear Method
Total Class See Also Send Feedback
Clears the object's state.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

This method also disposes all object's children.

See Also

Total Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Total..::.Dispose Method
Total Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Total Class
Total Members
FastReport.Data Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
Total..::.GetExpressions Method
Total Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

Total Class
FastReport.Data Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
Total..::.InvokeEditor Method
Total Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

Total Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Total..::.MemberwiseClone Method
Total Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Total Class
Total Members
FastReport.Data Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Total..::.Serialize Method
Total Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Total Class
FastReport.Data Namespace


Total Properties

[image] [image]

FastReport.Net Class Reference
Total Properties
Total Class See Also Send Feedback

The Total type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EvaluateCondition | Gets or sets the condition which tells the total to evaluate.
Evaluator | Gets or sets the evaluator databand.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | Gets or sets the expression used to calculate the total.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IncludeInvisibleRows | Gets or sets a value that determines if invisible rows of the Evaluator should be included into the total's value.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintOn | Gets or sets the band to print the total on.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResetAfterPrint | Gets or sets a value that determines whether the total should be resetted after print.
ResetOnReprint | Gets or sets a value that determines whether the total should be resetted if printed on repeated band (i.e. band with "RepeatOnEveryPage" flag).
Resetter | This property is kept for compatibility only.
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
TotalType | Gets or sets the total type.
Value | Gets the value of total.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Total Class
FastReport.Data Namespace


EvaluateCondition Property

[image]

FastReport.Net Class Reference
Total..::.EvaluateCondition Property
Total Class See Also Send Feedback
Gets or sets the condition which tells the total to evaluate.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string EvaluateCondition { get; set; }
Visual Basic (Declaration)
Public Property EvaluateCondition As String
Visual C++
public:
property String^ EvaluateCondition {
    String^ get ();
    void set (String^ value);
}

See Also

Total Class
FastReport.Data Namespace


Evaluator Property

[image]

FastReport.Net Class Reference
Total..::.Evaluator Property
Total Class See Also Send Feedback
Gets or sets the evaluator databand.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataBand Evaluator { get; set; }
Visual Basic (Declaration)
Public Property Evaluator As DataBand
Visual C++
public:
property DataBand^ Evaluator {
    DataBand^ get ();
    void set (DataBand^ value);
}

Remarks

The total will be calculated for each row of this band.

See Also

Total Class
FastReport.Data Namespace


Expression Property

[image]

FastReport.Net Class Reference
Total..::.Expression Property
Total Class See Also Send Feedback
Gets or sets the expression used to calculate the total.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

Total Class
FastReport.Data Namespace


IncludeInvisibleRows Property

[image]

FastReport.Net Class Reference
Total..::.IncludeInvisibleRows Property
Total Class See Also Send Feedback
Gets or sets a value that determines if invisible rows of the Evaluator should be included into the total's value.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IncludeInvisibleRows { get; set; }
Visual Basic (Declaration)
Public Property IncludeInvisibleRows As Boolean
Visual C++
public:
property bool IncludeInvisibleRows {
    bool get ();
    void set (bool value);
}

See Also

Total Class
FastReport.Data Namespace


PrintOn Property

[image]

FastReport.Net Class Reference
Total..::.PrintOn Property
Total Class See Also Send Feedback
Gets or sets the band to print the total on.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandBase PrintOn { get; set; }
Visual Basic (Declaration)
Public Property PrintOn As BandBase
Visual C++
public:
property BandBase^ PrintOn {
    BandBase^ get ();
    void set (BandBase^ value);
}

Remarks

The total will be resetted after the specified band has been printed.

See Also

Total Class
FastReport.Data Namespace


ResetAfterPrint Property

[image]

FastReport.Net Class Reference
Total..::.ResetAfterPrint Property
Total Class See Also Send Feedback
Gets or sets a value that determines whether the total should be resetted after print.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ResetAfterPrint { get; set; }
Visual Basic (Declaration)
Public Property ResetAfterPrint As Boolean
Visual C++
public:
property bool ResetAfterPrint {
    bool get ();
    void set (bool value);
}

See Also

Total Class
FastReport.Data Namespace


ResetOnReprint Property

[image]

FastReport.Net Class Reference
Total..::.ResetOnReprint Property
Total Class See Also Send Feedback
Gets or sets a value that determines whether the total should be resetted if printed on repeated band (i.e. band with "RepeatOnEveryPage" flag).

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ResetOnReprint { get; set; }
Visual Basic (Declaration)
Public Property ResetOnReprint As Boolean
Visual C++
public:
property bool ResetOnReprint {
    bool get ();
    void set (bool value);
}

See Also

Total Class
FastReport.Data Namespace


Resetter Property

[image]

FastReport.Net Class Reference
Total..::.Resetter Property
Total Class See Also Send Feedback
This property is kept for compatibility only.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandBase Resetter { get; set; }
Visual Basic (Declaration)
Public Property Resetter As BandBase
Visual C++
public:
property BandBase^ Resetter {
    BandBase^ get ();
    void set (BandBase^ value);
}

See Also

Total Class
FastReport.Data Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
Total..::.Restrictions Property
Total Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

Total Class
FastReport.Data Namespace


TotalType Property

[image]

FastReport.Net Class Reference
Total..::.TotalType Property
Total Class See Also Send Feedback
Gets or sets the total type.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TotalType TotalType { get; set; }
Visual Basic (Declaration)
Public Property TotalType As TotalType
Visual C++
public:
property TotalType TotalType {
    TotalType get ();
    void set (TotalType value);
}

See Also

Total Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
Total..::.Value Property
Total Class See Also Send Feedback
Gets the value of total.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

Total Class
FastReport.Data Namespace


Total Events

[image] [image]

FastReport.Net Class Reference
Total Events
Total Class See Also Send Feedback

The Total type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Total Class
FastReport.Data Namespace


TotalCollection Class

[image]

FastReport.Net Class Reference
TotalCollection Class
Members See Also Send Feedback
Represents the collection of Total objects.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TotalCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class TotalCollection _
    Inherits FRCollectionBase
Visual C++
public ref class TotalCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Data..::.TotalCollection

See Also

TotalCollection Members
FastReport.Data Namespace


TotalCollection Members

[image] [image]

FastReport.Net Class Reference
TotalCollection Members
TotalCollection Class Constructors Methods Properties See Also Send Feedback

The TotalCollection type exposes the following members.

Constructors

Name | Description
TotalCollection | Initializes a new instance of the TotalCollection class with default settings.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique total name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a total by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a total.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TotalCollection Class
FastReport.Data Namespace


TotalCollection Constructor

[image]

FastReport.Net Class Reference
TotalCollection Constructor
TotalCollection Class See Also Send Feedback
Initializes a new instance of the TotalCollection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TotalCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
TotalCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

TotalCollection Class
FastReport.Data Namespace


TotalCollection Methods

[image] [image]

FastReport.Net Class Reference
TotalCollection Methods
TotalCollection Class See Also Send Feedback

The TotalCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
CreateUniqueName | Returns an unique total name based on given name.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindByName | Finds a total by its name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TotalCollection Class
FastReport.Data Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
TotalCollection..::.AddRange Method
TotalCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

TotalCollection Class
TotalCollection Members
FastReport.Data Namespace


CreateUniqueName Method

[image]

FastReport.Net Class Reference
TotalCollection..::.CreateUniqueName Method
TotalCollection Class See Also Send Feedback
Returns an unique total name based on given name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CreateUniqueName(
    string name
)
Visual Basic (Declaration)
Public Function CreateUniqueName ( _
    name As String _
) As String
Visual C++
public:
String^ CreateUniqueName(
    String^ name
)

Parameters

name
Type: System..::.String
The base name.

Return Value

The unique name.

See Also

TotalCollection Class
FastReport.Data Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
TotalCollection..::.Equals Method
TotalCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

TotalCollection Class
TotalCollection Members
FastReport.Data Namespace


FindByName Method

[image]

FastReport.Net Class Reference
TotalCollection..::.FindByName Method
TotalCollection Class See Also Send Feedback
Finds a total by its name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Total FindByName(
    string name
)
Visual Basic (Declaration)
Public Function FindByName ( _
    name As String _
) As Total
Visual C++
public:
Total^ FindByName(
    String^ name
)

Parameters

name
Type: System..::.String
The name of a total.

Return Value

The Total object if found; otherwise null.

See Also

TotalCollection Class
FastReport.Data Namespace


TotalCollection Properties

[image] [image]

FastReport.Net Class Reference
TotalCollection Properties
TotalCollection Class See Also Send Feedback

The TotalCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a total.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TotalCollection Class
FastReport.Data Namespace


Item Property

[image]

FastReport.Net Class Reference
TotalCollection..::.Item Property
TotalCollection Class See Also Send Feedback
Gets or sets a total.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Total this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Total
Visual C++
public:
property Total^ default[int index] {
    Total^ get (int index);
    void set (int index, Total^ value);
}

Parameters

index
Type: System..::.Int32
The index of a total in this collection.

Return Value

The total with specified index.

See Also

TotalCollection Class
FastReport.Data Namespace


TotalPagesMacroVariable Class

[image]

FastReport.Net Class Reference
TotalPagesMacroVariable Class
Members See Also Send Feedback
Returns the number of total pages in the report.

This variable is actually a macro. Its value is substituted when the component is viewed in the preview window. That means you cannot use it in an expression.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TotalPagesMacroVariable : SystemVariable
Visual Basic (Declaration)
Public Class TotalPagesMacroVariable _
    Inherits SystemVariable
Visual C++
public ref class TotalPagesMacroVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.TotalPagesMacroVariable

See Also

TotalPagesMacroVariable Members
FastReport.Data Namespace


TotalPagesMacroVariable Members

[image] [image]

FastReport.Net Class Reference
TotalPagesMacroVariable Members
TotalPagesMacroVariable Class Methods Properties Events See Also Send Feedback

The TotalPagesMacroVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TotalPagesMacroVariable Class
FastReport.Data Namespace


TotalPagesMacroVariable Methods

[image] [image]

FastReport.Net Class Reference
TotalPagesMacroVariable Methods
TotalPagesMacroVariable Class See Also Send Feedback

The TotalPagesMacroVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

TotalPagesMacroVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TotalPagesMacroVariable..::.Dispose Method
TotalPagesMacroVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TotalPagesMacroVariable Class
TotalPagesMacroVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TotalPagesMacroVariable..::.MemberwiseClone Method
TotalPagesMacroVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TotalPagesMacroVariable Class
TotalPagesMacroVariable Members
FastReport.Data Namespace


TotalPagesMacroVariable Properties

[image] [image]

FastReport.Net Class Reference
TotalPagesMacroVariable Properties
TotalPagesMacroVariable Class See Also Send Feedback

The TotalPagesMacroVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TotalPagesMacroVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
TotalPagesMacroVariable..::.Value Property
TotalPagesMacroVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

TotalPagesMacroVariable Class
FastReport.Data Namespace


TotalPagesMacroVariable Events

[image] [image]

FastReport.Net Class Reference
TotalPagesMacroVariable Events
TotalPagesMacroVariable Class See Also Send Feedback

The TotalPagesMacroVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TotalPagesMacroVariable Class
FastReport.Data Namespace


TotalPagesVariable Class

[image]

FastReport.Net Class Reference
TotalPagesVariable Class
Members See Also Send Feedback
Returns total number of pages in the report. To use this variable, you need to enable the report's double pass.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TotalPagesVariable : SystemVariable
Visual Basic (Declaration)
Public Class TotalPagesVariable _
    Inherits SystemVariable
Visual C++
public ref class TotalPagesVariable : public SystemVariable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.Parameter
FastReport.Data..::.SystemVariable
FastReport.Data..::.TotalPagesVariable

See Also

TotalPagesVariable Members
FastReport.Data Namespace


TotalPagesVariable Members

[image] [image]

FastReport.Net Class Reference
TotalPagesVariable Members
TotalPagesVariable Class Methods Properties Events See Also Send Feedback

The TotalPagesVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TotalPagesVariable Class
FastReport.Data Namespace


TotalPagesVariable Methods

[image] [image]

FastReport.Net Class Reference
TotalPagesVariable Methods
TotalPagesVariable Class See Also Send Feedback

The TotalPagesVariable type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Parameter.)
Assign | Copies the contents of another, similar object. (Inherited from Parameter.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from SystemVariable.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Parameter.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Parameter.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Parameter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Parameter.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from Parameter.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Parameter.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Parameter.)

See Also

TotalPagesVariable Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TotalPagesVariable..::.Dispose Method
TotalPagesVariable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TotalPagesVariable Class
TotalPagesVariable Members
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TotalPagesVariable..::.MemberwiseClone Method
TotalPagesVariable Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TotalPagesVariable Class
TotalPagesVariable Members
FastReport.Data Namespace


TotalPagesVariable Properties

[image] [image]

FastReport.Net Class Reference
TotalPagesVariable Properties
TotalPagesVariable Class See Also Send Feedback

The TotalPagesVariable type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AsString | Gets or sets value of the parameter as a string. (Inherited from Parameter.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataType | Gets or sets the type of parameter. (Inherited from Parameter.)
Description | This property is not relevant to this class. (Inherited from SystemVariable.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from SystemVariable.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FullName | Gets the full name of the parameter. This is useful to get the nested parameter's full name. (Inherited from Parameter.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parameters | Gets a collection of nested parameters. (Inherited from Parameter.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class. (Inherited from Parameter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Value | Gets or sets the value of parameter. (Overrides Parameter..::.Value.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TotalPagesVariable Class
FastReport.Data Namespace


Value Property

[image]

FastReport.Net Class Reference
TotalPagesVariable..::.Value Property
TotalPagesVariable Class See Also Send Feedback
Gets or sets the value of parameter.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As Object
Visual C++
public:
virtual property Object^ Value {
    Object^ get () override;
}

Remarks

You may specify the static value in this property. Note: if the Expression property is not empty, it will be calculated and its value will be returned.

See Also

TotalPagesVariable Class
FastReport.Data Namespace


TotalPagesVariable Events

[image] [image]

FastReport.Net Class Reference
TotalPagesVariable Events
TotalPagesVariable Class See Also Send Feedback

The TotalPagesVariable type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TotalPagesVariable Class
FastReport.Data Namespace


TotalType Enumeration

[image]

FastReport.Net Class Reference
TotalType Enumeration
See Also Send Feedback
Specifies the total type.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum TotalType
Visual Basic (Declaration)
Public Enumeration TotalType
Visual C++
public enum class TotalType

Members

Member name | Description
Sum | The total returns sum of values.
Min | The total returns minimal value.
Max | The total returns maximal value.
Avg | The total returns average value.
Count | The total returns number of values.

See Also

FastReport.Data Namespace


ViewDataSource Class

[image]

FastReport.Net Class Reference
ViewDataSource Class
Members See Also Send Feedback
Represents a datasource based on DataView class.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ViewDataSource : DataSourceBase
Visual Basic (Declaration)
Public Class ViewDataSource _
    Inherits DataSourceBase
Visual C++
public ref class ViewDataSource : public DataSourceBase

Remarks

This class is used to support FastReport.Net infrastructure, do not use it directly. If you want to use data from DataView object, call the RegisterData(DataView, String) method of the Report.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.Column
FastReport.Data..::.DataSourceBase
FastReport.Data..::.ViewDataSource

See Also

ViewDataSource Members
FastReport.Data Namespace


ViewDataSource Members

[image] [image]

FastReport.Net Class Reference
ViewDataSource Members
ViewDataSource Class Constructors Methods Properties Events See Also Send Feedback

The ViewDataSource type exposes the following members.

Constructors

Name | Description
ViewDataSource | Initializes a new instance of the ViewDataSource class

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Column.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from Column.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Inherited from DataSourceBase.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet. (Inherited from DataSourceBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row. (Inherited from DataSourceBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Column.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Inherited from DataSourceBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema. (Overrides DataSourceBase..::.InitSchema()()().)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data. (Overrides DataSourceBase..::.LoadData(ArrayList).)
MemberwiseClone | Overloaded.
Next | Navigates to the next row. (Inherited from DataSourceBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row. (Inherited from DataSourceBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Column.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataSourceBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
Calculated | This property is not relevant to this class. (Inherited from DataSourceBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row. (Inherited from DataSourceBase.)
CurrentRowNo | Gets an index of current data row. (Inherited from DataSourceBase.)
CustomBindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
DataType | This property is not relevant to this class. (Inherited from DataSourceBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from DataSourceBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource. (Inherited from DataSourceBase.)
Format | This property is not relevant to this class. (Inherited from DataSourceBase.)
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount. (Inherited from DataSourceBase.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource. (Inherited from DataSourceBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
View | Gets the underlying DataView object.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data. (Inherited from DataSourceBase.)

See Also

ViewDataSource Class
FastReport.Data Namespace


ViewDataSource Constructor

[image]

FastReport.Net Class Reference
ViewDataSource Constructor
ViewDataSource Class See Also Send Feedback
Initializes a new instance of the ViewDataSource class

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ViewDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewDataSource()

See Also

ViewDataSource Class
FastReport.Data Namespace


ViewDataSource Methods

[image] [image]

FastReport.Net Class Reference
ViewDataSource Methods
ViewDataSource Class See Also Send Feedback

The ViewDataSource type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from Column.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from Column.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Column.)
Deserialize | Deserializes the object. (Inherited from DataSourceBase.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
EnsureInit | Initializes the data source if it is not initialized yet. (Inherited from DataSourceBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
First | Navigates to the first row. (Inherited from DataSourceBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from Column.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from Column.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Column.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Overloaded.
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init | Overloaded.
InitializeComponent | Initializes the object before running a report. (Inherited from DataSourceBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitSchema | Initializes the datasource schema. (Overrides DataSourceBase..::.InitSchema()()().)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadData | Loads the datasource with data. (Overrides DataSourceBase..::.LoadData(ArrayList).)
MemberwiseClone | Overloaded.
Next | Navigates to the next row. (Inherited from DataSourceBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
Prior | Navigates to the prior row. (Inherited from DataSourceBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from Column.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataSourceBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from Column.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Column.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from Column.)

See Also

ViewDataSource Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ViewDataSource..::.Dispose Method
ViewDataSource Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ViewDataSource Class
ViewDataSource Members
FastReport.Data Namespace


GetValue Method

[image] [image]

FastReport.Net Class Reference
ViewDataSource..::.GetValue Method
ViewDataSource Class See Also Send Feedback

Overload List

Name | Description
GetValue(String) | Gets data stored in a specified column. (Inherited from DataSourceBase.)
GetValue(Column) | Gets data stored in a specified column. (Overrides DataSourceBase..::.GetValue(Column).)

See Also

ViewDataSource Class
ViewDataSource Members
FastReport.Data Namespace


GetValue Method (Column)

[image]

FastReport.Net Class Reference
ViewDataSource..::.GetValue Method (Column)
ViewDataSource Class See Also Send Feedback
Gets data stored in a specified column.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue(
    Column column
)
Visual Basic (Declaration)
Protected Overrides Function GetValue ( _
    column As Column _
) As Object
Visual C++
protected:
virtual Object^ GetValue(
    Column^ column
) override

Parameters

column
Type: FastReport.Data..::.Column
The column.

Return Value

An object that contains the data.

See Also

ViewDataSource Class
GetValue Overload
FastReport.Data Namespace


Init Method

[image] [image]

FastReport.Net Class Reference
ViewDataSource..::.Init Method
ViewDataSource Class See Also Send Feedback

Overload List

Name | Description
Init()()() | Initializes this datasource. (Inherited from DataSourceBase.)
Init(DataSourceBase) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. (Inherited from DataSourceBase.)
Init(String) | Initializes this datasource and applies the specified filter. (Inherited from DataSourceBase.)
Init(String, SortCollection) | Initializes this datasource, applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)
Init(DataSourceBase, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation between this datasource and parentData. Also applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)
Init(Relation, String, SortCollection) | Initializes this datasource and filters data rows according to the master-detail relation. Also applies the specified filter and sorts the rows. (Inherited from DataSourceBase.)

See Also

ViewDataSource Class
ViewDataSource Members
FastReport.Data Namespace


InitSchema Method

[image]

FastReport.Net Class Reference
ViewDataSource..::.InitSchema Method
ViewDataSource Class See Also Send Feedback
Initializes the datasource schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitSchema()
Visual Basic (Declaration)
Public Overrides Sub InitSchema
Visual C++
public:
virtual void InitSchema() override

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

ViewDataSource Class
FastReport.Data Namespace


LoadData Method

[image]

FastReport.Net Class Reference
ViewDataSource..::.LoadData Method
ViewDataSource Class See Also Send Feedback
Loads the datasource with data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void LoadData(
    ArrayList rows
)
Visual Basic (Declaration)
Public Overrides Sub LoadData ( _
    rows As ArrayList _
)
Visual C++
public:
virtual void LoadData(
    ArrayList^ rows
) override

Parameters

rows
Type: System.Collections..::.ArrayList
Rows to fill with data.

Remarks

This method is used to support the FastReport.Net infrastructure. Do not call it directly.

See Also

ViewDataSource Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ViewDataSource..::.MemberwiseClone Method
ViewDataSource Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ViewDataSource Class
ViewDataSource Members
FastReport.Data Namespace


ViewDataSource Properties

[image] [image]

FastReport.Net Class Reference
ViewDataSource Properties
ViewDataSource Class See Also Send Feedback

The ViewDataSource type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
Calculated | This property is not relevant to this class. (Inherited from DataSourceBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Columns | Gets the collection of child columns. (Inherited from Column.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurrentRow | Gets the current data row. (Inherited from DataSourceBase.)
CurrentRowNo | Gets an index of current data row. (Inherited from DataSourceBase.)
CustomBindableControl | This property is not relevant to this class. (Inherited from DataSourceBase.)
DataType | This property is not relevant to this class. (Inherited from DataSourceBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Expression | This property is not relevant to this class. (Inherited from DataSourceBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
ForceLoadData | Forces loading of data for this datasource. (Inherited from DataSourceBase.)
Format | This property is not relevant to this class. (Inherited from DataSourceBase.)
HasMoreRows | Gets a value indicating that datasource has more rows, that is the CurrentRowNo is less than the RowCount. (Inherited from DataSourceBase.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Overloaded.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PropDescriptor | Gets or sets the business object property descriptor which this column is bound to. (Inherited from Column.)
PropName | Gets or sets the business object property name which this column is bound to. (Inherited from Column.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RowCount | Gets a number of data rows in this datasource. (Inherited from DataSourceBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
View | Gets the underlying DataView object.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ViewDataSource Class
FastReport.Data Namespace


Item Property

[image] [image]

FastReport.Net Class Reference
ViewDataSource..::.Item Property
ViewDataSource Class See Also Send Feedback

Overload List

Name | Description
Item[([(Column])]) | Gets data stored in a specified column. (Inherited from DataSourceBase.)
Item[([(String])]) | Gets data stored in a specified column. (Inherited from DataSourceBase.)

See Also

ViewDataSource Class
ViewDataSource Members
FastReport.Data Namespace


View Property

[image]

FastReport.Net Class Reference
ViewDataSource..::.View Property
ViewDataSource Class See Also Send Feedback
Gets the underlying DataView object.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataView View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As DataView
Visual C++
public:
property DataView^ View {
    DataView^ get ();
}

See Also

ViewDataSource Class
FastReport.Data Namespace


ViewDataSource Events

[image] [image]

FastReport.Net Class Reference
ViewDataSource Events
ViewDataSource Class See Also Send Feedback

The ViewDataSource type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Load | Occurs when the FastReport engine loads data source with data. (Inherited from DataSourceBase.)

See Also

ViewDataSource Class
FastReport.Data Namespace


XmlConnectionStringBuilder Class

[image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Class
Members See Also Send Feedback
Represents the XmlDataConnection connection string builder.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class XmlConnectionStringBuilder : DbConnectionStringBuilder
Visual Basic (Declaration)
Public Class XmlConnectionStringBuilder _
    Inherits DbConnectionStringBuilder
Visual C++
public ref class XmlConnectionStringBuilder : public DbConnectionStringBuilder

Remarks

Use this class to parse connection string returned by the XmlDataConnection class.

Inheritance Hierarchy

System..::.Object
System.Data.Common..::.DbConnectionStringBuilder
FastReport.Data..::.XmlConnectionStringBuilder

See Also

XmlConnectionStringBuilder Members
FastReport.Data Namespace


XmlConnectionStringBuilder Members

[image] [image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Members
XmlConnectionStringBuilder Class Constructors Methods Properties See Also Send Feedback

The XmlConnectionStringBuilder type exposes the following members.

Constructors

Name | Description
XmlConnectionStringBuilder | Overloaded.

Methods

Name | Description
Add | Adds an entry with the specified key and value into the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
Clear | Clears the contents of the DbConnectionStringBuilder instance. (Inherited from DbConnectionStringBuilder.)
ClearPropertyDescriptors | Clears the collection of PropertyDescriptor objects on the associated DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
ContainsKey | Determines whether the DbConnectionStringBuilder contains a specific key. (Inherited from DbConnectionStringBuilder.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EquivalentTo | Compares the connection information in this DbConnectionStringBuilder object with the connection information in the supplied object. (Inherited from DbConnectionStringBuilder.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Fills a supplied Hashtable with information about all the properties of this DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the entry with the specified key from the DbConnectionStringBuilder instance. (Inherited from DbConnectionStringBuilder.)
ShouldSerialize | Indicates whether the specified key exists in this DbConnectionStringBuilder instance. (Inherited from DbConnectionStringBuilder.)
ToString | Returns the connection string associated with this DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
TryGetValue | Retrieves a value corresponding to the supplied key from this DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)

Properties

Name | Description
BrowsableConnectionString | Gets or sets a value that indicates whether the ConnectionString property is visible in Visual Studio designers. (Inherited from DbConnectionStringBuilder.)
ConnectionString | Gets or sets the connection string associated with the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
Count | Gets the current number of keys that are contained within the ConnectionString property. (Inherited from DbConnectionStringBuilder.)
IsFixedSize | Gets a value that indicates whether the DbConnectionStringBuilder has a fixed size. (Inherited from DbConnectionStringBuilder.)
IsReadOnly | Gets a value that indicates whether the DbConnectionStringBuilder is read-only. (Inherited from DbConnectionStringBuilder.)
Item | Gets or sets the value associated with the specified key. (Inherited from DbConnectionStringBuilder.)
Keys | Gets an ICollection that contains the keys in the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
Values | Gets an ICollection that contains the values in the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
XmlFile | Gets or sets the path to .xml file.
XsdFile | Gets or sets the path to .xsd file.

See Also

XmlConnectionStringBuilder Class
FastReport.Data Namespace


XmlConnectionStringBuilder Constructor

[image] [image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Constructor
XmlConnectionStringBuilder Class See Also Send Feedback

Overload List

Name | Description
XmlConnectionStringBuilder()()() | Initializes a new instance of the XmlConnectionStringBuilder class with default settings.
XmlConnectionStringBuilder(String) | Initializes a new instance of the XmlConnectionStringBuilder class with specified connection string.

See Also

XmlConnectionStringBuilder Class
XmlConnectionStringBuilder Members
FastReport.Data Namespace


XmlConnectionStringBuilder Constructor

[image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Constructor
XmlConnectionStringBuilder Class See Also Send Feedback
Initializes a new instance of the XmlConnectionStringBuilder class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlConnectionStringBuilder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlConnectionStringBuilder()

See Also

XmlConnectionStringBuilder Class
XmlConnectionStringBuilder Overload
FastReport.Data Namespace


XmlConnectionStringBuilder Constructor (String)

[image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Constructor (String)
XmlConnectionStringBuilder Class See Also Send Feedback
Initializes a new instance of the XmlConnectionStringBuilder class with specified connection string.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlConnectionStringBuilder(
    string connectionString
)
Visual Basic (Declaration)
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
XmlConnectionStringBuilder(
    String^ connectionString
)

Parameters

connectionString
Type: System..::.String
The connection string.

See Also

XmlConnectionStringBuilder Class
XmlConnectionStringBuilder Overload
FastReport.Data Namespace


XmlConnectionStringBuilder Methods

[image] [image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Methods
XmlConnectionStringBuilder Class See Also Send Feedback

The XmlConnectionStringBuilder type exposes the following members.

Methods

Name | Description
Add | Adds an entry with the specified key and value into the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
Clear | Clears the contents of the DbConnectionStringBuilder instance. (Inherited from DbConnectionStringBuilder.)
ClearPropertyDescriptors | Clears the collection of PropertyDescriptor objects on the associated DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
ContainsKey | Determines whether the DbConnectionStringBuilder contains a specific key. (Inherited from DbConnectionStringBuilder.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EquivalentTo | Compares the connection information in this DbConnectionStringBuilder object with the connection information in the supplied object. (Inherited from DbConnectionStringBuilder.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Fills a supplied Hashtable with information about all the properties of this DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the entry with the specified key from the DbConnectionStringBuilder instance. (Inherited from DbConnectionStringBuilder.)
ShouldSerialize | Indicates whether the specified key exists in this DbConnectionStringBuilder instance. (Inherited from DbConnectionStringBuilder.)
ToString | Returns the connection string associated with this DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
TryGetValue | Retrieves a value corresponding to the supplied key from this DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)

See Also

XmlConnectionStringBuilder Class
FastReport.Data Namespace


XmlConnectionStringBuilder Properties

[image] [image]

FastReport.Net Class Reference
XmlConnectionStringBuilder Properties
XmlConnectionStringBuilder Class See Also Send Feedback

The XmlConnectionStringBuilder type exposes the following members.

Properties

Name | Description
BrowsableConnectionString | Gets or sets a value that indicates whether the ConnectionString property is visible in Visual Studio designers. (Inherited from DbConnectionStringBuilder.)
ConnectionString | Gets or sets the connection string associated with the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
Count | Gets the current number of keys that are contained within the ConnectionString property. (Inherited from DbConnectionStringBuilder.)
IsFixedSize | Gets a value that indicates whether the DbConnectionStringBuilder has a fixed size. (Inherited from DbConnectionStringBuilder.)
IsReadOnly | Gets a value that indicates whether the DbConnectionStringBuilder is read-only. (Inherited from DbConnectionStringBuilder.)
Item | Gets or sets the value associated with the specified key. (Inherited from DbConnectionStringBuilder.)
Keys | Gets an ICollection that contains the keys in the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
Values | Gets an ICollection that contains the values in the DbConnectionStringBuilder. (Inherited from DbConnectionStringBuilder.)
XmlFile | Gets or sets the path to .xml file.
XsdFile | Gets or sets the path to .xsd file.

See Also

XmlConnectionStringBuilder Class
FastReport.Data Namespace


XmlFile Property

[image]

FastReport.Net Class Reference
XmlConnectionStringBuilder..::.XmlFile Property
XmlConnectionStringBuilder Class See Also Send Feedback
Gets or sets the path to .xml file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string XmlFile { get; set; }
Visual Basic (Declaration)
Public Property XmlFile As String
Visual C++
public:
property String^ XmlFile {
    String^ get ();
    void set (String^ value);
}

See Also

XmlConnectionStringBuilder Class
FastReport.Data Namespace


XsdFile Property

[image]

FastReport.Net Class Reference
XmlConnectionStringBuilder..::.XsdFile Property
XmlConnectionStringBuilder Class See Also Send Feedback
Gets or sets the path to .xsd file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string XsdFile { get; set; }
Visual Basic (Declaration)
Public Property XsdFile As String
Visual C++
public:
property String^ XsdFile {
    String^ get ();
    void set (String^ value);
}

See Also

XmlConnectionStringBuilder Class
FastReport.Data Namespace


XmlDataConnection Class

[image]

FastReport.Net Class Reference
XmlDataConnection Class
Members Example See Also Send Feedback
Represents a connection to xml file-based database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class XmlDataConnection : DataConnectionBase
Visual Basic (Declaration)
Public Class XmlDataConnection _
    Inherits DataConnectionBase
Visual C++
public ref class XmlDataConnection : public DataConnectionBase

Examples

This example shows how to add a new connection to the report.
CopyC#
Report report1;
XmlDataConnection conn = new XmlDataConnection();
conn.XmlFile = @"c:\data.xml";
report1.Dictionary.Connections.Add(conn);
conn.CreateAllTables();

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Data..::.DataComponentBase
FastReport.Data..::.DataConnectionBase
FastReport.Data..::.XmlDataConnection

See Also

XmlDataConnection Members
FastReport.Data Namespace


XmlDataConnection Members

[image] [image]

FastReport.Net Class Reference
XmlDataConnection Members
XmlDataConnection Class Constructors Methods Properties Events See Also Send Feedback

The XmlDataConnection type exposes the following members.

Constructors

Name | Description
XmlDataConnection | Initializes a new instance of the XmlDataConnection class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Overrides DataConnectionBase..::.CreateDataSet()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Overrides DataConnectionBase..::.FillTableData(DataTable, String, CommandParameterCollection).)
FillTableSchema | Fills the table schema. (Overrides DataConnectionBase..::.FillTableSchema(DataTable, String, CommandParameterCollection).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Inherited from DataConnectionBase.)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Inherited from DataConnectionBase.)
GetConnectionType | Returns a type of connection. (Inherited from DataConnectionBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Inherited from DataConnectionBase.)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Inherited from DataConnectionBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Overrides DataConnectionBase..::.SetConnectionString(String).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Overrides DataConnectionBase..::.TestConnection()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
XmlFile | Gets or sets the path to .xml file.
XsdFile | Gets or sets the path to .xsd file.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XmlDataConnection Class
FastReport.Data Namespace


XmlDataConnection Constructor

[image]

FastReport.Net Class Reference
XmlDataConnection Constructor
XmlDataConnection Class See Also Send Feedback
Initializes a new instance of the XmlDataConnection class with default settings.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlDataConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlDataConnection()

See Also

XmlDataConnection Class
FastReport.Data Namespace


XmlDataConnection Methods

[image] [image]

FastReport.Net Class Reference
XmlDataConnection Methods
XmlDataConnection Class See Also Send Feedback

The XmlDataConnection type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from DataConnectionBase.)
Assign | Copies the contents of another, similar object. (Inherited from DataComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from DataConnectionBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateAllTables | Overloaded.
CreateDataSet | Initializes a DataSet instance. (Overrides DataConnectionBase..::.CreateDataSet()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateRelations | Creates the relations between tables. Applies to XmlDataConnection only. (Inherited from DataConnectionBase.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from DataConnectionBase.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
DisposeConnection | Disposes a connection. (Inherited from DataConnectionBase.)
DisposeDataSet | Disposes a DataSet. (Inherited from DataConnectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillTableData | Fills the table data. (Overrides DataConnectionBase..::.FillTableData(DataTable, String, CommandParameterCollection).)
FillTableSchema | Fills the table schema. (Overrides DataConnectionBase..::.FillTableSchema(DataTable, String, CommandParameterCollection).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAdapter | Returns a DbDataAdapter object that is specific to this connection. (Inherited from DataConnectionBase.)
GetChildObjects | Gets a list of child objects. (Inherited from DataConnectionBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from DataConnectionBase.)
GetConnection | Returns a connection object. (Inherited from DataConnectionBase.)
GetConnectionId | Gets a string that will identify a connection in the Data Wizard. (Overrides DataConnectionBase..::.GetConnectionId()()().)
GetConnectionStringWithLoginInfo | Gets a connection string that contains username and password specified. (Inherited from DataConnectionBase.)
GetConnectionType | Returns a type of connection. (Inherited from DataConnectionBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultParameterType | Gets the default type for a new parameter. (Inherited from DataConnectionBase.)
GetEditor | Gets a control that will be used to edit the connection properties. (Overrides DataConnectionBase..::.GetEditor()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from DataConnectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetParameterType | Gets the type of parameter that is specific to this connection. (Inherited from DataConnectionBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetTableNames | Gets an array of table names available in the database. (Overrides DataConnectionBase..::.GetTableNames()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from DataComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from DataConnectionBase.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OpenConnection | Opens a specified connection object. (Inherited from DataConnectionBase.)
QuoteIdentifier | Quotes the specified DB identifier such as table name or column name. (Overrides DataConnectionBase..::.QuoteIdentifier(String, DbConnection).)
RemoveChild | Removes a specified object from this object's childs. (Inherited from DataConnectionBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DataConnectionBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from DataConnectionBase.)
SetConnectionString | Sets the connection string. (Overrides DataConnectionBase..::.SetConnectionString(String).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from DataComponentBase.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
TestConnection | Tests the connection. (Overrides DataConnectionBase..::.TestConnection()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from DataConnectionBase.)

See Also

XmlDataConnection Class
FastReport.Data Namespace


CreateAllTables Method

[image] [image]

FastReport.Net Class Reference
XmlDataConnection..::.CreateAllTables Method
XmlDataConnection Class See Also Send Feedback

Overload List

Name | Description
CreateAllTables()()() | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)
CreateAllTables(Boolean) | Fills the Tables collection with all tables available in the database. (Inherited from DataConnectionBase.)

See Also

XmlDataConnection Class
XmlDataConnection Members
FastReport.Data Namespace


CreateDataSet Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.CreateDataSet Method
XmlDataConnection Class See Also Send Feedback
Initializes a DataSet instance.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override DataSet CreateDataSet()
Visual Basic (Declaration)
Protected Overrides Function CreateDataSet As DataSet
Visual C++
protected:
virtual DataSet^ CreateDataSet() override

Return Value

The DataSet object.

Remarks

This method is used to support FastReport infrastructure. You don't need to use it.

See Also

XmlDataConnection Class
FastReport.Data Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
XmlDataConnection..::.Dispose Method
XmlDataConnection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DataConnectionBase.)

See Also

XmlDataConnection Class
XmlDataConnection Members
FastReport.Data Namespace


FillTableData Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.FillTableData Method
XmlDataConnection Class See Also Send Feedback
Fills the table data.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FillTableData(
    DataTable table,
    string selectCommand,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overrides Sub FillTableData ( _
    table As DataTable, _
    selectCommand As String, _
    parameters As CommandParameterCollection _
)
Visual C++
public:
virtual void FillTableData(
    DataTable^ table,
    String^ selectCommand,
    CommandParameterCollection^ parameters
) override

Parameters

table
Type: System.Data..::.DataTable
DataTable to fill.
selectCommand
Type: System..::.String
The SQL select command.
parameters
Type: FastReport.Data..::.CommandParameterCollection
SQL parameters.

Remarks

Usually you don't need to use this method. Internally it uses the GetConnection()()() and GetAdapter(String, DbConnection, CommandParameterCollection) methods to fill the table data. If you create own connection component that does not use nor connection or adapter, then you need to override this method.

See Also

XmlDataConnection Class
FastReport.Data Namespace


FillTableSchema Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.FillTableSchema Method
XmlDataConnection Class See Also Send Feedback
Fills the table schema.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FillTableSchema(
    DataTable table,
    string selectCommand,
    CommandParameterCollection parameters
)
Visual Basic (Declaration)
Public Overrides Sub FillTableSchema ( _
    table As DataTable, _
    selectCommand As String, _
    parameters As CommandParameterCollection _
)
Visual C++
public:
virtual void FillTableSchema(
    DataTable^ table,
    String^ selectCommand,
    CommandParameterCollection^ parameters
) override

Parameters

table
Type: System.Data..::.DataTable
DataTable to fill.
selectCommand
Type: System..::.String
The SQL select command.
parameters
Type: FastReport.Data..::.CommandParameterCollection
SQL parameters.

Remarks

Usually you don't need to use this method. Internally it uses the GetConnection()()() and GetAdapter(String, DbConnection, CommandParameterCollection) methods to fill the table schema. If you create own connection component that does not use nor connection or adapter, then you need to override this method.

See Also

XmlDataConnection Class
FastReport.Data Namespace


GetConnectionId Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.GetConnectionId Method
XmlDataConnection Class See Also Send Feedback
Gets a string that will identify a connection in the Data Wizard.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string GetConnectionId()
Visual Basic (Declaration)
Public Overrides Function GetConnectionId As String
Visual C++
public:
virtual String^ GetConnectionId() override

Return Value

The string that contains the connection type and some meaningful information.

See Also

XmlDataConnection Class
FastReport.Data Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.GetEditor Method
XmlDataConnection Class See Also Send Feedback
Gets a control that will be used to edit the connection properties.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ConnectionEditorBase GetEditor()
Visual Basic (Declaration)
Public Overrides Function GetEditor As ConnectionEditorBase
Visual C++
public:
virtual ConnectionEditorBase^ GetEditor() override

Return Value

The editor's control.

See Also

XmlDataConnection Class
FastReport.Data Namespace


GetTableNames Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.GetTableNames Method
XmlDataConnection Class See Also Send Feedback
Gets an array of table names available in the database.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetTableNames()
Visual Basic (Declaration)
Public Overrides Function GetTableNames As String()
Visual C++
public:
virtual array<String^>^ GetTableNames() override

Return Value

An array of strings.

See Also

XmlDataConnection Class
FastReport.Data Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
XmlDataConnection..::.MemberwiseClone Method
XmlDataConnection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

XmlDataConnection Class
XmlDataConnection Members
FastReport.Data Namespace


QuoteIdentifier Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.QuoteIdentifier Method
XmlDataConnection Class See Also Send Feedback
Quotes the specified DB identifier such as table name or column name.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string QuoteIdentifier(
    string value,
    DbConnection connection
)
Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier ( _
    value As String, _
    connection As DbConnection _
) As String
Visual C++
public:
virtual String^ QuoteIdentifier(
    String^ value,
    DbConnection^ connection
) override

Parameters

value
Type: System..::.String
Identifier to quote.
connection
Type: System.Data.Common..::.DbConnection
The opened DB connection.

Return Value

The quoted identifier.

See Also

XmlDataConnection Class
FastReport.Data Namespace


SetConnectionString Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.SetConnectionString Method
XmlDataConnection Class See Also Send Feedback
Sets the connection string.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void SetConnectionString(
    string value
)
Visual Basic (Declaration)
Protected Overrides Sub SetConnectionString ( _
    value As String _
)
Visual C++
protected:
virtual void SetConnectionString(
    String^ value
) override

Parameters

value
Type: System..::.String
New connection string.

Remarks

Use this method if you need to perform some actions when the connection string is set.

See Also

XmlDataConnection Class
FastReport.Data Namespace


TestConnection Method

[image]

FastReport.Net Class Reference
XmlDataConnection..::.TestConnection Method
XmlDataConnection Class See Also Send Feedback
Tests the connection.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void TestConnection()
Visual Basic (Declaration)
Public Overrides Sub TestConnection
Visual C++
public:
virtual void TestConnection() override

Remarks

If test connection is not successful, this method throws an exception. Catch this exception to show an error message.

See Also

XmlDataConnection Class
FastReport.Data Namespace


XmlDataConnection Properties

[image] [image]

FastReport.Net Class Reference
XmlDataConnection Properties
XmlDataConnection Class See Also Send Feedback

The XmlDataConnection type exposes the following members.

Properties

Name | Description
Alias | Gets or sets alias of this object. (Inherited from DataComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
CommandTimeout | Gets or sets the command timeout, in seconds. (Inherited from DataConnectionBase.)
ConnectionString | Gets or sets a connection string that contains all connection parameters. (Inherited from DataConnectionBase.)
ConnectionStringExpression | Gets or sets an expression that returns a connection string. (Inherited from DataConnectionBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSet | Gets an internal DataSet object that contains all data tables. (Inherited from DataConnectionBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Enabled | Gets or sets a value indicates that object is enabled and thus can be used in a report. (Inherited from DataComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAliased | Gets a value indicates that this object has an alias. (Inherited from DataComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
IsSqlBased | Gets or sets a value indicates if this connection is SQL-based. (Inherited from DataConnectionBase.)
LoginPrompt | Gets or sets a value indicating whether a login dialog appears immediately before opening a connection. (Inherited from DataConnectionBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Reference | Gets or sets a reference to the data object. (Inherited from DataComponentBase.)
ReferenceName | Gets or sets a name of the data object. (Inherited from DataComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Tables | Gets a collection of data tables in this connection. (Inherited from DataConnectionBase.)
XmlFile | Gets or sets the path to .xml file.
XsdFile | Gets or sets the path to .xsd file.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

XmlDataConnection Class
FastReport.Data Namespace


XmlFile Property

[image]

FastReport.Net Class Reference
XmlDataConnection..::.XmlFile Property
XmlDataConnection Class See Also Send Feedback
Gets or sets the path to .xml file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string XmlFile { get; set; }
Visual Basic (Declaration)
Public Property XmlFile As String
Visual C++
public:
property String^ XmlFile {
    String^ get ();
    void set (String^ value);
}

See Also

XmlDataConnection Class
FastReport.Data Namespace


XsdFile Property

[image]

FastReport.Net Class Reference
XmlDataConnection..::.XsdFile Property
XmlDataConnection Class See Also Send Feedback
Gets or sets the path to .xsd file.

Namespace: FastReport.Data
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string XsdFile { get; set; }
Visual Basic (Declaration)
Public Property XsdFile As String
Visual C++
public:
property String^ XsdFile {
    String^ get ();
    void set (String^ value);
}

See Also

XmlDataConnection Class
FastReport.Data Namespace


XmlDataConnection Events

[image] [image]

FastReport.Net Class Reference
XmlDataConnection Events
XmlDataConnection Class See Also Send Feedback

The XmlDataConnection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XmlDataConnection Class
FastReport.Data Namespace


FastReport.Data.ConnectionEditors Namespace

[image]

FastReport.Net Class Reference
FastReport.Data.ConnectionEditors Namespace
Send Feedback

Classes

Class | Description
ConnectionEditorBase | The base class for all connection editors. This control is used when you edit the connection in the Data Wizard.


ConnectionEditorBase Class

[image]

FastReport.Net Class Reference
ConnectionEditorBase Class
Members See Also Send Feedback
The base class for all connection editors. This control is used when you edit the connection in the Data Wizard.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ConnectionEditorBase : UserControl
Visual Basic (Declaration)
Public Class ConnectionEditorBase _
    Inherits UserControl
Visual C++
public ref class ConnectionEditorBase : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Data.ConnectionEditors..::.ConnectionEditorBase

See Also

ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


ConnectionEditorBase Members

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase Members
ConnectionEditorBase Class Constructors Methods Properties Events See Also Send Feedback

The ConnectionEditorBase type exposes the following members.

Constructors

Name | Description
ConnectionEditorBase | Initializes a new instance of the ConnectionEditorBase class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetConnectionString | This method should construct the connection string from values entered by user.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetConnectionString | This method should parse the connection string and fill the user interface elements.
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateLayout | This method is called when form layout is complete.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConnectionString | Gets or sets a connection string.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


ConnectionEditorBase Constructor

[image]

FastReport.Net Class Reference
ConnectionEditorBase Constructor
ConnectionEditorBase Class See Also Send Feedback
Initializes a new instance of the ConnectionEditorBase class with default settings.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ConnectionEditorBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectionEditorBase()

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


ConnectionEditorBase Methods

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase Methods
ConnectionEditorBase Class See Also Send Feedback

The ConnectionEditorBase type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetConnectionString | This method should construct the connection string from values entered by user.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetConnectionString | This method should parse the connection string and fill the user interface elements.
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateLayout | This method is called when form layout is complete.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.AccessibilityNotifyClients Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.BeginInvoke Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Dispose Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Dispose Method (Boolean)
ConnectionEditorBase Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ConnectionEditorBase Class
Dispose Overload
FastReport.Data.ConnectionEditors Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.GetChildAtPoint Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


GetConnectionString Method

[image]

FastReport.Net Class Reference
ConnectionEditorBase..::.GetConnectionString Method
ConnectionEditorBase Class See Also Send Feedback
This method should construct the connection string from values entered by user.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual string GetConnectionString()
Visual Basic (Declaration)
Protected Overridable Function GetConnectionString As String
Visual C++
protected:
virtual String^ GetConnectionString()

Return Value

The connection string.

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Invalidate Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Invoke Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.MemberwiseClone Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.PerformLayout Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.ResumeLayout Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.RtlTranslateAlignment Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Scale Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Select Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.SetBounds Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


SetConnectionString Method

[image]

FastReport.Net Class Reference
ConnectionEditorBase..::.SetConnectionString Method
ConnectionEditorBase Class See Also Send Feedback
This method should parse the connection string and fill the user interface elements.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void SetConnectionString(
    string value
)
Visual Basic (Declaration)
Protected Overridable Sub SetConnectionString ( _
    value As String _
)
Visual C++
protected:
virtual void SetConnectionString(
    String^ value
)

Parameters

value
Type: System..::.String
The connection string.

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.UpdateBounds Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
ConnectionEditorBase..::.UpdateLayout Method
ConnectionEditorBase Class See Also Send Feedback
This method is called when form layout is complete.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateLayout()
Visual Basic (Declaration)
Public Overridable Sub UpdateLayout
Visual C++
public:
virtual void UpdateLayout()

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.Validate Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase..::.ValidateChildren Method
ConnectionEditorBase Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ConnectionEditorBase Class
ConnectionEditorBase Members
FastReport.Data.ConnectionEditors Namespace


ConnectionEditorBase Properties

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase Properties
ConnectionEditorBase Class See Also Send Feedback

The ConnectionEditorBase type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConnectionString | Gets or sets a connection string.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


ConnectionString Property

[image]

FastReport.Net Class Reference
ConnectionEditorBase..::.ConnectionString Property
ConnectionEditorBase Class See Also Send Feedback
Gets or sets a connection string.

Namespace: FastReport.Data.ConnectionEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


ConnectionEditorBase Events

[image] [image]

FastReport.Net Class Reference
ConnectionEditorBase Events
ConnectionEditorBase Class See Also Send Feedback

The ConnectionEditorBase type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ConnectionEditorBase Class
FastReport.Data.ConnectionEditors Namespace


FastReport.Design Namespace

[image]

FastReport.Net Class Reference
FastReport.Design Namespace
Send Feedback

Classes

Class | Description
AboutCommand | Represents the "Help|About..." command.
AddDataCommand | Represents the "Data|Add Data Source..." command.
BringToFrontCommand | Represents the "Bring To Front" context menu command.
ChooseDataCommand | Represents the "Data|Choose Report Data..." command.
CloseAllCommand | Represents the "Window|Close All" command.
CloseCommand | Represents the "File|Close" command.
CopyCommand | Represents the "Edit|Copy" command.
CustomQueryBuilderEventArgs | Provides data for the CustomQueryBuilder event.
CutCommand | Represents the "Edit|Cut" command.
DeleteCommand | Represents the "Edit|Delete" command.
DeletePageCommand | Represents the "Edit|Delete Page" command.
Designer | Represents the report's designer control.
DesignerCommand | The base class for all designer commands.
DesignerPlugins | Represents list of registered design plugins.
DesignerRestrictions | Represents a set of designer's restrictions.
DesignerSettings | This class contains settings that will be applied to the report designer.
EditCommand | Represents the "Edit" command.
ExportPlugin | Base class for all export plugins.
FilterConnectionTablesEventArgs | Provides data for the FilterConnectionTables event.
FindCommand | Represents the "Edit|Find..." command.
FormatPainterCommand | Represents the "Format Painter" toolbar command.
GroupCommand | Represents the "Edit|Group" command.
HelpContentsCommand | Represents the "Help|Help Contents..." command.
ImportPlugin | Base class for all import plugins.
InsertBandCommand | Represents the "Insert Band" command.
InsertCommand | Represents the "Insert" command.
NewCommand | Represents the "File|New" command.
NewDialogCommand | Represents the "New Dialog" toolbar command.
NewPageCommand | Represents the "New Page" toolbar command.
ObjectInsertedEventArgs | Provides a data for the designer ObjectInserted event.
OpenCommand | Represents the "File|Open..." command. Also can be used for loading a file from the recent files list.
OpenSaveDialogEventArgs | Provides a data for the designer's custom dialog events.
OpenSaveReportEventArgs | Provides a data for the designer's custom dialog events.
OptionsCommand | Represents the "View|Options..." command.
PageSettingsCommand | Represents the "File|Page Setup..." command.
PasteCommand | Represents the "Edit|Paste" command.
PluginCollection | Represents collection of designer plugins.
PreviewCommand | Represents the "File|Preview..." command.
PrinterSettingsCommand | Represents the "File|Printer Setup..." command.
RecentFilesCommand | Represents the "Recent Files" command.
RedoCommand | Represents the "Edit|Redo" command.
ReplaceCommand | Represents the "Edit|Replace..." command.
ReportLoadedEventArgs | Provides a data for the designer ReportLoaded event.
ReportSettingsCommand | Represents the "Report|Options..." command.
ReportStylesCommand | Represents the "Report|Styles..." command.
SaveAllCommand | Represents the "File|Save All" command.
SaveAsCommand | Represents the "File|Save As..." command.
SaveCommand | Represents the "File|Save" command.
SelectAllCommand | Represents the "Edit|Select All" command.
SelectLanguageCommand | Represents the "File|Select Language..." command.
SendToBackCommand | Represents the "Send To Back" context menu command.
UndoCommand | Represents the "Edit|Undo" command.
UngroupCommand | Represents the "Edit|Ungroup" command.
ViewStartPageCommand | Represents the "View|Start Page" command.

Interfaces

Interface | Description
IDesignerPlugin | Provides functionality required for report designer plugins such as toolbars and toolwindows.

Delegates

Delegate | Description
CustomQueryBuilderEventHandler | Represents the method that will handle the CustomQueryBuilder event.
FilterConnectionTablesEventHandler | Represents the method that will handle the FilterConnectionTables event.
ObjectInsertedEventHandler | Represents the method that will handle the designer ObjectInserted event.
OpenSaveDialogEventHandler | Represents the method that will handle the designer's custom dialogs event.
OpenSaveReportEventHandler | Represents the method that will handle the designer's custom dialogs event.
ReportLoadedEventHandler | Represents the method that will handle the designer ReportLoaded event.


AboutCommand Class

[image]

FastReport.Net Class Reference
AboutCommand Class
Members See Also Send Feedback
Represents the "Help|About..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AboutCommand : DesignerCommand
Visual Basic (Declaration)
Public Class AboutCommand _
    Inherits DesignerCommand
Visual C++
public ref class AboutCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.AboutCommand

See Also

AboutCommand Members
FastReport.Design Namespace


AboutCommand Members

[image] [image]

FastReport.Net Class Reference
AboutCommand Members
AboutCommand Class Methods Properties Events See Also Send Feedback

The AboutCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from DesignerCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

AboutCommand Class
FastReport.Design Namespace


AboutCommand Methods

[image] [image]

FastReport.Net Class Reference
AboutCommand Methods
AboutCommand Class See Also Send Feedback

The AboutCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from DesignerCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AboutCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
AboutCommand..::.Invoke Method
AboutCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

AboutCommand Class
AboutCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
AboutCommand..::.Invoke Method
AboutCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

AboutCommand Class
Invoke Overload
FastReport.Design Namespace


AboutCommand Properties

[image] [image]

FastReport.Net Class Reference
AboutCommand Properties
AboutCommand Class See Also Send Feedback

The AboutCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

AboutCommand Class
FastReport.Design Namespace


AboutCommand Events

[image] [image]

FastReport.Net Class Reference
AboutCommand Events
AboutCommand Class See Also Send Feedback

The AboutCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

AboutCommand Class
FastReport.Design Namespace


AddDataCommand Class

[image]

FastReport.Net Class Reference
AddDataCommand Class
Members See Also Send Feedback
Represents the "Data|Add Data Source..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AddDataCommand : DesignerCommand
Visual Basic (Declaration)
Public Class AddDataCommand _
    Inherits DesignerCommand
Visual C++
public ref class AddDataCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.AddDataCommand

See Also

AddDataCommand Members
FastReport.Design Namespace


AddDataCommand Members

[image] [image]

FastReport.Net Class Reference
AddDataCommand Members
AddDataCommand Class Methods Properties Events See Also Send Feedback

The AddDataCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

AddDataCommand Class
FastReport.Design Namespace


AddDataCommand Methods

[image] [image]

FastReport.Net Class Reference
AddDataCommand Methods
AddDataCommand Class See Also Send Feedback

The AddDataCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddDataCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
AddDataCommand..::.GetEnabled Method
AddDataCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

AddDataCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
AddDataCommand..::.Invoke Method
AddDataCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

AddDataCommand Class
AddDataCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
AddDataCommand..::.Invoke Method
AddDataCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

AddDataCommand Class
Invoke Overload
FastReport.Design Namespace


AddDataCommand Properties

[image] [image]

FastReport.Net Class Reference
AddDataCommand Properties
AddDataCommand Class See Also Send Feedback

The AddDataCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

AddDataCommand Class
FastReport.Design Namespace


AddDataCommand Events

[image] [image]

FastReport.Net Class Reference
AddDataCommand Events
AddDataCommand Class See Also Send Feedback

The AddDataCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

AddDataCommand Class
FastReport.Design Namespace


BringToFrontCommand Class

[image]

FastReport.Net Class Reference
BringToFrontCommand Class
Members See Also Send Feedback
Represents the "Bring To Front" context menu command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BringToFrontCommand : DesignerCommand
Visual Basic (Declaration)
Public Class BringToFrontCommand _
    Inherits DesignerCommand
Visual C++
public ref class BringToFrontCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.BringToFrontCommand
FastReport.Design..::.SendToBackCommand

See Also

BringToFrontCommand Members
FastReport.Design Namespace


BringToFrontCommand Members

[image] [image]

FastReport.Net Class Reference
BringToFrontCommand Members
BringToFrontCommand Class Methods Properties Events See Also Send Feedback

The BringToFrontCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

BringToFrontCommand Class
FastReport.Design Namespace


BringToFrontCommand Methods

[image] [image]

FastReport.Net Class Reference
BringToFrontCommand Methods
BringToFrontCommand Class See Also Send Feedback

The BringToFrontCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BringToFrontCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
BringToFrontCommand..::.GetEnabled Method
BringToFrontCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

BringToFrontCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
BringToFrontCommand..::.Invoke Method
BringToFrontCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

BringToFrontCommand Class
BringToFrontCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
BringToFrontCommand..::.Invoke Method
BringToFrontCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

BringToFrontCommand Class
Invoke Overload
FastReport.Design Namespace


BringToFrontCommand Properties

[image] [image]

FastReport.Net Class Reference
BringToFrontCommand Properties
BringToFrontCommand Class See Also Send Feedback

The BringToFrontCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

BringToFrontCommand Class
FastReport.Design Namespace


BringToFrontCommand Events

[image] [image]

FastReport.Net Class Reference
BringToFrontCommand Events
BringToFrontCommand Class See Also Send Feedback

The BringToFrontCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

BringToFrontCommand Class
FastReport.Design Namespace


ChooseDataCommand Class

[image]

FastReport.Net Class Reference
ChooseDataCommand Class
Members See Also Send Feedback
Represents the "Data|Choose Report Data..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ChooseDataCommand : DesignerCommand
Visual Basic (Declaration)
Public Class ChooseDataCommand _
    Inherits DesignerCommand
Visual C++
public ref class ChooseDataCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.ChooseDataCommand

See Also

ChooseDataCommand Members
FastReport.Design Namespace


ChooseDataCommand Members

[image] [image]

FastReport.Net Class Reference
ChooseDataCommand Members
ChooseDataCommand Class Methods Properties Events See Also Send Feedback

The ChooseDataCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ChooseDataCommand Class
FastReport.Design Namespace


ChooseDataCommand Methods

[image] [image]

FastReport.Net Class Reference
ChooseDataCommand Methods
ChooseDataCommand Class See Also Send Feedback

The ChooseDataCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChooseDataCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
ChooseDataCommand..::.GetEnabled Method
ChooseDataCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

ChooseDataCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ChooseDataCommand..::.Invoke Method
ChooseDataCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

ChooseDataCommand Class
ChooseDataCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
ChooseDataCommand..::.Invoke Method
ChooseDataCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

ChooseDataCommand Class
Invoke Overload
FastReport.Design Namespace


ChooseDataCommand Properties

[image] [image]

FastReport.Net Class Reference
ChooseDataCommand Properties
ChooseDataCommand Class See Also Send Feedback

The ChooseDataCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

ChooseDataCommand Class
FastReport.Design Namespace


ChooseDataCommand Events

[image] [image]

FastReport.Net Class Reference
ChooseDataCommand Events
ChooseDataCommand Class See Also Send Feedback

The ChooseDataCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ChooseDataCommand Class
FastReport.Design Namespace


CloseAllCommand Class

[image]

FastReport.Net Class Reference
CloseAllCommand Class
Members See Also Send Feedback
Represents the "Window|Close All" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CloseAllCommand : CloseCommand
Visual Basic (Declaration)
Public Class CloseAllCommand _
    Inherits CloseCommand
Visual C++
public ref class CloseAllCommand : public CloseCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.CloseCommand
FastReport.Design..::.CloseAllCommand

See Also

CloseAllCommand Members
FastReport.Design Namespace


CloseAllCommand Members

[image] [image]

FastReport.Net Class Reference
CloseAllCommand Members
CloseAllCommand Class Methods Properties Events See Also Send Feedback

The CloseAllCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from CloseCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CloseAllCommand Class
FastReport.Design Namespace


CloseAllCommand Methods

[image] [image]

FastReport.Net Class Reference
CloseAllCommand Methods
CloseAllCommand Class See Also Send Feedback

The CloseAllCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from CloseCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CloseAllCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
CloseAllCommand..::.Invoke Method
CloseAllCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides CloseCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

CloseAllCommand Class
CloseAllCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
CloseAllCommand..::.Invoke Method
CloseAllCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

CloseAllCommand Class
Invoke Overload
FastReport.Design Namespace


CloseAllCommand Properties

[image] [image]

FastReport.Net Class Reference
CloseAllCommand Properties
CloseAllCommand Class See Also Send Feedback

The CloseAllCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

CloseAllCommand Class
FastReport.Design Namespace


CloseAllCommand Events

[image] [image]

FastReport.Net Class Reference
CloseAllCommand Events
CloseAllCommand Class See Also Send Feedback

The CloseAllCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CloseAllCommand Class
FastReport.Design Namespace


CloseCommand Class

[image]

FastReport.Net Class Reference
CloseCommand Class
Members See Also Send Feedback
Represents the "File|Close" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CloseCommand : DesignerCommand
Visual Basic (Declaration)
Public Class CloseCommand _
    Inherits DesignerCommand
Visual C++
public ref class CloseCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.CloseCommand
FastReport.Design..::.CloseAllCommand

See Also

CloseCommand Members
FastReport.Design Namespace


CloseCommand Members

[image] [image]

FastReport.Net Class Reference
CloseCommand Members
CloseCommand Class Methods Properties Events See Also Send Feedback

The CloseCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CloseCommand Class
FastReport.Design Namespace


CloseCommand Methods

[image] [image]

FastReport.Net Class Reference
CloseCommand Methods
CloseCommand Class See Also Send Feedback

The CloseCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CloseCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
CloseCommand..::.GetEnabled Method
CloseCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

CloseCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
CloseCommand..::.Invoke Method
CloseCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

CloseCommand Class
CloseCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
CloseCommand..::.Invoke Method
CloseCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

CloseCommand Class
Invoke Overload
FastReport.Design Namespace


CloseCommand Properties

[image] [image]

FastReport.Net Class Reference
CloseCommand Properties
CloseCommand Class See Also Send Feedback

The CloseCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

CloseCommand Class
FastReport.Design Namespace


CloseCommand Events

[image] [image]

FastReport.Net Class Reference
CloseCommand Events
CloseCommand Class See Also Send Feedback

The CloseCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CloseCommand Class
FastReport.Design Namespace


CopyCommand Class

[image]

FastReport.Net Class Reference
CopyCommand Class
Members See Also Send Feedback
Represents the "Edit|Copy" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CopyCommand : CutCommand
Visual Basic (Declaration)
Public Class CopyCommand _
    Inherits CutCommand
Visual C++
public ref class CopyCommand : public CutCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.CutCommand
FastReport.Design..::.CopyCommand

See Also

CopyCommand Members
FastReport.Design Namespace


CopyCommand Members

[image] [image]

FastReport.Net Class Reference
CopyCommand Members
CopyCommand Class Methods Properties Events See Also Send Feedback

The CopyCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from CutCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CopyCommand Class
FastReport.Design Namespace


CopyCommand Methods

[image] [image]

FastReport.Net Class Reference
CopyCommand Methods
CopyCommand Class See Also Send Feedback

The CopyCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from CutCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CopyCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
CopyCommand..::.Invoke Method
CopyCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides CutCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

CopyCommand Class
CopyCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
CopyCommand..::.Invoke Method
CopyCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

CopyCommand Class
Invoke Overload
FastReport.Design Namespace


CopyCommand Properties

[image] [image]

FastReport.Net Class Reference
CopyCommand Properties
CopyCommand Class See Also Send Feedback

The CopyCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

CopyCommand Class
FastReport.Design Namespace


CopyCommand Events

[image] [image]

FastReport.Net Class Reference
CopyCommand Events
CopyCommand Class See Also Send Feedback

The CopyCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CopyCommand Class
FastReport.Design Namespace


CustomQueryBuilderEventArgs Class

[image]

FastReport.Net Class Reference
CustomQueryBuilderEventArgs Class
Members See Also Send Feedback
Provides data for the CustomQueryBuilder event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CustomQueryBuilderEventArgs
Visual Basic (Declaration)
Public Class CustomQueryBuilderEventArgs
Visual C++
public ref class CustomQueryBuilderEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.CustomQueryBuilderEventArgs

See Also

CustomQueryBuilderEventArgs Members
FastReport.Design Namespace


CustomQueryBuilderEventArgs Members

[image] [image]

FastReport.Net Class Reference
CustomQueryBuilderEventArgs Members
CustomQueryBuilderEventArgs Class Methods Properties See Also Send Feedback

The CustomQueryBuilderEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Connection | Gets the Connection object.
SQL | Gets or sets the query text.

See Also

CustomQueryBuilderEventArgs Class
FastReport.Design Namespace


CustomQueryBuilderEventArgs Methods

[image] [image]

FastReport.Net Class Reference
CustomQueryBuilderEventArgs Methods
CustomQueryBuilderEventArgs Class See Also Send Feedback

The CustomQueryBuilderEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomQueryBuilderEventArgs Class
FastReport.Design Namespace


CustomQueryBuilderEventArgs Properties

[image] [image]

FastReport.Net Class Reference
CustomQueryBuilderEventArgs Properties
CustomQueryBuilderEventArgs Class See Also Send Feedback

The CustomQueryBuilderEventArgs type exposes the following members.

Properties

Name | Description
Connection | Gets the Connection object.
SQL | Gets or sets the query text.

See Also

CustomQueryBuilderEventArgs Class
FastReport.Design Namespace


Connection Property

[image]

FastReport.Net Class Reference
CustomQueryBuilderEventArgs..::.Connection Property
CustomQueryBuilderEventArgs Class See Also Send Feedback
Gets the Connection object.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataConnectionBase Connection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connection As DataConnectionBase
Visual C++
public:
property DataConnectionBase^ Connection {
    DataConnectionBase^ get ();
}

See Also

CustomQueryBuilderEventArgs Class
FastReport.Design Namespace


SQL Property

[image]

FastReport.Net Class Reference
CustomQueryBuilderEventArgs..::.SQL Property
CustomQueryBuilderEventArgs Class See Also Send Feedback
Gets or sets the query text.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SQL { get; set; }
Visual Basic (Declaration)
Public Property SQL As String
Visual C++
public:
property String^ SQL {
    String^ get ();
    void set (String^ value);
}

See Also

CustomQueryBuilderEventArgs Class
FastReport.Design Namespace


CustomQueryBuilderEventHandler Delegate

[image]

FastReport.Net Class Reference
CustomQueryBuilderEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the CustomQueryBuilder event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void CustomQueryBuilderEventHandler(
    Object sender,
    CustomQueryBuilderEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CustomQueryBuilderEventHandler ( _
    sender As Object, _
    e As CustomQueryBuilderEventArgs _
)
Visual C++
public delegate void CustomQueryBuilderEventHandler(
    Object^ sender,
    CustomQueryBuilderEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Design..::.CustomQueryBuilderEventArgs
The event data.

See Also

FastReport.Design Namespace


CutCommand Class

[image]

FastReport.Net Class Reference
CutCommand Class
Members See Also Send Feedback
Represents the "Edit|Cut" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CutCommand : DesignerCommand
Visual Basic (Declaration)
Public Class CutCommand _
    Inherits DesignerCommand
Visual C++
public ref class CutCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.CutCommand
FastReport.Design..::.CopyCommand

See Also

CutCommand Members
FastReport.Design Namespace


CutCommand Members

[image] [image]

FastReport.Net Class Reference
CutCommand Members
CutCommand Class Methods Properties Events See Also Send Feedback

The CutCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CutCommand Class
FastReport.Design Namespace


CutCommand Methods

[image] [image]

FastReport.Net Class Reference
CutCommand Methods
CutCommand Class See Also Send Feedback

The CutCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CutCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
CutCommand..::.GetEnabled Method
CutCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

CutCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
CutCommand..::.Invoke Method
CutCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

CutCommand Class
CutCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
CutCommand..::.Invoke Method
CutCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

CutCommand Class
Invoke Overload
FastReport.Design Namespace


CutCommand Properties

[image] [image]

FastReport.Net Class Reference
CutCommand Properties
CutCommand Class See Also Send Feedback

The CutCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

CutCommand Class
FastReport.Design Namespace


CutCommand Events

[image] [image]

FastReport.Net Class Reference
CutCommand Events
CutCommand Class See Also Send Feedback

The CutCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

CutCommand Class
FastReport.Design Namespace


DeleteCommand Class

[image]

FastReport.Net Class Reference
DeleteCommand Class
Members See Also Send Feedback
Represents the "Edit|Delete" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DeleteCommand : DesignerCommand
Visual Basic (Declaration)
Public Class DeleteCommand _
    Inherits DesignerCommand
Visual C++
public ref class DeleteCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.DeleteCommand

See Also

DeleteCommand Members
FastReport.Design Namespace


DeleteCommand Members

[image] [image]

FastReport.Net Class Reference
DeleteCommand Members
DeleteCommand Class Methods Properties Events See Also Send Feedback

The DeleteCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

DeleteCommand Class
FastReport.Design Namespace


DeleteCommand Methods

[image] [image]

FastReport.Net Class Reference
DeleteCommand Methods
DeleteCommand Class See Also Send Feedback

The DeleteCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
DeleteCommand..::.GetEnabled Method
DeleteCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

DeleteCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DeleteCommand..::.Invoke Method
DeleteCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

DeleteCommand Class
DeleteCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
DeleteCommand..::.Invoke Method
DeleteCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

DeleteCommand Class
Invoke Overload
FastReport.Design Namespace


DeleteCommand Properties

[image] [image]

FastReport.Net Class Reference
DeleteCommand Properties
DeleteCommand Class See Also Send Feedback

The DeleteCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

DeleteCommand Class
FastReport.Design Namespace


DeleteCommand Events

[image] [image]

FastReport.Net Class Reference
DeleteCommand Events
DeleteCommand Class See Also Send Feedback

The DeleteCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

DeleteCommand Class
FastReport.Design Namespace


DeletePageCommand Class

[image]

FastReport.Net Class Reference
DeletePageCommand Class
Members See Also Send Feedback
Represents the "Edit|Delete Page" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DeletePageCommand : DesignerCommand
Visual Basic (Declaration)
Public Class DeletePageCommand _
    Inherits DesignerCommand
Visual C++
public ref class DeletePageCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.DeletePageCommand

See Also

DeletePageCommand Members
FastReport.Design Namespace


DeletePageCommand Members

[image] [image]

FastReport.Net Class Reference
DeletePageCommand Members
DeletePageCommand Class Methods Properties Events See Also Send Feedback

The DeletePageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

DeletePageCommand Class
FastReport.Design Namespace


DeletePageCommand Methods

[image] [image]

FastReport.Net Class Reference
DeletePageCommand Methods
DeletePageCommand Class See Also Send Feedback

The DeletePageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeletePageCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
DeletePageCommand..::.GetEnabled Method
DeletePageCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

DeletePageCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DeletePageCommand..::.Invoke Method
DeletePageCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

DeletePageCommand Class
DeletePageCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
DeletePageCommand..::.Invoke Method
DeletePageCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

DeletePageCommand Class
Invoke Overload
FastReport.Design Namespace


DeletePageCommand Properties

[image] [image]

FastReport.Net Class Reference
DeletePageCommand Properties
DeletePageCommand Class See Also Send Feedback

The DeletePageCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

DeletePageCommand Class
FastReport.Design Namespace


DeletePageCommand Events

[image] [image]

FastReport.Net Class Reference
DeletePageCommand Events
DeletePageCommand Class See Also Send Feedback

The DeletePageCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

DeletePageCommand Class
FastReport.Design Namespace


Designer Class

[image]

FastReport.Net Class Reference
Designer Class
Members See Also Send Feedback
Represents the report's designer control.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Designer : UserControl, ISupportInitialize
Visual Basic (Declaration)
Public Class Designer _
    Inherits UserControl _
    Implements ISupportInitialize
Visual C++
public ref class Designer : public UserControl,
    ISupportInitialize

Remarks

Usually you don't need to create an instance of this class. The designer can be called using the Design()()() method of the Report instance.

This control represents pure designer surface + Objects toolbar. If you need standard menu, statusbar, toolbars and tool windows, use the DesignerControl control instead. Also you may decide to use a designer's form (DesignerForm) instead of a control.

To run a designer, you need to attach a Report instance to it. This can be done via the Report property.

To call the designer in MDI (Multi-Document Interface) mode, use the MdiMode property.

To set up some global properties, use the Config static class or EnvironmentSettings component that you can use in the Visual Studio IDE.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Design..::.Designer
FastReport.Design.StandardDesigner..::.DesignerControl

See Also

Designer Members
FastReport.Design Namespace


Designer Members

[image] [image]

FastReport.Net Class Reference
Designer Members
Designer Class Constructors Methods Properties Events See Also Send Feedback

The Designer type exposes the following members.

Constructors

Name | Description
Designer | Initializes a new instance of the Designer class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInit | Signals the object that initialization is starting.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ClearMessages | Clears the "Messages" window.
CloseAll | Close all opened reports, ask to save changes.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateEmptyReport | Tries to create a new empty report.
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | Signals the object that initialization is complete.
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InitPlugins | Initializes designer plugins such as toolbars and toolwindows.
InitReport | Initializes the workspace after the new report is loaded.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Lock | Locks all plugins.
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Overrides ContainerControl..::.OnParentChanged(EventArgs).)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshLayout | Refresh the designer's toolbars and toolwindows layout.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreConfig | Restores config from a FastReport configuration file.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveConfig | Saves config to a FastReport configuration file.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectionChanged | Call this method to tell the designer that current selection is changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetModified | Overloaded.
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowMessage | Displays a message in the "Messages" window.
ShowStatus | Shows the selected object's information in the designer's statusbar.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Unlock | Unlocks all plugins.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdatePlugins | Call this method to refresh all plugins' content.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveReport | Gets active report object.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AskSave | Gets or sets a value that determines whether to ask user to save changes when closing the designer.
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
cmdAbout | The "Help|About..." command.
cmdAddData | The "Data|Add New Data Source..." command.
cmdBringToFront | The "Bring To Front" command.
cmdChooseData | The "Data|Choose Report Data..." command.
cmdClose | The "File|Close" command.
cmdCloseAll | The "Window|Close All" command.
cmdCopy | The "Edit|Copy" command.
cmdCut | The "Edit|Cut" command.
cmdDelete | The "Edit|Delete" command.
cmdDeletePage | The "Edit|Delete Page" command.
cmdEdit | The "Edit" command.
cmdFind | The "Edit|Find..." command.
cmdFormatPainter | The "Format Painter" toolbar command.
cmdGroup | The "Edit|Group" command.
cmdHelpContents | The "Help|Help Contents..." command.
cmdInsert | The "Insert" command.
cmdInsertBand | The "Insert Band" command.
cmdNew | The "File|New" command.
cmdNewDialog | The "New Dialog" toolbar command.
cmdNewPage | The "New Page" toolbar command.
cmdOpen | The "File|Open..." command.
cmdOptions | The "View|Options..." command.
cmdPageSetup | The "File|Page Setup..." command.
cmdPaste | The "Edit|Paste" command.
cmdPreview | The "File|Preview..." command.
cmdPrinterSetup | The "File|Printer Setup..." command.
cmdRecentFiles | The "Recent Files" command.
cmdRedo | The "Edit|Redo" command.
cmdReplace | The "Edit|Replace..." command.
cmdReportSettings | The "Report|Options..." command.
cmdReportStyles | The "Report|Styles..." command.
cmdSave | The "File|Save" command.
cmdSaveAll | The "File|Save All" command.
cmdSaveAs | The "File|Save As..." command.
cmdSelectAll | The "Edit|Select All" command.
cmdSelectLanguage | The "File|Select Language..." command.
cmdSendToBack | The "Send To Back" command.
cmdUndo | The "Edit|Undo" command.
cmdUngroup | The "Edit|Ungroup" command.
cmdViewStartPage | The "View|Start Page" command.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsPreviewPageDesigner | Gets a value indicating that designer is used to edit a preview page.
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutState | Gets or sets the layout state of the designer.
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MdiMode | Gets or sets a value indicating that designer is run in MDI mode.
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Modified | Gets or sets a value indicating that the report was modified.
Name | Gets or sets the name of the control. (Inherited from Control.)
Objects | Gets a collection of objects on the active page of the active report.
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Plugins | Gets a collection of global plugins such as menu, properties window, etc.
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the edited report.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Restrictions | Gets the designer restrictions.
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedComponents | Gets a collection of selected objects of the ComponentBase type.
SelectedObjects | Gets a collection of selected objects on the active page of the active report.
SelectedReportComponents | Gets a collection of selected objects of the ReportComponentBase type.
SelectedTextObjects | Gets a collection of selected objects of the TextObject type.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UIStyle | Gets or sets the visual style.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutChangedEvent | Fires when the layout is changed.
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
UIStateChanged | Occurs when designer's UI state changed.
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Designer Class
FastReport.Design Namespace


Designer Constructor

[image]

FastReport.Net Class Reference
Designer Constructor
Designer Class See Also Send Feedback
Initializes a new instance of the Designer class with default settings.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Designer()

See Also

Designer Class
FastReport.Design Namespace


Designer Methods

[image] [image]

FastReport.Net Class Reference
Designer Methods
Designer Class See Also Send Feedback

The Designer type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInit | Signals the object that initialization is starting.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ClearMessages | Clears the "Messages" window.
CloseAll | Close all opened reports, ask to save changes.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateEmptyReport | Tries to create a new empty report.
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | Signals the object that initialization is complete.
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InitPlugins | Initializes designer plugins such as toolbars and toolwindows.
InitReport | Initializes the workspace after the new report is loaded.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Lock | Locks all plugins.
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Overrides ContainerControl..::.OnParentChanged(EventArgs).)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshLayout | Refresh the designer's toolbars and toolwindows layout.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreConfig | Restores config from a FastReport configuration file.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveConfig | Saves config to a FastReport configuration file.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectionChanged | Call this method to tell the designer that current selection is changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetModified | Overloaded.
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowMessage | Displays a message in the "Messages" window.
ShowStatus | Shows the selected object's information in the designer's statusbar.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Unlock | Unlocks all plugins.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdatePlugins | Call this method to refresh all plugins' content.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

Designer Class
FastReport.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
Designer..::.AccessibilityNotifyClients Method
Designer Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


BeginInit Method

[image]

FastReport.Net Class Reference
Designer..::.BeginInit Method
Designer Class See Also Send Feedback
Signals the object that initialization is starting.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void BeginInit()
Visual Basic (Declaration)
Public Sub BeginInit
Visual C++
public:
virtual void BeginInit() sealed

Implements

ISupportInitialize..::.BeginInit()()()

See Also

Designer Class
FastReport.Design Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
Designer..::.BeginInvoke Method
Designer Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


ClearMessages Method

[image]

FastReport.Net Class Reference
Designer..::.ClearMessages Method
Designer Class See Also Send Feedback
Clears the "Messages" window.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ClearMessages()
Visual Basic (Declaration)
Public Sub ClearMessages
Visual C++
public:
void ClearMessages()

See Also

Designer Class
FastReport.Design Namespace


CloseAll Method

[image]

FastReport.Net Class Reference
Designer..::.CloseAll Method
Designer Class See Also Send Feedback
Close all opened reports, ask to save changes.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CloseAll()
Visual Basic (Declaration)
Public Function CloseAll As Boolean
Visual C++
public:
bool CloseAll()

Return Value

true if all tabs closed succesfully.

Remarks

Use this method to close all opened documents and save changes when you closing the main form that contains the designer control. To do this, create an event handler for your form's FormClosing event and call this method inside the handler. If it returns false, set e.Cancel to true.

See Also

Designer Class
FastReport.Design Namespace


CreateEmptyReport Method

[image]

FastReport.Net Class Reference
Designer..::.CreateEmptyReport Method
Designer Class See Also Send Feedback
Tries to create a new empty report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CreateEmptyReport()
Visual Basic (Declaration)
Public Function CreateEmptyReport As Boolean
Visual C++
public:
bool CreateEmptyReport()

Return Value

true if report was created successfully; false if user cancels the action.

See Also

Designer Class
FastReport.Design Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Designer..::.Dispose Method
Designer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


EndInit Method

[image]

FastReport.Net Class Reference
Designer..::.EndInit Method
Designer Class See Also Send Feedback
Signals the object that initialization is complete.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EndInit()
Visual Basic (Declaration)
Public Sub EndInit
Visual C++
public:
virtual void EndInit() sealed

Implements

ISupportInitialize..::.EndInit()()()

See Also

Designer Class
FastReport.Design Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
Designer..::.GetChildAtPoint Method
Designer Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


InitPlugins Method

[image]

FastReport.Net Class Reference
Designer..::.InitPlugins Method
Designer Class See Also Send Feedback
Initializes designer plugins such as toolbars and toolwindows.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void InitPlugins()
Visual Basic (Declaration)
Protected Overridable Sub InitPlugins
Visual C++
protected:
virtual void InitPlugins()

See Also

Designer Class
FastReport.Design Namespace


InitReport Method

[image]

FastReport.Net Class Reference
Designer..::.InitReport Method
Designer Class See Also Send Feedback
Initializes the workspace after the new report is loaded.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void InitReport()
Visual Basic (Declaration)
Public Sub InitReport
Visual C++
public:
void InitReport()

See Also

Designer Class
FastReport.Design Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
Designer..::.Invalidate Method
Designer Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
Designer..::.Invoke Method
Designer Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


Lock Method

[image]

FastReport.Net Class Reference
Designer..::.Lock Method
Designer Class See Also Send Feedback
Locks all plugins.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Lock()
Visual Basic (Declaration)
Public Sub Lock
Visual C++
public:
void Lock()

Remarks

This method is usually called when we destroy the report to prevent unexpected errors - such as trying to draw destroyed objects.

See Also

Designer Class
FastReport.Design Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Designer..::.MemberwiseClone Method
Designer Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


OnParentChanged Method

[image]

FastReport.Net Class Reference
Designer..::.OnParentChanged Method
Designer Class See Also Send Feedback

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnParentChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnParentChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnParentChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
An EventArgs that contains the event data.

See Also

Designer Class
FastReport.Design Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
Designer..::.PerformLayout Method
Designer Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


RefreshLayout Method

[image]

FastReport.Net Class Reference
Designer..::.RefreshLayout Method
Designer Class See Also Send Feedback
Refresh the designer's toolbars and toolwindows layout.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RefreshLayout()
Visual Basic (Declaration)
Public Sub RefreshLayout
Visual C++
public:
void RefreshLayout()

Remarks

Call this method if you use DesignerControl. To restore the layout that you've created in VS design time, you need to call this method in the form's Load event handler. If you don't do this, tool windows like Properties, Data, Report Tree will not be available.

See Also

Designer Class
FastReport.Design Namespace


RestoreConfig Method

[image]

FastReport.Net Class Reference
Designer..::.RestoreConfig Method
Designer Class See Also Send Feedback
Restores config from a FastReport configuration file.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RestoreConfig()
Visual Basic (Declaration)
Public Sub RestoreConfig
Visual C++
public:
void RestoreConfig()

Remarks

Call this method to restore the designer's layout. You need to do this after the designer's control is placed on a form.

See Also

Designer Class
FastReport.Design Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
Designer..::.ResumeLayout Method
Designer Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
Designer..::.RtlTranslateAlignment Method
Designer Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


SaveConfig Method

[image]

FastReport.Net Class Reference
Designer..::.SaveConfig Method
Designer Class See Also Send Feedback
Saves config to a FastReport configuration file.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveConfig()
Visual Basic (Declaration)
Public Sub SaveConfig
Visual C++
public:
void SaveConfig()

See Also

Designer Class
FastReport.Design Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
Designer..::.Scale Method
Designer Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
Designer..::.Select Method
Designer Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
Designer..::.SelectionChanged Method
Designer Class See Also Send Feedback
Call this method to tell the designer that current selection is changed.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectionChanged(
    Object sender
)
Visual Basic (Declaration)
Public Sub SelectionChanged ( _
    sender As Object _
)
Visual C++
public:
void SelectionChanged(
    Object^ sender
)

Parameters

sender
Type: System..::.Object
The plugin that changes the selection (may be null).

See Also

Designer Class
FastReport.Design Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
Designer..::.SetBounds Method
Designer Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


SetModified Method

[image] [image]

FastReport.Net Class Reference
Designer..::.SetModified Method
Designer Class See Also Send Feedback

Overload List

Name | Description
SetModified()()() | Call this method if you change something in the report.
SetModified(Object, String) | Call this method if you change something in the report.
SetModified(Object, String, String) | Call this method if you change something in the report.

See Also

Designer Class
Designer Members
FastReport.Design Namespace


SetModified Method

[image]

FastReport.Net Class Reference
Designer..::.SetModified Method
Designer Class See Also Send Feedback
Call this method if you change something in the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetModified()
Visual Basic (Declaration)
Public Sub SetModified
Visual C++
public:
void SetModified()

Remarks

This method adds the current report state to the undo buffer and updates all plugins.

See Also

Designer Class
SetModified Overload
FastReport.Design Namespace


SetModified Method (Object, String)

[image]

FastReport.Net Class Reference
Designer..::.SetModified Method (Object, String)
Designer Class See Also Send Feedback
Call this method if you change something in the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetModified(
    Object sender,
    string action
)
Visual Basic (Declaration)
Public Sub SetModified ( _
    sender As Object, _
    action As String _
)
Visual C++
public:
void SetModified(
    Object^ sender,
    String^ action
)

Parameters

sender
Type: System..::.Object
The object that was modified.
action
Type: System..::.String
The undo action name.

Remarks

This method adds the current report state to the undo buffer and updates all plugins.

See Also

Designer Class
SetModified Overload
FastReport.Design Namespace


SetModified Method (Object, String, String)

[image]

FastReport.Net Class Reference
Designer..::.SetModified Method (Object, String, String)
Designer Class See Also Send Feedback
Call this method if you change something in the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetModified(
    Object sender,
    string action,
    string objName
)
Visual Basic (Declaration)
Public Sub SetModified ( _
    sender As Object, _
    action As String, _
    objName As String _
)
Visual C++
public:
void SetModified(
    Object^ sender,
    String^ action,
    String^ objName
)

Parameters

sender
Type: System..::.Object
The object that was modified.
action
Type: System..::.String
The undo action name.
objName
Type: System..::.String
The name of modified object.

See Also

Designer Class
SetModified Overload
FastReport.Design Namespace


ShowMessage Method

[image]

FastReport.Net Class Reference
Designer..::.ShowMessage Method
Designer Class See Also Send Feedback
Displays a message in the "Messages" window.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowMessage(
    string msg
)
Visual Basic (Declaration)
Public Sub ShowMessage ( _
    msg As String _
)
Visual C++
public:
void ShowMessage(
    String^ msg
)

Parameters

msg
Type: System..::.String
Message text.

See Also

Designer Class
FastReport.Design Namespace


ShowStatus Method

[image]

FastReport.Net Class Reference
Designer..::.ShowStatus Method
Designer Class See Also Send Feedback
Shows the selected object's information in the designer's statusbar.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void ShowStatus(
    string location,
    string size,
    string text
)
Visual Basic (Declaration)
Public Overridable Sub ShowStatus ( _
    location As String, _
    size As String, _
    text As String _
)
Visual C++
public:
virtual void ShowStatus(
    String^ location,
    String^ size,
    String^ text
)

Parameters

location
Type: System..::.String
Object's location.
size
Type: System..::.String
Object's size.
text
Type: System..::.String
Textual information about the selected object.

See Also

Designer Class
FastReport.Design Namespace


Unlock Method

[image]

FastReport.Net Class Reference
Designer..::.Unlock Method
Designer Class See Also Send Feedback
Unlocks all plugins.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Unlock()
Visual Basic (Declaration)
Public Sub Unlock
Visual C++
public:
void Unlock()

Remarks

Call this method after the Lock.

See Also

Designer Class
FastReport.Design Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
Designer..::.UpdateBounds Method
Designer Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


UpdatePlugins Method

[image]

FastReport.Net Class Reference
Designer..::.UpdatePlugins Method
Designer Class See Also Send Feedback
Call this method to refresh all plugins' content.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdatePlugins(
    Object sender
)
Visual Basic (Declaration)
Public Sub UpdatePlugins ( _
    sender As Object _
)
Visual C++
public:
void UpdatePlugins(
    Object^ sender
)

Parameters

sender
Type: System..::.Object
The plugin that we don't need to refresh.

See Also

Designer Class
FastReport.Design Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
Designer..::.Validate Method
Designer Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
Designer..::.ValidateChildren Method
Designer Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

Designer Class
Designer Members
FastReport.Design Namespace


Designer Properties

[image] [image]

FastReport.Net Class Reference
Designer Properties
Designer Class See Also Send Feedback

The Designer type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveReport | Gets active report object.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AskSave | Gets or sets a value that determines whether to ask user to save changes when closing the designer.
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
cmdAbout | The "Help|About..." command.
cmdAddData | The "Data|Add New Data Source..." command.
cmdBringToFront | The "Bring To Front" command.
cmdChooseData | The "Data|Choose Report Data..." command.
cmdClose | The "File|Close" command.
cmdCloseAll | The "Window|Close All" command.
cmdCopy | The "Edit|Copy" command.
cmdCut | The "Edit|Cut" command.
cmdDelete | The "Edit|Delete" command.
cmdDeletePage | The "Edit|Delete Page" command.
cmdEdit | The "Edit" command.
cmdFind | The "Edit|Find..." command.
cmdFormatPainter | The "Format Painter" toolbar command.
cmdGroup | The "Edit|Group" command.
cmdHelpContents | The "Help|Help Contents..." command.
cmdInsert | The "Insert" command.
cmdInsertBand | The "Insert Band" command.
cmdNew | The "File|New" command.
cmdNewDialog | The "New Dialog" toolbar command.
cmdNewPage | The "New Page" toolbar command.
cmdOpen | The "File|Open..." command.
cmdOptions | The "View|Options..." command.
cmdPageSetup | The "File|Page Setup..." command.
cmdPaste | The "Edit|Paste" command.
cmdPreview | The "File|Preview..." command.
cmdPrinterSetup | The "File|Printer Setup..." command.
cmdRecentFiles | The "Recent Files" command.
cmdRedo | The "Edit|Redo" command.
cmdReplace | The "Edit|Replace..." command.
cmdReportSettings | The "Report|Options..." command.
cmdReportStyles | The "Report|Styles..." command.
cmdSave | The "File|Save" command.
cmdSaveAll | The "File|Save All" command.
cmdSaveAs | The "File|Save As..." command.
cmdSelectAll | The "Edit|Select All" command.
cmdSelectLanguage | The "File|Select Language..." command.
cmdSendToBack | The "Send To Back" command.
cmdUndo | The "Edit|Undo" command.
cmdUngroup | The "Edit|Ungroup" command.
cmdViewStartPage | The "View|Start Page" command.
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsPreviewPageDesigner | Gets a value indicating that designer is used to edit a preview page.
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutState | Gets or sets the layout state of the designer.
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MdiMode | Gets or sets a value indicating that designer is run in MDI mode.
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Modified | Gets or sets a value indicating that the report was modified.
Name | Gets or sets the name of the control. (Inherited from Control.)
Objects | Gets a collection of objects on the active page of the active report.
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Plugins | Gets a collection of global plugins such as menu, properties window, etc.
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the edited report.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Restrictions | Gets the designer restrictions.
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedComponents | Gets a collection of selected objects of the ComponentBase type.
SelectedObjects | Gets a collection of selected objects on the active page of the active report.
SelectedReportComponents | Gets a collection of selected objects of the ReportComponentBase type.
SelectedTextObjects | Gets a collection of selected objects of the TextObject type.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UIStyle | Gets or sets the visual style.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

Designer Class
FastReport.Design Namespace


ActiveReport Property

[image]

FastReport.Net Class Reference
Designer..::.ActiveReport Property
Designer Class See Also Send Feedback
Gets active report object.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report ActiveReport { get; set; }
Visual Basic (Declaration)
Public Property ActiveReport As Report
Visual C++
public:
property Report^ ActiveReport {
    Report^ get ();
    void set (Report^ value);
}

Remarks

May be null if Start Page selected, or no reports opened.

See Also

Designer Class
FastReport.Design Namespace


AskSave Property

[image]

FastReport.Net Class Reference
Designer..::.AskSave Property
Designer Class See Also Send Feedback
Gets or sets a value that determines whether to ask user to save changes when closing the designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AskSave { get; set; }
Visual Basic (Declaration)
Public Property AskSave As Boolean
Visual C++
public:
property bool AskSave {
    bool get ();
    void set (bool value);
}

See Also

Designer Class
FastReport.Design Namespace


cmdAbout Property

[image]

FastReport.Net Class Reference
Designer..::.cmdAbout Property
Designer Class See Also Send Feedback
The "Help|About..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AboutCommand cmdAbout { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdAbout As AboutCommand
Visual C++
public:
property AboutCommand^ cmdAbout {
    AboutCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdAddData Property

[image]

FastReport.Net Class Reference
Designer..::.cmdAddData Property
Designer Class See Also Send Feedback
The "Data|Add New Data Source..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AddDataCommand cmdAddData { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdAddData As AddDataCommand
Visual C++
public:
property AddDataCommand^ cmdAddData {
    AddDataCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdBringToFront Property

[image]

FastReport.Net Class Reference
Designer..::.cmdBringToFront Property
Designer Class See Also Send Feedback
The "Bring To Front" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BringToFrontCommand cmdBringToFront { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdBringToFront As BringToFrontCommand
Visual C++
public:
property BringToFrontCommand^ cmdBringToFront {
    BringToFrontCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdChooseData Property

[image]

FastReport.Net Class Reference
Designer..::.cmdChooseData Property
Designer Class See Also Send Feedback
The "Data|Choose Report Data..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ChooseDataCommand cmdChooseData { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdChooseData As ChooseDataCommand
Visual C++
public:
property ChooseDataCommand^ cmdChooseData {
    ChooseDataCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdClose Property

[image]

FastReport.Net Class Reference
Designer..::.cmdClose Property
Designer Class See Also Send Feedback
The "File|Close" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloseCommand cmdClose { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdClose As CloseCommand
Visual C++
public:
property CloseCommand^ cmdClose {
    CloseCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdCloseAll Property

[image]

FastReport.Net Class Reference
Designer..::.cmdCloseAll Property
Designer Class See Also Send Feedback
The "Window|Close All" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CloseAllCommand cmdCloseAll { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdCloseAll As CloseAllCommand
Visual C++
public:
property CloseAllCommand^ cmdCloseAll {
    CloseAllCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdCopy Property

[image]

FastReport.Net Class Reference
Designer..::.cmdCopy Property
Designer Class See Also Send Feedback
The "Edit|Copy" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CopyCommand cmdCopy { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdCopy As CopyCommand
Visual C++
public:
property CopyCommand^ cmdCopy {
    CopyCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdCut Property

[image]

FastReport.Net Class Reference
Designer..::.cmdCut Property
Designer Class See Also Send Feedback
The "Edit|Cut" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CutCommand cmdCut { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdCut As CutCommand
Visual C++
public:
property CutCommand^ cmdCut {
    CutCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdDelete Property

[image]

FastReport.Net Class Reference
Designer..::.cmdDelete Property
Designer Class See Also Send Feedback
The "Edit|Delete" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DeleteCommand cmdDelete { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdDelete As DeleteCommand
Visual C++
public:
property DeleteCommand^ cmdDelete {
    DeleteCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdDeletePage Property

[image]

FastReport.Net Class Reference
Designer..::.cmdDeletePage Property
Designer Class See Also Send Feedback
The "Edit|Delete Page" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DeletePageCommand cmdDeletePage { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdDeletePage As DeletePageCommand
Visual C++
public:
property DeletePageCommand^ cmdDeletePage {
    DeletePageCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdEdit Property

[image]

FastReport.Net Class Reference
Designer..::.cmdEdit Property
Designer Class See Also Send Feedback
The "Edit" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EditCommand cmdEdit { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdEdit As EditCommand
Visual C++
public:
property EditCommand^ cmdEdit {
    EditCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdFind Property

[image]

FastReport.Net Class Reference
Designer..::.cmdFind Property
Designer Class See Also Send Feedback
The "Edit|Find..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FindCommand cmdFind { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdFind As FindCommand
Visual C++
public:
property FindCommand^ cmdFind {
    FindCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdFormatPainter Property

[image]

FastReport.Net Class Reference
Designer..::.cmdFormatPainter Property
Designer Class See Also Send Feedback
The "Format Painter" toolbar command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FormatPainterCommand cmdFormatPainter { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdFormatPainter As FormatPainterCommand
Visual C++
public:
property FormatPainterCommand^ cmdFormatPainter {
    FormatPainterCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdGroup Property

[image]

FastReport.Net Class Reference
Designer..::.cmdGroup Property
Designer Class See Also Send Feedback
The "Edit|Group" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupCommand cmdGroup { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdGroup As GroupCommand
Visual C++
public:
property GroupCommand^ cmdGroup {
    GroupCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdHelpContents Property

[image]

FastReport.Net Class Reference
Designer..::.cmdHelpContents Property
Designer Class See Also Send Feedback
The "Help|Help Contents..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HelpContentsCommand cmdHelpContents { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdHelpContents As HelpContentsCommand
Visual C++
public:
property HelpContentsCommand^ cmdHelpContents {
    HelpContentsCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdInsert Property

[image]

FastReport.Net Class Reference
Designer..::.cmdInsert Property
Designer Class See Also Send Feedback
The "Insert" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public InsertCommand cmdInsert { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdInsert As InsertCommand
Visual C++
public:
property InsertCommand^ cmdInsert {
    InsertCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdInsertBand Property

[image]

FastReport.Net Class Reference
Designer..::.cmdInsertBand Property
Designer Class See Also Send Feedback
The "Insert Band" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public InsertBandCommand cmdInsertBand { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdInsertBand As InsertBandCommand
Visual C++
public:
property InsertBandCommand^ cmdInsertBand {
    InsertBandCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdNew Property

[image]

FastReport.Net Class Reference
Designer..::.cmdNew Property
Designer Class See Also Send Feedback
The "File|New" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NewCommand cmdNew { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdNew As NewCommand
Visual C++
public:
property NewCommand^ cmdNew {
    NewCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdNewDialog Property

[image]

FastReport.Net Class Reference
Designer..::.cmdNewDialog Property
Designer Class See Also Send Feedback
The "New Dialog" toolbar command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NewDialogCommand cmdNewDialog { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdNewDialog As NewDialogCommand
Visual C++
public:
property NewDialogCommand^ cmdNewDialog {
    NewDialogCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdNewPage Property

[image]

FastReport.Net Class Reference
Designer..::.cmdNewPage Property
Designer Class See Also Send Feedback
The "New Page" toolbar command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NewPageCommand cmdNewPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdNewPage As NewPageCommand
Visual C++
public:
property NewPageCommand^ cmdNewPage {
    NewPageCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdOpen Property

[image]

FastReport.Net Class Reference
Designer..::.cmdOpen Property
Designer Class See Also Send Feedback
The "File|Open..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OpenCommand cmdOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdOpen As OpenCommand
Visual C++
public:
property OpenCommand^ cmdOpen {
    OpenCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdOptions Property

[image]

FastReport.Net Class Reference
Designer..::.cmdOptions Property
Designer Class See Also Send Feedback
The "View|Options..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OptionsCommand cmdOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdOptions As OptionsCommand
Visual C++
public:
property OptionsCommand^ cmdOptions {
    OptionsCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdPageSetup Property

[image]

FastReport.Net Class Reference
Designer..::.cmdPageSetup Property
Designer Class See Also Send Feedback
The "File|Page Setup..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageSettingsCommand cmdPageSetup { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdPageSetup As PageSettingsCommand
Visual C++
public:
property PageSettingsCommand^ cmdPageSetup {
    PageSettingsCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdPaste Property

[image]

FastReport.Net Class Reference
Designer..::.cmdPaste Property
Designer Class See Also Send Feedback
The "Edit|Paste" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PasteCommand cmdPaste { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdPaste As PasteCommand
Visual C++
public:
property PasteCommand^ cmdPaste {
    PasteCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdPreview Property

[image]

FastReport.Net Class Reference
Designer..::.cmdPreview Property
Designer Class See Also Send Feedback
The "File|Preview..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewCommand cmdPreview { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdPreview As PreviewCommand
Visual C++
public:
property PreviewCommand^ cmdPreview {
    PreviewCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdPrinterSetup Property

[image]

FastReport.Net Class Reference
Designer..::.cmdPrinterSetup Property
Designer Class See Also Send Feedback
The "File|Printer Setup..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PrinterSettingsCommand cmdPrinterSetup { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdPrinterSetup As PrinterSettingsCommand
Visual C++
public:
property PrinterSettingsCommand^ cmdPrinterSetup {
    PrinterSettingsCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdRecentFiles Property

[image]

FastReport.Net Class Reference
Designer..::.cmdRecentFiles Property
Designer Class See Also Send Feedback
The "Recent Files" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RecentFilesCommand cmdRecentFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdRecentFiles As RecentFilesCommand
Visual C++
public:
property RecentFilesCommand^ cmdRecentFiles {
    RecentFilesCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdRedo Property

[image]

FastReport.Net Class Reference
Designer..::.cmdRedo Property
Designer Class See Also Send Feedback
The "Edit|Redo" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RedoCommand cmdRedo { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdRedo As RedoCommand
Visual C++
public:
property RedoCommand^ cmdRedo {
    RedoCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdReplace Property

[image]

FastReport.Net Class Reference
Designer..::.cmdReplace Property
Designer Class See Also Send Feedback
The "Edit|Replace..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReplaceCommand cmdReplace { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdReplace As ReplaceCommand
Visual C++
public:
property ReplaceCommand^ cmdReplace {
    ReplaceCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdReportSettings Property

[image]

FastReport.Net Class Reference
Designer..::.cmdReportSettings Property
Designer Class See Also Send Feedback
The "Report|Options..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportSettingsCommand cmdReportSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdReportSettings As ReportSettingsCommand
Visual C++
public:
property ReportSettingsCommand^ cmdReportSettings {
    ReportSettingsCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdReportStyles Property

[image]

FastReport.Net Class Reference
Designer..::.cmdReportStyles Property
Designer Class See Also Send Feedback
The "Report|Styles..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportStylesCommand cmdReportStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdReportStyles As ReportStylesCommand
Visual C++
public:
property ReportStylesCommand^ cmdReportStyles {
    ReportStylesCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdSave Property

[image]

FastReport.Net Class Reference
Designer..::.cmdSave Property
Designer Class See Also Send Feedback
The "File|Save" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SaveCommand cmdSave { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdSave As SaveCommand
Visual C++
public:
property SaveCommand^ cmdSave {
    SaveCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdSaveAll Property

[image]

FastReport.Net Class Reference
Designer..::.cmdSaveAll Property
Designer Class See Also Send Feedback
The "File|Save All" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SaveAllCommand cmdSaveAll { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdSaveAll As SaveAllCommand
Visual C++
public:
property SaveAllCommand^ cmdSaveAll {
    SaveAllCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdSaveAs Property

[image]

FastReport.Net Class Reference
Designer..::.cmdSaveAs Property
Designer Class See Also Send Feedback
The "File|Save As..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SaveAsCommand cmdSaveAs { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdSaveAs As SaveAsCommand
Visual C++
public:
property SaveAsCommand^ cmdSaveAs {
    SaveAsCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdSelectAll Property

[image]

FastReport.Net Class Reference
Designer..::.cmdSelectAll Property
Designer Class See Also Send Feedback
The "Edit|Select All" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectAllCommand cmdSelectAll { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdSelectAll As SelectAllCommand
Visual C++
public:
property SelectAllCommand^ cmdSelectAll {
    SelectAllCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdSelectLanguage Property

[image]

FastReport.Net Class Reference
Designer..::.cmdSelectLanguage Property
Designer Class See Also Send Feedback
The "File|Select Language..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectLanguageCommand cmdSelectLanguage { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdSelectLanguage As SelectLanguageCommand
Visual C++
public:
property SelectLanguageCommand^ cmdSelectLanguage {
    SelectLanguageCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdSendToBack Property

[image]

FastReport.Net Class Reference
Designer..::.cmdSendToBack Property
Designer Class See Also Send Feedback
The "Send To Back" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SendToBackCommand cmdSendToBack { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdSendToBack As SendToBackCommand
Visual C++
public:
property SendToBackCommand^ cmdSendToBack {
    SendToBackCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdUndo Property

[image]

FastReport.Net Class Reference
Designer..::.cmdUndo Property
Designer Class See Also Send Feedback
The "Edit|Undo" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UndoCommand cmdUndo { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdUndo As UndoCommand
Visual C++
public:
property UndoCommand^ cmdUndo {
    UndoCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdUngroup Property

[image]

FastReport.Net Class Reference
Designer..::.cmdUngroup Property
Designer Class See Also Send Feedback
The "Edit|Ungroup" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UngroupCommand cmdUngroup { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdUngroup As UngroupCommand
Visual C++
public:
property UngroupCommand^ cmdUngroup {
    UngroupCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


cmdViewStartPage Property

[image]

FastReport.Net Class Reference
Designer..::.cmdViewStartPage Property
Designer Class See Also Send Feedback
The "View|Start Page" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ViewStartPageCommand cmdViewStartPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property cmdViewStartPage As ViewStartPageCommand
Visual C++
public:
property ViewStartPageCommand^ cmdViewStartPage {
    ViewStartPageCommand^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


IsPreviewPageDesigner Property

[image]

FastReport.Net Class Reference
Designer..::.IsPreviewPageDesigner Property
Designer Class See Also Send Feedback
Gets a value indicating that designer is used to edit a preview page.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsPreviewPageDesigner { get; set; }
Visual Basic (Declaration)
Public Property IsPreviewPageDesigner As Boolean
Visual C++
public:
property bool IsPreviewPageDesigner {
    bool get ();
    void set (bool value);
}

See Also

Designer Class
FastReport.Design Namespace


LayoutState Property

[image]

FastReport.Net Class Reference
Designer..::.LayoutState Property
Designer Class See Also Send Feedback
Gets or sets the layout state of the designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LayoutState { get; set; }
Visual Basic (Declaration)
Public Property LayoutState As String
Visual C++
public:
property String^ LayoutState {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to store layout in Visual Studio design time. You may also use it to save and restore the designer's layout in your code. However, consider using the SaveConfig()()() and RestoreConfig()()() methods that use FastReport configuration file.

See Also

Designer Class
FastReport.Design Namespace


MdiMode Property

[image]

FastReport.Net Class Reference
Designer..::.MdiMode Property
Designer Class See Also Send Feedback
Gets or sets a value indicating that designer is run in MDI mode.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MdiMode { get; set; }
Visual Basic (Declaration)
Public Property MdiMode As Boolean
Visual C++
public:
property bool MdiMode {
    bool get ();
    void set (bool value);
}

Remarks

To call the designer in MDI (Multi-Document Interface) mode, use the following code:

CopyC#
DesignerControl designer = new DesignerControl();
designer.MdiMode = true;
designer.ShowDialog();

See Also

Designer Class
FastReport.Design Namespace


Modified Property

[image]

FastReport.Net Class Reference
Designer..::.Modified Property
Designer Class See Also Send Feedback
Gets or sets a value indicating that the report was modified.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Modified { get; set; }
Visual Basic (Declaration)
Public Property Modified As Boolean
Visual C++
public:
property bool Modified {
    bool get ();
    void set (bool value);
}

See Also

Designer Class
FastReport.Design Namespace


Objects Property

[image]

FastReport.Net Class Reference
Designer..::.Objects Property
Designer Class See Also Send Feedback
Gets a collection of objects on the active page of the active report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ObjectCollection Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As ObjectCollection
Visual C++
public:
property ObjectCollection^ Objects {
    ObjectCollection^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


Plugins Property

[image]

FastReport.Net Class Reference
Designer..::.Plugins Property
Designer Class See Also Send Feedback
Gets a collection of global plugins such as menu, properties window, etc.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PluginCollection Plugins { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plugins As PluginCollection
Visual C++
public:
property PluginCollection^ Plugins {
    PluginCollection^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


Report Property

[image]

FastReport.Net Class Reference
Designer..::.Report Property
Designer Class See Also Send Feedback
Gets or sets the edited report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; set; }
Visual Basic (Declaration)
Public Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}

Remarks

To initialize the designer, you need to pass a Report instance to this property. This will create the designer's surface associated with the report.
CopyC#
Designer designer = new Designer();
designer.Parent = form1;
designer.Report = report1;

See Also

Designer Class
FastReport.Design Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
Designer..::.Restrictions Property
Designer Class See Also Send Feedback
Gets the designer restrictions.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerRestrictions Restrictions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Restrictions As DesignerRestrictions
Visual C++
public:
property DesignerRestrictions^ Restrictions {
    DesignerRestrictions^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


SelectedComponents Property

[image]

FastReport.Net Class Reference
Designer..::.SelectedComponents Property
Designer Class See Also Send Feedback
Gets a collection of selected objects of the ComponentBase type.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectedComponents SelectedComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedComponents As SelectedComponents
Visual C++
public:
property SelectedComponents^ SelectedComponents {
    SelectedComponents^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


SelectedObjects Property

[image]

FastReport.Net Class Reference
Designer..::.SelectedObjects Property
Designer Class See Also Send Feedback
Gets a collection of selected objects on the active page of the active report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectedObjectCollection SelectedObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedObjects As SelectedObjectCollection
Visual C++
public:
property SelectedObjectCollection^ SelectedObjects {
    SelectedObjectCollection^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


SelectedReportComponents Property

[image]

FastReport.Net Class Reference
Designer..::.SelectedReportComponents Property
Designer Class See Also Send Feedback
Gets a collection of selected objects of the ReportComponentBase type.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectedReportComponents SelectedReportComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedReportComponents As SelectedReportComponents
Visual C++
public:
property SelectedReportComponents^ SelectedReportComponents {
    SelectedReportComponents^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


SelectedTextObjects Property

[image]

FastReport.Net Class Reference
Designer..::.SelectedTextObjects Property
Designer Class See Also Send Feedback
Gets a collection of selected objects of the TextObject type.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectedTextObjects SelectedTextObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedTextObjects As SelectedTextObjects
Visual C++
public:
property SelectedTextObjects^ SelectedTextObjects {
    SelectedTextObjects^ get ();
}

See Also

Designer Class
FastReport.Design Namespace


UIStyle Property

[image]

FastReport.Net Class Reference
Designer..::.UIStyle Property
Designer Class See Also Send Feedback
Gets or sets the visual style.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UIStyle UIStyle { get; set; }
Visual Basic (Declaration)
Public Property UIStyle As UIStyle
Visual C++
public:
property UIStyle UIStyle {
    UIStyle get ();
    void set (UIStyle value);
}

See Also

Designer Class
FastReport.Design Namespace


Designer Events

[image] [image]

FastReport.Net Class Reference
Designer Events
Designer Class See Also Send Feedback

The Designer type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutChangedEvent | Fires when the layout is changed.
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
UIStateChanged | Occurs when designer's UI state changed.
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Designer Class
FastReport.Design Namespace


LayoutChangedEvent Event

[image]

FastReport.Net Class Reference
Designer..::.LayoutChangedEvent Event
Designer Class See Also Send Feedback
Fires when the layout is changed.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler LayoutChangedEvent
Visual Basic (Declaration)
Public Event LayoutChangedEvent As EventHandler
Visual C++
public:
 event EventHandler^ LayoutChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

This event is for internal use only.

See Also

Designer Class
FastReport.Design Namespace


UIStateChanged Event

[image]

FastReport.Net Class Reference
Designer..::.UIStateChanged Event
Designer Class See Also Send Feedback
Occurs when designer's UI state changed.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler UIStateChanged
Visual Basic (Declaration)
Public Event UIStateChanged As EventHandler
Visual C++
public:
 event EventHandler^ UIStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Designer Class
FastReport.Design Namespace


DesignerCommand Class

[image]

FastReport.Net Class Reference
DesignerCommand Class
Members See Also Send Feedback
The base class for all designer commands.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerCommand
Visual Basic (Declaration)
Public Class DesignerCommand
Visual C++
public ref class DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.AboutCommand
FastReport.Design..::.AddDataCommand
FastReport.Design..::.BringToFrontCommand
FastReport.Design..::.ChooseDataCommand
FastReport.Design..::.CloseCommand
FastReport.Design..::.CutCommand
FastReport.Design..::.DeleteCommand
FastReport.Design..::.DeletePageCommand
FastReport.Design..::.EditCommand
FastReport.Design..::.FindCommand
FastReport.Design..::.FormatPainterCommand
FastReport.Design..::.GroupCommand
FastReport.Design..::.HelpContentsCommand
FastReport.Design..::.InsertBandCommand
FastReport.Design..::.InsertCommand
FastReport.Design..::.NewCommand
FastReport.Design..::.NewDialogCommand
FastReport.Design..::.NewPageCommand
FastReport.Design..::.OpenCommand
FastReport.Design..::.OptionsCommand
FastReport.Design..::.PageSettingsCommand
FastReport.Design..::.PasteCommand
FastReport.Design..::.PreviewCommand
FastReport.Design..::.PrinterSettingsCommand
FastReport.Design..::.RecentFilesCommand
FastReport.Design..::.RedoCommand
FastReport.Design..::.ReportSettingsCommand
FastReport.Design..::.ReportStylesCommand
FastReport.Design..::.SaveAllCommand
FastReport.Design..::.SaveAsCommand
FastReport.Design..::.SaveCommand
FastReport.Design..::.SelectAllCommand
FastReport.Design..::.SelectLanguageCommand
FastReport.Design..::.UndoCommand
FastReport.Design..::.ViewStartPageCommand

See Also

DesignerCommand Members
FastReport.Design Namespace


DesignerCommand Members

[image] [image]

FastReport.Net Class Reference
DesignerCommand Members
DesignerCommand Class Methods Properties Events See Also Send Feedback

The DesignerCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled.

Events

Name | Description
CustomAction | Defines a custom action for this command.

See Also

DesignerCommand Class
FastReport.Design Namespace


DesignerCommand Methods

[image] [image]

FastReport.Net Class Reference
DesignerCommand Methods
DesignerCommand Class See Also Send Feedback

The DesignerCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
DesignerCommand..::.GetEnabled Method
DesignerCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual bool GetEnabled()
Visual Basic (Declaration)
Protected Overridable Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled()

Return Value

true if command is enabled.

See Also

DesignerCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DesignerCommand..::.Invoke Method
DesignerCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command.
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args.

See Also

DesignerCommand Class
DesignerCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
DesignerCommand..::.Invoke Method
DesignerCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Invoke()
Visual Basic (Declaration)
Public Overridable Sub Invoke
Visual C++
public:
virtual void Invoke()

See Also

DesignerCommand Class
Invoke Overload
FastReport.Design Namespace


Invoke Method (Object, EventArgs)

[image]

FastReport.Net Class Reference
DesignerCommand..::.Invoke Method (Object, EventArgs)
DesignerCommand Class See Also Send Feedback
Invokes the command with specified sender and event args.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Invoke(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Public Sub Invoke ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public:
void Invoke(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
Sender.
e
Type: System..::.EventArgs
Event args.

Remarks

This method is compatible with standard EventHandler and can be passed to the event handler constructor directly.

See Also

DesignerCommand Class
Invoke Overload
FastReport.Design Namespace


DesignerCommand Properties

[image] [image]

FastReport.Net Class Reference
DesignerCommand Properties
DesignerCommand Class See Also Send Feedback

The DesignerCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled.

See Also

DesignerCommand Class
FastReport.Design Namespace


Enabled Property

[image]

FastReport.Net Class Reference
DesignerCommand..::.Enabled Property
DesignerCommand Class See Also Send Feedback
Gets a value indicating that the command is enabled.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
}

Remarks

If you use own controls that invoke designer commands, use this property to refresh the Enabled state of a control that is bound to this command.

See Also

DesignerCommand Class
FastReport.Design Namespace


DesignerCommand Events

[image] [image]

FastReport.Net Class Reference
DesignerCommand Events
DesignerCommand Class See Also Send Feedback

The DesignerCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command.

See Also

DesignerCommand Class
FastReport.Design Namespace


CustomAction Event

[image]

FastReport.Net Class Reference
DesignerCommand..::.CustomAction Event
DesignerCommand Class Example See Also Send Feedback
Defines a custom action for this command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler CustomAction
Visual Basic (Declaration)
Public Event CustomAction As EventHandler
Visual C++
public:
 event EventHandler^ CustomAction {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Using custom action, you can override the standard behavior of this designer's command.

Examples

This example demonstrates how to override the "New..." command behavior.
CopyC#
// add an event handler that will be fired when the designer is run
Config.DesignerSettings.DesignerLoaded += new EventHandler(DesignerSettings_DesignerLoaded);

void DesignerSettings_DesignerLoaded(object sender, EventArgs e)
{
  // override "New..." command behavior
  (sender as Designer).cmdNew.CustomAction += new EventHandler(cmdNew_CustomAction);
}

void cmdNew_CustomAction(object sender, EventArgs e)
{
  // show the "Label" wizard instead of standard "Add New Item" dialog
  Designer designer = sender as Designer;
  LabelWizard wizard = new LabelWizard();
  wizard.Run(designer);
}

See Also

DesignerCommand Class
FastReport.Design Namespace


DesignerPlugins Class

[image]

FastReport.Net Class Reference
DesignerPlugins Class
Members See Also Send Feedback
Represents list of registered design plugins.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class DesignerPlugins
Visual Basic (Declaration)
Public NotInheritable Class DesignerPlugins
Visual C++
public ref class DesignerPlugins abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerPlugins

See Also

DesignerPlugins Members
FastReport.Design Namespace


DesignerPlugins Members

[image] [image]

FastReport.Net Class Reference
DesignerPlugins Members
DesignerPlugins Class Methods See Also Send Feedback

The DesignerPlugins type exposes the following members.

Methods

Name | Description
Add | Adds a new plugin's type.

See Also

DesignerPlugins Class
FastReport.Design Namespace


DesignerPlugins Methods

[image] [image]

FastReport.Net Class Reference
DesignerPlugins Methods
DesignerPlugins Class See Also Send Feedback

The DesignerPlugins type exposes the following members.

Methods

Name | Description
Add | Adds a new plugin's type.

See Also

DesignerPlugins Class
FastReport.Design Namespace


Add Method

[image]

FastReport.Net Class Reference
DesignerPlugins..::.Add Method
DesignerPlugins Class See Also Send Feedback
Adds a new plugin's type.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Add(
    Type plugin
)
Visual Basic (Declaration)
Public Shared Sub Add ( _
    plugin As Type _
)
Visual C++
public:
static void Add(
    Type^ plugin
)

Parameters

plugin
Type: System..::.Type
The type of a plugin.

See Also

DesignerPlugins Class
FastReport.Design Namespace


DesignerRestrictions Class

[image]

FastReport.Net Class Reference
DesignerRestrictions Class
Members See Also Send Feedback
Represents a set of designer's restrictions.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerRestrictions
Visual Basic (Declaration)
Public Class DesignerRestrictions
Visual C++
public ref class DesignerRestrictions

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerRestrictions

See Also

DesignerRestrictions Members
FastReport.Design Namespace


DesignerRestrictions Members

[image] [image]

FastReport.Net Class Reference
DesignerRestrictions Members
DesignerRestrictions Class Constructors Methods Properties See Also Send Feedback

The DesignerRestrictions type exposes the following members.

Constructors

Name | Description
DesignerRestrictions | Initializes a new instance of the DesignerRestrictions class

Methods

Name | Description
Assign | Copies the contents of another, similar object.
Clone | Creates exact copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DontChangePageOptions | Gets or sets a value that enables or disables the "Page Setup" action.
DontChangeReportOptions | Gets or sets a value that enables or disables the "Report|Options..." menu.
DontCreateData | Gets or sets a value that enables or disables the "Data|Add New Data Source..." menu.
DontCreatePage | Gets or sets a value that enables or disables the creation of report/dialog pages.
DontCreateReport | Gets or sets a value that enables or disables the "New..." action.
DontDeletePage | Gets or sets a value that enables or disables the "Delete Page" action.
DontEditCode | Gets or sets a value that enables or disables the "Code" tab.
DontEditData | Gets or sets a value that enables or disables the "Data" menu.
DontInsertBand | Gets or sets a value that enables or disables the insertion of bands.
DontInsertObject | Gets or sets a value that enables or disables insertion of objects.
DontLoadReport | Gets or sets a value that enables or disables the "Open" action.
DontPreviewReport | Gets or sets a value that enables or disables the "Preview" action.
DontSaveReport | Gets or sets a value that enables or disables the "Save/Save as" actions.
DontShowRecentFiles | Gets or sets a value that enables or disables the recent files list.

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DesignerRestrictions Constructor

[image]

FastReport.Net Class Reference
DesignerRestrictions Constructor
DesignerRestrictions Class See Also Send Feedback
Initializes a new instance of the DesignerRestrictions class

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerRestrictions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerRestrictions()

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DesignerRestrictions Methods

[image] [image]

FastReport.Net Class Reference
DesignerRestrictions Methods
DesignerRestrictions Class See Also Send Feedback

The DesignerRestrictions type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object.
Clone | Creates exact copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerRestrictions Class
FastReport.Design Namespace


Assign Method

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.Assign Method
DesignerRestrictions Class See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    DesignerRestrictions source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As DesignerRestrictions _
)
Visual C++
public:
void Assign(
    DesignerRestrictions^ source
)

Parameters

source
Type: FastReport.Design..::.DesignerRestrictions
Source object to copy the contents from.

See Also

DesignerRestrictions Class
FastReport.Design Namespace


Clone Method

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.Clone Method
DesignerRestrictions Class See Also Send Feedback
Creates exact copy of this object.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerRestrictions Clone()
Visual Basic (Declaration)
Public Function Clone As DesignerRestrictions
Visual C++
public:
DesignerRestrictions^ Clone()

Return Value

The copy of this object.

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DesignerRestrictions Properties

[image] [image]

FastReport.Net Class Reference
DesignerRestrictions Properties
DesignerRestrictions Class See Also Send Feedback

The DesignerRestrictions type exposes the following members.

Properties

Name | Description
DontChangePageOptions | Gets or sets a value that enables or disables the "Page Setup" action.
DontChangeReportOptions | Gets or sets a value that enables or disables the "Report|Options..." menu.
DontCreateData | Gets or sets a value that enables or disables the "Data|Add New Data Source..." menu.
DontCreatePage | Gets or sets a value that enables or disables the creation of report/dialog pages.
DontCreateReport | Gets or sets a value that enables or disables the "New..." action.
DontDeletePage | Gets or sets a value that enables or disables the "Delete Page" action.
DontEditCode | Gets or sets a value that enables or disables the "Code" tab.
DontEditData | Gets or sets a value that enables or disables the "Data" menu.
DontInsertBand | Gets or sets a value that enables or disables the insertion of bands.
DontInsertObject | Gets or sets a value that enables or disables insertion of objects.
DontLoadReport | Gets or sets a value that enables or disables the "Open" action.
DontPreviewReport | Gets or sets a value that enables or disables the "Preview" action.
DontSaveReport | Gets or sets a value that enables or disables the "Save/Save as" actions.
DontShowRecentFiles | Gets or sets a value that enables or disables the recent files list.

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontChangePageOptions Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontChangePageOptions Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Page Setup" action.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontChangePageOptions { get; set; }
Visual Basic (Declaration)
Public Property DontChangePageOptions As Boolean
Visual C++
public:
property bool DontChangePageOptions {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontChangeReportOptions Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontChangeReportOptions Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Report|Options..." menu.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontChangeReportOptions { get; set; }
Visual Basic (Declaration)
Public Property DontChangeReportOptions As Boolean
Visual C++
public:
property bool DontChangeReportOptions {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontCreateData Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontCreateData Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Data|Add New Data Source..." menu.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontCreateData { get; set; }
Visual Basic (Declaration)
Public Property DontCreateData As Boolean
Visual C++
public:
property bool DontCreateData {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontCreatePage Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontCreatePage Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the creation of report/dialog pages.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontCreatePage { get; set; }
Visual Basic (Declaration)
Public Property DontCreatePage As Boolean
Visual C++
public:
property bool DontCreatePage {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontCreateReport Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontCreateReport Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "New..." action.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontCreateReport { get; set; }
Visual Basic (Declaration)
Public Property DontCreateReport As Boolean
Visual C++
public:
property bool DontCreateReport {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontDeletePage Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontDeletePage Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Delete Page" action.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontDeletePage { get; set; }
Visual Basic (Declaration)
Public Property DontDeletePage As Boolean
Visual C++
public:
property bool DontDeletePage {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontEditCode Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontEditCode Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Code" tab.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontEditCode { get; set; }
Visual Basic (Declaration)
Public Property DontEditCode As Boolean
Visual C++
public:
property bool DontEditCode {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontEditData Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontEditData Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Data" menu.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontEditData { get; set; }
Visual Basic (Declaration)
Public Property DontEditData As Boolean
Visual C++
public:
property bool DontEditData {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontInsertBand Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontInsertBand Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the insertion of bands.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontInsertBand { get; set; }
Visual Basic (Declaration)
Public Property DontInsertBand As Boolean
Visual C++
public:
property bool DontInsertBand {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontInsertObject Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontInsertObject Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables insertion of objects.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontInsertObject { get; set; }
Visual Basic (Declaration)
Public Property DontInsertObject As Boolean
Visual C++
public:
property bool DontInsertObject {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontLoadReport Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontLoadReport Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Open" action.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontLoadReport { get; set; }
Visual Basic (Declaration)
Public Property DontLoadReport As Boolean
Visual C++
public:
property bool DontLoadReport {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontPreviewReport Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontPreviewReport Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Preview" action.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontPreviewReport { get; set; }
Visual Basic (Declaration)
Public Property DontPreviewReport As Boolean
Visual C++
public:
property bool DontPreviewReport {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontSaveReport Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontSaveReport Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the "Save/Save as" actions.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontSaveReport { get; set; }
Visual Basic (Declaration)
Public Property DontSaveReport As Boolean
Visual C++
public:
property bool DontSaveReport {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DontShowRecentFiles Property

[image]

FastReport.Net Class Reference
DesignerRestrictions..::.DontShowRecentFiles Property
DesignerRestrictions Class See Also Send Feedback
Gets or sets a value that enables or disables the recent files list.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DontShowRecentFiles { get; set; }
Visual Basic (Declaration)
Public Property DontShowRecentFiles As Boolean
Visual C++
public:
property bool DontShowRecentFiles {
    bool get ();
    void set (bool value);
}

See Also

DesignerRestrictions Class
FastReport.Design Namespace


DesignerSettings Class

[image]

FastReport.Net Class Reference
DesignerSettings Class
Members See Also Send Feedback
This class contains settings that will be applied to the report designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerSettings
Visual Basic (Declaration)
Public Class DesignerSettings
Visual C++
public ref class DesignerSettings

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerSettings

See Also

DesignerSettings Members
FastReport.Design Namespace


DesignerSettings Members

[image] [image]

FastReport.Net Class Reference
DesignerSettings Members
DesignerSettings Class Constructors Methods Properties Events See Also Send Feedback

The DesignerSettings type exposes the following members.

Constructors

Name | Description
DesignerSettings | Initializes a new instance of the DesignerSettings class.

Methods

Name | Description
AddCustomConnection | Adds a custom connection used in the "Data Wizard" window.
ClearCustomConnections | Clears the custom connections added by the AddCustomConnection method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplicationConnection | Gets or sets application-defined DbConnection object that will be used in the designer to create a new datasource.
DefaultFont | Gets or sets the default font used in a report.
Icon | Gets or sets the icon for the designer window.
Restrictions | Gets the designer restrictions flags.
ShowInTaskbar | Gets or sets a value indicating whether the designer window is displayed in the Windows taskbar.
Text | Gets or sets the title text for the designer window.
ToolStripRenderer | Gets the toolstrip renderer.

Events

Name | Description
CustomOpenDialog | Occurs when the report designer is about to show the "Open" dialog.
CustomOpenReport | Occurs when the report designer is about to load the report.
CustomPreviewReport | Occurs when previewing a report from the designer.
CustomQueryBuilder | Occurs when the query builder is called.
CustomSaveDialog | Occurs when the report designer is about to show the "Save" dialog.
CustomSaveReport | Occurs when the report designer is about to save the report.
DesignerLoaded | Occurs when the designer is loaded.
FilterConnectionTables | Occurs when getting available table names from the connection.
ObjectInserted | Occurs when object is inserted.
PageAdded | Occurs when a report page or a dialog form is added to the report.
ReportLoaded | Occurs when the report is loaded.

See Also

DesignerSettings Class
FastReport.Design Namespace


DesignerSettings Constructor

[image]

FastReport.Net Class Reference
DesignerSettings Constructor
DesignerSettings Class See Also Send Feedback
Initializes a new instance of the DesignerSettings class.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerSettings()

See Also

DesignerSettings Class
FastReport.Design Namespace


DesignerSettings Methods

[image] [image]

FastReport.Net Class Reference
DesignerSettings Methods
DesignerSettings Class See Also Send Feedback

The DesignerSettings type exposes the following members.

Methods

Name | Description
AddCustomConnection | Adds a custom connection used in the "Data Wizard" window.
ClearCustomConnections | Clears the custom connections added by the AddCustomConnection method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerSettings Class
FastReport.Design Namespace


AddCustomConnection Method

[image]

FastReport.Net Class Reference
DesignerSettings..::.AddCustomConnection Method
DesignerSettings Class Example See Also Send Feedback
Adds a custom connection used in the "Data Wizard" window.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddCustomConnection(
    Type connectionType,
    string connectionString
)
Visual Basic (Declaration)
Public Sub AddCustomConnection ( _
    connectionType As Type, _
    connectionString As String _
)
Visual C++
public:
void AddCustomConnection(
    Type^ connectionType,
    String^ connectionString
)

Parameters

connectionType
Type: System..::.Type
connectionString
Type: System..::.String

Remarks

Use this method to provide own connection strings for the "Data Wizard" dialog. To do this, you need to pass the type of connection object and connection string associated with it. You must use one of the connection objects registered in FastReport that inherit from the DataConnectionBase class.

To clear the custom connections, use the ClearCustomConnections()()() method.

Examples

This example shows how to add own connection string.
CopyC#
Config.DesignerSettings.AddCustomConnection(typeof(MsAccessDataConnection), @"Data Source=c:\data.mdb");

See Also

DesignerSettings Class
FastReport.Design Namespace


ClearCustomConnections Method

[image]

FastReport.Net Class Reference
DesignerSettings..::.ClearCustomConnections Method
DesignerSettings Class See Also Send Feedback
Clears the custom connections added by the AddCustomConnection method.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ClearCustomConnections()
Visual Basic (Declaration)
Public Sub ClearCustomConnections
Visual C++
public:
void ClearCustomConnections()

See Also

DesignerSettings Class
FastReport.Design Namespace


DesignerSettings Properties

[image] [image]

FastReport.Net Class Reference
DesignerSettings Properties
DesignerSettings Class See Also Send Feedback

The DesignerSettings type exposes the following members.

Properties

Name | Description
ApplicationConnection | Gets or sets application-defined DbConnection object that will be used in the designer to create a new datasource.
DefaultFont | Gets or sets the default font used in a report.
Icon | Gets or sets the icon for the designer window.
Restrictions | Gets the designer restrictions flags.
ShowInTaskbar | Gets or sets a value indicating whether the designer window is displayed in the Windows taskbar.
Text | Gets or sets the title text for the designer window.
ToolStripRenderer | Gets the toolstrip renderer.

See Also

DesignerSettings Class
FastReport.Design Namespace


ApplicationConnection Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.ApplicationConnection Property
DesignerSettings Class See Also Send Feedback
Gets or sets application-defined DbConnection object that will be used in the designer to create a new datasource.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DbConnection ApplicationConnection { get; set; }
Visual Basic (Declaration)
Public Property ApplicationConnection As DbConnection
Visual C++
public:
property DbConnection^ ApplicationConnection {
    DbConnection^ get ();
    void set (DbConnection^ value);
}

Remarks

The application connection object is used in the "Data Wizard" to create new datasources. In this mode, you can't create any other connections in the wizard; only application connection is available. You still able to choose tables or create a new queries inside this connection. The connection information (ConnectionString) is not stored in the report file.

See Also

DesignerSettings Class
FastReport.Design Namespace


DefaultFont Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.DefaultFont Property
DesignerSettings Class See Also Send Feedback
Gets or sets the default font used in a report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font DefaultFont { get; set; }
Visual Basic (Declaration)
Public Property DefaultFont As Font
Visual C++
public:
property Font^ DefaultFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


Icon Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.Icon Property
DesignerSettings Class See Also Send Feedback
Gets or sets the icon for the designer window.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Icon Icon { get; set; }
Visual Basic (Declaration)
Public Property Icon As Icon
Visual C++
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.Restrictions Property
DesignerSettings Class See Also Send Feedback
Gets the designer restrictions flags.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerRestrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As DesignerRestrictions
Visual C++
public:
property DesignerRestrictions^ Restrictions {
    DesignerRestrictions^ get ();
    void set (DesignerRestrictions^ value);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


ShowInTaskbar Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.ShowInTaskbar Property
DesignerSettings Class See Also Send Feedback
Gets or sets a value indicating whether the designer window is displayed in the Windows taskbar.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowInTaskbar { get; set; }
Visual Basic (Declaration)
Public Property ShowInTaskbar As Boolean
Visual C++
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


Text Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.Text Property
DesignerSettings Class See Also Send Feedback
Gets or sets the title text for the designer window.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

If no text is set, the default text "FastReport -" will be used.

See Also

DesignerSettings Class
FastReport.Design Namespace


ToolStripRenderer Property

[image]

FastReport.Net Class Reference
DesignerSettings..::.ToolStripRenderer Property
DesignerSettings Class See Also Send Feedback
Gets the toolstrip renderer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ToolStripRenderer ToolStripRenderer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToolStripRenderer As ToolStripRenderer
Visual C++
public:
property ToolStripRenderer^ ToolStripRenderer {
    ToolStripRenderer^ get ();
}

See Also

DesignerSettings Class
FastReport.Design Namespace


DesignerSettings Events

[image] [image]

FastReport.Net Class Reference
DesignerSettings Events
DesignerSettings Class See Also Send Feedback

The DesignerSettings type exposes the following members.

Events

Name | Description
CustomOpenDialog | Occurs when the report designer is about to show the "Open" dialog.
CustomOpenReport | Occurs when the report designer is about to load the report.
CustomPreviewReport | Occurs when previewing a report from the designer.
CustomQueryBuilder | Occurs when the query builder is called.
CustomSaveDialog | Occurs when the report designer is about to show the "Save" dialog.
CustomSaveReport | Occurs when the report designer is about to save the report.
DesignerLoaded | Occurs when the designer is loaded.
FilterConnectionTables | Occurs when getting available table names from the connection.
ObjectInserted | Occurs when object is inserted.
PageAdded | Occurs when a report page or a dialog form is added to the report.
ReportLoaded | Occurs when the report is loaded.

See Also

DesignerSettings Class
FastReport.Design Namespace


CustomOpenDialog Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.CustomOpenDialog Event
DesignerSettings Class Example See Also Send Feedback
Occurs when the report designer is about to show the "Open" dialog.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveDialogEventHandler CustomOpenDialog
Visual Basic (Declaration)
Public Event CustomOpenDialog As OpenSaveDialogEventHandler
Visual C++
public:
 event OpenSaveDialogEventHandler^ CustomOpenDialog {
    void add (OpenSaveDialogEventHandler^ value);
    void remove (OpenSaveDialogEventHandler^ value);
}

Remarks

Use this event to attach own "Open" dialog to the designer. In the event handler, you must display a dialog window to allow user to choose a report file. If dialog was executed successfully, you must return e.Cancel = false and set the e.FileName to the selected file name.

You also need to use CustomOpenReport event to provide code that will open the report.

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


CustomOpenReport Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.CustomOpenReport Event
DesignerSettings Class Example See Also Send Feedback
Occurs when the report designer is about to load the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveReportEventHandler CustomOpenReport
Visual Basic (Declaration)
Public Event CustomOpenReport As OpenSaveReportEventHandler
Visual C++
public:
 event OpenSaveReportEventHandler^ CustomOpenReport {
    void add (OpenSaveReportEventHandler^ value);
    void remove (OpenSaveReportEventHandler^ value);
}

Remarks

This event is used together with the CustomOpenDialog event.

Use this event to attach own "Open" dialog to the designer. In the event handler, you must load the e.Report from the location specified in the e.FileName property. For example, if you work with files: e.Report.Load(e.FileName);

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


CustomPreviewReport Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.CustomPreviewReport Event
DesignerSettings Class Example See Also Send Feedback
Occurs when previewing a report from the designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler CustomPreviewReport
Visual Basic (Declaration)
Public Event CustomPreviewReport As EventHandler
Visual C++
public:
 event EventHandler^ CustomPreviewReport {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event to show own preview window.

Examples

CopyC#
Config.DesignerSettings.CustomPreviewReport += new EventHandler(MyPreviewHandler);

private void MyPreviewHandler(object sender, EventArgs e)
{
  Report report = sender as Report;
  using (MyPreviewForm form = new MyPreviewForm())
  {
    report.Preview = form.previewControl1;
    report.ShowPreparedReport();
    form.ShowDialog();
  }
}

See Also

DesignerSettings Class
FastReport.Design Namespace


CustomQueryBuilder Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.CustomQueryBuilder Event
DesignerSettings Class See Also Send Feedback
Occurs when the query builder is called.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event CustomQueryBuilderEventHandler CustomQueryBuilder
Visual Basic (Declaration)
Public Event CustomQueryBuilder As CustomQueryBuilderEventHandler
Visual C++
public:
 event CustomQueryBuilderEventHandler^ CustomQueryBuilder {
    void add (CustomQueryBuilderEventHandler^ value);
    void remove (CustomQueryBuilderEventHandler^ value);
}

Remarks

Subscribe to this event if you want to replace the embedded query builder with your own one.

See Also

DesignerSettings Class
FastReport.Design Namespace


CustomSaveDialog Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.CustomSaveDialog Event
DesignerSettings Class Example See Also Send Feedback
Occurs when the report designer is about to show the "Save" dialog.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveDialogEventHandler CustomSaveDialog
Visual Basic (Declaration)
Public Event CustomSaveDialog As OpenSaveDialogEventHandler
Visual C++
public:
 event OpenSaveDialogEventHandler^ CustomSaveDialog {
    void add (OpenSaveDialogEventHandler^ value);
    void remove (OpenSaveDialogEventHandler^ value);
}

Remarks

Use this event to attach own "Save" dialog to the designer. In the event handler, you must display a dialog window to allow user to choose a report file. If dialog was executed successfully, you must return e.Cancel = false and set the e.FileName to the selected file name.

You also need to use CustomSaveReport event to provide code that will save the report.

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


CustomSaveReport Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.CustomSaveReport Event
DesignerSettings Class Example See Also Send Feedback
Occurs when the report designer is about to save the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event OpenSaveReportEventHandler CustomSaveReport
Visual Basic (Declaration)
Public Event CustomSaveReport As OpenSaveReportEventHandler
Visual C++
public:
 event OpenSaveReportEventHandler^ CustomSaveReport {
    void add (OpenSaveReportEventHandler^ value);
    void remove (OpenSaveReportEventHandler^ value);
}

Remarks

This event is used together with the CustomSaveDialog event.

Use this event to attach own "Save" dialog to the designer. In the event handler, you must save the e.Report to the location specified in the e.FileName property. For example, if you work with files: e.Report.Save(e.FileName);

Examples

This example shows how to attach own "Open" and "Save" dialogs to the designer. It uses the following events: CustomOpenDialog, CustomSaveDialog, CustomOpenReport, CustomSaveReport.
CopyC#
private void CustomOpenDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (OpenFileDialog dialog = new OpenFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomSaveDialog_Handler(object sender, OpenSaveDialogEventArgs e)
{
  using (SaveFileDialog dialog = new SaveFileDialog())
  {
    dialog.Filter = "Report files (*.frx)|*.frx";
    // get default file name from e.FileName
    dialog.FileName = e.FileName;

    // set e.Cancel to false if dialog was succesfully executed
    e.Cancel = dialog.ShowDialog() != DialogResult.OK;
    // set e.FileName to the selected file name
    e.FileName = dialog.FileName;
  }
}

private void CustomOpenReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // load the report from the given e.FileName
  e.Report.Load(e.FileName);
}

private void CustomSaveReport_Handler(object sender, OpenSaveReportEventArgs e)
{
  // save the report to the given e.FileName
  e.Report.Save(e.FileName);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


DesignerLoaded Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.DesignerLoaded Event
DesignerSettings Class Example See Also Send Feedback
Occurs when the designer is loaded.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler DesignerLoaded
Visual Basic (Declaration)
Public Event DesignerLoaded As EventHandler
Visual C++
public:
 event EventHandler^ DesignerLoaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event if you want to customize some aspects of the designer, for example, to hide some menu items.

Examples

This example demonstrates how to hide the "File|Select Language..." menu item.
CopyC#
Config.DesignerSettings.DesignerLoaded += new EventHandler(DesignerSettings_DesignerLoaded);

void DesignerSettings_DesignerLoaded(object sender, EventArgs e)
{
  (sender as DesignerControl).MainMenu.miFileSelectLanguage.Visible = false;
}

See Also

DesignerSettings Class
FastReport.Design Namespace


FilterConnectionTables Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.FilterConnectionTables Event
DesignerSettings Class Example See Also Send Feedback
Occurs when getting available table names from the connection.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event FilterConnectionTablesEventHandler FilterConnectionTables
Visual Basic (Declaration)
Public Event FilterConnectionTables As FilterConnectionTablesEventHandler
Visual C++
public:
 event FilterConnectionTablesEventHandler^ FilterConnectionTables {
    void add (FilterConnectionTablesEventHandler^ value);
    void remove (FilterConnectionTablesEventHandler^ value);
}

Remarks

Use this handler to filter the list of tables returned by the connection object.

Examples

This example demonstrates how to hide the table with "Table 1" name from the Data Wizard.
CopyC#
Config.DesignerSettings.FilterConnectionTables += DesignerSettings_FilterConnectionTables;

private void DesignerSettings_FilterConnectionTables(object sender, FilterConnectionTablesEventArgs e)
{
  if (e.TableName == "Table 1")
    e.Skip = true;
}

See Also

DesignerSettings Class
FastReport.Design Namespace


ObjectInserted Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.ObjectInserted Event
DesignerSettings Class See Also Send Feedback
Occurs when object is inserted.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ObjectInsertedEventHandler ObjectInserted
Visual Basic (Declaration)
Public Event ObjectInserted As ObjectInsertedEventHandler
Visual C++
public:
 event ObjectInsertedEventHandler^ ObjectInserted {
    void add (ObjectInsertedEventHandler^ value);
    void remove (ObjectInsertedEventHandler^ value);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


PageAdded Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.PageAdded Event
DesignerSettings Class Example See Also Send Feedback
Occurs when a report page or a dialog form is added to the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler PageAdded
Visual Basic (Declaration)
Public Event PageAdded As EventHandler
Visual C++
public:
 event EventHandler^ PageAdded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event if you want to customize the page properties.

Examples

This example demonstrates how to change the default page margins.
CopyC#
Config.DesignerSettings.PageAdded += new EventHandler(DesignerSettings_PageAdded);

void DesignerSettings_PageAdded(object sender, EventArgs e)
{
  if (sender is ReportPage)
    (sender as ReportPage).TopMargin = 0;
}

See Also

DesignerSettings Class
FastReport.Design Namespace


ReportLoaded Event

[image]

FastReport.Net Class Reference
DesignerSettings..::.ReportLoaded Event
DesignerSettings Class See Also Send Feedback
Occurs when the report is loaded.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ReportLoadedEventHandler ReportLoaded
Visual Basic (Declaration)
Public Event ReportLoaded As ReportLoadedEventHandler
Visual C++
public:
 event ReportLoadedEventHandler^ ReportLoaded {
    void add (ReportLoadedEventHandler^ value);
    void remove (ReportLoadedEventHandler^ value);
}

See Also

DesignerSettings Class
FastReport.Design Namespace


EditCommand Class

[image]

FastReport.Net Class Reference
EditCommand Class
Members See Also Send Feedback
Represents the "Edit" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class EditCommand : DesignerCommand
Visual Basic (Declaration)
Public Class EditCommand _
    Inherits DesignerCommand
Visual C++
public ref class EditCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.EditCommand

See Also

EditCommand Members
FastReport.Design Namespace


EditCommand Members

[image] [image]

FastReport.Net Class Reference
EditCommand Members
EditCommand Class Methods Properties Events See Also Send Feedback

The EditCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

EditCommand Class
FastReport.Design Namespace


EditCommand Methods

[image] [image]

FastReport.Net Class Reference
EditCommand Methods
EditCommand Class See Also Send Feedback

The EditCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
EditCommand..::.GetEnabled Method
EditCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

EditCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
EditCommand..::.Invoke Method
EditCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

EditCommand Class
EditCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
EditCommand..::.Invoke Method
EditCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

EditCommand Class
Invoke Overload
FastReport.Design Namespace


EditCommand Properties

[image] [image]

FastReport.Net Class Reference
EditCommand Properties
EditCommand Class See Also Send Feedback

The EditCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

EditCommand Class
FastReport.Design Namespace


EditCommand Events

[image] [image]

FastReport.Net Class Reference
EditCommand Events
EditCommand Class See Also Send Feedback

The EditCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

EditCommand Class
FastReport.Design Namespace


ExportPlugin Class

[image]

FastReport.Net Class Reference
ExportPlugin Class
Members See Also Send Feedback
Base class for all export plugins.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ExportPlugin : IDesignerPlugin
Visual Basic (Declaration)
Public Class ExportPlugin _
    Implements IDesignerPlugin
Visual C++
public ref class ExportPlugin : IDesignerPlugin

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.ExportPlugin

See Also

ExportPlugin Members
FastReport.Design Namespace


ExportPlugin Members

[image] [image]

FastReport.Net Class Reference
ExportPlugin Members
ExportPlugin Class Constructors Methods Properties See Also Send Feedback

The ExportPlugin type exposes the following members.

Constructors

Name | Description
ExportPlugin | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Returns a file filter for a save dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreState | Restores the plugin state.
SaveReport | Saves the specified report into specified file.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

Properties

Name | Description
Designer | Gets or sets reference to the designer.
Filter | Gets or sets the filter string used in the "Save File" dialog.
Name | Gets or sets the name of plugin.
PluginName | Gets the plugin name.
Report | Gets or sets reference to the report.

See Also

ExportPlugin Class
FastReport.Design Namespace


ExportPlugin Constructor

[image] [image]

FastReport.Net Class Reference
ExportPlugin Constructor
ExportPlugin Class See Also Send Feedback

Overload List

Name | Description
ExportPlugin()()() | Initializes a new instance of the ExportPlugin class with default settings.
ExportPlugin(Designer) | Initializes a new instance of the ExportPlugin class with a specified designer.

See Also

ExportPlugin Class
ExportPlugin Members
FastReport.Design Namespace


ExportPlugin Constructor

[image]

FastReport.Net Class Reference
ExportPlugin Constructor
ExportPlugin Class See Also Send Feedback
Initializes a new instance of the ExportPlugin class with default settings.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ExportPlugin()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExportPlugin()

See Also

ExportPlugin Class
ExportPlugin Overload
FastReport.Design Namespace


ExportPlugin Constructor (Designer)

[image]

FastReport.Net Class Reference
ExportPlugin Constructor (Designer)
ExportPlugin Class See Also Send Feedback
Initializes a new instance of the ExportPlugin class with a specified designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ExportPlugin(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ExportPlugin(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

ExportPlugin Class
ExportPlugin Overload
FastReport.Design Namespace


ExportPlugin Methods

[image] [image]

FastReport.Net Class Reference
ExportPlugin Methods
ExportPlugin Class See Also Send Feedback

The ExportPlugin type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Returns a file filter for a save dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreState | Restores the plugin state.
SaveReport | Saves the specified report into specified file.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

See Also

ExportPlugin Class
FastReport.Design Namespace


GetFilter Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.GetFilter Method
ExportPlugin Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual string GetFilter()
Visual Basic (Declaration)
Protected Overridable Function GetFilter As String
Visual C++
protected:
virtual String^ GetFilter()

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

ExportPlugin Class
FastReport.Design Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.GetOptionsPage Method
ExportPlugin Class See Also Send Feedback
Gets an options page that will be used in the Designer Options dialog to edit the plugin options.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Public Function GetOptionsPage As DesignerOptionsPage
Visual C++
public:
virtual DesignerOptionsPage^ GetOptionsPage() sealed

Return Value

The options page, if implemented; otherwise, null.

Implements

IDesignerPlugin..::.GetOptionsPage()()()

See Also

ExportPlugin Class
FastReport.Design Namespace


Localize Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.Localize Method
ExportPlugin Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Localize()
Visual Basic (Declaration)
Public Sub Localize
Visual C++
public:
virtual void Localize() sealed

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

ExportPlugin Class
FastReport.Design Namespace


Lock Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.Lock Method
ExportPlugin Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Lock()
Visual Basic (Declaration)
Public Sub Lock
Visual C++
public:
virtual void Lock() sealed

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

ExportPlugin Class
FastReport.Design Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.RestoreState Method
ExportPlugin Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RestoreState()
Visual Basic (Declaration)
Public Sub RestoreState
Visual C++
public:
virtual void RestoreState() sealed

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

ExportPlugin Class
FastReport.Design Namespace


SaveReport Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.SaveReport Method
ExportPlugin Class See Also Send Feedback
Saves the specified report into specified file.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SaveReport(
    Report report,
    string filename
)
Visual Basic (Declaration)
Public Overridable Sub SaveReport ( _
    report As Report, _
    filename As String _
)
Visual C++
public:
virtual void SaveReport(
    Report^ report,
    String^ filename
)

Parameters

report
Type: FastReport..::.Report
Report object.
filename
Type: System..::.String
File name.

See Also

ExportPlugin Class
FastReport.Design Namespace


SaveState Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.SaveState Method
ExportPlugin Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveState()
Visual Basic (Declaration)
Public Sub SaveState
Visual C++
public:
virtual void SaveState() sealed

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

ExportPlugin Class
FastReport.Design Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.SelectionChanged Method
ExportPlugin Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectionChanged()
Visual Basic (Declaration)
Public Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() sealed

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ExportPlugin Class
FastReport.Design Namespace


Unlock Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.Unlock Method
ExportPlugin Class See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Unlock()
Visual Basic (Declaration)
Public Sub Unlock
Visual C++
public:
virtual void Unlock() sealed

Implements

IDesignerPlugin..::.Unlock()()()

See Also

ExportPlugin Class
FastReport.Design Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.UpdateContent Method
ExportPlugin Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateContent()
Visual Basic (Declaration)
Public Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() sealed

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ExportPlugin Class
FastReport.Design Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
ExportPlugin..::.UpdateUIStyle Method
ExportPlugin Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateUIStyle()
Visual Basic (Declaration)
Public Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle() sealed

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

ExportPlugin Class
FastReport.Design Namespace


ExportPlugin Properties

[image] [image]

FastReport.Net Class Reference
ExportPlugin Properties
ExportPlugin Class See Also Send Feedback

The ExportPlugin type exposes the following members.

Properties

Name | Description
Designer | Gets or sets reference to the designer.
Filter | Gets or sets the filter string used in the "Save File" dialog.
Name | Gets or sets the name of plugin.
PluginName | Gets the plugin name.
Report | Gets or sets reference to the report.

See Also

ExportPlugin Class
FastReport.Design Namespace


Designer Property

[image]

FastReport.Net Class Reference
ExportPlugin..::.Designer Property
ExportPlugin Class See Also Send Feedback
Gets or sets reference to the designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; protected set; }
Visual Basic (Declaration)
Public Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
    void set (Designer^ value);
}

See Also

ExportPlugin Class
FastReport.Design Namespace


Filter Property

[image]

FastReport.Net Class Reference
ExportPlugin..::.Filter Property
ExportPlugin Class See Also Send Feedback
Gets or sets the filter string used in the "Save File" dialog.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; protected set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

ExportPlugin Class
FastReport.Design Namespace


Name Property

[image]

FastReport.Net Class Reference
ExportPlugin..::.Name Property
ExportPlugin Class See Also Send Feedback
Gets or sets the name of plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; protected set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ExportPlugin Class
FastReport.Design Namespace


PluginName Property

[image]

FastReport.Net Class Reference
ExportPlugin..::.PluginName Property
ExportPlugin Class See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PluginName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PluginName As String
Visual C++
public:
virtual property String^ PluginName {
    String^ get () sealed;
}

Implements

IDesignerPlugin..::.PluginName

See Also

ExportPlugin Class
FastReport.Design Namespace


Report Property

[image]

FastReport.Net Class Reference
ExportPlugin..::.Report Property
ExportPlugin Class See Also Send Feedback
Gets or sets reference to the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; protected set; }
Visual Basic (Declaration)
Public Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}

See Also

ExportPlugin Class
FastReport.Design Namespace


FilterConnectionTablesEventArgs Class

[image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs Class
Members See Also Send Feedback
Provides data for the FilterConnectionTables event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FilterConnectionTablesEventArgs
Visual Basic (Declaration)
Public Class FilterConnectionTablesEventArgs
Visual C++
public ref class FilterConnectionTablesEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.FilterConnectionTablesEventArgs

See Also

FilterConnectionTablesEventArgs Members
FastReport.Design Namespace


FilterConnectionTablesEventArgs Members

[image] [image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs Members
FilterConnectionTablesEventArgs Class Methods Properties See Also Send Feedback

The FilterConnectionTablesEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Connection | Gets the Connection object.
Skip | Gets or sets a value that indicates whether this table should be skipped.
TableName | Gets the table name.

See Also

FilterConnectionTablesEventArgs Class
FastReport.Design Namespace


FilterConnectionTablesEventArgs Methods

[image] [image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs Methods
FilterConnectionTablesEventArgs Class See Also Send Feedback

The FilterConnectionTablesEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterConnectionTablesEventArgs Class
FastReport.Design Namespace


FilterConnectionTablesEventArgs Properties

[image] [image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs Properties
FilterConnectionTablesEventArgs Class See Also Send Feedback

The FilterConnectionTablesEventArgs type exposes the following members.

Properties

Name | Description
Connection | Gets the Connection object.
Skip | Gets or sets a value that indicates whether this table should be skipped.
TableName | Gets the table name.

See Also

FilterConnectionTablesEventArgs Class
FastReport.Design Namespace


Connection Property

[image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs..::.Connection Property
FilterConnectionTablesEventArgs Class See Also Send Feedback
Gets the Connection object.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataConnectionBase Connection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connection As DataConnectionBase
Visual C++
public:
property DataConnectionBase^ Connection {
    DataConnectionBase^ get ();
}

See Also

FilterConnectionTablesEventArgs Class
FastReport.Design Namespace


Skip Property

[image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs..::.Skip Property
FilterConnectionTablesEventArgs Class See Also Send Feedback
Gets or sets a value that indicates whether this table should be skipped.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Skip { get; set; }
Visual Basic (Declaration)
Public Property Skip As Boolean
Visual C++
public:
property bool Skip {
    bool get ();
    void set (bool value);
}

See Also

FilterConnectionTablesEventArgs Class
FastReport.Design Namespace


TableName Property

[image]

FastReport.Net Class Reference
FilterConnectionTablesEventArgs..::.TableName Property
FilterConnectionTablesEventArgs Class See Also Send Feedback
Gets the table name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TableName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TableName As String
Visual C++
public:
property String^ TableName {
    String^ get ();
}

See Also

FilterConnectionTablesEventArgs Class
FastReport.Design Namespace


FilterConnectionTablesEventHandler Delegate

[image]

FastReport.Net Class Reference
FilterConnectionTablesEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the FilterConnectionTables event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void FilterConnectionTablesEventHandler(
    Object sender,
    FilterConnectionTablesEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub FilterConnectionTablesEventHandler ( _
    sender As Object, _
    e As FilterConnectionTablesEventArgs _
)
Visual C++
public delegate void FilterConnectionTablesEventHandler(
    Object^ sender,
    FilterConnectionTablesEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Design..::.FilterConnectionTablesEventArgs
The event data.

See Also

FastReport.Design Namespace


FindCommand Class

[image]

FastReport.Net Class Reference
FindCommand Class
Members See Also Send Feedback
Represents the "Edit|Find..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FindCommand : DesignerCommand
Visual Basic (Declaration)
Public Class FindCommand _
    Inherits DesignerCommand
Visual C++
public ref class FindCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.FindCommand
FastReport.Design..::.ReplaceCommand

See Also

FindCommand Members
FastReport.Design Namespace


FindCommand Members

[image] [image]

FastReport.Net Class Reference
FindCommand Members
FindCommand Class Methods Properties Events See Also Send Feedback

The FindCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

FindCommand Class
FastReport.Design Namespace


FindCommand Methods

[image] [image]

FastReport.Net Class Reference
FindCommand Methods
FindCommand Class See Also Send Feedback

The FindCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
FindCommand..::.GetEnabled Method
FindCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

FindCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
FindCommand..::.Invoke Method
FindCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

FindCommand Class
FindCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
FindCommand..::.Invoke Method
FindCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

FindCommand Class
Invoke Overload
FastReport.Design Namespace


FindCommand Properties

[image] [image]

FastReport.Net Class Reference
FindCommand Properties
FindCommand Class See Also Send Feedback

The FindCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

FindCommand Class
FastReport.Design Namespace


FindCommand Events

[image] [image]

FastReport.Net Class Reference
FindCommand Events
FindCommand Class See Also Send Feedback

The FindCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

FindCommand Class
FastReport.Design Namespace


FormatPainterCommand Class

[image]

FastReport.Net Class Reference
FormatPainterCommand Class
Members See Also Send Feedback
Represents the "Format Painter" toolbar command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FormatPainterCommand : DesignerCommand
Visual Basic (Declaration)
Public Class FormatPainterCommand _
    Inherits DesignerCommand
Visual C++
public ref class FormatPainterCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.FormatPainterCommand

See Also

FormatPainterCommand Members
FastReport.Design Namespace


FormatPainterCommand Members

[image] [image]

FastReport.Net Class Reference
FormatPainterCommand Members
FormatPainterCommand Class Methods Properties Events See Also Send Feedback

The FormatPainterCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

FormatPainterCommand Class
FastReport.Design Namespace


FormatPainterCommand Methods

[image] [image]

FastReport.Net Class Reference
FormatPainterCommand Methods
FormatPainterCommand Class See Also Send Feedback

The FormatPainterCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatPainterCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
FormatPainterCommand..::.GetEnabled Method
FormatPainterCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

FormatPainterCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
FormatPainterCommand..::.Invoke Method
FormatPainterCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

FormatPainterCommand Class
FormatPainterCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
FormatPainterCommand..::.Invoke Method
FormatPainterCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

FormatPainterCommand Class
Invoke Overload
FastReport.Design Namespace


FormatPainterCommand Properties

[image] [image]

FastReport.Net Class Reference
FormatPainterCommand Properties
FormatPainterCommand Class See Also Send Feedback

The FormatPainterCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

FormatPainterCommand Class
FastReport.Design Namespace


FormatPainterCommand Events

[image] [image]

FastReport.Net Class Reference
FormatPainterCommand Events
FormatPainterCommand Class See Also Send Feedback

The FormatPainterCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

FormatPainterCommand Class
FastReport.Design Namespace


GroupCommand Class

[image]

FastReport.Net Class Reference
GroupCommand Class
Members See Also Send Feedback
Represents the "Edit|Group" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GroupCommand : DesignerCommand
Visual Basic (Declaration)
Public Class GroupCommand _
    Inherits DesignerCommand
Visual C++
public ref class GroupCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.GroupCommand
FastReport.Design..::.UngroupCommand

See Also

GroupCommand Members
FastReport.Design Namespace


GroupCommand Members

[image] [image]

FastReport.Net Class Reference
GroupCommand Members
GroupCommand Class Methods Properties Events See Also Send Feedback

The GroupCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

GroupCommand Class
FastReport.Design Namespace


GroupCommand Methods

[image] [image]

FastReport.Net Class Reference
GroupCommand Methods
GroupCommand Class See Also Send Feedback

The GroupCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
GroupCommand..::.GetEnabled Method
GroupCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

GroupCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
GroupCommand..::.Invoke Method
GroupCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

GroupCommand Class
GroupCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
GroupCommand..::.Invoke Method
GroupCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

GroupCommand Class
Invoke Overload
FastReport.Design Namespace


GroupCommand Properties

[image] [image]

FastReport.Net Class Reference
GroupCommand Properties
GroupCommand Class See Also Send Feedback

The GroupCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

GroupCommand Class
FastReport.Design Namespace


GroupCommand Events

[image] [image]

FastReport.Net Class Reference
GroupCommand Events
GroupCommand Class See Also Send Feedback

The GroupCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

GroupCommand Class
FastReport.Design Namespace


HelpContentsCommand Class

[image]

FastReport.Net Class Reference
HelpContentsCommand Class
Members See Also Send Feedback
Represents the "Help|Help Contents..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HelpContentsCommand : DesignerCommand
Visual Basic (Declaration)
Public Class HelpContentsCommand _
    Inherits DesignerCommand
Visual C++
public ref class HelpContentsCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.HelpContentsCommand

See Also

HelpContentsCommand Members
FastReport.Design Namespace


HelpContentsCommand Members

[image] [image]

FastReport.Net Class Reference
HelpContentsCommand Members
HelpContentsCommand Class Methods Properties Events See Also Send Feedback

The HelpContentsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

HelpContentsCommand Class
FastReport.Design Namespace


HelpContentsCommand Methods

[image] [image]

FastReport.Net Class Reference
HelpContentsCommand Methods
HelpContentsCommand Class See Also Send Feedback

The HelpContentsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HelpContentsCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
HelpContentsCommand..::.GetEnabled Method
HelpContentsCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

HelpContentsCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
HelpContentsCommand..::.Invoke Method
HelpContentsCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

HelpContentsCommand Class
HelpContentsCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
HelpContentsCommand..::.Invoke Method
HelpContentsCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

HelpContentsCommand Class
Invoke Overload
FastReport.Design Namespace


HelpContentsCommand Properties

[image] [image]

FastReport.Net Class Reference
HelpContentsCommand Properties
HelpContentsCommand Class See Also Send Feedback

The HelpContentsCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

HelpContentsCommand Class
FastReport.Design Namespace


HelpContentsCommand Events

[image] [image]

FastReport.Net Class Reference
HelpContentsCommand Events
HelpContentsCommand Class See Also Send Feedback

The HelpContentsCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

HelpContentsCommand Class
FastReport.Design Namespace


IDesignerPlugin Interface

[image]

FastReport.Net Class Reference
IDesignerPlugin Interface
Members See Also Send Feedback
Provides functionality required for report designer plugins such as toolbars and toolwindows.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public interface IDesignerPlugin
Visual Basic (Declaration)
Public Interface IDesignerPlugin
Visual C++
public interface class IDesignerPlugin

See Also

IDesignerPlugin Members
FastReport.Design Namespace


IDesignerPlugin Members

[image] [image]

FastReport.Net Class Reference
IDesignerPlugin Members
IDesignerPlugin Interface Methods Properties See Also Send Feedback

The IDesignerPlugin type exposes the following members.

Methods

Name | Description
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
Localize | Localizes the plugin.
Lock | Locks the plugin.
RestoreState | Restores the plugin state.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

Properties

Name | Description
PluginName | Gets the plugin name.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


IDesignerPlugin Methods

[image] [image]

FastReport.Net Class Reference
IDesignerPlugin Methods
IDesignerPlugin Interface See Also Send Feedback

The IDesignerPlugin type exposes the following members.

Methods

Name | Description
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
Localize | Localizes the plugin.
Lock | Locks the plugin.
RestoreState | Restores the plugin state.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.GetOptionsPage Method
IDesignerPlugin Interface See Also Send Feedback
Gets an options page that will be used in the Designer Options dialog to edit the plugin options.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Function GetOptionsPage As DesignerOptionsPage
Visual C++
DesignerOptionsPage^ GetOptionsPage()

Return Value

The options page, if implemented; otherwise, null.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


Localize Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.Localize Method
IDesignerPlugin Interface See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void Localize()
Visual Basic (Declaration)
Sub Localize
Visual C++
void Localize()

Remarks

This method is called by the designer when current localization is changed.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


Lock Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.Lock Method
IDesignerPlugin Interface See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void Lock()
Visual Basic (Declaration)
Sub Lock
Visual C++
void Lock()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.RestoreState Method
IDesignerPlugin Interface Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void RestoreState()
Visual Basic (Declaration)
Sub RestoreState
Visual C++
void RestoreState()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


SaveState Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.SaveState Method
IDesignerPlugin Interface Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void SaveState()
Visual Basic (Declaration)
Sub SaveState
Visual C++
void SaveState()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.SelectionChanged Method
IDesignerPlugin Interface See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void SelectionChanged()
Visual Basic (Declaration)
Sub SelectionChanged
Visual C++
void SelectionChanged()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


Unlock Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.Unlock Method
IDesignerPlugin Interface See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void Unlock()
Visual Basic (Declaration)
Sub Unlock
Visual C++
void Unlock()

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.UpdateContent Method
IDesignerPlugin Interface See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void UpdateContent()
Visual Basic (Declaration)
Sub UpdateContent
Visual C++
void UpdateContent()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.UpdateUIStyle Method
IDesignerPlugin Interface See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
void UpdateUIStyle()
Visual Basic (Declaration)
Sub UpdateUIStyle
Visual C++
void UpdateUIStyle()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


IDesignerPlugin Properties

[image] [image]

FastReport.Net Class Reference
IDesignerPlugin Properties
IDesignerPlugin Interface See Also Send Feedback

The IDesignerPlugin type exposes the following members.

Properties

Name | Description
PluginName | Gets the plugin name.

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


PluginName Property

[image]

FastReport.Net Class Reference
IDesignerPlugin..::.PluginName Property
IDesignerPlugin Interface See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
string PluginName { get; }
Visual Basic (Declaration)
ReadOnly Property PluginName As String
Visual C++
property String^ PluginName {
    String^ get ();
}

See Also

IDesignerPlugin Interface
FastReport.Design Namespace


ImportPlugin Class

[image]

FastReport.Net Class Reference
ImportPlugin Class
Members See Also Send Feedback
Base class for all import plugins.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ImportPlugin : IDesignerPlugin
Visual Basic (Declaration)
Public Class ImportPlugin _
    Implements IDesignerPlugin
Visual C++
public ref class ImportPlugin : IDesignerPlugin

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.ImportPlugin

See Also

ImportPlugin Members
FastReport.Design Namespace


ImportPlugin Members

[image] [image]

FastReport.Net Class Reference
ImportPlugin Members
ImportPlugin Class Constructors Methods Properties See Also Send Feedback

The ImportPlugin type exposes the following members.

Constructors

Name | Description
ImportPlugin | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Returns a file filter for a open dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadReport | Loads the specified file into specified report.
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreState | Restores the plugin state.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

Properties

Name | Description
Designer | Gets or sets reference to the designer.
Filter | Gets or sets the filter string used in the "Open File" dialog.
Name | Gets or sets the name of plugin.
PluginName | Gets the plugin name.
Report | Gets or sets reference to the report.

See Also

ImportPlugin Class
FastReport.Design Namespace


ImportPlugin Constructor

[image] [image]

FastReport.Net Class Reference
ImportPlugin Constructor
ImportPlugin Class See Also Send Feedback

Overload List

Name | Description
ImportPlugin()()() | Initializes a new instance of the ImportPlugin class with default settings.
ImportPlugin(Designer) | Initializes a new instance of the ImportPlugin class with a specified designer.

See Also

ImportPlugin Class
ImportPlugin Members
FastReport.Design Namespace


ImportPlugin Constructor

[image]

FastReport.Net Class Reference
ImportPlugin Constructor
ImportPlugin Class See Also Send Feedback
Initializes a new instance of the ImportPlugin class with default settings.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImportPlugin()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImportPlugin()

See Also

ImportPlugin Class
ImportPlugin Overload
FastReport.Design Namespace


ImportPlugin Constructor (Designer)

[image]

FastReport.Net Class Reference
ImportPlugin Constructor (Designer)
ImportPlugin Class See Also Send Feedback
Initializes a new instance of the ImportPlugin class with a specified designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImportPlugin(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ImportPlugin(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

ImportPlugin Class
ImportPlugin Overload
FastReport.Design Namespace


ImportPlugin Methods

[image] [image]

FastReport.Net Class Reference
ImportPlugin Methods
ImportPlugin Class See Also Send Feedback

The ImportPlugin type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Returns a file filter for a open dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadReport | Loads the specified file into specified report.
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreState | Restores the plugin state.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

See Also

ImportPlugin Class
FastReport.Design Namespace


GetFilter Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.GetFilter Method
ImportPlugin Class See Also Send Feedback
Returns a file filter for a open dialog.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual string GetFilter()
Visual Basic (Declaration)
Protected Overridable Function GetFilter As String
Visual C++
protected:
virtual String^ GetFilter()

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

ImportPlugin Class
FastReport.Design Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.GetOptionsPage Method
ImportPlugin Class See Also Send Feedback
Gets an options page that will be used in the Designer Options dialog to edit the plugin options.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Public Function GetOptionsPage As DesignerOptionsPage
Visual C++
public:
virtual DesignerOptionsPage^ GetOptionsPage() sealed

Return Value

The options page, if implemented; otherwise, null.

Implements

IDesignerPlugin..::.GetOptionsPage()()()

See Also

ImportPlugin Class
FastReport.Design Namespace


LoadReport Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.LoadReport Method
ImportPlugin Class See Also Send Feedback
Loads the specified file into specified report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void LoadReport(
    Report report,
    string filename
)
Visual Basic (Declaration)
Public Overridable Sub LoadReport ( _
    report As Report, _
    filename As String _
)
Visual C++
public:
virtual void LoadReport(
    Report^ report,
    String^ filename
)

Parameters

report
Type: FastReport..::.Report
Report object.
filename
Type: System..::.String
File name.

See Also

ImportPlugin Class
FastReport.Design Namespace


Localize Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.Localize Method
ImportPlugin Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Localize()
Visual Basic (Declaration)
Public Overridable Sub Localize
Visual C++
public:
virtual void Localize()

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

ImportPlugin Class
FastReport.Design Namespace


Lock Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.Lock Method
ImportPlugin Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Lock()
Visual Basic (Declaration)
Public Sub Lock
Visual C++
public:
virtual void Lock() sealed

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

ImportPlugin Class
FastReport.Design Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.RestoreState Method
ImportPlugin Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RestoreState()
Visual Basic (Declaration)
Public Sub RestoreState
Visual C++
public:
virtual void RestoreState() sealed

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

ImportPlugin Class
FastReport.Design Namespace


SaveState Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.SaveState Method
ImportPlugin Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveState()
Visual Basic (Declaration)
Public Sub SaveState
Visual C++
public:
virtual void SaveState() sealed

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

ImportPlugin Class
FastReport.Design Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.SelectionChanged Method
ImportPlugin Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectionChanged()
Visual Basic (Declaration)
Public Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() sealed

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ImportPlugin Class
FastReport.Design Namespace


Unlock Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.Unlock Method
ImportPlugin Class See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Unlock()
Visual Basic (Declaration)
Public Sub Unlock
Visual C++
public:
virtual void Unlock() sealed

Implements

IDesignerPlugin..::.Unlock()()()

See Also

ImportPlugin Class
FastReport.Design Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.UpdateContent Method
ImportPlugin Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateContent()
Visual Basic (Declaration)
Public Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() sealed

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ImportPlugin Class
FastReport.Design Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
ImportPlugin..::.UpdateUIStyle Method
ImportPlugin Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateUIStyle()
Visual Basic (Declaration)
Public Overridable Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle()

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

ImportPlugin Class
FastReport.Design Namespace


ImportPlugin Properties

[image] [image]

FastReport.Net Class Reference
ImportPlugin Properties
ImportPlugin Class See Also Send Feedback

The ImportPlugin type exposes the following members.

Properties

Name | Description
Designer | Gets or sets reference to the designer.
Filter | Gets or sets the filter string used in the "Open File" dialog.
Name | Gets or sets the name of plugin.
PluginName | Gets the plugin name.
Report | Gets or sets reference to the report.

See Also

ImportPlugin Class
FastReport.Design Namespace


Designer Property

[image]

FastReport.Net Class Reference
ImportPlugin..::.Designer Property
ImportPlugin Class See Also Send Feedback
Gets or sets reference to the designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; protected set; }
Visual Basic (Declaration)
Public Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
    void set (Designer^ value);
}

See Also

ImportPlugin Class
FastReport.Design Namespace


Filter Property

[image]

FastReport.Net Class Reference
ImportPlugin..::.Filter Property
ImportPlugin Class See Also Send Feedback
Gets or sets the filter string used in the "Open File" dialog.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; protected set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

ImportPlugin Class
FastReport.Design Namespace


Name Property

[image]

FastReport.Net Class Reference
ImportPlugin..::.Name Property
ImportPlugin Class See Also Send Feedback
Gets or sets the name of plugin.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; protected set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ImportPlugin Class
FastReport.Design Namespace


PluginName Property

[image]

FastReport.Net Class Reference
ImportPlugin..::.PluginName Property
ImportPlugin Class See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PluginName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PluginName As String
Visual C++
public:
virtual property String^ PluginName {
    String^ get () sealed;
}

Implements

IDesignerPlugin..::.PluginName

See Also

ImportPlugin Class
FastReport.Design Namespace


Report Property

[image]

FastReport.Net Class Reference
ImportPlugin..::.Report Property
ImportPlugin Class See Also Send Feedback
Gets or sets reference to the report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; protected set; }
Visual Basic (Declaration)
Public Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}

See Also

ImportPlugin Class
FastReport.Design Namespace


InsertBandCommand Class

[image]

FastReport.Net Class Reference
InsertBandCommand Class
Members See Also Send Feedback
Represents the "Insert Band" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class InsertBandCommand : DesignerCommand
Visual Basic (Declaration)
Public Class InsertBandCommand _
    Inherits DesignerCommand
Visual C++
public ref class InsertBandCommand : public DesignerCommand

Remarks

This command has no default action associated with it. Check the Enabled property to see if the insert operation is enabled.

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.InsertBandCommand

See Also

InsertBandCommand Members
FastReport.Design Namespace


InsertBandCommand Members

[image] [image]

FastReport.Net Class Reference
InsertBandCommand Members
InsertBandCommand Class Methods Properties Events See Also Send Feedback

The InsertBandCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

InsertBandCommand Class
FastReport.Design Namespace


InsertBandCommand Methods

[image] [image]

FastReport.Net Class Reference
InsertBandCommand Methods
InsertBandCommand Class See Also Send Feedback

The InsertBandCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertBandCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
InsertBandCommand..::.GetEnabled Method
InsertBandCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

InsertBandCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
InsertBandCommand..::.Invoke Method
InsertBandCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Inherited from DesignerCommand.)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

InsertBandCommand Class
InsertBandCommand Members
FastReport.Design Namespace


InsertBandCommand Properties

[image] [image]

FastReport.Net Class Reference
InsertBandCommand Properties
InsertBandCommand Class See Also Send Feedback

The InsertBandCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

InsertBandCommand Class
FastReport.Design Namespace


InsertBandCommand Events

[image] [image]

FastReport.Net Class Reference
InsertBandCommand Events
InsertBandCommand Class See Also Send Feedback

The InsertBandCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

InsertBandCommand Class
FastReport.Design Namespace


InsertCommand Class

[image]

FastReport.Net Class Reference
InsertCommand Class
Members See Also Send Feedback
Represents the "Insert" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class InsertCommand : DesignerCommand
Visual Basic (Declaration)
Public Class InsertCommand _
    Inherits DesignerCommand
Visual C++
public ref class InsertCommand : public DesignerCommand

Remarks

This command has no default action associated with it. Check the Enabled property to see if the insert operation is enabled.

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.InsertCommand

See Also

InsertCommand Members
FastReport.Design Namespace


InsertCommand Members

[image] [image]

FastReport.Net Class Reference
InsertCommand Members
InsertCommand Class Methods Properties Events See Also Send Feedback

The InsertCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

InsertCommand Class
FastReport.Design Namespace


InsertCommand Methods

[image] [image]

FastReport.Net Class Reference
InsertCommand Methods
InsertCommand Class See Also Send Feedback

The InsertCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
InsertCommand..::.GetEnabled Method
InsertCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

InsertCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
InsertCommand..::.Invoke Method
InsertCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Inherited from DesignerCommand.)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

InsertCommand Class
InsertCommand Members
FastReport.Design Namespace


InsertCommand Properties

[image] [image]

FastReport.Net Class Reference
InsertCommand Properties
InsertCommand Class See Also Send Feedback

The InsertCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

InsertCommand Class
FastReport.Design Namespace


InsertCommand Events

[image] [image]

FastReport.Net Class Reference
InsertCommand Events
InsertCommand Class See Also Send Feedback

The InsertCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

InsertCommand Class
FastReport.Design Namespace


NewCommand Class

[image]

FastReport.Net Class Reference
NewCommand Class
Members See Also Send Feedback
Represents the "File|New" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NewCommand : DesignerCommand
Visual Basic (Declaration)
Public Class NewCommand _
    Inherits DesignerCommand
Visual C++
public ref class NewCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.NewCommand

See Also

NewCommand Members
FastReport.Design Namespace


NewCommand Members

[image] [image]

FastReport.Net Class Reference
NewCommand Members
NewCommand Class Methods Properties Events See Also Send Feedback

The NewCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

NewCommand Class
FastReport.Design Namespace


NewCommand Methods

[image] [image]

FastReport.Net Class Reference
NewCommand Methods
NewCommand Class See Also Send Feedback

The NewCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
NewCommand..::.GetEnabled Method
NewCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

NewCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
NewCommand..::.Invoke Method
NewCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

NewCommand Class
NewCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
NewCommand..::.Invoke Method
NewCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

NewCommand Class
Invoke Overload
FastReport.Design Namespace


NewCommand Properties

[image] [image]

FastReport.Net Class Reference
NewCommand Properties
NewCommand Class See Also Send Feedback

The NewCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

NewCommand Class
FastReport.Design Namespace


NewCommand Events

[image] [image]

FastReport.Net Class Reference
NewCommand Events
NewCommand Class See Also Send Feedback

The NewCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

NewCommand Class
FastReport.Design Namespace


NewDialogCommand Class

[image]

FastReport.Net Class Reference
NewDialogCommand Class
Members See Also Send Feedback
Represents the "New Dialog" toolbar command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NewDialogCommand : DesignerCommand
Visual Basic (Declaration)
Public Class NewDialogCommand _
    Inherits DesignerCommand
Visual C++
public ref class NewDialogCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.NewDialogCommand

See Also

NewDialogCommand Members
FastReport.Design Namespace


NewDialogCommand Members

[image] [image]

FastReport.Net Class Reference
NewDialogCommand Members
NewDialogCommand Class Methods Properties Events See Also Send Feedback

The NewDialogCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

NewDialogCommand Class
FastReport.Design Namespace


NewDialogCommand Methods

[image] [image]

FastReport.Net Class Reference
NewDialogCommand Methods
NewDialogCommand Class See Also Send Feedback

The NewDialogCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewDialogCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
NewDialogCommand..::.GetEnabled Method
NewDialogCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

NewDialogCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
NewDialogCommand..::.Invoke Method
NewDialogCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

NewDialogCommand Class
NewDialogCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
NewDialogCommand..::.Invoke Method
NewDialogCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

NewDialogCommand Class
Invoke Overload
FastReport.Design Namespace


NewDialogCommand Properties

[image] [image]

FastReport.Net Class Reference
NewDialogCommand Properties
NewDialogCommand Class See Also Send Feedback

The NewDialogCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

NewDialogCommand Class
FastReport.Design Namespace


NewDialogCommand Events

[image] [image]

FastReport.Net Class Reference
NewDialogCommand Events
NewDialogCommand Class See Also Send Feedback

The NewDialogCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

NewDialogCommand Class
FastReport.Design Namespace


NewPageCommand Class

[image]

FastReport.Net Class Reference
NewPageCommand Class
Members See Also Send Feedback
Represents the "New Page" toolbar command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NewPageCommand : DesignerCommand
Visual Basic (Declaration)
Public Class NewPageCommand _
    Inherits DesignerCommand
Visual C++
public ref class NewPageCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.NewPageCommand

See Also

NewPageCommand Members
FastReport.Design Namespace


NewPageCommand Members

[image] [image]

FastReport.Net Class Reference
NewPageCommand Members
NewPageCommand Class Methods Properties Events See Also Send Feedback

The NewPageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

NewPageCommand Class
FastReport.Design Namespace


NewPageCommand Methods

[image] [image]

FastReport.Net Class Reference
NewPageCommand Methods
NewPageCommand Class See Also Send Feedback

The NewPageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewPageCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
NewPageCommand..::.GetEnabled Method
NewPageCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

NewPageCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
NewPageCommand..::.Invoke Method
NewPageCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

NewPageCommand Class
NewPageCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
NewPageCommand..::.Invoke Method
NewPageCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

NewPageCommand Class
Invoke Overload
FastReport.Design Namespace


NewPageCommand Properties

[image] [image]

FastReport.Net Class Reference
NewPageCommand Properties
NewPageCommand Class See Also Send Feedback

The NewPageCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

NewPageCommand Class
FastReport.Design Namespace


NewPageCommand Events

[image] [image]

FastReport.Net Class Reference
NewPageCommand Events
NewPageCommand Class See Also Send Feedback

The NewPageCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

NewPageCommand Class
FastReport.Design Namespace


ObjectInsertedEventArgs Class

[image]

FastReport.Net Class Reference
ObjectInsertedEventArgs Class
Members See Also Send Feedback
Provides a data for the designer ObjectInserted event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ObjectInsertedEventArgs
Visual Basic (Declaration)
Public Class ObjectInsertedEventArgs
Visual C++
public ref class ObjectInsertedEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.ObjectInsertedEventArgs

See Also

ObjectInsertedEventArgs Members
FastReport.Design Namespace


ObjectInsertedEventArgs Members

[image] [image]

FastReport.Net Class Reference
ObjectInsertedEventArgs Members
ObjectInsertedEventArgs Class Methods Properties See Also Send Feedback

The ObjectInsertedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InsertSource | Gets the source where the object is inserted from.
Object | Gets the inserted object.

See Also

ObjectInsertedEventArgs Class
FastReport.Design Namespace


ObjectInsertedEventArgs Methods

[image] [image]

FastReport.Net Class Reference
ObjectInsertedEventArgs Methods
ObjectInsertedEventArgs Class See Also Send Feedback

The ObjectInsertedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectInsertedEventArgs Class
FastReport.Design Namespace


ObjectInsertedEventArgs Properties

[image] [image]

FastReport.Net Class Reference
ObjectInsertedEventArgs Properties
ObjectInsertedEventArgs Class See Also Send Feedback

The ObjectInsertedEventArgs type exposes the following members.

Properties

Name | Description
InsertSource | Gets the source where the object is inserted from.
Object | Gets the inserted object.

See Also

ObjectInsertedEventArgs Class
FastReport.Design Namespace


InsertSource Property

[image]

FastReport.Net Class Reference
ObjectInsertedEventArgs..::.InsertSource Property
ObjectInsertedEventArgs Class See Also Send Feedback
Gets the source where the object is inserted from.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public InsertFrom InsertSource { get; }
Visual Basic (Declaration)
Public ReadOnly Property InsertSource As InsertFrom
Visual C++
public:
property InsertFrom InsertSource {
    InsertFrom get ();
}

See Also

ObjectInsertedEventArgs Class
FastReport.Design Namespace


Object Property

[image]

FastReport.Net Class Reference
ObjectInsertedEventArgs..::.Object Property
ObjectInsertedEventArgs Class See Also Send Feedback
Gets the inserted object.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base Object { get; }
Visual Basic (Declaration)
Public ReadOnly Property Object As Base
Visual C++
public:
property Base^ Object {
    Base^ get ();
}

See Also

ObjectInsertedEventArgs Class
FastReport.Design Namespace


ObjectInsertedEventHandler Delegate

[image]

FastReport.Net Class Reference
ObjectInsertedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the designer ObjectInserted event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void ObjectInsertedEventHandler(
    Object sender,
    ObjectInsertedEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ObjectInsertedEventHandler ( _
    sender As Object, _
    e As ObjectInsertedEventArgs _
)
Visual C++
public delegate void ObjectInsertedEventHandler(
    Object^ sender,
    ObjectInsertedEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Design..::.ObjectInsertedEventArgs
The event data.

See Also

FastReport.Design Namespace


OpenCommand Class

[image]

FastReport.Net Class Reference
OpenCommand Class
Members See Also Send Feedback
Represents the "File|Open..." command. Also can be used for loading a file from the recent files list.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OpenCommand : DesignerCommand
Visual Basic (Declaration)
Public Class OpenCommand _
    Inherits DesignerCommand
Visual C++
public ref class OpenCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.OpenCommand

See Also

OpenCommand Members
FastReport.Design Namespace


OpenCommand Members

[image] [image]

FastReport.Net Class Reference
OpenCommand Members
OpenCommand Class Methods Properties Events See Also Send Feedback

The OpenCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
LoadFile | Loads a specified report file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

OpenCommand Class
FastReport.Design Namespace


OpenCommand Methods

[image] [image]

FastReport.Net Class Reference
OpenCommand Methods
OpenCommand Class See Also Send Feedback

The OpenCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
LoadFile | Loads a specified report file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
OpenCommand..::.GetEnabled Method
OpenCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

OpenCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
OpenCommand..::.Invoke Method
OpenCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

OpenCommand Class
OpenCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
OpenCommand..::.Invoke Method
OpenCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

OpenCommand Class
Invoke Overload
FastReport.Design Namespace


LoadFile Method

[image]

FastReport.Net Class Reference
OpenCommand..::.LoadFile Method
OpenCommand Class See Also Send Feedback
Loads a specified report file.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadFile(
    string fileName
)
Visual Basic (Declaration)
Public Sub LoadFile ( _
    fileName As String _
)
Visual C++
public:
void LoadFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File to load.

See Also

OpenCommand Class
FastReport.Design Namespace


OpenCommand Properties

[image] [image]

FastReport.Net Class Reference
OpenCommand Properties
OpenCommand Class See Also Send Feedback

The OpenCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

OpenCommand Class
FastReport.Design Namespace


OpenCommand Events

[image] [image]

FastReport.Net Class Reference
OpenCommand Events
OpenCommand Class See Also Send Feedback

The OpenCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

OpenCommand Class
FastReport.Design Namespace


OpenSaveDialogEventArgs Class

[image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs Class
Members See Also Send Feedback
Provides a data for the designer's custom dialog events.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OpenSaveDialogEventArgs
Visual Basic (Declaration)
Public Class OpenSaveDialogEventArgs
Visual C++
public ref class OpenSaveDialogEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.OpenSaveDialogEventArgs

See Also

OpenSaveDialogEventArgs Members
FastReport.Design Namespace


OpenSaveDialogEventArgs Members

[image] [image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs Members
OpenSaveDialogEventArgs Class Methods Properties See Also Send Feedback

The OpenSaveDialogEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets a value indicating that the dialog was cancelled.
Data | Gets or sets the custom data that is shared across events.
Designer | Gets a report designer.
FileName | Gets or sets a file name.

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


OpenSaveDialogEventArgs Methods

[image] [image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs Methods
OpenSaveDialogEventArgs Class See Also Send Feedback

The OpenSaveDialogEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


OpenSaveDialogEventArgs Properties

[image] [image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs Properties
OpenSaveDialogEventArgs Class See Also Send Feedback

The OpenSaveDialogEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets a value indicating that the dialog was cancelled.
Data | Gets or sets the custom data that is shared across events.
Designer | Gets a report designer.
FileName | Gets or sets a file name.

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


Cancel Property

[image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs..::.Cancel Property
OpenSaveDialogEventArgs Class See Also Send Feedback
Gets or sets a value indicating that the dialog was cancelled.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to tell the designer that the user was cancelled the dialog.

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


Data Property

[image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs..::.Data Property
OpenSaveDialogEventArgs Class See Also Send Feedback
Gets or sets the custom data that is shared across events.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Object
Visual C++
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}

Remarks

You may set the Data in the OpenDialog event and use it later in the OpenReport event.

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


Designer Property

[image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs..::.Designer Property
OpenSaveDialogEventArgs Class See Also Send Feedback
Gets a report designer.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
}

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


FileName Property

[image]

FastReport.Net Class Reference
OpenSaveDialogEventArgs..::.FileName Property
OpenSaveDialogEventArgs Class See Also Send Feedback
Gets or sets a file name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FileName { get; set; }
Visual Basic (Declaration)
Public Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property contains the location of a report. If you work with files (like the standard "Open" and "Save" dialogs do), treat this property as a file name.

See Also

OpenSaveDialogEventArgs Class
FastReport.Design Namespace


OpenSaveDialogEventHandler Delegate

[image]

FastReport.Net Class Reference
OpenSaveDialogEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the designer's custom dialogs event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void OpenSaveDialogEventHandler(
    Object sender,
    OpenSaveDialogEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub OpenSaveDialogEventHandler ( _
    sender As Object, _
    e As OpenSaveDialogEventArgs _
)
Visual C++
public delegate void OpenSaveDialogEventHandler(
    Object^ sender,
    OpenSaveDialogEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Design..::.OpenSaveDialogEventArgs
The event data.

See Also

FastReport.Design Namespace


OpenSaveReportEventArgs Class

[image]

FastReport.Net Class Reference
OpenSaveReportEventArgs Class
Members See Also Send Feedback
Provides a data for the designer's custom dialog events.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OpenSaveReportEventArgs
Visual Basic (Declaration)
Public Class OpenSaveReportEventArgs
Visual C++
public ref class OpenSaveReportEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.OpenSaveReportEventArgs

See Also

OpenSaveReportEventArgs Members
FastReport.Design Namespace


OpenSaveReportEventArgs Members

[image] [image]

FastReport.Net Class Reference
OpenSaveReportEventArgs Members
OpenSaveReportEventArgs Class Methods Properties See Also Send Feedback

The OpenSaveReportEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the custom data that was set in the OpenDialog event.
FileName | Gets a file name.
Report | Gets a report.

See Also

OpenSaveReportEventArgs Class
FastReport.Design Namespace


OpenSaveReportEventArgs Methods

[image] [image]

FastReport.Net Class Reference
OpenSaveReportEventArgs Methods
OpenSaveReportEventArgs Class See Also Send Feedback

The OpenSaveReportEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenSaveReportEventArgs Class
FastReport.Design Namespace


OpenSaveReportEventArgs Properties

[image] [image]

FastReport.Net Class Reference
OpenSaveReportEventArgs Properties
OpenSaveReportEventArgs Class See Also Send Feedback

The OpenSaveReportEventArgs type exposes the following members.

Properties

Name | Description
Data | Gets the custom data that was set in the OpenDialog event.
FileName | Gets a file name.
Report | Gets a report.

See Also

OpenSaveReportEventArgs Class
FastReport.Design Namespace


Data Property

[image]

FastReport.Net Class Reference
OpenSaveReportEventArgs..::.Data Property
OpenSaveReportEventArgs Class See Also Send Feedback
Gets the custom data that was set in the OpenDialog event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As Object
Visual C++
public:
property Object^ Data {
    Object^ get ();
}

See Also

OpenSaveReportEventArgs Class
FastReport.Design Namespace


FileName Property

[image]

FastReport.Net Class Reference
OpenSaveReportEventArgs..::.FileName Property
OpenSaveReportEventArgs Class See Also Send Feedback
Gets a file name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
}

Remarks

This property contains the location of a report that was selected by the user in the open/save dialogs. If you work with files (like the standard "Open" and "Save" dialogs do), treat this property as a file name.

See Also

OpenSaveReportEventArgs Class
FastReport.Design Namespace


Report Property

[image]

FastReport.Net Class Reference
OpenSaveReportEventArgs..::.Report Property
OpenSaveReportEventArgs Class See Also Send Feedback
Gets a report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
}

Remarks

Use this report in the load/save operations.

See Also

OpenSaveReportEventArgs Class
FastReport.Design Namespace


OpenSaveReportEventHandler Delegate

[image]

FastReport.Net Class Reference
OpenSaveReportEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the designer's custom dialogs event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void OpenSaveReportEventHandler(
    Object sender,
    OpenSaveReportEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub OpenSaveReportEventHandler ( _
    sender As Object, _
    e As OpenSaveReportEventArgs _
)
Visual C++
public delegate void OpenSaveReportEventHandler(
    Object^ sender,
    OpenSaveReportEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Design..::.OpenSaveReportEventArgs
The event data.

See Also

FastReport.Design Namespace


OptionsCommand Class

[image]

FastReport.Net Class Reference
OptionsCommand Class
Members See Also Send Feedback
Represents the "View|Options..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OptionsCommand : DesignerCommand
Visual Basic (Declaration)
Public Class OptionsCommand _
    Inherits DesignerCommand
Visual C++
public ref class OptionsCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.OptionsCommand

See Also

OptionsCommand Members
FastReport.Design Namespace


OptionsCommand Members

[image] [image]

FastReport.Net Class Reference
OptionsCommand Members
OptionsCommand Class Methods Properties Events See Also Send Feedback

The OptionsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from DesignerCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

OptionsCommand Class
FastReport.Design Namespace


OptionsCommand Methods

[image] [image]

FastReport.Net Class Reference
OptionsCommand Methods
OptionsCommand Class See Also Send Feedback

The OptionsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from DesignerCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
OptionsCommand..::.Invoke Method
OptionsCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

OptionsCommand Class
OptionsCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
OptionsCommand..::.Invoke Method
OptionsCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

OptionsCommand Class
Invoke Overload
FastReport.Design Namespace


OptionsCommand Properties

[image] [image]

FastReport.Net Class Reference
OptionsCommand Properties
OptionsCommand Class See Also Send Feedback

The OptionsCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

OptionsCommand Class
FastReport.Design Namespace


OptionsCommand Events

[image] [image]

FastReport.Net Class Reference
OptionsCommand Events
OptionsCommand Class See Also Send Feedback

The OptionsCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

OptionsCommand Class
FastReport.Design Namespace


PageSettingsCommand Class

[image]

FastReport.Net Class Reference
PageSettingsCommand Class
Members See Also Send Feedback
Represents the "File|Page Setup..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageSettingsCommand : DesignerCommand
Visual Basic (Declaration)
Public Class PageSettingsCommand _
    Inherits DesignerCommand
Visual C++
public ref class PageSettingsCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.PageSettingsCommand

See Also

PageSettingsCommand Members
FastReport.Design Namespace


PageSettingsCommand Members

[image] [image]

FastReport.Net Class Reference
PageSettingsCommand Members
PageSettingsCommand Class Methods Properties Events See Also Send Feedback

The PageSettingsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PageSettingsCommand Class
FastReport.Design Namespace


PageSettingsCommand Methods

[image] [image]

FastReport.Net Class Reference
PageSettingsCommand Methods
PageSettingsCommand Class See Also Send Feedback

The PageSettingsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageSettingsCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
PageSettingsCommand..::.GetEnabled Method
PageSettingsCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

PageSettingsCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PageSettingsCommand..::.Invoke Method
PageSettingsCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

PageSettingsCommand Class
PageSettingsCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
PageSettingsCommand..::.Invoke Method
PageSettingsCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

PageSettingsCommand Class
Invoke Overload
FastReport.Design Namespace


PageSettingsCommand Properties

[image] [image]

FastReport.Net Class Reference
PageSettingsCommand Properties
PageSettingsCommand Class See Also Send Feedback

The PageSettingsCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

PageSettingsCommand Class
FastReport.Design Namespace


PageSettingsCommand Events

[image] [image]

FastReport.Net Class Reference
PageSettingsCommand Events
PageSettingsCommand Class See Also Send Feedback

The PageSettingsCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PageSettingsCommand Class
FastReport.Design Namespace


PasteCommand Class

[image]

FastReport.Net Class Reference
PasteCommand Class
Members See Also Send Feedback
Represents the "Edit|Paste" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PasteCommand : DesignerCommand
Visual Basic (Declaration)
Public Class PasteCommand _
    Inherits DesignerCommand
Visual C++
public ref class PasteCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.PasteCommand

See Also

PasteCommand Members
FastReport.Design Namespace


PasteCommand Members

[image] [image]

FastReport.Net Class Reference
PasteCommand Members
PasteCommand Class Methods Properties Events See Also Send Feedback

The PasteCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PasteCommand Class
FastReport.Design Namespace


PasteCommand Methods

[image] [image]

FastReport.Net Class Reference
PasteCommand Methods
PasteCommand Class See Also Send Feedback

The PasteCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PasteCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
PasteCommand..::.GetEnabled Method
PasteCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

PasteCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PasteCommand..::.Invoke Method
PasteCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

PasteCommand Class
PasteCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
PasteCommand..::.Invoke Method
PasteCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

PasteCommand Class
Invoke Overload
FastReport.Design Namespace


PasteCommand Properties

[image] [image]

FastReport.Net Class Reference
PasteCommand Properties
PasteCommand Class See Also Send Feedback

The PasteCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

PasteCommand Class
FastReport.Design Namespace


PasteCommand Events

[image] [image]

FastReport.Net Class Reference
PasteCommand Events
PasteCommand Class See Also Send Feedback

The PasteCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PasteCommand Class
FastReport.Design Namespace


PluginCollection Class

[image]

FastReport.Net Class Reference
PluginCollection Class
Members See Also Send Feedback
Represents collection of designer plugins.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PluginCollection : CollectionBase
Visual Basic (Declaration)
Public Class PluginCollection _
    Inherits CollectionBase
Visual C++
public ref class PluginCollection : public CollectionBase

Remarks

This class is used in the Designer.Plugins property.

To register own plugin, add its type to the DesignerPlugins global collection:

CopyC#
DesignerPlugins.Add(typeof(MyToolbar));

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Design..::.PluginCollection

See Also

PluginCollection Members
FastReport.Design Namespace


PluginCollection Members

[image] [image]

FastReport.Net Class Reference
PluginCollection Members
PluginCollection Class Methods Properties See Also Send Feedback

The PluginCollection type exposes the following members.

Methods

Name | Description
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Finds a plugin by its name.
FindType | Finds a plugin by its type name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

PluginCollection Class
FastReport.Design Namespace


PluginCollection Methods

[image] [image]

FastReport.Net Class Reference
PluginCollection Methods
PluginCollection Class See Also Send Feedback

The PluginCollection type exposes the following members.

Methods

Name | Description
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Finds a plugin by its name.
FindType | Finds a plugin by its type name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PluginCollection Class
FastReport.Design Namespace


Find Method

[image]

FastReport.Net Class Reference
PluginCollection..::.Find Method
PluginCollection Class Example See Also Send Feedback
Finds a plugin by its name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public IDesignerPlugin Find(
    string pluginName
)
Visual Basic (Declaration)
Public Function Find ( _
    pluginName As String _
) As IDesignerPlugin
Visual C++
public:
IDesignerPlugin^ Find(
    String^ pluginName
)

Parameters

pluginName
Type: System..::.String
The plugin's name.

Return Value

The plugin, if found; otherwise, null.

Examples

This example shows how to find a plugin.
CopyC#
MessagesWindow window = designer.Plugins.Find("MessagesWindow") as MessagesWindow;

See Also

PluginCollection Class
FastReport.Design Namespace


FindType Method

[image]

FastReport.Net Class Reference
PluginCollection..::.FindType Method
PluginCollection Class Example See Also Send Feedback
Finds a plugin by its type name.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public IDesignerPlugin FindType(
    string typeName
)
Visual Basic (Declaration)
Public Function FindType ( _
    typeName As String _
) As IDesignerPlugin
Visual C++
public:
IDesignerPlugin^ FindType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The plugin's type name.

Return Value

The plugin, if found; otherwise, null.

Examples

This example shows how to find a plugin.
CopyC#
MessagesWindow window = designer.Plugins.FindType("MessagesWindow") as MessagesWindow;

See Also

PluginCollection Class
FastReport.Design Namespace


PluginCollection Properties

[image] [image]

FastReport.Net Class Reference
PluginCollection Properties
PluginCollection Class See Also Send Feedback

The PluginCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

PluginCollection Class
FastReport.Design Namespace


PreviewCommand Class

[image]

FastReport.Net Class Reference
PreviewCommand Class
Members See Also Send Feedback
Represents the "File|Preview..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PreviewCommand : DesignerCommand
Visual Basic (Declaration)
Public Class PreviewCommand _
    Inherits DesignerCommand
Visual C++
public ref class PreviewCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.PreviewCommand

See Also

PreviewCommand Members
FastReport.Design Namespace


PreviewCommand Members

[image] [image]

FastReport.Net Class Reference
PreviewCommand Members
PreviewCommand Class Methods Properties Events See Also Send Feedback

The PreviewCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PreviewCommand Class
FastReport.Design Namespace


PreviewCommand Methods

[image] [image]

FastReport.Net Class Reference
PreviewCommand Methods
PreviewCommand Class See Also Send Feedback

The PreviewCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
PreviewCommand..::.GetEnabled Method
PreviewCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

PreviewCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PreviewCommand..::.Invoke Method
PreviewCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

PreviewCommand Class
PreviewCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
PreviewCommand..::.Invoke Method
PreviewCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

PreviewCommand Class
Invoke Overload
FastReport.Design Namespace


PreviewCommand Properties

[image] [image]

FastReport.Net Class Reference
PreviewCommand Properties
PreviewCommand Class See Also Send Feedback

The PreviewCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

PreviewCommand Class
FastReport.Design Namespace


PreviewCommand Events

[image] [image]

FastReport.Net Class Reference
PreviewCommand Events
PreviewCommand Class See Also Send Feedback

The PreviewCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PreviewCommand Class
FastReport.Design Namespace


PrinterSettingsCommand Class

[image]

FastReport.Net Class Reference
PrinterSettingsCommand Class
Members See Also Send Feedback
Represents the "File|Printer Setup..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PrinterSettingsCommand : DesignerCommand
Visual Basic (Declaration)
Public Class PrinterSettingsCommand _
    Inherits DesignerCommand
Visual C++
public ref class PrinterSettingsCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.PrinterSettingsCommand

See Also

PrinterSettingsCommand Members
FastReport.Design Namespace


PrinterSettingsCommand Members

[image] [image]

FastReport.Net Class Reference
PrinterSettingsCommand Members
PrinterSettingsCommand Class Methods Properties Events See Also Send Feedback

The PrinterSettingsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PrinterSettingsCommand Class
FastReport.Design Namespace


PrinterSettingsCommand Methods

[image] [image]

FastReport.Net Class Reference
PrinterSettingsCommand Methods
PrinterSettingsCommand Class See Also Send Feedback

The PrinterSettingsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrinterSettingsCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
PrinterSettingsCommand..::.GetEnabled Method
PrinterSettingsCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

PrinterSettingsCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PrinterSettingsCommand..::.Invoke Method
PrinterSettingsCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

PrinterSettingsCommand Class
PrinterSettingsCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
PrinterSettingsCommand..::.Invoke Method
PrinterSettingsCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

PrinterSettingsCommand Class
Invoke Overload
FastReport.Design Namespace


PrinterSettingsCommand Properties

[image] [image]

FastReport.Net Class Reference
PrinterSettingsCommand Properties
PrinterSettingsCommand Class See Also Send Feedback

The PrinterSettingsCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

PrinterSettingsCommand Class
FastReport.Design Namespace


PrinterSettingsCommand Events

[image] [image]

FastReport.Net Class Reference
PrinterSettingsCommand Events
PrinterSettingsCommand Class See Also Send Feedback

The PrinterSettingsCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

PrinterSettingsCommand Class
FastReport.Design Namespace


RecentFilesCommand Class

[image]

FastReport.Net Class Reference
RecentFilesCommand Class
Members See Also Send Feedback
Represents the "Recent Files" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RecentFilesCommand : DesignerCommand
Visual Basic (Declaration)
Public Class RecentFilesCommand _
    Inherits DesignerCommand
Visual C++
public ref class RecentFilesCommand : public DesignerCommand

Remarks

This command has no default action associated with it. Check the Enabled property to see if the recent files list is enabled.

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.RecentFilesCommand

See Also

RecentFilesCommand Members
FastReport.Design Namespace


RecentFilesCommand Members

[image] [image]

FastReport.Net Class Reference
RecentFilesCommand Members
RecentFilesCommand Class Methods Properties Events See Also Send Feedback

The RecentFilesCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

RecentFilesCommand Class
FastReport.Design Namespace


RecentFilesCommand Methods

[image] [image]

FastReport.Net Class Reference
RecentFilesCommand Methods
RecentFilesCommand Class See Also Send Feedback

The RecentFilesCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecentFilesCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
RecentFilesCommand..::.GetEnabled Method
RecentFilesCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

RecentFilesCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
RecentFilesCommand..::.Invoke Method
RecentFilesCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Inherited from DesignerCommand.)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

RecentFilesCommand Class
RecentFilesCommand Members
FastReport.Design Namespace


RecentFilesCommand Properties

[image] [image]

FastReport.Net Class Reference
RecentFilesCommand Properties
RecentFilesCommand Class See Also Send Feedback

The RecentFilesCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

RecentFilesCommand Class
FastReport.Design Namespace


RecentFilesCommand Events

[image] [image]

FastReport.Net Class Reference
RecentFilesCommand Events
RecentFilesCommand Class See Also Send Feedback

The RecentFilesCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

RecentFilesCommand Class
FastReport.Design Namespace


RedoCommand Class

[image]

FastReport.Net Class Reference
RedoCommand Class
Members See Also Send Feedback
Represents the "Edit|Redo" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RedoCommand : DesignerCommand
Visual Basic (Declaration)
Public Class RedoCommand _
    Inherits DesignerCommand
Visual C++
public ref class RedoCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.RedoCommand

See Also

RedoCommand Members
FastReport.Design Namespace


RedoCommand Members

[image] [image]

FastReport.Net Class Reference
RedoCommand Members
RedoCommand Class Methods Properties Events See Also Send Feedback

The RedoCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | Redo several actions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

RedoCommand Class
FastReport.Design Namespace


RedoCommand Methods

[image] [image]

FastReport.Net Class Reference
RedoCommand Methods
RedoCommand Class See Also Send Feedback

The RedoCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | Redo several actions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RedoCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
RedoCommand..::.GetEnabled Method
RedoCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

RedoCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
RedoCommand..::.Invoke Method
RedoCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

RedoCommand Class
RedoCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
RedoCommand..::.Invoke Method
RedoCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

RedoCommand Class
Invoke Overload
FastReport.Design Namespace


Redo Method

[image]

FastReport.Net Class Reference
RedoCommand..::.Redo Method
RedoCommand Class See Also Send Feedback
Redo several actions.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Redo(
    int actionsCount
)
Visual Basic (Declaration)
Public Sub Redo ( _
    actionsCount As Integer _
)
Visual C++
public:
void Redo(
    int actionsCount
)

Parameters

actionsCount
Type: System..::.Int32
Number of actions to redo.

See Also

RedoCommand Class
FastReport.Design Namespace


RedoCommand Properties

[image] [image]

FastReport.Net Class Reference
RedoCommand Properties
RedoCommand Class See Also Send Feedback

The RedoCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

RedoCommand Class
FastReport.Design Namespace


RedoCommand Events

[image] [image]

FastReport.Net Class Reference
RedoCommand Events
RedoCommand Class See Also Send Feedback

The RedoCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

RedoCommand Class
FastReport.Design Namespace


ReplaceCommand Class

[image]

FastReport.Net Class Reference
ReplaceCommand Class
Members See Also Send Feedback
Represents the "Edit|Replace..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReplaceCommand : FindCommand
Visual Basic (Declaration)
Public Class ReplaceCommand _
    Inherits FindCommand
Visual C++
public ref class ReplaceCommand : public FindCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.FindCommand
FastReport.Design..::.ReplaceCommand

See Also

ReplaceCommand Members
FastReport.Design Namespace


ReplaceCommand Members

[image] [image]

FastReport.Net Class Reference
ReplaceCommand Members
ReplaceCommand Class Methods Properties Events See Also Send Feedback

The ReplaceCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from FindCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ReplaceCommand Class
FastReport.Design Namespace


ReplaceCommand Methods

[image] [image]

FastReport.Net Class Reference
ReplaceCommand Methods
ReplaceCommand Class See Also Send Feedback

The ReplaceCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from FindCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReplaceCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ReplaceCommand..::.Invoke Method
ReplaceCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Inherited from FindCommand.)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

ReplaceCommand Class
ReplaceCommand Members
FastReport.Design Namespace


ReplaceCommand Properties

[image] [image]

FastReport.Net Class Reference
ReplaceCommand Properties
ReplaceCommand Class See Also Send Feedback

The ReplaceCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

ReplaceCommand Class
FastReport.Design Namespace


ReplaceCommand Events

[image] [image]

FastReport.Net Class Reference
ReplaceCommand Events
ReplaceCommand Class See Also Send Feedback

The ReplaceCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ReplaceCommand Class
FastReport.Design Namespace


ReportLoadedEventArgs Class

[image]

FastReport.Net Class Reference
ReportLoadedEventArgs Class
Members See Also Send Feedback
Provides a data for the designer ReportLoaded event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportLoadedEventArgs
Visual Basic (Declaration)
Public Class ReportLoadedEventArgs
Visual C++
public ref class ReportLoadedEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.ReportLoadedEventArgs

See Also

ReportLoadedEventArgs Members
FastReport.Design Namespace


ReportLoadedEventArgs Members

[image] [image]

FastReport.Net Class Reference
ReportLoadedEventArgs Members
ReportLoadedEventArgs Class Methods Properties See Also Send Feedback

The ReportLoadedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Report | The current report.

See Also

ReportLoadedEventArgs Class
FastReport.Design Namespace


ReportLoadedEventArgs Methods

[image] [image]

FastReport.Net Class Reference
ReportLoadedEventArgs Methods
ReportLoadedEventArgs Class See Also Send Feedback

The ReportLoadedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportLoadedEventArgs Class
FastReport.Design Namespace


ReportLoadedEventArgs Properties

[image] [image]

FastReport.Net Class Reference
ReportLoadedEventArgs Properties
ReportLoadedEventArgs Class See Also Send Feedback

The ReportLoadedEventArgs type exposes the following members.

Properties

Name | Description
Report | The current report.

See Also

ReportLoadedEventArgs Class
FastReport.Design Namespace


Report Property

[image]

FastReport.Net Class Reference
ReportLoadedEventArgs..::.Report Property
ReportLoadedEventArgs Class See Also Send Feedback
The current report.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
}

See Also

ReportLoadedEventArgs Class
FastReport.Design Namespace


ReportLoadedEventHandler Delegate

[image]

FastReport.Net Class Reference
ReportLoadedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the designer ReportLoaded event.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public delegate void ReportLoadedEventHandler(
    Object sender,
    ReportLoadedEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ReportLoadedEventHandler ( _
    sender As Object, _
    e As ReportLoadedEventArgs _
)
Visual C++
public delegate void ReportLoadedEventHandler(
    Object^ sender,
    ReportLoadedEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: FastReport.Design..::.ReportLoadedEventArgs
The event data.

See Also

FastReport.Design Namespace


ReportSettingsCommand Class

[image]

FastReport.Net Class Reference
ReportSettingsCommand Class
Members See Also Send Feedback
Represents the "Report|Options..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportSettingsCommand : DesignerCommand
Visual Basic (Declaration)
Public Class ReportSettingsCommand _
    Inherits DesignerCommand
Visual C++
public ref class ReportSettingsCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.ReportSettingsCommand

See Also

ReportSettingsCommand Members
FastReport.Design Namespace


ReportSettingsCommand Members

[image] [image]

FastReport.Net Class Reference
ReportSettingsCommand Members
ReportSettingsCommand Class Methods Properties Events See Also Send Feedback

The ReportSettingsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ReportSettingsCommand Class
FastReport.Design Namespace


ReportSettingsCommand Methods

[image] [image]

FastReport.Net Class Reference
ReportSettingsCommand Methods
ReportSettingsCommand Class See Also Send Feedback

The ReportSettingsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportSettingsCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
ReportSettingsCommand..::.GetEnabled Method
ReportSettingsCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

ReportSettingsCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ReportSettingsCommand..::.Invoke Method
ReportSettingsCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

ReportSettingsCommand Class
ReportSettingsCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
ReportSettingsCommand..::.Invoke Method
ReportSettingsCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

ReportSettingsCommand Class
Invoke Overload
FastReport.Design Namespace


ReportSettingsCommand Properties

[image] [image]

FastReport.Net Class Reference
ReportSettingsCommand Properties
ReportSettingsCommand Class See Also Send Feedback

The ReportSettingsCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

ReportSettingsCommand Class
FastReport.Design Namespace


ReportSettingsCommand Events

[image] [image]

FastReport.Net Class Reference
ReportSettingsCommand Events
ReportSettingsCommand Class See Also Send Feedback

The ReportSettingsCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ReportSettingsCommand Class
FastReport.Design Namespace


ReportStylesCommand Class

[image]

FastReport.Net Class Reference
ReportStylesCommand Class
Members See Also Send Feedback
Represents the "Report|Styles..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportStylesCommand : DesignerCommand
Visual Basic (Declaration)
Public Class ReportStylesCommand _
    Inherits DesignerCommand
Visual C++
public ref class ReportStylesCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.ReportStylesCommand

See Also

ReportStylesCommand Members
FastReport.Design Namespace


ReportStylesCommand Members

[image] [image]

FastReport.Net Class Reference
ReportStylesCommand Members
ReportStylesCommand Class Methods Properties Events See Also Send Feedback

The ReportStylesCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ReportStylesCommand Class
FastReport.Design Namespace


ReportStylesCommand Methods

[image] [image]

FastReport.Net Class Reference
ReportStylesCommand Methods
ReportStylesCommand Class See Also Send Feedback

The ReportStylesCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportStylesCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
ReportStylesCommand..::.GetEnabled Method
ReportStylesCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

ReportStylesCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ReportStylesCommand..::.Invoke Method
ReportStylesCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

ReportStylesCommand Class
ReportStylesCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
ReportStylesCommand..::.Invoke Method
ReportStylesCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

ReportStylesCommand Class
Invoke Overload
FastReport.Design Namespace


ReportStylesCommand Properties

[image] [image]

FastReport.Net Class Reference
ReportStylesCommand Properties
ReportStylesCommand Class See Also Send Feedback

The ReportStylesCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

ReportStylesCommand Class
FastReport.Design Namespace


ReportStylesCommand Events

[image] [image]

FastReport.Net Class Reference
ReportStylesCommand Events
ReportStylesCommand Class See Also Send Feedback

The ReportStylesCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ReportStylesCommand Class
FastReport.Design Namespace


SaveAllCommand Class

[image]

FastReport.Net Class Reference
SaveAllCommand Class
Members See Also Send Feedback
Represents the "File|Save All" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SaveAllCommand : DesignerCommand
Visual Basic (Declaration)
Public Class SaveAllCommand _
    Inherits DesignerCommand
Visual C++
public ref class SaveAllCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.SaveAllCommand

See Also

SaveAllCommand Members
FastReport.Design Namespace


SaveAllCommand Members

[image] [image]

FastReport.Net Class Reference
SaveAllCommand Members
SaveAllCommand Class Methods Properties Events See Also Send Feedback

The SaveAllCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SaveAllCommand Class
FastReport.Design Namespace


SaveAllCommand Methods

[image] [image]

FastReport.Net Class Reference
SaveAllCommand Methods
SaveAllCommand Class See Also Send Feedback

The SaveAllCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveAllCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
SaveAllCommand..::.GetEnabled Method
SaveAllCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

SaveAllCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SaveAllCommand..::.Invoke Method
SaveAllCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

SaveAllCommand Class
SaveAllCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
SaveAllCommand..::.Invoke Method
SaveAllCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

SaveAllCommand Class
Invoke Overload
FastReport.Design Namespace


SaveAllCommand Properties

[image] [image]

FastReport.Net Class Reference
SaveAllCommand Properties
SaveAllCommand Class See Also Send Feedback

The SaveAllCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

SaveAllCommand Class
FastReport.Design Namespace


SaveAllCommand Events

[image] [image]

FastReport.Net Class Reference
SaveAllCommand Events
SaveAllCommand Class See Also Send Feedback

The SaveAllCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SaveAllCommand Class
FastReport.Design Namespace


SaveAsCommand Class

[image]

FastReport.Net Class Reference
SaveAsCommand Class
Members See Also Send Feedback
Represents the "File|Save As..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SaveAsCommand : DesignerCommand
Visual Basic (Declaration)
Public Class SaveAsCommand _
    Inherits DesignerCommand
Visual C++
public ref class SaveAsCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.SaveAsCommand

See Also

SaveAsCommand Members
FastReport.Design Namespace


SaveAsCommand Members

[image] [image]

FastReport.Net Class Reference
SaveAsCommand Members
SaveAsCommand Class Methods Properties Events See Also Send Feedback

The SaveAsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SaveAsCommand Class
FastReport.Design Namespace


SaveAsCommand Methods

[image] [image]

FastReport.Net Class Reference
SaveAsCommand Methods
SaveAsCommand Class See Also Send Feedback

The SaveAsCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveAsCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
SaveAsCommand..::.GetEnabled Method
SaveAsCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

SaveAsCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SaveAsCommand..::.Invoke Method
SaveAsCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

SaveAsCommand Class
SaveAsCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
SaveAsCommand..::.Invoke Method
SaveAsCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

SaveAsCommand Class
Invoke Overload
FastReport.Design Namespace


SaveAsCommand Properties

[image] [image]

FastReport.Net Class Reference
SaveAsCommand Properties
SaveAsCommand Class See Also Send Feedback

The SaveAsCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

SaveAsCommand Class
FastReport.Design Namespace


SaveAsCommand Events

[image] [image]

FastReport.Net Class Reference
SaveAsCommand Events
SaveAsCommand Class See Also Send Feedback

The SaveAsCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SaveAsCommand Class
FastReport.Design Namespace


SaveCommand Class

[image]

FastReport.Net Class Reference
SaveCommand Class
Members See Also Send Feedback
Represents the "File|Save" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SaveCommand : DesignerCommand
Visual Basic (Declaration)
Public Class SaveCommand _
    Inherits DesignerCommand
Visual C++
public ref class SaveCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.SaveCommand

See Also

SaveCommand Members
FastReport.Design Namespace


SaveCommand Members

[image] [image]

FastReport.Net Class Reference
SaveCommand Members
SaveCommand Class Methods Properties Events See Also Send Feedback

The SaveCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SaveCommand Class
FastReport.Design Namespace


SaveCommand Methods

[image] [image]

FastReport.Net Class Reference
SaveCommand Methods
SaveCommand Class See Also Send Feedback

The SaveCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
SaveCommand..::.GetEnabled Method
SaveCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

SaveCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SaveCommand..::.Invoke Method
SaveCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

SaveCommand Class
SaveCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
SaveCommand..::.Invoke Method
SaveCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

SaveCommand Class
Invoke Overload
FastReport.Design Namespace


SaveCommand Properties

[image] [image]

FastReport.Net Class Reference
SaveCommand Properties
SaveCommand Class See Also Send Feedback

The SaveCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

SaveCommand Class
FastReport.Design Namespace


SaveCommand Events

[image] [image]

FastReport.Net Class Reference
SaveCommand Events
SaveCommand Class See Also Send Feedback

The SaveCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SaveCommand Class
FastReport.Design Namespace


SelectAllCommand Class

[image]

FastReport.Net Class Reference
SelectAllCommand Class
Members See Also Send Feedback
Represents the "Edit|Select All" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectAllCommand : DesignerCommand
Visual Basic (Declaration)
Public Class SelectAllCommand _
    Inherits DesignerCommand
Visual C++
public ref class SelectAllCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.SelectAllCommand

See Also

SelectAllCommand Members
FastReport.Design Namespace


SelectAllCommand Members

[image] [image]

FastReport.Net Class Reference
SelectAllCommand Members
SelectAllCommand Class Methods Properties Events See Also Send Feedback

The SelectAllCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SelectAllCommand Class
FastReport.Design Namespace


SelectAllCommand Methods

[image] [image]

FastReport.Net Class Reference
SelectAllCommand Methods
SelectAllCommand Class See Also Send Feedback

The SelectAllCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectAllCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
SelectAllCommand..::.GetEnabled Method
SelectAllCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

SelectAllCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SelectAllCommand..::.Invoke Method
SelectAllCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

SelectAllCommand Class
SelectAllCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
SelectAllCommand..::.Invoke Method
SelectAllCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

SelectAllCommand Class
Invoke Overload
FastReport.Design Namespace


SelectAllCommand Properties

[image] [image]

FastReport.Net Class Reference
SelectAllCommand Properties
SelectAllCommand Class See Also Send Feedback

The SelectAllCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

SelectAllCommand Class
FastReport.Design Namespace


SelectAllCommand Events

[image] [image]

FastReport.Net Class Reference
SelectAllCommand Events
SelectAllCommand Class See Also Send Feedback

The SelectAllCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SelectAllCommand Class
FastReport.Design Namespace


SelectLanguageCommand Class

[image]

FastReport.Net Class Reference
SelectLanguageCommand Class
Members See Also Send Feedback
Represents the "File|Select Language..." command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectLanguageCommand : DesignerCommand
Visual Basic (Declaration)
Public Class SelectLanguageCommand _
    Inherits DesignerCommand
Visual C++
public ref class SelectLanguageCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.SelectLanguageCommand

See Also

SelectLanguageCommand Members
FastReport.Design Namespace


SelectLanguageCommand Members

[image] [image]

FastReport.Net Class Reference
SelectLanguageCommand Members
SelectLanguageCommand Class Methods Properties Events See Also Send Feedback

The SelectLanguageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from DesignerCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SelectLanguageCommand Class
FastReport.Design Namespace


SelectLanguageCommand Methods

[image] [image]

FastReport.Net Class Reference
SelectLanguageCommand Methods
SelectLanguageCommand Class See Also Send Feedback

The SelectLanguageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from DesignerCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectLanguageCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SelectLanguageCommand..::.Invoke Method
SelectLanguageCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

SelectLanguageCommand Class
SelectLanguageCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
SelectLanguageCommand..::.Invoke Method
SelectLanguageCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

SelectLanguageCommand Class
Invoke Overload
FastReport.Design Namespace


SelectLanguageCommand Properties

[image] [image]

FastReport.Net Class Reference
SelectLanguageCommand Properties
SelectLanguageCommand Class See Also Send Feedback

The SelectLanguageCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

SelectLanguageCommand Class
FastReport.Design Namespace


SelectLanguageCommand Events

[image] [image]

FastReport.Net Class Reference
SelectLanguageCommand Events
SelectLanguageCommand Class See Also Send Feedback

The SelectLanguageCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SelectLanguageCommand Class
FastReport.Design Namespace


SendToBackCommand Class

[image]

FastReport.Net Class Reference
SendToBackCommand Class
Members See Also Send Feedback
Represents the "Send To Back" context menu command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SendToBackCommand : BringToFrontCommand
Visual Basic (Declaration)
Public Class SendToBackCommand _
    Inherits BringToFrontCommand
Visual C++
public ref class SendToBackCommand : public BringToFrontCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.BringToFrontCommand
FastReport.Design..::.SendToBackCommand

See Also

SendToBackCommand Members
FastReport.Design Namespace


SendToBackCommand Members

[image] [image]

FastReport.Net Class Reference
SendToBackCommand Members
SendToBackCommand Class Methods Properties Events See Also Send Feedback

The SendToBackCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from BringToFrontCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SendToBackCommand Class
FastReport.Design Namespace


SendToBackCommand Methods

[image] [image]

FastReport.Net Class Reference
SendToBackCommand Methods
SendToBackCommand Class See Also Send Feedback

The SendToBackCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from BringToFrontCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendToBackCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
SendToBackCommand..::.Invoke Method
SendToBackCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides BringToFrontCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

SendToBackCommand Class
SendToBackCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
SendToBackCommand..::.Invoke Method
SendToBackCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

SendToBackCommand Class
Invoke Overload
FastReport.Design Namespace


SendToBackCommand Properties

[image] [image]

FastReport.Net Class Reference
SendToBackCommand Properties
SendToBackCommand Class See Also Send Feedback

The SendToBackCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

SendToBackCommand Class
FastReport.Design Namespace


SendToBackCommand Events

[image] [image]

FastReport.Net Class Reference
SendToBackCommand Events
SendToBackCommand Class See Also Send Feedback

The SendToBackCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

SendToBackCommand Class
FastReport.Design Namespace


UndoCommand Class

[image]

FastReport.Net Class Reference
UndoCommand Class
Members See Also Send Feedback
Represents the "Edit|Undo" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class UndoCommand : DesignerCommand
Visual Basic (Declaration)
Public Class UndoCommand _
    Inherits DesignerCommand
Visual C++
public ref class UndoCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.UndoCommand

See Also

UndoCommand Members
FastReport.Design Namespace


UndoCommand Members

[image] [image]

FastReport.Net Class Reference
UndoCommand Members
UndoCommand Class Methods Properties Events See Also Send Feedback

The UndoCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | Undo several actions.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

UndoCommand Class
FastReport.Design Namespace


UndoCommand Methods

[image] [image]

FastReport.Net Class Reference
UndoCommand Methods
UndoCommand Class See Also Send Feedback

The UndoCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | Undo several actions.

See Also

UndoCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
UndoCommand..::.GetEnabled Method
UndoCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

UndoCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
UndoCommand..::.Invoke Method
UndoCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

UndoCommand Class
UndoCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
UndoCommand..::.Invoke Method
UndoCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

UndoCommand Class
Invoke Overload
FastReport.Design Namespace


Undo Method

[image]

FastReport.Net Class Reference
UndoCommand..::.Undo Method
UndoCommand Class See Also Send Feedback
Undo several actions.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Undo(
    int actionsCount
)
Visual Basic (Declaration)
Public Sub Undo ( _
    actionsCount As Integer _
)
Visual C++
public:
void Undo(
    int actionsCount
)

Parameters

actionsCount
Type: System..::.Int32
Number of actions to undo.

See Also

UndoCommand Class
FastReport.Design Namespace


UndoCommand Properties

[image] [image]

FastReport.Net Class Reference
UndoCommand Properties
UndoCommand Class See Also Send Feedback

The UndoCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

UndoCommand Class
FastReport.Design Namespace


UndoCommand Events

[image] [image]

FastReport.Net Class Reference
UndoCommand Events
UndoCommand Class See Also Send Feedback

The UndoCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

UndoCommand Class
FastReport.Design Namespace


UngroupCommand Class

[image]

FastReport.Net Class Reference
UngroupCommand Class
Members See Also Send Feedback
Represents the "Edit|Ungroup" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class UngroupCommand : GroupCommand
Visual Basic (Declaration)
Public Class UngroupCommand _
    Inherits GroupCommand
Visual C++
public ref class UngroupCommand : public GroupCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.GroupCommand
FastReport.Design..::.UngroupCommand

See Also

UngroupCommand Members
FastReport.Design Namespace


UngroupCommand Members

[image] [image]

FastReport.Net Class Reference
UngroupCommand Members
UngroupCommand Class Methods Properties Events See Also Send Feedback

The UngroupCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from GroupCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

UngroupCommand Class
FastReport.Design Namespace


UngroupCommand Methods

[image] [image]

FastReport.Net Class Reference
UngroupCommand Methods
UngroupCommand Class See Also Send Feedback

The UngroupCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Inherited from GroupCommand.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UngroupCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
UngroupCommand..::.Invoke Method
UngroupCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides GroupCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

UngroupCommand Class
UngroupCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
UngroupCommand..::.Invoke Method
UngroupCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

UngroupCommand Class
Invoke Overload
FastReport.Design Namespace


UngroupCommand Properties

[image] [image]

FastReport.Net Class Reference
UngroupCommand Properties
UngroupCommand Class See Also Send Feedback

The UngroupCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

UngroupCommand Class
FastReport.Design Namespace


UngroupCommand Events

[image] [image]

FastReport.Net Class Reference
UngroupCommand Events
UngroupCommand Class See Also Send Feedback

The UngroupCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

UngroupCommand Class
FastReport.Design Namespace


ViewStartPageCommand Class

[image]

FastReport.Net Class Reference
ViewStartPageCommand Class
Members See Also Send Feedback
Represents the "View|Start Page" command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ViewStartPageCommand : DesignerCommand
Visual Basic (Declaration)
Public Class ViewStartPageCommand _
    Inherits DesignerCommand
Visual C++
public ref class ViewStartPageCommand : public DesignerCommand

Inheritance Hierarchy

System..::.Object
FastReport.Design..::.DesignerCommand
FastReport.Design..::.ViewStartPageCommand

See Also

ViewStartPageCommand Members
FastReport.Design Namespace


ViewStartPageCommand Members

[image] [image]

FastReport.Net Class Reference
ViewStartPageCommand Members
ViewStartPageCommand Class Methods Properties Events See Also Send Feedback

The ViewStartPageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ViewStartPageCommand Class
FastReport.Design Namespace


ViewStartPageCommand Methods

[image] [image]

FastReport.Net Class Reference
ViewStartPageCommand Methods
ViewStartPageCommand Class See Also Send Feedback

The ViewStartPageCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnabled | Gets a value for the Enabled property. (Overrides DesignerCommand..::.GetEnabled()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewStartPageCommand Class
FastReport.Design Namespace


GetEnabled Method

[image]

FastReport.Net Class Reference
ViewStartPageCommand..::.GetEnabled Method
ViewStartPageCommand Class See Also Send Feedback
Gets a value for the Enabled property.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool GetEnabled()
Visual Basic (Declaration)
Protected Overrides Function GetEnabled As Boolean
Visual C++
protected:
virtual bool GetEnabled() override

Return Value

true if command is enabled.

See Also

ViewStartPageCommand Class
FastReport.Design Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ViewStartPageCommand..::.Invoke Method
ViewStartPageCommand Class See Also Send Feedback

Overload List

Name | Description
Invoke()()() | Invokes the command. (Overrides DesignerCommand..::.Invoke()()().)
Invoke(Object, EventArgs) | Invokes the command with specified sender and event args. (Inherited from DesignerCommand.)

See Also

ViewStartPageCommand Class
ViewStartPageCommand Members
FastReport.Design Namespace


Invoke Method

[image]

FastReport.Net Class Reference
ViewStartPageCommand..::.Invoke Method
ViewStartPageCommand Class See Also Send Feedback
Invokes the command.

Namespace: FastReport.Design
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Invoke()
Visual Basic (Declaration)
Public Overrides Sub Invoke
Visual C++
public:
virtual void Invoke() override

See Also

ViewStartPageCommand Class
Invoke Overload
FastReport.Design Namespace


ViewStartPageCommand Properties

[image] [image]

FastReport.Net Class Reference
ViewStartPageCommand Properties
ViewStartPageCommand Class See Also Send Feedback

The ViewStartPageCommand type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating that the command is enabled. (Inherited from DesignerCommand.)

See Also

ViewStartPageCommand Class
FastReport.Design Namespace


ViewStartPageCommand Events

[image] [image]

FastReport.Net Class Reference
ViewStartPageCommand Events
ViewStartPageCommand Class See Also Send Feedback

The ViewStartPageCommand type exposes the following members.

Events

Name | Description
CustomAction | Defines a custom action for this command. (Inherited from DesignerCommand.)

See Also

ViewStartPageCommand Class
FastReport.Design Namespace


FastReport.Design.ImportPlugins Namespace

[image]

FastReport.Net Class Reference
FastReport.Design.ImportPlugins Namespace
Send Feedback

Classes

Class | Description
ComponentsFactory | The components factory.


ComponentsFactory Class

[image]

FastReport.Net Class Reference
ComponentsFactory Class
Members See Also Send Feedback
The components factory.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class ComponentsFactory
Visual Basic (Declaration)
Public NotInheritable Class ComponentsFactory
Visual C++
public ref class ComponentsFactory abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Design.ImportPlugins..::.ComponentsFactory

See Also

ComponentsFactory Members
FastReport.Design.ImportPlugins Namespace


ComponentsFactory Members

[image] [image]

FastReport.Net Class Reference
ComponentsFactory Members
ComponentsFactory Class Methods See Also Send Feedback

The ComponentsFactory type exposes the following members.

Methods

Name | Description
CreateChildBand | Creates a ChildBand instance in the specified BandBase.
CreateDataBand | Creates a DataBand instance in the specified ReportPage.
CreateLineObject | Creates a LineObject instance with the specified name and parent.
CreateMatrixObject | Creates a MatrixObject instance with the specified name and parent.
CreateMSChartObject | Creates a MSChartObject instance with the specified name and parent.
CreatePageFooterBand | Creates a PageFooterBand instance in the specified ReportPage.
CreatePageHeaderBand | Creates a PageHeaderBand instance in the specified ReportPage.
CreatePictureObject | Creates a PictureObject instance with the specified name and parent.
CreateReportPage | Creates a ReportPage instance in the specified Report.
CreateReportSummaryBand | Creates a ReportSummaryBand instance in the specified ReportPage.
CreateReportTitleBand | Creates a ReportTitleBand instance in the specified ReportPage.
CreateShapeObject | Creates a ShapeObject instance with the specified name and parent.
CreateSubreportObject | Creates a SubreportObject instance with the specified name and parent.
CreateTableObject | Creates a TableObject instance with the specified name and parent.
CreateTextObject | Creates a TextObject instance with the specified name and parent.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


ComponentsFactory Methods

[image] [image]

FastReport.Net Class Reference
ComponentsFactory Methods
ComponentsFactory Class See Also Send Feedback

The ComponentsFactory type exposes the following members.

Methods

Name | Description
CreateChildBand | Creates a ChildBand instance in the specified BandBase.
CreateDataBand | Creates a DataBand instance in the specified ReportPage.
CreateLineObject | Creates a LineObject instance with the specified name and parent.
CreateMatrixObject | Creates a MatrixObject instance with the specified name and parent.
CreateMSChartObject | Creates a MSChartObject instance with the specified name and parent.
CreatePageFooterBand | Creates a PageFooterBand instance in the specified ReportPage.
CreatePageHeaderBand | Creates a PageHeaderBand instance in the specified ReportPage.
CreatePictureObject | Creates a PictureObject instance with the specified name and parent.
CreateReportPage | Creates a ReportPage instance in the specified Report.
CreateReportSummaryBand | Creates a ReportSummaryBand instance in the specified ReportPage.
CreateReportTitleBand | Creates a ReportTitleBand instance in the specified ReportPage.
CreateShapeObject | Creates a ShapeObject instance with the specified name and parent.
CreateSubreportObject | Creates a SubreportObject instance with the specified name and parent.
CreateTableObject | Creates a TableObject instance with the specified name and parent.
CreateTextObject | Creates a TextObject instance with the specified name and parent.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateChildBand Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateChildBand Method
ComponentsFactory Class See Also Send Feedback
Creates a ChildBand instance in the specified BandBase.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ChildBand CreateChildBand(
    BandBase parent
)
Visual Basic (Declaration)
Public Shared Function CreateChildBand ( _
    parent As BandBase _
) As ChildBand
Visual C++
public:
static ChildBand^ CreateChildBand(
    BandBase^ parent
)

Parameters

parent
Type: FastReport..::.BandBase
The BandBase instance.

Return Value

The ChildBand instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateDataBand Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateDataBand Method
ComponentsFactory Class See Also Send Feedback
Creates a DataBand instance in the specified ReportPage.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DataBand CreateDataBand(
    ReportPage page
)
Visual Basic (Declaration)
Public Shared Function CreateDataBand ( _
    page As ReportPage _
) As DataBand
Visual C++
public:
static DataBand^ CreateDataBand(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The ReportPage instance.

Return Value

The DataBand instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateLineObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateLineObject Method
ComponentsFactory Class See Also Send Feedback
Creates a LineObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static LineObject CreateLineObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateLineObject ( _
    name As String, _
    parent As Base _
) As LineObject
Visual C++
public:
static LineObject^ CreateLineObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the LineObject instance.
parent
Type: FastReport..::.Base
The parent of the LineObject instance.

Return Value

The LineObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateMatrixObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateMatrixObject Method
ComponentsFactory Class See Also Send Feedback
Creates a MatrixObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static MatrixObject CreateMatrixObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateMatrixObject ( _
    name As String, _
    parent As Base _
) As MatrixObject
Visual C++
public:
static MatrixObject^ CreateMatrixObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the MatrixObject instance.
parent
Type: FastReport..::.Base
The parent of the MatrixObject instance.

Return Value

The MatrixObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateMSChartObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateMSChartObject Method
ComponentsFactory Class See Also Send Feedback
Creates a MSChartObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static MSChartObject CreateMSChartObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateMSChartObject ( _
    name As String, _
    parent As Base _
) As MSChartObject
Visual C++
public:
static MSChartObject^ CreateMSChartObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the MSChartObject instance.
parent
Type: FastReport..::.Base
The parent of the MSChartObject instance.

Return Value

The MSChartObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreatePageFooterBand Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreatePageFooterBand Method
ComponentsFactory Class See Also Send Feedback
Creates a PageFooterBand instance in the specified ReportPage.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static PageFooterBand CreatePageFooterBand(
    ReportPage page
)
Visual Basic (Declaration)
Public Shared Function CreatePageFooterBand ( _
    page As ReportPage _
) As PageFooterBand
Visual C++
public:
static PageFooterBand^ CreatePageFooterBand(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The ReportPage instance.

Return Value

The PageFooterBand instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreatePageHeaderBand Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreatePageHeaderBand Method
ComponentsFactory Class See Also Send Feedback
Creates a PageHeaderBand instance in the specified ReportPage.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static PageHeaderBand CreatePageHeaderBand(
    ReportPage page
)
Visual Basic (Declaration)
Public Shared Function CreatePageHeaderBand ( _
    page As ReportPage _
) As PageHeaderBand
Visual C++
public:
static PageHeaderBand^ CreatePageHeaderBand(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The ReportPage instance.

Return Value

The PageHeaderBand instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreatePictureObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreatePictureObject Method
ComponentsFactory Class See Also Send Feedback
Creates a PictureObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static PictureObject CreatePictureObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreatePictureObject ( _
    name As String, _
    parent As Base _
) As PictureObject
Visual C++
public:
static PictureObject^ CreatePictureObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the PictureObject instance.
parent
Type: FastReport..::.Base
The parent of the PictureObject instance.

Return Value

The PictureObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateReportPage Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateReportPage Method
ComponentsFactory Class See Also Send Feedback
Creates a ReportPage instance in the specified Report.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ReportPage CreateReportPage(
    Report report
)
Visual Basic (Declaration)
Public Shared Function CreateReportPage ( _
    report As Report _
) As ReportPage
Visual C++
public:
static ReportPage^ CreateReportPage(
    Report^ report
)

Parameters

report
Type: FastReport..::.Report
The Report instance.

Return Value

The ReportPage instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateReportSummaryBand Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateReportSummaryBand Method
ComponentsFactory Class See Also Send Feedback
Creates a ReportSummaryBand instance in the specified ReportPage.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ReportSummaryBand CreateReportSummaryBand(
    ReportPage page
)
Visual Basic (Declaration)
Public Shared Function CreateReportSummaryBand ( _
    page As ReportPage _
) As ReportSummaryBand
Visual C++
public:
static ReportSummaryBand^ CreateReportSummaryBand(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The ReportPage instance.

Return Value

The ReportSummaryBand instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateReportTitleBand Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateReportTitleBand Method
ComponentsFactory Class See Also Send Feedback
Creates a ReportTitleBand instance in the specified ReportPage.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ReportTitleBand CreateReportTitleBand(
    ReportPage page
)
Visual Basic (Declaration)
Public Shared Function CreateReportTitleBand ( _
    page As ReportPage _
) As ReportTitleBand
Visual C++
public:
static ReportTitleBand^ CreateReportTitleBand(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The ReportPage instance.

Return Value

The ReportTitleBand instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateShapeObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateShapeObject Method
ComponentsFactory Class See Also Send Feedback
Creates a ShapeObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ShapeObject CreateShapeObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateShapeObject ( _
    name As String, _
    parent As Base _
) As ShapeObject
Visual C++
public:
static ShapeObject^ CreateShapeObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the ShapeObject instance.
parent
Type: FastReport..::.Base
The parent of the ShapeObject instance.

Return Value

The ShapeObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateSubreportObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateSubreportObject Method
ComponentsFactory Class See Also Send Feedback
Creates a SubreportObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static SubreportObject CreateSubreportObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateSubreportObject ( _
    name As String, _
    parent As Base _
) As SubreportObject
Visual C++
public:
static SubreportObject^ CreateSubreportObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the SubreportObject instance.
parent
Type: FastReport..::.Base
The parent of the SubreportObject instance.

Return Value

The SubreportObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateTableObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateTableObject Method
ComponentsFactory Class See Also Send Feedback
Creates a TableObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static TableObject CreateTableObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateTableObject ( _
    name As String, _
    parent As Base _
) As TableObject
Visual C++
public:
static TableObject^ CreateTableObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the TableObject instance.
parent
Type: FastReport..::.Base
The parent of the TableObject instance.

Return Value

The TableObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


CreateTextObject Method

[image]

FastReport.Net Class Reference
ComponentsFactory..::.CreateTextObject Method
ComponentsFactory Class See Also Send Feedback
Creates a TextObject instance with the specified name and parent.

Namespace: FastReport.Design.ImportPlugins
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static TextObject CreateTextObject(
    string name,
    Base parent
)
Visual Basic (Declaration)
Public Shared Function CreateTextObject ( _
    name As String, _
    parent As Base _
) As TextObject
Visual C++
public:
static TextObject^ CreateTextObject(
    String^ name,
    Base^ parent
)

Parameters

name
Type: System..::.String
The name of the TextObject instance.
parent
Type: FastReport..::.Base
The parent of the TextObject instance.

Return Value

The TextObject instance.

See Also

ComponentsFactory Class
FastReport.Design.ImportPlugins Namespace


FastReport.Design.StandardDesigner Namespace

[image]

FastReport.Net Class Reference
FastReport.Design.StandardDesigner Namespace
Send Feedback

Classes

Class | Description
DesignerControl | Represents the standard report designer.
DesignerForm | Represents standard designer's form.
DesignerMenu | Represents the designer's main menu.
DesignerStatusBar | Represents the designer's statusbar.
Office2007DesignerForm | Represents designer's form in Office 2007 style.
ToolbarBase | Base class for all designer toolbars.


DesignerControl Class

[image]

FastReport.Net Class Reference
DesignerControl Class
Members See Also Send Feedback
Represents the standard report designer.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerControl : Designer
Visual Basic (Declaration)
Public Class DesignerControl _
    Inherits Designer
Visual C++
public ref class DesignerControl : public Designer

Remarks

This control extends the Designer control with standard menu, status bar, and toolbars.

To choose toolbars and tool windows in design-time, click the "View" menu in this control and select what you want to see. Toolbars can be reordered using the mouse.

To restore the designer layout at runtime, you need to call the RefreshLayout method in your form's Load event handler.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Design..::.Designer
FastReport.Design.StandardDesigner..::.DesignerControl

See Also

DesignerControl Members
FastReport.Design.StandardDesigner Namespace


DesignerControl Members

[image] [image]

FastReport.Net Class Reference
DesignerControl Members
DesignerControl Class Constructors Methods Properties Events See Also Send Feedback

The DesignerControl type exposes the following members.

Constructors

Name | Description
DesignerControl | Initializes a new instance of the DesignerControl class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInit | Signals the object that initialization is starting. (Inherited from Designer.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ClearMessages | Clears the "Messages" window. (Inherited from Designer.)
CloseAll | Close all opened reports, ask to save changes. (Inherited from Designer.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateEmptyReport | Tries to create a new empty report. (Inherited from Designer.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | Signals the object that initialization is complete. (Inherited from Designer.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InitPlugins | Initializes designer plugins such as toolbars and toolwindows. (Overrides Designer..::.InitPlugins()()().)
InitReport | Initializes the workspace after the new report is loaded. (Inherited from Designer.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Lock | Locks all plugins. (Inherited from Designer.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Designer.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshLayout | Refresh the designer's toolbars and toolwindows layout. (Inherited from Designer.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreConfig | Restores config from a FastReport configuration file. (Inherited from Designer.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveConfig | Saves config to a FastReport configuration file. (Inherited from Designer.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectionChanged | Call this method to tell the designer that current selection is changed. (Inherited from Designer.)
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetModified | Overloaded.
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowMessage | Displays a message in the "Messages" window. (Inherited from Designer.)
ShowStatus | Shows the selected object's information in the designer's statusbar. (Overrides Designer..::.ShowStatus(String, String, String).)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Unlock | Unlocks all plugins. (Inherited from Designer.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdatePlugins | Call this method to refresh all plugins' content. (Inherited from Designer.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveReport | Gets active report object. (Inherited from Designer.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AskSave | Gets or sets a value that determines whether to ask user to save changes when closing the designer. (Inherited from Designer.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
cmdAbout | The "Help|About..." command. (Inherited from Designer.)
cmdAddData | The "Data|Add New Data Source..." command. (Inherited from Designer.)
cmdBringToFront | The "Bring To Front" command. (Inherited from Designer.)
cmdChooseData | The "Data|Choose Report Data..." command. (Inherited from Designer.)
cmdClose | The "File|Close" command. (Inherited from Designer.)
cmdCloseAll | The "Window|Close All" command. (Inherited from Designer.)
cmdCopy | The "Edit|Copy" command. (Inherited from Designer.)
cmdCut | The "Edit|Cut" command. (Inherited from Designer.)
cmdDelete | The "Edit|Delete" command. (Inherited from Designer.)
cmdDeletePage | The "Edit|Delete Page" command. (Inherited from Designer.)
cmdEdit | The "Edit" command. (Inherited from Designer.)
cmdFind | The "Edit|Find..." command. (Inherited from Designer.)
cmdFormatPainter | The "Format Painter" toolbar command. (Inherited from Designer.)
cmdGroup | The "Edit|Group" command. (Inherited from Designer.)
cmdHelpContents | The "Help|Help Contents..." command. (Inherited from Designer.)
cmdInsert | The "Insert" command. (Inherited from Designer.)
cmdInsertBand | The "Insert Band" command. (Inherited from Designer.)
cmdNew | The "File|New" command. (Inherited from Designer.)
cmdNewDialog | The "New Dialog" toolbar command. (Inherited from Designer.)
cmdNewPage | The "New Page" toolbar command. (Inherited from Designer.)
cmdOpen | The "File|Open..." command. (Inherited from Designer.)
cmdOptions | The "View|Options..." command. (Inherited from Designer.)
cmdPageSetup | The "File|Page Setup..." command. (Inherited from Designer.)
cmdPaste | The "Edit|Paste" command. (Inherited from Designer.)
cmdPreview | The "File|Preview..." command. (Inherited from Designer.)
cmdPrinterSetup | The "File|Printer Setup..." command. (Inherited from Designer.)
cmdRecentFiles | The "Recent Files" command. (Inherited from Designer.)
cmdRedo | The "Edit|Redo" command. (Inherited from Designer.)
cmdReplace | The "Edit|Replace..." command. (Inherited from Designer.)
cmdReportSettings | The "Report|Options..." command. (Inherited from Designer.)
cmdReportStyles | The "Report|Styles..." command. (Inherited from Designer.)
cmdSave | The "File|Save" command. (Inherited from Designer.)
cmdSaveAll | The "File|Save All" command. (Inherited from Designer.)
cmdSaveAs | The "File|Save As..." command. (Inherited from Designer.)
cmdSelectAll | The "Edit|Select All" command. (Inherited from Designer.)
cmdSelectLanguage | The "File|Select Language..." command. (Inherited from Designer.)
cmdSendToBack | The "Send To Back" command. (Inherited from Designer.)
cmdUndo | The "Edit|Undo" command. (Inherited from Designer.)
cmdUngroup | The "Edit|Ungroup" command. (Inherited from Designer.)
cmdViewStartPage | The "View|Start Page" command. (Inherited from Designer.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsPreviewPageDesigner | Gets a value indicating that designer is used to edit a preview page. (Inherited from Designer.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutState | Gets or sets the layout state of the designer. (Inherited from Designer.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
MainMenu | Gets the main menu.
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MdiMode | Gets or sets a value indicating that designer is run in MDI mode. (Inherited from Designer.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Modified | Gets or sets a value indicating that the report was modified. (Inherited from Designer.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Objects | Gets a collection of objects on the active page of the active report. (Inherited from Designer.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Plugins | Gets a collection of global plugins such as menu, properties window, etc. (Inherited from Designer.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the edited report. (Inherited from Designer.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Restrictions | Gets the designer restrictions. (Inherited from Designer.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedComponents | Gets a collection of selected objects of the ComponentBase type. (Inherited from Designer.)
SelectedObjects | Gets a collection of selected objects on the active page of the active report. (Inherited from Designer.)
SelectedReportComponents | Gets a collection of selected objects of the ReportComponentBase type. (Inherited from Designer.)
SelectedTextObjects | Gets a collection of selected objects of the TextObject type. (Inherited from Designer.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowMainMenu | Gets or sets a value indicating whether the main menu should be displayed or not.
ShowStatusBar | Gets or sets a value indicating whether the status bar should be displayed or not.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UIStyle | Gets or sets the visual style. (Inherited from Designer.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutChangedEvent | Fires when the layout is changed. (Inherited from Designer.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
UIStateChanged | Occurs when designer's UI state changed. (Inherited from Designer.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


DesignerControl Constructor

[image]

FastReport.Net Class Reference
DesignerControl Constructor
DesignerControl Class See Also Send Feedback
Initializes a new instance of the DesignerControl class with default settings.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerControl()

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


DesignerControl Methods

[image] [image]

FastReport.Net Class Reference
DesignerControl Methods
DesignerControl Class See Also Send Feedback

The DesignerControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInit | Signals the object that initialization is starting. (Inherited from Designer.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ClearMessages | Clears the "Messages" window. (Inherited from Designer.)
CloseAll | Close all opened reports, ask to save changes. (Inherited from Designer.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateEmptyReport | Tries to create a new empty report. (Inherited from Designer.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | Signals the object that initialization is complete. (Inherited from Designer.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InitPlugins | Initializes designer plugins such as toolbars and toolwindows. (Overrides Designer..::.InitPlugins()()().)
InitReport | Initializes the workspace after the new report is loaded. (Inherited from Designer.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Lock | Locks all plugins. (Inherited from Designer.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Designer.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshLayout | Refresh the designer's toolbars and toolwindows layout. (Inherited from Designer.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreConfig | Restores config from a FastReport configuration file. (Inherited from Designer.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveConfig | Saves config to a FastReport configuration file. (Inherited from Designer.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectionChanged | Call this method to tell the designer that current selection is changed. (Inherited from Designer.)
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetModified | Overloaded.
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowMessage | Displays a message in the "Messages" window. (Inherited from Designer.)
ShowStatus | Shows the selected object's information in the designer's statusbar. (Overrides Designer..::.ShowStatus(String, String, String).)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Unlock | Unlocks all plugins. (Inherited from Designer.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdatePlugins | Call this method to refresh all plugins' content. (Inherited from Designer.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.AccessibilityNotifyClients Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.BeginInvoke Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.Dispose Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DesignerControl..::.Dispose Method (Boolean)
DesignerControl Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DesignerControl Class
Dispose Overload
FastReport.Design.StandardDesigner Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.GetChildAtPoint Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


InitPlugins Method

[image]

FastReport.Net Class Reference
DesignerControl..::.InitPlugins Method
DesignerControl Class See Also Send Feedback
Initializes designer plugins such as toolbars and toolwindows.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void InitPlugins()
Visual Basic (Declaration)
Protected Overrides Sub InitPlugins
Visual C++
protected:
virtual void InitPlugins() override

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.Invalidate Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.Invoke Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.MemberwiseClone Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.PerformLayout Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.ResumeLayout Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.RtlTranslateAlignment Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.Scale Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.Select Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.SetBounds Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


SetModified Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.SetModified Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
SetModified()()() | Call this method if you change something in the report. (Inherited from Designer.)
SetModified(Object, String) | Call this method if you change something in the report. (Inherited from Designer.)
SetModified(Object, String, String) | Call this method if you change something in the report. (Inherited from Designer.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


ShowStatus Method

[image]

FastReport.Net Class Reference
DesignerControl..::.ShowStatus Method
DesignerControl Class See Also Send Feedback
Shows the selected object's information in the designer's statusbar.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void ShowStatus(
    string location,
    string size,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub ShowStatus ( _
    location As String, _
    size As String, _
    text As String _
)
Visual C++
public:
virtual void ShowStatus(
    String^ location,
    String^ size,
    String^ text
) override

Parameters

location
Type: System..::.String
Object's location.
size
Type: System..::.String
Object's size.
text
Type: System..::.String
Textual information about the selected object.

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.UpdateBounds Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.Validate Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
DesignerControl..::.ValidateChildren Method
DesignerControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerControl Class
DesignerControl Members
FastReport.Design.StandardDesigner Namespace


DesignerControl Properties

[image] [image]

FastReport.Net Class Reference
DesignerControl Properties
DesignerControl Class See Also Send Feedback

The DesignerControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveReport | Gets active report object. (Inherited from Designer.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AskSave | Gets or sets a value that determines whether to ask user to save changes when closing the designer. (Inherited from Designer.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
cmdAbout | The "Help|About..." command. (Inherited from Designer.)
cmdAddData | The "Data|Add New Data Source..." command. (Inherited from Designer.)
cmdBringToFront | The "Bring To Front" command. (Inherited from Designer.)
cmdChooseData | The "Data|Choose Report Data..." command. (Inherited from Designer.)
cmdClose | The "File|Close" command. (Inherited from Designer.)
cmdCloseAll | The "Window|Close All" command. (Inherited from Designer.)
cmdCopy | The "Edit|Copy" command. (Inherited from Designer.)
cmdCut | The "Edit|Cut" command. (Inherited from Designer.)
cmdDelete | The "Edit|Delete" command. (Inherited from Designer.)
cmdDeletePage | The "Edit|Delete Page" command. (Inherited from Designer.)
cmdEdit | The "Edit" command. (Inherited from Designer.)
cmdFind | The "Edit|Find..." command. (Inherited from Designer.)
cmdFormatPainter | The "Format Painter" toolbar command. (Inherited from Designer.)
cmdGroup | The "Edit|Group" command. (Inherited from Designer.)
cmdHelpContents | The "Help|Help Contents..." command. (Inherited from Designer.)
cmdInsert | The "Insert" command. (Inherited from Designer.)
cmdInsertBand | The "Insert Band" command. (Inherited from Designer.)
cmdNew | The "File|New" command. (Inherited from Designer.)
cmdNewDialog | The "New Dialog" toolbar command. (Inherited from Designer.)
cmdNewPage | The "New Page" toolbar command. (Inherited from Designer.)
cmdOpen | The "File|Open..." command. (Inherited from Designer.)
cmdOptions | The "View|Options..." command. (Inherited from Designer.)
cmdPageSetup | The "File|Page Setup..." command. (Inherited from Designer.)
cmdPaste | The "Edit|Paste" command. (Inherited from Designer.)
cmdPreview | The "File|Preview..." command. (Inherited from Designer.)
cmdPrinterSetup | The "File|Printer Setup..." command. (Inherited from Designer.)
cmdRecentFiles | The "Recent Files" command. (Inherited from Designer.)
cmdRedo | The "Edit|Redo" command. (Inherited from Designer.)
cmdReplace | The "Edit|Replace..." command. (Inherited from Designer.)
cmdReportSettings | The "Report|Options..." command. (Inherited from Designer.)
cmdReportStyles | The "Report|Styles..." command. (Inherited from Designer.)
cmdSave | The "File|Save" command. (Inherited from Designer.)
cmdSaveAll | The "File|Save All" command. (Inherited from Designer.)
cmdSaveAs | The "File|Save As..." command. (Inherited from Designer.)
cmdSelectAll | The "Edit|Select All" command. (Inherited from Designer.)
cmdSelectLanguage | The "File|Select Language..." command. (Inherited from Designer.)
cmdSendToBack | The "Send To Back" command. (Inherited from Designer.)
cmdUndo | The "Edit|Undo" command. (Inherited from Designer.)
cmdUngroup | The "Edit|Ungroup" command. (Inherited from Designer.)
cmdViewStartPage | The "View|Start Page" command. (Inherited from Designer.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsPreviewPageDesigner | Gets a value indicating that designer is used to edit a preview page. (Inherited from Designer.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutState | Gets or sets the layout state of the designer. (Inherited from Designer.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
MainMenu | Gets the main menu.
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MdiMode | Gets or sets a value indicating that designer is run in MDI mode. (Inherited from Designer.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Modified | Gets or sets a value indicating that the report was modified. (Inherited from Designer.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Objects | Gets a collection of objects on the active page of the active report. (Inherited from Designer.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Plugins | Gets a collection of global plugins such as menu, properties window, etc. (Inherited from Designer.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets or sets the edited report. (Inherited from Designer.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Restrictions | Gets the designer restrictions. (Inherited from Designer.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedComponents | Gets a collection of selected objects of the ComponentBase type. (Inherited from Designer.)
SelectedObjects | Gets a collection of selected objects on the active page of the active report. (Inherited from Designer.)
SelectedReportComponents | Gets a collection of selected objects of the ReportComponentBase type. (Inherited from Designer.)
SelectedTextObjects | Gets a collection of selected objects of the TextObject type. (Inherited from Designer.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowMainMenu | Gets or sets a value indicating whether the main menu should be displayed or not.
ShowStatusBar | Gets or sets a value indicating whether the status bar should be displayed or not.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UIStyle | Gets or sets the visual style. (Inherited from Designer.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


MainMenu Property

[image]

FastReport.Net Class Reference
DesignerControl..::.MainMenu Property
DesignerControl Class See Also Send Feedback
Gets the main menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerMenu MainMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property MainMenu As DesignerMenu
Visual C++
public:
property DesignerMenu^ MainMenu {
    DesignerMenu^ get ();
}

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


ShowMainMenu Property

[image]

FastReport.Net Class Reference
DesignerControl..::.ShowMainMenu Property
DesignerControl Class See Also Send Feedback
Gets or sets a value indicating whether the main menu should be displayed or not.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowMainMenu { get; set; }
Visual Basic (Declaration)
Public Property ShowMainMenu As Boolean
Visual C++
public:
property bool ShowMainMenu {
    bool get ();
    void set (bool value);
}

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


ShowStatusBar Property

[image]

FastReport.Net Class Reference
DesignerControl..::.ShowStatusBar Property
DesignerControl Class See Also Send Feedback
Gets or sets a value indicating whether the status bar should be displayed or not.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowStatusBar { get; set; }
Visual Basic (Declaration)
Public Property ShowStatusBar As Boolean
Visual C++
public:
property bool ShowStatusBar {
    bool get ();
    void set (bool value);
}

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


DesignerControl Events

[image] [image]

FastReport.Net Class Reference
DesignerControl Events
DesignerControl Class See Also Send Feedback

The DesignerControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutChangedEvent | Fires when the layout is changed. (Inherited from Designer.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
UIStateChanged | Occurs when designer's UI state changed. (Inherited from Designer.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerControl Class
FastReport.Design.StandardDesigner Namespace


DesignerForm Class

[image]

FastReport.Net Class Reference
DesignerForm Class
Members See Also Send Feedback
Represents standard designer's form.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerForm : Form
Visual Basic (Declaration)
Public Class DesignerForm _
    Inherits Form
Visual C++
public ref class DesignerForm : public Form

Remarks

This form contains the DesignerControl. Use the Designer property to get access to this control.

Usually you don't need to create an instance of this class. The designer can be called using the Design()()() method of the Report instance.

If you decided to use this class, you need:

  • create an instance of this class;
  • set the Designer.Report property to report that you need to design;
  • call either ShowModal or Show methods to display a form.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Design.StandardDesigner..::.DesignerForm

See Also

DesignerForm Members
FastReport.Design.StandardDesigner Namespace


DesignerForm Members

[image] [image]

FastReport.Net Class Reference
DesignerForm Members
DesignerForm Class Constructors Methods Properties Events See Also Send Feedback

The DesignerForm type exposes the following members.

Constructors

Name | Description
DesignerForm | Creates a new instance of the DesignerForm class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
Designer | Gets a reference to the DesignerControl control which is actually a designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerForm Class
FastReport.Design.StandardDesigner Namespace


DesignerForm Constructor

[image]

FastReport.Net Class Reference
DesignerForm Constructor
DesignerForm Class See Also Send Feedback
Creates a new instance of the DesignerForm class with default settings.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerForm()

See Also

DesignerForm Class
FastReport.Design.StandardDesigner Namespace


DesignerForm Methods

[image] [image]

FastReport.Net Class Reference
DesignerForm Methods
DesignerForm Class See Also Send Feedback

The DesignerForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

DesignerForm Class
FastReport.Design.StandardDesigner Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.AccessibilityNotifyClients Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.BeginInvoke Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Dispose Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DesignerForm..::.Dispose Method (Boolean)
DesignerForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DesignerForm Class
Dispose Overload
FastReport.Design.StandardDesigner Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.GetChildAtPoint Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Invalidate Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Invoke Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.MemberwiseClone Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.PerformLayout Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.ResumeLayout Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.RtlTranslateAlignment Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Scale Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Select Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.SetBounds Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Show Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.ShowDialog Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.UpdateBounds Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.Validate Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
DesignerForm..::.ValidateChildren Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
FastReport.Design.StandardDesigner Namespace


DesignerForm Properties

[image] [image]

FastReport.Net Class Reference
DesignerForm Properties
DesignerForm Class See Also Send Feedback

The DesignerForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
Designer | Gets a reference to the DesignerControl control which is actually a designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerForm Class
FastReport.Design.StandardDesigner Namespace


Designer Property

[image]

FastReport.Net Class Reference
DesignerForm..::.Designer Property
DesignerForm Class See Also Send Feedback
Gets a reference to the DesignerControl control which is actually a designer.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerControl Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As DesignerControl
Visual C++
public:
property DesignerControl^ Designer {
    DesignerControl^ get ();
}

See Also

DesignerForm Class
FastReport.Design.StandardDesigner Namespace


DesignerForm Events

[image] [image]

FastReport.Net Class Reference
DesignerForm Events
DesignerForm Class See Also Send Feedback

The DesignerForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerForm Class
FastReport.Design.StandardDesigner Namespace


DesignerMenu Class

[image]

FastReport.Net Class Reference
DesignerMenu Class
Members See Also Send Feedback
Represents the designer's main menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerMenu : Bar,
    IDesignerPlugin
Visual Basic (Declaration)
Public Class DesignerMenu _
    Inherits Bar _
    Implements IDesignerPlugin
Visual C++
public ref class DesignerMenu : public Bar,
    IDesignerPlugin

Remarks

To get this menu, use the following code:
CopyC#
Designer designer;
DesignerMenu menu = designer.Plugins.FindType("DesignerMenu") as DesignerMenu;

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
FastReport.Design.StandardDesigner..::.DesignerMenu

See Also

DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


DesignerMenu Members

[image] [image]

FastReport.Net Class Reference
DesignerMenu Members
DesignerMenu Class Constructors Methods Fields Properties Events See Also Send Feedback

The DesignerMenu type exposes the following members.

Constructors

Name | Description
DesignerMenu | Initializes a new instance of the DesignerMenu class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from Bar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreState | Restores the plugin state.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
SaveState | Saves the plugin state.
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectionChanged | Updates plugin state when current selection was changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Unlock | Unlocks the plugin.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateContent | Updates plugin state when the report was modified.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateUIStyle | Updates UI style of the plugin.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miData | The "Data" menu.
miDataAdd | The "Data|Add Data Source..." menu.
miDataChoose | The "Data|Choose Report Data..." menu.
miDataShowData | The "Data|Show Data Dictionary" menu.
miEdit | The "Edit" menu.
miEditCopy | The "Edit|Copy" menu.
miEditCut | The "Edit|Cut" menu.
miEditDelete | The "Edit|Delete" menu.
miEditDeletePage | The "Edit|Delete Page" menu.
miEditFind | The "Edit|Find..." menu.
miEditGroup | The "Edit|Group" menu.
miEditPaste | The "Edit|Paste" menu.
miEditRedo | The "Edit|Redo" menu.
miEditReplace | The "Edit|Replace..." menu.
miEditSelectAll | The "Edit|Select All" menu.
miEditUndo | The "Edit|Undo" menu.
miEditUngroup | The "Edit|Ungroup" menu.
miFile | The "File" menu.
miFileClose | The "File|Close" menu.
miFileExit | The "File|Exit" menu.
miFileNew | The "File|New..." menu.
miFileOpen | The "File|Open..." menu.
miFilePageSetup | The "File|Page Setup..." menu.
miFilePreview | The "File|Preview..." menu.
miFilePrinterSetup | The "File|Printer Setup..." menu.
miFileSave | The "File|Save" menu.
miFileSaveAll | The "File|Save All" menu.
miFileSaveAs | The "File|Save as..." menu.
miFileSelectLanguage | The "File|Select Language" menu.
miHelp | The "Help" menu.
miHelpAbout | The "Help|About..." menu.
miHelpContents | The "Help|Help Contents..." menu.
miInsert | The "Insert" menu.
miReport | The "Report" menu.
miReportOptions | The "Report|Options..." menu.
miView | The "View" menu.
miViewOptions | The "View|Options..." menu.
miViewStartPage | The "View|Start Page" menu.
miViewToolbars | The "View|Toolbars" menu.
miWindow | The "Window" menu.
miWindowCloseAll | The "Window|Close All" menu.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | (Inherited from Bar.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PluginName | Gets the plugin name.
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from Bar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


DesignerMenu Constructor

[image]

FastReport.Net Class Reference
DesignerMenu Constructor
DesignerMenu Class See Also Send Feedback
Initializes a new instance of the DesignerMenu class with default settings.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerMenu(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
DesignerMenu(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


DesignerMenu Fields

[image] [image]

FastReport.Net Class Reference
DesignerMenu Fields
DesignerMenu Class See Also Send Feedback

The DesignerMenu type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)
miData | The "Data" menu.
miDataAdd | The "Data|Add Data Source..." menu.
miDataChoose | The "Data|Choose Report Data..." menu.
miDataShowData | The "Data|Show Data Dictionary" menu.
miEdit | The "Edit" menu.
miEditCopy | The "Edit|Copy" menu.
miEditCut | The "Edit|Cut" menu.
miEditDelete | The "Edit|Delete" menu.
miEditDeletePage | The "Edit|Delete Page" menu.
miEditFind | The "Edit|Find..." menu.
miEditGroup | The "Edit|Group" menu.
miEditPaste | The "Edit|Paste" menu.
miEditRedo | The "Edit|Redo" menu.
miEditReplace | The "Edit|Replace..." menu.
miEditSelectAll | The "Edit|Select All" menu.
miEditUndo | The "Edit|Undo" menu.
miEditUngroup | The "Edit|Ungroup" menu.
miFile | The "File" menu.
miFileClose | The "File|Close" menu.
miFileExit | The "File|Exit" menu.
miFileNew | The "File|New..." menu.
miFileOpen | The "File|Open..." menu.
miFilePageSetup | The "File|Page Setup..." menu.
miFilePreview | The "File|Preview..." menu.
miFilePrinterSetup | The "File|Printer Setup..." menu.
miFileSave | The "File|Save" menu.
miFileSaveAll | The "File|Save All" menu.
miFileSaveAs | The "File|Save as..." menu.
miFileSelectLanguage | The "File|Select Language" menu.
miHelp | The "Help" menu.
miHelpAbout | The "Help|About..." menu.
miHelpContents | The "Help|Help Contents..." menu.
miInsert | The "Insert" menu.
miReport | The "Report" menu.
miReportOptions | The "Report|Options..." menu.
miView | The "View" menu.
miViewOptions | The "View|Options..." menu.
miViewStartPage | The "View|Start Page" menu.
miViewToolbars | The "View|Toolbars" menu.
miWindow | The "Window" menu.
miWindowCloseAll | The "Window|Close All" menu.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miData Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miData Field
DesignerMenu Class See Also Send Feedback
The "Data" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miData
Visual Basic (Declaration)
Public miData As ButtonItem
Visual C++
public:
ButtonItem^ miData

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miDataAdd Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miDataAdd Field
DesignerMenu Class See Also Send Feedback
The "Data|Add Data Source..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miDataAdd
Visual Basic (Declaration)
Public miDataAdd As ButtonItem
Visual C++
public:
ButtonItem^ miDataAdd

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miDataChoose Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miDataChoose Field
DesignerMenu Class See Also Send Feedback
The "Data|Choose Report Data..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miDataChoose
Visual Basic (Declaration)
Public miDataChoose As ButtonItem
Visual C++
public:
ButtonItem^ miDataChoose

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miDataShowData Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miDataShowData Field
DesignerMenu Class See Also Send Feedback
The "Data|Show Data Dictionary" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miDataShowData
Visual Basic (Declaration)
Public miDataShowData As ButtonItem
Visual C++
public:
ButtonItem^ miDataShowData

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEdit Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEdit Field
DesignerMenu Class See Also Send Feedback
The "Edit" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEdit
Visual Basic (Declaration)
Public miEdit As ButtonItem
Visual C++
public:
ButtonItem^ miEdit

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditCopy Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditCopy Field
DesignerMenu Class See Also Send Feedback
The "Edit|Copy" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditCopy
Visual Basic (Declaration)
Public miEditCopy As ButtonItem
Visual C++
public:
ButtonItem^ miEditCopy

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditCut Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditCut Field
DesignerMenu Class See Also Send Feedback
The "Edit|Cut" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditCut
Visual Basic (Declaration)
Public miEditCut As ButtonItem
Visual C++
public:
ButtonItem^ miEditCut

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditDelete Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditDelete Field
DesignerMenu Class See Also Send Feedback
The "Edit|Delete" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditDelete
Visual Basic (Declaration)
Public miEditDelete As ButtonItem
Visual C++
public:
ButtonItem^ miEditDelete

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditDeletePage Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditDeletePage Field
DesignerMenu Class See Also Send Feedback
The "Edit|Delete Page" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditDeletePage
Visual Basic (Declaration)
Public miEditDeletePage As ButtonItem
Visual C++
public:
ButtonItem^ miEditDeletePage

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditFind Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditFind Field
DesignerMenu Class See Also Send Feedback
The "Edit|Find..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditFind
Visual Basic (Declaration)
Public miEditFind As ButtonItem
Visual C++
public:
ButtonItem^ miEditFind

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditGroup Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditGroup Field
DesignerMenu Class See Also Send Feedback
The "Edit|Group" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditGroup
Visual Basic (Declaration)
Public miEditGroup As ButtonItem
Visual C++
public:
ButtonItem^ miEditGroup

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditPaste Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditPaste Field
DesignerMenu Class See Also Send Feedback
The "Edit|Paste" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditPaste
Visual Basic (Declaration)
Public miEditPaste As ButtonItem
Visual C++
public:
ButtonItem^ miEditPaste

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditRedo Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditRedo Field
DesignerMenu Class See Also Send Feedback
The "Edit|Redo" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditRedo
Visual Basic (Declaration)
Public miEditRedo As ButtonItem
Visual C++
public:
ButtonItem^ miEditRedo

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditReplace Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditReplace Field
DesignerMenu Class See Also Send Feedback
The "Edit|Replace..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditReplace
Visual Basic (Declaration)
Public miEditReplace As ButtonItem
Visual C++
public:
ButtonItem^ miEditReplace

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditSelectAll Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditSelectAll Field
DesignerMenu Class See Also Send Feedback
The "Edit|Select All" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditSelectAll
Visual Basic (Declaration)
Public miEditSelectAll As ButtonItem
Visual C++
public:
ButtonItem^ miEditSelectAll

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditUndo Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditUndo Field
DesignerMenu Class See Also Send Feedback
The "Edit|Undo" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditUndo
Visual Basic (Declaration)
Public miEditUndo As ButtonItem
Visual C++
public:
ButtonItem^ miEditUndo

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miEditUngroup Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miEditUngroup Field
DesignerMenu Class See Also Send Feedback
The "Edit|Ungroup" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miEditUngroup
Visual Basic (Declaration)
Public miEditUngroup As ButtonItem
Visual C++
public:
ButtonItem^ miEditUngroup

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFile Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFile Field
DesignerMenu Class See Also Send Feedback
The "File" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFile
Visual Basic (Declaration)
Public miFile As ButtonItem
Visual C++
public:
ButtonItem^ miFile

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileClose Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileClose Field
DesignerMenu Class See Also Send Feedback
The "File|Close" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileClose
Visual Basic (Declaration)
Public miFileClose As ButtonItem
Visual C++
public:
ButtonItem^ miFileClose

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileExit Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileExit Field
DesignerMenu Class See Also Send Feedback
The "File|Exit" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileExit
Visual Basic (Declaration)
Public miFileExit As ButtonItem
Visual C++
public:
ButtonItem^ miFileExit

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileNew Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileNew Field
DesignerMenu Class See Also Send Feedback
The "File|New..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileNew
Visual Basic (Declaration)
Public miFileNew As ButtonItem
Visual C++
public:
ButtonItem^ miFileNew

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileOpen Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileOpen Field
DesignerMenu Class See Also Send Feedback
The "File|Open..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileOpen
Visual Basic (Declaration)
Public miFileOpen As ButtonItem
Visual C++
public:
ButtonItem^ miFileOpen

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFilePageSetup Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFilePageSetup Field
DesignerMenu Class See Also Send Feedback
The "File|Page Setup..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFilePageSetup
Visual Basic (Declaration)
Public miFilePageSetup As ButtonItem
Visual C++
public:
ButtonItem^ miFilePageSetup

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFilePreview Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFilePreview Field
DesignerMenu Class See Also Send Feedback
The "File|Preview..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFilePreview
Visual Basic (Declaration)
Public miFilePreview As ButtonItem
Visual C++
public:
ButtonItem^ miFilePreview

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFilePrinterSetup Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFilePrinterSetup Field
DesignerMenu Class See Also Send Feedback
The "File|Printer Setup..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFilePrinterSetup
Visual Basic (Declaration)
Public miFilePrinterSetup As ButtonItem
Visual C++
public:
ButtonItem^ miFilePrinterSetup

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileSave Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileSave Field
DesignerMenu Class See Also Send Feedback
The "File|Save" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileSave
Visual Basic (Declaration)
Public miFileSave As ButtonItem
Visual C++
public:
ButtonItem^ miFileSave

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileSaveAll Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileSaveAll Field
DesignerMenu Class See Also Send Feedback
The "File|Save All" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileSaveAll
Visual Basic (Declaration)
Public miFileSaveAll As ButtonItem
Visual C++
public:
ButtonItem^ miFileSaveAll

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileSaveAs Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileSaveAs Field
DesignerMenu Class See Also Send Feedback
The "File|Save as..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileSaveAs
Visual Basic (Declaration)
Public miFileSaveAs As ButtonItem
Visual C++
public:
ButtonItem^ miFileSaveAs

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miFileSelectLanguage Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miFileSelectLanguage Field
DesignerMenu Class See Also Send Feedback
The "File|Select Language" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miFileSelectLanguage
Visual Basic (Declaration)
Public miFileSelectLanguage As ButtonItem
Visual C++
public:
ButtonItem^ miFileSelectLanguage

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miHelp Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miHelp Field
DesignerMenu Class See Also Send Feedback
The "Help" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miHelp
Visual Basic (Declaration)
Public miHelp As ButtonItem
Visual C++
public:
ButtonItem^ miHelp

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miHelpAbout Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miHelpAbout Field
DesignerMenu Class See Also Send Feedback
The "Help|About..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miHelpAbout
Visual Basic (Declaration)
Public miHelpAbout As ButtonItem
Visual C++
public:
ButtonItem^ miHelpAbout

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miHelpContents Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miHelpContents Field
DesignerMenu Class See Also Send Feedback
The "Help|Help Contents..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miHelpContents
Visual Basic (Declaration)
Public miHelpContents As ButtonItem
Visual C++
public:
ButtonItem^ miHelpContents

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miInsert Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miInsert Field
DesignerMenu Class See Also Send Feedback
The "Insert" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miInsert
Visual Basic (Declaration)
Public miInsert As ButtonItem
Visual C++
public:
ButtonItem^ miInsert

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miReport Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miReport Field
DesignerMenu Class See Also Send Feedback
The "Report" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miReport
Visual Basic (Declaration)
Public miReport As ButtonItem
Visual C++
public:
ButtonItem^ miReport

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miReportOptions Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miReportOptions Field
DesignerMenu Class See Also Send Feedback
The "Report|Options..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miReportOptions
Visual Basic (Declaration)
Public miReportOptions As ButtonItem
Visual C++
public:
ButtonItem^ miReportOptions

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miView Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miView Field
DesignerMenu Class See Also Send Feedback
The "View" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miView
Visual Basic (Declaration)
Public miView As ButtonItem
Visual C++
public:
ButtonItem^ miView

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miViewOptions Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miViewOptions Field
DesignerMenu Class See Also Send Feedback
The "View|Options..." menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miViewOptions
Visual Basic (Declaration)
Public miViewOptions As ButtonItem
Visual C++
public:
ButtonItem^ miViewOptions

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miViewStartPage Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miViewStartPage Field
DesignerMenu Class See Also Send Feedback
The "View|Start Page" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miViewStartPage
Visual Basic (Declaration)
Public miViewStartPage As ButtonItem
Visual C++
public:
ButtonItem^ miViewStartPage

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miViewToolbars Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miViewToolbars Field
DesignerMenu Class See Also Send Feedback
The "View|Toolbars" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miViewToolbars
Visual Basic (Declaration)
Public miViewToolbars As ButtonItem
Visual C++
public:
ButtonItem^ miViewToolbars

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miWindow Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miWindow Field
DesignerMenu Class See Also Send Feedback
The "Window" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miWindow
Visual Basic (Declaration)
Public miWindow As ButtonItem
Visual C++
public:
ButtonItem^ miWindow

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


miWindowCloseAll Field

[image]

FastReport.Net Class Reference
DesignerMenu..::.miWindowCloseAll Field
DesignerMenu Class See Also Send Feedback
The "Window|Close All" menu.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem miWindowCloseAll
Visual Basic (Declaration)
Public miWindowCloseAll As ButtonItem
Visual C++
public:
ButtonItem^ miWindowCloseAll

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


DesignerMenu Methods

[image] [image]

FastReport.Net Class Reference
DesignerMenu Methods
DesignerMenu Class See Also Send Feedback

The DesignerMenu type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateMenuItem | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from Bar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreState | Restores the plugin state.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
SaveState | Saves the plugin state.
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectionChanged | Updates plugin state when current selection was changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Unlock | Unlocks the plugin.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateContent | Updates plugin state when the report was modified.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateUIStyle | Updates UI style of the plugin.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.AccessibilityNotifyClients Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.BeginInvoke Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.CloseDockTab Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


CreateMenuItem Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.CreateMenuItem Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
CreateMenuItem()()() | Creates a new menu item.
CreateMenuItem(EventHandler) | Creates a new menu item.
CreateMenuItem(Image, EventHandler) | Creates a new menu item.
CreateMenuItem(String, EventHandler) | Creates a new menu item.
CreateMenuItem(Image, String, EventHandler) | Creates a new menu item.

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


CreateMenuItem Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.CreateMenuItem Method
DesignerMenu Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateMenuItem()
Visual Basic (Declaration)
Public Function CreateMenuItem As ButtonItem
Visual C++
public:
ButtonItem^ CreateMenuItem()

Return Value

New menu item.

See Also

DesignerMenu Class
CreateMenuItem Overload
FastReport.Design.StandardDesigner Namespace


CreateMenuItem Method (EventHandler)

[image]

FastReport.Net Class Reference
DesignerMenu..::.CreateMenuItem Method (EventHandler)
DesignerMenu Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateMenuItem(
    EventHandler click
)
Visual Basic (Declaration)
Public Function CreateMenuItem ( _
    click As EventHandler _
) As ButtonItem
Visual C++
public:
ButtonItem^ CreateMenuItem(
    EventHandler^ click
)

Parameters

click
Type: System..::.EventHandler
Click handler.

Return Value

New menu item.

See Also

DesignerMenu Class
CreateMenuItem Overload
FastReport.Design.StandardDesigner Namespace


CreateMenuItem Method (Image, EventHandler)

[image]

FastReport.Net Class Reference
DesignerMenu..::.CreateMenuItem Method (Image, EventHandler)
DesignerMenu Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateMenuItem(
    Image image,
    EventHandler click
)
Visual Basic (Declaration)
Public Function CreateMenuItem ( _
    image As Image, _
    click As EventHandler _
) As ButtonItem
Visual C++
public:
ButtonItem^ CreateMenuItem(
    Image^ image,
    EventHandler^ click
)

Parameters

image
Type: System.Drawing..::.Image
Item's image.
click
Type: System..::.EventHandler
Click handler.

Return Value

New menu item.

See Also

DesignerMenu Class
CreateMenuItem Overload
FastReport.Design.StandardDesigner Namespace


CreateMenuItem Method (String, EventHandler)

[image]

FastReport.Net Class Reference
DesignerMenu..::.CreateMenuItem Method (String, EventHandler)
DesignerMenu Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateMenuItem(
    string text,
    EventHandler click
)
Visual Basic (Declaration)
Public Function CreateMenuItem ( _
    text As String, _
    click As EventHandler _
) As ButtonItem
Visual C++
public:
ButtonItem^ CreateMenuItem(
    String^ text,
    EventHandler^ click
)

Parameters

text
Type: System..::.String
Item's text.
click
Type: System..::.EventHandler
Click handler.

Return Value

New menu item.

See Also

DesignerMenu Class
CreateMenuItem Overload
FastReport.Design.StandardDesigner Namespace


CreateMenuItem Method (Image, String, EventHandler)

[image]

FastReport.Net Class Reference
DesignerMenu..::.CreateMenuItem Method (Image, String, EventHandler)
DesignerMenu Class See Also Send Feedback
Creates a new menu item.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateMenuItem(
    Image image,
    string text,
    EventHandler click
)
Visual Basic (Declaration)
Public Function CreateMenuItem ( _
    image As Image, _
    text As String, _
    click As EventHandler _
) As ButtonItem
Visual C++
public:
ButtonItem^ CreateMenuItem(
    Image^ image,
    String^ text,
    EventHandler^ click
)

Parameters

image
Type: System.Drawing..::.Image
Item's image.
text
Type: System..::.String
Item's text.
click
Type: System..::.EventHandler
Click handler.

Return Value

New menu item.

See Also

DesignerMenu Class
CreateMenuItem Overload
FastReport.Design.StandardDesigner Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.Dispose Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.GetChildAtPoint Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.GetItems Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.GetOptionsPage Method
DesignerMenu Class See Also Send Feedback
Gets an options page that will be used in the Designer Options dialog to edit the plugin options.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Public Overridable Function GetOptionsPage As DesignerOptionsPage
Visual C++
public:
virtual DesignerOptionsPage^ GetOptionsPage()

Return Value

The options page, if implemented; otherwise, null.

Implements

IDesignerPlugin..::.GetOptionsPage()()()

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.Invalidate Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.Invoke Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


Localize Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.Localize Method
DesignerMenu Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Localize()
Visual Basic (Declaration)
Public Sub Localize
Visual C++
public:
virtual void Localize() sealed

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


Lock Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.Lock Method
DesignerMenu Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Lock()
Visual Basic (Declaration)
Public Sub Lock
Visual C++
public:
virtual void Lock() sealed

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.MemberwiseClone Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.PerformLayout Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.RestoreState Method
DesignerMenu Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RestoreState()
Visual Basic (Declaration)
Public Sub RestoreState
Visual C++
public:
virtual void RestoreState() sealed

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.ResumeLayout Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.RtlTranslateAlignment Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


SaveState Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.SaveState Method
DesignerMenu Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveState()
Visual Basic (Declaration)
Public Sub SaveState
Visual C++
public:
virtual void SaveState() sealed

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.Scale Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.Select Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.SelectionChanged Method
DesignerMenu Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectionChanged()
Visual Basic (Declaration)
Public Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() sealed

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.SetBounds Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.SetSize Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


Unlock Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.Unlock Method
DesignerMenu Class See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Unlock()
Visual Basic (Declaration)
Public Sub Unlock
Visual C++
public:
virtual void Unlock() sealed

Implements

IDesignerPlugin..::.Unlock()()()

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerMenu..::.UpdateBounds Method
DesignerMenu Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerMenu Class
DesignerMenu Members
FastReport.Design.StandardDesigner Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.UpdateContent Method
DesignerMenu Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateContent()
Visual Basic (Declaration)
Public Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() sealed

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
DesignerMenu..::.UpdateUIStyle Method
DesignerMenu Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateUIStyle()
Visual Basic (Declaration)
Public Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle() sealed

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


DesignerMenu Properties

[image] [image]

FastReport.Net Class Reference
DesignerMenu Properties
DesignerMenu Class See Also Send Feedback

The DesignerMenu type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | (Inherited from Bar.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PluginName | Gets the plugin name.
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from Bar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


PluginName Property

[image]

FastReport.Net Class Reference
DesignerMenu..::.PluginName Property
DesignerMenu Class See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PluginName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PluginName As String
Visual C++
public:
virtual property String^ PluginName {
    String^ get () sealed;
}

Implements

IDesignerPlugin..::.PluginName

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


DesignerMenu Events

[image] [image]

FastReport.Net Class Reference
DesignerMenu Events
DesignerMenu Class See Also Send Feedback

The DesignerMenu type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerMenu Class
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Class

[image]

FastReport.Net Class Reference
DesignerStatusBar Class
Members See Also Send Feedback
Represents the designer's statusbar.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerStatusBar : Bar,
    IDesignerPlugin
Visual Basic (Declaration)
Public Class DesignerStatusBar _
    Inherits Bar _
    Implements IDesignerPlugin
Visual C++
public ref class DesignerStatusBar : public Bar,
    IDesignerPlugin

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
FastReport.Design.StandardDesigner..::.DesignerStatusBar

See Also

DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Members

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar Members
DesignerStatusBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Constructors

Name | Description
DesignerStatusBar | Initializes a new instance of the DesignerStatusBar class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from Bar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreState | Restores the plugin state.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
SaveState | Saves the plugin state.
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectionChanged | Updates plugin state when current selection was changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Unlock | Unlocks the plugin.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateContent | Updates plugin state when the report was modified.
UpdateLocationAndSize | Updates the information about location and size.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateText | Updates the name and text information.
UpdateUIStyle | Updates UI style of the plugin.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | (Inherited from Bar.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PluginName | Gets the plugin name.
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from Bar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Constructor

[image]

FastReport.Net Class Reference
DesignerStatusBar Constructor
DesignerStatusBar Class See Also Send Feedback
Initializes a new instance of the DesignerStatusBar class with default settings.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerStatusBar(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
DesignerStatusBar(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Fields

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar Fields
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Methods

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar Methods
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from Bar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreState | Restores the plugin state.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
SaveState | Saves the plugin state.
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectionChanged | Updates plugin state when current selection was changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Unlock | Unlocks the plugin.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateContent | Updates plugin state when the report was modified.
UpdateLocationAndSize | Updates the information about location and size.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateText | Updates the name and text information.
UpdateUIStyle | Updates UI style of the plugin.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.AccessibilityNotifyClients Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.BeginInvoke Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.CloseDockTab Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.Dispose Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.GetChildAtPoint Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.GetItems Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.GetOptionsPage Method
DesignerStatusBar Class See Also Send Feedback
Gets an options page that will be used in the Designer Options dialog to edit the plugin options.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Public Function GetOptionsPage As DesignerOptionsPage
Visual C++
public:
virtual DesignerOptionsPage^ GetOptionsPage() sealed

Return Value

The options page, if implemented; otherwise, null.

Implements

IDesignerPlugin..::.GetOptionsPage()()()

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.Invalidate Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.Invoke Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


Localize Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.Localize Method
DesignerStatusBar Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Localize()
Visual Basic (Declaration)
Public Sub Localize
Visual C++
public:
virtual void Localize() sealed

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


Lock Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.Lock Method
DesignerStatusBar Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Lock()
Visual Basic (Declaration)
Public Sub Lock
Visual C++
public:
virtual void Lock() sealed

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.MemberwiseClone Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.PerformLayout Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.RestoreState Method
DesignerStatusBar Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RestoreState()
Visual Basic (Declaration)
Public Sub RestoreState
Visual C++
public:
virtual void RestoreState() sealed

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.ResumeLayout Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.RtlTranslateAlignment Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


SaveState Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.SaveState Method
DesignerStatusBar Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveState()
Visual Basic (Declaration)
Public Sub SaveState
Visual C++
public:
virtual void SaveState() sealed

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.Scale Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.Select Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.SelectionChanged Method
DesignerStatusBar Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SelectionChanged()
Visual Basic (Declaration)
Public Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() sealed

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.SetBounds Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.SetSize Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


Unlock Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.Unlock Method
DesignerStatusBar Class See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Unlock()
Visual Basic (Declaration)
Public Sub Unlock
Visual C++
public:
virtual void Unlock() sealed

Implements

IDesignerPlugin..::.Unlock()()()

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar..::.UpdateBounds Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
FastReport.Design.StandardDesigner Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.UpdateContent Method
DesignerStatusBar Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateContent()
Visual Basic (Declaration)
Public Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() sealed

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


UpdateLocationAndSize Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.UpdateLocationAndSize Method
DesignerStatusBar Class See Also Send Feedback
Updates the information about location and size.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLocationAndSize(
    string location,
    string size
)
Visual Basic (Declaration)
Public Sub UpdateLocationAndSize ( _
    location As String, _
    size As String _
)
Visual C++
public:
void UpdateLocationAndSize(
    String^ location,
    String^ size
)

Parameters

location
Type: System..::.String
The location.
size
Type: System..::.String
The size.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


UpdateText Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.UpdateText Method
DesignerStatusBar Class See Also Send Feedback
Updates the name and text information.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateText(
    string s
)
Visual Basic (Declaration)
Public Sub UpdateText ( _
    s As String _
)
Visual C++
public:
void UpdateText(
    String^ s
)

Parameters

s
Type: System..::.String
The text.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.UpdateUIStyle Method
DesignerStatusBar Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateUIStyle()
Visual Basic (Declaration)
Public Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle() sealed

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Properties

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar Properties
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | (Inherited from Bar.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PluginName | Gets the plugin name.
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from Bar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


PluginName Property

[image]

FastReport.Net Class Reference
DesignerStatusBar..::.PluginName Property
DesignerStatusBar Class See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PluginName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PluginName As String
Visual C++
public:
virtual property String^ PluginName {
    String^ get () sealed;
}

Implements

IDesignerPlugin..::.PluginName

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


DesignerStatusBar Events

[image] [image]

FastReport.Net Class Reference
DesignerStatusBar Events
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerStatusBar Class
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Class

[image]

FastReport.Net Class Reference
Office2007DesignerForm Class
Members See Also Send Feedback
Represents designer's form in Office 2007 style.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Office2007DesignerForm : Office2007Form
Visual Basic (Declaration)
Public Class Office2007DesignerForm _
    Inherits Office2007Form
Visual C++
public ref class Office2007DesignerForm : public Office2007Form

Remarks

This form contains the DesignerControl. Use the Designer property to get access to this control.

Usually you don't need to create an instance of this class. The designer can be called using the Design()()() method of the Report instance.

If you decided to use this class, you need:

  • create an instance of this class;
  • set the Designer.Report property to report that you need to design;
  • call either ShowModal or Show methods to display a form.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
Office2007RibbonForm
Office2007Form
FastReport.Design.StandardDesigner..::.Office2007DesignerForm

See Also

Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Members

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm Members
Office2007DesignerForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The Office2007DesignerForm type exposes the following members.

Constructors

Name | Description
Office2007DesignerForm | Creates a new instance of the DesignerForm class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustBounds | Overloaded.
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BaseWndProc | (Inherited from Office2007RibbonForm.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetBorderColors | (Inherited from Office2007RibbonForm.)
GetChildAtPoint | Overloaded.
GetClientRectangle | (Inherited from Office2007Form.)
GetColorScheme | (Inherited from Office2007Form.)
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetFormPath | (Inherited from Office2007Form.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRegion | (Inherited from Office2007RibbonForm.)
GetRenderer | (Inherited from Office2007Form.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
InvalidateNonClient | (Inherited from Office2007Form.)
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsCustomFormStyleEnabled | (Inherited from Office2007Form.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | (Inherited from Office2007RibbonForm.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Office2007RibbonForm.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | (Inherited from Office2007Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | (Inherited from Office2007Form.)
OnControlRemoved | (Inherited from Office2007RibbonForm.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | (Inherited from Office2007Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnableCustomStyleChanged | (Inherited from Office2007RibbonForm.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Office2007Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Office2007Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from Office2007RibbonForm.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | (Inherited from Office2007Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Office2007RibbonForm.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | (Inherited from Office2007Form.)
OnMouseMove | (Inherited from Office2007RibbonForm.)
OnMouseUp | (Inherited from Office2007RibbonForm.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Office2007RibbonForm.)
OnPaintBackground | (Inherited from Office2007RibbonForm.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Office2007Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Office2007Form.)
OnSystemColorsChanged | (Inherited from Office2007Form.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Office2007Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Office2007Form.)
PaintCaptionParts | (Inherited from Office2007RibbonForm.)
PaintFormBorder | Overloaded.
PaintNonClientArea | (Inherited from Office2007Form.)
PaintNonClientAreaBuffered | Overloaded.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Redraw | (Inherited from Office2007RibbonForm.)
RedrawBorder | (Inherited from Office2007RibbonForm.)
ReduceDisplayRectangle | (Inherited from Office2007Form.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Office2007RibbonForm.)
SetClientSizeCore | (Inherited from Office2007RibbonForm.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateFormStyle | (Inherited from Office2007RibbonForm.)
UpdateFormText | (Inherited from Office2007Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WindowsMessageDwmCompositionChanged | (Inherited from Office2007RibbonForm.)
WindowsMessageInitMenuPopup | (Inherited from Office2007RibbonForm.)
WindowsMessageMdiRefreshMenu | (Inherited from Office2007RibbonForm.)
WindowsMessageMdiSetMenu | (Inherited from Office2007RibbonForm.)
WindowsMessageMouseActivate | (Inherited from Office2007RibbonForm.)
WindowsMessageNCActivate | (Inherited from Office2007Form.)
WindowsMessageNCCalcSize | (Inherited from Office2007Form.)
WindowsMessageNCDblClk | (Inherited from Office2007RibbonForm.)
WindowsMessageNCHitTest | (Inherited from Office2007Form.)
WindowsMessageNCLButtonDown | (Inherited from Office2007Form.)
WindowsMessageNCLButtonUp | (Inherited from Office2007Form.)
WindowsMessageNCMouseLeave | (Inherited from Office2007Form.)
WindowsMessageNCMouseMove | (Inherited from Office2007Form.)
WindowsMessageNCPaint | (Inherited from Office2007Form.)
WindowsMessageSetCursor | (Inherited from Office2007RibbonForm.)
WindowsMessageSetIcon | (Inherited from Office2007Form.)
WindowsMessageSetText | (Inherited from Office2007RibbonForm.)
WindowsMessageStyleChanged | (Inherited from Office2007RibbonForm.)
WindowsMessageWindowsPosChanged | (Inherited from Office2007RibbonForm.)
WndProc | (Inherited from Office2007RibbonForm.)

Fields

Name | Description
m_DisplayRectangleReductionBottom | (Inherited from Office2007RibbonForm.)
m_DisplayRectangleReductionHorizontal | (Inherited from Office2007RibbonForm.)
m_DisplayRectangleReductionTop | (Inherited from Office2007RibbonForm.)
m_EnableCustomStyle | (Inherited from Office2007RibbonForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | (Inherited from Office2007Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
BottomLeftCornerSize | (Inherited from Office2007RibbonForm.)
BottomRightCornerSize | (Inherited from Office2007RibbonForm.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CaptionAntiAlias | (Inherited from Office2007Form.)
CaptionFont | (Inherited from Office2007Form.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseEnabled | (Inherited from Office2007Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
Designer | Gets a reference to the DesignerControl control which is actually a designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | (Inherited from Office2007RibbonForm.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
EnableCustomStyle | (Inherited from Office2007RibbonForm.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnableGlass | (Inherited from Office2007RibbonForm.)
EnableGlassExtend | (Inherited from Office2007Form.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlattenMDIBorder | (Inherited from Office2007RibbonForm.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
HasCustomRegion | (Inherited from Office2007RibbonForm.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | (Inherited from Office2007Form.)
IconTooltip | (Inherited from Office2007Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
IsSizable | (Inherited from Office2007RibbonForm.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Office2007ColorTable | (Inherited from Office2007Form.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PaintClientBorder | (Inherited from Office2007Form.)
PaintRibbonCaption | (Inherited from Office2007Form.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Office2007Form.)
RenderMode | (Inherited from Office2007Form.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
RibbonControl | (Inherited from Office2007RibbonForm.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
TitleText | (Inherited from Office2007Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLeftCornerSize | (Inherited from Office2007RibbonForm.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TopRightCornerSize | (Inherited from Office2007RibbonForm.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | (Inherited from Office2007RibbonForm.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Constructor

[image]

FastReport.Net Class Reference
Office2007DesignerForm Constructor
Office2007DesignerForm Class See Also Send Feedback
Creates a new instance of the DesignerForm class with default settings.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Office2007DesignerForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Office2007DesignerForm()

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Fields

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm Fields
Office2007DesignerForm Class See Also Send Feedback

The Office2007DesignerForm type exposes the following members.

Fields

Name | Description
m_DisplayRectangleReductionBottom | (Inherited from Office2007RibbonForm.)
m_DisplayRectangleReductionHorizontal | (Inherited from Office2007RibbonForm.)
m_DisplayRectangleReductionTop | (Inherited from Office2007RibbonForm.)
m_EnableCustomStyle | (Inherited from Office2007RibbonForm.)

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Methods

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm Methods
Office2007DesignerForm Class See Also Send Feedback

The Office2007DesignerForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustBounds | Overloaded.
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BaseWndProc | (Inherited from Office2007RibbonForm.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetBorderColors | (Inherited from Office2007RibbonForm.)
GetChildAtPoint | Overloaded.
GetClientRectangle | (Inherited from Office2007Form.)
GetColorScheme | (Inherited from Office2007Form.)
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetFormPath | (Inherited from Office2007Form.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRegion | (Inherited from Office2007RibbonForm.)
GetRenderer | (Inherited from Office2007Form.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
InvalidateNonClient | (Inherited from Office2007Form.)
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsCustomFormStyleEnabled | (Inherited from Office2007Form.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | (Inherited from Office2007RibbonForm.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Office2007RibbonForm.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | (Inherited from Office2007Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | (Inherited from Office2007Form.)
OnControlRemoved | (Inherited from Office2007RibbonForm.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | (Inherited from Office2007Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnableCustomStyleChanged | (Inherited from Office2007RibbonForm.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Office2007Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Office2007Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from Office2007RibbonForm.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | (Inherited from Office2007Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Office2007RibbonForm.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | (Inherited from Office2007Form.)
OnMouseMove | (Inherited from Office2007RibbonForm.)
OnMouseUp | (Inherited from Office2007RibbonForm.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Office2007RibbonForm.)
OnPaintBackground | (Inherited from Office2007RibbonForm.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Office2007Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Office2007Form.)
OnSystemColorsChanged | (Inherited from Office2007Form.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Office2007Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Office2007Form.)
PaintCaptionParts | (Inherited from Office2007RibbonForm.)
PaintFormBorder | Overloaded.
PaintNonClientArea | (Inherited from Office2007Form.)
PaintNonClientAreaBuffered | Overloaded.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Redraw | (Inherited from Office2007RibbonForm.)
RedrawBorder | (Inherited from Office2007RibbonForm.)
ReduceDisplayRectangle | (Inherited from Office2007Form.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Office2007RibbonForm.)
SetClientSizeCore | (Inherited from Office2007RibbonForm.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateFormStyle | (Inherited from Office2007RibbonForm.)
UpdateFormText | (Inherited from Office2007Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WindowsMessageDwmCompositionChanged | (Inherited from Office2007RibbonForm.)
WindowsMessageInitMenuPopup | (Inherited from Office2007RibbonForm.)
WindowsMessageMdiRefreshMenu | (Inherited from Office2007RibbonForm.)
WindowsMessageMdiSetMenu | (Inherited from Office2007RibbonForm.)
WindowsMessageMouseActivate | (Inherited from Office2007RibbonForm.)
WindowsMessageNCActivate | (Inherited from Office2007Form.)
WindowsMessageNCCalcSize | (Inherited from Office2007Form.)
WindowsMessageNCDblClk | (Inherited from Office2007RibbonForm.)
WindowsMessageNCHitTest | (Inherited from Office2007Form.)
WindowsMessageNCLButtonDown | (Inherited from Office2007Form.)
WindowsMessageNCLButtonUp | (Inherited from Office2007Form.)
WindowsMessageNCMouseLeave | (Inherited from Office2007Form.)
WindowsMessageNCMouseMove | (Inherited from Office2007Form.)
WindowsMessageNCPaint | (Inherited from Office2007Form.)
WindowsMessageSetCursor | (Inherited from Office2007RibbonForm.)
WindowsMessageSetIcon | (Inherited from Office2007Form.)
WindowsMessageSetText | (Inherited from Office2007RibbonForm.)
WindowsMessageStyleChanged | (Inherited from Office2007RibbonForm.)
WindowsMessageWindowsPosChanged | (Inherited from Office2007RibbonForm.)
WndProc | (Inherited from Office2007RibbonForm.)

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.AccessibilityNotifyClients Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


AdjustBounds Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.AdjustBounds Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
AdjustBounds(Int32%, Int32%) | (Inherited from Office2007RibbonForm.)
AdjustBounds(Int32%, Int32%, BoundsSpecified) | (Inherited from Office2007Form.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.BeginInvoke Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Dispose Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Office2007RibbonFormDispose(Boolean).)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Dispose Method (Boolean)
Office2007DesignerForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

Office2007DesignerForm Class
Dispose Overload
FastReport.Design.StandardDesigner Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.GetChildAtPoint Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Invalidate Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Invoke Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.MemberwiseClone Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


PaintFormBorder Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.PaintFormBorder Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
PaintFormBorder(PaintEventArgs) | (Inherited from Office2007RibbonForm.)
PaintFormBorder(Graphics, Int32) | (Inherited from Office2007RibbonForm.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


PaintNonClientAreaBuffered Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.PaintNonClientAreaBuffered Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
PaintNonClientAreaBuffered()()() | (Inherited from Office2007Form.)
PaintNonClientAreaBuffered(Graphics) | (Inherited from Office2007Form.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.PerformLayout Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.ResumeLayout Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.RtlTranslateAlignment Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Scale Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Select Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.SetBounds Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Show Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.ShowDialog Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.UpdateBounds Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Validate Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm..::.ValidateChildren Method
Office2007DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

Office2007DesignerForm Class
Office2007DesignerForm Members
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Properties

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm Properties
Office2007DesignerForm Class See Also Send Feedback

The Office2007DesignerForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | (Inherited from Office2007Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
BottomLeftCornerSize | (Inherited from Office2007RibbonForm.)
BottomRightCornerSize | (Inherited from Office2007RibbonForm.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CaptionAntiAlias | (Inherited from Office2007Form.)
CaptionFont | (Inherited from Office2007Form.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseEnabled | (Inherited from Office2007Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
Designer | Gets a reference to the DesignerControl control which is actually a designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | (Inherited from Office2007RibbonForm.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
EnableCustomStyle | (Inherited from Office2007RibbonForm.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnableGlass | (Inherited from Office2007RibbonForm.)
EnableGlassExtend | (Inherited from Office2007Form.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlattenMDIBorder | (Inherited from Office2007RibbonForm.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
HasCustomRegion | (Inherited from Office2007RibbonForm.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | (Inherited from Office2007Form.)
IconTooltip | (Inherited from Office2007Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
IsSizable | (Inherited from Office2007RibbonForm.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Office2007ColorTable | (Inherited from Office2007Form.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PaintClientBorder | (Inherited from Office2007Form.)
PaintRibbonCaption | (Inherited from Office2007Form.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Office2007Form.)
RenderMode | (Inherited from Office2007Form.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
RibbonControl | (Inherited from Office2007RibbonForm.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
TitleText | (Inherited from Office2007Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLeftCornerSize | (Inherited from Office2007RibbonForm.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TopRightCornerSize | (Inherited from Office2007RibbonForm.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | (Inherited from Office2007RibbonForm.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


Designer Property

[image]

FastReport.Net Class Reference
Office2007DesignerForm..::.Designer Property
Office2007DesignerForm Class See Also Send Feedback
Gets a reference to the DesignerControl control which is actually a designer.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerControl Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As DesignerControl
Visual C++
public:
property DesignerControl^ Designer {
    DesignerControl^ get ();
}

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


Office2007DesignerForm Events

[image] [image]

FastReport.Net Class Reference
Office2007DesignerForm Events
Office2007DesignerForm Class See Also Send Feedback

The Office2007DesignerForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Office2007DesignerForm Class
FastReport.Design.StandardDesigner Namespace


ToolbarBase Class

[image]

FastReport.Net Class Reference
ToolbarBase Class
Members See Also Send Feedback
Base class for all designer toolbars.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ToolbarBase : Bar,
    IDesignerPlugin
Visual Basic (Declaration)
Public Class ToolbarBase _
    Inherits Bar _
    Implements IDesignerPlugin
Visual C++
public ref class ToolbarBase : public Bar,
    IDesignerPlugin

Remarks

Use this class to write own designer's toolbar. To do this:

- in the constructor, set the Name property and create toolbar buttons. The Name will be used to restore toolbar's state;

- override the SelectionChanged method. This method is called when current selection is changed. In this method, you should update buttons state to reflect the current selection. Selected objects can be accessed via Designer.SelectedObjects property;

- override the UpdateContent method. This method is called when the report content was changed. Typically you need to do the same actions in SelectionChanged and UpdateContent methods;

- to register a toolbar, add its type to the DesignerPlugins global collection:

CopyC#
DesignerPlugins.Add(typeof(MyToolbar));

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Bar
FastReport.Design.StandardDesigner..::.ToolbarBase

See Also

ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


ToolbarBase Members

[image] [image]

FastReport.Net Class Reference
ToolbarBase Members
ToolbarBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToolbarBase type exposes the following members.

Constructors

Name | Description
ToolbarBase | Initializes a new instance of the ToolbarBase class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateButton | Overloaded.
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from Bar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreState | Restores the plugin state.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
SaveState | Saves the plugin state.
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectionChanged | Updates plugin state when current selection was changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Unlock | Unlocks the plugin.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateContent | Updates plugin state when the report was modified.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateUIStyle | Updates UI style of the plugin.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | Gets the report designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | (Inherited from Bar.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PluginName | Gets the plugin name.
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from Bar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


ToolbarBase Constructor

[image]

FastReport.Net Class Reference
ToolbarBase Constructor
ToolbarBase Class See Also Send Feedback
Initializes a new instance of the ToolbarBase class with default settings.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarBase(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ToolbarBase(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

Remarks

You don't need to call this constructor. The designer will do this automatically.

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


ToolbarBase Fields

[image] [image]

FastReport.Net Class Reference
ToolbarBase Fields
ToolbarBase Class See Also Send Feedback

The ToolbarBase type exposes the following members.

Fields

Name | Description
m_ToolTipWnd | (Inherited from Bar.)

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


ToolbarBase Methods

[image] [image]

FastReport.Net Class Reference
ToolbarBase Methods
ToolbarBase Class See Also Send Feedback

The ToolbarBase type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInit | (Inherited from Bar.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CloseDockTab | Overloaded.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Bar.)
CreateButton | Overloaded.
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | (Inherited from Bar.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInit | (Inherited from Bar.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoHidePanel | (Inherited from Bar.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItem | (Inherited from Bar.)
GetItems | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetOptionsPage | Gets an options page that will be used in the Designer Options dialog to edit the plugin options.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRenderer | (Inherited from Bar.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from Bar.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSysKeyDown | (Inherited from Bar.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeCaptionButtonClick | (Inherited from Bar.)
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsContextPopup | (Inherited from Bar.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from Bar.)
LoadDefinition | (Inherited from Bar.)
LoadLayout | (Inherited from Bar.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Overloaded.
MinimumDockSize | (Inherited from Bar.)
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from Bar.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | (Inherited from Bar.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | (Inherited from Bar.)
OnDoubleClick | (Inherited from Bar.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | (Inherited from Bar.)
OnFontChanged | (Inherited from Bar.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | (Inherited from Bar.)
OnHandleCreated | (Inherited from Bar.)
OnHandleDestroyed | (Inherited from Bar.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemClick | (Inherited from Bar.)
OnKeyDown | (Inherited from Bar.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | (Inherited from Bar.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | (Inherited from Bar.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from Bar.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | (Inherited from Bar.)
OnMouseLeave | (Inherited from Bar.)
OnMouseMove | (Inherited from Bar.)
OnMouseUp | (Inherited from Bar.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | (Inherited from Bar.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Bar.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPostRender | (Inherited from Bar.)
OnPreRender | (Inherited from Bar.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Bar.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Bar.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Bar.)
PaintDotNet | (Inherited from Bar.)
PaintOffice | (Inherited from Bar.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredDockSize | (Inherited from Bar.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecalcLayout | (Inherited from Bar.)
RecalcSize | (Inherited from Bar.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
ReDock | (Inherited from Bar.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ReleaseFocus | (Inherited from Bar.)
ResetBackColor | (Inherited from Bar.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetColorScheme | (Inherited from Bar.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | (Inherited from Bar.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
RestoreState | Restores the plugin state.
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDefinition | (Inherited from Bar.)
SaveLayout | (Inherited from Bar.)
SaveState | Saves the plugin state.
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectionChanged | Updates plugin state when current selection was changed.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDesignMode | (Inherited from Bar.)
SetDockLine | (Inherited from Bar.)
SetSize | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
ShouldSerializeBackColor | (Inherited from Bar.)
ShouldSerializeBackgroundImageAlpha | (Inherited from Bar.)
ShouldSerializeColorScheme | (Inherited from Bar.)
ShouldSerializeDockSide | (Inherited from Bar.)
ShouldSerializeFont | (Inherited from Bar.)
ShouldSerializeSingleLineColor | (Inherited from Bar.)
ShouldSerializeSize | (Inherited from Bar.)
Show | (Inherited from Bar.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | (Inherited from Bar.)
ToString | (Inherited from Bar.)
Unlock | Unlocks the plugin.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateContent | Updates plugin state when the report was modified.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateUIStyle | Updates UI style of the plugin.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Bar.)

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.AccessibilityNotifyClients Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.BeginInvoke Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


CloseDockTab Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.CloseDockTab Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
CloseDockTab(DockContainerItem) | (Inherited from Bar.)
CloseDockTab(DockContainerItem, eEventSource) | (Inherited from Bar.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


CreateButton Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.CreateButton Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
CreateButton(String, Image, EventHandler) | Creates a new button.
CreateButton(String, Image, String, EventHandler) | Creates a new button.

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


CreateButton Method (String, Image, EventHandler)

[image]

FastReport.Net Class Reference
ToolbarBase..::.CreateButton Method (String, Image, EventHandler)
ToolbarBase Class See Also Send Feedback
Creates a new button.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateButton(
    string name,
    Image image,
    EventHandler click
)
Visual Basic (Declaration)
Public Function CreateButton ( _
    name As String, _
    image As Image, _
    click As EventHandler _
) As ButtonItem
Visual C++
public:
ButtonItem^ CreateButton(
    String^ name,
    Image^ image,
    EventHandler^ click
)

Parameters

name
Type: System..::.String
Button's name.
image
Type: System.Drawing..::.Image
Button's image.
click
Type: System..::.EventHandler
Click handler.

Return Value

New button.

See Also

ToolbarBase Class
CreateButton Overload
FastReport.Design.StandardDesigner Namespace


CreateButton Method (String, Image, String, EventHandler)

[image]

FastReport.Net Class Reference
ToolbarBase..::.CreateButton Method (String, Image, String, EventHandler)
ToolbarBase Class See Also Send Feedback
Creates a new button.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonItem CreateButton(
    string name,
    Image image,
    string tooltip,
    EventHandler click
)
Visual Basic (Declaration)
Public Function CreateButton ( _
    name As String, _
    image As Image, _
    tooltip As String, _
    click As EventHandler _
) As ButtonItem
Visual C++
public:
ButtonItem^ CreateButton(
    String^ name,
    Image^ image,
    String^ tooltip,
    EventHandler^ click
)

Parameters

name
Type: System..::.String
Button's name.
image
Type: System.Drawing..::.Image
Button's image.
tooltip
Type: System..::.String
Button's tooltip text.
click
Type: System..::.EventHandler
Click handler.

Return Value

New button.

See Also

ToolbarBase Class
CreateButton Overload
FastReport.Design.StandardDesigner Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.Dispose Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Bar.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.GetChildAtPoint Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


GetItems Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.GetItems Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
GetItems(String) | (Inherited from Bar.)
GetItems(String, Type) | (Inherited from Bar.)
GetItems(String, Type, Boolean) | (Inherited from Bar.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.GetOptionsPage Method
ToolbarBase Class See Also Send Feedback
Gets an options page that will be used in the Designer Options dialog to edit the plugin options.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Public Overridable Function GetOptionsPage As DesignerOptionsPage
Visual C++
public:
virtual DesignerOptionsPage^ GetOptionsPage()

Return Value

The options page, if implemented; otherwise, null.

Implements

IDesignerPlugin..::.GetOptionsPage()()()

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.Invalidate Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.Invoke Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


Localize Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.Localize Method
ToolbarBase Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Localize()
Visual Basic (Declaration)
Public Overridable Sub Localize
Visual C++
public:
virtual void Localize()

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


Lock Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.Lock Method
ToolbarBase Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Lock()
Visual Basic (Declaration)
Public Sub Lock
Visual C++
public:
virtual void Lock() sealed

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.MemberwiseClone Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.PerformLayout Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.RestoreState Method
ToolbarBase Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RestoreState()
Visual Basic (Declaration)
Public Overridable Sub RestoreState
Visual C++
public:
virtual void RestoreState()

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.ResumeLayout Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Bar.)
ResumeLayout(Boolean) | (Inherited from Bar.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.RtlTranslateAlignment Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


SaveState Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.SaveState Method
ToolbarBase Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SaveState()
Visual Basic (Declaration)
Public Overridable Sub SaveState
Visual C++
public:
virtual void SaveState()

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.Scale Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.Select Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.SelectionChanged Method
ToolbarBase Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SelectionChanged()
Visual Basic (Declaration)
Public Overridable Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged()

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.SetBounds Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


SetSize Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.SetSize Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
SetSize(Size) | Obsolete. (Inherited from Bar.)
SetSize(Int32, Int32) | Obsolete. (Inherited from Bar.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


Unlock Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.Unlock Method
ToolbarBase Class See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Unlock()
Visual Basic (Declaration)
Public Sub Unlock
Visual C++
public:
virtual void Unlock() sealed

Implements

IDesignerPlugin..::.Unlock()()()

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ToolbarBase..::.UpdateBounds Method
ToolbarBase Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ToolbarBase Class
ToolbarBase Members
FastReport.Design.StandardDesigner Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.UpdateContent Method
ToolbarBase Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateContent()
Visual Basic (Declaration)
Public Overridable Sub UpdateContent
Visual C++
public:
virtual void UpdateContent()

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
ToolbarBase..::.UpdateUIStyle Method
ToolbarBase Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateUIStyle()
Visual Basic (Declaration)
Public Overridable Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle()

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


ToolbarBase Properties

[image] [image]

FastReport.Net Class Reference
ToolbarBase Properties
ToolbarBase Class See Also Send Feedback

The ToolbarBase type exposes the following members.

Properties

Name | Description
AcceptDropItems | (Inherited from Bar.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | (Inherited from Bar.)
AlwaysDisplayDockTab | (Inherited from Bar.)
AlwaysDisplayKeyAccelerators | (Inherited from Bar.)
Anchor | (Inherited from Bar.)
AntiAlias | (Inherited from Bar.)
AutoCreateCaptionMenu | (Inherited from Bar.)
AutoHide | (Inherited from Bar.)
AutoHideAnimationTime | (Inherited from Bar.)
AutoHideSide | (Inherited from Bar.)
AutoHideTabTextAlwaysVisible | (Inherited from Bar.)
AutoHideVisible | (Inherited from Bar.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoSyncBarCaption | (Inherited from Bar.)
BackColor | (Inherited from Bar.)
BackgroundImage | (Inherited from Bar.)
BackgroundImageAlpha | (Inherited from Bar.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImagePosition | (Inherited from Bar.)
BarState | (Inherited from Bar.)
BarType | (Inherited from Bar.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanAutoHide | (Inherited from Bar.)
CanCustomize | (Inherited from Bar.)
CanDockBottom | (Inherited from Bar.)
CanDockDocument | (Inherited from Bar.)
CanDockLeft | (Inherited from Bar.)
CanDockRight | (Inherited from Bar.)
CanDockTab | (Inherited from Bar.)
CanDockTop | (Inherited from Bar.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanHide | (Inherited from Bar.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanReorderTabs | (Inherited from Bar.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanTearOffTabs | (Inherited from Bar.)
CanUndock | (Inherited from Bar.)
CaptionBackColor | (Inherited from Bar.)
CaptionForeColor | (Inherited from Bar.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | (Inherited from Bar.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CloseSingleTab | (Inherited from Bar.)
ColorScheme | (Inherited from Bar.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | (Inherited from Bar.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Bar.)
Cursor | (Inherited from Bar.)
CustomBar | (Inherited from Bar.)
CustomizeMenu | (Inherited from Bar.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
Definition | (Inherited from Bar.)
Designer | Gets the report designer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisabledImagesGrayScale | (Inherited from Bar.)
DisplayMoreItemsOnMenu | (Inherited from Bar.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | (Inherited from Bar.)
Docked | (Inherited from Bar.)
DockedBorderStyle | (Inherited from Bar.)
DockedSite | (Inherited from Bar.)
DockLine | (Inherited from Bar.)
DockOffset | (Inherited from Bar.)
DockOrientation | (Inherited from Bar.)
DockSide | (Inherited from Bar.)
DockTabAlignment | (Inherited from Bar.)
DockTabCloseButtonVisible | (Inherited from Bar.)
DockTabControl | (Inherited from Bar.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EqualButtonSize | (Inherited from Bar.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FadeEffect | (Inherited from Bar.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from Bar.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from Bar.)
GlobalParentComponent | (Inherited from Bar.)
GrabHandleRect | (Inherited from Bar.)
GrabHandleStyle | (Inherited from Bar.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFloatingInactive | (Inherited from Bar.)
Images | (Inherited from Bar.)
ImageSize | (Inherited from Bar.)
ImagesLarge | (Inherited from Bar.)
ImagesMedium | (Inherited from Bar.)
ImeMode | (Inherited from Bar.)
ImeModeBase | (Inherited from Control.)
InitalFloatLocation | (Inherited from Bar.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsThemed | (Inherited from Bar.)
Items | (Inherited from Bar.)
ItemsContainer | (Inherited from Bar.)
ItemSpacing | (Inherited from Bar.)
LastFocusControl | (Inherited from Bar.)
LayoutDefinition | (Inherited from Bar.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutType | (Inherited from Bar.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LoadingHideFloating | (Inherited from Bar.)
Location | (Inherited from Bar.)
LockDockPosition | (Inherited from Bar.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MenuBar | (Inherited from Bar.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | (Inherited from Bar.)
Owner | (Inherited from Bar.)
Padding | (Inherited from Bar.)
PaddingBottom | (Inherited from Bar.)
PaddingLeft | (Inherited from Bar.)
PaddingRight | (Inherited from Bar.)
PaddingTop | (Inherited from Bar.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentItem | (Inherited from Bar.)
PluginName | Gets the plugin name.
PopupAnimation | (Inherited from Bar.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Renderer | (Inherited from Bar.)
RenderMode | (Inherited from Bar.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | (Inherited from Bar.)
RoundCorners | (Inherited from Bar.)
SaveLayoutChanges | (Inherited from Bar.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedDockContainerItem | (Inherited from Bar.)
SelectedDockTab | (Inherited from Bar.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolTips | (Inherited from Bar.)
SideBar | (Inherited from Bar.)
SingleLineColor | (Inherited from Bar.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | (Inherited from Bar.)
Stretch | (Inherited from Bar.)
Style | (Inherited from Bar.)
TabIndex | (Inherited from Bar.)
TabNavigation | (Inherited from Bar.)
TabStop | (Inherited from Bar.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Bar.)
ThemeAware | (Inherited from Bar.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | (Inherited from Bar.)
VisibleItemCount | (Inherited from Bar.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
WrapItems | (Inherited from Bar.)
WrapItemsDock | (Inherited from Bar.)
WrapItemsFloat | (Inherited from Bar.)

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


Designer Property

[image]

FastReport.Net Class Reference
ToolbarBase..::.Designer Property
ToolbarBase Class See Also Send Feedback
Gets the report designer.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerControl Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As DesignerControl
Visual C++
public:
property DesignerControl^ Designer {
    DesignerControl^ get ();
}

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


PluginName Property

[image]

FastReport.Net Class Reference
ToolbarBase..::.PluginName Property
ToolbarBase Class See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design.StandardDesigner
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PluginName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PluginName As String
Visual C++
public:
virtual property String^ PluginName {
    String^ get () sealed;
}

Implements

IDesignerPlugin..::.PluginName

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


ToolbarBase Events

[image] [image]

FastReport.Net Class Reference
ToolbarBase Events
ToolbarBase Class See Also Send Feedback

The ToolbarBase type exposes the following members.

Events

Name | Description
AutoHideChanged | (Inherited from Bar.)
AutoHideDisplay | (Inherited from Bar.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BarDock | (Inherited from Bar.)
BarUndock | (Inherited from Bar.)
BeforeDockTabDisplayed | (Inherited from Bar.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionButtonClick | (Inherited from Bar.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closing | (Inherited from Bar.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DefinitionLoaded | (Inherited from Bar.)
DeserializeItem | (Inherited from Bar.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockTabChange | (Inherited from Bar.)
DockTabClosing | (Inherited from Bar.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FocusItemChange | (Inherited from Bar.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemClick | (Inherited from Bar.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocalizeString | (Inherited from Bar.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PopupClose | (Inherited from Bar.)
PopupContainerLoad | (Inherited from Bar.)
PopupContainerUnload | (Inherited from Bar.)
PopupOpen | (Inherited from Bar.)
PopupShowing | (Inherited from Bar.)
PostRender | (Inherited from Bar.)
PreRender | (Inherited from Bar.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SerializeItem | (Inherited from Bar.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TabStripStyleChanged | (Inherited from Bar.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
UserVisibleChanged | (Inherited from Bar.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ToolbarBase Class
FastReport.Design.StandardDesigner Namespace


FastReport.Design.ToolWindows Namespace

[image]

FastReport.Net Class Reference
FastReport.Design.ToolWindows Namespace
Send Feedback

Classes

Class | Description
DictionaryWindow | Represents the "Data Dictionary" window.
DictionaryWindow..::.DraggedItem | Describes an item dragged from the "Data Dictionary" window.
MessagesWindow | Represents the "Messages" window.
PropertiesWindow | Represents the "Properties" window.
ReportTreeWindow | Represents the "Report Tree" window.
ToolWindowBase | Base class for all tool windows such as "Properties", "Data Dictionary" etc.


DictionaryWindow Class

[image]

FastReport.Net Class Reference
DictionaryWindow Class
Members See Also Send Feedback
Represents the "Data Dictionary" window.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DictionaryWindow : ToolWindowBase
Visual Basic (Declaration)
Public Class DictionaryWindow _
    Inherits ToolWindowBase
Visual C++
public ref class DictionaryWindow : public ToolWindowBase

Inheritance Hierarchy

System..::.Object
BaseItem
ImageItem
DockContainerItem
FastReport.Design.ToolWindows..::.ToolWindowBase
FastReport.Design.ToolWindows..::.DictionaryWindow

See Also

DictionaryWindow Members
FastReport.Design.ToolWindows Namespace


DictionaryWindow Members

[image] [image]

FastReport.Net Class Reference
DictionaryWindow Members
DictionaryWindow Class Constructors Methods Fields Properties Events See Also Send Feedback

The DictionaryWindow type exposes the following members.

Constructors

Name | Description
DictionaryWindow | Initializes a new instance of the DictionaryWindow class with default settings.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Inherited from ToolWindowBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Overrides ToolWindowBase..::.RestoreState()()().)
SaveState | Saves the plugin state. (Overrides ToolWindowBase..::.SaveState()()().)
SelectionChanged | Updates plugin state when current selection was changed. (Overrides ToolWindowBase..::.SelectionChanged()()().)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Overrides ToolWindowBase..::.UpdateContent()()().)
UpdateUIStyle | Updates UI style of the plugin. (Overrides ToolWindowBase..::.UpdateUIStyle()()().)

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow Constructor

[image]

FastReport.Net Class Reference
DictionaryWindow Constructor
DictionaryWindow Class See Also Send Feedback
Initializes a new instance of the DictionaryWindow class with default settings.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DictionaryWindow(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
DictionaryWindow(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow Fields

[image] [image]

FastReport.Net Class Reference
DictionaryWindow Fields
DictionaryWindow Class See Also Send Feedback

The DictionaryWindow type exposes the following members.

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow Methods

[image] [image]

FastReport.Net Class Reference
DictionaryWindow Methods
DictionaryWindow Class See Also Send Feedback

The DictionaryWindow type exposes the following members.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Inherited from ToolWindowBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Overrides ToolWindowBase..::.RestoreState()()().)
SaveState | Saves the plugin state. (Overrides ToolWindowBase..::.SaveState()()().)
SelectionChanged | Updates plugin state when current selection was changed. (Overrides ToolWindowBase..::.SelectionChanged()()().)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Overrides ToolWindowBase..::.UpdateContent()()().)
UpdateUIStyle | Updates UI style of the plugin. (Overrides ToolWindowBase..::.UpdateUIStyle()()().)

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


Localize Method

[image]

FastReport.Net Class Reference
DictionaryWindow..::.Localize Method
DictionaryWindow Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


RaiseClick Method

[image] [image]

FastReport.Net Class Reference
DictionaryWindow..::.RaiseClick Method
DictionaryWindow Class See Also Send Feedback

Overload List

Name | Description
RaiseClick()()() | (Inherited from BaseItem.)
RaiseClick(eEventSource) | (Inherited from BaseItem.)

See Also

DictionaryWindow Class
DictionaryWindow Members
FastReport.Design.ToolWindows Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
DictionaryWindow..::.RestoreState Method
DictionaryWindow Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


SaveState Method

[image]

FastReport.Net Class Reference
DictionaryWindow..::.SaveState Method
DictionaryWindow Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
DictionaryWindow..::.SelectionChanged Method
DictionaryWindow Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
DictionaryWindow..::.UpdateContent Method
DictionaryWindow Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void UpdateContent()
Visual Basic (Declaration)
Public Overrides Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() override

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
DictionaryWindow..::.UpdateUIStyle Method
DictionaryWindow Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void UpdateUIStyle()
Visual Basic (Declaration)
Public Overrides Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle() override

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow Properties

[image] [image]

FastReport.Net Class Reference
DictionaryWindow Properties
DictionaryWindow Class See Also Send Feedback

The DictionaryWindow type exposes the following members.

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow Events

[image] [image]

FastReport.Net Class Reference
DictionaryWindow Events
DictionaryWindow Class See Also Send Feedback

The DictionaryWindow type exposes the following members.

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

DictionaryWindow Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow.DraggedItem Class

[image]

FastReport.Net Class Reference
DictionaryWindow..::.DraggedItem Class
DictionaryWindow Class Members See Also Send Feedback
Describes an item dragged from the "Data Dictionary" window.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DraggedItem
Visual Basic (Declaration)
Public Class DraggedItem
Visual C++
public ref class DraggedItem

Inheritance Hierarchy

System..::.Object
FastReport.Design.ToolWindows..::.DictionaryWindow..::.DraggedItem

See Also

DictionaryWindow..::.DraggedItem Members
FastReport.Design.ToolWindows Namespace


DictionaryWindow.DraggedItem Members

[image] [image]

FastReport.Net Class Reference
DictionaryWindow..::.DraggedItem Members
DictionaryWindow..::.DraggedItem Class Methods Fields See Also Send Feedback

Represents the "Data Dictionary" window.

The DictionaryWindow..::.DraggedItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Obj | The dragged object.
Text | The text of dragged object.

See Also

DictionaryWindow..::.DraggedItem Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow.DraggedItem Fields

[image] [image]

FastReport.Net Class Reference
DictionaryWindow..::.DraggedItem Fields
DictionaryWindow..::.DraggedItem Class See Also Send Feedback

The DictionaryWindow..::.DraggedItem type exposes the following members.

Fields

Name | Description
Obj | The dragged object.
Text | The text of dragged object.

See Also

DictionaryWindow..::.DraggedItem Class
FastReport.Design.ToolWindows Namespace


Obj Field

[image]

FastReport.Net Class Reference
DictionaryWindow..::.DraggedItem..::.Obj Field
DictionaryWindow..::.DraggedItem Class See Also Send Feedback
The dragged object.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Obj
Visual Basic (Declaration)
Public Obj As Object
Visual C++
public:
Object^ Obj

See Also

DictionaryWindow..::.DraggedItem Class
FastReport.Design.ToolWindows Namespace


Text Field

[image]

FastReport.Net Class Reference
DictionaryWindow..::.DraggedItem..::.Text Field
DictionaryWindow..::.DraggedItem Class See Also Send Feedback
The text of dragged object.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text
Visual Basic (Declaration)
Public Text As String
Visual C++
public:
String^ Text

See Also

DictionaryWindow..::.DraggedItem Class
FastReport.Design.ToolWindows Namespace


DictionaryWindow.DraggedItem Methods

[image] [image]

FastReport.Net Class Reference
DictionaryWindow..::.DraggedItem Methods
DictionaryWindow..::.DraggedItem Class See Also Send Feedback

The DictionaryWindow..::.DraggedItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DictionaryWindow..::.DraggedItem Class
FastReport.Design.ToolWindows Namespace


MessagesWindow Class

[image]

FastReport.Net Class Reference
MessagesWindow Class
Members See Also Send Feedback
Represents the "Messages" window.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MessagesWindow : ToolWindowBase
Visual Basic (Declaration)
Public Class MessagesWindow _
    Inherits ToolWindowBase
Visual C++
public ref class MessagesWindow : public ToolWindowBase

Remarks

To get this window, use the following code:
CopyC#
Designer designer;
MessagesWindow window = designer.Plugins.FindType("MessagesWindow") as MessagesWindow;

Inheritance Hierarchy

System..::.Object
BaseItem
ImageItem
DockContainerItem
FastReport.Design.ToolWindows..::.ToolWindowBase
FastReport.Design.ToolWindows..::.MessagesWindow

See Also

MessagesWindow Members
FastReport.Design.ToolWindows Namespace


MessagesWindow Members

[image] [image]

FastReport.Net Class Reference
MessagesWindow Members
MessagesWindow Class Constructors Methods Fields Properties Events See Also Send Feedback

The MessagesWindow type exposes the following members.

Constructors

Name | Description
MessagesWindow | Initializes a new instance of the MessagesWindow class with default settings.

Methods

Name | Description
AddMessage | Overloaded.
ClearMessages | Clears the message list.
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Inherited from ToolWindowBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Inherited from ToolWindowBase.)
SaveState | Saves the plugin state. (Inherited from ToolWindowBase.)
SelectionChanged | Updates plugin state when current selection was changed. (Inherited from ToolWindowBase.)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Inherited from ToolWindowBase.)
UpdateUIStyle | Updates UI style of the plugin. (Inherited from ToolWindowBase.)

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


MessagesWindow Constructor

[image]

FastReport.Net Class Reference
MessagesWindow Constructor
MessagesWindow Class See Also Send Feedback
Initializes a new instance of the MessagesWindow class with default settings.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MessagesWindow(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
MessagesWindow(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


MessagesWindow Fields

[image] [image]

FastReport.Net Class Reference
MessagesWindow Fields
MessagesWindow Class See Also Send Feedback

The MessagesWindow type exposes the following members.

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


MessagesWindow Methods

[image] [image]

FastReport.Net Class Reference
MessagesWindow Methods
MessagesWindow Class See Also Send Feedback

The MessagesWindow type exposes the following members.

Methods

Name | Description
AddMessage | Overloaded.
ClearMessages | Clears the message list.
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Inherited from ToolWindowBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Inherited from ToolWindowBase.)
SaveState | Saves the plugin state. (Inherited from ToolWindowBase.)
SelectionChanged | Updates plugin state when current selection was changed. (Inherited from ToolWindowBase.)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Inherited from ToolWindowBase.)
UpdateUIStyle | Updates UI style of the plugin. (Inherited from ToolWindowBase.)

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


AddMessage Method

[image] [image]

FastReport.Net Class Reference
MessagesWindow..::.AddMessage Method
MessagesWindow Class See Also Send Feedback

Overload List

Name | Description
AddMessage(String, String) | Adds a new message.
AddMessage(String, Int32, Int32) | Adds a new script-related message.

See Also

MessagesWindow Class
MessagesWindow Members
FastReport.Design.ToolWindows Namespace


AddMessage Method (String, String)

[image]

FastReport.Net Class Reference
MessagesWindow..::.AddMessage Method (String, String)
MessagesWindow Class See Also Send Feedback
Adds a new message.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddMessage(
    string description,
    string objName
)
Visual Basic (Declaration)
Public Sub AddMessage ( _
    description As String, _
    objName As String _
)
Visual C++
public:
void AddMessage(
    String^ description,
    String^ objName
)

Parameters

description
Type: System..::.String
The message text.
objName
Type: System..::.String
The name of object related to a message.

See Also

MessagesWindow Class
AddMessage Overload
FastReport.Design.ToolWindows Namespace


AddMessage Method (String, Int32, Int32)

[image]

FastReport.Net Class Reference
MessagesWindow..::.AddMessage Method (String, Int32, Int32)
MessagesWindow Class See Also Send Feedback
Adds a new script-related message.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddMessage(
    string description,
    int line,
    int column
)
Visual Basic (Declaration)
Public Sub AddMessage ( _
    description As String, _
    line As Integer, _
    column As Integer _
)
Visual C++
public:
void AddMessage(
    String^ description,
    int line,
    int column
)

Parameters

description
Type: System..::.String
The message text.
line
Type: System..::.Int32
The line of the script.
column
Type: System..::.Int32
The column of the script.

See Also

MessagesWindow Class
AddMessage Overload
FastReport.Design.ToolWindows Namespace


ClearMessages Method

[image]

FastReport.Net Class Reference
MessagesWindow..::.ClearMessages Method
MessagesWindow Class See Also Send Feedback
Clears the message list.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ClearMessages()
Visual Basic (Declaration)
Public Sub ClearMessages
Visual C++
public:
void ClearMessages()

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


Localize Method

[image]

FastReport.Net Class Reference
MessagesWindow..::.Localize Method
MessagesWindow Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


RaiseClick Method

[image] [image]

FastReport.Net Class Reference
MessagesWindow..::.RaiseClick Method
MessagesWindow Class See Also Send Feedback

Overload List

Name | Description
RaiseClick()()() | (Inherited from BaseItem.)
RaiseClick(eEventSource) | (Inherited from BaseItem.)

See Also

MessagesWindow Class
MessagesWindow Members
FastReport.Design.ToolWindows Namespace


MessagesWindow Properties

[image] [image]

FastReport.Net Class Reference
MessagesWindow Properties
MessagesWindow Class See Also Send Feedback

The MessagesWindow type exposes the following members.

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


MessagesWindow Events

[image] [image]

FastReport.Net Class Reference
MessagesWindow Events
MessagesWindow Class See Also Send Feedback

The MessagesWindow type exposes the following members.

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

MessagesWindow Class
FastReport.Design.ToolWindows Namespace


PropertiesWindow Class

[image]

FastReport.Net Class Reference
PropertiesWindow Class
Members See Also Send Feedback
Represents the "Properties" window.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PropertiesWindow : ToolWindowBase
Visual Basic (Declaration)
Public Class PropertiesWindow _
    Inherits ToolWindowBase
Visual C++
public ref class PropertiesWindow : public ToolWindowBase

Inheritance Hierarchy

System..::.Object
BaseItem
ImageItem
DockContainerItem
FastReport.Design.ToolWindows..::.ToolWindowBase
FastReport.Design.ToolWindows..::.PropertiesWindow

See Also

PropertiesWindow Members
FastReport.Design.ToolWindows Namespace


PropertiesWindow Members

[image] [image]

FastReport.Net Class Reference
PropertiesWindow Members
PropertiesWindow Class Constructors Methods Fields Properties Events See Also Send Feedback

The PropertiesWindow type exposes the following members.

Constructors

Name | Description
PropertiesWindow | Initializes a new instance of the PropertiesWindow class with default settings.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Overrides ToolWindowBase..::.Lock()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Overrides ToolWindowBase..::.RestoreState()()().)
SaveState | Saves the plugin state. (Overrides ToolWindowBase..::.SaveState()()().)
SelectionChanged | Updates plugin state when current selection was changed. (Overrides ToolWindowBase..::.SelectionChanged()()().)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Overrides ToolWindowBase..::.UpdateContent()()().)
UpdateUIStyle | Updates UI style of the plugin. (Overrides ToolWindowBase..::.UpdateUIStyle()()().)

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


PropertiesWindow Constructor

[image]

FastReport.Net Class Reference
PropertiesWindow Constructor
PropertiesWindow Class See Also Send Feedback
Initializes a new instance of the PropertiesWindow class with default settings.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertiesWindow(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
PropertiesWindow(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


PropertiesWindow Fields

[image] [image]

FastReport.Net Class Reference
PropertiesWindow Fields
PropertiesWindow Class See Also Send Feedback

The PropertiesWindow type exposes the following members.

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


PropertiesWindow Methods

[image] [image]

FastReport.Net Class Reference
PropertiesWindow Methods
PropertiesWindow Class See Also Send Feedback

The PropertiesWindow type exposes the following members.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Overrides ToolWindowBase..::.Lock()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Overrides ToolWindowBase..::.RestoreState()()().)
SaveState | Saves the plugin state. (Overrides ToolWindowBase..::.SaveState()()().)
SelectionChanged | Updates plugin state when current selection was changed. (Overrides ToolWindowBase..::.SelectionChanged()()().)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Overrides ToolWindowBase..::.UpdateContent()()().)
UpdateUIStyle | Updates UI style of the plugin. (Overrides ToolWindowBase..::.UpdateUIStyle()()().)

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


Localize Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.Localize Method
PropertiesWindow Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


Lock Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.Lock Method
PropertiesWindow Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Lock()
Visual Basic (Declaration)
Public Overrides Sub Lock
Visual C++
public:
virtual void Lock() override

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


RaiseClick Method

[image] [image]

FastReport.Net Class Reference
PropertiesWindow..::.RaiseClick Method
PropertiesWindow Class See Also Send Feedback

Overload List

Name | Description
RaiseClick()()() | (Inherited from BaseItem.)
RaiseClick(eEventSource) | (Inherited from BaseItem.)

See Also

PropertiesWindow Class
PropertiesWindow Members
FastReport.Design.ToolWindows Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.RestoreState Method
PropertiesWindow Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


SaveState Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.SaveState Method
PropertiesWindow Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.SelectionChanged Method
PropertiesWindow Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.UpdateContent Method
PropertiesWindow Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void UpdateContent()
Visual Basic (Declaration)
Public Overrides Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() override

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
PropertiesWindow..::.UpdateUIStyle Method
PropertiesWindow Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void UpdateUIStyle()
Visual Basic (Declaration)
Public Overrides Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle() override

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


PropertiesWindow Properties

[image] [image]

FastReport.Net Class Reference
PropertiesWindow Properties
PropertiesWindow Class See Also Send Feedback

The PropertiesWindow type exposes the following members.

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


PropertiesWindow Events

[image] [image]

FastReport.Net Class Reference
PropertiesWindow Events
PropertiesWindow Class See Also Send Feedback

The PropertiesWindow type exposes the following members.

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

PropertiesWindow Class
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Class

[image]

FastReport.Net Class Reference
ReportTreeWindow Class
Members See Also Send Feedback
Represents the "Report Tree" window.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportTreeWindow : ToolWindowBase
Visual Basic (Declaration)
Public Class ReportTreeWindow _
    Inherits ToolWindowBase
Visual C++
public ref class ReportTreeWindow : public ToolWindowBase

Inheritance Hierarchy

System..::.Object
BaseItem
ImageItem
DockContainerItem
FastReport.Design.ToolWindows..::.ToolWindowBase
FastReport.Design.ToolWindows..::.ReportTreeWindow

See Also

ReportTreeWindow Members
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Members

[image] [image]

FastReport.Net Class Reference
ReportTreeWindow Members
ReportTreeWindow Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportTreeWindow type exposes the following members.

Constructors

Name | Description
ReportTreeWindow | Initializes a new instance of the ReportTreeWindow class with default settings.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Inherited from ToolWindowBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Inherited from ToolWindowBase.)
SaveState | Saves the plugin state. (Inherited from ToolWindowBase.)
SelectionChanged | Updates plugin state when current selection was changed. (Overrides ToolWindowBase..::.SelectionChanged()()().)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Overrides ToolWindowBase..::.UpdateContent()()().)
UpdateUIStyle | Updates UI style of the plugin. (Inherited from ToolWindowBase.)

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Constructor

[image]

FastReport.Net Class Reference
ReportTreeWindow Constructor
ReportTreeWindow Class See Also Send Feedback
Initializes a new instance of the ReportTreeWindow class with default settings.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportTreeWindow(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ReportTreeWindow(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Fields

[image] [image]

FastReport.Net Class Reference
ReportTreeWindow Fields
ReportTreeWindow Class See Also Send Feedback

The ReportTreeWindow type exposes the following members.

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Methods

[image] [image]

FastReport.Net Class Reference
ReportTreeWindow Methods
ReportTreeWindow Class See Also Send Feedback

The ReportTreeWindow type exposes the following members.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method. (Inherited from ToolWindowBase.)
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow. (Inherited from ToolWindowBase.)
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin. (Overrides ToolWindowBase..::.Localize()()().)
Lock | Locks the plugin. (Inherited from ToolWindowBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Inherited from ToolWindowBase.)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state. (Inherited from ToolWindowBase.)
SaveState | Saves the plugin state. (Inherited from ToolWindowBase.)
SelectionChanged | Updates plugin state when current selection was changed. (Overrides ToolWindowBase..::.SelectionChanged()()().)
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow. (Inherited from ToolWindowBase.)
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin. (Inherited from ToolWindowBase.)
UpdateContent | Updates plugin state when the report was modified. (Overrides ToolWindowBase..::.UpdateContent()()().)
UpdateUIStyle | Updates UI style of the plugin. (Inherited from ToolWindowBase.)

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


Localize Method

[image]

FastReport.Net Class Reference
ReportTreeWindow..::.Localize Method
ReportTreeWindow Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


RaiseClick Method

[image] [image]

FastReport.Net Class Reference
ReportTreeWindow..::.RaiseClick Method
ReportTreeWindow Class See Also Send Feedback

Overload List

Name | Description
RaiseClick()()() | (Inherited from BaseItem.)
RaiseClick(eEventSource) | (Inherited from BaseItem.)

See Also

ReportTreeWindow Class
ReportTreeWindow Members
FastReport.Design.ToolWindows Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
ReportTreeWindow..::.SelectionChanged Method
ReportTreeWindow Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
ReportTreeWindow..::.UpdateContent Method
ReportTreeWindow Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void UpdateContent()
Visual Basic (Declaration)
Public Overrides Sub UpdateContent
Visual C++
public:
virtual void UpdateContent() override

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Properties

[image] [image]

FastReport.Net Class Reference
ReportTreeWindow Properties
ReportTreeWindow Class See Also Send Feedback

The ReportTreeWindow type exposes the following members.

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button. (Inherited from ToolWindowBase.)
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer. (Inherited from ToolWindowBase.)
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked. (Inherited from ToolWindowBase.)
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls. (Inherited from ToolWindowBase.)
PluginName | Gets the plugin name. (Inherited from ToolWindowBase.)
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow. (Inherited from ToolWindowBase.)
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


ReportTreeWindow Events

[image] [image]

FastReport.Net Class Reference
ReportTreeWindow Events
ReportTreeWindow Class See Also Send Feedback

The ReportTreeWindow type exposes the following members.

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

ReportTreeWindow Class
FastReport.Design.ToolWindows Namespace


ToolWindowBase Class

[image]

FastReport.Net Class Reference
ToolWindowBase Class
Members See Also Send Feedback
Base class for all tool windows such as "Properties", "Data Dictionary" etc.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ToolWindowBase : DockContainerItem,
    IDesignerPlugin
Visual Basic (Declaration)
Public Class ToolWindowBase _
    Inherits DockContainerItem _
    Implements IDesignerPlugin
Visual C++
public ref class ToolWindowBase : public DockContainerItem,
    IDesignerPlugin

Remarks

Use this class to create own tool window. To do this:

- in the constructor, set the Name and Image properties and create necessary controls. The Name will be used to restore window's state;

- override the SelectionChanged method. This method is called when current selection is changed. In this method, you should update buttons state to reflect the current selection. Selected objects can be accessed via Designer.SelectedObjects property;

- override the UpdateContent method. This method is called when the report content was changed. Typically you need to do the same actions in SelectionChanged and UpdateContent methods;

- to register a toolwindow, add its type to the DesignerPlugins global collection:

CopyC#
DesignerPlugins.Add(typeof(MyToolWindow));

Inheritance Hierarchy

System..::.Object
BaseItem
ImageItem
DockContainerItem
FastReport.Design.ToolWindows..::.ToolWindowBase
FastReport.Design.ToolWindows..::.DictionaryWindow
FastReport.Design.ToolWindows..::.MessagesWindow
FastReport.Design.ToolWindows..::.PropertiesWindow
FastReport.Design.ToolWindows..::.ReportTreeWindow

See Also

ToolWindowBase Members
FastReport.Design.ToolWindows Namespace


ToolWindowBase Members

[image] [image]

FastReport.Net Class Reference
ToolWindowBase Members
ToolWindowBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToolWindowBase type exposes the following members.

Constructors

Name | Description
ToolWindowBase | Initializes a new instance of the ToolWindowBase class with default settings.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method.
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow.
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Overrides DockContainerItemOnContainerChanged(Object).)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow.
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button.
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer.
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked.
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls.
PluginName | Gets the plugin name.
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow.
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


ToolWindowBase Constructor

[image]

FastReport.Net Class Reference
ToolWindowBase Constructor
ToolWindowBase Class See Also Send Feedback
Initializes a new instance of the ToolWindowBase class with default settings.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ToolWindowBase(
    Designer designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As Designer _
)
Visual C++
public:
ToolWindowBase(
    Designer^ designer
)

Parameters

designer
Type: FastReport.Design..::.Designer
The report designer.

Remarks

You don't need to call this constructor. The designer will do this automatically.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


ToolWindowBase Fields

[image] [image]

FastReport.Net Class Reference
ToolWindowBase Fields
ToolWindowBase Class See Also Send Feedback

The ToolWindowBase type exposes the following members.

Fields

Name | Description
m_AccessKey | (Inherited from BaseItem.)
m_AllowOnlyOneSubItemExpanded | (Inherited from BaseItem.)
m_AutoExpand | (Inherited from BaseItem.)
m_BeginGroup | (Inherited from BaseItem.)
m_Category | (Inherited from BaseItem.)
m_CheckMouseMovePressed | (Inherited from BaseItem.)
m_ContainerControl | (Inherited from BaseItem.)
m_Description | (Inherited from BaseItem.)
m_Displayed | (Inherited from BaseItem.)
m_Enabled | (Inherited from BaseItem.)
m_Expanded | (Inherited from BaseItem.)
m_HotSubItem | (Inherited from BaseItem.)
m_IsContainer | (Inherited from BaseItem.)
m_ItemData | (Inherited from BaseItem.)
m_Name | (Inherited from BaseItem.)
m_NeedRecalcSize | (Inherited from BaseItem.)
m_Orientation | (Inherited from BaseItem.)
m_Parent | (Inherited from BaseItem.)
m_RecalculatingSize | (Inherited from BaseItem.)
m_Rect | (Inherited from BaseItem.)
m_ShouldSerialize | (Inherited from BaseItem.)
m_Style | (Inherited from BaseItem.)
m_SubItems | (Inherited from BaseItem.)
m_SupportedOrientation | (Inherited from BaseItem.)
m_SystemItem | (Inherited from BaseItem.)
m_Text | (Inherited from BaseItem.)
m_ThemeAware | (Inherited from BaseItem.)
m_Tooltip | (Inherited from BaseItem.)
m_ToolTipWnd | (Inherited from BaseItem.)
m_Visible | (Inherited from BaseItem.)

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


ToolWindowBase Methods

[image] [image]

FastReport.Net Class Reference
ToolWindowBase Methods
ToolWindowBase Class See Also Send Feedback

The ToolWindowBase type exposes the following members.

Methods

Name | Description
Clone | (Inherited from BaseItem.)
ContainerGotFocus | (Inherited from BaseItem.)
ContainerLostFocus | (Inherited from BaseItem.)
Copy | (Inherited from DockContainerItem.)
CopyToItem | (Inherited from DockContainerItem.)
CreateAccessibilityInstance | (Inherited from BaseItem.)
Deserialize | (Inherited from DockContainerItem.)
Dispose | (Inherited from DockContainerItem.)
DrawInsertMarker | (Inherited from BaseItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCommand | (Inherited from BaseItem.)
ExpandedItem | (Inherited from BaseItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Focus | (Inherited from BaseItem.)
FocusedItem | (Inherited from BaseItem.)
GetFont | (Inherited from DockContainerItem.)
GetHashCode | (Inherited from BaseItem.)
GetIOwnerItemEvents | (Inherited from BaseItem.)
GetOptionsPage | Implements GetOptionsPage()()() method.
GetOwner | (Inherited from BaseItem.)
GetTooltipShortcutString | (Inherited from BaseItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Hides the toolwindow.
HideToolTip | (Inherited from BaseItem.)
InternalClick | (Inherited from BaseItem.)
InternalDoubleClick | (Inherited from BaseItem.)
InternalKeyDown | (Inherited from BaseItem.)
InternalMouseDown | (Inherited from BaseItem.)
InternalMouseEnter | (Inherited from BaseItem.)
InternalMouseHover | (Inherited from BaseItem.)
InternalMouseLeave | (Inherited from BaseItem.)
InternalMouseMove | (Inherited from BaseItem.)
InternalMouseUp | (Inherited from BaseItem.)
Invalidate | (Inherited from BaseItem.)
InvokeDoubleClick | (Inherited from BaseItem.)
IsAnyOnHandle | (Inherited from DockContainerItem.)
ItemAtLocation | (Inherited from BaseItem.)
LeaveHotSubItem | (Inherited from BaseItem.)
Localize | Localizes the plugin.
Lock | Locks the plugin.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAfterItemRemoved | (Inherited from DockContainerItem.)
OnAppearanceChanged | (Inherited from BaseItem.)
OnBeforeItemRemoved | (Inherited from BaseItem.)
OnClick | (Inherited from BaseItem.)
OnCommandChanged | (Inherited from BaseItem.)
OnContainerChanged | (Overrides DockContainerItemOnContainerChanged(Object).)
OnDesignModeChanged | (Inherited from DockContainerItem.)
OnDisplayedChanged | (Inherited from DockContainerItem.)
OnEnabledChanged | (Inherited from DockContainerItem.)
OnExpandChange | (Inherited from BaseItem.)
OnExternalSizeChange | (Inherited from DockContainerItem.)
OnGotFocus | (Inherited from DockContainerItem.)
OnImageChanged | (Inherited from ImageItem.)
OnIsOnCustomizeDialogChanged | (Inherited from DockContainerItem.)
OnIsOnCustomizeMenuChanged | (Inherited from DockContainerItem.)
OnItemAdded | (Inherited from ImageItem.)
OnLeftLocationChanged | (Inherited from BaseItem.)
OnLostFocus | (Inherited from BaseItem.)
OnOwnerChanged | (Inherited from BaseItem.)
OnParentChanged | (Inherited from BaseItem.)
OnProcessDelayedCommands | (Inherited from DockContainerItem.)
OnSiteChanged | (Inherited from BaseItem.)
OnStyleChanged | (Inherited from DockContainerItem.)
OnSubItemExpandChange | (Inherited from BaseItem.)
OnSubItemGotFocus | (Inherited from BaseItem.)
OnSubItemImageSizeChanged | (Inherited from ImageItem.)
OnSubItemLostFocus | (Inherited from BaseItem.)
OnSubItemsChanged | (Inherited from BaseItem.)
OnSubItemsClear | (Inherited from BaseItem.)
OnTextChanged | (Inherited from DockContainerItem.)
OnTooltip | (Inherited from BaseItem.)
OnTooltipChanged | (Inherited from DockContainerItem.)
OnTopLocationChanged | (Inherited from BaseItem.)
OnVisibleChanged | (Inherited from DockContainerItem.)
Paint | (Inherited from DockContainerItem.)
RaiseClick | Overloaded.
RecalcSize | (Inherited from DockContainerItem.)
Refresh | (Inherited from BaseItem.)
RefreshImageSize | (Inherited from ImageItem.)
RefreshSubItemImageSize | (Inherited from ImageItem.)
ReleaseFocus | (Inherited from BaseItem.)
ResetHover | (Inherited from BaseItem.)
ResetMinimumSize | (Inherited from DockContainerItem.)
RestoreState | Restores the plugin state.
SaveState | Saves the plugin state.
SelectionChanged | Updates plugin state when current selection was changed.
Serialize | (Inherited from DockContainerItem.)
SetDesignMode | (Inherited from BaseItem.)
SetIsContainer | (Inherited from BaseItem.)
SetParent | (Inherited from BaseItem.)
ShouldSerializeDefaultFloatingSize | (Inherited from DockContainerItem.)
ShouldSerializeMinimumSize | (Inherited from DockContainerItem.)
ShouldSerializeSubItems | (Inherited from BaseItem.)
Show | Shows the toolwindow.
ShowToolTip | (Inherited from BaseItem.)
SubItemSizeChanged | (Inherited from BaseItem.)
TextMarkupLinkClick | (Inherited from BaseItem.)
ToString | (Inherited from BaseItem.)
Unlock | Unlocks the plugin.
UpdateContent | Updates plugin state when the report was modified.
UpdateUIStyle | Updates UI style of the plugin.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


GetOptionsPage Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.GetOptionsPage Method
ToolWindowBase Class See Also Send Feedback
Implements GetOptionsPage()()() method.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual DesignerOptionsPage GetOptionsPage()
Visual Basic (Declaration)
Public Overridable Function GetOptionsPage As DesignerOptionsPage
Visual C++
public:
virtual DesignerOptionsPage^ GetOptionsPage()

Return Value

The options page, if implemented; otherwise, null.

Implements

IDesignerPlugin..::.GetOptionsPage()()()

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Hide Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Hide Method
ToolWindowBase Class See Also Send Feedback
Hides the toolwindow.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Localize Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Localize Method
ToolWindowBase Class See Also Send Feedback
Localizes the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Localize()
Visual Basic (Declaration)
Public Overridable Sub Localize
Visual C++
public:
virtual void Localize()

Implements

IDesignerPlugin..::.Localize()()()

Remarks

This method is called by the designer when current localization is changed.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Lock Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Lock Method
ToolWindowBase Class See Also Send Feedback
Locks the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Lock()
Visual Basic (Declaration)
Public Overridable Sub Lock
Visual C++
public:
virtual void Lock()

Implements

IDesignerPlugin..::.Lock()()()

Remarks

This method is called by the designer when report is loading. It may be needed to disable some operations (like painting) that use the report.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


OnContainerChanged Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.OnContainerChanged Method
ToolWindowBase Class See Also Send Feedback

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnContainerChanged(
    Object objOldContainer
)
Visual Basic (Declaration)
Protected Overrides Sub OnContainerChanged ( _
    objOldContainer As Object _
)
Visual C++
protected:
virtual void OnContainerChanged(
    Object^ objOldContainer
) override

Parameters

objOldContainer
Type: System..::.Object

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


RaiseClick Method

[image] [image]

FastReport.Net Class Reference
ToolWindowBase..::.RaiseClick Method
ToolWindowBase Class See Also Send Feedback

Overload List

Name | Description
RaiseClick()()() | (Inherited from BaseItem.)
RaiseClick(eEventSource) | (Inherited from BaseItem.)

See Also

ToolWindowBase Class
ToolWindowBase Members
FastReport.Design.ToolWindows Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.RestoreState Method
ToolWindowBase Class Example See Also Send Feedback
Restores the plugin state.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RestoreState()
Visual Basic (Declaration)
Public Overridable Sub RestoreState
Visual C++
public:
virtual void RestoreState()

Implements

IDesignerPlugin..::.RestoreState()()()

Examples

This example shows how to restore the state:
CopyC#
public void RestoreState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  DialogWorkspace.ShowGrid = xi.GetProp("ShowGrid") != "0";
}

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


SaveState Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.SaveState Method
ToolWindowBase Class Example See Also Send Feedback
Saves the plugin state.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SaveState()
Visual Basic (Declaration)
Public Overridable Sub SaveState
Visual C++
public:
virtual void SaveState()

Implements

IDesignerPlugin..::.SaveState()()()

Examples

This example shows how to save the state:
CopyC#
public void SaveState()
{
  XmlItem xi = Config.Root.FindItem("Designer").FindItem(Name);
  xi.SetProp("ShowGrid", DialogWorkspace.ShowGrid ? "1" : "0");
}

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.SelectionChanged Method
ToolWindowBase Class See Also Send Feedback
Updates plugin state when current selection was changed.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SelectionChanged()
Visual Basic (Declaration)
Public Overridable Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged()

Implements

IDesignerPlugin..::.SelectionChanged()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Show Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Show Method
ToolWindowBase Class See Also Send Feedback
Shows the toolwindow.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Unlock Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Unlock Method
ToolWindowBase Class See Also Send Feedback
Unlocks the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Unlock()
Visual Basic (Declaration)
Public Overridable Sub Unlock
Visual C++
public:
virtual void Unlock()

Implements

IDesignerPlugin..::.Unlock()()()

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


UpdateContent Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.UpdateContent Method
ToolWindowBase Class See Also Send Feedback
Updates plugin state when the report was modified.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateContent()
Visual Basic (Declaration)
Public Overridable Sub UpdateContent
Visual C++
public:
virtual void UpdateContent()

Implements

IDesignerPlugin..::.UpdateContent()()()

Remarks

Typically you need to do the same work in the SelectionChanged()()() and UpdateContent()()() methods.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


UpdateUIStyle Method

[image]

FastReport.Net Class Reference
ToolWindowBase..::.UpdateUIStyle Method
ToolWindowBase Class See Also Send Feedback
Updates UI style of the plugin.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateUIStyle()
Visual Basic (Declaration)
Public Overridable Sub UpdateUIStyle
Visual C++
public:
virtual void UpdateUIStyle()

Implements

IDesignerPlugin..::.UpdateUIStyle()()()

Remarks

The plugin should update its style according to the designer's UIStyle property.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


ToolWindowBase Properties

[image] [image]

FastReport.Net Class Reference
ToolWindowBase Properties
ToolWindowBase Class See Also Send Feedback

The ToolWindowBase type exposes the following members.

Properties

Name | Description
AccessibleDefaultActionDescription | (Inherited from BaseItem.)
AccessibleDescription | (Inherited from BaseItem.)
AccessibleName | (Inherited from BaseItem.)
AccessibleObject | (Inherited from BaseItem.)
AccessibleRole | (Inherited from BaseItem.)
AccessKey | (Inherited from BaseItem.)
AutoCollapseOnClick | (Inherited from BaseItem.)
AutoExpand | (Inherited from BaseItem.)
BeginGroup | (Inherited from BaseItem.)
BindingContext | (Inherited from BaseItem.)
Bounds | (Inherited from BaseItem.)
CanCustomize | (Inherited from DockContainerItem.)
CanHide | Gets or sets a value indicating that the toolwindow can be closed by the x button.
Category | (Inherited from DockContainerItem.)
ClickAutoRepeat | (Inherited from DockContainerItem.)
ClickRepeatInterval | (Inherited from DockContainerItem.)
Command | (Inherited from BaseItem.)
CommandParameter | (Inherited from BaseItem.)
ContainerControl | (Inherited from BaseItem.)
Control | (Inherited from DockContainerItem.)
Cursor | (Inherited from BaseItem.)
DataBindings | (Inherited from BaseItem.)
DefaultFloatingSize | (Inherited from DockContainerItem.)
Description | (Inherited from DockContainerItem.)
Designer | Gets the report designer.
DesignMode | (Inherited from DockContainerItem.)
Displayed | (Inherited from BaseItem.)
DisplayRectangle | (Inherited from BaseItem.)
Enabled | (Inherited from BaseItem.)
Expanded | (Inherited from BaseItem.)
Focused | (Inherited from BaseItem.)
GlobalItem | (Inherited from DockContainerItem.)
GlobalName | (Inherited from BaseItem.)
Height | (Inherited from DockContainerItem.)
HeightInternal | (Inherited from BaseItem.)
Icon | (Inherited from DockContainerItem.)
Id | (Inherited from BaseItem.)
Image | (Inherited from DockContainerItem.)
ImageIndex | (Inherited from DockContainerItem.)
ImageList | (Inherited from DockContainerItem.)
ImageSize | (Inherited from ImageItem.)
IsAccessible | (Inherited from BaseItem.)
IsContainer | (Inherited from BaseItem.)
IsDisposed | (Inherited from BaseItem.)
IsMarkupSupported | (Inherited from BaseItem.)
IsOnBar | (Inherited from BaseItem.)
IsOnContextMenu | (Inherited from BaseItem.)
IsOnCustomizeDialog | (Inherited from BaseItem.)
IsOnCustomizeMenu | (Inherited from BaseItem.)
IsOnMenu | (Inherited from BaseItem.)
IsOnMenuBar | (Inherited from BaseItem.)
IsRecalculatingSize | (Inherited from BaseItem.)
IsRightToLeft | (Inherited from BaseItem.)
IsWindowed | (Inherited from DockContainerItem.)
ItemAlignment | (Inherited from DockContainerItem.)
KeyTips | (Inherited from BaseItem.)
LeftInternal | (Inherited from BaseItem.)
Locked | Gets a value indicating that window is locked.
MinFormClientSize | Obsolete. (Inherited from DockContainerItem.)
MinimumSize | (Inherited from DockContainerItem.)
Name | (Inherited from BaseItem.)
NeedRecalcSize | (Inherited from BaseItem.)
Orientation | (Inherited from BaseItem.)
Parent | (Inherited from BaseItem.)
ParentControl | Gets a parent control that contains all controls.
PluginName | Gets the plugin name.
PredefinedTabColor | (Inherited from DockContainerItem.)
Selected | (Inherited from DockContainerItem.)
Shortcut | Gets or sets shortcut keys used to show this toolwindow.
Shortcuts | (Inherited from DockContainerItem.)
ShortcutString | (Inherited from BaseItem.)
ShouldSerialize | (Inherited from BaseItem.)
ShouldSyncProperties | (Inherited from BaseItem.)
ShowSubItems | (Inherited from DockContainerItem.)
ShowToolTips | (Inherited from BaseItem.)
Site | (Inherited from BaseItem.)
Size | (Inherited from BaseItem.)
Stretch | (Inherited from DockContainerItem.)
Style | (Inherited from BaseItem.)
SubItems | (Inherited from BaseItem.)
SubItemsImageSize | (Inherited from ImageItem.)
SupportedOrientation | (Inherited from BaseItem.)
SuspendLayout | (Inherited from BaseItem.)
SystemItem | (Inherited from BaseItem.)
Tag | (Inherited from BaseItem.)
Text | (Inherited from BaseItem.)
ThemeAware | (Inherited from BaseItem.)
Tooltip | (Inherited from BaseItem.)
ToolTipControl | (Inherited from BaseItem.)
ToolTipVisible | (Inherited from BaseItem.)
TopInternal | (Inherited from BaseItem.)
UserCustomized | (Inherited from BaseItem.)
Visible | (Inherited from DockContainerItem.)
VisibleSubItems | (Inherited from BaseItem.)
Width | (Inherited from DockContainerItem.)
WidthInternal | (Inherited from BaseItem.)

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


CanHide Property

[image]

FastReport.Net Class Reference
ToolWindowBase..::.CanHide Property
ToolWindowBase Class See Also Send Feedback
Gets or sets a value indicating that the toolwindow can be closed by the x button.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanHide { get; set; }
Visual Basic (Declaration)
Public Property CanHide As Boolean
Visual C++
public:
property bool CanHide {
    bool get ();
    void set (bool value);
}

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Designer Property

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Designer Property
ToolWindowBase Class See Also Send Feedback
Gets the report designer.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Designer Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As Designer
Visual C++
public:
property Designer^ Designer {
    Designer^ get ();
}

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Locked Property

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Locked Property
ToolWindowBase Class See Also Send Feedback
Gets a value indicating that window is locked.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Locked { get; }
Visual Basic (Declaration)
Public ReadOnly Property Locked As Boolean
Visual C++
public:
property bool Locked {
    bool get ();
}

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


ParentControl Property

[image]

FastReport.Net Class Reference
ToolWindowBase..::.ParentControl Property
ToolWindowBase Class See Also Send Feedback
Gets a parent control that contains all controls.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Control ParentControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentControl As Control
Visual C++
public:
property Control^ ParentControl {
    Control^ get ();
}

Remarks

Add your control to the parent control Controls collection.

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


PluginName Property

[image]

FastReport.Net Class Reference
ToolWindowBase..::.PluginName Property
ToolWindowBase Class See Also Send Feedback
Gets the plugin name.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PluginName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PluginName As String
Visual C++
public:
virtual property String^ PluginName {
    String^ get () sealed;
}

Implements

IDesignerPlugin..::.PluginName

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


Shortcut Property

[image]

FastReport.Net Class Reference
ToolWindowBase..::.Shortcut Property
ToolWindowBase Class See Also Send Feedback
Gets or sets shortcut keys used to show this toolwindow.

Namespace: FastReport.Design.ToolWindows
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public eShortcut Shortcut { get; set; }
Visual Basic (Declaration)
Public Property Shortcut As eShortcut
Visual C++
public:
property eShortcut Shortcut {
    eShortcut get ();
    void set (eShortcut value);
}

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


ToolWindowBase Events

[image] [image]

FastReport.Net Class Reference
ToolWindowBase Events
ToolWindowBase Class See Also Send Feedback

The ToolWindowBase type exposes the following members.

Events

Name | Description
Click | (Inherited from BaseItem.)
ContainerControlDeserialize | (Inherited from DockContainerItem.)
ContainerControlSerialize | (Inherited from DockContainerItem.)
ContainerLoadControl | (Inherited from DockContainerItem.)
Disposed | (Inherited from BaseItem.)
DoubleClick | (Inherited from BaseItem.)
EnabledChanged | (Inherited from BaseItem.)
ExpandChange | (Inherited from BaseItem.)
GotFocus | (Inherited from BaseItem.)
ItemCopied | (Inherited from BaseItem.)
LostFocus | (Inherited from BaseItem.)
MouseDown | (Inherited from BaseItem.)
MouseEnter | (Inherited from BaseItem.)
MouseHover | (Inherited from BaseItem.)
MouseLeave | (Inherited from BaseItem.)
MouseMove | (Inherited from BaseItem.)
MouseUp | (Inherited from BaseItem.)
SubItemsChanged | (Inherited from BaseItem.)
TextChanged | (Inherited from BaseItem.)
ToolTipVisibleChanged | (Inherited from BaseItem.)
VisibleChanged | (Inherited from BaseItem.)

See Also

ToolWindowBase Class
FastReport.Design.ToolWindows Namespace


FastReport.Dialog Namespace

[image]

FastReport.Net Class Reference
FastReport.Dialog Namespace
Send Feedback

Classes

Class | Description
ButtonBaseControl | Implements base behavior of button controls.
ButtonControl | Represents a Windows button control. Wraps the Button control.
CheckBoxControl | Represents a Windows CheckBox. Wraps the CheckBox control.
CheckedListBoxControl | Displays a ListBox in which a check box is displayed to the left of each item. Wraps the CheckedListBox control.
ComboBoxControl | Represents a Windows combo box control. Wraps the ComboBox control.
DataFilterBaseControl | The base class for all controls that support the data filtering feature.
DataSelectorControl | Represents the control with two lists (available items and selected items).
DateTimePickerControl | Represents a Windows control that allows the user to select a date and a time and to display the date and time with a specified format. Wraps the DateTimePicker control.
DialogComponentBase | Base class for all dialog components.
DialogComponentCollection | Represents the collection of dialog components.
DialogControl | Base class for all dialog controls such as ButtonControl, TextBoxControl.
DialogPage | Represents the special kind of report page that wraps the Form and used to display dialog forms.
GridControl | Displays data in a customizable grid. Wraps the DataGridView control.
GridControlColumn | Represents the GridControl's column. Wraps the DataGridViewTextBoxColumn class.
GridControlColumnCollection | Represents the collection of GridControl columns.
GroupBoxControl | Represents a Windows control that displays a frame around a group of controls with an optional caption. Wraps the GroupBox control.
LabelControl | Represents a standard Windows label. Wraps the Label control.
ListBoxBaseControl | Base class for list box controls such as ListBoxControl, CheckedListBoxControl.
ListBoxControl | Represents a Windows control to display a list of items. Wraps the ListBox control.
ListViewControl | Represents a Windows list view control, which displays a collection of items that can be displayed using one of four different views. Wraps the ListView control.
MaskedTextBoxControl | Uses a mask to distinguish between proper and improper user input. Wraps the MaskedTextBox control.
MonthCalendarControl | Represents a Windows control that enables the user to select a date using a visual monthly calendar display. Wraps the MonthCalendar control.
NumericUpDownControl | Represents a Windows spin box (also known as an up-down control) that displays numeric values. Wraps the NumericUpDown control.
PanelControl | Used to group collections of controls. Wraps the Panel control.
ParentControl | Base class for controls that may contain child controls.
PictureBoxControl | Represents a Windows picture box control for displaying an image. Wraps the PictureBox control.
RadioButtonControl | Enables the user to select a single option from a group of choices when paired with other RadioButton controls. Wraps the RadioButton control.
RichTextBoxControl | Represents a Windows rich text box control. Wraps the RichTextBox control.
TextBoxControl | Represents a Windows text box control. Wraps the TextBox control.
TreeViewControl | Displays a hierarchical collection of labeled items, each represented by a TreeNode. Wraps the TreeView control.


ButtonBaseControl Class

[image]

FastReport.Net Class Reference
ButtonBaseControl Class
Members See Also Send Feedback
Implements base behavior of button controls.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ButtonBaseControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class ButtonBaseControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class ButtonBaseControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ButtonBaseControl
FastReport.Dialog..::.ButtonControl
FastReport.Dialog..::.CheckBoxControl
FastReport.Dialog..::.RadioButtonControl

See Also

ButtonBaseControl Members
FastReport.Dialog Namespace


ButtonBaseControl Members

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl Members
ButtonBaseControl Class Constructors Methods Properties Events See Also Send Feedback

The ButtonBaseControl type exposes the following members.

Constructors

Name | Description
ButtonBaseControl | Initializes a new instance of the ButtonBaseControl class

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class.
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property.
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


ButtonBaseControl Constructor

[image]

FastReport.Net Class Reference
ButtonBaseControl Constructor
ButtonBaseControl Class See Also Send Feedback
Initializes a new instance of the ButtonBaseControl class

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonBaseControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ButtonBaseControl()

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


ButtonBaseControl Methods

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl Methods
ButtonBaseControl Class See Also Send Feedback

The ButtonBaseControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl..::.Dispose Method
ButtonBaseControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ButtonBaseControl Class
ButtonBaseControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl..::.DrawSelectionPoint Method
ButtonBaseControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ButtonBaseControl Class
ButtonBaseControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl..::.FillData Method
ButtonBaseControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

ButtonBaseControl Class
ButtonBaseControl Members
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.GetValue Method
ButtonBaseControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl..::.MemberwiseClone Method
ButtonBaseControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ButtonBaseControl Class
ButtonBaseControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.Serialize Method
ButtonBaseControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


ButtonBaseControl Properties

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl Properties
ButtonBaseControl Class See Also Send Feedback

The ButtonBaseControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class.
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property.
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


AutoFill Property

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.AutoFill Property
ButtonBaseControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFill { get; set; }
Visual Basic (Declaration)
Public Property AutoFill As Boolean
Visual C++
public:
property bool AutoFill {
    bool get ();
    void set (bool value);
}

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.AutoSize Property
ButtonBaseControl Class See Also Send Feedback
Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
Visual C++
public:
virtual property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


Image Property

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.Image Property
ButtonBaseControl Class See Also Send Feedback
Gets or sets the image that is displayed on a button control. Wraps the Image property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


ImageAlign Property

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.ImageAlign Property
ButtonBaseControl Class See Also Send Feedback
Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ContentAlignment ImageAlign { get; set; }
Visual Basic (Declaration)
Public Property ImageAlign As ContentAlignment
Visual C++
public:
property ContentAlignment ImageAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


TextAlign Property

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.TextAlign Property
ButtonBaseControl Class See Also Send Feedback
Gets or sets the alignment of the text on the button control. Wraps the TextAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Overridable Property TextAlign As ContentAlignment
Visual C++
public:
virtual property ContentAlignment TextAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


TextImageRelation Property

[image]

FastReport.Net Class Reference
ButtonBaseControl..::.TextImageRelation Property
ButtonBaseControl Class See Also Send Feedback
Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextImageRelation TextImageRelation { get; set; }
Visual Basic (Declaration)
Public Property TextImageRelation As TextImageRelation
Visual C++
public:
property TextImageRelation TextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


ButtonBaseControl Events

[image] [image]

FastReport.Net Class Reference
ButtonBaseControl Events
ButtonBaseControl Class See Also Send Feedback

The ButtonBaseControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ButtonBaseControl Class
FastReport.Dialog Namespace


ButtonControl Class

[image]

FastReport.Net Class Reference
ButtonControl Class
Members See Also Send Feedback
Represents a Windows button control. Wraps the Button control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ButtonControl : ButtonBaseControl
Visual Basic (Declaration)
Public Class ButtonControl _
    Inherits ButtonBaseControl
Visual C++
public ref class ButtonControl : public ButtonBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ButtonBaseControl
FastReport.Dialog..::.ButtonControl

See Also

ButtonControl Members
FastReport.Dialog Namespace


ButtonControl Members

[image] [image]

FastReport.Net Class Reference
ButtonControl Members
ButtonControl Class Constructors Methods Properties Events See Also Send Feedback

The ButtonControl type exposes the following members.

Constructors

Name | Description
ButtonControl | Initializes a new instance of the ButtonControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Inherited from ButtonBaseControl.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ButtonBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class. (Inherited from ButtonBaseControl.)
AutoFilter | This property is not relevant to this class.
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property. (Overrides ButtonBaseControl..::.AutoSize.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Button | Gets an internal Button.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | This property is not relevant to this class.
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. Wraps the DialogResult property.
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | This property is not relevant to this class.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property. (Inherited from ButtonBaseControl.)
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property. (Inherited from ButtonBaseControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | This property is not relevant to this class.
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property. (Overrides ButtonBaseControl..::.TextAlign.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property. (Inherited from ButtonBaseControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ButtonControl Class
FastReport.Dialog Namespace


ButtonControl Constructor

[image]

FastReport.Net Class Reference
ButtonControl Constructor
ButtonControl Class See Also Send Feedback
Initializes a new instance of the ButtonControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ButtonControl()

See Also

ButtonControl Class
FastReport.Dialog Namespace


ButtonControl Methods

[image] [image]

FastReport.Net Class Reference
ButtonControl Methods
ButtonControl Class See Also Send Feedback

The ButtonControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Inherited from ButtonBaseControl.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ButtonBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ButtonControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ButtonControl..::.Dispose Method
ButtonControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ButtonControl Class
ButtonControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ButtonControl..::.DrawSelectionPoint Method
ButtonControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ButtonControl Class
ButtonControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
ButtonControl..::.FillData Method
ButtonControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

ButtonControl Class
ButtonControl Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ButtonControl..::.MemberwiseClone Method
ButtonControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ButtonControl Class
ButtonControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ButtonControl..::.Serialize Method
ButtonControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ButtonControl Class
FastReport.Dialog Namespace


ButtonControl Properties

[image] [image]

FastReport.Net Class Reference
ButtonControl Properties
ButtonControl Class See Also Send Feedback

The ButtonControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class. (Inherited from ButtonBaseControl.)
AutoFilter | This property is not relevant to this class.
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property. (Overrides ButtonBaseControl..::.AutoSize.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Button | Gets an internal Button.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | This property is not relevant to this class.
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. Wraps the DialogResult property.
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | This property is not relevant to this class.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property. (Inherited from ButtonBaseControl.)
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property. (Inherited from ButtonBaseControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | This property is not relevant to this class.
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property. (Overrides ButtonBaseControl..::.TextAlign.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property. (Inherited from ButtonBaseControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ButtonControl Class
FastReport.Dialog Namespace


AutoFilter Property

[image]

FastReport.Net Class Reference
ButtonControl..::.AutoFilter Property
ButtonControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFilter { get; set; }
Visual Basic (Declaration)
Public Property AutoFilter As Boolean
Visual C++
public:
property bool AutoFilter {
    bool get ();
    void set (bool value);
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
ButtonControl..::.AutoSize Property
ButtonControl Class See Also Send Feedback
Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Overrides Property AutoSize As Boolean
Visual C++
public:
virtual property bool AutoSize {
    bool get () override;
    void set (bool value) override;
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


Button Property

[image]

FastReport.Net Class Reference
ButtonControl..::.Button Property
ButtonControl Class See Also Send Feedback
Gets an internal Button.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Button Button { get; }
Visual Basic (Declaration)
Public ReadOnly Property Button As Button
Visual C++
public:
property Button^ Button {
    Button^ get ();
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
ButtonControl..::.DataColumn Property
ButtonControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


DialogResult Property

[image]

FastReport.Net Class Reference
ButtonControl..::.DialogResult Property
ButtonControl Class See Also Send Feedback
Gets or sets a value that is returned to the parent form when the button is clicked. Wraps the DialogResult property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogResult DialogResult { get; set; }
Visual Basic (Declaration)
Public Property DialogResult As DialogResult
Visual C++
public:
property DialogResult DialogResult {
    DialogResult get ();
    void set (DialogResult value);
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


FilterOperation Property

[image]

FastReport.Net Class Reference
ButtonControl..::.FilterOperation Property
ButtonControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FilterOperation FilterOperation { get; set; }
Visual Basic (Declaration)
Public Property FilterOperation As FilterOperation
Visual C++
public:
property FilterOperation FilterOperation {
    FilterOperation get ();
    void set (FilterOperation value);
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


ReportParameter Property

[image]

FastReport.Net Class Reference
ButtonControl..::.ReportParameter Property
ButtonControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportParameter { get; set; }
Visual Basic (Declaration)
Public Property ReportParameter As String
Visual C++
public:
property String^ ReportParameter {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


TextAlign Property

[image]

FastReport.Net Class Reference
ButtonControl..::.TextAlign Property
ButtonControl Class See Also Send Feedback
Gets or sets the alignment of the text on the button control. Wraps the TextAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Overrides Property TextAlign As ContentAlignment
Visual C++
public:
virtual property ContentAlignment TextAlign {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}

See Also

ButtonControl Class
FastReport.Dialog Namespace


ButtonControl Events

[image] [image]

FastReport.Net Class Reference
ButtonControl Events
ButtonControl Class See Also Send Feedback

The ButtonControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ButtonControl Class
FastReport.Dialog Namespace


CheckBoxControl Class

[image]

FastReport.Net Class Reference
CheckBoxControl Class
Members See Also Send Feedback
Represents a Windows CheckBox. Wraps the CheckBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CheckBoxControl : ButtonBaseControl
Visual Basic (Declaration)
Public Class CheckBoxControl _
    Inherits ButtonBaseControl
Visual C++
public ref class CheckBoxControl : public ButtonBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ButtonBaseControl
FastReport.Dialog..::.CheckBoxControl

See Also

CheckBoxControl Members
FastReport.Dialog Namespace


CheckBoxControl Members

[image] [image]

FastReport.Net Class Reference
CheckBoxControl Members
CheckBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The CheckBoxControl type exposes the following members.

Constructors

Name | Description
CheckBoxControl | Initializes a new instance of the CheckBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides ButtonBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnCheckedChanged | This method fires the CheckedChanged event and the script code connected to the CheckedChangedEvent.
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ButtonBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
Appearance | Gets or sets the value that determines the appearance of a CheckBox control. Wraps the Appearance property.
AutoFill | This property is not relevant to this class. (Inherited from ButtonBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property. (Inherited from ButtonBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. Wraps the CheckAlign property.
CheckBox | Gets an internal CheckBox.
Checked | Gets or set a value indicating whether the CheckBox is in the checked state. Wraps the Checked property.
CheckedChangedEvent | Gets or sets a script method name that will be used to handle the CheckedChanged event.
CheckState | Gets or sets the state of the CheckBox. Wraps the CheckState property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property. (Inherited from ButtonBaseControl.)
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property. (Inherited from ButtonBaseControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property. (Inherited from ButtonBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property. (Inherited from ButtonBaseControl.)
ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. Wraps the ThreeState property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
CheckedChanged | Occurs when the value of the Checked property changes. Wraps the CheckedChanged event.
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckBoxControl Constructor

[image]

FastReport.Net Class Reference
CheckBoxControl Constructor
CheckBoxControl Class See Also Send Feedback
Initializes a new instance of the CheckBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CheckBoxControl()

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckBoxControl Methods

[image] [image]

FastReport.Net Class Reference
CheckBoxControl Methods
CheckBoxControl Class See Also Send Feedback

The CheckBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides ButtonBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnCheckedChanged | This method fires the CheckedChanged event and the script code connected to the CheckedChangedEvent.
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ButtonBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
CheckBoxControl..::.AttachEvents Method
CheckBoxControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
CheckBoxControl..::.DetachEvents Method
CheckBoxControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CheckBoxControl..::.Dispose Method
CheckBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

CheckBoxControl Class
CheckBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
CheckBoxControl..::.DrawSelectionPoint Method
CheckBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

CheckBoxControl Class
CheckBoxControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
CheckBoxControl..::.FillData Method
CheckBoxControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

CheckBoxControl Class
CheckBoxControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
CheckBoxControl..::.GetSelectionPoints Method
CheckBoxControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
CheckBoxControl..::.GetValue Method
CheckBoxControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CheckBoxControl..::.MemberwiseClone Method
CheckBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CheckBoxControl Class
CheckBoxControl Members
FastReport.Dialog Namespace


OnCheckedChanged Method

[image]

FastReport.Net Class Reference
CheckBoxControl..::.OnCheckedChanged Method
CheckBoxControl Class See Also Send Feedback
This method fires the CheckedChanged event and the script code connected to the CheckedChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnCheckedChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnCheckedChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnCheckedChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CheckBoxControl..::.Serialize Method
CheckBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckBoxControl Properties

[image] [image]

FastReport.Net Class Reference
CheckBoxControl Properties
CheckBoxControl Class See Also Send Feedback

The CheckBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
Appearance | Gets or sets the value that determines the appearance of a CheckBox control. Wraps the Appearance property.
AutoFill | This property is not relevant to this class. (Inherited from ButtonBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property. (Inherited from ButtonBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. Wraps the CheckAlign property.
CheckBox | Gets an internal CheckBox.
Checked | Gets or set a value indicating whether the CheckBox is in the checked state. Wraps the Checked property.
CheckedChangedEvent | Gets or sets a script method name that will be used to handle the CheckedChanged event.
CheckState | Gets or sets the state of the CheckBox. Wraps the CheckState property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property. (Inherited from ButtonBaseControl.)
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property. (Inherited from ButtonBaseControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property. (Inherited from ButtonBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property. (Inherited from ButtonBaseControl.)
ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. Wraps the ThreeState property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


Appearance Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.Appearance Property
CheckBoxControl Class See Also Send Feedback
Gets or sets the value that determines the appearance of a CheckBox control. Wraps the Appearance property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Appearance Appearance { get; set; }
Visual Basic (Declaration)
Public Property Appearance As Appearance
Visual C++
public:
property Appearance Appearance {
    Appearance get ();
    void set (Appearance value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckAlign Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.CheckAlign Property
CheckBoxControl Class See Also Send Feedback
Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. Wraps the CheckAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ContentAlignment CheckAlign { get; set; }
Visual Basic (Declaration)
Public Property CheckAlign As ContentAlignment
Visual C++
public:
property ContentAlignment CheckAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckBox Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.CheckBox Property
CheckBoxControl Class See Also Send Feedback
Gets an internal CheckBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckBox CheckBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckBox As CheckBox
Visual C++
public:
property CheckBox^ CheckBox {
    CheckBox^ get ();
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


Checked Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.Checked Property
CheckBoxControl Class See Also Send Feedback
Gets or set a value indicating whether the CheckBox is in the checked state. Wraps the Checked property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckedChangedEvent Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.CheckedChangedEvent Property
CheckBoxControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the CheckedChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CheckedChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property CheckedChangedEvent As String
Visual C++
public:
property String^ CheckedChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckState Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.CheckState Property
CheckBoxControl Class See Also Send Feedback
Gets or sets the state of the CheckBox. Wraps the CheckState property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckState CheckState { get; set; }
Visual Basic (Declaration)
Public Property CheckState As CheckState
Visual C++
public:
property CheckState CheckState {
    CheckState get ();
    void set (CheckState value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


ThreeState Property

[image]

FastReport.Net Class Reference
CheckBoxControl..::.ThreeState Property
CheckBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. Wraps the ThreeState property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ThreeState { get; set; }
Visual Basic (Declaration)
Public Property ThreeState As Boolean
Visual C++
public:
property bool ThreeState {
    bool get ();
    void set (bool value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckBoxControl Events

[image] [image]

FastReport.Net Class Reference
CheckBoxControl Events
CheckBoxControl Class See Also Send Feedback

The CheckBoxControl type exposes the following members.

Events

Name | Description
CheckedChanged | Occurs when the value of the Checked property changes. Wraps the CheckedChanged event.
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckedChanged Event

[image]

FastReport.Net Class Reference
CheckBoxControl..::.CheckedChanged Event
CheckBoxControl Class See Also Send Feedback
Occurs when the value of the Checked property changes. Wraps the CheckedChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler CheckedChanged
Visual Basic (Declaration)
Public Event CheckedChanged As EventHandler
Visual C++
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

CheckBoxControl Class
FastReport.Dialog Namespace


CheckedListBoxControl Class

[image]

FastReport.Net Class Reference
CheckedListBoxControl Class
Members See Also Send Feedback
Displays a ListBox in which a check box is displayed to the left of each item. Wraps the CheckedListBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CheckedListBoxControl : ListBoxBaseControl
Visual Basic (Declaration)
Public Class CheckedListBoxControl _
    Inherits ListBoxBaseControl
Visual C++
public ref class CheckedListBoxControl : public ListBoxBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ListBoxBaseControl
FastReport.Dialog..::.CheckedListBoxControl

See Also

CheckedListBoxControl Members
FastReport.Dialog Namespace


CheckedListBoxControl Members

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl Members
CheckedListBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The CheckedListBoxControl type exposes the following members.

Constructors

Name | Description
CheckedListBoxControl | Initializes a new instance of the CheckedListBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides ListBoxBaseControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides ListBoxBaseControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent. (Inherited from ListBoxBaseControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnItemCheck | This method fires the ItemCheck event and the script code connected to the ItemCheckEvent.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent. (Inherited from ListBoxBaseControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent. (Inherited from ListBoxBaseControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ListBoxBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from ListBoxBaseControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from ListBoxBaseControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckedIndices | Collection of checked indexes in this CheckedListBox. Wraps the CheckedIndices property.
CheckedItems | Collection of checked items in this CheckedListBox. Wraps the CheckedItems property.
CheckedListBox | Gets an internal CheckedListBox.
CheckOnClick | Gets or sets a value indicating whether the check box should be toggled when an item is selected. Wraps the CheckOnClick property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property. (Inherited from ListBoxBaseControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event. (Inherited from ListBoxBaseControl.)
DrawMode | This property is not relevant to this class. (Overrides ListBoxBaseControl..::.DrawMode.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemCheckEvent | Gets or sets a script method name that will be used to handle the ItemCheck event.
ItemHeight | This property is not relevant to this class. (Overrides ListBoxBaseControl..::.ItemHeight.)
Items | Gets the items of the ListBox. Wraps the Items property. (Inherited from ListBoxBaseControl.)
ItemsText | Gets or sets the string that contains all items text. (Inherited from ListBoxBaseControl.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property. (Inherited from ListBoxBaseControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property. (Inherited from ListBoxBaseControl.)
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property. (Inherited from ListBoxBaseControl.)
SelectedItem | Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property. (Inherited from ListBoxBaseControl.)
SelectedItems | Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property. (Inherited from ListBoxBaseControl.)
SelectionMode | Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property. (Inherited from ListBoxBaseControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property. (Inherited from ListBoxBaseControl.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Inherited from ListBoxBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property. (Inherited from ListBoxBaseControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event. (Inherited from ListBoxBaseControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
ItemCheck | Occurs after item's check state was changed. Wraps the ItemCheck event.
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedListBoxControl Constructor

[image]

FastReport.Net Class Reference
CheckedListBoxControl Constructor
CheckedListBoxControl Class See Also Send Feedback
Initializes a new instance of the CheckedListBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckedListBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CheckedListBoxControl()

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedListBoxControl Methods

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl Methods
CheckedListBoxControl Class See Also Send Feedback

The CheckedListBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides ListBoxBaseControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides ListBoxBaseControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent. (Inherited from ListBoxBaseControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnItemCheck | This method fires the ItemCheck event and the script code connected to the ItemCheckEvent.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent. (Inherited from ListBoxBaseControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent. (Inherited from ListBoxBaseControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ListBoxBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from ListBoxBaseControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from ListBoxBaseControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.AttachEvents Method
CheckedListBoxControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.DetachEvents Method
CheckedListBoxControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl..::.Dispose Method
CheckedListBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides DialogControl..::.Dispose(Boolean).)

See Also

CheckedListBoxControl Class
CheckedListBoxControl Members
FastReport.Dialog Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.Dispose Method (Boolean)
CheckedListBoxControl Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

CheckedListBoxControl Class
Dispose Overload
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl..::.DrawSelectionPoint Method
CheckedListBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

CheckedListBoxControl Class
CheckedListBoxControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl..::.FillData Method
CheckedListBoxControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from ListBoxBaseControl.)

See Also

CheckedListBoxControl Class
CheckedListBoxControl Members
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.GetValue Method
CheckedListBoxControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl..::.MemberwiseClone Method
CheckedListBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CheckedListBoxControl Class
CheckedListBoxControl Members
FastReport.Dialog Namespace


OnItemCheck Method

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.OnItemCheck Method
CheckedListBoxControl Class See Also Send Feedback
This method fires the ItemCheck event and the script code connected to the ItemCheckEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnItemCheck(
    ItemCheckEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnItemCheck ( _
    e As ItemCheckEventArgs _
)
Visual C++
public:
virtual void OnItemCheck(
    ItemCheckEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.ItemCheckEventArgs
Event data.

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.Serialize Method
CheckedListBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedListBoxControl Properties

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl Properties
CheckedListBoxControl Class See Also Send Feedback

The CheckedListBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckedIndices | Collection of checked indexes in this CheckedListBox. Wraps the CheckedIndices property.
CheckedItems | Collection of checked items in this CheckedListBox. Wraps the CheckedItems property.
CheckedListBox | Gets an internal CheckedListBox.
CheckOnClick | Gets or sets a value indicating whether the check box should be toggled when an item is selected. Wraps the CheckOnClick property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property. (Inherited from ListBoxBaseControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event. (Inherited from ListBoxBaseControl.)
DrawMode | This property is not relevant to this class. (Overrides ListBoxBaseControl..::.DrawMode.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemCheckEvent | Gets or sets a script method name that will be used to handle the ItemCheck event.
ItemHeight | This property is not relevant to this class. (Overrides ListBoxBaseControl..::.ItemHeight.)
Items | Gets the items of the ListBox. Wraps the Items property. (Inherited from ListBoxBaseControl.)
ItemsText | Gets or sets the string that contains all items text. (Inherited from ListBoxBaseControl.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property. (Inherited from ListBoxBaseControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property. (Inherited from ListBoxBaseControl.)
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property. (Inherited from ListBoxBaseControl.)
SelectedItem | Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property. (Inherited from ListBoxBaseControl.)
SelectedItems | Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property. (Inherited from ListBoxBaseControl.)
SelectionMode | Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property. (Inherited from ListBoxBaseControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property. (Inherited from ListBoxBaseControl.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Inherited from ListBoxBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property. (Inherited from ListBoxBaseControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedIndices Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.CheckedIndices Property
CheckedListBoxControl Class See Also Send Feedback
Collection of checked indexes in this CheckedListBox. Wraps the CheckedIndices property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckedListBox..::.CheckedIndexCollection CheckedIndices { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedIndices As CheckedListBox..::.CheckedIndexCollection
Visual C++
public:
property CheckedListBox..::.CheckedIndexCollection^ CheckedIndices {
    CheckedListBox..::.CheckedIndexCollection^ get ();
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedItems Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.CheckedItems Property
CheckedListBoxControl Class See Also Send Feedback
Collection of checked items in this CheckedListBox. Wraps the CheckedItems property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckedListBox..::.CheckedItemCollection CheckedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedItems As CheckedListBox..::.CheckedItemCollection
Visual C++
public:
property CheckedListBox..::.CheckedItemCollection^ CheckedItems {
    CheckedListBox..::.CheckedItemCollection^ get ();
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedListBox Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.CheckedListBox Property
CheckedListBoxControl Class See Also Send Feedback
Gets an internal CheckedListBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CheckedListBox CheckedListBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedListBox As CheckedListBox
Visual C++
public:
property CheckedListBox^ CheckedListBox {
    CheckedListBox^ get ();
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckOnClick Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.CheckOnClick Property
CheckedListBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether the check box should be toggled when an item is selected. Wraps the CheckOnClick property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CheckOnClick { get; set; }
Visual Basic (Declaration)
Public Property CheckOnClick As Boolean
Visual C++
public:
property bool CheckOnClick {
    bool get ();
    void set (bool value);
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


DrawMode Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.DrawMode Property
CheckedListBoxControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DrawMode DrawMode { get; set; }
Visual Basic (Declaration)
Public Overrides Property DrawMode As DrawMode
Visual C++
public:
virtual property DrawMode DrawMode {
    DrawMode get () override;
    void set (DrawMode value) override;
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


ItemCheckEvent Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.ItemCheckEvent Property
CheckedListBoxControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ItemCheck event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ItemCheckEvent { get; set; }
Visual Basic (Declaration)
Public Property ItemCheckEvent As String
Visual C++
public:
property String^ ItemCheckEvent {
    String^ get ();
    void set (String^ value);
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


ItemHeight Property

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.ItemHeight Property
CheckedListBoxControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int ItemHeight { get; set; }
Visual Basic (Declaration)
Public Overrides Property ItemHeight As Integer
Visual C++
public:
virtual property int ItemHeight {
    int get () override;
    void set (int value) override;
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


CheckedListBoxControl Events

[image] [image]

FastReport.Net Class Reference
CheckedListBoxControl Events
CheckedListBoxControl Class See Also Send Feedback

The CheckedListBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event. (Inherited from ListBoxBaseControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
ItemCheck | Occurs after item's check state was changed. Wraps the ItemCheck event.
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


ItemCheck Event

[image]

FastReport.Net Class Reference
CheckedListBoxControl..::.ItemCheck Event
CheckedListBoxControl Class See Also Send Feedback
Occurs after item's check state was changed. Wraps the ItemCheck event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ItemCheckEventHandler ItemCheck
Visual Basic (Declaration)
Public Event ItemCheck As ItemCheckEventHandler
Visual C++
public:
 event ItemCheckEventHandler^ ItemCheck {
    void add (ItemCheckEventHandler^ value);
    void remove (ItemCheckEventHandler^ value);
}

See Also

CheckedListBoxControl Class
FastReport.Dialog Namespace


ComboBoxControl Class

[image]

FastReport.Net Class Reference
ComboBoxControl Class
Members See Also Send Feedback
Represents a Windows combo box control. Wraps the ComboBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ComboBoxControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class ComboBoxControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class ComboBoxControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ComboBoxControl

See Also

ComboBoxControl Members
FastReport.Dialog Namespace


ComboBoxControl Members

[image] [image]

FastReport.Net Class Reference
ComboBoxControl Members
ComboBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The ComboBoxControl type exposes the following members.

Constructors

Name | Description
ComboBoxControl | Initializes a new instance of the ComboBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent.
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ComboBox | Gets an internal ComboBox.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event.
DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. Wraps the DrawMode property.
DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox. Wraps the DropDownHeight property.
DropDownStyle | Gets or sets a value specifying the style of the combo box. Wraps the DropDownStyle property.
DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. Wraps the DropDownWidth property.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemHeight | Gets or sets the height of an item in the combo box. Wraps the ItemHeight property.
Items | Gets a collection of the items contained in this ComboBox. Wraps the Items property.
ItemsText | Gets or sets the string that contains all items text.
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. Wraps the MaxDropDownItems property.
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the index specifying the currently selected item. Wraps the SelectedIndex property.
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.
SelectedItem | Gets or sets currently selected item in the ComboBox. Wraps the SelectedItem property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. Wraps the Sorted property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ComboBox changes. Wraps the DrawItem event.
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined. Wraps the MeasureItem event.
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs after the selection has been changed. Wraps the SelectedIndexChanged event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ComboBoxControl Constructor

[image]

FastReport.Net Class Reference
ComboBoxControl Constructor
ComboBoxControl Class See Also Send Feedback
Initializes a new instance of the ComboBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComboBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ComboBoxControl()

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ComboBoxControl Methods

[image] [image]

FastReport.Net Class Reference
ComboBoxControl Methods
ComboBoxControl Class See Also Send Feedback

The ComboBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent.
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.AttachEvents Method
ComboBoxControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DetachEvents Method
ComboBoxControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ComboBoxControl..::.Dispose Method
ComboBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ComboBoxControl Class
ComboBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ComboBoxControl..::.DrawSelectionPoint Method
ComboBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ComboBoxControl Class
ComboBoxControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
ComboBoxControl..::.FillData Method
ComboBoxControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Overrides DataFilterBaseControl..::.FillData(DataSourceBase, Column).)

See Also

ComboBoxControl Class
ComboBoxControl Members
FastReport.Dialog Namespace


FillData Method (DataSourceBase, Column)

[image]

FastReport.Net Class Reference
ComboBoxControl..::.FillData Method (DataSourceBase, Column)
ComboBoxControl Class Example See Also Send Feedback
Fills the control with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void FillData(
    DataSourceBase dataSource,
    Column column
)
Visual Basic (Declaration)
Protected Overrides Sub FillData ( _
    dataSource As DataSourceBase, _
    column As Column _
)
Visual C++
protected:
virtual void FillData(
    DataSourceBase^ dataSource,
    Column^ column
) override

Parameters

dataSource
Type: FastReport.Data..::.DataSourceBase
The data source.
column
Type: FastReport.Data..::.Column
The data column.

Examples

Here is the example of FillData method implementation:
CopyC#
protected override void FillData(DataSourceBase dataSource, Column column)
{
  Items.Clear();
  dataSource.First();
  while (dataSource.HasMoreRows)
  {
    Items.Add(dataSource[column].ToString());
    dataSource.Next();
  }
}

See Also

ComboBoxControl Class
FillData Overload
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.GetSelectionPoints Method
ComboBoxControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.GetValue Method
ComboBoxControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ComboBoxControl..::.MemberwiseClone Method
ComboBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ComboBoxControl Class
ComboBoxControl Members
FastReport.Dialog Namespace


OnDrawItem Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.OnDrawItem Method
ComboBoxControl Class See Also Send Feedback
This method fires the DrawItem event and the script code connected to the DrawItemEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnDrawItem(
    DrawItemEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnDrawItem ( _
    e As DrawItemEventArgs _
)
Visual C++
public:
virtual void OnDrawItem(
    DrawItemEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.DrawItemEventArgs
Event data.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


OnLeave Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.OnLeave Method
ComboBoxControl Class See Also Send Feedback
This method fires the Leave event and the script code connected to the LeaveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


OnMeasureItem Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.OnMeasureItem Method
ComboBoxControl Class See Also Send Feedback
This method fires the MeasureItem event and the script code connected to the MeasureItemEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMeasureItem(
    MeasureItemEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMeasureItem ( _
    e As MeasureItemEventArgs _
)
Visual C++
public:
virtual void OnMeasureItem(
    MeasureItemEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MeasureItemEventArgs
Event data.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


OnSelectedIndexChanged Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.OnSelectedIndexChanged Method
ComboBoxControl Class See Also Send Feedback
This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.Serialize Method
ComboBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.ShouldSerializeBackColor Method
ComboBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
ComboBoxControl..::.ShouldSerializeForeColor Method
ComboBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ComboBoxControl Properties

[image] [image]

FastReport.Net Class Reference
ComboBoxControl Properties
ComboBoxControl Class See Also Send Feedback

The ComboBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ComboBox | Gets an internal ComboBox.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event.
DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. Wraps the DrawMode property.
DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox. Wraps the DropDownHeight property.
DropDownStyle | Gets or sets a value specifying the style of the combo box. Wraps the DropDownStyle property.
DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. Wraps the DropDownWidth property.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemHeight | Gets or sets the height of an item in the combo box. Wraps the ItemHeight property.
Items | Gets a collection of the items contained in this ComboBox. Wraps the Items property.
ItemsText | Gets or sets the string that contains all items text.
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. Wraps the MaxDropDownItems property.
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the index specifying the currently selected item. Wraps the SelectedIndex property.
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.
SelectedItem | Gets or sets currently selected item in the ComboBox. Wraps the SelectedItem property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. Wraps the Sorted property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ComboBox Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.ComboBox Property
ComboBoxControl Class See Also Send Feedback
Gets an internal ComboBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComboBox ComboBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property ComboBox As ComboBox
Visual C++
public:
property ComboBox^ ComboBox {
    ComboBox^ get ();
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DrawItemEvent Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DrawItemEvent Property
ComboBoxControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the DrawItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DrawItemEvent { get; set; }
Visual Basic (Declaration)
Public Property DrawItemEvent As String
Visual C++
public:
property String^ DrawItemEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DrawMode Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DrawMode Property
ComboBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. Wraps the DrawMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DrawMode DrawMode { get; set; }
Visual Basic (Declaration)
Public Property DrawMode As DrawMode
Visual C++
public:
property DrawMode DrawMode {
    DrawMode get ();
    void set (DrawMode value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DropDownHeight Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DropDownHeight Property
ComboBoxControl Class See Also Send Feedback
Gets or sets the height in pixels of the drop-down portion of the ComboBox. Wraps the DropDownHeight property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Integer
Visual C++
public:
property int DropDownHeight {
    int get ();
    void set (int value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DropDownStyle Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DropDownStyle Property
ComboBoxControl Class See Also Send Feedback
Gets or sets a value specifying the style of the combo box. Wraps the DropDownStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComboBoxStyle DropDownStyle { get; set; }
Visual Basic (Declaration)
Public Property DropDownStyle As ComboBoxStyle
Visual C++
public:
property ComboBoxStyle DropDownStyle {
    ComboBoxStyle get ();
    void set (ComboBoxStyle value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DropDownWidth Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DropDownWidth Property
ComboBoxControl Class See Also Send Feedback
Gets or sets the width of the of the drop-down portion of a combo box. Wraps the DropDownWidth property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Integer
Visual C++
public:
property int DropDownWidth {
    int get ();
    void set (int value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ItemHeight Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.ItemHeight Property
ComboBoxControl Class See Also Send Feedback
Gets or sets the height of an item in the combo box. Wraps the ItemHeight property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ItemHeight { get; set; }
Visual Basic (Declaration)
Public Property ItemHeight As Integer
Visual C++
public:
property int ItemHeight {
    int get ();
    void set (int value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


Items Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.Items Property
ComboBoxControl Class See Also Send Feedback
Gets a collection of the items contained in this ComboBox. Wraps the Items property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComboBox..::.ObjectCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ComboBox..::.ObjectCollection
Visual C++
public:
property ComboBox..::.ObjectCollection^ Items {
    ComboBox..::.ObjectCollection^ get ();
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ItemsText Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.ItemsText Property
ComboBoxControl Class See Also Send Feedback
Gets or sets the string that contains all items text.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ItemsText { get; set; }
Visual Basic (Declaration)
Public Property ItemsText As String
Visual C++
public:
property String^ ItemsText {
    String^ get ();
    void set (String^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


MaxDropDownItems Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.MaxDropDownItems Property
ComboBoxControl Class See Also Send Feedback
Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. Wraps the MaxDropDownItems property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int MaxDropDownItems { get; set; }
Visual Basic (Declaration)
Public Property MaxDropDownItems As Integer
Visual C++
public:
property int MaxDropDownItems {
    int get ();
    void set (int value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


MeasureItemEvent Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.MeasureItemEvent Property
ComboBoxControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MeasureItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MeasureItemEvent { get; set; }
Visual Basic (Declaration)
Public Property MeasureItemEvent As String
Visual C++
public:
property String^ MeasureItemEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


SelectedIndex Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.SelectedIndex Property
ComboBoxControl Class See Also Send Feedback
Gets or sets the index specifying the currently selected item. Wraps the SelectedIndex property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


SelectedIndexChangedEvent Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.SelectedIndexChangedEvent Property
ComboBoxControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectedIndexChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndexChangedEvent As String
Visual C++
public:
property String^ SelectedIndexChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


SelectedItem Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.SelectedItem Property
ComboBoxControl Class See Also Send Feedback
Gets or sets currently selected item in the ComboBox. Wraps the SelectedItem property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object
Visual C++
public:
property Object^ SelectedItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


Sorted Property

[image]

FastReport.Net Class Reference
ComboBoxControl..::.Sorted Property
ComboBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether the items in the combo box are sorted. Wraps the Sorted property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Sorted { get; set; }
Visual Basic (Declaration)
Public Property Sorted As Boolean
Visual C++
public:
property bool Sorted {
    bool get ();
    void set (bool value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


ComboBoxControl Events

[image] [image]

FastReport.Net Class Reference
ComboBoxControl Events
ComboBoxControl Class See Also Send Feedback

The ComboBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ComboBox changes. Wraps the DrawItem event.
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined. Wraps the MeasureItem event.
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs after the selection has been changed. Wraps the SelectedIndexChanged event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DrawItem Event

[image]

FastReport.Net Class Reference
ComboBoxControl..::.DrawItem Event
ComboBoxControl Class See Also Send Feedback
Occurs when a visual aspect of an owner-drawn ComboBox changes. Wraps the DrawItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event DrawItemEventHandler DrawItem
Visual Basic (Declaration)
Public Event DrawItem As DrawItemEventHandler
Visual C++
public:
 event DrawItemEventHandler^ DrawItem {
    void add (DrawItemEventHandler^ value);
    void remove (DrawItemEventHandler^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


MeasureItem Event

[image]

FastReport.Net Class Reference
ComboBoxControl..::.MeasureItem Event
ComboBoxControl Class See Also Send Feedback
Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined. Wraps the MeasureItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MeasureItemEventHandler MeasureItem
Visual Basic (Declaration)
Public Event MeasureItem As MeasureItemEventHandler
Visual C++
public:
 event MeasureItemEventHandler^ MeasureItem {
    void add (MeasureItemEventHandler^ value);
    void remove (MeasureItemEventHandler^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


SelectedIndexChanged Event

[image]

FastReport.Net Class Reference
ComboBoxControl..::.SelectedIndexChanged Event
ComboBoxControl Class See Also Send Feedback
Occurs after the selection has been changed. Wraps the SelectedIndexChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic (Declaration)
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ComboBoxControl Class
FastReport.Dialog Namespace


DataFilterBaseControl Class

[image]

FastReport.Net Class Reference
DataFilterBaseControl Class
Members See Also Send Feedback
The base class for all controls that support the data filtering feature.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class DataFilterBaseControl : DialogControl
Visual Basic (Declaration)
Public MustInherit Class DataFilterBaseControl _
    Inherits DialogControl
Visual C++
public ref class DataFilterBaseControl abstract : public DialogControl

Remarks

The data filtering allows you to bind the control to a DataColumn. It will be automatically filled by data from the datasource's column. When you select/check item(s) and close the dialog with OK button, it will filter the datasource according to your selection.

You can set the filter operation using the FilterOperation property.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ButtonBaseControl
FastReport.Dialog..::.ComboBoxControl
FastReport.Dialog..::.DataSelectorControl
FastReport.Dialog..::.DateTimePickerControl
FastReport.Dialog..::.ListBoxBaseControl
FastReport.Dialog..::.MaskedTextBoxControl
FastReport.Dialog..::.MonthCalendarControl
FastReport.Dialog..::.NumericUpDownControl
FastReport.Dialog..::.TextBoxControl

See Also

DataFilterBaseControl Members
FastReport.Dialog Namespace


DataFilterBaseControl Members

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl Members
DataFilterBaseControl Class Constructors Methods Properties Events See Also Send Feedback

The DataFilterBaseControl type exposes the following members.

Constructors

Name | Description
DataFilterBaseControl | Initializes a new instance of the DataFilterBaseControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data.
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control.
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Overrides DialogControl..::.InitializeControl()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent.
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Overrides DialogControl..::.OnEnabledChanged()()().)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically.
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data.
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering.
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog.
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataFilterBaseControl Constructor

[image]

FastReport.Net Class Reference
DataFilterBaseControl Constructor
DataFilterBaseControl Class See Also Send Feedback
Initializes a new instance of the DataFilterBaseControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataFilterBaseControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataFilterBaseControl()

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataFilterBaseControl Methods

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl Methods
DataFilterBaseControl Class See Also Send Feedback

The DataFilterBaseControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data.
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control.
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Overrides DialogControl..::.InitializeControl()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent.
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Overrides DialogControl..::.OnEnabledChanged()()().)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl..::.Dispose Method
DataFilterBaseControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

DataFilterBaseControl Class
DataFilterBaseControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl..::.DrawSelectionPoint Method
DataFilterBaseControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

DataFilterBaseControl Class
DataFilterBaseControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FillData Method
DataFilterBaseControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource.
FillData(DataSourceBase) | Fills the control with data from a datasource.
FillData(DataFilterBaseControl) | Fills the control with data from a datasource.
FillData(DataSourceBase, Column) | Fills the control with data.

See Also

DataFilterBaseControl Class
DataFilterBaseControl Members
FastReport.Dialog Namespace


FillData Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FillData Method
DataFilterBaseControl Class See Also Send Feedback
Fills the control with data from a datasource.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void FillData()
Visual Basic (Declaration)
Public Sub FillData
Visual C++
public:
void FillData()

Remarks

Call this method if you set the AutoFill property to false.

See Also

DataFilterBaseControl Class
FillData Overload
FastReport.Dialog Namespace


FillData Method (DataSourceBase)

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FillData Method (DataSourceBase)
DataFilterBaseControl Class See Also Send Feedback
Fills the control with data from a datasource.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void FillData(
    DataSourceBase parentData
)
Visual Basic (Declaration)
Public Sub FillData ( _
    parentData As DataSourceBase _
)
Visual C++
public:
void FillData(
    DataSourceBase^ parentData
)

Parameters

parentData
Type: FastReport.Data..::.DataSourceBase
Parent data source

Remarks

Call this method if you need to implement cascaded filter. In the parentData parameter, pass the parent data source that will be used to set up master-detail relationship with data source in this control.

See Also

DataFilterBaseControl Class
FillData Overload
FastReport.Dialog Namespace


FillData Method (DataFilterBaseControl)

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FillData Method (DataFilterBaseControl)
DataFilterBaseControl Class See Also Send Feedback
Fills the control with data from a datasource.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void FillData(
    DataFilterBaseControl parentControl
)
Visual Basic (Declaration)
Public Sub FillData ( _
    parentControl As DataFilterBaseControl _
)
Visual C++
public:
void FillData(
    DataFilterBaseControl^ parentControl
)

Parameters

parentControl
Type: FastReport.Dialog..::.DataFilterBaseControl
Parent control

Remarks

Call this method if you need to implement cascaded filter. In the parentControl parameter, pass the parent control which performs filtering on a parent data source.

See Also

DataFilterBaseControl Class
FillData Overload
FastReport.Dialog Namespace


FillData Method (DataSourceBase, Column)

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FillData Method (DataSourceBase, Column)
DataFilterBaseControl Class Example See Also Send Feedback
Fills the control with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void FillData(
    DataSourceBase dataSource,
    Column column
)
Visual Basic (Declaration)
Protected Overridable Sub FillData ( _
    dataSource As DataSourceBase, _
    column As Column _
)
Visual C++
protected:
virtual void FillData(
    DataSourceBase^ dataSource,
    Column^ column
)

Parameters

dataSource
Type: FastReport.Data..::.DataSourceBase
The data source.
column
Type: FastReport.Data..::.Column
The data column.

Examples

Here is the example of FillData method implementation:
CopyC#
protected override void FillData(DataSourceBase dataSource, Column column)
{
  Items.Clear();
  dataSource.First();
  while (dataSource.HasMoreRows)
  {
    Items.Add(dataSource[column].ToString());
    dataSource.Next();
  }
}

See Also

DataFilterBaseControl Class
FillData Overload
FastReport.Dialog Namespace


FilterData Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FilterData Method
DataFilterBaseControl Class See Also Send Feedback
Applies the filter to a datasource.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void FilterData()
Visual Basic (Declaration)
Public Sub FilterData
Visual C++
public:
void FilterData()

Remarks

Call this method if you set the AutoFilter property to false.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


GetListOfData Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.GetListOfData Method
DataFilterBaseControl Class See Also Send Feedback
Returns list of values that can be used to fill control with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected string[] GetListOfData(
    DataSourceBase dataSource,
    Column column
)
Visual Basic (Declaration)
Protected Function GetListOfData ( _
    dataSource As DataSourceBase, _
    column As Column _
) As String()
Visual C++
protected:
array<String^>^ GetListOfData(
    DataSourceBase^ dataSource,
    Column^ column
)

Parameters

dataSource
Type: FastReport.Data..::.DataSourceBase
The data source.
column
Type: FastReport.Data..::.Column
The data column.

Return Value

List of string values.

Remarks

This method is used by the FillData method to fill list-type controls such as ListBox with data. The result list contains distinct values.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.GetValue Method
DataFilterBaseControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected abstract Object GetValue()
Visual Basic (Declaration)
Protected MustOverride Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() abstract

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


InitializeControl Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.InitializeControl Method
DataFilterBaseControl Class See Also Send Feedback
Initializes the control before display it in the dialog form.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeControl()
Visual Basic (Declaration)
Public Overrides Sub InitializeControl
Visual C++
public:
virtual void InitializeControl() override

Remarks

This method is called when report is run.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl..::.MemberwiseClone Method
DataFilterBaseControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataFilterBaseControl Class
DataFilterBaseControl Members
FastReport.Dialog Namespace


OnDataLoaded Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.OnDataLoaded Method
DataFilterBaseControl Class See Also Send Feedback
This method fires the DataLoaded event and the script code connected to the DataLoadedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnDataLoaded(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnDataLoaded ( _
    e As EventArgs _
)
Visual C++
public:
void OnDataLoaded(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


OnEnabledChanged Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.OnEnabledChanged Method
DataFilterBaseControl Class See Also Send Feedback
Called when the control's Enabled state changed.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnEnabledChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnEnabledChanged
Visual C++
protected:
virtual void OnEnabledChanged() override

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


OnFilterChanged Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.OnFilterChanged Method
DataFilterBaseControl Class See Also Send Feedback
Handles the cascaded filter internal logic.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void OnFilterChanged()
Visual Basic (Declaration)
Protected Sub OnFilterChanged
Visual C++
protected:
void OnFilterChanged()

Remarks

This method should be called in your custom dialog control that supports data filtering. Call it when the value in your control is changed.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


ResetFilter Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.ResetFilter Method
DataFilterBaseControl Class See Also Send Feedback
Resets the filter set by this control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ResetFilter()
Visual Basic (Declaration)
Public Sub ResetFilter
Visual C++
public:
void ResetFilter()

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.Serialize Method
DataFilterBaseControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataFilterBaseControl Properties

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl Properties
DataFilterBaseControl Class See Also Send Feedback

The DataFilterBaseControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically.
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data.
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering.
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog.
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


AutoFill Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.AutoFill Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets a value that determines whether to fill the control with data automatically.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFill { get; set; }
Visual Basic (Declaration)
Public Property AutoFill As Boolean
Visual C++
public:
property bool AutoFill {
    bool get ();
    void set (bool value);
}

Remarks

The default value of this property is true. If you set it to false, you need to call the FillData()()() method manually.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


AutoFilter Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.AutoFilter Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFilter { get; set; }
Visual Basic (Declaration)
Public Property AutoFilter As Boolean
Visual C++
public:
property bool AutoFilter {
    bool get ();
    void set (bool value);
}

Remarks

The default value of this property is true. If you set it to false, you need to call the FilterData()()() method manually.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.DataColumn Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets a data column name that will be used to fill this control with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

This property must contain both datasource name and column name, for example: Orders.OrderID. You also may use relations, for example: Orders.Customers.CompanyName.

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataLoadedEvent Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.DataLoadedEvent Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the DataLoaded event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataLoadedEvent { get; set; }
Visual Basic (Declaration)
Public Property DataLoadedEvent As String
Visual C++
public:
property String^ DataLoadedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DetailControl Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.DetailControl Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets the detail control used in cascaded filtering.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataFilterBaseControl DetailControl { get; set; }
Visual Basic (Declaration)
Public Property DetailControl As DataFilterBaseControl
Visual C++
public:
property DataFilterBaseControl^ DetailControl {
    DataFilterBaseControl^ get ();
    void set (DataFilterBaseControl^ value);
}

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


FilterOperation Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.FilterOperation Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets a value that specifies the filter operation.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FilterOperation FilterOperation { get; set; }
Visual Basic (Declaration)
Public Property FilterOperation As FilterOperation
Visual C++
public:
property FilterOperation FilterOperation {
    FilterOperation get ();
    void set (FilterOperation value);
}

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


ReportParameter Property

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.ReportParameter Property
DataFilterBaseControl Class See Also Send Feedback
Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportParameter { get; set; }
Visual Basic (Declaration)
Public Property ReportParameter As String
Visual C++
public:
property String^ ReportParameter {
    String^ get ();
    void set (String^ value);
}

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataFilterBaseControl Events

[image] [image]

FastReport.Net Class Reference
DataFilterBaseControl Events
DataFilterBaseControl Class See Also Send Feedback

The DataFilterBaseControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataLoaded Event

[image]

FastReport.Net Class Reference
DataFilterBaseControl..::.DataLoaded Event
DataFilterBaseControl Class See Also Send Feedback
Occurs after the control is filled with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler DataLoaded
Visual Basic (Declaration)
Public Event DataLoaded As EventHandler
Visual C++
public:
 event EventHandler^ DataLoaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataFilterBaseControl Class
FastReport.Dialog Namespace


DataSelectorControl Class

[image]

FastReport.Net Class Reference
DataSelectorControl Class
Members See Also Send Feedback
Represents the control with two lists (available items and selected items).

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataSelectorControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class DataSelectorControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class DataSelectorControl : public DataFilterBaseControl

Remarks

The control allows to select one or several items and then filter the datasource which it is connected to. All you need is to setup the DataColumn property.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.DataSelectorControl

See Also

DataSelectorControl Members
FastReport.Dialog Namespace


DataSelectorControl Members

[image] [image]

FastReport.Net Class Reference
DataSelectorControl Members
DataSelectorControl Class Constructors Methods Properties Events See Also Send Feedback

The DataSelectorControl type exposes the following members.

Constructors

Name | Description
DataSelectorControl | Initializes a new instance of the DataSelectorControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides DialogControl..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class.
AutoFilter | This property is not relevant to this class.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides DialogControl..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating that the items must be sorted.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Overrides DialogControl..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


DataSelectorControl Constructor

[image]

FastReport.Net Class Reference
DataSelectorControl Constructor
DataSelectorControl Class See Also Send Feedback
Initializes a new instance of the DataSelectorControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSelectorControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataSelectorControl()

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


DataSelectorControl Methods

[image] [image]

FastReport.Net Class Reference
DataSelectorControl Methods
DataSelectorControl Class See Also Send Feedback

The DataSelectorControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides DialogControl..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DataSelectorControl..::.Dispose Method
DataSelectorControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

DataSelectorControl Class
DataSelectorControl Members
FastReport.Dialog Namespace


Draw Method

[image]

FastReport.Net Class Reference
DataSelectorControl..::.Draw Method
DataSelectorControl Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
DataSelectorControl..::.DrawSelectionPoint Method
DataSelectorControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

DataSelectorControl Class
DataSelectorControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
DataSelectorControl..::.FillData Method
DataSelectorControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Overrides DataFilterBaseControl..::.FillData(DataSourceBase, Column).)

See Also

DataSelectorControl Class
DataSelectorControl Members
FastReport.Dialog Namespace


FillData Method (DataSourceBase, Column)

[image]

FastReport.Net Class Reference
DataSelectorControl..::.FillData Method (DataSourceBase, Column)
DataSelectorControl Class Example See Also Send Feedback
Fills the control with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void FillData(
    DataSourceBase dataSource,
    Column column
)
Visual Basic (Declaration)
Protected Overrides Sub FillData ( _
    dataSource As DataSourceBase, _
    column As Column _
)
Visual C++
protected:
virtual void FillData(
    DataSourceBase^ dataSource,
    Column^ column
) override

Parameters

dataSource
Type: FastReport.Data..::.DataSourceBase
The data source.
column
Type: FastReport.Data..::.Column
The data column.

Examples

Here is the example of FillData method implementation:
CopyC#
protected override void FillData(DataSourceBase dataSource, Column column)
{
  Items.Clear();
  dataSource.First();
  while (dataSource.HasMoreRows)
  {
    Items.Add(dataSource[column].ToString());
    dataSource.Next();
  }
}

See Also

DataSelectorControl Class
FillData Overload
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
DataSelectorControl..::.GetValue Method
DataSelectorControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DataSelectorControl..::.MemberwiseClone Method
DataSelectorControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataSelectorControl Class
DataSelectorControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DataSelectorControl..::.Serialize Method
DataSelectorControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


DataSelectorControl Properties

[image] [image]

FastReport.Net Class Reference
DataSelectorControl Properties
DataSelectorControl Class See Also Send Feedback

The DataSelectorControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class.
AutoFilter | This property is not relevant to this class.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides DialogControl..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating that the items must be sorted.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Overrides DialogControl..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


AutoFill Property

[image]

FastReport.Net Class Reference
DataSelectorControl..::.AutoFill Property
DataSelectorControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFill { get; set; }
Visual Basic (Declaration)
Public Property AutoFill As Boolean
Visual C++
public:
property bool AutoFill {
    bool get ();
    void set (bool value);
}

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


AutoFilter Property

[image]

FastReport.Net Class Reference
DataSelectorControl..::.AutoFilter Property
DataSelectorControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoFilter { get; set; }
Visual Basic (Declaration)
Public Property AutoFilter As Boolean
Visual C++
public:
property bool AutoFilter {
    bool get ();
    void set (bool value);
}

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


Height Property

[image]

FastReport.Net Class Reference
DataSelectorControl..::.Height Property
DataSelectorControl Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


Sorted Property

[image]

FastReport.Net Class Reference
DataSelectorControl..::.Sorted Property
DataSelectorControl Class See Also Send Feedback
Gets or sets a value indicating that the items must be sorted.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Sorted { get; set; }
Visual Basic (Declaration)
Public Property Sorted As Boolean
Visual C++
public:
property bool Sorted {
    bool get ();
    void set (bool value);
}

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


Width Property

[image]

FastReport.Net Class Reference
DataSelectorControl..::.Width Property
DataSelectorControl Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


DataSelectorControl Events

[image] [image]

FastReport.Net Class Reference
DataSelectorControl Events
DataSelectorControl Class See Also Send Feedback

The DataSelectorControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

DataSelectorControl Class
FastReport.Dialog Namespace


DateTimePickerControl Class

[image]

FastReport.Net Class Reference
DateTimePickerControl Class
Members See Also Send Feedback
Represents a Windows control that allows the user to select a date and a time and to display the date and time with a specified format. Wraps the DateTimePicker control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DateTimePickerControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class DateTimePickerControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class DateTimePickerControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.DateTimePickerControl

See Also

DateTimePickerControl Members
FastReport.Dialog Namespace


DateTimePickerControl Members

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl Members
DateTimePickerControl Class Constructors Methods Properties Events See Also Send Feedback

The DateTimePickerControl type exposes the following members.

Constructors

Name | Description
DateTimePickerControl | Initializes a new instance of the DateTimePickerControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
OnValueChanged | This method fires the ValueChanged event and the script code connected to the ValueChangedEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Checked | Gets or sets a value indicating whether the Value property has been set with a valid date/time value and the displayed value is able to be updated. Wraps the Checked property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
CustomFormat | Gets or sets the custom date/time format string. Wraps the CustomFormat property.
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DateTimePicker | Gets an internal DateTimePicker.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DropDownAlign | Gets or sets the alignment of the drop-down calendar on the DateTimePicker control. Wraps the DropDownAlign property.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
Format | Gets or sets the format of the date and time displayed in the control. Wraps the Format property.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxDate | Gets or sets the maximum date and time that can be selected in the control. Wraps the MaxDate property.
MinDate | Gets or sets the minimum date and time that can be selected in the control. Wraps the MinDate property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
ShowCheckBox | Gets or sets a value indicating whether a check box is displayed to the left of the selected date. Wraps the ShowCheckBox property.
ShowUpDown | Gets or sets a value indicating whether a spin button control (also known as an up-down control) is used to adjust the date/time value. Wraps the ShowUpDown property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Value | Gets or sets the date/time value assigned to the control. Wraps the Value property.
ValueChangedEvent | Gets or sets a script method name that will be used to handle the ValueChanged event.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)
ValueChanged | Occurs after the date has been changed. Wraps the ValueChanged event.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DateTimePickerControl Constructor

[image]

FastReport.Net Class Reference
DateTimePickerControl Constructor
DateTimePickerControl Class See Also Send Feedback
Initializes a new instance of the DateTimePickerControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTimePickerControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimePickerControl()

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DateTimePickerControl Methods

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl Methods
DateTimePickerControl Class See Also Send Feedback

The DateTimePickerControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
OnValueChanged | This method fires the ValueChanged event and the script code connected to the ValueChangedEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.AttachEvents Method
DateTimePickerControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.DetachEvents Method
DateTimePickerControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl..::.Dispose Method
DateTimePickerControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

DateTimePickerControl Class
DateTimePickerControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl..::.DrawSelectionPoint Method
DateTimePickerControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

DateTimePickerControl Class
DateTimePickerControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl..::.FillData Method
DateTimePickerControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

DateTimePickerControl Class
DateTimePickerControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.GetSelectionPoints Method
DateTimePickerControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.GetValue Method
DateTimePickerControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl..::.MemberwiseClone Method
DateTimePickerControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DateTimePickerControl Class
DateTimePickerControl Members
FastReport.Dialog Namespace


OnValueChanged Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.OnValueChanged Method
DateTimePickerControl Class See Also Send Feedback
This method fires the ValueChanged event and the script code connected to the ValueChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnValueChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnValueChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.Serialize Method
DateTimePickerControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.ShouldSerializeBackColor Method
DateTimePickerControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.ShouldSerializeForeColor Method
DateTimePickerControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DateTimePickerControl Properties

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl Properties
DateTimePickerControl Class See Also Send Feedback

The DateTimePickerControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Checked | Gets or sets a value indicating whether the Value property has been set with a valid date/time value and the displayed value is able to be updated. Wraps the Checked property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
CustomFormat | Gets or sets the custom date/time format string. Wraps the CustomFormat property.
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DateTimePicker | Gets an internal DateTimePicker.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DropDownAlign | Gets or sets the alignment of the drop-down calendar on the DateTimePicker control. Wraps the DropDownAlign property.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
Format | Gets or sets the format of the date and time displayed in the control. Wraps the Format property.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxDate | Gets or sets the maximum date and time that can be selected in the control. Wraps the MaxDate property.
MinDate | Gets or sets the minimum date and time that can be selected in the control. Wraps the MinDate property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
ShowCheckBox | Gets or sets a value indicating whether a check box is displayed to the left of the selected date. Wraps the ShowCheckBox property.
ShowUpDown | Gets or sets a value indicating whether a spin button control (also known as an up-down control) is used to adjust the date/time value. Wraps the ShowUpDown property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Value | Gets or sets the date/time value assigned to the control. Wraps the Value property.
ValueChangedEvent | Gets or sets a script method name that will be used to handle the ValueChanged event.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


Checked Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.Checked Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets a value indicating whether the Value property has been set with a valid date/time value and the displayed value is able to be updated. Wraps the Checked property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


CustomFormat Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.CustomFormat Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets the custom date/time format string. Wraps the CustomFormat property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CustomFormat { get; set; }
Visual Basic (Declaration)
Public Property CustomFormat As String
Visual C++
public:
property String^ CustomFormat {
    String^ get ();
    void set (String^ value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DateTimePicker Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.DateTimePicker Property
DateTimePickerControl Class See Also Send Feedback
Gets an internal DateTimePicker.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTimePicker DateTimePicker { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateTimePicker As DateTimePicker
Visual C++
public:
property DateTimePicker^ DateTimePicker {
    DateTimePicker^ get ();
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DropDownAlign Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.DropDownAlign Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets the alignment of the drop-down calendar on the DateTimePicker control. Wraps the DropDownAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LeftRightAlignment DropDownAlign { get; set; }
Visual Basic (Declaration)
Public Property DropDownAlign As LeftRightAlignment
Visual C++
public:
property LeftRightAlignment DropDownAlign {
    LeftRightAlignment get ();
    void set (LeftRightAlignment value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


Format Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.Format Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets the format of the date and time displayed in the control. Wraps the Format property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTimePickerFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As DateTimePickerFormat
Visual C++
public:
property DateTimePickerFormat Format {
    DateTimePickerFormat get ();
    void set (DateTimePickerFormat value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


MaxDate Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.MaxDate Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets the maximum date and time that can be selected in the control. Wraps the MaxDate property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime MaxDate { get; set; }
Visual Basic (Declaration)
Public Property MaxDate As DateTime
Visual C++
public:
property DateTime MaxDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


MinDate Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.MinDate Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets the minimum date and time that can be selected in the control. Wraps the MinDate property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime MinDate { get; set; }
Visual Basic (Declaration)
Public Property MinDate As DateTime
Visual C++
public:
property DateTime MinDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


ShowCheckBox Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.ShowCheckBox Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets a value indicating whether a check box is displayed to the left of the selected date. Wraps the ShowCheckBox property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowCheckBox { get; set; }
Visual Basic (Declaration)
Public Property ShowCheckBox As Boolean
Visual C++
public:
property bool ShowCheckBox {
    bool get ();
    void set (bool value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


ShowUpDown Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.ShowUpDown Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets a value indicating whether a spin button control (also known as an up-down control) is used to adjust the date/time value. Wraps the ShowUpDown property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowUpDown { get; set; }
Visual Basic (Declaration)
Public Property ShowUpDown As Boolean
Visual C++
public:
property bool ShowUpDown {
    bool get ();
    void set (bool value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.Text Property
DateTimePickerControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


Value Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.Value Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets the date/time value assigned to the control. Wraps the Value property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime Value { get; set; }
Visual Basic (Declaration)
Public Property Value As DateTime
Visual C++
public:
property DateTime Value {
    DateTime get ();
    void set (DateTime value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


ValueChangedEvent Property

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.ValueChangedEvent Property
DateTimePickerControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ValueChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ValueChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property ValueChangedEvent As String
Visual C++
public:
property String^ ValueChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DateTimePickerControl Events

[image] [image]

FastReport.Net Class Reference
DateTimePickerControl Events
DateTimePickerControl Class See Also Send Feedback

The DateTimePickerControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)
ValueChanged | Occurs after the date has been changed. Wraps the ValueChanged event.

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


ValueChanged Event

[image]

FastReport.Net Class Reference
DateTimePickerControl..::.ValueChanged Event
DateTimePickerControl Class See Also Send Feedback
Occurs after the date has been changed. Wraps the ValueChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DateTimePickerControl Class
FastReport.Dialog Namespace


DialogComponentBase Class

[image]

FastReport.Net Class Reference
DialogComponentBase Class
Members See Also Send Feedback
Base class for all dialog components.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class DialogComponentBase : ComponentBase
Visual Basic (Declaration)
Public MustInherit Class DialogComponentBase _
    Inherits ComponentBase
Visual C++
public ref class DialogComponentBase abstract : public ComponentBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl

See Also

DialogComponentBase Members
FastReport.Dialog Namespace


DialogComponentBase Members

[image] [image]

FastReport.Net Class Reference
DialogComponentBase Members
DialogComponentBase Class Constructors Methods Properties Events See Also Send Feedback

The DialogComponentBase type exposes the following members.

Constructors

Name | Description
DialogComponentBase | Initializes a new instance of the DialogComponentBase class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ComponentBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides ComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


DialogComponentBase Constructor

[image]

FastReport.Net Class Reference
DialogComponentBase Constructor
DialogComponentBase Class See Also Send Feedback
Initializes a new instance of the DialogComponentBase class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogComponentBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DialogComponentBase()

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


DialogComponentBase Methods

[image] [image]

FastReport.Net Class Reference
DialogComponentBase Methods
DialogComponentBase Class See Also Send Feedback

The DialogComponentBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ComponentBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Assign Method

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Assign Method
DialogComponentBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

DialogComponentBase Class
FastReport.Dialog Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
DialogComponentBase..::.Dispose Method
DialogComponentBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DialogComponentBase Class
DialogComponentBase Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DialogComponentBase..::.MemberwiseClone Method
DialogComponentBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DialogComponentBase Class
DialogComponentBase Members
FastReport.Dialog Namespace


DialogComponentBase Properties

[image] [image]

FastReport.Net Class Reference
DialogComponentBase Properties
DialogComponentBase Class See Also Send Feedback

The DialogComponentBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides ComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Height Property

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Height Property
DialogComponentBase Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Left Property

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Left Property
DialogComponentBase Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Location Property

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Location Property
DialogComponentBase Class See Also Send Feedback
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Point Location { get; set; }
Visual Basic (Declaration)
Public Property Location As Point
Visual C++
public:
property Point Location {
    Point get ();
    void set (Point value);
}

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Size Property

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Size Property
DialogComponentBase Class See Also Send Feedback
Gets or sets the height and width of the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Size Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Size
Visual C++
public:
property Size Size {
    Size get ();
    void set (Size value);
}

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Top Property

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Top Property
DialogComponentBase Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


Width Property

[image]

FastReport.Net Class Reference
DialogComponentBase..::.Width Property
DialogComponentBase Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


DialogComponentBase Events

[image] [image]

FastReport.Net Class Reference
DialogComponentBase Events
DialogComponentBase Class See Also Send Feedback

The DialogComponentBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DialogComponentBase Class
FastReport.Dialog Namespace


DialogComponentCollection Class

[image]

FastReport.Net Class Reference
DialogComponentCollection Class
Members See Also Send Feedback
Represents the collection of dialog components.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DialogComponentCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class DialogComponentCollection _
    Inherits FRCollectionBase
Visual C++
public ref class DialogComponentCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Dialog..::.DialogComponentCollection

See Also

DialogComponentCollection Members
FastReport.Dialog Namespace


DialogComponentCollection Members

[image] [image]

FastReport.Net Class Reference
DialogComponentCollection Members
DialogComponentCollection Class Constructors Methods Properties See Also Send Feedback

The DialogComponentCollection type exposes the following members.

Constructors

Name | Description
DialogComponentCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a component.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

DialogComponentCollection Class
FastReport.Dialog Namespace


DialogComponentCollection Constructor

[image] [image]

FastReport.Net Class Reference
DialogComponentCollection Constructor
DialogComponentCollection Class See Also Send Feedback

Overload List

Name | Description
DialogComponentCollection()()() | Initializes a new instance of the DialogComponentCollection class with default settings.
DialogComponentCollection(Base) | Initializes a new instance of the DialogComponentCollection class with default settings.

See Also

DialogComponentCollection Class
DialogComponentCollection Members
FastReport.Dialog Namespace


DialogComponentCollection Constructor

[image]

FastReport.Net Class Reference
DialogComponentCollection Constructor
DialogComponentCollection Class See Also Send Feedback
Initializes a new instance of the DialogComponentCollection class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogComponentCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DialogComponentCollection()

See Also

DialogComponentCollection Class
DialogComponentCollection Overload
FastReport.Dialog Namespace


DialogComponentCollection Constructor (Base)

[image]

FastReport.Net Class Reference
DialogComponentCollection Constructor (Base)
DialogComponentCollection Class See Also Send Feedback
Initializes a new instance of the DialogComponentCollection class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogComponentCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
DialogComponentCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

DialogComponentCollection Class
DialogComponentCollection Overload
FastReport.Dialog Namespace


DialogComponentCollection Methods

[image] [image]

FastReport.Net Class Reference
DialogComponentCollection Methods
DialogComponentCollection Class See Also Send Feedback

The DialogComponentCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogComponentCollection Class
FastReport.Dialog Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
DialogComponentCollection..::.AddRange Method
DialogComponentCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

DialogComponentCollection Class
DialogComponentCollection Members
FastReport.Dialog Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
DialogComponentCollection..::.Equals Method
DialogComponentCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

DialogComponentCollection Class
DialogComponentCollection Members
FastReport.Dialog Namespace


DialogComponentCollection Properties

[image] [image]

FastReport.Net Class Reference
DialogComponentCollection Properties
DialogComponentCollection Class See Also Send Feedback

The DialogComponentCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a component.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

DialogComponentCollection Class
FastReport.Dialog Namespace


Item Property

[image]

FastReport.Net Class Reference
DialogComponentCollection..::.Item Property
DialogComponentCollection Class See Also Send Feedback
Gets or sets a component.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogComponentBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As DialogComponentBase
Visual C++
public:
property DialogComponentBase^ default[int index] {
    DialogComponentBase^ get (int index);
    void set (int index, DialogComponentBase^ value);
}

Parameters

index
Type: System..::.Int32
The index of a component in this collection.

Return Value

The component with specified index.

See Also

DialogComponentCollection Class
FastReport.Dialog Namespace


DialogControl Class

[image]

FastReport.Net Class Reference
DialogControl Class
Members See Also Send Feedback
Base class for all dialog controls such as ButtonControl, TextBoxControl.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class DialogControl : DialogComponentBase,
    IHasEditor
Visual Basic (Declaration)
Public MustInherit Class DialogControl _
    Inherits DialogComponentBase _
    Implements IHasEditor
Visual C++
public ref class DialogControl abstract : public DialogComponentBase,
    IHasEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.GridControl
FastReport.Dialog..::.LabelControl
FastReport.Dialog..::.ListViewControl
FastReport.Dialog..::.ParentControl
FastReport.Dialog..::.PictureBoxControl
FastReport.Dialog..::.RichTextBoxControl
FastReport.Dialog..::.TreeViewControl

See Also

DialogControl Members
FastReport.Dialog Namespace


DialogControl Members

[image] [image]

FastReport.Net Class Reference
DialogControl Members
DialogControl Class Constructors Methods Properties Events See Also Send Feedback

The DialogControl type exposes the following members.

Constructors

Name | Description
DialogControl | Initializes a new instance of the DialogControl class

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers.
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Overrides ComponentBase..::.CheckParent(Boolean).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers.
Dispose | Overloaded.
Draw | Draws the object. (Overrides ComponentBase..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user.
InitializeControl | Initializes the control before display it in the dialog form.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnClick | This method fires the Click event and the script code connected to the ClickEvent.
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent.
OnEnabledChanged | Called when the control's Enabled state changed.
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent.
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent.
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent.
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent.
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent.
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent.
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent.
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Overrides Base..::.SetParent(Base).)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property.
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property.
ShouldSerializeFont | Determines whether is necessary to serialize the Font property.
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property.
Show | Displays the control to the user.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Overrides ComponentBase..::.Anchor.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property.
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event.
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Overrides ComponentBase..::.Dock.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property.
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property.
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides DialogComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event.
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event.
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event.
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event.
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides DialogComponentBase..::.Left.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event.
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event.
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event.
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event.
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property.
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property.
Text | Gets or sets the text associated with this control. Wraps the Text property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides DialogComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Overrides ComponentBase..::.Visible.)
Width | Gets or sets the width of the object. (Overrides DialogComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event.
Enter | Occurs when the control is entered. Wraps the Enter event.
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event.
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event.
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event.
Leave | Occurs when the input focus leaves the control. Wraps the Leave event.
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event.
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event.
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event.
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event.
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event.
Paint | Occurs when the control is redrawn. Wraps the Paint event.
Resize | Occurs when the control is resized. Wraps the Resize event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event.

See Also

DialogControl Class
FastReport.Dialog Namespace


DialogControl Constructor

[image]

FastReport.Net Class Reference
DialogControl Constructor
DialogControl Class See Also Send Feedback
Initializes a new instance of the DialogControl class

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected DialogControl()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DialogControl()

See Also

DialogControl Class
FastReport.Dialog Namespace


DialogControl Methods

[image] [image]

FastReport.Net Class Reference
DialogControl Methods
DialogControl Class See Also Send Feedback

The DialogControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers.
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Overrides ComponentBase..::.CheckParent(Boolean).)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers.
Dispose | Overloaded.
Draw | Draws the object. (Overrides ComponentBase..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user.
InitializeControl | Initializes the control before display it in the dialog form.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script.
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnClick | This method fires the Click event and the script code connected to the ClickEvent.
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent.
OnEnabledChanged | Called when the control's Enabled state changed.
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent.
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent.
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent.
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent.
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent.
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent.
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent.
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Overrides Base..::.SetParent(Base).)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property.
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property.
ShouldSerializeFont | Determines whether is necessary to serialize the Font property.
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property.
Show | Displays the control to the user.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DialogControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
DialogControl..::.AttachEvents Method
DialogControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void AttachEvents()
Visual Basic (Declaration)
Protected Overridable Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents()

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


CheckParent Method

[image]

FastReport.Net Class Reference
DialogControl..::.CheckParent Method
DialogControl Class See Also Send Feedback
Checks if the object is inside its parent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void CheckParent(
    bool immediately
)
Visual Basic (Declaration)
Public Overrides Sub CheckParent ( _
    immediately As Boolean _
)
Visual C++
public:
virtual void CheckParent(
    bool immediately
) override

Parameters

immediately
Type: System..::.Boolean
if true, check now independent of any conditions.

Remarks

Typically you don't need to use or override this method.

When you move an object with the mouse, it may be moved outside its parent. If so, this method must find a new parent for the object and correct it's Left, Top and Parent properties. If immediately parameter is false, you can optimize the method to search for new parent only if the object's bounds are outside parent. If this parameter is true, you must skip any optimizations and search for a parent immediately.

See Also

DialogControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
DialogControl..::.DetachEvents Method
DialogControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void DetachEvents()
Visual Basic (Declaration)
Protected Overridable Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents()

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DialogControl..::.Dispose Method
DialogControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

DialogControl Class
DialogControl Members
FastReport.Dialog Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DialogControl..::.Dispose Method (Boolean)
DialogControl Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

DialogControl Class
Dispose Overload
FastReport.Dialog Namespace


Draw Method

[image]

FastReport.Net Class Reference
DialogControl..::.Draw Method
DialogControl Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

DialogControl Class
FastReport.Dialog Namespace


DrawSelection Method

[image]

FastReport.Net Class Reference
DialogControl..::.DrawSelection Method
DialogControl Class See Also Send Feedback
Draw the selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawSelection(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawSelection ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawSelection(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method draws a set of selection points returned by the GetSelectionPoints()()() method.

See Also

DialogControl Class
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
DialogControl..::.DrawSelectionPoint Method
DialogControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point.

See Also

DialogControl Class
DialogControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method (Graphics, Pen, Brush, Single, Single)

[image]

FastReport.Net Class Reference
DialogControl..::.DrawSelectionPoint Method (Graphics, Pen, Brush, Single, Single)
DialogControl Class See Also Send Feedback
Draws the selection point.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected void DrawSelectionPoint(
    Graphics g,
    Pen p,
    Brush b,
    float x,
    float y
)
Visual Basic (Declaration)
Protected Sub DrawSelectionPoint ( _
    g As Graphics, _
    p As Pen, _
    b As Brush, _
    x As Single, _
    y As Single _
)
Visual C++
protected:
void DrawSelectionPoint(
    Graphics^ g,
    Pen^ p,
    Brush^ b,
    float x,
    float y
)

Parameters

g
Type: System.Drawing..::.Graphics
Graphics object to draw on.
p
Type: System.Drawing..::.Pen
Pen object.
b
Type: System.Drawing..::.Brush
Brush object.
x
Type: System..::.Single
Left coordinate.
y
Type: System..::.Single
Top coordinate.

See Also

DialogControl Class
DrawSelectionPoint Overload
FastReport.Dialog Namespace


FinalizeControl Method

[image]

FastReport.Net Class Reference
DialogControl..::.FinalizeControl Method
DialogControl Class See Also Send Feedback
Finalizes the control after its parent form is closed.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void FinalizeControl()
Visual Basic (Declaration)
Public Overridable Sub FinalizeControl
Visual C++
public:
virtual void FinalizeControl()

Remarks

This method is called when report is run.

See Also

DialogControl Class
FastReport.Dialog Namespace


Focus Method

[image]

FastReport.Net Class Reference
DialogControl..::.Focus Method
DialogControl Class See Also Send Feedback
Sets input focus to the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Focus()
Visual Basic (Declaration)
Public Sub Focus
Visual C++
public:
void Focus()

See Also

DialogControl Class
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
DialogControl..::.GetSelectionPoints Method
DialogControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

DialogControl Class
FastReport.Dialog Namespace


Hide Method

[image]

FastReport.Net Class Reference
DialogControl..::.Hide Method
DialogControl Class See Also Send Feedback
Conceals the control from the user.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide
Visual C++
public:
void Hide()

See Also

DialogControl Class
FastReport.Dialog Namespace


InitializeControl Method

[image]

FastReport.Net Class Reference
DialogControl..::.InitializeControl Method
DialogControl Class See Also Send Feedback
Initializes the control before display it in the dialog form.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void InitializeControl()
Visual Basic (Declaration)
Public Overridable Sub InitializeControl
Visual C++
public:
virtual void InitializeControl()

Remarks

This method is called when report is run.

See Also

DialogControl Class
FastReport.Dialog Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
DialogControl..::.InvokeEditor Method
DialogControl Class See Also Send Feedback
Creates the empty event handler for the ClickEvent event in the report's script.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if event handler was created successfully.

Implements

IHasEditor..::.InvokeEditor()()()

See Also

DialogControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DialogControl..::.MemberwiseClone Method
DialogControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DialogControl Class
DialogControl Members
FastReport.Dialog Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnBeforeInsert Method
DialogControl Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

DialogControl Class
FastReport.Dialog Namespace


OnClick Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnClick Method
DialogControl Class See Also Send Feedback
This method fires the Click event and the script code connected to the ClickEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnClick(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnClick ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnClick(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnDoubleClick Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnDoubleClick Method
DialogControl Class See Also Send Feedback
This method fires the DoubleClick event and the script code connected to the DoubleClickEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnDoubleClick(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnDoubleClick ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnDoubleClick(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnEnabledChanged Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnEnabledChanged Method
DialogControl Class See Also Send Feedback
Called when the control's Enabled state changed.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void OnEnabledChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnEnabledChanged
Visual C++
protected:
virtual void OnEnabledChanged()

See Also

DialogControl Class
FastReport.Dialog Namespace


OnEnter Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnEnter Method
DialogControl Class See Also Send Feedback
This method fires the Enter event and the script code connected to the EnterEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnEnter(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnEnter ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnEnter(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnKeyDown Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnKeyDown Method
DialogControl Class See Also Send Feedback
This method fires the KeyDown event and the script code connected to the KeyDownEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
public:
virtual void OnKeyDown(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnKeyPress Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnKeyPress Method
DialogControl Class See Also Send Feedback
This method fires the KeyPress event and the script code connected to the KeyPressEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnKeyPress(
    KeyPressEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
Visual C++
public:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.KeyPressEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnKeyUp Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnKeyUp Method
DialogControl Class See Also Send Feedback
This method fires the KeyUp event and the script code connected to the KeyUpEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnKeyUp(
    KeyEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
public:
virtual void OnKeyUp(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnLeave Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnLeave Method
DialogControl Class See Also Send Feedback
This method fires the Leave event and the script code connected to the LeaveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnLeave(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnMouseDown Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnMouseDown Method
DialogControl Class See Also Send Feedback
This method fires the MouseDown event and the script code connected to the MouseDownEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseDown(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnMouseEnter Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnMouseEnter Method
DialogControl Class See Also Send Feedback
This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseEnter(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseEnter(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnMouseLeave Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnMouseLeave Method
DialogControl Class See Also Send Feedback
This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseLeave(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnMouseMove Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnMouseMove Method
DialogControl Class See Also Send Feedback
This method fires the MouseMove event and the script code connected to the MouseMoveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnMouseUp Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnMouseUp Method
DialogControl Class See Also Send Feedback
This method fires the MouseUp event and the script code connected to the MouseUpEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMouseUp(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnPaint Method
DialogControl Class See Also Send Feedback
This method fires the Paint event and the script code connected to the PaintEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnResize Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnResize Method
DialogControl Class See Also Send Feedback
This method fires the Resize event and the script code connected to the ResizeEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnResize(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnResize ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnResize(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


OnTextChanged Method

[image]

FastReport.Net Class Reference
DialogControl..::.OnTextChanged Method
DialogControl Class See Also Send Feedback
This method fires the TextChanged event and the script code connected to the TextChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnTextChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnTextChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DialogControl..::.Serialize Method
DialogControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DialogControl Class
FastReport.Dialog Namespace


SetParent Method

[image]

FastReport.Net Class Reference
DialogControl..::.SetParent Method
DialogControl Class See Also Send Feedback
Sets the object's parent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetParent(
    Base value
)
Visual Basic (Declaration)
Public Overrides Sub SetParent ( _
    value As Base _
)
Visual C++
public:
virtual void SetParent(
    Base^ value
) override

Parameters

value
Type: FastReport..::.Base
New parent.

Remarks

This method is for internal use only. You can use it if you are developing a new component for FastReport. Override it to perform some actions when the parent of an object is changing. This method checks that parent can contain a child.

Exceptions

Exception | Condition
FastReport.Utils..::.ParentException | Parent object cannot contain this object.

See Also

DialogControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
DialogControl..::.ShouldSerializeBackColor Method
DialogControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor()

Return Value

true if serialization is necessary.

See Also

DialogControl Class
FastReport.Dialog Namespace


ShouldSerializeCursor Method

[image]

FastReport.Net Class Reference
DialogControl..::.ShouldSerializeCursor Method
DialogControl Class See Also Send Feedback
Determines whether is necessary to serialize the Cursor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual bool ShouldSerializeCursor()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeCursor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeCursor()

Return Value

true if serialization is necessary.

See Also

DialogControl Class
FastReport.Dialog Namespace


ShouldSerializeFont Method

[image]

FastReport.Net Class Reference
DialogControl..::.ShouldSerializeFont Method
DialogControl Class See Also Send Feedback
Determines whether is necessary to serialize the Font property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual bool ShouldSerializeFont()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeFont As Boolean
Visual C++
protected:
virtual bool ShouldSerializeFont()

Return Value

true if serialization is necessary.

See Also

DialogControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
DialogControl..::.ShouldSerializeForeColor Method
DialogControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor()

Return Value

true if serialization is necessary.

See Also

DialogControl Class
FastReport.Dialog Namespace


Show Method

[image]

FastReport.Net Class Reference
DialogControl..::.Show Method
DialogControl Class See Also Send Feedback
Displays the control to the user.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show
Visual C++
public:
void Show()

See Also

DialogControl Class
FastReport.Dialog Namespace


DialogControl Properties

[image] [image]

FastReport.Net Class Reference
DialogControl Properties
DialogControl Class See Also Send Feedback

The DialogControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Overrides ComponentBase..::.Anchor.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property.
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event.
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Overrides ComponentBase..::.Dock.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property.
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property.
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides DialogComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event.
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event.
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event.
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event.
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides DialogComponentBase..::.Left.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event.
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event.
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event.
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event.
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property.
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property.
Text | Gets or sets the text associated with this control. Wraps the Text property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides DialogComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Overrides ComponentBase..::.Visible.)
Width | Gets or sets the width of the object. (Overrides DialogComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DialogControl Class
FastReport.Dialog Namespace


Anchor Property

[image]

FastReport.Net Class Reference
DialogControl..::.Anchor Property
DialogControl Class See Also Send Feedback
Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overrides Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get () override;
    void set (AnchorStyles value) override;
}

See Also

DialogControl Class
FastReport.Dialog Namespace


BackColor Property

[image]

FastReport.Net Class Reference
DialogControl..::.BackColor Property
DialogControl Class See Also Send Feedback
Gets or sets the background color for the control. Wraps the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Color BackColor { get; set; }
Visual Basic (Declaration)
Public Overridable Property BackColor As Color
Visual C++
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


BindableProperty Property

[image]

FastReport.Net Class Reference
DialogControl..::.BindableProperty Property
DialogControl Class See Also Send Feedback
Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyInfo BindableProperty { get; set; }
Visual Basic (Declaration)
Public Property BindableProperty As PropertyInfo
Visual C++
public:
property PropertyInfo^ BindableProperty {
    PropertyInfo^ get ();
    void set (PropertyInfo^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


ClickEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.ClickEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Click event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ClickEvent { get; set; }
Visual Basic (Declaration)
Public Property ClickEvent As String
Visual C++
public:
property String^ ClickEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Control Property

[image]

FastReport.Net Class Reference
DialogControl..::.Control Property
DialogControl Class See Also Send Feedback
Gets an internal Control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Control Control { get; set; }
Visual Basic (Declaration)
Public Property Control As Control
Visual C++
public:
property Control^ Control {
    Control^ get ();
    void set (Control^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Cursor Property

[image]

FastReport.Net Class Reference
DialogControl..::.Cursor Property
DialogControl Class See Also Send Feedback
Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Cursor Cursor { get; set; }
Visual Basic (Declaration)
Public Property Cursor As Cursor
Visual C++
public:
property Cursor^ Cursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Dock Property

[image]

FastReport.Net Class Reference
DialogControl..::.Dock Property
DialogControl Class See Also Send Feedback
Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get () override;
    void set (DockStyle value) override;
}

See Also

DialogControl Class
FastReport.Dialog Namespace


DoubleClickEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.DoubleClickEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the DoubleClick event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DoubleClickEvent { get; set; }
Visual Basic (Declaration)
Public Property DoubleClickEvent As String
Visual C++
public:
property String^ DoubleClickEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Enabled Property

[image]

FastReport.Net Class Reference
DialogControl..::.Enabled Property
DialogControl Class See Also Send Feedback
Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


EnterEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.EnterEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Enter event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string EnterEvent { get; set; }
Visual Basic (Declaration)
Public Property EnterEvent As String
Visual C++
public:
property String^ EnterEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Font Property

[image]

FastReport.Net Class Reference
DialogControl..::.Font Property
DialogControl Class See Also Send Feedback
Gets or sets the font of the text displayed by the control. Wraps the Font property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


ForeColor Property

[image]

FastReport.Net Class Reference
DialogControl..::.ForeColor Property
DialogControl Class See Also Send Feedback
Gets or sets the foreground color of the control. Wraps the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
Visual C++
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Height Property

[image]

FastReport.Net Class Reference
DialogControl..::.Height Property
DialogControl Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

DialogControl Class
FastReport.Dialog Namespace


KeyDownEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.KeyDownEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the KeyDown event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string KeyDownEvent { get; set; }
Visual Basic (Declaration)
Public Property KeyDownEvent As String
Visual C++
public:
property String^ KeyDownEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


KeyPressEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.KeyPressEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the KeyPress event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string KeyPressEvent { get; set; }
Visual Basic (Declaration)
Public Property KeyPressEvent As String
Visual C++
public:
property String^ KeyPressEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


KeyUpEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.KeyUpEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the KeyUp event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string KeyUpEvent { get; set; }
Visual Basic (Declaration)
Public Property KeyUpEvent As String
Visual C++
public:
property String^ KeyUpEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


LeaveEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.LeaveEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Leave event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LeaveEvent { get; set; }
Visual Basic (Declaration)
Public Property LeaveEvent As String
Visual C++
public:
property String^ LeaveEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Left Property

[image]

FastReport.Net Class Reference
DialogControl..::.Left Property
DialogControl Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseDownEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.MouseDownEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MouseDown event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseDownEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseDownEvent As String
Visual C++
public:
property String^ MouseDownEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseEnterEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.MouseEnterEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MouseEnter event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseEnterEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseEnterEvent As String
Visual C++
public:
property String^ MouseEnterEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseLeaveEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.MouseLeaveEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MouseLeave event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseLeaveEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseLeaveEvent As String
Visual C++
public:
property String^ MouseLeaveEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseMoveEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.MouseMoveEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MouseMove event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseMoveEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseMoveEvent As String
Visual C++
public:
property String^ MouseMoveEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseUpEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.MouseUpEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MouseUp event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MouseUpEvent { get; set; }
Visual Basic (Declaration)
Public Property MouseUpEvent As String
Visual C++
public:
property String^ MouseUpEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


PaintEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.PaintEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Paint event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PaintEvent { get; set; }
Visual Basic (Declaration)
Public Property PaintEvent As String
Visual C++
public:
property String^ PaintEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


ResizeEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.ResizeEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Resize event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ResizeEvent { get; set; }
Visual Basic (Declaration)
Public Property ResizeEvent As String
Visual C++
public:
property String^ ResizeEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


RightToLeft Property

[image]

FastReport.Net Class Reference
DialogControl..::.RightToLeft Property
DialogControl Class See Also Send Feedback
Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RightToLeft RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
Visual C++
public:
property RightToLeft RightToLeft {
    RightToLeft get ();
    void set (RightToLeft value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


TabIndex Property

[image]

FastReport.Net Class Reference
DialogControl..::.TabIndex Property
DialogControl Class See Also Send Feedback
Gets or sets the tab order of the control within its container. Wraps the TabIndex property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int TabIndex { get; set; }
Visual Basic (Declaration)
Public Property TabIndex As Integer
Visual C++
public:
property int TabIndex {
    int get ();
    void set (int value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


TabStop Property

[image]

FastReport.Net Class Reference
DialogControl..::.TabStop Property
DialogControl Class See Also Send Feedback
Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool TabStop { get; set; }
Visual Basic (Declaration)
Public Property TabStop As Boolean
Visual C++
public:
property bool TabStop {
    bool get ();
    void set (bool value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
DialogControl..::.Text Property
DialogControl Class See Also Send Feedback
Gets or sets the text associated with this control. Wraps the Text property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual string Text { get; set; }
Visual Basic (Declaration)
Public Overridable Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


TextChangedEvent Property

[image]

FastReport.Net Class Reference
DialogControl..::.TextChangedEvent Property
DialogControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the TextChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TextChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property TextChangedEvent As String
Visual C++
public:
property String^ TextChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Top Property

[image]

FastReport.Net Class Reference
DialogControl..::.Top Property
DialogControl Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

DialogControl Class
FastReport.Dialog Namespace


Visible Property

[image]

FastReport.Net Class Reference
DialogControl..::.Visible Property
DialogControl Class See Also Send Feedback
Gets or sets a value indicating whether the control is displayed. Wraps the Visible property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get () override;
    void set (bool value) override;
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Width Property

[image]

FastReport.Net Class Reference
DialogControl..::.Width Property
DialogControl Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

DialogControl Class
FastReport.Dialog Namespace


DialogControl Events

[image] [image]

FastReport.Net Class Reference
DialogControl Events
DialogControl Class See Also Send Feedback

The DialogControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event.
Enter | Occurs when the control is entered. Wraps the Enter event.
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event.
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event.
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event.
Leave | Occurs when the input focus leaves the control. Wraps the Leave event.
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event.
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event.
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event.
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event.
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event.
Paint | Occurs when the control is redrawn. Wraps the Paint event.
Resize | Occurs when the control is resized. Wraps the Resize event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event.

See Also

DialogControl Class
FastReport.Dialog Namespace


Click Event

[image]

FastReport.Net Class Reference
DialogControl..::.Click Event
DialogControl Class See Also Send Feedback
Occurs when the control is clicked. Wraps the Click event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Click
Visual Basic (Declaration)
Public Event Click As EventHandler
Visual C++
public:
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


DoubleClick Event

[image]

FastReport.Net Class Reference
DialogControl..::.DoubleClick Event
DialogControl Class See Also Send Feedback
Occurs when the control is double-clicked. Wraps the DoubleClick event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler DoubleClick
Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
Visual C++
public:
 event EventHandler^ DoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Enter Event

[image]

FastReport.Net Class Reference
DialogControl..::.Enter Event
DialogControl Class See Also Send Feedback
Occurs when the control is entered. Wraps the Enter event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Enter
Visual Basic (Declaration)
Public Event Enter As EventHandler
Visual C++
public:
 event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


KeyDown Event

[image]

FastReport.Net Class Reference
DialogControl..::.KeyDown Event
DialogControl Class See Also Send Feedback
Occurs when a key is pressed while the control has focus. Wraps the KeyDown event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event KeyEventHandler KeyDown
Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


KeyPress Event

[image]

FastReport.Net Class Reference
DialogControl..::.KeyPress Event
DialogControl Class See Also Send Feedback
Occurs when a key is pressed while the control has focus. Wraps the KeyPress event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event KeyPressEventHandler KeyPress
Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
Visual C++
public:
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


KeyUp Event

[image]

FastReport.Net Class Reference
DialogControl..::.KeyUp Event
DialogControl Class See Also Send Feedback
Occurs when a key is released while the control has focus. Wraps the KeyUp event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event KeyEventHandler KeyUp
Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Leave Event

[image]

FastReport.Net Class Reference
DialogControl..::.Leave Event
DialogControl Class See Also Send Feedback
Occurs when the input focus leaves the control. Wraps the Leave event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Leave
Visual Basic (Declaration)
Public Event Leave As EventHandler
Visual C++
public:
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseDown Event

[image]

FastReport.Net Class Reference
DialogControl..::.MouseDown Event
DialogControl Class See Also Send Feedback
Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MouseEventHandler MouseDown
Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseEnter Event

[image]

FastReport.Net Class Reference
DialogControl..::.MouseEnter Event
DialogControl Class See Also Send Feedback
Occurs when the mouse pointer enters the control. Wraps the MouseEnter event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler MouseEnter
Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
Visual C++
public:
 event EventHandler^ MouseEnter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseLeave Event

[image]

FastReport.Net Class Reference
DialogControl..::.MouseLeave Event
DialogControl Class See Also Send Feedback
Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler MouseLeave
Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
Visual C++
public:
 event EventHandler^ MouseLeave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseMove Event

[image]

FastReport.Net Class Reference
DialogControl..::.MouseMove Event
DialogControl Class See Also Send Feedback
Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MouseEventHandler MouseMove
Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


MouseUp Event

[image]

FastReport.Net Class Reference
DialogControl..::.MouseUp Event
DialogControl Class See Also Send Feedback
Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MouseEventHandler MouseUp
Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Paint Event

[image]

FastReport.Net Class Reference
DialogControl..::.Paint Event
DialogControl Class See Also Send Feedback
Occurs when the control is redrawn. Wraps the Paint event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event PaintEventHandler Paint
Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
Visual C++
public:
 event PaintEventHandler^ Paint {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


Resize Event

[image]

FastReport.Net Class Reference
DialogControl..::.Resize Event
DialogControl Class See Also Send Feedback
Occurs when the control is resized. Wraps the Resize event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Resize
Visual Basic (Declaration)
Public Event Resize As EventHandler
Visual C++
public:
 event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


TextChanged Event

[image]

FastReport.Net Class Reference
DialogControl..::.TextChanged Event
DialogControl Class See Also Send Feedback
Occurs when the Text property value changes. Wraps the TextChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler TextChanged
Visual Basic (Declaration)
Public Event TextChanged As EventHandler
Visual C++
public:
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogControl Class
FastReport.Dialog Namespace


DialogPage Class

[image]

FastReport.Net Class Reference
DialogPage Class
Members Example See Also Send Feedback
Represents the special kind of report page that wraps the Form and used to display dialog forms.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DialogPage : PageBase, IParent
Visual Basic (Declaration)
Public Class DialogPage _
    Inherits PageBase _
    Implements IParent
Visual C++
public ref class DialogPage : public PageBase,
    IParent

Remarks

Use the Controls property to add/remove controls to/from a dialog form.

If you set the Visible property to false, this dialog form will be skippen when you run a report.

Examples

This example shows how to create a dialog form with one button in code.
CopyC#
DialogPage form = new DialogPage();
// set the width and height in pixels
form.Width = 200;
form.Height = 200;
form.Name = "Form1";
// create a button
ButtonControl button = new ButtonControl();
button.Location = new Point(20, 20);
button.Size = new Size(75, 25);
button.Text = "The button";
// add the button to the form
form.Controls.Add(button);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.PageBase
FastReport.Dialog..::.DialogPage

See Also

DialogPage Members
FastReport.Dialog Namespace


DialogPage Members

[image] [image]

FastReport.Net Class Reference
DialogPage Members
DialogPage Class Constructors Methods Properties Events See Also Send Feedback

The DialogPage type exposes the following members.

Constructors

Name | Description
DialogPage | Initializes a new instance of the DialogPage class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageDesignerType | Gets a page designer for this page type. (Overrides PageBase..::.GetPageDesignerType()()().)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Overrides ComponentBase..::.HandleDoubleClick()()().)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
Modify | Modifies the page content and refresh it in the preview window. (Inherited from PageBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnFormClosed | This method fires the FormClosed event and the script code connected to the FormClosedEvent.
OnFormClosing | This method fires the FormClosing event and the script code connected to the FormClosingEvent.
OnLoad | This method fires the Load event and the script code connected to the LoadEvent.
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent.
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent.
OnShown | This method fires the Shown event and the script code connected to the ShownEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
Refresh | Causes the page to refresh in the preview window. (Inherited from PageBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetDefaults | This method is called by the designer when you create a new page. (Overrides PageBase..::.SetDefaults()()().)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner. Wraps the ShowDialog()()() method.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. Wraps the AcceptButton property.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from PageBase.)
BackColor | Gets or sets the background color for the form. Wraps the BackColor property.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. Wraps the CancelButton property.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Overrides ComponentBase..::.ClientSize.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Controls | Gets the collection of controls contained within the form.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from PageBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property.
Form | Gets an internal Form.
FormBorderStyle | Gets or sets the border style of the form. Wraps the FormBorderStyle property.
FormClosedEvent | Gets or sets a script method name that will be used to handle the FormClosed event.
FormClosingEvent | Gets or sets a script method name that will be used to handle the FormClosing event.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides ComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
LoadEvent | Gets or sets a script method name that will be used to handle the Load event.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event.
Restrictions | This property is not relevant to this class. (Inherited from PageBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property.
ShownEvent | Gets or sets a script method name that will be used to handle the Shown event.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SnapSize | Gets the snap size for this page. (Overrides PageBase..::.SnapSize.)
Text | Gets or sets the text associated with this form. Wraps the Text property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FormClosed | Occurs after the form is closed. Wraps the FormClosed event.
FormClosing | Occurs before the form is closed. Wraps the FormClosing event.
Load | Occurs before a form is displayed for the first time. Wraps the Load event.
Paint | Occurs when the form is redrawn. Wraps the Paint event.
Resize | Occurs when the form is resized. Wraps the Resize event.
Shown | Occurs whenever the form is first displayed. Wraps the Shown event.

See Also

DialogPage Class
FastReport.Dialog Namespace


DialogPage Constructor

[image]

FastReport.Net Class Reference
DialogPage Constructor
DialogPage Class See Also Send Feedback
Initializes a new instance of the DialogPage class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogPage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DialogPage()

See Also

DialogPage Class
FastReport.Dialog Namespace


DialogPage Methods

[image] [image]

FastReport.Net Class Reference
DialogPage Methods
DialogPage Class See Also Send Feedback

The DialogPage type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides ComponentBase..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageDesignerType | Gets a page designer for this page type. (Overrides PageBase..::.GetPageDesignerType()()().)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Overrides ComponentBase..::.HandleDoubleClick()()().)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
Modify | Modifies the page content and refresh it in the preview window. (Inherited from PageBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnFormClosed | This method fires the FormClosed event and the script code connected to the FormClosedEvent.
OnFormClosing | This method fires the FormClosing event and the script code connected to the FormClosingEvent.
OnLoad | This method fires the Load event and the script code connected to the LoadEvent.
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent.
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent.
OnShown | This method fires the Shown event and the script code connected to the ShownEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
Refresh | Causes the page to refresh in the preview window. (Inherited from PageBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetDefaults | This method is called by the designer when you create a new page. (Overrides PageBase..::.SetDefaults()()().)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner. Wraps the ShowDialog()()() method.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

DialogPage Class
FastReport.Dialog Namespace


AddChild Method

[image]

FastReport.Net Class Reference
DialogPage..::.AddChild Method
DialogPage Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

DialogPage Class
FastReport.Dialog Namespace


Assign Method

[image]

FastReport.Net Class Reference
DialogPage..::.Assign Method
DialogPage Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

DialogPage Class
FastReport.Dialog Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
DialogPage..::.CanContain Method
DialogPage Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

DialogPage Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DialogPage..::.Dispose Method
DialogPage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

DialogPage Class
DialogPage Members
FastReport.Dialog Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
DialogPage..::.Dispose Method (Boolean)
DialogPage Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

DialogPage Class
Dispose Overload
FastReport.Dialog Namespace


DrawSelection Method

[image]

FastReport.Net Class Reference
DialogPage..::.DrawSelection Method
DialogPage Class See Also Send Feedback
Draw the selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawSelection(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawSelection ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawSelection(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method draws a set of selection points returned by the GetSelectionPoints()()() method.

See Also

DialogPage Class
FastReport.Dialog Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
DialogPage..::.GetChildObjects Method
DialogPage Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overridable Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

DialogPage Class
FastReport.Dialog Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
DialogPage..::.GetChildOrder Method
DialogPage Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

DialogPage Class
FastReport.Dialog Namespace


GetPageDesignerType Method

[image]

FastReport.Net Class Reference
DialogPage..::.GetPageDesignerType Method
DialogPage Class See Also Send Feedback
Gets a page designer for this page type.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Type GetPageDesignerType()
Visual Basic (Declaration)
Public Overrides Function GetPageDesignerType As Type
Visual C++
public:
virtual Type^ GetPageDesignerType() override

Return Value

The page designer.

See Also

DialogPage Class
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
DialogPage..::.GetSelectionPoints Method
DialogPage Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

DialogPage Class
FastReport.Dialog Namespace


HandleDoubleClick Method

[image]

FastReport.Net Class Reference
DialogPage..::.HandleDoubleClick Method
DialogPage Class See Also Send Feedback
Handles double click event in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDoubleClick()
Visual Basic (Declaration)
Public Overrides Sub HandleDoubleClick
Visual C++
public:
virtual void HandleDoubleClick() override

Remarks

This method is called when the user doubleclicks the object in the designer. Typical implementation invokes the object's editor (calls the InvokeEditor method) and sets the designer's Modified flag.

See Also

DialogPage Class
FastReport.Dialog Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
DialogPage..::.HandleMouseDown Method
DialogPage Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

DialogPage Class
FastReport.Dialog Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
DialogPage..::.HandleMouseHover Method
DialogPage Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

DialogPage Class
FastReport.Dialog Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
DialogPage..::.HandleMouseUp Method
DialogPage Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

DialogPage Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DialogPage..::.MemberwiseClone Method
DialogPage Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DialogPage Class
DialogPage Members
FastReport.Dialog Namespace


OnFormClosed Method

[image]

FastReport.Net Class Reference
DialogPage..::.OnFormClosed Method
DialogPage Class See Also Send Feedback
This method fires the FormClosed event and the script code connected to the FormClosedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnFormClosed(
    FormClosedEventArgs e
)
Visual Basic (Declaration)
Public Sub OnFormClosed ( _
    e As FormClosedEventArgs _
)
Visual C++
public:
void OnFormClosed(
    FormClosedEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.FormClosedEventArgs
Event data.

See Also

DialogPage Class
FastReport.Dialog Namespace


OnFormClosing Method

[image]

FastReport.Net Class Reference
DialogPage..::.OnFormClosing Method
DialogPage Class See Also Send Feedback
This method fires the FormClosing event and the script code connected to the FormClosingEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnFormClosing(
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Public Sub OnFormClosing ( _
    e As FormClosingEventArgs _
)
Visual C++
public:
void OnFormClosing(
    FormClosingEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.FormClosingEventArgs
Event data.

See Also

DialogPage Class
FastReport.Dialog Namespace


OnLoad Method

[image]

FastReport.Net Class Reference
DialogPage..::.OnLoad Method
DialogPage Class See Also Send Feedback
This method fires the Load event and the script code connected to the LoadEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
public:
void OnLoad(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogPage Class
FastReport.Dialog Namespace


OnPaint Method

[image]

FastReport.Net Class Reference
DialogPage..::.OnPaint Method
DialogPage Class See Also Send Feedback
This method fires the Paint event and the script code connected to the PaintEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Public Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
void OnPaint(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
Event data.

See Also

DialogPage Class
FastReport.Dialog Namespace


OnResize Method

[image]

FastReport.Net Class Reference
DialogPage..::.OnResize Method
DialogPage Class See Also Send Feedback
This method fires the Resize event and the script code connected to the ResizeEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnResize(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnResize ( _
    e As EventArgs _
)
Visual C++
public:
void OnResize(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogPage Class
FastReport.Dialog Namespace


OnShown Method

[image]

FastReport.Net Class Reference
DialogPage..::.OnShown Method
DialogPage Class See Also Send Feedback
This method fires the Shown event and the script code connected to the ShownEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnShown(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnShown ( _
    e As EventArgs _
)
Visual C++
public:
void OnShown(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

DialogPage Class
FastReport.Dialog Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
DialogPage..::.RemoveChild Method
DialogPage Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

DialogPage Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DialogPage..::.Serialize Method
DialogPage Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DialogPage Class
FastReport.Dialog Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
DialogPage..::.SetChildOrder Method
DialogPage Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Overridable Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
)

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

DialogPage Class
FastReport.Dialog Namespace


SetDefaults Method

[image]

FastReport.Net Class Reference
DialogPage..::.SetDefaults Method
DialogPage Class See Also Send Feedback
This method is called by the designer when you create a new page.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SetDefaults()
Visual Basic (Declaration)
Public Overrides Sub SetDefaults
Visual C++
public:
virtual void SetDefaults() override

Remarks

You may create the default page layout (add default bands, set default page size, etc).

See Also

DialogPage Class
FastReport.Dialog Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
DialogPage..::.ShowDialog Method
DialogPage Class See Also Send Feedback
Shows the form as a modal dialog box with the currently active window set as its owner. Wraps the ShowDialog()()() method.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogResult ShowDialog()
Visual Basic (Declaration)
Public Function ShowDialog As DialogResult
Visual C++
public:
DialogResult ShowDialog()

Return Value

One of the DialogResult values.

See Also

DialogPage Class
FastReport.Dialog Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
DialogPage..::.UpdateLayout Method
DialogPage Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Overridable Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
)

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

DialogPage Class
FastReport.Dialog Namespace


DialogPage Properties

[image] [image]

FastReport.Net Class Reference
DialogPage Properties
DialogPage Class See Also Send Feedback

The DialogPage type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. Wraps the AcceptButton property.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Inherited from PageBase.)
BackColor | Gets or sets the background color for the form. Wraps the BackColor property.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. Wraps the CancelButton property.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Overrides ComponentBase..::.ClientSize.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Controls | Gets the collection of controls contained within the form.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Inherited from PageBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property.
Form | Gets an internal Form.
FormBorderStyle | Gets or sets the border style of the form. Wraps the FormBorderStyle property.
FormClosedEvent | Gets or sets a script method name that will be used to handle the FormClosed event.
FormClosingEvent | Gets or sets a script method name that will be used to handle the FormClosing event.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Overrides ComponentBase..::.Height.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
LoadEvent | Gets or sets a script method name that will be used to handle the Load event.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event.
Restrictions | This property is not relevant to this class. (Inherited from PageBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property.
ShownEvent | Gets or sets a script method name that will be used to handle the Shown event.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SnapSize | Gets the snap size for this page. (Overrides PageBase..::.SnapSize.)
Text | Gets or sets the text associated with this form. Wraps the Text property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DialogPage Class
FastReport.Dialog Namespace


AcceptButton Property

[image]

FastReport.Net Class Reference
DialogPage..::.AcceptButton Property
DialogPage Class See Also Send Feedback
Gets or sets the button on the form that is clicked when the user presses the ENTER key. Wraps the AcceptButton property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonControl AcceptButton { get; set; }
Visual Basic (Declaration)
Public Property AcceptButton As ButtonControl
Visual C++
public:
property ButtonControl^ AcceptButton {
    ButtonControl^ get ();
    void set (ButtonControl^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


BackColor Property

[image]

FastReport.Net Class Reference
DialogPage..::.BackColor Property
DialogPage Class See Also Send Feedback
Gets or sets the background color for the form. Wraps the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


CancelButton Property

[image]

FastReport.Net Class Reference
DialogPage..::.CancelButton Property
DialogPage Class See Also Send Feedback
Gets or sets the button control that is clicked when the user presses the ESC key. Wraps the CancelButton property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ButtonControl CancelButton { get; set; }
Visual Basic (Declaration)
Public Property CancelButton As ButtonControl
Visual C++
public:
property ButtonControl^ CancelButton {
    ButtonControl^ get ();
    void set (ButtonControl^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


ClientSize Property

[image]

FastReport.Net Class Reference
DialogPage..::.ClientSize Property
DialogPage Class See Also Send Feedback
Gets or sets the size of client area of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF ClientSize { get; set; }
Visual Basic (Declaration)
Public Overrides Property ClientSize As SizeF
Visual C++
public:
virtual property SizeF ClientSize {
    SizeF get () override;
    void set (SizeF value) override;
}

Remarks

This property is used in the DialogPage class.

See Also

DialogPage Class
FastReport.Dialog Namespace


Controls Property

[image]

FastReport.Net Class Reference
DialogPage..::.Controls Property
DialogPage Class See Also Send Feedback
Gets the collection of controls contained within the form.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogComponentCollection Controls { get; }
Visual Basic (Declaration)
Public ReadOnly Property Controls As DialogComponentCollection
Visual C++
public:
property DialogComponentCollection^ Controls {
    DialogComponentCollection^ get ();
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Font Property

[image]

FastReport.Net Class Reference
DialogPage..::.Font Property
DialogPage Class See Also Send Feedback
Gets or sets the font of the text displayed by the control. Wraps the Font property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Form Property

[image]

FastReport.Net Class Reference
DialogPage..::.Form Property
DialogPage Class See Also Send Feedback
Gets an internal Form.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Form Form { get; }
Visual Basic (Declaration)
Public ReadOnly Property Form As Form
Visual C++
public:
property Form^ Form {
    Form^ get ();
}

See Also

DialogPage Class
FastReport.Dialog Namespace


FormBorderStyle Property

[image]

FastReport.Net Class Reference
DialogPage..::.FormBorderStyle Property
DialogPage Class See Also Send Feedback
Gets or sets the border style of the form. Wraps the FormBorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FormBorderStyle FormBorderStyle { get; set; }
Visual Basic (Declaration)
Public Property FormBorderStyle As FormBorderStyle
Visual C++
public:
property FormBorderStyle FormBorderStyle {
    FormBorderStyle get ();
    void set (FormBorderStyle value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


FormClosedEvent Property

[image]

FastReport.Net Class Reference
DialogPage..::.FormClosedEvent Property
DialogPage Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the FormClosed event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FormClosedEvent { get; set; }
Visual Basic (Declaration)
Public Property FormClosedEvent As String
Visual C++
public:
property String^ FormClosedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


FormClosingEvent Property

[image]

FastReport.Net Class Reference
DialogPage..::.FormClosingEvent Property
DialogPage Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the FormClosing event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FormClosingEvent { get; set; }
Visual Basic (Declaration)
Public Property FormClosingEvent As String
Visual C++
public:
property String^ FormClosingEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Height Property

[image]

FastReport.Net Class Reference
DialogPage..::.Height Property
DialogPage Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

DialogPage Class
FastReport.Dialog Namespace


Left Property

[image]

FastReport.Net Class Reference
DialogPage..::.Left Property
DialogPage Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

DialogPage Class
FastReport.Dialog Namespace


LoadEvent Property

[image]

FastReport.Net Class Reference
DialogPage..::.LoadEvent Property
DialogPage Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Load event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LoadEvent { get; set; }
Visual Basic (Declaration)
Public Property LoadEvent As String
Visual C++
public:
property String^ LoadEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


PaintEvent Property

[image]

FastReport.Net Class Reference
DialogPage..::.PaintEvent Property
DialogPage Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Paint event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PaintEvent { get; set; }
Visual Basic (Declaration)
Public Property PaintEvent As String
Visual C++
public:
property String^ PaintEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


ResizeEvent Property

[image]

FastReport.Net Class Reference
DialogPage..::.ResizeEvent Property
DialogPage Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Resize event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ResizeEvent { get; set; }
Visual Basic (Declaration)
Public Property ResizeEvent As String
Visual C++
public:
property String^ ResizeEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


RightToLeft Property

[image]

FastReport.Net Class Reference
DialogPage..::.RightToLeft Property
DialogPage Class See Also Send Feedback
Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RightToLeft RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
Visual C++
public:
property RightToLeft RightToLeft {
    RightToLeft get ();
    void set (RightToLeft value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


ShownEvent Property

[image]

FastReport.Net Class Reference
DialogPage..::.ShownEvent Property
DialogPage Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the Shown event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ShownEvent { get; set; }
Visual Basic (Declaration)
Public Property ShownEvent As String
Visual C++
public:
property String^ ShownEvent {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


SnapSize Property

[image]

FastReport.Net Class Reference
DialogPage..::.SnapSize Property
DialogPage Class See Also Send Feedback
Gets the snap size for this page.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF SnapSize { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SnapSize As SizeF
Visual C++
public:
virtual property SizeF SnapSize {
    SizeF get () override;
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
DialogPage..::.Text Property
DialogPage Class See Also Send Feedback
Gets or sets the text associated with this form. Wraps the Text property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Top Property

[image]

FastReport.Net Class Reference
DialogPage..::.Top Property
DialogPage Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

DialogPage Class
FastReport.Dialog Namespace


Width Property

[image]

FastReport.Net Class Reference
DialogPage..::.Width Property
DialogPage Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

DialogPage Class
FastReport.Dialog Namespace


DialogPage Events

[image] [image]

FastReport.Net Class Reference
DialogPage Events
DialogPage Class See Also Send Feedback

The DialogPage type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
FormClosed | Occurs after the form is closed. Wraps the FormClosed event.
FormClosing | Occurs before the form is closed. Wraps the FormClosing event.
Load | Occurs before a form is displayed for the first time. Wraps the Load event.
Paint | Occurs when the form is redrawn. Wraps the Paint event.
Resize | Occurs when the form is resized. Wraps the Resize event.
Shown | Occurs whenever the form is first displayed. Wraps the Shown event.

See Also

DialogPage Class
FastReport.Dialog Namespace


FormClosed Event

[image]

FastReport.Net Class Reference
DialogPage..::.FormClosed Event
DialogPage Class See Also Send Feedback
Occurs after the form is closed. Wraps the FormClosed event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event FormClosedEventHandler FormClosed
Visual Basic (Declaration)
Public Event FormClosed As FormClosedEventHandler
Visual C++
public:
 event FormClosedEventHandler^ FormClosed {
    void add (FormClosedEventHandler^ value);
    void remove (FormClosedEventHandler^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


FormClosing Event

[image]

FastReport.Net Class Reference
DialogPage..::.FormClosing Event
DialogPage Class See Also Send Feedback
Occurs before the form is closed. Wraps the FormClosing event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event FormClosingEventHandler FormClosing
Visual Basic (Declaration)
Public Event FormClosing As FormClosingEventHandler
Visual C++
public:
 event FormClosingEventHandler^ FormClosing {
    void add (FormClosingEventHandler^ value);
    void remove (FormClosingEventHandler^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Load Event

[image]

FastReport.Net Class Reference
DialogPage..::.Load Event
DialogPage Class See Also Send Feedback
Occurs before a form is displayed for the first time. Wraps the Load event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Load
Visual Basic (Declaration)
Public Event Load As EventHandler
Visual C++
public:
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Paint Event

[image]

FastReport.Net Class Reference
DialogPage..::.Paint Event
DialogPage Class See Also Send Feedback
Occurs when the form is redrawn. Wraps the Paint event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event PaintEventHandler Paint
Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
Visual C++
public:
 event PaintEventHandler^ Paint {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Resize Event

[image]

FastReport.Net Class Reference
DialogPage..::.Resize Event
DialogPage Class See Also Send Feedback
Occurs when the form is resized. Wraps the Resize event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Resize
Visual Basic (Declaration)
Public Event Resize As EventHandler
Visual C++
public:
 event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


Shown Event

[image]

FastReport.Net Class Reference
DialogPage..::.Shown Event
DialogPage Class See Also Send Feedback
Occurs whenever the form is first displayed. Wraps the Shown event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler Shown
Visual Basic (Declaration)
Public Event Shown As EventHandler
Visual C++
public:
 event EventHandler^ Shown {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DialogPage Class
FastReport.Dialog Namespace


GridControl Class

[image]

FastReport.Net Class Reference
GridControl Class
Members See Also Send Feedback
Displays data in a customizable grid. Wraps the DataGridView control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GridControl : DialogControl,
    IParent
Visual Basic (Declaration)
Public Class GridControl _
    Inherits DialogControl _
    Implements IParent
Visual C++
public ref class GridControl : public DialogControl,
    IParent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.GridControl

See Also

GridControl Members
FastReport.Dialog Namespace


GridControl Members

[image] [image]

FastReport.Net Class Reference
GridControl Members
GridControl Class Constructors Methods Properties Events See Also Send Feedback

The GridControl type exposes the following members.

Constructors

Name | Description
GridControl | Initializes a new instance of the GridControl class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Overrides DialogControl..::.FinalizeControl()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Overrides DialogControl..::.InitializeControl()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowUserToAddRows | Gets or sets a value indicating whether the option to add rows is displayed to the user. Wraps the AllowUserToAddRows property.
AllowUserToDeleteRows | Gets or sets a value indicating whether the user is allowed to delete rows from the DataGridView. Wraps the AllowUserToDeleteRows property.
AlternatingRowsDefaultCellStyle | Gets or sets the default cell style applied to odd-numbered rows of the DataGridView. Wraps the AlternatingRowsDefaultCellStyle property.
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoSizeColumnsMode | Gets or sets a value indicating how column widths are determined. Wraps the AutoSizeColumnsMode property.
AutoSizeRowsMode | Gets or sets a value indicating how row heights are determined. Wraps the AutoSizeRowsMode property.
BackColor | This property is not relevant to this class. (Overrides DialogControl..::.BackColor.)
BackgroundColor | Gets or sets the background color of the DataGridView. Wraps the BackgroundColor property.
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BorderStyle | Gets or sets the border style for the DataGridView. Wraps the BorderStyle property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CellBorderStyle | Gets the cell border style for the DataGridView. Wraps the CellBorderStyle property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnHeadersBorderStyle | Gets the border style applied to the column headers. Wraps the ColumnHeadersBorderStyle property.
ColumnHeadersDefaultCellStyle | Gets or sets the default column header style. Wraps the ColumnHeadersDefaultCellStyle property.
ColumnHeadersHeight | Gets or sets the height, in pixels, of the column headers row. Wraps the ColumnHeadersHeight property.
ColumnHeadersHeightSizeMode | Gets or sets a value indicating whether the height of the column headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers. Wraps the ColumnHeadersHeightSizeMode property.
ColumnHeadersVisible | Gets or sets a value indicating whether the column header row is displayed. Wraps the ColumnHeadersVisible property.
Columns | Gets the collection of GridControlColumn objects that represents the grid columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataGridView | Gets an internal DataGridView.
DataSource | Gets or sets the data source that the DataGridView is displaying data for.
DefaultCellStyle | Gets or sets the default cell style to be applied to the cells in the DataGridView if no other cell style properties are set. Wraps the DefaultCellStyle property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | This property is not relevant to this class. (Overrides DialogControl..::.ForeColor.)
GridColor | Gets or sets the color of the grid lines separating the cells of the DataGridView. Wraps the GridColor property.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiSelect | Gets or sets a value indicating whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time. Wraps the MultiSelect property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ReadOnly | Gets a value indicating whether the user can edit the cells of the DataGridView control. Wraps the ReadOnly property.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
RowHeadersBorderStyle | Gets or sets the border style of the row header cells. Wraps the RowHeadersBorderStyle property.
RowHeadersDefaultCellStyle | Gets or sets the default style applied to the row header cells. Wraps the RowHeadersDefaultCellStyle property.
RowHeadersVisible | Gets or sets a value indicating whether the column that contains row headers is displayed. Wraps the RowHeadersVisible property.
RowHeadersWidth | Gets or sets the width, in pixels, of the column that contains the row headers. Wraps the RowHeadersWidth property.
RowHeadersWidthSizeMode | Gets or sets a value indicating whether the width of the row headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers. Wraps the RowHeadersWidthSizeMode property.
RowsDefaultCellStyle | Gets or sets the default style applied to the row cells of the DataGridView. Wraps the RowsDefaultCellStyle property.
ScrollBars | Gets or sets the type of scroll bars to display for the DataGridView control. Wraps the ScrollBars property.
SelectionMode | Gets or sets a value indicating how the cells of the DataGridView can be selected. Wraps the SelectionMode property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

GridControl Class
FastReport.Dialog Namespace


GridControl Constructor

[image]

FastReport.Net Class Reference
GridControl Constructor
GridControl Class See Also Send Feedback
Initializes a new instance of the GridControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GridControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridControl()

See Also

GridControl Class
FastReport.Dialog Namespace


GridControl Methods

[image] [image]

FastReport.Net Class Reference
GridControl Methods
GridControl Class See Also Send Feedback

The GridControl type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Overrides DialogControl..::.FinalizeControl()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Overrides DialogControl..::.InitializeControl()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

GridControl Class
FastReport.Dialog Namespace


AddChild Method

[image]

FastReport.Net Class Reference
GridControl..::.AddChild Method
GridControl Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

GridControl Class
FastReport.Dialog Namespace


CanContain Method

[image]

FastReport.Net Class Reference
GridControl..::.CanContain Method
GridControl Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

GridControl Class
FastReport.Dialog Namespace


Clear Method

[image]

FastReport.Net Class Reference
GridControl..::.Clear Method
GridControl Class See Also Send Feedback
Clears the object's state.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

This method also disposes all object's children.

See Also

GridControl Class
FastReport.Dialog Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
GridControl..::.DeserializeSubItems Method
GridControl Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overrides Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

GridControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
GridControl..::.Dispose Method
GridControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

GridControl Class
GridControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
GridControl..::.DrawSelectionPoint Method
GridControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

GridControl Class
GridControl Members
FastReport.Dialog Namespace


FinalizeControl Method

[image]

FastReport.Net Class Reference
GridControl..::.FinalizeControl Method
GridControl Class See Also Send Feedback
Finalizes the control after its parent form is closed.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FinalizeControl()
Visual Basic (Declaration)
Public Overrides Sub FinalizeControl
Visual C++
public:
virtual void FinalizeControl() override

Remarks

This method is called when report is run.

See Also

GridControl Class
FastReport.Dialog Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
GridControl..::.GetChildObjects Method
GridControl Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

GridControl Class
FastReport.Dialog Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
GridControl..::.GetChildOrder Method
GridControl Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

GridControl Class
FastReport.Dialog Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
GridControl..::.GetContextMenu Method
GridControl Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

GridControl Class
FastReport.Dialog Namespace


InitializeControl Method

[image]

FastReport.Net Class Reference
GridControl..::.InitializeControl Method
GridControl Class See Also Send Feedback
Initializes the control before display it in the dialog form.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeControl()
Visual Basic (Declaration)
Public Overrides Sub InitializeControl
Visual C++
public:
virtual void InitializeControl() override

Remarks

This method is called when report is run.

See Also

GridControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
GridControl..::.MemberwiseClone Method
GridControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GridControl Class
GridControl Members
FastReport.Dialog Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
GridControl..::.RemoveChild Method
GridControl Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

GridControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
GridControl..::.Serialize Method
GridControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

GridControl Class
FastReport.Dialog Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
GridControl..::.SetChildOrder Method
GridControl Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

GridControl Class
FastReport.Dialog Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
GridControl..::.UpdateLayout Method
GridControl Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

GridControl Class
FastReport.Dialog Namespace


GridControl Properties

[image] [image]

FastReport.Net Class Reference
GridControl Properties
GridControl Class See Also Send Feedback

The GridControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowUserToAddRows | Gets or sets a value indicating whether the option to add rows is displayed to the user. Wraps the AllowUserToAddRows property.
AllowUserToDeleteRows | Gets or sets a value indicating whether the user is allowed to delete rows from the DataGridView. Wraps the AllowUserToDeleteRows property.
AlternatingRowsDefaultCellStyle | Gets or sets the default cell style applied to odd-numbered rows of the DataGridView. Wraps the AlternatingRowsDefaultCellStyle property.
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoSizeColumnsMode | Gets or sets a value indicating how column widths are determined. Wraps the AutoSizeColumnsMode property.
AutoSizeRowsMode | Gets or sets a value indicating how row heights are determined. Wraps the AutoSizeRowsMode property.
BackColor | This property is not relevant to this class. (Overrides DialogControl..::.BackColor.)
BackgroundColor | Gets or sets the background color of the DataGridView. Wraps the BackgroundColor property.
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BorderStyle | Gets or sets the border style for the DataGridView. Wraps the BorderStyle property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CellBorderStyle | Gets the cell border style for the DataGridView. Wraps the CellBorderStyle property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnHeadersBorderStyle | Gets the border style applied to the column headers. Wraps the ColumnHeadersBorderStyle property.
ColumnHeadersDefaultCellStyle | Gets or sets the default column header style. Wraps the ColumnHeadersDefaultCellStyle property.
ColumnHeadersHeight | Gets or sets the height, in pixels, of the column headers row. Wraps the ColumnHeadersHeight property.
ColumnHeadersHeightSizeMode | Gets or sets a value indicating whether the height of the column headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers. Wraps the ColumnHeadersHeightSizeMode property.
ColumnHeadersVisible | Gets or sets a value indicating whether the column header row is displayed. Wraps the ColumnHeadersVisible property.
Columns | Gets the collection of GridControlColumn objects that represents the grid columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataGridView | Gets an internal DataGridView.
DataSource | Gets or sets the data source that the DataGridView is displaying data for.
DefaultCellStyle | Gets or sets the default cell style to be applied to the cells in the DataGridView if no other cell style properties are set. Wraps the DefaultCellStyle property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | This property is not relevant to this class. (Overrides DialogControl..::.ForeColor.)
GridColor | Gets or sets the color of the grid lines separating the cells of the DataGridView. Wraps the GridColor property.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiSelect | Gets or sets a value indicating whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time. Wraps the MultiSelect property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ReadOnly | Gets a value indicating whether the user can edit the cells of the DataGridView control. Wraps the ReadOnly property.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
RowHeadersBorderStyle | Gets or sets the border style of the row header cells. Wraps the RowHeadersBorderStyle property.
RowHeadersDefaultCellStyle | Gets or sets the default style applied to the row header cells. Wraps the RowHeadersDefaultCellStyle property.
RowHeadersVisible | Gets or sets a value indicating whether the column that contains row headers is displayed. Wraps the RowHeadersVisible property.
RowHeadersWidth | Gets or sets the width, in pixels, of the column that contains the row headers. Wraps the RowHeadersWidth property.
RowHeadersWidthSizeMode | Gets or sets a value indicating whether the width of the row headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers. Wraps the RowHeadersWidthSizeMode property.
RowsDefaultCellStyle | Gets or sets the default style applied to the row cells of the DataGridView. Wraps the RowsDefaultCellStyle property.
ScrollBars | Gets or sets the type of scroll bars to display for the DataGridView control. Wraps the ScrollBars property.
SelectionMode | Gets or sets a value indicating how the cells of the DataGridView can be selected. Wraps the SelectionMode property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

GridControl Class
FastReport.Dialog Namespace


AllowUserToAddRows Property

[image]

FastReport.Net Class Reference
GridControl..::.AllowUserToAddRows Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the option to add rows is displayed to the user. Wraps the AllowUserToAddRows property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowUserToAddRows { get; set; }
Visual Basic (Declaration)
Public Property AllowUserToAddRows As Boolean
Visual C++
public:
property bool AllowUserToAddRows {
    bool get ();
    void set (bool value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


AllowUserToDeleteRows Property

[image]

FastReport.Net Class Reference
GridControl..::.AllowUserToDeleteRows Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the user is allowed to delete rows from the DataGridView. Wraps the AllowUserToDeleteRows property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowUserToDeleteRows { get; set; }
Visual Basic (Declaration)
Public Property AllowUserToDeleteRows As Boolean
Visual C++
public:
property bool AllowUserToDeleteRows {
    bool get ();
    void set (bool value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


AlternatingRowsDefaultCellStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.AlternatingRowsDefaultCellStyle Property
GridControl Class See Also Send Feedback
Gets or sets the default cell style applied to odd-numbered rows of the DataGridView. Wraps the AlternatingRowsDefaultCellStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellStyle AlternatingRowsDefaultCellStyle { get; set; }
Visual Basic (Declaration)
Public Property AlternatingRowsDefaultCellStyle As DataGridViewCellStyle
Visual C++
public:
property DataGridViewCellStyle^ AlternatingRowsDefaultCellStyle {
    DataGridViewCellStyle^ get ();
    void set (DataGridViewCellStyle^ value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


AutoSizeColumnsMode Property

[image]

FastReport.Net Class Reference
GridControl..::.AutoSizeColumnsMode Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating how column widths are determined. Wraps the AutoSizeColumnsMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewAutoSizeColumnsMode AutoSizeColumnsMode { get; set; }
Visual Basic (Declaration)
Public Property AutoSizeColumnsMode As DataGridViewAutoSizeColumnsMode
Visual C++
public:
property DataGridViewAutoSizeColumnsMode AutoSizeColumnsMode {
    DataGridViewAutoSizeColumnsMode get ();
    void set (DataGridViewAutoSizeColumnsMode value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


AutoSizeRowsMode Property

[image]

FastReport.Net Class Reference
GridControl..::.AutoSizeRowsMode Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating how row heights are determined. Wraps the AutoSizeRowsMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewAutoSizeRowsMode AutoSizeRowsMode { get; set; }
Visual Basic (Declaration)
Public Property AutoSizeRowsMode As DataGridViewAutoSizeRowsMode
Visual C++
public:
property DataGridViewAutoSizeRowsMode AutoSizeRowsMode {
    DataGridViewAutoSizeRowsMode get ();
    void set (DataGridViewAutoSizeRowsMode value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


BackColor Property

[image]

FastReport.Net Class Reference
GridControl..::.BackColor Property
GridControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Color BackColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property BackColor As Color
Visual C++
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}

See Also

GridControl Class
FastReport.Dialog Namespace


BackgroundColor Property

[image]

FastReport.Net Class Reference
GridControl..::.BackgroundColor Property
GridControl Class See Also Send Feedback
Gets or sets the background color of the DataGridView. Wraps the BackgroundColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic (Declaration)
Public Property BackgroundColor As Color
Visual C++
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


BorderStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.BorderStyle Property
GridControl Class See Also Send Feedback
Gets or sets the border style for the DataGridView. Wraps the BorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderStyle BorderStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
Visual C++
public:
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


CellBorderStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.CellBorderStyle Property
GridControl Class See Also Send Feedback
Gets the cell border style for the DataGridView. Wraps the CellBorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellBorderStyle CellBorderStyle { get; set; }
Visual Basic (Declaration)
Public Property CellBorderStyle As DataGridViewCellBorderStyle
Visual C++
public:
property DataGridViewCellBorderStyle CellBorderStyle {
    DataGridViewCellBorderStyle get ();
    void set (DataGridViewCellBorderStyle value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ColumnHeadersBorderStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.ColumnHeadersBorderStyle Property
GridControl Class See Also Send Feedback
Gets the border style applied to the column headers. Wraps the ColumnHeadersBorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewHeaderBorderStyle ColumnHeadersBorderStyle { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadersBorderStyle As DataGridViewHeaderBorderStyle
Visual C++
public:
property DataGridViewHeaderBorderStyle ColumnHeadersBorderStyle {
    DataGridViewHeaderBorderStyle get ();
    void set (DataGridViewHeaderBorderStyle value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ColumnHeadersDefaultCellStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.ColumnHeadersDefaultCellStyle Property
GridControl Class See Also Send Feedback
Gets or sets the default column header style. Wraps the ColumnHeadersDefaultCellStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellStyle ColumnHeadersDefaultCellStyle { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadersDefaultCellStyle As DataGridViewCellStyle
Visual C++
public:
property DataGridViewCellStyle^ ColumnHeadersDefaultCellStyle {
    DataGridViewCellStyle^ get ();
    void set (DataGridViewCellStyle^ value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ColumnHeadersHeight Property

[image]

FastReport.Net Class Reference
GridControl..::.ColumnHeadersHeight Property
GridControl Class See Also Send Feedback
Gets or sets the height, in pixels, of the column headers row. Wraps the ColumnHeadersHeight property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ColumnHeadersHeight { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadersHeight As Integer
Visual C++
public:
property int ColumnHeadersHeight {
    int get ();
    void set (int value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ColumnHeadersHeightSizeMode Property

[image]

FastReport.Net Class Reference
GridControl..::.ColumnHeadersHeightSizeMode Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the height of the column headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers. Wraps the ColumnHeadersHeightSizeMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewColumnHeadersHeightSizeMode ColumnHeadersHeightSizeMode { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadersHeightSizeMode As DataGridViewColumnHeadersHeightSizeMode
Visual C++
public:
property DataGridViewColumnHeadersHeightSizeMode ColumnHeadersHeightSizeMode {
    DataGridViewColumnHeadersHeightSizeMode get ();
    void set (DataGridViewColumnHeadersHeightSizeMode value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ColumnHeadersVisible Property

[image]

FastReport.Net Class Reference
GridControl..::.ColumnHeadersVisible Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the column header row is displayed. Wraps the ColumnHeadersVisible property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ColumnHeadersVisible { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadersVisible As Boolean
Visual C++
public:
property bool ColumnHeadersVisible {
    bool get ();
    void set (bool value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


Columns Property

[image]

FastReport.Net Class Reference
GridControl..::.Columns Property
GridControl Class See Also Send Feedback
Gets the collection of GridControlColumn objects that represents the grid columns.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GridControlColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As GridControlColumnCollection
Visual C++
public:
property GridControlColumnCollection^ Columns {
    GridControlColumnCollection^ get ();
}

See Also

GridControl Class
FastReport.Dialog Namespace


DataGridView Property

[image]

FastReport.Net Class Reference
GridControl..::.DataGridView Property
GridControl Class See Also Send Feedback
Gets an internal DataGridView.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridView DataGridView { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataGridView As DataGridView
Visual C++
public:
property DataGridView^ DataGridView {
    DataGridView^ get ();
}

See Also

GridControl Class
FastReport.Dialog Namespace


DataSource Property

[image]

FastReport.Net Class Reference
GridControl..::.DataSource Property
GridControl Class See Also Send Feedback
Gets or sets the data source that the DataGridView is displaying data for.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


DefaultCellStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.DefaultCellStyle Property
GridControl Class See Also Send Feedback
Gets or sets the default cell style to be applied to the cells in the DataGridView if no other cell style properties are set. Wraps the DefaultCellStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellStyle DefaultCellStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultCellStyle As DataGridViewCellStyle
Visual C++
public:
property DataGridViewCellStyle^ DefaultCellStyle {
    DataGridViewCellStyle^ get ();
    void set (DataGridViewCellStyle^ value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ForeColor Property

[image]

FastReport.Net Class Reference
GridControl..::.ForeColor Property
GridControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property ForeColor As Color
Visual C++
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}

See Also

GridControl Class
FastReport.Dialog Namespace


GridColor Property

[image]

FastReport.Net Class Reference
GridControl..::.GridColor Property
GridControl Class See Also Send Feedback
Gets or sets the color of the grid lines separating the cells of the DataGridView. Wraps the GridColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color GridColor { get; set; }
Visual Basic (Declaration)
Public Property GridColor As Color
Visual C++
public:
property Color GridColor {
    Color get ();
    void set (Color value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


MultiSelect Property

[image]

FastReport.Net Class Reference
GridControl..::.MultiSelect Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time. Wraps the MultiSelect property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MultiSelect { get; set; }
Visual Basic (Declaration)
Public Property MultiSelect As Boolean
Visual C++
public:
property bool MultiSelect {
    bool get ();
    void set (bool value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ReadOnly Property

[image]

FastReport.Net Class Reference
GridControl..::.ReadOnly Property
GridControl Class See Also Send Feedback
Gets a value indicating whether the user can edit the cells of the DataGridView control. Wraps the ReadOnly property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


RowHeadersBorderStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.RowHeadersBorderStyle Property
GridControl Class See Also Send Feedback
Gets or sets the border style of the row header cells. Wraps the RowHeadersBorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewHeaderBorderStyle RowHeadersBorderStyle { get; set; }
Visual Basic (Declaration)
Public Property RowHeadersBorderStyle As DataGridViewHeaderBorderStyle
Visual C++
public:
property DataGridViewHeaderBorderStyle RowHeadersBorderStyle {
    DataGridViewHeaderBorderStyle get ();
    void set (DataGridViewHeaderBorderStyle value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


RowHeadersDefaultCellStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.RowHeadersDefaultCellStyle Property
GridControl Class See Also Send Feedback
Gets or sets the default style applied to the row header cells. Wraps the RowHeadersDefaultCellStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellStyle RowHeadersDefaultCellStyle { get; set; }
Visual Basic (Declaration)
Public Property RowHeadersDefaultCellStyle As DataGridViewCellStyle
Visual C++
public:
property DataGridViewCellStyle^ RowHeadersDefaultCellStyle {
    DataGridViewCellStyle^ get ();
    void set (DataGridViewCellStyle^ value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


RowHeadersVisible Property

[image]

FastReport.Net Class Reference
GridControl..::.RowHeadersVisible Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the column that contains row headers is displayed. Wraps the RowHeadersVisible property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool RowHeadersVisible { get; set; }
Visual Basic (Declaration)
Public Property RowHeadersVisible As Boolean
Visual C++
public:
property bool RowHeadersVisible {
    bool get ();
    void set (bool value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


RowHeadersWidth Property

[image]

FastReport.Net Class Reference
GridControl..::.RowHeadersWidth Property
GridControl Class See Also Send Feedback
Gets or sets the width, in pixels, of the column that contains the row headers. Wraps the RowHeadersWidth property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowHeadersWidth { get; set; }
Visual Basic (Declaration)
Public Property RowHeadersWidth As Integer
Visual C++
public:
property int RowHeadersWidth {
    int get ();
    void set (int value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


RowHeadersWidthSizeMode Property

[image]

FastReport.Net Class Reference
GridControl..::.RowHeadersWidthSizeMode Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating whether the width of the row headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers. Wraps the RowHeadersWidthSizeMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewRowHeadersWidthSizeMode RowHeadersWidthSizeMode { get; set; }
Visual Basic (Declaration)
Public Property RowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode
Visual C++
public:
property DataGridViewRowHeadersWidthSizeMode RowHeadersWidthSizeMode {
    DataGridViewRowHeadersWidthSizeMode get ();
    void set (DataGridViewRowHeadersWidthSizeMode value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


RowsDefaultCellStyle Property

[image]

FastReport.Net Class Reference
GridControl..::.RowsDefaultCellStyle Property
GridControl Class See Also Send Feedback
Gets or sets the default style applied to the row cells of the DataGridView. Wraps the RowsDefaultCellStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellStyle RowsDefaultCellStyle { get; set; }
Visual Basic (Declaration)
Public Property RowsDefaultCellStyle As DataGridViewCellStyle
Visual C++
public:
property DataGridViewCellStyle^ RowsDefaultCellStyle {
    DataGridViewCellStyle^ get ();
    void set (DataGridViewCellStyle^ value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


ScrollBars Property

[image]

FastReport.Net Class Reference
GridControl..::.ScrollBars Property
GridControl Class See Also Send Feedback
Gets or sets the type of scroll bars to display for the DataGridView control. Wraps the ScrollBars property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ScrollBars ScrollBars { get; set; }
Visual Basic (Declaration)
Public Property ScrollBars As ScrollBars
Visual C++
public:
property ScrollBars ScrollBars {
    ScrollBars get ();
    void set (ScrollBars value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


SelectionMode Property

[image]

FastReport.Net Class Reference
GridControl..::.SelectionMode Property
GridControl Class See Also Send Feedback
Gets or sets a value indicating how the cells of the DataGridView can be selected. Wraps the SelectionMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewSelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As DataGridViewSelectionMode
Visual C++
public:
property DataGridViewSelectionMode SelectionMode {
    DataGridViewSelectionMode get ();
    void set (DataGridViewSelectionMode value);
}

See Also

GridControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
GridControl..::.Text Property
GridControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

GridControl Class
FastReport.Dialog Namespace


GridControl Events

[image] [image]

FastReport.Net Class Reference
GridControl Events
GridControl Class See Also Send Feedback

The GridControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

GridControl Class
FastReport.Dialog Namespace


GridControlColumn Class

[image]

FastReport.Net Class Reference
GridControlColumn Class
Members See Also Send Feedback
Represents the GridControl's column. Wraps the DataGridViewTextBoxColumn class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GridControlColumn : Base
Visual Basic (Declaration)
Public Class GridControlColumn _
    Inherits Base
Visual C++
public ref class GridControlColumn : public Base

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Dialog..::.GridControlColumn

See Also

GridControlColumn Members
FastReport.Dialog Namespace


GridControlColumn Members

[image] [image]

FastReport.Net Class Reference
GridControlColumn Members
GridControlColumn Class Constructors Methods Properties Events See Also Send Feedback

The GridControlColumn type exposes the following members.

Constructors

Name | Description
GridControlColumn | Initializes a new instance of the GridControlColumn class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. Wraps the AutoSizeMode property.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataColumn | Gets or sets the data column attached to this column.
DefaultCellStyle | Gets or sets the column's default cell style. Wraps the DefaultCellStyle property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. Wraps the FillWeight property.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
HeaderText | Gets or sets the caption text on the column's header cell. Wraps the HeaderText property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | This property is not relevant to this class.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Visible | Gets or sets a value indicating whether the column is visible. Wraps the Visible property.
Width | Gets or sets the current width of the column. Wraps the Width property.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

GridControlColumn Class
FastReport.Dialog Namespace


GridControlColumn Constructor

[image]

FastReport.Net Class Reference
GridControlColumn Constructor
GridControlColumn Class See Also Send Feedback
Initializes a new instance of the GridControlColumn class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GridControlColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridControlColumn()

See Also

GridControlColumn Class
FastReport.Dialog Namespace


GridControlColumn Methods

[image] [image]

FastReport.Net Class Reference
GridControlColumn Methods
GridControlColumn Class See Also Send Feedback

The GridControlColumn type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

GridControlColumn Class
FastReport.Dialog Namespace


Assign Method

[image]

FastReport.Net Class Reference
GridControlColumn..::.Assign Method
GridControlColumn Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

GridControlColumn Class
FastReport.Dialog Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
GridControlColumn..::.Dispose Method
GridControlColumn Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

GridControlColumn Class
GridControlColumn Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
GridControlColumn..::.MemberwiseClone Method
GridControlColumn Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GridControlColumn Class
GridControlColumn Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
GridControlColumn..::.Serialize Method
GridControlColumn Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

GridControlColumn Class
FastReport.Dialog Namespace


GridControlColumn Properties

[image] [image]

FastReport.Net Class Reference
GridControlColumn Properties
GridControlColumn Class See Also Send Feedback

The GridControlColumn type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. Wraps the AutoSizeMode property.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataColumn | Gets or sets the data column attached to this column.
DefaultCellStyle | Gets or sets the column's default cell style. Wraps the DefaultCellStyle property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. Wraps the FillWeight property.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
HeaderText | Gets or sets the caption text on the column's header cell. Wraps the HeaderText property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | This property is not relevant to this class.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Visible | Gets or sets a value indicating whether the column is visible. Wraps the Visible property.
Width | Gets or sets the current width of the column. Wraps the Width property.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

GridControlColumn Class
FastReport.Dialog Namespace


AutoSizeMode Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.AutoSizeMode Property
GridControlColumn Class See Also Send Feedback
Gets or sets the mode by which the column automatically adjusts its width. Wraps the AutoSizeMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewAutoSizeColumnMode AutoSizeMode { get; set; }
Visual Basic (Declaration)
Public Property AutoSizeMode As DataGridViewAutoSizeColumnMode
Visual C++
public:
property DataGridViewAutoSizeColumnMode AutoSizeMode {
    DataGridViewAutoSizeColumnMode get ();
    void set (DataGridViewAutoSizeColumnMode value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


DataColumn Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.DataColumn Property
GridControlColumn Class See Also Send Feedback
Gets or sets the data column attached to this column.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DataColumn { get; set; }
Visual Basic (Declaration)
Public Property DataColumn As String
Visual C++
public:
property String^ DataColumn {
    String^ get ();
    void set (String^ value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


DefaultCellStyle Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.DefaultCellStyle Property
GridControlColumn Class See Also Send Feedback
Gets or sets the column's default cell style. Wraps the DefaultCellStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataGridViewCellStyle DefaultCellStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultCellStyle As DataGridViewCellStyle
Visual C++
public:
property DataGridViewCellStyle^ DefaultCellStyle {
    DataGridViewCellStyle^ get ();
    void set (DataGridViewCellStyle^ value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


FillWeight Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.FillWeight Property
GridControlColumn Class See Also Send Feedback
Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. Wraps the FillWeight property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float FillWeight { get; set; }
Visual Basic (Declaration)
Public Property FillWeight As Single
Visual C++
public:
property float FillWeight {
    float get ();
    void set (float value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


HeaderText Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.HeaderText Property
GridControlColumn Class See Also Send Feedback
Gets or sets the caption text on the column's header cell. Wraps the HeaderText property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string HeaderText { get; set; }
Visual Basic (Declaration)
Public Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


Name Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.Name Property
GridControlColumn Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.Restrictions Property
GridControlColumn Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


Visible Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.Visible Property
GridControlColumn Class See Also Send Feedback
Gets or sets a value indicating whether the column is visible. Wraps the Visible property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


Width Property

[image]

FastReport.Net Class Reference
GridControlColumn..::.Width Property
GridControlColumn Class See Also Send Feedback
Gets or sets the current width of the column. Wraps the Width property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

GridControlColumn Class
FastReport.Dialog Namespace


GridControlColumn Events

[image] [image]

FastReport.Net Class Reference
GridControlColumn Events
GridControlColumn Class See Also Send Feedback

The GridControlColumn type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

GridControlColumn Class
FastReport.Dialog Namespace


GridControlColumnCollection Class

[image]

FastReport.Net Class Reference
GridControlColumnCollection Class
Members See Also Send Feedback
Represents the collection of GridControl columns.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GridControlColumnCollection : FRCollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class GridControlColumnCollection _
    Inherits FRCollectionBase _
    Implements IFRSerializable
Visual C++
public ref class GridControlColumnCollection : public FRCollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Dialog..::.GridControlColumnCollection

See Also

GridControlColumnCollection Members
FastReport.Dialog Namespace


GridControlColumnCollection Members

[image] [image]

FastReport.Net Class Reference
GridControlColumnCollection Members
GridControlColumnCollection Class Constructors Methods Properties See Also Send Feedback

The GridControlColumnCollection type exposes the following members.

Constructors

Name | Description
GridControlColumnCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Deserialize | Deserializes the collection.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides FRCollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides FRCollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the collection.
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a column.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


GridControlColumnCollection Constructor

[image] [image]

FastReport.Net Class Reference
GridControlColumnCollection Constructor
GridControlColumnCollection Class See Also Send Feedback

Overload List

Name | Description
GridControlColumnCollection()()() | Initializes a new instance of the GridControlColumnCollection class with default settings.
GridControlColumnCollection(GridControl) | Initializes a new instance of the GridControlColumnCollection class with default settings.

See Also

GridControlColumnCollection Class
GridControlColumnCollection Members
FastReport.Dialog Namespace


GridControlColumnCollection Constructor

[image]

FastReport.Net Class Reference
GridControlColumnCollection Constructor
GridControlColumnCollection Class See Also Send Feedback
Initializes a new instance of the GridControlColumnCollection class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GridControlColumnCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridControlColumnCollection()

See Also

GridControlColumnCollection Class
GridControlColumnCollection Overload
FastReport.Dialog Namespace


GridControlColumnCollection Constructor (GridControl)

[image]

FastReport.Net Class Reference
GridControlColumnCollection Constructor (GridControl)
GridControlColumnCollection Class See Also Send Feedback
Initializes a new instance of the GridControlColumnCollection class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GridControlColumnCollection(
    GridControl owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As GridControl _
)
Visual C++
public:
GridControlColumnCollection(
    GridControl^ owner
)

Parameters

owner
Type: FastReport.Dialog..::.GridControl
The owner of this collection.

See Also

GridControlColumnCollection Class
GridControlColumnCollection Overload
FastReport.Dialog Namespace


GridControlColumnCollection Methods

[image] [image]

FastReport.Net Class Reference
GridControlColumnCollection Methods
GridControlColumnCollection Class See Also Send Feedback

The GridControlColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Deserialize | Deserializes the collection.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides FRCollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides FRCollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the collection.
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
GridControlColumnCollection..::.AddRange Method
GridControlColumnCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

GridControlColumnCollection Class
GridControlColumnCollection Members
FastReport.Dialog Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
GridControlColumnCollection..::.Deserialize Method
GridControlColumnCollection Class See Also Send Feedback
Deserializes the collection.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

This method is for internal use only.

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
GridControlColumnCollection..::.Equals Method
GridControlColumnCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

GridControlColumnCollection Class
GridControlColumnCollection Members
FastReport.Dialog Namespace


OnInsert Method

[image]

FastReport.Net Class Reference
GridControlColumnCollection..::.OnInsert Method
GridControlColumnCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new element into the CollectionBase instance.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which to insert value.
value
Type: System..::.Object
The new value of the element at index.

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


OnRemove Method

[image]

FastReport.Net Class Reference
GridControlColumnCollection..::.OnRemove Method
GridControlColumnCollection Class See Also Send Feedback
Performs additional custom processes when removing an element from the CollectionBase instance.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which value can be found.
value
Type: System..::.Object
The value of the element to remove from index.

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
GridControlColumnCollection..::.Serialize Method
GridControlColumnCollection Class See Also Send Feedback
Serializes the collection.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

This method is for internal use only.

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


GridControlColumnCollection Properties

[image] [image]

FastReport.Net Class Reference
GridControlColumnCollection Properties
GridControlColumnCollection Class See Also Send Feedback

The GridControlColumnCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets a column.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


Item Property

[image]

FastReport.Net Class Reference
GridControlColumnCollection..::.Item Property
GridControlColumnCollection Class See Also Send Feedback
Gets or sets a column.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GridControlColumn this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As GridControlColumn
Visual C++
public:
property GridControlColumn^ default[int index] {
    GridControlColumn^ get (int index);
    void set (int index, GridControlColumn^ value);
}

Parameters

index
Type: System..::.Int32
The index of a column in this collection.

Return Value

The column with specified index.

See Also

GridControlColumnCollection Class
FastReport.Dialog Namespace


GroupBoxControl Class

[image]

FastReport.Net Class Reference
GroupBoxControl Class
Members See Also Send Feedback
Represents a Windows control that displays a frame around a group of controls with an optional caption. Wraps the GroupBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GroupBoxControl : ParentControl
Visual Basic (Declaration)
Public Class GroupBoxControl _
    Inherits ParentControl
Visual C++
public ref class GroupBoxControl : public ParentControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.ParentControl
FastReport.Dialog..::.GroupBoxControl

See Also

GroupBoxControl Members
FastReport.Dialog Namespace


GroupBoxControl Members

[image] [image]

FastReport.Net Class Reference
GroupBoxControl Members
GroupBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The GroupBoxControl type exposes the following members.

Constructors

Name | Description
GroupBoxControl | Initializes a new instance of the GroupBoxControl class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from ParentControl.)
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from ParentControl.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ParentControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects. (Inherited from ParentControl.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from ParentControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ParentControl.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ParentControl.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ParentControl.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from ParentControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DialogControl.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from ParentControl.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from ParentControl.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Controls | Gets the collection of child controls. (Inherited from ParentControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupBox | Gets an internal GroupBox.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

GroupBoxControl Class
FastReport.Dialog Namespace


GroupBoxControl Constructor

[image]

FastReport.Net Class Reference
GroupBoxControl Constructor
GroupBoxControl Class See Also Send Feedback
Initializes a new instance of the GroupBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupBoxControl()

See Also

GroupBoxControl Class
FastReport.Dialog Namespace


GroupBoxControl Methods

[image] [image]

FastReport.Net Class Reference
GroupBoxControl Methods
GroupBoxControl Class See Also Send Feedback

The GroupBoxControl type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from ParentControl.)
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from ParentControl.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ParentControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects. (Inherited from ParentControl.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from ParentControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ParentControl.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ParentControl.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ParentControl.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from ParentControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DialogControl.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from ParentControl.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from ParentControl.)

See Also

GroupBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
GroupBoxControl..::.Dispose Method
GroupBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

GroupBoxControl Class
GroupBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
GroupBoxControl..::.DrawSelectionPoint Method
GroupBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

GroupBoxControl Class
GroupBoxControl Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
GroupBoxControl..::.MemberwiseClone Method
GroupBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GroupBoxControl Class
GroupBoxControl Members
FastReport.Dialog Namespace


GroupBoxControl Properties

[image] [image]

FastReport.Net Class Reference
GroupBoxControl Properties
GroupBoxControl Class See Also Send Feedback

The GroupBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Controls | Gets the collection of child controls. (Inherited from ParentControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupBox | Gets an internal GroupBox.
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

GroupBoxControl Class
FastReport.Dialog Namespace


GroupBox Property

[image]

FastReport.Net Class Reference
GroupBoxControl..::.GroupBox Property
GroupBoxControl Class See Also Send Feedback
Gets an internal GroupBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupBox GroupBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupBox As GroupBox
Visual C++
public:
property GroupBox^ GroupBox {
    GroupBox^ get ();
}

See Also

GroupBoxControl Class
FastReport.Dialog Namespace


GroupBoxControl Events

[image] [image]

FastReport.Net Class Reference
GroupBoxControl Events
GroupBoxControl Class See Also Send Feedback

The GroupBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

GroupBoxControl Class
FastReport.Dialog Namespace


LabelControl Class

[image]

FastReport.Net Class Reference
LabelControl Class
Members See Also Send Feedback
Represents a standard Windows label. Wraps the Label control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LabelControl : DialogControl
Visual Basic (Declaration)
Public Class LabelControl _
    Inherits DialogControl
Visual C++
public ref class LabelControl : public DialogControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.LabelControl

See Also

LabelControl Members
FastReport.Dialog Namespace


LabelControl Members

[image] [image]

FastReport.Net Class Reference
LabelControl Members
LabelControl Class Constructors Methods Properties Events See Also Send Feedback

The LabelControl type exposes the following members.

Constructors

Name | Description
LabelControl | Initializes a new instance of the LabelControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. Wraps the AutoSize property.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
Label | Gets an internal Label.
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of text in the label. Wraps the TextAlign property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

LabelControl Class
FastReport.Dialog Namespace


LabelControl Constructor

[image]

FastReport.Net Class Reference
LabelControl Constructor
LabelControl Class See Also Send Feedback
Initializes a new instance of the LabelControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LabelControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LabelControl()

See Also

LabelControl Class
FastReport.Dialog Namespace


LabelControl Methods

[image] [image]

FastReport.Net Class Reference
LabelControl Methods
LabelControl Class See Also Send Feedback

The LabelControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

LabelControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
LabelControl..::.Dispose Method
LabelControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

LabelControl Class
LabelControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
LabelControl..::.DrawSelectionPoint Method
LabelControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

LabelControl Class
LabelControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
LabelControl..::.GetSelectionPoints Method
LabelControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

LabelControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
LabelControl..::.MemberwiseClone Method
LabelControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

LabelControl Class
LabelControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
LabelControl..::.Serialize Method
LabelControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

LabelControl Class
FastReport.Dialog Namespace


LabelControl Properties

[image] [image]

FastReport.Net Class Reference
LabelControl Properties
LabelControl Class See Also Send Feedback

The LabelControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. Wraps the AutoSize property.
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
Label | Gets an internal Label.
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of text in the label. Wraps the TextAlign property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

LabelControl Class
FastReport.Dialog Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
LabelControl..::.AutoSize Property
LabelControl Class See Also Send Feedback
Gets or sets a value indicating whether the control is automatically resized to display its entire contents. Wraps the AutoSize property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

LabelControl Class
FastReport.Dialog Namespace


Label Property

[image]

FastReport.Net Class Reference
LabelControl..::.Label Property
LabelControl Class See Also Send Feedback
Gets an internal Label.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Label Label { get; }
Visual Basic (Declaration)
Public ReadOnly Property Label As Label
Visual C++
public:
property Label^ Label {
    Label^ get ();
}

See Also

LabelControl Class
FastReport.Dialog Namespace


TextAlign Property

[image]

FastReport.Net Class Reference
LabelControl..::.TextAlign Property
LabelControl Class See Also Send Feedback
Gets or sets the alignment of text in the label. Wraps the TextAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

LabelControl Class
FastReport.Dialog Namespace


LabelControl Events

[image] [image]

FastReport.Net Class Reference
LabelControl Events
LabelControl Class See Also Send Feedback

The LabelControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

LabelControl Class
FastReport.Dialog Namespace


ListBoxBaseControl Class

[image]

FastReport.Net Class Reference
ListBoxBaseControl Class
Members See Also Send Feedback
Base class for list box controls such as ListBoxControl, CheckedListBoxControl.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class ListBoxBaseControl : DataFilterBaseControl
Visual Basic (Declaration)
Public MustInherit Class ListBoxBaseControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class ListBoxBaseControl abstract : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ListBoxBaseControl
FastReport.Dialog..::.CheckedListBoxControl
FastReport.Dialog..::.ListBoxControl

See Also

ListBoxBaseControl Members
FastReport.Dialog Namespace


ListBoxBaseControl Members

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl Members
ListBoxBaseControl Class Constructors Methods Properties Events See Also Send Feedback

The ListBoxBaseControl type exposes the following members.

Constructors

Name | Description
ListBoxBaseControl | Initializes a new instance of the ListBoxBaseControl class

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Inherited from DataFilterBaseControl.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent.
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event.
DrawMode | Gets or sets the drawing mode for the control. Wraps the DrawMode property.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemHeight | Gets or sets the height of an item in the ListBox. Wraps the ItemHeight property.
Items | Gets the items of the ListBox. Wraps the Items property.
ItemsText | Gets or sets the string that contains all items text.
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property.
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property.
SelectedItem | Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property.
SelectedItems | Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property.
SelectionMode | Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event.
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event.
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ListBoxBaseControl Constructor

[image]

FastReport.Net Class Reference
ListBoxBaseControl Constructor
ListBoxBaseControl Class See Also Send Feedback
Initializes a new instance of the ListBoxBaseControl class

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ListBoxBaseControl()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ListBoxBaseControl()

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ListBoxBaseControl Methods

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl Methods
ListBoxBaseControl Class See Also Send Feedback

The ListBoxBaseControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Inherited from DataFilterBaseControl.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent.
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.AttachEvents Method
ListBoxBaseControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.DetachEvents Method
ListBoxBaseControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl..::.Dispose Method
ListBoxBaseControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ListBoxBaseControl Class
ListBoxBaseControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl..::.DrawSelectionPoint Method
ListBoxBaseControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ListBoxBaseControl Class
ListBoxBaseControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl..::.FillData Method
ListBoxBaseControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Overrides DataFilterBaseControl..::.FillData(DataSourceBase, Column).)

See Also

ListBoxBaseControl Class
ListBoxBaseControl Members
FastReport.Dialog Namespace


FillData Method (DataSourceBase, Column)

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.FillData Method (DataSourceBase, Column)
ListBoxBaseControl Class Example See Also Send Feedback
Fills the control with data.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void FillData(
    DataSourceBase dataSource,
    Column column
)
Visual Basic (Declaration)
Protected Overrides Sub FillData ( _
    dataSource As DataSourceBase, _
    column As Column _
)
Visual C++
protected:
virtual void FillData(
    DataSourceBase^ dataSource,
    Column^ column
) override

Parameters

dataSource
Type: FastReport.Data..::.DataSourceBase
The data source.
column
Type: FastReport.Data..::.Column
The data column.

Examples

Here is the example of FillData method implementation:
CopyC#
protected override void FillData(DataSourceBase dataSource, Column column)
{
  Items.Clear();
  dataSource.First();
  while (dataSource.HasMoreRows)
  {
    Items.Add(dataSource[column].ToString());
    dataSource.Next();
  }
}

See Also

ListBoxBaseControl Class
FillData Overload
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl..::.MemberwiseClone Method
ListBoxBaseControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ListBoxBaseControl Class
ListBoxBaseControl Members
FastReport.Dialog Namespace


OnDrawItem Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.OnDrawItem Method
ListBoxBaseControl Class See Also Send Feedback
This method fires the DrawItem event and the script code connected to the DrawItemEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnDrawItem(
    DrawItemEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnDrawItem ( _
    e As DrawItemEventArgs _
)
Visual C++
public:
virtual void OnDrawItem(
    DrawItemEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.DrawItemEventArgs
Event data.

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


OnMeasureItem Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.OnMeasureItem Method
ListBoxBaseControl Class See Also Send Feedback
This method fires the MeasureItem event and the script code connected to the MeasureItemEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnMeasureItem(
    MeasureItemEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnMeasureItem ( _
    e As MeasureItemEventArgs _
)
Visual C++
public:
virtual void OnMeasureItem(
    MeasureItemEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.MeasureItemEventArgs
Event data.

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


OnSelectedIndexChanged Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.OnSelectedIndexChanged Method
ListBoxBaseControl Class See Also Send Feedback
This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.Serialize Method
ListBoxBaseControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.ShouldSerializeBackColor Method
ListBoxBaseControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.ShouldSerializeForeColor Method
ListBoxBaseControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ListBoxBaseControl Properties

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl Properties
ListBoxBaseControl Class See Also Send Feedback

The ListBoxBaseControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event.
DrawMode | Gets or sets the drawing mode for the control. Wraps the DrawMode property.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemHeight | Gets or sets the height of an item in the ListBox. Wraps the ItemHeight property.
Items | Gets the items of the ListBox. Wraps the Items property.
ItemsText | Gets or sets the string that contains all items text.
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property.
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property.
SelectedItem | Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property.
SelectedItems | Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property.
SelectionMode | Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ColumnWidth Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.ColumnWidth Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property ColumnWidth As Integer
Visual C++
public:
property int ColumnWidth {
    int get ();
    void set (int value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


DrawItemEvent Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.DrawItemEvent Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the DrawItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DrawItemEvent { get; set; }
Visual Basic (Declaration)
Public Property DrawItemEvent As String
Visual C++
public:
property String^ DrawItemEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


DrawMode Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.DrawMode Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the drawing mode for the control. Wraps the DrawMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual DrawMode DrawMode { get; set; }
Visual Basic (Declaration)
Public Overridable Property DrawMode As DrawMode
Visual C++
public:
virtual property DrawMode DrawMode {
    DrawMode get ();
    void set (DrawMode value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ItemHeight Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.ItemHeight Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the height of an item in the ListBox. Wraps the ItemHeight property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int ItemHeight { get; set; }
Visual Basic (Declaration)
Public Overridable Property ItemHeight As Integer
Visual C++
public:
virtual property int ItemHeight {
    int get ();
    void set (int value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


Items Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.Items Property
ListBoxBaseControl Class See Also Send Feedback
Gets the items of the ListBox. Wraps the Items property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListBox..::.ObjectCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ListBox..::.ObjectCollection
Visual C++
public:
property ListBox..::.ObjectCollection^ Items {
    ListBox..::.ObjectCollection^ get ();
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ItemsText Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.ItemsText Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the string that contains all items text.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ItemsText { get; set; }
Visual Basic (Declaration)
Public Property ItemsText As String
Visual C++
public:
property String^ ItemsText {
    String^ get ();
    void set (String^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


MeasureItemEvent Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.MeasureItemEvent Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the MeasureItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MeasureItemEvent { get; set; }
Visual Basic (Declaration)
Public Property MeasureItemEvent As String
Visual C++
public:
property String^ MeasureItemEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


MultiColumn Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.MultiColumn Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MultiColumn { get; set; }
Visual Basic (Declaration)
Public Property MultiColumn As Boolean
Visual C++
public:
property bool MultiColumn {
    bool get ();
    void set (bool value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectedIndex Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectedIndex Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectedIndexChangedEvent Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectedIndexChangedEvent Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectedIndexChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndexChangedEvent As String
Visual C++
public:
property String^ SelectedIndexChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectedIndices Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectedIndices Property
ListBoxBaseControl Class See Also Send Feedback
Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListBox..::.SelectedIndexCollection SelectedIndices { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedIndices As ListBox..::.SelectedIndexCollection
Visual C++
public:
property ListBox..::.SelectedIndexCollection^ SelectedIndices {
    ListBox..::.SelectedIndexCollection^ get ();
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectedItem Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectedItem Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object
Visual C++
public:
property Object^ SelectedItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectedItems Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectedItems Property
ListBoxBaseControl Class See Also Send Feedback
Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListBox..::.SelectedObjectCollection SelectedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItems As ListBox..::.SelectedObjectCollection
Visual C++
public:
property ListBox..::.SelectedObjectCollection^ SelectedItems {
    ListBox..::.SelectedObjectCollection^ get ();
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectionMode Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectionMode Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As SelectionMode
Visual C++
public:
property SelectionMode SelectionMode {
    SelectionMode get ();
    void set (SelectionMode value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


Sorted Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.Sorted Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Sorted { get; set; }
Visual Basic (Declaration)
Public Property Sorted As Boolean
Visual C++
public:
property bool Sorted {
    bool get ();
    void set (bool value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.Text Property
ListBoxBaseControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


UseTabStops Property

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.UseTabStops Property
ListBoxBaseControl Class See Also Send Feedback
Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseTabStops { get; set; }
Visual Basic (Declaration)
Public Property UseTabStops As Boolean
Visual C++
public:
property bool UseTabStops {
    bool get ();
    void set (bool value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ListBoxBaseControl Events

[image] [image]

FastReport.Net Class Reference
ListBoxBaseControl Events
ListBoxBaseControl Class See Also Send Feedback

The ListBoxBaseControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event.
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event.
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


DrawItem Event

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.DrawItem Event
ListBoxBaseControl Class See Also Send Feedback
Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event DrawItemEventHandler DrawItem
Visual Basic (Declaration)
Public Event DrawItem As DrawItemEventHandler
Visual C++
public:
 event DrawItemEventHandler^ DrawItem {
    void add (DrawItemEventHandler^ value);
    void remove (DrawItemEventHandler^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


MeasureItem Event

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.MeasureItem Event
ListBoxBaseControl Class See Also Send Feedback
Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event MeasureItemEventHandler MeasureItem
Visual Basic (Declaration)
Public Event MeasureItem As MeasureItemEventHandler
Visual C++
public:
 event MeasureItemEventHandler^ MeasureItem {
    void add (MeasureItemEventHandler^ value);
    void remove (MeasureItemEventHandler^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


SelectedIndexChanged Event

[image]

FastReport.Net Class Reference
ListBoxBaseControl..::.SelectedIndexChanged Event
ListBoxBaseControl Class See Also Send Feedback
Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic (Declaration)
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ListBoxBaseControl Class
FastReport.Dialog Namespace


ListBoxControl Class

[image]

FastReport.Net Class Reference
ListBoxControl Class
Members See Also Send Feedback
Represents a Windows control to display a list of items. Wraps the ListBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ListBoxControl : ListBoxBaseControl
Visual Basic (Declaration)
Public Class ListBoxControl _
    Inherits ListBoxBaseControl
Visual C++
public ref class ListBoxControl : public ListBoxBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ListBoxBaseControl
FastReport.Dialog..::.ListBoxControl

See Also

ListBoxControl Members
FastReport.Dialog Namespace


ListBoxControl Members

[image] [image]

FastReport.Net Class Reference
ListBoxControl Members
ListBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The ListBoxControl type exposes the following members.

Constructors

Name | Description
ListBoxControl | Initializes a new instance of the ListBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from ListBoxBaseControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from ListBoxBaseControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent. (Inherited from ListBoxBaseControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent. (Inherited from ListBoxBaseControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent. (Overrides ListBoxBaseControl..::.OnSelectedIndexChanged(EventArgs).)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ListBoxBaseControl.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from ListBoxBaseControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from ListBoxBaseControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property. (Inherited from ListBoxBaseControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event. (Inherited from ListBoxBaseControl.)
DrawMode | Gets or sets the drawing mode for the control. Wraps the DrawMode property. (Inherited from ListBoxBaseControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemHeight | Gets or sets the height of an item in the ListBox. Wraps the ItemHeight property. (Inherited from ListBoxBaseControl.)
Items | Gets the items of the ListBox. Wraps the Items property. (Inherited from ListBoxBaseControl.)
ItemsText | Gets or sets the string that contains all items text. (Inherited from ListBoxBaseControl.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
ListBox | Gets an internal ListBox.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property. (Inherited from ListBoxBaseControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property. (Inherited from ListBoxBaseControl.)
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property. (Inherited from ListBoxBaseControl.)
SelectedItem | Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property. (Inherited from ListBoxBaseControl.)
SelectedItems | Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property. (Inherited from ListBoxBaseControl.)
SelectionMode | Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property. (Inherited from ListBoxBaseControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property. (Inherited from ListBoxBaseControl.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Inherited from ListBoxBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property. (Inherited from ListBoxBaseControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event. (Inherited from ListBoxBaseControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ListBoxControl Class
FastReport.Dialog Namespace


ListBoxControl Constructor

[image]

FastReport.Net Class Reference
ListBoxControl Constructor
ListBoxControl Class See Also Send Feedback
Initializes a new instance of the ListBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListBoxControl()

See Also

ListBoxControl Class
FastReport.Dialog Namespace


ListBoxControl Methods

[image] [image]

FastReport.Net Class Reference
ListBoxControl Methods
ListBoxControl Class See Also Send Feedback

The ListBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from ListBoxBaseControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from ListBoxBaseControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnDrawItem | This method fires the DrawItem event and the script code connected to the DrawItemEvent. (Inherited from ListBoxBaseControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMeasureItem | This method fires the MeasureItem event and the script code connected to the MeasureItemEvent. (Inherited from ListBoxBaseControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent. (Overrides ListBoxBaseControl..::.OnSelectedIndexChanged(EventArgs).)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ListBoxBaseControl.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from ListBoxBaseControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from ListBoxBaseControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ListBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ListBoxControl..::.Dispose Method
ListBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ListBoxControl Class
ListBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ListBoxControl..::.DrawSelectionPoint Method
ListBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ListBoxControl Class
ListBoxControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
ListBoxControl..::.FillData Method
ListBoxControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from ListBoxBaseControl.)

See Also

ListBoxControl Class
ListBoxControl Members
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
ListBoxControl..::.GetValue Method
ListBoxControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

ListBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ListBoxControl..::.MemberwiseClone Method
ListBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ListBoxControl Class
ListBoxControl Members
FastReport.Dialog Namespace


OnSelectedIndexChanged Method

[image]

FastReport.Net Class Reference
ListBoxControl..::.OnSelectedIndexChanged Method
ListBoxControl Class See Also Send Feedback
This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ListBoxControl Class
FastReport.Dialog Namespace


ListBoxControl Properties

[image] [image]

FastReport.Net Class Reference
ListBoxControl Properties
ListBoxControl Class See Also Send Feedback

The ListBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. Wraps the ColumnWidth property. (Inherited from ListBoxBaseControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
DrawItemEvent | Gets or sets a script method name that will be used to handle the DrawItem event. (Inherited from ListBoxBaseControl.)
DrawMode | Gets or sets the drawing mode for the control. Wraps the DrawMode property. (Inherited from ListBoxBaseControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemHeight | Gets or sets the height of an item in the ListBox. Wraps the ItemHeight property. (Inherited from ListBoxBaseControl.)
Items | Gets the items of the ListBox. Wraps the Items property. (Inherited from ListBoxBaseControl.)
ItemsText | Gets or sets the string that contains all items text. (Inherited from ListBoxBaseControl.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
ListBox | Gets an internal ListBox.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MeasureItemEvent | Gets or sets a script method name that will be used to handle the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. Wraps the MultiColumn property. (Inherited from ListBoxBaseControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. Wraps the SelectedIndex property. (Inherited from ListBoxBaseControl.)
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. Wraps the SelectedIndices property. (Inherited from ListBoxBaseControl.)
SelectedItem | Gets or sets the currently selected item in the ListBox. Wraps the SelectedItem property. (Inherited from ListBoxBaseControl.)
SelectedItems | Gets a collection containing the currently selected items in the ListBox. Wraps the SelectedItems property. (Inherited from ListBoxBaseControl.)
SelectionMode | Gets or sets the method in which items are selected in the ListBox. Wraps the SelectionMode property. (Inherited from ListBoxBaseControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. Wraps the Sorted property. (Inherited from ListBoxBaseControl.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Inherited from ListBoxBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. Wraps the UseTabStops property. (Inherited from ListBoxBaseControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ListBoxControl Class
FastReport.Dialog Namespace


ListBox Property

[image]

FastReport.Net Class Reference
ListBoxControl..::.ListBox Property
ListBoxControl Class See Also Send Feedback
Gets an internal ListBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListBox ListBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListBox As ListBox
Visual C++
public:
property ListBox^ ListBox {
    ListBox^ get ();
}

See Also

ListBoxControl Class
FastReport.Dialog Namespace


ListBoxControl Events

[image] [image]

FastReport.Net Class Reference
ListBoxControl Events
ListBoxControl Class See Also Send Feedback

The ListBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. Wraps the DrawItem event. (Inherited from ListBoxBaseControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. Wraps the MeasureItem event. (Inherited from ListBoxBaseControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. Wraps the SelectedIndexChanged event. (Inherited from ListBoxBaseControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ListBoxControl Class
FastReport.Dialog Namespace


ListViewControl Class

[image]

FastReport.Net Class Reference
ListViewControl Class
Members See Also Send Feedback
Represents a Windows list view control, which displays a collection of items that can be displayed using one of four different views. Wraps the ListView control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ListViewControl : DialogControl
Visual Basic (Declaration)
Public Class ListViewControl _
    Inherits DialogControl
Visual C++
public ref class ListViewControl : public DialogControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.ListViewControl

See Also

ListViewControl Members
FastReport.Dialog Namespace


ListViewControl Members

[image] [image]

FastReport.Net Class Reference
ListViewControl Members
ListViewControl Class Constructors Methods Properties Events See Also Send Feedback

The ListViewControl type exposes the following members.

Constructors

Name | Description
ListViewControl | Initializes a new instance of the ListViewControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnItemChecked | This method fires the ItemChecked event and the script code connected to the ItemCheckedEvent.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. Wraps the CheckBoxes property.
CheckedIndices | Gets the indexes of the currently checked items in the control. Wraps the CheckedIndices property.
CheckedItems | Gets the currently checked items in the control. Wraps the CheckedItems property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Columns | Gets the collection of all column headers that appear in the control. Wraps the Columns property.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Groups | Gets the collection of ListViewGroup objects assigned to the control. Wraps the Groups property.
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemCheckedEvent | Gets or sets a script method name that will be used to handle the ItemChecked event.
Items | Gets a collection containing all items in the control. Wraps the Items property.
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control. Wraps the LargeImageList property.
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
ListView | Gets an internal ListView.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiSelect | Gets or sets a value indicating whether multiple items can be selected. Wraps the MultiSelect property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.
SelectedIndices | Gets the indexes of the selected items in the control. Wraps the SelectedIndices property.
SelectedItems | Gets the items that are selected in the control. Wraps the SelectedItems property.
ShowGroups | Gets or sets a value indicating whether items are displayed in groups. Wraps the ShowGroups property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. Wraps the SmallImageList property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
View | Gets or sets how items are displayed in the control. Wraps the View property.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
ItemChecked | Occurs when the checked state of an item changes. Wraps the ItemChecked event.
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the index of the selected item in the list view control changes. Wraps the SelectedIndexChanged event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ListViewControl Class
FastReport.Dialog Namespace


ListViewControl Constructor

[image]

FastReport.Net Class Reference
ListViewControl Constructor
ListViewControl Class See Also Send Feedback
Initializes a new instance of the ListViewControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListViewControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListViewControl()

See Also

ListViewControl Class
FastReport.Dialog Namespace


ListViewControl Methods

[image] [image]

FastReport.Net Class Reference
ListViewControl Methods
ListViewControl Class See Also Send Feedback

The ListViewControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnItemChecked | This method fires the ItemChecked event and the script code connected to the ItemCheckedEvent.
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnSelectedIndexChanged | This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ListViewControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
ListViewControl..::.AttachEvents Method
ListViewControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
ListViewControl..::.DetachEvents Method
ListViewControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ListViewControl..::.Dispose Method
ListViewControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ListViewControl Class
ListViewControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ListViewControl..::.DrawSelectionPoint Method
ListViewControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ListViewControl Class
ListViewControl Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ListViewControl..::.MemberwiseClone Method
ListViewControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ListViewControl Class
ListViewControl Members
FastReport.Dialog Namespace


OnItemChecked Method

[image]

FastReport.Net Class Reference
ListViewControl..::.OnItemChecked Method
ListViewControl Class See Also Send Feedback
This method fires the ItemChecked event and the script code connected to the ItemCheckedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnItemChecked(
    ItemCheckedEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnItemChecked ( _
    e As ItemCheckedEventArgs _
)
Visual C++
public:
virtual void OnItemChecked(
    ItemCheckedEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.ItemCheckedEventArgs
Event data.

See Also

ListViewControl Class
FastReport.Dialog Namespace


OnSelectedIndexChanged Method

[image]

FastReport.Net Class Reference
ListViewControl..::.OnSelectedIndexChanged Method
ListViewControl Class See Also Send Feedback
This method fires the SelectedIndexChanged event and the script code connected to the SelectedIndexChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

ListViewControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ListViewControl..::.Serialize Method
ListViewControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ListViewControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
ListViewControl..::.ShouldSerializeBackColor Method
ListViewControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

ListViewControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
ListViewControl..::.ShouldSerializeForeColor Method
ListViewControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

ListViewControl Class
FastReport.Dialog Namespace


ListViewControl Properties

[image] [image]

FastReport.Net Class Reference
ListViewControl Properties
ListViewControl Class See Also Send Feedback

The ListViewControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. Wraps the CheckBoxes property.
CheckedIndices | Gets the indexes of the currently checked items in the control. Wraps the CheckedIndices property.
CheckedItems | Gets the currently checked items in the control. Wraps the CheckedItems property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Columns | Gets the collection of all column headers that appear in the control. Wraps the Columns property.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Groups | Gets the collection of ListViewGroup objects assigned to the control. Wraps the Groups property.
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
ItemCheckedEvent | Gets or sets a script method name that will be used to handle the ItemChecked event.
Items | Gets a collection containing all items in the control. Wraps the Items property.
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control. Wraps the LargeImageList property.
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
ListView | Gets an internal ListView.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
MultiSelect | Gets or sets a value indicating whether multiple items can be selected. Wraps the MultiSelect property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedIndexChangedEvent | Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.
SelectedIndices | Gets the indexes of the selected items in the control. Wraps the SelectedIndices property.
SelectedItems | Gets the items that are selected in the control. Wraps the SelectedItems property.
ShowGroups | Gets or sets a value indicating whether items are displayed in groups. Wraps the ShowGroups property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. Wraps the SmallImageList property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
View | Gets or sets how items are displayed in the control. Wraps the View property.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ListViewControl Class
FastReport.Dialog Namespace


CheckBoxes Property

[image]

FastReport.Net Class Reference
ListViewControl..::.CheckBoxes Property
ListViewControl Class See Also Send Feedback
Gets or sets a value indicating whether a check box appears next to each item in the control. Wraps the CheckBoxes property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CheckBoxes { get; set; }
Visual Basic (Declaration)
Public Property CheckBoxes As Boolean
Visual C++
public:
property bool CheckBoxes {
    bool get ();
    void set (bool value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


CheckedIndices Property

[image]

FastReport.Net Class Reference
ListViewControl..::.CheckedIndices Property
ListViewControl Class See Also Send Feedback
Gets the indexes of the currently checked items in the control. Wraps the CheckedIndices property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView..::.CheckedIndexCollection CheckedIndices { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedIndices As ListView..::.CheckedIndexCollection
Visual C++
public:
property ListView..::.CheckedIndexCollection^ CheckedIndices {
    ListView..::.CheckedIndexCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


CheckedItems Property

[image]

FastReport.Net Class Reference
ListViewControl..::.CheckedItems Property
ListViewControl Class See Also Send Feedback
Gets the currently checked items in the control. Wraps the CheckedItems property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView..::.CheckedListViewItemCollection CheckedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckedItems As ListView..::.CheckedListViewItemCollection
Visual C++
public:
property ListView..::.CheckedListViewItemCollection^ CheckedItems {
    ListView..::.CheckedListViewItemCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


Columns Property

[image]

FastReport.Net Class Reference
ListViewControl..::.Columns Property
ListViewControl Class See Also Send Feedback
Gets the collection of all column headers that appear in the control. Wraps the Columns property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView..::.ColumnHeaderCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As ListView..::.ColumnHeaderCollection
Visual C++
public:
property ListView..::.ColumnHeaderCollection^ Columns {
    ListView..::.ColumnHeaderCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


Groups Property

[image]

FastReport.Net Class Reference
ListViewControl..::.Groups Property
ListViewControl Class See Also Send Feedback
Gets the collection of ListViewGroup objects assigned to the control. Wraps the Groups property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListViewGroupCollection Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As ListViewGroupCollection
Visual C++
public:
property ListViewGroupCollection^ Groups {
    ListViewGroupCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


ItemCheckedEvent Property

[image]

FastReport.Net Class Reference
ListViewControl..::.ItemCheckedEvent Property
ListViewControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ItemChecked event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ItemCheckedEvent { get; set; }
Visual Basic (Declaration)
Public Property ItemCheckedEvent As String
Visual C++
public:
property String^ ItemCheckedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


Items Property

[image]

FastReport.Net Class Reference
ListViewControl..::.Items Property
ListViewControl Class See Also Send Feedback
Gets a collection containing all items in the control. Wraps the Items property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView..::.ListViewItemCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ListView..::.ListViewItemCollection
Visual C++
public:
property ListView..::.ListViewItemCollection^ Items {
    ListView..::.ListViewItemCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


LargeImageList Property

[image]

FastReport.Net Class Reference
ListViewControl..::.LargeImageList Property
ListViewControl Class See Also Send Feedback
Gets or sets the ImageList to use when displaying items as large icons in the control. Wraps the LargeImageList property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageList LargeImageList { get; set; }
Visual Basic (Declaration)
Public Property LargeImageList As ImageList
Visual C++
public:
property ImageList^ LargeImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


ListView Property

[image]

FastReport.Net Class Reference
ListViewControl..::.ListView Property
ListViewControl Class See Also Send Feedback
Gets an internal ListView.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView ListView { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListView As ListView
Visual C++
public:
property ListView^ ListView {
    ListView^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


MultiSelect Property

[image]

FastReport.Net Class Reference
ListViewControl..::.MultiSelect Property
ListViewControl Class See Also Send Feedback
Gets or sets a value indicating whether multiple items can be selected. Wraps the MultiSelect property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MultiSelect { get; set; }
Visual Basic (Declaration)
Public Property MultiSelect As Boolean
Visual C++
public:
property bool MultiSelect {
    bool get ();
    void set (bool value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


SelectedIndexChangedEvent Property

[image]

FastReport.Net Class Reference
ListViewControl..::.SelectedIndexChangedEvent Property
ListViewControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the SelectedIndexChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectedIndexChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndexChangedEvent As String
Visual C++
public:
property String^ SelectedIndexChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


SelectedIndices Property

[image]

FastReport.Net Class Reference
ListViewControl..::.SelectedIndices Property
ListViewControl Class See Also Send Feedback
Gets the indexes of the selected items in the control. Wraps the SelectedIndices property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView..::.SelectedIndexCollection SelectedIndices { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedIndices As ListView..::.SelectedIndexCollection
Visual C++
public:
property ListView..::.SelectedIndexCollection^ SelectedIndices {
    ListView..::.SelectedIndexCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


SelectedItems Property

[image]

FastReport.Net Class Reference
ListViewControl..::.SelectedItems Property
ListViewControl Class See Also Send Feedback
Gets the items that are selected in the control. Wraps the SelectedItems property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ListView..::.SelectedListViewItemCollection SelectedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItems As ListView..::.SelectedListViewItemCollection
Visual C++
public:
property ListView..::.SelectedListViewItemCollection^ SelectedItems {
    ListView..::.SelectedListViewItemCollection^ get ();
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


ShowGroups Property

[image]

FastReport.Net Class Reference
ListViewControl..::.ShowGroups Property
ListViewControl Class See Also Send Feedback
Gets or sets a value indicating whether items are displayed in groups. Wraps the ShowGroups property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowGroups { get; set; }
Visual Basic (Declaration)
Public Property ShowGroups As Boolean
Visual C++
public:
property bool ShowGroups {
    bool get ();
    void set (bool value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


SmallImageList Property

[image]

FastReport.Net Class Reference
ListViewControl..::.SmallImageList Property
ListViewControl Class See Also Send Feedback
Gets or sets the ImageList to use when displaying items as small icons in the control. Wraps the SmallImageList property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageList SmallImageList { get; set; }
Visual Basic (Declaration)
Public Property SmallImageList As ImageList
Visual C++
public:
property ImageList^ SmallImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
ListViewControl..::.Text Property
ListViewControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


View Property

[image]

FastReport.Net Class Reference
ListViewControl..::.View Property
ListViewControl Class See Also Send Feedback
Gets or sets how items are displayed in the control. Wraps the View property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View View {
    View get ();
    void set (View value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


ListViewControl Events

[image] [image]

FastReport.Net Class Reference
ListViewControl Events
ListViewControl Class See Also Send Feedback

The ListViewControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
ItemChecked | Occurs when the checked state of an item changes. Wraps the ItemChecked event.
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
SelectedIndexChanged | Occurs when the index of the selected item in the list view control changes. Wraps the SelectedIndexChanged event.
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ListViewControl Class
FastReport.Dialog Namespace


ItemChecked Event

[image]

FastReport.Net Class Reference
ListViewControl..::.ItemChecked Event
ListViewControl Class See Also Send Feedback
Occurs when the checked state of an item changes. Wraps the ItemChecked event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event ItemCheckedEventHandler ItemChecked
Visual Basic (Declaration)
Public Event ItemChecked As ItemCheckedEventHandler
Visual C++
public:
 event ItemCheckedEventHandler^ ItemChecked {
    void add (ItemCheckedEventHandler^ value);
    void remove (ItemCheckedEventHandler^ value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


SelectedIndexChanged Event

[image]

FastReport.Net Class Reference
ListViewControl..::.SelectedIndexChanged Event
ListViewControl Class See Also Send Feedback
Occurs when the index of the selected item in the list view control changes. Wraps the SelectedIndexChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic (Declaration)
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ListViewControl Class
FastReport.Dialog Namespace


MaskedTextBoxControl Class

[image]

FastReport.Net Class Reference
MaskedTextBoxControl Class
Members See Also Send Feedback
Uses a mask to distinguish between proper and improper user input. Wraps the MaskedTextBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MaskedTextBoxControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class MaskedTextBoxControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class MaskedTextBoxControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.MaskedTextBoxControl

See Also

MaskedTextBoxControl Members
FastReport.Dialog Namespace


MaskedTextBoxControl Members

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl Members
MaskedTextBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The MaskedTextBoxControl type exposes the following members.

Constructors

Name | Description
MaskedTextBoxControl | Initializes a new instance of the MaskedTextBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Overrides DialogControl..::.ShouldSerializeCursor()()().)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
Mask | Gets or sets the input mask to use at run time. Wraps the Mask property.
MaskedTextBox | Gets an internal MaskedTextBox.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
SkipLiterals | Gets or sets a value indicating whether the user is allowed to reenter literal values. Wraps the SkipLiterals property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets how text is aligned in a masked text box control. Wraps the TextAlign property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MaskedTextBoxControl Constructor

[image]

FastReport.Net Class Reference
MaskedTextBoxControl Constructor
MaskedTextBoxControl Class See Also Send Feedback
Initializes a new instance of the MaskedTextBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MaskedTextBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaskedTextBoxControl()

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MaskedTextBoxControl Methods

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl Methods
MaskedTextBoxControl Class See Also Send Feedback

The MaskedTextBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Overrides DialogControl..::.ShouldSerializeCursor()()().)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.Dispose Method
MaskedTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

MaskedTextBoxControl Class
MaskedTextBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.DrawSelectionPoint Method
MaskedTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

MaskedTextBoxControl Class
MaskedTextBoxControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.FillData Method
MaskedTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

MaskedTextBoxControl Class
MaskedTextBoxControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.GetSelectionPoints Method
MaskedTextBoxControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.GetValue Method
MaskedTextBoxControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.MemberwiseClone Method
MaskedTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MaskedTextBoxControl Class
MaskedTextBoxControl Members
FastReport.Dialog Namespace


OnLeave Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.OnLeave Method
MaskedTextBoxControl Class See Also Send Feedback
This method fires the Leave event and the script code connected to the LeaveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.Serialize Method
MaskedTextBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.ShouldSerializeBackColor Method
MaskedTextBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeCursor Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.ShouldSerializeCursor Method
MaskedTextBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the Cursor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeCursor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeCursor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeCursor() override

Return Value

true if serialization is necessary.

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.ShouldSerializeForeColor Method
MaskedTextBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MaskedTextBoxControl Properties

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl Properties
MaskedTextBoxControl Class See Also Send Feedback

The MaskedTextBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
Mask | Gets or sets the input mask to use at run time. Wraps the Mask property.
MaskedTextBox | Gets an internal MaskedTextBox.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
SkipLiterals | Gets or sets a value indicating whether the user is allowed to reenter literal values. Wraps the SkipLiterals property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets how text is aligned in a masked text box control. Wraps the TextAlign property.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


Mask Property

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.Mask Property
MaskedTextBoxControl Class See Also Send Feedback
Gets or sets the input mask to use at run time. Wraps the Mask property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Mask { get; set; }
Visual Basic (Declaration)
Public Property Mask As String
Visual C++
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MaskedTextBox Property

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.MaskedTextBox Property
MaskedTextBoxControl Class See Also Send Feedback
Gets an internal MaskedTextBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MaskedTextBox MaskedTextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaskedTextBox As MaskedTextBox
Visual C++
public:
property MaskedTextBox^ MaskedTextBox {
    MaskedTextBox^ get ();
}

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


SkipLiterals Property

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.SkipLiterals Property
MaskedTextBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether the user is allowed to reenter literal values. Wraps the SkipLiterals property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SkipLiterals { get; set; }
Visual Basic (Declaration)
Public Property SkipLiterals As Boolean
Visual C++
public:
property bool SkipLiterals {
    bool get ();
    void set (bool value);
}

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


TextAlign Property

[image]

FastReport.Net Class Reference
MaskedTextBoxControl..::.TextAlign Property
MaskedTextBoxControl Class See Also Send Feedback
Gets or sets how text is aligned in a masked text box control. Wraps the TextAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HorizontalAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As HorizontalAlignment
Visual C++
public:
property HorizontalAlignment TextAlign {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MaskedTextBoxControl Events

[image] [image]

FastReport.Net Class Reference
MaskedTextBoxControl Events
MaskedTextBoxControl Class See Also Send Feedback

The MaskedTextBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

MaskedTextBoxControl Class
FastReport.Dialog Namespace


MonthCalendarControl Class

[image]

FastReport.Net Class Reference
MonthCalendarControl Class
Members See Also Send Feedback
Represents a Windows control that enables the user to select a date using a visual monthly calendar display. Wraps the MonthCalendar control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MonthCalendarControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class MonthCalendarControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class MonthCalendarControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.MonthCalendarControl

See Also

MonthCalendarControl Members
FastReport.Dialog Namespace


MonthCalendarControl Members

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl Members
MonthCalendarControl Class Constructors Methods Properties Events See Also Send Feedback

The MonthCalendarControl type exposes the following members.

Constructors

Name | Description
MonthCalendarControl | Initializes a new instance of the MonthCalendarControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDateChanged | This method fires the DateChanged event and the script code connected to the DateChangedEvent.
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCalendarDimensions |
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AnnuallyBoldedDates | Gets or sets the array of DateTime objects that determines which annual days are displayed in bold. Wraps the AnnuallyBoldedDates property.
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BoldedDates | Gets or sets the array of DateTime objects that determines which nonrecurring dates are displayed in bold. Wraps the BoldedDates property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CalendarDimensions | Gets or sets the number of columns and rows of months displayed. Wraps the CalendarDimensions property.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DateChangedEvent | Gets or sets a script method name that will be used to handle the DateChanged event.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
FirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar. Wraps the FirstDayOfWeek property.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxDate | Gets or sets the maximum allowable date. Wraps the MaxDate property.
MaxSelectionCount | Gets or sets the maximum number of days that can be selected in a month calendar control. Wraps the MaxSelectionCount property.
MinDate | Gets or sets the minimum allowable date. Wraps the MinDate property.
MonthCalendar | Gets an internal MonthCalendar.
MonthlyBoldedDates | Gets or sets the array of DateTime objects that determine which monthly days to bold. Wraps the MonthlyBoldedDates property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectionEnd | Gets or sets the end date of the selected range of dates. Wraps the SelectionEnd property.
SelectionRange | Gets or sets the selected range of dates for a month calendar control. Wraps the SelectionRange property.
SelectionStart | Gets or sets the start date of the selected range of dates. Wraps the SelectionStart property.
ShowToday | Gets or sets a value indicating whether the date represented by the TodayDate property is displayed at the bottom of the control. Wraps the ShowToday property.
ShowTodayCircle | Gets or sets a value indicating whether today's date is circled. Wraps the ShowTodayCircle property.
ShowWeekNumbers | Gets or sets a value indicating whether the month calendar control displays week numbers (1-52) to the left of each row of days. Wraps the ShowWeekNumbers property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TodayDate | Gets or sets the value that is used by MonthCalendar as today's date. Wraps the TodayDate property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
DateChanged | Occurs when the date selected in the MonthCalendar changes. Wraps the DateChanged event.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MonthCalendarControl Constructor

[image]

FastReport.Net Class Reference
MonthCalendarControl Constructor
MonthCalendarControl Class See Also Send Feedback
Initializes a new instance of the MonthCalendarControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MonthCalendarControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MonthCalendarControl()

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MonthCalendarControl Methods

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl Methods
MonthCalendarControl Class See Also Send Feedback

The MonthCalendarControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDateChanged | This method fires the DateChanged event and the script code connected to the DateChangedEvent.
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCalendarDimensions |
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.AttachEvents Method
MonthCalendarControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.DetachEvents Method
MonthCalendarControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl..::.Dispose Method
MonthCalendarControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

MonthCalendarControl Class
MonthCalendarControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl..::.DrawSelectionPoint Method
MonthCalendarControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

MonthCalendarControl Class
MonthCalendarControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl..::.FillData Method
MonthCalendarControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

MonthCalendarControl Class
MonthCalendarControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.GetSelectionPoints Method
MonthCalendarControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.GetValue Method
MonthCalendarControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl..::.MemberwiseClone Method
MonthCalendarControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MonthCalendarControl Class
MonthCalendarControl Members
FastReport.Dialog Namespace


OnDateChanged Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.OnDateChanged Method
MonthCalendarControl Class See Also Send Feedback
This method fires the DateChanged event and the script code connected to the DateChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnDateChanged(
    DateRangeEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnDateChanged ( _
    e As DateRangeEventArgs _
)
Visual C++
public:
virtual void OnDateChanged(
    DateRangeEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.DateRangeEventArgs
Event data.

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.Serialize Method
MonthCalendarControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.ShouldSerializeBackColor Method
MonthCalendarControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


ShouldSerializeCalendarDimensions Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.ShouldSerializeCalendarDimensions Method
MonthCalendarControl Class See Also Send Feedback

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected bool ShouldSerializeCalendarDimensions()
Visual Basic (Declaration)
Protected Function ShouldSerializeCalendarDimensions As Boolean
Visual C++
protected:
bool ShouldSerializeCalendarDimensions()

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.ShouldSerializeForeColor Method
MonthCalendarControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MonthCalendarControl Properties

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl Properties
MonthCalendarControl Class See Also Send Feedback

The MonthCalendarControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AnnuallyBoldedDates | Gets or sets the array of DateTime objects that determines which annual days are displayed in bold. Wraps the AnnuallyBoldedDates property.
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BoldedDates | Gets or sets the array of DateTime objects that determines which nonrecurring dates are displayed in bold. Wraps the BoldedDates property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CalendarDimensions | Gets or sets the number of columns and rows of months displayed. Wraps the CalendarDimensions property.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DateChangedEvent | Gets or sets a script method name that will be used to handle the DateChanged event.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
FirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar. Wraps the FirstDayOfWeek property.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxDate | Gets or sets the maximum allowable date. Wraps the MaxDate property.
MaxSelectionCount | Gets or sets the maximum number of days that can be selected in a month calendar control. Wraps the MaxSelectionCount property.
MinDate | Gets or sets the minimum allowable date. Wraps the MinDate property.
MonthCalendar | Gets an internal MonthCalendar.
MonthlyBoldedDates | Gets or sets the array of DateTime objects that determine which monthly days to bold. Wraps the MonthlyBoldedDates property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectionEnd | Gets or sets the end date of the selected range of dates. Wraps the SelectionEnd property.
SelectionRange | Gets or sets the selected range of dates for a month calendar control. Wraps the SelectionRange property.
SelectionStart | Gets or sets the start date of the selected range of dates. Wraps the SelectionStart property.
ShowToday | Gets or sets a value indicating whether the date represented by the TodayDate property is displayed at the bottom of the control. Wraps the ShowToday property.
ShowTodayCircle | Gets or sets a value indicating whether today's date is circled. Wraps the ShowTodayCircle property.
ShowWeekNumbers | Gets or sets a value indicating whether the month calendar control displays week numbers (1-52) to the left of each row of days. Wraps the ShowWeekNumbers property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TodayDate | Gets or sets the value that is used by MonthCalendar as today's date. Wraps the TodayDate property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


AnnuallyBoldedDates Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.AnnuallyBoldedDates Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the array of DateTime objects that determines which annual days are displayed in bold. Wraps the AnnuallyBoldedDates property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime[] AnnuallyBoldedDates { get; set; }
Visual Basic (Declaration)
Public Property AnnuallyBoldedDates As DateTime()
Visual C++
public:
property array<DateTime>^ AnnuallyBoldedDates {
    array<DateTime>^ get ();
    void set (array<DateTime>^ value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


BoldedDates Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.BoldedDates Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the array of DateTime objects that determines which nonrecurring dates are displayed in bold. Wraps the BoldedDates property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime[] BoldedDates { get; set; }
Visual Basic (Declaration)
Public Property BoldedDates As DateTime()
Visual C++
public:
property array<DateTime>^ BoldedDates {
    array<DateTime>^ get ();
    void set (array<DateTime>^ value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


CalendarDimensions Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.CalendarDimensions Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the number of columns and rows of months displayed. Wraps the CalendarDimensions property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Size CalendarDimensions { get; set; }
Visual Basic (Declaration)
Public Property CalendarDimensions As Size
Visual C++
public:
property Size CalendarDimensions {
    Size get ();
    void set (Size value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


DateChangedEvent Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.DateChangedEvent Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the DateChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DateChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property DateChangedEvent As String
Visual C++
public:
property String^ DateChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


FirstDayOfWeek Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.FirstDayOfWeek Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the first day of the week as displayed in the month calendar. Wraps the FirstDayOfWeek property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Day FirstDayOfWeek { get; set; }
Visual Basic (Declaration)
Public Property FirstDayOfWeek As Day
Visual C++
public:
property Day FirstDayOfWeek {
    Day get ();
    void set (Day value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MaxDate Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.MaxDate Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the maximum allowable date. Wraps the MaxDate property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime MaxDate { get; set; }
Visual Basic (Declaration)
Public Property MaxDate As DateTime
Visual C++
public:
property DateTime MaxDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MaxSelectionCount Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.MaxSelectionCount Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the maximum number of days that can be selected in a month calendar control. Wraps the MaxSelectionCount property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int MaxSelectionCount { get; set; }
Visual Basic (Declaration)
Public Property MaxSelectionCount As Integer
Visual C++
public:
property int MaxSelectionCount {
    int get ();
    void set (int value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MinDate Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.MinDate Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the minimum allowable date. Wraps the MinDate property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime MinDate { get; set; }
Visual Basic (Declaration)
Public Property MinDate As DateTime
Visual C++
public:
property DateTime MinDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MonthCalendar Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.MonthCalendar Property
MonthCalendarControl Class See Also Send Feedback
Gets an internal MonthCalendar.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MonthCalendar MonthCalendar { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthCalendar As MonthCalendar
Visual C++
public:
property MonthCalendar^ MonthCalendar {
    MonthCalendar^ get ();
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MonthlyBoldedDates Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.MonthlyBoldedDates Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the array of DateTime objects that determine which monthly days to bold. Wraps the MonthlyBoldedDates property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime[] MonthlyBoldedDates { get; set; }
Visual Basic (Declaration)
Public Property MonthlyBoldedDates As DateTime()
Visual C++
public:
property array<DateTime>^ MonthlyBoldedDates {
    array<DateTime>^ get ();
    void set (array<DateTime>^ value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


SelectionEnd Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.SelectionEnd Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the end date of the selected range of dates. Wraps the SelectionEnd property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime SelectionEnd { get; set; }
Visual Basic (Declaration)
Public Property SelectionEnd As DateTime
Visual C++
public:
property DateTime SelectionEnd {
    DateTime get ();
    void set (DateTime value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


SelectionRange Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.SelectionRange Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the selected range of dates for a month calendar control. Wraps the SelectionRange property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectionRange SelectionRange { get; set; }
Visual Basic (Declaration)
Public Property SelectionRange As SelectionRange
Visual C++
public:
property SelectionRange^ SelectionRange {
    SelectionRange^ get ();
    void set (SelectionRange^ value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


SelectionStart Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.SelectionStart Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the start date of the selected range of dates. Wraps the SelectionStart property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime SelectionStart { get; set; }
Visual Basic (Declaration)
Public Property SelectionStart As DateTime
Visual C++
public:
property DateTime SelectionStart {
    DateTime get ();
    void set (DateTime value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


ShowToday Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.ShowToday Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets a value indicating whether the date represented by the TodayDate property is displayed at the bottom of the control. Wraps the ShowToday property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowToday { get; set; }
Visual Basic (Declaration)
Public Property ShowToday As Boolean
Visual C++
public:
property bool ShowToday {
    bool get ();
    void set (bool value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


ShowTodayCircle Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.ShowTodayCircle Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets a value indicating whether today's date is circled. Wraps the ShowTodayCircle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowTodayCircle { get; set; }
Visual Basic (Declaration)
Public Property ShowTodayCircle As Boolean
Visual C++
public:
property bool ShowTodayCircle {
    bool get ();
    void set (bool value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


ShowWeekNumbers Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.ShowWeekNumbers Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets a value indicating whether the month calendar control displays week numbers (1-52) to the left of each row of days. Wraps the ShowWeekNumbers property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowWeekNumbers { get; set; }
Visual Basic (Declaration)
Public Property ShowWeekNumbers As Boolean
Visual C++
public:
property bool ShowWeekNumbers {
    bool get ();
    void set (bool value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


TodayDate Property

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.TodayDate Property
MonthCalendarControl Class See Also Send Feedback
Gets or sets the value that is used by MonthCalendar as today's date. Wraps the TodayDate property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime TodayDate { get; set; }
Visual Basic (Declaration)
Public Property TodayDate As DateTime
Visual C++
public:
property DateTime TodayDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


MonthCalendarControl Events

[image] [image]

FastReport.Net Class Reference
MonthCalendarControl Events
MonthCalendarControl Class See Also Send Feedback

The MonthCalendarControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
DateChanged | Occurs when the date selected in the MonthCalendar changes. Wraps the DateChanged event.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


DateChanged Event

[image]

FastReport.Net Class Reference
MonthCalendarControl..::.DateChanged Event
MonthCalendarControl Class See Also Send Feedback
Occurs when the date selected in the MonthCalendar changes. Wraps the DateChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event DateRangeEventHandler DateChanged
Visual Basic (Declaration)
Public Event DateChanged As DateRangeEventHandler
Visual C++
public:
 event DateRangeEventHandler^ DateChanged {
    void add (DateRangeEventHandler^ value);
    void remove (DateRangeEventHandler^ value);
}

See Also

MonthCalendarControl Class
FastReport.Dialog Namespace


NumericUpDownControl Class

[image]

FastReport.Net Class Reference
NumericUpDownControl Class
Members See Also Send Feedback
Represents a Windows spin box (also known as an up-down control) that displays numeric values. Wraps the NumericUpDown control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NumericUpDownControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class NumericUpDownControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class NumericUpDownControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.NumericUpDownControl

See Also

NumericUpDownControl Members
FastReport.Dialog Namespace


NumericUpDownControl Members

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl Members
NumericUpDownControl Class Constructors Methods Properties Events See Also Send Feedback

The NumericUpDownControl type exposes the following members.

Constructors

Name | Description
NumericUpDownControl | Initializes a new instance of the NumericUpDownControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
OnValueChanged | This method fires the ValueChanged event and the script code connected to the ValueChangedEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DecimalPlaces | Gets or sets the number of decimal places to display in the up-down control. Wraps the DecimalPlaces property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Hexadecimal | Gets or sets a value indicating whether the up-down control should display the value it contains in hexadecimal format. Wraps the Hexadecimal property.
Increment | Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked. Wraps the Increment property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
Maximum | Gets or sets the maximum value for the up-down control. Wraps the Maximum property.
Minimum | Gets or sets the minimum value for the up-down control. Wraps the Minimum property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NumericUpDown | Gets an internal NumericUpDown.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
ThousandsSeparator | Gets or sets a value indicating whether a thousands separator is displayed in the up-down control when appropriate. Wraps the ThousandsSeparator property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Value | Gets or sets the value assigned to the up-down control. Wraps the Value property.
ValueChangedEvent | Gets or sets a script method name that will be used to handle the ValueChanged event.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)
ValueChanged | Occurs when the Value property has been changed in some way. Wraps the ValueChanged event.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


NumericUpDownControl Constructor

[image]

FastReport.Net Class Reference
NumericUpDownControl Constructor
NumericUpDownControl Class See Also Send Feedback
Initializes a new instance of the NumericUpDownControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NumericUpDownControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NumericUpDownControl()

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


NumericUpDownControl Methods

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl Methods
NumericUpDownControl Class See Also Send Feedback

The NumericUpDownControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
OnValueChanged | This method fires the ValueChanged event and the script code connected to the ValueChangedEvent.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.AttachEvents Method
NumericUpDownControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.DetachEvents Method
NumericUpDownControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl..::.Dispose Method
NumericUpDownControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

NumericUpDownControl Class
NumericUpDownControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl..::.DrawSelectionPoint Method
NumericUpDownControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

NumericUpDownControl Class
NumericUpDownControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl..::.FillData Method
NumericUpDownControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

NumericUpDownControl Class
NumericUpDownControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.GetSelectionPoints Method
NumericUpDownControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.GetValue Method
NumericUpDownControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl..::.MemberwiseClone Method
NumericUpDownControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NumericUpDownControl Class
NumericUpDownControl Members
FastReport.Dialog Namespace


OnLeave Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.OnLeave Method
NumericUpDownControl Class See Also Send Feedback
This method fires the Leave event and the script code connected to the LeaveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


OnValueChanged Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.OnValueChanged Method
NumericUpDownControl Class See Also Send Feedback
This method fires the ValueChanged event and the script code connected to the ValueChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnValueChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnValueChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Serialize Method
NumericUpDownControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.ShouldSerializeBackColor Method
NumericUpDownControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.ShouldSerializeForeColor Method
NumericUpDownControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


NumericUpDownControl Properties

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl Properties
NumericUpDownControl Class See Also Send Feedback

The NumericUpDownControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DecimalPlaces | Gets or sets the number of decimal places to display in the up-down control. Wraps the DecimalPlaces property.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Hexadecimal | Gets or sets a value indicating whether the up-down control should display the value it contains in hexadecimal format. Wraps the Hexadecimal property.
Increment | Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked. Wraps the Increment property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
Maximum | Gets or sets the maximum value for the up-down control. Wraps the Maximum property.
Minimum | Gets or sets the minimum value for the up-down control. Wraps the Minimum property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NumericUpDown | Gets an internal NumericUpDown.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
ThousandsSeparator | Gets or sets a value indicating whether a thousands separator is displayed in the up-down control when appropriate. Wraps the ThousandsSeparator property.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Value | Gets or sets the value assigned to the up-down control. Wraps the Value property.
ValueChangedEvent | Gets or sets a script method name that will be used to handle the ValueChanged event.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


DecimalPlaces Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.DecimalPlaces Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets the number of decimal places to display in the up-down control. Wraps the DecimalPlaces property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DecimalPlaces { get; set; }
Visual Basic (Declaration)
Public Property DecimalPlaces As Integer
Visual C++
public:
property int DecimalPlaces {
    int get ();
    void set (int value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Hexadecimal Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Hexadecimal Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets a value indicating whether the up-down control should display the value it contains in hexadecimal format. Wraps the Hexadecimal property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Hexadecimal { get; set; }
Visual Basic (Declaration)
Public Property Hexadecimal As Boolean
Visual C++
public:
property bool Hexadecimal {
    bool get ();
    void set (bool value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Increment Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Increment Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked. Wraps the Increment property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Single
Visual C++
public:
property float Increment {
    float get ();
    void set (float value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Maximum Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Maximum Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets the maximum value for the up-down control. Wraps the Maximum property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public decimal Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Decimal
Visual C++
public:
property Decimal Maximum {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Minimum Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Minimum Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets the minimum value for the up-down control. Wraps the Minimum property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public decimal Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Decimal
Visual C++
public:
property Decimal Minimum {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


NumericUpDown Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.NumericUpDown Property
NumericUpDownControl Class See Also Send Feedback
Gets an internal NumericUpDown.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NumericUpDown NumericUpDown { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumericUpDown As NumericUpDown
Visual C++
public:
property NumericUpDown^ NumericUpDown {
    NumericUpDown^ get ();
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Text Property
NumericUpDownControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


ThousandsSeparator Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.ThousandsSeparator Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets a value indicating whether a thousands separator is displayed in the up-down control when appropriate. Wraps the ThousandsSeparator property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ThousandsSeparator { get; set; }
Visual Basic (Declaration)
Public Property ThousandsSeparator As Boolean
Visual C++
public:
property bool ThousandsSeparator {
    bool get ();
    void set (bool value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


Value Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.Value Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets the value assigned to the up-down control. Wraps the Value property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public decimal Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Decimal
Visual C++
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


ValueChangedEvent Property

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.ValueChangedEvent Property
NumericUpDownControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ValueChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ValueChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property ValueChangedEvent As String
Visual C++
public:
property String^ ValueChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


NumericUpDownControl Events

[image] [image]

FastReport.Net Class Reference
NumericUpDownControl Events
NumericUpDownControl Class See Also Send Feedback

The NumericUpDownControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)
ValueChanged | Occurs when the Value property has been changed in some way. Wraps the ValueChanged event.

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


ValueChanged Event

[image]

FastReport.Net Class Reference
NumericUpDownControl..::.ValueChanged Event
NumericUpDownControl Class See Also Send Feedback
Occurs when the Value property has been changed in some way. Wraps the ValueChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

NumericUpDownControl Class
FastReport.Dialog Namespace


PanelControl Class

[image]

FastReport.Net Class Reference
PanelControl Class
Members See Also Send Feedback
Used to group collections of controls. Wraps the Panel control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PanelControl : ParentControl
Visual Basic (Declaration)
Public Class PanelControl _
    Inherits ParentControl
Visual C++
public ref class PanelControl : public ParentControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.ParentControl
FastReport.Dialog..::.PanelControl

See Also

PanelControl Members
FastReport.Dialog Namespace


PanelControl Members

[image] [image]

FastReport.Net Class Reference
PanelControl Members
PanelControl Class Constructors Methods Properties Events See Also Send Feedback

The PanelControl type exposes the following members.

Constructors

Name | Description
PanelControl | Initializes a new instance of the PanelControl class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from ParentControl.)
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from ParentControl.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides DialogControl..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ParentControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects. (Inherited from ParentControl.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from ParentControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ParentControl.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ParentControl.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ParentControl.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from ParentControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from ParentControl.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from ParentControl.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BorderStyle | Indicates the border style for the control. Wraps the BorderStyle property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Controls | Gets the collection of child controls. (Inherited from ParentControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Panel | Gets an internal Panel.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

PanelControl Class
FastReport.Dialog Namespace


PanelControl Constructor

[image]

FastReport.Net Class Reference
PanelControl Constructor
PanelControl Class See Also Send Feedback
Initializes a new instance of the PanelControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PanelControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelControl()

See Also

PanelControl Class
FastReport.Dialog Namespace


PanelControl Methods

[image] [image]

FastReport.Net Class Reference
PanelControl Methods
PanelControl Class See Also Send Feedback

The PanelControl type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from ParentControl.)
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from ParentControl.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides DialogControl..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ParentControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects. (Inherited from ParentControl.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from ParentControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ParentControl.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ParentControl.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ParentControl.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from ParentControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from ParentControl.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from ParentControl.)

See Also

PanelControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PanelControl..::.Dispose Method
PanelControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

PanelControl Class
PanelControl Members
FastReport.Dialog Namespace


Draw Method

[image]

FastReport.Net Class Reference
PanelControl..::.Draw Method
PanelControl Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

PanelControl Class
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
PanelControl..::.DrawSelectionPoint Method
PanelControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

PanelControl Class
PanelControl Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PanelControl..::.MemberwiseClone Method
PanelControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PanelControl Class
PanelControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
PanelControl..::.Serialize Method
PanelControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

PanelControl Class
FastReport.Dialog Namespace


PanelControl Properties

[image] [image]

FastReport.Net Class Reference
PanelControl Properties
PanelControl Class See Also Send Feedback

The PanelControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BorderStyle | Indicates the border style for the control. Wraps the BorderStyle property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Controls | Gets the collection of child controls. (Inherited from ParentControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Panel | Gets an internal Panel.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PanelControl Class
FastReport.Dialog Namespace


BorderStyle Property

[image]

FastReport.Net Class Reference
PanelControl..::.BorderStyle Property
PanelControl Class See Also Send Feedback
Indicates the border style for the control. Wraps the BorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderStyle BorderStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
Visual C++
public:
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}

See Also

PanelControl Class
FastReport.Dialog Namespace


Panel Property

[image]

FastReport.Net Class Reference
PanelControl..::.Panel Property
PanelControl Class See Also Send Feedback
Gets an internal Panel.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Panel Panel { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panel As Panel
Visual C++
public:
property Panel^ Panel {
    Panel^ get ();
}

See Also

PanelControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
PanelControl..::.Text Property
PanelControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

PanelControl Class
FastReport.Dialog Namespace


PanelControl Events

[image] [image]

FastReport.Net Class Reference
PanelControl Events
PanelControl Class See Also Send Feedback

The PanelControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

PanelControl Class
FastReport.Dialog Namespace


ParentControl Class

[image]

FastReport.Net Class Reference
ParentControl Class
Members See Also Send Feedback
Base class for controls that may contain child controls.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ParentControl : DialogControl,
    IParent
Visual Basic (Declaration)
Public Class ParentControl _
    Inherits DialogControl _
    Implements IParent
Visual C++
public ref class ParentControl : public DialogControl,
    IParent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.ParentControl
FastReport.Dialog..::.GroupBoxControl
FastReport.Dialog..::.PanelControl

See Also

ParentControl Members
FastReport.Dialog Namespace


ParentControl Members

[image] [image]

FastReport.Net Class Reference
ParentControl Members
ParentControl Class Constructors Methods Properties Events See Also Send Feedback

The ParentControl type exposes the following members.

Constructors

Name | Description
ParentControl | Initializes a new instance of the ParentControl class with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides DialogControl..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DialogControl.)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Controls | Gets the collection of child controls.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ParentControl Class
FastReport.Dialog Namespace


ParentControl Constructor

[image]

FastReport.Net Class Reference
ParentControl Constructor
ParentControl Class See Also Send Feedback
Initializes a new instance of the ParentControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ParentControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParentControl()

See Also

ParentControl Class
FastReport.Dialog Namespace


ParentControl Methods

[image] [image]

FastReport.Net Class Reference
ParentControl Methods
ParentControl Class See Also Send Feedback

The ParentControl type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Overrides DialogControl..::.DrawSelection(FRPaintEventArgs).)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from DialogControl.)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

ParentControl Class
FastReport.Dialog Namespace


AddChild Method

[image]

FastReport.Net Class Reference
ParentControl..::.AddChild Method
ParentControl Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

ParentControl Class
FastReport.Dialog Namespace


CanContain Method

[image]

FastReport.Net Class Reference
ParentControl..::.CanContain Method
ParentControl Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

ParentControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ParentControl..::.Dispose Method
ParentControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

ParentControl Class
ParentControl Members
FastReport.Dialog Namespace


DrawSelection Method

[image]

FastReport.Net Class Reference
ParentControl..::.DrawSelection Method
ParentControl Class See Also Send Feedback
Draw the selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawSelection(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawSelection ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawSelection(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method draws a set of selection points returned by the GetSelectionPoints()()() method.

See Also

ParentControl Class
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
ParentControl..::.DrawSelectionPoint Method
ParentControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

ParentControl Class
ParentControl Members
FastReport.Dialog Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
ParentControl..::.GetChildObjects Method
ParentControl Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overridable Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

ParentControl Class
FastReport.Dialog Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
ParentControl..::.GetChildOrder Method
ParentControl Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Overridable Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

ParentControl Class
FastReport.Dialog Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
ParentControl..::.HandleMouseDown Method
ParentControl Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

ParentControl Class
FastReport.Dialog Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
ParentControl..::.HandleMouseHover Method
ParentControl Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

ParentControl Class
FastReport.Dialog Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
ParentControl..::.HandleMouseUp Method
ParentControl Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

ParentControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ParentControl..::.MemberwiseClone Method
ParentControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ParentControl Class
ParentControl Members
FastReport.Dialog Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
ParentControl..::.RemoveChild Method
ParentControl Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Overridable Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
)

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

ParentControl Class
FastReport.Dialog Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
ParentControl..::.SetChildOrder Method
ParentControl Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Overridable Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
)

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

ParentControl Class
FastReport.Dialog Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
ParentControl..::.UpdateLayout Method
ParentControl Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Overridable Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
)

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

ParentControl Class
FastReport.Dialog Namespace


ParentControl Properties

[image] [image]

FastReport.Net Class Reference
ParentControl Properties
ParentControl Class See Also Send Feedback

The ParentControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Controls | Gets the collection of child controls.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ParentControl Class
FastReport.Dialog Namespace


Controls Property

[image]

FastReport.Net Class Reference
ParentControl..::.Controls Property
ParentControl Class See Also Send Feedback
Gets the collection of child controls.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogComponentCollection Controls { get; }
Visual Basic (Declaration)
Public ReadOnly Property Controls As DialogComponentCollection
Visual C++
public:
property DialogComponentCollection^ Controls {
    DialogComponentCollection^ get ();
}

See Also

ParentControl Class
FastReport.Dialog Namespace


ParentControl Events

[image] [image]

FastReport.Net Class Reference
ParentControl Events
ParentControl Class See Also Send Feedback

The ParentControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

ParentControl Class
FastReport.Dialog Namespace


PictureBoxControl Class

[image]

FastReport.Net Class Reference
PictureBoxControl Class
Members See Also Send Feedback
Represents a Windows picture box control for displaying an image. Wraps the PictureBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PictureBoxControl : DialogControl
Visual Basic (Declaration)
Public Class PictureBoxControl _
    Inherits DialogControl
Visual C++
public ref class PictureBoxControl : public DialogControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.PictureBoxControl

See Also

PictureBoxControl Members
FastReport.Dialog Namespace


PictureBoxControl Members

[image] [image]

FastReport.Net Class Reference
PictureBoxControl Members
PictureBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The PictureBoxControl type exposes the following members.

Constructors

Name | Description
PictureBoxControl | Initializes a new instance of the PictureBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides DialogControl..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BorderStyle | Indicates the border style for the control. Wraps the BorderStyle property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that the PictureBox displays. Wraps the Image property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PictureBox | Gets an internal PictureBox.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
SizeMode | Indicates how the image is displayed. Wraps the SizeMode property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


PictureBoxControl Constructor

[image]

FastReport.Net Class Reference
PictureBoxControl Constructor
PictureBoxControl Class See Also Send Feedback
Initializes a new instance of the PictureBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PictureBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureBoxControl()

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


PictureBoxControl Methods

[image] [image]

FastReport.Net Class Reference
PictureBoxControl Methods
PictureBoxControl Class See Also Send Feedback

The PictureBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides DialogControl..::.Draw(FRPaintEventArgs).)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PictureBoxControl..::.Dispose Method
PictureBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

PictureBoxControl Class
PictureBoxControl Members
FastReport.Dialog Namespace


Draw Method

[image]

FastReport.Net Class Reference
PictureBoxControl..::.Draw Method
PictureBoxControl Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
PictureBoxControl..::.DrawSelectionPoint Method
PictureBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

PictureBoxControl Class
PictureBoxControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
PictureBoxControl..::.GetSelectionPoints Method
PictureBoxControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PictureBoxControl..::.MemberwiseClone Method
PictureBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PictureBoxControl Class
PictureBoxControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
PictureBoxControl..::.Serialize Method
PictureBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


PictureBoxControl Properties

[image] [image]

FastReport.Net Class Reference
PictureBoxControl Properties
PictureBoxControl Class See Also Send Feedback

The PictureBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
BorderStyle | Indicates the border style for the control. Wraps the BorderStyle property.
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that the PictureBox displays. Wraps the Image property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PictureBox | Gets an internal PictureBox.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
SizeMode | Indicates how the image is displayed. Wraps the SizeMode property.
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


BorderStyle Property

[image]

FastReport.Net Class Reference
PictureBoxControl..::.BorderStyle Property
PictureBoxControl Class See Also Send Feedback
Indicates the border style for the control. Wraps the BorderStyle property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderStyle BorderStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
Visual C++
public:
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


Image Property

[image]

FastReport.Net Class Reference
PictureBoxControl..::.Image Property
PictureBoxControl Class See Also Send Feedback
Gets or sets the image that the PictureBox displays. Wraps the Image property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


PictureBox Property

[image]

FastReport.Net Class Reference
PictureBoxControl..::.PictureBox Property
PictureBoxControl Class See Also Send Feedback
Gets an internal PictureBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PictureBox PictureBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureBox As PictureBox
Visual C++
public:
property PictureBox^ PictureBox {
    PictureBox^ get ();
}

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


SizeMode Property

[image]

FastReport.Net Class Reference
PictureBoxControl..::.SizeMode Property
PictureBoxControl Class See Also Send Feedback
Indicates how the image is displayed. Wraps the SizeMode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PictureBoxSizeMode SizeMode { get; set; }
Visual Basic (Declaration)
Public Property SizeMode As PictureBoxSizeMode
Visual C++
public:
property PictureBoxSizeMode SizeMode {
    PictureBoxSizeMode get ();
    void set (PictureBoxSizeMode value);
}

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
PictureBoxControl..::.Text Property
PictureBoxControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


PictureBoxControl Events

[image] [image]

FastReport.Net Class Reference
PictureBoxControl Events
PictureBoxControl Class See Also Send Feedback

The PictureBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

PictureBoxControl Class
FastReport.Dialog Namespace


RadioButtonControl Class

[image]

FastReport.Net Class Reference
RadioButtonControl Class
Members See Also Send Feedback
Enables the user to select a single option from a group of choices when paired with other RadioButton controls. Wraps the RadioButton control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RadioButtonControl : ButtonBaseControl
Visual Basic (Declaration)
Public Class RadioButtonControl _
    Inherits ButtonBaseControl
Visual C++
public ref class RadioButtonControl : public ButtonBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.ButtonBaseControl
FastReport.Dialog..::.RadioButtonControl

See Also

RadioButtonControl Members
FastReport.Dialog Namespace


RadioButtonControl Members

[image] [image]

FastReport.Net Class Reference
RadioButtonControl Members
RadioButtonControl Class Constructors Methods Properties Events See Also Send Feedback

The RadioButtonControl type exposes the following members.

Constructors

Name | Description
RadioButtonControl | Initializes a new instance of the RadioButtonControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides ButtonBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnCheckedChanged | This method fires the CheckedChanged event and the script code connected to the CheckedChangedEvent.
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ButtonBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class. (Inherited from ButtonBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property. (Inherited from ButtonBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckAlign | Gets or sets the location of the check box portion of the RadioButton. Wraps the CheckAlign property.
Checked | Gets or sets a value indicating whether the control is checked. Wraps the Checked property.
CheckedChangedEvent | Gets or sets a script method name that will be used to handle the CheckedChanged event.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property. (Inherited from ButtonBaseControl.)
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property. (Inherited from ButtonBaseControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
RadioButton | Gets an internal RadioButton.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property. (Inherited from ButtonBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property. (Inherited from ButtonBaseControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
CheckedChanged | Occurs when the value of the Checked property changes. Wraps the CheckedChanged event.
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


RadioButtonControl Constructor

[image]

FastReport.Net Class Reference
RadioButtonControl Constructor
RadioButtonControl Class See Also Send Feedback
Initializes a new instance of the RadioButtonControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RadioButtonControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadioButtonControl()

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


RadioButtonControl Methods

[image] [image]

FastReport.Net Class Reference
RadioButtonControl Methods
RadioButtonControl Class See Also Send Feedback

The RadioButtonControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides ButtonBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnCheckedChanged | This method fires the CheckedChanged event and the script code connected to the CheckedChangedEvent.
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ButtonBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
RadioButtonControl..::.AttachEvents Method
RadioButtonControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
RadioButtonControl..::.DetachEvents Method
RadioButtonControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
RadioButtonControl..::.Dispose Method
RadioButtonControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

RadioButtonControl Class
RadioButtonControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
RadioButtonControl..::.DrawSelectionPoint Method
RadioButtonControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

RadioButtonControl Class
RadioButtonControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
RadioButtonControl..::.FillData Method
RadioButtonControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

RadioButtonControl Class
RadioButtonControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
RadioButtonControl..::.GetSelectionPoints Method
RadioButtonControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
RadioButtonControl..::.GetValue Method
RadioButtonControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
RadioButtonControl..::.MemberwiseClone Method
RadioButtonControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RadioButtonControl Class
RadioButtonControl Members
FastReport.Dialog Namespace


OnCheckedChanged Method

[image]

FastReport.Net Class Reference
RadioButtonControl..::.OnCheckedChanged Method
RadioButtonControl Class See Also Send Feedback
This method fires the CheckedChanged event and the script code connected to the CheckedChangedEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnCheckedChanged(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnCheckedChanged ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnCheckedChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
RadioButtonControl..::.Serialize Method
RadioButtonControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


RadioButtonControl Properties

[image] [image]

FastReport.Net Class Reference
RadioButtonControl Properties
RadioButtonControl Class See Also Send Feedback

The RadioButtonControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | This property is not relevant to this class. (Inherited from ButtonBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. Wraps the AutoSize property. (Inherited from ButtonBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckAlign | Gets or sets the location of the check box portion of the RadioButton. Wraps the CheckAlign property.
Checked | Gets or sets a value indicating whether the control is checked. Wraps the Checked property.
CheckedChangedEvent | Gets or sets a script method name that will be used to handle the CheckedChanged event.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
Image | Gets or sets the image that is displayed on a button control. Wraps the Image property. (Inherited from ButtonBaseControl.)
ImageAlign | Gets or sets the alignment of the image on the button control. Wraps the ImageAlign property. (Inherited from ButtonBaseControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
RadioButton | Gets an internal RadioButton.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets the alignment of the text on the button control. Wraps the TextAlign property. (Inherited from ButtonBaseControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
TextImageRelation | Gets or sets the position of text and image relative to each other. Wraps the TextImageRelation property. (Inherited from ButtonBaseControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


CheckAlign Property

[image]

FastReport.Net Class Reference
RadioButtonControl..::.CheckAlign Property
RadioButtonControl Class See Also Send Feedback
Gets or sets the location of the check box portion of the RadioButton. Wraps the CheckAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ContentAlignment CheckAlign { get; set; }
Visual Basic (Declaration)
Public Property CheckAlign As ContentAlignment
Visual C++
public:
property ContentAlignment CheckAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


Checked Property

[image]

FastReport.Net Class Reference
RadioButtonControl..::.Checked Property
RadioButtonControl Class See Also Send Feedback
Gets or sets a value indicating whether the control is checked. Wraps the Checked property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


CheckedChangedEvent Property

[image]

FastReport.Net Class Reference
RadioButtonControl..::.CheckedChangedEvent Property
RadioButtonControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the CheckedChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CheckedChangedEvent { get; set; }
Visual Basic (Declaration)
Public Property CheckedChangedEvent As String
Visual C++
public:
property String^ CheckedChangedEvent {
    String^ get ();
    void set (String^ value);
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


RadioButton Property

[image]

FastReport.Net Class Reference
RadioButtonControl..::.RadioButton Property
RadioButtonControl Class See Also Send Feedback
Gets an internal RadioButton.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RadioButton RadioButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property RadioButton As RadioButton
Visual C++
public:
property RadioButton^ RadioButton {
    RadioButton^ get ();
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


RadioButtonControl Events

[image] [image]

FastReport.Net Class Reference
RadioButtonControl Events
RadioButtonControl Class See Also Send Feedback

The RadioButtonControl type exposes the following members.

Events

Name | Description
CheckedChanged | Occurs when the value of the Checked property changes. Wraps the CheckedChanged event.
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


CheckedChanged Event

[image]

FastReport.Net Class Reference
RadioButtonControl..::.CheckedChanged Event
RadioButtonControl Class See Also Send Feedback
Occurs when the value of the Checked property changes. Wraps the CheckedChanged event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler CheckedChanged
Visual Basic (Declaration)
Public Event CheckedChanged As EventHandler
Visual C++
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

RadioButtonControl Class
FastReport.Dialog Namespace


RichTextBoxControl Class

[image]

FastReport.Net Class Reference
RichTextBoxControl Class
Members See Also Send Feedback
Represents a Windows rich text box control. Wraps the RichTextBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RichTextBoxControl : DialogControl
Visual Basic (Declaration)
Public Class RichTextBoxControl _
    Inherits DialogControl
Visual C++
public ref class RichTextBoxControl : public DialogControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.RichTextBoxControl

See Also

RichTextBoxControl Members
FastReport.Dialog Namespace


RichTextBoxControl Members

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl Members
RichTextBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The RichTextBoxControl type exposes the following members.

Constructors

Name | Description
RichTextBoxControl | Initializes a new instance of the RichTextBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadFile | Overloaded.
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RichTextBox | Gets an internal RichTextBox.
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. Wraps the Rtf property.
ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. Wraps the ScrollBars property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


RichTextBoxControl Constructor

[image]

FastReport.Net Class Reference
RichTextBoxControl Constructor
RichTextBoxControl Class See Also Send Feedback
Initializes a new instance of the RichTextBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RichTextBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichTextBoxControl()

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


RichTextBoxControl Methods

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl Methods
RichTextBoxControl Class See Also Send Feedback

The RichTextBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadFile | Overloaded.
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Inherited from DialogControl.)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Inherited from DialogControl.)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl..::.Dispose Method
RichTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

RichTextBoxControl Class
RichTextBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl..::.DrawSelectionPoint Method
RichTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

RichTextBoxControl Class
RichTextBoxControl Members
FastReport.Dialog Namespace


LoadFile Method

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl..::.LoadFile Method
RichTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
LoadFile(String) | Loads rtf from a file.
LoadFile(Stream, RichTextBoxStreamType) | Loads rtf from a stream using specified stream type.
LoadFile(String, RichTextBoxStreamType) | Loads rtf from a file using specified stream type.

See Also

RichTextBoxControl Class
RichTextBoxControl Members
FastReport.Dialog Namespace


LoadFile Method (String)

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.LoadFile Method (String)
RichTextBoxControl Class See Also Send Feedback
Loads rtf from a file.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadFile(
    string path
)
Visual Basic (Declaration)
Public Sub LoadFile ( _
    path As String _
)
Visual C++
public:
void LoadFile(
    String^ path
)

Parameters

path
Type: System..::.String
File to load from.

See Also

RichTextBoxControl Class
LoadFile Overload
FastReport.Dialog Namespace


LoadFile Method (Stream, RichTextBoxStreamType)

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.LoadFile Method (Stream, RichTextBoxStreamType)
RichTextBoxControl Class See Also Send Feedback
Loads rtf from a stream using specified stream type.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadFile(
    Stream data,
    RichTextBoxStreamType fileType
)
Visual Basic (Declaration)
Public Sub LoadFile ( _
    data As Stream, _
    fileType As RichTextBoxStreamType _
)
Visual C++
public:
void LoadFile(
    Stream^ data,
    RichTextBoxStreamType fileType
)

Parameters

data
Type: System.IO..::.Stream
Stream to load from.
fileType
Type: System.Windows.Forms..::.RichTextBoxStreamType
Type of a stream.

See Also

RichTextBoxControl Class
LoadFile Overload
FastReport.Dialog Namespace


LoadFile Method (String, RichTextBoxStreamType)

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.LoadFile Method (String, RichTextBoxStreamType)
RichTextBoxControl Class See Also Send Feedback
Loads rtf from a file using specified stream type.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadFile(
    string path,
    RichTextBoxStreamType fileType
)
Visual Basic (Declaration)
Public Sub LoadFile ( _
    path As String, _
    fileType As RichTextBoxStreamType _
)
Visual C++
public:
void LoadFile(
    String^ path,
    RichTextBoxStreamType fileType
)

Parameters

path
Type: System..::.String
File to load from.
fileType
Type: System.Windows.Forms..::.RichTextBoxStreamType
Type of a stream.

See Also

RichTextBoxControl Class
LoadFile Overload
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl..::.MemberwiseClone Method
RichTextBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RichTextBoxControl Class
RichTextBoxControl Members
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.Serialize Method
RichTextBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


RichTextBoxControl Properties

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl Properties
RichTextBoxControl Class See Also Send Feedback

The RichTextBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RichTextBox | Gets an internal RichTextBox.
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. Wraps the Rtf property.
ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. Wraps the ScrollBars property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


RichTextBox Property

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.RichTextBox Property
RichTextBoxControl Class See Also Send Feedback
Gets an internal RichTextBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RichTextBox RichTextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property RichTextBox As RichTextBox
Visual C++
public:
property RichTextBox^ RichTextBox {
    RichTextBox^ get ();
}

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


Rtf Property

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.Rtf Property
RichTextBoxControl Class See Also Send Feedback
Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. Wraps the Rtf property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Rtf { get; set; }
Visual Basic (Declaration)
Public Property Rtf As String
Visual C++
public:
property String^ Rtf {
    String^ get ();
    void set (String^ value);
}

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


ScrollBars Property

[image]

FastReport.Net Class Reference
RichTextBoxControl..::.ScrollBars Property
RichTextBoxControl Class See Also Send Feedback
Gets or sets the type of scroll bars to display in the RichTextBox control. Wraps the ScrollBars property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RichTextBoxScrollBars ScrollBars { get; set; }
Visual Basic (Declaration)
Public Property ScrollBars As RichTextBoxScrollBars
Visual C++
public:
property RichTextBoxScrollBars ScrollBars {
    RichTextBoxScrollBars get ();
    void set (RichTextBoxScrollBars value);
}

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


RichTextBoxControl Events

[image] [image]

FastReport.Net Class Reference
RichTextBoxControl Events
RichTextBoxControl Class See Also Send Feedback

The RichTextBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

RichTextBoxControl Class
FastReport.Dialog Namespace


TextBoxControl Class

[image]

FastReport.Net Class Reference
TextBoxControl Class
Members See Also Send Feedback
Represents a Windows text box control. Wraps the TextBox control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextBoxControl : DataFilterBaseControl
Visual Basic (Declaration)
Public Class TextBoxControl _
    Inherits DataFilterBaseControl
Visual C++
public ref class TextBoxControl : public DataFilterBaseControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.DataFilterBaseControl
FastReport.Dialog..::.TextBoxControl

See Also

TextBoxControl Members
FastReport.Dialog Namespace


TextBoxControl Members

[image] [image]

FastReport.Net Class Reference
TextBoxControl Members
TextBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The TextBoxControl type exposes the following members.

Constructors

Name | Description
TextBoxControl | Initializes a new instance of the TextBoxControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Overrides DialogControl..::.ShouldSerializeCursor()()().)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Wraps the AcceptsReturn property.
AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. Wraps the AcceptsTab property.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. Wraps the CharacterCasing property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. Wraps the MaxLength property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. Wraps the Multiline property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. Wraps the ReadOnly property.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. Wraps the ScrollBars property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets how text is aligned in a TextBox control. Wraps the TextAlign property.
TextBox | Gets an internal TextBox.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. Wraps the UseSystemPasswordChar property.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. Wraps the WordWrap property.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TextBoxControl Constructor

[image]

FastReport.Net Class Reference
TextBoxControl Constructor
TextBoxControl Class See Also Send Feedback
Initializes a new instance of the TextBoxControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextBoxControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxControl()

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TextBoxControl Methods

[image] [image]

FastReport.Net Class Reference
TextBoxControl Methods
TextBoxControl Class See Also Send Feedback

The TextBoxControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Inherited from DialogControl.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Inherited from DialogControl.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
FillData | Overloaded.
FilterData | Applies the filter to a datasource. (Inherited from DataFilterBaseControl.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetListOfData | Returns list of values that can be used to fill control with data. (Inherited from DataFilterBaseControl.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides DialogControl..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns value entered in the control. (Overrides DataFilterBaseControl..::.GetValue()()().)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DataFilterBaseControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDataLoaded | This method fires the DataLoaded event and the script code connected to the DataLoadedEvent. (Inherited from DataFilterBaseControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DataFilterBaseControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnFilterChanged | Handles the cascaded filter internal logic. (Inherited from DataFilterBaseControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Overrides DialogControl..::.OnLeave(EventArgs).)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
ResetFilter | Resets the filter set by this control. (Inherited from DataFilterBaseControl.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DataFilterBaseControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Overrides DialogControl..::.ShouldSerializeCursor()()().)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TextBoxControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextBoxControl..::.Dispose Method
TextBoxControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

TextBoxControl Class
TextBoxControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
TextBoxControl..::.DrawSelectionPoint Method
TextBoxControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

TextBoxControl Class
TextBoxControl Members
FastReport.Dialog Namespace


FillData Method

[image] [image]

FastReport.Net Class Reference
TextBoxControl..::.FillData Method
TextBoxControl Class See Also Send Feedback

Overload List

Name | Description
FillData()()() | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataFilterBaseControl) | Fills the control with data from a datasource. (Inherited from DataFilterBaseControl.)
FillData(DataSourceBase, Column) | Fills the control with data. (Inherited from DataFilterBaseControl.)

See Also

TextBoxControl Class
TextBoxControl Members
FastReport.Dialog Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.GetSelectionPoints Method
TextBoxControl Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

TextBoxControl Class
FastReport.Dialog Namespace


GetValue Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.GetValue Method
TextBoxControl Class See Also Send Feedback
Returns value entered in the control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override Object GetValue()
Visual Basic (Declaration)
Protected Overrides Function GetValue As Object
Visual C++
protected:
virtual Object^ GetValue() override

Return Value

The value of type supported by this control.

Remarks

This method must return a value entered by the user. For example, TextBox control must return its Text property value. If this control supports multi-selection, return selected values in an array, for example string[] array for CheckedListBox.

See Also

TextBoxControl Class
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextBoxControl..::.MemberwiseClone Method
TextBoxControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextBoxControl Class
TextBoxControl Members
FastReport.Dialog Namespace


OnLeave Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.OnLeave Method
TextBoxControl Class See Also Send Feedback
This method fires the Leave event and the script code connected to the LeaveEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

TextBoxControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.Serialize Method
TextBoxControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TextBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.ShouldSerializeBackColor Method
TextBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

TextBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeCursor Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.ShouldSerializeCursor Method
TextBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the Cursor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeCursor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeCursor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeCursor() override

Return Value

true if serialization is necessary.

See Also

TextBoxControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
TextBoxControl..::.ShouldSerializeForeColor Method
TextBoxControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TextBoxControl Properties

[image] [image]

FastReport.Net Class Reference
TextBoxControl Properties
TextBoxControl Class See Also Send Feedback

The TextBoxControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Wraps the AcceptsReturn property.
AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. Wraps the AcceptsTab property.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
AutoFill | Gets or sets a value that determines whether to fill the control with data automatically. (Inherited from DataFilterBaseControl.)
AutoFilter | Gets or sets a value that determines whether to filter the datasource automatically when you close the dialog by OK button. (Inherited from DataFilterBaseControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. Wraps the CharacterCasing property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DataColumn | Gets or sets a data column name that will be used to fill this control with data. (Inherited from DataFilterBaseControl.)
DataLoadedEvent | Gets or sets a script method name that will be used to handle the DataLoaded event. (Inherited from DataFilterBaseControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DetailControl | Gets or sets the detail control used in cascaded filtering. (Inherited from DataFilterBaseControl.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterOperation | Gets or sets a value that specifies the filter operation. (Inherited from DataFilterBaseControl.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. Wraps the MaxLength property.
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. Wraps the Multiline property.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. Wraps the ReadOnly property.
Report | Gets reference to the parent Report object. (Inherited from Base.)
ReportParameter | Gets or sets name of report parameter which value will be set to value contained in this control when you close the dialog. (Inherited from DataFilterBaseControl.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. Wraps the ScrollBars property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | Gets or sets the text associated with this control. Wraps the Text property. (Inherited from DialogControl.)
TextAlign | Gets or sets how text is aligned in a TextBox control. Wraps the TextAlign property.
TextBox | Gets an internal TextBox.
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. Wraps the UseSystemPasswordChar property.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. Wraps the WordWrap property.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TextBoxControl Class
FastReport.Dialog Namespace


AcceptsReturn Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.AcceptsReturn Property
TextBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Wraps the AcceptsReturn property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AcceptsReturn { get; set; }
Visual Basic (Declaration)
Public Property AcceptsReturn As Boolean
Visual C++
public:
property bool AcceptsReturn {
    bool get ();
    void set (bool value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


AcceptsTab Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.AcceptsTab Property
TextBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. Wraps the AcceptsTab property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AcceptsTab { get; set; }
Visual Basic (Declaration)
Public Property AcceptsTab As Boolean
Visual C++
public:
property bool AcceptsTab {
    bool get ();
    void set (bool value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


CharacterCasing Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.CharacterCasing Property
TextBoxControl Class See Also Send Feedback
Gets or sets whether the TextBox control modifies the case of characters as they are typed. Wraps the CharacterCasing property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CharacterCasing CharacterCasing { get; set; }
Visual Basic (Declaration)
Public Property CharacterCasing As CharacterCasing
Visual C++
public:
property CharacterCasing CharacterCasing {
    CharacterCasing get ();
    void set (CharacterCasing value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


MaxLength Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.MaxLength Property
TextBoxControl Class See Also Send Feedback
Gets or sets the maximum number of characters the user can type or paste into the text box control. Wraps the MaxLength property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int MaxLength { get; set; }
Visual Basic (Declaration)
Public Property MaxLength As Integer
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


Multiline Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.Multiline Property
TextBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether this is a multiline TextBox control. Wraps the Multiline property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Multiline { get; set; }
Visual Basic (Declaration)
Public Property Multiline As Boolean
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


ReadOnly Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.ReadOnly Property
TextBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether text in the text box is read-only. Wraps the ReadOnly property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


ScrollBars Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.ScrollBars Property
TextBoxControl Class See Also Send Feedback
Gets or sets which scroll bars should appear in a multiline TextBox control. Wraps the ScrollBars property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ScrollBars ScrollBars { get; set; }
Visual Basic (Declaration)
Public Property ScrollBars As ScrollBars
Visual C++
public:
property ScrollBars ScrollBars {
    ScrollBars get ();
    void set (ScrollBars value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TextAlign Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.TextAlign Property
TextBoxControl Class See Also Send Feedback
Gets or sets how text is aligned in a TextBox control. Wraps the TextAlign property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HorizontalAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As HorizontalAlignment
Visual C++
public:
property HorizontalAlignment TextAlign {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TextBox Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.TextBox Property
TextBoxControl Class See Also Send Feedback
Gets an internal TextBox.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextBox TextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBox As TextBox
Visual C++
public:
property TextBox^ TextBox {
    TextBox^ get ();
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


UseSystemPasswordChar Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.UseSystemPasswordChar Property
TextBoxControl Class See Also Send Feedback
Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. Wraps the UseSystemPasswordChar property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseSystemPasswordChar { get; set; }
Visual Basic (Declaration)
Public Property UseSystemPasswordChar As Boolean
Visual C++
public:
property bool UseSystemPasswordChar {
    bool get ();
    void set (bool value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


WordWrap Property

[image]

FastReport.Net Class Reference
TextBoxControl..::.WordWrap Property
TextBoxControl Class See Also Send Feedback
Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. Wraps the WordWrap property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool WordWrap { get; set; }
Visual Basic (Declaration)
Public Property WordWrap As Boolean
Visual C++
public:
property bool WordWrap {
    bool get ();
    void set (bool value);
}

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TextBoxControl Events

[image] [image]

FastReport.Net Class Reference
TextBoxControl Events
TextBoxControl Class See Also Send Feedback

The TextBoxControl type exposes the following members.

Events

Name | Description
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
DataLoaded | Occurs after the control is filled with data. (Inherited from DataFilterBaseControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

TextBoxControl Class
FastReport.Dialog Namespace


TreeViewControl Class

[image]

FastReport.Net Class Reference
TreeViewControl Class
Members See Also Send Feedback
Displays a hierarchical collection of labeled items, each represented by a TreeNode. Wraps the TreeView control.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TreeViewControl : DialogControl
Visual Basic (Declaration)
Public Class TreeViewControl _
    Inherits DialogControl
Visual C++
public ref class TreeViewControl : public DialogControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Dialog..::.DialogComponentBase
FastReport.Dialog..::.DialogControl
FastReport.Dialog..::.TreeViewControl

See Also

TreeViewControl Members
FastReport.Dialog Namespace


TreeViewControl Members

[image] [image]

FastReport.Net Class Reference
TreeViewControl Members
TreeViewControl Class Constructors Methods Properties Events See Also Send Feedback

The TreeViewControl type exposes the following members.

Constructors

Name | Description
TreeViewControl | Initializes a new instance of the TreeViewControl class with default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnAfterSelect | This method fires the AfterSelect event and the script code connected to the AfterSelectEvent.
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterSelectEvent | Gets or sets a script method name that will be used to handle the AfterSelect event.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. Wraps the CheckBoxes property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes. Wraps the ImageList property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Nodes | Gets the collection of tree nodes that are assigned to the tree view control. Wraps the Nodes property.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. Wraps the SelectedNode property.
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. Wraps the ShowLines property.
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. Wraps the ShowRootLines property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
TreeView | Gets an internal TreeView.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterSelect | Occurs after the tree node is selected. Wraps the AfterSelect event.
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

TreeViewControl Class
FastReport.Dialog Namespace


TreeViewControl Constructor

[image]

FastReport.Net Class Reference
TreeViewControl Constructor
TreeViewControl Class See Also Send Feedback
Initializes a new instance of the TreeViewControl class with default settings.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TreeViewControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TreeViewControl()

See Also

TreeViewControl Class
FastReport.Dialog Namespace


TreeViewControl Methods

[image] [image]

FastReport.Net Class Reference
TreeViewControl Methods
TreeViewControl Class See Also Send Feedback

The TreeViewControl type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from DialogComponentBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AttachEvents | Attaches Control events to its event handlers. (Overrides DialogControl..::.AttachEvents()()().)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from DialogControl.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
DetachEvents | Detaches Control events from its event handlers. (Overrides DialogControl..::.DetachEvents()()().)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from DialogControl.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from DialogControl.)
DrawSelectionPoint | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeControl | Finalizes the control after its parent form is closed. (Inherited from DialogControl.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
Focus | Sets input focus to the control. (Inherited from DialogControl.)
GetContextMenu | Gets the object's context menu. (Inherited from ComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from DialogControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Hide | Conceals the control from the user. (Inherited from DialogControl.)
InitializeControl | Initializes the control before display it in the dialog form. (Inherited from DialogControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Creates the empty event handler for the ClickEvent event in the report's script. (Inherited from DialogControl.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnAfterSelect | This method fires the AfterSelect event and the script code connected to the AfterSelectEvent.
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from DialogControl.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from DialogControl.)
OnDoubleClick | This method fires the DoubleClick event and the script code connected to the DoubleClickEvent. (Inherited from DialogControl.)
OnEnabledChanged | Called when the control's Enabled state changed. (Inherited from DialogControl.)
OnEnter | This method fires the Enter event and the script code connected to the EnterEvent. (Inherited from DialogControl.)
OnKeyDown | This method fires the KeyDown event and the script code connected to the KeyDownEvent. (Inherited from DialogControl.)
OnKeyPress | This method fires the KeyPress event and the script code connected to the KeyPressEvent. (Inherited from DialogControl.)
OnKeyUp | This method fires the KeyUp event and the script code connected to the KeyUpEvent. (Inherited from DialogControl.)
OnLeave | This method fires the Leave event and the script code connected to the LeaveEvent. (Inherited from DialogControl.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from DialogControl.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from DialogControl.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from DialogControl.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from DialogControl.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from DialogControl.)
OnPaint | This method fires the Paint event and the script code connected to the PaintEvent. (Inherited from DialogControl.)
OnResize | This method fires the Resize event and the script code connected to the ResizeEvent. (Inherited from DialogControl.)
OnTextChanged | This method fires the TextChanged event and the script code connected to the TextChangedEvent. (Inherited from DialogControl.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides DialogControl..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from DialogControl.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShouldSerializeBackColor | Determines whether is necessary to serialize the BackColor property. (Overrides DialogControl..::.ShouldSerializeBackColor()()().)
ShouldSerializeCursor | Determines whether is necessary to serialize the Cursor property. (Inherited from DialogControl.)
ShouldSerializeFont | Determines whether is necessary to serialize the Font property. (Inherited from DialogControl.)
ShouldSerializeForeColor | Determines whether is necessary to serialize the ForeColor property. (Overrides DialogControl..::.ShouldSerializeForeColor()()().)
Show | Displays the control to the user. (Inherited from DialogControl.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TreeViewControl Class
FastReport.Dialog Namespace


AttachEvents Method

[image]

FastReport.Net Class Reference
TreeViewControl..::.AttachEvents Method
TreeViewControl Class Example See Also Send Feedback
Attaches Control events to its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void AttachEvents()
Visual Basic (Declaration)
Protected Overrides Sub AttachEvents
Visual C++
protected:
virtual void AttachEvents() override

Remarks

Override this method if your custom control has own events.

Examples

See the example of AttachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void AttachEvents()
{
  base.AttachEvents();
  CheckBox.CheckedChanged += new EventHandler(CheckBox_CheckedChanged);
}

private void CheckBox_CheckedChanged(object sender, EventArgs e)
{
  if (CheckedChanged != null)
    CheckedChanged(this, e);
  InvokeEvent(CheckedChangedEvent, e);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


DetachEvents Method

[image]

FastReport.Net Class Reference
TreeViewControl..::.DetachEvents Method
TreeViewControl Class Example See Also Send Feedback
Detaches Control events from its event handlers.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DetachEvents()
Visual Basic (Declaration)
Protected Overrides Sub DetachEvents
Visual C++
protected:
virtual void DetachEvents() override

Remarks

Override this method if your custom control has own events. In this method, you should detach control's events that were attached in the AttachEvents()()() method.

Examples

See the example of DetachEvents implementation used in the CheckBoxControl:
CopyC#
protected override void DetachEvents()
{
  base.DetachEvents();
  CheckBox.CheckedChanged -= new EventHandler(CheckBox_CheckedChanged);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TreeViewControl..::.Dispose Method
TreeViewControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from DialogControl.)

See Also

TreeViewControl Class
TreeViewControl Members
FastReport.Dialog Namespace


DrawSelectionPoint Method

[image] [image]

FastReport.Net Class Reference
TreeViewControl..::.DrawSelectionPoint Method
TreeViewControl Class See Also Send Feedback

Overload List

Name | Description
DrawSelectionPoint(FRPaintEventArgs, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from ComponentBase.)
DrawSelectionPoint(Graphics, Pen, Brush, Single, Single) | Draws the selection point. (Inherited from DialogControl.)

See Also

TreeViewControl Class
TreeViewControl Members
FastReport.Dialog Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TreeViewControl..::.MemberwiseClone Method
TreeViewControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TreeViewControl Class
TreeViewControl Members
FastReport.Dialog Namespace


OnAfterSelect Method

[image]

FastReport.Net Class Reference
TreeViewControl..::.OnAfterSelect Method
TreeViewControl Class See Also Send Feedback
This method fires the AfterSelect event and the script code connected to the AfterSelectEvent.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void OnAfterSelect(
    TreeViewEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnAfterSelect ( _
    e As TreeViewEventArgs _
)
Visual C++
public:
virtual void OnAfterSelect(
    TreeViewEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::.TreeViewEventArgs
Event data.

See Also

TreeViewControl Class
FastReport.Dialog Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TreeViewControl..::.Serialize Method
TreeViewControl Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TreeViewControl Class
FastReport.Dialog Namespace


ShouldSerializeBackColor Method

[image]

FastReport.Net Class Reference
TreeViewControl..::.ShouldSerializeBackColor Method
TreeViewControl Class See Also Send Feedback
Determines whether is necessary to serialize the BackColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeBackColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeBackColor() override

Return Value

true if serialization is necessary.

See Also

TreeViewControl Class
FastReport.Dialog Namespace


ShouldSerializeForeColor Method

[image]

FastReport.Net Class Reference
TreeViewControl..::.ShouldSerializeForeColor Method
TreeViewControl Class See Also Send Feedback
Determines whether is necessary to serialize the ForeColor property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override bool ShouldSerializeForeColor()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeForeColor As Boolean
Visual C++
protected:
virtual bool ShouldSerializeForeColor() override

Return Value

true if serialization is necessary.

See Also

TreeViewControl Class
FastReport.Dialog Namespace


TreeViewControl Properties

[image] [image]

FastReport.Net Class Reference
TreeViewControl Properties
TreeViewControl Class See Also Send Feedback

The TreeViewControl type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterSelectEvent | Gets or sets a script method name that will be used to handle the AfterSelect event.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. Wraps the Anchor property. (Inherited from DialogControl.)
BackColor | Gets or sets the background color for the control. Wraps the BackColor property. (Inherited from DialogControl.)
BaseName | The base part of the object's name. (Inherited from Base.)
BindableProperty | Gets or sets a property that returns actual data contained in a control. This value is used in the "Data" window. (Inherited from DialogControl.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. Wraps the CheckBoxes property.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script method name that will be used to handle the Click event. (Inherited from DialogControl.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Control | Gets an internal Control. (Inherited from DialogControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. Wraps the Cursor property. (Inherited from DialogControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. Wraps the Dock property. (Inherited from DialogControl.)
DoubleClickEvent | Gets or sets a script method name that will be used to handle the DoubleClick event. (Inherited from DialogControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. Wraps the Enabled property. (Inherited from DialogControl.)
EnterEvent | Gets or sets a script method name that will be used to handle the Enter event. (Inherited from DialogControl.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Font | Gets or sets the font of the text displayed by the control. Wraps the Font property. (Inherited from DialogControl.)
ForeColor | Gets or sets the foreground color of the control. Wraps the ForeColor property. (Inherited from DialogControl.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets the height of the object. (Inherited from DialogControl.)
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes. Wraps the ImageList property.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeyDownEvent | Gets or sets a script method name that will be used to handle the KeyDown event. (Inherited from DialogControl.)
KeyPressEvent | Gets or sets a script method name that will be used to handle the KeyPress event. (Inherited from DialogControl.)
KeyUpEvent | Gets or sets a script method name that will be used to handle the KeyUp event. (Inherited from DialogControl.)
LeaveEvent | Gets or sets a script method name that will be used to handle the Leave event. (Inherited from DialogControl.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from DialogControl.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from DialogComponentBase.)
MouseDownEvent | Gets or sets a script method name that will be used to handle the MouseDown event. (Inherited from DialogControl.)
MouseEnterEvent | Gets or sets a script method name that will be used to handle the MouseEnter event. (Inherited from DialogControl.)
MouseLeaveEvent | Gets or sets a script method name that will be used to handle the MouseLeave event. (Inherited from DialogControl.)
MouseMoveEvent | Gets or sets a script method name that will be used to handle the MouseMove event. (Inherited from DialogControl.)
MouseUpEvent | Gets or sets a script method name that will be used to handle the MouseUp event. (Inherited from DialogControl.)
Name | Gets or sets the name of the object. (Inherited from Base.)
Nodes | Gets the collection of tree nodes that are assigned to the tree view control. Wraps the Nodes property.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PaintEvent | Gets or sets a script method name that will be used to handle the Paint event. (Inherited from DialogControl.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
ResizeEvent | Gets or sets a script method name that will be used to handle the Resize event. (Inherited from DialogControl.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. Wraps the RightToLeft property. (Inherited from DialogControl.)
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. Wraps the SelectedNode property.
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. Wraps the ShowLines property.
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. Wraps the ShowRootLines property.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Size | Gets or sets the height and width of the control. (Inherited from DialogComponentBase.)
TabIndex | Gets or sets the tab order of the control within its container. Wraps the TabIndex property. (Inherited from DialogControl.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. Wraps the TabStop property. (Inherited from DialogControl.)
Text | This property is not relevant to this class. (Overrides DialogControl..::.Text.)
TextChangedEvent | Gets or sets a script method name that will be used to handle the TextChanged event. (Inherited from DialogControl.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from DialogControl.)
TreeView | Gets an internal TreeView.
Visible | Gets or sets a value indicating whether the control is displayed. Wraps the Visible property. (Inherited from DialogControl.)
Width | Gets or sets the width of the object. (Inherited from DialogControl.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TreeViewControl Class
FastReport.Dialog Namespace


AfterSelectEvent Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.AfterSelectEvent Property
TreeViewControl Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the AfterSelect event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AfterSelectEvent { get; set; }
Visual Basic (Declaration)
Public Property AfterSelectEvent As String
Visual C++
public:
property String^ AfterSelectEvent {
    String^ get ();
    void set (String^ value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


CheckBoxes Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.CheckBoxes Property
TreeViewControl Class See Also Send Feedback
Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. Wraps the CheckBoxes property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CheckBoxes { get; set; }
Visual Basic (Declaration)
Public Property CheckBoxes As Boolean
Visual C++
public:
property bool CheckBoxes {
    bool get ();
    void set (bool value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


ImageList Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.ImageList Property
TreeViewControl Class See Also Send Feedback
Gets or sets the ImageList that contains the Image objects used by the tree nodes. Wraps the ImageList property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic (Declaration)
Public Property ImageList As ImageList
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


Nodes Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.Nodes Property
TreeViewControl Class See Also Send Feedback
Gets the collection of tree nodes that are assigned to the tree view control. Wraps the Nodes property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TreeNodeCollection Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As TreeNodeCollection
Visual C++
public:
property TreeNodeCollection^ Nodes {
    TreeNodeCollection^ get ();
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


SelectedNode Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.SelectedNode Property
TreeViewControl Class See Also Send Feedback
Gets or sets the tree node that is currently selected in the tree view control. Wraps the SelectedNode property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TreeNode SelectedNode { get; set; }
Visual Basic (Declaration)
Public Property SelectedNode As TreeNode
Visual C++
public:
property TreeNode^ SelectedNode {
    TreeNode^ get ();
    void set (TreeNode^ value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


ShowLines Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.ShowLines Property
TreeViewControl Class See Also Send Feedback
Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. Wraps the ShowLines property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowLines { get; set; }
Visual Basic (Declaration)
Public Property ShowLines As Boolean
Visual C++
public:
property bool ShowLines {
    bool get ();
    void set (bool value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


ShowRootLines Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.ShowRootLines Property
TreeViewControl Class See Also Send Feedback
Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. Wraps the ShowRootLines property.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowRootLines { get; set; }
Visual Basic (Declaration)
Public Property ShowRootLines As Boolean
Visual C++
public:
property bool ShowRootLines {
    bool get ();
    void set (bool value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


Text Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.Text Property
TreeViewControl Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


TreeView Property

[image]

FastReport.Net Class Reference
TreeViewControl..::.TreeView Property
TreeViewControl Class See Also Send Feedback
Gets an internal TreeView.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TreeView TreeView { get; }
Visual Basic (Declaration)
Public ReadOnly Property TreeView As TreeView
Visual C++
public:
property TreeView^ TreeView {
    TreeView^ get ();
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


TreeViewControl Events

[image] [image]

FastReport.Net Class Reference
TreeViewControl Events
TreeViewControl Class See Also Send Feedback

The TreeViewControl type exposes the following members.

Events

Name | Description
AfterSelect | Occurs after the tree node is selected. Wraps the AfterSelect event.
Click | Occurs when the control is clicked. Wraps the Click event. (Inherited from DialogControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DoubleClick | Occurs when the control is double-clicked. Wraps the DoubleClick event. (Inherited from DialogControl.)
Enter | Occurs when the control is entered. Wraps the Enter event. (Inherited from DialogControl.)
KeyDown | Occurs when a key is pressed while the control has focus. Wraps the KeyDown event. (Inherited from DialogControl.)
KeyPress | Occurs when a key is pressed while the control has focus. Wraps the KeyPress event. (Inherited from DialogControl.)
KeyUp | Occurs when a key is released while the control has focus. Wraps the KeyUp event. (Inherited from DialogControl.)
Leave | Occurs when the input focus leaves the control. Wraps the Leave event. (Inherited from DialogControl.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Wraps the MouseDown event. (Inherited from DialogControl.)
MouseEnter | Occurs when the mouse pointer enters the control. Wraps the MouseEnter event. (Inherited from DialogControl.)
MouseLeave | Occurs when the mouse pointer leaves the control. Wraps the MouseLeave event. (Inherited from DialogControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. Wraps the MouseMove event. (Inherited from DialogControl.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Wraps the MouseUp event. (Inherited from DialogControl.)
Paint | Occurs when the control is redrawn. Wraps the Paint event. (Inherited from DialogControl.)
Resize | Occurs when the control is resized. Wraps the Resize event. (Inherited from DialogControl.)
TextChanged | Occurs when the Text property value changes. Wraps the TextChanged event. (Inherited from DialogControl.)

See Also

TreeViewControl Class
FastReport.Dialog Namespace


AfterSelect Event

[image]

FastReport.Net Class Reference
TreeViewControl..::.AfterSelect Event
TreeViewControl Class See Also Send Feedback
Occurs after the tree node is selected. Wraps the AfterSelect event.

Namespace: FastReport.Dialog
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event TreeViewEventHandler AfterSelect
Visual Basic (Declaration)
Public Event AfterSelect As TreeViewEventHandler
Visual C++
public:
 event TreeViewEventHandler^ AfterSelect {
    void add (TreeViewEventHandler^ value);
    void remove (TreeViewEventHandler^ value);
}

See Also

TreeViewControl Class
FastReport.Dialog Namespace


FastReport.Engine Namespace

[image]

FastReport.Net Class Reference
FastReport.Engine Namespace
Send Feedback

Classes

Class | Description
ReportEngine | Represents the report engine.


ReportEngine Class

[image]

FastReport.Net Class Reference
ReportEngine Class
Members See Also Send Feedback
Represents the report engine.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportEngine
Visual Basic (Declaration)
Public Class ReportEngine
Visual C++
public ref class ReportEngine

Inheritance Hierarchy

System..::.Object
FastReport.Engine..::.ReportEngine

See Also

ReportEngine Members
FastReport.Engine Namespace


ReportEngine Members

[image] [image]

FastReport.Net Class Reference
ReportEngine Members
ReportEngine Class Methods Properties See Also Send Feedback

The ReportEngine type exposes the following members.

Methods

Name | Description
AddBookmark | Creates a new bookmark with specified name at current position.
AddOutline | Creates a new outline element with specified text.
EndKeep | Ends the keep mechanism.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBookmarkPage | Gets a page number for the specified bookmark name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OutlineRoot | Sets the current outline position to root.
OutlineUp | Shifts the current outline position one level up.
ProcessObject | Processes the specified text object which ProcessAt property is set to Custom.
ResetLogicalPageNumber | Resets the logical page numbers.
ShowBand | Shows band at the current position.
StartKeep | Starts the keep mechanism.
StartNewColumn | Starts a new column.
StartNewPage | Starts a new page.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AbsRowNo | Gets the running current row number of currently printing band.
ColumnFooterHeight | Gets the height of column footer (including all its child bands), in pixels.
CurColumn | Gets the index of currently printing column in the multi-column report.
CurPage | Gets or sets index of current prepared page the current band will print on.
CurX | Gets or sets the current X offset.
CurY | Gets or sets the current Y offset.
Date | Gets the date of report start.
FinalPass | Gets a value indicating whether the report is executing the final pass.
FirstPass | Gets a value indicating whether the report is executing the first pass.
FreeSpace | Gets the free space on the current page, in pixels.
HierarchyLevel | Gets a level of hierarchy when printing hierarchical bands.
HierarchyRowNo | Gets the row number like "1.2.1" when printing hierarchical bands.
PageFooterHeight | Gets the height of page footer (including all its child bands), in pixels.
PageHeight | Gets the current page height, in pixels.
PageN | Gets the string that represents the current page number.
PageNo | Gets the current prepared page number.
PageNofM | Gets the string that represents the "Page N of M" number.
PageWidth | Gets the current page width, in pixels.
RowNo | Gets the current row number of currently printing band.
TotalPages | Gets the number of total pages in a prepared report.

See Also

ReportEngine Class
FastReport.Engine Namespace


ReportEngine Methods

[image] [image]

FastReport.Net Class Reference
ReportEngine Methods
ReportEngine Class See Also Send Feedback

The ReportEngine type exposes the following members.

Methods

Name | Description
AddBookmark | Creates a new bookmark with specified name at current position.
AddOutline | Creates a new outline element with specified text.
EndKeep | Ends the keep mechanism.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBookmarkPage | Gets a page number for the specified bookmark name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OutlineRoot | Sets the current outline position to root.
OutlineUp | Shifts the current outline position one level up.
ProcessObject | Processes the specified text object which ProcessAt property is set to Custom.
ResetLogicalPageNumber | Resets the logical page numbers.
ShowBand | Shows band at the current position.
StartKeep | Starts the keep mechanism.
StartNewColumn | Starts a new column.
StartNewPage | Starts a new page.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportEngine Class
FastReport.Engine Namespace


AddBookmark Method

[image]

FastReport.Net Class Reference
ReportEngine..::.AddBookmark Method
ReportEngine Class See Also Send Feedback
Creates a new bookmark with specified name at current position.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddBookmark(
    string name
)
Visual Basic (Declaration)
Public Sub AddBookmark ( _
    name As String _
)
Visual C++
public:
void AddBookmark(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

ReportEngine Class
FastReport.Engine Namespace


AddOutline Method

[image]

FastReport.Net Class Reference
ReportEngine..::.AddOutline Method
ReportEngine Class See Also Send Feedback
Creates a new outline element with specified text.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddOutline(
    string text
)
Visual Basic (Declaration)
Public Sub AddOutline ( _
    text As String _
)
Visual C++
public:
void AddOutline(
    String^ text
)

Parameters

text
Type: System..::.String
Text of element.

Remarks

After you call this method, the element will be added to the current position in the outline. The next call to AddOutline will add new element as a child of this element. To shift the position, use the OutlineRoot()()() or OutlineUp methods.

See Also

ReportEngine Class
FastReport.Engine Namespace


EndKeep Method

[image]

FastReport.Net Class Reference
ReportEngine..::.EndKeep Method
ReportEngine Class See Also Send Feedback
Ends the keep mechanism.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EndKeep()
Visual Basic (Declaration)
Public Sub EndKeep
Visual C++
public:
void EndKeep()

Remarks

Use this method along with the StartKeep()()() method if you want to keep several bands together. Call StartKeep method before printing the first band you want to keep, then call the EndKeep method after printing the last band you want to keep.

See Also

ReportEngine Class
FastReport.Engine Namespace


GetBookmarkPage Method

[image]

FastReport.Net Class Reference
ReportEngine..::.GetBookmarkPage Method
ReportEngine Class See Also Send Feedback
Gets a page number for the specified bookmark name.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetBookmarkPage(
    string name
)
Visual Basic (Declaration)
Public Function GetBookmarkPage ( _
    name As String _
) As Integer
Visual C++
public:
int GetBookmarkPage(
    String^ name
)

Parameters

name
Type: System..::.String
Name of bookmark.

Return Value

Page number if bookmark with such name found; 0 otherwise.

Remarks

Use this method to print the table of contents in your report. Normally it can be done using bookmarks.
Note: You must set your report to double pass to use this method.

See Also

ReportEngine Class
FastReport.Engine Namespace


OutlineRoot Method

[image]

FastReport.Net Class Reference
ReportEngine..::.OutlineRoot Method
ReportEngine Class See Also Send Feedback
Sets the current outline position to root.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OutlineRoot()
Visual Basic (Declaration)
Public Sub OutlineRoot
Visual C++
public:
void OutlineRoot()

See Also

ReportEngine Class
FastReport.Engine Namespace


OutlineUp Method

[image]

FastReport.Net Class Reference
ReportEngine..::.OutlineUp Method
ReportEngine Class See Also Send Feedback
Shifts the current outline position one level up.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OutlineUp()
Visual Basic (Declaration)
Public Sub OutlineUp
Visual C++
public:
void OutlineUp()

See Also

ReportEngine Class
FastReport.Engine Namespace


ProcessObject Method

[image]

FastReport.Net Class Reference
ReportEngine..::.ProcessObject Method
ReportEngine Class See Also Send Feedback
Processes the specified text object which ProcessAt property is set to Custom.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ProcessObject(
    TextObjectBase obj
)
Visual Basic (Declaration)
Public Sub ProcessObject ( _
    obj As TextObjectBase _
)
Visual C++
public:
void ProcessObject(
    TextObjectBase^ obj
)

Parameters

obj
Type: FastReport..::.TextObjectBase
The text object to process.

See Also

ReportEngine Class
FastReport.Engine Namespace


ResetLogicalPageNumber Method

[image]

FastReport.Net Class Reference
ReportEngine..::.ResetLogicalPageNumber Method
ReportEngine Class See Also Send Feedback
Resets the logical page numbers.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ResetLogicalPageNumber()
Visual Basic (Declaration)
Public Sub ResetLogicalPageNumber
Visual C++
public:
void ResetLogicalPageNumber()

See Also

ReportEngine Class
FastReport.Engine Namespace


ShowBand Method

[image]

FastReport.Net Class Reference
ReportEngine..::.ShowBand Method
ReportEngine Class See Also Send Feedback
Shows band at the current position.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowBand(
    BandBase band
)
Visual Basic (Declaration)
Public Sub ShowBand ( _
    band As BandBase _
)
Visual C++
public:
void ShowBand(
    BandBase^ band
)

Parameters

band
Type: FastReport..::.BandBase
Band to show.

Remarks

After the band is shown, the current position is advanced by the band's height.

See Also

ReportEngine Class
FastReport.Engine Namespace


StartKeep Method

[image]

FastReport.Net Class Reference
ReportEngine..::.StartKeep Method
ReportEngine Class See Also Send Feedback
Starts the keep mechanism.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void StartKeep()
Visual Basic (Declaration)
Public Sub StartKeep
Visual C++
public:
void StartKeep()

Remarks

Use this method along with the EndKeep()()() method if you want to keep several bands together. Call StartKeep method before printing the first band you want to keep, then call the EndKeep method after printing the last band you want to keep.

See Also

ReportEngine Class
FastReport.Engine Namespace


StartNewColumn Method

[image]

FastReport.Net Class Reference
ReportEngine..::.StartNewColumn Method
ReportEngine Class See Also Send Feedback
Starts a new column.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void StartNewColumn()
Visual Basic (Declaration)
Public Sub StartNewColumn
Visual C++
public:
void StartNewColumn()

See Also

ReportEngine Class
FastReport.Engine Namespace


StartNewPage Method

[image]

FastReport.Net Class Reference
ReportEngine..::.StartNewPage Method
ReportEngine Class See Also Send Feedback
Starts a new page.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void StartNewPage()
Visual Basic (Declaration)
Public Sub StartNewPage
Visual C++
public:
void StartNewPage()

See Also

ReportEngine Class
FastReport.Engine Namespace


ReportEngine Properties

[image] [image]

FastReport.Net Class Reference
ReportEngine Properties
ReportEngine Class See Also Send Feedback

The ReportEngine type exposes the following members.

Properties

Name | Description
AbsRowNo | Gets the running current row number of currently printing band.
ColumnFooterHeight | Gets the height of column footer (including all its child bands), in pixels.
CurColumn | Gets the index of currently printing column in the multi-column report.
CurPage | Gets or sets index of current prepared page the current band will print on.
CurX | Gets or sets the current X offset.
CurY | Gets or sets the current Y offset.
Date | Gets the date of report start.
FinalPass | Gets a value indicating whether the report is executing the final pass.
FirstPass | Gets a value indicating whether the report is executing the first pass.
FreeSpace | Gets the free space on the current page, in pixels.
HierarchyLevel | Gets a level of hierarchy when printing hierarchical bands.
HierarchyRowNo | Gets the row number like "1.2.1" when printing hierarchical bands.
PageFooterHeight | Gets the height of page footer (including all its child bands), in pixels.
PageHeight | Gets the current page height, in pixels.
PageN | Gets the string that represents the current page number.
PageNo | Gets the current prepared page number.
PageNofM | Gets the string that represents the "Page N of M" number.
PageWidth | Gets the current page width, in pixels.
RowNo | Gets the current row number of currently printing band.
TotalPages | Gets the number of total pages in a prepared report.

See Also

ReportEngine Class
FastReport.Engine Namespace


AbsRowNo Property

[image]

FastReport.Net Class Reference
ReportEngine..::.AbsRowNo Property
ReportEngine Class See Also Send Feedback
Gets the running current row number of currently printing band.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int AbsRowNo { get; }
Visual Basic (Declaration)
Public ReadOnly Property AbsRowNo As Integer
Visual C++
public:
property int AbsRowNo {
    int get ();
}

Remarks

This value is 1-based.

See Also

ReportEngine Class
FastReport.Engine Namespace


ColumnFooterHeight Property

[image]

FastReport.Net Class Reference
ReportEngine..::.ColumnFooterHeight Property
ReportEngine Class See Also Send Feedback
Gets the height of column footer (including all its child bands), in pixels.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ColumnFooterHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnFooterHeight As Single
Visual C++
public:
property float ColumnFooterHeight {
    float get ();
}

See Also

ReportEngine Class
FastReport.Engine Namespace


CurColumn Property

[image]

FastReport.Net Class Reference
ReportEngine..::.CurColumn Property
ReportEngine Class See Also Send Feedback
Gets the index of currently printing column in the multi-column report.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CurColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurColumn As Integer
Visual C++
public:
property int CurColumn {
    int get ();
}

Remarks

This value is 0-based.

See Also

ReportEngine Class
FastReport.Engine Namespace


CurPage Property

[image]

FastReport.Net Class Reference
ReportEngine..::.CurPage Property
ReportEngine Class See Also Send Feedback
Gets or sets index of current prepared page the current band will print on.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CurPage { get; set; }
Visual Basic (Declaration)
Public Property CurPage As Integer
Visual C++
public:
property int CurPage {
    int get ();
    void set (int value);
}

Remarks

Note: the page with specified index must exists. This property is used to print side-by-side subreports and Table object. Usually you don't need to use it.

See Also

ReportEngine Class
FastReport.Engine Namespace


CurX Property

[image]

FastReport.Net Class Reference
ReportEngine..::.CurX Property
ReportEngine Class See Also Send Feedback
Gets or sets the current X offset.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CurX { get; set; }
Visual Basic (Declaration)
Public Property CurX As Single
Visual C++
public:
property float CurX {
    float get ();
    void set (float value);
}

Remarks

This property specifies the X offset where the current band will be printed.

See Also

ReportEngine Class
FastReport.Engine Namespace


CurY Property

[image]

FastReport.Net Class Reference
ReportEngine..::.CurY Property
ReportEngine Class See Also Send Feedback
Gets or sets the current Y offset.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CurY { get; set; }
Visual Basic (Declaration)
Public Property CurY As Single
Visual C++
public:
property float CurY {
    float get ();
    void set (float value);
}

Remarks

This property specifies the Y offset where the current band will be printed. After the band is printed, this value is incremented by the band's height.

See Also

ReportEngine Class
FastReport.Engine Namespace


Date Property

[image]

FastReport.Net Class Reference
ReportEngine..::.Date Property
ReportEngine Class See Also Send Feedback
Gets the date of report start.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateTime Date { get; }
Visual Basic (Declaration)
Public ReadOnly Property Date As DateTime
Visual C++
public:
property DateTime Date {
    DateTime get ();
}

See Also

ReportEngine Class
FastReport.Engine Namespace


FinalPass Property

[image]

FastReport.Net Class Reference
ReportEngine..::.FinalPass Property
ReportEngine Class See Also Send Feedback
Gets a value indicating whether the report is executing the final pass.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FinalPass { get; }
Visual Basic (Declaration)
Public ReadOnly Property FinalPass As Boolean
Visual C++
public:
property bool FinalPass {
    bool get ();
}

Remarks

This property is true if report is one-pass, or if report is two-pass and the second pass is executing.

See Also

ReportEngine Class
FastReport.Engine Namespace


FirstPass Property

[image]

FastReport.Net Class Reference
ReportEngine..::.FirstPass Property
ReportEngine Class See Also Send Feedback
Gets a value indicating whether the report is executing the first pass.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FirstPass { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstPass As Boolean
Visual C++
public:
property bool FirstPass {
    bool get ();
}

Remarks

This property is true if report is one-pass, or if report is two-pass and the first pass is executing.

See Also

ReportEngine Class
FastReport.Engine Namespace


FreeSpace Property

[image]

FastReport.Net Class Reference
ReportEngine..::.FreeSpace Property
ReportEngine Class See Also Send Feedback
Gets the free space on the current page, in pixels.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float FreeSpace { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreeSpace As Single
Visual C++
public:
property float FreeSpace {
    float get ();
}

Remarks

This property returns the page height minus footers height minus CurY value.

See Also

ReportEngine Class
FastReport.Engine Namespace


HierarchyLevel Property

[image]

FastReport.Net Class Reference
ReportEngine..::.HierarchyLevel Property
ReportEngine Class See Also Send Feedback
Gets a level of hierarchy when printing hierarchical bands.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int HierarchyLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property HierarchyLevel As Integer
Visual C++
public:
property int HierarchyLevel {
    int get ();
}

Remarks

The first level of hierarchy has 0 index.

See Also

ReportEngine Class
FastReport.Engine Namespace


HierarchyRowNo Property

[image]

FastReport.Net Class Reference
ReportEngine..::.HierarchyRowNo Property
ReportEngine Class See Also Send Feedback
Gets the row number like "1.2.1" when printing hierarchical bands.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string HierarchyRowNo { get; }
Visual Basic (Declaration)
Public ReadOnly Property HierarchyRowNo As String
Visual C++
public:
property String^ HierarchyRowNo {
    String^ get ();
}

See Also

ReportEngine Class
FastReport.Engine Namespace


PageFooterHeight Property

[image]

FastReport.Net Class Reference
ReportEngine..::.PageFooterHeight Property
ReportEngine Class See Also Send Feedback
Gets the height of page footer (including all its child bands), in pixels.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PageFooterHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageFooterHeight As Single
Visual C++
public:
property float PageFooterHeight {
    float get ();
}

See Also

ReportEngine Class
FastReport.Engine Namespace


PageHeight Property

[image]

FastReport.Net Class Reference
ReportEngine..::.PageHeight Property
ReportEngine Class See Also Send Feedback
Gets the current page height, in pixels.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PageHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageHeight As Single
Visual C++
public:
property float PageHeight {
    float get ();
}

Remarks

This property returns a paper height minus top and bottom margins.

See Also

ReportEngine Class
FastReport.Engine Namespace


PageN Property

[image]

FastReport.Net Class Reference
ReportEngine..::.PageN Property
ReportEngine Class See Also Send Feedback
Gets the string that represents the current page number.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageN { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageN As String
Visual C++
public:
property String^ PageN {
    String^ get ();
}

Remarks

This property returns a locale-based value, for example: "Page 1".

See Also

ReportEngine Class
FastReport.Engine Namespace


PageNo Property

[image]

FastReport.Net Class Reference
ReportEngine..::.PageNo Property
ReportEngine Class See Also Send Feedback
Gets the current prepared page number.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PageNo { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNo As Integer
Visual C++
public:
property int PageNo {
    int get ();
}

Remarks

This value is 1-based. The initial value (usually 1) is set in the Report.InitialPageNumber property.

See Also

ReportEngine Class
FastReport.Engine Namespace


PageNofM Property

[image]

FastReport.Net Class Reference
ReportEngine..::.PageNofM Property
ReportEngine Class See Also Send Feedback
Gets the string that represents the "Page N of M" number.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageNofM { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNofM As String
Visual C++
public:
property String^ PageNofM {
    String^ get ();
}

Remarks

This property returns a locale-based value, for example: "Page 1 of 10".

See Also

ReportEngine Class
FastReport.Engine Namespace


PageWidth Property

[image]

FastReport.Net Class Reference
ReportEngine..::.PageWidth Property
ReportEngine Class See Also Send Feedback
Gets the current page width, in pixels.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PageWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageWidth As Single
Visual C++
public:
property float PageWidth {
    float get ();
}

Remarks

This property returns a paper width minus left and right margins.

See Also

ReportEngine Class
FastReport.Engine Namespace


RowNo Property

[image]

FastReport.Net Class Reference
ReportEngine..::.RowNo Property
ReportEngine Class See Also Send Feedback
Gets the current row number of currently printing band.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowNo { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowNo As Integer
Visual C++
public:
property int RowNo {
    int get ();
}

Remarks

This value is 1-based. It resets to 1 on each new group.

See Also

ReportEngine Class
FastReport.Engine Namespace


TotalPages Property

[image]

FastReport.Net Class Reference
ReportEngine..::.TotalPages Property
ReportEngine Class See Also Send Feedback
Gets the number of total pages in a prepared report.

Namespace: FastReport.Engine
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int TotalPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalPages As Integer
Visual C++
public:
property int TotalPages {
    int get ();
}

Remarks

To use this property, your report must be two-pass. Set the DoublePass property to true.

See Also

ReportEngine Class
FastReport.Engine Namespace


FastReport.Export Namespace

[image]

FastReport.Net Class Reference
FastReport.Export Namespace
Send Feedback

Classes

Class | Description
ExportBase | The base class for all export filters.


ExportBase Class

[image]

FastReport.Net Class Reference
ExportBase Class
Members See Also Send Feedback
The base class for all export filters.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ExportBase : Base
Visual Basic (Declaration)
Public Class ExportBase _
    Inherits Base
Visual C++
public ref class ExportBase : public Base

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Csv..::.CSVExport
FastReport.Export.Dbf..::.DBFExport
FastReport.Export.Html..::.HTMLExport
FastReport.Export.Image..::.ImageExport
FastReport.Export.Mht..::.MHTExport
FastReport.Export.Odf..::.ODFExport
FastReport.Export.OoXML..::.OOExportBase
FastReport.Export.Pdf..::.PDFExport
FastReport.Export.RichText..::.RTFExport
FastReport.Export.Text..::.TextExport
FastReport.Export.Xml..::.XMLExport

See Also

ExportBase Members
FastReport.Export Namespace


ExportBase Members

[image] [image]

FastReport.Net Class Reference
ExportBase Members
ExportBase Class Constructors Methods Properties Events See Also Send Feedback

The ExportBase type exposes the following members.

Constructors

Name | Description
ExportBase | Initializes a new instance of the ExportBase class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished.
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options.
Start | This method is called when the export starts.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog.
FileName | File name to export to.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export.
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export.
PageRange | Range of pages to export.
Pages | Array of page numbers to export.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to.
Zoom | Zoom factor for output file
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExportBase Class
FastReport.Export Namespace


ExportBase Constructor

[image]

FastReport.Net Class Reference
ExportBase Constructor
ExportBase Class See Also Send Feedback
Initializes a new instance of the ExportBase class.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ExportBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExportBase()

See Also

ExportBase Class
FastReport.Export Namespace


ExportBase Methods

[image] [image]

FastReport.Net Class Reference
ExportBase Methods
ExportBase Class See Also Send Feedback

The ExportBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished.
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options.
Start | This method is called when the export starts.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ExportBase Class
FastReport.Export Namespace


Assign Method

[image]

FastReport.Net Class Reference
ExportBase..::.Assign Method
ExportBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ExportBase Class
FastReport.Export Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
ExportBase..::.Dispose Method
ExportBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ExportBase Class
ExportBase Members
FastReport.Export Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
ExportBase..::.Export Method
ExportBase Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file.
Export(Report, Stream) | Exports the report to a stream.
Export(Report, String) | Exports the report to a file.

See Also

ExportBase Class
ExportBase Members
FastReport.Export Namespace


Export Method (Report)

[image]

FastReport.Net Class Reference
ExportBase..::.Export Method (Report)
ExportBase Class See Also Send Feedback
Exports the report to a file.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Export(
    Report report
)
Visual Basic (Declaration)
Public Function Export ( _
    report As Report _
) As Boolean
Visual C++
public:
bool Export(
    Report^ report
)

Parameters

report
Type: FastReport..::.Report
Report to export.

Return Value

true if report was succesfully exported.

Remarks

This method displays an export options dialog, then prompts a file name using standard "Open file" dialog. If both dialogs were closed by OK button, exports the report and returns true.

See Also

ExportBase Class
Export Overload
FastReport.Export Namespace


Export Method (Report, Stream)

[image]

FastReport.Net Class Reference
ExportBase..::.Export Method (Report, Stream)
ExportBase Class See Also Send Feedback
Exports the report to a stream.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Export(
    Report report,
    Stream stream
)
Visual Basic (Declaration)
Public Sub Export ( _
    report As Report, _
    stream As Stream _
)
Visual C++
public:
void Export(
    Report^ report,
    Stream^ stream
)

Parameters

report
Type: FastReport..::.Report
Report to export.
stream
Type: System.IO..::.Stream
Stream to export to.

Remarks

This method does not show an export options dialog. If you want to show it, call ShowDialog()()() method prior to calling this method, or use the "Export(Report report)" method instead.

See Also

ExportBase Class
Export Overload
FastReport.Export Namespace


Export Method (Report, String)

[image]

FastReport.Net Class Reference
ExportBase..::.Export Method (Report, String)
ExportBase Class See Also Send Feedback
Exports the report to a file.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Export(
    Report report,
    string fileName
)
Visual Basic (Declaration)
Public Sub Export ( _
    report As Report, _
    fileName As String _
)
Visual C++
public:
void Export(
    Report^ report,
    String^ fileName
)

Parameters

report
Type: FastReport..::.Report
Report to export.
fileName
Type: System..::.String
File name to export to.

Remarks

This method does not show an export options dialog. If you want to show it, call ShowDialog()()() method prior to calling this method, or use the "Export(Report report)" method instead.

See Also

ExportBase Class
Export Overload
FastReport.Export Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
ExportBase..::.ExportPage Method
ExportBase Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overridable Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
)

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

ExportBase Class
FastReport.Export Namespace


Finish Method

[image]

FastReport.Net Class Reference
ExportBase..::.Finish Method
ExportBase Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void Finish()
Visual Basic (Declaration)
Protected Overridable Sub Finish
Visual C++
protected:
virtual void Finish()

See Also

ExportBase Class
FastReport.Export Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
ExportBase..::.GetFileFilter Method
ExportBase Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual string GetFileFilter()
Visual Basic (Declaration)
Protected Overridable Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter()

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

ExportBase Class
FastReport.Export Namespace


GetPage Method

[image]

FastReport.Net Class Reference
ExportBase..::.GetPage Method
ExportBase Class See Also Send Feedback
Gets a report page with specified index.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ReportPage GetPage(
    int index
)
Visual Basic (Declaration)
Protected Function GetPage ( _
    index As Integer _
) As ReportPage
Visual C++
protected:
ReportPage^ GetPage(
    int index
)

Parameters

index
Type: System..::.Int32
Zero-based index of page.

Return Value

The prepared report page.

See Also

ExportBase Class
FastReport.Export Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ExportBase..::.MemberwiseClone Method
ExportBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ExportBase Class
ExportBase Members
FastReport.Export Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ExportBase..::.Serialize Method
ExportBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ExportBase Class
FastReport.Export Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
ExportBase..::.ShowDialog Method
ExportBase Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool ShowDialog()
Visual Basic (Declaration)
Public Overridable Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog()

Return Value

true if dialog was closed with OK button.

See Also

ExportBase Class
FastReport.Export Namespace


Start Method

[image]

FastReport.Net Class Reference
ExportBase..::.Start Method
ExportBase Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void Start()
Visual Basic (Declaration)
Protected Overridable Sub Start
Visual C++
protected:
virtual void Start()

See Also

ExportBase Class
FastReport.Export Namespace


ExportBase Properties

[image] [image]

FastReport.Net Class Reference
ExportBase Properties
ExportBase Class See Also Send Feedback

The ExportBase type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog.
FileName | File name to export to.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export.
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export.
PageRange | Range of pages to export.
Pages | Array of page numbers to export.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to.
Zoom | Zoom factor for output file
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ExportBase Class
FastReport.Export Namespace


AllowOpenAfter Property

[image]

FastReport.Net Class Reference
ExportBase..::.AllowOpenAfter Property
ExportBase Class See Also Send Feedback
Allows or disables the OpenAfterExport feature.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowOpenAfter { get; set; }
Visual Basic (Declaration)
Public Property AllowOpenAfter As Boolean
Visual C++
public:
property bool AllowOpenAfter {
    bool get ();
    void set (bool value);
}

See Also

ExportBase Class
FastReport.Export Namespace


CurPage Property

[image]

FastReport.Net Class Reference
ExportBase..::.CurPage Property
ExportBase Class See Also Send Feedback
Current page number.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int CurPage { get; set; }
Visual Basic (Declaration)
Public Property CurPage As Integer
Visual C++
public:
property int CurPage {
    int get ();
    void set (int value);
}

Remarks

Page number need to be exported if user selects "Current page" radiobutton in the export options dialog. This property is typically set to current page number in the preview window.

See Also

ExportBase Class
FastReport.Export Namespace


FileFilter Property

[image]

FastReport.Net Class Reference
ExportBase..::.FileFilter Property
ExportBase Class See Also Send Feedback
File filter that can be used in the "Save file" dialog.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FileFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileFilter As String
Visual C++
public:
property String^ FileFilter {
    String^ get ();
}

See Also

ExportBase Class
FastReport.Export Namespace


FileName Property

[image]

FastReport.Net Class Reference
ExportBase..::.FileName Property
ExportBase Class See Also Send Feedback
File name to export to.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected string FileName { get; }
Visual Basic (Declaration)
Protected ReadOnly Property FileName As String
Visual C++
protected:
property String^ FileName {
    String^ get ();
}

See Also

ExportBase Class
FastReport.Export Namespace


GeneratedFiles Property

[image]

FastReport.Net Class Reference
ExportBase..::.GeneratedFiles Property
ExportBase Class See Also Send Feedback
Gets a list of files generated by this export.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<string> GeneratedFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property GeneratedFiles As List(Of String)
Visual C++
public:
property List<String^>^ GeneratedFiles {
    List<String^>^ get ();
}

See Also

ExportBase Class
FastReport.Export Namespace


HasMultipleFiles Property

[image]

FastReport.Net Class Reference
ExportBase..::.HasMultipleFiles Property
ExportBase Class See Also Send Feedback
Gets a value indicating that the export may produce multiple output files.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasMultipleFiles { get; set; }
Visual Basic (Declaration)
Public Property HasMultipleFiles As Boolean
Visual C++
public:
property bool HasMultipleFiles {
    bool get ();
    void set (bool value);
}

See Also

ExportBase Class
FastReport.Export Namespace


OpenAfterExport Property

[image]

FastReport.Net Class Reference
ExportBase..::.OpenAfterExport Property
ExportBase Class See Also Send Feedback
Open the document after export.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool OpenAfterExport { get; set; }
Visual Basic (Declaration)
Public Property OpenAfterExport As Boolean
Visual C++
public:
property bool OpenAfterExport {
    bool get ();
    void set (bool value);
}

See Also

ExportBase Class
FastReport.Export Namespace


PageNumbers Property

[image]

FastReport.Net Class Reference
ExportBase..::.PageNumbers Property
ExportBase Class See Also Send Feedback
Page numbers to export.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageNumbers { get; set; }
Visual Basic (Declaration)
Public Property PageNumbers As String
Visual C++
public:
property String^ PageNumbers {
    String^ get ();
    void set (String^ value);
}

Remarks

Use page numbers separated by comma and/or page ranges, for example: "1,3-5,12". Empty string means that all pages need to be exported.

See Also

ExportBase Class
FastReport.Export Namespace


PageRange Property

[image]

FastReport.Net Class Reference
ExportBase..::.PageRange Property
ExportBase Class See Also Send Feedback
Range of pages to export.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageRange PageRange { get; set; }
Visual Basic (Declaration)
Public Property PageRange As PageRange
Visual C++
public:
property PageRange PageRange {
    PageRange get ();
    void set (PageRange value);
}

See Also

ExportBase Class
FastReport.Export Namespace


Pages Property

[image]

FastReport.Net Class Reference
ExportBase..::.Pages Property
ExportBase Class See Also Send Feedback
Array of page numbers to export.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected int[] Pages { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Pages As Integer()
Visual C++
protected:
property array<int>^ Pages {
    array<int>^ get ();
}

See Also

ExportBase Class
FastReport.Export Namespace


ShowProgress Property

[image]

FastReport.Net Class Reference
ExportBase..::.ShowProgress Property
ExportBase Class See Also Send Feedback
Gets or sets a value that determines whether to show progress window during export or not.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowProgress { get; set; }
Visual Basic (Declaration)
Public Property ShowProgress As Boolean
Visual C++
public:
property bool ShowProgress {
    bool get ();
    void set (bool value);
}

See Also

ExportBase Class
FastReport.Export Namespace


Stream Property

[image]

FastReport.Net Class Reference
ExportBase..::.Stream Property
ExportBase Class See Also Send Feedback
Stream to export to.

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Stream Stream { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Stream As Stream
Visual C++
protected:
property Stream^ Stream {
    Stream^ get ();
}

See Also

ExportBase Class
FastReport.Export Namespace


Zoom Property

[image]

FastReport.Net Class Reference
ExportBase..::.Zoom Property
ExportBase Class See Also Send Feedback
Zoom factor for output file

Namespace: FastReport.Export
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Single
Visual C++
public:
property float Zoom {
    float get ();
    void set (float value);
}

See Also

ExportBase Class
FastReport.Export Namespace


ExportBase Events

[image] [image]

FastReport.Net Class Reference
ExportBase Events
ExportBase Class See Also Send Feedback

The ExportBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExportBase Class
FastReport.Export Namespace


FastReport.Export.Csv Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Csv Namespace
Send Feedback

Classes

Class | Description
CSVExport | Represents the CSV export filter.


CSVExport Class

[image]

FastReport.Net Class Reference
CSVExport Class
Members See Also Send Feedback
Represents the CSV export filter.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CSVExport : ExportBase
Visual Basic (Declaration)
Public Class CSVExport _
    Inherits ExportBase
Visual C++
public ref class CSVExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Csv..::.CSVExport

See Also

CSVExport Members
FastReport.Export.Csv Namespace


CSVExport Members

[image] [image]

FastReport.Net Class Reference
CSVExport Members
CSVExport Class Constructors Methods Properties Events See Also Send Feedback

The CSVExport type exposes the following members.

Constructors

Name | Description
CSVExport | Initializes a new instance of the CSVExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ExportBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Encoding | Gets or set the resulting file encoding.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Separator | Gets or set the separator character used in csv format.
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CSVExport Class
FastReport.Export.Csv Namespace


CSVExport Constructor

[image]

FastReport.Net Class Reference
CSVExport Constructor
CSVExport Class See Also Send Feedback
Initializes a new instance of the CSVExport class.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CSVExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CSVExport()

See Also

CSVExport Class
FastReport.Export.Csv Namespace


CSVExport Methods

[image] [image]

FastReport.Net Class Reference
CSVExport Methods
CSVExport Class See Also Send Feedback

The CSVExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ExportBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CSVExport Class
FastReport.Export.Csv Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
CSVExport..::.Dispose Method
CSVExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

CSVExport Class
CSVExport Members
FastReport.Export.Csv Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
CSVExport..::.Export Method
CSVExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

CSVExport Class
CSVExport Members
FastReport.Export.Csv Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
CSVExport..::.ExportPage Method
CSVExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

CSVExport Class
FastReport.Export.Csv Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
CSVExport..::.GetFileFilter Method
CSVExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

CSVExport Class
FastReport.Export.Csv Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
CSVExport..::.MemberwiseClone Method
CSVExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CSVExport Class
CSVExport Members
FastReport.Export.Csv Namespace


Serialize Method

[image]

FastReport.Net Class Reference
CSVExport..::.Serialize Method
CSVExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

CSVExport Class
FastReport.Export.Csv Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
CSVExport..::.ShowDialog Method
CSVExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

CSVExport Class
FastReport.Export.Csv Namespace


Start Method

[image]

FastReport.Net Class Reference
CSVExport..::.Start Method
CSVExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

CSVExport Class
FastReport.Export.Csv Namespace


CSVExport Properties

[image] [image]

FastReport.Net Class Reference
CSVExport Properties
CSVExport Class See Also Send Feedback

The CSVExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Encoding | Gets or set the resulting file encoding.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Separator | Gets or set the separator character used in csv format.
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

CSVExport Class
FastReport.Export.Csv Namespace


DataOnly Property

[image]

FastReport.Net Class Reference
CSVExport..::.DataOnly Property
CSVExport Class See Also Send Feedback
Gets or sets a value that determines whether to export the databand rows only.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DataOnly { get; set; }
Visual Basic (Declaration)
Public Property DataOnly As Boolean
Visual C++
public:
property bool DataOnly {
    bool get ();
    void set (bool value);
}

See Also

CSVExport Class
FastReport.Export.Csv Namespace


Encoding Property

[image]

FastReport.Net Class Reference
CSVExport..::.Encoding Property
CSVExport Class See Also Send Feedback
Gets or set the resulting file encoding.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As Encoding
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

See Also

CSVExport Class
FastReport.Export.Csv Namespace


Separator Property

[image]

FastReport.Net Class Reference
CSVExport..::.Separator Property
CSVExport Class See Also Send Feedback
Gets or set the separator character used in csv format.

Namespace: FastReport.Export.Csv
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Separator { get; set; }
Visual Basic (Declaration)
Public Property Separator As String
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

See Also

CSVExport Class
FastReport.Export.Csv Namespace


CSVExport Events

[image] [image]

FastReport.Net Class Reference
CSVExport Events
CSVExport Class See Also Send Feedback

The CSVExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CSVExport Class
FastReport.Export.Csv Namespace


FastReport.Export.Dbf Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Dbf Namespace
Send Feedback

Classes

Class | Description
DBFExport | Represents the export to DBF.
Record | Represents the record.


DBFExport Class

[image]

FastReport.Net Class Reference
DBFExport Class
Members See Also Send Feedback
Represents the export to DBF.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DBFExport : ExportBase
Visual Basic (Declaration)
Public Class DBFExport _
    Inherits ExportBase
Visual C++
public ref class DBFExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Dbf..::.DBFExport

See Also

DBFExport Members
FastReport.Export.Dbf Namespace


DBFExport Members

[image] [image]

FastReport.Net Class Reference
DBFExport Members
DBFExport Class Constructors Methods Properties Events See Also Send Feedback

The DBFExport type exposes the following members.

Constructors

Name | Description
DBFExport | Initializes a new instance of the DBFExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Encoding | Gets or sets the encoding.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FieldNames | Gets or sets the list of field names.
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


DBFExport Constructor

[image]

FastReport.Net Class Reference
DBFExport Constructor
DBFExport Class See Also Send Feedback
Initializes a new instance of the DBFExport class.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DBFExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DBFExport()

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


DBFExport Methods

[image] [image]

FastReport.Net Class Reference
DBFExport Methods
DBFExport Class See Also Send Feedback

The DBFExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DBFExport..::.Dispose Method
DBFExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

DBFExport Class
DBFExport Members
FastReport.Export.Dbf Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
DBFExport..::.Export Method
DBFExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

DBFExport Class
DBFExport Members
FastReport.Export.Dbf Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
DBFExport..::.ExportPage Method
DBFExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


Finish Method

[image]

FastReport.Net Class Reference
DBFExport..::.Finish Method
DBFExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
DBFExport..::.GetFileFilter Method
DBFExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DBFExport..::.MemberwiseClone Method
DBFExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DBFExport Class
DBFExport Members
FastReport.Export.Dbf Namespace


Serialize Method

[image]

FastReport.Net Class Reference
DBFExport..::.Serialize Method
DBFExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
DBFExport..::.ShowDialog Method
DBFExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


Start Method

[image]

FastReport.Net Class Reference
DBFExport..::.Start Method
DBFExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


DBFExport Properties

[image] [image]

FastReport.Net Class Reference
DBFExport Properties
DBFExport Class See Also Send Feedback

The DBFExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Encoding | Gets or sets the encoding.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FieldNames | Gets or sets the list of field names.
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


DataOnly Property

[image]

FastReport.Net Class Reference
DBFExport..::.DataOnly Property
DBFExport Class See Also Send Feedback
Gets or sets a value that determines whether to export the databand rows only.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DataOnly { get; set; }
Visual Basic (Declaration)
Public Property DataOnly As Boolean
Visual C++
public:
property bool DataOnly {
    bool get ();
    void set (bool value);
}

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


Encoding Property

[image]

FastReport.Net Class Reference
DBFExport..::.Encoding Property
DBFExport Class See Also Send Feedback
Gets or sets the encoding.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As Encoding
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


FieldNames Property

[image]

FastReport.Net Class Reference
DBFExport..::.FieldNames Property
DBFExport Class See Also Send Feedback
Gets or sets the list of field names.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FieldNames { get; set; }
Visual Basic (Declaration)
Public Property FieldNames As String
Visual C++
public:
property String^ FieldNames {
    String^ get ();
    void set (String^ value);
}

Remarks

The field names must be separated by ";" symbol, for example: Column1;Column2;Column3

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


DBFExport Events

[image] [image]

FastReport.Net Class Reference
DBFExport Events
DBFExport Class See Also Send Feedback

The DBFExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

DBFExport Class
FastReport.Export.Dbf Namespace


Record Class

[image]

FastReport.Net Class Reference
Record Class
Members See Also Send Feedback
Represents the record.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Record
Visual Basic (Declaration)
Public Class Record
Visual C++
public ref class Record

Inheritance Hierarchy

System..::.Object
FastReport.Export.Dbf..::.Record

See Also

Record Members
FastReport.Export.Dbf Namespace


Record Members

[image] [image]

FastReport.Net Class Reference
Record Members
Record Class Constructors Methods Properties See Also Send Feedback

The Record type exposes the following members.

Constructors

Name | Description
Record | Initializes a new instance of the Record class.

Methods

Name | Description
Add | Adds the new item into a list of fields.
Clear | Clears the list of fields.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the count of a fields.
Item | Gets or sets the field with a specified index.
Size | Gets the size of a fields.

See Also

Record Class
FastReport.Export.Dbf Namespace


Record Constructor

[image]

FastReport.Net Class Reference
Record Constructor
Record Class See Also Send Feedback
Initializes a new instance of the Record class.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Record()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Record()

See Also

Record Class
FastReport.Export.Dbf Namespace


Record Methods

[image] [image]

FastReport.Net Class Reference
Record Methods
Record Class See Also Send Feedback

The Record type exposes the following members.

Methods

Name | Description
Add | Adds the new item into a list of fields.
Clear | Clears the list of fields.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Record Class
FastReport.Export.Dbf Namespace


Add Method

[image]

FastReport.Net Class Reference
Record..::.Add Method
Record Class See Also Send Feedback
Adds the new item into a list of fields.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Add(
    StringBuilder item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As StringBuilder _
)
Visual C++
public:
void Add(
    StringBuilder^ item
)

Parameters

item
Type: System.Text..::.StringBuilder

See Also

Record Class
FastReport.Export.Dbf Namespace


Clear Method

[image]

FastReport.Net Class Reference
Record..::.Clear Method
Record Class See Also Send Feedback
Clears the list of fields.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Record Class
FastReport.Export.Dbf Namespace


Record Properties

[image] [image]

FastReport.Net Class Reference
Record Properties
Record Class See Also Send Feedback

The Record type exposes the following members.

Properties

Name | Description
Count | Gets the count of a fields.
Item | Gets or sets the field with a specified index.
Size | Gets the size of a fields.

See Also

Record Class
FastReport.Export.Dbf Namespace


Count Property

[image]

FastReport.Net Class Reference
Record..::.Count Property
Record Class See Also Send Feedback
Gets the count of a fields.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

Record Class
FastReport.Export.Dbf Namespace


Item Property

[image]

FastReport.Net Class Reference
Record..::.Item Property
Record Class See Also Send Feedback
Gets or sets the field with a specified index.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StringBuilder this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As StringBuilder
Visual C++
public:
property StringBuilder^ default[int index] {
    StringBuilder^ get (int index);
    void set (int index, StringBuilder^ value);
}

Parameters

index
Type: System..::.Int32

See Also

Record Class
FastReport.Export.Dbf Namespace


Size Property

[image]

FastReport.Net Class Reference
Record..::.Size Property
Record Class See Also Send Feedback
Gets the size of a fields.

Namespace: FastReport.Export.Dbf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
Visual C++
public:
property int Size {
    int get ();
}

See Also

Record Class
FastReport.Export.Dbf Namespace


FastReport.Export.Email Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Email Namespace
Send Feedback

Classes

Class | Description
EmailExport | Represents the email export.
EmailSettings | Contains the email account settings such as host, email address, name.
MAPI | Allows to send message using MAPI interface.


EmailExport Class

[image]

FastReport.Net Class Reference
EmailExport Class
Members Example See Also Send Feedback
Represents the email export.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class EmailExport
Visual Basic (Declaration)
Public Class EmailExport
Visual C++
public ref class EmailExport

Remarks

In order to use this class, you need to set up at least the following properties: Address, Subject, Account. Use the Export property to choose the format of an attachment. If you leave it empty, the attachment will be in the .FRP format (FastReport prepared report). When you done with settings, call the SendEmail(Report) method to send an email.

Examples

This example demonstrates the bare minimum required to send an email.
CopyC#
EmailExport export = new EmailExport();
export.Account.Address = "my@address.net";
export.Account.Host = "myhost";
export.Address = "recipient@address.net";
export.Subject = "Re: analysis report";
// the report1 report must be prepared at this moment
export.SendEmail(report1);

Inheritance Hierarchy

System..::.Object
FastReport.Export.Email..::.EmailExport

See Also

EmailExport Members
FastReport.Export.Email Namespace


EmailExport Members

[image] [image]

FastReport.Net Class Reference
EmailExport Members
EmailExport Class Constructors Methods Properties See Also Send Feedback

The EmailExport type exposes the following members.

Constructors

Name | Description
EmailExport | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SendEmail | Sends an email.
ShowDialog | Displays the dialog box in which you can set up all parameters.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Account | Gets the email account settings such as host, user name, password.
Address | Gets or sets the recipient's address.
CC | Gets or sets the carbon copy adresses.
Export | Gets or sets the export filter which will be used to export a report.
MessageBody | Gets or sets the message body.
Report | Gets the parent Report object
Subject | Gets or sets the subject of the message.

See Also

EmailExport Class
FastReport.Export.Email Namespace


EmailExport Constructor

[image] [image]

FastReport.Net Class Reference
EmailExport Constructor
EmailExport Class See Also Send Feedback

Overload List

Name | Description
EmailExport()()() | Initializes a new instance of the EmailExport class with default settings.
EmailExport(Report) | Initializes a new instance of the EmailExport class with default settings.

See Also

EmailExport Class
EmailExport Members
FastReport.Export.Email Namespace


EmailExport Constructor

[image]

FastReport.Net Class Reference
EmailExport Constructor
EmailExport Class See Also Send Feedback
Initializes a new instance of the EmailExport class with default settings.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailExport()

See Also

EmailExport Class
EmailExport Overload
FastReport.Export.Email Namespace


EmailExport Constructor (Report)

[image]

FastReport.Net Class Reference
EmailExport Constructor (Report)
EmailExport Class See Also Send Feedback
Initializes a new instance of the EmailExport class with default settings.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailExport(
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    report As Report _
)
Visual C++
public:
EmailExport(
    Report^ report
)

Parameters

report
Type: FastReport..::.Report

See Also

EmailExport Class
EmailExport Overload
FastReport.Export.Email Namespace


EmailExport Methods

[image] [image]

FastReport.Net Class Reference
EmailExport Methods
EmailExport Class See Also Send Feedback

The EmailExport type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SendEmail | Sends an email.
ShowDialog | Displays the dialog box in which you can set up all parameters.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailExport Class
FastReport.Export.Email Namespace


SendEmail Method

[image]

FastReport.Net Class Reference
EmailExport..::.SendEmail Method
EmailExport Class See Also Send Feedback
Sends an email.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SendEmail(
    Report report
)
Visual Basic (Declaration)
Public Sub SendEmail ( _
    report As Report _
)
Visual C++
public:
void SendEmail(
    Report^ report
)

Parameters

report
Type: FastReport..::.Report
Report that will be sent as an attachment.

Remarks

Before using this method, set up the following properties (it's a bare minimum): Address, Subject, Account.

The report that you pass in this method must be prepared using the Prepare method.

See Also

EmailExport Class
FastReport.Export.Email Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
EmailExport..::.ShowDialog Method
EmailExport Class See Also Send Feedback
Displays the dialog box in which you can set up all parameters.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DialogResult ShowDialog()
Visual Basic (Declaration)
Public Function ShowDialog As DialogResult
Visual C++
public:
DialogResult ShowDialog()

Return Value

true if user pressed OK button in the dialog.

See Also

EmailExport Class
FastReport.Export.Email Namespace


EmailExport Properties

[image] [image]

FastReport.Net Class Reference
EmailExport Properties
EmailExport Class See Also Send Feedback

The EmailExport type exposes the following members.

Properties

Name | Description
Account | Gets the email account settings such as host, user name, password.
Address | Gets or sets the recipient's address.
CC | Gets or sets the carbon copy adresses.
Export | Gets or sets the export filter which will be used to export a report.
MessageBody | Gets or sets the message body.
Report | Gets the parent Report object
Subject | Gets or sets the subject of the message.

See Also

EmailExport Class
FastReport.Export.Email Namespace


Account Property

[image]

FastReport.Net Class Reference
EmailExport..::.Account Property
EmailExport Class See Also Send Feedback
Gets the email account settings such as host, user name, password.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailSettings Account { get; set; }
Visual Basic (Declaration)
Public Property Account As EmailSettings
Visual C++
public:
property EmailSettings^ Account {
    EmailSettings^ get ();
    void set (EmailSettings^ value);
}

See Also

EmailExport Class
FastReport.Export.Email Namespace


Address Property

[image]

FastReport.Net Class Reference
EmailExport..::.Address Property
EmailExport Class See Also Send Feedback
Gets or sets the recipient's address.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Address { get; set; }
Visual Basic (Declaration)
Public Property Address As String
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property must contain value in form "john@url.com".

See Also

EmailExport Class
FastReport.Export.Email Namespace


CC Property

[image]

FastReport.Net Class Reference
EmailExport..::.CC Property
EmailExport Class See Also Send Feedback
Gets or sets the carbon copy adresses.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string[] CC { get; set; }
Visual Basic (Declaration)
Public Property CC As String()
Visual C++
public:
property array<String^>^ CC {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

This property must contain an array of values in form "john@url.com".

See Also

EmailExport Class
FastReport.Export.Email Namespace


Export Property

[image]

FastReport.Net Class Reference
EmailExport..::.Export Property
EmailExport Class See Also Send Feedback
Gets or sets the export filter which will be used to export a report.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ExportBase Export { get; set; }
Visual Basic (Declaration)
Public Property Export As ExportBase
Visual C++
public:
property ExportBase^ Export {
    ExportBase^ get ();
    void set (ExportBase^ value);
}

Remarks

Set this property to instance of any export filter. When you send the email, the report will be exported using that export filter.

By default, this property is set to null. In this case the report will be send in .FRP format.

See Also

EmailExport Class
FastReport.Export.Email Namespace


MessageBody Property

[image]

FastReport.Net Class Reference
EmailExport..::.MessageBody Property
EmailExport Class See Also Send Feedback
Gets or sets the message body.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MessageBody { get; set; }
Visual Basic (Declaration)
Public Property MessageBody As String
Visual C++
public:
property String^ MessageBody {
    String^ get ();
    void set (String^ value);
}

See Also

EmailExport Class
FastReport.Export.Email Namespace


Report Property

[image]

FastReport.Net Class Reference
EmailExport..::.Report Property
EmailExport Class See Also Send Feedback
Gets the parent Report object

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
}

See Also

EmailExport Class
FastReport.Export.Email Namespace


Subject Property

[image]

FastReport.Net Class Reference
EmailExport..::.Subject Property
EmailExport Class See Also Send Feedback
Gets or sets the subject of the message.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

EmailExport Class
FastReport.Export.Email Namespace


EmailSettings Class

[image]

FastReport.Net Class Reference
EmailSettings Class
Members See Also Send Feedback
Contains the email account settings such as host, email address, name.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class EmailSettings
Visual Basic (Declaration)
Public Class EmailSettings
Visual C++
public ref class EmailSettings

Remarks

You have to set up at least the Address and Host properties. If your host requires authentication, provide the UserName and Password properties as well.

Set UseMAPI property to true if you want to use default email client such as Outlook to send an email. In this case, all other properties will be ignored.

Inheritance Hierarchy

System..::.Object
FastReport.Export.Email..::.EmailSettings

See Also

EmailSettings Members
FastReport.Export.Email Namespace


EmailSettings Members

[image] [image]

FastReport.Net Class Reference
EmailSettings Members
EmailSettings Class Constructors Methods Properties See Also Send Feedback

The EmailSettings type exposes the following members.

Constructors

Name | Description
EmailSettings | Initializes a new instance of the EmailSettings class with default settings.

Methods

Name | Description
Assign | Copies email settings from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address | Gets or sets the sender's email address.
AllowUI | Gets or sets a value that determines whether the account setting page in the "Send Email" window is enabled.
EnableSSL | Gets or sets a value that determines whether to enable the SSL protocol.
Host | Gets or sets the SMTP host name or IP address.
MessageTemplate | Gets or sets the template that will be used to create a new message.
Name | Gets or sets the sender's name.
Password | Gets or sets the password.
Port | Gets or sets the SMTP port.
UseMAPI | Gets or sets a value that determines whether to use MAPI instead of SMTP when sending an email.
UserName | Gets or sets the user name.

See Also

EmailSettings Class
FastReport.Export.Email Namespace


EmailSettings Constructor

[image]

FastReport.Net Class Reference
EmailSettings Constructor
EmailSettings Class See Also Send Feedback
Initializes a new instance of the EmailSettings class with default settings.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EmailSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailSettings()

See Also

EmailSettings Class
FastReport.Export.Email Namespace


EmailSettings Methods

[image] [image]

FastReport.Net Class Reference
EmailSettings Methods
EmailSettings Class See Also Send Feedback

The EmailSettings type exposes the following members.

Methods

Name | Description
Assign | Copies email settings from another source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailSettings Class
FastReport.Export.Email Namespace


Assign Method

[image]

FastReport.Net Class Reference
EmailSettings..::.Assign Method
EmailSettings Class See Also Send Feedback
Copies email settings from another source.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    EmailSettings source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As EmailSettings _
)
Visual C++
public:
void Assign(
    EmailSettings^ source
)

Parameters

source
Type: FastReport.Export.Email..::.EmailSettings
Source to copy settings from.

See Also

EmailSettings Class
FastReport.Export.Email Namespace


EmailSettings Properties

[image] [image]

FastReport.Net Class Reference
EmailSettings Properties
EmailSettings Class See Also Send Feedback

The EmailSettings type exposes the following members.

Properties

Name | Description
Address | Gets or sets the sender's email address.
AllowUI | Gets or sets a value that determines whether the account setting page in the "Send Email" window is enabled.
EnableSSL | Gets or sets a value that determines whether to enable the SSL protocol.
Host | Gets or sets the SMTP host name or IP address.
MessageTemplate | Gets or sets the template that will be used to create a new message.
Name | Gets or sets the sender's name.
Password | Gets or sets the password.
Port | Gets or sets the SMTP port.
UseMAPI | Gets or sets a value that determines whether to use MAPI instead of SMTP when sending an email.
UserName | Gets or sets the user name.

See Also

EmailSettings Class
FastReport.Export.Email Namespace


Address Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Address Property
EmailSettings Class See Also Send Feedback
Gets or sets the sender's email address.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Address { get; set; }
Visual Basic (Declaration)
Public Property Address As String
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property contains your email address (for example, "john@site.com").

See Also

EmailSettings Class
FastReport.Export.Email Namespace


AllowUI Property

[image]

FastReport.Net Class Reference
EmailSettings..::.AllowUI Property
EmailSettings Class See Also Send Feedback
Gets or sets a value that determines whether the account setting page in the "Send Email" window is enabled.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowUI { get; set; }
Visual Basic (Declaration)
Public Property AllowUI As Boolean
Visual C++
public:
property bool AllowUI {
    bool get ();
    void set (bool value);
}

See Also

EmailSettings Class
FastReport.Export.Email Namespace


EnableSSL Property

[image]

FastReport.Net Class Reference
EmailSettings..::.EnableSSL Property
EmailSettings Class See Also Send Feedback
Gets or sets a value that determines whether to enable the SSL protocol.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool EnableSSL { get; set; }
Visual Basic (Declaration)
Public Property EnableSSL As Boolean
Visual C++
public:
property bool EnableSSL {
    bool get ();
    void set (bool value);
}

See Also

EmailSettings Class
FastReport.Export.Email Namespace


Host Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Host Property
EmailSettings Class See Also Send Feedback
Gets or sets the SMTP host name or IP address.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Host { get; set; }
Visual Basic (Declaration)
Public Property Host As String
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

See Also

EmailSettings Class
FastReport.Export.Email Namespace


MessageTemplate Property

[image]

FastReport.Net Class Reference
EmailSettings..::.MessageTemplate Property
EmailSettings Class See Also Send Feedback
Gets or sets the template that will be used to create a new message.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string MessageTemplate { get; set; }
Visual Basic (Declaration)
Public Property MessageTemplate As String
Visual C++
public:
property String^ MessageTemplate {
    String^ get ();
    void set (String^ value);
}

See Also

EmailSettings Class
FastReport.Export.Email Namespace


Name Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Name Property
EmailSettings Class See Also Send Feedback
Gets or sets the sender's name.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property contains your name (for example, "John Smith").

See Also

EmailSettings Class
FastReport.Export.Email Namespace


Password Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Password Property
EmailSettings Class See Also Send Feedback
Gets or sets the password.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Remarks

Specify the UserName and Password properties if your host requires authentication.

See Also

EmailSettings Class
FastReport.Export.Email Namespace


Port Property

[image]

FastReport.Net Class Reference
EmailSettings..::.Port Property
EmailSettings Class See Also Send Feedback
Gets or sets the SMTP port.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Port { get; set; }
Visual Basic (Declaration)
Public Property Port As Integer
Visual C++
public:
property int Port {
    int get ();
    void set (int value);
}

Remarks

The default value for this property is 25.

See Also

EmailSettings Class
FastReport.Export.Email Namespace


UseMAPI Property

[image]

FastReport.Net Class Reference
EmailSettings..::.UseMAPI Property
EmailSettings Class See Also Send Feedback
Gets or sets a value that determines whether to use MAPI instead of SMTP when sending an email.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseMAPI { get; set; }
Visual Basic (Declaration)
Public Property UseMAPI As Boolean
Visual C++
public:
property bool UseMAPI {
    bool get ();
    void set (bool value);
}

See Also

EmailSettings Class
FastReport.Export.Email Namespace


UserName Property

[image]

FastReport.Net Class Reference
EmailSettings..::.UserName Property
EmailSettings Class See Also Send Feedback
Gets or sets the user name.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Remarks

Specify the UserName and Password properties if your host requires authentication.

See Also

EmailSettings Class
FastReport.Export.Email Namespace


MAPI Class

[image]

FastReport.Net Class Reference
MAPI Class
Members See Also Send Feedback
Allows to send message using MAPI interface.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class MAPI
Visual Basic (Declaration)
Public NotInheritable Class MAPI
Visual C++
public ref class MAPI abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Export.Email..::.MAPI

See Also

MAPI Members
FastReport.Export.Email Namespace


MAPI Members

[image] [image]

FastReport.Net Class Reference
MAPI Members
MAPI Class Methods See Also Send Feedback

The MAPI type exposes the following members.

Methods

Name | Description
GetErrorText | Returns a text describing an error.
SendMail | Sends a message.

See Also

MAPI Class
FastReport.Export.Email Namespace


MAPI Methods

[image] [image]

FastReport.Net Class Reference
MAPI Methods
MAPI Class See Also Send Feedback

The MAPI type exposes the following members.

Methods

Name | Description
GetErrorText | Returns a text describing an error.
SendMail | Sends a message.

See Also

MAPI Class
FastReport.Export.Email Namespace


GetErrorText Method

[image]

FastReport.Net Class Reference
MAPI..::.GetErrorText Method
MAPI Class See Also Send Feedback
Returns a text describing an error.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string GetErrorText(
    int error
)
Visual Basic (Declaration)
Public Shared Function GetErrorText ( _
    error As Integer _
) As String
Visual C++
public:
static String^ GetErrorText(
    int error
)

Parameters

error
Type: System..::.Int32
The error code.

Return Value

The text describing an error.

See Also

MAPI Class
FastReport.Export.Email Namespace


SendMail Method

[image]

FastReport.Net Class Reference
MAPI..::.SendMail Method
MAPI Class See Also Send Feedback
Sends a message.

Namespace: FastReport.Export.Email
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int SendMail(
    IntPtr handle,
    string[] files,
    string mailSubject,
    string mailBody,
    string[] recipentName,
    string[] recipientAddress
)
Visual Basic (Declaration)
Public Shared Function SendMail ( _
    handle As IntPtr, _
    files As String(), _
    mailSubject As String, _
    mailBody As String, _
    recipentName As String(), _
    recipientAddress As String() _
) As Integer
Visual C++
public:
static int SendMail(
    IntPtr handle,
    array<String^>^ files,
    String^ mailSubject,
    String^ mailBody,
    array<String^>^ recipentName,
    array<String^>^ recipientAddress
)

Parameters

handle
Type: System..::.IntPtr
Parent window handle.
files
Type: array< System..::.String >[]()[]
Files to attach.
mailSubject
Type: System..::.String
Email subject.
mailBody
Type: System..::.String
Email body.
recipentName
Type: array< System..::.String >[]()[]
Recipient names.
recipientAddress
Type: array< System..::.String >[]()[]
Recipient addresses.

Return Value

Error code. 0 if operation was completed succesfully.

See Also

MAPI Class
FastReport.Export.Email Namespace


FastReport.Export.Html Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Html Namespace
Send Feedback

Classes

Class | Description
HTMLExport | Represents the HTML export filter.
HTMLPageData | For internal use only.
HtmlTemplates | Represents the HTML export templates.

Enumerations

Enumeration | Description
HTMLExportFormat | Represents the HTML export format enum
HtmlSizeUnits | Specifies the units of HTML sizes.
ImageFormat | Specifies the image format in HTML export.


HTMLExport Class

[image]

FastReport.Net Class Reference
HTMLExport Class
Members See Also Send Feedback
Represents the HTML export filter.
Represents the HTML export filter.
Represents the HTML export filter.
Represents the HTML export filter.
Represents the HTML export filter.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HTMLExport : ExportBase
Visual Basic (Declaration)
Public Class HTMLExport _
    Inherits ExportBase
Visual C++
public ref class HTMLExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Html..::.HTMLExport

See Also

HTMLExport Members
FastReport.Export.Html Namespace


HTMLExport Members

[image] [image]

FastReport.Net Class Reference
HTMLExport Members
HTMLExport Class Constructors Methods Properties Events See Also Send Feedback

The HTMLExport type exposes the following members.

Constructors

Name | Description
HTMLExport | Initializes a new instance of the HTMLExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init_WebMode | For internal use only.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
ProcessPage | Process Page with number p and real page ReportPage
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Count | For internal use only.
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Format | Specifies the output format
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
GeneratedStreams | Gets list of generated streams
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
HeightUnits | Specifies the height units in HTML export
ImageFormat | Gets or sets the image format.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layers | Enable or disable layers export mode
Name | Gets or sets the name of the object. (Inherited from Base.)
Navigator | Enable or disable the page navigator in html export
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Enable or disable the breaks between pages in print preview when single page mode is enabled
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Pictures | Enable or disable the pictures in HTML export
PreparedPages | For internal use only.
Print | Enable or disable showing of print dialog in browser when html document is opened
PrintPageData | Gets print page data
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
SaveStreams | Enable or disable saving streams in GeneratedStreams collection
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
SinglePage | Enable or disable the single HTML page creation
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
StylePrefix | For internal use only.
SubFolder | Enable or disable the sub-folder for files of export
WebImagePrefix | For internal use only.
WebImageSuffix | For internal use only.
WidthUnits | Specifies the width units in HTML export
Wysiwyg | Gets or sets the Wysiwyg quality of export
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HTMLExport Class
FastReport.Export.Html Namespace


HTMLExport Constructor

[image]

FastReport.Net Class Reference
HTMLExport Constructor
HTMLExport Class See Also Send Feedback
Initializes a new instance of the HTMLExport class.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HTMLExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HTMLExport()

See Also

HTMLExport Class
FastReport.Export.Html Namespace


HTMLExport Methods

[image] [image]

FastReport.Net Class Reference
HTMLExport Methods
HTMLExport Class See Also Send Feedback

The HTMLExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
Init_WebMode | For internal use only.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
ProcessPage | Process Page with number p and real page ReportPage
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
HTMLExport..::.Dispose Method
HTMLExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

HTMLExport Class
HTMLExport Members
FastReport.Export.Html Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
HTMLExport..::.Export Method
HTMLExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

HTMLExport Class
HTMLExport Members
FastReport.Export.Html Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
HTMLExport..::.ExportPage Method
HTMLExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Finish Method

[image]

FastReport.Net Class Reference
HTMLExport..::.Finish Method
HTMLExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

HTMLExport Class
FastReport.Export.Html Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
HTMLExport..::.GetFileFilter Method
HTMLExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Init_WebMode Method

[image]

FastReport.Net Class Reference
HTMLExport..::.Init_WebMode Method
HTMLExport Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Init_WebMode()
Visual Basic (Declaration)
Public Sub Init_WebMode
Visual C++
public:
void Init_WebMode()

See Also

HTMLExport Class
FastReport.Export.Html Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
HTMLExport..::.MemberwiseClone Method
HTMLExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

HTMLExport Class
HTMLExport Members
FastReport.Export.Html Namespace


ProcessPage Method

[image]

FastReport.Net Class Reference
HTMLExport..::.ProcessPage Method
HTMLExport Class See Also Send Feedback
Process Page with number p and real page ReportPage

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ProcessPage(
    int p,
    int ReportPage
)
Visual Basic (Declaration)
Public Sub ProcessPage ( _
    p As Integer, _
    ReportPage As Integer _
)
Visual C++
public:
void ProcessPage(
    int p,
    int ReportPage
)

Parameters

p
Type: System..::.Int32
ReportPage
Type: System..::.Int32

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Serialize Method

[image]

FastReport.Net Class Reference
HTMLExport..::.Serialize Method
HTMLExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

HTMLExport Class
FastReport.Export.Html Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
HTMLExport..::.ShowDialog Method
HTMLExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Start Method

[image]

FastReport.Net Class Reference
HTMLExport..::.Start Method
HTMLExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

HTMLExport Class
FastReport.Export.Html Namespace


HTMLExport Properties

[image] [image]

FastReport.Net Class Reference
HTMLExport Properties
HTMLExport Class See Also Send Feedback

The HTMLExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Count | For internal use only.
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Format | Specifies the output format
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
GeneratedStreams | Gets list of generated streams
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
HeightUnits | Specifies the height units in HTML export
ImageFormat | Gets or sets the image format.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layers | Enable or disable layers export mode
Name | Gets or sets the name of the object. (Inherited from Base.)
Navigator | Enable or disable the page navigator in html export
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Enable or disable the breaks between pages in print preview when single page mode is enabled
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Pictures | Enable or disable the pictures in HTML export
PreparedPages | For internal use only.
Print | Enable or disable showing of print dialog in browser when html document is opened
PrintPageData | Gets print page data
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
SaveStreams | Enable or disable saving streams in GeneratedStreams collection
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
SinglePage | Enable or disable the single HTML page creation
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
StylePrefix | For internal use only.
SubFolder | Enable or disable the sub-folder for files of export
WebImagePrefix | For internal use only.
WebImageSuffix | For internal use only.
WidthUnits | Specifies the width units in HTML export
Wysiwyg | Gets or sets the Wysiwyg quality of export
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Count Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Count Property
HTMLExport Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Format Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Format Property
HTMLExport Class See Also Send Feedback
Specifies the output format

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HTMLExportFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As HTMLExportFormat
Visual C++
public:
property HTMLExportFormat Format {
    HTMLExportFormat get ();
    void set (HTMLExportFormat value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


GeneratedStreams Property

[image]

FastReport.Net Class Reference
HTMLExport..::.GeneratedStreams Property
HTMLExport Class See Also Send Feedback
Gets list of generated streams

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<Stream> GeneratedStreams { get; }
Visual Basic (Declaration)
Public ReadOnly Property GeneratedStreams As List(Of Stream)
Visual C++
public:
property List<Stream^>^ GeneratedStreams {
    List<Stream^>^ get ();
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


HeightUnits Property

[image]

FastReport.Net Class Reference
HTMLExport..::.HeightUnits Property
HTMLExport Class See Also Send Feedback
Specifies the height units in HTML export

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HtmlSizeUnits HeightUnits { get; set; }
Visual Basic (Declaration)
Public Property HeightUnits As HtmlSizeUnits
Visual C++
public:
property HtmlSizeUnits HeightUnits {
    HtmlSizeUnits get ();
    void set (HtmlSizeUnits value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


ImageFormat Property

[image]

FastReport.Net Class Reference
HTMLExport..::.ImageFormat Property
HTMLExport Class See Also Send Feedback
Gets or sets the image format.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As ImageFormat
Visual C++
public:
property ImageFormat ImageFormat {
    ImageFormat get ();
    void set (ImageFormat value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Layers Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Layers Property
HTMLExport Class See Also Send Feedback
Enable or disable layers export mode

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Layers { get; set; }
Visual Basic (Declaration)
Public Property Layers As Boolean
Visual C++
public:
property bool Layers {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Navigator Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Navigator Property
HTMLExport Class See Also Send Feedback
Enable or disable the page navigator in html export

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Navigator { get; set; }
Visual Basic (Declaration)
Public Property Navigator As Boolean
Visual C++
public:
property bool Navigator {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


PageBreaks Property

[image]

FastReport.Net Class Reference
HTMLExport..::.PageBreaks Property
HTMLExport Class See Also Send Feedback
Enable or disable the breaks between pages in print preview when single page mode is enabled

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreaks { get; set; }
Visual Basic (Declaration)
Public Property PageBreaks As Boolean
Visual C++
public:
property bool PageBreaks {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Pictures Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Pictures Property
HTMLExport Class See Also Send Feedback
Enable or disable the pictures in HTML export

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Pictures { get; set; }
Visual Basic (Declaration)
Public Property Pictures As Boolean
Visual C++
public:
property bool Pictures {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


PreparedPages Property

[image]

FastReport.Net Class Reference
HTMLExport..::.PreparedPages Property
HTMLExport Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<HTMLPageData> PreparedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreparedPages As List(Of HTMLPageData)
Visual C++
public:
property List<HTMLPageData^>^ PreparedPages {
    List<HTMLPageData^>^ get ();
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Print Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Print Property
HTMLExport Class See Also Send Feedback
Enable or disable showing of print dialog in browser when html document is opened

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Print { get; set; }
Visual Basic (Declaration)
Public Property Print As Boolean
Visual C++
public:
property bool Print {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


PrintPageData Property

[image]

FastReport.Net Class Reference
HTMLExport..::.PrintPageData Property
HTMLExport Class See Also Send Feedback
Gets print page data

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HTMLPageData PrintPageData { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintPageData As HTMLPageData
Visual C++
public:
property HTMLPageData^ PrintPageData {
    HTMLPageData^ get ();
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


SaveStreams Property

[image]

FastReport.Net Class Reference
HTMLExport..::.SaveStreams Property
HTMLExport Class See Also Send Feedback
Enable or disable saving streams in GeneratedStreams collection

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SaveStreams { get; set; }
Visual Basic (Declaration)
Public Property SaveStreams As Boolean
Visual C++
public:
property bool SaveStreams {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


SinglePage Property

[image]

FastReport.Net Class Reference
HTMLExport..::.SinglePage Property
HTMLExport Class See Also Send Feedback
Enable or disable the single HTML page creation

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SinglePage { get; set; }
Visual Basic (Declaration)
Public Property SinglePage As Boolean
Visual C++
public:
property bool SinglePage {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


StylePrefix Property

[image]

FastReport.Net Class Reference
HTMLExport..::.StylePrefix Property
HTMLExport Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string StylePrefix { get; set; }
Visual Basic (Declaration)
Public Property StylePrefix As String
Visual C++
public:
property String^ StylePrefix {
    String^ get ();
    void set (String^ value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


SubFolder Property

[image]

FastReport.Net Class Reference
HTMLExport..::.SubFolder Property
HTMLExport Class See Also Send Feedback
Enable or disable the sub-folder for files of export

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SubFolder { get; set; }
Visual Basic (Declaration)
Public Property SubFolder As Boolean
Visual C++
public:
property bool SubFolder {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


WebImagePrefix Property

[image]

FastReport.Net Class Reference
HTMLExport..::.WebImagePrefix Property
HTMLExport Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string WebImagePrefix { get; set; }
Visual Basic (Declaration)
Public Property WebImagePrefix As String
Visual C++
public:
property String^ WebImagePrefix {
    String^ get ();
    void set (String^ value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


WebImageSuffix Property

[image]

FastReport.Net Class Reference
HTMLExport..::.WebImageSuffix Property
HTMLExport Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string WebImageSuffix { get; set; }
Visual Basic (Declaration)
Public Property WebImageSuffix As String
Visual C++
public:
property String^ WebImageSuffix {
    String^ get ();
    void set (String^ value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


WidthUnits Property

[image]

FastReport.Net Class Reference
HTMLExport..::.WidthUnits Property
HTMLExport Class See Also Send Feedback
Specifies the width units in HTML export

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HtmlSizeUnits WidthUnits { get; set; }
Visual Basic (Declaration)
Public Property WidthUnits As HtmlSizeUnits
Visual C++
public:
property HtmlSizeUnits WidthUnits {
    HtmlSizeUnits get ();
    void set (HtmlSizeUnits value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
HTMLExport..::.Wysiwyg Property
HTMLExport Class See Also Send Feedback
Gets or sets the Wysiwyg quality of export

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

See Also

HTMLExport Class
FastReport.Export.Html Namespace


HTMLExport Events

[image] [image]

FastReport.Net Class Reference
HTMLExport Events
HTMLExport Class See Also Send Feedback

The HTMLExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HTMLExport Class
FastReport.Export.Html Namespace


HTMLExportFormat Enumeration

[image]

FastReport.Net Class Reference
HTMLExportFormat Enumeration
See Also Send Feedback
Represents the HTML export format enum

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum HTMLExportFormat
Visual Basic (Declaration)
Public Enumeration HTMLExportFormat
Visual C++
public enum class HTMLExportFormat

Members

Member name | Description
MessageHTML | Represents the message-HTML type
HTML | Represents the HTML type

See Also

FastReport.Export.Html Namespace


HTMLPageData Class

[image]

FastReport.Net Class Reference
HTMLPageData Class
Members See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HTMLPageData
Visual Basic (Declaration)
Public Class HTMLPageData
Visual C++
public ref class HTMLPageData

Inheritance Hierarchy

System..::.Object
FastReport.Export.Html..::.HTMLPageData

See Also

HTMLPageData Members
FastReport.Export.Html Namespace


HTMLPageData Members

[image] [image]

FastReport.Net Class Reference
HTMLPageData Members
HTMLPageData Class Constructors Methods Properties See Also Send Feedback

The HTMLPageData type exposes the following members.

Constructors

Name | Description
HTMLPageData | For internal use only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CSSText | For internal use only.
Guids | For internal use only.
Height | For internal use only.
PageEvent | For internal use only.
PageNumber | For internal use only.
PageText | For internal use only.
Pictures | For internal use only.
Width | For internal use only.

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


HTMLPageData Constructor

[image]

FastReport.Net Class Reference
HTMLPageData Constructor
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HTMLPageData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HTMLPageData()

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


HTMLPageData Methods

[image] [image]

FastReport.Net Class Reference
HTMLPageData Methods
HTMLPageData Class See Also Send Feedback

The HTMLPageData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


HTMLPageData Properties

[image] [image]

FastReport.Net Class Reference
HTMLPageData Properties
HTMLPageData Class See Also Send Feedback

The HTMLPageData type exposes the following members.

Properties

Name | Description
CSSText | For internal use only.
Guids | For internal use only.
Height | For internal use only.
PageEvent | For internal use only.
PageNumber | For internal use only.
PageText | For internal use only.
Pictures | For internal use only.
Width | For internal use only.

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


CSSText Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.CSSText Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CSSText { get; set; }
Visual Basic (Declaration)
Public Property CSSText As String
Visual C++
public:
property String^ CSSText {
    String^ get ();
    void set (String^ value);
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


Guids Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.Guids Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<string> Guids { get; }
Visual Basic (Declaration)
Public ReadOnly Property Guids As List(Of String)
Visual C++
public:
property List<String^>^ Guids {
    List<String^>^ get ();
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


Height Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.Height Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Single
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


PageEvent Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.PageEvent Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ManualResetEvent PageEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageEvent As ManualResetEvent
Visual C++
public:
property ManualResetEvent^ PageEvent {
    ManualResetEvent^ get ();
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


PageNumber Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.PageNumber Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


PageText Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.PageText Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageText { get; set; }
Visual Basic (Declaration)
Public Property PageText As String
Visual C++
public:
property String^ PageText {
    String^ get ();
    void set (String^ value);
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


Pictures Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.Pictures Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<Stream> Pictures { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pictures As List(Of Stream)
Visual C++
public:
property List<Stream^>^ Pictures {
    List<Stream^>^ get ();
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


Width Property

[image]

FastReport.Net Class Reference
HTMLPageData..::.Width Property
HTMLPageData Class See Also Send Feedback
For internal use only.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

HTMLPageData Class
FastReport.Export.Html Namespace


HtmlSizeUnits Enumeration

[image]

FastReport.Net Class Reference
HtmlSizeUnits Enumeration
See Also Send Feedback
Specifies the units of HTML sizes.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum HtmlSizeUnits
Visual Basic (Declaration)
Public Enumeration HtmlSizeUnits
Visual C++
public enum class HtmlSizeUnits

Members

Member name | Description
Pixel | Specifies the pixel units.
Percent | Specifies the percent units.

See Also

FastReport.Export.Html Namespace


HtmlTemplates Class

[image]

FastReport.Net Class Reference
HtmlTemplates Class
Members See Also Send Feedback
Represents the HTML export templates.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class HtmlTemplates
Visual Basic (Declaration)
Public Class HtmlTemplates
Visual C++
public ref class HtmlTemplates

Inheritance Hierarchy

System..::.Object
FastReport.Export.Html..::.HtmlTemplates

See Also

HtmlTemplates Members
FastReport.Export.Html Namespace


HtmlTemplates Members

[image] [image]

FastReport.Net Class Reference
HtmlTemplates Members
HtmlTemplates Class Constructors Methods Properties See Also Send Feedback

The HtmlTemplates type exposes the following members.

Constructors

Name | Description
HtmlTemplates | Initializes a new instance of the HtmlTemplates class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IndexTemplate | Index Template
NavigatorTemplate | Navigator Template
OutlineTemplate | OutlineTemplate
PageTemplateFooter | Page Template Footer
PageTemplateTitle | Page Template Title

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


HtmlTemplates Constructor

[image]

FastReport.Net Class Reference
HtmlTemplates Constructor
HtmlTemplates Class See Also Send Feedback
Initializes a new instance of the HtmlTemplates class.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public HtmlTemplates()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HtmlTemplates()

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


HtmlTemplates Methods

[image] [image]

FastReport.Net Class Reference
HtmlTemplates Methods
HtmlTemplates Class See Also Send Feedback

The HtmlTemplates type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


HtmlTemplates Properties

[image] [image]

FastReport.Net Class Reference
HtmlTemplates Properties
HtmlTemplates Class See Also Send Feedback

The HtmlTemplates type exposes the following members.

Properties

Name | Description
IndexTemplate | Index Template
NavigatorTemplate | Navigator Template
OutlineTemplate | OutlineTemplate
PageTemplateFooter | Page Template Footer
PageTemplateTitle | Page Template Title

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


IndexTemplate Property

[image]

FastReport.Net Class Reference
HtmlTemplates..::.IndexTemplate Property
HtmlTemplates Class See Also Send Feedback
Index Template

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string IndexTemplate { get; set; }
Visual Basic (Declaration)
Public Property IndexTemplate As String
Visual C++
public:
property String^ IndexTemplate {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


NavigatorTemplate Property

[image]

FastReport.Net Class Reference
HtmlTemplates..::.NavigatorTemplate Property
HtmlTemplates Class See Also Send Feedback
Navigator Template

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string NavigatorTemplate { get; set; }
Visual Basic (Declaration)
Public Property NavigatorTemplate As String
Visual C++
public:
property String^ NavigatorTemplate {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


OutlineTemplate Property

[image]

FastReport.Net Class Reference
HtmlTemplates..::.OutlineTemplate Property
HtmlTemplates Class See Also Send Feedback
OutlineTemplate

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string OutlineTemplate { get; set; }
Visual Basic (Declaration)
Public Property OutlineTemplate As String
Visual C++
public:
property String^ OutlineTemplate {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


PageTemplateFooter Property

[image]

FastReport.Net Class Reference
HtmlTemplates..::.PageTemplateFooter Property
HtmlTemplates Class See Also Send Feedback
Page Template Footer

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageTemplateFooter { get; set; }
Visual Basic (Declaration)
Public Property PageTemplateFooter As String
Visual C++
public:
property String^ PageTemplateFooter {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


PageTemplateTitle Property

[image]

FastReport.Net Class Reference
HtmlTemplates..::.PageTemplateTitle Property
HtmlTemplates Class See Also Send Feedback
Page Template Title

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PageTemplateTitle { get; set; }
Visual Basic (Declaration)
Public Property PageTemplateTitle As String
Visual C++
public:
property String^ PageTemplateTitle {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTemplates Class
FastReport.Export.Html Namespace


ImageFormat Enumeration

[image]

FastReport.Net Class Reference
ImageFormat Enumeration
See Also Send Feedback
Specifies the image format in HTML export.

Namespace: FastReport.Export.Html
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ImageFormat
Visual Basic (Declaration)
Public Enumeration ImageFormat
Visual C++
public enum class ImageFormat

Members

Member name | Description
Bmp | Specifies the .bmp format.
Png | Specifies the .png format.
Jpeg | Specifies the .jpg format.
Gif | Specifies the .gif format.

See Also

FastReport.Export.Html Namespace


FastReport.Export.Image Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Image Namespace
Send Feedback

Classes

Class | Description
ImageExport | Represents the image export filter.

Enumerations

Enumeration | Description
ImageExportFormat | Specifies the image export format.


ImageExport Class

[image]

FastReport.Net Class Reference
ImageExport Class
Members See Also Send Feedback
Represents the image export filter.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ImageExport : ExportBase
Visual Basic (Declaration)
Public Class ImageExport _
    Inherits ExportBase
Visual C++
public ref class ImageExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Image..::.ImageExport

See Also

ImageExport Members
FastReport.Export.Image Namespace


ImageExport Members

[image] [image]

FastReport.Net Class Reference
ImageExport Members
ImageExport Class Constructors Methods Properties Events See Also Send Feedback

The ImageExport type exposes the following members.

Constructors

Name | Description
ImageExport | Initializes a new instance of the ImageExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
JpegQuality | Gets or sets the jpg image quality.
MonochromeTiff | Gets or sets a value that determines whether the Tiff export must produce monochrome image.
MonochromeTiffCompression | Gets or sets the compression method for a monochrome TIFF image.
MultiFrameTiff | Gets or sets the value determines whether to produce multi-frame tiff file.
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Resolution | Gets or sets image resolution, in dpi.
ResolutionX | Gets or sets horizontal image resolution, in dpi.
ResolutionY | Gets or sets vertical image resolution, in dpi.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
SeparateFiles | Gets or sets a value that determines whether to generate separate image file for each exported page.
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ImageExport Class
FastReport.Export.Image Namespace


ImageExport Constructor

[image]

FastReport.Net Class Reference
ImageExport Constructor
ImageExport Class See Also Send Feedback
Initializes a new instance of the ImageExport class.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageExport()

See Also

ImageExport Class
FastReport.Export.Image Namespace


ImageExport Methods

[image] [image]

FastReport.Net Class Reference
ImageExport Methods
ImageExport Class See Also Send Feedback

The ImageExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ImageExport Class
FastReport.Export.Image Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ImageExport..::.Dispose Method
ImageExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ImageExport Class
ImageExport Members
FastReport.Export.Image Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
ImageExport..::.Export Method
ImageExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

ImageExport Class
ImageExport Members
FastReport.Export.Image Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
ImageExport..::.ExportPage Method
ImageExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

ImageExport Class
FastReport.Export.Image Namespace


Finish Method

[image]

FastReport.Net Class Reference
ImageExport..::.Finish Method
ImageExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

ImageExport Class
FastReport.Export.Image Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
ImageExport..::.GetFileFilter Method
ImageExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

ImageExport Class
FastReport.Export.Image Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ImageExport..::.MemberwiseClone Method
ImageExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ImageExport Class
ImageExport Members
FastReport.Export.Image Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ImageExport..::.Serialize Method
ImageExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ImageExport Class
FastReport.Export.Image Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
ImageExport..::.ShowDialog Method
ImageExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

ImageExport Class
FastReport.Export.Image Namespace


Start Method

[image]

FastReport.Net Class Reference
ImageExport..::.Start Method
ImageExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

ImageExport Class
FastReport.Export.Image Namespace


ImageExport Properties

[image] [image]

FastReport.Net Class Reference
ImageExport Properties
ImageExport Class See Also Send Feedback

The ImageExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
JpegQuality | Gets or sets the jpg image quality.
MonochromeTiff | Gets or sets a value that determines whether the Tiff export must produce monochrome image.
MonochromeTiffCompression | Gets or sets the compression method for a monochrome TIFF image.
MultiFrameTiff | Gets or sets the value determines whether to produce multi-frame tiff file.
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Resolution | Gets or sets image resolution, in dpi.
ResolutionX | Gets or sets horizontal image resolution, in dpi.
ResolutionY | Gets or sets vertical image resolution, in dpi.
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
SeparateFiles | Gets or sets a value that determines whether to generate separate image file for each exported page.
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ImageExport Class
FastReport.Export.Image Namespace


ImageFormat Property

[image]

FastReport.Net Class Reference
ImageExport..::.ImageFormat Property
ImageExport Class See Also Send Feedback
Gets or sets the image format.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageExportFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As ImageExportFormat
Visual C++
public:
property ImageExportFormat ImageFormat {
    ImageExportFormat get ();
    void set (ImageExportFormat value);
}

See Also

ImageExport Class
FastReport.Export.Image Namespace


JpegQuality Property

[image]

FastReport.Net Class Reference
ImageExport..::.JpegQuality Property
ImageExport Class See Also Send Feedback
Gets or sets the jpg image quality.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Integer
Visual C++
public:
property int JpegQuality {
    int get ();
    void set (int value);
}

Remarks

This property is used if ImageFormat is set to Jpeg. By default it is set to 100. Use lesser value to decrease the jpg file size.

See Also

ImageExport Class
FastReport.Export.Image Namespace


MonochromeTiff Property

[image]

FastReport.Net Class Reference
ImageExport..::.MonochromeTiff Property
ImageExport Class See Also Send Feedback
Gets or sets a value that determines whether the Tiff export must produce monochrome image.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MonochromeTiff { get; set; }
Visual Basic (Declaration)
Public Property MonochromeTiff As Boolean
Visual C++
public:
property bool MonochromeTiff {
    bool get ();
    void set (bool value);
}

Remarks

Monochrome tiff image is compressed using the compression method specified in the MonochromeTiffCompression property.

See Also

ImageExport Class
FastReport.Export.Image Namespace


MonochromeTiffCompression Property

[image]

FastReport.Net Class Reference
ImageExport..::.MonochromeTiffCompression Property
ImageExport Class See Also Send Feedback
Gets or sets the compression method for a monochrome TIFF image.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EncoderValue MonochromeTiffCompression { get; set; }
Visual Basic (Declaration)
Public Property MonochromeTiffCompression As EncoderValue
Visual C++
public:
property EncoderValue MonochromeTiffCompression {
    EncoderValue get ();
    void set (EncoderValue value);
}

Remarks

This property is used only when exporting to TIFF image, and the MonochromeTiff property is set to true.

The valid values for this property are: EncoderValue.CompressionNone, EncoderValue.CompressionLZW, EncoderValue.CompressionRle, EncoderValue.CompressionCCITT3, EncoderValue.CompressionCCITT4. The default compression method is CCITT4.

See Also

ImageExport Class
FastReport.Export.Image Namespace


MultiFrameTiff Property

[image]

FastReport.Net Class Reference
ImageExport..::.MultiFrameTiff Property
ImageExport Class See Also Send Feedback
Gets or sets the value determines whether to produce multi-frame tiff file.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MultiFrameTiff { get; set; }
Visual Basic (Declaration)
Public Property MultiFrameTiff As Boolean
Visual C++
public:
property bool MultiFrameTiff {
    bool get ();
    void set (bool value);
}

See Also

ImageExport Class
FastReport.Export.Image Namespace


Resolution Property

[image]

FastReport.Net Class Reference
ImageExport..::.Resolution Property
ImageExport Class See Also Send Feedback
Gets or sets image resolution, in dpi.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Resolution { get; set; }
Visual Basic (Declaration)
Public Property Resolution As Integer
Visual C++
public:
property int Resolution {
    int get ();
    void set (int value);
}

Remarks

By default this property is set to 96 dpi. Use bigger values (300-600 dpi) if you going to print the exported images.

See Also

ImageExport Class
FastReport.Export.Image Namespace


ResolutionX Property

[image]

FastReport.Net Class Reference
ImageExport..::.ResolutionX Property
ImageExport Class See Also Send Feedback
Gets or sets horizontal image resolution, in dpi.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ResolutionX { get; set; }
Visual Basic (Declaration)
Public Property ResolutionX As Integer
Visual C++
public:
property int ResolutionX {
    int get ();
    void set (int value);
}

Remarks

Separate horizontal and vertical resolution is used when exporting to TIFF. In other cases, use the Resolution property instead.

See Also

ImageExport Class
FastReport.Export.Image Namespace


ResolutionY Property

[image]

FastReport.Net Class Reference
ImageExport..::.ResolutionY Property
ImageExport Class See Also Send Feedback
Gets or sets vertical image resolution, in dpi.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ResolutionY { get; set; }
Visual Basic (Declaration)
Public Property ResolutionY As Integer
Visual C++
public:
property int ResolutionY {
    int get ();
    void set (int value);
}

Remarks

Separate horizontal and vertical resolution is used when exporting to TIFF. In other cases, use the Resolution property instead.

See Also

ImageExport Class
FastReport.Export.Image Namespace


SeparateFiles Property

[image]

FastReport.Net Class Reference
ImageExport..::.SeparateFiles Property
ImageExport Class See Also Send Feedback
Gets or sets a value that determines whether to generate separate image file for each exported page.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SeparateFiles { get; set; }
Visual Basic (Declaration)
Public Property SeparateFiles As Boolean
Visual C++
public:
property bool SeparateFiles {
    bool get ();
    void set (bool value);
}

Remarks

If this property is set to true, the export filter will produce one big image containing all exported pages. Be careful using this property with a big report because it may produce out of memory error.

See Also

ImageExport Class
FastReport.Export.Image Namespace


ImageExport Events

[image] [image]

FastReport.Net Class Reference
ImageExport Events
ImageExport Class See Also Send Feedback

The ImageExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ImageExport Class
FastReport.Export.Image Namespace


ImageExportFormat Enumeration

[image]

FastReport.Net Class Reference
ImageExportFormat Enumeration
See Also Send Feedback
Specifies the image export format.

Namespace: FastReport.Export.Image
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ImageExportFormat
Visual Basic (Declaration)
Public Enumeration ImageExportFormat
Visual C++
public enum class ImageExportFormat

Members

Member name | Description
Bmp | Specifies the .bmp format.
Png | Specifies the .png format.
Jpeg | Specifies the .jpg format.
Gif | Specifies the .gif format.
Tiff | Specifies the .tif format.
Metafile | Specifies the .emf format.

See Also

FastReport.Export.Image Namespace


FastReport.Export.Mht Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Mht Namespace
Send Feedback

Classes

Class | Description
MHTExport | Represents the MHT export filter.


MHTExport Class

[image]

FastReport.Net Class Reference
MHTExport Class
Members See Also Send Feedback
Represents the MHT export filter.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MHTExport : ExportBase
Visual Basic (Declaration)
Public Class MHTExport _
    Inherits ExportBase
Visual C++
public ref class MHTExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Mht..::.MHTExport

See Also

MHTExport Members
FastReport.Export.Mht Namespace


MHTExport Members

[image] [image]

FastReport.Net Class Reference
MHTExport Members
MHTExport Class Constructors Methods Properties Events See Also Send Feedback

The MHTExport type exposes the following members.

Constructors

Name | Description
MHTExport | Initializes a new instance of the MHTExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Pictures | Enable or disable the pictures in MHT export
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets the Wysiwyg quality of export
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MHTExport Class
FastReport.Export.Mht Namespace


MHTExport Constructor

[image]

FastReport.Net Class Reference
MHTExport Constructor
MHTExport Class See Also Send Feedback
Initializes a new instance of the MHTExport class.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MHTExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MHTExport()

See Also

MHTExport Class
FastReport.Export.Mht Namespace


MHTExport Methods

[image] [image]

FastReport.Net Class Reference
MHTExport Methods
MHTExport Class See Also Send Feedback

The MHTExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

MHTExport Class
FastReport.Export.Mht Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MHTExport..::.Dispose Method
MHTExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

MHTExport Class
MHTExport Members
FastReport.Export.Mht Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
MHTExport..::.Export Method
MHTExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

MHTExport Class
MHTExport Members
FastReport.Export.Mht Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
MHTExport..::.ExportPage Method
MHTExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

MHTExport Class
FastReport.Export.Mht Namespace


Finish Method

[image]

FastReport.Net Class Reference
MHTExport..::.Finish Method
MHTExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

MHTExport Class
FastReport.Export.Mht Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
MHTExport..::.GetFileFilter Method
MHTExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

MHTExport Class
FastReport.Export.Mht Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MHTExport..::.MemberwiseClone Method
MHTExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MHTExport Class
MHTExport Members
FastReport.Export.Mht Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
MHTExport..::.ShowDialog Method
MHTExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

MHTExport Class
FastReport.Export.Mht Namespace


Start Method

[image]

FastReport.Net Class Reference
MHTExport..::.Start Method
MHTExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

MHTExport Class
FastReport.Export.Mht Namespace


MHTExport Properties

[image] [image]

FastReport.Net Class Reference
MHTExport Properties
MHTExport Class See Also Send Feedback

The MHTExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Pictures | Enable or disable the pictures in MHT export
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets the Wysiwyg quality of export
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MHTExport Class
FastReport.Export.Mht Namespace


ImageFormat Property

[image]

FastReport.Net Class Reference
MHTExport..::.ImageFormat Property
MHTExport Class See Also Send Feedback
Gets or sets the image format.

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As ImageFormat
Visual C++
public:
property ImageFormat ImageFormat {
    ImageFormat get ();
    void set (ImageFormat value);
}

See Also

MHTExport Class
FastReport.Export.Mht Namespace


Pictures Property

[image]

FastReport.Net Class Reference
MHTExport..::.Pictures Property
MHTExport Class See Also Send Feedback
Enable or disable the pictures in MHT export

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Pictures { get; set; }
Visual Basic (Declaration)
Public Property Pictures As Boolean
Visual C++
public:
property bool Pictures {
    bool get ();
    void set (bool value);
}

See Also

MHTExport Class
FastReport.Export.Mht Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
MHTExport..::.Wysiwyg Property
MHTExport Class See Also Send Feedback
Gets or sets the Wysiwyg quality of export

Namespace: FastReport.Export.Mht
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

See Also

MHTExport Class
FastReport.Export.Mht Namespace


MHTExport Events

[image] [image]

FastReport.Net Class Reference
MHTExport Events
MHTExport Class See Also Send Feedback

The MHTExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MHTExport Class
FastReport.Export.Mht Namespace


FastReport.Export.Odf Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Odf Namespace
Send Feedback

Classes

Class | Description
ODFExport | Base class for any ODF exports
ODSExport | Open Document Spreadsheet export (Open Office Calc)
ODTExport | Open Document Text export (Open Office Writer)


ODFExport Class

[image]

FastReport.Net Class Reference
ODFExport Class
Members See Also Send Feedback
Base class for any ODF exports

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ODFExport : ExportBase
Visual Basic (Declaration)
Public Class ODFExport _
    Inherits ExportBase
Visual C++
public ref class ODFExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Odf..::.ODFExport
FastReport.Export.Odf..::.ODSExport
FastReport.Export.Odf..::.ODTExport

See Also

ODFExport Members
FastReport.Export.Odf Namespace


ODFExport Members

[image] [image]

FastReport.Net Class Reference
ODFExport Members
ODFExport Class Constructors Methods Properties Events See Also Send Feedback

The ODFExport type exposes the following members.

Constructors

Name | Description
ODFExport | Initializes a new instance of the ODFExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Inherited from ExportBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Switch of page breaks
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Wysiwyg mode, set for better results
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ODFExport Class
FastReport.Export.Odf Namespace


ODFExport Constructor

[image]

FastReport.Net Class Reference
ODFExport Constructor
ODFExport Class See Also Send Feedback
Initializes a new instance of the ODFExport class.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ODFExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ODFExport()

See Also

ODFExport Class
FastReport.Export.Odf Namespace


ODFExport Methods

[image] [image]

FastReport.Net Class Reference
ODFExport Methods
ODFExport Class See Also Send Feedback

The ODFExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Inherited from ExportBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ODFExport Class
FastReport.Export.Odf Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ODFExport..::.Dispose Method
ODFExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ODFExport Class
ODFExport Members
FastReport.Export.Odf Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
ODFExport..::.Export Method
ODFExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

ODFExport Class
ODFExport Members
FastReport.Export.Odf Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
ODFExport..::.ExportPage Method
ODFExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

ODFExport Class
FastReport.Export.Odf Namespace


Finish Method

[image]

FastReport.Net Class Reference
ODFExport..::.Finish Method
ODFExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

ODFExport Class
FastReport.Export.Odf Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ODFExport..::.MemberwiseClone Method
ODFExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ODFExport Class
ODFExport Members
FastReport.Export.Odf Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ODFExport..::.Serialize Method
ODFExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ODFExport Class
FastReport.Export.Odf Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
ODFExport..::.ShowDialog Method
ODFExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

ODFExport Class
FastReport.Export.Odf Namespace


Start Method

[image]

FastReport.Net Class Reference
ODFExport..::.Start Method
ODFExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

ODFExport Class
FastReport.Export.Odf Namespace


ODFExport Properties

[image] [image]

FastReport.Net Class Reference
ODFExport Properties
ODFExport Class See Also Send Feedback

The ODFExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Switch of page breaks
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Wysiwyg mode, set for better results
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ODFExport Class
FastReport.Export.Odf Namespace


Creator Property

[image]

FastReport.Net Class Reference
ODFExport..::.Creator Property
ODFExport Class See Also Send Feedback
Creator of the document

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Creator { get; set; }
Visual Basic (Declaration)
Public Property Creator As String
Visual C++
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}

See Also

ODFExport Class
FastReport.Export.Odf Namespace


PageBreaks Property

[image]

FastReport.Net Class Reference
ODFExport..::.PageBreaks Property
ODFExport Class See Also Send Feedback
Switch of page breaks

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreaks { get; set; }
Visual Basic (Declaration)
Public Property PageBreaks As Boolean
Visual C++
public:
property bool PageBreaks {
    bool get ();
    void set (bool value);
}

See Also

ODFExport Class
FastReport.Export.Odf Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
ODFExport..::.Wysiwyg Property
ODFExport Class See Also Send Feedback
Wysiwyg mode, set for better results

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

See Also

ODFExport Class
FastReport.Export.Odf Namespace


ODFExport Events

[image] [image]

FastReport.Net Class Reference
ODFExport Events
ODFExport Class See Also Send Feedback

The ODFExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ODFExport Class
FastReport.Export.Odf Namespace


ODSExport Class

[image]

FastReport.Net Class Reference
ODSExport Class
Members See Also Send Feedback
Open Document Spreadsheet export (Open Office Calc)

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ODSExport : ODFExport
Visual Basic (Declaration)
Public Class ODSExport _
    Inherits ODFExport
Visual C++
public ref class ODSExport : public ODFExport

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Odf..::.ODFExport
FastReport.Export.Odf..::.ODSExport

See Also

ODSExport Members
FastReport.Export.Odf Namespace


ODSExport Members

[image] [image]

FastReport.Net Class Reference
ODSExport Members
ODSExport Class Constructors Methods Properties Events See Also Send Feedback

The ODSExport type exposes the following members.

Constructors

Name | Description
ODSExport | Initializes a new instance of the ODSExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Inherited from ODFExport.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ODFExport.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ODFExport.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Inherited from ODFExport.)
Start | This method is called when the export starts. (Inherited from ODFExport.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document (Inherited from ODFExport.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Switch of page breaks (Inherited from ODFExport.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Wysiwyg mode, set for better results (Inherited from ODFExport.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ODSExport Class
FastReport.Export.Odf Namespace


ODSExport Constructor

[image]

FastReport.Net Class Reference
ODSExport Constructor
ODSExport Class See Also Send Feedback
Initializes a new instance of the ODSExport class.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ODSExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ODSExport()

See Also

ODSExport Class
FastReport.Export.Odf Namespace


ODSExport Methods

[image] [image]

FastReport.Net Class Reference
ODSExport Methods
ODSExport Class See Also Send Feedback

The ODSExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Inherited from ODFExport.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ODFExport.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ODFExport.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Inherited from ODFExport.)
Start | This method is called when the export starts. (Inherited from ODFExport.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ODSExport Class
FastReport.Export.Odf Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ODSExport..::.Dispose Method
ODSExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ODSExport Class
ODSExport Members
FastReport.Export.Odf Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
ODSExport..::.Export Method
ODSExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

ODSExport Class
ODSExport Members
FastReport.Export.Odf Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
ODSExport..::.GetFileFilter Method
ODSExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

ODSExport Class
FastReport.Export.Odf Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ODSExport..::.MemberwiseClone Method
ODSExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ODSExport Class
ODSExport Members
FastReport.Export.Odf Namespace


ODSExport Properties

[image] [image]

FastReport.Net Class Reference
ODSExport Properties
ODSExport Class See Also Send Feedback

The ODSExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document (Inherited from ODFExport.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Switch of page breaks (Inherited from ODFExport.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Wysiwyg mode, set for better results (Inherited from ODFExport.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ODSExport Class
FastReport.Export.Odf Namespace


ODSExport Events

[image] [image]

FastReport.Net Class Reference
ODSExport Events
ODSExport Class See Also Send Feedback

The ODSExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ODSExport Class
FastReport.Export.Odf Namespace


ODTExport Class

[image]

FastReport.Net Class Reference
ODTExport Class
Members See Also Send Feedback
Open Document Text export (Open Office Writer)

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ODTExport : ODFExport
Visual Basic (Declaration)
Public Class ODTExport _
    Inherits ODFExport
Visual C++
public ref class ODTExport : public ODFExport

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Odf..::.ODFExport
FastReport.Export.Odf..::.ODTExport

See Also

ODTExport Members
FastReport.Export.Odf Namespace


ODTExport Members

[image] [image]

FastReport.Net Class Reference
ODTExport Members
ODTExport Class Constructors Methods Properties Events See Also Send Feedback

The ODTExport type exposes the following members.

Constructors

Name | Description
ODTExport | Initializes a new instance of the ODTExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Inherited from ODFExport.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ODFExport.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ODFExport.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Inherited from ODFExport.)
Start | This method is called when the export starts. (Inherited from ODFExport.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document (Inherited from ODFExport.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Switch of page breaks (Inherited from ODFExport.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Wysiwyg mode, set for better results (Inherited from ODFExport.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ODTExport Class
FastReport.Export.Odf Namespace


ODTExport Constructor

[image]

FastReport.Net Class Reference
ODTExport Constructor
ODTExport Class See Also Send Feedback
Initializes a new instance of the ODTExport class.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ODTExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ODTExport()

See Also

ODTExport Class
FastReport.Export.Odf Namespace


ODTExport Methods

[image] [image]

FastReport.Net Class Reference
ODTExport Methods
ODTExport Class See Also Send Feedback

The ODTExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Inherited from ODFExport.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ODFExport.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ODFExport.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Inherited from ODFExport.)
Start | This method is called when the export starts. (Inherited from ODFExport.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ODTExport Class
FastReport.Export.Odf Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ODTExport..::.Dispose Method
ODTExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ODTExport Class
ODTExport Members
FastReport.Export.Odf Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
ODTExport..::.Export Method
ODTExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

ODTExport Class
ODTExport Members
FastReport.Export.Odf Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
ODTExport..::.GetFileFilter Method
ODTExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Odf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

ODTExport Class
FastReport.Export.Odf Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ODTExport..::.MemberwiseClone Method
ODTExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ODTExport Class
ODTExport Members
FastReport.Export.Odf Namespace


ODTExport Properties

[image] [image]

FastReport.Net Class Reference
ODTExport Properties
ODTExport Class See Also Send Feedback

The ODTExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document (Inherited from ODFExport.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Switch of page breaks (Inherited from ODFExport.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Wysiwyg mode, set for better results (Inherited from ODFExport.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ODTExport Class
FastReport.Export.Odf Namespace


ODTExport Events

[image] [image]

FastReport.Net Class Reference
ODTExport Events
ODTExport Class See Also Send Feedback

The ODTExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ODTExport Class
FastReport.Export.Odf Namespace


FastReport.Export.OoXML Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.OoXML Namespace
Send Feedback

Classes

Class | Description
Excel2007Export | Excel 2007 export class
OOExportBase | Base class for Microsoft Office 2007 export objects
PowerPoint2007Export | Represents the PowerPoint 2007 export.
Word2007Export | MS Word 2007 export class
XPSExport | Main class of XML export

Enumerations

Enumeration | Description
PptImageFormat | Specifies the image format in PowerPoint export.


Excel2007Export Class

[image]

FastReport.Net Class Reference
Excel2007Export Class
Members See Also Send Feedback
Excel 2007 export class

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Excel2007Export : OOExportBase
Visual Basic (Declaration)
Public Class Excel2007Export _
    Inherits OOExportBase
Visual C++
public ref class Excel2007Export : public OOExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.OoXML..::.OOExportBase
FastReport.Export.OoXML..::.Excel2007Export

See Also

Excel2007Export Members
FastReport.Export.OoXML Namespace


Excel2007Export Members

[image] [image]

FastReport.Net Class Reference
Excel2007Export Members
Excel2007Export Class Constructors Methods Fields Properties Events See Also Send Feedback

The Excel2007Export type exposes the following members.

Constructors

Name | Description
Excel2007Export | Initializes a new instance of the class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Gets or sets a value that determines whether to insert page breaks in the output file or not.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Excel2007Export Constructor

[image]

FastReport.Net Class Reference
Excel2007Export Constructor
Excel2007Export Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Excel2007Export()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Excel2007Export()

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Excel2007Export Fields

[image] [image]

FastReport.Net Class Reference
Excel2007Export Fields
Excel2007Export Class See Also Send Feedback

The Excel2007Export type exposes the following members.

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Excel2007Export Methods

[image] [image]

FastReport.Net Class Reference
Excel2007Export Methods
Excel2007Export Class See Also Send Feedback

The Excel2007Export type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Excel2007Export..::.Dispose Method
Excel2007Export Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Excel2007Export Class
Excel2007Export Members
FastReport.Export.OoXML Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
Excel2007Export..::.Export Method
Excel2007Export Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

Excel2007Export Class
Excel2007Export Members
FastReport.Export.OoXML Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
Excel2007Export..::.ExportPage Method
Excel2007Export Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Finish Method

[image]

FastReport.Net Class Reference
Excel2007Export..::.Finish Method
Excel2007Export Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
Excel2007Export..::.GetFileFilter Method
Excel2007Export Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Excel2007Export..::.MemberwiseClone Method
Excel2007Export Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Excel2007Export Class
Excel2007Export Members
FastReport.Export.OoXML Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Excel2007Export..::.Serialize Method
Excel2007Export Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
Excel2007Export..::.ShowDialog Method
Excel2007Export Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Start Method

[image]

FastReport.Net Class Reference
Excel2007Export..::.Start Method
Excel2007Export Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Excel2007Export Properties

[image] [image]

FastReport.Net Class Reference
Excel2007Export Properties
Excel2007Export Class See Also Send Feedback

The Excel2007Export type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Gets or sets a value that determines whether to insert page breaks in the output file or not.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


DataOnly Property

[image]

FastReport.Net Class Reference
Excel2007Export..::.DataOnly Property
Excel2007Export Class See Also Send Feedback
Gets or sets a value that determines whether to export the databand rows only.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DataOnly { get; set; }
Visual Basic (Declaration)
Public Property DataOnly As Boolean
Visual C++
public:
property bool DataOnly {
    bool get ();
    void set (bool value);
}

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


PageBreaks Property

[image]

FastReport.Net Class Reference
Excel2007Export..::.PageBreaks Property
Excel2007Export Class See Also Send Feedback
Gets or sets a value that determines whether to insert page breaks in the output file or not.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreaks { get; set; }
Visual Basic (Declaration)
Public Property PageBreaks As Boolean
Visual C++
public:
property bool PageBreaks {
    bool get ();
    void set (bool value);
}

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
Excel2007Export..::.Wysiwyg Property
Excel2007Export Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting Excel file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


Excel2007Export Events

[image] [image]

FastReport.Net Class Reference
Excel2007Export Events
Excel2007Export Class See Also Send Feedback

The Excel2007Export type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Excel2007Export Class
FastReport.Export.OoXML Namespace


OOExportBase Class

[image]

FastReport.Net Class Reference
OOExportBase Class
Members See Also Send Feedback
Base class for Microsoft Office 2007 export objects

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class OOExportBase : ExportBase
Visual Basic (Declaration)
Public Class OOExportBase _
    Inherits ExportBase
Visual C++
public ref class OOExportBase : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.OoXML..::.OOExportBase
FastReport.Export.OoXML..::.Excel2007Export
FastReport.Export.OoXML..::.PowerPoint2007Export
FastReport.Export.OoXML..::.Word2007Export
FastReport.Export.OoXML..::.XPSExport

See Also

OOExportBase Members
FastReport.Export.OoXML Namespace


OOExportBase Members

[image] [image]

FastReport.Net Class Reference
OOExportBase Members
OOExportBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The OOExportBase type exposes the following members.

Constructors

Name | Description
OOExportBase | Initializes a new instance of the OOExportBase class

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Inherited from ExportBase.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ExportBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Inherited from ExportBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Inherited from ExportBase.)
Start | This method is called when the export starts. (Inherited from ExportBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
FTempFolder | Temporary folder for export files
xml_header | Default XML header

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


OOExportBase Constructor

[image]

FastReport.Net Class Reference
OOExportBase Constructor
OOExportBase Class See Also Send Feedback
Initializes a new instance of the OOExportBase class

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public OOExportBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OOExportBase()

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


OOExportBase Fields

[image] [image]

FastReport.Net Class Reference
OOExportBase Fields
OOExportBase Class See Also Send Feedback

The OOExportBase type exposes the following members.

Fields

Name | Description
FTempFolder | Temporary folder for export files
xml_header | Default XML header

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


FTempFolder Field

[image]

FastReport.Net Class Reference
OOExportBase..::.FTempFolder Field
OOExportBase Class See Also Send Feedback
Temporary folder for export files

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected string FTempFolder
Visual Basic (Declaration)
Protected FTempFolder As String
Visual C++
protected:
String^ FTempFolder

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


xml_header Field

[image]

FastReport.Net Class Reference
OOExportBase..::.xml_header Field
OOExportBase Class See Also Send Feedback
Default XML header

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected const string xml_header
Visual Basic (Declaration)
Protected Const xml_header As String
Visual C++
protected:
literal String^ xml_header

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


OOExportBase Methods

[image] [image]

FastReport.Net Class Reference
OOExportBase Methods
OOExportBase Class See Also Send Feedback

The OOExportBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Inherited from ExportBase.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Inherited from ExportBase.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Inherited from ExportBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Inherited from ExportBase.)
Start | This method is called when the export starts. (Inherited from ExportBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
OOExportBase..::.Dispose Method
OOExportBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

OOExportBase Class
OOExportBase Members
FastReport.Export.OoXML Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
OOExportBase..::.Export Method
OOExportBase Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

OOExportBase Class
OOExportBase Members
FastReport.Export.OoXML Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
OOExportBase..::.MemberwiseClone Method
OOExportBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OOExportBase Class
OOExportBase Members
FastReport.Export.OoXML Namespace


OOExportBase Properties

[image] [image]

FastReport.Net Class Reference
OOExportBase Properties
OOExportBase Class See Also Send Feedback

The OOExportBase type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


OOExportBase Events

[image] [image]

FastReport.Net Class Reference
OOExportBase Events
OOExportBase Class See Also Send Feedback

The OOExportBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OOExportBase Class
FastReport.Export.OoXML Namespace


PowerPoint2007Export Class

[image]

FastReport.Net Class Reference
PowerPoint2007Export Class
Members See Also Send Feedback
Represents the PowerPoint 2007 export.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PowerPoint2007Export : OOExportBase
Visual Basic (Declaration)
Public Class PowerPoint2007Export _
    Inherits OOExportBase
Visual C++
public ref class PowerPoint2007Export : public OOExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.OoXML..::.OOExportBase
FastReport.Export.OoXML..::.PowerPoint2007Export

See Also

PowerPoint2007Export Members
FastReport.Export.OoXML Namespace


PowerPoint2007Export Members

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export Members
PowerPoint2007Export Class Constructors Methods Fields Properties Events See Also Send Feedback

The PowerPoint2007Export type exposes the following members.

Constructors

Name | Description
PowerPoint2007Export | Creates a new instance of the PowerPoint2007Export class with the default settings.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format used when exporting.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


PowerPoint2007Export Constructor

[image]

FastReport.Net Class Reference
PowerPoint2007Export Constructor
PowerPoint2007Export Class See Also Send Feedback
Creates a new instance of the PowerPoint2007Export class with the default settings.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PowerPoint2007Export()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PowerPoint2007Export()

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


PowerPoint2007Export Fields

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export Fields
PowerPoint2007Export Class See Also Send Feedback

The PowerPoint2007Export type exposes the following members.

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


PowerPoint2007Export Methods

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export Methods
PowerPoint2007Export Class See Also Send Feedback

The PowerPoint2007Export type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export..::.Dispose Method
PowerPoint2007Export Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PowerPoint2007Export Class
PowerPoint2007Export Members
FastReport.Export.OoXML Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export..::.Export Method
PowerPoint2007Export Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

PowerPoint2007Export Class
PowerPoint2007Export Members
FastReport.Export.OoXML Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.ExportPage Method
PowerPoint2007Export Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


Finish Method

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.Finish Method
PowerPoint2007Export Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.GetFileFilter Method
PowerPoint2007Export Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export..::.MemberwiseClone Method
PowerPoint2007Export Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PowerPoint2007Export Class
PowerPoint2007Export Members
FastReport.Export.OoXML Namespace


Serialize Method

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.Serialize Method
PowerPoint2007Export Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.ShowDialog Method
PowerPoint2007Export Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


Start Method

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.Start Method
PowerPoint2007Export Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


PowerPoint2007Export Properties

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export Properties
PowerPoint2007Export Class See Also Send Feedback

The PowerPoint2007Export type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format used when exporting.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


ImageFormat Property

[image]

FastReport.Net Class Reference
PowerPoint2007Export..::.ImageFormat Property
PowerPoint2007Export Class See Also Send Feedback
Gets or sets the image format used when exporting.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PptImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As PptImageFormat
Visual C++
public:
property PptImageFormat ImageFormat {
    PptImageFormat get ();
    void set (PptImageFormat value);
}

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


PowerPoint2007Export Events

[image] [image]

FastReport.Net Class Reference
PowerPoint2007Export Events
PowerPoint2007Export Class See Also Send Feedback

The PowerPoint2007Export type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PowerPoint2007Export Class
FastReport.Export.OoXML Namespace


PptImageFormat Enumeration

[image]

FastReport.Net Class Reference
PptImageFormat Enumeration
See Also Send Feedback
Specifies the image format in PowerPoint export.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PptImageFormat
Visual Basic (Declaration)
Public Enumeration PptImageFormat
Visual C++
public enum class PptImageFormat

Members

Member name | Description
Png | Specifies the .png format.
Jpeg | Specifies the .jpg format.

See Also

FastReport.Export.OoXML Namespace


Word2007Export Class

[image]

FastReport.Net Class Reference
Word2007Export Class
Members See Also Send Feedback
MS Word 2007 export class

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Word2007Export : OOExportBase
Visual Basic (Declaration)
Public Class Word2007Export _
    Inherits OOExportBase
Visual C++
public ref class Word2007Export : public OOExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.OoXML..::.OOExportBase
FastReport.Export.OoXML..::.Word2007Export

See Also

Word2007Export Members
FastReport.Export.OoXML Namespace


Word2007Export Members

[image] [image]

FastReport.Net Class Reference
Word2007Export Members
Word2007Export Class Constructors Methods Fields Properties Events See Also Send Feedback

The Word2007Export type exposes the following members.

Constructors

Name | Description
Word2007Export | Initializes a new instance of the Word2007Export class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
MatrixBased | Enable or disable matrix view of document
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Word2007Export Constructor

[image]

FastReport.Net Class Reference
Word2007Export Constructor
Word2007Export Class See Also Send Feedback
Initializes a new instance of the Word2007Export class.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Word2007Export()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Word2007Export()

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Word2007Export Fields

[image] [image]

FastReport.Net Class Reference
Word2007Export Fields
Word2007Export Class See Also Send Feedback

The Word2007Export type exposes the following members.

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Word2007Export Methods

[image] [image]

FastReport.Net Class Reference
Word2007Export Methods
Word2007Export Class See Also Send Feedback

The Word2007Export type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
Word2007Export..::.Dispose Method
Word2007Export Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

Word2007Export Class
Word2007Export Members
FastReport.Export.OoXML Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
Word2007Export..::.Export Method
Word2007Export Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

Word2007Export Class
Word2007Export Members
FastReport.Export.OoXML Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
Word2007Export..::.ExportPage Method
Word2007Export Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Finish Method

[image]

FastReport.Net Class Reference
Word2007Export..::.Finish Method
Word2007Export Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
Word2007Export..::.GetFileFilter Method
Word2007Export Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
Word2007Export..::.MemberwiseClone Method
Word2007Export Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Word2007Export Class
Word2007Export Members
FastReport.Export.OoXML Namespace


Serialize Method

[image]

FastReport.Net Class Reference
Word2007Export..::.Serialize Method
Word2007Export Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
Word2007Export..::.ShowDialog Method
Word2007Export Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Start Method

[image]

FastReport.Net Class Reference
Word2007Export..::.Start Method
Word2007Export Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Word2007Export Properties

[image] [image]

FastReport.Net Class Reference
Word2007Export Properties
Word2007Export Class See Also Send Feedback

The Word2007Export type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
MatrixBased | Enable or disable matrix view of document
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


MatrixBased Property

[image]

FastReport.Net Class Reference
Word2007Export..::.MatrixBased Property
Word2007Export Class See Also Send Feedback
Enable or disable matrix view of document

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MatrixBased { get; set; }
Visual Basic (Declaration)
Public Property MatrixBased As Boolean
Visual C++
public:
property bool MatrixBased {
    bool get ();
    void set (bool value);
}

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
Word2007Export..::.Wysiwyg Property
Word2007Export Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting Excel file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


Word2007Export Events

[image] [image]

FastReport.Net Class Reference
Word2007Export Events
Word2007Export Class See Also Send Feedback

The Word2007Export type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Word2007Export Class
FastReport.Export.OoXML Namespace


XPSExport Class

[image]

FastReport.Net Class Reference
XPSExport Class
Members See Also Send Feedback
Main class of XML export

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class XPSExport : OOExportBase, IDisposable
Visual Basic (Declaration)
Public Class XPSExport _
    Inherits OOExportBase _
    Implements IDisposable
Visual C++
public ref class XPSExport : public OOExportBase,
    IDisposable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.OoXML..::.OOExportBase
FastReport.Export.OoXML..::.XPSExport

See Also

XPSExport Members
FastReport.Export.OoXML Namespace


XPSExport Members

[image] [image]

FastReport.Net Class Reference
XPSExport Members
XPSExport Class Constructors Methods Fields Properties Events See Also Send Feedback

The XPSExport type exposes the following members.

Constructors

Name | Description
XPSExport | Constructor of XPSExport

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)
HumanReadable | HumanReadable
PicturesCount | PicturesCount

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


XPSExport Constructor

[image]

FastReport.Net Class Reference
XPSExport Constructor
XPSExport Class See Also Send Feedback
Constructor of XPSExport

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XPSExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XPSExport()

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


XPSExport Fields

[image] [image]

FastReport.Net Class Reference
XPSExport Fields
XPSExport Class See Also Send Feedback

The XPSExport type exposes the following members.

Fields

Name | Description
FTempFolder | Temporary folder for export files (Inherited from OOExportBase.)
HumanReadable | HumanReadable
PicturesCount | PicturesCount

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


HumanReadable Field

[image]

FastReport.Net Class Reference
XPSExport..::.HumanReadable Field
XPSExport Class See Also Send Feedback
HumanReadable

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HumanReadable
Visual Basic (Declaration)
Public HumanReadable As Boolean
Visual C++
public:
bool HumanReadable

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


PicturesCount Field

[image]

FastReport.Net Class Reference
XPSExport..::.PicturesCount Field
XPSExport Class See Also Send Feedback
PicturesCount

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PicturesCount
Visual Basic (Declaration)
Public PicturesCount As Integer
Visual C++
public:
int PicturesCount

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


XPSExport Methods

[image] [image]

FastReport.Net Class Reference
XPSExport Methods
XPSExport Class See Also Send Feedback

The XPSExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
XPSExport..::.Dispose Method
XPSExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Destructor of XPSExport
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

XPSExport Class
XPSExport Members
FastReport.Export.OoXML Namespace


Dispose Method

[image]

FastReport.Net Class Reference
XPSExport..::.Dispose Method
XPSExport Class See Also Send Feedback
Destructor of XPSExport

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

XPSExport Class
Dispose Overload
FastReport.Export.OoXML Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
XPSExport..::.Export Method
XPSExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

XPSExport Class
XPSExport Members
FastReport.Export.OoXML Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
XPSExport..::.ExportPage Method
XPSExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


Finish Method

[image]

FastReport.Net Class Reference
XPSExport..::.Finish Method
XPSExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
XPSExport..::.GetFileFilter Method
XPSExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
XPSExport..::.MemberwiseClone Method
XPSExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

XPSExport Class
XPSExport Members
FastReport.Export.OoXML Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
XPSExport..::.ShowDialog Method
XPSExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


Start Method

[image]

FastReport.Net Class Reference
XPSExport..::.Start Method
XPSExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.OoXML
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


XPSExport Properties

[image] [image]

FastReport.Net Class Reference
XPSExport Properties
XPSExport Class See Also Send Feedback

The XPSExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


XPSExport Events

[image] [image]

FastReport.Net Class Reference
XPSExport Events
XPSExport Class See Also Send Feedback

The XPSExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XPSExport Class
FastReport.Export.OoXML Namespace


FastReport.Export.Pdf Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Pdf Namespace
Send Feedback

Classes

Class | Description
PDFExport | PDF export (Adobe Acrobat)


PDFExport Class

[image]

FastReport.Net Class Reference
PDFExport Class
Members See Also Send Feedback
PDF export (Adobe Acrobat)

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PDFExport : ExportBase
Visual Basic (Declaration)
Public Class PDFExport _
    Inherits ExportBase
Visual C++
public ref class PDFExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Pdf..::.PDFExport

See Also

PDFExport Members
FastReport.Export.Pdf Namespace


PDFExport Members

[image] [image]

FastReport.Net Class Reference
PDFExport Members
PDFExport Class Constructors Methods Properties Events See Also Send Feedback

The PDFExport type exposes the following members.

Constructors

Name | Description
PDFExport | Initializes a new instance of the PDFExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowAnnotate | Enable or disable annotating in protected document.
AllowCopy | Enable or disable copying in protected document.
AllowModify | Enable or disable modifying in protected document.
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
AllowPrint | Enable or disable printing in protected document.
Author | Author of the document.
Background | Enable or disable of exporting the background.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterWindow | Enable or disable of centering the window.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Compressed | Enable or disable the compression in PDF document.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document.
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayDocTitle | Enable or disable of displaying document's title.
EmbeddingFonts | Enable or disable of embedding the TrueType fonts.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
FitWindow | Enable or disable of fitting the window
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
HideMenubar | Enable or disable hide the menu's bar.
HideToolbar | Enable or disable hide the toolbar.
HideWindowUI | Enable or disable hide the Windows UI.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
JpegQuality | Sets the quality of images in the PDF
Keywords | Keywords of the document.
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Outline | Enable or disable of document's Outline.
OwnerPassword | Sets the owner password.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintOptimized | Enable or disable of optimization the images for printing.
PrintScaling | Enable or disable of scaling the page for shrink to printable area.
Producer | Producer of the document.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RichTextQuality | Sets the quality of RichText objects in the PDF
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Subject | Subject of the document.
Title | Title of the document.
UserPassword | Sets the user password.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


PDFExport Constructor

[image]

FastReport.Net Class Reference
PDFExport Constructor
PDFExport Class See Also Send Feedback
Initializes a new instance of the PDFExport class.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PDFExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PDFExport()

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


PDFExport Methods

[image] [image]

FastReport.Net Class Reference
PDFExport Methods
PDFExport Class See Also Send Feedback

The PDFExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PDFExport..::.Dispose Method
PDFExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

PDFExport Class
PDFExport Members
FastReport.Export.Pdf Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
PDFExport..::.Export Method
PDFExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

PDFExport Class
PDFExport Members
FastReport.Export.Pdf Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
PDFExport..::.ExportPage Method
PDFExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Finish Method

[image]

FastReport.Net Class Reference
PDFExport..::.Finish Method
PDFExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
PDFExport..::.GetFileFilter Method
PDFExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PDFExport..::.MemberwiseClone Method
PDFExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PDFExport Class
PDFExport Members
FastReport.Export.Pdf Namespace


Serialize Method

[image]

FastReport.Net Class Reference
PDFExport..::.Serialize Method
PDFExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
PDFExport..::.ShowDialog Method
PDFExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Start Method

[image]

FastReport.Net Class Reference
PDFExport..::.Start Method
PDFExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


PDFExport Properties

[image] [image]

FastReport.Net Class Reference
PDFExport Properties
PDFExport Class See Also Send Feedback

The PDFExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowAnnotate | Enable or disable annotating in protected document.
AllowCopy | Enable or disable copying in protected document.
AllowModify | Enable or disable modifying in protected document.
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
AllowPrint | Enable or disable printing in protected document.
Author | Author of the document.
Background | Enable or disable of exporting the background.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterWindow | Enable or disable of centering the window.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Compressed | Enable or disable the compression in PDF document.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Creator of the document.
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayDocTitle | Enable or disable of displaying document's title.
EmbeddingFonts | Enable or disable of embedding the TrueType fonts.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
FitWindow | Enable or disable of fitting the window
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
HideMenubar | Enable or disable hide the menu's bar.
HideToolbar | Enable or disable hide the toolbar.
HideWindowUI | Enable or disable hide the Windows UI.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
JpegQuality | Sets the quality of images in the PDF
Keywords | Keywords of the document.
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Outline | Enable or disable of document's Outline.
OwnerPassword | Sets the owner password.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintOptimized | Enable or disable of optimization the images for printing.
PrintScaling | Enable or disable of scaling the page for shrink to printable area.
Producer | Producer of the document.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
RichTextQuality | Sets the quality of RichText objects in the PDF
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Subject | Subject of the document.
Title | Title of the document.
UserPassword | Sets the user password.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


AllowAnnotate Property

[image]

FastReport.Net Class Reference
PDFExport..::.AllowAnnotate Property
PDFExport Class See Also Send Feedback
Enable or disable annotating in protected document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowAnnotate { get; set; }
Visual Basic (Declaration)
Public Property AllowAnnotate As Boolean
Visual C++
public:
property bool AllowAnnotate {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


AllowCopy Property

[image]

FastReport.Net Class Reference
PDFExport..::.AllowCopy Property
PDFExport Class See Also Send Feedback
Enable or disable copying in protected document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowCopy { get; set; }
Visual Basic (Declaration)
Public Property AllowCopy As Boolean
Visual C++
public:
property bool AllowCopy {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


AllowModify Property

[image]

FastReport.Net Class Reference
PDFExport..::.AllowModify Property
PDFExport Class See Also Send Feedback
Enable or disable modifying in protected document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowModify { get; set; }
Visual Basic (Declaration)
Public Property AllowModify As Boolean
Visual C++
public:
property bool AllowModify {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


AllowPrint Property

[image]

FastReport.Net Class Reference
PDFExport..::.AllowPrint Property
PDFExport Class See Also Send Feedback
Enable or disable printing in protected document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AllowPrint { get; set; }
Visual Basic (Declaration)
Public Property AllowPrint As Boolean
Visual C++
public:
property bool AllowPrint {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Author Property

[image]

FastReport.Net Class Reference
PDFExport..::.Author Property
PDFExport Class See Also Send Feedback
Author of the document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Author { get; set; }
Visual Basic (Declaration)
Public Property Author As String
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Background Property

[image]

FastReport.Net Class Reference
PDFExport..::.Background Property
PDFExport Class See Also Send Feedback
Enable or disable of exporting the background.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Background { get; set; }
Visual Basic (Declaration)
Public Property Background As Boolean
Visual C++
public:
property bool Background {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


CenterWindow Property

[image]

FastReport.Net Class Reference
PDFExport..::.CenterWindow Property
PDFExport Class See Also Send Feedback
Enable or disable of centering the window.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CenterWindow { get; set; }
Visual Basic (Declaration)
Public Property CenterWindow As Boolean
Visual C++
public:
property bool CenterWindow {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Compressed Property

[image]

FastReport.Net Class Reference
PDFExport..::.Compressed Property
PDFExport Class See Also Send Feedback
Enable or disable the compression in PDF document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Compressed { get; set; }
Visual Basic (Declaration)
Public Property Compressed As Boolean
Visual C++
public:
property bool Compressed {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Creator Property

[image]

FastReport.Net Class Reference
PDFExport..::.Creator Property
PDFExport Class See Also Send Feedback
Creator of the document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Creator { get; set; }
Visual Basic (Declaration)
Public Property Creator As String
Visual C++
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


DisplayDocTitle Property

[image]

FastReport.Net Class Reference
PDFExport..::.DisplayDocTitle Property
PDFExport Class See Also Send Feedback
Enable or disable of displaying document's title.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DisplayDocTitle { get; set; }
Visual Basic (Declaration)
Public Property DisplayDocTitle As Boolean
Visual C++
public:
property bool DisplayDocTitle {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


EmbeddingFonts Property

[image]

FastReport.Net Class Reference
PDFExport..::.EmbeddingFonts Property
PDFExport Class See Also Send Feedback
Enable or disable of embedding the TrueType fonts.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool EmbeddingFonts { get; set; }
Visual Basic (Declaration)
Public Property EmbeddingFonts As Boolean
Visual C++
public:
property bool EmbeddingFonts {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


FitWindow Property

[image]

FastReport.Net Class Reference
PDFExport..::.FitWindow Property
PDFExport Class See Also Send Feedback
Enable or disable of fitting the window

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FitWindow { get; set; }
Visual Basic (Declaration)
Public Property FitWindow As Boolean
Visual C++
public:
property bool FitWindow {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


HideMenubar Property

[image]

FastReport.Net Class Reference
PDFExport..::.HideMenubar Property
PDFExport Class See Also Send Feedback
Enable or disable hide the menu's bar.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideMenubar { get; set; }
Visual Basic (Declaration)
Public Property HideMenubar As Boolean
Visual C++
public:
property bool HideMenubar {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


HideToolbar Property

[image]

FastReport.Net Class Reference
PDFExport..::.HideToolbar Property
PDFExport Class See Also Send Feedback
Enable or disable hide the toolbar.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideToolbar { get; set; }
Visual Basic (Declaration)
Public Property HideToolbar As Boolean
Visual C++
public:
property bool HideToolbar {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


HideWindowUI Property

[image]

FastReport.Net Class Reference
PDFExport..::.HideWindowUI Property
PDFExport Class See Also Send Feedback
Enable or disable hide the Windows UI.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideWindowUI { get; set; }
Visual Basic (Declaration)
Public Property HideWindowUI As Boolean
Visual C++
public:
property bool HideWindowUI {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


JpegQuality Property

[image]

FastReport.Net Class Reference
PDFExport..::.JpegQuality Property
PDFExport Class See Also Send Feedback
Sets the quality of images in the PDF

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Integer
Visual C++
public:
property int JpegQuality {
    int get ();
    void set (int value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Keywords Property

[image]

FastReport.Net Class Reference
PDFExport..::.Keywords Property
PDFExport Class See Also Send Feedback
Keywords of the document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Keywords { get; set; }
Visual Basic (Declaration)
Public Property Keywords As String
Visual C++
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Outline Property

[image]

FastReport.Net Class Reference
PDFExport..::.Outline Property
PDFExport Class See Also Send Feedback
Enable or disable of document's Outline.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Outline { get; set; }
Visual Basic (Declaration)
Public Property Outline As Boolean
Visual C++
public:
property bool Outline {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


OwnerPassword Property

[image]

FastReport.Net Class Reference
PDFExport..::.OwnerPassword Property
PDFExport Class See Also Send Feedback
Sets the owner password.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string OwnerPassword { get; set; }
Visual Basic (Declaration)
Public Property OwnerPassword As String
Visual C++
public:
property String^ OwnerPassword {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


PrintOptimized Property

[image]

FastReport.Net Class Reference
PDFExport..::.PrintOptimized Property
PDFExport Class See Also Send Feedback
Enable or disable of optimization the images for printing.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintOptimized { get; set; }
Visual Basic (Declaration)
Public Property PrintOptimized As Boolean
Visual C++
public:
property bool PrintOptimized {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


PrintScaling Property

[image]

FastReport.Net Class Reference
PDFExport..::.PrintScaling Property
PDFExport Class See Also Send Feedback
Enable or disable of scaling the page for shrink to printable area.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintScaling { get; set; }
Visual Basic (Declaration)
Public Property PrintScaling As Boolean
Visual C++
public:
property bool PrintScaling {
    bool get ();
    void set (bool value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Producer Property

[image]

FastReport.Net Class Reference
PDFExport..::.Producer Property
PDFExport Class See Also Send Feedback
Producer of the document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Producer { get; set; }
Visual Basic (Declaration)
Public Property Producer As String
Visual C++
public:
property String^ Producer {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


RichTextQuality Property

[image]

FastReport.Net Class Reference
PDFExport..::.RichTextQuality Property
PDFExport Class See Also Send Feedback
Sets the quality of RichText objects in the PDF

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RichTextQuality { get; set; }
Visual Basic (Declaration)
Public Property RichTextQuality As Integer
Visual C++
public:
property int RichTextQuality {
    int get ();
    void set (int value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Subject Property

[image]

FastReport.Net Class Reference
PDFExport..::.Subject Property
PDFExport Class See Also Send Feedback
Subject of the document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


Title Property

[image]

FastReport.Net Class Reference
PDFExport..::.Title Property
PDFExport Class See Also Send Feedback
Title of the document.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


UserPassword Property

[image]

FastReport.Net Class Reference
PDFExport..::.UserPassword Property
PDFExport Class See Also Send Feedback
Sets the user password.

Namespace: FastReport.Export.Pdf
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string UserPassword { get; set; }
Visual Basic (Declaration)
Public Property UserPassword As String
Visual C++
public:
property String^ UserPassword {
    String^ get ();
    void set (String^ value);
}

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


PDFExport Events

[image] [image]

FastReport.Net Class Reference
PDFExport Events
PDFExport Class See Also Send Feedback

The PDFExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PDFExport Class
FastReport.Export.Pdf Namespace


FastReport.Export.RichText Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.RichText Namespace
Send Feedback

Classes

Class | Description
RTFExport | Represents the RTF export filter.

Enumerations

Enumeration | Description
RTFImageFormat | Specifies the image format in RTF export.


RTFExport Class

[image]

FastReport.Net Class Reference
RTFExport Class
Members See Also Send Feedback
Represents the RTF export filter.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class RTFExport : ExportBase
Visual Basic (Declaration)
Public Class RTFExport _
    Inherits ExportBase
Visual C++
public ref class RTFExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.RichText..::.RTFExport

See Also

RTFExport Members
FastReport.Export.RichText Namespace


RTFExport Members

[image] [image]

FastReport.Net Class Reference
RTFExport Members
RTFExport Class Constructors Methods Properties Events See Also Send Feedback

The RTFExport type exposes the following members.

Constructors

Name | Description
RTFExport | Initializes a new instance of the RTFExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
AutoSize | Gets or sets a value that determines whether the rows in the resulting table should calculate its height automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Gets or sets the creator of the document.
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format that will be used to save pictures in RTF file.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
JpegQuality | Gets or sets the quality of Jpeg images in RTF file.
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Gets or sets a value indicating that page breaks are enabled.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Pictures | Gets or sets a value indicating that pictures are enabled.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

RTFExport Class
FastReport.Export.RichText Namespace


RTFExport Constructor

[image]

FastReport.Net Class Reference
RTFExport Constructor
RTFExport Class See Also Send Feedback
Initializes a new instance of the RTFExport class.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RTFExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RTFExport()

See Also

RTFExport Class
FastReport.Export.RichText Namespace


RTFExport Methods

[image] [image]

FastReport.Net Class Reference
RTFExport Methods
RTFExport Class See Also Send Feedback

The RTFExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RTFExport Class
FastReport.Export.RichText Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
RTFExport..::.Dispose Method
RTFExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

RTFExport Class
RTFExport Members
FastReport.Export.RichText Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
RTFExport..::.Export Method
RTFExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

RTFExport Class
RTFExport Members
FastReport.Export.RichText Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
RTFExport..::.ExportPage Method
RTFExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

RTFExport Class
FastReport.Export.RichText Namespace


Finish Method

[image]

FastReport.Net Class Reference
RTFExport..::.Finish Method
RTFExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

RTFExport Class
FastReport.Export.RichText Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
RTFExport..::.GetFileFilter Method
RTFExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

RTFExport Class
FastReport.Export.RichText Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
RTFExport..::.MemberwiseClone Method
RTFExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RTFExport Class
RTFExport Members
FastReport.Export.RichText Namespace


Serialize Method

[image]

FastReport.Net Class Reference
RTFExport..::.Serialize Method
RTFExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

RTFExport Class
FastReport.Export.RichText Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
RTFExport..::.ShowDialog Method
RTFExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

RTFExport Class
FastReport.Export.RichText Namespace


Start Method

[image]

FastReport.Net Class Reference
RTFExport..::.Start Method
RTFExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

RTFExport Class
FastReport.Export.RichText Namespace


RTFExport Properties

[image] [image]

FastReport.Net Class Reference
RTFExport Properties
RTFExport Class See Also Send Feedback

The RTFExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
AutoSize | Gets or sets a value that determines whether the rows in the resulting table should calculate its height automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Gets or sets the creator of the document.
CurPage | Current page number. (Inherited from ExportBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
ImageFormat | Gets or sets the image format that will be used to save pictures in RTF file.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
JpegQuality | Gets or sets the quality of Jpeg images in RTF file.
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Gets or sets a value indicating that page breaks are enabled.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Pictures | Gets or sets a value indicating that pictures are enabled.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

RTFExport Class
FastReport.Export.RichText Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
RTFExport..::.AutoSize Property
RTFExport Class See Also Send Feedback
Gets or sets a value that determines whether the rows in the resulting table should calculate its height automatically.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

Remarks

Default value for this property is false. In this mode, each row in the resulting table has fixed height to get maximum wysiwyg. If you set it to true, the height of resulting table will be calculated automatically by the Word processor. The document will be more editable, but less wysiwyg.

See Also

RTFExport Class
FastReport.Export.RichText Namespace


Creator Property

[image]

FastReport.Net Class Reference
RTFExport..::.Creator Property
RTFExport Class See Also Send Feedback
Gets or sets the creator of the document.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Creator { get; set; }
Visual Basic (Declaration)
Public Property Creator As String
Visual C++
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}

See Also

RTFExport Class
FastReport.Export.RichText Namespace


ImageFormat Property

[image]

FastReport.Net Class Reference
RTFExport..::.ImageFormat Property
RTFExport Class See Also Send Feedback
Gets or sets the image format that will be used to save pictures in RTF file.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RTFImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As RTFImageFormat
Visual C++
public:
property RTFImageFormat ImageFormat {
    RTFImageFormat get ();
    void set (RTFImageFormat value);
}

Remarks

Default value is Metafile. This format is better for exporting such objects as MSChartObject and ShapeObject.

See Also

RTFExport Class
FastReport.Export.RichText Namespace


JpegQuality Property

[image]

FastReport.Net Class Reference
RTFExport..::.JpegQuality Property
RTFExport Class See Also Send Feedback
Gets or sets the quality of Jpeg images in RTF file.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Integer
Visual C++
public:
property int JpegQuality {
    int get ();
    void set (int value);
}

Remarks

Default value is 90. This property will be used if you select Jpeg in the ImageFormat property.

See Also

RTFExport Class
FastReport.Export.RichText Namespace


PageBreaks Property

[image]

FastReport.Net Class Reference
RTFExport..::.PageBreaks Property
RTFExport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreaks { get; set; }
Visual Basic (Declaration)
Public Property PageBreaks As Boolean
Visual C++
public:
property bool PageBreaks {
    bool get ();
    void set (bool value);
}

See Also

RTFExport Class
FastReport.Export.RichText Namespace


Pictures Property

[image]

FastReport.Net Class Reference
RTFExport..::.Pictures Property
RTFExport Class See Also Send Feedback
Gets or sets a value indicating that pictures are enabled.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Pictures { get; set; }
Visual Basic (Declaration)
Public Property Pictures As Boolean
Visual C++
public:
property bool Pictures {
    bool get ();
    void set (bool value);
}

See Also

RTFExport Class
FastReport.Export.RichText Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
RTFExport..::.Wysiwyg Property
RTFExport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

RTFExport Class
FastReport.Export.RichText Namespace


RTFExport Events

[image] [image]

FastReport.Net Class Reference
RTFExport Events
RTFExport Class See Also Send Feedback

The RTFExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

RTFExport Class
FastReport.Export.RichText Namespace


RTFImageFormat Enumeration

[image]

FastReport.Net Class Reference
RTFImageFormat Enumeration
See Also Send Feedback
Specifies the image format in RTF export.

Namespace: FastReport.Export.RichText
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum RTFImageFormat
Visual Basic (Declaration)
Public Enumeration RTFImageFormat
Visual C++
public enum class RTFImageFormat

Members

Member name | Description
Png | Specifies the .png format.
Jpeg | Specifies the .jpg format.
Metafile | Specifies the .emf format.

See Also

FastReport.Export.RichText Namespace


FastReport.Export.Text Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Text Namespace
Send Feedback

Classes

Class | Description
TextExport | Represents the text export.
TextExportPrint | Represents supplement class for print of any stream directly in printer.
TextExportPrinterCommand | Represents the printer command class
TextExportPrinterType | Represents of the printer type class.


TextExport Class

[image]

FastReport.Net Class Reference
TextExport Class
Members See Also Send Feedback
Represents the text export.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextExport : ExportBase
Visual Basic (Declaration)
Public Class TextExport _
    Inherits ExportBase
Visual C++
public ref class TextExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Text..::.TextExport

See Also

TextExport Members
FastReport.Export.Text Namespace


TextExport Members

[image] [image]

FastReport.Net Class Reference
TextExport Members
TextExport Class Constructors Methods Properties Events See Also Send Feedback

The TextExport type exposes the following members.

Constructors

Name | Description
TextExport | Initializes a new instance of the TextExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
AvoidDataLoss | Enable or disable the Data loss avoiding. Auto calculation of ScaleX and ScaleY will be launched when dialogue window will be off.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Copies | Gets or sets the count of copies for printing of results.
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Enable or disable the data only output without any headers. Default value is false.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EmptyLines | Enable or disable the output of empty lines in resulting document. Default value is false.
Encoding | Gets or sets the encoding of resulting document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Frames | Enable or disable frames in resulting document. Default value is true.
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Enable or disable the breaks of pages in resulting document. Default value is true.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintAfterExport | Enable or disable the printing results after export.
PrinterName | Gets or sets the printer name for printing of results.
PrinterType | Gets or sets the active index of registered printer type.
PrinterTypes | Gets or sets the list of printer types. TextExportPrinterType
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ScaleX | Gets or sets the scale by X axis for correct text objects placement.
ScaleY | Gets or sets the scale by Y axis for correct text objects placement.
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
TextFrames | Enable or disable the text (non graphic) frames in resulting document. Default value is false.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TextExport Class
FastReport.Export.Text Namespace


TextExport Constructor

[image]

FastReport.Net Class Reference
TextExport Constructor
TextExport Class See Also Send Feedback
Initializes a new instance of the TextExport class.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextExport()

See Also

TextExport Class
FastReport.Export.Text Namespace


TextExport Methods

[image] [image]

FastReport.Net Class Reference
TextExport Methods
TextExport Class See Also Send Feedback

The TextExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ExportBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TextExport Class
FastReport.Export.Text Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TextExport..::.Dispose Method
TextExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TextExport Class
TextExport Members
FastReport.Export.Text Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
TextExport..::.Export Method
TextExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

TextExport Class
TextExport Members
FastReport.Export.Text Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
TextExport..::.ExportPage Method
TextExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

TextExport Class
FastReport.Export.Text Namespace


Finish Method

[image]

FastReport.Net Class Reference
TextExport..::.Finish Method
TextExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

TextExport Class
FastReport.Export.Text Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
TextExport..::.GetFileFilter Method
TextExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

TextExport Class
FastReport.Export.Text Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TextExport..::.MemberwiseClone Method
TextExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextExport Class
TextExport Members
FastReport.Export.Text Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
TextExport..::.ShowDialog Method
TextExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

TextExport Class
FastReport.Export.Text Namespace


Start Method

[image]

FastReport.Net Class Reference
TextExport..::.Start Method
TextExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

TextExport Class
FastReport.Export.Text Namespace


TextExport Properties

[image] [image]

FastReport.Net Class Reference
TextExport Properties
TextExport Class See Also Send Feedback

The TextExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
AvoidDataLoss | Enable or disable the Data loss avoiding. Auto calculation of ScaleX and ScaleY will be launched when dialogue window will be off.
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Copies | Gets or sets the count of copies for printing of results.
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Enable or disable the data only output without any headers. Default value is false.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EmptyLines | Enable or disable the output of empty lines in resulting document. Default value is false.
Encoding | Gets or sets the encoding of resulting document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Frames | Enable or disable frames in resulting document. Default value is true.
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Enable or disable the breaks of pages in resulting document. Default value is true.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PrintAfterExport | Enable or disable the printing results after export.
PrinterName | Gets or sets the printer name for printing of results.
PrinterType | Gets or sets the active index of registered printer type.
PrinterTypes | Gets or sets the list of printer types. TextExportPrinterType
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ScaleX | Gets or sets the scale by X axis for correct text objects placement.
ScaleY | Gets or sets the scale by Y axis for correct text objects placement.
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
TextFrames | Enable or disable the text (non graphic) frames in resulting document. Default value is false.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TextExport Class
FastReport.Export.Text Namespace


AvoidDataLoss Property

[image]

FastReport.Net Class Reference
TextExport..::.AvoidDataLoss Property
TextExport Class See Also Send Feedback
Enable or disable the Data loss avoiding. Auto calculation of ScaleX and ScaleY will be launched when dialogue window will be off.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AvoidDataLoss { get; set; }
Visual Basic (Declaration)
Public Property AvoidDataLoss As Boolean
Visual C++
public:
property bool AvoidDataLoss {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


Copies Property

[image]

FastReport.Net Class Reference
TextExport..::.Copies Property
TextExport Class See Also Send Feedback
Gets or sets the count of copies for printing of results.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Copies { get; set; }
Visual Basic (Declaration)
Public Property Copies As Integer
Visual C++
public:
property int Copies {
    int get ();
    void set (int value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


DataOnly Property

[image]

FastReport.Net Class Reference
TextExport..::.DataOnly Property
TextExport Class See Also Send Feedback
Enable or disable the data only output without any headers. Default value is false.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DataOnly { get; set; }
Visual Basic (Declaration)
Public Property DataOnly As Boolean
Visual C++
public:
property bool DataOnly {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


EmptyLines Property

[image]

FastReport.Net Class Reference
TextExport..::.EmptyLines Property
TextExport Class See Also Send Feedback
Enable or disable the output of empty lines in resulting document. Default value is false.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool EmptyLines { get; set; }
Visual Basic (Declaration)
Public Property EmptyLines As Boolean
Visual C++
public:
property bool EmptyLines {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


Encoding Property

[image]

FastReport.Net Class Reference
TextExport..::.Encoding Property
TextExport Class Example See Also Send Feedback
Gets or sets the encoding of resulting document.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As Encoding
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Examples

Windows ANSI encoding
CopyC#
TextExport.Encoding = Encoding.Default;
 Unicode UTF-8 encoding
CopyC#
TextExport.Encoding = Encoding.UTF8;
 OEM encoding for current system locale sessings
CopyC#
TextExport.Encoding = Encoding.GetEncoding(CultureInfo.CurrentCulture.TextInfo.OEMCodePage);

See Also

TextExport Class
FastReport.Export.Text Namespace


Frames Property

[image]

FastReport.Net Class Reference
TextExport..::.Frames Property
TextExport Class See Also Send Feedback
Enable or disable frames in resulting document. Default value is true.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Frames { get; set; }
Visual Basic (Declaration)
Public Property Frames As Boolean
Visual C++
public:
property bool Frames {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


PageBreaks Property

[image]

FastReport.Net Class Reference
TextExport..::.PageBreaks Property
TextExport Class See Also Send Feedback
Enable or disable the breaks of pages in resulting document. Default value is true.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreaks { get; set; }
Visual Basic (Declaration)
Public Property PageBreaks As Boolean
Visual C++
public:
property bool PageBreaks {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


PrintAfterExport Property

[image]

FastReport.Net Class Reference
TextExport..::.PrintAfterExport Property
TextExport Class See Also Send Feedback
Enable or disable the printing results after export.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintAfterExport { get; set; }
Visual Basic (Declaration)
Public Property PrintAfterExport As Boolean
Visual C++
public:
property bool PrintAfterExport {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


PrinterName Property

[image]

FastReport.Net Class Reference
TextExport..::.PrinterName Property
TextExport Class See Also Send Feedback
Gets or sets the printer name for printing of results.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PrinterName { get; set; }
Visual Basic (Declaration)
Public Property PrinterName As String
Visual C++
public:
property String^ PrinterName {
    String^ get ();
    void set (String^ value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


PrinterType Property

[image]

FastReport.Net Class Reference
TextExport..::.PrinterType Property
TextExport Class See Also Send Feedback
Gets or sets the active index of registered printer type.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PrinterType { get; set; }
Visual Basic (Declaration)
Public Property PrinterType As Integer
Visual C++
public:
property int PrinterType {
    int get ();
    void set (int value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


PrinterTypes Property

[image]

FastReport.Net Class Reference
TextExport..::.PrinterTypes Property
TextExport Class See Also Send Feedback
Gets or sets the list of printer types. TextExportPrinterType

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<TextExportPrinterType> PrinterTypes { get; set; }
Visual Basic (Declaration)
Public Property PrinterTypes As List(Of TextExportPrinterType)
Visual C++
public:
property List<TextExportPrinterType^>^ PrinterTypes {
    List<TextExportPrinterType^>^ get ();
    void set (List<TextExportPrinterType^>^ value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


ScaleX Property

[image]

FastReport.Net Class Reference
TextExport..::.ScaleX Property
TextExport Class See Also Send Feedback
Gets or sets the scale by X axis for correct text objects placement.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ScaleX { get; set; }
Visual Basic (Declaration)
Public Property ScaleX As Single
Visual C++
public:
property float ScaleX {
    float get ();
    void set (float value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


ScaleY Property

[image]

FastReport.Net Class Reference
TextExport..::.ScaleY Property
TextExport Class See Also Send Feedback
Gets or sets the scale by Y axis for correct text objects placement.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ScaleY { get; set; }
Visual Basic (Declaration)
Public Property ScaleY As Single
Visual C++
public:
property float ScaleY {
    float get ();
    void set (float value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


TextFrames Property

[image]

FastReport.Net Class Reference
TextExport..::.TextFrames Property
TextExport Class See Also Send Feedback
Enable or disable the text (non graphic) frames in resulting document. Default value is false.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextFrames { get; set; }
Visual Basic (Declaration)
Public Property TextFrames As Boolean
Visual C++
public:
property bool TextFrames {
    bool get ();
    void set (bool value);
}

See Also

TextExport Class
FastReport.Export.Text Namespace


TextExport Events

[image] [image]

FastReport.Net Class Reference
TextExport Events
TextExport Class See Also Send Feedback

The TextExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TextExport Class
FastReport.Export.Text Namespace


TextExportPrint Class

[image]

FastReport.Net Class Reference
TextExportPrint Class
Members See Also Send Feedback
Represents supplement class for print of any stream directly in printer.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class TextExportPrint
Visual Basic (Declaration)
Public NotInheritable Class TextExportPrint
Visual C++
public ref class TextExportPrint abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Export.Text..::.TextExportPrint

See Also

TextExportPrint Members
FastReport.Export.Text Namespace


TextExportPrint Members

[image] [image]

FastReport.Net Class Reference
TextExportPrint Members
TextExportPrint Class Methods See Also Send Feedback

The TextExportPrint type exposes the following members.

Methods

Name | Description
PrintStream | Prints a stream.

See Also

TextExportPrint Class
FastReport.Export.Text Namespace


TextExportPrint Methods

[image] [image]

FastReport.Net Class Reference
TextExportPrint Methods
TextExportPrint Class See Also Send Feedback

The TextExportPrint type exposes the following members.

Methods

Name | Description
PrintStream | Prints a stream.

See Also

TextExportPrint Class
FastReport.Export.Text Namespace


PrintStream Method

[image]

FastReport.Net Class Reference
TextExportPrint..::.PrintStream Method
TextExportPrint Class Example See Also Send Feedback
Prints a stream.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void PrintStream(
    string PrinterName,
    string DocName,
    int Copies,
    Stream Stream
)
Visual Basic (Declaration)
Public Shared Sub PrintStream ( _
    PrinterName As String, _
    DocName As String, _
    Copies As Integer, _
    Stream As Stream _
)
Visual C++
public:
static void PrintStream(
    String^ PrinterName,
    String^ DocName,
    int Copies,
    Stream^ Stream
)

Parameters

PrinterName
Type: System..::.String
Printer name on which should be print.
DocName
Type: System..::.String
Document title for printer spooler.
Copies
Type: System..::.Int32
Count of copies.
Stream
Type: System.IO..::.Stream
Stream that will be printed.

Examples

This example demonstrates the printing of Stream.
CopyC#
TextExportPrint.PrintStream("EPSON FX-1000", "My Report", 1, txtStream)

See Also

TextExportPrint Class
FastReport.Export.Text Namespace


TextExportPrinterCommand Class

[image]

FastReport.Net Class Reference
TextExportPrinterCommand Class
Members See Also Send Feedback
Represents the printer command class

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextExportPrinterCommand
Visual Basic (Declaration)
Public Class TextExportPrinterCommand
Visual C++
public ref class TextExportPrinterCommand

Inheritance Hierarchy

System..::.Object
FastReport.Export.Text..::.TextExportPrinterCommand

See Also

TextExportPrinterCommand Members
FastReport.Export.Text Namespace


TextExportPrinterCommand Members

[image] [image]

FastReport.Net Class Reference
TextExportPrinterCommand Members
TextExportPrinterCommand Class Constructors Methods Properties See Also Send Feedback

The TextExportPrinterCommand type exposes the following members.

Constructors

Name | Description
TextExportPrinterCommand | Initializes a new instance of the TextExportPrinterCommand class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets the active state of command. Default value is false.
Name | Gets or sets the command name.
SequenceOff | Gets or sets the list of "off sequence".
SequenceOn | Gets or sets the list of "on sequence".

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


TextExportPrinterCommand Constructor

[image]

FastReport.Net Class Reference
TextExportPrinterCommand Constructor
TextExportPrinterCommand Class See Also Send Feedback
Initializes a new instance of the TextExportPrinterCommand class.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextExportPrinterCommand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextExportPrinterCommand()

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


TextExportPrinterCommand Methods

[image] [image]

FastReport.Net Class Reference
TextExportPrinterCommand Methods
TextExportPrinterCommand Class See Also Send Feedback

The TextExportPrinterCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


TextExportPrinterCommand Properties

[image] [image]

FastReport.Net Class Reference
TextExportPrinterCommand Properties
TextExportPrinterCommand Class See Also Send Feedback

The TextExportPrinterCommand type exposes the following members.

Properties

Name | Description
Active | Gets or sets the active state of command. Default value is false.
Name | Gets or sets the command name.
SequenceOff | Gets or sets the list of "off sequence".
SequenceOn | Gets or sets the list of "on sequence".

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


Active Property

[image]

FastReport.Net Class Reference
TextExportPrinterCommand..::.Active Property
TextExportPrinterCommand Class See Also Send Feedback
Gets or sets the active state of command. Default value is false.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Active { get; set; }
Visual Basic (Declaration)
Public Property Active As Boolean
Visual C++
public:
property bool Active {
    bool get ();
    void set (bool value);
}

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


Name Property

[image]

FastReport.Net Class Reference
TextExportPrinterCommand..::.Name Property
TextExportPrinterCommand Class See Also Send Feedback
Gets or sets the command name.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


SequenceOff Property

[image]

FastReport.Net Class Reference
TextExportPrinterCommand..::.SequenceOff Property
TextExportPrinterCommand Class See Also Send Feedback
Gets or sets the list of "off sequence".

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<byte> SequenceOff { get; set; }
Visual Basic (Declaration)
Public Property SequenceOff As List(Of Byte)
Visual C++
public:
property List<unsigned char>^ SequenceOff {
    List<unsigned char>^ get ();
    void set (List<unsigned char>^ value);
}

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


SequenceOn Property

[image]

FastReport.Net Class Reference
TextExportPrinterCommand..::.SequenceOn Property
TextExportPrinterCommand Class See Also Send Feedback
Gets or sets the list of "on sequence".

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<byte> SequenceOn { get; set; }
Visual Basic (Declaration)
Public Property SequenceOn As List(Of Byte)
Visual C++
public:
property List<unsigned char>^ SequenceOn {
    List<unsigned char>^ get ();
    void set (List<unsigned char>^ value);
}

See Also

TextExportPrinterCommand Class
FastReport.Export.Text Namespace


TextExportPrinterType Class

[image]

FastReport.Net Class Reference
TextExportPrinterType Class
Members See Also Send Feedback
Represents of the printer type class.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TextExportPrinterType
Visual Basic (Declaration)
Public Class TextExportPrinterType
Visual C++
public ref class TextExportPrinterType

Inheritance Hierarchy

System..::.Object
FastReport.Export.Text..::.TextExportPrinterType

See Also

TextExportPrinterType Members
FastReport.Export.Text Namespace


TextExportPrinterType Members

[image] [image]

FastReport.Net Class Reference
TextExportPrinterType Members
TextExportPrinterType Class Constructors Methods Properties See Also Send Feedback

The TextExportPrinterType type exposes the following members.

Constructors

Name | Description
TextExportPrinterType | Initializes a new instance of the TextExportPrinterType class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Commands | Gets or sets the list of printer commands. TextExportPrinterCommand
Name | Gets or sets the printer name.

See Also

TextExportPrinterType Class
FastReport.Export.Text Namespace


TextExportPrinterType Constructor

[image]

FastReport.Net Class Reference
TextExportPrinterType Constructor
TextExportPrinterType Class See Also Send Feedback
Initializes a new instance of the TextExportPrinterType class.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TextExportPrinterType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextExportPrinterType()

See Also

TextExportPrinterType Class
FastReport.Export.Text Namespace


TextExportPrinterType Methods

[image] [image]

FastReport.Net Class Reference
TextExportPrinterType Methods
TextExportPrinterType Class See Also Send Feedback

The TextExportPrinterType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextExportPrinterType Class
FastReport.Export.Text Namespace


TextExportPrinterType Properties

[image] [image]

FastReport.Net Class Reference
TextExportPrinterType Properties
TextExportPrinterType Class See Also Send Feedback

The TextExportPrinterType type exposes the following members.

Properties

Name | Description
Commands | Gets or sets the list of printer commands. TextExportPrinterCommand
Name | Gets or sets the printer name.

See Also

TextExportPrinterType Class
FastReport.Export.Text Namespace


Commands Property

[image]

FastReport.Net Class Reference
TextExportPrinterType..::.Commands Property
TextExportPrinterType Class See Also Send Feedback
Gets or sets the list of printer commands. TextExportPrinterCommand

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<TextExportPrinterCommand> Commands { get; set; }
Visual Basic (Declaration)
Public Property Commands As List(Of TextExportPrinterCommand)
Visual C++
public:
property List<TextExportPrinterCommand^>^ Commands {
    List<TextExportPrinterCommand^>^ get ();
    void set (List<TextExportPrinterCommand^>^ value);
}

See Also

TextExportPrinterType Class
FastReport.Export.Text Namespace


Name Property

[image]

FastReport.Net Class Reference
TextExportPrinterType..::.Name Property
TextExportPrinterType Class See Also Send Feedback
Gets or sets the printer name.

Namespace: FastReport.Export.Text
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

TextExportPrinterType Class
FastReport.Export.Text Namespace


FastReport.Export.Xml Namespace

[image]

FastReport.Net Class Reference
FastReport.Export.Xml Namespace
Send Feedback

Classes

Class | Description
XMLExport | Represents the Excel 2003 XML export filter.


XMLExport Class

[image]

FastReport.Net Class Reference
XMLExport Class
Members See Also Send Feedback
Represents the Excel 2003 XML export filter.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class XMLExport : ExportBase
Visual Basic (Declaration)
Public Class XMLExport _
    Inherits ExportBase
Visual C++
public ref class XMLExport : public ExportBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Export..::.ExportBase
FastReport.Export.Xml..::.XMLExport

See Also

XMLExport Members
FastReport.Export.Xml Namespace


XMLExport Members

[image] [image]

FastReport.Net Class Reference
XMLExport Members
XMLExport Class Constructors Methods Properties Events See Also Send Feedback

The XMLExport type exposes the following members.

Constructors

Name | Description
XMLExport | Initializes a new instance of the XMLExport class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Gets or sets the name of document creator.
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Gets or sets a value that determines whether to insert page breaks in the output file or not.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XMLExport Class
FastReport.Export.Xml Namespace


XMLExport Constructor

[image]

FastReport.Net Class Reference
XMLExport Constructor
XMLExport Class See Also Send Feedback
Initializes a new instance of the XMLExport class.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XMLExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XMLExport()

See Also

XMLExport Class
FastReport.Export.Xml Namespace


XMLExport Methods

[image] [image]

FastReport.Net Class Reference
XMLExport Methods
XMLExport Class See Also Send Feedback

The XMLExport type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ExportBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportPage | This method is called for each exported page. (Overrides ExportBase..::.ExportPage(Int32).)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
Finish | This method is called when the export is finished. (Overrides ExportBase..::.Finish()()().)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetFileFilter | Returns a file filter for a save dialog. (Overrides ExportBase..::.GetFileFilter()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPage | Gets a report page with specified index. (Inherited from ExportBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ExportBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ShowDialog | Displays a dialog with export options. (Overrides ExportBase..::.ShowDialog()()().)
Start | This method is called when the export starts. (Overrides ExportBase..::.Start()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

XMLExport Class
FastReport.Export.Xml Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
XMLExport..::.Dispose Method
XMLExport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

XMLExport Class
XMLExport Members
FastReport.Export.Xml Namespace


Export Method

[image] [image]

FastReport.Net Class Reference
XMLExport..::.Export Method
XMLExport Class See Also Send Feedback

Overload List

Name | Description
Export(Report) | Exports the report to a file. (Inherited from ExportBase.)
Export(Report, Stream) | Exports the report to a stream. (Inherited from ExportBase.)
Export(Report, String) | Exports the report to a file. (Inherited from ExportBase.)

See Also

XMLExport Class
XMLExport Members
FastReport.Export.Xml Namespace


ExportPage Method

[image]

FastReport.Net Class Reference
XMLExport..::.ExportPage Method
XMLExport Class See Also Send Feedback
This method is called for each exported page.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void ExportPage(
    int pageNo
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    pageNo As Integer _
)
Visual C++
protected:
virtual void ExportPage(
    int pageNo
) override

Parameters

pageNo
Type: System..::.Int32
Page number to export.

Remarks

To get a page, use the following code:
CopyC#
ReportPage page = Report.PreparedPages.GetPage(pageNo);

See Also

XMLExport Class
FastReport.Export.Xml Namespace


Finish Method

[image]

FastReport.Net Class Reference
XMLExport..::.Finish Method
XMLExport Class See Also Send Feedback
This method is called when the export is finished.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Finish()
Visual Basic (Declaration)
Protected Overrides Sub Finish
Visual C++
protected:
virtual void Finish() override

See Also

XMLExport Class
FastReport.Export.Xml Namespace


GetFileFilter Method

[image]

FastReport.Net Class Reference
XMLExport..::.GetFileFilter Method
XMLExport Class See Also Send Feedback
Returns a file filter for a save dialog.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetFileFilter()
Visual Basic (Declaration)
Protected Overrides Function GetFileFilter As String
Visual C++
protected:
virtual String^ GetFileFilter() override

Return Value

String that contains a file filter, for example: "Bitmap image (*.bmp)|*.bmp"

See Also

XMLExport Class
FastReport.Export.Xml Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
XMLExport..::.MemberwiseClone Method
XMLExport Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

XMLExport Class
XMLExport Members
FastReport.Export.Xml Namespace


Serialize Method

[image]

FastReport.Net Class Reference
XMLExport..::.Serialize Method
XMLExport Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

XMLExport Class
FastReport.Export.Xml Namespace


ShowDialog Method

[image]

FastReport.Net Class Reference
XMLExport..::.ShowDialog Method
XMLExport Class See Also Send Feedback
Displays a dialog with export options.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As Boolean
Visual C++
public:
virtual bool ShowDialog() override

Return Value

true if dialog was closed with OK button.

See Also

XMLExport Class
FastReport.Export.Xml Namespace


Start Method

[image]

FastReport.Net Class Reference
XMLExport..::.Start Method
XMLExport Class See Also Send Feedback
This method is called when the export starts.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Start()
Visual Basic (Declaration)
Protected Overrides Sub Start
Visual C++
protected:
virtual void Start() override

See Also

XMLExport Class
FastReport.Export.Xml Namespace


XMLExport Properties

[image] [image]

FastReport.Net Class Reference
XMLExport Properties
XMLExport Class See Also Send Feedback

The XMLExport type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowOpenAfter | Allows or disables the OpenAfterExport feature. (Inherited from ExportBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Creator | Gets or sets the name of document creator.
CurPage | Current page number. (Inherited from ExportBase.)
DataOnly | Gets or sets a value that determines whether to export the databand rows only.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileFilter | File filter that can be used in the "Save file" dialog. (Inherited from ExportBase.)
FileName | File name to export to. (Inherited from ExportBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GeneratedFiles | Gets a list of files generated by this export. (Inherited from ExportBase.)
HasMultipleFiles | Gets a value indicating that the export may produce multiple output files. (Inherited from ExportBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OpenAfterExport | Open the document after export. (Inherited from ExportBase.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreaks | Gets or sets a value that determines whether to insert page breaks in the output file or not.
PageNumbers | Page numbers to export. (Inherited from ExportBase.)
PageRange | Range of pages to export. (Inherited from ExportBase.)
Pages | Array of page numbers to export. (Inherited from ExportBase.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShowProgress | Gets or sets a value that determines whether to show progress window during export or not. (Inherited from ExportBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Stream | Stream to export to. (Inherited from ExportBase.)
Wysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Zoom factor for output file (Inherited from ExportBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

XMLExport Class
FastReport.Export.Xml Namespace


Creator Property

[image]

FastReport.Net Class Reference
XMLExport..::.Creator Property
XMLExport Class See Also Send Feedback
Gets or sets the name of document creator.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Creator { get; set; }
Visual Basic (Declaration)
Public Property Creator As String
Visual C++
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}

See Also

XMLExport Class
FastReport.Export.Xml Namespace


DataOnly Property

[image]

FastReport.Net Class Reference
XMLExport..::.DataOnly Property
XMLExport Class See Also Send Feedback
Gets or sets a value that determines whether to export the databand rows only.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool DataOnly { get; set; }
Visual Basic (Declaration)
Public Property DataOnly As Boolean
Visual C++
public:
property bool DataOnly {
    bool get ();
    void set (bool value);
}

See Also

XMLExport Class
FastReport.Export.Xml Namespace


PageBreaks Property

[image]

FastReport.Net Class Reference
XMLExport..::.PageBreaks Property
XMLExport Class See Also Send Feedback
Gets or sets a value that determines whether to insert page breaks in the output file or not.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreaks { get; set; }
Visual Basic (Declaration)
Public Property PageBreaks As Boolean
Visual C++
public:
property bool PageBreaks {
    bool get ();
    void set (bool value);
}

See Also

XMLExport Class
FastReport.Export.Xml Namespace


Wysiwyg Property

[image]

FastReport.Net Class Reference
XMLExport..::.Wysiwyg Property
XMLExport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Export.Xml
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Wysiwyg { get; set; }
Visual Basic (Declaration)
Public Property Wysiwyg As Boolean
Visual C++
public:
property bool Wysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting Excel file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

XMLExport Class
FastReport.Export.Xml Namespace


XMLExport Events

[image] [image]

FastReport.Net Class Reference
XMLExport Events
XMLExport Class See Also Send Feedback

The XMLExport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XMLExport Class
FastReport.Export.Xml Namespace


FastReport.FastQueryBuilder Namespace

[image]

FastReport.Net Class Reference
FastReport.FastQueryBuilder Namespace
Send Feedback

Classes

Class | Description
Field | For internal use only.
Link | For internal use only.


Field Class

[image]

FastReport.Net Class Reference
Field Class
Members See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Field
Visual Basic (Declaration)
Public Class Field
Visual C++
public ref class Field

Inheritance Hierarchy

System..::.Object
FastReport.FastQueryBuilder..::.Field

See Also

Field Members
FastReport.FastQueryBuilder Namespace


Field Members

[image] [image]

FastReport.Net Class Reference
Field Members
Field Class Methods Properties See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Alias | For internal use only.
Filter | For internal use only.
Func | For internal use only.
Group | For internal use only.
Name | For internal use only.
Order | For internal use only.

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Field Methods

[image] [image]

FastReport.Net Class Reference
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

Field Class
FastReport.FastQueryBuilder Namespace


ToString Method

[image]

FastReport.Net Class Reference
Field..::.ToString Method
Field Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Field Properties

[image] [image]

FastReport.Net Class Reference
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

Name | Description
Alias | For internal use only.
Filter | For internal use only.
Func | For internal use only.
Group | For internal use only.
Name | For internal use only.
Order | For internal use only.

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Alias Property

[image]

FastReport.Net Class Reference
Field..::.Alias Property
Field Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Alias { get; set; }
Visual Basic (Declaration)
Public Property Alias As String
Visual C++
public:
property String^ Alias {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Filter Property

[image]

FastReport.Net Class Reference
Field..::.Filter Property
Field Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Func Property

[image]

FastReport.Net Class Reference
Field..::.Func Property
Field Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Func { get; set; }
Visual Basic (Declaration)
Public Property Func As String
Visual C++
public:
property String^ Func {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Group Property

[image]

FastReport.Net Class Reference
Field..::.Group Property
Field Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Group { get; set; }
Visual Basic (Declaration)
Public Property Group As Boolean
Visual C++
public:
property bool Group {
    bool get ();
    void set (bool value);
}

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Name Property

[image]

FastReport.Net Class Reference
Field..::.Name Property
Field Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Order Property

[image]

FastReport.Net Class Reference
Field..::.Order Property
Field Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Order { get; set; }
Visual Basic (Declaration)
Public Property Order As String
Visual C++
public:
property String^ Order {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
FastReport.FastQueryBuilder Namespace


Link Class

[image]

FastReport.Net Class Reference
Link Class
Members See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class Link
Visual Basic (Declaration)
Public Class Link
Visual C++
public ref class Link

Inheritance Hierarchy

System..::.Object
FastReport.FastQueryBuilder..::.Link

See Also

Link Members
FastReport.FastQueryBuilder Namespace


Link Members

[image] [image]

FastReport.Net Class Reference
Link Members
Link Class Methods Properties See Also Send Feedback

The Link type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delete | For internal use only.
Editor | For internal use only.
Name | For internal use only.

See Also

Link Class
FastReport.FastQueryBuilder Namespace


Link Methods

[image] [image]

FastReport.Net Class Reference
Link Methods
Link Class See Also Send Feedback

The Link type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Link Class
FastReport.FastQueryBuilder Namespace


Link Properties

[image] [image]

FastReport.Net Class Reference
Link Properties
Link Class See Also Send Feedback

The Link type exposes the following members.

Properties

Name | Description
Delete | For internal use only.
Editor | For internal use only.
Name | For internal use only.

See Also

Link Class
FastReport.FastQueryBuilder Namespace


Delete Property

[image]

FastReport.Net Class Reference
Link..::.Delete Property
Link Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Delete { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delete As String
Visual C++
public:
property String^ Delete {
    String^ get ();
}

See Also

Link Class
FastReport.FastQueryBuilder Namespace


Editor Property

[image]

FastReport.Net Class Reference
Link..::.Editor Property
Link Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Editor { get; }
Visual Basic (Declaration)
Public ReadOnly Property Editor As String
Visual C++
public:
property String^ Editor {
    String^ get ();
}

See Also

Link Class
FastReport.FastQueryBuilder Namespace


Name Property

[image]

FastReport.Net Class Reference
Link..::.Name Property
Link Class See Also Send Feedback
For internal use only.

Namespace: FastReport.FastQueryBuilder
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Link Class
FastReport.FastQueryBuilder Namespace


FastReport.Format Namespace

[image]

FastReport.Net Class Reference
FastReport.Format Namespace
Send Feedback

Classes

Class | Description
BooleanFormat | Defines how boolean values are formatted and displayed.
CurrencyFormat | Defines how currency values are formatted and displayed.
CustomFormat | Represents a format that uses the Format string to display values.
DateFormat | Defines how date values are formatted and displayed.
FormatBase | Base class for all formats.
FormatCollection | Represents a collection of formats used by the TextObject and RichObject objects.
GeneralFormat | Represents a format used to display values with no formatting.
NumberFormat | Defines how numeric values are formatted and displayed.
PercentFormat | Defines how percent values are formatted and displayed.
TimeFormat | Defines how time values are formatted and displayed.


BooleanFormat Class

[image]

FastReport.Net Class Reference
BooleanFormat Class
Members See Also Send Feedback
Defines how boolean values are formatted and displayed.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BooleanFormat : FormatBase
Visual Basic (Declaration)
Public Class BooleanFormat _
    Inherits FormatBase
Visual C++
public ref class BooleanFormat : public FormatBase

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.BooleanFormat

See Also

BooleanFormat Members
FastReport.Format Namespace


BooleanFormat Members

[image] [image]

FastReport.Net Class Reference
BooleanFormat Members
BooleanFormat Class Constructors Methods Properties See Also Send Feedback

The BooleanFormat type exposes the following members.

Constructors

Name | Description
BooleanFormat | Initializes a new instance of the BooleanFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FalseText | Gets or sets a string that will be displayed if value is false.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
TrueText | Gets or sets a string that will be displayed if value is true.

See Also

BooleanFormat Class
FastReport.Format Namespace


BooleanFormat Constructor

[image]

FastReport.Net Class Reference
BooleanFormat Constructor
BooleanFormat Class See Also Send Feedback
Initializes a new instance of the BooleanFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BooleanFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BooleanFormat()

See Also

BooleanFormat Class
FastReport.Format Namespace


BooleanFormat Methods

[image] [image]

FastReport.Net Class Reference
BooleanFormat Methods
BooleanFormat Class See Also Send Feedback

The BooleanFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
BooleanFormat..::.Clone Method
BooleanFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

BooleanFormat Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
BooleanFormat..::.Equals Method
BooleanFormat Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

BooleanFormat Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
BooleanFormat..::.FormatValue Method
BooleanFormat Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public Overrides Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) override

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

BooleanFormat Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
BooleanFormat..::.GetHashCode Method
BooleanFormat Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

BooleanFormat Class
FastReport.Format Namespace


BooleanFormat Properties

[image] [image]

FastReport.Net Class Reference
BooleanFormat Properties
BooleanFormat Class See Also Send Feedback

The BooleanFormat type exposes the following members.

Properties

Name | Description
FalseText | Gets or sets a string that will be displayed if value is false.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
TrueText | Gets or sets a string that will be displayed if value is true.

See Also

BooleanFormat Class
FastReport.Format Namespace


FalseText Property

[image]

FastReport.Net Class Reference
BooleanFormat..::.FalseText Property
BooleanFormat Class See Also Send Feedback
Gets or sets a string that will be displayed if value is false.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string FalseText { get; set; }
Visual Basic (Declaration)
Public Property FalseText As String
Visual C++
public:
property String^ FalseText {
    String^ get ();
    void set (String^ value);
}

See Also

BooleanFormat Class
FastReport.Format Namespace


TrueText Property

[image]

FastReport.Net Class Reference
BooleanFormat..::.TrueText Property
BooleanFormat Class See Also Send Feedback
Gets or sets a string that will be displayed if value is true.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TrueText { get; set; }
Visual Basic (Declaration)
Public Property TrueText As String
Visual C++
public:
property String^ TrueText {
    String^ get ();
    void set (String^ value);
}

See Also

BooleanFormat Class
FastReport.Format Namespace


CurrencyFormat Class

[image]

FastReport.Net Class Reference
CurrencyFormat Class
Members See Also Send Feedback
Defines how currency values are formatted and displayed.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CurrencyFormat : FormatBase
Visual Basic (Declaration)
Public Class CurrencyFormat _
    Inherits FormatBase
Visual C++
public ref class CurrencyFormat : public FormatBase

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.CurrencyFormat

See Also

CurrencyFormat Members
FastReport.Format Namespace


CurrencyFormat Members

[image] [image]

FastReport.Net Class Reference
CurrencyFormat Members
CurrencyFormat Class Constructors Methods Properties See Also Send Feedback

The CurrencyFormat type exposes the following members.

Constructors

Name | Description
CurrencyFormat | Initializes a new instance of the CurrencyFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrencySymbol | Gets or sets the string to use as the currency symbol.
DecimalDigits | Gets or sets the number of decimal places to use in currency values.
DecimalSeparator | Gets or sets the string to use as the decimal separator in currency values.
GroupSeparator | Gets or sets the string that separates groups of digits to the left of the decimal in currency values.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
NegativePattern | Gets or sets the format pattern for negative currency values.
PositivePattern | Gets or sets the format pattern for positive currency values.
UseLocale | Gets or sets a value that determines whether to use system locale settings to format a value.

See Also

CurrencyFormat Class
FastReport.Format Namespace


CurrencyFormat Constructor

[image]

FastReport.Net Class Reference
CurrencyFormat Constructor
CurrencyFormat Class See Also Send Feedback
Initializes a new instance of the CurrencyFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CurrencyFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurrencyFormat()

See Also

CurrencyFormat Class
FastReport.Format Namespace


CurrencyFormat Methods

[image] [image]

FastReport.Net Class Reference
CurrencyFormat Methods
CurrencyFormat Class See Also Send Feedback

The CurrencyFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurrencyFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
CurrencyFormat..::.Clone Method
CurrencyFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

CurrencyFormat Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
CurrencyFormat..::.Equals Method
CurrencyFormat Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

CurrencyFormat Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
CurrencyFormat..::.FormatValue Method
CurrencyFormat Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public Overrides Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) override

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

CurrencyFormat Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
CurrencyFormat..::.GetHashCode Method
CurrencyFormat Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

CurrencyFormat Class
FastReport.Format Namespace


CurrencyFormat Properties

[image] [image]

FastReport.Net Class Reference
CurrencyFormat Properties
CurrencyFormat Class See Also Send Feedback

The CurrencyFormat type exposes the following members.

Properties

Name | Description
CurrencySymbol | Gets or sets the string to use as the currency symbol.
DecimalDigits | Gets or sets the number of decimal places to use in currency values.
DecimalSeparator | Gets or sets the string to use as the decimal separator in currency values.
GroupSeparator | Gets or sets the string that separates groups of digits to the left of the decimal in currency values.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
NegativePattern | Gets or sets the format pattern for negative currency values.
PositivePattern | Gets or sets the format pattern for positive currency values.
UseLocale | Gets or sets a value that determines whether to use system locale settings to format a value.

See Also

CurrencyFormat Class
FastReport.Format Namespace


CurrencySymbol Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.CurrencySymbol Property
CurrencyFormat Class See Also Send Feedback
Gets or sets the string to use as the currency symbol.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CurrencySymbol { get; set; }
Visual Basic (Declaration)
Public Property CurrencySymbol As String
Visual C++
public:
property String^ CurrencySymbol {
    String^ get ();
    void set (String^ value);
}

See Also

CurrencyFormat Class
FastReport.Format Namespace


DecimalDigits Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.DecimalDigits Property
CurrencyFormat Class See Also Send Feedback
Gets or sets the number of decimal places to use in currency values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DecimalDigits { get; set; }
Visual Basic (Declaration)
Public Property DecimalDigits As Integer
Visual C++
public:
property int DecimalDigits {
    int get ();
    void set (int value);
}

See Also

CurrencyFormat Class
FastReport.Format Namespace


DecimalSeparator Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.DecimalSeparator Property
CurrencyFormat Class See Also Send Feedback
Gets or sets the string to use as the decimal separator in currency values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DecimalSeparator { get; set; }
Visual Basic (Declaration)
Public Property DecimalSeparator As String
Visual C++
public:
property String^ DecimalSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

CurrencyFormat Class
FastReport.Format Namespace


GroupSeparator Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.GroupSeparator Property
CurrencyFormat Class See Also Send Feedback
Gets or sets the string that separates groups of digits to the left of the decimal in currency values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GroupSeparator { get; set; }
Visual Basic (Declaration)
Public Property GroupSeparator As String
Visual C++
public:
property String^ GroupSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

CurrencyFormat Class
FastReport.Format Namespace


NegativePattern Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.NegativePattern Property
CurrencyFormat Class See Also Send Feedback
Gets or sets the format pattern for negative currency values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int NegativePattern { get; set; }
Visual Basic (Declaration)
Public Property NegativePattern As Integer
Visual C++
public:
property int NegativePattern {
    int get ();
    void set (int value);
}

Remarks

This property can have one of the values in the following table. The symbol "$" is the CurrencySymbol and n is a number.
Value | Associated Pattern
0 | ($n)
1 | -$n
2 | $-n
3 | $n-
4 | (n$)
5 | -n$
6 | n-$
7 | n$-
8 | -n $
9 | -$ n
10 | n $-
11 | $ n-
12 | $ -n
13 | n- $
14 | ($ n)
15 | (n $)

See Also

CurrencyFormat Class
FastReport.Format Namespace


PositivePattern Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.PositivePattern Property
CurrencyFormat Class See Also Send Feedback
Gets or sets the format pattern for positive currency values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PositivePattern { get; set; }
Visual Basic (Declaration)
Public Property PositivePattern As Integer
Visual C++
public:
property int PositivePattern {
    int get ();
    void set (int value);
}

Remarks

This property can have one of the values in the following table. The symbol "$" is the CurrencySymbol and n is a number.
Value | Associated Pattern
0 | $n
1 | n$
2 | $ n
3 | n $

See Also

CurrencyFormat Class
FastReport.Format Namespace


UseLocale Property

[image]

FastReport.Net Class Reference
CurrencyFormat..::.UseLocale Property
CurrencyFormat Class See Also Send Feedback
Gets or sets a value that determines whether to use system locale settings to format a value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseLocale { get; set; }
Visual Basic (Declaration)
Public Property UseLocale As Boolean
Visual C++
public:
property bool UseLocale {
    bool get ();
    void set (bool value);
}

See Also

CurrencyFormat Class
FastReport.Format Namespace


CustomFormat Class

[image]

FastReport.Net Class Reference
CustomFormat Class
Members See Also Send Feedback
Represents a format that uses the Format string to display values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CustomFormat : FormatBase
Visual Basic (Declaration)
Public Class CustomFormat _
    Inherits FormatBase
Visual C++
public ref class CustomFormat : public FormatBase

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.CustomFormat
FastReport.Format..::.DateFormat
FastReport.Format..::.TimeFormat

See Also

CustomFormat Members
FastReport.Format Namespace


CustomFormat Members

[image] [image]

FastReport.Net Class Reference
CustomFormat Members
CustomFormat Class Constructors Methods Properties See Also Send Feedback

The CustomFormat type exposes the following members.

Constructors

Name | Description
CustomFormat | Initializes a new instance of the CustomFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Format | Gets or sets a format string.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

CustomFormat Class
FastReport.Format Namespace


CustomFormat Constructor

[image]

FastReport.Net Class Reference
CustomFormat Constructor
CustomFormat Class See Also Send Feedback
Initializes a new instance of the CustomFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public CustomFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CustomFormat()

See Also

CustomFormat Class
FastReport.Format Namespace


CustomFormat Methods

[image] [image]

FastReport.Net Class Reference
CustomFormat Methods
CustomFormat Class See Also Send Feedback

The CustomFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
CustomFormat..::.Clone Method
CustomFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

CustomFormat Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
CustomFormat..::.Equals Method
CustomFormat Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

CustomFormat Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
CustomFormat..::.FormatValue Method
CustomFormat Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public Overrides Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) override

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

CustomFormat Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
CustomFormat..::.GetHashCode Method
CustomFormat Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

CustomFormat Class
FastReport.Format Namespace


CustomFormat Properties

[image] [image]

FastReport.Net Class Reference
CustomFormat Properties
CustomFormat Class See Also Send Feedback

The CustomFormat type exposes the following members.

Properties

Name | Description
Format | Gets or sets a format string.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

CustomFormat Class
FastReport.Format Namespace


Format Property

[image]

FastReport.Net Class Reference
CustomFormat..::.Format Property
CustomFormat Class See Also Send Feedback
Gets or sets a format string.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

Remarks

Default format is "G". For example, if you want to format a date, use the following format string: "MM/dd/yyyy". See the System.String.Format method for list of possible format strings.

See Also

CustomFormat Class
FastReport.Format Namespace


DateFormat Class

[image]

FastReport.Net Class Reference
DateFormat Class
Members See Also Send Feedback
Defines how date values are formatted and displayed.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DateFormat : CustomFormat
Visual Basic (Declaration)
Public Class DateFormat _
    Inherits CustomFormat
Visual C++
public ref class DateFormat : public CustomFormat

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.CustomFormat
FastReport.Format..::.DateFormat

See Also

DateFormat Members
FastReport.Format Namespace


DateFormat Members

[image] [image]

FastReport.Net Class Reference
DateFormat Members
DateFormat Class Constructors Methods Properties See Also Send Feedback

The DateFormat type exposes the following members.

Constructors

Name | Description
DateFormat | Initializes a new instance of the DateFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides CustomFormat..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from CustomFormat.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Inherited from CustomFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from CustomFormat.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Format | Gets or sets a format string. (Inherited from CustomFormat.)
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

DateFormat Class
FastReport.Format Namespace


DateFormat Constructor

[image]

FastReport.Net Class Reference
DateFormat Constructor
DateFormat Class See Also Send Feedback
Initializes a new instance of the DateFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DateFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateFormat()

See Also

DateFormat Class
FastReport.Format Namespace


DateFormat Methods

[image] [image]

FastReport.Net Class Reference
DateFormat Methods
DateFormat Class See Also Send Feedback

The DateFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides CustomFormat..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from CustomFormat.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Inherited from CustomFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from CustomFormat.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
DateFormat..::.Clone Method
DateFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

DateFormat Class
FastReport.Format Namespace


DateFormat Properties

[image] [image]

FastReport.Net Class Reference
DateFormat Properties
DateFormat Class See Also Send Feedback

The DateFormat type exposes the following members.

Properties

Name | Description
Format | Gets or sets a format string. (Inherited from CustomFormat.)
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

DateFormat Class
FastReport.Format Namespace


FormatBase Class

[image]

FastReport.Net Class Reference
FormatBase Class
Members See Also Send Feedback
Base class for all formats.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class FormatBase : IFRSerializable
Visual Basic (Declaration)
Public MustInherit Class FormatBase _
    Implements IFRSerializable
Visual C++
public ref class FormatBase abstract : IFRSerializable

Remarks

The format is used to format expression value in a TextObject object.

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.BooleanFormat
FastReport.Format..::.CurrencyFormat
FastReport.Format..::.CustomFormat
FastReport.Format..::.GeneralFormat
FastReport.Format..::.NumberFormat
FastReport.Format..::.PercentFormat

See Also

FormatBase Members
FastReport.Format Namespace


FormatBase Members

[image] [image]

FastReport.Net Class Reference
FormatBase Members
FormatBase Class Constructors Methods Properties See Also Send Feedback

The FormatBase type exposes the following members.

Constructors

Name | Description
FormatBase | Initializes a new instance of the FormatBase class

Methods

Name | Description
Clone | Creates exact copy of this format.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the short format name (e.g. without a "Format" suffix).

See Also

FormatBase Class
FastReport.Format Namespace


FormatBase Constructor

[image]

FastReport.Net Class Reference
FormatBase Constructor
FormatBase Class See Also Send Feedback
Initializes a new instance of the FormatBase class

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected FormatBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
FormatBase()

See Also

FormatBase Class
FastReport.Format Namespace


FormatBase Methods

[image] [image]

FastReport.Net Class Reference
FormatBase Methods
FormatBase Class See Also Send Feedback

The FormatBase type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatBase Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
FormatBase..::.Clone Method
FormatBase Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract FormatBase Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() abstract

Return Value

The copy of this format.

See Also

FormatBase Class
FastReport.Format Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
FormatBase..::.Deserialize Method
FormatBase Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

FormatBase Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
FormatBase..::.FormatValue Method
FormatBase Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public MustOverride Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) abstract

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

FormatBase Class
FastReport.Format Namespace


Serialize Method

[image]

FastReport.Net Class Reference
FormatBase..::.Serialize Method
FormatBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

FormatBase Class
FastReport.Format Namespace


FormatBase Properties

[image] [image]

FastReport.Net Class Reference
FormatBase Properties
FormatBase Class See Also Send Feedback

The FormatBase type exposes the following members.

Properties

Name | Description
Name | Gets the short format name (e.g. without a "Format" suffix).

See Also

FormatBase Class
FastReport.Format Namespace


Name Property

[image]

FastReport.Net Class Reference
FormatBase..::.Name Property
FormatBase Class See Also Send Feedback
Gets the short format name (e.g. without a "Format" suffix).

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FormatBase Class
FastReport.Format Namespace


FormatCollection Class

[image]

FastReport.Net Class Reference
FormatCollection Class
Members See Also Send Feedback
Represents a collection of formats used by the TextObject and RichObject objects.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FormatCollection : CollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class FormatCollection _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class FormatCollection : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Format..::.FormatCollection

See Also

FormatCollection Members
FastReport.Format Namespace


FormatCollection Members

[image] [image]

FastReport.Net Class Reference
FormatCollection Members
FormatCollection Class Constructors Methods Properties See Also Send Feedback

The FormatCollection type exposes the following members.

Constructors

Name | Description
FormatCollection | Initializes a new instance of the FormatCollection class

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Assign | Copies formats from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FormatCollection Class
FastReport.Format Namespace


FormatCollection Constructor

[image]

FastReport.Net Class Reference
FormatCollection Constructor
FormatCollection Class See Also Send Feedback
Initializes a new instance of the FormatCollection class

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FormatCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormatCollection()

See Also

FormatCollection Class
FastReport.Format Namespace


FormatCollection Methods

[image] [image]

FastReport.Net Class Reference
FormatCollection Methods
FormatCollection Class See Also Send Feedback

The FormatCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Adds the specified elements to the end of this collection.
Assign | Copies formats from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatCollection Class
FastReport.Format Namespace


Add Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Add Method
FormatCollection Class See Also Send Feedback
Adds an object to the end of this collection.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    FormatBase value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As FormatBase _
) As Integer
Visual C++
public:
int Add(
    FormatBase^ value
)

Parameters

value
Type: FastReport.Format..::.FormatBase
Object to add.

Return Value

Index of the added object.

See Also

FormatCollection Class
FastReport.Format Namespace


AddRange Method

[image]

FastReport.Net Class Reference
FormatCollection..::.AddRange Method
FormatCollection Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    FormatBase[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As FormatBase() _
)
Visual C++
public:
void AddRange(
    array<FormatBase^>^ range
)

Parameters

range
Type: array< FastReport.Format..::.FormatBase >[]()[]
Array of elements to add.

See Also

FormatCollection Class
FastReport.Format Namespace


Assign Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Assign Method
FormatCollection Class See Also Send Feedback
Copies formats from another collection.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    FormatCollection collection
)
Visual Basic (Declaration)
Public Sub Assign ( _
    collection As FormatCollection _
)
Visual C++
public:
void Assign(
    FormatCollection^ collection
)

Parameters

collection
Type: FastReport.Format..::.FormatCollection
Collection to copy from.

See Also

FormatCollection Class
FastReport.Format Namespace


Contains Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Contains Method
FormatCollection Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    FormatBase value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As FormatBase _
) As Boolean
Visual C++
public:
bool Contains(
    FormatBase^ value
)

Parameters

value
Type: FastReport.Format..::.FormatBase
The object to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

FormatCollection Class
FastReport.Format Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Deserialize Method
FormatCollection Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

FormatCollection Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Equals Method
FormatCollection Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

FormatCollection Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
FormatCollection..::.GetHashCode Method
FormatCollection Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

FormatCollection Class
FastReport.Format Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
FormatCollection..::.IndexOf Method
FormatCollection Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    FormatBase value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As FormatBase _
) As Integer
Visual C++
public:
int IndexOf(
    FormatBase^ value
)

Parameters

value
Type: FastReport.Format..::.FormatBase
The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

FormatCollection Class
FastReport.Format Namespace


Insert Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Insert Method
FormatCollection Class See Also Send Feedback
Inserts an object into this collection at the specified index.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    FormatBase value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As FormatBase _
)
Visual C++
public:
void Insert(
    int index,
    FormatBase^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport.Format..::.FormatBase
The object to insert.

See Also

FormatCollection Class
FastReport.Format Namespace


Remove Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Remove Method
FormatCollection Class See Also Send Feedback
Removes the specified object from the collection.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    FormatBase value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As FormatBase _
)
Visual C++
public:
void Remove(
    FormatBase^ value
)

Parameters

value
Type: FastReport.Format..::.FormatBase
Object to remove.

See Also

FormatCollection Class
FastReport.Format Namespace


Serialize Method

[image]

FastReport.Net Class Reference
FormatCollection..::.Serialize Method
FormatCollection Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

FormatCollection Class
FastReport.Format Namespace


FormatCollection Properties

[image] [image]

FastReport.Net Class Reference
FormatCollection Properties
FormatCollection Class See Also Send Feedback

The FormatCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FormatCollection Class
FastReport.Format Namespace


Item Property

[image]

FastReport.Net Class Reference
FormatCollection..::.Item Property
FormatCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FormatBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As FormatBase
Visual C++
public:
property FormatBase^ default[int index] {
    FormatBase^ get (int index);
    void set (int index, FormatBase^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

FormatCollection Class
FastReport.Format Namespace


GeneralFormat Class

[image]

FastReport.Net Class Reference
GeneralFormat Class
Members See Also Send Feedback
Represents a format used to display values with no formatting.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class GeneralFormat : FormatBase
Visual Basic (Declaration)
Public Class GeneralFormat _
    Inherits FormatBase
Visual C++
public ref class GeneralFormat : public FormatBase

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.GeneralFormat

See Also

GeneralFormat Members
FastReport.Format Namespace


GeneralFormat Members

[image] [image]

FastReport.Net Class Reference
GeneralFormat Members
GeneralFormat Class Constructors Methods Properties See Also Send Feedback

The GeneralFormat type exposes the following members.

Constructors

Name | Description
GeneralFormat | Initializes a new instance of the GeneralFormat class

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

GeneralFormat Class
FastReport.Format Namespace


GeneralFormat Constructor

[image]

FastReport.Net Class Reference
GeneralFormat Constructor
GeneralFormat Class See Also Send Feedback
Initializes a new instance of the GeneralFormat class

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GeneralFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeneralFormat()

See Also

GeneralFormat Class
FastReport.Format Namespace


GeneralFormat Methods

[image] [image]

FastReport.Net Class Reference
GeneralFormat Methods
GeneralFormat Class See Also Send Feedback

The GeneralFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeneralFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
GeneralFormat..::.Clone Method
GeneralFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

GeneralFormat Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
GeneralFormat..::.Equals Method
GeneralFormat Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

GeneralFormat Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
GeneralFormat..::.FormatValue Method
GeneralFormat Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public Overrides Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) override

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

GeneralFormat Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
GeneralFormat..::.GetHashCode Method
GeneralFormat Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

GeneralFormat Class
FastReport.Format Namespace


GeneralFormat Properties

[image] [image]

FastReport.Net Class Reference
GeneralFormat Properties
GeneralFormat Class See Also Send Feedback

The GeneralFormat type exposes the following members.

Properties

Name | Description
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

GeneralFormat Class
FastReport.Format Namespace


NumberFormat Class

[image]

FastReport.Net Class Reference
NumberFormat Class
Members See Also Send Feedback
Defines how numeric values are formatted and displayed.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NumberFormat : FormatBase
Visual Basic (Declaration)
Public Class NumberFormat _
    Inherits FormatBase
Visual C++
public ref class NumberFormat : public FormatBase

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.NumberFormat

See Also

NumberFormat Members
FastReport.Format Namespace


NumberFormat Members

[image] [image]

FastReport.Net Class Reference
NumberFormat Members
NumberFormat Class Constructors Methods Properties See Also Send Feedback

The NumberFormat type exposes the following members.

Constructors

Name | Description
NumberFormat | Initializes a new instance of the NumberFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DecimalDigits | Gets or sets the number of decimal places to use in numeric values.
DecimalSeparator | Gets or sets the string to use as the decimal separator in numeric values.
GroupSeparator | Gets or sets the string that separates groups of digits to the left of the decimal in numeric values.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
NegativePattern | Gets or sets the format pattern for negative numeric values.
UseLocale | Gets or sets a value that determines whether to use system locale settings to format a value.

See Also

NumberFormat Class
FastReport.Format Namespace


NumberFormat Constructor

[image]

FastReport.Net Class Reference
NumberFormat Constructor
NumberFormat Class See Also Send Feedback
Initializes a new instance of the NumberFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NumberFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NumberFormat()

See Also

NumberFormat Class
FastReport.Format Namespace


NumberFormat Methods

[image] [image]

FastReport.Net Class Reference
NumberFormat Methods
NumberFormat Class See Also Send Feedback

The NumberFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumberFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
NumberFormat..::.Clone Method
NumberFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

NumberFormat Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
NumberFormat..::.Equals Method
NumberFormat Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

NumberFormat Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
NumberFormat..::.FormatValue Method
NumberFormat Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public Overrides Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) override

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

NumberFormat Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
NumberFormat..::.GetHashCode Method
NumberFormat Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

NumberFormat Class
FastReport.Format Namespace


NumberFormat Properties

[image] [image]

FastReport.Net Class Reference
NumberFormat Properties
NumberFormat Class See Also Send Feedback

The NumberFormat type exposes the following members.

Properties

Name | Description
DecimalDigits | Gets or sets the number of decimal places to use in numeric values.
DecimalSeparator | Gets or sets the string to use as the decimal separator in numeric values.
GroupSeparator | Gets or sets the string that separates groups of digits to the left of the decimal in numeric values.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
NegativePattern | Gets or sets the format pattern for negative numeric values.
UseLocale | Gets or sets a value that determines whether to use system locale settings to format a value.

See Also

NumberFormat Class
FastReport.Format Namespace


DecimalDigits Property

[image]

FastReport.Net Class Reference
NumberFormat..::.DecimalDigits Property
NumberFormat Class See Also Send Feedback
Gets or sets the number of decimal places to use in numeric values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DecimalDigits { get; set; }
Visual Basic (Declaration)
Public Property DecimalDigits As Integer
Visual C++
public:
property int DecimalDigits {
    int get ();
    void set (int value);
}

See Also

NumberFormat Class
FastReport.Format Namespace


DecimalSeparator Property

[image]

FastReport.Net Class Reference
NumberFormat..::.DecimalSeparator Property
NumberFormat Class See Also Send Feedback
Gets or sets the string to use as the decimal separator in numeric values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DecimalSeparator { get; set; }
Visual Basic (Declaration)
Public Property DecimalSeparator As String
Visual C++
public:
property String^ DecimalSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

NumberFormat Class
FastReport.Format Namespace


GroupSeparator Property

[image]

FastReport.Net Class Reference
NumberFormat..::.GroupSeparator Property
NumberFormat Class See Also Send Feedback
Gets or sets the string that separates groups of digits to the left of the decimal in numeric values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GroupSeparator { get; set; }
Visual Basic (Declaration)
Public Property GroupSeparator As String
Visual C++
public:
property String^ GroupSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

NumberFormat Class
FastReport.Format Namespace


NegativePattern Property

[image]

FastReport.Net Class Reference
NumberFormat..::.NegativePattern Property
NumberFormat Class See Also Send Feedback
Gets or sets the format pattern for negative numeric values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int NegativePattern { get; set; }
Visual Basic (Declaration)
Public Property NegativePattern As Integer
Visual C++
public:
property int NegativePattern {
    int get ();
    void set (int value);
}

Remarks

This property can have one of the values in the following table. The symbol n is a number.
Value | Associated Pattern
0 | (n)
1 | -n
2 | - n
3 | n-
4 | n -

See Also

NumberFormat Class
FastReport.Format Namespace


UseLocale Property

[image]

FastReport.Net Class Reference
NumberFormat..::.UseLocale Property
NumberFormat Class See Also Send Feedback
Gets or sets a value that determines whether to use system locale settings to format a value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseLocale { get; set; }
Visual Basic (Declaration)
Public Property UseLocale As Boolean
Visual C++
public:
property bool UseLocale {
    bool get ();
    void set (bool value);
}

See Also

NumberFormat Class
FastReport.Format Namespace


PercentFormat Class

[image]

FastReport.Net Class Reference
PercentFormat Class
Members See Also Send Feedback
Defines how percent values are formatted and displayed.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PercentFormat : FormatBase
Visual Basic (Declaration)
Public Class PercentFormat _
    Inherits FormatBase
Visual C++
public ref class PercentFormat : public FormatBase

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.PercentFormat

See Also

PercentFormat Members
FastReport.Format Namespace


PercentFormat Members

[image] [image]

FastReport.Net Class Reference
PercentFormat Members
PercentFormat Class Constructors Methods Properties See Also Send Feedback

The PercentFormat type exposes the following members.

Constructors

Name | Description
PercentFormat | Initializes a new instance of the PercentFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DecimalDigits | Gets or sets the number of decimal places to use in percent values.
DecimalSeparator | Gets or sets the string to use as the decimal separator in percent values.
GroupSeparator | Gets or sets the string that separates groups of digits to the left of the decimal in percent values.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
NegativePattern | Gets or sets the format pattern for negative percent values.
PercentSymbol | Gets or sets the string to use as the percent symbol.
PositivePattern | Gets or sets the format pattern for positive percent values.
UseLocale | Gets or sets a value that determines whether to use system locale settings to format a value.

See Also

PercentFormat Class
FastReport.Format Namespace


PercentFormat Constructor

[image]

FastReport.Net Class Reference
PercentFormat Constructor
PercentFormat Class See Also Send Feedback
Initializes a new instance of the PercentFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PercentFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PercentFormat()

See Also

PercentFormat Class
FastReport.Format Namespace


PercentFormat Methods

[image] [image]

FastReport.Net Class Reference
PercentFormat Methods
PercentFormat Class See Also Send Feedback

The PercentFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides FormatBase..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Overrides FormatBase..::.FormatValue(Object).)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PercentFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
PercentFormat..::.Clone Method
PercentFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

PercentFormat Class
FastReport.Format Namespace


Equals Method

[image]

FastReport.Net Class Reference
PercentFormat..::.Equals Method
PercentFormat Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

PercentFormat Class
FastReport.Format Namespace


FormatValue Method

[image]

FastReport.Net Class Reference
PercentFormat..::.FormatValue Method
PercentFormat Class See Also Send Feedback
Formats the specified value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string FormatValue(
    Object value
)
Visual Basic (Declaration)
Public Overrides Function FormatValue ( _
    value As Object _
) As String
Visual C++
public:
virtual String^ FormatValue(
    Object^ value
) override

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The string that represents the formatted value.

See Also

PercentFormat Class
FastReport.Format Namespace


GetHashCode Method

[image]

FastReport.Net Class Reference
PercentFormat..::.GetHashCode Method
PercentFormat Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

PercentFormat Class
FastReport.Format Namespace


PercentFormat Properties

[image] [image]

FastReport.Net Class Reference
PercentFormat Properties
PercentFormat Class See Also Send Feedback

The PercentFormat type exposes the following members.

Properties

Name | Description
DecimalDigits | Gets or sets the number of decimal places to use in percent values.
DecimalSeparator | Gets or sets the string to use as the decimal separator in percent values.
GroupSeparator | Gets or sets the string that separates groups of digits to the left of the decimal in percent values.
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)
NegativePattern | Gets or sets the format pattern for negative percent values.
PercentSymbol | Gets or sets the string to use as the percent symbol.
PositivePattern | Gets or sets the format pattern for positive percent values.
UseLocale | Gets or sets a value that determines whether to use system locale settings to format a value.

See Also

PercentFormat Class
FastReport.Format Namespace


DecimalDigits Property

[image]

FastReport.Net Class Reference
PercentFormat..::.DecimalDigits Property
PercentFormat Class See Also Send Feedback
Gets or sets the number of decimal places to use in percent values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int DecimalDigits { get; set; }
Visual Basic (Declaration)
Public Property DecimalDigits As Integer
Visual C++
public:
property int DecimalDigits {
    int get ();
    void set (int value);
}

See Also

PercentFormat Class
FastReport.Format Namespace


DecimalSeparator Property

[image]

FastReport.Net Class Reference
PercentFormat..::.DecimalSeparator Property
PercentFormat Class See Also Send Feedback
Gets or sets the string to use as the decimal separator in percent values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DecimalSeparator { get; set; }
Visual Basic (Declaration)
Public Property DecimalSeparator As String
Visual C++
public:
property String^ DecimalSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

PercentFormat Class
FastReport.Format Namespace


GroupSeparator Property

[image]

FastReport.Net Class Reference
PercentFormat..::.GroupSeparator Property
PercentFormat Class See Also Send Feedback
Gets or sets the string that separates groups of digits to the left of the decimal in percent values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GroupSeparator { get; set; }
Visual Basic (Declaration)
Public Property GroupSeparator As String
Visual C++
public:
property String^ GroupSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

PercentFormat Class
FastReport.Format Namespace


NegativePattern Property

[image]

FastReport.Net Class Reference
PercentFormat..::.NegativePattern Property
PercentFormat Class See Also Send Feedback
Gets or sets the format pattern for negative percent values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int NegativePattern { get; set; }
Visual Basic (Declaration)
Public Property NegativePattern As Integer
Visual C++
public:
property int NegativePattern {
    int get ();
    void set (int value);
}

Remarks

This property can have one of the values in the following table. The symbol "%" is the PercentSymbol and n is a number.
Value | Associated Pattern
0 | -n %
1 | -n%
2 | -%n
3 | %-n
4 | %n-
5 | n-%
6 | n%-
7 | -%n
8 | n %-
9 | % n-
10 | % -n
11 | n- %

See Also

PercentFormat Class
FastReport.Format Namespace


PercentSymbol Property

[image]

FastReport.Net Class Reference
PercentFormat..::.PercentSymbol Property
PercentFormat Class See Also Send Feedback
Gets or sets the string to use as the percent symbol.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PercentSymbol { get; set; }
Visual Basic (Declaration)
Public Property PercentSymbol As String
Visual C++
public:
property String^ PercentSymbol {
    String^ get ();
    void set (String^ value);
}

See Also

PercentFormat Class
FastReport.Format Namespace


PositivePattern Property

[image]

FastReport.Net Class Reference
PercentFormat..::.PositivePattern Property
PercentFormat Class See Also Send Feedback
Gets or sets the format pattern for positive percent values.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PositivePattern { get; set; }
Visual Basic (Declaration)
Public Property PositivePattern As Integer
Visual C++
public:
property int PositivePattern {
    int get ();
    void set (int value);
}

Remarks

This property can have one of the values in the following table. The symbol "%" is the PercentSymbol and n is a number.
Value | Associated Pattern
0 | n %
1 | n%
2 | %n
3 | % n

See Also

PercentFormat Class
FastReport.Format Namespace


UseLocale Property

[image]

FastReport.Net Class Reference
PercentFormat..::.UseLocale Property
PercentFormat Class See Also Send Feedback
Gets or sets a value that determines whether to use system locale settings to format a value.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseLocale { get; set; }
Visual Basic (Declaration)
Public Property UseLocale As Boolean
Visual C++
public:
property bool UseLocale {
    bool get ();
    void set (bool value);
}

See Also

PercentFormat Class
FastReport.Format Namespace


TimeFormat Class

[image]

FastReport.Net Class Reference
TimeFormat Class
Members See Also Send Feedback
Defines how time values are formatted and displayed.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TimeFormat : CustomFormat
Visual Basic (Declaration)
Public Class TimeFormat _
    Inherits CustomFormat
Visual C++
public ref class TimeFormat : public CustomFormat

Inheritance Hierarchy

System..::.Object
FastReport.Format..::.FormatBase
FastReport.Format..::.CustomFormat
FastReport.Format..::.TimeFormat

See Also

TimeFormat Members
FastReport.Format Namespace


TimeFormat Members

[image] [image]

FastReport.Net Class Reference
TimeFormat Members
TimeFormat Class Constructors Methods Properties See Also Send Feedback

The TimeFormat type exposes the following members.

Constructors

Name | Description
TimeFormat | Initializes a new instance of the TimeFormat class with default settings.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides CustomFormat..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from CustomFormat.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Inherited from CustomFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from CustomFormat.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Format | Gets or sets a format string. (Inherited from CustomFormat.)
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

TimeFormat Class
FastReport.Format Namespace


TimeFormat Constructor

[image]

FastReport.Net Class Reference
TimeFormat Constructor
TimeFormat Class See Also Send Feedback
Initializes a new instance of the TimeFormat class with default settings.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TimeFormat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeFormat()

See Also

TimeFormat Class
FastReport.Format Namespace


TimeFormat Methods

[image] [image]

FastReport.Net Class Reference
TimeFormat Methods
TimeFormat Class See Also Send Feedback

The TimeFormat type exposes the following members.

Methods

Name | Description
Clone | Creates exact copy of this format. (Overrides CustomFormat..::.Clone()()().)
Deserialize | Deserializes the object. (Inherited from FormatBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from CustomFormat.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatValue | Formats the specified value. (Inherited from CustomFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from CustomFormat.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Inherited from FormatBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeFormat Class
FastReport.Format Namespace


Clone Method

[image]

FastReport.Net Class Reference
TimeFormat..::.Clone Method
TimeFormat Class See Also Send Feedback
Creates exact copy of this format.

Namespace: FastReport.Format
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FormatBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As FormatBase
Visual C++
public:
virtual FormatBase^ Clone() override

Return Value

The copy of this format.

See Also

TimeFormat Class
FastReport.Format Namespace


TimeFormat Properties

[image] [image]

FastReport.Net Class Reference
TimeFormat Properties
TimeFormat Class See Also Send Feedback

The TimeFormat type exposes the following members.

Properties

Name | Description
Format | Gets or sets a format string. (Inherited from CustomFormat.)
Name | Gets the short format name (e.g. without a "Format" suffix). (Inherited from FormatBase.)

See Also

TimeFormat Class
FastReport.Format Namespace


FastReport.Forms Namespace

[image]

FastReport.Net Class Reference
FastReport.Forms Namespace
Send Feedback

Classes

Class | Description
AdvancedConnectionPropertiesForm | The "Advanced Connection Properties" form.
BaseDialogForm | Base class for all dialog forms with two buttons, OK and Cancel.
BaseExportForm | Base form for all export options dialog forms.
DesignerOptionsPage | The base class for designer plugin's options page.
ExceptionForm | Represents the FastReport exception form.


AdvancedConnectionPropertiesForm Class

[image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Class
Members See Also Send Feedback
The "Advanced Connection Properties" form.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AdvancedConnectionPropertiesForm : BaseDialogForm
Visual Basic (Declaration)
Public Class AdvancedConnectionPropertiesForm _
    Inherits BaseDialogForm
Visual C++
public ref class AdvancedConnectionPropertiesForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Forms..::.AdvancedConnectionPropertiesForm

See Also

AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


AdvancedConnectionPropertiesForm Members

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Members
AdvancedConnectionPropertiesForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The AdvancedConnectionPropertiesForm type exposes the following members.

Constructors

Name | Description
AdvancedConnectionPropertiesForm | Initializes a new instance of the AdvancedConnectionPropertiesForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AdvancedProperties | Gets or sets the connection string builder which contains the connection properties.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


AdvancedConnectionPropertiesForm Constructor

[image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Constructor
AdvancedConnectionPropertiesForm Class See Also Send Feedback
Initializes a new instance of the AdvancedConnectionPropertiesForm class.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AdvancedConnectionPropertiesForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedConnectionPropertiesForm()

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


AdvancedConnectionPropertiesForm Fields

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Fields
AdvancedConnectionPropertiesForm Class See Also Send Feedback

The AdvancedConnectionPropertiesForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


AdvancedConnectionPropertiesForm Methods

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Methods
AdvancedConnectionPropertiesForm Class See Also Send Feedback

The AdvancedConnectionPropertiesForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Inherited from BaseDialogForm.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.AccessibilityNotifyClients Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.BeginInvoke Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Dispose Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Dispose Method (Boolean)
AdvancedConnectionPropertiesForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AdvancedConnectionPropertiesForm Class
Dispose Overload
FastReport.Forms Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.GetChildAtPoint Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Invalidate Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Invoke Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.MemberwiseClone Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.PerformLayout Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.ResumeLayout Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.RtlTranslateAlignment Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Scale Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Select Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.SetBounds Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Show Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.ShowDialog Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.UpdateBounds Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.Validate Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.ValidateChildren Method
AdvancedConnectionPropertiesForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AdvancedConnectionPropertiesForm Class
AdvancedConnectionPropertiesForm Members
FastReport.Forms Namespace


AdvancedConnectionPropertiesForm Properties

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Properties
AdvancedConnectionPropertiesForm Class See Also Send Feedback

The AdvancedConnectionPropertiesForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AdvancedProperties | Gets or sets the connection string builder which contains the connection properties.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


AdvancedProperties Property

[image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm..::.AdvancedProperties Property
AdvancedConnectionPropertiesForm Class See Also Send Feedback
Gets or sets the connection string builder which contains the connection properties.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DbConnectionStringBuilder AdvancedProperties { get; set; }
Visual Basic (Declaration)
Public Property AdvancedProperties As DbConnectionStringBuilder
Visual C++
public:
property DbConnectionStringBuilder^ AdvancedProperties {
    DbConnectionStringBuilder^ get ();
    void set (DbConnectionStringBuilder^ value);
}

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


AdvancedConnectionPropertiesForm Events

[image] [image]

FastReport.Net Class Reference
AdvancedConnectionPropertiesForm Events
AdvancedConnectionPropertiesForm Class See Also Send Feedback

The AdvancedConnectionPropertiesForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AdvancedConnectionPropertiesForm Class
FastReport.Forms Namespace


BaseDialogForm Class

[image]

FastReport.Net Class Reference
BaseDialogForm Class
Members See Also Send Feedback
Base class for all dialog forms with two buttons, OK and Cancel.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BaseDialogForm : Form
Visual Basic (Declaration)
Public Class BaseDialogForm _
    Inherits Form
Visual C++
public ref class BaseDialogForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Cloud.StorageClient..::.CloudStorageClientForm
FastReport.Cloud.StorageClient.Dropbox..::.ApplicationInfoForm
FastReport.Cloud.StorageClient.Dropbox..::.DropboxStorageClientForm
FastReport.Cloud.StorageClient.Dropbox..::.WebBrowserForm
FastReport.Cloud.StorageClient.GoogleDrive..::.ClientInfoForm
FastReport.Cloud.StorageClient.GoogleDrive..::.WebBrowserForm
FastReport.Cloud.StorageClient.SkyDrive..::.ClientInfoForm
FastReport.Cloud.StorageClient.SkyDrive..::.SkyDriveStorageClientForm
FastReport.Cloud.StorageClient.SkyDrive..::.WebBrowserForm
FastReport.Cloud.StorageClient..::.WebBrowserFormBase
FastReport.Forms..::.AdvancedConnectionPropertiesForm
FastReport.Forms..::.BaseExportForm
FastReport.Forms..::.ExceptionForm

See Also

BaseDialogForm Members
FastReport.Forms Namespace


BaseDialogForm Members

[image] [image]

FastReport.Net Class Reference
BaseDialogForm Members
BaseDialogForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The BaseDialogForm type exposes the following members.

Constructors

Name | Description
BaseDialogForm | Initializes a new instance of the BaseDialogForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls.
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button.
btnOk | The OK button.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseDialogForm Class
FastReport.Forms Namespace


BaseDialogForm Constructor

[image]

FastReport.Net Class Reference
BaseDialogForm Constructor
BaseDialogForm Class See Also Send Feedback
Initializes a new instance of the BaseDialogForm class.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BaseDialogForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BaseDialogForm()

See Also

BaseDialogForm Class
FastReport.Forms Namespace


BaseDialogForm Fields

[image] [image]

FastReport.Net Class Reference
BaseDialogForm Fields
BaseDialogForm Class See Also Send Feedback

The BaseDialogForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button.
btnOk | The OK button.

See Also

BaseDialogForm Class
FastReport.Forms Namespace


btnCancel Field

[image]

FastReport.Net Class Reference
BaseDialogForm..::.btnCancel Field
BaseDialogForm Class See Also Send Feedback
The Cancel button.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Button btnCancel
Visual Basic (Declaration)
Public btnCancel As Button
Visual C++
public:
Button^ btnCancel

See Also

BaseDialogForm Class
FastReport.Forms Namespace


btnOk Field

[image]

FastReport.Net Class Reference
BaseDialogForm..::.btnOk Field
BaseDialogForm Class See Also Send Feedback
The OK button.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Button btnOk
Visual Basic (Declaration)
Public btnOk As Button
Visual C++
public:
Button^ btnOk

See Also

BaseDialogForm Class
FastReport.Forms Namespace


BaseDialogForm Methods

[image] [image]

FastReport.Net Class Reference
BaseDialogForm Methods
BaseDialogForm Class See Also Send Feedback

The BaseDialogForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls.
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

BaseDialogForm Class
FastReport.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.AccessibilityNotifyClients Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.BeginInvoke Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Dispose Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
BaseDialogForm..::.Dispose Method (Boolean)
BaseDialogForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

BaseDialogForm Class
Dispose Overload
FastReport.Forms Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.GetChildAtPoint Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Invalidate Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Invoke Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Localize Method

[image]

FastReport.Net Class Reference
BaseDialogForm..::.Localize Method
BaseDialogForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Localize()
Visual Basic (Declaration)
Public Overridable Sub Localize
Visual C++
public:
virtual void Localize()

Remarks

Use this method to set control's captions specific to the current locale.

See Also

BaseDialogForm Class
FastReport.Forms Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.MemberwiseClone Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.PerformLayout Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.ResumeLayout Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.RtlTranslateAlignment Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Scale Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Select Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.SetBounds Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Show Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.ShowDialog Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.UpdateBounds Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.Validate Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
BaseDialogForm..::.ValidateChildren Method
BaseDialogForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

BaseDialogForm Class
BaseDialogForm Members
FastReport.Forms Namespace


BaseDialogForm Properties

[image] [image]

FastReport.Net Class Reference
BaseDialogForm Properties
BaseDialogForm Class See Also Send Feedback

The BaseDialogForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

BaseDialogForm Class
FastReport.Forms Namespace


BaseDialogForm Events

[image] [image]

FastReport.Net Class Reference
BaseDialogForm Events
BaseDialogForm Class See Also Send Feedback

The BaseDialogForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseDialogForm Class
FastReport.Forms Namespace


BaseExportForm Class

[image]

FastReport.Net Class Reference
BaseExportForm Class
Members See Also Send Feedback
Base form for all export options dialog forms.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BaseExportForm : BaseDialogForm
Visual Basic (Declaration)
Public Class BaseExportForm _
    Inherits BaseDialogForm
Visual C++
public ref class BaseExportForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Forms..::.BaseExportForm

See Also

BaseExportForm Members
FastReport.Forms Namespace


BaseExportForm Members

[image] [image]

FastReport.Net Class Reference
BaseExportForm Members
BaseExportForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The BaseExportForm type exposes the following members.

Constructors

Name | Description
BaseExportForm | Initializes a new instance of the BaseExportForm class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Called when editing is done.
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes controls with initial values.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Overrides Form..::.OnShown(EventArgs).)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
cbOpenAfter | "Open after export" checkbox.
gbPageRange | "Page Range" groupbox.
lblHint | "Page Numbers" label.
panPages | Pages panel.
pcPages | PageControl.
rbAll | "All Pages" radiobutton.
rbCurrent | "Current Page" radiobutton.
rbNumbers | "Page Numbers" radiobutton.
tbNumbers | "Page Numbers" textbox.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Export | Gets a reference to the currently editing export filter.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseExportForm Class
FastReport.Forms Namespace


BaseExportForm Constructor

[image]

FastReport.Net Class Reference
BaseExportForm Constructor
BaseExportForm Class See Also Send Feedback
Initializes a new instance of the BaseExportForm class with default settings.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BaseExportForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BaseExportForm()

See Also

BaseExportForm Class
FastReport.Forms Namespace


BaseExportForm Fields

[image] [image]

FastReport.Net Class Reference
BaseExportForm Fields
BaseExportForm Class See Also Send Feedback

The BaseExportForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)
cbOpenAfter | "Open after export" checkbox.
gbPageRange | "Page Range" groupbox.
lblHint | "Page Numbers" label.
panPages | Pages panel.
pcPages | PageControl.
rbAll | "All Pages" radiobutton.
rbCurrent | "Current Page" radiobutton.
rbNumbers | "Page Numbers" radiobutton.
tbNumbers | "Page Numbers" textbox.

See Also

BaseExportForm Class
FastReport.Forms Namespace


cbOpenAfter Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.cbOpenAfter Field
BaseExportForm Class See Also Send Feedback
"Open after export" checkbox.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected CheckBox cbOpenAfter
Visual Basic (Declaration)
Protected cbOpenAfter As CheckBox
Visual C++
protected:
CheckBox^ cbOpenAfter

See Also

BaseExportForm Class
FastReport.Forms Namespace


gbPageRange Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.gbPageRange Field
BaseExportForm Class See Also Send Feedback
"Page Range" groupbox.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected GroupBox gbPageRange
Visual Basic (Declaration)
Protected gbPageRange As GroupBox
Visual C++
protected:
GroupBox^ gbPageRange

See Also

BaseExportForm Class
FastReport.Forms Namespace


lblHint Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.lblHint Field
BaseExportForm Class See Also Send Feedback
"Page Numbers" label.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected Label lblHint
Visual Basic (Declaration)
Protected lblHint As Label
Visual C++
protected:
Label^ lblHint

See Also

BaseExportForm Class
FastReport.Forms Namespace


panPages Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.panPages Field
BaseExportForm Class See Also Send Feedback
Pages panel.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected PageControlPage panPages
Visual Basic (Declaration)
Protected panPages As PageControlPage
Visual C++
protected:
PageControlPage^ panPages

See Also

BaseExportForm Class
FastReport.Forms Namespace


pcPages Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.pcPages Field
BaseExportForm Class See Also Send Feedback
PageControl.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected PageControl pcPages
Visual Basic (Declaration)
Protected pcPages As PageControl
Visual C++
protected:
PageControl^ pcPages

See Also

BaseExportForm Class
FastReport.Forms Namespace


rbAll Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.rbAll Field
BaseExportForm Class See Also Send Feedback
"All Pages" radiobutton.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected RadioButton rbAll
Visual Basic (Declaration)
Protected rbAll As RadioButton
Visual C++
protected:
RadioButton^ rbAll

See Also

BaseExportForm Class
FastReport.Forms Namespace


rbCurrent Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.rbCurrent Field
BaseExportForm Class See Also Send Feedback
"Current Page" radiobutton.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected RadioButton rbCurrent
Visual Basic (Declaration)
Protected rbCurrent As RadioButton
Visual C++
protected:
RadioButton^ rbCurrent

See Also

BaseExportForm Class
FastReport.Forms Namespace


rbNumbers Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.rbNumbers Field
BaseExportForm Class See Also Send Feedback
"Page Numbers" radiobutton.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected RadioButton rbNumbers
Visual Basic (Declaration)
Protected rbNumbers As RadioButton
Visual C++
protected:
RadioButton^ rbNumbers

See Also

BaseExportForm Class
FastReport.Forms Namespace


tbNumbers Field

[image]

FastReport.Net Class Reference
BaseExportForm..::.tbNumbers Field
BaseExportForm Class See Also Send Feedback
"Page Numbers" textbox.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected TextBox tbNumbers
Visual Basic (Declaration)
Protected tbNumbers As TextBox
Visual C++
protected:
TextBox^ tbNumbers

See Also

BaseExportForm Class
FastReport.Forms Namespace


BaseExportForm Methods

[image] [image]

FastReport.Net Class Reference
BaseExportForm Methods
BaseExportForm Class See Also Send Feedback

The BaseExportForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Called when editing is done.
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes controls with initial values.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Overrides Form..::.OnShown(EventArgs).)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

BaseExportForm Class
FastReport.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.AccessibilityNotifyClients Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.BeginInvoke Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Dispose Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
BaseExportForm..::.Dispose Method (Boolean)
BaseExportForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

BaseExportForm Class
Dispose Overload
FastReport.Forms Namespace


Done Method

[image]

FastReport.Net Class Reference
BaseExportForm..::.Done Method
BaseExportForm Class Example See Also Send Feedback
Called when editing is done.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected virtual void Done()
Visual Basic (Declaration)
Protected Overridable Sub Done
Visual C++
protected:
virtual void Done()

Remarks

Override this method to pass edited values from the dialog controls to the export filter.

Examples

See the example of this method implementation that is used in the ImageExport.
CopyC#
protected override void Done()
{
  base.Done();
  ImageExport imageExport = Export as ImageExport;
  imageExport.ImageFormat = (ImageExportFormat)cbxImageFormat.SelectedIndex;
  imageExport.Resolution = (int)udResolution.Value;
  imageExport.JpegQuality = (int)udQuality.Value;
  imageExport.SeparateFiles = cbSeparateFiles.Checked;
}

See Also

BaseExportForm Class
FastReport.Forms Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.GetChildAtPoint Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Init Method

[image]

FastReport.Net Class Reference
BaseExportForm..::.Init Method
BaseExportForm Class Example See Also Send Feedback
Initializes controls with initial values.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Init(
    ExportBase export
)
Visual Basic (Declaration)
Public Overridable Sub Init ( _
    export As ExportBase _
)
Visual C++
public:
virtual void Init(
    ExportBase^ export
)

Parameters

export
Type: FastReport.Export..::.ExportBase
The export filter to edit.

Remarks

Override this method to pass values from the export filter to the dialog controls.

Examples

See the example of this method implementation that is used in the ImageExport.
CopyC#
public override void Init(ExportBase export)
{
  base.Init(export);
  ImageExport imageExport = Export as ImageExport;
  cbxImageFormat.SelectedIndex = (int)imageExport.ImageFormat;
  udResolution.Value = imageExport.Resolution;
  udQuality.Value = imageExport.JpegQuality;
  cbSeparateFiles.Checked = imageExport.SeparateFiles;
}

See Also

BaseExportForm Class
FastReport.Forms Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Invalidate Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Invoke Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Localize Method

[image]

FastReport.Net Class Reference
BaseExportForm..::.Localize Method
BaseExportForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

BaseExportForm Class
FastReport.Forms Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.MemberwiseClone Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


OnFormClosed Method

[image]

FastReport.Net Class Reference
BaseExportForm..::.OnFormClosed Method
BaseExportForm Class See Also Send Feedback
Raises the FormClosed event.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnFormClosed(
    FormClosedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosed ( _
    e As FormClosedEventArgs _
)
Visual C++
protected:
virtual void OnFormClosed(
    FormClosedEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosedEventArgs
A FormClosedEventArgs that contains the event data.

See Also

BaseExportForm Class
FastReport.Forms Namespace


OnFormClosing Method

[image]

FastReport.Net Class Reference
BaseExportForm..::.OnFormClosing Method
BaseExportForm Class See Also Send Feedback
Raises the FormClosing event.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnFormClosing(
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosing ( _
    e As FormClosingEventArgs _
)
Visual C++
protected:
virtual void OnFormClosing(
    FormClosingEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosingEventArgs
A FormClosingEventArgs that contains the event data.

See Also

BaseExportForm Class
FastReport.Forms Namespace


OnShown Method

[image]

FastReport.Net Class Reference
BaseExportForm..::.OnShown Method
BaseExportForm Class See Also Send Feedback
Raises the Shown event.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnShown(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnShown ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnShown(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
A EventArgs that contains the event data.

See Also

BaseExportForm Class
FastReport.Forms Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.PerformLayout Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.ResumeLayout Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.RtlTranslateAlignment Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Scale Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Select Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.SetBounds Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Show Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.ShowDialog Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.UpdateBounds Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.Validate Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
BaseExportForm..::.ValidateChildren Method
BaseExportForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

BaseExportForm Class
BaseExportForm Members
FastReport.Forms Namespace


BaseExportForm Properties

[image] [image]

FastReport.Net Class Reference
BaseExportForm Properties
BaseExportForm Class See Also Send Feedback

The BaseExportForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Export | Gets a reference to the currently editing export filter.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

BaseExportForm Class
FastReport.Forms Namespace


Export Property

[image]

FastReport.Net Class Reference
BaseExportForm..::.Export Property
BaseExportForm Class See Also Send Feedback
Gets a reference to the currently editing export filter.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected ExportBase Export { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Export As ExportBase
Visual C++
protected:
property ExportBase^ Export {
    ExportBase^ get ();
}

See Also

BaseExportForm Class
FastReport.Forms Namespace


BaseExportForm Events

[image] [image]

FastReport.Net Class Reference
BaseExportForm Events
BaseExportForm Class See Also Send Feedback

The BaseExportForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseExportForm Class
FastReport.Forms Namespace


DesignerOptionsPage Class

[image]

FastReport.Net Class Reference
DesignerOptionsPage Class
Members See Also Send Feedback
The base class for designer plugin's options page.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DesignerOptionsPage : Form
Visual Basic (Declaration)
Public Class DesignerOptionsPage _
    Inherits Form
Visual C++
public ref class DesignerOptionsPage : public Form

Remarks

Use this class if you develop a designer plugin that may be configured in the "View|Options..." menu. You need to implement an options page for your plugin and return it in the IDesignerPlugin.GetOptionsPage method.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.DesignerOptionsPage

See Also

DesignerOptionsPage Members
FastReport.Forms Namespace


DesignerOptionsPage Members

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage Members
DesignerOptionsPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The DesignerOptionsPage type exposes the following members.

Constructors

Name | Description
DesignerOptionsPage | Initializes a new instance of the DesignerOptionsPage class with default settings.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Finalizes the options page.
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes controls on this options page.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
tab1 | The TabPage control.
tc1 | The TabControl control.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


DesignerOptionsPage Constructor

[image]

FastReport.Net Class Reference
DesignerOptionsPage Constructor
DesignerOptionsPage Class Example See Also Send Feedback
Initializes a new instance of the DesignerOptionsPage class with default settings.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DesignerOptionsPage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerOptionsPage()

Remarks

Usually you need to define another contructor which takes one parameter - the plugin.

Examples

This example shows how to define own constructor which takes a plugin:
CopyC#
public DialogPageOptions(DialogPageDesigner pd) : base()
{
  FPageDesigner = pd;
  InitializeComponent();
}

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


DesignerOptionsPage Fields

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage Fields
DesignerOptionsPage Class See Also Send Feedback

The DesignerOptionsPage type exposes the following members.

Fields

Name | Description
tab1 | The TabPage control.
tc1 | The TabControl control.

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


tab1 Field

[image]

FastReport.Net Class Reference
DesignerOptionsPage..::.tab1 Field
DesignerOptionsPage Class See Also Send Feedback
The TabPage control.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TabPage tab1
Visual Basic (Declaration)
Public tab1 As TabPage
Visual C++
public:
TabPage^ tab1

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


tc1 Field

[image]

FastReport.Net Class Reference
DesignerOptionsPage..::.tc1 Field
DesignerOptionsPage Class See Also Send Feedback
The TabControl control.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TabControl tc1
Visual Basic (Declaration)
Public tc1 As TabControl
Visual C++
public:
TabControl^ tc1

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


DesignerOptionsPage Methods

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage Methods
DesignerOptionsPage Class See Also Send Feedback

The DesignerOptionsPage type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Done | Finalizes the options page.
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
Init | Initializes controls on this options page.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.AccessibilityNotifyClients Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.BeginInvoke Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Dispose Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Done Method

[image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Done Method
DesignerOptionsPage Class See Also Send Feedback
Finalizes the options page.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Done(
    DialogResult result
)
Visual Basic (Declaration)
Public Overridable Sub Done ( _
    result As DialogResult _
)
Visual C++
public:
virtual void Done(
    DialogResult result
)

Parameters

result
Type: System.Windows.Forms..::.DialogResult
The dialog result.

Remarks

Override this method to pass controls' values to the plugin. Do this if result is DialogResult.OK.

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.GetChildAtPoint Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Init Method

[image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Init Method
DesignerOptionsPage Class See Also Send Feedback
Initializes controls on this options page.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Init()
Visual Basic (Declaration)
Public Overridable Sub Init
Visual C++
public:
virtual void Init()

Remarks

Override this method to fill options page's controls with initial values.

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Invalidate Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Invoke Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.MemberwiseClone Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.PerformLayout Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.ResumeLayout Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.RtlTranslateAlignment Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Scale Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Select Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.SetBounds Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Show Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.ShowDialog Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.UpdateBounds Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.Validate Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage..::.ValidateChildren Method
DesignerOptionsPage Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DesignerOptionsPage Class
DesignerOptionsPage Members
FastReport.Forms Namespace


DesignerOptionsPage Properties

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage Properties
DesignerOptionsPage Class See Also Send Feedback

The DesignerOptionsPage type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


DesignerOptionsPage Events

[image] [image]

FastReport.Net Class Reference
DesignerOptionsPage Events
DesignerOptionsPage Class See Also Send Feedback

The DesignerOptionsPage type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerOptionsPage Class
FastReport.Forms Namespace


ExceptionForm Class

[image]

FastReport.Net Class Reference
ExceptionForm Class
Members See Also Send Feedback
Represents the FastReport exception form.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ExceptionForm : BaseDialogForm
Visual Basic (Declaration)
Public Class ExceptionForm _
    Inherits BaseDialogForm
Visual C++
public ref class ExceptionForm : public BaseDialogForm

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
FastReport.Forms..::.BaseDialogForm
FastReport.Forms..::.ExceptionForm

See Also

ExceptionForm Members
FastReport.Forms Namespace


ExceptionForm Members

[image] [image]

FastReport.Net Class Reference
ExceptionForm Members
ExceptionForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The ExceptionForm type exposes the following members.

Constructors

Name | Description
ExceptionForm | Creates a new instance ofthe form.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ExceptionForm Class
FastReport.Forms Namespace


ExceptionForm Constructor

[image]

FastReport.Net Class Reference
ExceptionForm Constructor
ExceptionForm Class See Also Send Feedback
Creates a new instance ofthe form.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ExceptionForm(
    Exception ex
)
Visual Basic (Declaration)
Public Sub New ( _
    ex As Exception _
)
Visual C++
public:
ExceptionForm(
    Exception^ ex
)

Parameters

ex
Type: System..::.Exception
The exception object which data to display in the form.

See Also

ExceptionForm Class
FastReport.Forms Namespace


ExceptionForm Fields

[image] [image]

FastReport.Net Class Reference
ExceptionForm Fields
ExceptionForm Class See Also Send Feedback

The ExceptionForm type exposes the following members.

Fields

Name | Description
btnCancel | The Cancel button. (Inherited from BaseDialogForm.)
btnOk | The OK button. (Inherited from BaseDialogForm.)

See Also

ExceptionForm Class
FastReport.Forms Namespace


ExceptionForm Methods

[image] [image]

FastReport.Net Class Reference
ExceptionForm Methods
ExceptionForm Class See Also Send Feedback

The ExceptionForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Localize | Localizes the dialog controls. (Overrides BaseDialogForm..::.Localize()()().)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ExceptionForm Class
FastReport.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.AccessibilityNotifyClients Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.BeginInvoke Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Dispose Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides BaseDialogForm..::.Dispose(Boolean).)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
ExceptionForm..::.Dispose Method (Boolean)
ExceptionForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ExceptionForm Class
Dispose Overload
FastReport.Forms Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.GetChildAtPoint Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Invalidate Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Invoke Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Localize Method

[image]

FastReport.Net Class Reference
ExceptionForm..::.Localize Method
ExceptionForm Class See Also Send Feedback
Localizes the dialog controls.

Namespace: FastReport.Forms
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Localize()
Visual Basic (Declaration)
Public Overrides Sub Localize
Visual C++
public:
virtual void Localize() override

Remarks

Use this method to set control's captions specific to the current locale.

See Also

ExceptionForm Class
FastReport.Forms Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.MemberwiseClone Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.PerformLayout Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.ResumeLayout Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.RtlTranslateAlignment Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Scale Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Select Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.SetBounds Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Show Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Show Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


ShowDialog Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.ShowDialog Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.UpdateBounds Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.Validate Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
ExceptionForm..::.ValidateChildren Method
ExceptionForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ExceptionForm Class
ExceptionForm Members
FastReport.Forms Namespace


ExceptionForm Properties

[image] [image]

FastReport.Net Class Reference
ExceptionForm Properties
ExceptionForm Class See Also Send Feedback

The ExceptionForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ExceptionForm Class
FastReport.Forms Namespace


ExceptionForm Events

[image] [image]

FastReport.Net Class Reference
ExceptionForm Events
ExceptionForm Class See Also Send Feedback

The ExceptionForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ExceptionForm Class
FastReport.Forms Namespace


FastReport.Functions Namespace

[image]

FastReport.Net Class Reference
FastReport.Functions Namespace
Send Feedback

Classes

Class | Description
StdFunctions | Contains standard functions registered in the "Data" window.


StdFunctions Class

[image]

FastReport.Net Class Reference
StdFunctions Class
Members See Also Send Feedback
Contains standard functions registered in the "Data" window.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class StdFunctions
Visual Basic (Declaration)
Public NotInheritable Class StdFunctions
Visual C++
public ref class StdFunctions abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Functions..::.StdFunctions

See Also

StdFunctions Members
FastReport.Functions Namespace


StdFunctions Members

[image] [image]

FastReport.Net Class Reference
StdFunctions Members
StdFunctions Class Methods See Also Send Feedback

The StdFunctions type exposes the following members.

Methods

Name | Description
AddDays | Adds the specified number of days to the original date.
AddHours | Adds the specified number of hours to the original date.
AddMinutes | Adds the specified number of minutes to the original date.
AddMonths | Adds the specified number of months to the original date.
AddSeconds | Adds the specified number of seconds to the original date.
AddYears | Adds the specified number of years to the original date.
Asc | Returns an integer value representing the character code corresponding to a character.
Choose | Selects and returns a value from a list of arguments.
Chr | Returns the character associated with the specified character code.
DateDiff | Subtracts the specified date and time from the original date.
DateSerial | Initializes a new instance of the DateTime.
Day | Gets the day of the month.
DayOfWeek | Gets the localized name of the day of the week.
DayOfYear | Gets the day of the year.
DaysInMonth | Returns the number of days in the specified month and year.
Format | Replaces the format item in a specified String with the text equivalent of the value of a corresponding Object instance in a specified array.
FormatCurrency | Overloaded.
FormatDateTime | Overloaded.
FormatNumber | Overloaded.
FormatPercent | Overloaded.
Hour | Gets the hour component of the date.
IIf | Returns one of two objects, depending on the evaluation of an expression.
Insert | Inserts a specified string at a specified index position in the original string.
IsNull | Checks if the specified object is null.
Length | Gets the number of characters in a string.
LowerCase | Converts a specified string to lowercase.
Maximum | Overloaded.
Minimum | Overloaded.
Minute | Gets the minute component of the date.
Month | Gets the month component of the date.
MonthName | Gets the localized month name.
PadLeft | Overloaded.
PadRight | Overloaded.
Remove | Overloaded.
Replace | Replaces all occurrences of a specified string in the original string, with another specified string.
Second | Gets the seconds component of the date.
Substring | Overloaded.
Switch | Evaluates a list of expressions and returns a value corresponding to the first expression in the list that is True.
TitleCase | Converts the specified string to titlecase.
ToRoman | Converts a numeric value to Roman string representation.
ToWords | Overloaded.
ToWordsEnGb | Overloaded.
ToWordsEs | Overloaded.
ToWordsRu | Overloaded.
Trim | Removes all occurrences of white space characters from the beginning and end of the original string.
UpperCase | Converts a specified string to uppercase.
WeekOfYear | Gets the week of the year.
Year | Gets the year component of the date.

See Also

StdFunctions Class
FastReport.Functions Namespace


StdFunctions Methods

[image] [image]

FastReport.Net Class Reference
StdFunctions Methods
StdFunctions Class See Also Send Feedback

The StdFunctions type exposes the following members.

Methods

Name | Description
AddDays | Adds the specified number of days to the original date.
AddHours | Adds the specified number of hours to the original date.
AddMinutes | Adds the specified number of minutes to the original date.
AddMonths | Adds the specified number of months to the original date.
AddSeconds | Adds the specified number of seconds to the original date.
AddYears | Adds the specified number of years to the original date.
Asc | Returns an integer value representing the character code corresponding to a character.
Choose | Selects and returns a value from a list of arguments.
Chr | Returns the character associated with the specified character code.
DateDiff | Subtracts the specified date and time from the original date.
DateSerial | Initializes a new instance of the DateTime.
Day | Gets the day of the month.
DayOfWeek | Gets the localized name of the day of the week.
DayOfYear | Gets the day of the year.
DaysInMonth | Returns the number of days in the specified month and year.
Format | Replaces the format item in a specified String with the text equivalent of the value of a corresponding Object instance in a specified array.
FormatCurrency | Overloaded.
FormatDateTime | Overloaded.
FormatNumber | Overloaded.
FormatPercent | Overloaded.
Hour | Gets the hour component of the date.
IIf | Returns one of two objects, depending on the evaluation of an expression.
Insert | Inserts a specified string at a specified index position in the original string.
IsNull | Checks if the specified object is null.
Length | Gets the number of characters in a string.
LowerCase | Converts a specified string to lowercase.
Maximum | Overloaded.
Minimum | Overloaded.
Minute | Gets the minute component of the date.
Month | Gets the month component of the date.
MonthName | Gets the localized month name.
PadLeft | Overloaded.
PadRight | Overloaded.
Remove | Overloaded.
Replace | Replaces all occurrences of a specified string in the original string, with another specified string.
Second | Gets the seconds component of the date.
Substring | Overloaded.
Switch | Evaluates a list of expressions and returns a value corresponding to the first expression in the list that is True.
TitleCase | Converts the specified string to titlecase.
ToRoman | Converts a numeric value to Roman string representation.
ToWords | Overloaded.
ToWordsEnGb | Overloaded.
ToWordsEs | Overloaded.
ToWordsRu | Overloaded.
Trim | Removes all occurrences of white space characters from the beginning and end of the original string.
UpperCase | Converts a specified string to uppercase.
WeekOfYear | Gets the week of the year.
Year | Gets the year component of the date.

See Also

StdFunctions Class
FastReport.Functions Namespace


AddDays Method

[image]

FastReport.Net Class Reference
StdFunctions..::.AddDays Method
StdFunctions Class See Also Send Feedback
Adds the specified number of days to the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime AddDays(
    DateTime date,
    double value
)
Visual Basic (Declaration)
Public Shared Function AddDays ( _
    date As DateTime, _
    value As Double _
) As DateTime
Visual C++
public:
static DateTime AddDays(
    DateTime date,
    double value
)

Parameters

date
Type: System..::.DateTime
The original date.
value
Type: System..::.Double
A number of whole and fractional days.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


AddHours Method

[image]

FastReport.Net Class Reference
StdFunctions..::.AddHours Method
StdFunctions Class See Also Send Feedback
Adds the specified number of hours to the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime AddHours(
    DateTime date,
    double value
)
Visual Basic (Declaration)
Public Shared Function AddHours ( _
    date As DateTime, _
    value As Double _
) As DateTime
Visual C++
public:
static DateTime AddHours(
    DateTime date,
    double value
)

Parameters

date
Type: System..::.DateTime
The original date.
value
Type: System..::.Double
A number of whole and fractional hours.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


AddMinutes Method

[image]

FastReport.Net Class Reference
StdFunctions..::.AddMinutes Method
StdFunctions Class See Also Send Feedback
Adds the specified number of minutes to the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime AddMinutes(
    DateTime date,
    double value
)
Visual Basic (Declaration)
Public Shared Function AddMinutes ( _
    date As DateTime, _
    value As Double _
) As DateTime
Visual C++
public:
static DateTime AddMinutes(
    DateTime date,
    double value
)

Parameters

date
Type: System..::.DateTime
The original date.
value
Type: System..::.Double
A number of whole and fractional minutes.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


AddMonths Method

[image]

FastReport.Net Class Reference
StdFunctions..::.AddMonths Method
StdFunctions Class See Also Send Feedback
Adds the specified number of months to the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime AddMonths(
    DateTime date,
    int value
)
Visual Basic (Declaration)
Public Shared Function AddMonths ( _
    date As DateTime, _
    value As Integer _
) As DateTime
Visual C++
public:
static DateTime AddMonths(
    DateTime date,
    int value
)

Parameters

date
Type: System..::.DateTime
The original date.
value
Type: System..::.Int32
A number of months.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


AddSeconds Method

[image]

FastReport.Net Class Reference
StdFunctions..::.AddSeconds Method
StdFunctions Class See Also Send Feedback
Adds the specified number of seconds to the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime AddSeconds(
    DateTime date,
    double value
)
Visual Basic (Declaration)
Public Shared Function AddSeconds ( _
    date As DateTime, _
    value As Double _
) As DateTime
Visual C++
public:
static DateTime AddSeconds(
    DateTime date,
    double value
)

Parameters

date
Type: System..::.DateTime
The original date.
value
Type: System..::.Double
A number of whole and fractional seconds.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


AddYears Method

[image]

FastReport.Net Class Reference
StdFunctions..::.AddYears Method
StdFunctions Class See Also Send Feedback
Adds the specified number of years to the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime AddYears(
    DateTime date,
    int value
)
Visual Basic (Declaration)
Public Shared Function AddYears ( _
    date As DateTime, _
    value As Integer _
) As DateTime
Visual C++
public:
static DateTime AddYears(
    DateTime date,
    int value
)

Parameters

date
Type: System..::.DateTime
The original date.
value
Type: System..::.Int32
A number of years.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


Asc Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Asc Method
StdFunctions Class See Also Send Feedback
Returns an integer value representing the character code corresponding to a character.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Asc(
    char c
)
Visual Basic (Declaration)
Public Shared Function Asc ( _
    c As Char _
) As Integer
Visual C++
public:
static int Asc(
    wchar_t c
)

Parameters

c
Type: System..::.Char
Character to convert.

Return Value

The character code.

See Also

StdFunctions Class
FastReport.Functions Namespace


Choose Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Choose Method
StdFunctions Class See Also Send Feedback
Selects and returns a value from a list of arguments.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Object Choose(
    double index,
    params Object[] choice
)
Visual Basic (Declaration)
Public Shared Function Choose ( _
    index As Double, _
    ParamArray choice As Object() _
) As Object
Visual C++
public:
static Object^ Choose(
    double index,
    ... array<Object^>^ choice
)

Parameters

index
Type: System..::.Double
A value between 1 and the number of elements passed in the "choice" argument.
choice
Type: array< System..::.Object >[]()[]
Object parameter array.

Return Value

One of the values in the "choice" argument.

See Also

StdFunctions Class
FastReport.Functions Namespace


Chr Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Chr Method
StdFunctions Class See Also Send Feedback
Returns the character associated with the specified character code.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static char Chr(
    int i
)
Visual Basic (Declaration)
Public Shared Function Chr ( _
    i As Integer _
) As Char
Visual C++
public:
static wchar_t Chr(
    int i
)

Parameters

i
Type: System..::.Int32
Character code to convert.

Return Value

The character.

See Also

StdFunctions Class
FastReport.Functions Namespace


DateDiff Method

[image]

FastReport.Net Class Reference
StdFunctions..::.DateDiff Method
StdFunctions Class See Also Send Feedback
Subtracts the specified date and time from the original date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static TimeSpan DateDiff(
    DateTime date1,
    DateTime date2
)
Visual Basic (Declaration)
Public Shared Function DateDiff ( _
    date1 As DateTime, _
    date2 As DateTime _
) As TimeSpan
Visual C++
public:
static TimeSpan DateDiff(
    DateTime date1,
    DateTime date2
)

Parameters

date1
Type: System..::.DateTime
The original date.
date2
Type: System..::.DateTime
The date and time to subtract.

Return Value

A TimeSpan interval between two dates.

See Also

StdFunctions Class
FastReport.Functions Namespace


DateSerial Method

[image]

FastReport.Net Class Reference
StdFunctions..::.DateSerial Method
StdFunctions Class See Also Send Feedback
Initializes a new instance of the DateTime.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DateTime DateSerial(
    int year,
    int month,
    int day
)
Visual Basic (Declaration)
Public Shared Function DateSerial ( _
    year As Integer, _
    month As Integer, _
    day As Integer _
) As DateTime
Visual C++
public:
static DateTime DateSerial(
    int year,
    int month,
    int day
)

Parameters

year
Type: System..::.Int32
The year.
month
Type: System..::.Int32
The month.
day
Type: System..::.Int32
The day.

Return Value

A new DateTime value.

See Also

StdFunctions Class
FastReport.Functions Namespace


Day Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Day Method
StdFunctions Class See Also Send Feedback
Gets the day of the month.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Day(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function Day ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int Day(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date value.

Return Value

The day component.

See Also

StdFunctions Class
FastReport.Functions Namespace


DayOfWeek Method

[image]

FastReport.Net Class Reference
StdFunctions..::.DayOfWeek Method
StdFunctions Class See Also Send Feedback
Gets the localized name of the day of the week.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string DayOfWeek(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function DayOfWeek ( _
    date As DateTime _
) As String
Visual C++
public:
static String^ DayOfWeek(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date value.

Return Value

The name of the day of the week.

See Also

StdFunctions Class
FastReport.Functions Namespace


DayOfYear Method

[image]

FastReport.Net Class Reference
StdFunctions..::.DayOfYear Method
StdFunctions Class See Also Send Feedback
Gets the day of the year.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int DayOfYear(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function DayOfYear ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int DayOfYear(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date value.

Return Value

The day of the year.

See Also

StdFunctions Class
FastReport.Functions Namespace


DaysInMonth Method

[image]

FastReport.Net Class Reference
StdFunctions..::.DaysInMonth Method
StdFunctions Class See Also Send Feedback
Returns the number of days in the specified month and year.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int DaysInMonth(
    int year,
    int month
)
Visual Basic (Declaration)
Public Shared Function DaysInMonth ( _
    year As Integer, _
    month As Integer _
) As Integer
Visual C++
public:
static int DaysInMonth(
    int year,
    int month
)

Parameters

year
Type: System..::.Int32
The year.
month
Type: System..::.Int32
The month.

Return Value

The number of days in month for the specified year.

See Also

StdFunctions Class
FastReport.Functions Namespace


Format Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Format Method
StdFunctions Class See Also Send Feedback
Replaces the format item in a specified String with the text equivalent of the value of a corresponding Object instance in a specified array.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Format(
    string format,
    params Object[] args
)
Visual Basic (Declaration)
Public Shared Function Format ( _
    format As String, _
    ParamArray args As Object() _
) As String
Visual C++
public:
static String^ Format(
    String^ format,
    ... array<Object^>^ args
)

Parameters

format
Type: System..::.String
A String containing zero or more format items.
args
Type: array< System..::.Object >[]()[]
An Object array containing zero or more objects to format.

Return Value

A copy of format in which the format items have been replaced by the String equivalent of the corresponding instances of Object in args.

See Also

StdFunctions Class
FastReport.Functions Namespace


FormatCurrency Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.FormatCurrency Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
FormatCurrency(Object) | Returns a string formatted as a currency value.
FormatCurrency(Object, Int32) | Returns a string formatted as a currency value with specified number of decimal digits.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


FormatCurrency Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatCurrency Method (Object)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a currency value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatCurrency(
    Object value
)
Visual Basic (Declaration)
Public Shared Function FormatCurrency ( _
    value As Object _
) As String
Visual C++
public:
static String^ FormatCurrency(
    Object^ value
)

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatCurrency Overload
FastReport.Functions Namespace


FormatCurrency Method (Object, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatCurrency Method (Object, Int32)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a currency value with specified number of decimal digits.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatCurrency(
    Object value,
    int decimalDigits
)
Visual Basic (Declaration)
Public Shared Function FormatCurrency ( _
    value As Object, _
    decimalDigits As Integer _
) As String
Visual C++
public:
static String^ FormatCurrency(
    Object^ value,
    int decimalDigits
)

Parameters

value
Type: System..::.Object
The value to format.
decimalDigits
Type: System..::.Int32
Number of decimal digits.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatCurrency Overload
FastReport.Functions Namespace


FormatDateTime Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.FormatDateTime Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
FormatDateTime(DateTime) | Returns a string formatted as a date/time value.
FormatDateTime(DateTime, String) | Returns a string formatted as a date/time value.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


FormatDateTime Method (DateTime)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatDateTime Method (DateTime)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a date/time value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatDateTime(
    DateTime value
)
Visual Basic (Declaration)
Public Shared Function FormatDateTime ( _
    value As DateTime _
) As String
Visual C++
public:
static String^ FormatDateTime(
    DateTime value
)

Parameters

value
Type: System..::.DateTime
The value to format.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatDateTime Overload
FastReport.Functions Namespace


FormatDateTime Method (DateTime, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatDateTime Method (DateTime, String)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a date/time value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatDateTime(
    DateTime value,
    string format
)
Visual Basic (Declaration)
Public Shared Function FormatDateTime ( _
    value As DateTime, _
    format As String _
) As String
Visual C++
public:
static String^ FormatDateTime(
    DateTime value,
    String^ format
)

Parameters

value
Type: System..::.DateTime
The value to format.
format
Type: System..::.String
The format specifier, one of the "Long Date", "Short Date", "Long Time", "Short Time" values.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatDateTime Overload
FastReport.Functions Namespace


FormatNumber Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.FormatNumber Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
FormatNumber(Object) | Returns a string formatted as a numeric value.
FormatNumber(Object, Int32) | Returns a string formatted as a numeric value with specified number of decimal digits.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


FormatNumber Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatNumber Method (Object)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a numeric value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatNumber(
    Object value
)
Visual Basic (Declaration)
Public Shared Function FormatNumber ( _
    value As Object _
) As String
Visual C++
public:
static String^ FormatNumber(
    Object^ value
)

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatNumber Overload
FastReport.Functions Namespace


FormatNumber Method (Object, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatNumber Method (Object, Int32)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a numeric value with specified number of decimal digits.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatNumber(
    Object value,
    int decimalDigits
)
Visual Basic (Declaration)
Public Shared Function FormatNumber ( _
    value As Object, _
    decimalDigits As Integer _
) As String
Visual C++
public:
static String^ FormatNumber(
    Object^ value,
    int decimalDigits
)

Parameters

value
Type: System..::.Object
The value to format.
decimalDigits
Type: System..::.Int32
Number of decimal digits.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatNumber Overload
FastReport.Functions Namespace


FormatPercent Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.FormatPercent Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
FormatPercent(Object) | Returns a string formatted as a percent value.
FormatPercent(Object, Int32) | Returns a string formatted as a percent value with specified number of decimal digits.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


FormatPercent Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatPercent Method (Object)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a percent value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatPercent(
    Object value
)
Visual Basic (Declaration)
Public Shared Function FormatPercent ( _
    value As Object _
) As String
Visual C++
public:
static String^ FormatPercent(
    Object^ value
)

Parameters

value
Type: System..::.Object
The value to format.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatPercent Overload
FastReport.Functions Namespace


FormatPercent Method (Object, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.FormatPercent Method (Object, Int32)
StdFunctions Class See Also Send Feedback
Returns a string formatted as a percent value with specified number of decimal digits.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FormatPercent(
    Object value,
    int decimalDigits
)
Visual Basic (Declaration)
Public Shared Function FormatPercent ( _
    value As Object, _
    decimalDigits As Integer _
) As String
Visual C++
public:
static String^ FormatPercent(
    Object^ value,
    int decimalDigits
)

Parameters

value
Type: System..::.Object
The value to format.
decimalDigits
Type: System..::.Int32
Number of decimal digits.

Return Value

The formatted string.

See Also

StdFunctions Class
FormatPercent Overload
FastReport.Functions Namespace


Hour Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Hour Method
StdFunctions Class See Also Send Feedback
Gets the hour component of the date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Hour(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function Hour ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int Hour(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date.

Return Value

The hour component.

See Also

StdFunctions Class
FastReport.Functions Namespace


IIf Method

[image]

FastReport.Net Class Reference
StdFunctions..::.IIf Method
StdFunctions Class See Also Send Feedback
Returns one of two objects, depending on the evaluation of an expression.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Object IIf(
    bool expression,
    Object truePart,
    Object falsePart
)
Visual Basic (Declaration)
Public Shared Function IIf ( _
    expression As Boolean, _
    truePart As Object, _
    falsePart As Object _
) As Object
Visual C++
public:
static Object^ IIf(
    bool expression,
    Object^ truePart,
    Object^ falsePart
)

Parameters

expression
Type: System..::.Boolean
The expression you want to evaluate.
truePart
Type: System..::.Object
Returned if Expression evaluates to True.
falsePart
Type: System..::.Object
Returned if Expression evaluates to False.

Return Value

Either truePart os falsePart.

See Also

StdFunctions Class
FastReport.Functions Namespace


Insert Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Insert Method
StdFunctions Class See Also Send Feedback
Inserts a specified string at a specified index position in the original string.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Insert(
    string s,
    int startIndex,
    string value
)
Visual Basic (Declaration)
Public Shared Function Insert ( _
    s As String, _
    startIndex As Integer, _
    value As String _
) As String
Visual C++
public:
static String^ Insert(
    String^ s,
    int startIndex,
    String^ value
)

Parameters

s
Type: System..::.String
The original string.
startIndex
Type: System..::.Int32
The index position of the insertion.
value
Type: System..::.String
The string to insert.

Return Value

A new string.

See Also

StdFunctions Class
FastReport.Functions Namespace


IsNull Method

[image]

FastReport.Net Class Reference
StdFunctions..::.IsNull Method
StdFunctions Class See Also Send Feedback
Checks if the specified object is null.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool IsNull(
    Report thisReport,
    string name
)
Visual Basic (Declaration)
Public Shared Function IsNull ( _
    thisReport As Report, _
    name As String _
) As Boolean
Visual C++
public:
static bool IsNull(
    Report^ thisReport,
    String^ name
)

Parameters

thisReport
Type: FastReport..::.Report
The report instance.
name
Type: System..::.String
Either a name of DB column, or a parameter name, or a total name to check.

Return Value

true if the object's value is null.

See Also

StdFunctions Class
FastReport.Functions Namespace


Length Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Length Method
StdFunctions Class See Also Send Feedback
Gets the number of characters in a string.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Length(
    string s
)
Visual Basic (Declaration)
Public Shared Function Length ( _
    s As String _
) As Integer
Visual C++
public:
static int Length(
    String^ s
)

Parameters

s
Type: System..::.String
The original string.

Return Value

The number of characters.

See Also

StdFunctions Class
FastReport.Functions Namespace


LowerCase Method

[image]

FastReport.Net Class Reference
StdFunctions..::.LowerCase Method
StdFunctions Class See Also Send Feedback
Converts a specified string to lowercase.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string LowerCase(
    string s
)
Visual Basic (Declaration)
Public Shared Function LowerCase ( _
    s As String _
) As String
Visual C++
public:
static String^ LowerCase(
    String^ s
)

Parameters

s
Type: System..::.String
The string to convert.

Return Value

A string in lowercase.

See Also

StdFunctions Class
FastReport.Functions Namespace


Maximum Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.Maximum Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
Maximum(Decimal, Decimal) | Returns the larger of two decimal numbers.
Maximum(Double, Double) | Returns the larger of two double-precision floating-point numbers.
Maximum(Int32, Int32) | Returns the larger of two 32-bit signed integers.
Maximum(Int64, Int64) | Returns the larger of two 64-bit signed integers.
Maximum(Single, Single) | Returns the larger of two single-precision floating-point numbers.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


Maximum Method (Decimal, Decimal)

[image]

FastReport.Net Class Reference
StdFunctions..::.Maximum Method (Decimal, Decimal)
StdFunctions Class See Also Send Feedback
Returns the larger of two decimal numbers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static decimal Maximum(
    decimal val1,
    decimal val2
)
Visual Basic (Declaration)
Public Shared Function Maximum ( _
    val1 As Decimal, _
    val2 As Decimal _
) As Decimal
Visual C++
public:
static Decimal Maximum(
    Decimal val1,
    Decimal val2
)

Parameters

val1
Type: System..::.Decimal
The first of two values to compare.
val2
Type: System..::.Decimal
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is larger.

See Also

StdFunctions Class
Maximum Overload
FastReport.Functions Namespace


Maximum Method (Double, Double)

[image]

FastReport.Net Class Reference
StdFunctions..::.Maximum Method (Double, Double)
StdFunctions Class See Also Send Feedback
Returns the larger of two double-precision floating-point numbers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static double Maximum(
    double val1,
    double val2
)
Visual Basic (Declaration)
Public Shared Function Maximum ( _
    val1 As Double, _
    val2 As Double _
) As Double
Visual C++
public:
static double Maximum(
    double val1,
    double val2
)

Parameters

val1
Type: System..::.Double
The first of two values to compare.
val2
Type: System..::.Double
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is larger.

See Also

StdFunctions Class
Maximum Overload
FastReport.Functions Namespace


Maximum Method (Int32, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.Maximum Method (Int32, Int32)
StdFunctions Class See Also Send Feedback
Returns the larger of two 32-bit signed integers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Maximum(
    int val1,
    int val2
)
Visual Basic (Declaration)
Public Shared Function Maximum ( _
    val1 As Integer, _
    val2 As Integer _
) As Integer
Visual C++
public:
static int Maximum(
    int val1,
    int val2
)

Parameters

val1
Type: System..::.Int32
The first of two values to compare.
val2
Type: System..::.Int32
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is larger.

See Also

StdFunctions Class
Maximum Overload
FastReport.Functions Namespace


Maximum Method (Int64, Int64)

[image]

FastReport.Net Class Reference
StdFunctions..::.Maximum Method (Int64, Int64)
StdFunctions Class See Also Send Feedback
Returns the larger of two 64-bit signed integers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static long Maximum(
    long val1,
    long val2
)
Visual Basic (Declaration)
Public Shared Function Maximum ( _
    val1 As Long, _
    val2 As Long _
) As Long
Visual C++
public:
static long long Maximum(
    long long val1,
    long long val2
)

Parameters

val1
Type: System..::.Int64
The first of two values to compare.
val2
Type: System..::.Int64
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is larger.

See Also

StdFunctions Class
Maximum Overload
FastReport.Functions Namespace


Maximum Method (Single, Single)

[image]

FastReport.Net Class Reference
StdFunctions..::.Maximum Method (Single, Single)
StdFunctions Class See Also Send Feedback
Returns the larger of two single-precision floating-point numbers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float Maximum(
    float val1,
    float val2
)
Visual Basic (Declaration)
Public Shared Function Maximum ( _
    val1 As Single, _
    val2 As Single _
) As Single
Visual C++
public:
static float Maximum(
    float val1,
    float val2
)

Parameters

val1
Type: System..::.Single
The first of two values to compare.
val2
Type: System..::.Single
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is larger.

See Also

StdFunctions Class
Maximum Overload
FastReport.Functions Namespace


Minimum Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.Minimum Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
Minimum(Decimal, Decimal) | Returns the smaller of two decimal numbers.
Minimum(Double, Double) | Returns the smaller of two double-precision floating-point numbers.
Minimum(Int32, Int32) | Returns the smaller of two 32-bit signed integers.
Minimum(Int64, Int64) | Returns the smaller of two 64-bit signed integers.
Minimum(Single, Single) | Returns the smaller of two single-precision floating-point numbers.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


Minimum Method (Decimal, Decimal)

[image]

FastReport.Net Class Reference
StdFunctions..::.Minimum Method (Decimal, Decimal)
StdFunctions Class See Also Send Feedback
Returns the smaller of two decimal numbers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static decimal Minimum(
    decimal val1,
    decimal val2
)
Visual Basic (Declaration)
Public Shared Function Minimum ( _
    val1 As Decimal, _
    val2 As Decimal _
) As Decimal
Visual C++
public:
static Decimal Minimum(
    Decimal val1,
    Decimal val2
)

Parameters

val1
Type: System..::.Decimal
The first of two values to compare.
val2
Type: System..::.Decimal
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is smaller.

See Also

StdFunctions Class
Minimum Overload
FastReport.Functions Namespace


Minimum Method (Double, Double)

[image]

FastReport.Net Class Reference
StdFunctions..::.Minimum Method (Double, Double)
StdFunctions Class See Also Send Feedback
Returns the smaller of two double-precision floating-point numbers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static double Minimum(
    double val1,
    double val2
)
Visual Basic (Declaration)
Public Shared Function Minimum ( _
    val1 As Double, _
    val2 As Double _
) As Double
Visual C++
public:
static double Minimum(
    double val1,
    double val2
)

Parameters

val1
Type: System..::.Double
The first of two values to compare.
val2
Type: System..::.Double
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is smaller.

See Also

StdFunctions Class
Minimum Overload
FastReport.Functions Namespace


Minimum Method (Int32, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.Minimum Method (Int32, Int32)
StdFunctions Class See Also Send Feedback
Returns the smaller of two 32-bit signed integers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Minimum(
    int val1,
    int val2
)
Visual Basic (Declaration)
Public Shared Function Minimum ( _
    val1 As Integer, _
    val2 As Integer _
) As Integer
Visual C++
public:
static int Minimum(
    int val1,
    int val2
)

Parameters

val1
Type: System..::.Int32
The first of two values to compare.
val2
Type: System..::.Int32
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is smaller.

See Also

StdFunctions Class
Minimum Overload
FastReport.Functions Namespace


Minimum Method (Int64, Int64)

[image]

FastReport.Net Class Reference
StdFunctions..::.Minimum Method (Int64, Int64)
StdFunctions Class See Also Send Feedback
Returns the smaller of two 64-bit signed integers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static long Minimum(
    long val1,
    long val2
)
Visual Basic (Declaration)
Public Shared Function Minimum ( _
    val1 As Long, _
    val2 As Long _
) As Long
Visual C++
public:
static long long Minimum(
    long long val1,
    long long val2
)

Parameters

val1
Type: System..::.Int64
The first of two values to compare.
val2
Type: System..::.Int64
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is smaller.

See Also

StdFunctions Class
Minimum Overload
FastReport.Functions Namespace


Minimum Method (Single, Single)

[image]

FastReport.Net Class Reference
StdFunctions..::.Minimum Method (Single, Single)
StdFunctions Class See Also Send Feedback
Returns the smaller of two single-precision floating-point numbers.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float Minimum(
    float val1,
    float val2
)
Visual Basic (Declaration)
Public Shared Function Minimum ( _
    val1 As Single, _
    val2 As Single _
) As Single
Visual C++
public:
static float Minimum(
    float val1,
    float val2
)

Parameters

val1
Type: System..::.Single
The first of two values to compare.
val2
Type: System..::.Single
The second of two values to compare.

Return Value

Parameter val1 or val2, whichever is smaller.

See Also

StdFunctions Class
Minimum Overload
FastReport.Functions Namespace


Minute Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Minute Method
StdFunctions Class See Also Send Feedback
Gets the minute component of the date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Minute(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function Minute ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int Minute(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date.

Return Value

The minute component.

See Also

StdFunctions Class
FastReport.Functions Namespace


Month Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Month Method
StdFunctions Class See Also Send Feedback
Gets the month component of the date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Month(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function Month ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int Month(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date.

Return Value

The month component.

See Also

StdFunctions Class
FastReport.Functions Namespace


MonthName Method

[image]

FastReport.Net Class Reference
StdFunctions..::.MonthName Method
StdFunctions Class See Also Send Feedback
Gets the localized month name.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string MonthName(
    int month
)
Visual Basic (Declaration)
Public Shared Function MonthName ( _
    month As Integer _
) As String
Visual C++
public:
static String^ MonthName(
    int month
)

Parameters

month
Type: System..::.Int32
The month number.

Return Value

The month name.

See Also

StdFunctions Class
FastReport.Functions Namespace


PadLeft Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.PadLeft Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
PadLeft(String, Int32) | Right-aligns the characters in a string, padding with spaces on the left for a specified total length.
PadLeft(String, Int32, Char) | Right-aligns the characters in a string, padding on the left with a specified character for a specified total length.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


PadLeft Method (String, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.PadLeft Method (String, Int32)
StdFunctions Class See Also Send Feedback
Right-aligns the characters in a string, padding with spaces on the left for a specified total length.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string PadLeft(
    string s,
    int totalWidth
)
Visual Basic (Declaration)
Public Shared Function PadLeft ( _
    s As String, _
    totalWidth As Integer _
) As String
Visual C++
public:
static String^ PadLeft(
    String^ s,
    int totalWidth
)

Parameters

s
Type: System..::.String
The original string.
totalWidth
Type: System..::.Int32
The number of characters in the resulting string.

Return Value

Right-aligned string, padded on the left with spaces.

See Also

StdFunctions Class
PadLeft Overload
FastReport.Functions Namespace


PadLeft Method (String, Int32, Char)

[image]

FastReport.Net Class Reference
StdFunctions..::.PadLeft Method (String, Int32, Char)
StdFunctions Class See Also Send Feedback
Right-aligns the characters in a string, padding on the left with a specified character for a specified total length.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string PadLeft(
    string s,
    int totalWidth,
    char paddingChar
)
Visual Basic (Declaration)
Public Shared Function PadLeft ( _
    s As String, _
    totalWidth As Integer, _
    paddingChar As Char _
) As String
Visual C++
public:
static String^ PadLeft(
    String^ s,
    int totalWidth,
    wchar_t paddingChar
)

Parameters

s
Type: System..::.String
The original string.
totalWidth
Type: System..::.Int32
The number of characters in the resulting string.
paddingChar
Type: System..::.Char
A padding character.

Return Value

Right-aligned string, padded on the left with padding characters.

See Also

StdFunctions Class
PadLeft Overload
FastReport.Functions Namespace


PadRight Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.PadRight Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
PadRight(String, Int32) | Left-aligns the characters in a string, padding with spaces on the right, for a specified total length.
PadRight(String, Int32, Char) | Left-aligns the characters in a string, padding on the right with a specified character, for a specified total length.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


PadRight Method (String, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.PadRight Method (String, Int32)
StdFunctions Class See Also Send Feedback
Left-aligns the characters in a string, padding with spaces on the right, for a specified total length.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string PadRight(
    string s,
    int totalWidth
)
Visual Basic (Declaration)
Public Shared Function PadRight ( _
    s As String, _
    totalWidth As Integer _
) As String
Visual C++
public:
static String^ PadRight(
    String^ s,
    int totalWidth
)

Parameters

s
Type: System..::.String
The original string.
totalWidth
Type: System..::.Int32
The number of characters in the resulting string.

Return Value

Left-aligned string, padded on the right with spaces.

See Also

StdFunctions Class
PadRight Overload
FastReport.Functions Namespace


PadRight Method (String, Int32, Char)

[image]

FastReport.Net Class Reference
StdFunctions..::.PadRight Method (String, Int32, Char)
StdFunctions Class See Also Send Feedback
Left-aligns the characters in a string, padding on the right with a specified character, for a specified total length.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string PadRight(
    string s,
    int totalWidth,
    char paddingChar
)
Visual Basic (Declaration)
Public Shared Function PadRight ( _
    s As String, _
    totalWidth As Integer, _
    paddingChar As Char _
) As String
Visual C++
public:
static String^ PadRight(
    String^ s,
    int totalWidth,
    wchar_t paddingChar
)

Parameters

s
Type: System..::.String
The original string.
totalWidth
Type: System..::.Int32
The number of characters in the resulting string.
paddingChar
Type: System..::.Char
A padding character.

Return Value

Left-aligned string, padded on the right with padding characters.

See Also

StdFunctions Class
PadRight Overload
FastReport.Functions Namespace


Remove Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.Remove Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
Remove(String, Int32) | Deletes all the characters from a string beginning at a specified position.
Remove(String, Int32, Int32) | Deletes a specified number of characters from a string beginning at a specified position.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


Remove Method (String, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.Remove Method (String, Int32)
StdFunctions Class See Also Send Feedback
Deletes all the characters from a string beginning at a specified position.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Remove(
    string s,
    int startIndex
)
Visual Basic (Declaration)
Public Shared Function Remove ( _
    s As String, _
    startIndex As Integer _
) As String
Visual C++
public:
static String^ Remove(
    String^ s,
    int startIndex
)

Parameters

s
Type: System..::.String
The original string.
startIndex
Type: System..::.Int32
The position to begin deleting characters.

Return Value

A new string.

See Also

StdFunctions Class
Remove Overload
FastReport.Functions Namespace


Remove Method (String, Int32, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.Remove Method (String, Int32, Int32)
StdFunctions Class See Also Send Feedback
Deletes a specified number of characters from a string beginning at a specified position.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Remove(
    string s,
    int startIndex,
    int count
)
Visual Basic (Declaration)
Public Shared Function Remove ( _
    s As String, _
    startIndex As Integer, _
    count As Integer _
) As String
Visual C++
public:
static String^ Remove(
    String^ s,
    int startIndex,
    int count
)

Parameters

s
Type: System..::.String
The original string.
startIndex
Type: System..::.Int32
The position to begin deleting characters.
count
Type: System..::.Int32
The number of characters to delete.

Return Value

A new string.

See Also

StdFunctions Class
Remove Overload
FastReport.Functions Namespace


Replace Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Replace Method
StdFunctions Class See Also Send Feedback
Replaces all occurrences of a specified string in the original string, with another specified string.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Replace(
    string s,
    string oldValue,
    string newValue
)
Visual Basic (Declaration)
Public Shared Function Replace ( _
    s As String, _
    oldValue As String, _
    newValue As String _
) As String
Visual C++
public:
static String^ Replace(
    String^ s,
    String^ oldValue,
    String^ newValue
)

Parameters

s
Type: System..::.String
The original string.
oldValue
Type: System..::.String
A string to be replaced.
newValue
Type: System..::.String
A string to replace all occurrences of oldValue.

Return Value

A new string.

See Also

StdFunctions Class
FastReport.Functions Namespace


Second Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Second Method
StdFunctions Class See Also Send Feedback
Gets the seconds component of the date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Second(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function Second ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int Second(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date.

Return Value

The seconds component.

See Also

StdFunctions Class
FastReport.Functions Namespace


Substring Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.Substring Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
Substring(String, Int32) | Retrieves a substring from the original string, starting at a specified character position.
Substring(String, Int32, Int32) | Retrieves a substring from the original string, starting at a specified character position, with a specified length.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


Substring Method (String, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.Substring Method (String, Int32)
StdFunctions Class See Also Send Feedback
Retrieves a substring from the original string, starting at a specified character position.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Substring(
    string s,
    int startIndex
)
Visual Basic (Declaration)
Public Shared Function Substring ( _
    s As String, _
    startIndex As Integer _
) As String
Visual C++
public:
static String^ Substring(
    String^ s,
    int startIndex
)

Parameters

s
Type: System..::.String
The original string.
startIndex
Type: System..::.Int32
The starting character position of a substring.

Return Value

A new string.

See Also

StdFunctions Class
Substring Overload
FastReport.Functions Namespace


Substring Method (String, Int32, Int32)

[image]

FastReport.Net Class Reference
StdFunctions..::.Substring Method (String, Int32, Int32)
StdFunctions Class See Also Send Feedback
Retrieves a substring from the original string, starting at a specified character position, with a specified length.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Substring(
    string s,
    int startIndex,
    int length
)
Visual Basic (Declaration)
Public Shared Function Substring ( _
    s As String, _
    startIndex As Integer, _
    length As Integer _
) As String
Visual C++
public:
static String^ Substring(
    String^ s,
    int startIndex,
    int length
)

Parameters

s
Type: System..::.String
The original string.
startIndex
Type: System..::.Int32
The starting character position of a substring.
length
Type: System..::.Int32
The number of characters in the substring.

Return Value

A new string.

See Also

StdFunctions Class
Substring Overload
FastReport.Functions Namespace


Switch Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Switch Method
StdFunctions Class See Also Send Feedback
Evaluates a list of expressions and returns a value corresponding to the first expression in the list that is True.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Object Switch(
    params Object[] expressions
)
Visual Basic (Declaration)
Public Shared Function Switch ( _
    ParamArray expressions As Object() _
) As Object
Visual C++
public:
static Object^ Switch(
    ... array<Object^>^ expressions
)

Parameters

expressions
Type: array< System..::.Object >[]()[]
Parameter array consists of paired expressions and values.

Return Value

The value corresponding to an expression which returns true.

See Also

StdFunctions Class
FastReport.Functions Namespace


TitleCase Method

[image]

FastReport.Net Class Reference
StdFunctions..::.TitleCase Method
StdFunctions Class See Also Send Feedback
Converts the specified string to titlecase.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string TitleCase(
    string s
)
Visual Basic (Declaration)
Public Shared Function TitleCase ( _
    s As String _
) As String
Visual C++
public:
static String^ TitleCase(
    String^ s
)

Parameters

s
Type: System..::.String
The string to convert.

Return Value

A new string.

See Also

StdFunctions Class
FastReport.Functions Namespace


ToRoman Method

[image]

FastReport.Net Class Reference
StdFunctions..::.ToRoman Method
StdFunctions Class See Also Send Feedback
Converts a numeric value to Roman string representation.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToRoman(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToRoman ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToRoman(
    Object^ value
)

Parameters

value
Type: System..::.Object
Integer value in range 0-3998.

Return Value

The string in Roman form.

See Also

StdFunctions Class
FastReport.Functions Namespace


ToWords Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.ToWords Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
ToWords(Object) | Converts a currency value to an english (US) string representation of that value.
ToWords(Object, String) | Converts a currency value to an english (US) string representation of that value, using the specified currency.
ToWords(Object, String, String) | Converts a numeric value to an english (US) string representation of that value.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


ToWords Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWords Method (Object)
StdFunctions Class See Also Send Feedback
Converts a currency value to an english (US) string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWords(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToWords ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToWords(
    Object^ value
)

Parameters

value
Type: System..::.Object
The currency value to convert.

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWords Overload
FastReport.Functions Namespace


ToWords Method (Object, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWords Method (Object, String)
StdFunctions Class See Also Send Feedback
Converts a currency value to an english (US) string representation of that value, using the specified currency.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWords(
    Object value,
    string currencyName
)
Visual Basic (Declaration)
Public Shared Function ToWords ( _
    value As Object, _
    currencyName As String _
) As String
Visual C++
public:
static String^ ToWords(
    Object^ value,
    String^ currencyName
)

Parameters

value
Type: System..::.Object
The currency value to convert.
currencyName
Type: System..::.String
The 3-digit ISO name of the currency, for example "EUR".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWords Overload
FastReport.Functions Namespace


ToWords Method (Object, String, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWords Method (Object, String, String)
StdFunctions Class See Also Send Feedback
Converts a numeric value to an english (US) string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWords(
    Object value,
    string one,
    string many
)
Visual Basic (Declaration)
Public Shared Function ToWords ( _
    value As Object, _
    one As String, _
    many As String _
) As String
Visual C++
public:
static String^ ToWords(
    Object^ value,
    String^ one,
    String^ many
)

Parameters

value
Type: System..::.Object
The numeric value to convert.
one
Type: System..::.String
The name in singular form, for example "page".
many
Type: System..::.String
The name in plural form, for example "pages".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWords Overload
FastReport.Functions Namespace


ToWordsEnGb Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEnGb Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
ToWordsEnGb(Object) | Converts a currency value to an english (GB) string representation of that value.
ToWordsEnGb(Object, String) | Converts a currency value to an english (GB) string representation of that value, using the specified currency.
ToWordsEnGb(Object, String, String) | Converts a numeric value to an english (GB) string representation of that value.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


ToWordsEnGb Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEnGb Method (Object)
StdFunctions Class See Also Send Feedback
Converts a currency value to an english (GB) string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsEnGb(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToWordsEnGb ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToWordsEnGb(
    Object^ value
)

Parameters

value
Type: System..::.Object
The currency value to convert.

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsEnGb Overload
FastReport.Functions Namespace


ToWordsEnGb Method (Object, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEnGb Method (Object, String)
StdFunctions Class See Also Send Feedback
Converts a currency value to an english (GB) string representation of that value, using the specified currency.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsEnGb(
    Object value,
    string currencyName
)
Visual Basic (Declaration)
Public Shared Function ToWordsEnGb ( _
    value As Object, _
    currencyName As String _
) As String
Visual C++
public:
static String^ ToWordsEnGb(
    Object^ value,
    String^ currencyName
)

Parameters

value
Type: System..::.Object
The currency value to convert.
currencyName
Type: System..::.String
The 3-digit ISO name of the currency, for example "EUR".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsEnGb Overload
FastReport.Functions Namespace


ToWordsEnGb Method (Object, String, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEnGb Method (Object, String, String)
StdFunctions Class See Also Send Feedback
Converts a numeric value to an english (GB) string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsEnGb(
    Object value,
    string one,
    string many
)
Visual Basic (Declaration)
Public Shared Function ToWordsEnGb ( _
    value As Object, _
    one As String, _
    many As String _
) As String
Visual C++
public:
static String^ ToWordsEnGb(
    Object^ value,
    String^ one,
    String^ many
)

Parameters

value
Type: System..::.Object
The numeric value to convert.
one
Type: System..::.String
The name in singular form, for example "page".
many
Type: System..::.String
The name in plural form, for example "pages".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsEnGb Overload
FastReport.Functions Namespace


ToWordsEs Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEs Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
ToWordsEs(Object) | Converts a currency value to a spanish string representation of that value.
ToWordsEs(Object, String) | Converts a currency value to a spanish string representation of that value, using the specified currency.
ToWordsEs(Object, String, String) | Converts a numeric value to a spanish string representation of that value.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


ToWordsEs Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEs Method (Object)
StdFunctions Class See Also Send Feedback
Converts a currency value to a spanish string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsEs(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToWordsEs ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToWordsEs(
    Object^ value
)

Parameters

value
Type: System..::.Object
The currency value to convert.

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsEs Overload
FastReport.Functions Namespace


ToWordsEs Method (Object, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEs Method (Object, String)
StdFunctions Class See Also Send Feedback
Converts a currency value to a spanish string representation of that value, using the specified currency.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsEs(
    Object value,
    string currencyName
)
Visual Basic (Declaration)
Public Shared Function ToWordsEs ( _
    value As Object, _
    currencyName As String _
) As String
Visual C++
public:
static String^ ToWordsEs(
    Object^ value,
    String^ currencyName
)

Parameters

value
Type: System..::.Object
The currency value to convert.
currencyName
Type: System..::.String
The 3-digit ISO name of the currency, for example "EUR".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsEs Overload
FastReport.Functions Namespace


ToWordsEs Method (Object, String, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsEs Method (Object, String, String)
StdFunctions Class See Also Send Feedback
Converts a numeric value to a spanish string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsEs(
    Object value,
    string one,
    string many
)
Visual Basic (Declaration)
Public Shared Function ToWordsEs ( _
    value As Object, _
    one As String, _
    many As String _
) As String
Visual C++
public:
static String^ ToWordsEs(
    Object^ value,
    String^ one,
    String^ many
)

Parameters

value
Type: System..::.Object
The numeric value to convert.
one
Type: System..::.String
The name in singular form, for example "page".
many
Type: System..::.String
The name in plural form, for example "pages".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsEs Overload
FastReport.Functions Namespace


ToWordsRu Method

[image] [image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsRu Method
StdFunctions Class See Also Send Feedback

Overload List

Name | Description
ToWordsRu(Object) | Converts a currency value to a russian string representation of that value.
ToWordsRu(Object, String) | Converts a currency value to a russian string representation of that value, using the specified currency.
ToWordsRu(Object, Boolean, String, String, String) | Converts a numeric value to a russian string representation of that value.

See Also

StdFunctions Class
StdFunctions Members
FastReport.Functions Namespace


ToWordsRu Method (Object)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsRu Method (Object)
StdFunctions Class See Also Send Feedback
Converts a currency value to a russian string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsRu(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToWordsRu ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToWordsRu(
    Object^ value
)

Parameters

value
Type: System..::.Object
The currency value to convert.

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsRu Overload
FastReport.Functions Namespace


ToWordsRu Method (Object, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsRu Method (Object, String)
StdFunctions Class See Also Send Feedback
Converts a currency value to a russian string representation of that value, using the specified currency.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsRu(
    Object value,
    string currencyName
)
Visual Basic (Declaration)
Public Shared Function ToWordsRu ( _
    value As Object, _
    currencyName As String _
) As String
Visual C++
public:
static String^ ToWordsRu(
    Object^ value,
    String^ currencyName
)

Parameters

value
Type: System..::.Object
The currency value to convert.
currencyName
Type: System..::.String
The 3-digit ISO name of the currency, for example "EUR".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsRu Overload
FastReport.Functions Namespace


ToWordsRu Method (Object, Boolean, String, String, String)

[image]

FastReport.Net Class Reference
StdFunctions..::.ToWordsRu Method (Object, Boolean, String, String, String)
StdFunctions Class See Also Send Feedback
Converts a numeric value to a russian string representation of that value.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToWordsRu(
    Object value,
    bool male,
    string one,
    string two,
    string many
)
Visual Basic (Declaration)
Public Shared Function ToWordsRu ( _
    value As Object, _
    male As Boolean, _
    one As String, _
    two As String, _
    many As String _
) As String
Visual C++
public:
static String^ ToWordsRu(
    Object^ value,
    bool male,
    String^ one,
    String^ two,
    String^ many
)

Parameters

value
Type: System..::.Object
The numeric value to convert.
male
Type: System..::.Boolean
True if the name is of male gender.
one
Type: System..::.String
The name in singular form, for example "страница".
two
Type: System..::.String
The name in plural form, for example "страницы".
many
Type: System..::.String
The name in plural form, for example "страниц".

Return Value

The string representation of the specified value.

See Also

StdFunctions Class
ToWordsRu Overload
FastReport.Functions Namespace


Trim Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Trim Method
StdFunctions Class See Also Send Feedback
Removes all occurrences of white space characters from the beginning and end of the original string.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Trim(
    string s
)
Visual Basic (Declaration)
Public Shared Function Trim ( _
    s As String _
) As String
Visual C++
public:
static String^ Trim(
    String^ s
)

Parameters

s
Type: System..::.String
The original string.

Return Value

A new string.

See Also

StdFunctions Class
FastReport.Functions Namespace


UpperCase Method

[image]

FastReport.Net Class Reference
StdFunctions..::.UpperCase Method
StdFunctions Class See Also Send Feedback
Converts a specified string to uppercase.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string UpperCase(
    string s
)
Visual Basic (Declaration)
Public Shared Function UpperCase ( _
    s As String _
) As String
Visual C++
public:
static String^ UpperCase(
    String^ s
)

Parameters

s
Type: System..::.String
The string to convert.

Return Value

A string in uppercase.

See Also

StdFunctions Class
FastReport.Functions Namespace


WeekOfYear Method

[image]

FastReport.Net Class Reference
StdFunctions..::.WeekOfYear Method
StdFunctions Class See Also Send Feedback
Gets the week of the year.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int WeekOfYear(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function WeekOfYear ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int WeekOfYear(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date value.

Return Value

The week of the year.

See Also

StdFunctions Class
FastReport.Functions Namespace


Year Method

[image]

FastReport.Net Class Reference
StdFunctions..::.Year Method
StdFunctions Class See Also Send Feedback
Gets the year component of the date.

Namespace: FastReport.Functions
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static int Year(
    DateTime date
)
Visual Basic (Declaration)
Public Shared Function Year ( _
    date As DateTime _
) As Integer
Visual C++
public:
static int Year(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date.

Return Value

The year component.

See Also

StdFunctions Class
FastReport.Functions Namespace


FastReport.Map Namespace

[image]

FastReport.Net Class Reference
FastReport.Map Namespace
Send Feedback

Classes

Class | Description
BoundingBox | Represents four coordinates that define a bounding box.
ColorRange | Represents a single color range.
ColorRanges | Represents a set of color ranges used to highlight polygons based on analytical value.
ColorScale | Represents the color scale.
DistanceScale | Represents a distance scale.
LayerCollection | Represents a collection of MapLayer objects.
MapLayer | Represents a map layer.
MapObject | Represents a map object.
ScaleBase | The base class for scale-type controls such as DistanceScale and ColorScale.
ShapeBase | The base class for shape objects such as ShapePoint, ShapePolyLine and ShapePolygon.
ShapeCollection | Holds the list of objects of ShapeBase type.
ShapePoint | Represents a map point.
ShapePolygon | Represents a polygon shape.
ShapePolyLine | Represents a line shape.
ShapeSpatialData | Represents the spatial data of a shape.
ShapeStyle | Represents the style of a shape.
SizeRange | Represents a single size range.
SizeRanges | Represents a set of size ranges used to draw points based on analytical value.

Structures

Structure | Description
PointD | Represents a pair of double coordinates that defines a constituent point.

Enumerations

Enumeration | Description
LayerType | Specifies the type of objects that layer contains.
MapLabelKind | Determines how map labels are displayed.
MapPalette | Defines the palette used to display map shapes.
ScaleDock | Specifies the position of a scale control inside the map.
SpatialSource | Specifies the spatial source for the layer.


BoundingBox Class

[image]

FastReport.Net Class Reference
BoundingBox Class
Members See Also Send Feedback
Represents four coordinates that define a bounding box.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BoundingBox
Visual Basic (Declaration)
Public Class BoundingBox
Visual C++
public ref class BoundingBox

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.BoundingBox

See Also

BoundingBox Members
FastReport.Map Namespace


BoundingBox Members

[image] [image]

FastReport.Net Class Reference
BoundingBox Members
BoundingBox Class Constructors Methods Properties See Also Send Feedback

The BoundingBox type exposes the following members.

Constructors

Name | Description
BoundingBox | Initializes a new instance of the BoundingBox class

Methods

Name | Description
Assign | Copies the contents of another BoundingBox instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MaxX | Gets or sets the maximum X-coordinate of a bounding box.
MaxY | Gets or sets the maximum Y-coordinate of a bounding box.
MinX | Gets or sets the minimum X-coordinate of a bounding box.
MinY | Gets or sets the minimum Y-coordinate of a bounding box.

See Also

BoundingBox Class
FastReport.Map Namespace


BoundingBox Constructor

[image]

FastReport.Net Class Reference
BoundingBox Constructor
BoundingBox Class See Also Send Feedback
Initializes a new instance of the BoundingBox class

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BoundingBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBox()

See Also

BoundingBox Class
FastReport.Map Namespace


BoundingBox Methods

[image] [image]

FastReport.Net Class Reference
BoundingBox Methods
BoundingBox Class See Also Send Feedback

The BoundingBox type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another BoundingBox instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBox Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
BoundingBox..::.Assign Method
BoundingBox Class See Also Send Feedback
Copies the contents of another BoundingBox instance.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    BoundingBox src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As BoundingBox _
)
Visual C++
public:
void Assign(
    BoundingBox^ src
)

Parameters

src
Type: FastReport.Map..::.BoundingBox
Source box to copy the contents from.

See Also

BoundingBox Class
FastReport.Map Namespace


BoundingBox Properties

[image] [image]

FastReport.Net Class Reference
BoundingBox Properties
BoundingBox Class See Also Send Feedback

The BoundingBox type exposes the following members.

Properties

Name | Description
MaxX | Gets or sets the maximum X-coordinate of a bounding box.
MaxY | Gets or sets the maximum Y-coordinate of a bounding box.
MinX | Gets or sets the minimum X-coordinate of a bounding box.
MinY | Gets or sets the minimum Y-coordinate of a bounding box.

See Also

BoundingBox Class
FastReport.Map Namespace


MaxX Property

[image]

FastReport.Net Class Reference
BoundingBox..::.MaxX Property
BoundingBox Class See Also Send Feedback
Gets or sets the maximum X-coordinate of a bounding box.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double MaxX { get; set; }
Visual Basic (Declaration)
Public Property MaxX As Double
Visual C++
public:
property double MaxX {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class
FastReport.Map Namespace


MaxY Property

[image]

FastReport.Net Class Reference
BoundingBox..::.MaxY Property
BoundingBox Class See Also Send Feedback
Gets or sets the maximum Y-coordinate of a bounding box.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double MaxY { get; set; }
Visual Basic (Declaration)
Public Property MaxY As Double
Visual C++
public:
property double MaxY {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class
FastReport.Map Namespace


MinX Property

[image]

FastReport.Net Class Reference
BoundingBox..::.MinX Property
BoundingBox Class See Also Send Feedback
Gets or sets the minimum X-coordinate of a bounding box.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double MinX { get; set; }
Visual Basic (Declaration)
Public Property MinX As Double
Visual C++
public:
property double MinX {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class
FastReport.Map Namespace


MinY Property

[image]

FastReport.Net Class Reference
BoundingBox..::.MinY Property
BoundingBox Class See Also Send Feedback
Gets or sets the minimum Y-coordinate of a bounding box.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double MinY { get; set; }
Visual Basic (Declaration)
Public Property MinY As Double
Visual C++
public:
property double MinY {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class
FastReport.Map Namespace


ColorRange Class

[image]

FastReport.Net Class Reference
ColorRange Class
Members See Also Send Feedback
Represents a single color range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorRange
Visual Basic (Declaration)
Public Class ColorRange
Visual C++
public ref class ColorRange

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ColorRange

See Also

ColorRange Members
FastReport.Map Namespace


ColorRange Members

[image] [image]

FastReport.Net Class Reference
ColorRange Members
ColorRange Class Constructors Methods Properties See Also Send Feedback

The ColorRange type exposes the following members.

Constructors

Name | Description
ColorRange | Overloaded.

Methods

Name | Description
Assign | Copies the contents of another ColorRange.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets color of the range.
EndValue | Gets or sets end value of the range.
StartValue | Gets or sets start value of the range.

See Also

ColorRange Class
FastReport.Map Namespace


ColorRange Constructor

[image] [image]

FastReport.Net Class Reference
ColorRange Constructor
ColorRange Class See Also Send Feedback

Overload List

Name | Description
ColorRange()()() | Initializes a new instance of the ColorRange class.
ColorRange(Color, Double, Double) | Initializes a new instance of the ColorRange class with a specified parameters.

See Also

ColorRange Class
ColorRange Members
FastReport.Map Namespace


ColorRange Constructor

[image]

FastReport.Net Class Reference
ColorRange Constructor
ColorRange Class See Also Send Feedback
Initializes a new instance of the ColorRange class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorRange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorRange()

See Also

ColorRange Class
ColorRange Overload
FastReport.Map Namespace


ColorRange Constructor (Color, Double, Double)

[image]

FastReport.Net Class Reference
ColorRange Constructor (Color, Double, Double)
ColorRange Class See Also Send Feedback
Initializes a new instance of the ColorRange class with a specified parameters.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorRange(
    Color color,
    double startValue,
    double endValue
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    startValue As Double, _
    endValue As Double _
)
Visual C++
public:
ColorRange(
    Color color,
    double startValue,
    double endValue
)

Parameters

color
Type: System.Drawing..::.Color
The color of the range.
startValue
Type: System..::.Double
The start value of the range.
endValue
Type: System..::.Double
The end value of the range.

See Also

ColorRange Class
ColorRange Overload
FastReport.Map Namespace


ColorRange Methods

[image] [image]

FastReport.Net Class Reference
ColorRange Methods
ColorRange Class See Also Send Feedback

The ColorRange type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another ColorRange.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorRange Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ColorRange..::.Assign Method
ColorRange Class See Also Send Feedback
Copies the contents of another ColorRange.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    ColorRange src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As ColorRange _
)
Visual C++
public:
void Assign(
    ColorRange^ src
)

Parameters

src
Type: FastReport.Map..::.ColorRange
The ColorRange instance to copy the contents from.

See Also

ColorRange Class
FastReport.Map Namespace


ColorRange Properties

[image] [image]

FastReport.Net Class Reference
ColorRange Properties
ColorRange Class See Also Send Feedback

The ColorRange type exposes the following members.

Properties

Name | Description
Color | Gets or sets color of the range.
EndValue | Gets or sets end value of the range.
StartValue | Gets or sets start value of the range.

See Also

ColorRange Class
FastReport.Map Namespace


Color Property

[image]

FastReport.Net Class Reference
ColorRange..::.Color Property
ColorRange Class See Also Send Feedback
Gets or sets color of the range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ColorRange Class
FastReport.Map Namespace


EndValue Property

[image]

FastReport.Net Class Reference
ColorRange..::.EndValue Property
ColorRange Class See Also Send Feedback
Gets or sets end value of the range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double EndValue { get; set; }
Visual Basic (Declaration)
Public Property EndValue As Double
Visual C++
public:
property double EndValue {
    double get ();
    void set (double value);
}

See Also

ColorRange Class
FastReport.Map Namespace


StartValue Property

[image]

FastReport.Net Class Reference
ColorRange..::.StartValue Property
ColorRange Class See Also Send Feedback
Gets or sets start value of the range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double StartValue { get; set; }
Visual Basic (Declaration)
Public Property StartValue As Double
Visual C++
public:
property double StartValue {
    double get ();
    void set (double value);
}

See Also

ColorRange Class
FastReport.Map Namespace


ColorRanges Class

[image]

FastReport.Net Class Reference
ColorRanges Class
Members See Also Send Feedback
Represents a set of color ranges used to highlight polygons based on analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorRanges
Visual Basic (Declaration)
Public Class ColorRanges
Visual C++
public ref class ColorRanges

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ColorRanges

See Also

ColorRanges Members
FastReport.Map Namespace


ColorRanges Members

[image] [image]

FastReport.Net Class Reference
ColorRanges Members
ColorRanges Class Constructors Methods Properties See Also Send Feedback

The ColorRanges type exposes the following members.

Constructors

Name | Description
ColorRanges | Initializes a new instance of the ColorRanges class.

Methods

Name | Description
Assign | Copies the contents of another ColorRanges.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Gets a color associated with given analytical value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EndColor | Gets or sets the end color.
MiddleColor | Gets or sets the middle color.
RangeCount | Gets or sets the number of ranges.
Ranges | Gets the list of ranges.
RangesAsString | Gets or sets ranges as a string.
ShowInColorScale | Gets or sets a value indicating that the map's color scale must display data from this color ranges.
StartColor | Gets or sets the start color.

See Also

ColorRanges Class
FastReport.Map Namespace


ColorRanges Constructor

[image]

FastReport.Net Class Reference
ColorRanges Constructor
ColorRanges Class See Also Send Feedback
Initializes a new instance of the ColorRanges class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorRanges()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorRanges()

See Also

ColorRanges Class
FastReport.Map Namespace


ColorRanges Methods

[image] [image]

FastReport.Net Class Reference
ColorRanges Methods
ColorRanges Class See Also Send Feedback

The ColorRanges type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another ColorRanges.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Gets a color associated with given analytical value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorRanges Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ColorRanges..::.Assign Method
ColorRanges Class See Also Send Feedback
Copies the contents of another ColorRanges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    ColorRanges src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As ColorRanges _
)
Visual C++
public:
void Assign(
    ColorRanges^ src
)

Parameters

src
Type: FastReport.Map..::.ColorRanges
The ColorRanges instance to copy the contents from.

See Also

ColorRanges Class
FastReport.Map Namespace


GetColor Method

[image]

FastReport.Net Class Reference
ColorRanges..::.GetColor Method
ColorRanges Class See Also Send Feedback
Gets a color associated with given analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color GetColor(
    double value
)
Visual Basic (Declaration)
Public Function GetColor ( _
    value As Double _
) As Color
Visual C++
public:
Color GetColor(
    double value
)

Parameters

value
Type: System..::.Double
The analytical value.

Return Value

The color associated with this value, or Color.Transparent if no association found.

See Also

ColorRanges Class
FastReport.Map Namespace


ColorRanges Properties

[image] [image]

FastReport.Net Class Reference
ColorRanges Properties
ColorRanges Class See Also Send Feedback

The ColorRanges type exposes the following members.

Properties

Name | Description
EndColor | Gets or sets the end color.
MiddleColor | Gets or sets the middle color.
RangeCount | Gets or sets the number of ranges.
Ranges | Gets the list of ranges.
RangesAsString | Gets or sets ranges as a string.
ShowInColorScale | Gets or sets a value indicating that the map's color scale must display data from this color ranges.
StartColor | Gets or sets the start color.

See Also

ColorRanges Class
FastReport.Map Namespace


EndColor Property

[image]

FastReport.Net Class Reference
ColorRanges..::.EndColor Property
ColorRanges Class See Also Send Feedback
Gets or sets the end color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color EndColor { get; set; }
Visual Basic (Declaration)
Public Property EndColor As Color
Visual C++
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}

See Also

ColorRanges Class
FastReport.Map Namespace


MiddleColor Property

[image]

FastReport.Net Class Reference
ColorRanges..::.MiddleColor Property
ColorRanges Class See Also Send Feedback
Gets or sets the middle color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color MiddleColor { get; set; }
Visual Basic (Declaration)
Public Property MiddleColor As Color
Visual C++
public:
property Color MiddleColor {
    Color get ();
    void set (Color value);
}

See Also

ColorRanges Class
FastReport.Map Namespace


RangeCount Property

[image]

FastReport.Net Class Reference
ColorRanges..::.RangeCount Property
ColorRanges Class See Also Send Feedback
Gets or sets the number of ranges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RangeCount { get; set; }
Visual Basic (Declaration)
Public Property RangeCount As Integer
Visual C++
public:
property int RangeCount {
    int get ();
    void set (int value);
}

See Also

ColorRanges Class
FastReport.Map Namespace


Ranges Property

[image]

FastReport.Net Class Reference
ColorRanges..::.Ranges Property
ColorRanges Class See Also Send Feedback
Gets the list of ranges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<ColorRange> Ranges { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ranges As List(Of ColorRange)
Visual C++
public:
property List<ColorRange^>^ Ranges {
    List<ColorRange^>^ get ();
}

See Also

ColorRanges Class
FastReport.Map Namespace


RangesAsString Property

[image]

FastReport.Net Class Reference
ColorRanges..::.RangesAsString Property
ColorRanges Class See Also Send Feedback
Gets or sets ranges as a string.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string RangesAsString { get; set; }
Visual Basic (Declaration)
Public Property RangesAsString As String
Visual C++
public:
property String^ RangesAsString {
    String^ get ();
    void set (String^ value);
}

See Also

ColorRanges Class
FastReport.Map Namespace


ShowInColorScale Property

[image]

FastReport.Net Class Reference
ColorRanges..::.ShowInColorScale Property
ColorRanges Class See Also Send Feedback
Gets or sets a value indicating that the map's color scale must display data from this color ranges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowInColorScale { get; set; }
Visual Basic (Declaration)
Public Property ShowInColorScale As Boolean
Visual C++
public:
property bool ShowInColorScale {
    bool get ();
    void set (bool value);
}

See Also

ColorRanges Class
FastReport.Map Namespace


StartColor Property

[image]

FastReport.Net Class Reference
ColorRanges..::.StartColor Property
ColorRanges Class See Also Send Feedback
Gets or sets the start color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color StartColor { get; set; }
Visual Basic (Declaration)
Public Property StartColor As Color
Visual C++
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}

See Also

ColorRanges Class
FastReport.Map Namespace


ColorScale Class

[image]

FastReport.Net Class Reference
ColorScale Class
Members See Also Send Feedback
Represents the color scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorScale : ScaleBase
Visual Basic (Declaration)
Public Class ColorScale _
    Inherits ScaleBase
Visual C++
public ref class ColorScale : public ScaleBase

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ScaleBase
FastReport.Map..::.ColorScale

See Also

ColorScale Members
FastReport.Map Namespace


ColorScale Members

[image] [image]

FastReport.Net Class Reference
ColorScale Members
ColorScale Class Constructors Methods Properties See Also Send Feedback

The ColorScale type exposes the following members.

Constructors

Name | Description
ColorScale | Initializes a new instance of the ColorScale class.

Methods

Name | Description
Assign | Copies the contents of another ScaleBase. (Overrides ScaleBase..::.Assign(ScaleBase).)
CalcSize | Gets the size of the scale, in pixels. (Overrides ScaleBase..::.CalcSize()()().)
Draw | Draws the object. (Overrides ScaleBase..::.Draw(FRPaintEventArgs, MapObject).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the scale. (Overrides ScaleBase..::.Serialize(FRWriter, String, ScaleBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Border | Gets or sets the border. (Inherited from ScaleBase.)
BorderColor | Gets or sets the border color. (Inherited from ScaleBase.)
Data | Gets or sets ColorRanges that must be displayed in this color scale.
Dock | Gets or sets the location of the scale. (Inherited from ScaleBase.)
Fill | Gets or sets the fill. (Inherited from ScaleBase.)
Font | Gets or sets the font. (Inherited from ScaleBase.)
Format | Gets or sets the format string used to format data values.
HideIfNoData | Gets or sets a value indicating whether the color scale must be hidden if there is no data in it.
NoDataText | Gets or sets the text displayed in the color scale if there is no data in it.
TextColor | Gets or sets the text color. (Inherited from ScaleBase.)
TitleColor | Gets or sets the title text color. (Inherited from ScaleBase.)
TitleFont | Gets or sets the title font. (Inherited from ScaleBase.)
TitleText | Gets or sets the title text. (Inherited from ScaleBase.)
Visible | Gets or sets the visibility of a scale. (Inherited from ScaleBase.)

See Also

ColorScale Class
FastReport.Map Namespace


ColorScale Constructor

[image]

FastReport.Net Class Reference
ColorScale Constructor
ColorScale Class See Also Send Feedback
Initializes a new instance of the ColorScale class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorScale()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorScale()

See Also

ColorScale Class
FastReport.Map Namespace


ColorScale Methods

[image] [image]

FastReport.Net Class Reference
ColorScale Methods
ColorScale Class See Also Send Feedback

The ColorScale type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another ScaleBase. (Overrides ScaleBase..::.Assign(ScaleBase).)
CalcSize | Gets the size of the scale, in pixels. (Overrides ScaleBase..::.CalcSize()()().)
Draw | Draws the object. (Overrides ScaleBase..::.Draw(FRPaintEventArgs, MapObject).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the scale. (Overrides ScaleBase..::.Serialize(FRWriter, String, ScaleBase).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorScale Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ColorScale..::.Assign Method
ColorScale Class See Also Send Feedback
Copies the contents of another ScaleBase.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    ScaleBase src
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    src As ScaleBase _
)
Visual C++
public:
virtual void Assign(
    ScaleBase^ src
) override

Parameters

src
Type: FastReport.Map..::.ScaleBase
The ScaleBase instance to copy the contents from.

See Also

ColorScale Class
FastReport.Map Namespace


CalcSize Method

[image]

FastReport.Net Class Reference
ColorScale..::.CalcSize Method
ColorScale Class See Also Send Feedback
Gets the size of the scale, in pixels.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF CalcSize()
Visual Basic (Declaration)
Public Overrides Function CalcSize As SizeF
Visual C++
public:
virtual SizeF CalcSize() override

Return Value

The SizeF structure containing the size of the object.

See Also

ColorScale Class
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
ColorScale..::.Draw Method
ColorScale Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e,
    MapObject parent
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs, _
    parent As MapObject _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e,
    MapObject^ parent
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw parameters.
parent
Type: FastReport.Map..::.MapObject
Parent map object.

See Also

ColorScale Class
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ColorScale..::.Serialize Method
ColorScale Class See Also Send Feedback
Serializes the scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer,
    string prefix,
    ScaleBase diff
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    diff As ScaleBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    ScaleBase^ diff
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Scale property name.
diff
Type: FastReport.Map..::.ScaleBase
Another ScaleBase to compare with.

Remarks

This method is for internal use only.

See Also

ColorScale Class
FastReport.Map Namespace


ColorScale Properties

[image] [image]

FastReport.Net Class Reference
ColorScale Properties
ColorScale Class See Also Send Feedback

The ColorScale type exposes the following members.

Properties

Name | Description
Border | Gets or sets the border. (Inherited from ScaleBase.)
BorderColor | Gets or sets the border color. (Inherited from ScaleBase.)
Data | Gets or sets ColorRanges that must be displayed in this color scale.
Dock | Gets or sets the location of the scale. (Inherited from ScaleBase.)
Fill | Gets or sets the fill. (Inherited from ScaleBase.)
Font | Gets or sets the font. (Inherited from ScaleBase.)
Format | Gets or sets the format string used to format data values.
HideIfNoData | Gets or sets a value indicating whether the color scale must be hidden if there is no data in it.
NoDataText | Gets or sets the text displayed in the color scale if there is no data in it.
TextColor | Gets or sets the text color. (Inherited from ScaleBase.)
TitleColor | Gets or sets the title text color. (Inherited from ScaleBase.)
TitleFont | Gets or sets the title font. (Inherited from ScaleBase.)
TitleText | Gets or sets the title text. (Inherited from ScaleBase.)
Visible | Gets or sets the visibility of a scale. (Inherited from ScaleBase.)

See Also

ColorScale Class
FastReport.Map Namespace


Data Property

[image]

FastReport.Net Class Reference
ColorScale..::.Data Property
ColorScale Class See Also Send Feedback
Gets or sets ColorRanges that must be displayed in this color scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorRanges Data { get; set; }
Visual Basic (Declaration)
Public Property Data As ColorRanges
Visual C++
public:
property ColorRanges^ Data {
    ColorRanges^ get ();
    void set (ColorRanges^ value);
}

See Also

ColorScale Class
FastReport.Map Namespace


Format Property

[image]

FastReport.Net Class Reference
ColorScale..::.Format Property
ColorScale Class See Also Send Feedback
Gets or sets the format string used to format data values.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

See Also

ColorScale Class
FastReport.Map Namespace


HideIfNoData Property

[image]

FastReport.Net Class Reference
ColorScale..::.HideIfNoData Property
ColorScale Class See Also Send Feedback
Gets or sets a value indicating whether the color scale must be hidden if there is no data in it.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HideIfNoData { get; set; }
Visual Basic (Declaration)
Public Property HideIfNoData As Boolean
Visual C++
public:
property bool HideIfNoData {
    bool get ();
    void set (bool value);
}

See Also

ColorScale Class
FastReport.Map Namespace


NoDataText Property

[image]

FastReport.Net Class Reference
ColorScale..::.NoDataText Property
ColorScale Class See Also Send Feedback
Gets or sets the text displayed in the color scale if there is no data in it.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string NoDataText { get; set; }
Visual Basic (Declaration)
Public Property NoDataText As String
Visual C++
public:
property String^ NoDataText {
    String^ get ();
    void set (String^ value);
}

See Also

ColorScale Class
FastReport.Map Namespace


DistanceScale Class

[image]

FastReport.Net Class Reference
DistanceScale Class
Members See Also Send Feedback
Represents a distance scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DistanceScale : ScaleBase
Visual Basic (Declaration)
Public Class DistanceScale _
    Inherits ScaleBase
Visual C++
public ref class DistanceScale : public ScaleBase

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ScaleBase
FastReport.Map..::.DistanceScale

See Also

DistanceScale Members
FastReport.Map Namespace


DistanceScale Members

[image] [image]

FastReport.Net Class Reference
DistanceScale Members
DistanceScale Class Constructors Methods Properties See Also Send Feedback

The DistanceScale type exposes the following members.

Constructors

Name | Description
DistanceScale | Initializes a new instance of the DistanceScale class.

Methods

Name | Description
Assign | Copies the contents of another ScaleBase. (Inherited from ScaleBase.)
CalcSize | Gets the size of the scale, in pixels. (Inherited from ScaleBase.)
Draw | Draws the object. (Inherited from ScaleBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the scale. (Inherited from ScaleBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Border | Gets or sets the border. (Inherited from ScaleBase.)
BorderColor | Gets or sets the border color. (Inherited from ScaleBase.)
Dock | Gets or sets the location of the scale. (Inherited from ScaleBase.)
Fill | Gets or sets the fill. (Inherited from ScaleBase.)
Font | Gets or sets the font. (Inherited from ScaleBase.)
TextColor | Gets or sets the text color. (Inherited from ScaleBase.)
TitleColor | Gets or sets the title text color. (Inherited from ScaleBase.)
TitleFont | Gets or sets the title font. (Inherited from ScaleBase.)
TitleText | Gets or sets the title text. (Inherited from ScaleBase.)
Visible | Gets or sets the visibility of a scale. (Inherited from ScaleBase.)

See Also

DistanceScale Class
FastReport.Map Namespace


DistanceScale Constructor

[image]

FastReport.Net Class Reference
DistanceScale Constructor
DistanceScale Class See Also Send Feedback
Initializes a new instance of the DistanceScale class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DistanceScale()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistanceScale()

See Also

DistanceScale Class
FastReport.Map Namespace


DistanceScale Methods

[image] [image]

FastReport.Net Class Reference
DistanceScale Methods
DistanceScale Class See Also Send Feedback

The DistanceScale type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another ScaleBase. (Inherited from ScaleBase.)
CalcSize | Gets the size of the scale, in pixels. (Inherited from ScaleBase.)
Draw | Draws the object. (Inherited from ScaleBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the scale. (Inherited from ScaleBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistanceScale Class
FastReport.Map Namespace


DistanceScale Properties

[image] [image]

FastReport.Net Class Reference
DistanceScale Properties
DistanceScale Class See Also Send Feedback

The DistanceScale type exposes the following members.

Properties

Name | Description
Border | Gets or sets the border. (Inherited from ScaleBase.)
BorderColor | Gets or sets the border color. (Inherited from ScaleBase.)
Dock | Gets or sets the location of the scale. (Inherited from ScaleBase.)
Fill | Gets or sets the fill. (Inherited from ScaleBase.)
Font | Gets or sets the font. (Inherited from ScaleBase.)
TextColor | Gets or sets the text color. (Inherited from ScaleBase.)
TitleColor | Gets or sets the title text color. (Inherited from ScaleBase.)
TitleFont | Gets or sets the title font. (Inherited from ScaleBase.)
TitleText | Gets or sets the title text. (Inherited from ScaleBase.)
Visible | Gets or sets the visibility of a scale. (Inherited from ScaleBase.)

See Also

DistanceScale Class
FastReport.Map Namespace


LayerCollection Class

[image]

FastReport.Net Class Reference
LayerCollection Class
Members See Also Send Feedback
Represents a collection of MapLayer objects.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LayerCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class LayerCollection _
    Inherits FRCollectionBase
Visual C++
public ref class LayerCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Map..::.LayerCollection

See Also

LayerCollection Members
FastReport.Map Namespace


LayerCollection Members

[image] [image]

FastReport.Net Class Reference
LayerCollection Members
LayerCollection Class Methods Properties See Also Send Feedback

The LayerCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a layer with specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

LayerCollection Class
FastReport.Map Namespace


LayerCollection Methods

[image] [image]

FastReport.Net Class Reference
LayerCollection Methods
LayerCollection Class See Also Send Feedback

The LayerCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayerCollection Class
FastReport.Map Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
LayerCollection..::.AddRange Method
LayerCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

LayerCollection Class
LayerCollection Members
FastReport.Map Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
LayerCollection..::.Equals Method
LayerCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

LayerCollection Class
LayerCollection Members
FastReport.Map Namespace


LayerCollection Properties

[image] [image]

FastReport.Net Class Reference
LayerCollection Properties
LayerCollection Class See Also Send Feedback

The LayerCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a layer with specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

LayerCollection Class
FastReport.Map Namespace


Item Property

[image]

FastReport.Net Class Reference
LayerCollection..::.Item Property
LayerCollection Class See Also Send Feedback
Gets a layer with specified index.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapLayer this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As MapLayer
Visual C++
public:
property MapLayer^ default[int index] {
    MapLayer^ get (int index);
    void set (int index, MapLayer^ value);
}

Parameters

index
Type: System..::.Int32
Index of a layer.

Return Value

The layer with specified index.

See Also

LayerCollection Class
FastReport.Map Namespace


LayerType Enumeration

[image]

FastReport.Net Class Reference
LayerType Enumeration
See Also Send Feedback
Specifies the type of objects that layer contains.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum LayerType
Visual Basic (Declaration)
Public Enumeration LayerType
Visual C++
public enum class LayerType

Members

Member name | Description
Point | The layer contains points.
Line | The layer contains lines.
Polygon | The layer contains polygons.

See Also

FastReport.Map Namespace


MapLabelKind Enumeration

[image]

FastReport.Net Class Reference
MapLabelKind Enumeration
See Also Send Feedback
Determines how map labels are displayed.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum MapLabelKind
Visual Basic (Declaration)
Public Enumeration MapLabelKind
Visual C++
public enum class MapLabelKind

Members

Member name | Description
None | No label displayed.
Name | The shape name is displayed.
Value | The value is displayed.
NameAndValue | Both name and value displayed.

See Also

FastReport.Map Namespace


MapLayer Class

[image]

FastReport.Net Class Reference
MapLayer Class
Members See Also Send Feedback
Represents a map layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MapLayer : Base, IParent,
    ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class MapLayer _
    Inherits Base _
    Implements IParent, ICustomTypeDescriptor
Visual C++
public ref class MapLayer : public Base,
    IParent, ICustomTypeDescriptor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Map..::.MapLayer

See Also

MapLayer Members
FastReport.Map Namespace


MapLayer Members

[image] [image]

FastReport.Net Class Reference
MapLayer Members
MapLayer Class Constructors Methods Properties Events See Also Send Feedback

The MapLayer type exposes the following members.

Constructors

Name | Description
MapLayer | Initializes a new instance of the MapLayer class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
AddValue | Overloaded.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all contained objects such as points, lines, polygons, etc.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the layer.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component.
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Finds the shape under cursor.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadShapefile | Loads the layer contents from ESRI shapefile (*.shp/*.dbf).
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Overrides Base..::.OnAfterLoad()()().)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shapes in this layer.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
Accuracy | Gets or sets the map accuracy. Lower value is better, but slower.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AnalyticalValue | Gets or sets an expression that returns analytical value.
BaseName | The base part of the object's name. (Inherited from Base.)
Box | Gets or sets a bounding box of layer.
BoxAsString | Gets or sets the bounding box as a string.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ColorRanges | Gets the color ranges used to highlight shapes based on analytical value.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSource | Gets or sets the data source.
DefaultShapeStyle | Gets the default style of shapes in this layer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filter | Gets or sets the datasource filter expression.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Function | Gets or sets the aggregate function.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
LabelColumn | Gets or sets label's column name.
LabelFormat | Gets or sets the format of label's value.
LabelKind | Gets or sets a value that determines how map labels are displayed.
LabelsVisibleAtZoom | Gets or sets the value that determines the labels visiblity at a certain zoom value.
LabelValue | Gets or sets an expression that returns label value.
LatitudeValue | Gets or sets an expression that returns latitude value.
LongitudeValue | Gets or sets an expression that returns longitude value.
Map | Gets a reference to the Map object.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Palette | Gets or sets the palette used to highlight shapes.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Shapefile | Gets or sets the name of ESRI shapefile.
Shapes | Gets a collection of map objects.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SizeRanges | Gets the size ranges used to draw points based on analytical value.
SpatialColumn | Gets or sets spatial column name.
SpatialSource | Gets or sets the spatial source for the layer.
SpatialValue | Gets or sets an expression that returns spatial value.
Type | Gets or sets a type of layer.
Visible | Gets or sets a value indicating that the layer is visible.
ZoomPolygon | Gets or sets the expression that returns the name of polygon to zoom.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MapLayer Class
FastReport.Map Namespace


MapLayer Constructor

[image]

FastReport.Net Class Reference
MapLayer Constructor
MapLayer Class See Also Send Feedback
Initializes a new instance of the MapLayer class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapLayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MapLayer()

See Also

MapLayer Class
FastReport.Map Namespace


MapLayer Methods

[image] [image]

FastReport.Net Class Reference
MapLayer Methods
MapLayer Class See Also Send Feedback

The MapLayer type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
AddValue | Overloaded.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all contained objects such as points, lines, polygons, etc.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the layer.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component.
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Finds the shape under cursor.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
LoadShapefile | Loads the layer contents from ESRI shapefile (*.shp/*.dbf).
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Overrides Base..::.OnAfterLoad()()().)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shapes in this layer.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

MapLayer Class
FastReport.Map Namespace


AddChild Method

[image]

FastReport.Net Class Reference
MapLayer..::.AddChild Method
MapLayer Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

MapLayer Class
FastReport.Map Namespace


AddValue Method

[image] [image]

FastReport.Net Class Reference
MapLayer..::.AddValue Method
MapLayer Class See Also Send Feedback

Overload List

Name | Description
AddValue(String, Double) | Adds a spatial/analytical value pair to the list.
AddValue(Double, Double, String, Double) | Adds application provided data.

See Also

MapLayer Class
MapLayer Members
FastReport.Map Namespace


AddValue Method (String, Double)

[image]

FastReport.Net Class Reference
MapLayer..::.AddValue Method (String, Double)
MapLayer Class See Also Send Feedback
Adds a spatial/analytical value pair to the list.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddValue(
    string spatialValue,
    double analyticalValue
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    spatialValue As String, _
    analyticalValue As Double _
)
Visual C++
public:
void AddValue(
    String^ spatialValue,
    double analyticalValue
)

Parameters

spatialValue
Type: System..::.String
The spatial value.
analyticalValue
Type: System..::.Double
The analytical value.

Remarks

Use this method if the SpatialSource is set to ShpFile.

See Also

MapLayer Class
AddValue Overload
FastReport.Map Namespace


AddValue Method (Double, Double, String, Double)

[image]

FastReport.Net Class Reference
MapLayer..::.AddValue Method (Double, Double, String, Double)
MapLayer Class See Also Send Feedback
Adds application provided data.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddValue(
    double latitude,
    double longitude,
    string name,
    double analyticalValue
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    latitude As Double, _
    longitude As Double, _
    name As String, _
    analyticalValue As Double _
)
Visual C++
public:
void AddValue(
    double latitude,
    double longitude,
    String^ name,
    double analyticalValue
)

Parameters

latitude
Type: System..::.Double
Latitude value.
longitude
Type: System..::.Double
Longitude value.
name
Type: System..::.String
The name displayed as a label.
analyticalValue
Type: System..::.Double
Analytical value.

Remarks

Use this method if the SpatialSource is set to ApplicationData.

See Also

MapLayer Class
AddValue Overload
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
MapLayer..::.Assign Method
MapLayer Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

MapLayer Class
FastReport.Map Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
MapLayer..::.CanContain Method
MapLayer Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

MapLayer Class
FastReport.Map Namespace


CreateUniqueNames Method

[image]

FastReport.Net Class Reference
MapLayer..::.CreateUniqueNames Method
MapLayer Class See Also Send Feedback
Creates unique names for all contained objects such as points, lines, polygons, etc.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateUniqueNames()
Visual Basic (Declaration)
Public Sub CreateUniqueNames
Visual C++
public:
void CreateUniqueNames()

See Also

MapLayer Class
FastReport.Map Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MapLayer..::.Dispose Method
MapLayer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

MapLayer Class
MapLayer Members
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
MapLayer..::.Draw Method
MapLayer Class See Also Send Feedback
Draws the layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
void Draw(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
The drawing parameters.

See Also

MapLayer Class
FastReport.Map Namespace


GetAttributes Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetAttributes Method
MapLayer Class See Also Send Feedback
Returns a collection of custom attributes for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AttributeCollection GetAttributes()
Visual Basic (Declaration)
Public Function GetAttributes As AttributeCollection
Visual C++
public:
virtual AttributeCollection^ GetAttributes() sealed

Return Value

An AttributeCollection containing the attributes for this object.

Implements

ICustomTypeDescriptor..::.GetAttributes()()()

See Also

MapLayer Class
FastReport.Map Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetChildObjects Method
MapLayer Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

MapLayer Class
FastReport.Map Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetChildOrder Method
MapLayer Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

MapLayer Class
FastReport.Map Namespace


GetClassName Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetClassName Method
MapLayer Class See Also Send Feedback
Returns the class name of this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetClassName()
Visual Basic (Declaration)
Public Function GetClassName As String
Visual C++
public:
virtual String^ GetClassName() sealed

Return Value

The class name of the object, or null if the class does not have a name.

Implements

ICustomTypeDescriptor..::.GetClassName()()()

See Also

MapLayer Class
FastReport.Map Namespace


GetComponentName Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetComponentName Method
MapLayer Class See Also Send Feedback
Returns the name of this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetComponentName()
Visual Basic (Declaration)
Public Function GetComponentName As String
Visual C++
public:
virtual String^ GetComponentName() sealed

Return Value

The name of the object, or null if the object does not have a name.

Implements

ICustomTypeDescriptor..::.GetComponentName()()()

See Also

MapLayer Class
FastReport.Map Namespace


GetConverter Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetConverter Method
MapLayer Class See Also Send Feedback
Returns a type converter for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TypeConverter GetConverter()
Visual Basic (Declaration)
Public Function GetConverter As TypeConverter
Visual C++
public:
virtual TypeConverter^ GetConverter() sealed

Return Value

A TypeConverter that is the converter for this object, or null if there is no TypeConverter for this object.

Implements

ICustomTypeDescriptor..::.GetConverter()()()

See Also

MapLayer Class
FastReport.Map Namespace


GetDefaultEvent Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetDefaultEvent Method
MapLayer Class See Also Send Feedback
Returns the default event for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EventDescriptor GetDefaultEvent()
Visual Basic (Declaration)
Public Function GetDefaultEvent As EventDescriptor
Visual C++
public:
virtual EventDescriptor^ GetDefaultEvent() sealed

Return Value

An EventDescriptor that represents the default event for this object, or null if this object does not have events.

Implements

ICustomTypeDescriptor..::.GetDefaultEvent()()()

See Also

MapLayer Class
FastReport.Map Namespace


GetDefaultProperty Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetDefaultProperty Method
MapLayer Class See Also Send Feedback
Returns the default property for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptor GetDefaultProperty()
Visual Basic (Declaration)
Public Function GetDefaultProperty As PropertyDescriptor
Visual C++
public:
virtual PropertyDescriptor^ GetDefaultProperty() sealed

Return Value

A PropertyDescriptor that represents the default property for this object, or null if this object does not have properties.

Implements

ICustomTypeDescriptor..::.GetDefaultProperty()()()

See Also

MapLayer Class
FastReport.Map Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetEditor Method
MapLayer Class See Also Send Feedback
Returns an editor of the specified type for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetEditor(
    Type editorBaseType
)
Visual Basic (Declaration)
Public Function GetEditor ( _
    editorBaseType As Type _
) As Object
Visual C++
public:
virtual Object^ GetEditor(
    Type^ editorBaseType
) sealed

Parameters

editorBaseType
Type: System..::.Type
A Type that represents the editor for this object.

Return Value

An Object of the specified type that is the editor for this object, or null if the editor cannot be found.

Implements

ICustomTypeDescriptor..::.GetEditor(Type)

See Also

MapLayer Class
FastReport.Map Namespace


GetEvents Method

[image] [image]

FastReport.Net Class Reference
MapLayer..::.GetEvents Method
MapLayer Class See Also Send Feedback

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component.
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter.

See Also

MapLayer Class
MapLayer Members
FastReport.Map Namespace


GetEvents Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetEvents Method
MapLayer Class See Also Send Feedback
Returns the events for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EventDescriptorCollection GetEvents()
Visual Basic (Declaration)
Public Function GetEvents As EventDescriptorCollection
Visual C++
public:
virtual EventDescriptorCollection^ GetEvents() sealed

Return Value

An EventDescriptorCollection that represents the events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents()()()

See Also

MapLayer Class
GetEvents Overload
FastReport.Map Namespace


GetEvents Method (Attribute[])

[image]

FastReport.Net Class Reference
MapLayer..::.GetEvents Method (array<Attribute>[]()[])
MapLayer Class See Also Send Feedback
Returns the events for this instance of a component using the specified attribute array as a filter.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EventDescriptorCollection GetEvents(
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Function GetEvents ( _
    attributes As Attribute() _
) As EventDescriptorCollection
Visual C++
public:
virtual EventDescriptorCollection^ GetEvents(
    array<Attribute^>^ attributes
) sealed

Parameters

attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

An EventDescriptorCollection that represents the filtered events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents(array<Attribute>[]()[])

See Also

MapLayer Class
GetEvents Overload
FastReport.Map Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetExpressions Method
MapLayer Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

MapLayer Class
FastReport.Map Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
MapLayer..::.GetProperties Method
MapLayer Class See Also Send Feedback

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component.
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter.

See Also

MapLayer Class
MapLayer Members
FastReport.Map Namespace


GetProperties Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetProperties Method
MapLayer Class See Also Send Feedback
Returns the properties for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptorCollection GetProperties()
Visual Basic (Declaration)
Public Function GetProperties As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties() sealed

Return Value

A PropertyDescriptorCollection that represents the properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties()()()

See Also

MapLayer Class
GetProperties Overload
FastReport.Map Namespace


GetProperties Method (Attribute[])

[image]

FastReport.Net Class Reference
MapLayer..::.GetProperties Method (array<Attribute>[]()[])
MapLayer Class See Also Send Feedback
Returns the properties for this instance of a component using the attribute array as a filter.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptorCollection GetProperties(
    Attribute[] attr
)
Visual Basic (Declaration)
Public Function GetProperties ( _
    attr As Attribute() _
) As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties(
    array<Attribute^>^ attr
) sealed

Parameters

attr
Type: array< System..::.Attribute >[]()[]

Return Value

A PropertyDescriptorCollection that represents the filtered properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties(array<Attribute>[]()[])

See Also

MapLayer Class
GetProperties Overload
FastReport.Map Namespace


GetPropertyOwner Method

[image]

FastReport.Net Class Reference
MapLayer..::.GetPropertyOwner Method
MapLayer Class See Also Send Feedback
Returns an object that contains the property described by the specified property descriptor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetPropertyOwner(
    PropertyDescriptor pd
)
Visual Basic (Declaration)
Public Function GetPropertyOwner ( _
    pd As PropertyDescriptor _
) As Object
Visual C++
public:
virtual Object^ GetPropertyOwner(
    PropertyDescriptor^ pd
) sealed

Parameters

pd
Type: System.ComponentModel..::.PropertyDescriptor
A PropertyDescriptor that represents the property whose owner is to be found.

Return Value

An Object that represents the owner of the specified property.

Implements

ICustomTypeDescriptor..::.GetPropertyOwner(PropertyDescriptor)

See Also

MapLayer Class
FastReport.Map Namespace


HitTest Method

[image]

FastReport.Net Class Reference
MapLayer..::.HitTest Method
MapLayer Class See Also Send Feedback
Finds the shape under cursor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeBase HitTest(
    PointF point
)
Visual Basic (Declaration)
Public Function HitTest ( _
    point As PointF _
) As ShapeBase
Visual C++
public:
ShapeBase^ HitTest(
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF
The cursor coordinates.

Return Value

The ShapeBase object if found.

See Also

MapLayer Class
FastReport.Map Namespace


LoadShapefile Method

[image]

FastReport.Net Class Reference
MapLayer..::.LoadShapefile Method
MapLayer Class See Also Send Feedback
Loads the layer contents from ESRI shapefile (*.shp/*.dbf).

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void LoadShapefile(
    string fileName
)
Visual Basic (Declaration)
Public Sub LoadShapefile ( _
    fileName As String _
)
Visual C++
public:
void LoadShapefile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file name.

See Also

MapLayer Class
FastReport.Map Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MapLayer..::.MemberwiseClone Method
MapLayer Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MapLayer Class
MapLayer Members
FastReport.Map Namespace


OnAfterLoad Method

[image]

FastReport.Net Class Reference
MapLayer..::.OnAfterLoad Method
MapLayer Class See Also Send Feedback
Called after all report objects were loaded.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterLoad()
Visual Basic (Declaration)
Public Overrides Sub OnAfterLoad
Visual C++
public:
virtual void OnAfterLoad() override

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

See Also

MapLayer Class
FastReport.Map Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
MapLayer..::.RemoveChild Method
MapLayer Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

MapLayer Class
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MapLayer..::.Serialize Method
MapLayer Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MapLayer Class
FastReport.Map Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
MapLayer..::.SetChildOrder Method
MapLayer Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

MapLayer Class
FastReport.Map Namespace


Simplify Method

[image]

FastReport.Net Class Reference
MapLayer..::.Simplify Method
MapLayer Class See Also Send Feedback
Reduces the number of points in the shapes in this layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Simplify(
    double accuracy
)
Visual Basic (Declaration)
Public Sub Simplify ( _
    accuracy As Double _
)
Visual C++
public:
void Simplify(
    double accuracy
)

Parameters

accuracy
Type: System..::.Double
The accuracy value.

See Also

MapLayer Class
FastReport.Map Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
MapLayer..::.UpdateLayout Method
MapLayer Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

MapLayer Class
FastReport.Map Namespace


MapLayer Properties

[image] [image]

FastReport.Net Class Reference
MapLayer Properties
MapLayer Class See Also Send Feedback

The MapLayer type exposes the following members.

Properties

Name | Description
Accuracy | Gets or sets the map accuracy. Lower value is better, but slower.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AnalyticalValue | Gets or sets an expression that returns analytical value.
BaseName | The base part of the object's name. (Inherited from Base.)
Box | Gets or sets a bounding box of layer.
BoxAsString | Gets or sets the bounding box as a string.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ColorRanges | Gets the color ranges used to highlight shapes based on analytical value.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSource | Gets or sets the data source.
DefaultShapeStyle | Gets the default style of shapes in this layer.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filter | Gets or sets the datasource filter expression.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
Function | Gets or sets the aggregate function.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
LabelColumn | Gets or sets label's column name.
LabelFormat | Gets or sets the format of label's value.
LabelKind | Gets or sets a value that determines how map labels are displayed.
LabelsVisibleAtZoom | Gets or sets the value that determines the labels visiblity at a certain zoom value.
LabelValue | Gets or sets an expression that returns label value.
LatitudeValue | Gets or sets an expression that returns latitude value.
LongitudeValue | Gets or sets an expression that returns longitude value.
Map | Gets a reference to the Map object.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Palette | Gets or sets the palette used to highlight shapes.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Shapefile | Gets or sets the name of ESRI shapefile.
Shapes | Gets a collection of map objects.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SizeRanges | Gets the size ranges used to draw points based on analytical value.
SpatialColumn | Gets or sets spatial column name.
SpatialSource | Gets or sets the spatial source for the layer.
SpatialValue | Gets or sets an expression that returns spatial value.
Type | Gets or sets a type of layer.
Visible | Gets or sets a value indicating that the layer is visible.
ZoomPolygon | Gets or sets the expression that returns the name of polygon to zoom.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MapLayer Class
FastReport.Map Namespace


Accuracy Property

[image]

FastReport.Net Class Reference
MapLayer..::.Accuracy Property
MapLayer Class See Also Send Feedback
Gets or sets the map accuracy. Lower value is better, but slower.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Single
Visual C++
public:
property float Accuracy {
    float get ();
    void set (float value);
}

See Also

MapLayer Class
FastReport.Map Namespace


AnalyticalValue Property

[image]

FastReport.Net Class Reference
MapLayer..::.AnalyticalValue Property
MapLayer Class See Also Send Feedback
Gets or sets an expression that returns analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AnalyticalValue { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalValue As String
Visual C++
public:
property String^ AnalyticalValue {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


Box Property

[image]

FastReport.Net Class Reference
MapLayer..::.Box Property
MapLayer Class See Also Send Feedback
Gets or sets a bounding box of layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BoundingBox Box { get; set; }
Visual Basic (Declaration)
Public Property Box As BoundingBox
Visual C++
public:
property BoundingBox^ Box {
    BoundingBox^ get ();
    void set (BoundingBox^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


BoxAsString Property

[image]

FastReport.Net Class Reference
MapLayer..::.BoxAsString Property
MapLayer Class See Also Send Feedback
Gets or sets the bounding box as a string.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string BoxAsString { get; set; }
Visual Basic (Declaration)
Public Property BoxAsString As String
Visual C++
public:
property String^ BoxAsString {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


ColorRanges Property

[image]

FastReport.Net Class Reference
MapLayer..::.ColorRanges Property
MapLayer Class See Also Send Feedback
Gets the color ranges used to highlight shapes based on analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorRanges ColorRanges { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorRanges As ColorRanges
Visual C++
public:
property ColorRanges^ ColorRanges {
    ColorRanges^ get ();
}

See Also

MapLayer Class
FastReport.Map Namespace


DataSource Property

[image]

FastReport.Net Class Reference
MapLayer..::.DataSource Property
MapLayer Class See Also Send Feedback
Gets or sets the data source.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


DefaultShapeStyle Property

[image]

FastReport.Net Class Reference
MapLayer..::.DefaultShapeStyle Property
MapLayer Class See Also Send Feedback
Gets the default style of shapes in this layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeStyle DefaultShapeStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultShapeStyle As ShapeStyle
Visual C++
public:
property ShapeStyle^ DefaultShapeStyle {
    ShapeStyle^ get ();
}

See Also

MapLayer Class
FastReport.Map Namespace


Filter Property

[image]

FastReport.Net Class Reference
MapLayer..::.Filter Property
MapLayer Class See Also Send Feedback
Gets or sets the datasource filter expression.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


Function Property

[image]

FastReport.Net Class Reference
MapLayer..::.Function Property
MapLayer Class See Also Send Feedback
Gets or sets the aggregate function.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TotalType Function { get; set; }
Visual Basic (Declaration)
Public Property Function As TotalType
Visual C++
public:
property TotalType Function {
    TotalType get ();
    void set (TotalType value);
}

See Also

MapLayer Class
FastReport.Map Namespace


LabelColumn Property

[image]

FastReport.Net Class Reference
MapLayer..::.LabelColumn Property
MapLayer Class See Also Send Feedback
Gets or sets label's column name.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LabelColumn { get; set; }
Visual Basic (Declaration)
Public Property LabelColumn As String
Visual C++
public:
property String^ LabelColumn {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


LabelFormat Property

[image]

FastReport.Net Class Reference
MapLayer..::.LabelFormat Property
MapLayer Class See Also Send Feedback
Gets or sets the format of label's value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LabelFormat { get; set; }
Visual Basic (Declaration)
Public Property LabelFormat As String
Visual C++
public:
property String^ LabelFormat {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


LabelKind Property

[image]

FastReport.Net Class Reference
MapLayer..::.LabelKind Property
MapLayer Class See Also Send Feedback
Gets or sets a value that determines how map labels are displayed.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapLabelKind LabelKind { get; set; }
Visual Basic (Declaration)
Public Property LabelKind As MapLabelKind
Visual C++
public:
property MapLabelKind LabelKind {
    MapLabelKind get ();
    void set (MapLabelKind value);
}

See Also

MapLayer Class
FastReport.Map Namespace


LabelsVisibleAtZoom Property

[image]

FastReport.Net Class Reference
MapLayer..::.LabelsVisibleAtZoom Property
MapLayer Class See Also Send Feedback
Gets or sets the value that determines the labels visiblity at a certain zoom value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float LabelsVisibleAtZoom { get; set; }
Visual Basic (Declaration)
Public Property LabelsVisibleAtZoom As Single
Visual C++
public:
property float LabelsVisibleAtZoom {
    float get ();
    void set (float value);
}

See Also

MapLayer Class
FastReport.Map Namespace


LabelValue Property

[image]

FastReport.Net Class Reference
MapLayer..::.LabelValue Property
MapLayer Class See Also Send Feedback
Gets or sets an expression that returns label value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LabelValue { get; set; }
Visual Basic (Declaration)
Public Property LabelValue As String
Visual C++
public:
property String^ LabelValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if the SpatialSource is set to ApplicationData.

See Also

MapLayer Class
FastReport.Map Namespace


LatitudeValue Property

[image]

FastReport.Net Class Reference
MapLayer..::.LatitudeValue Property
MapLayer Class See Also Send Feedback
Gets or sets an expression that returns latitude value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LatitudeValue { get; set; }
Visual Basic (Declaration)
Public Property LatitudeValue As String
Visual C++
public:
property String^ LatitudeValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if the SpatialSource is set to ApplicationData.

See Also

MapLayer Class
FastReport.Map Namespace


LongitudeValue Property

[image]

FastReport.Net Class Reference
MapLayer..::.LongitudeValue Property
MapLayer Class See Also Send Feedback
Gets or sets an expression that returns longitude value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string LongitudeValue { get; set; }
Visual Basic (Declaration)
Public Property LongitudeValue As String
Visual C++
public:
property String^ LongitudeValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if the SpatialSource is set to ApplicationData.

See Also

MapLayer Class
FastReport.Map Namespace


Map Property

[image]

FastReport.Net Class Reference
MapLayer..::.Map Property
MapLayer Class See Also Send Feedback
Gets a reference to the Map object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapObject Map { get; }
Visual Basic (Declaration)
Public ReadOnly Property Map As MapObject
Visual C++
public:
property MapObject^ Map {
    MapObject^ get ();
}

See Also

MapLayer Class
FastReport.Map Namespace


Palette Property

[image]

FastReport.Net Class Reference
MapLayer..::.Palette Property
MapLayer Class See Also Send Feedback
Gets or sets the palette used to highlight shapes.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapPalette Palette { get; set; }
Visual Basic (Declaration)
Public Property Palette As MapPalette
Visual C++
public:
property MapPalette Palette {
    MapPalette get ();
    void set (MapPalette value);
}

See Also

MapLayer Class
FastReport.Map Namespace


Shapefile Property

[image]

FastReport.Net Class Reference
MapLayer..::.Shapefile Property
MapLayer Class See Also Send Feedback
Gets or sets the name of ESRI shapefile.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Shapefile { get; set; }
Visual Basic (Declaration)
Public Property Shapefile As String
Visual C++
public:
property String^ Shapefile {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


Shapes Property

[image]

FastReport.Net Class Reference
MapLayer..::.Shapes Property
MapLayer Class See Also Send Feedback
Gets a collection of map objects.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeCollection Shapes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Shapes As ShapeCollection
Visual C++
public:
property ShapeCollection^ Shapes {
    ShapeCollection^ get ();
}

See Also

MapLayer Class
FastReport.Map Namespace


SizeRanges Property

[image]

FastReport.Net Class Reference
MapLayer..::.SizeRanges Property
MapLayer Class See Also Send Feedback
Gets the size ranges used to draw points based on analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizeRanges SizeRanges { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeRanges As SizeRanges
Visual C++
public:
property SizeRanges^ SizeRanges {
    SizeRanges^ get ();
}

See Also

MapLayer Class
FastReport.Map Namespace


SpatialColumn Property

[image]

FastReport.Net Class Reference
MapLayer..::.SpatialColumn Property
MapLayer Class See Also Send Feedback
Gets or sets spatial column name.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SpatialColumn { get; set; }
Visual Basic (Declaration)
Public Property SpatialColumn As String
Visual C++
public:
property String^ SpatialColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if the SpatialSource is set to ShpFile.

See Also

MapLayer Class
FastReport.Map Namespace


SpatialSource Property

[image]

FastReport.Net Class Reference
MapLayer..::.SpatialSource Property
MapLayer Class See Also Send Feedback
Gets or sets the spatial source for the layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SpatialSource SpatialSource { get; set; }
Visual Basic (Declaration)
Public Property SpatialSource As SpatialSource
Visual C++
public:
property SpatialSource SpatialSource {
    SpatialSource get ();
    void set (SpatialSource value);
}

See Also

MapLayer Class
FastReport.Map Namespace


SpatialValue Property

[image]

FastReport.Net Class Reference
MapLayer..::.SpatialValue Property
MapLayer Class See Also Send Feedback
Gets or sets an expression that returns spatial value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SpatialValue { get; set; }
Visual Basic (Declaration)
Public Property SpatialValue As String
Visual C++
public:
property String^ SpatialValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if the SpatialSource is set to ShpFile.

See Also

MapLayer Class
FastReport.Map Namespace


Type Property

[image]

FastReport.Net Class Reference
MapLayer..::.Type Property
MapLayer Class See Also Send Feedback
Gets or sets a type of layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LayerType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As LayerType
Visual C++
public:
property LayerType Type {
    LayerType get ();
    void set (LayerType value);
}

See Also

MapLayer Class
FastReport.Map Namespace


Visible Property

[image]

FastReport.Net Class Reference
MapLayer..::.Visible Property
MapLayer Class See Also Send Feedback
Gets or sets a value indicating that the layer is visible.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

MapLayer Class
FastReport.Map Namespace


ZoomPolygon Property

[image]

FastReport.Net Class Reference
MapLayer..::.ZoomPolygon Property
MapLayer Class See Also Send Feedback
Gets or sets the expression that returns the name of polygon to zoom.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ZoomPolygon { get; set; }
Visual Basic (Declaration)
Public Property ZoomPolygon As String
Visual C++
public:
property String^ ZoomPolygon {
    String^ get ();
    void set (String^ value);
}

See Also

MapLayer Class
FastReport.Map Namespace


MapLayer Events

[image] [image]

FastReport.Net Class Reference
MapLayer Events
MapLayer Class See Also Send Feedback

The MapLayer type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MapLayer Class
FastReport.Map Namespace


MapObject Class

[image]

FastReport.Net Class Reference
MapObject Class
Members See Also Send Feedback
Represents a map object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MapObject : ReportComponentBase, IParent,
    IHasEditor
Visual Basic (Declaration)
Public Class MapObject _
    Inherits ReportComponentBase _
    Implements IParent, IHasEditor
Visual C++
public ref class MapObject : public ReportComponentBase,
    IParent, IHasEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport.Map..::.MapObject

See Also

MapObject Members
FastReport.Map Namespace


MapObject Members

[image] [image]

FastReport.Net Class Reference
MapObject Members
MapObject Class Constructors Methods Fields Properties Events See Also Send Feedback

The MapObject type exposes the following members.

Constructors

Name | Description
MapObject | Initializes a new instance of the MapObject class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all contained objects such as layers, shapes, etc.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Overrides ComponentBase..::.HandleMouseWheel(FRMouseEventArgs).)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
Load | Loads a map from ESRI shp/dbf files.
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Overrides ReportComponentBase..::.OnMouseDown(MouseEventArgs).)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Overrides ReportComponentBase..::.OnMouseEnter(EventArgs).)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Overrides ReportComponentBase..::.OnMouseLeave(EventArgs).)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Overrides ReportComponentBase..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Overrides ReportComponentBase..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Overrides ReportComponentBase..::.OnMouseWheel(MouseEventArgs).)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Fields

Name | Description
ShapefileFolder | Gets or sets the path to folder containing shapefiles.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColorScale | Gets the color scale settings.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | This property is not relevant to this class.
EvenStylePriority | This property is not relevant to this class.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | This property is not relevant to this class.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Overrides Base..::.IsSelected.)
Layers | Gets or sets a collection of map layers.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MaxZoom | Gets or sets maximum zoom value.
MercatorProjection | Gets or sets the value indicating that mercator projection must be used to view the map.
MinZoom | Gets or sets minimum zoom value.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OffsetX | Gets or sets the X offset of the map.
OffsetY | Gets or sets the Y offset of the map.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the map.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | This property is not relevant to this class.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
Zoom | Gets or sets the map zoom.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

MapObject Class
FastReport.Map Namespace


MapObject Constructor

[image]

FastReport.Net Class Reference
MapObject Constructor
MapObject Class See Also Send Feedback
Initializes a new instance of the MapObject class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MapObject()

See Also

MapObject Class
FastReport.Map Namespace


MapObject Fields

[image] [image]

FastReport.Net Class Reference
MapObject Fields
MapObject Class See Also Send Feedback

The MapObject type exposes the following members.

Fields

Name | Description
ShapefileFolder | Gets or sets the path to folder containing shapefiles.

See Also

MapObject Class
FastReport.Map Namespace


ShapefileFolder Field

[image]

FastReport.Net Class Reference
MapObject..::.ShapefileFolder Field
MapObject Class See Also Send Feedback
Gets or sets the path to folder containing shapefiles.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ShapefileFolder
Visual Basic (Declaration)
Public Shared ShapefileFolder As String
Visual C++
public:
static String^ ShapefileFolder

Remarks

This property is used by the map editor when selecting a shapefile.

See Also

MapObject Class
FastReport.Map Namespace


MapObject Methods

[image] [image]

FastReport.Net Class Reference
MapObject Methods
MapObject Class See Also Send Feedback

The MapObject type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all contained objects such as layers, shapes, etc.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Overrides ComponentBase..::.HandleMouseWheel(FRMouseEventArgs).)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
Load | Loads a map from ESRI shp/dbf files.
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Overrides ReportComponentBase..::.OnMouseDown(MouseEventArgs).)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Overrides ReportComponentBase..::.OnMouseEnter(EventArgs).)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Overrides ReportComponentBase..::.OnMouseLeave(EventArgs).)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Overrides ReportComponentBase..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Overrides ReportComponentBase..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Overrides ReportComponentBase..::.OnMouseWheel(MouseEventArgs).)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

MapObject Class
FastReport.Map Namespace


AddChild Method

[image]

FastReport.Net Class Reference
MapObject..::.AddChild Method
MapObject Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

MapObject Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
MapObject..::.Assign Method
MapObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

MapObject Class
FastReport.Map Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
MapObject..::.CanContain Method
MapObject Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

MapObject Class
FastReport.Map Namespace


CreateUniqueNames Method

[image]

FastReport.Net Class Reference
MapObject..::.CreateUniqueNames Method
MapObject Class See Also Send Feedback
Creates unique names for all contained objects such as layers, shapes, etc.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateUniqueNames()
Visual Basic (Declaration)
Public Sub CreateUniqueNames
Visual C++
public:
void CreateUniqueNames()

See Also

MapObject Class
FastReport.Map Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MapObject..::.Dispose Method
MapObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

MapObject Class
MapObject Members
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
MapObject..::.Draw Method
MapObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

MapObject Class
FastReport.Map Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
MapObject..::.DrawMarkers Method
MapObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

MapObject Class
MapObject Members
FastReport.Map Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
MapObject..::.FinalizeComponent Method
MapObject Class See Also Send Feedback
Performs a finalization after the report is finished.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FinalizeComponent()
Visual Basic (Declaration)
Public Overrides Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

MapObject Class
FastReport.Map Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
MapObject..::.GetChildObjects Method
MapObject Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

MapObject Class
FastReport.Map Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
MapObject..::.GetChildOrder Method
MapObject Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

MapObject Class
FastReport.Map Namespace


GetData Method

[image]

FastReport.Net Class Reference
MapObject..::.GetData Method
MapObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

MapObject Class
FastReport.Map Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
MapObject..::.GetPreferredSize Method
MapObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

MapObject Class
FastReport.Map Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
MapObject..::.HandleMouseDown Method
MapObject Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

MapObject Class
FastReport.Map Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
MapObject..::.HandleMouseHover Method
MapObject Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

MapObject Class
FastReport.Map Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
MapObject..::.HandleMouseMove Method
MapObject Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

MapObject Class
FastReport.Map Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
MapObject..::.HandleMouseUp Method
MapObject Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

MapObject Class
FastReport.Map Namespace


HandleMouseWheel Method

[image]

FastReport.Net Class Reference
MapObject..::.HandleMouseWheel Method
MapObject Class See Also Send Feedback
Handles mouse wheel event.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseWheel(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseWheel ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseWheel(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

See Also

MapObject Class
FastReport.Map Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
MapObject..::.InitializeComponent Method
MapObject Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

MapObject Class
FastReport.Map Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
MapObject..::.InvokeEditor Method
MapObject Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

MapObject Class
FastReport.Map Namespace


Load Method

[image]

FastReport.Net Class Reference
MapObject..::.Load Method
MapObject Class See Also Send Feedback
Loads a map from ESRI shp/dbf files.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string filename
)
Visual Basic (Declaration)
Public Sub Load ( _
    filename As String _
)
Visual C++
public:
void Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
Name of file that contains a map.

See Also

MapObject Class
FastReport.Map Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MapObject..::.MemberwiseClone Method
MapObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MapObject Class
MapObject Members
FastReport.Map Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
MapObject..::.OnBeforeInsert Method
MapObject Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

MapObject Class
FastReport.Map Namespace


OnMouseDown Method

[image]

FastReport.Net Class Reference
MapObject..::.OnMouseDown Method
MapObject Class See Also Send Feedback
This method fires the MouseDown event and the script code connected to the MouseDownEvent.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

MapObject Class
FastReport.Map Namespace


OnMouseEnter Method

[image]

FastReport.Net Class Reference
MapObject..::.OnMouseEnter Method
MapObject Class See Also Send Feedback
This method fires the MouseEnter event and the script code connected to the MouseEnterEvent.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseEnter(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

MapObject Class
FastReport.Map Namespace


OnMouseLeave Method

[image]

FastReport.Net Class Reference
MapObject..::.OnMouseLeave Method
MapObject Class See Also Send Feedback
This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

MapObject Class
FastReport.Map Namespace


OnMouseMove Method

[image]

FastReport.Net Class Reference
MapObject..::.OnMouseMove Method
MapObject Class See Also Send Feedback
This method fires the MouseMove event and the script code connected to the MouseMoveEvent.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

MapObject Class
FastReport.Map Namespace


OnMouseUp Method

[image]

FastReport.Net Class Reference
MapObject..::.OnMouseUp Method
MapObject Class See Also Send Feedback
This method fires the MouseUp event and the script code connected to the MouseUpEvent.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

MapObject Class
FastReport.Map Namespace


OnMouseWheel Method

[image]

FastReport.Net Class Reference
MapObject..::.OnMouseWheel Method
MapObject Class See Also Send Feedback
This method is fired when the user scrolls the mouse in the preview window.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

MapObject Class
FastReport.Map Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
MapObject..::.RemoveChild Method
MapObject Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

MapObject Class
FastReport.Map Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
MapObject..::.RestoreState Method
MapObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

MapObject Class
FastReport.Map Namespace


SaveState Method

[image]

FastReport.Net Class Reference
MapObject..::.SaveState Method
MapObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

MapObject Class
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MapObject..::.Serialize Method
MapObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MapObject Class
FastReport.Map Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
MapObject..::.SetChildOrder Method
MapObject Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

MapObject Class
FastReport.Map Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
MapObject..::.UpdateLayout Method
MapObject Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

MapObject Class
FastReport.Map Namespace


MapObject Properties

[image] [image]

FastReport.Net Class Reference
MapObject Properties
MapObject Class See Also Send Feedback

The MapObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColorScale | Gets the color scale settings.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | This property is not relevant to this class.
EvenStylePriority | This property is not relevant to this class.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | This property is not relevant to this class.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Overrides Base..::.IsSelected.)
Layers | Gets or sets a collection of map layers.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MaxZoom | Gets or sets maximum zoom value.
MercatorProjection | Gets or sets the value indicating that mercator projection must be used to view the map.
MinZoom | Gets or sets minimum zoom value.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OffsetX | Gets or sets the X offset of the map.
OffsetY | Gets or sets the Y offset of the map.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the map.
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | This property is not relevant to this class.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
Zoom | Gets or sets the map zoom.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MapObject Class
FastReport.Map Namespace


CanGrow Property

[image]

FastReport.Net Class Reference
MapObject..::.CanGrow Property
MapObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

See Also

MapObject Class
FastReport.Map Namespace


CanShrink Property

[image]

FastReport.Net Class Reference
MapObject..::.CanShrink Property
MapObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

See Also

MapObject Class
FastReport.Map Namespace


ColorScale Property

[image]

FastReport.Net Class Reference
MapObject..::.ColorScale Property
MapObject Class See Also Send Feedback
Gets the color scale settings.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorScale ColorScale { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorScale As ColorScale
Visual C++
public:
property ColorScale^ ColorScale {
    ColorScale^ get ();
}

See Also

MapObject Class
FastReport.Map Namespace


EvenStyle Property

[image]

FastReport.Net Class Reference
MapObject..::.EvenStyle Property
MapObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string EvenStyle { get; set; }
Visual Basic (Declaration)
Public Property EvenStyle As String
Visual C++
public:
property String^ EvenStyle {
    String^ get ();
    void set (String^ value);
}

See Also

MapObject Class
FastReport.Map Namespace


EvenStylePriority Property

[image]

FastReport.Net Class Reference
MapObject..::.EvenStylePriority Property
MapObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StylePriority EvenStylePriority { get; set; }
Visual Basic (Declaration)
Public Property EvenStylePriority As StylePriority
Visual C++
public:
property StylePriority EvenStylePriority {
    StylePriority get ();
    void set (StylePriority value);
}

See Also

MapObject Class
FastReport.Map Namespace


HoverStyle Property

[image]

FastReport.Net Class Reference
MapObject..::.HoverStyle Property
MapObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string HoverStyle { get; set; }
Visual Basic (Declaration)
Public Property HoverStyle As String
Visual C++
public:
property String^ HoverStyle {
    String^ get ();
    void set (String^ value);
}

See Also

MapObject Class
FastReport.Map Namespace


IsSelected Property

[image]

FastReport.Net Class Reference
MapObject..::.IsSelected Property
MapObject Class See Also Send Feedback
Gets a value indicating whether the object is selected in the designer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsSelected { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsSelected As Boolean
Visual C++
public:
virtual property bool IsSelected {
    bool get () override;
}

See Also

MapObject Class
FastReport.Map Namespace


Layers Property

[image]

FastReport.Net Class Reference
MapObject..::.Layers Property
MapObject Class See Also Send Feedback
Gets or sets a collection of map layers.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LayerCollection Layers { get; set; }
Visual Basic (Declaration)
Public Property Layers As LayerCollection
Visual C++
public:
property LayerCollection^ Layers {
    LayerCollection^ get ();
    void set (LayerCollection^ value);
}

See Also

MapObject Class
FastReport.Map Namespace


MaxZoom Property

[image]

FastReport.Net Class Reference
MapObject..::.MaxZoom Property
MapObject Class See Also Send Feedback
Gets or sets maximum zoom value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MaxZoom { get; set; }
Visual Basic (Declaration)
Public Property MaxZoom As Single
Visual C++
public:
property float MaxZoom {
    float get ();
    void set (float value);
}

See Also

MapObject Class
FastReport.Map Namespace


MercatorProjection Property

[image]

FastReport.Net Class Reference
MapObject..::.MercatorProjection Property
MapObject Class See Also Send Feedback
Gets or sets the value indicating that mercator projection must be used to view the map.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MercatorProjection { get; set; }
Visual Basic (Declaration)
Public Property MercatorProjection As Boolean
Visual C++
public:
property bool MercatorProjection {
    bool get ();
    void set (bool value);
}

See Also

MapObject Class
FastReport.Map Namespace


MinZoom Property

[image]

FastReport.Net Class Reference
MapObject..::.MinZoom Property
MapObject Class See Also Send Feedback
Gets or sets minimum zoom value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MinZoom { get; set; }
Visual Basic (Declaration)
Public Property MinZoom As Single
Visual C++
public:
property float MinZoom {
    float get ();
    void set (float value);
}

See Also

MapObject Class
FastReport.Map Namespace


OffsetX Property

[image]

FastReport.Net Class Reference
MapObject..::.OffsetX Property
MapObject Class See Also Send Feedback
Gets or sets the X offset of the map.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float OffsetX { get; set; }
Visual Basic (Declaration)
Public Property OffsetX As Single
Visual C++
public:
property float OffsetX {
    float get ();
    void set (float value);
}

See Also

MapObject Class
FastReport.Map Namespace


OffsetY Property

[image]

FastReport.Net Class Reference
MapObject..::.OffsetY Property
MapObject Class See Also Send Feedback
Gets or sets the Y offset of the map.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float OffsetY { get; set; }
Visual Basic (Declaration)
Public Property OffsetY As Single
Visual C++
public:
property float OffsetY {
    float get ();
    void set (float value);
}

See Also

MapObject Class
FastReport.Map Namespace


Padding Property

[image]

FastReport.Net Class Reference
MapObject..::.Padding Property
MapObject Class See Also Send Feedback
Gets or sets padding within the map.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

MapObject Class
FastReport.Map Namespace


Style Property

[image]

FastReport.Net Class Reference
MapObject..::.Style Property
MapObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

MapObject Class
FastReport.Map Namespace


Zoom Property

[image]

FastReport.Net Class Reference
MapObject..::.Zoom Property
MapObject Class See Also Send Feedback
Gets or sets the map zoom.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Single
Visual C++
public:
property float Zoom {
    float get ();
    void set (float value);
}

See Also

MapObject Class
FastReport.Map Namespace


MapObject Events

[image] [image]

FastReport.Net Class Reference
MapObject Events
MapObject Class See Also Send Feedback

The MapObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

MapObject Class
FastReport.Map Namespace


MapPalette Enumeration

[image]

FastReport.Net Class Reference
MapPalette Enumeration
See Also Send Feedback
Defines the palette used to display map shapes.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum MapPalette
Visual Basic (Declaration)
Public Enumeration MapPalette
Visual C++
public enum class MapPalette

Members

Member name | Description
None | No palette used.
Light | Light palette.
Pastel | Pastel palette.
Grayscale | Grayscale palette.
Earth | Earth tones palette.
Sea | Sea green palette.
BrightPastel | Bright pastel palette.

See Also

FastReport.Map Namespace


PointD Structure

[image]

FastReport.Net Class Reference
PointD Structure
Members See Also Send Feedback
Represents a pair of double coordinates that defines a constituent point.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public struct PointD
Visual Basic (Declaration)
Public Structure PointD
Visual C++
public value class PointD

See Also

PointD Members
FastReport.Map Namespace


PointD Members

[image] [image]

FastReport.Net Class Reference
PointD Members
PointD Structure Constructors Methods Properties See Also Send Feedback

The PointD type exposes the following members.

Constructors

Name | Description
PointD | Creates a new instance of the PointD class with specified coordinates.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
X | Gets or sets the X-coordinate of a point.
Y | Gets or sets the Y-coordinate of a point.

See Also

PointD Structure
FastReport.Map Namespace


PointD Constructor

[image]

FastReport.Net Class Reference
PointD Constructor
PointD Structure See Also Send Feedback
Creates a new instance of the PointD class with specified coordinates.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PointD(
    double x,
    double y
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
PointD(
    double x,
    double y
)

Parameters

x
Type: System..::.Double
X coordinate.
y
Type: System..::.Double
Y coordinate.

See Also

PointD Structure
FastReport.Map Namespace


PointD Methods

[image] [image]

FastReport.Net Class Reference
PointD Methods
PointD Structure See Also Send Feedback

The PointD type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

PointD Structure
FastReport.Map Namespace


PointD Properties

[image] [image]

FastReport.Net Class Reference
PointD Properties
PointD Structure See Also Send Feedback

The PointD type exposes the following members.

Properties

Name | Description
X | Gets or sets the X-coordinate of a point.
Y | Gets or sets the Y-coordinate of a point.

See Also

PointD Structure
FastReport.Map Namespace


X Property

[image]

FastReport.Net Class Reference
PointD..::.X Property
PointD Structure See Also Send Feedback
Gets or sets the X-coordinate of a point.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

PointD Structure
FastReport.Map Namespace


Y Property

[image]

FastReport.Net Class Reference
PointD..::.Y Property
PointD Structure See Also Send Feedback
Gets or sets the Y-coordinate of a point.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

PointD Structure
FastReport.Map Namespace


ScaleBase Class

[image]

FastReport.Net Class Reference
ScaleBase Class
Members See Also Send Feedback
The base class for scale-type controls such as DistanceScale and ColorScale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ScaleBase
Visual Basic (Declaration)
Public Class ScaleBase
Visual C++
public ref class ScaleBase

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ScaleBase
FastReport.Map..::.ColorScale
FastReport.Map..::.DistanceScale

See Also

ScaleBase Members
FastReport.Map Namespace


ScaleBase Members

[image] [image]

FastReport.Net Class Reference
ScaleBase Members
ScaleBase Class Constructors Methods Properties See Also Send Feedback

The ScaleBase type exposes the following members.

Constructors

Name | Description
ScaleBase | Initializes a new instance of the ScaleBase class.

Methods

Name | Description
Assign | Copies the contents of another ScaleBase.
CalcSize | Gets the size of the scale, in pixels.
Draw | Draws the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Border | Gets or sets the border.
BorderColor | Gets or sets the border color.
Dock | Gets or sets the location of the scale.
Fill | Gets or sets the fill.
Font | Gets or sets the font.
TextColor | Gets or sets the text color.
TitleColor | Gets or sets the title text color.
TitleFont | Gets or sets the title font.
TitleText | Gets or sets the title text.
Visible | Gets or sets the visibility of a scale.

See Also

ScaleBase Class
FastReport.Map Namespace


ScaleBase Constructor

[image]

FastReport.Net Class Reference
ScaleBase Constructor
ScaleBase Class See Also Send Feedback
Initializes a new instance of the ScaleBase class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ScaleBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScaleBase()

See Also

ScaleBase Class
FastReport.Map Namespace


ScaleBase Methods

[image] [image]

FastReport.Net Class Reference
ScaleBase Methods
ScaleBase Class See Also Send Feedback

The ScaleBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another ScaleBase.
CalcSize | Gets the size of the scale, in pixels.
Draw | Draws the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleBase Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ScaleBase..::.Assign Method
ScaleBase Class See Also Send Feedback
Copies the contents of another ScaleBase.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Assign(
    ScaleBase src
)
Visual Basic (Declaration)
Public Overridable Sub Assign ( _
    src As ScaleBase _
)
Visual C++
public:
virtual void Assign(
    ScaleBase^ src
)

Parameters

src
Type: FastReport.Map..::.ScaleBase
The ScaleBase instance to copy the contents from.

See Also

ScaleBase Class
FastReport.Map Namespace


CalcSize Method

[image]

FastReport.Net Class Reference
ScaleBase..::.CalcSize Method
ScaleBase Class See Also Send Feedback
Gets the size of the scale, in pixels.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual SizeF CalcSize()
Visual Basic (Declaration)
Public Overridable Function CalcSize As SizeF
Visual C++
public:
virtual SizeF CalcSize()

Return Value

The SizeF structure containing the size of the object.

See Also

ScaleBase Class
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
ScaleBase..::.Draw Method
ScaleBase Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Draw(
    FRPaintEventArgs e,
    MapObject parent
)
Visual Basic (Declaration)
Public Overridable Sub Draw ( _
    e As FRPaintEventArgs, _
    parent As MapObject _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e,
    MapObject^ parent
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw parameters.
parent
Type: FastReport.Map..::.MapObject
Parent map object.

See Also

ScaleBase Class
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ScaleBase..::.Serialize Method
ScaleBase Class See Also Send Feedback
Serializes the scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Serialize(
    FRWriter writer,
    string prefix,
    ScaleBase diff
)
Visual Basic (Declaration)
Public Overridable Sub Serialize ( _
    writer As FRWriter, _
    prefix As String, _
    diff As ScaleBase _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer,
    String^ prefix,
    ScaleBase^ diff
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.
prefix
Type: System..::.String
Scale property name.
diff
Type: FastReport.Map..::.ScaleBase
Another ScaleBase to compare with.

Remarks

This method is for internal use only.

See Also

ScaleBase Class
FastReport.Map Namespace


ScaleBase Properties

[image] [image]

FastReport.Net Class Reference
ScaleBase Properties
ScaleBase Class See Also Send Feedback

The ScaleBase type exposes the following members.

Properties

Name | Description
Border | Gets or sets the border.
BorderColor | Gets or sets the border color.
Dock | Gets or sets the location of the scale.
Fill | Gets or sets the fill.
Font | Gets or sets the font.
TextColor | Gets or sets the text color.
TitleColor | Gets or sets the title text color.
TitleFont | Gets or sets the title font.
TitleText | Gets or sets the title text.
Visible | Gets or sets the visibility of a scale.

See Also

ScaleBase Class
FastReport.Map Namespace


Border Property

[image]

FastReport.Net Class Reference
ScaleBase..::.Border Property
ScaleBase Class See Also Send Feedback
Gets or sets the border.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


BorderColor Property

[image]

FastReport.Net Class Reference
ScaleBase..::.BorderColor Property
ScaleBase Class See Also Send Feedback
Gets or sets the border color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic (Declaration)
Public Property BorderColor As Color
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


Dock Property

[image]

FastReport.Net Class Reference
ScaleBase..::.Dock Property
ScaleBase Class See Also Send Feedback
Gets or sets the location of the scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ScaleDock Dock { get; set; }
Visual Basic (Declaration)
Public Property Dock As ScaleDock
Visual C++
public:
property ScaleDock Dock {
    ScaleDock get ();
    void set (ScaleDock value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


Fill Property

[image]

FastReport.Net Class Reference
ScaleBase..::.Fill Property
ScaleBase Class See Also Send Feedback
Gets or sets the fill.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As FillBase
Visual C++
public:
property FillBase^ Fill {
    FillBase^ get ();
    void set (FillBase^ value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


Font Property

[image]

FastReport.Net Class Reference
ScaleBase..::.Font Property
ScaleBase Class See Also Send Feedback
Gets or sets the font.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


TextColor Property

[image]

FastReport.Net Class Reference
ScaleBase..::.TextColor Property
ScaleBase Class See Also Send Feedback
Gets or sets the text color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


TitleColor Property

[image]

FastReport.Net Class Reference
ScaleBase..::.TitleColor Property
ScaleBase Class See Also Send Feedback
Gets or sets the title text color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color TitleColor { get; set; }
Visual Basic (Declaration)
Public Property TitleColor As Color
Visual C++
public:
property Color TitleColor {
    Color get ();
    void set (Color value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


TitleFont Property

[image]

FastReport.Net Class Reference
ScaleBase..::.TitleFont Property
ScaleBase Class See Also Send Feedback
Gets or sets the title font.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font TitleFont { get; set; }
Visual Basic (Declaration)
Public Property TitleFont As Font
Visual C++
public:
property Font^ TitleFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


TitleText Property

[image]

FastReport.Net Class Reference
ScaleBase..::.TitleText Property
ScaleBase Class See Also Send Feedback
Gets or sets the title text.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string TitleText { get; set; }
Visual Basic (Declaration)
Public Property TitleText As String
Visual C++
public:
property String^ TitleText {
    String^ get ();
    void set (String^ value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


Visible Property

[image]

FastReport.Net Class Reference
ScaleBase..::.Visible Property
ScaleBase Class See Also Send Feedback
Gets or sets the visibility of a scale.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ScaleBase Class
FastReport.Map Namespace


ScaleDock Enumeration

[image]

FastReport.Net Class Reference
ScaleDock Enumeration
See Also Send Feedback
Specifies the position of a scale control inside the map.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ScaleDock
Visual Basic (Declaration)
Public Enumeration ScaleDock
Visual C++
public enum class ScaleDock

Members

Member name | Description
TopLeft | The scale is displayed at top left corner.
TopCenter | The scale is displayed at top center side.
TopRight | The scale is displayed at top right corner.
MiddleLeft | The scale is displayed at middle left side.
MiddleRight | The scale is displayed at middle right side.
BottomLeft | The scale is displayed at bottom left corner.
BottomCenter | The scale is displayed at bottom center side.
BottomRight | The scale is displayed at bottom right corner.

See Also

FastReport.Map Namespace


ShapeBase Class

[image]

FastReport.Net Class Reference
ShapeBase Class
Members See Also Send Feedback
The base class for shape objects such as ShapePoint, ShapePolyLine and ShapePolygon.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapeBase : Base, ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class ShapeBase _
    Inherits Base _
    Implements ICustomTypeDescriptor
Visual C++
public ref class ShapeBase : public Base,
    ICustomTypeDescriptor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Map..::.ShapeBase
FastReport.Map..::.ShapePoint
FastReport.Map..::.ShapePolygon

See Also

ShapeBase Members
FastReport.Map Namespace


ShapeBase Members

[image] [image]

FastReport.Net Class Reference
ShapeBase Members
ShapeBase Class Constructors Methods Properties Events See Also Send Feedback

The ShapeBase type exposes the following members.

Constructors

Name | Description
ShapeBase | Initializes a new instance of the ShapeBase class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape.
DrawLabel | Draws the label.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component.
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor.
InitializeComponent | Initializes a component before running a report.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component.
SaveState | Saves the state of this component.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset.
CenterOffsetY | Gets or sets the center point Y offset.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object.
Map | Gets a reference to the parent Map object.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeOffsetX | Gets or sets the shape X offset.
ShapeOffsetY | Gets or sets the shape Y offset.
ShapeScale | Gets or sets the scale factor for this shape.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape.
UseCustomStyle | Gets or sets a value indicating that custom shape style is used.
Value | Gets or sets the value.
Visible | Gets or sets the shape visibility.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeBase Constructor

[image]

FastReport.Net Class Reference
ShapeBase Constructor
ShapeBase Class See Also Send Feedback
Initializes a new instance of the ShapeBase class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeBase()

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeBase Methods

[image] [image]

FastReport.Net Class Reference
ShapeBase Methods
ShapeBase Class See Also Send Feedback

The ShapeBase type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape.
DrawLabel | Draws the label.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report.
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component.
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor.
InitializeComponent | Initializes a component before running a report.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component.
SaveState | Saves the state of this component.
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ShapeBase Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ShapeBase..::.Assign Method
ShapeBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ShapeBase Class
FastReport.Map Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
ShapeBase..::.Dispose Method
ShapeBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ShapeBase Class
ShapeBase Members
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
ShapeBase..::.Draw Method
ShapeBase Class See Also Send Feedback
Draws the shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapeBase Class
FastReport.Map Namespace


DrawLabel Method

[image]

FastReport.Net Class Reference
ShapeBase..::.DrawLabel Method
ShapeBase Class See Also Send Feedback
Draws the label.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void DrawLabel(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub DrawLabel ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawLabel(
    FRPaintEventArgs^ e
)

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapeBase Class
FastReport.Map Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
ShapeBase..::.FinalizeComponent Method
ShapeBase Class See Also Send Feedback
Finalizes a component before running a report.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void FinalizeComponent()
Visual Basic (Declaration)
Public Overridable Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent()

See Also

ShapeBase Class
FastReport.Map Namespace


GetAttributes Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetAttributes Method
ShapeBase Class See Also Send Feedback
Returns a collection of custom attributes for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AttributeCollection GetAttributes()
Visual Basic (Declaration)
Public Function GetAttributes As AttributeCollection
Visual C++
public:
virtual AttributeCollection^ GetAttributes() sealed

Return Value

An AttributeCollection containing the attributes for this object.

Implements

ICustomTypeDescriptor..::.GetAttributes()()()

See Also

ShapeBase Class
FastReport.Map Namespace


GetClassName Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetClassName Method
ShapeBase Class See Also Send Feedback
Returns the class name of this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetClassName()
Visual Basic (Declaration)
Public Function GetClassName As String
Visual C++
public:
virtual String^ GetClassName() sealed

Return Value

The class name of the object, or null if the class does not have a name.

Implements

ICustomTypeDescriptor..::.GetClassName()()()

See Also

ShapeBase Class
FastReport.Map Namespace


GetComponentName Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetComponentName Method
ShapeBase Class See Also Send Feedback
Returns the name of this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetComponentName()
Visual Basic (Declaration)
Public Function GetComponentName As String
Visual C++
public:
virtual String^ GetComponentName() sealed

Return Value

The name of the object, or null if the object does not have a name.

Implements

ICustomTypeDescriptor..::.GetComponentName()()()

See Also

ShapeBase Class
FastReport.Map Namespace


GetConverter Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetConverter Method
ShapeBase Class See Also Send Feedback
Returns a type converter for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TypeConverter GetConverter()
Visual Basic (Declaration)
Public Function GetConverter As TypeConverter
Visual C++
public:
virtual TypeConverter^ GetConverter() sealed

Return Value

A TypeConverter that is the converter for this object, or null if there is no TypeConverter for this object.

Implements

ICustomTypeDescriptor..::.GetConverter()()()

See Also

ShapeBase Class
FastReport.Map Namespace


GetDefaultEvent Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetDefaultEvent Method
ShapeBase Class See Also Send Feedback
Returns the default event for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EventDescriptor GetDefaultEvent()
Visual Basic (Declaration)
Public Function GetDefaultEvent As EventDescriptor
Visual C++
public:
virtual EventDescriptor^ GetDefaultEvent() sealed

Return Value

An EventDescriptor that represents the default event for this object, or null if this object does not have events.

Implements

ICustomTypeDescriptor..::.GetDefaultEvent()()()

See Also

ShapeBase Class
FastReport.Map Namespace


GetDefaultProperty Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetDefaultProperty Method
ShapeBase Class See Also Send Feedback
Returns the default property for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptor GetDefaultProperty()
Visual Basic (Declaration)
Public Function GetDefaultProperty As PropertyDescriptor
Visual C++
public:
virtual PropertyDescriptor^ GetDefaultProperty() sealed

Return Value

A PropertyDescriptor that represents the default property for this object, or null if this object does not have properties.

Implements

ICustomTypeDescriptor..::.GetDefaultProperty()()()

See Also

ShapeBase Class
FastReport.Map Namespace


GetEditor Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetEditor Method
ShapeBase Class See Also Send Feedback
Returns an editor of the specified type for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetEditor(
    Type editorBaseType
)
Visual Basic (Declaration)
Public Function GetEditor ( _
    editorBaseType As Type _
) As Object
Visual C++
public:
virtual Object^ GetEditor(
    Type^ editorBaseType
) sealed

Parameters

editorBaseType
Type: System..::.Type
A Type that represents the editor for this object.

Return Value

An Object of the specified type that is the editor for this object, or null if the editor cannot be found.

Implements

ICustomTypeDescriptor..::.GetEditor(Type)

See Also

ShapeBase Class
FastReport.Map Namespace


GetEvents Method

[image] [image]

FastReport.Net Class Reference
ShapeBase..::.GetEvents Method
ShapeBase Class See Also Send Feedback

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component.
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter.

See Also

ShapeBase Class
ShapeBase Members
FastReport.Map Namespace


GetEvents Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetEvents Method
ShapeBase Class See Also Send Feedback
Returns the events for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EventDescriptorCollection GetEvents()
Visual Basic (Declaration)
Public Function GetEvents As EventDescriptorCollection
Visual C++
public:
virtual EventDescriptorCollection^ GetEvents() sealed

Return Value

An EventDescriptorCollection that represents the events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents()()()

See Also

ShapeBase Class
GetEvents Overload
FastReport.Map Namespace


GetEvents Method (Attribute[])

[image]

FastReport.Net Class Reference
ShapeBase..::.GetEvents Method (array<Attribute>[]()[])
ShapeBase Class See Also Send Feedback
Returns the events for this instance of a component using the specified attribute array as a filter.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public EventDescriptorCollection GetEvents(
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Function GetEvents ( _
    attributes As Attribute() _
) As EventDescriptorCollection
Visual C++
public:
virtual EventDescriptorCollection^ GetEvents(
    array<Attribute^>^ attributes
) sealed

Parameters

attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

An EventDescriptorCollection that represents the filtered events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents(array<Attribute>[]()[])

See Also

ShapeBase Class
GetEvents Overload
FastReport.Map Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
ShapeBase..::.GetProperties Method
ShapeBase Class See Also Send Feedback

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component.
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter.

See Also

ShapeBase Class
ShapeBase Members
FastReport.Map Namespace


GetProperties Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetProperties Method
ShapeBase Class See Also Send Feedback
Returns the properties for this instance of a component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptorCollection GetProperties()
Visual Basic (Declaration)
Public Function GetProperties As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties() sealed

Return Value

A PropertyDescriptorCollection that represents the properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties()()()

See Also

ShapeBase Class
GetProperties Overload
FastReport.Map Namespace


GetProperties Method (Attribute[])

[image]

FastReport.Net Class Reference
ShapeBase..::.GetProperties Method (array<Attribute>[]()[])
ShapeBase Class See Also Send Feedback
Returns the properties for this instance of a component using the attribute array as a filter.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PropertyDescriptorCollection GetProperties(
    Attribute[] attr
)
Visual Basic (Declaration)
Public Function GetProperties ( _
    attr As Attribute() _
) As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties(
    array<Attribute^>^ attr
) sealed

Parameters

attr
Type: array< System..::.Attribute >[]()[]

Return Value

A PropertyDescriptorCollection that represents the filtered properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties(array<Attribute>[]()[])

See Also

ShapeBase Class
GetProperties Overload
FastReport.Map Namespace


GetPropertyOwner Method

[image]

FastReport.Net Class Reference
ShapeBase..::.GetPropertyOwner Method
ShapeBase Class See Also Send Feedback
Returns an object that contains the property described by the specified property descriptor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object GetPropertyOwner(
    PropertyDescriptor pd
)
Visual Basic (Declaration)
Public Function GetPropertyOwner ( _
    pd As PropertyDescriptor _
) As Object
Visual C++
public:
virtual Object^ GetPropertyOwner(
    PropertyDescriptor^ pd
) sealed

Parameters

pd
Type: System.ComponentModel..::.PropertyDescriptor
A PropertyDescriptor that represents the property whose owner is to be found.

Return Value

An Object that represents the owner of the specified property.

Implements

ICustomTypeDescriptor..::.GetPropertyOwner(PropertyDescriptor)

See Also

ShapeBase Class
FastReport.Map Namespace


HitTest Method

[image]

FastReport.Net Class Reference
ShapeBase..::.HitTest Method
ShapeBase Class See Also Send Feedback
Checks if the shape is under cursor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual bool HitTest(
    PointF point
)
Visual Basic (Declaration)
Public Overridable Function HitTest ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool HitTest(
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF
The cursor coordinates.

Return Value

true if the cursor is over the shape.

See Also

ShapeBase Class
FastReport.Map Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
ShapeBase..::.InitializeComponent Method
ShapeBase Class See Also Send Feedback
Initializes a component before running a report.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void InitializeComponent()
Visual Basic (Declaration)
Public Overridable Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent()

See Also

ShapeBase Class
FastReport.Map Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ShapeBase..::.MemberwiseClone Method
ShapeBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ShapeBase Class
ShapeBase Members
FastReport.Map Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
ShapeBase..::.RestoreState Method
ShapeBase Class See Also Send Feedback
Restores the state of this component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void RestoreState()
Visual Basic (Declaration)
Public Overridable Sub RestoreState
Visual C++
public:
virtual void RestoreState()

See Also

ShapeBase Class
FastReport.Map Namespace


SaveState Method

[image]

FastReport.Net Class Reference
ShapeBase..::.SaveState Method
ShapeBase Class See Also Send Feedback
Saves the state of this component.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void SaveState()
Visual Basic (Declaration)
Public Overridable Sub SaveState
Visual C++
public:
virtual void SaveState()

See Also

ShapeBase Class
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ShapeBase..::.Serialize Method
ShapeBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ShapeBase Class
FastReport.Map Namespace


Simplify Method

[image]

FastReport.Net Class Reference
ShapeBase..::.Simplify Method
ShapeBase Class See Also Send Feedback
Reduces the number of points in the shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Simplify(
    double accuracy
)
Visual Basic (Declaration)
Public Overridable Sub Simplify ( _
    accuracy As Double _
)
Visual C++
public:
virtual void Simplify(
    double accuracy
)

Parameters

accuracy
Type: System..::.Double
The accuracy value.

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeBase Properties

[image] [image]

FastReport.Net Class Reference
ShapeBase Properties
ShapeBase Class See Also Send Feedback

The ShapeBase type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset.
CenterOffsetY | Gets or sets the center point Y offset.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object.
Map | Gets a reference to the parent Map object.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeOffsetX | Gets or sets the shape X offset.
ShapeOffsetY | Gets or sets the shape Y offset.
ShapeScale | Gets or sets the scale factor for this shape.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape.
UseCustomStyle | Gets or sets a value indicating that custom shape style is used.
Value | Gets or sets the value.
Visible | Gets or sets the shape visibility.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ShapeBase Class
FastReport.Map Namespace


CenterOffsetX Property

[image]

FastReport.Net Class Reference
ShapeBase..::.CenterOffsetX Property
ShapeBase Class See Also Send Feedback
Gets or sets the center point X offset.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CenterOffsetX { get; set; }
Visual Basic (Declaration)
Public Property CenterOffsetX As Single
Visual C++
public:
property float CenterOffsetX {
    float get ();
    void set (float value);
}

Remarks

Use this property to adjust the label's position.

See Also

ShapeBase Class
FastReport.Map Namespace


CenterOffsetY Property

[image]

FastReport.Net Class Reference
ShapeBase..::.CenterOffsetY Property
ShapeBase Class See Also Send Feedback
Gets or sets the center point Y offset.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CenterOffsetY { get; set; }
Visual Basic (Declaration)
Public Property CenterOffsetY As Single
Visual C++
public:
property float CenterOffsetY {
    float get ();
    void set (float value);
}

Remarks

Use this property to adjust the label's position.

See Also

ShapeBase Class
FastReport.Map Namespace


CustomStyle Property

[image]

FastReport.Net Class Reference
ShapeBase..::.CustomStyle Property
ShapeBase Class See Also Send Feedback
Gets a custom shape style.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeStyle CustomStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property CustomStyle As ShapeStyle
Visual C++
public:
property ShapeStyle^ CustomStyle {
    ShapeStyle^ get ();
}

Remarks

To use this property, first set the UseCustomStyle property to true.

See Also

ShapeBase Class
FastReport.Map Namespace


Layer Property

[image]

FastReport.Net Class Reference
ShapeBase..::.Layer Property
ShapeBase Class See Also Send Feedback
Gets a reference to the parent Layer object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapLayer Layer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layer As MapLayer
Visual C++
public:
property MapLayer^ Layer {
    MapLayer^ get ();
}

See Also

ShapeBase Class
FastReport.Map Namespace


Map Property

[image]

FastReport.Net Class Reference
ShapeBase..::.Map Property
ShapeBase Class See Also Send Feedback
Gets a reference to the parent Map object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MapObject Map { get; }
Visual Basic (Declaration)
Public ReadOnly Property Map As MapObject
Visual C++
public:
property MapObject^ Map {
    MapObject^ get ();
}

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeOffsetX Property

[image]

FastReport.Net Class Reference
ShapeBase..::.ShapeOffsetX Property
ShapeBase Class See Also Send Feedback
Gets or sets the shape X offset.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ShapeOffsetX { get; set; }
Visual Basic (Declaration)
Public Property ShapeOffsetX As Single
Visual C++
public:
property float ShapeOffsetX {
    float get ();
    void set (float value);
}

Remarks

Use this property to adjust the shape position.

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeOffsetY Property

[image]

FastReport.Net Class Reference
ShapeBase..::.ShapeOffsetY Property
ShapeBase Class See Also Send Feedback
Gets or sets the shape Y offset.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ShapeOffsetY { get; set; }
Visual Basic (Declaration)
Public Property ShapeOffsetY As Single
Visual C++
public:
property float ShapeOffsetY {
    float get ();
    void set (float value);
}

Remarks

Use this property to adjust the shape position.

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeScale Property

[image]

FastReport.Net Class Reference
ShapeBase..::.ShapeScale Property
ShapeBase Class See Also Send Feedback
Gets or sets the scale factor for this shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ShapeScale { get; set; }
Visual Basic (Declaration)
Public Property ShapeScale As Single
Visual C++
public:
property float ShapeScale {
    float get ();
    void set (float value);
}

Remarks

Use this property to adjust the shape size.

See Also

ShapeBase Class
FastReport.Map Namespace


SpatialData Property

[image]

FastReport.Net Class Reference
ShapeBase..::.SpatialData Property
ShapeBase Class See Also Send Feedback
Gets or sets the spatial data associated with this shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeSpatialData SpatialData { get; set; }
Visual Basic (Declaration)
Public Property SpatialData As ShapeSpatialData
Visual C++
public:
property ShapeSpatialData^ SpatialData {
    ShapeSpatialData^ get ();
    void set (ShapeSpatialData^ value);
}

See Also

ShapeBase Class
FastReport.Map Namespace


UseCustomStyle Property

[image]

FastReport.Net Class Reference
ShapeBase..::.UseCustomStyle Property
ShapeBase Class See Also Send Feedback
Gets or sets a value indicating that custom shape style is used.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseCustomStyle { get; set; }
Visual Basic (Declaration)
Public Property UseCustomStyle As Boolean
Visual C++
public:
property bool UseCustomStyle {
    bool get ();
    void set (bool value);
}

Remarks

If this property is false, the layer's DefaultShapeStyle is used.

See Also

ShapeBase Class
FastReport.Map Namespace


Value Property

[image]

FastReport.Net Class Reference
ShapeBase..::.Value Property
ShapeBase Class See Also Send Feedback
Gets or sets the value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

ShapeBase Class
FastReport.Map Namespace


Visible Property

[image]

FastReport.Net Class Reference
ShapeBase..::.Visible Property
ShapeBase Class See Also Send Feedback
Gets or sets the shape visibility.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeBase Events

[image] [image]

FastReport.Net Class Reference
ShapeBase Events
ShapeBase Class See Also Send Feedback

The ShapeBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapeBase Class
FastReport.Map Namespace


ShapeCollection Class

[image]

FastReport.Net Class Reference
ShapeCollection Class
Members See Also Send Feedback
Holds the list of objects of ShapeBase type.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapeCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class ShapeCollection _
    Inherits FRCollectionBase
Visual C++
public ref class ShapeCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Map..::.ShapeCollection

See Also

ShapeCollection Members
FastReport.Map Namespace


ShapeCollection Members

[image] [image]

FastReport.Net Class Reference
ShapeCollection Members
ShapeCollection Class Constructors Methods Properties See Also Send Feedback

The ShapeCollection type exposes the following members.

Constructors

Name | Description
ShapeCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ShapeCollection Class
FastReport.Map Namespace


ShapeCollection Constructor

[image] [image]

FastReport.Net Class Reference
ShapeCollection Constructor
ShapeCollection Class See Also Send Feedback

Overload List

Name | Description
ShapeCollection()()() | Initializes a new instance of the ShapeCollection class with default settings.
ShapeCollection(Base) | Initializes a new instance of the ShapeCollection class with specified owner.

See Also

ShapeCollection Class
ShapeCollection Members
FastReport.Map Namespace


ShapeCollection Constructor

[image]

FastReport.Net Class Reference
ShapeCollection Constructor
ShapeCollection Class See Also Send Feedback
Initializes a new instance of the ShapeCollection class with default settings.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeCollection()

See Also

ShapeCollection Class
ShapeCollection Overload
FastReport.Map Namespace


ShapeCollection Constructor (Base)

[image]

FastReport.Net Class Reference
ShapeCollection Constructor (Base)
ShapeCollection Class See Also Send Feedback
Initializes a new instance of the ShapeCollection class with specified owner.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeCollection(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
ShapeCollection(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base

See Also

ShapeCollection Class
ShapeCollection Overload
FastReport.Map Namespace


ShapeCollection Methods

[image] [image]

FastReport.Net Class Reference
ShapeCollection Methods
ShapeCollection Class See Also Send Feedback

The ShapeCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeCollection Class
FastReport.Map Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
ShapeCollection..::.AddRange Method
ShapeCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

ShapeCollection Class
ShapeCollection Members
FastReport.Map Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
ShapeCollection..::.Equals Method
ShapeCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

ShapeCollection Class
ShapeCollection Members
FastReport.Map Namespace


ShapeCollection Properties

[image] [image]

FastReport.Net Class Reference
ShapeCollection Properties
ShapeCollection Class See Also Send Feedback

The ShapeCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

ShapeCollection Class
FastReport.Map Namespace


Item Property

[image]

FastReport.Net Class Reference
ShapeCollection..::.Item Property
ShapeCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeBase this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ShapeBase
Visual C++
public:
property ShapeBase^ default[int index] {
    ShapeBase^ get (int index);
    void set (int index, ShapeBase^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

ShapeCollection Class
FastReport.Map Namespace


ShapePoint Class

[image]

FastReport.Net Class Reference
ShapePoint Class
Members See Also Send Feedback
Represents a map point.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapePoint : ShapeBase
Visual Basic (Declaration)
Public Class ShapePoint _
    Inherits ShapeBase
Visual C++
public ref class ShapePoint : public ShapeBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Map..::.ShapeBase
FastReport.Map..::.ShapePoint

See Also

ShapePoint Members
FastReport.Map Namespace


ShapePoint Members

[image] [image]

FastReport.Net Class Reference
ShapePoint Members
ShapePoint Class Constructors Methods Properties Events See Also Send Feedback

The ShapePoint type exposes the following members.

Constructors

Name | Description
ShapePoint | Initializes a new instance of the ShapePoint class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ShapeBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape. (Overrides ShapeBase..::.Draw(FRPaintEventArgs).)
DrawLabel | Draws the label. (Overrides ShapeBase..::.DrawLabel(FRPaintEventArgs).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report. (Inherited from ShapeBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ShapeBase.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ShapeBase.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ShapeBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ShapeBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ShapeBase.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ShapeBase.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ShapeBase.)
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ShapeBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor. (Overrides ShapeBase..::.HitTest(PointF).)
InitializeComponent | Initializes a component before running a report. (Inherited from ShapeBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component. (Inherited from ShapeBase.)
SaveState | Saves the state of this component. (Inherited from ShapeBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ShapeBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape. (Inherited from ShapeBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset. (Inherited from ShapeBase.)
CenterOffsetY | Gets or sets the center point Y offset. (Inherited from ShapeBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style. (Inherited from ShapeBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object. (Inherited from ShapeBase.)
Map | Gets a reference to the parent Map object. (Inherited from ShapeBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeOffsetX | Gets or sets the shape X offset. (Inherited from ShapeBase.)
ShapeOffsetY | Gets or sets the shape Y offset. (Inherited from ShapeBase.)
ShapeScale | Gets or sets the scale factor for this shape. (Inherited from ShapeBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape. (Inherited from ShapeBase.)
UseCustomStyle | Gets or sets a value indicating that custom shape style is used. (Inherited from ShapeBase.)
Value | Gets or sets the value. (Inherited from ShapeBase.)
Visible | Gets or sets the shape visibility. (Inherited from ShapeBase.)
X | Gets or sets the X-coordinate of the point.
Y | Gets or sets the Y-coordinate of the point.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapePoint Class
FastReport.Map Namespace


ShapePoint Constructor

[image]

FastReport.Net Class Reference
ShapePoint Constructor
ShapePoint Class See Also Send Feedback
Initializes a new instance of the ShapePoint class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapePoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapePoint()

See Also

ShapePoint Class
FastReport.Map Namespace


ShapePoint Methods

[image] [image]

FastReport.Net Class Reference
ShapePoint Methods
ShapePoint Class See Also Send Feedback

The ShapePoint type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ShapeBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape. (Overrides ShapeBase..::.Draw(FRPaintEventArgs).)
DrawLabel | Draws the label. (Overrides ShapeBase..::.DrawLabel(FRPaintEventArgs).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report. (Inherited from ShapeBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ShapeBase.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ShapeBase.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ShapeBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ShapeBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ShapeBase.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ShapeBase.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ShapeBase.)
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ShapeBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor. (Overrides ShapeBase..::.HitTest(PointF).)
InitializeComponent | Initializes a component before running a report. (Inherited from ShapeBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component. (Inherited from ShapeBase.)
SaveState | Saves the state of this component. (Inherited from ShapeBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ShapeBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape. (Inherited from ShapeBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ShapePoint Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ShapePoint..::.Assign Method
ShapePoint Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ShapePoint Class
FastReport.Map Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
ShapePoint..::.Dispose Method
ShapePoint Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ShapePoint Class
ShapePoint Members
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
ShapePoint..::.Draw Method
ShapePoint Class See Also Send Feedback
Draws the shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapePoint Class
FastReport.Map Namespace


DrawLabel Method

[image]

FastReport.Net Class Reference
ShapePoint..::.DrawLabel Method
ShapePoint Class See Also Send Feedback
Draws the label.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawLabel(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawLabel ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawLabel(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapePoint Class
FastReport.Map Namespace


GetEvents Method

[image] [image]

FastReport.Net Class Reference
ShapePoint..::.GetEvents Method
ShapePoint Class See Also Send Feedback

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component. (Inherited from ShapeBase.)
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter. (Inherited from ShapeBase.)

See Also

ShapePoint Class
ShapePoint Members
FastReport.Map Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
ShapePoint..::.GetProperties Method
ShapePoint Class See Also Send Feedback

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component. (Inherited from ShapeBase.)
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter. (Inherited from ShapeBase.)

See Also

ShapePoint Class
ShapePoint Members
FastReport.Map Namespace


HitTest Method

[image]

FastReport.Net Class Reference
ShapePoint..::.HitTest Method
ShapePoint Class See Also Send Feedback
Checks if the shape is under cursor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool HitTest(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function HitTest ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool HitTest(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF
The cursor coordinates.

Return Value

true if the cursor is over the shape.

See Also

ShapePoint Class
FastReport.Map Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ShapePoint..::.MemberwiseClone Method
ShapePoint Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ShapePoint Class
ShapePoint Members
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ShapePoint..::.Serialize Method
ShapePoint Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ShapePoint Class
FastReport.Map Namespace


ShapePoint Properties

[image] [image]

FastReport.Net Class Reference
ShapePoint Properties
ShapePoint Class See Also Send Feedback

The ShapePoint type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset. (Inherited from ShapeBase.)
CenterOffsetY | Gets or sets the center point Y offset. (Inherited from ShapeBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style. (Inherited from ShapeBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object. (Inherited from ShapeBase.)
Map | Gets a reference to the parent Map object. (Inherited from ShapeBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeOffsetX | Gets or sets the shape X offset. (Inherited from ShapeBase.)
ShapeOffsetY | Gets or sets the shape Y offset. (Inherited from ShapeBase.)
ShapeScale | Gets or sets the scale factor for this shape. (Inherited from ShapeBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape. (Inherited from ShapeBase.)
UseCustomStyle | Gets or sets a value indicating that custom shape style is used. (Inherited from ShapeBase.)
Value | Gets or sets the value. (Inherited from ShapeBase.)
Visible | Gets or sets the shape visibility. (Inherited from ShapeBase.)
X | Gets or sets the X-coordinate of the point.
Y | Gets or sets the Y-coordinate of the point.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ShapePoint Class
FastReport.Map Namespace


X Property

[image]

FastReport.Net Class Reference
ShapePoint..::.X Property
ShapePoint Class See Also Send Feedback
Gets or sets the X-coordinate of the point.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

ShapePoint Class
FastReport.Map Namespace


Y Property

[image]

FastReport.Net Class Reference
ShapePoint..::.Y Property
ShapePoint Class See Also Send Feedback
Gets or sets the Y-coordinate of the point.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

ShapePoint Class
FastReport.Map Namespace


ShapePoint Events

[image] [image]

FastReport.Net Class Reference
ShapePoint Events
ShapePoint Class See Also Send Feedback

The ShapePoint type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapePoint Class
FastReport.Map Namespace


ShapePolygon Class

[image]

FastReport.Net Class Reference
ShapePolygon Class
Members See Also Send Feedback
Represents a polygon shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapePolygon : ShapeBase
Visual Basic (Declaration)
Public Class ShapePolygon _
    Inherits ShapeBase
Visual C++
public ref class ShapePolygon : public ShapeBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Map..::.ShapeBase
FastReport.Map..::.ShapePolygon
FastReport.Map..::.ShapePolyLine

See Also

ShapePolygon Members
FastReport.Map Namespace


ShapePolygon Members

[image] [image]

FastReport.Net Class Reference
ShapePolygon Members
ShapePolygon Class Constructors Methods Fields Properties Events See Also Send Feedback

The ShapePolygon type exposes the following members.

Constructors

Name | Description
ShapePolygon | Initializes a new instance of the ShapePolygon class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ShapeBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape. (Overrides ShapeBase..::.Draw(FRPaintEventArgs).)
DrawLabel | Draws the label. (Overrides ShapeBase..::.DrawLabel(FRPaintEventArgs).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report. (Overrides ShapeBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ShapeBase.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ShapeBase.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ShapeBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ShapeBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ShapeBase.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ShapeBase.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ShapeBase.)
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ShapeBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor. (Overrides ShapeBase..::.HitTest(PointF).)
InitializeComponent | Initializes a component before running a report. (Overrides ShapeBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component. (Inherited from ShapeBase.)
SaveState | Saves the state of this component. (Inherited from ShapeBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ShapeBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape. (Overrides ShapeBase..::.Simplify(Double).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
largestBoundsRect | Holds the largest bounding rectangle of this shape.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
Box | Gets or sets a bounding box of this shape.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset. (Inherited from ShapeBase.)
CenterOffsetY | Gets or sets the center point Y offset. (Inherited from ShapeBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style. (Inherited from ShapeBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object. (Inherited from ShapeBase.)
Map | Gets a reference to the parent Map object. (Inherited from ShapeBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Parts | Gets or sets a list of polygons in this shape.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeData | Gets or sets the shape data in binary format.
ShapeOffsetX | Gets or sets the shape X offset. (Inherited from ShapeBase.)
ShapeOffsetY | Gets or sets the shape Y offset. (Inherited from ShapeBase.)
ShapeScale | Gets or sets the scale factor for this shape. (Inherited from ShapeBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape. (Inherited from ShapeBase.)
UseCustomStyle | Gets or sets a value indicating that custom shape style is used. (Inherited from ShapeBase.)
Value | Gets or sets the value. (Inherited from ShapeBase.)
Visible | Gets or sets the shape visibility. (Inherited from ShapeBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapePolygon Constructor

[image]

FastReport.Net Class Reference
ShapePolygon Constructor
ShapePolygon Class See Also Send Feedback
Initializes a new instance of the ShapePolygon class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapePolygon()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapePolygon()

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapePolygon Fields

[image] [image]

FastReport.Net Class Reference
ShapePolygon Fields
ShapePolygon Class See Also Send Feedback

The ShapePolygon type exposes the following members.

Fields

Name | Description
largestBoundsRect | Holds the largest bounding rectangle of this shape.

See Also

ShapePolygon Class
FastReport.Map Namespace


largestBoundsRect Field

[image]

FastReport.Net Class Reference
ShapePolygon..::.largestBoundsRect Field
ShapePolygon Class See Also Send Feedback
Holds the largest bounding rectangle of this shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected internal RectangleF largestBoundsRect
Visual Basic (Declaration)
Protected Friend largestBoundsRect As RectangleF
Visual C++
protected public:
RectangleF largestBoundsRect

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapePolygon Methods

[image] [image]

FastReport.Net Class Reference
ShapePolygon Methods
ShapePolygon Class See Also Send Feedback

The ShapePolygon type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ShapeBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape. (Overrides ShapeBase..::.Draw(FRPaintEventArgs).)
DrawLabel | Draws the label. (Overrides ShapeBase..::.DrawLabel(FRPaintEventArgs).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report. (Overrides ShapeBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ShapeBase.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ShapeBase.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ShapeBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ShapeBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ShapeBase.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ShapeBase.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ShapeBase.)
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ShapeBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor. (Overrides ShapeBase..::.HitTest(PointF).)
InitializeComponent | Initializes a component before running a report. (Overrides ShapeBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component. (Inherited from ShapeBase.)
SaveState | Saves the state of this component. (Inherited from ShapeBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ShapeBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape. (Overrides ShapeBase..::.Simplify(Double).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ShapePolygon Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.Assign Method
ShapePolygon Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

ShapePolygon Class
FastReport.Map Namespace
AssignAll Method


Deserialize Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.Deserialize Method
ShapePolygon Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

ShapePolygon Class
FastReport.Map Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ShapePolygon..::.Dispose Method
ShapePolygon Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ShapePolygon Class
ShapePolygon Members
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.Draw Method
ShapePolygon Class See Also Send Feedback
Draws the shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapePolygon Class
FastReport.Map Namespace


DrawLabel Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.DrawLabel Method
ShapePolygon Class See Also Send Feedback
Draws the label.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawLabel(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawLabel ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawLabel(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapePolygon Class
FastReport.Map Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.FinalizeComponent Method
ShapePolygon Class See Also Send Feedback
Finalizes a component before running a report.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FinalizeComponent()
Visual Basic (Declaration)
Public Overrides Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent() override

See Also

ShapePolygon Class
FastReport.Map Namespace


GetEvents Method

[image] [image]

FastReport.Net Class Reference
ShapePolygon..::.GetEvents Method
ShapePolygon Class See Also Send Feedback

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component. (Inherited from ShapeBase.)
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter. (Inherited from ShapeBase.)

See Also

ShapePolygon Class
ShapePolygon Members
FastReport.Map Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
ShapePolygon..::.GetProperties Method
ShapePolygon Class See Also Send Feedback

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component. (Inherited from ShapeBase.)
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter. (Inherited from ShapeBase.)

See Also

ShapePolygon Class
ShapePolygon Members
FastReport.Map Namespace


HitTest Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.HitTest Method
ShapePolygon Class See Also Send Feedback
Checks if the shape is under cursor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool HitTest(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function HitTest ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool HitTest(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF
The cursor coordinates.

Return Value

true if the cursor is over the shape.

See Also

ShapePolygon Class
FastReport.Map Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.InitializeComponent Method
ShapePolygon Class See Also Send Feedback
Initializes a component before running a report.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

See Also

ShapePolygon Class
FastReport.Map Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ShapePolygon..::.MemberwiseClone Method
ShapePolygon Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ShapePolygon Class
ShapePolygon Members
FastReport.Map Namespace


Serialize Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.Serialize Method
ShapePolygon Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

ShapePolygon Class
FastReport.Map Namespace


Simplify Method

[image]

FastReport.Net Class Reference
ShapePolygon..::.Simplify Method
ShapePolygon Class See Also Send Feedback
Reduces the number of points in the shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Simplify(
    double accuracy
)
Visual Basic (Declaration)
Public Overrides Sub Simplify ( _
    accuracy As Double _
)
Visual C++
public:
virtual void Simplify(
    double accuracy
) override

Parameters

accuracy
Type: System..::.Double
The accuracy value.

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapePolygon Properties

[image] [image]

FastReport.Net Class Reference
ShapePolygon Properties
ShapePolygon Class See Also Send Feedback

The ShapePolygon type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
Box | Gets or sets a bounding box of this shape.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset. (Inherited from ShapeBase.)
CenterOffsetY | Gets or sets the center point Y offset. (Inherited from ShapeBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style. (Inherited from ShapeBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object. (Inherited from ShapeBase.)
Map | Gets a reference to the parent Map object. (Inherited from ShapeBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Parts | Gets or sets a list of polygons in this shape.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeData | Gets or sets the shape data in binary format.
ShapeOffsetX | Gets or sets the shape X offset. (Inherited from ShapeBase.)
ShapeOffsetY | Gets or sets the shape Y offset. (Inherited from ShapeBase.)
ShapeScale | Gets or sets the scale factor for this shape. (Inherited from ShapeBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape. (Inherited from ShapeBase.)
UseCustomStyle | Gets or sets a value indicating that custom shape style is used. (Inherited from ShapeBase.)
Value | Gets or sets the value. (Inherited from ShapeBase.)
Visible | Gets or sets the shape visibility. (Inherited from ShapeBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ShapePolygon Class
FastReport.Map Namespace


Box Property

[image]

FastReport.Net Class Reference
ShapePolygon..::.Box Property
ShapePolygon Class See Also Send Feedback
Gets or sets a bounding box of this shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BoundingBox Box { get; set; }
Visual Basic (Declaration)
Public Property Box As BoundingBox
Visual C++
public:
property BoundingBox^ Box {
    BoundingBox^ get ();
    void set (BoundingBox^ value);
}

See Also

ShapePolygon Class
FastReport.Map Namespace


Parts Property

[image]

FastReport.Net Class Reference
ShapePolygon..::.Parts Property
ShapePolygon Class See Also Send Feedback
Gets or sets a list of polygons in this shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<PointD[]> Parts { get; set; }
Visual Basic (Declaration)
Public Property Parts As List(Of PointD())
Visual C++
public:
property List<array<PointD>^>^ Parts {
    List<array<PointD>^>^ get ();
    void set (List<array<PointD>^>^ value);
}

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapeData Property

[image]

FastReport.Net Class Reference
ShapePolygon..::.ShapeData Property
ShapePolygon Class See Also Send Feedback
Gets or sets the shape data in binary format.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public byte[] ShapeData { get; set; }
Visual Basic (Declaration)
Public Property ShapeData As Byte()
Visual C++
public:
property array<unsigned char>^ ShapeData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapePolygon Events

[image] [image]

FastReport.Net Class Reference
ShapePolygon Events
ShapePolygon Class See Also Send Feedback

The ShapePolygon type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapePolygon Class
FastReport.Map Namespace


ShapePolyLine Class

[image]

FastReport.Net Class Reference
ShapePolyLine Class
Members See Also Send Feedback
Represents a line shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapePolyLine : ShapePolygon
Visual Basic (Declaration)
Public Class ShapePolyLine _
    Inherits ShapePolygon
Visual C++
public ref class ShapePolyLine : public ShapePolygon

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.Map..::.ShapeBase
FastReport.Map..::.ShapePolygon
FastReport.Map..::.ShapePolyLine

See Also

ShapePolyLine Members
FastReport.Map Namespace


ShapePolyLine Members

[image] [image]

FastReport.Net Class Reference
ShapePolyLine Members
ShapePolyLine Class Constructors Methods Fields Properties Events See Also Send Feedback

The ShapePolyLine type exposes the following members.

Constructors

Name | Description
ShapePolyLine | Initializes a new instance of the ShapePolyLine class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ShapePolygon.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from ShapePolygon.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape. (Overrides ShapePolygon..::.Draw(FRPaintEventArgs).)
DrawLabel | Draws the label. (Overrides ShapePolygon..::.DrawLabel(FRPaintEventArgs).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report. (Inherited from ShapePolygon.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ShapeBase.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ShapeBase.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ShapeBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ShapeBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ShapeBase.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ShapeBase.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ShapeBase.)
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ShapeBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor. (Overrides ShapePolygon..::.HitTest(PointF).)
InitializeComponent | Initializes a component before running a report. (Inherited from ShapePolygon.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component. (Inherited from ShapeBase.)
SaveState | Saves the state of this component. (Inherited from ShapeBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ShapePolygon.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape. (Inherited from ShapePolygon.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Fields

Name | Description
largestBoundsRect | Holds the largest bounding rectangle of this shape. (Inherited from ShapePolygon.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
Box | Gets or sets a bounding box of this shape. (Inherited from ShapePolygon.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset. (Inherited from ShapeBase.)
CenterOffsetY | Gets or sets the center point Y offset. (Inherited from ShapeBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style. (Inherited from ShapeBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object. (Inherited from ShapeBase.)
Map | Gets a reference to the parent Map object. (Inherited from ShapeBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Parts | Gets or sets a list of polygons in this shape. (Inherited from ShapePolygon.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeData | Gets or sets the shape data in binary format. (Inherited from ShapePolygon.)
ShapeOffsetX | Gets or sets the shape X offset. (Inherited from ShapeBase.)
ShapeOffsetY | Gets or sets the shape Y offset. (Inherited from ShapeBase.)
ShapeScale | Gets or sets the scale factor for this shape. (Inherited from ShapeBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape. (Inherited from ShapeBase.)
UseCustomStyle | Gets or sets a value indicating that custom shape style is used. (Inherited from ShapeBase.)
Value | Gets or sets the value. (Inherited from ShapeBase.)
Visible | Gets or sets the shape visibility. (Inherited from ShapeBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapePolyLine Class
FastReport.Map Namespace


ShapePolyLine Constructor

[image]

FastReport.Net Class Reference
ShapePolyLine Constructor
ShapePolyLine Class See Also Send Feedback
Initializes a new instance of the ShapePolyLine class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapePolyLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapePolyLine()

See Also

ShapePolyLine Class
FastReport.Map Namespace


ShapePolyLine Fields

[image] [image]

FastReport.Net Class Reference
ShapePolyLine Fields
ShapePolyLine Class See Also Send Feedback

The ShapePolyLine type exposes the following members.

Fields

Name | Description
largestBoundsRect | Holds the largest bounding rectangle of this shape. (Inherited from ShapePolygon.)

See Also

ShapePolyLine Class
FastReport.Map Namespace


ShapePolyLine Methods

[image] [image]

FastReport.Net Class Reference
ShapePolyLine Methods
ShapePolyLine Class See Also Send Feedback

The ShapePolyLine type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Inherited from ShapePolygon.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from ShapePolygon.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the shape. (Overrides ShapePolygon..::.Draw(FRPaintEventArgs).)
DrawLabel | Draws the label. (Overrides ShapePolygon..::.DrawLabel(FRPaintEventArgs).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Finalizes a component before running a report. (Inherited from ShapePolygon.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ShapeBase.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ShapeBase.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ShapeBase.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ShapeBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ShapeBase.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ShapeBase.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ShapeBase.)
GetEvents | Overloaded.
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ShapeBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
HitTest | Checks if the shape is under cursor. (Overrides ShapePolygon..::.HitTest(PointF).)
InitializeComponent | Initializes a component before running a report. (Inherited from ShapePolygon.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
RestoreState | Restores the state of this component. (Inherited from ShapeBase.)
SaveState | Saves the state of this component. (Inherited from ShapeBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from ShapePolygon.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Simplify | Reduces the number of points in the shape. (Inherited from ShapePolygon.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ShapePolyLine Class
FastReport.Map Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
ShapePolyLine..::.Dispose Method
ShapePolyLine Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

ShapePolyLine Class
ShapePolyLine Members
FastReport.Map Namespace


Draw Method

[image]

FastReport.Net Class Reference
ShapePolyLine..::.Draw Method
ShapePolyLine Class See Also Send Feedback
Draws the shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapePolyLine Class
FastReport.Map Namespace


DrawLabel Method

[image]

FastReport.Net Class Reference
ShapePolyLine..::.DrawLabel Method
ShapePolyLine Class See Also Send Feedback
Draws the label.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void DrawLabel(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub DrawLabel ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void DrawLabel(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Object that provides a data for paint event.

See Also

ShapePolyLine Class
FastReport.Map Namespace


GetEvents Method

[image] [image]

FastReport.Net Class Reference
ShapePolyLine..::.GetEvents Method
ShapePolyLine Class See Also Send Feedback

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component. (Inherited from ShapeBase.)
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter. (Inherited from ShapeBase.)

See Also

ShapePolyLine Class
ShapePolyLine Members
FastReport.Map Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
ShapePolyLine..::.GetProperties Method
ShapePolyLine Class See Also Send Feedback

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component. (Inherited from ShapeBase.)
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter. (Inherited from ShapeBase.)

See Also

ShapePolyLine Class
ShapePolyLine Members
FastReport.Map Namespace


HitTest Method

[image]

FastReport.Net Class Reference
ShapePolyLine..::.HitTest Method
ShapePolyLine Class See Also Send Feedback
Checks if the shape is under cursor.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool HitTest(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function HitTest ( _
    point As PointF _
) As Boolean
Visual C++
public:
virtual bool HitTest(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF
The cursor coordinates.

Return Value

true if the cursor is over the shape.

See Also

ShapePolyLine Class
FastReport.Map Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
ShapePolyLine..::.MemberwiseClone Method
ShapePolyLine Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ShapePolyLine Class
ShapePolyLine Members
FastReport.Map Namespace


ShapePolyLine Properties

[image] [image]

FastReport.Net Class Reference
ShapePolyLine Properties
ShapePolyLine Class See Also Send Feedback

The ShapePolyLine type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
Box | Gets or sets a bounding box of this shape. (Inherited from ShapePolygon.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CenterOffsetX | Gets or sets the center point X offset. (Inherited from ShapeBase.)
CenterOffsetY | Gets or sets the center point Y offset. (Inherited from ShapeBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CustomStyle | Gets a custom shape style. (Inherited from ShapeBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Layer | Gets a reference to the parent Layer object. (Inherited from ShapeBase.)
Map | Gets a reference to the parent Map object. (Inherited from ShapeBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Parts | Gets or sets a list of polygons in this shape. (Inherited from ShapePolygon.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ShapeData | Gets or sets the shape data in binary format. (Inherited from ShapePolygon.)
ShapeOffsetX | Gets or sets the shape X offset. (Inherited from ShapeBase.)
ShapeOffsetY | Gets or sets the shape Y offset. (Inherited from ShapeBase.)
ShapeScale | Gets or sets the scale factor for this shape. (Inherited from ShapeBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SpatialData | Gets or sets the spatial data associated with this shape. (Inherited from ShapeBase.)
UseCustomStyle | Gets or sets a value indicating that custom shape style is used. (Inherited from ShapeBase.)
Value | Gets or sets the value. (Inherited from ShapeBase.)
Visible | Gets or sets the shape visibility. (Inherited from ShapeBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

ShapePolyLine Class
FastReport.Map Namespace


ShapePolyLine Events

[image] [image]

FastReport.Net Class Reference
ShapePolyLine Events
ShapePolyLine Class See Also Send Feedback

The ShapePolyLine type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ShapePolyLine Class
FastReport.Map Namespace


ShapeSpatialData Class

[image]

FastReport.Net Class Reference
ShapeSpatialData Class
Members See Also Send Feedback
Represents the spatial data of a shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapeSpatialData
Visual Basic (Declaration)
Public Class ShapeSpatialData
Visual C++
public ref class ShapeSpatialData

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ShapeSpatialData

See Also

ShapeSpatialData Members
FastReport.Map Namespace


ShapeSpatialData Members

[image] [image]

FastReport.Net Class Reference
ShapeSpatialData Members
ShapeSpatialData Class Constructors Methods See Also Send Feedback

The ShapeSpatialData type exposes the following members.

Constructors

Name | Description
ShapeSpatialData | Creates a new instance of the ShapeSpatialData class.

Methods

Name | Description
Assign | Copies contents from another spatial data object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Gets a list of keys.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Gets a value by its key.
IsEqual | Compares two spatial data objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetValue | Sets a value by its key.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeSpatialData Class
FastReport.Map Namespace


ShapeSpatialData Constructor

[image]

FastReport.Net Class Reference
ShapeSpatialData Constructor
ShapeSpatialData Class See Also Send Feedback
Creates a new instance of the ShapeSpatialData class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeSpatialData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeSpatialData()

See Also

ShapeSpatialData Class
FastReport.Map Namespace


ShapeSpatialData Methods

[image] [image]

FastReport.Net Class Reference
ShapeSpatialData Methods
ShapeSpatialData Class See Also Send Feedback

The ShapeSpatialData type exposes the following members.

Methods

Name | Description
Assign | Copies contents from another spatial data object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Gets a list of keys.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Gets a value by its key.
IsEqual | Compares two spatial data objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetValue | Sets a value by its key.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeSpatialData Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ShapeSpatialData..::.Assign Method
ShapeSpatialData Class See Also Send Feedback
Copies contents from another spatial data object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    ShapeSpatialData src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As ShapeSpatialData _
)
Visual C++
public:
void Assign(
    ShapeSpatialData^ src
)

Parameters

src
Type: FastReport.Map..::.ShapeSpatialData
The object to copy contents from.

See Also

ShapeSpatialData Class
FastReport.Map Namespace


GetKeys Method

[image]

FastReport.Net Class Reference
ShapeSpatialData..::.GetKeys Method
ShapeSpatialData Class See Also Send Feedback
Gets a list of keys.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<string> GetKeys()
Visual Basic (Declaration)
Public Function GetKeys As List(Of String)
Visual C++
public:
List<String^>^ GetKeys()

Return Value

The list of keys.

See Also

ShapeSpatialData Class
FastReport.Map Namespace


GetValue Method

[image]

FastReport.Net Class Reference
ShapeSpatialData..::.GetValue Method
ShapeSpatialData Class See Also Send Feedback
Gets a value by its key.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetValue(
    string key
)
Visual Basic (Declaration)
Public Function GetValue ( _
    key As String _
) As String
Visual C++
public:
String^ GetValue(
    String^ key
)

Parameters

key
Type: System..::.String
The key of value.

Return Value

The value.

See Also

ShapeSpatialData Class
FastReport.Map Namespace


IsEqual Method

[image]

FastReport.Net Class Reference
ShapeSpatialData..::.IsEqual Method
ShapeSpatialData Class See Also Send Feedback
Compares two spatial data objects.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsEqual(
    ShapeSpatialData src
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    src As ShapeSpatialData _
) As Boolean
Visual C++
public:
bool IsEqual(
    ShapeSpatialData^ src
)

Parameters

src
Type: FastReport.Map..::.ShapeSpatialData
The spatial object to compare with.

Return Value

true if spatial objects are identical.

See Also

ShapeSpatialData Class
FastReport.Map Namespace


SetValue Method

[image]

FastReport.Net Class Reference
ShapeSpatialData..::.SetValue Method
ShapeSpatialData Class See Also Send Feedback
Sets a value by its key.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetValue(
    string key,
    string value
)
Visual Basic (Declaration)
Public Sub SetValue ( _
    key As String, _
    value As String _
)
Visual C++
public:
void SetValue(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::.String
The key of value.
value
Type: System..::.String
The value.

See Also

ShapeSpatialData Class
FastReport.Map Namespace


ShapeStyle Class

[image]

FastReport.Net Class Reference
ShapeStyle Class
Members See Also Send Feedback
Represents the style of a shape.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ShapeStyle
Visual Basic (Declaration)
Public Class ShapeStyle
Visual C++
public ref class ShapeStyle

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.ShapeStyle

See Also

ShapeStyle Members
FastReport.Map Namespace


ShapeStyle Members

[image] [image]

FastReport.Net Class Reference
ShapeStyle Members
ShapeStyle Class Constructors Methods Properties See Also Send Feedback

The ShapeStyle type exposes the following members.

Constructors

Name | Description
ShapeStyle | Initializes a new instance of the ShapeStyle class.

Methods

Name | Description
Assign | Copies contents from another similar object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BorderColor | Gets or sets the border color.
BorderStyle | Gets or sets the border style.
BorderWidth | Gets or sets the border width.
FillColor | Gets or sets the fill color.
Font | Gets or sets the font.
PointSize | Gets or sets the point size, in pixels.
TextColor | Gets or sets the text color.

See Also

ShapeStyle Class
FastReport.Map Namespace


ShapeStyle Constructor

[image]

FastReport.Net Class Reference
ShapeStyle Constructor
ShapeStyle Class See Also Send Feedback
Initializes a new instance of the ShapeStyle class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShapeStyle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeStyle()

See Also

ShapeStyle Class
FastReport.Map Namespace


ShapeStyle Methods

[image] [image]

FastReport.Net Class Reference
ShapeStyle Methods
ShapeStyle Class See Also Send Feedback

The ShapeStyle type exposes the following members.

Methods

Name | Description
Assign | Copies contents from another similar object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeStyle Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
ShapeStyle..::.Assign Method
ShapeStyle Class See Also Send Feedback
Copies contents from another similar object.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    ShapeStyle src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As ShapeStyle _
)
Visual C++
public:
void Assign(
    ShapeStyle^ src
)

Parameters

src
Type: FastReport.Map..::.ShapeStyle
The object to copy the contents from.

See Also

ShapeStyle Class
FastReport.Map Namespace


ShapeStyle Properties

[image] [image]

FastReport.Net Class Reference
ShapeStyle Properties
ShapeStyle Class See Also Send Feedback

The ShapeStyle type exposes the following members.

Properties

Name | Description
BorderColor | Gets or sets the border color.
BorderStyle | Gets or sets the border style.
BorderWidth | Gets or sets the border width.
FillColor | Gets or sets the fill color.
Font | Gets or sets the font.
PointSize | Gets or sets the point size, in pixels.
TextColor | Gets or sets the text color.

See Also

ShapeStyle Class
FastReport.Map Namespace


BorderColor Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.BorderColor Property
ShapeStyle Class See Also Send Feedback
Gets or sets the border color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic (Declaration)
Public Property BorderColor As Color
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


BorderStyle Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.BorderStyle Property
ShapeStyle Class See Also Send Feedback
Gets or sets the border style.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DashStyle BorderStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderStyle As DashStyle
Visual C++
public:
property DashStyle BorderStyle {
    DashStyle get ();
    void set (DashStyle value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


BorderWidth Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.BorderWidth Property
ShapeStyle Class See Also Send Feedback
Gets or sets the border width.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float BorderWidth { get; set; }
Visual Basic (Declaration)
Public Property BorderWidth As Single
Visual C++
public:
property float BorderWidth {
    float get ();
    void set (float value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


FillColor Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.FillColor Property
ShapeStyle Class See Also Send Feedback
Gets or sets the fill color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color FillColor { get; set; }
Visual Basic (Declaration)
Public Property FillColor As Color
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


Font Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.Font Property
ShapeStyle Class See Also Send Feedback
Gets or sets the font.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


PointSize Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.PointSize Property
ShapeStyle Class See Also Send Feedback
Gets or sets the point size, in pixels.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float PointSize { get; set; }
Visual Basic (Declaration)
Public Property PointSize As Single
Visual C++
public:
property float PointSize {
    float get ();
    void set (float value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


TextColor Property

[image]

FastReport.Net Class Reference
ShapeStyle..::.TextColor Property
ShapeStyle Class See Also Send Feedback
Gets or sets the text color.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

ShapeStyle Class
FastReport.Map Namespace


SizeRange Class

[image]

FastReport.Net Class Reference
SizeRange Class
Members See Also Send Feedback
Represents a single size range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SizeRange
Visual Basic (Declaration)
Public Class SizeRange
Visual C++
public ref class SizeRange

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.SizeRange

See Also

SizeRange Members
FastReport.Map Namespace


SizeRange Members

[image] [image]

FastReport.Net Class Reference
SizeRange Members
SizeRange Class Constructors Methods Properties See Also Send Feedback

The SizeRange type exposes the following members.

Constructors

Name | Description
SizeRange | Overloaded.

Methods

Name | Description
Assign | Copies the contents of another SizeRange.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EndValue | Gets or sets end value of the range.
Size | Gets or sets size of the range.
StartValue | Gets or sets start value of the range.

See Also

SizeRange Class
FastReport.Map Namespace


SizeRange Constructor

[image] [image]

FastReport.Net Class Reference
SizeRange Constructor
SizeRange Class See Also Send Feedback

Overload List

Name | Description
SizeRange()()() | Initializes a new instance of the SizeRange class.
SizeRange(Single, Double, Double) | Initializes a new instance of the SizeRange class with a specified parameters.

See Also

SizeRange Class
SizeRange Members
FastReport.Map Namespace


SizeRange Constructor

[image]

FastReport.Net Class Reference
SizeRange Constructor
SizeRange Class See Also Send Feedback
Initializes a new instance of the SizeRange class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizeRange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SizeRange()

See Also

SizeRange Class
SizeRange Overload
FastReport.Map Namespace


SizeRange Constructor (Single, Double, Double)

[image]

FastReport.Net Class Reference
SizeRange Constructor (Single, Double, Double)
SizeRange Class See Also Send Feedback
Initializes a new instance of the SizeRange class with a specified parameters.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizeRange(
    float size,
    double startValue,
    double endValue
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Single, _
    startValue As Double, _
    endValue As Double _
)
Visual C++
public:
SizeRange(
    float size,
    double startValue,
    double endValue
)

Parameters

size
Type: System..::.Single
The size of the range.
startValue
Type: System..::.Double
The start value of the range.
endValue
Type: System..::.Double
The end value of the range.

See Also

SizeRange Class
SizeRange Overload
FastReport.Map Namespace


SizeRange Methods

[image] [image]

FastReport.Net Class Reference
SizeRange Methods
SizeRange Class See Also Send Feedback

The SizeRange type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another SizeRange.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeRange Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
SizeRange..::.Assign Method
SizeRange Class See Also Send Feedback
Copies the contents of another SizeRange.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    SizeRange src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As SizeRange _
)
Visual C++
public:
void Assign(
    SizeRange^ src
)

Parameters

src
Type: FastReport.Map..::.SizeRange
The SizeRange instance to copy the contents from.

See Also

SizeRange Class
FastReport.Map Namespace


SizeRange Properties

[image] [image]

FastReport.Net Class Reference
SizeRange Properties
SizeRange Class See Also Send Feedback

The SizeRange type exposes the following members.

Properties

Name | Description
EndValue | Gets or sets end value of the range.
Size | Gets or sets size of the range.
StartValue | Gets or sets start value of the range.

See Also

SizeRange Class
FastReport.Map Namespace


EndValue Property

[image]

FastReport.Net Class Reference
SizeRange..::.EndValue Property
SizeRange Class See Also Send Feedback
Gets or sets end value of the range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double EndValue { get; set; }
Visual Basic (Declaration)
Public Property EndValue As Double
Visual C++
public:
property double EndValue {
    double get ();
    void set (double value);
}

See Also

SizeRange Class
FastReport.Map Namespace


Size Property

[image]

FastReport.Net Class Reference
SizeRange..::.Size Property
SizeRange Class See Also Send Feedback
Gets or sets size of the range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Single
Visual C++
public:
property float Size {
    float get ();
    void set (float value);
}

See Also

SizeRange Class
FastReport.Map Namespace


StartValue Property

[image]

FastReport.Net Class Reference
SizeRange..::.StartValue Property
SizeRange Class See Also Send Feedback
Gets or sets start value of the range.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double StartValue { get; set; }
Visual Basic (Declaration)
Public Property StartValue As Double
Visual C++
public:
property double StartValue {
    double get ();
    void set (double value);
}

See Also

SizeRange Class
FastReport.Map Namespace


SizeRanges Class

[image]

FastReport.Net Class Reference
SizeRanges Class
Members See Also Send Feedback
Represents a set of size ranges used to draw points based on analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SizeRanges
Visual Basic (Declaration)
Public Class SizeRanges
Visual C++
public ref class SizeRanges

Inheritance Hierarchy

System..::.Object
FastReport.Map..::.SizeRanges

See Also

SizeRanges Members
FastReport.Map Namespace


SizeRanges Members

[image] [image]

FastReport.Net Class Reference
SizeRanges Members
SizeRanges Class Constructors Methods Properties See Also Send Feedback

The SizeRanges type exposes the following members.

Constructors

Name | Description
SizeRanges | Initializes a new instance of the SizeRanges class.

Methods

Name | Description
Assign | Copies the contents of another SizeRanges.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Gets a size associated with given analytical value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EndSize | Gets or sets the end size.
RangeCount | Gets or sets the number of ranges.
Ranges | Gets the list of ranges.
RangesAsString | Gets or sets ranges as a string.
StartSize | Gets or sets the start size.

See Also

SizeRanges Class
FastReport.Map Namespace


SizeRanges Constructor

[image]

FastReport.Net Class Reference
SizeRanges Constructor
SizeRanges Class See Also Send Feedback
Initializes a new instance of the SizeRanges class.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizeRanges()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SizeRanges()

See Also

SizeRanges Class
FastReport.Map Namespace


SizeRanges Methods

[image] [image]

FastReport.Net Class Reference
SizeRanges Methods
SizeRanges Class See Also Send Feedback

The SizeRanges type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another SizeRanges.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Gets a size associated with given analytical value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeRanges Class
FastReport.Map Namespace


Assign Method

[image]

FastReport.Net Class Reference
SizeRanges..::.Assign Method
SizeRanges Class See Also Send Feedback
Copies the contents of another SizeRanges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    SizeRanges src
)
Visual Basic (Declaration)
Public Sub Assign ( _
    src As SizeRanges _
)
Visual C++
public:
void Assign(
    SizeRanges^ src
)

Parameters

src
Type: FastReport.Map..::.SizeRanges
The SizeRanges instance to copy the contents from.

See Also

SizeRanges Class
FastReport.Map Namespace


GetSize Method

[image]

FastReport.Net Class Reference
SizeRanges..::.GetSize Method
SizeRanges Class See Also Send Feedback
Gets a size associated with given analytical value.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float GetSize(
    double value
)
Visual Basic (Declaration)
Public Function GetSize ( _
    value As Double _
) As Single
Visual C++
public:
float GetSize(
    double value
)

Parameters

value
Type: System..::.Double
The analytical value.

Return Value

The size associated with this value, or 0 if no association found.

See Also

SizeRanges Class
FastReport.Map Namespace


SizeRanges Properties

[image] [image]

FastReport.Net Class Reference
SizeRanges Properties
SizeRanges Class See Also Send Feedback

The SizeRanges type exposes the following members.

Properties

Name | Description
EndSize | Gets or sets the end size.
RangeCount | Gets or sets the number of ranges.
Ranges | Gets the list of ranges.
RangesAsString | Gets or sets ranges as a string.
StartSize | Gets or sets the start size.

See Also

SizeRanges Class
FastReport.Map Namespace


EndSize Property

[image]

FastReport.Net Class Reference
SizeRanges..::.EndSize Property
SizeRanges Class See Also Send Feedback
Gets or sets the end size.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float EndSize { get; set; }
Visual Basic (Declaration)
Public Property EndSize As Single
Visual C++
public:
property float EndSize {
    float get ();
    void set (float value);
}

See Also

SizeRanges Class
FastReport.Map Namespace


RangeCount Property

[image]

FastReport.Net Class Reference
SizeRanges..::.RangeCount Property
SizeRanges Class See Also Send Feedback
Gets or sets the number of ranges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RangeCount { get; set; }
Visual Basic (Declaration)
Public Property RangeCount As Integer
Visual C++
public:
property int RangeCount {
    int get ();
    void set (int value);
}

See Also

SizeRanges Class
FastReport.Map Namespace


Ranges Property

[image]

FastReport.Net Class Reference
SizeRanges..::.Ranges Property
SizeRanges Class See Also Send Feedback
Gets the list of ranges.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<SizeRange> Ranges { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ranges As List(Of SizeRange)
Visual C++
public:
property List<SizeRange^>^ Ranges {
    List<SizeRange^>^ get ();
}

See Also

SizeRanges Class
FastReport.Map Namespace


RangesAsString Property

[image]

FastReport.Net Class Reference
SizeRanges..::.RangesAsString Property
SizeRanges Class See Also Send Feedback
Gets or sets ranges as a string.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string RangesAsString { get; set; }
Visual Basic (Declaration)
Public Property RangesAsString As String
Visual C++
public:
property String^ RangesAsString {
    String^ get ();
    void set (String^ value);
}

See Also

SizeRanges Class
FastReport.Map Namespace


StartSize Property

[image]

FastReport.Net Class Reference
SizeRanges..::.StartSize Property
SizeRanges Class See Also Send Feedback
Gets or sets the start size.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float StartSize { get; set; }
Visual Basic (Declaration)
Public Property StartSize As Single
Visual C++
public:
property float StartSize {
    float get ();
    void set (float value);
}

See Also

SizeRanges Class
FastReport.Map Namespace


SpatialSource Enumeration

[image]

FastReport.Net Class Reference
SpatialSource Enumeration
See Also Send Feedback
Specifies the spatial source for the layer.

Namespace: FastReport.Map
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum SpatialSource
Visual Basic (Declaration)
Public Enumeration SpatialSource
Visual C++
public enum class SpatialSource

Members

Member name | Description
ShpFile | Source is ESRI shapefile.
ApplicationData | Source is a latitude/longitude/name provided by an application.

See Also

FastReport.Map Namespace


FastReport.Map.Import Namespace

[image]

FastReport.Net Class Reference
FastReport.Map.Import Namespace
Send Feedback

Classes

Class | Description
DBaseFieldDescription | Represents the description of dBase field.
DbfFileImport | Represents loading map data from dbf-file.

Enumerations

Enumeration | Description
DBaseFieldType | The type of dBase field.


DBaseFieldDescription Class

[image]

FastReport.Net Class Reference
DBaseFieldDescription Class
Members See Also Send Feedback
Represents the description of dBase field.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DBaseFieldDescription
Visual Basic (Declaration)
Public Class DBaseFieldDescription
Visual C++
public ref class DBaseFieldDescription

Inheritance Hierarchy

System..::.Object
FastReport.Map.Import..::.DBaseFieldDescription

See Also

DBaseFieldDescription Members
FastReport.Map.Import Namespace


DBaseFieldDescription Members

[image] [image]

FastReport.Net Class Reference
DBaseFieldDescription Members
DBaseFieldDescription Class Constructors Methods Properties See Also Send Feedback

The DBaseFieldDescription type exposes the following members.

Constructors

Name | Description
DBaseFieldDescription | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length | Gets the field length.
Name | Gets the field name.
Type | Gets the field type.

See Also

DBaseFieldDescription Class
FastReport.Map.Import Namespace


DBaseFieldDescription Constructor

[image] [image]

FastReport.Net Class Reference
DBaseFieldDescription Constructor
DBaseFieldDescription Class See Also Send Feedback

Overload List

Name | Description
DBaseFieldDescription()()() | Initializes a new instance of the DBaseFieldDescription class.
DBaseFieldDescription(String, DBaseFieldType, Int32) | Initializes a new instance of the DBaseFieldDescription class with a specified parameters.
DBaseFieldDescription(String, String, Int32) | Initializes a new instance of the DBaseFieldDescription class with a specified parameters.

See Also

DBaseFieldDescription Class
DBaseFieldDescription Members
FastReport.Map.Import Namespace


DBaseFieldDescription Constructor

[image]

FastReport.Net Class Reference
DBaseFieldDescription Constructor
DBaseFieldDescription Class See Also Send Feedback
Initializes a new instance of the DBaseFieldDescription class.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DBaseFieldDescription()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DBaseFieldDescription()

See Also

DBaseFieldDescription Class
DBaseFieldDescription Overload
FastReport.Map.Import Namespace


DBaseFieldDescription Constructor (String, DBaseFieldType, Int32)

[image]

FastReport.Net Class Reference
DBaseFieldDescription Constructor (String, DBaseFieldType, Int32)
DBaseFieldDescription Class See Also Send Feedback
Initializes a new instance of the DBaseFieldDescription class with a specified parameters.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DBaseFieldDescription(
    string name,
    DBaseFieldType type,
    int length
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As DBaseFieldType, _
    length As Integer _
)
Visual C++
public:
DBaseFieldDescription(
    String^ name,
    DBaseFieldType type,
    int length
)

Parameters

name
Type: System..::.String
The field name.
type
Type: FastReport.Map.Import..::.DBaseFieldType
The field type.
length
Type: System..::.Int32
The field length.

See Also

DBaseFieldDescription Class
DBaseFieldDescription Overload
FastReport.Map.Import Namespace


DBaseFieldDescription Constructor (String, String, Int32)

[image]

FastReport.Net Class Reference
DBaseFieldDescription Constructor (String, String, Int32)
DBaseFieldDescription Class See Also Send Feedback
Initializes a new instance of the DBaseFieldDescription class with a specified parameters.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DBaseFieldDescription(
    string name,
    string type,
    int length
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As String, _
    length As Integer _
)
Visual C++
public:
DBaseFieldDescription(
    String^ name,
    String^ type,
    int length
)

Parameters

name
Type: System..::.String
The field name.
type
Type: System..::.String
The field type.
length
Type: System..::.Int32
The field length.

See Also

DBaseFieldDescription Class
DBaseFieldDescription Overload
FastReport.Map.Import Namespace


DBaseFieldDescription Methods

[image] [image]

FastReport.Net Class Reference
DBaseFieldDescription Methods
DBaseFieldDescription Class See Also Send Feedback

The DBaseFieldDescription type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DBaseFieldDescription Class
FastReport.Map.Import Namespace


DBaseFieldDescription Properties

[image] [image]

FastReport.Net Class Reference
DBaseFieldDescription Properties
DBaseFieldDescription Class See Also Send Feedback

The DBaseFieldDescription type exposes the following members.

Properties

Name | Description
Length | Gets the field length.
Name | Gets the field name.
Type | Gets the field type.

See Also

DBaseFieldDescription Class
FastReport.Map.Import Namespace


Length Property

[image]

FastReport.Net Class Reference
DBaseFieldDescription..::.Length Property
DBaseFieldDescription Class See Also Send Feedback
Gets the field length.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
}

See Also

DBaseFieldDescription Class
FastReport.Map.Import Namespace


Name Property

[image]

FastReport.Net Class Reference
DBaseFieldDescription..::.Name Property
DBaseFieldDescription Class See Also Send Feedback
Gets the field name.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

DBaseFieldDescription Class
FastReport.Map.Import Namespace


Type Property

[image]

FastReport.Net Class Reference
DBaseFieldDescription..::.Type Property
DBaseFieldDescription Class See Also Send Feedback
Gets the field type.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DBaseFieldType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As DBaseFieldType
Visual C++
public:
property DBaseFieldType Type {
    DBaseFieldType get ();
}

See Also

DBaseFieldDescription Class
FastReport.Map.Import Namespace


DBaseFieldType Enumeration

[image]

FastReport.Net Class Reference
DBaseFieldType Enumeration
See Also Send Feedback
The type of dBase field.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum DBaseFieldType
Visual Basic (Declaration)
Public Enumeration DBaseFieldType
Visual C++
public enum class DBaseFieldType

Members

Member name | Description
Char | Character field.
Date | Date field.
Numeric | Numeric field.
Logical | Logical field.
Memo | Memo field.

See Also

FastReport.Map.Import Namespace


DbfFileImport Class

[image]

FastReport.Net Class Reference
DbfFileImport Class
Members See Also Send Feedback
Represents loading map data from dbf-file.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DbfFileImport
Visual Basic (Declaration)
Public Class DbfFileImport
Visual C++
public ref class DbfFileImport

Inheritance Hierarchy

System..::.Object
FastReport.Map.Import..::.DbfFileImport

See Also

DbfFileImport Members
FastReport.Map.Import Namespace


DbfFileImport Members

[image] [image]

FastReport.Net Class Reference
DbfFileImport Members
DbfFileImport Class Constructors Methods Properties See Also Send Feedback

The DbfFileImport type exposes the following members.

Constructors

Name | Description
DbfFileImport | Initializes a new instance of the DbfFileImport class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Returns a file filter for an open file dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportFile | Imports the map data from a specified file into a specfied layer.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filter | Gets or sets the filter string used in an open file dialog.

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


DbfFileImport Constructor

[image]

FastReport.Net Class Reference
DbfFileImport Constructor
DbfFileImport Class See Also Send Feedback
Initializes a new instance of the DbfFileImport class.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DbfFileImport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DbfFileImport()

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


DbfFileImport Methods

[image] [image]

FastReport.Net Class Reference
DbfFileImport Methods
DbfFileImport Class See Also Send Feedback

The DbfFileImport type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilter | Returns a file filter for an open file dialog.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportFile | Imports the map data from a specified file into a specfied layer.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


GetFilter Method

[image]

FastReport.Net Class Reference
DbfFileImport..::.GetFilter Method
DbfFileImport Class See Also Send Feedback
Returns a file filter for an open file dialog.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected string GetFilter()
Visual Basic (Declaration)
Protected Function GetFilter As String
Visual C++
protected:
String^ GetFilter()

Return Value

String that contains a file filter.

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


ImportFile Method

[image]

FastReport.Net Class Reference
DbfFileImport..::.ImportFile Method
DbfFileImport Class See Also Send Feedback
Imports the map data from a specified file into a specfied layer.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ImportFile(
    MapLayer layer,
    string filename
)
Visual Basic (Declaration)
Public Sub ImportFile ( _
    layer As MapLayer, _
    filename As String _
)
Visual C++
public:
void ImportFile(
    MapLayer^ layer,
    String^ filename
)

Parameters

layer
Type: FastReport.Map..::.MapLayer
The MapObject for an importing map.
filename
Type: System..::.String
The name of a file that contains map.

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


DbfFileImport Properties

[image] [image]

FastReport.Net Class Reference
DbfFileImport Properties
DbfFileImport Class See Also Send Feedback

The DbfFileImport type exposes the following members.

Properties

Name | Description
Filter | Gets or sets the filter string used in an open file dialog.

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


Filter Property

[image]

FastReport.Net Class Reference
DbfFileImport..::.Filter Property
DbfFileImport Class See Also Send Feedback
Gets or sets the filter string used in an open file dialog.

Namespace: FastReport.Map.Import
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; protected set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

DbfFileImport Class
FastReport.Map.Import Namespace


FastReport.Matrix Namespace

[image]

FastReport.Net Class Reference
FastReport.Matrix Namespace
Send Feedback

Classes

Class | Description
MatrixCellDescriptor | The descriptor that is used to describe one matrix data cell.
MatrixCells | Represents a collection of matrix data descriptors used in the MatrixObject.
MatrixData | Contains a set of properties and methods to hold and manipulate the matrix descriptors.
MatrixDescriptor | The base class for matrix element descriptors such as MatrixHeaderDescriptor and MatrixCellDescriptor.
MatrixHeader | Represents a collection of matrix header descriptors used in the MatrixObject.
MatrixHeaderDescriptor | The descriptor that is used to describe one element of the matrix header.
MatrixObject | Represents the matrix object that is used to print pivot table (also known as cross-tab).

Enumerations

Enumeration | Description
MatrixAggregateFunction | Specifies the aggregate function used in the MatrixObject.
MatrixEvenStylePriority | Describes how the even style is applied to a matrix.
MatrixPercent | Determines how matrix percents are calculated.


MatrixAggregateFunction Enumeration

[image]

FastReport.Net Class Reference
MatrixAggregateFunction Enumeration
See Also Send Feedback
Specifies the aggregate function used in the MatrixObject.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum MatrixAggregateFunction
Visual Basic (Declaration)
Public Enumeration MatrixAggregateFunction
Visual C++
public enum class MatrixAggregateFunction

Members

Member name | Description
None | No aggregates are used.
Sum | Specifies the sum of values.
Min | Specifies the minimum of values.
Max | Specifies the maximum of values.
Avg | Specifies the average of values.
Count | Specifies the count of values.
Custom | Specifies the custom function.

See Also

FastReport.Matrix Namespace


MatrixCellDescriptor Class

[image]

FastReport.Net Class Reference
MatrixCellDescriptor Class
Members See Also Send Feedback
The descriptor that is used to describe one matrix data cell.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixCellDescriptor : MatrixDescriptor
Visual Basic (Declaration)
Public Class MatrixCellDescriptor _
    Inherits MatrixDescriptor
Visual C++
public ref class MatrixCellDescriptor : public MatrixDescriptor

Remarks

The MatrixCellDescriptor class is used to define one data cell of the matrix. The key properties are Expression and Function. To set visual appearance of the data cell, use the TemplateCell property.

The collection of descriptors used to represent the matrix data cells is stored in the MatrixObject.Data.Cells property.

Inheritance Hierarchy

System..::.Object
FastReport.Matrix..::.MatrixDescriptor
FastReport.Matrix..::.MatrixCellDescriptor

See Also

MatrixCellDescriptor Members
FastReport.Matrix Namespace


MatrixCellDescriptor Members

[image] [image]

FastReport.Net Class Reference
MatrixCellDescriptor Members
MatrixCellDescriptor Class Constructors Methods Properties See Also Send Feedback

The MatrixCellDescriptor type exposes the following members.

Constructors

Name | Description
MatrixCellDescriptor | Overloaded.

Methods

Name | Description
Assign | Assigns values from another descriptor. (Overrides MatrixDescriptor..::.Assign(MatrixDescriptor).)
Deserialize | Deserializes the object. (Inherited from MatrixDescriptor.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Overrides MatrixDescriptor..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Expression | Gets or sets an expression which value will be used to fill the matrix. (Inherited from MatrixDescriptor.)
Function | Gets or sets an aggregate function used to calculate totals for this cell.
Percent | Gets or sets a value that determines how to calculate the percent value for this cell.
TemplateCell | Gets or sets the template cell bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateColumn | Gets or sets the template column bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateRow | Gets or sets the template row bound to this descriptor. (Inherited from MatrixDescriptor.)

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


MatrixCellDescriptor Constructor

[image] [image]

FastReport.Net Class Reference
MatrixCellDescriptor Constructor
MatrixCellDescriptor Class See Also Send Feedback

Overload List

Name | Description
MatrixCellDescriptor()()() | Initializes a new instance of the MatrixCellDescriptor class with default settings.
MatrixCellDescriptor(String) | Initializes a new instance of the MatrixCellDescriptor class with specified expression.
MatrixCellDescriptor(String, MatrixAggregateFunction) | Initializes a new instance of the MatrixCellDescriptor class with specified expression and aggregate function.
MatrixCellDescriptor(String, MatrixAggregateFunction, MatrixPercent) | Initializes a new instance of the MatrixCellDescriptor class with specified expression, aggregate function, and a percent.

See Also

MatrixCellDescriptor Class
MatrixCellDescriptor Members
FastReport.Matrix Namespace


MatrixCellDescriptor Constructor

[image]

FastReport.Net Class Reference
MatrixCellDescriptor Constructor
MatrixCellDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixCellDescriptor class with default settings.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCellDescriptor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MatrixCellDescriptor()

See Also

MatrixCellDescriptor Class
MatrixCellDescriptor Overload
FastReport.Matrix Namespace


MatrixCellDescriptor Constructor (String)

[image]

FastReport.Net Class Reference
MatrixCellDescriptor Constructor (String)
MatrixCellDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixCellDescriptor class with specified expression.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCellDescriptor(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)
Visual C++
public:
MatrixCellDescriptor(
    String^ expression
)

Parameters

expression
Type: System..::.String
The descriptor's expression.

See Also

MatrixCellDescriptor Class
MatrixCellDescriptor Overload
FastReport.Matrix Namespace


MatrixCellDescriptor Constructor (String, MatrixAggregateFunction)

[image]

FastReport.Net Class Reference
MatrixCellDescriptor Constructor (String, MatrixAggregateFunction)
MatrixCellDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixCellDescriptor class with specified expression and aggregate function.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCellDescriptor(
    string expression,
    MatrixAggregateFunction function
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    function As MatrixAggregateFunction _
)
Visual C++
public:
MatrixCellDescriptor(
    String^ expression,
    MatrixAggregateFunction function
)

Parameters

expression
Type: System..::.String
The descriptor's expression.
function
Type: FastReport.Matrix..::.MatrixAggregateFunction
The aggregate function.

See Also

MatrixCellDescriptor Class
MatrixCellDescriptor Overload
FastReport.Matrix Namespace


MatrixCellDescriptor Constructor (String, MatrixAggregateFunction, MatrixPercent)

[image]

FastReport.Net Class Reference
MatrixCellDescriptor Constructor (String, MatrixAggregateFunction, MatrixPercent)
MatrixCellDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixCellDescriptor class with specified expression, aggregate function, and a percent.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCellDescriptor(
    string expression,
    MatrixAggregateFunction function,
    MatrixPercent percent
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    function As MatrixAggregateFunction, _
    percent As MatrixPercent _
)
Visual C++
public:
MatrixCellDescriptor(
    String^ expression,
    MatrixAggregateFunction function,
    MatrixPercent percent
)

Parameters

expression
Type: System..::.String
The descriptor's expression.
function
Type: FastReport.Matrix..::.MatrixAggregateFunction
The aggregate function.
percent
Type: FastReport.Matrix..::.MatrixPercent
The percent setting.

See Also

MatrixCellDescriptor Class
MatrixCellDescriptor Overload
FastReport.Matrix Namespace


MatrixCellDescriptor Methods

[image] [image]

FastReport.Net Class Reference
MatrixCellDescriptor Methods
MatrixCellDescriptor Class See Also Send Feedback

The MatrixCellDescriptor type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another descriptor. (Overrides MatrixDescriptor..::.Assign(MatrixDescriptor).)
Deserialize | Deserializes the object. (Inherited from MatrixDescriptor.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Overrides MatrixDescriptor..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


Assign Method

[image]

FastReport.Net Class Reference
MatrixCellDescriptor..::.Assign Method
MatrixCellDescriptor Class See Also Send Feedback
Assigns values from another descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    MatrixDescriptor source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As MatrixDescriptor _
)
Visual C++
public:
virtual void Assign(
    MatrixDescriptor^ source
) override

Parameters

source
Type: FastReport.Matrix..::.MatrixDescriptor
Descriptor to assign values from.

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MatrixCellDescriptor..::.Serialize Method
MatrixCellDescriptor Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


MatrixCellDescriptor Properties

[image] [image]

FastReport.Net Class Reference
MatrixCellDescriptor Properties
MatrixCellDescriptor Class See Also Send Feedback

The MatrixCellDescriptor type exposes the following members.

Properties

Name | Description
Expression | Gets or sets an expression which value will be used to fill the matrix. (Inherited from MatrixDescriptor.)
Function | Gets or sets an aggregate function used to calculate totals for this cell.
Percent | Gets or sets a value that determines how to calculate the percent value for this cell.
TemplateCell | Gets or sets the template cell bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateColumn | Gets or sets the template column bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateRow | Gets or sets the template row bound to this descriptor. (Inherited from MatrixDescriptor.)

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


Function Property

[image]

FastReport.Net Class Reference
MatrixCellDescriptor..::.Function Property
MatrixCellDescriptor Class See Also Send Feedback
Gets or sets an aggregate function used to calculate totals for this cell.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixAggregateFunction Function { get; set; }
Visual Basic (Declaration)
Public Property Function As MatrixAggregateFunction
Visual C++
public:
property MatrixAggregateFunction Function {
    MatrixAggregateFunction get ();
    void set (MatrixAggregateFunction value);
}

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


Percent Property

[image]

FastReport.Net Class Reference
MatrixCellDescriptor..::.Percent Property
MatrixCellDescriptor Class See Also Send Feedback
Gets or sets a value that determines how to calculate the percent value for this cell.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixPercent Percent { get; set; }
Visual Basic (Declaration)
Public Property Percent As MatrixPercent
Visual C++
public:
property MatrixPercent Percent {
    MatrixPercent get ();
    void set (MatrixPercent value);
}

See Also

MatrixCellDescriptor Class
FastReport.Matrix Namespace


MatrixCells Class

[image]

FastReport.Net Class Reference
MatrixCells Class
Members See Also Send Feedback
Represents a collection of matrix data descriptors used in the MatrixObject.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixCells : CollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class MatrixCells _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class MatrixCells : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Matrix..::.MatrixCells

See Also

MatrixCells Members
FastReport.Matrix Namespace


MatrixCells Members

[image] [image]

FastReport.Net Class Reference
MatrixCells Members
MatrixCells Class Methods Properties See Also Send Feedback

The MatrixCells type exposes the following members.

Methods

Name | Description
Add | Adds a descriptor to the end of this collection.
AddRange | Adds the specified descriptors to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a descriptor is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of a descriptor.
Insert | Inserts a descriptor into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified descriptor from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToArray | Copies the elements of this collection to a new array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

MatrixCells Class
FastReport.Matrix Namespace


MatrixCells Methods

[image] [image]

FastReport.Net Class Reference
MatrixCells Methods
MatrixCells Class See Also Send Feedback

The MatrixCells type exposes the following members.

Methods

Name | Description
Add | Adds a descriptor to the end of this collection.
AddRange | Adds the specified descriptors to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a descriptor is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of a descriptor.
Insert | Inserts a descriptor into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified descriptor from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToArray | Copies the elements of this collection to a new array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixCells Class
FastReport.Matrix Namespace


Add Method

[image]

FastReport.Net Class Reference
MatrixCells..::.Add Method
MatrixCells Class See Also Send Feedback
Adds a descriptor to the end of this collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    MatrixCellDescriptor value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As MatrixCellDescriptor _
) As Integer
Visual C++
public:
int Add(
    MatrixCellDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixCellDescriptor
Descriptor to add.

Return Value

Index of the added descriptor.

See Also

MatrixCells Class
FastReport.Matrix Namespace


AddRange Method

[image]

FastReport.Net Class Reference
MatrixCells..::.AddRange Method
MatrixCells Class See Also Send Feedback
Adds the specified descriptors to the end of this collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    MatrixCellDescriptor[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As MatrixCellDescriptor() _
)
Visual C++
public:
void AddRange(
    array<MatrixCellDescriptor^>^ range
)

Parameters

range
Type: array< FastReport.Matrix..::.MatrixCellDescriptor >[]()[]
Array of descriptors to add.

See Also

MatrixCells Class
FastReport.Matrix Namespace


Contains Method

[image]

FastReport.Net Class Reference
MatrixCells..::.Contains Method
MatrixCells Class See Also Send Feedback
Determines whether a descriptor is in the collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    MatrixCellDescriptor value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As MatrixCellDescriptor _
) As Boolean
Visual C++
public:
bool Contains(
    MatrixCellDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixCellDescriptor
The descriptor to locate in the collection.

Return Value

true if descriptor is found in the collection; otherwise, false.

See Also

MatrixCells Class
FastReport.Matrix Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
MatrixCells..::.Deserialize Method
MatrixCells Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

MatrixCells Class
FastReport.Matrix Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
MatrixCells..::.IndexOf Method
MatrixCells Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    MatrixCellDescriptor value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As MatrixCellDescriptor _
) As Integer
Visual C++
public:
int IndexOf(
    MatrixCellDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixCellDescriptor
The descriptor to locate in the collection.

Return Value

The zero-based index of the first occurrence of descriptor within the entire collection, if found; otherwise, -1.

See Also

MatrixCells Class
FastReport.Matrix Namespace


Insert Method

[image]

FastReport.Net Class Reference
MatrixCells..::.Insert Method
MatrixCells Class See Also Send Feedback
Inserts a descriptor into this collection at the specified index.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    MatrixCellDescriptor value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As MatrixCellDescriptor _
)
Visual C++
public:
void Insert(
    int index,
    MatrixCellDescriptor^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport.Matrix..::.MatrixCellDescriptor
The descriptor to insert.

See Also

MatrixCells Class
FastReport.Matrix Namespace


Remove Method

[image]

FastReport.Net Class Reference
MatrixCells..::.Remove Method
MatrixCells Class See Also Send Feedback
Removes the specified descriptor from the collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    MatrixCellDescriptor value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As MatrixCellDescriptor _
)
Visual C++
public:
void Remove(
    MatrixCellDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixCellDescriptor
Descriptor to remove.

See Also

MatrixCells Class
FastReport.Matrix Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MatrixCells..::.Serialize Method
MatrixCells Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

MatrixCells Class
FastReport.Matrix Namespace


ToArray Method

[image]

FastReport.Net Class Reference
MatrixCells..::.ToArray Method
MatrixCells Class See Also Send Feedback
Copies the elements of this collection to a new array.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCellDescriptor[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As MatrixCellDescriptor()
Visual C++
public:
array<MatrixCellDescriptor^>^ ToArray()

Return Value

An array containing copies of this collection elements.

See Also

MatrixCells Class
FastReport.Matrix Namespace


MatrixCells Properties

[image] [image]

FastReport.Net Class Reference
MatrixCells Properties
MatrixCells Class See Also Send Feedback

The MatrixCells type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

MatrixCells Class
FastReport.Matrix Namespace


Item Property

[image]

FastReport.Net Class Reference
MatrixCells..::.Item Property
MatrixCells Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCellDescriptor this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As MatrixCellDescriptor
Visual C++
public:
property MatrixCellDescriptor^ default[int index] {
    MatrixCellDescriptor^ get (int index);
    void set (int index, MatrixCellDescriptor^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

MatrixCells Class
FastReport.Matrix Namespace


MatrixData Class

[image]

FastReport.Net Class Reference
MatrixData Class
Members See Also Send Feedback
Contains a set of properties and methods to hold and manipulate the matrix descriptors.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixData
Visual Basic (Declaration)
Public Class MatrixData
Visual C++
public ref class MatrixData

Remarks

This class contains three collections of descriptors such as Columns, Rows and Cells. Use collections' methods to add/remove descriptors. When you are done, call the BuildTemplate()()() method to refresh the matrix.

To fill a matrix in code, use the AddValue method.

Inheritance Hierarchy

System..::.Object
FastReport.Matrix..::.MatrixData

See Also

MatrixData Members
FastReport.Matrix Namespace


MatrixData Members

[image] [image]

FastReport.Net Class Reference
MatrixData Members
MatrixData Class Methods Properties See Also Send Feedback

The MatrixData type exposes the following members.

Methods

Name | Description
AddValue | Overloaded.
Clear | Clears all descriptors.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cells | Gets a collection of data cell descriptors.
Columns | Gets a collection of column descriptors.
Rows | Gets a collection of row descriptors.

See Also

MatrixData Class
FastReport.Matrix Namespace


MatrixData Methods

[image] [image]

FastReport.Net Class Reference
MatrixData Methods
MatrixData Class See Also Send Feedback

The MatrixData type exposes the following members.

Methods

Name | Description
AddValue | Overloaded.
Clear | Clears all descriptors.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixData Class
FastReport.Matrix Namespace


AddValue Method

[image] [image]

FastReport.Net Class Reference
MatrixData..::.AddValue Method
MatrixData Class See Also Send Feedback

Overload List

Name | Description
AddValue(array<Object>[]()[], array<Object>[]()[], array<Object>[]()[]) | Adds a value in the matrix.
AddValue(array<Object>[]()[], array<Object>[]()[], array<Object>[]()[], Int32) | Adds a value in the matrix.

See Also

MatrixData Class
MatrixData Members
FastReport.Matrix Namespace


AddValue Method (Object[], Object[], Object[])

[image]

FastReport.Net Class Reference
MatrixData..::.AddValue Method (array<Object>[]()[], array<Object>[]()[], array<Object>[]()[])
MatrixData Class Example See Also Send Feedback
Adds a value in the matrix.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddValue(
    Object[] columnValues,
    Object[] rowValues,
    Object[] cellValues
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    columnValues As Object(), _
    rowValues As Object(), _
    cellValues As Object() _
)
Visual C++
public:
void AddValue(
    array<Object^>^ columnValues,
    array<Object^>^ rowValues,
    array<Object^>^ cellValues
)

Parameters

columnValues
Type: array< System..::.Object >[]()[]
Array of column values.
rowValues
Type: array< System..::.Object >[]()[]
Array of row values.
cellValues
Type: array< System..::.Object >[]()[]
Array of data values.

Remarks

The number of elements in an array passed to this method must be the same as a number of descriptors in the appropriate collection. That is, if your matrix has one column, two row and one cell descriptors (in Columns, Rows and Cells collections respectively), you have to pass one-element array for the columnValues param, two-element array for the rowValues and one-element array for the cellValues.

Examples

This example demonstrates how to fill a simple matrix that contains one column, row and cell.
CopyC#
MatrixObject matrix;
matrix.Data.AddValue(
  new object[] { 1996 },
  new object[] { "Andrew Fuller" },
  new object[] { 123.45f });

// this will produce the following result:
//               |   1996   |
// --------------+----------+
// Andrew Fuller |    123.45|
// --------------+----------+

See Also

MatrixData Class
AddValue Overload
FastReport.Matrix Namespace


AddValue Method (Object[], Object[], Object[], Int32)

[image]

FastReport.Net Class Reference
MatrixData..::.AddValue Method (array<Object>[]()[], array<Object>[]()[], array<Object>[]()[], Int32)
MatrixData Class See Also Send Feedback
Adds a value in the matrix.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddValue(
    Object[] columnValues,
    Object[] rowValues,
    Object[] cellValues,
    int dataRowNo
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    columnValues As Object(), _
    rowValues As Object(), _
    cellValues As Object(), _
    dataRowNo As Integer _
)
Visual C++
public:
void AddValue(
    array<Object^>^ columnValues,
    array<Object^>^ rowValues,
    array<Object^>^ cellValues,
    int dataRowNo
)

Parameters

columnValues
Type: array< System..::.Object >[]()[]
Array of column values.
rowValues
Type: array< System..::.Object >[]()[]
Array of row values.
cellValues
Type: array< System..::.Object >[]()[]
Array of data values.
dataRowNo
Type: System..::.Int32
Datasource row index.

Remarks

See the AddValue(array<Object>[]()[], array<Object>[]()[], array<Object>[]()[]) method for more details.

See Also

MatrixData Class
AddValue Overload
FastReport.Matrix Namespace


Clear Method

[image]

FastReport.Net Class Reference
MatrixData..::.Clear Method
MatrixData Class See Also Send Feedback
Clears all descriptors.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

MatrixData Class
FastReport.Matrix Namespace


MatrixData Properties

[image] [image]

FastReport.Net Class Reference
MatrixData Properties
MatrixData Class See Also Send Feedback

The MatrixData type exposes the following members.

Properties

Name | Description
Cells | Gets a collection of data cell descriptors.
Columns | Gets a collection of column descriptors.
Rows | Gets a collection of row descriptors.

See Also

MatrixData Class
FastReport.Matrix Namespace


Cells Property

[image]

FastReport.Net Class Reference
MatrixData..::.Cells Property
MatrixData Class See Also Send Feedback
Gets a collection of data cell descriptors.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixCells Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As MatrixCells
Visual C++
public:
property MatrixCells^ Cells {
    MatrixCells^ get ();
}

Remarks

Note: after you change something in this collection, call the BuildTemplate()()() method to refresh the matrix.

See Also

MatrixData Class
FastReport.Matrix Namespace


Columns Property

[image]

FastReport.Net Class Reference
MatrixData..::.Columns Property
MatrixData Class See Also Send Feedback
Gets a collection of column descriptors.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeader Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As MatrixHeader
Visual C++
public:
property MatrixHeader^ Columns {
    MatrixHeader^ get ();
}

Remarks

Note: after you change something in this collection, call the BuildTemplate()()() method to refresh the matrix.

See Also

MatrixData Class
FastReport.Matrix Namespace


Rows Property

[image]

FastReport.Net Class Reference
MatrixData..::.Rows Property
MatrixData Class See Also Send Feedback
Gets a collection of row descriptors.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeader Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As MatrixHeader
Visual C++
public:
property MatrixHeader^ Rows {
    MatrixHeader^ get ();
}

Remarks

Note: after you change something in this collection, call the BuildTemplate()()() method to refresh the matrix.

See Also

MatrixData Class
FastReport.Matrix Namespace


MatrixDescriptor Class

[image]

FastReport.Net Class Reference
MatrixDescriptor Class
Members See Also Send Feedback
The base class for matrix element descriptors such as MatrixHeaderDescriptor and MatrixCellDescriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixDescriptor : IFRSerializable
Visual Basic (Declaration)
Public Class MatrixDescriptor _
    Implements IFRSerializable
Visual C++
public ref class MatrixDescriptor : IFRSerializable

Inheritance Hierarchy

System..::.Object
FastReport.Matrix..::.MatrixDescriptor
FastReport.Matrix..::.MatrixCellDescriptor
FastReport.Matrix..::.MatrixHeaderDescriptor

See Also

MatrixDescriptor Members
FastReport.Matrix Namespace


MatrixDescriptor Members

[image] [image]

FastReport.Net Class Reference
MatrixDescriptor Members
MatrixDescriptor Class Constructors Methods Properties See Also Send Feedback

The MatrixDescriptor type exposes the following members.

Constructors

Name | Description
MatrixDescriptor | Initializes a new instance of the MatrixDescriptor class

Methods

Name | Description
Assign | Assigns values from another descriptor.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Expression | Gets or sets an expression which value will be used to fill the matrix.
TemplateCell | Gets or sets the template cell bound to this descriptor.
TemplateColumn | Gets or sets the template column bound to this descriptor.
TemplateRow | Gets or sets the template row bound to this descriptor.

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


MatrixDescriptor Constructor

[image]

FastReport.Net Class Reference
MatrixDescriptor Constructor
MatrixDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixDescriptor class

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixDescriptor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MatrixDescriptor()

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


MatrixDescriptor Methods

[image] [image]

FastReport.Net Class Reference
MatrixDescriptor Methods
MatrixDescriptor Class See Also Send Feedback

The MatrixDescriptor type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another descriptor.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


Assign Method

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.Assign Method
MatrixDescriptor Class See Also Send Feedback
Assigns values from another descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Assign(
    MatrixDescriptor source
)
Visual Basic (Declaration)
Public Overridable Sub Assign ( _
    source As MatrixDescriptor _
)
Visual C++
public:
virtual void Assign(
    MatrixDescriptor^ source
)

Parameters

source
Type: FastReport.Matrix..::.MatrixDescriptor
Descriptor to assign values from.

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.Deserialize Method
MatrixDescriptor Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.Serialize Method
MatrixDescriptor Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overridable Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
)

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


MatrixDescriptor Properties

[image] [image]

FastReport.Net Class Reference
MatrixDescriptor Properties
MatrixDescriptor Class See Also Send Feedback

The MatrixDescriptor type exposes the following members.

Properties

Name | Description
Expression | Gets or sets an expression which value will be used to fill the matrix.
TemplateCell | Gets or sets the template cell bound to this descriptor.
TemplateColumn | Gets or sets the template column bound to this descriptor.
TemplateRow | Gets or sets the template row bound to this descriptor.

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


Expression Property

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.Expression Property
MatrixDescriptor Class See Also Send Feedback
Gets or sets an expression which value will be used to fill the matrix.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Remarks

Expression may be any valid expression. Usually it's a data column: [DataSource.Column].

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


TemplateCell Property

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.TemplateCell Property
MatrixDescriptor Class Example See Also Send Feedback
Gets or sets the template cell bound to this descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCell TemplateCell { get; set; }
Visual Basic (Declaration)
Public Property TemplateCell As TableCell
Visual C++
public:
property TableCell^ TemplateCell {
    TableCell^ get ();
    void set (TableCell^ value);
}

Remarks

Using this property, you may access the matrix cell which is bound to this descriptor. It may be useful to change the cell's appearance.
Note: Before using this property, you must initialize the matrix descriptors by calling the BuildTemplate()()() method.

Examples

CopyC#
MatrixObject matrix;
// change the fill color of the first matrix cell
matrix.Data.Cells[0].TemplateCell.Fill = new SolidFill(Color.Red);

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


TemplateColumn Property

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.TemplateColumn Property
MatrixDescriptor Class See Also Send Feedback
Gets or sets the template column bound to this descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableColumn TemplateColumn { get; set; }
Visual Basic (Declaration)
Public Property TemplateColumn As TableColumn
Visual C++
public:
property TableColumn^ TemplateColumn {
    TableColumn^ get ();
    void set (TableColumn^ value);
}

Remarks

This property is for internal use; usually you don't need to use it.

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


TemplateRow Property

[image]

FastReport.Net Class Reference
MatrixDescriptor..::.TemplateRow Property
MatrixDescriptor Class See Also Send Feedback
Gets or sets the template row bound to this descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableRow TemplateRow { get; set; }
Visual Basic (Declaration)
Public Property TemplateRow As TableRow
Visual C++
public:
property TableRow^ TemplateRow {
    TableRow^ get ();
    void set (TableRow^ value);
}

Remarks

This property is for internal use; usually you don't need to use it.

See Also

MatrixDescriptor Class
FastReport.Matrix Namespace


MatrixEvenStylePriority Enumeration

[image]

FastReport.Net Class Reference
MatrixEvenStylePriority Enumeration
See Also Send Feedback
Describes how the even style is applied to a matrix.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum MatrixEvenStylePriority
Visual Basic (Declaration)
Public Enumeration MatrixEvenStylePriority
Visual C++
public enum class MatrixEvenStylePriority

Members

Member name | Description
Rows | The even style is applied to matrix rows.
Columns | The even style is applied to matrix columns.

See Also

FastReport.Matrix Namespace


MatrixHeader Class

[image]

FastReport.Net Class Reference
MatrixHeader Class
Members See Also Send Feedback
Represents a collection of matrix header descriptors used in the MatrixObject.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixHeader : CollectionBase,
    IFRSerializable
Visual Basic (Declaration)
Public Class MatrixHeader _
    Inherits CollectionBase _
    Implements IFRSerializable
Visual C++
public ref class MatrixHeader : public CollectionBase,
    IFRSerializable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Matrix..::.MatrixHeader

See Also

MatrixHeader Members
FastReport.Matrix Namespace


MatrixHeader Members

[image] [image]

FastReport.Net Class Reference
MatrixHeader Members
MatrixHeader Class Methods Properties See Also Send Feedback

The MatrixHeader type exposes the following members.

Methods

Name | Description
Add | Adds a descriptor to the end of this collection.
AddRange | Adds the specified descriptors to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a descriptor is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of a descriptor.
Insert | Inserts a descriptor into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified descriptor from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToArray | Copies the elements of this collection to a new array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

MatrixHeader Class
FastReport.Matrix Namespace


MatrixHeader Methods

[image] [image]

FastReport.Net Class Reference
MatrixHeader Methods
MatrixHeader Class See Also Send Feedback

The MatrixHeader type exposes the following members.

Methods

Name | Description
Add | Adds a descriptor to the end of this collection.
AddRange | Adds the specified descriptors to the end of this collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a descriptor is in the collection.
Deserialize | Deserializes the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of a descriptor.
Insert | Inserts a descriptor into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified descriptor from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Serialize | Serializes the object.
ToArray | Copies the elements of this collection to a new array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Add Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.Add Method
MatrixHeader Class See Also Send Feedback
Adds a descriptor to the end of this collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    MatrixHeaderDescriptor value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As MatrixHeaderDescriptor _
) As Integer
Visual C++
public:
int Add(
    MatrixHeaderDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixHeaderDescriptor
Descriptor to add.

Return Value

Index of the added descriptor.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


AddRange Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.AddRange Method
MatrixHeader Class See Also Send Feedback
Adds the specified descriptors to the end of this collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    MatrixHeaderDescriptor[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As MatrixHeaderDescriptor() _
)
Visual C++
public:
void AddRange(
    array<MatrixHeaderDescriptor^>^ range
)

Parameters

range
Type: array< FastReport.Matrix..::.MatrixHeaderDescriptor >[]()[]
Array of descriptors to add.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Contains Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.Contains Method
MatrixHeader Class See Also Send Feedback
Determines whether a descriptor is in the collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    MatrixHeaderDescriptor value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As MatrixHeaderDescriptor _
) As Boolean
Visual C++
public:
bool Contains(
    MatrixHeaderDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixHeaderDescriptor
The descriptor to locate in the collection.

Return Value

true if descriptor is found in the collection; otherwise, false.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.Deserialize Method
MatrixHeader Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) sealed

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

See Also

MatrixHeader Class
FastReport.Matrix Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.IndexOf Method
MatrixHeader Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    MatrixHeaderDescriptor value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As MatrixHeaderDescriptor _
) As Integer
Visual C++
public:
int IndexOf(
    MatrixHeaderDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixHeaderDescriptor
The descriptor to locate in the collection.

Return Value

The zero-based index of the first occurrence of descriptor within the entire collection, if found; otherwise, -1.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Insert Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.Insert Method
MatrixHeader Class See Also Send Feedback
Inserts a descriptor into this collection at the specified index.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    MatrixHeaderDescriptor value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As MatrixHeaderDescriptor _
)
Visual C++
public:
void Insert(
    int index,
    MatrixHeaderDescriptor^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport.Matrix..::.MatrixHeaderDescriptor
The descriptor to insert.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Remove Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.Remove Method
MatrixHeader Class See Also Send Feedback
Removes the specified descriptor from the collection.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    MatrixHeaderDescriptor value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As MatrixHeaderDescriptor _
)
Visual C++
public:
void Remove(
    MatrixHeaderDescriptor^ value
)

Parameters

value
Type: FastReport.Matrix..::.MatrixHeaderDescriptor
Descriptor to remove.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.Serialize Method
MatrixHeader Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) sealed

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

MatrixHeader Class
FastReport.Matrix Namespace


ToArray Method

[image]

FastReport.Net Class Reference
MatrixHeader..::.ToArray Method
MatrixHeader Class See Also Send Feedback
Copies the elements of this collection to a new array.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeaderDescriptor[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As MatrixHeaderDescriptor()
Visual C++
public:
array<MatrixHeaderDescriptor^>^ ToArray()

Return Value

An array containing copies of this collection elements.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


MatrixHeader Properties

[image] [image]

FastReport.Net Class Reference
MatrixHeader Properties
MatrixHeader Class See Also Send Feedback

The MatrixHeader type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

MatrixHeader Class
FastReport.Matrix Namespace


Item Property

[image]

FastReport.Net Class Reference
MatrixHeader..::.Item Property
MatrixHeader Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeaderDescriptor this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As MatrixHeaderDescriptor
Visual C++
public:
property MatrixHeaderDescriptor^ default[int index] {
    MatrixHeaderDescriptor^ get (int index);
    void set (int index, MatrixHeaderDescriptor^ value);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

MatrixHeader Class
FastReport.Matrix Namespace


MatrixHeaderDescriptor Class

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Class
Members See Also Send Feedback
The descriptor that is used to describe one element of the matrix header.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixHeaderDescriptor : MatrixDescriptor
Visual Basic (Declaration)
Public Class MatrixHeaderDescriptor _
    Inherits MatrixDescriptor
Visual C++
public ref class MatrixHeaderDescriptor : public MatrixDescriptor

Remarks

The MatrixHeaderDescriptor class is used to define one header element of the matrix (either the column element or row element). The key properties are Expression, Sort and Totals.

To set visual appearance of the element, use the TemplateCell property. To set visual appearance of the "total" element, use the TemplateTotalCell property.

The collection of descriptors used to represent the matrix header is stored in the MatrixObject.Data.Columns and MatrixObject.Data.Rows properties.

Inheritance Hierarchy

System..::.Object
FastReport.Matrix..::.MatrixDescriptor
FastReport.Matrix..::.MatrixHeaderDescriptor

See Also

MatrixHeaderDescriptor Members
FastReport.Matrix Namespace


MatrixHeaderDescriptor Members

[image] [image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Members
MatrixHeaderDescriptor Class Constructors Methods Properties See Also Send Feedback

The MatrixHeaderDescriptor type exposes the following members.

Constructors

Name | Description
MatrixHeaderDescriptor | Overloaded.

Methods

Name | Description
Assign | Assigns values from another descriptor. (Overrides MatrixDescriptor..::.Assign(MatrixDescriptor).)
Deserialize | Deserializes the object. (Inherited from MatrixDescriptor.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Overrides MatrixDescriptor..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Expression | Gets or sets an expression which value will be used to fill the matrix. (Inherited from MatrixDescriptor.)
PageBreak | Gets or sets a value indicating that the page break must be printed before this element.
Sort | Gets or sets the sort order of header values.
SuppressTotals | Gets or sets a value that determines whether it is necessary to suppress totals if there is only one value in a group.
TemplateCell | Gets or sets the template cell bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateColumn | Gets or sets the template column bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateRow | Gets or sets the template row bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateTotalCell | Gets or sets the template cell bound to the "total" element of this descriptor.
TemplateTotalColumn | Gets or sets the template column bound to the "total" element of this descriptor.
TemplateTotalRow | Gets or sets the template row bound to the "total" element of this descriptor.
Totals | Gets or sets a value indicating that this element has associated "total" element.
TotalsFirst | Gets or sets the value indicating whether the total values must be printed before the data.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


MatrixHeaderDescriptor Constructor

[image] [image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Constructor
MatrixHeaderDescriptor Class See Also Send Feedback

Overload List

Name | Description
MatrixHeaderDescriptor()()() | Initializes a new instance of the MatrixHeaderDescriptor class with default settings.
MatrixHeaderDescriptor(String) | Initializes a new instance of the MatrixHeaderDescriptor class with specified expression.
MatrixHeaderDescriptor(String, Boolean) | Initializes a new instance of the MatrixHeaderDescriptor class with specified expression and totals.
MatrixHeaderDescriptor(String, SortOrder, Boolean) | Initializes a new instance of the MatrixHeaderDescriptor class with specified expression, sort order and totals.

See Also

MatrixHeaderDescriptor Class
MatrixHeaderDescriptor Members
FastReport.Matrix Namespace


MatrixHeaderDescriptor Constructor

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Constructor
MatrixHeaderDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixHeaderDescriptor class with default settings.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeaderDescriptor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MatrixHeaderDescriptor()

See Also

MatrixHeaderDescriptor Class
MatrixHeaderDescriptor Overload
FastReport.Matrix Namespace


MatrixHeaderDescriptor Constructor (String)

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Constructor (String)
MatrixHeaderDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixHeaderDescriptor class with specified expression.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeaderDescriptor(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)
Visual C++
public:
MatrixHeaderDescriptor(
    String^ expression
)

Parameters

expression
Type: System..::.String
The descriptor's expression.

See Also

MatrixHeaderDescriptor Class
MatrixHeaderDescriptor Overload
FastReport.Matrix Namespace


MatrixHeaderDescriptor Constructor (String, Boolean)

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Constructor (String, Boolean)
MatrixHeaderDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixHeaderDescriptor class with specified expression and totals.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeaderDescriptor(
    string expression,
    bool totals
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    totals As Boolean _
)
Visual C++
public:
MatrixHeaderDescriptor(
    String^ expression,
    bool totals
)

Parameters

expression
Type: System..::.String
The descriptor's expression.
totals
Type: System..::.Boolean
Indicates whether to show the "total" element.

See Also

MatrixHeaderDescriptor Class
MatrixHeaderDescriptor Overload
FastReport.Matrix Namespace


MatrixHeaderDescriptor Constructor (String, SortOrder, Boolean)

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Constructor (String, SortOrder, Boolean)
MatrixHeaderDescriptor Class See Also Send Feedback
Initializes a new instance of the MatrixHeaderDescriptor class with specified expression, sort order and totals.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixHeaderDescriptor(
    string expression,
    SortOrder sort,
    bool totals
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    sort As SortOrder, _
    totals As Boolean _
)
Visual C++
public:
MatrixHeaderDescriptor(
    String^ expression,
    SortOrder sort,
    bool totals
)

Parameters

expression
Type: System..::.String
The descriptor's expression.
sort
Type: FastReport..::.SortOrder
Sort order used to sort header values.
totals
Type: System..::.Boolean
Indicates whether to show the "total" element.

See Also

MatrixHeaderDescriptor Class
MatrixHeaderDescriptor Overload
FastReport.Matrix Namespace


MatrixHeaderDescriptor Methods

[image] [image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Methods
MatrixHeaderDescriptor Class See Also Send Feedback

The MatrixHeaderDescriptor type exposes the following members.

Methods

Name | Description
Assign | Assigns values from another descriptor. (Overrides MatrixDescriptor..::.Assign(MatrixDescriptor).)
Deserialize | Deserializes the object. (Inherited from MatrixDescriptor.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the object. (Overrides MatrixDescriptor..::.Serialize(FRWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


Assign Method

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.Assign Method
MatrixHeaderDescriptor Class See Also Send Feedback
Assigns values from another descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    MatrixDescriptor source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As MatrixDescriptor _
)
Visual C++
public:
virtual void Assign(
    MatrixDescriptor^ source
) override

Parameters

source
Type: FastReport.Matrix..::.MatrixDescriptor
Descriptor to assign values from.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.Serialize Method
MatrixHeaderDescriptor Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


MatrixHeaderDescriptor Properties

[image] [image]

FastReport.Net Class Reference
MatrixHeaderDescriptor Properties
MatrixHeaderDescriptor Class See Also Send Feedback

The MatrixHeaderDescriptor type exposes the following members.

Properties

Name | Description
Expression | Gets or sets an expression which value will be used to fill the matrix. (Inherited from MatrixDescriptor.)
PageBreak | Gets or sets a value indicating that the page break must be printed before this element.
Sort | Gets or sets the sort order of header values.
SuppressTotals | Gets or sets a value that determines whether it is necessary to suppress totals if there is only one value in a group.
TemplateCell | Gets or sets the template cell bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateColumn | Gets or sets the template column bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateRow | Gets or sets the template row bound to this descriptor. (Inherited from MatrixDescriptor.)
TemplateTotalCell | Gets or sets the template cell bound to the "total" element of this descriptor.
TemplateTotalColumn | Gets or sets the template column bound to the "total" element of this descriptor.
TemplateTotalRow | Gets or sets the template row bound to the "total" element of this descriptor.
Totals | Gets or sets a value indicating that this element has associated "total" element.
TotalsFirst | Gets or sets the value indicating whether the total values must be printed before the data.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


PageBreak Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.PageBreak Property
MatrixHeaderDescriptor Class See Also Send Feedback
Gets or sets a value indicating that the page break must be printed before this element.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreak { get; set; }
Visual Basic (Declaration)
Public Property PageBreak As Boolean
Visual C++
public:
property bool PageBreak {
    bool get ();
    void set (bool value);
}

Remarks

Page break is not printed before the very first element.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


Sort Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.Sort Property
MatrixHeaderDescriptor Class See Also Send Feedback
Gets or sets the sort order of header values.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SortOrder Sort { get; set; }
Visual Basic (Declaration)
Public Property Sort As SortOrder
Visual C++
public:
property SortOrder Sort {
    SortOrder get ();
    void set (SortOrder value);
}

Remarks

This property determines how the values displayed in this element are sorted. The default sort is ascending.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


SuppressTotals Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.SuppressTotals Property
MatrixHeaderDescriptor Class See Also Send Feedback
Gets or sets a value that determines whether it is necessary to suppress totals if there is only one value in a group.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SuppressTotals { get; set; }
Visual Basic (Declaration)
Public Property SuppressTotals As Boolean
Visual C++
public:
property bool SuppressTotals {
    bool get ();
    void set (bool value);
}

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


TemplateTotalCell Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.TemplateTotalCell Property
MatrixHeaderDescriptor Class Example See Also Send Feedback
Gets or sets the template cell bound to the "total" element of this descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCell TemplateTotalCell { get; set; }
Visual Basic (Declaration)
Public Property TemplateTotalCell As TableCell
Visual C++
public:
property TableCell^ TemplateTotalCell {
    TableCell^ get ();
    void set (TableCell^ value);
}

Remarks

This property may be useful to change the "Total" text by something else.
Note: Before using this property, you must initialize the matrix descriptors by calling the BuildTemplate()()() method.

Examples

This example shows how to change the "Total" element.
CopyC#
MatrixObject matrix;
matrix.Data.Rows[0].TemplateTotalCell.Text = "Grand Total";
matrix.Data.Rows[0].TemplateTotalCell.Fill = new SolidFill(Color.Green);

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


TemplateTotalColumn Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.TemplateTotalColumn Property
MatrixHeaderDescriptor Class See Also Send Feedback
Gets or sets the template column bound to the "total" element of this descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableColumn TemplateTotalColumn { get; set; }
Visual Basic (Declaration)
Public Property TemplateTotalColumn As TableColumn
Visual C++
public:
property TableColumn^ TemplateTotalColumn {
    TableColumn^ get ();
    void set (TableColumn^ value);
}

Remarks

This property is for internal use; usually you don't need to use it.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


TemplateTotalRow Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.TemplateTotalRow Property
MatrixHeaderDescriptor Class See Also Send Feedback
Gets or sets the template row bound to the "total" element of this descriptor.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableRow TemplateTotalRow { get; set; }
Visual Basic (Declaration)
Public Property TemplateTotalRow As TableRow
Visual C++
public:
property TableRow^ TemplateTotalRow {
    TableRow^ get ();
    void set (TableRow^ value);
}

Remarks

This property is for internal use; usually you don't need to use it.

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


Totals Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.Totals Property
MatrixHeaderDescriptor Class Example See Also Send Feedback
Gets or sets a value indicating that this element has associated "total" element.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Totals { get; set; }
Visual Basic (Declaration)
Public Property Totals As Boolean
Visual C++
public:
property bool Totals {
    bool get ();
    void set (bool value);
}

Remarks

To access the matrix cell that is bound to the "Total" element, use the TemplateTotalCell property. It may be useful to change the "Total" text by something else.

Examples

This example shows how to change the "Total" text of the total element.
CopyC#
MatrixObject matrix;
matrix.Data.Rows[0].TemplateTotalCell.Text = "Grand Total";

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


TotalsFirst Property

[image]

FastReport.Net Class Reference
MatrixHeaderDescriptor..::.TotalsFirst Property
MatrixHeaderDescriptor Class See Also Send Feedback
Gets or sets the value indicating whether the total values must be printed before the data.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool TotalsFirst { get; set; }
Visual Basic (Declaration)
Public Property TotalsFirst As Boolean
Visual C++
public:
property bool TotalsFirst {
    bool get ();
    void set (bool value);
}

See Also

MatrixHeaderDescriptor Class
FastReport.Matrix Namespace


MatrixObject Class

[image]

FastReport.Net Class Reference
MatrixObject Class
Members Example See Also Send Feedback
Represents the matrix object that is used to print pivot table (also known as cross-tab).

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixObject : TableBase
Visual Basic (Declaration)
Public Class MatrixObject _
    Inherits TableBase
Visual C++
public ref class MatrixObject : public TableBase

Remarks

The matrix consists of the following elements: columns, rows and data cells. Each element is represented by the descriptor. The MatrixHeaderDescriptor class is used for columns and rows; the MatrixCellDescriptor is used for data cells. The Data property holds three collections of descriptors - Columns, Rows and Cells.

To create the matrix in a code, you should perform the following actions:

  • create an instance of the MatrixObject and add it to the report;
  • create descriptors for columns, rows and cells and add it to the collections inside the Data property;
  • call the BuildTemplate()()() method to create the matrix template that will be used to create a result;
  • modify the matrix template (change captions, set the visual appearance).

To connect the matrix to a datasource, use the DataSource property. If this property is not set, the result matrix will be empty. In this case you may use the ManualBuild event handler to fill the matrix.

Examples

This example demonstrates how to create a matrix in a code.
CopyC#
// create an instance of MatrixObject
MatrixObject matrix = new MatrixObject();
matrix.Name = "Matrix1";
// add it to the report title band of the first report page
matrix.Parent = (report.Pages[0] as ReportPage).ReportTitle;

// create two column descriptors
MatrixHeaderDescriptor column = new MatrixHeaderDescriptor("[MatrixDemo.Year]");
matrix.Data.Columns.Add(column);
column = new MatrixHeaderDescriptor("[MatrixDemo.Month]");
matrix.Data.Columns.Add(column);

// create one row descriptor
MatrixHeaderDescriptor row = new MatrixHeaderDescriptor("[MatrixDemo.Name]");
matrix.Data.Rows.Add(row);

// create one data cell
MatrixCellDescriptor cell = new MatrixCellDescriptor("[MatrixDemo.Revenue]", MatrixAggregateFunction.Sum);
matrix.Data.Cells.Add(cell);

// connect matrix to a datasource
matrix.DataSource = Report.GetDataSource("MatrixDemo");

// create the matrix template
matrix.BuildTemplate();

// change the style
matrix.Style = "Green";

// change the column and row total's text to "Grand Total"
matrix.Data.Columns[0].TemplateTotalCell.Text = "Grand Total";
matrix.Data.Rows[0].TemplateTotalCell.Text = "Grand Total";

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport.Table..::.TableBase
FastReport.Matrix..::.MatrixObject

See Also

MatrixObject Members
FastReport.Matrix Namespace


MatrixObject Members

[image] [image]

FastReport.Net Class Reference
MatrixObject Members
MatrixObject Class Constructors Methods Properties Events See Also Send Feedback

The MatrixObject type exposes the following members.

Constructors

Name | Description
MatrixObject | Initializes a new instance of the MatrixObject class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from TableBase.)
AddValue | Adds a value in the matrix.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides TableBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell. (Inherited from TableBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TableBase.)
BuildTemplate | Creates or updates the matrix template.
CalcHeight | Calculates the object's height. (Inherited from TableBase.)
CalcWidth | Calculates and returns the table width, in pixels. (Inherited from TableBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from TableBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell. (Inherited from TableBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells. (Inherited from TableBase.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Overrides TableBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from TableBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from TableBase.)
GetContextMenu | Gets the object's context menu. (Overrides TableBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Overrides TableBase..::.HandleKeyDown(Control, KeyEventArgs).)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides TableBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides TableBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides TableBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from TableBase.)
Max | Calculates a maximum of values in a specified cell. (Inherited from TableBase.)
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell. (Inherited from TableBase.)
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from TableBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides TableBase..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnManualBuild | This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.
OnModifyResult | This method fires the ModifyResult event and the script code connected to the ModifyResultEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from TableBase.)
RestoreState | Restores the object's state after printing it. (Overrides TableBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides TableBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides TableBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from TableBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell. (Inherited from TableBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from TableBase.)
Value | Gets the value of the data cell with the specified index.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages. (Inherited from TableBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
AutoSize | Gets or sets a value that determines whether the matrix must calculate column/row sizes automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from TableBase.)
CanBreak | This property is not relevant to this class.
CanGrow | This property is not relevant to this class. (Inherited from TableBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class. (Inherited from TableBase.)
CellsSideBySide | Gets or sets a value that determines how to print multiple data cells.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | This property is not relevant to this class. (Overrides TableBase..::.ColumnCount.)
ColumnIndex | Gets or sets the index of currently printing column.
Columns | Gets a collection of table columns. (Inherited from TableBase.)
ColumnValues | Gets or sets array of values that describes the currently printing column.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
Data | Gets the object that holds the collection of descriptors used to build a matrix.
DataSource | Gets or sets a data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
Filter | Gets the row filter expression.
FixedColumns | This property is not relevant to this class.
FixedRows | This property is not relevant to this class.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class.
Height | Gets or sets the height of the object. (Inherited from TableBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class. (Inherited from TableBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from TableBase.)
Item | Gets or sets the table cell. (Inherited from TableBase.)
KeepCellsSideBySide | Gets or sets a value indicating that the side-by-side cells must be kept together on the same page.
Layout | Gets or sets the table layout. (Inherited from TableBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
ManualBuildEvent | Gets or sets a script method name that will be used to handle the ManualBuild event.
MatrixEvenStylePriority | Gets or sets even style priority for matrix cells.
ModifyResultEvent | Gets or sets a script method name that will be used to handle the ModifyResult event.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page. (Inherited from TableBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table. (Inherited from TableBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | This property is not relevant to this class. (Overrides TableBase..::.RowCount.)
RowIndex | Gets or sets the index of currently printing row.
Rows | Gets a collection of table rows. (Inherited from TableBase.)
RowValues | Gets or sets array of values that describes the currently printing row.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShowTitle | Gets or sets a value indicating whether to show a title row.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets a matrix style.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TableBase.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode. (Inherited from TableBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
ManualBuild | Allows to fill the matrix in code.
ModifyResult | Allows to modify the prepared matrix elements such as cells, rows, columns.
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

MatrixObject Class
FastReport.Matrix Namespace


MatrixObject Constructor

[image]

FastReport.Net Class Reference
MatrixObject Constructor
MatrixObject Class See Also Send Feedback
Initializes a new instance of the MatrixObject class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MatrixObject()

See Also

MatrixObject Class
FastReport.Matrix Namespace


MatrixObject Methods

[image] [image]

FastReport.Net Class Reference
MatrixObject Methods
MatrixObject Class See Also Send Feedback

The MatrixObject type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from TableBase.)
AddValue | Adds a value in the matrix.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides TableBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell. (Inherited from TableBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TableBase.)
BuildTemplate | Creates or updates the matrix template.
CalcHeight | Calculates the object's height. (Inherited from TableBase.)
CalcWidth | Calculates and returns the table width, in pixels. (Inherited from TableBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from TableBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell. (Inherited from TableBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells. (Inherited from TableBase.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Overrides Base..::.DeserializeSubItems(FRReader).)
Dispose | Overloaded.
Draw | Draws the object. (Overrides TableBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from TableBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from TableBase.)
GetContextMenu | Gets the object's context menu. (Overrides TableBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Overrides TableBase..::.HandleKeyDown(Control, KeyEventArgs).)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides TableBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides TableBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides TableBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from TableBase.)
Max | Calculates a maximum of values in a specified cell. (Inherited from TableBase.)
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell. (Inherited from TableBase.)
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from TableBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides TableBase..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnManualBuild | This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.
OnModifyResult | This method fires the ModifyResult event and the script code connected to the ModifyResultEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from TableBase.)
RestoreState | Restores the object's state after printing it. (Overrides TableBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides TableBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides TableBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from TableBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell. (Inherited from TableBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from TableBase.)
Value | Gets the value of the data cell with the specified index.

See Also

MatrixObject Class
FastReport.Matrix Namespace


AddValue Method

[image]

FastReport.Net Class Reference
MatrixObject..::.AddValue Method
MatrixObject Class See Also Send Feedback
Adds a value in the matrix.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddValue(
    Object[] columnValues,
    Object[] rowValues,
    Object[] cellValues
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    columnValues As Object(), _
    rowValues As Object(), _
    cellValues As Object() _
)
Visual C++
public:
void AddValue(
    array<Object^>^ columnValues,
    array<Object^>^ rowValues,
    array<Object^>^ cellValues
)

Parameters

columnValues
Type: array< System..::.Object >[]()[]
Array of column values.
rowValues
Type: array< System..::.Object >[]()[]
Array of row values.
cellValues
Type: array< System..::.Object >[]()[]
Array of data values.

Remarks

This is a shortcut method to call the matrix Data.AddValue. See the AddValue(array<Object>[]()[], array<Object>[]()[], array<Object>[]()[]) method for more details.

See Also

MatrixObject Class
FastReport.Matrix Namespace


Assign Method

[image]

FastReport.Net Class Reference
MatrixObject..::.Assign Method
MatrixObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

MatrixObject Class
FastReport.Matrix Namespace
AssignAll Method


BuildTemplate Method

[image]

FastReport.Net Class Reference
MatrixObject..::.BuildTemplate Method
MatrixObject Class See Also Send Feedback
Creates or updates the matrix template.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void BuildTemplate()
Visual Basic (Declaration)
Public Sub BuildTemplate
Visual C++
public:
void BuildTemplate()

Remarks

Call this method after you modify the matrix descriptors using the Data object's properties.

See Also

MatrixObject Class
FastReport.Matrix Namespace


DeserializeSubItems Method

[image]

FastReport.Net Class Reference
MatrixObject..::.DeserializeSubItems Method
MatrixObject Class Example See Also Send Feedback
Deserializes nested object properties.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void DeserializeSubItems(
    FRReader reader
)
Visual Basic (Declaration)
Protected Overrides Sub DeserializeSubItems ( _
    reader As FRReader _
)
Visual C++
protected:
virtual void DeserializeSubItems(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Remarks

Typically the object serializes all properties to the single xml item:

CopyC#
<TextObject Name="Text2" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>

Some objects like DataBand have child objects that serialized in subitems:

CopyC#
<DataBand Name="Data1" Top="163" Width="718.2" Height="18.9">
  <TextObject Name="Text3" Left="18.9" Top="37.8" Width="283.5" Height="28.35"/>
</DataBand>

To read such subitems, the DeserializeSubItems method is used. Base implementation reads the child objects. You may override it to read some specific subitems.

Examples

The following code is used to read report's styles:
CopyC#
protected override void DeserializeSubItems(FRReader reader)
{
  if (String.Compare(reader.ItemName, "Styles", true) == 0)
    reader.Read(Styles);
  else
    base.DeserializeSubItems(reader);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MatrixObject..::.Dispose Method
MatrixObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

MatrixObject Class
MatrixObject Members
FastReport.Matrix Namespace


Draw Method

[image]

FastReport.Net Class Reference
MatrixObject..::.Draw Method
MatrixObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

MatrixObject Class
FastReport.Matrix Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
MatrixObject..::.DrawMarkers Method
MatrixObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

MatrixObject Class
MatrixObject Members
FastReport.Matrix Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
MatrixObject..::.FinalizeComponent Method
MatrixObject Class See Also Send Feedback
Performs a finalization after the report is finished.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FinalizeComponent()
Visual Basic (Declaration)
Public Overrides Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

MatrixObject Class
FastReport.Matrix Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
MatrixObject..::.GetContextMenu Method
MatrixObject Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

MatrixObject Class
FastReport.Matrix Namespace


GetData Method

[image]

FastReport.Net Class Reference
MatrixObject..::.GetData Method
MatrixObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

MatrixObject Class
FastReport.Matrix Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
MatrixObject..::.GetExpressions Method
MatrixObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

MatrixObject Class
FastReport.Matrix Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
MatrixObject..::.GetSelectionPoints Method
MatrixObject Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

MatrixObject Class
FastReport.Matrix Namespace


HandleDragDrop Method

[image]

FastReport.Net Class Reference
MatrixObject..::.HandleDragDrop Method
MatrixObject Class See Also Send Feedback
Handles the DragDrop event in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragDrop(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragDrop ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragDrop(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drops an item from the Data Tree window into this object. This method should copy the information from the e.DraggedObject object and set the e.Handled flag to true to complete the drag operation.

See Also

MatrixObject Class
FastReport.Matrix Namespace


HandleDragOver Method

[image]

FastReport.Net Class Reference
MatrixObject..::.HandleDragOver Method
MatrixObject Class See Also Send Feedback
Handles the DragOver event in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragOver(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragOver ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragOver(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drags an item from the Data Tree window. This method should check that the mouse (e.X, e.Y) is inside the object, then set the e.Handled flag to true if an item can be dragged into this object.

See Also

MatrixObject Class
FastReport.Matrix Namespace


HandleKeyDown Method

[image]

FastReport.Net Class Reference
MatrixObject..::.HandleKeyDown Method
MatrixObject Class See Also Send Feedback
Handles KeyDown event in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleKeyDown(
    Control sender,
    KeyEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleKeyDown ( _
    sender As Control, _
    e As KeyEventArgs _
)
Visual C++
public:
virtual void HandleKeyDown(
    Control^ sender,
    KeyEventArgs^ e
) override

Parameters

sender
Type: System.Windows.Forms..::.Control
The designer's workspace.
e
Type: System.Windows.Forms..::.KeyEventArgs
Keyboard event parameters.

Remarks

This method is called when the user presses any key in the designer. Typical implementation does nothing.

See Also

MatrixObject Class
FastReport.Matrix Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
MatrixObject..::.HandleMouseDown Method
MatrixObject Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

MatrixObject Class
FastReport.Matrix Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
MatrixObject..::.HandleMouseMove Method
MatrixObject Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

MatrixObject Class
FastReport.Matrix Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
MatrixObject..::.HandleMouseUp Method
MatrixObject Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

MatrixObject Class
FastReport.Matrix Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
MatrixObject..::.InitializeComponent Method
MatrixObject Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

MatrixObject Class
FastReport.Matrix Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MatrixObject..::.MemberwiseClone Method
MatrixObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MatrixObject Class
MatrixObject Members
FastReport.Matrix Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
MatrixObject..::.OnBeforeInsert Method
MatrixObject Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


OnManualBuild Method

[image]

FastReport.Net Class Reference
MatrixObject..::.OnManualBuild Method
MatrixObject Class See Also Send Feedback
This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnManualBuild(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnManualBuild ( _
    e As EventArgs _
)
Visual C++
public:
void OnManualBuild(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

MatrixObject Class
FastReport.Matrix Namespace


OnModifyResult Method

[image]

FastReport.Net Class Reference
MatrixObject..::.OnModifyResult Method
MatrixObject Class See Also Send Feedback
This method fires the ModifyResult event and the script code connected to the ModifyResultEvent.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnModifyResult(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnModifyResult ( _
    e As EventArgs _
)
Visual C++
public:
void OnModifyResult(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

MatrixObject Class
FastReport.Matrix Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
MatrixObject..::.RestoreState Method
MatrixObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

MatrixObject Class
FastReport.Matrix Namespace


SaveState Method

[image]

FastReport.Net Class Reference
MatrixObject..::.SaveState Method
MatrixObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

MatrixObject Class
FastReport.Matrix Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
MatrixObject..::.SelectionChanged Method
MatrixObject Class See Also Send Feedback
Called when the user selects another object in the designer.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Remarks

This method is typically used by the in-place object's editor to check if selection was changed and close the editor.

See Also

MatrixObject Class
FastReport.Matrix Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MatrixObject..::.Serialize Method
MatrixObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MatrixObject Class
FastReport.Matrix Namespace


Value Method

[image]

FastReport.Net Class Reference
MatrixObject..::.Value Method
MatrixObject Class See Also Send Feedback
Gets the value of the data cell with the specified index.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Variant Value(
    int index
)
Visual Basic (Declaration)
Public Function Value ( _
    index As Integer _
) As Variant
Visual C++
public:
Variant Value(
    int index
)

Parameters

index
Type: System..::.Int32
Zero-based index of the data cell.

Return Value

The cell's value.

Remarks

Use this method in the cell's expression if the cell has custom totals (the total function is set to "Custom"). The example:

Matrix1.Value(0) / Matrix1.Value(1)

will return the result of dividing the first data cell's value by the second one.

See Also

MatrixObject Class
FastReport.Matrix Namespace


MatrixObject Properties

[image] [image]

FastReport.Net Class Reference
MatrixObject Properties
MatrixObject Class See Also Send Feedback

The MatrixObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages. (Inherited from TableBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
AutoSize | Gets or sets a value that determines whether the matrix must calculate column/row sizes automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from TableBase.)
CanBreak | This property is not relevant to this class.
CanGrow | This property is not relevant to this class. (Inherited from TableBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class. (Inherited from TableBase.)
CellsSideBySide | Gets or sets a value that determines how to print multiple data cells.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | This property is not relevant to this class. (Overrides TableBase..::.ColumnCount.)
ColumnIndex | Gets or sets the index of currently printing column.
Columns | Gets a collection of table columns. (Inherited from TableBase.)
ColumnValues | Gets or sets array of values that describes the currently printing column.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
Data | Gets the object that holds the collection of descriptors used to build a matrix.
DataSource | Gets or sets a data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
Filter | Gets the row filter expression.
FixedColumns | This property is not relevant to this class.
FixedRows | This property is not relevant to this class.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class.
Height | Gets or sets the height of the object. (Inherited from TableBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class. (Inherited from TableBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from TableBase.)
Item | Gets or sets the table cell. (Inherited from TableBase.)
KeepCellsSideBySide | Gets or sets a value indicating that the side-by-side cells must be kept together on the same page.
Layout | Gets or sets the table layout. (Inherited from TableBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
ManualBuildEvent | Gets or sets a script method name that will be used to handle the ManualBuild event.
MatrixEvenStylePriority | Gets or sets even style priority for matrix cells.
ModifyResultEvent | Gets or sets a script method name that will be used to handle the ModifyResult event.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page. (Inherited from TableBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table. (Inherited from TableBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | This property is not relevant to this class. (Overrides TableBase..::.RowCount.)
RowIndex | Gets or sets the index of currently printing row.
Rows | Gets a collection of table rows. (Inherited from TableBase.)
RowValues | Gets or sets array of values that describes the currently printing row.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
ShowTitle | Gets or sets a value indicating whether to show a title row.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets a matrix style.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TableBase.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode. (Inherited from TableBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MatrixObject Class
FastReport.Matrix Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
MatrixObject..::.AutoSize Property
MatrixObject Class See Also Send Feedback
Gets or sets a value that determines whether the matrix must calculate column/row sizes automatically.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


CanBreak Property

[image]

FastReport.Net Class Reference
MatrixObject..::.CanBreak Property
MatrixObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanBreak { get; set; }
Visual Basic (Declaration)
Public Property CanBreak As Boolean
Visual C++
public:
property bool CanBreak {
    bool get ();
    void set (bool value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


CellsSideBySide Property

[image]

FastReport.Net Class Reference
MatrixObject..::.CellsSideBySide Property
MatrixObject Class See Also Send Feedback
Gets or sets a value that determines how to print multiple data cells.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CellsSideBySide { get; set; }
Visual Basic (Declaration)
Public Property CellsSideBySide As Boolean
Visual C++
public:
property bool CellsSideBySide {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used if matrix has two or more data cells. Default property value is false - that means the data cells will be stacked.

See Also

MatrixObject Class
FastReport.Matrix Namespace


ColumnCount Property

[image]

FastReport.Net Class Reference
MatrixObject..::.ColumnCount Property
MatrixObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int ColumnCount { get; set; }
Visual Basic (Declaration)
Public Overrides Property ColumnCount As Integer
Visual C++
public:
virtual property int ColumnCount {
    int get () override;
    void set (int value) override;
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


ColumnIndex Property

[image]

FastReport.Net Class Reference
MatrixObject..::.ColumnIndex Property
MatrixObject Class See Also Send Feedback
Gets or sets the index of currently printing column.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ColumnIndex { get; set; }
Visual Basic (Declaration)
Public Property ColumnIndex As Integer
Visual C++
public:
property int ColumnIndex {
    int get ();
    void set (int value);
}

Remarks

This property may be used to print even columns with alternate color. To do this:
  • select the cell that you need to highlight;
  • click the "Highlight" button on the "Text" toolbar;
  • add a new highlight condition that uses the Matrix.ColumnIndex, for example: Matrix1.ColumnIndex % 2 == 1.

See Also

MatrixObject Class
FastReport.Matrix Namespace


ColumnValues Property

[image]

FastReport.Net Class Reference
MatrixObject..::.ColumnValues Property
MatrixObject Class See Also Send Feedback
Gets or sets array of values that describes the currently printing column.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object[] ColumnValues { get; set; }
Visual Basic (Declaration)
Public Property ColumnValues As Object()
Visual C++
public:
property array<Object^>^ ColumnValues {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Remarks

Use this property when report is running. It can be used to highlight matrix elements depending on values of the currently printing column. To do this:
  • select the cell that you need to highlight;
  • click the "Highlight" button on the "Text" toolbar;
  • add a new highlight condition. Use the Matrix.ColumnValues to refer to the value you need to analyze. Note: these values are arrays of System.Object, so you need to cast it to actual type before making any comparisons. Example of highlight condition: (int)Matrix1.ColumnValues[0] == 2000.

See Also

MatrixObject Class
FastReport.Matrix Namespace


Data Property

[image]

FastReport.Net Class Reference
MatrixObject..::.Data Property
MatrixObject Class See Also Send Feedback
Gets the object that holds the collection of descriptors used to build a matrix.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixData Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As MatrixData
Visual C++
public:
property MatrixData^ Data {
    MatrixData^ get ();
}

Remarks

See the MatrixData class for more details.

See Also

MatrixObject Class
FastReport.Matrix Namespace


DataSource Property

[image]

FastReport.Net Class Reference
MatrixObject..::.DataSource Property
MatrixObject Class See Also Send Feedback
Gets or sets a data source.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

Remarks

When you create the matrix in the designer by drag-drop data columns into it, this property will be set automatically. However you need to set it if you create the matrix in code.

See Also

MatrixObject Class
FastReport.Matrix Namespace


Filter Property

[image]

FastReport.Net Class Reference
MatrixObject..::.Filter Property
MatrixObject Class See Also Send Feedback
Gets the row filter expression.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Remarks

This property can contain any valid boolean expression. If the expression returns false, the corresponding data row will be skipped.

See Also

MatrixObject Class
FastReport.Matrix Namespace


FixedColumns Property

[image]

FastReport.Net Class Reference
MatrixObject..::.FixedColumns Property
MatrixObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int FixedColumns { get; set; }
Visual Basic (Declaration)
Public Property FixedColumns As Integer
Visual C++
public:
property int FixedColumns {
    int get ();
    void set (int value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


FixedRows Property

[image]

FastReport.Net Class Reference
MatrixObject..::.FixedRows Property
MatrixObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int FixedRows { get; set; }
Visual Basic (Declaration)
Public Property FixedRows As Integer
Visual C++
public:
property int FixedRows {
    int get ();
    void set (int value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


GrowToBottom Property

[image]

FastReport.Net Class Reference
MatrixObject..::.GrowToBottom Property
MatrixObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool GrowToBottom { get; set; }
Visual Basic (Declaration)
Public Property GrowToBottom As Boolean
Visual C++
public:
property bool GrowToBottom {
    bool get ();
    void set (bool value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


KeepCellsSideBySide Property

[image]

FastReport.Net Class Reference
MatrixObject..::.KeepCellsSideBySide Property
MatrixObject Class See Also Send Feedback
Gets or sets a value indicating that the side-by-side cells must be kept together on the same page.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool KeepCellsSideBySide { get; set; }
Visual Basic (Declaration)
Public Property KeepCellsSideBySide As Boolean
Visual C++
public:
property bool KeepCellsSideBySide {
    bool get ();
    void set (bool value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


ManualBuildEvent Property

[image]

FastReport.Net Class Reference
MatrixObject..::.ManualBuildEvent Property
MatrixObject Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ManualBuild event.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ManualBuildEvent { get; set; }
Visual Basic (Declaration)
Public Property ManualBuildEvent As String
Visual C++
public:
property String^ ManualBuildEvent {
    String^ get ();
    void set (String^ value);
}

Remarks

See the ManualBuild event for more details.

See Also

MatrixObject Class
FastReport.Matrix Namespace


MatrixEvenStylePriority Property

[image]

FastReport.Net Class Reference
MatrixObject..::.MatrixEvenStylePriority Property
MatrixObject Class See Also Send Feedback
Gets or sets even style priority for matrix cells.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MatrixEvenStylePriority MatrixEvenStylePriority { get; set; }
Visual Basic (Declaration)
Public Property MatrixEvenStylePriority As MatrixEvenStylePriority
Visual C++
public:
property MatrixEvenStylePriority MatrixEvenStylePriority {
    MatrixEvenStylePriority get ();
    void set (MatrixEvenStylePriority value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


ModifyResultEvent Property

[image]

FastReport.Net Class Reference
MatrixObject..::.ModifyResultEvent Property
MatrixObject Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ModifyResult event.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ModifyResultEvent { get; set; }
Visual Basic (Declaration)
Public Property ModifyResultEvent As String
Visual C++
public:
property String^ ModifyResultEvent {
    String^ get ();
    void set (String^ value);
}

Remarks

See the ModifyResult event for more details.

See Also

MatrixObject Class
FastReport.Matrix Namespace


RowCount Property

[image]

FastReport.Net Class Reference
MatrixObject..::.RowCount Property
MatrixObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int RowCount { get; set; }
Visual Basic (Declaration)
Public Overrides Property RowCount As Integer
Visual C++
public:
virtual property int RowCount {
    int get () override;
    void set (int value) override;
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


RowIndex Property

[image]

FastReport.Net Class Reference
MatrixObject..::.RowIndex Property
MatrixObject Class See Also Send Feedback
Gets or sets the index of currently printing row.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowIndex { get; set; }
Visual Basic (Declaration)
Public Property RowIndex As Integer
Visual C++
public:
property int RowIndex {
    int get ();
    void set (int value);
}

Remarks

This property may be used to print even rows with alternate color. To do this:
  • select the cell that you need to highlight;
  • click the "Highlight" button on the "Text" toolbar;
  • add a new highlight condition that uses the Matrix.RowIndex, for example: Matrix1.RowIndex % 2 == 1.

See Also

MatrixObject Class
FastReport.Matrix Namespace


RowValues Property

[image]

FastReport.Net Class Reference
MatrixObject..::.RowValues Property
MatrixObject Class See Also Send Feedback
Gets or sets array of values that describes the currently printing row.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object[] RowValues { get; set; }
Visual Basic (Declaration)
Public Property RowValues As Object()
Visual C++
public:
property array<Object^>^ RowValues {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Remarks

Use this property when report is running. It can be used to highlight matrix elements depending on values of the currently printing row. To do this:
  • select the cell that you need to highlight;
  • click the "Highlight" button on the "Text" toolbar;
  • add a new highlight condition. Use the Matrix.RowValues to refer to the value you need to analyze. Note: these values are arrays of System.Object, so you need to cast it to actual type before making any comparisons. Example of highlight condition: (string)Matrix1.RowValues[0] == "Andrew Fuller".

See Also

MatrixObject Class
FastReport.Matrix Namespace


ShowTitle Property

[image]

FastReport.Net Class Reference
MatrixObject..::.ShowTitle Property
MatrixObject Class See Also Send Feedback
Gets or sets a value indicating whether to show a title row.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowTitle { get; set; }
Visual Basic (Declaration)
Public Property ShowTitle As Boolean
Visual C++
public:
property bool ShowTitle {
    bool get ();
    void set (bool value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


Style Property

[image]

FastReport.Net Class Reference
MatrixObject..::.Style Property
MatrixObject Class See Also Send Feedback
Gets or sets a matrix style.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


MatrixObject Events

[image] [image]

FastReport.Net Class Reference
MatrixObject Events
MatrixObject Class See Also Send Feedback

The MatrixObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
ManualBuild | Allows to fill the matrix in code.
ModifyResult | Allows to modify the prepared matrix elements such as cells, rows, columns.
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

MatrixObject Class
FastReport.Matrix Namespace


ManualBuild Event

[image]

FastReport.Net Class Reference
MatrixObject..::.ManualBuild Event
MatrixObject Class Example See Also Send Feedback
Allows to fill the matrix in code.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ManualBuild
Visual Basic (Declaration)
Public Event ManualBuild As EventHandler
Visual C++
public:
 event EventHandler^ ManualBuild {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

In most cases the matrix is connected to a datasource via the DataSource property. When you run a report, the matrix is filled with datasource values automatically.

Using this event, you can put additional values to the matrix or even completely fill it with own values (if DataSource is set to null. To do this, call the Data.AddValue method. See the AddValue(array<Object>[]()[], array<Object>[]()[], array<Object>[]()[]) method for more details.

Examples

This example shows how to fill a matrix with own values.
CopyC#
// suppose we have a matrix with one column, row and data cell.
// provide 3 one-dimensional arrays with one element in each to the AddValue method
Matrix1.Data.AddValue(
  new object[] { 1996 },
  new object[] { "Andrew Fuller" },
  new object[] { 123.45f });
Matrix1.Data.AddValue(
  new object[] { 1997 },
  new object[] { "Andrew Fuller" },
  new object[] { 21.35f });
Matrix1.Data.AddValue(
  new object[] { 1997 },
  new object[] { "Nancy Davolio" },
  new object[] { 421.5f });

// this code will produce the following matrix:
//               |  1996  |  1997  |
// --------------+--------+--------+
// Andrew Fuller |  123.45|   21.35|
// --------------+--------+--------+
// Nancy Davolio |        |  421.50|
// --------------+--------+--------+

See Also

MatrixObject Class
FastReport.Matrix Namespace


ModifyResult Event

[image]

FastReport.Net Class Reference
MatrixObject..::.ModifyResult Event
MatrixObject Class See Also Send Feedback
Allows to modify the prepared matrix elements such as cells, rows, columns.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ModifyResult
Visual Basic (Declaration)
Public Event ModifyResult As EventHandler
Visual C++
public:
 event EventHandler^ ModifyResult {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

MatrixObject Class
FastReport.Matrix Namespace


MatrixPercent Enumeration

[image]

FastReport.Net Class Reference
MatrixPercent Enumeration
See Also Send Feedback
Determines how matrix percents are calculated.

Namespace: FastReport.Matrix
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum MatrixPercent
Visual Basic (Declaration)
Public Enumeration MatrixPercent
Visual C++
public enum class MatrixPercent

Members

Member name | Description
None | Do not calculate percent value.
ColumnTotal | Calculate percent of the column total value.
RowTotal | Calculate percent of the row total value.
GrandTotal | Calculate percent of the grand total value.

See Also

FastReport.Matrix Namespace


FastReport.MSChart Namespace

[image]

FastReport.Net Class Reference
FastReport.MSChart Namespace
Send Feedback

Classes

Class | Description
MSChartObject | Represents the chart object based on Microsoft Chart control.
MSChartSeries | Represents a MS Chart series wrapper.
SeriesCollection | Represents a collection of MSChartSeries objects.

Enumerations

Enumeration | Description
ChartSortOrder | Specifies the direction in which the series points are sorted.
Collect | Specifies which data points to collect into one point.
GroupBy | Specifies how the series points are grouped.
PieExplode | Specifies which pie value to explode.
SortBy | Specifies how the series points are sorted.


ChartSortOrder Enumeration

[image]

FastReport.Net Class Reference
ChartSortOrder Enumeration
See Also Send Feedback
Specifies the direction in which the series points are sorted.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum ChartSortOrder
Visual Basic (Declaration)
Public Enumeration ChartSortOrder
Visual C++
public enum class ChartSortOrder

Members

Member name | Description
Ascending | Points are sorted in ascending order.
Descending | Points are sorted in descending order.

See Also

FastReport.MSChart Namespace


Collect Enumeration

[image]

FastReport.Net Class Reference
Collect Enumeration
See Also Send Feedback
Specifies which data points to collect into one point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum Collect
Visual Basic (Declaration)
Public Enumeration Collect
Visual C++
public enum class Collect

Members

Member name | Description
None | Do not collect points.
TopN | Show top N points (N value is specified in the CollectValue property), collect other points into one.
BottomN | Show bottom N points (N value is specified in the CollectValue property), collect other points into one.
LessThan | Collect points which have Y value less than specified in the CollectValue property.
LessThanPercent | Collect points which have Y value less than percent specified in the CollectValue property.
GreaterThan | Collect points which have Y value greater than specified in the CollectValue property.
GreaterThanPercent | Collect points which have Y value greater than percent specified in the CollectValue property.

See Also

FastReport.MSChart Namespace


GroupBy Enumeration

[image]

FastReport.Net Class Reference
GroupBy Enumeration
See Also Send Feedback
Specifies how the series points are grouped.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum GroupBy
Visual Basic (Declaration)
Public Enumeration GroupBy
Visual C++
public enum class GroupBy

Members

Member name | Description
None | Points are not grouped.
XValue | Points are grouped by X value.
Number | Points are grouped by number specified in the GroupInterval.
Years | Points are grouped by Years.
Months | Points are grouped by Months.
Weeks | Points are grouped by Weeks.
Days | Points are grouped by Days.
Hours | Points are grouped by Hours.
Minutes | Points are grouped by Minutes.
Seconds | Points are grouped by Seconds.
Milliseconds | Points are grouped by Milliseconds.

See Also

FastReport.MSChart Namespace


MSChartObject Class

[image]

FastReport.Net Class Reference
MSChartObject Class
Members See Also Send Feedback
Represents the chart object based on Microsoft Chart control.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MSChartObject : ReportComponentBase,
    IParent, IHasEditor
Visual Basic (Declaration)
Public Class MSChartObject _
    Inherits ReportComponentBase _
    Implements IParent, IHasEditor
Visual C++
public ref class MSChartObject : public ReportComponentBase,
    IParent, IHasEditor

Remarks

FastReport uses Microsoft Chart library to display charts. This library is included in .Net Framework 4.0. For .Net 3.5 it is available as a separate download here: http://www.microsoft.com/downloads/details.aspx?FamilyID=130f7986-bf49-4fe5-9ca8-910ae6ea442c

Note:This library requires .Net Framework 3.5 SP1.

To access Microsoft Chart object, use the Chart property. It allows you to set up chart appearance. For more information on available properties, refer to the MS Chart documentation.

Chart object may contain one or several series. Each series is represented by two objects:

  • the Series that is handled by MS Chart. It is stored in the Chart.Series collection;
  • the MSChartSeries object that provides data for MS Chart series. It is stored in the Series collection.

Do not operate series objects directly. To add or remove series, use the AddSeries(SeriesChartType) and DeleteSeries(Int32) methods. These methods handle Series and MSChartSeries in sync.

If you have a chart object on your Form and want to print it in FastReport, use the AssignChart(Chart) method.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport.MSChart..::.MSChartObject

See Also

MSChartObject Members
FastReport.MSChart Namespace


MSChartObject Members

[image] [image]

FastReport.Net Class Reference
MSChartObject Members
MSChartObject Class Constructors Methods Properties Events See Also Send Feedback

The MSChartObject type exposes the following members.

Constructors

Name | Description
MSChartObject | Initializes a new instance of the MSChartObject with default settings.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
AddSeries | Adds a new series.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignChart | Assigns chart appearance, series and data from the System.Windows.Forms.DataVisualization.Charting.Chart object.
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
DeleteSeries | Deletes a series at a specified index.
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Overrides ReportComponentBase..::.OnMouseLeave(EventArgs).)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Overrides ReportComponentBase..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AlignXValues | Gets or sets a value indicating that all series' data point should be aligned by its X value.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
AutoSeriesColor | Gets or set the color for auto-series.
AutoSeriesColumn | Gets or set the data column or expression for automatically created series.
AutoSeriesSortOrder | Gets or sets sort order for auto-series.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Overrides ReportComponentBase..::.Border.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Chart | Gets a reference to the MS Chart object.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataSource | Gets or sets the data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | This property is not relevant to this class.
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Overrides ReportComponentBase..::.Fill.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
Filter | Gets or sets the filter expression.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | This property is not relevant to this class.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Series | Gets the collection of MSChartSeries objects.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | This property is not relevant to this class.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

MSChartObject Class
FastReport.MSChart Namespace


MSChartObject Constructor

[image]

FastReport.Net Class Reference
MSChartObject Constructor
MSChartObject Class See Also Send Feedback
Initializes a new instance of the MSChartObject with default settings.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MSChartObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MSChartObject()

See Also

MSChartObject Class
FastReport.MSChart Namespace


MSChartObject Methods

[image] [image]

FastReport.Net Class Reference
MSChartObject Methods
MSChartObject Class See Also Send Feedback

The MSChartObject type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
AddSeries | Adds a new series.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides ReportComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignChart | Assigns chart appearance, series and data from the System.Windows.Forms.DataVisualization.Charting.Chart object.
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CalcHeight | Calculates the object's height. (Inherited from ReportComponentBase.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
DeleteSeries | Deletes a series at a specified index.
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Overrides ReportComponentBase..::.FinalizeComponent()()().)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Inherited from ReportComponentBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides ReportComponentBase..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Overrides ReportComponentBase..::.GetPreferredSize()()().)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ReportComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Overrides ReportComponentBase..::.InitializeComponent()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor.
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Overrides ReportComponentBase..::.OnMouseLeave(EventArgs).)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Overrides ReportComponentBase..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides ReportComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

MSChartObject Class
FastReport.MSChart Namespace


AddChild Method

[image]

FastReport.Net Class Reference
MSChartObject..::.AddChild Method
MSChartObject Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

MSChartObject Class
FastReport.MSChart Namespace


AddSeries Method

[image]

FastReport.Net Class Reference
MSChartObject..::.AddSeries Method
MSChartObject Class See Also Send Feedback
Adds a new series.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MSChartSeries AddSeries(
    SeriesChartType chartType
)
Visual Basic (Declaration)
Public Function AddSeries ( _
    chartType As SeriesChartType _
) As MSChartSeries
Visual C++
public:
MSChartSeries^ AddSeries(
    SeriesChartType chartType
)

Parameters

chartType
Type: SeriesChartType
The type of series.

Return Value

The new MSChartSeries object.

See Also

MSChartObject Class
FastReport.MSChart Namespace


Assign Method

[image]

FastReport.Net Class Reference
MSChartObject..::.Assign Method
MSChartObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

MSChartObject Class
FastReport.MSChart Namespace
AssignAll Method


AssignChart Method

[image]

FastReport.Net Class Reference
MSChartObject..::.AssignChart Method
MSChartObject Class See Also Send Feedback
Assigns chart appearance, series and data from the System.Windows.Forms.DataVisualization.Charting.Chart object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AssignChart(
    Chart sourceChart
)
Visual Basic (Declaration)
Public Sub AssignChart ( _
    sourceChart As Chart _
)
Visual C++
public:
void AssignChart(
    Chart^ sourceChart
)

Parameters

sourceChart
Type: Chart
Chart object to assign data from.

Remarks

Use this method if you have a chart in your application and want to print it in FastReport. To do this, put an empty MSChartObject in your report and execute the following code:
CopyC#
report.Load("...");
MSChartObject reportChart = report.FindObject("MSChart1") as MSChartObject;
reportChart.AssignChart(applicationChart);
report.Show();

See Also

MSChartObject Class
FastReport.MSChart Namespace


CanContain Method

[image]

FastReport.Net Class Reference
MSChartObject..::.CanContain Method
MSChartObject Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

MSChartObject Class
FastReport.MSChart Namespace


DeleteSeries Method

[image]

FastReport.Net Class Reference
MSChartObject..::.DeleteSeries Method
MSChartObject Class See Also Send Feedback
Deletes a series at a specified index.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DeleteSeries(
    int index
)
Visual Basic (Declaration)
Public Sub DeleteSeries ( _
    index As Integer _
)
Visual C++
public:
void DeleteSeries(
    int index
)

Parameters

index
Type: System..::.Int32
Index of series.

See Also

MSChartObject Class
FastReport.MSChart Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
MSChartObject..::.Deserialize Method
MSChartObject Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

MSChartObject Class
FastReport.MSChart Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MSChartObject..::.Dispose Method
MSChartObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

MSChartObject Class
MSChartObject Members
FastReport.MSChart Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
MSChartObject..::.Dispose Method (Boolean)
MSChartObject Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

MSChartObject Class
Dispose Overload
FastReport.MSChart Namespace


Draw Method

[image]

FastReport.Net Class Reference
MSChartObject..::.Draw Method
MSChartObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

MSChartObject Class
FastReport.MSChart Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
MSChartObject..::.DrawMarkers Method
MSChartObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

MSChartObject Class
MSChartObject Members
FastReport.MSChart Namespace


FinalizeComponent Method

[image]

FastReport.Net Class Reference
MSChartObject..::.FinalizeComponent Method
MSChartObject Class See Also Send Feedback
Performs a finalization after the report is finished.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void FinalizeComponent()
Visual Basic (Declaration)
Public Overrides Sub FinalizeComponent
Visual C++
public:
virtual void FinalizeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

MSChartObject Class
FastReport.MSChart Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
MSChartObject..::.GetChildObjects Method
MSChartObject Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

MSChartObject Class
FastReport.MSChart Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
MSChartObject..::.GetChildOrder Method
MSChartObject Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

MSChartObject Class
FastReport.MSChart Namespace


GetData Method

[image]

FastReport.Net Class Reference
MSChartObject..::.GetData Method
MSChartObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

MSChartObject Class
FastReport.MSChart Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
MSChartObject..::.GetExpressions Method
MSChartObject Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

MSChartObject Class
FastReport.MSChart Namespace


GetPreferredSize Method

[image]

FastReport.Net Class Reference
MSChartObject..::.GetPreferredSize Method
MSChartObject Class See Also Send Feedback
Gets the preferred size of an object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SizeF GetPreferredSize()
Visual Basic (Declaration)
Public Overrides Function GetPreferredSize As SizeF
Visual C++
public:
virtual SizeF GetPreferredSize() override

Return Value

Preferred size.

Remarks

This method is called by the FastReport designer when you insert a new object.

See Also

MSChartObject Class
FastReport.MSChart Namespace


InitializeComponent Method

[image]

FastReport.Net Class Reference
MSChartObject..::.InitializeComponent Method
MSChartObject Class See Also Send Feedback
Initializes the object before running a report.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void InitializeComponent()
Visual Basic (Declaration)
Public Overrides Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() override

Remarks

This method is used by the report engine, do not call it directly.

See Also

MSChartObject Class
FastReport.MSChart Namespace


InvokeEditor Method

[image]

FastReport.Net Class Reference
MSChartObject..::.InvokeEditor Method
MSChartObject Class See Also Send Feedback
Invokes the object's editor.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool InvokeEditor()
Visual Basic (Declaration)
Public Function InvokeEditor As Boolean
Visual C++
public:
virtual bool InvokeEditor() sealed

Return Value

true if object was succesfully edited.

Implements

IHasEditor..::.InvokeEditor()()()

Remarks

This method is called by FastReport when the object is doubleclicked in the designer.

See Also

MSChartObject Class
FastReport.MSChart Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MSChartObject..::.MemberwiseClone Method
MSChartObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MSChartObject Class
MSChartObject Members
FastReport.MSChart Namespace


OnAfterInsert Method

[image]

FastReport.Net Class Reference
MSChartObject..::.OnAfterInsert Method
MSChartObject Class See Also Send Feedback
Called after the new object was inserted in the designer.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterInsert(
    InsertFrom source
)
Visual Basic (Declaration)
Public Overrides Sub OnAfterInsert ( _
    source As InsertFrom _
)
Visual C++
public:
virtual void OnAfterInsert(
    InsertFrom source
) override

Parameters

source
Type: FastReport..::.InsertFrom
The insertion source.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called when new object is inserted, pasted from clipboard or dragged from "Dictionary" window. You may override this method if you need to perform some actions when object is inserted. Typical implementation invokes the object's editor if "Edit after insert" flag is set in the designer options.

See Also

MSChartObject Class
FastReport.MSChart Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
MSChartObject..::.OnBeforeInsert Method
MSChartObject Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


OnMouseLeave Method

[image]

FastReport.Net Class Reference
MSChartObject..::.OnMouseLeave Method
MSChartObject Class See Also Send Feedback
This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

MSChartObject Class
FastReport.MSChart Namespace


OnMouseMove Method

[image]

FastReport.Net Class Reference
MSChartObject..::.OnMouseMove Method
MSChartObject Class See Also Send Feedback
This method fires the MouseMove event and the script code connected to the MouseMoveEvent.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs
Event data.

See Also

MSChartObject Class
FastReport.MSChart Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
MSChartObject..::.RemoveChild Method
MSChartObject Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

MSChartObject Class
FastReport.MSChart Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
MSChartObject..::.RestoreState Method
MSChartObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

MSChartObject Class
FastReport.MSChart Namespace


SaveState Method

[image]

FastReport.Net Class Reference
MSChartObject..::.SaveState Method
MSChartObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

MSChartObject Class
FastReport.MSChart Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MSChartObject..::.Serialize Method
MSChartObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MSChartObject Class
FastReport.MSChart Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
MSChartObject..::.SetChildOrder Method
MSChartObject Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

MSChartObject Class
FastReport.MSChart Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
MSChartObject..::.UpdateLayout Method
MSChartObject Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

MSChartObject Class
FastReport.MSChart Namespace


MSChartObject Properties

[image] [image]

FastReport.Net Class Reference
MSChartObject Properties
MSChartObject Class See Also Send Feedback

The MSChartObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AlignXValues | Gets or sets a value indicating that all series' data point should be aligned by its X value.
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
AutoSeriesColor | Gets or set the color for auto-series.
AutoSeriesColumn | Gets or set the data column or expression for automatically created series.
AutoSeriesSortOrder | Gets or sets sort order for auto-series.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Overrides ReportComponentBase..::.Border.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanGrow | Determines if the object can grow. (Inherited from ReportComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | Determines if the object can shrink. (Inherited from ReportComponentBase.)
Chart | Gets a reference to the MS Chart object.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DataSource | Gets or sets the data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | This property is not relevant to this class.
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Overrides ReportComponentBase..::.Fill.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
Filter | Gets or sets the filter expression.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from ReportComponentBase.)
HoverStyle | This property is not relevant to this class.
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Series | Gets the collection of MSChartSeries objects.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | This property is not relevant to this class.
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from ReportComponentBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MSChartObject Class
FastReport.MSChart Namespace


AlignXValues Property

[image]

FastReport.Net Class Reference
MSChartObject..::.AlignXValues Property
MSChartObject Class See Also Send Feedback
Gets or sets a value indicating that all series' data point should be aligned by its X value.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AlignXValues { get; set; }
Visual Basic (Declaration)
Public Property AlignXValues As Boolean
Visual C++
public:
property bool AlignXValues {
    bool get ();
    void set (bool value);
}

Remarks

Using this property is necessary to print stacked type series. These series must have equal number of data points, and the order of data points must be the same for all series.

See Also

MSChartObject Class
FastReport.MSChart Namespace


AutoSeriesColor Property

[image]

FastReport.Net Class Reference
MSChartObject..::.AutoSeriesColor Property
MSChartObject Class See Also Send Feedback
Gets or set the color for auto-series.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AutoSeriesColor { get; set; }
Visual Basic (Declaration)
Public Property AutoSeriesColor As String
Visual C++
public:
property String^ AutoSeriesColor {
    String^ get ();
    void set (String^ value);
}

Remarks

If no color is specified, the new series will use the palette defined in the chart.

See Also

MSChartObject Class
FastReport.MSChart Namespace


AutoSeriesColumn Property

[image]

FastReport.Net Class Reference
MSChartObject..::.AutoSeriesColumn Property
MSChartObject Class See Also Send Feedback
Gets or set the data column or expression for automatically created series.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string AutoSeriesColumn { get; set; }
Visual Basic (Declaration)
Public Property AutoSeriesColumn As String
Visual C++
public:
property String^ AutoSeriesColumn {
    String^ get ();
    void set (String^ value);
}

Remarks

In order to create auto-series, you need to define one series that will be used as a template for new series, and set up the AutoSeriesColumn property. The value of this property will be a name of new series. If there is no series with such name yet, the new series will be added.

See Also

MSChartObject Class
FastReport.MSChart Namespace


AutoSeriesSortOrder Property

[image]

FastReport.Net Class Reference
MSChartObject..::.AutoSeriesSortOrder Property
MSChartObject Class See Also Send Feedback
Gets or sets sort order for auto-series.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SortOrder AutoSeriesSortOrder { get; set; }
Visual Basic (Declaration)
Public Property AutoSeriesSortOrder As SortOrder
Visual C++
public:
property SortOrder AutoSeriesSortOrder {
    SortOrder get ();
    void set (SortOrder value);
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


Border Property

[image]

FastReport.Net Class Reference
MSChartObject..::.Border Property
MSChartObject Class See Also Send Feedback
Gets or sets an object's border.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Border Border { get; set; }
Visual Basic (Declaration)
Public Overrides Property Border As Border
Visual C++
public:
virtual property Border^ Border {
    Border^ get () override;
    void set (Border^ value) override;
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


Chart Property

[image]

FastReport.Net Class Reference
MSChartObject..::.Chart Property
MSChartObject Class See Also Send Feedback
Gets a reference to the MS Chart object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Chart Chart { get; }
Visual Basic (Declaration)
Public ReadOnly Property Chart As Chart
Visual C++
public:
property Chart^ Chart {
    Chart^ get ();
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


DataSource Property

[image]

FastReport.Net Class Reference
MSChartObject..::.DataSource Property
MSChartObject Class See Also Send Feedback
Gets or sets the data source.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataSourceBase DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataSourceBase
Visual C++
public:
property DataSourceBase^ DataSource {
    DataSourceBase^ get ();
    void set (DataSourceBase^ value);
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


EvenStyle Property

[image]

FastReport.Net Class Reference
MSChartObject..::.EvenStyle Property
MSChartObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string EvenStyle { get; set; }
Visual Basic (Declaration)
Public Property EvenStyle As String
Visual C++
public:
property String^ EvenStyle {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


Fill Property

[image]

FastReport.Net Class Reference
MSChartObject..::.Fill Property
MSChartObject Class Example See Also Send Feedback
Gets or sets an object's fill.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override FillBase Fill { get; set; }
Visual Basic (Declaration)
Public Overrides Property Fill As FillBase
Visual C++
public:
virtual property FillBase^ Fill {
    FillBase^ get () override;
    void set (FillBase^ value) override;
}

Remarks

The fill can be one of the following types: SolidFill, LinearGradientFill, PathGradientFill, HatchFill.

To set the solid fill color, use the simpler FillColor property.

Examples

This example shows how to set the new fill and change its properties:
CopyC#
textObject1.Fill = new SolidFill(Color.Green);
(textObject1.Fill as SolidFill).Color = Color.Red;

See Also

MSChartObject Class
FastReport.MSChart Namespace


Filter Property

[image]

FastReport.Net Class Reference
MSChartObject..::.Filter Property
MSChartObject Class See Also Send Feedback
Gets or sets the filter expression.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Remarks

This filter will be applied to all series in chart. You may also use the series' Filter property to filter each series individually.

See Also

MSChartObject Class
FastReport.MSChart Namespace


HoverStyle Property

[image]

FastReport.Net Class Reference
MSChartObject..::.HoverStyle Property
MSChartObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string HoverStyle { get; set; }
Visual Basic (Declaration)
Public Property HoverStyle As String
Visual C++
public:
property String^ HoverStyle {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


Series Property

[image]

FastReport.Net Class Reference
MSChartObject..::.Series Property
MSChartObject Class See Also Send Feedback
Gets the collection of MSChartSeries objects.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SeriesCollection Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property Series As SeriesCollection
Visual C++
public:
property SeriesCollection^ Series {
    SeriesCollection^ get ();
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


Style Property

[image]

FastReport.Net Class Reference
MSChartObject..::.Style Property
MSChartObject Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartObject Class
FastReport.MSChart Namespace


MSChartObject Events

[image] [image]

FastReport.Net Class Reference
MSChartObject Events
MSChartObject Class See Also Send Feedback

The MSChartObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

MSChartObject Class
FastReport.MSChart Namespace


MSChartSeries Class

[image]

FastReport.Net Class Reference
MSChartSeries Class
Members See Also Send Feedback
Represents a MS Chart series wrapper.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MSChartSeries : Base
Visual Basic (Declaration)
Public Class MSChartSeries _
    Inherits Base
Visual C++
public ref class MSChartSeries : public Base

Remarks

This class provides a data for MS Chart series. The series itself is stored inside the MS Chart and is accessible via the SeriesSettings property.

You don't need to create an instance of this class directly. Instead, use the AddSeries(SeriesChartType) method.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport.MSChart..::.MSChartSeries

See Also

MSChartSeries Members
FastReport.MSChart Namespace


MSChartSeries Members

[image] [image]

FastReport.Net Class Reference
MSChartSeries Members
MSChartSeries Class Constructors Methods Properties Events See Also Send Feedback

The MSChartSeries type exposes the following members.

Constructors

Name | Description
MSChartSeries | Creates a new instance of the MSChartSeries class with default settings.

Methods

Name | Description
AddValue | Adds a data point with specified X and Y values.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
ClearValues | Clears all data points in this series.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Collect | Gets or sets the collect method used to collect several data points into one.
CollectedItemColor | Gets or sets the color for the collected value.
CollectedItemText | Gets or sets the text for the collected value.
CollectValue | Gets or sets the collect value used to collect several data points into one.
Color | Gets or sets the data column or expression that returns the color of data point.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filter | Gets os sets the data filter expression.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupBy | Gets or sets the group method used to group data points.
GroupFunction | Gets or sets the function used to group data points.
GroupInterval | Gets or sets the group interval.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Label | Gets or sets the data column or expression returns the label value of data point.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PieExplode | Gets or sets the method used to explode values in pie-type series.
PieExplodeValue | Gets or sets the value that must be exploded.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
SeriesSettings | Gets a reference to MS Chart Series object.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SortBy | Gets or sets the sort method used to sort data points.
SortOrder | Gets or sets the sort order used to sort data points.
XValue | Gets or sets the data column or expression that returns the X value of data point.
YValue1 | Gets or sets the data column or expression that returns the first Y value of data point.
YValue2 | Gets or sets the data column or expression returns the second Y value of data point.
YValue3 | Gets or sets the data column or expression returns the third Y value of data point.
YValue4 | Gets or sets the data column or expression returns the fourth Y value of data point.
YValuesPerPoint | Gets a number of Y value per data point.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MSChartSeries Class
FastReport.MSChart Namespace


MSChartSeries Constructor

[image]

FastReport.Net Class Reference
MSChartSeries Constructor
MSChartSeries Class See Also Send Feedback
Creates a new instance of the MSChartSeries class with default settings.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MSChartSeries()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MSChartSeries()

See Also

MSChartSeries Class
FastReport.MSChart Namespace


MSChartSeries Methods

[image] [image]

FastReport.Net Class Reference
MSChartSeries Methods
MSChartSeries Class See Also Send Feedback

The MSChartSeries type exposes the following members.

Methods

Name | Description
AddValue | Adds a data point with specified X and Y values.
Assign | Copies the contents of another, similar object. (Overrides Base..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Clear | Clears the object's state. (Inherited from Base.)
ClearValues | Clears all data points in this series.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Overrides Base..::.Deserialize(FRReader).)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Inherited from Base.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Overrides Base..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides Base..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

MSChartSeries Class
FastReport.MSChart Namespace


AddValue Method

[image]

FastReport.Net Class Reference
MSChartSeries..::.AddValue Method
MSChartSeries Class See Also Send Feedback
Adds a data point with specified X and Y values.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddValue(
    Object xValue,
    params Object[] yValues
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    xValue As Object, _
    ParamArray yValues As Object() _
)
Visual C++
public:
void AddValue(
    Object^ xValue,
    ... array<Object^>^ yValues
)

Parameters

xValue
Type: System..::.Object
X value.
yValues
Type: array< System..::.Object >[]()[]
Array of Y values.

Remarks

Note: number of values in the yValues parameter must be the same as value returned by the YValuesPerPoint property.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Assign Method

[image]

FastReport.Net Class Reference
MSChartSeries..::.Assign Method
MSChartSeries Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

MSChartSeries Class
FastReport.MSChart Namespace
AssignAll Method


ClearValues Method

[image]

FastReport.Net Class Reference
MSChartSeries..::.ClearValues Method
MSChartSeries Class See Also Send Feedback
Clears all data points in this series.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ClearValues()
Visual Basic (Declaration)
Public Sub ClearValues
Visual C++
public:
void ClearValues()

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Deserialize Method

[image]

FastReport.Net Class Reference
MSChartSeries..::.Deserialize Method
MSChartSeries Class See Also Send Feedback
Deserializes the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Deserialize(
    FRReader reader
)
Visual Basic (Declaration)
Public Overrides Sub Deserialize ( _
    reader As FRReader _
)
Visual C++
public:
virtual void Deserialize(
    FRReader^ reader
) override

Parameters

reader
Type: FastReport.Utils..::.FRReader
Reader object.

Implements

IFRSerializable..::.Deserialize(FRReader)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to restore the state. It may happen when:

  • loading the report from a file or stream;
  • loading the report from the designer's undo buffer;
  • assigning another object to this object using the Assign(Base) or AssignAll methods;
  • loading the object from the designer's clipboard;
  • loading the object from the preview pages.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
MSChartSeries..::.Dispose Method
MSChartSeries Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

MSChartSeries Class
MSChartSeries Members
FastReport.MSChart Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
MSChartSeries..::.GetExpressions Method
MSChartSeries Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
MSChartSeries..::.MemberwiseClone Method
MSChartSeries Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MSChartSeries Class
MSChartSeries Members
FastReport.MSChart Namespace


Serialize Method

[image]

FastReport.Net Class Reference
MSChartSeries..::.Serialize Method
MSChartSeries Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

MSChartSeries Class
FastReport.MSChart Namespace


MSChartSeries Properties

[image] [image]

FastReport.Net Class Reference
MSChartSeries Properties
MSChartSeries Class See Also Send Feedback

The MSChartSeries type exposes the following members.

Properties

Name | Description
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
BaseName | The base part of the object's name. (Inherited from Base.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
Collect | Gets or sets the collect method used to collect several data points into one.
CollectedItemColor | Gets or sets the color for the collected value.
CollectedItemText | Gets or sets the text for the collected value.
CollectValue | Gets or sets the collect value used to collect several data points into one.
Color | Gets or sets the data column or expression that returns the color of data point.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filter | Gets os sets the data filter expression.
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupBy | Gets or sets the group method used to group data points.
GroupFunction | Gets or sets the function used to group data points.
GroupInterval | Gets or sets the group interval.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Label | Gets or sets the data column or expression returns the label value of data point.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
PieExplode | Gets or sets the method used to explode values in pie-type series.
PieExplodeValue | Gets or sets the value that must be exploded.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | This property is not relevant to this class.
SeriesSettings | Gets a reference to MS Chart Series object.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SortBy | Gets or sets the sort method used to sort data points.
SortOrder | Gets or sets the sort order used to sort data points.
XValue | Gets or sets the data column or expression that returns the X value of data point.
YValue1 | Gets or sets the data column or expression that returns the first Y value of data point.
YValue2 | Gets or sets the data column or expression returns the second Y value of data point.
YValue3 | Gets or sets the data column or expression returns the third Y value of data point.
YValue4 | Gets or sets the data column or expression returns the fourth Y value of data point.
YValuesPerPoint | Gets a number of Y value per data point.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Collect Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.Collect Property
MSChartSeries Class See Also Send Feedback
Gets or sets the collect method used to collect several data points into one.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Collect Collect { get; set; }
Visual Basic (Declaration)
Public Property Collect As Collect
Visual C++
public:
property Collect Collect {
    Collect get ();
    void set (Collect value);
}

Remarks

This instrument for data processing allows to collect several series points into one point. The collected point will be displaed using the text specified in the CollectedItemText property and color specified in the CollectedItemColor property.

For example, to display top 5 values, set this property to TopN and specify N value (5) in the CollectValue property.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


CollectedItemColor Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.CollectedItemColor Property
MSChartSeries Class See Also Send Feedback
Gets or sets the color for the collected value.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color CollectedItemColor { get; set; }
Visual Basic (Declaration)
Public Property CollectedItemColor As Color
Visual C++
public:
property Color CollectedItemColor {
    Color get ();
    void set (Color value);
}

Remarks

If this property is set to Transparent (by default), the default palette color will be used to display a collected point.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


CollectedItemText Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.CollectedItemText Property
MSChartSeries Class See Also Send Feedback
Gets or sets the text for the collected value.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string CollectedItemText { get; set; }
Visual Basic (Declaration)
Public Property CollectedItemText As String
Visual C++
public:
property String^ CollectedItemText {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


CollectValue Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.CollectValue Property
MSChartSeries Class See Also Send Feedback
Gets or sets the collect value used to collect several data points into one.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CollectValue { get; set; }
Visual Basic (Declaration)
Public Property CollectValue As Single
Visual C++
public:
property float CollectValue {
    float get ();
    void set (float value);
}

Remarks

This property is used if the Collect property is set to any value other than None.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Color Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.Color Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression that returns the color of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Color { get; set; }
Visual Basic (Declaration)
Public Property Color As String
Visual C++
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Filter Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.Filter Property
MSChartSeries Class See Also Send Feedback
Gets os sets the data filter expression.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Remarks

The filter is applied for this series only. You can also use the Filter property to set a filter that will be applied to all series in a chart.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


GroupBy Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.GroupBy Property
MSChartSeries Class See Also Send Feedback
Gets or sets the group method used to group data points.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GroupBy GroupBy { get; set; }
Visual Basic (Declaration)
Public Property GroupBy As GroupBy
Visual C++
public:
property GroupBy GroupBy {
    GroupBy get ();
    void set (GroupBy value);
}

Remarks

This property is mainly used when series is filled with data with several identical X values. In this case, you need to set the property to XValue. All identical data points will be grouped into one point, their Y values will be summarized. You can choose the summary function using the GroupFunction property.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


GroupFunction Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.GroupFunction Property
MSChartSeries Class See Also Send Feedback
Gets or sets the function used to group data points.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TotalType GroupFunction { get; set; }
Visual Basic (Declaration)
Public Property GroupFunction As TotalType
Visual C++
public:
property TotalType GroupFunction {
    TotalType get ();
    void set (TotalType value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


GroupInterval Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.GroupInterval Property
MSChartSeries Class See Also Send Feedback
Gets or sets the group interval.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float GroupInterval { get; set; }
Visual Basic (Declaration)
Public Property GroupInterval As Single
Visual C++
public:
property float GroupInterval {
    float get ();
    void set (float value);
}

Remarks

This value is used if GroupBy property is set to Number.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Label Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.Label Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression returns the label value of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Label { get; set; }
Visual Basic (Declaration)
Public Property Label As String
Visual C++
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


PieExplode Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.PieExplode Property
MSChartSeries Class See Also Send Feedback
Gets or sets the method used to explode values in pie-type series.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PieExplode PieExplode { get; set; }
Visual Basic (Declaration)
Public Property PieExplode As PieExplode
Visual C++
public:
property PieExplode PieExplode {
    PieExplode get ();
    void set (PieExplode value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


PieExplodeValue Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.PieExplodeValue Property
MSChartSeries Class See Also Send Feedback
Gets or sets the value that must be exploded.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string PieExplodeValue { get; set; }
Visual Basic (Declaration)
Public Property PieExplodeValue As String
Visual C++
public:
property String^ PieExplodeValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used if PieExplode property is set to SpecificValue.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


Restrictions Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.Restrictions Property
MSChartSeries Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


SeriesSettings Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.SeriesSettings Property
MSChartSeries Class See Also Send Feedback
Gets a reference to MS Chart Series object.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Series SeriesSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property SeriesSettings As Series
Visual C++
public:
property Series^ SeriesSettings {
    Series^ get ();
}

Remarks

Use this property to set many options available for the Series object. These options include: visual appearance, labels, marks, value types. Refer to the Microsoft Chart control documentation to learn more.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


SortBy Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.SortBy Property
MSChartSeries Class See Also Send Feedback
Gets or sets the sort method used to sort data points.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SortBy SortBy { get; set; }
Visual Basic (Declaration)
Public Property SortBy As SortBy
Visual C++
public:
property SortBy SortBy {
    SortBy get ();
    void set (SortBy value);
}

Remarks

You have to specify the SortOrder property as well. Data points in this series will be sorted according selected sort criteria and order.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


SortOrder Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.SortOrder Property
MSChartSeries Class See Also Send Feedback
Gets or sets the sort order used to sort data points.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ChartSortOrder SortOrder { get; set; }
Visual Basic (Declaration)
Public Property SortOrder As ChartSortOrder
Visual C++
public:
property ChartSortOrder SortOrder {
    ChartSortOrder get ();
    void set (ChartSortOrder value);
}

Remarks

You have to specify the SortBy property as well. Data points in this series will be sorted according selected sort criteria and order.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


XValue Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.XValue Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression that returns the X value of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string XValue { get; set; }
Visual Basic (Declaration)
Public Property XValue As String
Visual C++
public:
property String^ XValue {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


YValue1 Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.YValue1 Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression that returns the first Y value of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string YValue1 { get; set; }
Visual Basic (Declaration)
Public Property YValue1 As String
Visual C++
public:
property String^ YValue1 {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


YValue2 Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.YValue2 Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression returns the second Y value of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string YValue2 { get; set; }
Visual Basic (Declaration)
Public Property YValue2 As String
Visual C++
public:
property String^ YValue2 {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


YValue3 Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.YValue3 Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression returns the third Y value of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string YValue3 { get; set; }
Visual Basic (Declaration)
Public Property YValue3 As String
Visual C++
public:
property String^ YValue3 {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


YValue4 Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.YValue4 Property
MSChartSeries Class See Also Send Feedback
Gets or sets the data column or expression returns the fourth Y value of data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string YValue4 { get; set; }
Visual Basic (Declaration)
Public Property YValue4 As String
Visual C++
public:
property String^ YValue4 {
    String^ get ();
    void set (String^ value);
}

See Also

MSChartSeries Class
FastReport.MSChart Namespace


YValuesPerPoint Property

[image]

FastReport.Net Class Reference
MSChartSeries..::.YValuesPerPoint Property
MSChartSeries Class See Also Send Feedback
Gets a number of Y value per data point.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int YValuesPerPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property YValuesPerPoint As Integer
Visual C++
public:
property int YValuesPerPoint {
    int get ();
}

Remarks

Number of Y values depends on series type. Most of series have only one Y value. Financial series such as Stock and Candlestick, use four Y values.

See Also

MSChartSeries Class
FastReport.MSChart Namespace


MSChartSeries Events

[image] [image]

FastReport.Net Class Reference
MSChartSeries Events
MSChartSeries Class See Also Send Feedback

The MSChartSeries type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

MSChartSeries Class
FastReport.MSChart Namespace


PieExplode Enumeration

[image]

FastReport.Net Class Reference
PieExplode Enumeration
See Also Send Feedback
Specifies which pie value to explode.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PieExplode
Visual Basic (Declaration)
Public Enumeration PieExplode
Visual C++
public enum class PieExplode

Members

Member name | Description
None | Do not explode pie values.
BiggestValue | Explode the biggest value.
LowestValue | Explode the lowest value.
SpecificValue | Explode the value specified in the PieExplodeValue property.

See Also

FastReport.MSChart Namespace


SeriesCollection Class

[image]

FastReport.Net Class Reference
SeriesCollection Class
Members See Also Send Feedback
Represents a collection of MSChartSeries objects.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SeriesCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class SeriesCollection _
    Inherits FRCollectionBase
Visual C++
public ref class SeriesCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.MSChart..::.SeriesCollection

See Also

SeriesCollection Members
FastReport.MSChart Namespace


SeriesCollection Members

[image] [image]

FastReport.Net Class Reference
SeriesCollection Members
SeriesCollection Class Methods Properties See Also Send Feedback

The SeriesCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishData | Finishes the series data.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
ProcessData | Processes the current data row.
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ResetData | Resets series data.
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

SeriesCollection Class
FastReport.MSChart Namespace


SeriesCollection Methods

[image] [image]

FastReport.Net Class Reference
SeriesCollection Methods
SeriesCollection Class See Also Send Feedback

The SeriesCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishData | Finishes the series data.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from FRCollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from FRCollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
ProcessData | Processes the current data row.
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ResetData | Resets series data.
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesCollection Class
FastReport.MSChart Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
SeriesCollection..::.AddRange Method
SeriesCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

SeriesCollection Class
SeriesCollection Members
FastReport.MSChart Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
SeriesCollection..::.Equals Method
SeriesCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

SeriesCollection Class
SeriesCollection Members
FastReport.MSChart Namespace


FinishData Method

[image]

FastReport.Net Class Reference
SeriesCollection..::.FinishData Method
SeriesCollection Class See Also Send Feedback
Finishes the series data.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void FinishData()
Visual Basic (Declaration)
Public Sub FinishData
Visual C++
public:
void FinishData()

See Also

SeriesCollection Class
FastReport.MSChart Namespace


ProcessData Method

[image]

FastReport.Net Class Reference
SeriesCollection..::.ProcessData Method
SeriesCollection Class See Also Send Feedback
Processes the current data row.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ProcessData()
Visual Basic (Declaration)
Public Sub ProcessData
Visual C++
public:
void ProcessData()

See Also

SeriesCollection Class
FastReport.MSChart Namespace


ResetData Method

[image]

FastReport.Net Class Reference
SeriesCollection..::.ResetData Method
SeriesCollection Class See Also Send Feedback
Resets series data.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ResetData()
Visual Basic (Declaration)
Public Sub ResetData
Visual C++
public:
void ResetData()

See Also

SeriesCollection Class
FastReport.MSChart Namespace


SeriesCollection Properties

[image] [image]

FastReport.Net Class Reference
SeriesCollection Properties
SeriesCollection Class See Also Send Feedback

The SeriesCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

SeriesCollection Class
FastReport.MSChart Namespace


Item Property

[image]

FastReport.Net Class Reference
SeriesCollection..::.Item Property
SeriesCollection Class See Also Send Feedback
Gets the element at the specified index.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MSChartSeries this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As MSChartSeries
Visual C++
public:
property MSChartSeries^ default[int index] {
    MSChartSeries^ get (int index);
}

Parameters

index
Type: System..::.Int32
Index of an element.

Return Value

The element at the specified index.

See Also

SeriesCollection Class
FastReport.MSChart Namespace


SortBy Enumeration

[image]

FastReport.Net Class Reference
SortBy Enumeration
See Also Send Feedback
Specifies how the series points are sorted.

Namespace: FastReport.MSChart
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum SortBy
Visual Basic (Declaration)
Public Enumeration SortBy
Visual C++
public enum class SortBy

Members

Member name | Description
None | Points are not sorted.
XValue | Points are sorted by X value.
YValue | Points are sorted by Y value.

See Also

FastReport.MSChart Namespace


FastReport.Preview Namespace

[image]

FastReport.Net Class Reference
FastReport.Preview Namespace
Send Feedback

Classes

Class | Description
PreparedPages | Represents the pages of a prepared report.
PreviewControl | Represents a Windows Forms control used to preview a report.

Enumerations

Enumeration | Description
AddPageAction | Specifies an action that will be performed on PreparedPages.AddPage method call.


AddPageAction Enumeration

[image]

FastReport.Net Class Reference
AddPageAction Enumeration
See Also Send Feedback
Specifies an action that will be performed on PreparedPages.AddPage method call.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum AddPageAction
Visual Basic (Declaration)
Public Enumeration AddPageAction
Visual C++
public enum class AddPageAction

Members

Member name | Description
WriteOver | Do not add the new prepared page if possible, increment the CurPage instead.
Add | Add the new prepared page.

See Also

FastReport.Preview Namespace


PreparedPages Class

[image]

FastReport.Net Class Reference
PreparedPages Class
Members See Also Send Feedback
Represents the pages of a prepared report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PreparedPages : IDisposable
Visual Basic (Declaration)
Public Class PreparedPages _
    Implements IDisposable
Visual C++
public ref class PreparedPages : IDisposable

Remarks

Prepared page is a page that you can see in the preview window. Prepared pages can be accessed via PreparedPages property.

The common scenarios of using this object are:

  • Working with prepared pages after the report is finished: load (Load(String)) or save (Save(String)) pages from/to a .fpx file, get a page with specified index to work with its objects (GetPage(Int32)); modify specified page (ModifyPage(Int32, ReportPage)).
  • Using the AddPage(ReportPage), AddSourcePage(ReportPage), AddBand(BandBase) methods while report is generating to produce an output.

Inheritance Hierarchy

System..::.Object
FastReport.Preview..::.PreparedPages

See Also

PreparedPages Members
FastReport.Preview Namespace


PreparedPages Members

[image] [image]

FastReport.Net Class Reference
PreparedPages Members
PreparedPages Class Methods Properties See Also Send Feedback

The PreparedPages type exposes the following members.

Methods

Name | Description
AddBand | Prints a band with all its child objects.
AddPage | Adds a new page.
AddSourcePage | Adds a source page to the prepared pages dictionary.
Clear | Clears the prepared report's pages.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | Gets a page with specified index.
GetPageSize | Gets the size of specified page, in pixels.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ModifyPage | Replaces the prepared page with specified one.
RemovePage | Removes a page with the specified index.
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddPageAction | Specifies an action that will be performed on AddPage(ReportPage) method call.
CanUploadToCache | Gets or sets a value indicating whether the prepared pages can be uploaded to the file cache.
Count | Gets the number of pages in the prepared report.

See Also

PreparedPages Class
FastReport.Preview Namespace


PreparedPages Methods

[image] [image]

FastReport.Net Class Reference
PreparedPages Methods
PreparedPages Class See Also Send Feedback

The PreparedPages type exposes the following members.

Methods

Name | Description
AddBand | Prints a band with all its child objects.
AddPage | Adds a new page.
AddSourcePage | Adds a source page to the prepared pages dictionary.
Clear | Clears the prepared report's pages.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | Gets a page with specified index.
GetPageSize | Gets the size of specified page, in pixels.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ModifyPage | Replaces the prepared page with specified one.
RemovePage | Removes a page with the specified index.
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreparedPages Class
FastReport.Preview Namespace


AddBand Method

[image]

FastReport.Net Class Reference
PreparedPages..::.AddBand Method
PreparedPages Class See Also Send Feedback
Prints a band with all its child objects.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AddBand(
    BandBase band
)
Visual Basic (Declaration)
Public Function AddBand ( _
    band As BandBase _
) As Boolean
Visual C++
public:
bool AddBand(
    BandBase^ band
)

Parameters

band
Type: FastReport..::.BandBase
The band to print.

Return Value

true if band was printed; false if it can't be printed on current page due to its PrintOn property value.

Remarks

Call the AddPage(ReportPage) method before adding a band.

See Also

PreparedPages Class
FastReport.Preview Namespace


AddPage Method

[image]

FastReport.Net Class Reference
PreparedPages..::.AddPage Method
PreparedPages Class See Also Send Feedback
Adds a new page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddPage(
    ReportPage page
)
Visual Basic (Declaration)
Public Sub AddPage ( _
    page As ReportPage _
)
Visual C++
public:
void AddPage(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The original (template) page to add.

Remarks

Call the AddSourcePage(ReportPage) method before adding a page. This method creates a new output page with settings based on page parameter.

See Also

PreparedPages Class
FastReport.Preview Namespace


AddSourcePage Method

[image]

FastReport.Net Class Reference
PreparedPages..::.AddSourcePage Method
PreparedPages Class See Also Send Feedback
Adds a source page to the prepared pages dictionary.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddSourcePage(
    ReportPage page
)
Visual Basic (Declaration)
Public Sub AddSourcePage ( _
    page As ReportPage _
)
Visual C++
public:
void AddSourcePage(
    ReportPage^ page
)

Parameters

page
Type: FastReport..::.ReportPage
The template page to add.

Remarks

Call this method before using AddPage and AddBand methods. This method adds a page to the dictionary that will be used to decrease size of the prepared report.

See Also

PreparedPages Class
FastReport.Preview Namespace


Clear Method

[image]

FastReport.Net Class Reference
PreparedPages..::.Clear Method
PreparedPages Class See Also Send Feedback
Clears the prepared report's pages.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

PreparedPages Class
FastReport.Preview Namespace


Dispose Method

[image]

FastReport.Net Class Reference
PreparedPages..::.Dispose Method
PreparedPages Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

PreparedPages Class
FastReport.Preview Namespace


GetPage Method

[image]

FastReport.Net Class Reference
PreparedPages..::.GetPage Method
PreparedPages Class See Also Send Feedback
Gets a page with specified index.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportPage GetPage(
    int index
)
Visual Basic (Declaration)
Public Function GetPage ( _
    index As Integer _
) As ReportPage
Visual C++
public:
ReportPage^ GetPage(
    int index
)

Parameters

index
Type: System..::.Int32
Zero-based index of page.

Return Value

The page with specified index.

See Also

PreparedPages Class
FastReport.Preview Namespace


GetPageSize Method

[image]

FastReport.Net Class Reference
PreparedPages..::.GetPageSize Method
PreparedPages Class See Also Send Feedback
Gets the size of specified page, in pixels.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizeF GetPageSize(
    int index
)
Visual Basic (Declaration)
Public Function GetPageSize ( _
    index As Integer _
) As SizeF
Visual C++
public:
SizeF GetPageSize(
    int index
)

Parameters

index
Type: System..::.Int32
Index of page.

Return Value

the size of specified page, in pixels.

See Also

PreparedPages Class
FastReport.Preview Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
PreparedPages..::.Load Method
PreparedPages Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads prepared pages from a stream.
Load(String) | Loads prepared pages from a .fpx file.

See Also

PreparedPages Class
PreparedPages Members
FastReport.Preview Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
PreparedPages..::.Load Method (Stream)
PreparedPages Class See Also Send Feedback
Loads prepared pages from a stream.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

See Also

PreparedPages Class
Load Overload
FastReport.Preview Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
PreparedPages..::.Load Method (String)
PreparedPages Class See Also Send Feedback
Loads prepared pages from a .fpx file.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file to load from.

See Also

PreparedPages Class
Load Overload
FastReport.Preview Namespace


ModifyPage Method

[image]

FastReport.Net Class Reference
PreparedPages..::.ModifyPage Method
PreparedPages Class See Also Send Feedback
Replaces the prepared page with specified one.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ModifyPage(
    int index,
    ReportPage newPage
)
Visual Basic (Declaration)
Public Sub ModifyPage ( _
    index As Integer, _
    newPage As ReportPage _
)
Visual C++
public:
void ModifyPage(
    int index,
    ReportPage^ newPage
)

Parameters

index
Type: System..::.Int32
The index of prepared page to replace.
newPage
Type: FastReport..::.ReportPage
The new page to replace with.

See Also

PreparedPages Class
FastReport.Preview Namespace


RemovePage Method

[image]

FastReport.Net Class Reference
PreparedPages..::.RemovePage Method
PreparedPages Class See Also Send Feedback
Removes a page with the specified index.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemovePage(
    int index
)
Visual Basic (Declaration)
Public Sub RemovePage ( _
    index As Integer _
)
Visual C++
public:
void RemovePage(
    int index
)

Parameters

index
Type: System..::.Int32
The zero-based index of page to remove.

See Also

PreparedPages Class
FastReport.Preview Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
PreparedPages..::.Save Method
PreparedPages Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves prepared pages to a stream.
Save(String) | Saves prepared pages to a .fpx file.

See Also

PreparedPages Class
PreparedPages Members
FastReport.Preview Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
PreparedPages..::.Save Method (Stream)
PreparedPages Class See Also Send Feedback
Saves prepared pages to a stream.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to save to.

See Also

PreparedPages Class
Save Overload
FastReport.Preview Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
PreparedPages..::.Save Method (String)
PreparedPages Class See Also Send Feedback
Saves prepared pages to a .fpx file.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file to save to.

See Also

PreparedPages Class
Save Overload
FastReport.Preview Namespace


PreparedPages Properties

[image] [image]

FastReport.Net Class Reference
PreparedPages Properties
PreparedPages Class See Also Send Feedback

The PreparedPages type exposes the following members.

Properties

Name | Description
AddPageAction | Specifies an action that will be performed on AddPage(ReportPage) method call.
CanUploadToCache | Gets or sets a value indicating whether the prepared pages can be uploaded to the file cache.
Count | Gets the number of pages in the prepared report.

See Also

PreparedPages Class
FastReport.Preview Namespace


AddPageAction Property

[image]

FastReport.Net Class Reference
PreparedPages..::.AddPageAction Property
PreparedPages Class See Also Send Feedback
Specifies an action that will be performed on AddPage(ReportPage) method call.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AddPageAction AddPageAction { get; set; }
Visual Basic (Declaration)
Public Property AddPageAction As AddPageAction
Visual C++
public:
property AddPageAction AddPageAction {
    AddPageAction get ();
    void set (AddPageAction value);
}

See Also

PreparedPages Class
FastReport.Preview Namespace


CanUploadToCache Property

[image]

FastReport.Net Class Reference
PreparedPages..::.CanUploadToCache Property
PreparedPages Class See Also Send Feedback
Gets or sets a value indicating whether the prepared pages can be uploaded to the file cache.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanUploadToCache { get; set; }
Visual Basic (Declaration)
Public Property CanUploadToCache As Boolean
Visual C++
public:
property bool CanUploadToCache {
    bool get ();
    void set (bool value);
}

Remarks

This property is used while report is generating.

Default value for this property is true. That means the prepared pages may be uploaded to the file cache if needed. To prevent this (for example, if you need to access some objects on previously generated pages), set the property value to false.

See Also

PreparedPages Class
FastReport.Preview Namespace


Count Property

[image]

FastReport.Net Class Reference
PreparedPages..::.Count Property
PreparedPages Class See Also Send Feedback
Gets the number of pages in the prepared report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

PreparedPages Class
FastReport.Preview Namespace


PreviewControl Class

[image]

FastReport.Net Class Reference
PreviewControl Class
Members See Also Send Feedback
Represents a Windows Forms control used to preview a report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PreviewControl : UserControl
Visual Basic (Declaration)
Public Class PreviewControl _
    Inherits UserControl
Visual C++
public ref class PreviewControl : public UserControl

Remarks

To use this control, place it on a form and link it to a report using the report's Preview property. To show a report, call the Report.Show method:
CopyC#
report1.Preview = previewControl1;
report1.Show();

Use this control's methods such as Print()()(), Save()()() etc. to handle the preview. Call Clear()()() method to clear the preview.

You can specify whether the standard toolbar is visible in the ToolbarVisible property. The StatusbarVisible property allows you to hide/show the statusbar.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
FastReport.Preview..::.PreviewControl

See Also

PreviewControl Members
FastReport.Preview Namespace


PreviewControl Members

[image] [image]

FastReport.Net Class Reference
PreviewControl Members
PreviewControl Class Constructors Methods Properties Events See Also Send Feedback

The PreviewControl type exposes the following members.

Constructors

Name | Description
PreviewControl | Initializes a new instance of the PreviewControl class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddTab | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Clear | Clears the preview.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DeleteTab | Deletes the report tab with specified text.
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EditPage | Edits the current page in the designer.
EditWatermark | Edits the watermark.
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Find | Overloaded.
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindNext | Finds the next occurence of text specified in the Find method.
First | Navigates to the first page.
Focus | Sets the focus to the preview control.
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Last | Navigates to the last page.
Load | Overloaded.
MemberwiseClone | Overloaded.
Next | Navigates to the next page.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PageSetup | Edits the page settings.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PositionTo | Navigates to the specified position inside a specified page.
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Prints the current report.
Prior | Navigates to the previuos page.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshReport | Refresh the report.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendEmail | Sends an email.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowStatus | Displays the text in the status bar.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
SwitchToTab | Switches to the tab with specified text.
TabExists | Checks if the tab with specified text exists.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)
ZoomIn | Zooms in.
ZoomOut | Zooms out.
ZoomPageWidth | Zooms to fit the page width.
ZoomWholePage | Zooms to fit the whole page.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActivePageBorderColor | Gets or sets the color of active page border.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Buttons | Specifies the set of buttons available in the toolbar.
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FastScrolling | Gets or sets a value indicating whether the fast scrolling method should be used.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OutlineVisible | Gets or sets a value indicating whether the outline control is visible.
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageBorderColor | Obsolete. Gets or sets the color of page border.
PageCount | Gets the pages count in the current report.
PageNo | Gets or sets the current page number.
PageOffset | Gets or sets the first page offset from the top left corner of the control.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets a reference to the report.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
StatusBar | Gets the preview window's statusbar.
StatusbarVisible | Gets or sets a value indicating whether the statusbar is visible.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ToolBar | Gets the preview window's toolbar.
ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UIStyle | Gets or sets the visual style.
UseBackColor | Gets or sets a value indicating that the BackColor property must be used to draw the background area.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Zoom | Gets or sets the zoom factor.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
PageChanged | Occurs when current page number is changed.
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PreviewControl Class
FastReport.Preview Namespace


PreviewControl Constructor

[image]

FastReport.Net Class Reference
PreviewControl Constructor
PreviewControl Class See Also Send Feedback
Initializes a new instance of the PreviewControl class.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PreviewControl()

See Also

PreviewControl Class
FastReport.Preview Namespace


PreviewControl Methods

[image] [image]

FastReport.Net Class Reference
PreviewControl Methods
PreviewControl Class See Also Send Feedback

The PreviewControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddTab | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Clear | Clears the preview.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DeleteTab | Deletes the report tab with specified text.
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EditPage | Edits the current page in the designer.
EditWatermark | Edits the watermark.
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Find | Overloaded.
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindNext | Finds the next occurence of text specified in the Find method.
First | Navigates to the first page.
Focus | Sets the focus to the preview control.
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Last | Navigates to the last page.
Load | Overloaded.
MemberwiseClone | Overloaded.
Next | Navigates to the next page.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PageSetup | Edits the page settings.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PositionTo | Navigates to the specified position inside a specified page.
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Prints the current report.
Prior | Navigates to the previuos page.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshReport | Refresh the report.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendEmail | Sends an email.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowStatus | Displays the text in the status bar.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
SwitchToTab | Switches to the tab with specified text.
TabExists | Checks if the tab with specified text exists.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)
ZoomIn | Zooms in.
ZoomOut | Zooms out.
ZoomPageWidth | Zooms to fit the page width.
ZoomWholePage | Zooms to fit the whole page.

See Also

PreviewControl Class
FastReport.Preview Namespace


AccessibilityNotifyClients Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.AccessibilityNotifyClients Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


AddTab Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.AddTab Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
AddTab(Report, String) | Adds a new report tab to the preview control.
AddTab(Report, String, Boolean) | Adds a new report tab to the preview control.

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


AddTab Method (Report, String)

[image]

FastReport.Net Class Reference
PreviewControl..::.AddTab Method (Report, String)
PreviewControl Class See Also Send Feedback
Adds a new report tab to the preview control.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddTab(
    Report report,
    string text
)
Visual Basic (Declaration)
Public Sub AddTab ( _
    report As Report, _
    text As String _
)
Visual C++
public:
void AddTab(
    Report^ report,
    String^ text
)

Parameters

report
Type: FastReport..::.Report
The Report object that contains the prepared report.
text
Type: System..::.String
The title for the new tab.

Remarks

Prepare the report using its Prepare method before you pass it to the report parameter.

See Also

PreviewControl Class
AddTab Overload
FastReport.Preview Namespace


AddTab Method (Report, String, Boolean)

[image]

FastReport.Net Class Reference
PreviewControl..::.AddTab Method (Report, String, Boolean)
PreviewControl Class See Also Send Feedback
Adds a new report tab to the preview control.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddTab(
    Report report,
    string text,
    bool setActive
)
Visual Basic (Declaration)
Public Sub AddTab ( _
    report As Report, _
    text As String, _
    setActive As Boolean _
)
Visual C++
public:
void AddTab(
    Report^ report,
    String^ text,
    bool setActive
)

Parameters

report
Type: FastReport..::.Report
The Report object that contains the prepared report.
text
Type: System..::.String
The title for the new tab.
setActive
Type: System..::.Boolean
If true, makes the new tab active.

Remarks

Prepare the report using its Prepare method before you pass it to the report parameter.

See Also

PreviewControl Class
AddTab Overload
FastReport.Preview Namespace


BeginInvoke Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.BeginInvoke Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Clear Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Clear Method
PreviewControl Class See Also Send Feedback
Clears the preview.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

PreviewControl Class
FastReport.Preview Namespace


DeleteTab Method

[image]

FastReport.Net Class Reference
PreviewControl..::.DeleteTab Method
PreviewControl Class See Also Send Feedback
Deletes the report tab with specified text.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void DeleteTab(
    string text
)
Visual Basic (Declaration)
Public Sub DeleteTab ( _
    text As String _
)
Visual C++
public:
void DeleteTab(
    String^ text
)

Parameters

text
Type: System..::.String
The text of the tab.

See Also

PreviewControl Class
FastReport.Preview Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Dispose Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
PreviewControl..::.Dispose Method (Boolean)
PreviewControl Class See Also Send Feedback

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

PreviewControl Class
Dispose Overload
FastReport.Preview Namespace


EditPage Method

[image]

FastReport.Net Class Reference
PreviewControl..::.EditPage Method
PreviewControl Class See Also Send Feedback
Edits the current page in the designer.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EditPage()
Visual Basic (Declaration)
Public Sub EditPage
Visual C++
public:
void EditPage()

See Also

PreviewControl Class
FastReport.Preview Namespace


EditWatermark Method

[image]

FastReport.Net Class Reference
PreviewControl..::.EditWatermark Method
PreviewControl Class See Also Send Feedback
Edits the watermark.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EditWatermark()
Visual Basic (Declaration)
Public Sub EditWatermark
Visual C++
public:
void EditWatermark()

See Also

PreviewControl Class
FastReport.Preview Namespace


Find Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Find Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Find()()() | Finds the text in the current report using the "Find Text" dialog.
Find(String, Boolean, Boolean) | Finds the specified text in the current report.

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Find Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Find Method
PreviewControl Class See Also Send Feedback
Finds the text in the current report using the "Find Text" dialog.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Find()
Visual Basic (Declaration)
Public Sub Find
Visual C++
public:
void Find()

See Also

PreviewControl Class
Find Overload
FastReport.Preview Namespace


Find Method (String, Boolean, Boolean)

[image]

FastReport.Net Class Reference
PreviewControl..::.Find Method (String, Boolean, Boolean)
PreviewControl Class See Also Send Feedback
Finds the specified text in the current report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Find(
    string text,
    bool matchCase,
    bool wholeWord
)
Visual Basic (Declaration)
Public Function Find ( _
    text As String, _
    matchCase As Boolean, _
    wholeWord As Boolean _
) As Boolean
Visual C++
public:
bool Find(
    String^ text,
    bool matchCase,
    bool wholeWord
)

Parameters

text
Type: System..::.String
Text to find.
matchCase
Type: System..::.Boolean
A value indicating whether the search is case-sensitive.
wholeWord
Type: System..::.Boolean
A value indicating whether the search matches whole words only.

Return Value

true if text found.

See Also

PreviewControl Class
Find Overload
FastReport.Preview Namespace


FindNext Method

[image]

FastReport.Net Class Reference
PreviewControl..::.FindNext Method
PreviewControl Class See Also Send Feedback
Finds the next occurence of text specified in the Find method.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FindNext()
Visual Basic (Declaration)
Public Function FindNext As Boolean
Visual C++
public:
bool FindNext()

Return Value

true if text found.

See Also

PreviewControl Class
FastReport.Preview Namespace


First Method

[image]

FastReport.Net Class Reference
PreviewControl..::.First Method
PreviewControl Class See Also Send Feedback
Navigates to the first page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void First()
Visual Basic (Declaration)
Public Sub First
Visual C++
public:
void First()

See Also

PreviewControl Class
FastReport.Preview Namespace


Focus Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Focus Method
PreviewControl Class See Also Send Feedback
Sets the focus to the preview control.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Focus()
Visual Basic (Declaration)
Public Sub Focus
Visual C++
public:
void Focus()

See Also

PreviewControl Class
FastReport.Preview Namespace


GetChildAtPoint Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.GetChildAtPoint Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Invalidate Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Invalidate Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Invoke Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Invoke Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Last Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Last Method
PreviewControl Class See Also Send Feedback
Navigates to the last page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Last()
Visual Basic (Declaration)
Public Sub Last
Visual C++
public:
void Last()

See Also

PreviewControl Class
FastReport.Preview Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Load Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the report from a .fpx file using the "Open File" dialog.
Load(Stream) | Load the report from a stream.
Load(String) | Loads the report from a specified .fpx file.

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Load Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Load Method
PreviewControl Class See Also Send Feedback
Loads the report from a .fpx file using the "Open File" dialog.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load()
Visual Basic (Declaration)
Public Sub Load
Visual C++
public:
void Load()

See Also

PreviewControl Class
Load Overload
FastReport.Preview Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
PreviewControl..::.Load Method (Stream)
PreviewControl Class See Also Send Feedback
Load the report from a stream.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

See Also

PreviewControl Class
Load Overload
FastReport.Preview Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
PreviewControl..::.Load Method (String)
PreviewControl Class See Also Send Feedback
Loads the report from a specified .fpx file.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

PreviewControl Class
Load Overload
FastReport.Preview Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.MemberwiseClone Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Next Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Next Method
PreviewControl Class See Also Send Feedback
Navigates to the next page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Next()
Visual Basic (Declaration)
Public Sub Next
Visual C++
public:
void Next()

See Also

PreviewControl Class
FastReport.Preview Namespace


PageSetup Method

[image]

FastReport.Net Class Reference
PreviewControl..::.PageSetup Method
PreviewControl Class See Also Send Feedback
Edits the page settings.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PageSetup()
Visual Basic (Declaration)
Public Sub PageSetup
Visual C++
public:
void PageSetup()

See Also

PreviewControl Class
FastReport.Preview Namespace


PerformLayout Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.PerformLayout Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


PositionTo Method

[image]

FastReport.Net Class Reference
PreviewControl..::.PositionTo Method
PreviewControl Class See Also Send Feedback
Navigates to the specified position inside a specified page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PositionTo(
    int pageNo,
    PointF point
)
Visual Basic (Declaration)
Public Sub PositionTo ( _
    pageNo As Integer, _
    point As PointF _
)
Visual C++
public:
void PositionTo(
    int pageNo,
    PointF point
)

Parameters

pageNo
Type: System..::.Int32
The page number (1-based).
point
Type: System.Drawing..::.PointF
The position inside a page, in pixels.

See Also

PreviewControl Class
FastReport.Preview Namespace


Print Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Print Method
PreviewControl Class See Also Send Feedback
Prints the current report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Print()
Visual Basic (Declaration)
Public Function Print As Boolean
Visual C++
public:
bool Print()

Return Value

true if report was printed; false if user cancels the "Print" dialog.

See Also

PreviewControl Class
FastReport.Preview Namespace


Prior Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Prior Method
PreviewControl Class See Also Send Feedback
Navigates to the previuos page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Prior()
Visual Basic (Declaration)
Public Sub Prior
Visual C++
public:
void Prior()

See Also

PreviewControl Class
FastReport.Preview Namespace


RefreshReport Method

[image]

FastReport.Net Class Reference
PreviewControl..::.RefreshReport Method
PreviewControl Class See Also Send Feedback
Refresh the report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RefreshReport()
Visual Basic (Declaration)
Public Sub RefreshReport
Visual C++
public:
void RefreshReport()

See Also

PreviewControl Class
FastReport.Preview Namespace


ResumeLayout Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.ResumeLayout Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


RtlTranslateAlignment Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.RtlTranslateAlignment Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Save Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Save()()() | Saves the current report to a .fpx file using the "Save FIle" dialog.
Save(Stream) | Saves the current report to a stream.
Save(String) | Saves the current report to a specified .fpx file.

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Save Method

[image]

FastReport.Net Class Reference
PreviewControl..::.Save Method
PreviewControl Class See Also Send Feedback
Saves the current report to a .fpx file using the "Save FIle" dialog.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save
Visual C++
public:
void Save()

See Also

PreviewControl Class
Save Overload
FastReport.Preview Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
PreviewControl..::.Save Method (Stream)
PreviewControl Class See Also Send Feedback
Saves the current report to a stream.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

PreviewControl Class
Save Overload
FastReport.Preview Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
PreviewControl..::.Save Method (String)
PreviewControl Class See Also Send Feedback
Saves the current report to a specified .fpx file.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

PreviewControl Class
Save Overload
FastReport.Preview Namespace


Scale Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Scale Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Select Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Select Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


SendEmail Method

[image]

FastReport.Net Class Reference
PreviewControl..::.SendEmail Method
PreviewControl Class See Also Send Feedback
Sends an email.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SendEmail()
Visual Basic (Declaration)
Public Sub SendEmail
Visual C++
public:
void SendEmail()

See Also

PreviewControl Class
FastReport.Preview Namespace


SetBounds Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.SetBounds Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


ShowStatus Method

[image]

FastReport.Net Class Reference
PreviewControl..::.ShowStatus Method
PreviewControl Class See Also Send Feedback
Displays the text in the status bar.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ShowStatus(
    string text
)
Visual Basic (Declaration)
Public Sub ShowStatus ( _
    text As String _
)
Visual C++
public:
void ShowStatus(
    String^ text
)

Parameters

text
Type: System..::.String
Text to display.

See Also

PreviewControl Class
FastReport.Preview Namespace


SwitchToTab Method

[image]

FastReport.Net Class Reference
PreviewControl..::.SwitchToTab Method
PreviewControl Class See Also Send Feedback
Switches to the tab with specified text.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SwitchToTab(
    string text
)
Visual Basic (Declaration)
Public Function SwitchToTab ( _
    text As String _
) As Boolean
Visual C++
public:
bool SwitchToTab(
    String^ text
)

Parameters

text
Type: System..::.String
Text of the tab.

Return Value

true if the tab with specified text exists, or false if there is no such tab.

See Also

PreviewControl Class
FastReport.Preview Namespace


TabExists Method

[image]

FastReport.Net Class Reference
PreviewControl..::.TabExists Method
PreviewControl Class See Also Send Feedback
Checks if the tab with specified text exists.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool TabExists(
    string text
)
Visual Basic (Declaration)
Public Function TabExists ( _
    text As String _
) As Boolean
Visual C++
public:
bool TabExists(
    String^ text
)

Parameters

text
Type: System..::.String
The text of the tab.

Return Value

true if the tab exists.

See Also

PreviewControl Class
FastReport.Preview Namespace


UpdateBounds Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.UpdateBounds Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


Validate Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.Validate Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


ValidateChildren Method

[image] [image]

FastReport.Net Class Reference
PreviewControl..::.ValidateChildren Method
PreviewControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

PreviewControl Class
PreviewControl Members
FastReport.Preview Namespace


ZoomIn Method

[image]

FastReport.Net Class Reference
PreviewControl..::.ZoomIn Method
PreviewControl Class See Also Send Feedback
Zooms in.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ZoomIn()
Visual Basic (Declaration)
Public Sub ZoomIn
Visual C++
public:
void ZoomIn()

See Also

PreviewControl Class
FastReport.Preview Namespace


ZoomOut Method

[image]

FastReport.Net Class Reference
PreviewControl..::.ZoomOut Method
PreviewControl Class See Also Send Feedback
Zooms out.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ZoomOut()
Visual Basic (Declaration)
Public Sub ZoomOut
Visual C++
public:
void ZoomOut()

See Also

PreviewControl Class
FastReport.Preview Namespace


ZoomPageWidth Method

[image]

FastReport.Net Class Reference
PreviewControl..::.ZoomPageWidth Method
PreviewControl Class See Also Send Feedback
Zooms to fit the page width.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ZoomPageWidth()
Visual Basic (Declaration)
Public Sub ZoomPageWidth
Visual C++
public:
void ZoomPageWidth()

See Also

PreviewControl Class
FastReport.Preview Namespace


ZoomWholePage Method

[image]

FastReport.Net Class Reference
PreviewControl..::.ZoomWholePage Method
PreviewControl Class See Also Send Feedback
Zooms to fit the whole page.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ZoomWholePage()
Visual Basic (Declaration)
Public Sub ZoomWholePage
Visual C++
public:
void ZoomWholePage()

See Also

PreviewControl Class
FastReport.Preview Namespace


PreviewControl Properties

[image] [image]

FastReport.Net Class Reference
PreviewControl Properties
PreviewControl Class See Also Send Feedback

The PreviewControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActivePageBorderColor | Gets or sets the color of active page border.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Buttons | Specifies the set of buttons available in the toolbar.
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FastScrolling | Gets or sets a value indicating whether the fast scrolling method should be used.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OutlineVisible | Gets or sets a value indicating whether the outline control is visible.
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageBorderColor | Obsolete. Gets or sets the color of page border.
PageCount | Gets the pages count in the current report.
PageNo | Gets or sets the current page number.
PageOffset | Gets or sets the first page offset from the top left corner of the control.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Report | Gets a reference to the report.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
StatusBar | Gets the preview window's statusbar.
StatusbarVisible | Gets or sets a value indicating whether the statusbar is visible.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ToolBar | Gets the preview window's toolbar.
ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UIStyle | Gets or sets the visual style.
UseBackColor | Gets or sets a value indicating that the BackColor property must be used to draw the background area.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Zoom | Gets or sets the zoom factor.

See Also

PreviewControl Class
FastReport.Preview Namespace


ActivePageBorderColor Property

[image]

FastReport.Net Class Reference
PreviewControl..::.ActivePageBorderColor Property
PreviewControl Class See Also Send Feedback
Gets or sets the color of active page border.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color ActivePageBorderColor { get; set; }
Visual Basic (Declaration)
Public Property ActivePageBorderColor As Color
Visual C++
public:
property Color ActivePageBorderColor {
    Color get ();
    void set (Color value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


Buttons Property

[image]

FastReport.Net Class Reference
PreviewControl..::.Buttons Property
PreviewControl Class See Also Send Feedback
Specifies the set of buttons available in the toolbar.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PreviewButtons Buttons { get; set; }
Visual Basic (Declaration)
Public Property Buttons As PreviewButtons
Visual C++
public:
property PreviewButtons Buttons {
    PreviewButtons get ();
    void set (PreviewButtons value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


FastScrolling Property

[image]

FastReport.Net Class Reference
PreviewControl..::.FastScrolling Property
PreviewControl Class See Also Send Feedback
Gets or sets a value indicating whether the fast scrolling method should be used.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool FastScrolling { get; set; }
Visual Basic (Declaration)
Public Property FastScrolling As Boolean
Visual C++
public:
property bool FastScrolling {
    bool get ();
    void set (bool value);
}

Remarks

If you enable this property, the gradient background will be disabled.

See Also

PreviewControl Class
FastReport.Preview Namespace


OutlineVisible Property

[image]

FastReport.Net Class Reference
PreviewControl..::.OutlineVisible Property
PreviewControl Class See Also Send Feedback
Gets or sets a value indicating whether the outline control is visible.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool OutlineVisible { get; set; }
Visual Basic (Declaration)
Public Property OutlineVisible As Boolean
Visual C++
public:
property bool OutlineVisible {
    bool get ();
    void set (bool value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


PageBorderColor Property

[image]

FastReport.Net Class Reference
PreviewControl..::.PageBorderColor Property
PreviewControl Class See Also Send Feedback
Obsolete. Gets or sets the color of page border.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Color PageBorderColor { get; set; }
Visual Basic (Declaration)
Public Property PageBorderColor As Color
Visual C++
public:
property Color PageBorderColor {
    Color get ();
    void set (Color value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


PageCount Property

[image]

FastReport.Net Class Reference
PreviewControl..::.PageCount Property
PreviewControl Class See Also Send Feedback
Gets the pages count in the current report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

PreviewControl Class
FastReport.Preview Namespace


PageNo Property

[image]

FastReport.Net Class Reference
PreviewControl..::.PageNo Property
PreviewControl Class See Also Send Feedback
Gets or sets the current page number.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int PageNo { get; set; }
Visual Basic (Declaration)
Public Property PageNo As Integer
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Remarks

This value is 1-based.

See Also

PreviewControl Class
FastReport.Preview Namespace


PageOffset Property

[image]

FastReport.Net Class Reference
PreviewControl..::.PageOffset Property
PreviewControl Class See Also Send Feedback
Gets or sets the first page offset from the top left corner of the control.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Point PageOffset { get; set; }
Visual Basic (Declaration)
Public Property PageOffset As Point
Visual C++
public:
property Point PageOffset {
    Point get ();
    void set (Point value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


Report Property

[image]

FastReport.Net Class Reference
PreviewControl..::.Report Property
PreviewControl Class See Also Send Feedback
Gets a reference to the report.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
}

See Also

PreviewControl Class
FastReport.Preview Namespace


StatusBar Property

[image]

FastReport.Net Class Reference
PreviewControl..::.StatusBar Property
PreviewControl Class See Also Send Feedback
Gets the preview window's statusbar.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Bar StatusBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property StatusBar As Bar
Visual C++
public:
property Bar^ StatusBar {
    Bar^ get ();
}

See Also

PreviewControl Class
FastReport.Preview Namespace


StatusbarVisible Property

[image]

FastReport.Net Class Reference
PreviewControl..::.StatusbarVisible Property
PreviewControl Class See Also Send Feedback
Gets or sets a value indicating whether the statusbar is visible.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool StatusbarVisible { get; set; }
Visual Basic (Declaration)
Public Property StatusbarVisible As Boolean
Visual C++
public:
property bool StatusbarVisible {
    bool get ();
    void set (bool value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


ToolBar Property

[image]

FastReport.Net Class Reference
PreviewControl..::.ToolBar Property
PreviewControl Class See Also Send Feedback
Gets the preview window's toolbar.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Bar ToolBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToolBar As Bar
Visual C++
public:
property Bar^ ToolBar {
    Bar^ get ();
}

See Also

PreviewControl Class
FastReport.Preview Namespace


ToolbarVisible Property

[image]

FastReport.Net Class Reference
PreviewControl..::.ToolbarVisible Property
PreviewControl Class See Also Send Feedback
Gets or sets a value indicating whether the toolbar is visible.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ToolbarVisible { get; set; }
Visual Basic (Declaration)
Public Property ToolbarVisible As Boolean
Visual C++
public:
property bool ToolbarVisible {
    bool get ();
    void set (bool value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


UIStyle Property

[image]

FastReport.Net Class Reference
PreviewControl..::.UIStyle Property
PreviewControl Class See Also Send Feedback
Gets or sets the visual style.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UIStyle UIStyle { get; set; }
Visual Basic (Declaration)
Public Property UIStyle As UIStyle
Visual C++
public:
property UIStyle UIStyle {
    UIStyle get ();
    void set (UIStyle value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


UseBackColor Property

[image]

FastReport.Net Class Reference
PreviewControl..::.UseBackColor Property
PreviewControl Class See Also Send Feedback
Gets or sets a value indicating that the BackColor property must be used to draw the background area.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool UseBackColor { get; set; }
Visual Basic (Declaration)
Public Property UseBackColor As Boolean
Visual C++
public:
property bool UseBackColor {
    bool get ();
    void set (bool value);
}

Remarks

By default, the background area is drawn using the color defined in the current UIStyle.

See Also

PreviewControl Class
FastReport.Preview Namespace


Zoom Property

[image]

FastReport.Net Class Reference
PreviewControl..::.Zoom Property
PreviewControl Class See Also Send Feedback
Gets or sets the zoom factor.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Single
Visual C++
public:
property float Zoom {
    float get ();
    void set (float value);
}

Remarks

1 corresponds to 100% zoom.

See Also

PreviewControl Class
FastReport.Preview Namespace


PreviewControl Events

[image] [image]

FastReport.Net Class Reference
PreviewControl Events
PreviewControl Class See Also Send Feedback

The PreviewControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
PageChanged | Occurs when current page number is changed.
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PreviewControl Class
FastReport.Preview Namespace


PageChanged Event

[image]

FastReport.Net Class Reference
PreviewControl..::.PageChanged Event
PreviewControl Class See Also Send Feedback
Occurs when current page number is changed.

Namespace: FastReport.Preview
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler PageChanged
Visual Basic (Declaration)
Public Event PageChanged As EventHandler
Visual C++
public:
 event EventHandler^ PageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

PreviewControl Class
FastReport.Preview Namespace


FastReport.Table Namespace

[image]

FastReport.Net Class Reference
FastReport.Table Namespace
Send Feedback

Classes

Class | Description
TableBase | The base class for table-type controls such as TableObject and MatrixObject.
TableCell | Represents a table cell.
TableColumn | Represents a table column.
TableColumnCollection | Represents a collection of TableColumn objects.
TableObject | Represents a table object that consists of several rows and columns.
TableResult | Represents a result table.
TableRow | Represents a table row.
TableRowCollection | Represents a collection of TableRow objects.

Enumerations

Enumeration | Description
TableLayout | Specifies the layout that will be used when printing a big table.


TableBase Class

[image]

FastReport.Net Class Reference
TableBase Class
Members See Also Send Feedback
The base class for table-type controls such as TableObject and MatrixObject.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableBase : BreakableComponent, IParent
Visual Basic (Declaration)
Public Class TableBase _
    Inherits BreakableComponent _
    Implements IParent
Visual C++
public ref class TableBase : public BreakableComponent,
    IParent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport.Table..::.TableBase
FastReport.Matrix..::.MatrixObject
FastReport.Table..::.TableObject
FastReport.Table..::.TableResult

See Also

TableBase Members
FastReport.Table Namespace


TableBase Members

[image] [image]

FastReport.Net Class Reference
TableBase Members
TableBase Class Constructors Methods Properties Events See Also Send Feedback

The TableBase type exposes the following members.

Constructors

Name | Description
TableBase | Initializes a new instance of the TableBase class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BreakableComponent..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell.
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CalcWidth | Calculates and returns the table width, in pixels.
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Overrides ComponentBase..::.HandleKeyDown(Control, KeyEventArgs).)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Overrides ReportComponentBase..::.IsVisible(FRPaintEventArgs).)
Max | Calculates a maximum of values in a specified cell.
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BreakableComponent..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages.
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class.
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | Gets or sets a number of columns in the table.
Columns | Gets a collection of table columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FixedColumns | Gets or sets the number of fixed columns that will be repeated on each page.
FixedRows | Gets or sets the number of fixed rows that will be repeated on each page.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Overrides ReportComponentBase..::.Height.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Overrides Base..::.IsSelected.)
Item | Gets or sets the table cell.
Layout | Gets or sets the table layout.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table.
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the table.
Rows | Gets a collection of table rows.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableBase Class
FastReport.Table Namespace


TableBase Constructor

[image]

FastReport.Net Class Reference
TableBase Constructor
TableBase Class See Also Send Feedback
Initializes a new instance of the TableBase class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableBase()

See Also

TableBase Class
FastReport.Table Namespace


TableBase Methods

[image] [image]

FastReport.Net Class Reference
TableBase Methods
TableBase Class See Also Send Feedback

The TableBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides BreakableComponent..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell.
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Overrides BreakableComponent..::.Break(BreakableComponent).)
CalcHeight | Calculates the object's height. (Overrides ReportComponentBase..::.CalcHeight()()().)
CalcWidth | Calculates and returns the table width, in pixels.
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells.
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides ReportComponentBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ReportComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Overrides ComponentBase..::.HandleKeyDown(Control, KeyEventArgs).)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Overrides ReportComponentBase..::.IsVisible(FRPaintEventArgs).)
Max | Calculates a maximum of values in a specified cell.
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Overrides ReportComponentBase..::.OnAfterInsert(InsertFrom).)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Overrides Base..::.OnBeforeInsert(Int32).)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides ReportComponentBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides ReportComponentBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides BreakableComponent..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

TableBase Class
FastReport.Table Namespace


AddChild Method

[image]

FastReport.Net Class Reference
TableBase..::.AddChild Method
TableBase Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

TableBase Class
FastReport.Table Namespace


Assign Method

[image]

FastReport.Net Class Reference
TableBase..::.Assign Method
TableBase Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TableBase Class
FastReport.Table Namespace
AssignAll Method


Avg Method

[image]

FastReport.Net Class Reference
TableBase..::.Avg Method
TableBase Class See Also Send Feedback
Calculates an average of values in a specified cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Avg(
    TableCell aggregateCell
)
Visual Basic (Declaration)
Public Function Avg ( _
    aggregateCell As TableCell _
) As Object
Visual C++
public:
Object^ Avg(
    TableCell^ aggregateCell
)

Parameters

aggregateCell
Type: FastReport.Table..::.TableCell
The cell.

Return Value

The object that contains calculated value.

Remarks

This method can be called from the ManualBuild event handler only.

See Also

TableBase Class
FastReport.Table Namespace


Break Method

[image]

FastReport.Net Class Reference
TableBase..::.Break Method
TableBase Class See Also Send Feedback
Breaks the contents of the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Break(
    BreakableComponent breakTo
)
Visual Basic (Declaration)
Public Overrides Function Break ( _
    breakTo As BreakableComponent _
) As Boolean
Visual C++
public:
virtual bool Break(
    BreakableComponent^ breakTo
) override

Parameters

breakTo
Type: FastReport..::.BreakableComponent
Object to put the part of content to that does not fit in this object. These two objects must have the same type.

Return Value

true if there is enough space in this object to display at least one text line.

Remarks

Do not call this method directly, it is used by the report engine. You should override it if you are writing a new FastReport object.

This method must break the contents of the object. The part of content that fit in current object's bounds should remain in this object, the part that does not fit should be transferred to breakTo object.

See Also

TableBase Class
FastReport.Table Namespace


CalcHeight Method

[image]

FastReport.Net Class Reference
TableBase..::.CalcHeight Method
TableBase Class See Also Send Feedback
Calculates the object's height.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float CalcHeight()
Visual Basic (Declaration)
Public Overrides Function CalcHeight As Single
Visual C++
public:
virtual float CalcHeight() override

Return Value

Actual object's height, in pixels.

Remarks

Applicable to objects that contain several text lines, such as TextObject. Returns the height needed to display all the text lines.

See Also

TableBase Class
FastReport.Table Namespace


CalcWidth Method

[image]

FastReport.Net Class Reference
TableBase..::.CalcWidth Method
TableBase Class See Also Send Feedback
Calculates and returns the table width, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float CalcWidth()
Visual Basic (Declaration)
Public Function CalcWidth As Single
Visual C++
public:
float CalcWidth()

See Also

TableBase Class
FastReport.Table Namespace


CanContain Method

[image]

FastReport.Net Class Reference
TableBase..::.CanContain Method
TableBase Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

TableBase Class
FastReport.Table Namespace


Count Method

[image]

FastReport.Net Class Reference
TableBase..::.Count Method
TableBase Class See Also Send Feedback
Calculates number of repeats of a specified cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Count(
    TableCell aggregateCell
)
Visual Basic (Declaration)
Public Function Count ( _
    aggregateCell As TableCell _
) As Object
Visual C++
public:
Object^ Count(
    TableCell^ aggregateCell
)

Parameters

aggregateCell
Type: FastReport.Table..::.TableCell
The cell.

Return Value

The object that contains calculated value.

Remarks

This method can be called from the ManualBuild event handler only.

See Also

TableBase Class
FastReport.Table Namespace


CreateUniqueNames Method

[image]

FastReport.Net Class Reference
TableBase..::.CreateUniqueNames Method
TableBase Class See Also Send Feedback
Creates unique names for all table elements such as rows, columns, cells.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateUniqueNames()
Visual Basic (Declaration)
Public Sub CreateUniqueNames
Visual C++
public:
void CreateUniqueNames()

See Also

TableBase Class
FastReport.Table Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableBase..::.Dispose Method
TableBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TableBase Class
TableBase Members
FastReport.Table Namespace


Draw Method

[image]

FastReport.Net Class Reference
TableBase..::.Draw Method
TableBase Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

TableBase Class
FastReport.Table Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
TableBase..::.DrawMarkers Method
TableBase Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

TableBase Class
TableBase Members
FastReport.Table Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
TableBase..::.GetChildObjects Method
TableBase Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overridable Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
)

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

TableBase Class
FastReport.Table Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
TableBase..::.GetChildOrder Method
TableBase Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

TableBase Class
FastReport.Table Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
TableBase..::.GetContextMenu Method
TableBase Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

TableBase Class
FastReport.Table Namespace


HandleKeyDown Method

[image]

FastReport.Net Class Reference
TableBase..::.HandleKeyDown Method
TableBase Class See Also Send Feedback
Handles KeyDown event in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleKeyDown(
    Control sender,
    KeyEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleKeyDown ( _
    sender As Control, _
    e As KeyEventArgs _
)
Visual C++
public:
virtual void HandleKeyDown(
    Control^ sender,
    KeyEventArgs^ e
) override

Parameters

sender
Type: System.Windows.Forms..::.Control
The designer's workspace.
e
Type: System.Windows.Forms..::.KeyEventArgs
Keyboard event parameters.

Remarks

This method is called when the user presses any key in the designer. Typical implementation does nothing.

See Also

TableBase Class
FastReport.Table Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
TableBase..::.HandleMouseDown Method
TableBase Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

TableBase Class
FastReport.Table Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
TableBase..::.HandleMouseHover Method
TableBase Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

TableBase Class
FastReport.Table Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
TableBase..::.HandleMouseMove Method
TableBase Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

TableBase Class
FastReport.Table Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
TableBase..::.HandleMouseUp Method
TableBase Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

TableBase Class
FastReport.Table Namespace


IsVisible Method

[image]

FastReport.Net Class Reference
TableBase..::.IsVisible Method
TableBase Class See Also Send Feedback
Determines if the object is visible on current drawing surface.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsVisible(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Function IsVisible ( _
    e As FRPaintEventArgs _
) As Boolean
Visual C++
public:
virtual bool IsVisible(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Draw event arguments.

See Also

TableBase Class
FastReport.Table Namespace


Max Method

[image]

FastReport.Net Class Reference
TableBase..::.Max Method
TableBase Class See Also Send Feedback
Calculates a maximum of values in a specified cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Max(
    TableCell aggregateCell
)
Visual Basic (Declaration)
Public Function Max ( _
    aggregateCell As TableCell _
) As Object
Visual C++
public:
Object^ Max(
    TableCell^ aggregateCell
)

Parameters

aggregateCell
Type: FastReport.Table..::.TableCell
The cell.

Return Value

The object that contains calculated value.

Remarks

This method can be called from the ManualBuild event handler only.

See Also

TableBase Class
FastReport.Table Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableBase..::.MemberwiseClone Method
TableBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableBase Class
TableBase Members
FastReport.Table Namespace


Min Method

[image]

FastReport.Net Class Reference
TableBase..::.Min Method
TableBase Class See Also Send Feedback
Calculates a minimum of values in a specified cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Min(
    TableCell aggregateCell
)
Visual Basic (Declaration)
Public Function Min ( _
    aggregateCell As TableCell _
) As Object
Visual C++
public:
Object^ Min(
    TableCell^ aggregateCell
)

Parameters

aggregateCell
Type: FastReport.Table..::.TableCell
The cell.

Return Value

The object that contains calculated value.

Remarks

This method can be called from the ManualBuild event handler only.

See Also

TableBase Class
FastReport.Table Namespace


OnAfterInsert Method

[image]

FastReport.Net Class Reference
TableBase..::.OnAfterInsert Method
TableBase Class See Also Send Feedback
Called after the new object was inserted in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnAfterInsert(
    InsertFrom source
)
Visual Basic (Declaration)
Public Overrides Sub OnAfterInsert ( _
    source As InsertFrom _
)
Visual C++
public:
virtual void OnAfterInsert(
    InsertFrom source
) override

Parameters

source
Type: FastReport..::.InsertFrom
The insertion source.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called when new object is inserted, pasted from clipboard or dragged from "Dictionary" window. You may override this method if you need to perform some actions when object is inserted. Typical implementation invokes the object's editor if "Edit after insert" flag is set in the designer options.

See Also

TableBase Class
FastReport.Table Namespace


OnBeforeInsert Method

[image]

FastReport.Net Class Reference
TableBase..::.OnBeforeInsert Method
TableBase Class See Also Send Feedback
Called before inserting a new object in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void OnBeforeInsert(
    int flags
)
Visual Basic (Declaration)
Public Overrides Sub OnBeforeInsert ( _
    flags As Integer _
)
Visual C++
public:
virtual void OnBeforeInsert(
    int flags
) override

Parameters

flags
Type: System..::.Int32
Object's flags.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

Some objects are registered in the designer several times with the same object type, but different flags. For example, the ShapeObject represents different shapes: rectangle, roundrect, ellipse and so on. All these shapes are registered in the designer using flags (the last parameter in this code):

CopyC#
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 108, "Objects,Shapes,Rectangle", 0);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 109, "Objects,Shapes,RoundRectangle", 1);
RegisteredObjects.Add(typeof(ShapeObject), "ReportPage,Shapes", 110, "Objects,Shapes,Ellipse", 2);

When we put the "Ellipse" object on a band, the designer creates the ShapeObject instance and calls its OnBeforeInsert method with flags value set to 2. In turn, the OnBeforeInsert method converts the int value of the flags to the shape kind:

CopyC#
public override void OnBeforeInsert(int flags)
{
  FShape = (ShapeKind)flags;
}

See Also

TableBase Class
FastReport.Table Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
TableBase..::.RemoveChild Method
TableBase Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

TableBase Class
FastReport.Table Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
TableBase..::.RestoreState Method
TableBase Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

TableBase Class
FastReport.Table Namespace


SaveState Method

[image]

FastReport.Net Class Reference
TableBase..::.SaveState Method
TableBase Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

TableBase Class
FastReport.Table Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TableBase..::.Serialize Method
TableBase Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TableBase Class
FastReport.Table Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
TableBase..::.SetChildOrder Method
TableBase Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

TableBase Class
FastReport.Table Namespace


Sum Method

[image]

FastReport.Net Class Reference
TableBase..::.Sum Method
TableBase Class See Also Send Feedback
Calculates a sum of values in a specified cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Sum(
    TableCell aggregateCell
)
Visual Basic (Declaration)
Public Function Sum ( _
    aggregateCell As TableCell _
) As Object
Visual C++
public:
Object^ Sum(
    TableCell^ aggregateCell
)

Parameters

aggregateCell
Type: FastReport.Table..::.TableCell
The cell.

Return Value

The object that contains calculated value.

Remarks

This method can be called from the ManualBuild event handler only.

See Also

TableBase Class
FastReport.Table Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
TableBase..::.UpdateLayout Method
TableBase Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

TableBase Class
FastReport.Table Namespace


TableBase Properties

[image] [image]

FastReport.Net Class Reference
TableBase Properties
TableBase Class See Also Send Feedback

The TableBase type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages.
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class.
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | Gets or sets a number of columns in the table.
Columns | Gets a collection of table columns.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FixedColumns | Gets or sets the number of fixed columns that will be repeated on each page.
FixedRows | Gets or sets the number of fixed rows that will be repeated on each page.
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Overrides ReportComponentBase..::.Height.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Overrides Base..::.IsSelected.)
Item | Gets or sets the table cell.
Layout | Gets or sets the table layout.
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page.
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table.
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the table.
Rows | Gets a collection of table rows.
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Overrides ReportComponentBase..::.Width.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode.
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableBase Class
FastReport.Table Namespace


AdjustSpannedCellsWidth Property

[image]

FastReport.Net Class Reference
TableBase..::.AdjustSpannedCellsWidth Property
TableBase Class See Also Send Feedback
Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AdjustSpannedCellsWidth { get; set; }
Visual Basic (Declaration)
Public Property AdjustSpannedCellsWidth As Boolean
Visual C++
public:
property bool AdjustSpannedCellsWidth {
    bool get ();
    void set (bool value);
}

Remarks

If set to true, the spanned cell's width will be adjusted to accomodate all contained text.

See Also

TableBase Class
FastReport.Table Namespace


BreakTo Property

[image]

FastReport.Net Class Reference
TableBase..::.BreakTo Property
TableBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BreakableComponent BreakTo { get; set; }
Visual Basic (Declaration)
Public Property BreakTo As BreakableComponent
Visual C++
public:
property BreakableComponent^ BreakTo {
    BreakableComponent^ get ();
    void set (BreakableComponent^ value);
}

See Also

TableBase Class
FastReport.Table Namespace


CanGrow Property

[image]

FastReport.Net Class Reference
TableBase..::.CanGrow Property
TableBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

See Also

TableBase Class
FastReport.Table Namespace


CanShrink Property

[image]

FastReport.Net Class Reference
TableBase..::.CanShrink Property
TableBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

See Also

TableBase Class
FastReport.Table Namespace


ColumnCount Property

[image]

FastReport.Net Class Reference
TableBase..::.ColumnCount Property
TableBase Class See Also Send Feedback
Gets or sets a number of columns in the table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int ColumnCount { get; set; }
Visual Basic (Declaration)
Public Overridable Property ColumnCount As Integer
Visual C++
public:
virtual property int ColumnCount {
    int get ();
    void set (int value);
}

See Also

TableBase Class
FastReport.Table Namespace


Columns Property

[image]

FastReport.Net Class Reference
TableBase..::.Columns Property
TableBase Class See Also Send Feedback
Gets a collection of table columns.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As TableColumnCollection
Visual C++
public:
property TableColumnCollection^ Columns {
    TableColumnCollection^ get ();
}

See Also

TableBase Class
FastReport.Table Namespace


FixedColumns Property

[image]

FastReport.Net Class Reference
TableBase..::.FixedColumns Property
TableBase Class See Also Send Feedback
Gets or sets the number of fixed columns that will be repeated on each page.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int FixedColumns { get; set; }
Visual Basic (Declaration)
Public Property FixedColumns As Integer
Visual C++
public:
property int FixedColumns {
    int get ();
    void set (int value);
}

See Also

TableBase Class
FastReport.Table Namespace


FixedRows Property

[image]

FastReport.Net Class Reference
TableBase..::.FixedRows Property
TableBase Class See Also Send Feedback
Gets or sets the number of fixed rows that will be repeated on each page.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int FixedRows { get; set; }
Visual Basic (Declaration)
Public Property FixedRows As Integer
Visual C++
public:
property int FixedRows {
    int get ();
    void set (int value);
}

See Also

TableBase Class
FastReport.Table Namespace


Height Property

[image]

FastReport.Net Class Reference
TableBase..::.Height Property
TableBase Class Example See Also Send Feedback
Gets or sets the height of the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Height to 10mm
text1.Height = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Height = " + (text1.Height / Units.Millimeters).ToString() + "mm");

See Also

TableBase Class
FastReport.Table Namespace


Hyperlink Property

[image]

FastReport.Net Class Reference
TableBase..::.Hyperlink Property
TableBase Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Hyperlink Hyperlink { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hyperlink As Hyperlink
Visual C++
public:
property Hyperlink^ Hyperlink {
    Hyperlink^ get ();
}

See Also

TableBase Class
FastReport.Table Namespace


IsSelected Property

[image]

FastReport.Net Class Reference
TableBase..::.IsSelected Property
TableBase Class See Also Send Feedback
Gets a value indicating whether the object is selected in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsSelected { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsSelected As Boolean
Visual C++
public:
virtual property bool IsSelected {
    bool get () override;
}

See Also

TableBase Class
FastReport.Table Namespace


Item Property

[image]

FastReport.Net Class Reference
TableBase..::.Item Property
TableBase Class See Also Send Feedback
Gets or sets the table cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCell this[
    int col,
    int row
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    col As Integer, _
    row As Integer _
) As TableCell
Visual C++
public:
property TableCell^ default[int col, int row] {
    TableCell^ get (int col, int row);
    void set (int col, int row, TableCell^ value);
}

Parameters

col
Type: System..::.Int32
Column index.
row
Type: System..::.Int32
Row index.

Return Value

The TableCell object that represents a cell.

See Also

TableBase Class
FastReport.Table Namespace


Layout Property

[image]

FastReport.Net Class Reference
TableBase..::.Layout Property
TableBase Class See Also Send Feedback
Gets or sets the table layout.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableLayout Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As TableLayout
Visual C++
public:
property TableLayout Layout {
    TableLayout get ();
    void set (TableLayout value);
}

Remarks

This property affects printing the big table that breaks across pages.

See Also

TableBase Class
FastReport.Table Namespace


RepeatHeaders Property

[image]

FastReport.Net Class Reference
TableBase..::.RepeatHeaders Property
TableBase Class See Also Send Feedback
Gets or sets a value that determines whether is necessary to repeat table header on each page.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool RepeatHeaders { get; set; }
Visual Basic (Declaration)
Public Property RepeatHeaders As Boolean
Visual C++
public:
property bool RepeatHeaders {
    bool get ();
    void set (bool value);
}

Remarks

To define a table header, set the FixedRows and FixedColumns properties.

See Also

TableBase Class
FastReport.Table Namespace


ResultTable Property

[image]

FastReport.Net Class Reference
TableBase..::.ResultTable Property
TableBase Class See Also Send Feedback
Gets a table which contains the result of rendering dynamic table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableResult ResultTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResultTable As TableResult
Visual C++
public:
property TableResult^ ResultTable {
    TableResult^ get ();
}

Remarks

Use this property to access the result of rendering your table in dynamic mode. It may be useful if you want to center or right-align the result table on a page. In this case, you need to add the following code at the end of your ManualBuild event handler:
CopyC#
// right-align the table
Table1.ResultTable.Left = Engine.PageWidth - Table1.ResultTable.CalcWidth() - 1;

See Also

TableBase Class
FastReport.Table Namespace


RowCount Property

[image]

FastReport.Net Class Reference
TableBase..::.RowCount Property
TableBase Class See Also Send Feedback
Gets or sets a number of rows in the table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public virtual int RowCount { get; set; }
Visual Basic (Declaration)
Public Overridable Property RowCount As Integer
Visual C++
public:
virtual property int RowCount {
    int get ();
    void set (int value);
}

See Also

TableBase Class
FastReport.Table Namespace


Rows Property

[image]

FastReport.Net Class Reference
TableBase..::.Rows Property
TableBase Class See Also Send Feedback
Gets a collection of table rows.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableRowCollection Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As TableRowCollection
Visual C++
public:
property TableRowCollection^ Rows {
    TableRowCollection^ get ();
}

See Also

TableBase Class
FastReport.Table Namespace


Width Property

[image]

FastReport.Net Class Reference
TableBase..::.Width Property
TableBase Class Example See Also Send Feedback
Gets or sets the width of the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Width to 10mm
text1.Width = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Width = " + (text1.Width / Units.Millimeters).ToString() + "mm");

See Also

TableBase Class
FastReport.Table Namespace


WrappedGap Property

[image]

FastReport.Net Class Reference
TableBase..::.WrappedGap Property
TableBase Class See Also Send Feedback
Gets or sets gap between parts of the table in wrapped layout mode.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float WrappedGap { get; set; }
Visual Basic (Declaration)
Public Property WrappedGap As Single
Visual C++
public:
property float WrappedGap {
    float get ();
    void set (float value);
}

Remarks

This property is used if you set the Layout property to Wrapped.

See Also

TableBase Class
FastReport.Table Namespace


TableBase Events

[image] [image]

FastReport.Net Class Reference
TableBase Events
TableBase Class See Also Send Feedback

The TableBase type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableBase Class
FastReport.Table Namespace


TableCell Class

[image]

FastReport.Net Class Reference
TableCell Class
Members See Also Send Feedback
Represents a table cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableCell : TextObject, IParent
Visual Basic (Declaration)
Public Class TableCell _
    Inherits TextObject _
    Implements IParent
Visual C++
public ref class TableCell : public TextObject,
    IParent

Remarks

Use ColSpan, RowSpan properties to set the cell's column and row spans. To put an object inside the cell, use its Objects property:
CopyC#
TableCell cell1;
PictureObject picture1 = new PictureObject();
picture1.Bounds = new RectangleF(0, 0, 32, 32);
picture1.Name = "Picture1";
cell1.Objects.Add(picture1);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport..::.TextObjectBase
FastReport..::.TextObject
FastReport.Table..::.TableCell

See Also

TableCell Members
FastReport.Table Namespace


TableCell Members

[image] [image]

FastReport.Net Class Reference
TableCell Members
TableCell Class Constructors Methods Properties Events See Also Send Feedback

The TableCell type exposes the following members.

Constructors

Name | Description
TableCell | Initializes a new instance of the TableCell class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from TextObject.)
Assign | Copies the contents of another, similar object. (Overrides TextObject..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from TextObject.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TextObject.)
CalcHeight | Calculates the object's height. (Inherited from TextObject.)
CalcWidth | Calculates the object's width. (Inherited from TextObject.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Clone | Creates the exact copy of this cell.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from TextObject.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from TextObject.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Inherited from TextObject.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
DrawText | Draws a text. (Inherited from TextObject.)
Equals | Overloaded.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides TextObject..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides TextObject..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides TextObject..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides TextObject..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Overrides ComponentBase..::.HandleDoubleClick()()().)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides TextObject..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides TextObject..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TextObject.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from TextObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides TextObject..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from TextObject.)
SaveState | Saves the object's state before printing it. (Overrides TextObject..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from TextObject.)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides TextObject..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides TextObject..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
SetStyle | Changes the cell's style.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Overrides ComponentBase..::.AbsLeft.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Overrides ComponentBase..::.AbsTop.)
Address | Gets the address of this cell.
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
Angle | Gets or sets the text angle, in degrees. (Inherited from TextObject.)
AutoShrink | Gets or sets a value that indicates whether the font size should shrink to display the longest text line without word wrap. (Inherited from TextObject.)
AutoShrinkMinSize | Gets or sets the minimum size of font (or minimum width ratio) if the AutoShrink mode is on. (Inherited from TextObject.)
AutoWidth | This property is not relevant to this class.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Clip | Gets or sets a value that indicates if text should be clipped inside the object's bounds. (Inherited from TextObject.)
ColSpan | Gets or sets the column span for this cell.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Duplicates | This property is not relevant to this class.
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstTabOffset | Gets or sets the offset, in pixels, of the first TAB symbol. (Inherited from TextObject.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Font | Gets or sets the font settings for this object. (Inherited from TextObject.)
FontWidthRatio | Gets or sets the width ratio of the font. (Inherited from TextObject.)
ForceJustify | Forces justify for the last text line. (Inherited from TextObject.)
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class.
Height | This property is not relevant to this class. (Overrides TextObject..::.Height.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
Highlight | Gets the collection of conditional highlight attributes. (Inherited from TextObject.)
HorzAlign | Gets or sets the horizontal alignment of a text in the TextObject object. (Inherited from TextObject.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
HtmlTags | Allows handling html tags in the text. (Inherited from TextObject.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | This property is not relevant to this class. (Overrides TextObject..::.Left.)
LineHeight | Gets or sets the height of single text line, in pixels. (Inherited from TextObject.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
Objects | Gets a collection of objects contained in this cell.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object. (Inherited from TextObjectBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
ParagraphOffset | Gets or sets the paragraph offset, in pixels. (Inherited from TextObject.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value that indicates whether the component should draw right-to-left for RTL languages. (Inherited from TextObject.)
RowSpan | Gets or sets the row span for this cell.
ShiftMode | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Table | Gets the TableBase object which this cell belongs to.
TabWidth | Gets or sets the width of TAB symbol, in pixels. (Inherited from TextObject.)
Text | Gets or sets the object's text. (Overrides TextObjectBase..::.Text.)
TextColor | Gets or sets the text color in a simple manner. (Inherited from TextObject.)
TextFill | Gets or sets the fill color used to draw a text. (Inherited from TextObject.)
Top | This property is not relevant to this class. (Overrides TextObject..::.Top.)
Trimming | Gets or sets the string trimming options. (Inherited from TextObject.)
Underlines | Gets or sets a value that determines if the text object will underline each text line. (Inherited from TextObject.)
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
VertAlign | Gets or sets the vertical alignment of a text in the TextObject object. (Inherited from TextObject.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | This property is not relevant to this class. (Overrides TextObject..::.Width.)
WordWrap | Gets or sets a value that indicates if lines are automatically word-wrapped. (Inherited from TextObject.)
Wysiwyg | Gets or sets a value that indicates if the text object should display its contents similar to the printout. (Inherited from TextObject.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableCell Class
FastReport.Table Namespace


TableCell Constructor

[image]

FastReport.Net Class Reference
TableCell Constructor
TableCell Class See Also Send Feedback
Initializes a new instance of the TableCell class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableCell()

See Also

TableCell Class
FastReport.Table Namespace


TableCell Methods

[image] [image]

FastReport.Net Class Reference
TableCell Methods
TableCell Class See Also Send Feedback

The TableCell type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
ApplyStyle | Applies the style settings. (Inherited from TextObject.)
Assign | Copies the contents of another, similar object. (Overrides TextObject..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from TextObject.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TextObject.)
CalcHeight | Calculates the object's height. (Inherited from TextObject.)
CalcWidth | Calculates the object's width. (Inherited from TextObject.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Clone | Creates the exact copy of this cell.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from TextObject.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from TextObject.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSearchHighlight | Draws the highlight to show the text found. (Inherited from TextObject.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
DrawText | Draws a text. (Inherited from TextObject.)
Equals | Overloaded.
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from TextObjectBase.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides TextObject..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Overrides TextObject..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Overrides TextObject..::.GetExpressions()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Overrides TextObject..::.GetSmartTag()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Overrides ComponentBase..::.HandleDoubleClick()()().)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides TextObject..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides TextObject..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TextObject.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Overrides ReportComponentBase..::.HandleMouseDown(FRMouseEventArgs).)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseHover(FRMouseEventArgs).)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Overrides ComponentBase..::.HandleMouseMove(FRMouseEventArgs).)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Overrides ComponentBase..::.HandleMouseUp(FRMouseEventArgs).)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEditor | Invokes the object's editor. (Inherited from TextObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from ReportComponentBase.)
MemberwiseClone | Overloaded.
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from ReportComponentBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
RestoreState | Restores the object's state after printing it. (Overrides TextObject..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from TextObject.)
SaveState | Saves the object's state before printing it. (Overrides TextObject..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from TextObject.)
SearchText | Finds the specified text inside the object. (Inherited from TextObjectBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides TextObject..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides TextObject..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
SetStyle | Changes the cell's style.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

TableCell Class
FastReport.Table Namespace


AddChild Method

[image]

FastReport.Net Class Reference
TableCell..::.AddChild Method
TableCell Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

TableCell Class
FastReport.Table Namespace


Assign Method

[image]

FastReport.Net Class Reference
TableCell..::.Assign Method
TableCell Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TableCell Class
FastReport.Table Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
TableCell..::.CanContain Method
TableCell Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

TableCell Class
FastReport.Table Namespace


Clone Method

[image]

FastReport.Net Class Reference
TableCell..::.Clone Method
TableCell Class See Also Send Feedback
Creates the exact copy of this cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCell Clone()
Visual Basic (Declaration)
Public Function Clone As TableCell
Visual C++
public:
TableCell^ Clone()

Return Value

The copy of this cell.

See Also

TableCell Class
FastReport.Table Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableCell..::.Dispose Method
TableCell Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TableCell Class
TableCell Members
FastReport.Table Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
TableCell..::.DrawMarkers Method
TableCell Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

TableCell Class
TableCell Members
FastReport.Table Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
TableCell..::.Equals Method
TableCell Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(TableCell) | Determines if two cells have identical settings.

See Also

TableCell Class
TableCell Members
FastReport.Table Namespace


Equals Method (TableCell)

[image]

FastReport.Net Class Reference
TableCell..::.Equals Method (TableCell)
TableCell Class See Also Send Feedback
Determines if two cells have identical settings.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Equals(
    TableCell cell
)
Visual Basic (Declaration)
Public Function Equals ( _
    cell As TableCell _
) As Boolean
Visual C++
public:
bool Equals(
    TableCell^ cell
)

Parameters

cell
Type: FastReport.Table..::.TableCell
Cell to compare with.

Return Value

true if cells are equal.

See Also

TableCell Class
Equals Overload
FastReport.Table Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
TableCell..::.GetChildObjects Method
TableCell Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

TableCell Class
FastReport.Table Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
TableCell..::.GetChildOrder Method
TableCell Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

TableCell Class
FastReport.Table Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
TableCell..::.GetContextMenu Method
TableCell Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

TableCell Class
FastReport.Table Namespace


GetData Method

[image]

FastReport.Net Class Reference
TableCell..::.GetData Method
TableCell Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

TableCell Class
FastReport.Table Namespace


GetExpressions Method

[image]

FastReport.Net Class Reference
TableCell..::.GetExpressions Method
TableCell Class See Also Send Feedback
Gets all expressions contained in the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string[] GetExpressions()
Visual Basic (Declaration)
Public Overrides Function GetExpressions As String()
Visual C++
public:
virtual array<String^>^ GetExpressions() override

Return Value

Array of expressions or null if object contains no expressions.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

This method is called by FastReport each time before run a report. FastReport do this to collect all expressions and compile them. For example, GetExpressions method of the TextObject class parses the text and returns all expressions found in the text.

See Also

TableCell Class
FastReport.Table Namespace


GetSmartTag Method

[image]

FastReport.Net Class Reference
TableCell..::.GetSmartTag Method
TableCell Class See Also Send Feedback
Returns a "smart tag" menu.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override SmartTagBase GetSmartTag()
Visual Basic (Declaration)
Public Overrides Function GetSmartTag As SmartTagBase
Visual C++
public:
virtual SmartTagBase^ GetSmartTag() override

Remarks

"Smart tag" is a little button that appears near the object's top-right corner when we are in the designer and move the mouse over the object. When you click that button you will see a popup window where you can set up some properties of the object. FastReport uses smart tags to quickly choose the datasource (for a band) or data column (for objects).

See Also

TableCell Class
FastReport.Table Namespace


HandleDoubleClick Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleDoubleClick Method
TableCell Class See Also Send Feedback
Handles double click event in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDoubleClick()
Visual Basic (Declaration)
Public Overrides Sub HandleDoubleClick
Visual C++
public:
virtual void HandleDoubleClick() override

Remarks

This method is called when the user doubleclicks the object in the designer. Typical implementation invokes the object's editor (calls the InvokeEditor method) and sets the designer's Modified flag.

See Also

TableCell Class
FastReport.Table Namespace


HandleDragDrop Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleDragDrop Method
TableCell Class See Also Send Feedback
Handles the DragDrop event in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragDrop(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragDrop ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragDrop(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drops an item from the Data Tree window into this object. This method should copy the information from the e.DraggedObject object and set the e.Handled flag to true to complete the drag operation.

See Also

TableCell Class
FastReport.Table Namespace


HandleDragOver Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleDragOver Method
TableCell Class See Also Send Feedback
Handles the DragOver event in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragOver(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragOver ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragOver(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drags an item from the Data Tree window. This method should check that the mouse (e.X, e.Y) is inside the object, then set the e.Handled flag to true if an item can be dragged into this object.

See Also

TableCell Class
FastReport.Table Namespace


HandleMouseDown Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleMouseDown Method
TableCell Class See Also Send Feedback
Handles MouseDown event that occurs when the user clicks the mouse in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseDown(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseDown ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseDown(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user press the mouse button in the designer. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • add an object to the selected objects list of the designer;
  • sets the e.Handled flag to true.

See Also

TableCell Class
FastReport.Table Namespace


HandleMouseHover Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleMouseHover Method
TableCell Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseHover(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseHover ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseHover(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. Typical use of this method is to change the mouse cursor to SizeAll when it is over an object. The standard implementation does the following:

  • checks if the mouse pointer is inside the object;
  • changes the cursor shape (e.Cursor property);
  • sets the e.Handled flag to true.

See Also

TableCell Class
FastReport.Table Namespace


HandleMouseMove Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleMouseMove Method
TableCell Class See Also Send Feedback
Handles MouseMove event that occurs when the user moves the mouse in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseMove(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseMove ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseMove(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user moves the mouse in the designer. The standard implementation does the following:

  • if mouse button is not pressed, check that mouse pointer is inside one of the selection points returned by the GetSelectionPoints()()() method and set the e.SizingPoint member to the corresponding sizing point;
  • if mouse button is pressed, and e.SizingPoint member is not SizingPoint.None, resize the object.

See Also

TableCell Class
FastReport.Table Namespace


HandleMouseUp Method

[image]

FastReport.Net Class Reference
TableCell..::.HandleMouseUp Method
TableCell Class See Also Send Feedback
Handles MouseUp event that occurs when the user releases the mouse button in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleMouseUp(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleMouseUp ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleMouseUp(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user releases the mouse button in the designer. The standard implementation does the following:

  • if e.Mode is WorkspaceMode2.SelectionRect, checks if object is inside the selection rectangle and sets e.Handled flag if so;
  • checks that object is inside its parent (calls the CheckParent(Boolean) method).

See Also

TableCell Class
FastReport.Table Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableCell..::.MemberwiseClone Method
TableCell Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableCell Class
TableCell Members
FastReport.Table Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
TableCell..::.RemoveChild Method
TableCell Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

TableCell Class
FastReport.Table Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
TableCell..::.RestoreState Method
TableCell Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

TableCell Class
FastReport.Table Namespace


SaveState Method

[image]

FastReport.Net Class Reference
TableCell..::.SaveState Method
TableCell Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

TableCell Class
FastReport.Table Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
TableCell..::.SelectionChanged Method
TableCell Class See Also Send Feedback
Called when the user selects another object in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Remarks

This method is typically used by the in-place object's editor to check if selection was changed and close the editor.

See Also

TableCell Class
FastReport.Table Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TableCell..::.Serialize Method
TableCell Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TableCell Class
FastReport.Table Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
TableCell..::.SetChildOrder Method
TableCell Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

TableCell Class
FastReport.Table Namespace


SetStyle Method

[image]

FastReport.Net Class Reference
TableCell..::.SetStyle Method
TableCell Class See Also Send Feedback
Changes the cell's style.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetStyle(
    TableCell style
)
Visual Basic (Declaration)
Public Sub SetStyle ( _
    style As TableCell _
)
Visual C++
public:
void SetStyle(
    TableCell^ style
)

Parameters

style
Type: FastReport.Table..::.TableCell
The new style.

Remarks

Each cell in a dynamic table object (or in a matrix) has associated style. Several cells may share one style. If you try to change the cell's appearance directly (like setting cell.TextColor), it may affect other cells in the table. To change the single cell, use this method.

See Also

TableCell Class
FastReport.Table Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
TableCell..::.UpdateLayout Method
TableCell Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

TableCell Class
FastReport.Table Namespace


TableCell Properties

[image] [image]

FastReport.Net Class Reference
TableCell Properties
TableCell Class See Also Send Feedback

The TableCell type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Overrides ComponentBase..::.AbsLeft.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Overrides ComponentBase..::.AbsTop.)
Address | Gets the address of this cell.
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
AllowExpressions | Gets or sets a value indicating that the object's text may contain expressions. (Inherited from TextObjectBase.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
Angle | Gets or sets the text angle, in degrees. (Inherited from TextObject.)
AutoShrink | Gets or sets a value that indicates whether the font size should shrink to display the longest text line without word wrap. (Inherited from TextObject.)
AutoShrinkMinSize | Gets or sets the minimum size of font (or minimum width ratio) if the AutoShrink mode is on. (Inherited from TextObject.)
AutoWidth | This property is not relevant to this class.
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
Brackets | Gets or sets the symbols that will be used to find expressions in the object's text. (Inherited from TextObjectBase.)
BreakTo | Gets or sets a reference to another similar object that will be used for displaying the text that not fit in this object. (Inherited from BreakableComponent.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class.
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Clip | Gets or sets a value that indicates if text should be clipped inside the object's bounds. (Inherited from TextObject.)
ColSpan | Gets or sets the column span for this cell.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Duplicates | This property is not relevant to this class.
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FirstTabOffset | Gets or sets the offset, in pixels, of the first TAB symbol. (Inherited from TextObject.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
Font | Gets or sets the font settings for this object. (Inherited from TextObject.)
FontWidthRatio | Gets or sets the width ratio of the font. (Inherited from TextObject.)
ForceJustify | Forces justify for the last text line. (Inherited from TextObject.)
Format | Gets or sets the formatter that will be used to format data in the Text object. (Inherited from TextObjectBase.)
Formats | Gets the collection of formatters. (Inherited from TextObjectBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | This property is not relevant to this class.
Height | This property is not relevant to this class. (Overrides TextObject..::.Height.)
HideValue | Gets or sets a value that will be hidden. (Inherited from TextObjectBase.)
HideZeros | Gets or sets a value indicating that zero values must be hidden. (Inherited from TextObjectBase.)
Highlight | Gets the collection of conditional highlight attributes. (Inherited from TextObject.)
HorzAlign | Gets or sets the horizontal alignment of a text in the TextObject object. (Inherited from TextObject.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
HtmlTags | Allows handling html tags in the text. (Inherited from TextObject.)
Hyperlink | Gets or sets a hyperlink. (Inherited from ReportComponentBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Left | This property is not relevant to this class. (Overrides TextObject..::.Left.)
LineHeight | Gets or sets the height of single text line, in pixels. (Inherited from TextObject.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
NullValue | Gets or sets a string that will be displayed instead of a null value. (Inherited from TextObjectBase.)
Objects | Gets a collection of objects contained in this cell.
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Padding | Gets or sets padding within the text object. (Inherited from TextObjectBase.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
ParagraphOffset | Gets or sets the paragraph offset, in pixels. (Inherited from TextObject.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
ProcessAt | Gets or sets a value that specifies how the report engine processes this text object. (Inherited from TextObjectBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RightToLeft | Gets or sets a value that indicates whether the component should draw right-to-left for RTL languages. (Inherited from TextObject.)
RowSpan | Gets or sets the row span for this cell.
ShiftMode | This property is not relevant to this class.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Table | Gets the TableBase object which this cell belongs to.
TabWidth | Gets or sets the width of TAB symbol, in pixels. (Inherited from TextObject.)
Text | Gets or sets the object's text. (Overrides TextObjectBase..::.Text.)
TextColor | Gets or sets the text color in a simple manner. (Inherited from TextObject.)
TextFill | Gets or sets the fill color used to draw a text. (Inherited from TextObject.)
Top | This property is not relevant to this class. (Overrides TextObject..::.Top.)
Trimming | Gets or sets the string trimming options. (Inherited from TextObject.)
Underlines | Gets or sets a value that determines if the text object will underline each text line. (Inherited from TextObject.)
Value | Gets a value of expression contained in the object's text. (Inherited from TextObjectBase.)
VertAlign | Gets or sets the vertical alignment of a text in the TextObject object. (Inherited from TextObject.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | This property is not relevant to this class. (Overrides TextObject..::.Width.)
WordWrap | Gets or sets a value that indicates if lines are automatically word-wrapped. (Inherited from TextObject.)
Wysiwyg | Gets or sets a value that indicates if the text object should display its contents similar to the printout. (Inherited from TextObject.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableCell Class
FastReport.Table Namespace


AbsLeft Property

[image]

FastReport.Net Class Reference
TableCell..::.AbsLeft Property
TableCell Class See Also Send Feedback
Gets the absolute left coordinate of the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float AbsLeft { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AbsLeft As Single
Visual C++
public:
virtual property float AbsLeft {
    float get () override;
}

See Also

TableCell Class
FastReport.Table Namespace


AbsTop Property

[image]

FastReport.Net Class Reference
TableCell..::.AbsTop Property
TableCell Class See Also Send Feedback
Gets the absolute top coordinate of the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float AbsTop { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AbsTop As Single
Visual C++
public:
virtual property float AbsTop {
    float get () override;
}

See Also

TableCell Class
FastReport.Table Namespace


Address Property

[image]

FastReport.Net Class Reference
TableCell..::.Address Property
TableCell Class See Also Send Feedback
Gets the address of this cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Point Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As Point
Visual C++
public:
property Point Address {
    Point get ();
}

See Also

TableCell Class
FastReport.Table Namespace


Anchor Property

[image]

FastReport.Net Class Reference
TableCell..::.Anchor Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overrides Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get () override;
    void set (AnchorStyles value) override;
}

See Also

TableCell Class
FastReport.Table Namespace


AutoWidth Property

[image]

FastReport.Net Class Reference
TableCell..::.AutoWidth Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoWidth As Boolean
Visual C++
public:
property bool AutoWidth {
    bool get ();
    void set (bool value);
}

See Also

TableCell Class
FastReport.Table Namespace


CanGrow Property

[image]

FastReport.Net Class Reference
TableCell..::.CanGrow Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

See Also

TableCell Class
FastReport.Table Namespace


CanShrink Property

[image]

FastReport.Net Class Reference
TableCell..::.CanShrink Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

See Also

TableCell Class
FastReport.Table Namespace


ColSpan Property

[image]

FastReport.Net Class Reference
TableCell..::.ColSpan Property
TableCell Class See Also Send Feedback
Gets or sets the column span for this cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ColSpan { get; set; }
Visual Basic (Declaration)
Public Property ColSpan As Integer
Visual C++
public:
property int ColSpan {
    int get ();
    void set (int value);
}

See Also

TableCell Class
FastReport.Table Namespace


Dock Property

[image]

FastReport.Net Class Reference
TableCell..::.Dock Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get () override;
    void set (DockStyle value) override;
}

See Also

TableCell Class
FastReport.Table Namespace


Duplicates Property

[image]

FastReport.Net Class Reference
TableCell..::.Duplicates Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Duplicates Duplicates { get; set; }
Visual Basic (Declaration)
Public Property Duplicates As Duplicates
Visual C++
public:
property Duplicates Duplicates {
    Duplicates get ();
    void set (Duplicates value);
}

See Also

TableCell Class
FastReport.Table Namespace


GrowToBottom Property

[image]

FastReport.Net Class Reference
TableCell..::.GrowToBottom Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool GrowToBottom { get; set; }
Visual Basic (Declaration)
Public Property GrowToBottom As Boolean
Visual C++
public:
property bool GrowToBottom {
    bool get ();
    void set (bool value);
}

See Also

TableCell Class
FastReport.Table Namespace


Height Property

[image]

FastReport.Net Class Reference
TableCell..::.Height Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

See Also

TableCell Class
FastReport.Table Namespace


Left Property

[image]

FastReport.Net Class Reference
TableCell..::.Left Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

See Also

TableCell Class
FastReport.Table Namespace


Objects Property

[image]

FastReport.Net Class Reference
TableCell..::.Objects Property
TableCell Class See Also Send Feedback
Gets a collection of objects contained in this cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentCollection Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As ReportComponentCollection
Visual C++
public:
property ReportComponentCollection^ Objects {
    ReportComponentCollection^ get ();
}

See Also

TableCell Class
FastReport.Table Namespace


RowSpan Property

[image]

FastReport.Net Class Reference
TableCell..::.RowSpan Property
TableCell Class See Also Send Feedback
Gets or sets the row span for this cell.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int RowSpan { get; set; }
Visual Basic (Declaration)
Public Property RowSpan As Integer
Visual C++
public:
property int RowSpan {
    int get ();
    void set (int value);
}

See Also

TableCell Class
FastReport.Table Namespace


ShiftMode Property

[image]

FastReport.Net Class Reference
TableCell..::.ShiftMode Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ShiftMode ShiftMode { get; set; }
Visual Basic (Declaration)
Public Property ShiftMode As ShiftMode
Visual C++
public:
property ShiftMode ShiftMode {
    ShiftMode get ();
    void set (ShiftMode value);
}

See Also

TableCell Class
FastReport.Table Namespace


Table Property

[image]

FastReport.Net Class Reference
TableCell..::.Table Property
TableCell Class See Also Send Feedback
Gets the TableBase object which this cell belongs to.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableBase Table { get; }
Visual Basic (Declaration)
Public ReadOnly Property Table As TableBase
Visual C++
public:
property TableBase^ Table {
    TableBase^ get ();
}

See Also

TableCell Class
FastReport.Table Namespace


Text Property

[image]

FastReport.Net Class Reference
TableCell..::.Text Property
TableCell Class See Also Send Feedback
Gets or sets the object's text.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Text may contain expressions and data items, for example: "Today is [Date]". When report is running, all expressions are calculated and replaced with actual values, so the text would be "Today is 01.01.2008".

See Also

TableCell Class
FastReport.Table Namespace


Top Property

[image]

FastReport.Net Class Reference
TableCell..::.Top Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

See Also

TableCell Class
FastReport.Table Namespace


Width Property

[image]

FastReport.Net Class Reference
TableCell..::.Width Property
TableCell Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

See Also

TableCell Class
FastReport.Table Namespace


TableCell Events

[image] [image]

FastReport.Net Class Reference
TableCell Events
TableCell Class See Also Send Feedback

The TableCell type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableCell Class
FastReport.Table Namespace


TableColumn Class

[image]

FastReport.Net Class Reference
TableColumn Class
Members See Also Send Feedback
Represents a table column.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableColumn : ComponentBase
Visual Basic (Declaration)
Public Class TableColumn _
    Inherits ComponentBase
Visual C++
public ref class TableColumn : public ComponentBase

Remarks

Use the Width property to set the width of a column. If AutoSize property is true, the column will calculate its width automatically.

You can also set the MinWidth and MaxWidth properties to restrict the column's width.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Table..::.TableColumn

See Also

TableColumn Members
FastReport.Table Namespace


TableColumn Members

[image] [image]

FastReport.Net Class Reference
TableColumn Members
TableColumn Class Constructors Methods Properties Events See Also Send Feedback

The TableColumn type exposes the following members.

Constructors

Name | Description
TableColumn | Initializes a new instance of the TableColumn class.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
AutoSize | Gets or sets a value determines if the column should calculate its width automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | This property is not relevant to this class. (Overrides ComponentBase..::.Height.)
Index | Gets the index of this column.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepColumns | Gets or sets the number of columns to keep on the same page.
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
MaxWidth | Gets or sets the maximal width for this column, in pixels.
MinWidth | Gets or sets the minimal width for this column, in pixels.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreak | Gets or sets the page break flag for this column.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top | This property is not relevant to this class. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets a width of the column, in pixels. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TableColumn Class
FastReport.Table Namespace


TableColumn Constructor

[image]

FastReport.Net Class Reference
TableColumn Constructor
TableColumn Class See Also Send Feedback
Initializes a new instance of the TableColumn class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableColumn()

See Also

TableColumn Class
FastReport.Table Namespace


TableColumn Methods

[image] [image]

FastReport.Net Class Reference
TableColumn Methods
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Methods

Name | Description
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TableColumn Class
FastReport.Table Namespace


Assign Method

[image]

FastReport.Net Class Reference
TableColumn..::.Assign Method
TableColumn Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TableColumn Class
FastReport.Table Namespace
AssignAll Method


Clear Method

[image]

FastReport.Net Class Reference
TableColumn..::.Clear Method
TableColumn Class See Also Send Feedback
Clears the object's state.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

This method also disposes all object's children.

See Also

TableColumn Class
FastReport.Table Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableColumn..::.Dispose Method
TableColumn Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TableColumn Class
TableColumn Members
FastReport.Table Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
TableColumn..::.GetContextMenu Method
TableColumn Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

TableColumn Class
FastReport.Table Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
TableColumn..::.GetSelectionPoints Method
TableColumn Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

TableColumn Class
FastReport.Table Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableColumn..::.MemberwiseClone Method
TableColumn Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableColumn Class
TableColumn Members
FastReport.Table Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
TableColumn..::.SelectionChanged Method
TableColumn Class See Also Send Feedback
Called when the user selects another object in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Remarks

This method is typically used by the in-place object's editor to check if selection was changed and close the editor.

See Also

TableColumn Class
FastReport.Table Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TableColumn..::.Serialize Method
TableColumn Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TableColumn Class
FastReport.Table Namespace


TableColumn Properties

[image] [image]

FastReport.Net Class Reference
TableColumn Properties
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
AutoSize | Gets or sets a value determines if the column should calculate its width automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | This property is not relevant to this class. (Overrides ComponentBase..::.Height.)
Index | Gets the index of this column.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
KeepColumns | Gets or sets the number of columns to keep on the same page.
Left | Gets or sets the left coordinate of the object in relation to its container. (Overrides ComponentBase..::.Left.)
MaxWidth | Gets or sets the maximal width for this column, in pixels.
MinWidth | Gets or sets the minimal width for this column, in pixels.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreak | Gets or sets the page break flag for this column.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top | This property is not relevant to this class. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets a width of the column, in pixels. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableColumn Class
FastReport.Table Namespace


Anchor Property

[image]

FastReport.Net Class Reference
TableColumn..::.Anchor Property
TableColumn Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overrides Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get () override;
    void set (AnchorStyles value) override;
}

See Also

TableColumn Class
FastReport.Table Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
TableColumn..::.AutoSize Property
TableColumn Class See Also Send Feedback
Gets or sets a value determines if the column should calculate its width automatically.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

Remarks

The column width cannot exceed the range defined by the MinWidth and MaxWidth properties.

See Also

TableColumn Class
FastReport.Table Namespace


Dock Property

[image]

FastReport.Net Class Reference
TableColumn..::.Dock Property
TableColumn Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get () override;
    void set (DockStyle value) override;
}

See Also

TableColumn Class
FastReport.Table Namespace


Height Property

[image]

FastReport.Net Class Reference
TableColumn..::.Height Property
TableColumn Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

See Also

TableColumn Class
FastReport.Table Namespace


Index Property

[image]

FastReport.Net Class Reference
TableColumn..::.Index Property
TableColumn Class See Also Send Feedback
Gets the index of this column.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

TableColumn Class
FastReport.Table Namespace


KeepColumns Property

[image]

FastReport.Net Class Reference
TableColumn..::.KeepColumns Property
TableColumn Class See Also Send Feedback
Gets or sets the number of columns to keep on the same page.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int KeepColumns { get; set; }
Visual Basic (Declaration)
Public Property KeepColumns As Integer
Visual C++
public:
property int KeepColumns {
    int get ();
    void set (int value);
}

See Also

TableColumn Class
FastReport.Table Namespace


Left Property

[image]

FastReport.Net Class Reference
TableColumn..::.Left Property
TableColumn Class Example See Also Send Feedback
Gets or sets the left coordinate of the object in relation to its container.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsLeft property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Left to 10mm
text1.Left = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Left = " + (text1.Left / Units.Millimeters).ToString() + "mm");

See Also

TableColumn Class
FastReport.Table Namespace


MaxWidth Property

[image]

FastReport.Net Class Reference
TableColumn..::.MaxWidth Property
TableColumn Class See Also Send Feedback
Gets or sets the maximal width for this column, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MaxWidth { get; set; }
Visual Basic (Declaration)
Public Property MaxWidth As Single
Visual C++
public:
property float MaxWidth {
    float get ();
    void set (float value);
}

See Also

TableColumn Class
FastReport.Table Namespace


MinWidth Property

[image]

FastReport.Net Class Reference
TableColumn..::.MinWidth Property
TableColumn Class See Also Send Feedback
Gets or sets the minimal width for this column, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MinWidth { get; set; }
Visual Basic (Declaration)
Public Property MinWidth As Single
Visual C++
public:
property float MinWidth {
    float get ();
    void set (float value);
}

See Also

TableColumn Class
FastReport.Table Namespace


PageBreak Property

[image]

FastReport.Net Class Reference
TableColumn..::.PageBreak Property
TableColumn Class See Also Send Feedback
Gets or sets the page break flag for this column.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreak { get; set; }
Visual Basic (Declaration)
Public Property PageBreak As Boolean
Visual C++
public:
property bool PageBreak {
    bool get ();
    void set (bool value);
}

See Also

TableColumn Class
FastReport.Table Namespace


Top Property

[image]

FastReport.Net Class Reference
TableColumn..::.Top Property
TableColumn Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

See Also

TableColumn Class
FastReport.Table Namespace


Width Property

[image]

FastReport.Net Class Reference
TableColumn..::.Width Property
TableColumn Class See Also Send Feedback
Gets or sets a width of the column, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

Remarks

The column width cannot exceed the range defined by the MinWidth and MaxWidth properties.
Note:To convert between pixels and report units, use the constants defined in the Units class.

See Also

TableColumn Class
FastReport.Table Namespace


TableColumn Events

[image] [image]

FastReport.Net Class Reference
TableColumn Events
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TableColumn Class
FastReport.Table Namespace


TableColumnCollection Class

[image]

FastReport.Net Class Reference
TableColumnCollection Class
Members See Also Send Feedback
Represents a collection of TableColumn objects.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableColumnCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class TableColumnCollection _
    Inherits FRCollectionBase
Visual C++
public ref class TableColumnCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Table..::.TableColumnCollection

See Also

TableColumnCollection Members
FastReport.Table Namespace


TableColumnCollection Members

[image] [image]

FastReport.Net Class Reference
TableColumnCollection Members
TableColumnCollection Class Methods Properties See Also Send Feedback

The TableColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides FRCollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides FRCollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a column with specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TableColumnCollection Class
FastReport.Table Namespace


TableColumnCollection Methods

[image] [image]

FastReport.Net Class Reference
TableColumnCollection Methods
TableColumnCollection Class See Also Send Feedback

The TableColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides FRCollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides FRCollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableColumnCollection Class
FastReport.Table Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
TableColumnCollection..::.AddRange Method
TableColumnCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

TableColumnCollection Class
TableColumnCollection Members
FastReport.Table Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
TableColumnCollection..::.Equals Method
TableColumnCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

TableColumnCollection Class
TableColumnCollection Members
FastReport.Table Namespace


OnInsert Method

[image]

FastReport.Net Class Reference
TableColumnCollection..::.OnInsert Method
TableColumnCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new element into the CollectionBase instance.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which to insert value.
value
Type: System..::.Object
The new value of the element at index.

See Also

TableColumnCollection Class
FastReport.Table Namespace


OnRemove Method

[image]

FastReport.Net Class Reference
TableColumnCollection..::.OnRemove Method
TableColumnCollection Class See Also Send Feedback
Performs additional custom processes when removing an element from the CollectionBase instance.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which value can be found.
value
Type: System..::.Object
The value of the element to remove from index.

See Also

TableColumnCollection Class
FastReport.Table Namespace


TableColumnCollection Properties

[image] [image]

FastReport.Net Class Reference
TableColumnCollection Properties
TableColumnCollection Class See Also Send Feedback

The TableColumnCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a column with specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TableColumnCollection Class
FastReport.Table Namespace


Item Property

[image]

FastReport.Net Class Reference
TableColumnCollection..::.Item Property
TableColumnCollection Class See Also Send Feedback
Gets a column with specified index.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableColumn this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As TableColumn
Visual C++
public:
property TableColumn^ default[int index] {
    TableColumn^ get (int index);
}

Parameters

index
Type: System..::.Int32
Index of a column.

Return Value

The column with specified index.

See Also

TableColumnCollection Class
FastReport.Table Namespace


TableLayout Enumeration

[image]

FastReport.Net Class Reference
TableLayout Enumeration
See Also Send Feedback
Specifies the layout that will be used when printing a big table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum TableLayout
Visual Basic (Declaration)
Public Enumeration TableLayout
Visual C++
public enum class TableLayout

Members

Member name | Description
AcrossThenDown | The table is printed across a pages then down.
DownThenAcross | The table is printed down then across a pages.
Wrapped | The table is wrapped.

See Also

FastReport.Table Namespace


TableObject Class

[image]

FastReport.Net Class Reference
TableObject Class
Members See Also Send Feedback
Represents a table object that consists of several rows and columns.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableObject : TableBase
Visual Basic (Declaration)
Public Class TableObject _
    Inherits TableBase
Visual C++
public ref class TableObject : public TableBase

Remarks

To add/remove columns, use the Columns collection. To add/remove rows, use the Rows collection. To initialize a table with specified number of columns and rows, use ColumnCount and RowCount properties.

To print a table in code, use the ManualBuild event. In the manual build mode, you can use aggregate functions. The following functions available:

Aggregate function | Description
Sum(cell) | Calculates the sum of values in specified table cell.
Min(cell) | Calculates the minimum of values in specified table cell.
Max(cell) | Calculates the maximum of values in specified table cell.
Avg(cell) | Calculates the average of values in specified table cell.
Count(cell) | Calculates the number of repeats of a specified table cell.

To print aggregate value, place the aggregate function call in the table cell: [Count(Cell2)].

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport.Table..::.TableBase
FastReport.Table..::.TableObject

See Also

TableObject Members
FastReport.Table Namespace


TableObject Members

[image] [image]

FastReport.Net Class Reference
TableObject Members
TableObject Class Constructors Methods Properties Events See Also Send Feedback

The TableObject type exposes the following members.

Constructors

Name | Description
TableObject | Initializes a new instance of the TableObject class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from TableBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides TableBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell. (Inherited from TableBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TableBase.)
CalcHeight | Calculates the object's height. (Inherited from TableBase.)
CalcWidth | Calculates and returns the table width, in pixels. (Inherited from TableBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from TableBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell. (Inherited from TableBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells. (Inherited from TableBase.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides TableBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from TableBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from TableBase.)
GetContextMenu | Gets the object's context menu. (Inherited from TableBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Overrides Base..::.GetCustomScript()()().)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TableBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from TableBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from TableBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from TableBase.)
Max | Calculates a maximum of values in a specified cell. (Inherited from TableBase.)
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell. (Inherited from TableBase.)
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from TableBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from TableBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnManualBuild | This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PageBreak | Adds a page before rows or columns.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
PrintColumn | Prints a column with specified index.
PrintColumns | Overloaded.
PrintRow | Prints a row with specified index.
PrintRows | Overloaded.
RemoveChild | Removes a specified object from this object's childs. (Inherited from TableBase.)
RestoreState | Restores the object's state after printing it. (Overrides TableBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides TableBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides TableBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from TableBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell. (Inherited from TableBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from TableBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages. (Inherited from TableBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from TableBase.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class. (Inherited from TableBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class. (Inherited from TableBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | Gets or sets a number of columns in the table. (Overrides TableBase..::.ColumnCount.)
Columns | Gets a collection of table columns. (Inherited from TableBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FixedColumns | Gets or sets the number of fixed columns that will be repeated on each page. (Inherited from TableBase.)
FixedRows | Gets or sets the number of fixed rows that will be repeated on each page. (Inherited from TableBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from TableBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class. (Inherited from TableBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from TableBase.)
Item | Gets or sets the table cell. (Inherited from TableBase.)
Layout | Gets or sets the table layout. (Inherited from TableBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
ManualBuildAutoSpans | Determines whether to manage cell spans automatically during manual build.
ManualBuildEvent | Gets or sets a script method name that will be used to handle the ManualBuild event.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page. (Inherited from TableBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table. (Inherited from TableBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the table. (Overrides TableBase..::.RowCount.)
Rows | Gets a collection of table rows. (Inherited from TableBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TableBase.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode. (Inherited from TableBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
ManualBuild | Allows to print table rows/columns dynamically.
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableObject Class
FastReport.Table Namespace


TableObject Constructor

[image]

FastReport.Net Class Reference
TableObject Constructor
TableObject Class See Also Send Feedback
Initializes a new instance of the TableObject class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableObject()

See Also

TableObject Class
FastReport.Table Namespace


TableObject Methods

[image] [image]

FastReport.Net Class Reference
TableObject Methods
TableObject Class See Also Send Feedback

The TableObject type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from TableBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Overrides TableBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell. (Inherited from TableBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TableBase.)
CalcHeight | Calculates the object's height. (Inherited from TableBase.)
CalcWidth | Calculates and returns the table width, in pixels. (Inherited from TableBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from TableBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell. (Inherited from TableBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells. (Inherited from TableBase.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Overrides TableBase..::.Draw(FRPaintEventArgs).)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Inherited from TableBase.)
GetChildOrder | Returns z-order of the specified child object. (Inherited from TableBase.)
GetContextMenu | Gets the object's context menu. (Inherited from TableBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Overrides Base..::.GetCustomScript()()().)
GetData | Gets the data from a datasource that the object is connected to. (Overrides ReportComponentBase..::.GetData()()().)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Overrides ComponentBase..::.HandleDragDrop(FRMouseEventArgs).)
HandleDragOver | Handles the DragOver event in the designer. (Overrides ComponentBase..::.HandleDragOver(FRMouseEventArgs).)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TableBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from TableBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from TableBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from TableBase.)
Max | Calculates a maximum of values in a specified cell. (Inherited from TableBase.)
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell. (Inherited from TableBase.)
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from TableBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from TableBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnManualBuild | This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PageBreak | Adds a page before rows or columns.
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
PrintColumn | Prints a column with specified index.
PrintColumns | Overloaded.
PrintRow | Prints a row with specified index.
PrintRows | Overloaded.
RemoveChild | Removes a specified object from this object's childs. (Inherited from TableBase.)
RestoreState | Restores the object's state after printing it. (Overrides TableBase..::.RestoreState()()().)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Overrides TableBase..::.SaveState()()().)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Overrides TableBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object. (Inherited from TableBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell. (Inherited from TableBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from TableBase.)

See Also

TableObject Class
FastReport.Table Namespace


Assign Method

[image]

FastReport.Net Class Reference
TableObject..::.Assign Method
TableObject Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TableObject Class
FastReport.Table Namespace
AssignAll Method


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableObject..::.Dispose Method
TableObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TableObject Class
TableObject Members
FastReport.Table Namespace


Draw Method

[image]

FastReport.Net Class Reference
TableObject..::.Draw Method
TableObject Class See Also Send Feedback
Draws the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Draw(
    FRPaintEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub Draw ( _
    e As FRPaintEventArgs _
)
Visual C++
public:
virtual void Draw(
    FRPaintEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRPaintEventArgs
Paint event args.

Remarks

This method is widely used in the FastReport. It is called each time when the object needs to draw or print itself.

In order to draw the object correctly, you should multiply the object's bounds by the scale parameter.

cache parameter is used to optimize the drawing speed. It holds all items such as pens, fonts, brushes, string formats that was used before. If the item with requested parameters exists in the cache, it will be returned (instead of create new item and then dispose it).

See Also

TableObject Class
FastReport.Table Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
TableObject..::.DrawMarkers Method
TableObject Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

TableObject Class
TableObject Members
FastReport.Table Namespace


GetCustomScript Method

[image]

FastReport.Net Class Reference
TableObject..::.GetCustomScript Method
TableObject Class See Also Send Feedback
Returns a custom code that will be added to the report script before report is run.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override string GetCustomScript()
Visual Basic (Declaration)
Public Overrides Function GetCustomScript As String
Visual C++
public:
virtual String^ GetCustomScript() override

Return Value

A custom script text, if any. Otherwise returns null.

Remarks

This method may return any valid code that may be inserted into the report script. Currently it is used in the TableObject to define the following script methods: Sum, Min, Max, Avg, Count.

Note: you must take into account the current script language - C# or VB.Net. You may check it via Report.ScriptLanguage property.

See Also

TableObject Class
FastReport.Table Namespace


GetData Method

[image]

FastReport.Net Class Reference
TableObject..::.GetData Method
TableObject Class See Also Send Feedback
Gets the data from a datasource that the object is connected to.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetData()
Visual Basic (Declaration)
Public Overrides Sub GetData
Visual C++
public:
virtual void GetData() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should get the data from a datasource that the object is connected to.

See Also

TableObject Class
FastReport.Table Namespace


HandleDragDrop Method

[image]

FastReport.Net Class Reference
TableObject..::.HandleDragDrop Method
TableObject Class See Also Send Feedback
Handles the DragDrop event in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragDrop(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragDrop ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragDrop(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drops an item from the Data Tree window into this object. This method should copy the information from the e.DraggedObject object and set the e.Handled flag to true to complete the drag operation.

See Also

TableObject Class
FastReport.Table Namespace


HandleDragOver Method

[image]

FastReport.Net Class Reference
TableObject..::.HandleDragOver Method
TableObject Class See Also Send Feedback
Handles the DragOver event in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void HandleDragOver(
    FRMouseEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub HandleDragOver ( _
    e As FRMouseEventArgs _
)
Visual C++
public:
virtual void HandleDragOver(
    FRMouseEventArgs^ e
) override

Parameters

e
Type: FastReport.Utils..::.FRMouseEventArgs
Current mouse state.

Remarks

This method is called when the user drags an item from the Data Tree window. This method should check that the mouse (e.X, e.Y) is inside the object, then set the e.Handled flag to true if an item can be dragged into this object.

See Also

TableObject Class
FastReport.Table Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableObject..::.MemberwiseClone Method
TableObject Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableObject Class
TableObject Members
FastReport.Table Namespace


OnManualBuild Method

[image]

FastReport.Net Class Reference
TableObject..::.OnManualBuild Method
TableObject Class See Also Send Feedback
This method fires the ManualBuild event and the script code connected to the ManualBuildEvent.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void OnManualBuild(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnManualBuild ( _
    e As EventArgs _
)
Visual C++
public:
void OnManualBuild(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
Event data.

See Also

TableObject Class
FastReport.Table Namespace


PageBreak Method

[image]

FastReport.Net Class Reference
TableObject..::.PageBreak Method
TableObject Class See Also Send Feedback
Adds a page before rows or columns.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PageBreak()
Visual Basic (Declaration)
Public Sub PageBreak
Visual C++
public:
void PageBreak()

Remarks

Call this method to insert a page break before the next row or column that you intend to print using PrintRow(s) or PrintColumn(s) methods. See the ManualBuild event for more details.

See Also

TableObject Class
FastReport.Table Namespace


PrintColumn Method

[image]

FastReport.Net Class Reference
TableObject..::.PrintColumn Method
TableObject Class See Also Send Feedback
Prints a column with specified index.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintColumn(
    int index
)
Visual Basic (Declaration)
Public Sub PrintColumn ( _
    index As Integer _
)
Visual C++
public:
void PrintColumn(
    int index
)

Parameters

index
Type: System..::.Int32
Index of a column to print.

Remarks

See the ManualBuild event for more details.

See Also

TableObject Class
FastReport.Table Namespace


PrintColumns Method

[image] [image]

FastReport.Net Class Reference
TableObject..::.PrintColumns Method
TableObject Class See Also Send Feedback

Overload List

Name | Description
PrintColumns()()() | Prints all columns.
PrintColumns(array<Int32>[]()[]) | Prints columns with specified indices.

See Also

TableObject Class
TableObject Members
FastReport.Table Namespace


PrintColumns Method

[image]

FastReport.Net Class Reference
TableObject..::.PrintColumns Method
TableObject Class See Also Send Feedback
Prints all columns.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintColumns()
Visual Basic (Declaration)
Public Sub PrintColumns
Visual C++
public:
void PrintColumns()

Remarks

See the ManualBuild event for more details.

See Also

TableObject Class
PrintColumns Overload
FastReport.Table Namespace


PrintColumns Method (Int32[])

[image]

FastReport.Net Class Reference
TableObject..::.PrintColumns Method (array<Int32>[]()[])
TableObject Class See Also Send Feedback
Prints columns with specified indices.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintColumns(
    int[] indices
)
Visual Basic (Declaration)
Public Sub PrintColumns ( _
    indices As Integer() _
)
Visual C++
public:
void PrintColumns(
    array<int>^ indices
)

Parameters

indices
Type: array< System..::.Int32 >[]()[]
Indices of columns to print.

Remarks

See the ManualBuild event for more details.

See Also

TableObject Class
PrintColumns Overload
FastReport.Table Namespace


PrintRow Method

[image]

FastReport.Net Class Reference
TableObject..::.PrintRow Method
TableObject Class See Also Send Feedback
Prints a row with specified index.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintRow(
    int index
)
Visual Basic (Declaration)
Public Sub PrintRow ( _
    index As Integer _
)
Visual C++
public:
void PrintRow(
    int index
)

Parameters

index
Type: System..::.Int32
Index of a row to print.

Remarks

See the ManualBuild event for more details.

See Also

TableObject Class
FastReport.Table Namespace


PrintRows Method

[image] [image]

FastReport.Net Class Reference
TableObject..::.PrintRows Method
TableObject Class See Also Send Feedback

Overload List

Name | Description
PrintRows()()() | Prints all rows.
PrintRows(array<Int32>[]()[]) | Prints rows with specified indices.

See Also

TableObject Class
TableObject Members
FastReport.Table Namespace


PrintRows Method

[image]

FastReport.Net Class Reference
TableObject..::.PrintRows Method
TableObject Class See Also Send Feedback
Prints all rows.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintRows()
Visual Basic (Declaration)
Public Sub PrintRows
Visual C++
public:
void PrintRows()

Remarks

See the ManualBuild event for more details.

See Also

TableObject Class
PrintRows Overload
FastReport.Table Namespace


PrintRows Method (Int32[])

[image]

FastReport.Net Class Reference
TableObject..::.PrintRows Method (array<Int32>[]()[])
TableObject Class See Also Send Feedback
Prints rows with specified indices.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintRows(
    int[] indices
)
Visual Basic (Declaration)
Public Sub PrintRows ( _
    indices As Integer() _
)
Visual C++
public:
void PrintRows(
    array<int>^ indices
)

Parameters

indices
Type: array< System..::.Int32 >[]()[]
Indices of rows to print.

Remarks

See the ManualBuild event for more details.

See Also

TableObject Class
PrintRows Overload
FastReport.Table Namespace


RestoreState Method

[image]

FastReport.Net Class Reference
TableObject..::.RestoreState Method
TableObject Class See Also Send Feedback
Restores the object's state after printing it.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void RestoreState()
Visual Basic (Declaration)
Public Overrides Sub RestoreState
Visual C++
public:
virtual void RestoreState() override

Remarks

This method is called by the report engine after processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should restore the object properties that were saved by the SaveState()()() method.

See Also

TableObject Class
FastReport.Table Namespace


SaveState Method

[image]

FastReport.Net Class Reference
TableObject..::.SaveState Method
TableObject Class See Also Send Feedback
Saves the object's state before printing it.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SaveState()
Visual Basic (Declaration)
Public Overrides Sub SaveState
Visual C++
public:
virtual void SaveState() override

Remarks

This method is called by the report engine before processing the object.

Do not call it directly. You may override it if you are developing a new FastReport component. In this method you should save any object properties that may be changed during the object printing. The standard implementation saves the object's bounds, visibility, bookmark and hyperlink.

See Also

TableObject Class
FastReport.Table Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TableObject..::.Serialize Method
TableObject Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TableObject Class
FastReport.Table Namespace


TableObject Properties

[image] [image]

FastReport.Net Class Reference
TableObject Properties
TableObject Class See Also Send Feedback

The TableObject type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages. (Inherited from TableBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from TableBase.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class. (Inherited from TableBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class. (Inherited from TableBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | Gets or sets a number of columns in the table. (Overrides TableBase..::.ColumnCount.)
Columns | Gets a collection of table columns. (Inherited from TableBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FixedColumns | Gets or sets the number of fixed columns that will be repeated on each page. (Inherited from TableBase.)
FixedRows | Gets or sets the number of fixed rows that will be repeated on each page. (Inherited from TableBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from TableBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class. (Inherited from TableBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from TableBase.)
Item | Gets or sets the table cell. (Inherited from TableBase.)
Layout | Gets or sets the table layout. (Inherited from TableBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
ManualBuildAutoSpans | Determines whether to manage cell spans automatically during manual build.
ManualBuildEvent | Gets or sets a script method name that will be used to handle the ManualBuild event.
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page. (Inherited from TableBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table. (Inherited from TableBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the table. (Overrides TableBase..::.RowCount.)
Rows | Gets a collection of table rows. (Inherited from TableBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TableBase.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode. (Inherited from TableBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableObject Class
FastReport.Table Namespace


ColumnCount Property

[image]

FastReport.Net Class Reference
TableObject..::.ColumnCount Property
TableObject Class See Also Send Feedback
Gets or sets a number of columns in the table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int ColumnCount { get; set; }
Visual Basic (Declaration)
Public Overrides Property ColumnCount As Integer
Visual C++
public:
virtual property int ColumnCount {
    int get () override;
    void set (int value) override;
}

See Also

TableObject Class
FastReport.Table Namespace


ManualBuildAutoSpans Property

[image]

FastReport.Net Class Reference
TableObject..::.ManualBuildAutoSpans Property
TableObject Class See Also Send Feedback
Determines whether to manage cell spans automatically during manual build.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ManualBuildAutoSpans { get; set; }
Visual Basic (Declaration)
Public Property ManualBuildAutoSpans As Boolean
Visual C++
public:
property bool ManualBuildAutoSpans {
    bool get ();
    void set (bool value);
}

Remarks

The default value for this property is true. If you set it to false, you need to manage spans in your ManualBuild event handler.

See Also

TableObject Class
FastReport.Table Namespace


ManualBuildEvent Property

[image]

FastReport.Net Class Reference
TableObject..::.ManualBuildEvent Property
TableObject Class See Also Send Feedback
Gets or sets a script method name that will be used to handle the ManualBuild event.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ManualBuildEvent { get; set; }
Visual Basic (Declaration)
Public Property ManualBuildEvent As String
Visual C++
public:
property String^ ManualBuildEvent {
    String^ get ();
    void set (String^ value);
}

Remarks

If you use this event, you must handle the table print process manually. See the ManualBuild event for details.

See Also

TableObject Class
FastReport.Table Namespace


RowCount Property

[image]

FastReport.Net Class Reference
TableObject..::.RowCount Property
TableObject Class See Also Send Feedback
Gets or sets a number of rows in the table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override int RowCount { get; set; }
Visual Basic (Declaration)
Public Overrides Property RowCount As Integer
Visual C++
public:
virtual property int RowCount {
    int get () override;
    void set (int value) override;
}

See Also

TableObject Class
FastReport.Table Namespace


TableObject Events

[image] [image]

FastReport.Net Class Reference
TableObject Events
TableObject Class See Also Send Feedback

The TableObject type exposes the following members.

Events

Name | Description
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
ManualBuild | Allows to print table rows/columns dynamically.
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableObject Class
FastReport.Table Namespace


ManualBuild Event

[image]

FastReport.Net Class Reference
TableObject..::.ManualBuild Event
TableObject Class Example See Also Send Feedback
Allows to print table rows/columns dynamically.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler ManualBuild
Visual Basic (Declaration)
Public Event ManualBuild As EventHandler
Visual C++
public:
 event EventHandler^ ManualBuild {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

This event is used to handle the table print process in a code. Using special methods like PrintRow(Int32), PrintColumn(Int32) you can print specified rows/columns.

First way is to repeat specified row(s) to get a table that will grow downwards. To do this, you have to call the PrintRow method followed by the PrintColumns method.

Another way is to repeat the specified column(s) to get a table that grows sidewards. To do this, call the PrintColumn method followed by the PrintRows method.

Finally, the third way is to repeat rows and columns. The table will grow downwards and sidewards. To do this, call the PrintRow method followed by the PrintColumn method (or vice versa).

Note: When you print a table row-by-row, you must call one of the PrintColumn, PrintColumns methods right after the PrintRow method. In the same manner, when you print a table column-by-column, call one of the PrintRow, PrintRows methods right after the PrintColumn method. If you ignore this rule you will get an exception.

Examples

In this example, we will consider all three ways to print a table which has 3 rows and 3 columns.

Case 1: print a table downwards.

CopyC#
// print table header (the first row)
Table1.PrintRow(0);
Table1.PrintColumns();
// print table body (the second row)
for (int i = 0; i < 10; i++)
{
  Table1.PrintRow(1);
  Table1.PrintColumns();
}
// print table footer (the third row)
Table1.PrintRow(2);
Table1.PrintColumns();

Case 2: print a table sidewards.

CopyC#
// print table header (the first column)
Table1.PrintColumn(0);
Table1.PrintRows();
// print table body (the second column)
for (int i = 0; i < 10; i++)
{
  Table1.PrintColumn(1);
  Table1.PrintRows();
}
// print table footer (the third column)
Table1.PrintColumn(2);
Table1.PrintRows();

Case 3: print a table downwards and sidewards.

CopyC#
// print the first row with all its columns
Table1.PrintRow(0);
// print header column
Table1.PrintColumn(0);
// print 10 data columns
for (int i = 0; i < 10; i++)
{
  Table1.PrintColumn(1);
}
// print footer column
Table1.PrintColumn(2);

// print table body (the second row)
for (int i = 0; i < 10; i++)
{
  // print data row with all its columns
  Table1.PrintRow(1);
  Table1.PrintColumn(0);
  for (int j = 0; j < 10; j++)
  {
    Table1.PrintColumn(1);
  }
  Table1.PrintColumn(2);
}

// print table footer (the third row)
Table1.PrintRow(2);
// again print all columns in the table footer
Table1.PrintColumn(0);
for (int i = 0; i < 10; i++)
{
  Table1.PrintColumn(1);
}
Table1.PrintColumn(2);

See Also

TableObject Class
FastReport.Table Namespace


TableResult Class

[image]

FastReport.Net Class Reference
TableResult Class
Members See Also Send Feedback
Represents a result table.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableResult : TableBase
Visual Basic (Declaration)
Public Class TableResult _
    Inherits TableBase
Visual C++
public ref class TableResult : public TableBase

Remarks

Do not use this class directly. It is used by the TableObject and MatrixObject objects to render a result.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport..::.ReportComponentBase
FastReport..::.BreakableComponent
FastReport.Table..::.TableBase
FastReport.Table..::.TableResult

See Also

TableResult Members
FastReport.Table Namespace


TableResult Members

[image] [image]

FastReport.Net Class Reference
TableResult Members
TableResult Class Constructors Methods Properties Events See Also Send Feedback

The TableResult type exposes the following members.

Constructors

Name | Description
TableResult | Creates a new instance of the TableResult class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from TableBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from TableBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell. (Inherited from TableBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TableBase.)
CalcHeight | Calculates the object's height. (Inherited from TableBase.)
CalcWidth | Calculates and returns the table width, in pixels. (Inherited from TableBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from TableBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell. (Inherited from TableBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells. (Inherited from TableBase.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from TableBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides TableBase..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Inherited from TableBase.)
GetContextMenu | Gets the object's context menu. (Inherited from TableBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TableBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from TableBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from TableBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from TableBase.)
Max | Calculates a maximum of values in a specified cell. (Inherited from TableBase.)
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell. (Inherited from TableBase.)
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from TableBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from TableBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from TableBase.)
RestoreState | Restores the object's state after printing it. (Inherited from TableBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from TableBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from TableBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from TableBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell. (Inherited from TableBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from TableBase.)

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages. (Inherited from TableBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from TableBase.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class. (Inherited from TableBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class. (Inherited from TableBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | Gets or sets a number of columns in the table. (Inherited from TableBase.)
Columns | Gets a collection of table columns. (Inherited from TableBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FixedColumns | Gets or sets the number of fixed columns that will be repeated on each page. (Inherited from TableBase.)
FixedRows | Gets or sets the number of fixed rows that will be repeated on each page. (Inherited from TableBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from TableBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class. (Inherited from TableBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from TableBase.)
Item | Gets or sets the table cell. (Inherited from TableBase.)
Layout | Gets or sets the table layout. (Inherited from TableBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page. (Inherited from TableBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table. (Inherited from TableBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the table. (Inherited from TableBase.)
Rows | Gets a collection of table rows. (Inherited from TableBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TableBase.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode. (Inherited from TableBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
AfterCalcBounds | Occurs after calculation of table bounds.
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableResult Class
FastReport.Table Namespace


TableResult Constructor

[image]

FastReport.Net Class Reference
TableResult Constructor
TableResult Class See Also Send Feedback
Creates a new instance of the TableResult class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableResult()

See Also

TableResult Class
FastReport.Table Namespace


TableResult Methods

[image] [image]

FastReport.Net Class Reference
TableResult Methods
TableResult Class See Also Send Feedback

The TableResult type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs. (Inherited from TableBase.)
ApplyStyle | Applies the style settings. (Inherited from ReportComponentBase.)
Assign | Copies the contents of another, similar object. (Inherited from TableBase.)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
AssignFormat | Assigns a format from another, similar object. (Inherited from ReportComponentBase.)
AssignPreviewEvents | Copies event handlers from another similar object. (Inherited from ReportComponentBase.)
Avg | Calculates an average of values in a specified cell. (Inherited from TableBase.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
Break | Breaks the contents of the object. (Inherited from TableBase.)
CalcHeight | Calculates the object's height. (Inherited from TableBase.)
CalcWidth | Calculates and returns the table width, in pixels. (Inherited from TableBase.)
CanContain | Gets a value indicating that this object can contain the specified child object. (Inherited from TableBase.)
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ReportComponentBase.)
Clear | Clears the object's state. (Inherited from Base.)
Count | Calculates number of repeats of a specified cell. (Inherited from TableBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
CreateUniqueNames | Creates unique names for all table elements such as rows, columns, cells. (Inherited from TableBase.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from TableBase.)
DrawBackground | Draws the object's background. (Inherited from ReportComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawMarkers | Overloaded.
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FinalizeComponent | Performs a finalization after the report is finished. (Inherited from ReportComponentBase.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects. (Overrides TableBase..::.GetChildObjects(ObjectCollection).)
GetChildOrder | Returns z-order of the specified child object. (Inherited from TableBase.)
GetContextMenu | Gets the object's context menu. (Inherited from TableBase.)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetData | Gets the data from a datasource that the object is connected to. (Inherited from ReportComponentBase.)
GetExpressions | Gets all expressions contained in the object. (Inherited from ReportComponentBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ReportComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Inherited from ComponentBase.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from TableBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from TableBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from TableBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from TableBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeComponent | Initializes the object before running a report. (Inherited from ReportComponentBase.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
IsVisible | Determines if the object is visible on current drawing surface. (Inherited from TableBase.)
Max | Calculates a maximum of values in a specified cell. (Inherited from TableBase.)
MemberwiseClone | Overloaded.
Min | Calculates a minimum of values in a specified cell. (Inherited from TableBase.)
OnAfterData | This method fires the AfterData event and the script code connected to the AfterDataEvent. (Inherited from ReportComponentBase.)
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from TableBase.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from ReportComponentBase.)
OnAfterPrint | This method fires the AfterPrint event and the script code connected to the AfterPrintEvent. (Inherited from ReportComponentBase.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from TableBase.)
OnBeforePrint | This method fires the BeforePrint event and the script code connected to the BeforePrintEvent. (Inherited from ReportComponentBase.)
OnClick | This method fires the Click event and the script code connected to the ClickEvent. (Inherited from ReportComponentBase.)
OnMouseDown | This method fires the MouseDown event and the script code connected to the MouseDownEvent. (Inherited from ReportComponentBase.)
OnMouseEnter | This method fires the MouseEnter event and the script code connected to the MouseEnterEvent. (Inherited from ReportComponentBase.)
OnMouseLeave | This method fires the MouseLeave event and the script code connected to the MouseLeaveEvent. (Inherited from ReportComponentBase.)
OnMouseMove | This method fires the MouseMove event and the script code connected to the MouseMoveEvent. (Inherited from ReportComponentBase.)
OnMouseUp | This method fires the MouseUp event and the script code connected to the MouseUpEvent. (Inherited from ReportComponentBase.)
OnMouseWheel | This method is fired when the user scrolls the mouse in the preview window. (Inherited from ReportComponentBase.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs. (Inherited from TableBase.)
RestoreState | Restores the object's state after printing it. (Inherited from TableBase.)
RestoreStyle | Restores the current style. (Inherited from ReportComponentBase.)
SaveState | Saves the object's state before printing it. (Inherited from TableBase.)
SaveStyle | Saves the current style. (Inherited from ReportComponentBase.)
SelectionChanged | Called when the user selects another object in the designer. (Inherited from Base.)
Serialize | Serializes the object. (Inherited from TableBase.)
SetChildOrder | Sets the z-order of the specified object. (Inherited from TableBase.)
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
Sum | Calculates a sum of values in a specified cell. (Inherited from TableBase.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values. (Inherited from TableBase.)

See Also

TableResult Class
FastReport.Table Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableResult..::.Dispose Method
TableResult Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Base..::.Dispose(Boolean).)

See Also

TableResult Class
TableResult Members
FastReport.Table Namespace


Dispose Method (Boolean)

[image]

FastReport.Net Class Reference
TableResult..::.Dispose Method (Boolean)
TableResult Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

TableResult Class
Dispose Overload
FastReport.Table Namespace


DrawMarkers Method

[image] [image]

FastReport.Net Class Reference
TableResult..::.DrawMarkers Method
TableResult Class See Also Send Feedback

Overload List

Name | Description
DrawMarkers(FRPaintEventArgs) | Draws the object's markers. (Inherited from ReportComponentBase.)
DrawMarkers(FRPaintEventArgs, MarkerStyle) | Draws the object's markers. (Inherited from ReportComponentBase.)

See Also

TableResult Class
TableResult Members
FastReport.Table Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
TableResult..::.GetChildObjects Method
TableResult Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Overrides Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) override

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

TableResult Class
FastReport.Table Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableResult..::.MemberwiseClone Method
TableResult Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableResult Class
TableResult Members
FastReport.Table Namespace


TableResult Properties

[image] [image]

FastReport.Net Class Reference
TableResult Properties
TableResult Class See Also Send Feedback

The TableResult type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AdjustSpannedCellsWidth | Gets or sets a value that determines whether to adjust the spanned cell's width when breaking the table across pages. (Inherited from TableBase.)
AfterDataEvent | Gets or sets a script event name that will be fired after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrintEvent | Gets or sets a script event name that will be fired after the object was printed in the preview page. (Inherited from ReportComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from ComponentBase.)
BaseName | The base part of the object's name. (Inherited from Base.)
BeforePrintEvent | Gets or sets a script event name that will be fired before the object will be printed in the preview page. (Inherited from ReportComponentBase.)
Bookmark | Gets or sets a bookmark expression. (Inherited from ReportComponentBase.)
Border | Gets or sets an object's border. (Inherited from ReportComponentBase.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
BreakTo | This property is not relevant to this class. (Inherited from TableBase.)
CanBreak | Gets or sets a value that determines if the component can break its contents across pages. (Inherited from BreakableComponent.)
CanGrow | This property is not relevant to this class. (Inherited from TableBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
CanShrink | This property is not relevant to this class. (Inherited from TableBase.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClickEvent | Gets or sets a script event name that will be fired when the user click the object in the preview window. (Inherited from ReportComponentBase.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
ColumnCount | Gets or sets a number of columns in the table. (Inherited from TableBase.)
Columns | Gets a collection of table columns. (Inherited from TableBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Cursor | Gets or sets an object's cursor shape. (Inherited from ReportComponentBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from ComponentBase.)
EvenStyle | Gets or sets a style name that will be applied to even band rows. (Inherited from ReportComponentBase.)
EvenStylePriority | Gets or sets a value that determines which properties of the even style to use. (Inherited from ReportComponentBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Exportable | Gets or sets a value that determines if the object can be exported. (Inherited from ReportComponentBase.)
Fill | Gets or sets an object's fill. (Inherited from ReportComponentBase.)
FillColor | Gets or sets the fill color in a simple manner. (Inherited from ReportComponentBase.)
FixedColumns | Gets or sets the number of fixed columns that will be repeated on each page. (Inherited from TableBase.)
FixedRows | Gets or sets the number of fixed rows that will be repeated on each page. (Inherited from TableBase.)
FlagPreviewVisible | Gets or sets a value indicates that object should not be added to the preview. (Inherited from ReportComponentBase.)
FlagProvidesHyperlinkValue | Determines if an object can provide the hyperlink value automatically. (Inherited from ReportComponentBase.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
FlagSerializeStyle | Determines if serializing the Style property is needed. (Inherited from ReportComponentBase.)
FlagSimpleBorder | Determines if the object has custom border and use only Border.Width, Border.Style and Border.Color properties. (Inherited from ReportComponentBase.)
FlagUseBorder | Determines if the object uses the Border. (Inherited from ReportComponentBase.)
FlagUseFill | Determines if the object uses the fill. (Inherited from ReportComponentBase.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
GrowToBottom | Determines if the object must grow to the band's bottom side. (Inherited from ReportComponentBase.)
Height | Gets or sets the height of the object. (Inherited from TableBase.)
HoverStyle | Gets or sets a style name that will be applied to this object when the mouse pointer is over it. (Inherited from ReportComponentBase.)
Hyperlink | This property is not relevant to this class. (Inherited from TableBase.)
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from TableBase.)
Item | Gets or sets the table cell. (Inherited from TableBase.)
Layout | Gets or sets the table layout. (Inherited from TableBase.)
Left | Gets or sets the left coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
MouseDownEvent | Gets or sets a script event name that will be fired when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnterEvent | Gets or sets a script event name that will be fired when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeaveEvent | Gets or sets a script event name that will be fired when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMoveEvent | Gets or sets a script event name that will be fired when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUpEvent | Gets or sets a script event name that will be fired when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Printable | Gets or sets a value that determines if the object can be printed on the printer. (Inherited from ReportComponentBase.)
PrintOn | Gets or sets a value that determines where to print the object. (Inherited from ReportComponentBase.)
RepeatHeaders | Gets or sets a value that determines whether is necessary to repeat table header on each page. (Inherited from TableBase.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
ResultTable | Gets a table which contains the result of rendering dynamic table. (Inherited from TableBase.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
RowCount | Gets or sets a number of rows in the table. (Inherited from TableBase.)
Rows | Gets a collection of table rows. (Inherited from TableBase.)
ShiftMode | Gets or sets a shift mode of the object. (Inherited from ReportComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Style | Gets or sets the style name. (Inherited from ReportComponentBase.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Inherited from ReportComponentBase.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | Gets or sets the width of the object. (Inherited from TableBase.)
WrappedGap | Gets or sets gap between parts of the table in wrapped layout mode. (Inherited from TableBase.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableResult Class
FastReport.Table Namespace


TableResult Events

[image] [image]

FastReport.Net Class Reference
TableResult Events
TableResult Class See Also Send Feedback

The TableResult type exposes the following members.

Events

Name | Description
AfterCalcBounds | Occurs after calculation of table bounds.
AfterData | This event occurs after the object was filled with data. (Inherited from ReportComponentBase.)
AfterPrint | This event occurs after the object was added to the preview pages. (Inherited from ReportComponentBase.)
BeforePrint | This event occurs before the object is added to the preview pages. (Inherited from ReportComponentBase.)
Click | This event occurs when the user clicks the object in the preview window. (Inherited from ReportComponentBase.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
MouseDown | This event occurs when the user clicks the mouse button in the preview window. (Inherited from ReportComponentBase.)
MouseEnter | This event occurs when the mouse enters the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseLeave | This event occurs when the mouse leaves the object's bounds in the preview window. (Inherited from ReportComponentBase.)
MouseMove | This event occurs when the user moves the mouse over the object in the preview window. (Inherited from ReportComponentBase.)
MouseUp | This event occurs when the user releases the mouse button in the preview window. (Inherited from ReportComponentBase.)

See Also

TableResult Class
FastReport.Table Namespace


AfterCalcBounds Event

[image]

FastReport.Net Class Reference
TableResult..::.AfterCalcBounds Event
TableResult Class See Also Send Feedback
Occurs after calculation of table bounds.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler AfterCalcBounds
Visual Basic (Declaration)
Public Event AfterCalcBounds As EventHandler
Visual C++
public:
 event EventHandler^ AfterCalcBounds {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

You may use this event to change automatically calculated rows/column sizes. It may be useful if you need to fit dynamically printed table on a page.

See Also

TableResult Class
FastReport.Table Namespace


TableRow Class

[image]

FastReport.Net Class Reference
TableRow Class
Members See Also Send Feedback
Represents a table row.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableRow : ComponentBase, IParent
Visual Basic (Declaration)
Public Class TableRow _
    Inherits ComponentBase _
    Implements IParent
Visual C++
public ref class TableRow : public ComponentBase,
    IParent

Remarks

Use the Height property to set the height of a row. If AutoSize property is true, the row will calculate its height automatically.

You can also set the MinHeight and MaxHeight properties to restrict the row's height.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
FastReport..::.Base
FastReport..::.ComponentBase
FastReport.Table..::.TableRow

See Also

TableRow Members
FastReport.Table Namespace


TableRow Members

[image] [image]

FastReport.Net Class Reference
TableRow Members
TableRow Class Constructors Methods Properties Events See Also Send Feedback

The TableRow type exposes the following members.

Constructors

Name | Description
TableRow | Initializes a new instance of the TableRow class.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
AutoSize | Gets or sets a value determines if the row should calculate its height automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets a height of the row, in pixels. (Overrides ComponentBase..::.Height.)
Index | Gets the index of this row.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Gets or sets the cell with specified index.
KeepRows | Gets or sets the number of rows to keep on the same page.
Left | This property is not relevant to this class. (Overrides ComponentBase..::.Left.)
MaxHeight | Gets or sets the maximal height for this row, in pixels.
MinHeight | Gets or sets the minimal height for this row, in pixels.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreak | Gets or sets the page break flag for this row.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | This property is not relevant to this class. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TableRow Class
FastReport.Table Namespace


TableRow Constructor

[image]

FastReport.Net Class Reference
TableRow Constructor
TableRow Class See Also Send Feedback
Initializes a new instance of the TableRow class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableRow()

See Also

TableRow Class
FastReport.Table Namespace


TableRow Methods

[image] [image]

FastReport.Net Class Reference
TableRow Methods
TableRow Class See Also Send Feedback

The TableRow type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object to this object's childs.
Assign | Copies the contents of another, similar object. (Overrides ComponentBase..::.Assign(Base).)
AssignAll | Copies the contents (including children) of another, similar object. (Inherited from Base.)
BaseAssign | Assigns values from another source. (Inherited from Base.)
CanContain | Gets a value indicating that this object can contain the specified child object.
CheckNegativeSize | Corrects the object's size and sizing point if the size becomes negative. (Inherited from ComponentBase.)
CheckParent | Checks if the object is inside its parent. (Inherited from ComponentBase.)
Clear | Clears the object's state. (Overrides Base..::.Clear()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateUniqueName | Creates the unique object's name. (Inherited from Base.)
Delete | Deletes the object in the designer. (Inherited from Base.)
Deserialize | Deserializes the object. (Inherited from Base.)
DeserializeSubItems | Deserializes nested object properties. (Inherited from Base.)
Dispose | Overloaded.
Draw | Draws the object. (Inherited from ComponentBase.)
DrawDragAcceptFrame | Draw the frame around the object to indicate that it accepts the drag&drop operation. (Inherited from ComponentBase.)
DrawSelection | Draw the selection points. (Inherited from ComponentBase.)
DrawSelectionPoint | Draws the selection point. (Inherited from ComponentBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractDefaultMacros | Replaces the macros in the given string and returns the new string. (Inherited from Base.)
ExtractMacros | Used to extract macros such as "TotalPages#" in the preview mode. (Inherited from Base.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindObject | Searches for an object with given name. (Inherited from Base.)
FloatDiff | Checks if two float values are different. (Inherited from Base.)
GetChildObjects | Gets a list of child objects.
GetChildOrder | Returns z-order of the specified child object.
GetContextMenu | Gets the object's context menu. (Overrides ComponentBase..::.GetContextMenu()()().)
GetCustomScript | Returns a custom code that will be added to the report script before report is run. (Inherited from Base.)
GetExpressions | Gets all expressions contained in the object. (Inherited from Base.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPreferredSize | Gets the preferred size of an object. (Inherited from ComponentBase.)
GetSelectionPoints | Gets the object's selection points. (Overrides ComponentBase..::.GetSelectionPoints()()().)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSmartTag | Returns a "smart tag" menu. (Inherited from ComponentBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleDoubleClick | Handles double click event in the designer. (Inherited from ComponentBase.)
HandleDragDrop | Handles the DragDrop event in the designer. (Inherited from ComponentBase.)
HandleDragOver | Handles the DragOver event in the designer. (Inherited from ComponentBase.)
HandleKeyDown | Handles KeyDown event in the designer. (Inherited from ComponentBase.)
HandleMouseDown | Handles MouseDown event that occurs when the user clicks the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseHover | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseMove | Handles MouseMove event that occurs when the user moves the mouse in the designer. (Inherited from ComponentBase.)
HandleMouseUp | Handles MouseUp event that occurs when the user releases the mouse button in the designer. (Inherited from ComponentBase.)
HandleMouseWheel | Handles mouse wheel event. (Inherited from ComponentBase.)
HasFlag | Gets a value indicating whether the object has a specified flag in its Flags property. (Inherited from Base.)
HasParent | Gets a value indicating whether the object has the specified parent in its parent hierarhy. (Inherited from Base.)
HasRestriction | Gets a value indicating whether the object has a specified restriction in its Restrictions property. (Inherited from Base.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InvokeEvent | Invokes script event. (Inherited from Base.)
MemberwiseClone | Overloaded.
OnAfterInsert | Called after the new object was inserted in the designer. (Inherited from Base.)
OnAfterLoad | Called after all report objects were loaded. (Inherited from Base.)
OnBeforeInsert | Called before inserting a new object in the designer. (Inherited from Base.)
PointInObject | Checks if given point is inside the object's bounds. (Inherited from ComponentBase.)
PointInSelectionPoint | Gets a value indicating that given point is inside selection point. (Inherited from ComponentBase.)
RemoveChild | Removes a specified object from this object's childs.
SelectionChanged | Called when the user selects another object in the designer. (Overrides Base..::.SelectionChanged()()().)
Serialize | Serializes the object. (Overrides ComponentBase..::.Serialize(FRWriter).)
SetChildOrder | Sets the z-order of the specified object.
SetFlags | Set object's flags. (Inherited from Base.)
SetName | Sets the object's name. (Inherited from Base.)
SetParent | Sets the object's parent. (Inherited from Base.)
SetParentCore | Sets the object's parent. (Inherited from Base.)
SetProp | Helper method, helps to set a reference-type value to the property. (Inherited from Base.)
SetReport | Sets the reference to a Report. (Inherited from Base.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateLayout | Updates the children layout when the size of this object is changed by dx, dy values.

See Also

TableRow Class
FastReport.Table Namespace


AddChild Method

[image]

FastReport.Net Class Reference
TableRow..::.AddChild Method
TableRow Class See Also Send Feedback
Adds a child object to this object's childs.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddChild(
    Base child
)
Visual Basic (Declaration)
Public Sub AddChild ( _
    child As Base _
)
Visual C++
public:
virtual void AddChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Object to add.

Implements

IParent..::.AddChild(Base)

See Also

TableRow Class
FastReport.Table Namespace


Assign Method

[image]

FastReport.Net Class Reference
TableRow..::.Assign Method
TableRow Class Example See Also Send Feedback
Copies the contents of another, similar object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Assign(
    Base source
)
Visual Basic (Declaration)
Public Overrides Sub Assign ( _
    source As Base _
)
Visual C++
public:
virtual void Assign(
    Base^ source
) override

Parameters

source
Type: FastReport..::.Base
Source object to copy the contents from.

Remarks

Call Assign to copy the properties from another object of the same type. The standard form of a call to Assign is

destination.Assign(source);

which tells the destination object to copy the contents of the source object to itself. In this method, all child objects are ignored. If you want to copy child objects, use the AssignAll method.

Examples

CopyC#
Report report1;
Report report2 = new Report();
// copy all report settings, do not copy report objects
report2.Assign(report1);

See Also

TableRow Class
FastReport.Table Namespace
AssignAll Method


CanContain Method

[image]

FastReport.Net Class Reference
TableRow..::.CanContain Method
TableRow Class See Also Send Feedback
Gets a value indicating that this object can contain the specified child object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool CanContain(
    Base child
)
Visual Basic (Declaration)
Public Function CanContain ( _
    child As Base _
) As Boolean
Visual C++
public:
virtual bool CanContain(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

true if this object can contain the specified child object; otherwise, false.

Implements

IParent..::.CanContain(Base)

See Also

TableRow Class
FastReport.Table Namespace


Clear Method

[image]

FastReport.Net Class Reference
TableRow..::.Clear Method
TableRow Class See Also Send Feedback
Clears the object's state.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

This method also disposes all object's children.

See Also

TableRow Class
FastReport.Table Namespace


Dispose Method

[image] [image]

FastReport.Net Class Reference
TableRow..::.Dispose Method
TableRow Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Base.)

See Also

TableRow Class
TableRow Members
FastReport.Table Namespace


GetChildObjects Method

[image]

FastReport.Net Class Reference
TableRow..::.GetChildObjects Method
TableRow Class See Also Send Feedback
Gets a list of child objects.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void GetChildObjects(
    ObjectCollection list
)
Visual Basic (Declaration)
Public Sub GetChildObjects ( _
    list As ObjectCollection _
)
Visual C++
public:
virtual void GetChildObjects(
    ObjectCollection^ list
) sealed

Parameters

list
Type: FastReport..::.ObjectCollection
List to fill with values.

Implements

IParent..::.GetChildObjects(ObjectCollection)

See Also

TableRow Class
FastReport.Table Namespace


GetChildOrder Method

[image]

FastReport.Net Class Reference
TableRow..::.GetChildOrder Method
TableRow Class See Also Send Feedback
Returns z-order of the specified child object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int GetChildOrder(
    Base child
)
Visual Basic (Declaration)
Public Function GetChildOrder ( _
    child As Base _
) As Integer
Visual C++
public:
virtual int GetChildOrder(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.

Return Value

Z-order of the specified object.

Implements

IParent..::.GetChildOrder(Base)

Remarks

This method must return the index of a specified child object in the internal child list.

See Also

TableRow Class
FastReport.Table Namespace


GetContextMenu Method

[image]

FastReport.Net Class Reference
TableRow..::.GetContextMenu Method
TableRow Class See Also Send Feedback
Gets the object's context menu.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override ContextMenuBar GetContextMenu()
Visual Basic (Declaration)
Public Overrides Function GetContextMenu As ContextMenuBar
Visual C++
public:
virtual ContextMenuBar^ GetContextMenu() override

Return Value

Null reference if object does not have a menu.

Remarks

Do not call this method directly. You may override it if you are developing a new component for FastReport.

You may use base menu classes such as ComponentMenuBase, ReportComponentBaseMenu to create own context menus.

See Also

TableRow Class
FastReport.Table Namespace


GetSelectionPoints Method

[image]

FastReport.Net Class Reference
TableRow..::.GetSelectionPoints Method
TableRow Class See Also Send Feedback
Gets the object's selection points.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override SelectionPoint[] GetSelectionPoints()
Visual Basic (Declaration)
Protected Overrides Function GetSelectionPoints As SelectionPoint()
Visual C++
protected:
virtual array<SelectionPoint^>^ GetSelectionPoints() override

Return Value

Array of SelectionPoint objects.

Remarks

Selection point is a small square displayed at the object's sides when object is selected in the designer. You can drag this square by the mouse to change the object's size. For example, the TextObject has eight selection points to change its width and height by the mouse.

If you are developing a new component for FastReport, you may override this method if your object has non-standard set of selection points. For example, if an object has something like "AutoSize" property, it would be good to disable all selection points if that property is true, to disable resizing of the object by the mouse.

See Also

TableRow Class
FastReport.Table Namespace


MemberwiseClone Method

[image] [image]

FastReport.Net Class Reference
TableRow..::.MemberwiseClone Method
TableRow Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TableRow Class
TableRow Members
FastReport.Table Namespace


RemoveChild Method

[image]

FastReport.Net Class Reference
TableRow..::.RemoveChild Method
TableRow Class See Also Send Feedback
Removes a specified object from this object's childs.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void RemoveChild(
    Base child
)
Visual Basic (Declaration)
Public Sub RemoveChild ( _
    child As Base _
)
Visual C++
public:
virtual void RemoveChild(
    Base^ child
) sealed

Parameters

child
Type: FastReport..::.Base

Implements

IParent..::.RemoveChild(Base)

See Also

TableRow Class
FastReport.Table Namespace


SelectionChanged Method

[image]

FastReport.Net Class Reference
TableRow..::.SelectionChanged Method
TableRow Class See Also Send Feedback
Called when the user selects another object in the designer.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void SelectionChanged()
Visual Basic (Declaration)
Public Overrides Sub SelectionChanged
Visual C++
public:
virtual void SelectionChanged() override

Remarks

This method is typically used by the in-place object's editor to check if selection was changed and close the editor.

See Also

TableRow Class
FastReport.Table Namespace


Serialize Method

[image]

FastReport.Net Class Reference
TableRow..::.Serialize Method
TableRow Class See Also Send Feedback
Serializes the object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void Serialize(
    FRWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    writer As FRWriter _
)
Visual C++
public:
virtual void Serialize(
    FRWriter^ writer
) override

Parameters

writer
Type: FastReport.Utils..::.FRWriter
Writer object.

Implements

IFRSerializable..::.Serialize(FRWriter)

Remarks

Do not call this method directly. You should override it if you are developing a new component for FastReport.

This method is called when the object needs to save the state. It may happen when:

  • saving the report to the file or stream;
  • saving the report to the designer's undo buffer;
  • assigning the object to another object using the Assign(Base) or AssignAll methods;
  • saving the object to the designer's clipboard;
  • saving the object to the preview (when run a report).

See Also

TableRow Class
FastReport.Table Namespace


SetChildOrder Method

[image]

FastReport.Net Class Reference
TableRow..::.SetChildOrder Method
TableRow Class See Also Send Feedback
Sets the z-order of the specified object.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetChildOrder(
    Base child,
    int order
)
Visual Basic (Declaration)
Public Sub SetChildOrder ( _
    child As Base, _
    order As Integer _
)
Visual C++
public:
virtual void SetChildOrder(
    Base^ child,
    int order
) sealed

Parameters

child
Type: FastReport..::.Base
Child object.
order
Type: System..::.Int32
New Z-order.

Implements

IParent..::.SetChildOrder(Base, Int32)

Remarks

This method must place the specified child object at the specified position in the internal child list.

See Also

TableRow Class
FastReport.Table Namespace


UpdateLayout Method

[image]

FastReport.Net Class Reference
TableRow..::.UpdateLayout Method
TableRow Class See Also Send Feedback
Updates the children layout when the size of this object is changed by dx, dy values.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void UpdateLayout(
    float dx,
    float dy
)
Visual Basic (Declaration)
Public Sub UpdateLayout ( _
    dx As Single, _
    dy As Single _
)
Visual C++
public:
virtual void UpdateLayout(
    float dx,
    float dy
) sealed

Parameters

dx
Type: System..::.Single
X delta.
dy
Type: System..::.Single
Y delta.

Implements

IParent..::.UpdateLayout(Single, Single)

Remarks

This method must update positions/sizes of child objects whose Dock or Anchor properties are set to non-default values.

See Also

TableRow Class
FastReport.Table Namespace


TableRow Properties

[image] [image]

FastReport.Net Class Reference
TableRow Properties
TableRow Class See Also Send Feedback

The TableRow type exposes the following members.

Properties

Name | Description
AbsBottom | Gets the absolute bottom coordinate of the object. (Inherited from ComponentBase.)
AbsBounds | Gets the absolute bounding rectangle of the object. (Inherited from ComponentBase.)
AbsLeft | Gets the absolute left coordinate of the object. (Inherited from ComponentBase.)
AbsRight | Gets the absolute right coordinate of the object. (Inherited from ComponentBase.)
AbsTop | Gets the absolute top coordinate of the object. (Inherited from ComponentBase.)
AllObjects | Gets the collection of all child objects. (Inherited from Base.)
Anchor | This property is not relevant to this class. (Overrides ComponentBase..::.Anchor.)
AutoSize | Gets or sets a value determines if the row should calculate its height automatically.
BaseName | The base part of the object's name. (Inherited from Base.)
Bottom | Gets the bottom coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Bounds | Gets or sets the bounding rectangle of the object. (Inherited from ComponentBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ChildObjects | Gets the collection of this object's child objects. (Inherited from Base.)
ClassName | Gets the short type name. (Inherited from Base.)
ClientSize | Gets or sets the size of client area of the object. (Inherited from ComponentBase.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dock | This property is not relevant to this class. (Overrides ComponentBase..::.Dock.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Flags | Gets the flags that allow some functionality in the designer. (Inherited from Base.)
GroupIndex | Gets or sets a group index. (Inherited from ComponentBase.)
Height | Gets or sets a height of the row, in pixels. (Overrides ComponentBase..::.Height.)
Index | Gets the index of this row.
IsAncestor | Gets a value indicating whether the object was introduced in the ancestor report. (Inherited from Base.)
IsDesigning | Gets a value indicating whether the object is in the design state. (Inherited from Base.)
IsParentSelected | Gets a value indicating whether one of the object's parent is selected in the designer. (Inherited from Base.)
IsPrinting | Gets a value indicating whether the object is currently printing. (Inherited from Base.)
IsRunning | Gets a value indicating whether the object is currently processed by the report engine. (Inherited from Base.)
IsSelected | Gets a value indicating whether the object is selected in the designer. (Inherited from Base.)
Item | Gets or sets the cell with specified index.
KeepRows | Gets or sets the number of rows to keep on the same page.
Left | This property is not relevant to this class. (Overrides ComponentBase..::.Left.)
MaxHeight | Gets or sets the maximal height for this row, in pixels.
MinHeight | Gets or sets the minimal height for this row, in pixels.
Name | Gets or sets the name of the object. (Inherited from Base.)
OriginalComponent | Gets an original component for this object. (Inherited from Base.)
Page | Gets reference to the parent PageBase object. (Inherited from Base.)
PageBreak | Gets or sets the page break flag for this row.
Parent | Gets or sets the parent of the object. (Inherited from Base.)
Report | Gets reference to the parent Report object. (Inherited from Base.)
Restrictions | Gets or sets the flags that restrict some actions in the designer. (Inherited from Base.)
Right | Gets the right coordinate of the object in relation to its container. (Inherited from ComponentBase.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top | Gets or sets the top coordinate of the object in relation to its container. (Overrides ComponentBase..::.Top.)
Visible | Gets or sets a value indicating whether the object is displayed in the preview window. (Inherited from ComponentBase.)
Width | This property is not relevant to this class. (Overrides ComponentBase..::.Width.)
ZOrder | Gets or sets the Z-order of the object. (Inherited from Base.)

See Also

TableRow Class
FastReport.Table Namespace


Anchor Property

[image]

FastReport.Net Class Reference
TableRow..::.Anchor Property
TableRow Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
Public Overrides Property Anchor As AnchorStyles
Visual C++
public:
virtual property AnchorStyles Anchor {
    AnchorStyles get () override;
    void set (AnchorStyles value) override;
}

See Also

TableRow Class
FastReport.Table Namespace


AutoSize Property

[image]

FastReport.Net Class Reference
TableRow..::.AutoSize Property
TableRow Class See Also Send Feedback
Gets or sets a value determines if the row should calculate its height automatically.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

Remarks

The row height cannot exceed the range defined by the MinHeight and MaxHeight properties.

See Also

TableRow Class
FastReport.Table Namespace


Dock Property

[image]

FastReport.Net Class Reference
TableRow..::.Dock Property
TableRow Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override DockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Dock As DockStyle
Visual C++
public:
virtual property DockStyle Dock {
    DockStyle get () override;
    void set (DockStyle value) override;
}

See Also

TableRow Class
FastReport.Table Namespace


Height Property

[image]

FastReport.Net Class Reference
TableRow..::.Height Property
TableRow Class See Also Send Feedback
Gets or sets a height of the row, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Single
Visual C++
public:
virtual property float Height {
    float get () override;
    void set (float value) override;
}

Remarks

The row height cannot exceed the range defined by the MinHeight and MaxHeight properties.
Note:To convert between pixels and report units, use the constants defined in the Units class.

See Also

TableRow Class
FastReport.Table Namespace


Index Property

[image]

FastReport.Net Class Reference
TableRow..::.Index Property
TableRow Class See Also Send Feedback
Gets the index of this row.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

TableRow Class
FastReport.Table Namespace


Item Property

[image]

FastReport.Net Class Reference
TableRow..::.Item Property
TableRow Class See Also Send Feedback
Gets or sets the cell with specified index.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableCell this[
    int col
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    col As Integer _
) As TableCell
Visual C++
public:
property TableCell^ default[int col] {
    TableCell^ get (int col);
    void set (int col, TableCell^ value);
}

Parameters

col
Type: System..::.Int32
Column index.

Return Value

The TableCell object.

See Also

TableRow Class
FastReport.Table Namespace


KeepRows Property

[image]

FastReport.Net Class Reference
TableRow..::.KeepRows Property
TableRow Class See Also Send Feedback
Gets or sets the number of rows to keep on the same page.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int KeepRows { get; set; }
Visual Basic (Declaration)
Public Property KeepRows As Integer
Visual C++
public:
property int KeepRows {
    int get ();
    void set (int value);
}

See Also

TableRow Class
FastReport.Table Namespace


Left Property

[image]

FastReport.Net Class Reference
TableRow..::.Left Property
TableRow Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Single
Visual C++
public:
virtual property float Left {
    float get () override;
    void set (float value) override;
}

See Also

TableRow Class
FastReport.Table Namespace


MaxHeight Property

[image]

FastReport.Net Class Reference
TableRow..::.MaxHeight Property
TableRow Class See Also Send Feedback
Gets or sets the maximal height for this row, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MaxHeight { get; set; }
Visual Basic (Declaration)
Public Property MaxHeight As Single
Visual C++
public:
property float MaxHeight {
    float get ();
    void set (float value);
}

See Also

TableRow Class
FastReport.Table Namespace


MinHeight Property

[image]

FastReport.Net Class Reference
TableRow..::.MinHeight Property
TableRow Class See Also Send Feedback
Gets or sets the minimal height for this row, in pixels.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float MinHeight { get; set; }
Visual Basic (Declaration)
Public Property MinHeight As Single
Visual C++
public:
property float MinHeight {
    float get ();
    void set (float value);
}

See Also

TableRow Class
FastReport.Table Namespace


PageBreak Property

[image]

FastReport.Net Class Reference
TableRow..::.PageBreak Property
TableRow Class See Also Send Feedback
Gets or sets the page break flag for this row.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool PageBreak { get; set; }
Visual Basic (Declaration)
Public Property PageBreak As Boolean
Visual C++
public:
property bool PageBreak {
    bool get ();
    void set (bool value);
}

See Also

TableRow Class
FastReport.Table Namespace


Top Property

[image]

FastReport.Net Class Reference
TableRow..::.Top Property
TableRow Class Example See Also Send Feedback
Gets or sets the top coordinate of the object in relation to its container.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Single
Visual C++
public:
virtual property float Top {
    float get () override;
    void set (float value) override;
}

Remarks

This property value is measured in the screen pixels. Use Units class to convert a value to desired units.

To obtain absolute coordinate, use AbsTop property.

Examples

The following example demonstrates how to convert between pixels and units:
CopyC#
TextObject text1;
// set Top to 10mm
text1.Top = Units.Millimeters * 10;
// convert a value to millimeters
MessageBox.Show("Top = " + (text1.Top / Units.Millimeters).ToString() + "mm");

See Also

TableRow Class
FastReport.Table Namespace


Width Property

[image]

FastReport.Net Class Reference
TableRow..::.Width Property
TableRow Class See Also Send Feedback
This property is not relevant to this class.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single
Visual C++
public:
virtual property float Width {
    float get () override;
    void set (float value) override;
}

See Also

TableRow Class
FastReport.Table Namespace


TableRow Events

[image] [image]

FastReport.Net Class Reference
TableRow Events
TableRow Class See Also Send Feedback

The TableRow type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TableRow Class
FastReport.Table Namespace


TableRowCollection Class

[image]

FastReport.Net Class Reference
TableRowCollection Class
Members See Also Send Feedback
Represents a collection of TableRow objects.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableRowCollection : FRCollectionBase
Visual Basic (Declaration)
Public Class TableRowCollection _
    Inherits FRCollectionBase
Visual C++
public ref class TableRowCollection : public FRCollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport.Table..::.TableRowCollection

See Also

TableRowCollection Members
FastReport.Table Namespace


TableRowCollection Members

[image] [image]

FastReport.Net Class Reference
TableRowCollection Members
TableRowCollection Class Methods Properties See Also Send Feedback

The TableRowCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides FRCollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides FRCollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a row with specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TableRowCollection Class
FastReport.Table Namespace


TableRowCollection Methods

[image] [image]

FastReport.Net Class Reference
TableRowCollection Methods
TableRowCollection Class See Also Send Feedback

The TableRowCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection. (Inherited from FRCollectionBase.)
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from FRCollectionBase.)
CopyTo | Copies the content to another collection. (Inherited from FRCollectionBase.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object. (Inherited from FRCollectionBase.)
Insert | Inserts an object into this collection at the specified index. (Inherited from FRCollectionBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from FRCollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides FRCollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides FRCollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection. (Inherited from FRCollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items. (Inherited from FRCollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableRowCollection Class
FastReport.Table Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
TableRowCollection..::.AddRange Method
TableRowCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection. (Inherited from FRCollectionBase.)

See Also

TableRowCollection Class
TableRowCollection Members
FastReport.Table Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
TableRowCollection..::.Equals Method
TableRowCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal. (Inherited from FRCollectionBase.)

See Also

TableRowCollection Class
TableRowCollection Members
FastReport.Table Namespace


OnInsert Method

[image]

FastReport.Net Class Reference
TableRowCollection..::.OnInsert Method
TableRowCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new element into the CollectionBase instance.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which to insert value.
value
Type: System..::.Object
The new value of the element at index.

See Also

TableRowCollection Class
FastReport.Table Namespace


OnRemove Method

[image]

FastReport.Net Class Reference
TableRowCollection..::.OnRemove Method
TableRowCollection Class See Also Send Feedback
Performs additional custom processes when removing an element from the CollectionBase instance.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which value can be found.
value
Type: System..::.Object
The value of the element to remove from index.

See Also

TableRowCollection Class
FastReport.Table Namespace


TableRowCollection Properties

[image] [image]

FastReport.Net Class Reference
TableRowCollection Properties
TableRowCollection Class See Also Send Feedback

The TableRowCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a row with specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection. (Inherited from FRCollectionBase.)

See Also

TableRowCollection Class
FastReport.Table Namespace


Item Property

[image]

FastReport.Net Class Reference
TableRowCollection..::.Item Property
TableRowCollection Class See Also Send Feedback
Gets a row with specified index.

Namespace: FastReport.Table
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public TableRow this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As TableRow
Visual C++
public:
property TableRow^ default[int index] {
    TableRow^ get (int index);
}

Parameters

index
Type: System..::.Int32
Index of a row.

Return Value

The row with specified index.

See Also

TableRowCollection Class
FastReport.Table Namespace


FastReport.TypeConverters Namespace

[image]

FastReport.Net Class Reference
FastReport.TypeConverters Namespace
Send Feedback

Classes

Class | Description
ComponentRefConverter | Provides a type converter for a property representing a reference to another component in a report.
DataTypeConverter | Provides a type converter for a property representing a data type.
FRExpandableObjectConverter | Provides a type converter for a property representing an expandable object.
UnitsConverter | Provides a type converter for a property representing a value measured in the current report units.


ComponentRefConverter Class

[image]

FastReport.Net Class Reference
ComponentRefConverter Class
Members See Also Send Feedback
Provides a type converter for a property representing a reference to another component in a report.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ComponentRefConverter : TypeConverter
Visual Basic (Declaration)
Public Class ComponentRefConverter _
    Inherits TypeConverter
Visual C++
public ref class ComponentRefConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
FastReport.TypeConverters..::.ComponentRefConverter

See Also

ComponentRefConverter Members
FastReport.TypeConverters Namespace


ComponentRefConverter Members

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter Members
ComponentRefConverter Class Constructors Methods See Also Send Feedback

The ComponentRefConverter type exposes the following members.

Constructors

Name | Description
ComponentRefConverter | Initializes a new instance of the ComponentRefConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComponentRefConverter Class
FastReport.TypeConverters Namespace


ComponentRefConverter Constructor

[image]

FastReport.Net Class Reference
ComponentRefConverter Constructor
ComponentRefConverter Class See Also Send Feedback
Initializes a new instance of the ComponentRefConverter class

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentRefConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ComponentRefConverter()

See Also

ComponentRefConverter Class
FastReport.TypeConverters Namespace


ComponentRefConverter Methods

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter Methods
ComponentRefConverter Class See Also Send Feedback

The ComponentRefConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComponentRefConverter Class
FastReport.TypeConverters Namespace


CanConvertFrom Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.CanConvertFrom Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
ComponentRefConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
ComponentRefConverter Class See Also Send Feedback
Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

ComponentRefConverter Class
CanConvertFrom Overload
FastReport.TypeConverters Namespace


CanConvertTo Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.CanConvertTo Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
ComponentRefConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
ComponentRefConverter Class See Also Send Feedback
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: System..::.Type
A Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

ComponentRefConverter Class
CanConvertTo Overload
FastReport.TypeConverters Namespace


ConvertFrom Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertFrom Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
ComponentRefConverter Class See Also Send Feedback
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::.Object
The Object to convert.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.NotSupportedException | The conversion cannot be performed.

See Also

ComponentRefConverter Class
ConvertFrom Overload
FastReport.TypeConverters Namespace


ConvertFromInvariantString Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertFromInvariantString Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


ConvertFromString Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertFromString Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertTo Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
ComponentRefConverter Class See Also Send Feedback
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

ComponentRefConverter Class
ConvertTo Overload
FastReport.TypeConverters Namespace


ConvertToInvariantString Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertToInvariantString Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


ConvertToString Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.ConvertToString Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


CreateInstance Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.CreateInstance Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


GetCreateInstanceSupported Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.GetCreateInstanceSupported Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.GetProperties Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


GetPropertiesSupported Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.GetPropertiesSupported Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


GetStandardValues Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.GetStandardValues Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesExclusive Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.GetStandardValuesExclusive Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesSupported Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.GetStandardValuesSupported Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


IsValid Method

[image] [image]

FastReport.Net Class Reference
ComponentRefConverter..::.IsValid Method
ComponentRefConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

ComponentRefConverter Class
ComponentRefConverter Members
FastReport.TypeConverters Namespace


DataTypeConverter Class

[image]

FastReport.Net Class Reference
DataTypeConverter Class
Members See Also Send Feedback
Provides a type converter for a property representing a data type.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataTypeConverter : TypeConverter
Visual Basic (Declaration)
Public Class DataTypeConverter _
    Inherits TypeConverter
Visual C++
public ref class DataTypeConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
FastReport.TypeConverters..::.DataTypeConverter

See Also

DataTypeConverter Members
FastReport.TypeConverters Namespace


DataTypeConverter Members

[image] [image]

FastReport.Net Class Reference
DataTypeConverter Members
DataTypeConverter Class Constructors Methods See Also Send Feedback

The DataTypeConverter type exposes the following members.

Constructors

Name | Description
DataTypeConverter | Initializes a new instance of the DataTypeConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTypeConverter Class
FastReport.TypeConverters Namespace


DataTypeConverter Constructor

[image]

FastReport.Net Class Reference
DataTypeConverter Constructor
DataTypeConverter Class See Also Send Feedback
Initializes a new instance of the DataTypeConverter class

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataTypeConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataTypeConverter()

See Also

DataTypeConverter Class
FastReport.TypeConverters Namespace


DataTypeConverter Methods

[image] [image]

FastReport.Net Class Reference
DataTypeConverter Methods
DataTypeConverter Class See Also Send Feedback

The DataTypeConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTypeConverter Class
FastReport.TypeConverters Namespace


CanConvertFrom Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.CanConvertFrom Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
DataTypeConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
DataTypeConverter Class See Also Send Feedback
Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

DataTypeConverter Class
CanConvertFrom Overload
FastReport.TypeConverters Namespace


CanConvertTo Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.CanConvertTo Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
DataTypeConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
DataTypeConverter Class See Also Send Feedback
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: System..::.Type
A Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

DataTypeConverter Class
CanConvertTo Overload
FastReport.TypeConverters Namespace


ConvertFrom Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertFrom Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
DataTypeConverter Class See Also Send Feedback
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::.Object
The Object to convert.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.NotSupportedException | The conversion cannot be performed.

See Also

DataTypeConverter Class
ConvertFrom Overload
FastReport.TypeConverters Namespace


ConvertFromInvariantString Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertFromInvariantString Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


ConvertFromString Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertFromString Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertTo Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
DataTypeConverter Class See Also Send Feedback
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

DataTypeConverter Class
ConvertTo Overload
FastReport.TypeConverters Namespace


ConvertToInvariantString Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertToInvariantString Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


ConvertToString Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.ConvertToString Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


CreateInstance Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.CreateInstance Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


GetCreateInstanceSupported Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.GetCreateInstanceSupported Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.GetProperties Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


GetPropertiesSupported Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.GetPropertiesSupported Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


GetStandardValues Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.GetStandardValues Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesExclusive Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.GetStandardValuesExclusive Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesSupported Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.GetStandardValuesSupported Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


IsValid Method

[image] [image]

FastReport.Net Class Reference
DataTypeConverter..::.IsValid Method
DataTypeConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

DataTypeConverter Class
DataTypeConverter Members
FastReport.TypeConverters Namespace


FRExpandableObjectConverter Class

[image]

FastReport.Net Class Reference
FRExpandableObjectConverter Class
Members See Also Send Feedback
Provides a type converter for a property representing an expandable object.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FRExpandableObjectConverter : TypeConverter
Visual Basic (Declaration)
Public Class FRExpandableObjectConverter _
    Inherits TypeConverter
Visual C++
public ref class FRExpandableObjectConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
FastReport.TypeConverters..::.FRExpandableObjectConverter

See Also

FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


FRExpandableObjectConverter Members

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter Members
FRExpandableObjectConverter Class Constructors Methods See Also Send Feedback

The FRExpandableObjectConverter type exposes the following members.

Constructors

Name | Description
FRExpandableObjectConverter | Initializes a new instance of the FRExpandableObjectConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FRExpandableObjectConverter Class
FastReport.TypeConverters Namespace


FRExpandableObjectConverter Constructor

[image]

FastReport.Net Class Reference
FRExpandableObjectConverter Constructor
FRExpandableObjectConverter Class See Also Send Feedback
Initializes a new instance of the FRExpandableObjectConverter class

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRExpandableObjectConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FRExpandableObjectConverter()

See Also

FRExpandableObjectConverter Class
FastReport.TypeConverters Namespace


FRExpandableObjectConverter Methods

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter Methods
FRExpandableObjectConverter Class See Also Send Feedback

The FRExpandableObjectConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FRExpandableObjectConverter Class
FastReport.TypeConverters Namespace


CanConvertFrom Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.CanConvertFrom Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


CanConvertTo Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.CanConvertTo Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
FRExpandableObjectConverter Class See Also Send Feedback
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: System..::.Type
A Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

FRExpandableObjectConverter Class
CanConvertTo Overload
FastReport.TypeConverters Namespace


ConvertFrom Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertFrom Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


ConvertFromInvariantString Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertFromInvariantString Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


ConvertFromString Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertFromString Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertTo Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
FRExpandableObjectConverter Class See Also Send Feedback
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

FRExpandableObjectConverter Class
ConvertTo Overload
FastReport.TypeConverters Namespace


ConvertToInvariantString Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertToInvariantString Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


ConvertToString Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.ConvertToString Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


CreateInstance Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.CreateInstance Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


GetCreateInstanceSupported Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetCreateInstanceSupported Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetProperties Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

[image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetProperties Method (ITypeDescriptorContext, Object, array<Attribute>[]()[])
FRExpandableObjectConverter Class See Also Send Feedback
Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties(
    ITypeDescriptorContext^ context,
    Object^ value,
    array<Attribute^>^ attributes
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
value
Type: System..::.Object
An Object that specifies the type of array for which to get properties.
attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

See Also

FRExpandableObjectConverter Class
GetProperties Overload
FastReport.TypeConverters Namespace


GetPropertiesSupported Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetPropertiesSupported Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


GetPropertiesSupported Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetPropertiesSupported Method (ITypeDescriptorContext)
FRExpandableObjectConverter Class See Also Send Feedback
Returns whether this object supports properties, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
Visual C++
public:
virtual bool GetPropertiesSupported(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.

Return Value

true if GetProperties(Object) should be called to find the properties of this object; otherwise, false.

See Also

FRExpandableObjectConverter Class
GetPropertiesSupported Overload
FastReport.TypeConverters Namespace


GetStandardValues Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetStandardValues Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesExclusive Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetStandardValuesExclusive Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesSupported Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.GetStandardValuesSupported Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


IsValid Method

[image] [image]

FastReport.Net Class Reference
FRExpandableObjectConverter..::.IsValid Method
FRExpandableObjectConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

FRExpandableObjectConverter Class
FRExpandableObjectConverter Members
FastReport.TypeConverters Namespace


UnitsConverter Class

[image]

FastReport.Net Class Reference
UnitsConverter Class
Members See Also Send Feedback
Provides a type converter for a property representing a value measured in the current report units.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class UnitsConverter : TypeConverter
Visual Basic (Declaration)
Public Class UnitsConverter _
    Inherits TypeConverter
Visual C++
public ref class UnitsConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
FastReport.TypeConverters..::.UnitsConverter

See Also

UnitsConverter Members
FastReport.TypeConverters Namespace


UnitsConverter Members

[image] [image]

FastReport.Net Class Reference
UnitsConverter Members
UnitsConverter Class Constructors Methods See Also Send Feedback

The UnitsConverter type exposes the following members.

Constructors

Name | Description
UnitsConverter | Initializes a new instance of the UnitsConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnitsConverter Class
FastReport.TypeConverters Namespace


UnitsConverter Constructor

[image]

FastReport.Net Class Reference
UnitsConverter Constructor
UnitsConverter Class See Also Send Feedback
Initializes a new instance of the UnitsConverter class

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public UnitsConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UnitsConverter()

See Also

UnitsConverter Class
FastReport.TypeConverters Namespace


UnitsConverter Methods

[image] [image]

FastReport.Net Class Reference
UnitsConverter Methods
UnitsConverter Class See Also Send Feedback

The UnitsConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnitsConverter Class
FastReport.TypeConverters Namespace


CanConvertFrom Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.CanConvertFrom Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
UnitsConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
UnitsConverter Class See Also Send Feedback
Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

UnitsConverter Class
CanConvertFrom Overload
FastReport.TypeConverters Namespace


CanConvertTo Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.CanConvertTo Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

FastReport.Net Class Reference
UnitsConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
UnitsConverter Class See Also Send Feedback
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: System..::.Type
A Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

UnitsConverter Class
CanConvertTo Overload
FastReport.TypeConverters Namespace


ConvertFrom Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertFrom Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
UnitsConverter Class See Also Send Feedback
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::.Object
The Object to convert.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.NotSupportedException | The conversion cannot be performed.

See Also

UnitsConverter Class
ConvertFrom Overload
FastReport.TypeConverters Namespace


ConvertFromInvariantString Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertFromInvariantString Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


ConvertFromString Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertFromString Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertTo Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
UnitsConverter Class See Also Send Feedback
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: FastReport.TypeConverters
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

UnitsConverter Class
ConvertTo Overload
FastReport.TypeConverters Namespace


ConvertToInvariantString Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertToInvariantString Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


ConvertToString Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.ConvertToString Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


CreateInstance Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.CreateInstance Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


GetCreateInstanceSupported Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.GetCreateInstanceSupported Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


GetProperties Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.GetProperties Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


GetPropertiesSupported Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.GetPropertiesSupported Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


GetStandardValues Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.GetStandardValues Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesExclusive Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.GetStandardValuesExclusive Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


GetStandardValuesSupported Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.GetStandardValuesSupported Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


IsValid Method

[image] [image]

FastReport.Net Class Reference
UnitsConverter..::.IsValid Method
UnitsConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

UnitsConverter Class
UnitsConverter Members
FastReport.TypeConverters Namespace


FastReport.TypeEditors Namespace

[image]

FastReport.Net Class Reference
FastReport.TypeEditors Namespace
Send Feedback

Classes

Class | Description
AngleEditor | Provides a user interface for editing an angle in degrees.
BandComponentRefEditor | Provides a user interface for selecting a component inside the same band.
BorderEditor | Provides a user interface for editing a component's border.
ColorEditor | Provides a user interface for choosing a color.
DataColumnEditor | Provides a user interface for choosing a data column.
DataTypeEditor | Provides a user interface for choosing a data type.
ExpressionEditor | Provides a user interface for editing an expression.
FillEditor | Provides a user interface for editing a fill.
FlagsEditor | Provides a user interface for editing a flags enumeration.
ItemsEditor | Provides a user interface for editing a string collection.
PageComponentRefEditor | Provides a user interface for selecting a component inside the same page.
ReportComponentRefEditor | Provides a user interface for selecting a component inside the report.


AngleEditor Class

[image]

FastReport.Net Class Reference
AngleEditor Class
Members See Also Send Feedback
Provides a user interface for editing an angle in degrees.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AngleEditor : UITypeEditor
Visual Basic (Declaration)
Public Class AngleEditor _
    Inherits UITypeEditor
Visual C++
public ref class AngleEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.AngleEditor

See Also

AngleEditor Members
FastReport.TypeEditors Namespace


AngleEditor Members

[image] [image]

FastReport.Net Class Reference
AngleEditor Members
AngleEditor Class Constructors Methods Properties See Also Send Feedback

The AngleEditor type exposes the following members.

Constructors

Name | Description
AngleEditor | Initializes a new instance of the AngleEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

AngleEditor Class
FastReport.TypeEditors Namespace


AngleEditor Constructor

[image]

FastReport.Net Class Reference
AngleEditor Constructor
AngleEditor Class See Also Send Feedback
Initializes a new instance of the AngleEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AngleEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AngleEditor()

See Also

AngleEditor Class
FastReport.TypeEditors Namespace


AngleEditor Methods

[image] [image]

FastReport.Net Class Reference
AngleEditor Methods
AngleEditor Class See Also Send Feedback

The AngleEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AngleEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
AngleEditor..::.EditValue Method
AngleEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

AngleEditor Class
AngleEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
AngleEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
AngleEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

AngleEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
AngleEditor..::.GetEditStyle Method
AngleEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

AngleEditor Class
AngleEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
AngleEditor..::.GetEditStyle Method (ITypeDescriptorContext)
AngleEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

AngleEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
AngleEditor..::.GetPaintValueSupported Method
AngleEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

AngleEditor Class
AngleEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
AngleEditor..::.PaintValue Method
AngleEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

AngleEditor Class
AngleEditor Members
FastReport.TypeEditors Namespace


AngleEditor Properties

[image] [image]

FastReport.Net Class Reference
AngleEditor Properties
AngleEditor Class See Also Send Feedback

The AngleEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

AngleEditor Class
FastReport.TypeEditors Namespace


BandComponentRefEditor Class

[image]

FastReport.Net Class Reference
BandComponentRefEditor Class
Members See Also Send Feedback
Provides a user interface for selecting a component inside the same band.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BandComponentRefEditor : UITypeEditor
Visual Basic (Declaration)
Public Class BandComponentRefEditor _
    Inherits UITypeEditor
Visual C++
public ref class BandComponentRefEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.BandComponentRefEditor

See Also

BandComponentRefEditor Members
FastReport.TypeEditors Namespace


BandComponentRefEditor Members

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor Members
BandComponentRefEditor Class Constructors Methods Properties See Also Send Feedback

The BandComponentRefEditor type exposes the following members.

Constructors

Name | Description
BandComponentRefEditor | Initializes a new instance of the BandComponentRefEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

BandComponentRefEditor Class
FastReport.TypeEditors Namespace


BandComponentRefEditor Constructor

[image]

FastReport.Net Class Reference
BandComponentRefEditor Constructor
BandComponentRefEditor Class See Also Send Feedback
Initializes a new instance of the BandComponentRefEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BandComponentRefEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BandComponentRefEditor()

See Also

BandComponentRefEditor Class
FastReport.TypeEditors Namespace


BandComponentRefEditor Methods

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor Methods
BandComponentRefEditor Class See Also Send Feedback

The BandComponentRefEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BandComponentRefEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor..::.EditValue Method
BandComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

BandComponentRefEditor Class
BandComponentRefEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
BandComponentRefEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
BandComponentRefEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

BandComponentRefEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor..::.GetEditStyle Method
BandComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

BandComponentRefEditor Class
BandComponentRefEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
BandComponentRefEditor..::.GetEditStyle Method (ITypeDescriptorContext)
BandComponentRefEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

BandComponentRefEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor..::.GetPaintValueSupported Method
BandComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

BandComponentRefEditor Class
BandComponentRefEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor..::.PaintValue Method
BandComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

BandComponentRefEditor Class
BandComponentRefEditor Members
FastReport.TypeEditors Namespace


BandComponentRefEditor Properties

[image] [image]

FastReport.Net Class Reference
BandComponentRefEditor Properties
BandComponentRefEditor Class See Also Send Feedback

The BandComponentRefEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

BandComponentRefEditor Class
FastReport.TypeEditors Namespace


IsDropDownResizable Property

[image]

FastReport.Net Class Reference
BandComponentRefEditor..::.IsDropDownResizable Property
BandComponentRefEditor Class See Also Send Feedback
Gets a value indicating whether drop-down editors should be resizable by the user.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsDropDownResizable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDropDownResizable As Boolean
Visual C++
public:
virtual property bool IsDropDownResizable {
    bool get () override;
}

Return Value

true if drop-down editors are resizable; otherwise, false.

See Also

BandComponentRefEditor Class
FastReport.TypeEditors Namespace


BorderEditor Class

[image]

FastReport.Net Class Reference
BorderEditor Class
Members See Also Send Feedback
Provides a user interface for editing a component's border.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BorderEditor : UITypeEditor
Visual Basic (Declaration)
Public Class BorderEditor _
    Inherits UITypeEditor
Visual C++
public ref class BorderEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.BorderEditor

See Also

BorderEditor Members
FastReport.TypeEditors Namespace


BorderEditor Members

[image] [image]

FastReport.Net Class Reference
BorderEditor Members
BorderEditor Class Constructors Methods Properties See Also Send Feedback

The BorderEditor type exposes the following members.

Constructors

Name | Description
BorderEditor | Initializes a new instance of the BorderEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

BorderEditor Class
FastReport.TypeEditors Namespace


BorderEditor Constructor

[image]

FastReport.Net Class Reference
BorderEditor Constructor
BorderEditor Class See Also Send Feedback
Initializes a new instance of the BorderEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BorderEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BorderEditor()

See Also

BorderEditor Class
FastReport.TypeEditors Namespace


BorderEditor Methods

[image] [image]

FastReport.Net Class Reference
BorderEditor Methods
BorderEditor Class See Also Send Feedback

The BorderEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BorderEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
BorderEditor..::.EditValue Method
BorderEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

BorderEditor Class
BorderEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
BorderEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
BorderEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

BorderEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
BorderEditor..::.GetEditStyle Method
BorderEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

BorderEditor Class
BorderEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
BorderEditor..::.GetEditStyle Method (ITypeDescriptorContext)
BorderEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

BorderEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
BorderEditor..::.GetPaintValueSupported Method
BorderEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

BorderEditor Class
BorderEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
BorderEditor..::.PaintValue Method
BorderEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

BorderEditor Class
BorderEditor Members
FastReport.TypeEditors Namespace


BorderEditor Properties

[image] [image]

FastReport.Net Class Reference
BorderEditor Properties
BorderEditor Class See Also Send Feedback

The BorderEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

BorderEditor Class
FastReport.TypeEditors Namespace


ColorEditor Class

[image]

FastReport.Net Class Reference
ColorEditor Class
Members See Also Send Feedback
Provides a user interface for choosing a color.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ColorEditor : UITypeEditor
Visual Basic (Declaration)
Public Class ColorEditor _
    Inherits UITypeEditor
Visual C++
public ref class ColorEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.ColorEditor

See Also

ColorEditor Members
FastReport.TypeEditors Namespace


ColorEditor Members

[image] [image]

FastReport.Net Class Reference
ColorEditor Members
ColorEditor Class Constructors Methods Properties See Also Send Feedback

The ColorEditor type exposes the following members.

Constructors

Name | Description
ColorEditor | Initializes a new instance of the ColorEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ColorEditor Class
FastReport.TypeEditors Namespace


ColorEditor Constructor

[image]

FastReport.Net Class Reference
ColorEditor Constructor
ColorEditor Class See Also Send Feedback
Initializes a new instance of the ColorEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ColorEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorEditor()

See Also

ColorEditor Class
FastReport.TypeEditors Namespace


ColorEditor Methods

[image] [image]

FastReport.Net Class Reference
ColorEditor Methods
ColorEditor Class See Also Send Feedback

The ColorEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
ColorEditor..::.EditValue Method
ColorEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

ColorEditor Class
ColorEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
ColorEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
ColorEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

ColorEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
ColorEditor..::.GetEditStyle Method
ColorEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

ColorEditor Class
ColorEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
ColorEditor..::.GetEditStyle Method (ITypeDescriptorContext)
ColorEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

ColorEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
ColorEditor..::.GetPaintValueSupported Method
ColorEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditor..::.GetPaintValueSupported(ITypeDescriptorContext).)

See Also

ColorEditor Class
ColorEditor Members
FastReport.TypeEditors Namespace


GetPaintValueSupported Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
ColorEditor..::.GetPaintValueSupported Method (ITypeDescriptorContext)
ColorEditor Class See Also Send Feedback
Indicates whether the specified context supports painting a representation of an object's value within the specified context.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool GetPaintValueSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetPaintValueSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
Visual C++
public:
virtual bool GetPaintValueSupported(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

true if PaintValue(Object, Graphics, Rectangle) is implemented; otherwise, false.

See Also

ColorEditor Class
GetPaintValueSupported Overload
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
ColorEditor..::.PaintValue Method
ColorEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditor..::.PaintValue(PaintValueEventArgs).)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

ColorEditor Class
ColorEditor Members
FastReport.TypeEditors Namespace


PaintValue Method (PaintValueEventArgs)

[image]

FastReport.Net Class Reference
ColorEditor..::.PaintValue Method (PaintValueEventArgs)
ColorEditor Class See Also Send Feedback
Paints a representation of the value of an object using the specified PaintValueEventArgs.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override void PaintValue(
    PaintValueEventArgs e
)
Visual Basic (Declaration)
Public Overrides Sub PaintValue ( _
    e As PaintValueEventArgs _
)
Visual C++
public:
virtual void PaintValue(
    PaintValueEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Design..::.PaintValueEventArgs
A PaintValueEventArgs that indicates what to paint and where to paint it.

See Also

ColorEditor Class
PaintValue Overload
FastReport.TypeEditors Namespace


ColorEditor Properties

[image] [image]

FastReport.Net Class Reference
ColorEditor Properties
ColorEditor Class See Also Send Feedback

The ColorEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ColorEditor Class
FastReport.TypeEditors Namespace


DataColumnEditor Class

[image]

FastReport.Net Class Reference
DataColumnEditor Class
Members See Also Send Feedback
Provides a user interface for choosing a data column.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataColumnEditor : UITypeEditor
Visual Basic (Declaration)
Public Class DataColumnEditor _
    Inherits UITypeEditor
Visual C++
public ref class DataColumnEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.DataColumnEditor

See Also

DataColumnEditor Members
FastReport.TypeEditors Namespace


DataColumnEditor Members

[image] [image]

FastReport.Net Class Reference
DataColumnEditor Members
DataColumnEditor Class Constructors Methods Properties See Also Send Feedback

The DataColumnEditor type exposes the following members.

Constructors

Name | Description
DataColumnEditor | Initializes a new instance of the DataColumnEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

DataColumnEditor Class
FastReport.TypeEditors Namespace


DataColumnEditor Constructor

[image]

FastReport.Net Class Reference
DataColumnEditor Constructor
DataColumnEditor Class See Also Send Feedback
Initializes a new instance of the DataColumnEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataColumnEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataColumnEditor()

See Also

DataColumnEditor Class
FastReport.TypeEditors Namespace


DataColumnEditor Methods

[image] [image]

FastReport.Net Class Reference
DataColumnEditor Methods
DataColumnEditor Class See Also Send Feedback

The DataColumnEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataColumnEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
DataColumnEditor..::.EditValue Method
DataColumnEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

DataColumnEditor Class
DataColumnEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
DataColumnEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
DataColumnEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

DataColumnEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
DataColumnEditor..::.GetEditStyle Method
DataColumnEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

DataColumnEditor Class
DataColumnEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
DataColumnEditor..::.GetEditStyle Method (ITypeDescriptorContext)
DataColumnEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

DataColumnEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
DataColumnEditor..::.GetPaintValueSupported Method
DataColumnEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

DataColumnEditor Class
DataColumnEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
DataColumnEditor..::.PaintValue Method
DataColumnEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

DataColumnEditor Class
DataColumnEditor Members
FastReport.TypeEditors Namespace


DataColumnEditor Properties

[image] [image]

FastReport.Net Class Reference
DataColumnEditor Properties
DataColumnEditor Class See Also Send Feedback

The DataColumnEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

DataColumnEditor Class
FastReport.TypeEditors Namespace


IsDropDownResizable Property

[image]

FastReport.Net Class Reference
DataColumnEditor..::.IsDropDownResizable Property
DataColumnEditor Class See Also Send Feedback
Gets a value indicating whether drop-down editors should be resizable by the user.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsDropDownResizable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDropDownResizable As Boolean
Visual C++
public:
virtual property bool IsDropDownResizable {
    bool get () override;
}

Return Value

true if drop-down editors are resizable; otherwise, false.

See Also

DataColumnEditor Class
FastReport.TypeEditors Namespace


DataTypeEditor Class

[image]

FastReport.Net Class Reference
DataTypeEditor Class
Members See Also Send Feedback
Provides a user interface for choosing a data type.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataTypeEditor : UITypeEditor
Visual Basic (Declaration)
Public Class DataTypeEditor _
    Inherits UITypeEditor
Visual C++
public ref class DataTypeEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.DataTypeEditor

See Also

DataTypeEditor Members
FastReport.TypeEditors Namespace


DataTypeEditor Members

[image] [image]

FastReport.Net Class Reference
DataTypeEditor Members
DataTypeEditor Class Constructors Methods Properties See Also Send Feedback

The DataTypeEditor type exposes the following members.

Constructors

Name | Description
DataTypeEditor | Initializes a new instance of the DataTypeEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

DataTypeEditor Class
FastReport.TypeEditors Namespace


DataTypeEditor Constructor

[image]

FastReport.Net Class Reference
DataTypeEditor Constructor
DataTypeEditor Class See Also Send Feedback
Initializes a new instance of the DataTypeEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public DataTypeEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataTypeEditor()

See Also

DataTypeEditor Class
FastReport.TypeEditors Namespace


DataTypeEditor Methods

[image] [image]

FastReport.Net Class Reference
DataTypeEditor Methods
DataTypeEditor Class See Also Send Feedback

The DataTypeEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTypeEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
DataTypeEditor..::.EditValue Method
DataTypeEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

DataTypeEditor Class
DataTypeEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
DataTypeEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
DataTypeEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

DataTypeEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
DataTypeEditor..::.GetEditStyle Method
DataTypeEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

DataTypeEditor Class
DataTypeEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
DataTypeEditor..::.GetEditStyle Method (ITypeDescriptorContext)
DataTypeEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

DataTypeEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
DataTypeEditor..::.GetPaintValueSupported Method
DataTypeEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

DataTypeEditor Class
DataTypeEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
DataTypeEditor..::.PaintValue Method
DataTypeEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

DataTypeEditor Class
DataTypeEditor Members
FastReport.TypeEditors Namespace


DataTypeEditor Properties

[image] [image]

FastReport.Net Class Reference
DataTypeEditor Properties
DataTypeEditor Class See Also Send Feedback

The DataTypeEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

DataTypeEditor Class
FastReport.TypeEditors Namespace


ExpressionEditor Class

[image]

FastReport.Net Class Reference
ExpressionEditor Class
Members See Also Send Feedback
Provides a user interface for editing an expression.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ExpressionEditor : UITypeEditor
Visual Basic (Declaration)
Public Class ExpressionEditor _
    Inherits UITypeEditor
Visual C++
public ref class ExpressionEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.ExpressionEditor

See Also

ExpressionEditor Members
FastReport.TypeEditors Namespace


ExpressionEditor Members

[image] [image]

FastReport.Net Class Reference
ExpressionEditor Members
ExpressionEditor Class Constructors Methods Properties See Also Send Feedback

The ExpressionEditor type exposes the following members.

Constructors

Name | Description
ExpressionEditor | Initializes a new instance of the ExpressionEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ExpressionEditor Class
FastReport.TypeEditors Namespace


ExpressionEditor Constructor

[image]

FastReport.Net Class Reference
ExpressionEditor Constructor
ExpressionEditor Class See Also Send Feedback
Initializes a new instance of the ExpressionEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ExpressionEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpressionEditor()

See Also

ExpressionEditor Class
FastReport.TypeEditors Namespace


ExpressionEditor Methods

[image] [image]

FastReport.Net Class Reference
ExpressionEditor Methods
ExpressionEditor Class See Also Send Feedback

The ExpressionEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpressionEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
ExpressionEditor..::.EditValue Method
ExpressionEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

ExpressionEditor Class
ExpressionEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
ExpressionEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
ExpressionEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

ExpressionEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
ExpressionEditor..::.GetEditStyle Method
ExpressionEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

ExpressionEditor Class
ExpressionEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
ExpressionEditor..::.GetEditStyle Method (ITypeDescriptorContext)
ExpressionEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

ExpressionEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
ExpressionEditor..::.GetPaintValueSupported Method
ExpressionEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

ExpressionEditor Class
ExpressionEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
ExpressionEditor..::.PaintValue Method
ExpressionEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

ExpressionEditor Class
ExpressionEditor Members
FastReport.TypeEditors Namespace


ExpressionEditor Properties

[image] [image]

FastReport.Net Class Reference
ExpressionEditor Properties
ExpressionEditor Class See Also Send Feedback

The ExpressionEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ExpressionEditor Class
FastReport.TypeEditors Namespace


FillEditor Class

[image]

FastReport.Net Class Reference
FillEditor Class
Members See Also Send Feedback
Provides a user interface for editing a fill.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FillEditor : UITypeEditor
Visual Basic (Declaration)
Public Class FillEditor _
    Inherits UITypeEditor
Visual C++
public ref class FillEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.FillEditor

See Also

FillEditor Members
FastReport.TypeEditors Namespace


FillEditor Members

[image] [image]

FastReport.Net Class Reference
FillEditor Members
FillEditor Class Constructors Methods Properties See Also Send Feedback

The FillEditor type exposes the following members.

Constructors

Name | Description
FillEditor | Initializes a new instance of the FillEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FillEditor Class
FastReport.TypeEditors Namespace


FillEditor Constructor

[image]

FastReport.Net Class Reference
FillEditor Constructor
FillEditor Class See Also Send Feedback
Initializes a new instance of the FillEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FillEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillEditor()

See Also

FillEditor Class
FastReport.TypeEditors Namespace


FillEditor Methods

[image] [image]

FastReport.Net Class Reference
FillEditor Methods
FillEditor Class See Also Send Feedback

The FillEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
FillEditor..::.EditValue Method
FillEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FillEditor Class
FillEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
FillEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FillEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

FillEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
FillEditor..::.GetEditStyle Method
FillEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

FillEditor Class
FillEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
FillEditor..::.GetEditStyle Method (ITypeDescriptorContext)
FillEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

FillEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
FillEditor..::.GetPaintValueSupported Method
FillEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FillEditor Class
FillEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
FillEditor..::.PaintValue Method
FillEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FillEditor Class
FillEditor Members
FastReport.TypeEditors Namespace


FillEditor Properties

[image] [image]

FastReport.Net Class Reference
FillEditor Properties
FillEditor Class See Also Send Feedback

The FillEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FillEditor Class
FastReport.TypeEditors Namespace


FlagsEditor Class

[image]

FastReport.Net Class Reference
FlagsEditor Class
Members See Also Send Feedback
Provides a user interface for editing a flags enumeration.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FlagsEditor : UITypeEditor
Visual Basic (Declaration)
Public Class FlagsEditor _
    Inherits UITypeEditor
Visual C++
public ref class FlagsEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.FlagsEditor

See Also

FlagsEditor Members
FastReport.TypeEditors Namespace


FlagsEditor Members

[image] [image]

FastReport.Net Class Reference
FlagsEditor Members
FlagsEditor Class Constructors Methods Properties See Also Send Feedback

The FlagsEditor type exposes the following members.

Constructors

Name | Description
FlagsEditor | Initializes a new instance of the FlagsEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FlagsEditor Class
FastReport.TypeEditors Namespace


FlagsEditor Constructor

[image]

FastReport.Net Class Reference
FlagsEditor Constructor
FlagsEditor Class See Also Send Feedback
Initializes a new instance of the FlagsEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FlagsEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FlagsEditor()

See Also

FlagsEditor Class
FastReport.TypeEditors Namespace


FlagsEditor Methods

[image] [image]

FastReport.Net Class Reference
FlagsEditor Methods
FlagsEditor Class See Also Send Feedback

The FlagsEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlagsEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
FlagsEditor..::.EditValue Method
FlagsEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FlagsEditor Class
FlagsEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
FlagsEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FlagsEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

FlagsEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
FlagsEditor..::.GetEditStyle Method
FlagsEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

FlagsEditor Class
FlagsEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
FlagsEditor..::.GetEditStyle Method (ITypeDescriptorContext)
FlagsEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

FlagsEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
FlagsEditor..::.GetPaintValueSupported Method
FlagsEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FlagsEditor Class
FlagsEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
FlagsEditor..::.PaintValue Method
FlagsEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FlagsEditor Class
FlagsEditor Members
FastReport.TypeEditors Namespace


FlagsEditor Properties

[image] [image]

FastReport.Net Class Reference
FlagsEditor Properties
FlagsEditor Class See Also Send Feedback

The FlagsEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FlagsEditor Class
FastReport.TypeEditors Namespace


ItemsEditor Class

[image]

FastReport.Net Class Reference
ItemsEditor Class
Members See Also Send Feedback
Provides a user interface for editing a string collection.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ItemsEditor : UITypeEditor
Visual Basic (Declaration)
Public Class ItemsEditor _
    Inherits UITypeEditor
Visual C++
public ref class ItemsEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.ItemsEditor

See Also

ItemsEditor Members
FastReport.TypeEditors Namespace


ItemsEditor Members

[image] [image]

FastReport.Net Class Reference
ItemsEditor Members
ItemsEditor Class Constructors Methods Properties See Also Send Feedback

The ItemsEditor type exposes the following members.

Constructors

Name | Description
ItemsEditor | Initializes a new instance of the ItemsEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ItemsEditor Class
FastReport.TypeEditors Namespace


ItemsEditor Constructor

[image]

FastReport.Net Class Reference
ItemsEditor Constructor
ItemsEditor Class See Also Send Feedback
Initializes a new instance of the ItemsEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ItemsEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ItemsEditor()

See Also

ItemsEditor Class
FastReport.TypeEditors Namespace


ItemsEditor Methods

[image] [image]

FastReport.Net Class Reference
ItemsEditor Methods
ItemsEditor Class See Also Send Feedback

The ItemsEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemsEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
ItemsEditor..::.EditValue Method
ItemsEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

ItemsEditor Class
ItemsEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
ItemsEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
ItemsEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

ItemsEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
ItemsEditor..::.GetEditStyle Method
ItemsEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

ItemsEditor Class
ItemsEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
ItemsEditor..::.GetEditStyle Method (ITypeDescriptorContext)
ItemsEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

ItemsEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
ItemsEditor..::.GetPaintValueSupported Method
ItemsEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

ItemsEditor Class
ItemsEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
ItemsEditor..::.PaintValue Method
ItemsEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

ItemsEditor Class
ItemsEditor Members
FastReport.TypeEditors Namespace


ItemsEditor Properties

[image] [image]

FastReport.Net Class Reference
ItemsEditor Properties
ItemsEditor Class See Also Send Feedback

The ItemsEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ItemsEditor Class
FastReport.TypeEditors Namespace


PageComponentRefEditor Class

[image]

FastReport.Net Class Reference
PageComponentRefEditor Class
Members See Also Send Feedback
Provides a user interface for selecting a component inside the same page.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class PageComponentRefEditor : UITypeEditor
Visual Basic (Declaration)
Public Class PageComponentRefEditor _
    Inherits UITypeEditor
Visual C++
public ref class PageComponentRefEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.PageComponentRefEditor

See Also

PageComponentRefEditor Members
FastReport.TypeEditors Namespace


PageComponentRefEditor Members

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor Members
PageComponentRefEditor Class Constructors Methods Properties See Also Send Feedback

The PageComponentRefEditor type exposes the following members.

Constructors

Name | Description
PageComponentRefEditor | Initializes a new instance of the PageComponentRefEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

PageComponentRefEditor Class
FastReport.TypeEditors Namespace


PageComponentRefEditor Constructor

[image]

FastReport.Net Class Reference
PageComponentRefEditor Constructor
PageComponentRefEditor Class See Also Send Feedback
Initializes a new instance of the PageComponentRefEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PageComponentRefEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageComponentRefEditor()

See Also

PageComponentRefEditor Class
FastReport.TypeEditors Namespace


PageComponentRefEditor Methods

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor Methods
PageComponentRefEditor Class See Also Send Feedback

The PageComponentRefEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageComponentRefEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor..::.EditValue Method
PageComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

PageComponentRefEditor Class
PageComponentRefEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
PageComponentRefEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
PageComponentRefEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

PageComponentRefEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor..::.GetEditStyle Method
PageComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

PageComponentRefEditor Class
PageComponentRefEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
PageComponentRefEditor..::.GetEditStyle Method (ITypeDescriptorContext)
PageComponentRefEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

PageComponentRefEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor..::.GetPaintValueSupported Method
PageComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

PageComponentRefEditor Class
PageComponentRefEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor..::.PaintValue Method
PageComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

PageComponentRefEditor Class
PageComponentRefEditor Members
FastReport.TypeEditors Namespace


PageComponentRefEditor Properties

[image] [image]

FastReport.Net Class Reference
PageComponentRefEditor Properties
PageComponentRefEditor Class See Also Send Feedback

The PageComponentRefEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

PageComponentRefEditor Class
FastReport.TypeEditors Namespace


IsDropDownResizable Property

[image]

FastReport.Net Class Reference
PageComponentRefEditor..::.IsDropDownResizable Property
PageComponentRefEditor Class See Also Send Feedback
Gets a value indicating whether drop-down editors should be resizable by the user.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsDropDownResizable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDropDownResizable As Boolean
Visual C++
public:
virtual property bool IsDropDownResizable {
    bool get () override;
}

Return Value

true if drop-down editors are resizable; otherwise, false.

See Also

PageComponentRefEditor Class
FastReport.TypeEditors Namespace


ReportComponentRefEditor Class

[image]

FastReport.Net Class Reference
ReportComponentRefEditor Class
Members See Also Send Feedback
Provides a user interface for selecting a component inside the report.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ReportComponentRefEditor : UITypeEditor
Visual Basic (Declaration)
Public Class ReportComponentRefEditor _
    Inherits UITypeEditor
Visual C++
public ref class ReportComponentRefEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
FastReport.TypeEditors..::.ReportComponentRefEditor

See Also

ReportComponentRefEditor Members
FastReport.TypeEditors Namespace


ReportComponentRefEditor Members

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor Members
ReportComponentRefEditor Class Constructors Methods Properties See Also Send Feedback

The ReportComponentRefEditor type exposes the following members.

Constructors

Name | Description
ReportComponentRefEditor | Initializes a new instance of the ReportComponentRefEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

ReportComponentRefEditor Class
FastReport.TypeEditors Namespace


ReportComponentRefEditor Constructor

[image]

FastReport.Net Class Reference
ReportComponentRefEditor Constructor
ReportComponentRefEditor Class See Also Send Feedback
Initializes a new instance of the ReportComponentRefEditor class

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ReportComponentRefEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportComponentRefEditor()

See Also

ReportComponentRefEditor Class
FastReport.TypeEditors Namespace


ReportComponentRefEditor Methods

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor Methods
ReportComponentRefEditor Class See Also Send Feedback

The ReportComponentRefEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportComponentRefEditor Class
FastReport.TypeEditors Namespace


EditValue Method

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.EditValue Method
ReportComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

ReportComponentRefEditor Class
ReportComponentRefEditor Members
FastReport.TypeEditors Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
ReportComponentRefEditor Class See Also Send Feedback
Edits the specified object's value using the editor style indicated by the GetEditStyle()()() method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object Value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    Value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ Value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: System..::.IServiceProvider
An IServiceProvider that this editor can use to obtain services.
Value
Type: System..::.Object

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

See Also

ReportComponentRefEditor Class
EditValue Overload
FastReport.TypeEditors Namespace


GetEditStyle Method

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.GetEditStyle Method
ReportComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

ReportComponentRefEditor Class
ReportComponentRefEditor Members
FastReport.TypeEditors Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.GetEditStyle Method (ITypeDescriptorContext)
ReportComponentRefEditor Class See Also Send Feedback
Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle()()() will return None.

See Also

ReportComponentRefEditor Class
GetEditStyle Overload
FastReport.TypeEditors Namespace


GetPaintValueSupported Method

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.GetPaintValueSupported Method
ReportComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

ReportComponentRefEditor Class
ReportComponentRefEditor Members
FastReport.TypeEditors Namespace


PaintValue Method

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.PaintValue Method
ReportComponentRefEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

ReportComponentRefEditor Class
ReportComponentRefEditor Members
FastReport.TypeEditors Namespace


ReportComponentRefEditor Properties

[image] [image]

FastReport.Net Class Reference
ReportComponentRefEditor Properties
ReportComponentRefEditor Class See Also Send Feedback

The ReportComponentRefEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Overrides UITypeEditor..::.IsDropDownResizable.)

See Also

ReportComponentRefEditor Class
FastReport.TypeEditors Namespace


IsDropDownResizable Property

[image]

FastReport.Net Class Reference
ReportComponentRefEditor..::.IsDropDownResizable Property
ReportComponentRefEditor Class See Also Send Feedback
Gets a value indicating whether drop-down editors should be resizable by the user.

Namespace: FastReport.TypeEditors
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool IsDropDownResizable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDropDownResizable As Boolean
Visual C++
public:
virtual property bool IsDropDownResizable {
    bool get () override;
}

Return Value

true if drop-down editors are resizable; otherwise, false.

See Also

ReportComponentRefEditor Class
FastReport.TypeEditors Namespace


FastReport.Utils Namespace

[image]

FastReport.Net Class Reference
FastReport.Utils Namespace
Send Feedback

Classes

Class | Description
AncestorException | The exception that is thrown when the user tried to rename an object that is introduced in the ancestor report.
AssemblyInitializerBase | Base class for plugin's assembly initializer.
ClassException | The exception that is thrown when trying to load a report file that contains reference to an unknown object type.
CompilerException | The exception that is thrown if there is an error in the report's script code.
Config | Contains some configuration properties and settings that will be applied to the FastReport.Net environment, including Report, Designer and Preview components.
Converter | Contains methods that peform string to object and vice versa conversions.
Crypter | Contains methods used to crypt/decrypt a data.
DataNotInitializedException | The exception that is thrown when trying to access a row of a datasource that is not initialized yet.
DataTableException | The exception that is thrown when initializing a table datasource which TableName or Alias is not set properly.
DecryptException | The exception that is thrown when loading an encrypted report with wrong password.
DuplicateNameException | The exception that is thrown when the user tried to set object's name that is already exists.
Editors | Contains methods to call common editors.
FastNameCreator | The helper class used to create unique component names using the fastest method.
FileFormatException | The exception that is thrown when loading bad formed xml report file.
FloatCollection | Represents a collection of float values.
FRCollectionBase | Represents a collection of FastReport base objects.
FRMouseEventArgs | Provides a data for mouse events.
FRPaintEventArgs | Provides a data for paint event.
FRReader | The reader used to deserialize object's properties from a report file.
FRWriter | The writer used to serialize object's properties to a report file.
MatrixValueException | The exception that is thrown if an error occurs in the MatrixObject.ManualBuild event.
MyRes | Used to access to resource IDs inside the specified branch.
NotValidIdentifierException | The exception that is thrown if an error occurs in the MatrixObject.ManualBuild event.
ObjectInfo | Holds the information about the registered object.
ParentException | The exception that is thrown when trying to set an object's Parent property to an object that not accepts children of this type.
Profiler | The profiler.
RegisteredObjects | Contains all registered report items such as objects, export filters, wizards.
Res | Used to get localized values from the language resource file.
ResourceLoader | Resource loader class.
SelectionPoint | Specifies a selection point used to resize an object.
SRCategory | Localized CategoryAttribute class.
TableManualBuildException | The exception that is thrown if an error occurs in the TableObject.ManualBuild event.
UIStyleUtils | Contains conversion methods between FastReport's UIStyle to various enums.
Units | Defines the constants used to convert between report units and screen pixels.
XmlDocument | Represents a xml document that contains the root xml node.
XmlItem | Represents a xml node.
ZipArchive |

Enumerations

Enumeration | Description
PageUnits | The report page units.
SerializeTo | Specifies the target for the serialize operation.
SizingPoint | Specifies the sizing point used to resize an object by mouse.
UIStyle | The style of FastReport user interface.
WorkspaceMode1 | Specifies the main mode of the designer's workspace.
WorkspaceMode2 | Specifies the additional mode of the designer's workspace.


AncestorException Class

[image]

FastReport.Net Class Reference
AncestorException Class
Members See Also Send Feedback
The exception that is thrown when the user tried to rename an object that is introduced in the ancestor report.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AncestorException : Exception
Visual Basic (Declaration)
Public Class AncestorException _
    Inherits Exception
Visual C++
public ref class AncestorException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.AncestorException

See Also

AncestorException Members
FastReport.Utils Namespace


AncestorException Members

[image] [image]

FastReport.Net Class Reference
AncestorException Members
AncestorException Class Methods Properties See Also Send Feedback

The AncestorException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AncestorException Class
FastReport.Utils Namespace


AncestorException Methods

[image] [image]

FastReport.Net Class Reference
AncestorException Methods
AncestorException Class See Also Send Feedback

The AncestorException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AncestorException Class
FastReport.Utils Namespace


AncestorException Properties

[image] [image]

FastReport.Net Class Reference
AncestorException Properties
AncestorException Class See Also Send Feedback

The AncestorException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AncestorException Class
FastReport.Utils Namespace


AssemblyInitializerBase Class

[image]

FastReport.Net Class Reference
AssemblyInitializerBase Class
Members See Also Send Feedback
Base class for plugin's assembly initializer.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class AssemblyInitializerBase
Visual Basic (Declaration)
Public Class AssemblyInitializerBase
Visual C++
public ref class AssemblyInitializerBase

Remarks

FastReport has an open architecture. That means you can extend it with own classes such as report objects, wizards, export filters. Usually such classes are placed in separate dlls (plugins). FastReport has mechanism to load plugin dlls. You can specify which plugins to load at first start, in the FastReport configuration file (by default it is located in the C:\Documents and Settings\User_Name\Local Settings\Application Data\FastReport\FastReport.config file). To do this, add an xml item with your plugin name inside the <Plugins> item:
CopyC#
<?xml version="1.0" encoding="utf-8"?>
<Config>
  <Plugins>
    <Plugin Name="c:\Program Files\MyProgram\MyPlugin.dll"/>
  </Plugins>
</Config>
 When you run your application and use the Report object first time, all plugins will be loaded. To register objects contained in a plugin, FastReport searches for classes of type AssemblyInitializerBase and instantiates them.

Use this class to register custom report objects, controls, wizards, exports that are contained in the assembly. To do this, make your own class of the AssemblyInitializerBase type and override its default constructor. In the constructor, call RegisteredObjects.Add methods to register all necessary items.

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.AssemblyInitializerBase
FastReport..::.AssemblyInitializer

See Also

AssemblyInitializerBase Members
FastReport.Utils Namespace


AssemblyInitializerBase Members

[image] [image]

FastReport.Net Class Reference
AssemblyInitializerBase Members
AssemblyInitializerBase Class Constructors Methods See Also Send Feedback

The AssemblyInitializerBase type exposes the following members.

Constructors

Name | Description
AssemblyInitializerBase | Registers plugins contained in this assembly.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyInitializerBase Class
FastReport.Utils Namespace


AssemblyInitializerBase Constructor

[image]

FastReport.Net Class Reference
AssemblyInitializerBase Constructor
AssemblyInitializerBase Class Example See Also Send Feedback
Registers plugins contained in this assembly.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public AssemblyInitializerBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssemblyInitializerBase()

Remarks

This constructor is called automatically when the assembly is loaded.

Examples

This example show how to create own assembly initializer to register own items.
CopyC#
public class MyAssemblyInitializer : AssemblyInitializerBase
{
  public MyAssemblyInitializer()
  {
    // register own wizard
    RegisteredObjects.AddWizard(typeof(MyWizard), myWizBmp, "My Wizard", true);
    // register own export filter
    RegisteredObjects.AddExport(typeof(MyExport), "My Export");
    // register own report object
    RegisteredObjects.Add(typeof(MyObject), "ReportPage", myObjBmp, "My Object");
  }
}

See Also

AssemblyInitializerBase Class
FastReport.Utils Namespace


AssemblyInitializerBase Methods

[image] [image]

FastReport.Net Class Reference
AssemblyInitializerBase Methods
AssemblyInitializerBase Class See Also Send Feedback

The AssemblyInitializerBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyInitializerBase Class
FastReport.Utils Namespace


ClassException Class

[image]

FastReport.Net Class Reference
ClassException Class
Members See Also Send Feedback
The exception that is thrown when trying to load a report file that contains reference to an unknown object type.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ClassException : Exception
Visual Basic (Declaration)
Public Class ClassException _
    Inherits Exception
Visual C++
public ref class ClassException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.ClassException

See Also

ClassException Members
FastReport.Utils Namespace


ClassException Members

[image] [image]

FastReport.Net Class Reference
ClassException Members
ClassException Class Methods Properties See Also Send Feedback

The ClassException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ClassException Class
FastReport.Utils Namespace


ClassException Methods

[image] [image]

FastReport.Net Class Reference
ClassException Methods
ClassException Class See Also Send Feedback

The ClassException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ClassException Class
FastReport.Utils Namespace


ClassException Properties

[image] [image]

FastReport.Net Class Reference
ClassException Properties
ClassException Class See Also Send Feedback

The ClassException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ClassException Class
FastReport.Utils Namespace


CompilerException Class

[image]

FastReport.Net Class Reference
CompilerException Class
Members See Also Send Feedback
The exception that is thrown if there is an error in the report's script code.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class CompilerException : Exception
Visual Basic (Declaration)
Public Class CompilerException _
    Inherits Exception
Visual C++
public ref class CompilerException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.CompilerException

See Also

CompilerException Members
FastReport.Utils Namespace


CompilerException Members

[image] [image]

FastReport.Net Class Reference
CompilerException Members
CompilerException Class Methods Properties See Also Send Feedback

The CompilerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CompilerException Class
FastReport.Utils Namespace


CompilerException Methods

[image] [image]

FastReport.Net Class Reference
CompilerException Methods
CompilerException Class See Also Send Feedback

The CompilerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CompilerException Class
FastReport.Utils Namespace


CompilerException Properties

[image] [image]

FastReport.Net Class Reference
CompilerException Properties
CompilerException Class See Also Send Feedback

The CompilerException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CompilerException Class
FastReport.Utils Namespace


Config Class

[image]

FastReport.Net Class Reference
Config Class
Members See Also Send Feedback
Contains some configuration properties and settings that will be applied to the FastReport.Net environment, including Report, Designer and Preview components.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Config
Visual Basic (Declaration)
Public NotInheritable Class Config
Visual C++
public ref class Config abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Config

See Also

Config Members
FastReport.Utils Namespace


Config Members

[image] [image]

FastReport.Net Class Reference
Config Members
Config Class Methods Properties See Also Send Feedback

The Config type exposes the following members.

Methods

Name | Description
RestoreFormState | Restores the form state from the configuration file.
SaveFormState | Saves the form state to the configuration file.

Properties

Name | Description
ApplicationFolder | Gets the application folder.
DesignerSettings | Gets or sets the settings for the report designer window.
EmailSettings | Gets or sets the settings for the "Send Email" window.
Folder | Gets or sets the path used to load/save the configuration file.
FullTrust | Gets a value indicating that the ASP.NET hosting permission level is set to full trust.
PreviewSettings | Gets or sets the settings for the preview window.
ReportSettings | Gets or sets the settings for the Report component.
Root | Gets the root item of config xml.
TempFolder | Gets or sets the path to the temporary folder used to store temporary files.
UIStyle | Gets or sets the UI style.
UseOffice2007Form | Gets or sets a value indicating whether the Office2007-style window should be used instead of standard Form when Office2007 color scheme is selected.
Version | Gets FastReport version.
WebMode | Gets or sets a value that determines whether to disable some functionality to run in web mode.

See Also

Config Class
FastReport.Utils Namespace


Config Methods

[image] [image]

FastReport.Net Class Reference
Config Methods
Config Class See Also Send Feedback

The Config type exposes the following members.

Methods

Name | Description
RestoreFormState | Restores the form state from the configuration file.
SaveFormState | Saves the form state to the configuration file.

See Also

Config Class
FastReport.Utils Namespace


RestoreFormState Method

[image]

FastReport.Net Class Reference
Config..::.RestoreFormState Method
Config Class See Also Send Feedback
Restores the form state from the configuration file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void RestoreFormState(
    Form form
)
Visual Basic (Declaration)
Public Shared Sub RestoreFormState ( _
    form As Form _
)
Visual C++
public:
static void RestoreFormState(
    Form^ form
)

Parameters

form
Type: System.Windows.Forms..::.Form
The form to restore.

See Also

Config Class
FastReport.Utils Namespace


SaveFormState Method

[image]

FastReport.Net Class Reference
Config..::.SaveFormState Method
Config Class See Also Send Feedback
Saves the form state to the configuration file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void SaveFormState(
    Form form
)
Visual Basic (Declaration)
Public Shared Sub SaveFormState ( _
    form As Form _
)
Visual C++
public:
static void SaveFormState(
    Form^ form
)

Parameters

form
Type: System.Windows.Forms..::.Form
The form to save.

See Also

Config Class
FastReport.Utils Namespace


Config Properties

[image] [image]

FastReport.Net Class Reference
Config Properties
Config Class See Also Send Feedback

The Config type exposes the following members.

Properties

Name | Description
ApplicationFolder | Gets the application folder.
DesignerSettings | Gets or sets the settings for the report designer window.
EmailSettings | Gets or sets the settings for the "Send Email" window.
Folder | Gets or sets the path used to load/save the configuration file.
FullTrust | Gets a value indicating that the ASP.NET hosting permission level is set to full trust.
PreviewSettings | Gets or sets the settings for the preview window.
ReportSettings | Gets or sets the settings for the Report component.
Root | Gets the root item of config xml.
TempFolder | Gets or sets the path to the temporary folder used to store temporary files.
UIStyle | Gets or sets the UI style.
UseOffice2007Form | Gets or sets a value indicating whether the Office2007-style window should be used instead of standard Form when Office2007 color scheme is selected.
Version | Gets FastReport version.
WebMode | Gets or sets a value that determines whether to disable some functionality to run in web mode.

See Also

Config Class
FastReport.Utils Namespace


ApplicationFolder Property

[image]

FastReport.Net Class Reference
Config..::.ApplicationFolder Property
Config Class See Also Send Feedback
Gets the application folder.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ApplicationFolder { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ApplicationFolder As String
Visual C++
public:
static property String^ ApplicationFolder {
    String^ get ();
}

See Also

Config Class
FastReport.Utils Namespace


DesignerSettings Property

[image]

FastReport.Net Class Reference
Config..::.DesignerSettings Property
Config Class See Also Send Feedback
Gets or sets the settings for the report designer window.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static DesignerSettings DesignerSettings { get; set; }
Visual Basic (Declaration)
Public Shared Property DesignerSettings As DesignerSettings
Visual C++
public:
static property DesignerSettings^ DesignerSettings {
    DesignerSettings^ get ();
    void set (DesignerSettings^ value);
}

See Also

Config Class
FastReport.Utils Namespace


EmailSettings Property

[image]

FastReport.Net Class Reference
Config..::.EmailSettings Property
Config Class See Also Send Feedback
Gets or sets the settings for the "Send Email" window.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static EmailSettings EmailSettings { get; set; }
Visual Basic (Declaration)
Public Shared Property EmailSettings As EmailSettings
Visual C++
public:
static property EmailSettings^ EmailSettings {
    EmailSettings^ get ();
    void set (EmailSettings^ value);
}

See Also

Config Class
FastReport.Utils Namespace


Folder Property

[image]

FastReport.Net Class Reference
Config..::.Folder Property
Config Class See Also Send Feedback
Gets or sets the path used to load/save the configuration file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Folder { get; set; }
Visual Basic (Declaration)
Public Shared Property Folder As String
Visual C++
public:
static property String^ Folder {
    String^ get ();
    void set (String^ value);
}

Remarks

By default, the configuration file is saved to the application local data folder (C:\Documents and Settings\User_Name\Local Settings\Application Data\FastReport\). Set this property to "" if you want to store the configuration file in the application folder.

See Also

Config Class
FastReport.Utils Namespace


FullTrust Property

[image]

FastReport.Net Class Reference
Config..::.FullTrust Property
Config Class See Also Send Feedback
Gets a value indicating that the ASP.NET hosting permission level is set to full trust.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool FullTrust { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FullTrust As Boolean
Visual C++
public:
static property bool FullTrust {
    bool get ();
}

See Also

Config Class
FastReport.Utils Namespace


PreviewSettings Property

[image]

FastReport.Net Class Reference
Config..::.PreviewSettings Property
Config Class See Also Send Feedback
Gets or sets the settings for the preview window.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static PreviewSettings PreviewSettings { get; set; }
Visual Basic (Declaration)
Public Shared Property PreviewSettings As PreviewSettings
Visual C++
public:
static property PreviewSettings^ PreviewSettings {
    PreviewSettings^ get ();
    void set (PreviewSettings^ value);
}

See Also

Config Class
FastReport.Utils Namespace


ReportSettings Property

[image]

FastReport.Net Class Reference
Config..::.ReportSettings Property
Config Class See Also Send Feedback
Gets or sets the settings for the Report component.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ReportSettings ReportSettings { get; set; }
Visual Basic (Declaration)
Public Shared Property ReportSettings As ReportSettings
Visual C++
public:
static property ReportSettings^ ReportSettings {
    ReportSettings^ get ();
    void set (ReportSettings^ value);
}

See Also

Config Class
FastReport.Utils Namespace


Root Property

[image]

FastReport.Net Class Reference
Config..::.Root Property
Config Class See Also Send Feedback
Gets the root item of config xml.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static XmlItem Root { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Root As XmlItem
Visual C++
public:
static property XmlItem^ Root {
    XmlItem^ get ();
}

See Also

Config Class
FastReport.Utils Namespace


TempFolder Property

[image]

FastReport.Net Class Reference
Config..::.TempFolder Property
Config Class See Also Send Feedback
Gets or sets the path to the temporary folder used to store temporary files.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string TempFolder { get; set; }
Visual Basic (Declaration)
Public Shared Property TempFolder As String
Visual C++
public:
static property String^ TempFolder {
    String^ get ();
    void set (String^ value);
}

Remarks

The default value is null, so the system temp folder will be used.

See Also

Config Class
FastReport.Utils Namespace


UIStyle Property

[image]

FastReport.Net Class Reference
Config..::.UIStyle Property
Config Class See Also Send Feedback
Gets or sets the UI style.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static UIStyle UIStyle { get; set; }
Visual Basic (Declaration)
Public Shared Property UIStyle As UIStyle
Visual C++
public:
static property UIStyle UIStyle {
    UIStyle get ();
    void set (UIStyle value);
}

Remarks

This property affects both designer and preview windows.

See Also

Config Class
FastReport.Utils Namespace


UseOffice2007Form Property

[image]

FastReport.Net Class Reference
Config..::.UseOffice2007Form Property
Config Class See Also Send Feedback
Gets or sets a value indicating whether the Office2007-style window should be used instead of standard Form when Office2007 color scheme is selected.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool UseOffice2007Form { get; set; }
Visual Basic (Declaration)
Public Shared Property UseOffice2007Form As Boolean
Visual C++
public:
static property bool UseOffice2007Form {
    bool get ();
    void set (bool value);
}

See Also

Config Class
FastReport.Utils Namespace


Version Property

[image]

FastReport.Net Class Reference
Config..::.Version Property
Config Class See Also Send Feedback
Gets FastReport version.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Version { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Version As String
Visual C++
public:
static property String^ Version {
    String^ get ();
}

See Also

Config Class
FastReport.Utils Namespace


WebMode Property

[image]

FastReport.Net Class Reference
Config..::.WebMode Property
Config Class See Also Send Feedback
Gets or sets a value that determines whether to disable some functionality to run in web mode.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool WebMode { get; set; }
Visual Basic (Declaration)
Public Shared Property WebMode As Boolean
Visual C++
public:
static property bool WebMode {
    bool get ();
    void set (bool value);
}

Remarks

Use this property if you use FastReport in ASP.Net. Set this property to truebefore you access any FastReport.Net objects.

See Also

Config Class
FastReport.Utils Namespace


Converter Class

[image]

FastReport.Net Class Reference
Converter Class
Members See Also Send Feedback
Contains methods that peform string to object and vice versa conversions.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Converter
Visual Basic (Declaration)
Public NotInheritable Class Converter
Visual C++
public ref class Converter abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Converter

See Also

Converter Members
FastReport.Utils Namespace


Converter Members

[image] [image]

FastReport.Net Class Reference
Converter Members
Converter Class Methods See Also Send Feedback

The Converter type exposes the following members.

Methods

Name | Description
ConvertNull | Converts null value to 0, false, empty string, depending on type.
DecreasePrecision | Decreases the precision of floating-point value.
FromString | Overloaded.
FromXml | Convert the xml-compatible string to the regular one.
IListToString | Converts a collection of strings to a string.
StringToByteArray | Converts string value to byte[].
StringToFloat | Overloaded.
StringToIList | Converts the string containing several text lines to a collection of strings.
StringToNameValueCollection | Converts a string to NameValueCollection.
ToString | Overloaded.
ToXml | Overloaded.

See Also

Converter Class
FastReport.Utils Namespace


Converter Methods

[image] [image]

FastReport.Net Class Reference
Converter Methods
Converter Class See Also Send Feedback

The Converter type exposes the following members.

Methods

Name | Description
ConvertNull | Converts null value to 0, false, empty string, depending on type.
DecreasePrecision | Decreases the precision of floating-point value.
FromString | Overloaded.
FromXml | Convert the xml-compatible string to the regular one.
IListToString | Converts a collection of strings to a string.
StringToByteArray | Converts string value to byte[].
StringToFloat | Overloaded.
StringToIList | Converts the string containing several text lines to a collection of strings.
StringToNameValueCollection | Converts a string to NameValueCollection.
ToString | Overloaded.
ToXml | Overloaded.

See Also

Converter Class
FastReport.Utils Namespace


ConvertNull Method

[image]

FastReport.Net Class Reference
Converter..::.ConvertNull Method
Converter Class See Also Send Feedback
Converts null value to 0, false, empty string, depending on type.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Object ConvertNull(
    Type type
)
Visual Basic (Declaration)
Public Shared Function ConvertNull ( _
    type As Type _
) As Object
Visual C++
public:
static Object^ ConvertNull(
    Type^ type
)

Parameters

type
Type: System..::.Type
The data type.

Return Value

The value of the type data type.

See Also

Converter Class
FastReport.Utils Namespace


DecreasePrecision Method

[image]

FastReport.Net Class Reference
Converter..::.DecreasePrecision Method
Converter Class See Also Send Feedback
Decreases the precision of floating-point value.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float DecreasePrecision(
    float value,
    int precision
)
Visual Basic (Declaration)
Public Shared Function DecreasePrecision ( _
    value As Single, _
    precision As Integer _
) As Single
Visual C++
public:
static float DecreasePrecision(
    float value,
    int precision
)

Parameters

value
Type: System..::.Single
The initial value.
precision
Type: System..::.Int32
The number of decimal digits in the fraction.

Return Value

The value with lesser precision.

See Also

Converter Class
FastReport.Utils Namespace


FromString Method

[image] [image]

FastReport.Net Class Reference
Converter..::.FromString Method
Converter Class See Also Send Feedback

Overload List

Name | Description
FromString(String, Type) | Converts a string to an object using the specified converter.
FromString(Type, String) | Converts a string value to the specified data type.

See Also

Converter Class
Converter Members
FastReport.Utils Namespace


FromString Method (String, Type)

[image]

FastReport.Net Class Reference
Converter..::.FromString Method (String, Type)
Converter Class See Also Send Feedback
Converts a string to an object using the specified converter.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Object FromString(
    string value,
    Type converterType
)
Visual Basic (Declaration)
Public Shared Function FromString ( _
    value As String, _
    converterType As Type _
) As Object
Visual C++
public:
static Object^ FromString(
    String^ value,
    Type^ converterType
)

Parameters

value
Type: System..::.String
The string to convert.
converterType
Type: System..::.Type
The type of converter.

Return Value

The object that contains the converted value.

See Also

Converter Class
FromString Overload
FastReport.Utils Namespace


FromString Method (Type, String)

[image]

FastReport.Net Class Reference
Converter..::.FromString Method (Type, String)
Converter Class See Also Send Feedback
Converts a string value to the specified data type.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Object FromString(
    Type type,
    string value
)
Visual Basic (Declaration)
Public Shared Function FromString ( _
    type As Type, _
    value As String _
) As Object
Visual C++
public:
static Object^ FromString(
    Type^ type,
    String^ value
)

Parameters

type
Type: System..::.Type
The data type to convert to.
value
Type: System..::.String
The string to convert from.

Return Value

The object of type specified in the type parameter that contains a converted value.

See Also

Converter Class
FromString Overload
FastReport.Utils Namespace


FromXml Method

[image]

FastReport.Net Class Reference
Converter..::.FromXml Method
Converter Class See Also Send Feedback
Convert the xml-compatible string to the regular one.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string FromXml(
    string s
)
Visual Basic (Declaration)
Public Shared Function FromXml ( _
    s As String _
) As String
Visual C++
public:
static String^ FromXml(
    String^ s
)

Parameters

s
Type: System..::.String
The string to convert.

Return Value

The result string.

Remarks

This is counterpart to the ToXml(String) method.

See Also

Converter Class
FastReport.Utils Namespace


IListToString Method

[image]

FastReport.Net Class Reference
Converter..::.IListToString Method
Converter Class See Also Send Feedback
Converts a collection of strings to a string.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string IListToString(
    IList list
)
Visual Basic (Declaration)
Public Shared Function IListToString ( _
    list As IList _
) As String
Visual C++
public:
static String^ IListToString(
    IList^ list
)

Parameters

list
Type: System.Collections..::.IList
The collection to convert.

Return Value

The string that contains all lines from the collection.

See Also

Converter Class
FastReport.Utils Namespace


StringToByteArray Method

[image]

FastReport.Net Class Reference
Converter..::.StringToByteArray Method
Converter Class See Also Send Feedback
Converts string value to byte[].

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static byte[] StringToByteArray(
    string Str
)
Visual Basic (Declaration)
Public Shared Function StringToByteArray ( _
    Str As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ StringToByteArray(
    String^ Str
)

Parameters

Str
Type: System..::.String
The string to convert

Return Value

The value of the byte[] data type.

See Also

Converter Class
FastReport.Utils Namespace


StringToFloat Method

[image] [image]

FastReport.Net Class Reference
Converter..::.StringToFloat Method
Converter Class See Also Send Feedback

Overload List

Name | Description
StringToFloat(String) | Converts a string value to the float.
StringToFloat(String, Boolean) | Converts a string value to the float.

See Also

Converter Class
Converter Members
FastReport.Utils Namespace


StringToFloat Method (String)

[image]

FastReport.Net Class Reference
Converter..::.StringToFloat Method (String)
Converter Class See Also Send Feedback
Converts a string value to the float.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float StringToFloat(
    string value
)
Visual Basic (Declaration)
Public Shared Function StringToFloat ( _
    value As String _
) As Single
Visual C++
public:
static float StringToFloat(
    String^ value
)

Parameters

value
Type: System..::.String
The string value to convert.

Return Value

The float value.

Remarks

Both "." or "," decimal separators are allowed.

See Also

Converter Class
StringToFloat Overload
FastReport.Utils Namespace


StringToFloat Method (String, Boolean)

[image]

FastReport.Net Class Reference
Converter..::.StringToFloat Method (String, Boolean)
Converter Class See Also Send Feedback
Converts a string value to the float.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float StringToFloat(
    string value,
    bool removeNonDigit
)
Visual Basic (Declaration)
Public Shared Function StringToFloat ( _
    value As String, _
    removeNonDigit As Boolean _
) As Single
Visual C++
public:
static float StringToFloat(
    String^ value,
    bool removeNonDigit
)

Parameters

value
Type: System..::.String
The string value to convert.
removeNonDigit
Type: System..::.Boolean
Indicates whether to ignore non-digit symbols.

Return Value

The float value.

See Also

Converter Class
StringToFloat Overload
FastReport.Utils Namespace


StringToIList Method

[image]

FastReport.Net Class Reference
Converter..::.StringToIList Method
Converter Class See Also Send Feedback
Converts the string containing several text lines to a collection of strings.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void StringToIList(
    string text,
    IList list
)
Visual Basic (Declaration)
Public Shared Sub StringToIList ( _
    text As String, _
    list As IList _
)
Visual C++
public:
static void StringToIList(
    String^ text,
    IList^ list
)

Parameters

text
Type: System..::.String
The string to convert.
list
Type: System.Collections..::.IList
The collection instance.

See Also

Converter Class
FastReport.Utils Namespace


StringToNameValueCollection Method

[image]

FastReport.Net Class Reference
Converter..::.StringToNameValueCollection Method
Converter Class See Also Send Feedback
Converts a string to NameValueCollection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static NameValueCollection StringToNameValueCollection(
    string text
)
Visual Basic (Declaration)
Public Shared Function StringToNameValueCollection ( _
    text As String _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ StringToNameValueCollection(
    String^ text
)

Parameters

text
Type: System..::.String
The string to convert.

Return Value

The NameValueCollection that contains the name/value pairs.

See Also

Converter Class
FastReport.Utils Namespace


ToString Method

[image] [image]

FastReport.Net Class Reference
Converter..::.ToString Method
Converter Class See Also Send Feedback

Overload List

Name | Description
ToString(Object) | Converts an object to a string.
ToString(Object, Type) | Converts a value to a string using the specified converter.

See Also

Converter Class
Converter Members
FastReport.Utils Namespace


ToString Method (Object)

[image]

FastReport.Net Class Reference
Converter..::.ToString Method (Object)
Converter Class See Also Send Feedback
Converts an object to a string.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToString(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToString ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToString(
    Object^ value
)

Parameters

value
Type: System..::.Object
The object to convert.

Return Value

The string that contains the converted value.

See Also

Converter Class
ToString Overload
FastReport.Utils Namespace


ToString Method (Object, Type)

[image]

FastReport.Net Class Reference
Converter..::.ToString Method (Object, Type)
Converter Class See Also Send Feedback
Converts a value to a string using the specified converter.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToString(
    Object value,
    Type converterType
)
Visual Basic (Declaration)
Public Shared Function ToString ( _
    value As Object, _
    converterType As Type _
) As String
Visual C++
public:
static String^ ToString(
    Object^ value,
    Type^ converterType
)

Parameters

value
Type: System..::.Object
The object to convert.
converterType
Type: System..::.Type
The type of converter.

Return Value

The string that contains the converted value.

See Also

Converter Class
ToString Overload
FastReport.Utils Namespace


ToXml Method

[image] [image]

FastReport.Net Class Reference
Converter..::.ToXml Method
Converter Class See Also Send Feedback

Overload List

Name | Description
ToXml(Object) | Converts a value to xml-compatible string.
ToXml(String) | Converts a string containing special symbols to the xml-compatible string.
ToXml(String, Boolean) | Converts a string containing special symbols to the xml-compatible string.

See Also

Converter Class
Converter Members
FastReport.Utils Namespace


ToXml Method (Object)

[image]

FastReport.Net Class Reference
Converter..::.ToXml Method (Object)
Converter Class See Also Send Feedback
Converts a value to xml-compatible string.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToXml(
    Object value
)
Visual Basic (Declaration)
Public Shared Function ToXml ( _
    value As Object _
) As String
Visual C++
public:
static String^ ToXml(
    Object^ value
)

Parameters

value
Type: System..::.Object
The value to convert.

Return Value

The result string.

See Also

Converter Class
ToXml Overload
FastReport.Utils Namespace


ToXml Method (String)

[image]

FastReport.Net Class Reference
Converter..::.ToXml Method (String)
Converter Class See Also Send Feedback
Converts a string containing special symbols to the xml-compatible string.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToXml(
    string s
)
Visual Basic (Declaration)
Public Shared Function ToXml ( _
    s As String _
) As String
Visual C++
public:
static String^ ToXml(
    String^ s
)

Parameters

s
Type: System..::.String
The string to convert.

Return Value

The result string.

Remarks

This method replaces some special symbols like <, > into xml-compatible form: &lt;, &gt;. To convert such string back to original form, use the FromXml(String) method.

See Also

Converter Class
ToXml Overload
FastReport.Utils Namespace


ToXml Method (String, Boolean)

[image]

FastReport.Net Class Reference
Converter..::.ToXml Method (String, Boolean)
Converter Class See Also Send Feedback
Converts a string containing special symbols to the xml-compatible string.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string ToXml(
    string s,
    bool convertCrlf
)
Visual Basic (Declaration)
Public Shared Function ToXml ( _
    s As String, _
    convertCrlf As Boolean _
) As String
Visual C++
public:
static String^ ToXml(
    String^ s,
    bool convertCrlf
)

Parameters

s
Type: System..::.String
The string to convert.
convertCrlf
Type: System..::.Boolean
Determines whether it is necessary to convert cr-lf symbols to xml form.

Return Value

The result string.

See Also

Converter Class
ToXml Overload
FastReport.Utils Namespace


Crypter Class

[image]

FastReport.Net Class Reference
Crypter Class
Members See Also Send Feedback
Contains methods used to crypt/decrypt a data.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Crypter
Visual Basic (Declaration)
Public NotInheritable Class Crypter
Visual C++
public ref class Crypter abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Crypter

See Also

Crypter Members
FastReport.Utils Namespace


Crypter Members

[image] [image]

FastReport.Net Class Reference
Crypter Members
Crypter Class Methods Properties See Also Send Feedback

The Crypter type exposes the following members.

Methods

Name | Description
Decrypt | Decrypts a stream using specified password.
DecryptString | Overloaded.
Encrypt | Crypts a stream using specified password.
EncryptString | Overloaded.
IsStreamEncrypted | Checks if the stream contains a crypt signature.

Properties

Name | Description
DefaultPassword | Sets the password that is used to crypt connection strings stored in a report.

See Also

Crypter Class
FastReport.Utils Namespace


Crypter Methods

[image] [image]

FastReport.Net Class Reference
Crypter Methods
Crypter Class See Also Send Feedback

The Crypter type exposes the following members.

Methods

Name | Description
Decrypt | Decrypts a stream using specified password.
DecryptString | Overloaded.
Encrypt | Crypts a stream using specified password.
EncryptString | Overloaded.
IsStreamEncrypted | Checks if the stream contains a crypt signature.

See Also

Crypter Class
FastReport.Utils Namespace


Decrypt Method

[image]

FastReport.Net Class Reference
Crypter..::.Decrypt Method
Crypter Class See Also Send Feedback
Decrypts a stream using specified password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Stream Decrypt(
    Stream source,
    string password
)
Visual Basic (Declaration)
Public Shared Function Decrypt ( _
    source As Stream, _
    password As String _
) As Stream
Visual C++
public:
static Stream^ Decrypt(
    Stream^ source,
    String^ password
)

Parameters

source
Type: System.IO..::.Stream
Stream that contains crypted data.
password
Type: System..::.String
The password.

Return Value

The stream that contains decrypted data.

Remarks

You should read from the stream that this method returns.

See Also

Crypter Class
FastReport.Utils Namespace


DecryptString Method

[image] [image]

FastReport.Net Class Reference
Crypter..::.DecryptString Method
Crypter Class See Also Send Feedback

Overload List

Name | Description
DecryptString(String) | Decrypts the string using the default password.
DecryptString(String, String) | Decrypts the string using specified password.

See Also

Crypter Class
Crypter Members
FastReport.Utils Namespace


DecryptString Method (String)

[image]

FastReport.Net Class Reference
Crypter..::.DecryptString Method (String)
Crypter Class See Also Send Feedback
Decrypts the string using the default password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string DecryptString(
    string data
)
Visual Basic (Declaration)
Public Shared Function DecryptString ( _
    data As String _
) As String
Visual C++
public:
static String^ DecryptString(
    String^ data
)

Parameters

data
Type: System..::.String
String to decrypt.

Return Value

The decrypted string.

Remarks

The password used to decrypt a string can be set via DefaultPassword property. You also may use the DecryptString(String, String) method if you want to specify another password.

See Also

Crypter Class
DecryptString Overload
FastReport.Utils Namespace


DecryptString Method (String, String)

[image]

FastReport.Net Class Reference
Crypter..::.DecryptString Method (String, String)
Crypter Class See Also Send Feedback
Decrypts the string using specified password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string DecryptString(
    string data,
    string password
)
Visual Basic (Declaration)
Public Shared Function DecryptString ( _
    data As String, _
    password As String _
) As String
Visual C++
public:
static String^ DecryptString(
    String^ data,
    String^ password
)

Parameters

data
Type: System..::.String
String to decrypt.
password
Type: System..::.String
The password.

Return Value

The decrypted string.

See Also

Crypter Class
DecryptString Overload
FastReport.Utils Namespace


Encrypt Method

[image]

FastReport.Net Class Reference
Crypter..::.Encrypt Method
Crypter Class See Also Send Feedback
Crypts a stream using specified password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Stream Encrypt(
    Stream dest,
    string password
)
Visual Basic (Declaration)
Public Shared Function Encrypt ( _
    dest As Stream, _
    password As String _
) As Stream
Visual C++
public:
static Stream^ Encrypt(
    Stream^ dest,
    String^ password
)

Parameters

dest
Type: System.IO..::.Stream
The destination stream that will receive the crypted data.
password
Type: System..::.String
The password.

Return Value

The stream that you need to write to.

Remarks

Pass the stream you need to write to, to the dest parameter. Write your data to the stream that this method returns. When you close this stream, the dest stream will be closed too and contains the crypted data.

See Also

Crypter Class
FastReport.Utils Namespace


EncryptString Method

[image] [image]

FastReport.Net Class Reference
Crypter..::.EncryptString Method
Crypter Class See Also Send Feedback

Overload List

Name | Description
EncryptString(String) | Encrypts the string using the default password.
EncryptString(String, String) | Encrypts the string using specified password.

See Also

Crypter Class
Crypter Members
FastReport.Utils Namespace


EncryptString Method (String)

[image]

FastReport.Net Class Reference
Crypter..::.EncryptString Method (String)
Crypter Class See Also Send Feedback
Encrypts the string using the default password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string EncryptString(
    string data
)
Visual Basic (Declaration)
Public Shared Function EncryptString ( _
    data As String _
) As String
Visual C++
public:
static String^ EncryptString(
    String^ data
)

Parameters

data
Type: System..::.String
String to encrypt.

Return Value

The encrypted string.

Remarks

The password used to encrypt a string can be set via DefaultPassword property. You also may use the EncryptString(String, String) method if you want to specify another password.

See Also

Crypter Class
EncryptString Overload
FastReport.Utils Namespace


EncryptString Method (String, String)

[image]

FastReport.Net Class Reference
Crypter..::.EncryptString Method (String, String)
Crypter Class See Also Send Feedback
Encrypts the string using specified password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string EncryptString(
    string data,
    string password
)
Visual Basic (Declaration)
Public Shared Function EncryptString ( _
    data As String, _
    password As String _
) As String
Visual C++
public:
static String^ EncryptString(
    String^ data,
    String^ password
)

Parameters

data
Type: System..::.String
String to encrypt.
password
Type: System..::.String
The password.

Return Value

The encrypted string.

See Also

Crypter Class
EncryptString Overload
FastReport.Utils Namespace


IsStreamEncrypted Method

[image]

FastReport.Net Class Reference
Crypter..::.IsStreamEncrypted Method
Crypter Class See Also Send Feedback
Checks if the stream contains a crypt signature.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool IsStreamEncrypted(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function IsStreamEncrypted ( _
    stream As Stream _
) As Boolean
Visual C++
public:
static bool IsStreamEncrypted(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to check.

Return Value

true if stream is crypted.

See Also

Crypter Class
FastReport.Utils Namespace


Crypter Properties

[image] [image]

FastReport.Net Class Reference
Crypter Properties
Crypter Class See Also Send Feedback

The Crypter type exposes the following members.

Properties

Name | Description
DefaultPassword | Sets the password that is used to crypt connection strings stored in a report.

See Also

Crypter Class
FastReport.Utils Namespace


DefaultPassword Property

[image]

FastReport.Net Class Reference
Crypter..::.DefaultPassword Property
Crypter Class See Also Send Feedback
Sets the password that is used to crypt connection strings stored in a report.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string DefaultPassword { set; }
Visual Basic (Declaration)
Public Shared WriteOnly Property DefaultPassword As String
Visual C++
public:
static property String^ DefaultPassword {
    void set (String^ value);
}

Remarks

See the ConnectionString property for more details.

See Also

Crypter Class
FastReport.Utils Namespace


DataNotInitializedException Class

[image]

FastReport.Net Class Reference
DataNotInitializedException Class
Members See Also Send Feedback
The exception that is thrown when trying to access a row of a datasource that is not initialized yet.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataNotInitializedException : Exception
Visual Basic (Declaration)
Public Class DataNotInitializedException _
    Inherits Exception
Visual C++
public ref class DataNotInitializedException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.DataNotInitializedException

See Also

DataNotInitializedException Members
FastReport.Utils Namespace


DataNotInitializedException Members

[image] [image]

FastReport.Net Class Reference
DataNotInitializedException Members
DataNotInitializedException Class Methods Properties See Also Send Feedback

The DataNotInitializedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataNotInitializedException Class
FastReport.Utils Namespace


DataNotInitializedException Methods

[image] [image]

FastReport.Net Class Reference
DataNotInitializedException Methods
DataNotInitializedException Class See Also Send Feedback

The DataNotInitializedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataNotInitializedException Class
FastReport.Utils Namespace


DataNotInitializedException Properties

[image] [image]

FastReport.Net Class Reference
DataNotInitializedException Properties
DataNotInitializedException Class See Also Send Feedback

The DataNotInitializedException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataNotInitializedException Class
FastReport.Utils Namespace


DataTableException Class

[image]

FastReport.Net Class Reference
DataTableException Class
Members See Also Send Feedback
The exception that is thrown when initializing a table datasource which TableName or Alias is not set properly.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DataTableException : Exception
Visual Basic (Declaration)
Public Class DataTableException _
    Inherits Exception
Visual C++
public ref class DataTableException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.DataTableException

See Also

DataTableException Members
FastReport.Utils Namespace


DataTableException Members

[image] [image]

FastReport.Net Class Reference
DataTableException Members
DataTableException Class Methods Properties See Also Send Feedback

The DataTableException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataTableException Class
FastReport.Utils Namespace


DataTableException Methods

[image] [image]

FastReport.Net Class Reference
DataTableException Methods
DataTableException Class See Also Send Feedback

The DataTableException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataTableException Class
FastReport.Utils Namespace


DataTableException Properties

[image] [image]

FastReport.Net Class Reference
DataTableException Properties
DataTableException Class See Also Send Feedback

The DataTableException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataTableException Class
FastReport.Utils Namespace


DecryptException Class

[image]

FastReport.Net Class Reference
DecryptException Class
Members See Also Send Feedback
The exception that is thrown when loading an encrypted report with wrong password.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DecryptException : Exception
Visual Basic (Declaration)
Public Class DecryptException _
    Inherits Exception
Visual C++
public ref class DecryptException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.DecryptException

See Also

DecryptException Members
FastReport.Utils Namespace


DecryptException Members

[image] [image]

FastReport.Net Class Reference
DecryptException Members
DecryptException Class Methods Properties See Also Send Feedback

The DecryptException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DecryptException Class
FastReport.Utils Namespace


DecryptException Methods

[image] [image]

FastReport.Net Class Reference
DecryptException Methods
DecryptException Class See Also Send Feedback

The DecryptException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DecryptException Class
FastReport.Utils Namespace


DecryptException Properties

[image] [image]

FastReport.Net Class Reference
DecryptException Properties
DecryptException Class See Also Send Feedback

The DecryptException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DecryptException Class
FastReport.Utils Namespace


DuplicateNameException Class

[image]

FastReport.Net Class Reference
DuplicateNameException Class
Members See Also Send Feedback
The exception that is thrown when the user tried to set object's name that is already exists.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class DuplicateNameException : Exception
Visual Basic (Declaration)
Public Class DuplicateNameException _
    Inherits Exception
Visual C++
public ref class DuplicateNameException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.DuplicateNameException

See Also

DuplicateNameException Members
FastReport.Utils Namespace


DuplicateNameException Members

[image] [image]

FastReport.Net Class Reference
DuplicateNameException Members
DuplicateNameException Class Methods Properties See Also Send Feedback

The DuplicateNameException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateNameException Class
FastReport.Utils Namespace


DuplicateNameException Methods

[image] [image]

FastReport.Net Class Reference
DuplicateNameException Methods
DuplicateNameException Class See Also Send Feedback

The DuplicateNameException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateNameException Class
FastReport.Utils Namespace


DuplicateNameException Properties

[image] [image]

FastReport.Net Class Reference
DuplicateNameException Properties
DuplicateNameException Class See Also Send Feedback

The DuplicateNameException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateNameException Class
FastReport.Utils Namespace


Editors Class

[image]

FastReport.Net Class Reference
Editors Class
Members See Also Send Feedback
Contains methods to call common editors.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Editors
Visual Basic (Declaration)
Public NotInheritable Class Editors
Visual C++
public ref class Editors abstract sealed

Remarks

Use this class if you are writing a new component for FastReport.

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Editors

See Also

Editors Members
FastReport.Utils Namespace


Editors Members

[image] [image]

FastReport.Net Class Reference
Editors Members
Editors Class Methods See Also Send Feedback

The Editors type exposes the following members.

Methods

Name | Description
EditBorder | Invokes the border editor.
EditExpression | Invokes the expression editor.
EditFill | Invokes the fill editor.

See Also

Editors Class
FastReport.Utils Namespace


Editors Methods

[image] [image]

FastReport.Net Class Reference
Editors Methods
Editors Class See Also Send Feedback

The Editors type exposes the following members.

Methods

Name | Description
EditBorder | Invokes the border editor.
EditExpression | Invokes the expression editor.
EditFill | Invokes the fill editor.

See Also

Editors Class
FastReport.Utils Namespace


EditBorder Method

[image]

FastReport.Net Class Reference
Editors..::.EditBorder Method
Editors Class See Also Send Feedback
Invokes the border editor.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Border EditBorder(
    Border border
)
Visual Basic (Declaration)
Public Shared Function EditBorder ( _
    border As Border _
) As Border
Visual C++
public:
static Border^ EditBorder(
    Border^ border
)

Parameters

border
Type: FastReport..::.Border
The Border to edit.

Return Value

The new border.

See Also

Editors Class
FastReport.Utils Namespace


EditExpression Method

[image]

FastReport.Net Class Reference
Editors..::.EditExpression Method
Editors Class See Also Send Feedback
Invokes the expression editor.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string EditExpression(
    Report report,
    string expression
)
Visual Basic (Declaration)
Public Shared Function EditExpression ( _
    report As Report, _
    expression As String _
) As String
Visual C++
public:
static String^ EditExpression(
    Report^ report,
    String^ expression
)

Parameters

report
Type: FastReport..::.Report
A reference to the report.
expression
Type: System..::.String
The expression to edit.

Return Value

The new expression.

See Also

Editors Class
FastReport.Utils Namespace


EditFill Method

[image]

FastReport.Net Class Reference
Editors..::.EditFill Method
Editors Class See Also Send Feedback
Invokes the fill editor.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static FillBase EditFill(
    FillBase fill
)
Visual Basic (Declaration)
Public Shared Function EditFill ( _
    fill As FillBase _
) As FillBase
Visual C++
public:
static FillBase^ EditFill(
    FillBase^ fill
)

Parameters

fill
Type: FastReport..::.FillBase
The fill to edit.

Return Value

The new fill.

See Also

Editors Class
FastReport.Utils Namespace


FastNameCreator Class

[image]

FastReport.Net Class Reference
FastNameCreator Class
Members Example See Also Send Feedback
The helper class used to create unique component names using the fastest method.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FastNameCreator
Visual Basic (Declaration)
Public Class FastNameCreator
Visual C++
public ref class FastNameCreator

Remarks

Note: you can create unique component's name using its CreateUniqueName method. However, it is very slow and can't be used in some situations (when you create a report layout in a code and have a lot of objects on a page).

Examples

This example demonstrates how to use this class.
CopyC#
FastNameCreator nameCreator = new FastNameCreator(Report.AllObjects);
foreach (Base c in Report.AllObjects)
{
  if (c.Name == "")
    nameCreator.CreateUniqueName(c);
}

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.FastNameCreator

See Also

FastNameCreator Members
FastReport.Utils Namespace


FastNameCreator Members

[image] [image]

FastReport.Net Class Reference
FastNameCreator Members
FastNameCreator Class Constructors Methods See Also Send Feedback

The FastNameCreator type exposes the following members.

Constructors

Name | Description
FastNameCreator | Initializes a new instance of the FastNameCreator class with collection of existing report objects.

Methods

Name | Description
CreateUniqueName | Creates the unique name for the given object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FastNameCreator Class
FastReport.Utils Namespace


FastNameCreator Constructor

[image]

FastReport.Net Class Reference
FastNameCreator Constructor
FastNameCreator Class See Also Send Feedback
Initializes a new instance of the FastNameCreator class with collection of existing report objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FastNameCreator(
    ObjectCollection objects
)
Visual Basic (Declaration)
Public Sub New ( _
    objects As ObjectCollection _
)
Visual C++
public:
FastNameCreator(
    ObjectCollection^ objects
)

Parameters

objects
Type: FastReport..::.ObjectCollection
The collection of existing report objects.

See Also

FastNameCreator Class
FastReport.Utils Namespace


FastNameCreator Methods

[image] [image]

FastReport.Net Class Reference
FastNameCreator Methods
FastNameCreator Class See Also Send Feedback

The FastNameCreator type exposes the following members.

Methods

Name | Description
CreateUniqueName | Creates the unique name for the given object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FastNameCreator Class
FastReport.Utils Namespace


CreateUniqueName Method

[image]

FastReport.Net Class Reference
FastNameCreator..::.CreateUniqueName Method
FastNameCreator Class See Also Send Feedback
Creates the unique name for the given object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CreateUniqueName(
    Base obj
)
Visual Basic (Declaration)
Public Sub CreateUniqueName ( _
    obj As Base _
)
Visual C++
public:
void CreateUniqueName(
    Base^ obj
)

Parameters

obj
Type: FastReport..::.Base
The object to create name for.

See Also

FastNameCreator Class
FastReport.Utils Namespace


FileFormatException Class

[image]

FastReport.Net Class Reference
FileFormatException Class
Members See Also Send Feedback
The exception that is thrown when loading bad formed xml report file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FileFormatException : Exception
Visual Basic (Declaration)
Public Class FileFormatException _
    Inherits Exception
Visual C++
public ref class FileFormatException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.FileFormatException

See Also

FileFormatException Members
FastReport.Utils Namespace


FileFormatException Members

[image] [image]

FastReport.Net Class Reference
FileFormatException Members
FileFormatException Class Methods Properties See Also Send Feedback

The FileFormatException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileFormatException Class
FastReport.Utils Namespace


FileFormatException Methods

[image] [image]

FastReport.Net Class Reference
FileFormatException Methods
FileFormatException Class See Also Send Feedback

The FileFormatException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileFormatException Class
FastReport.Utils Namespace


FileFormatException Properties

[image] [image]

FastReport.Net Class Reference
FileFormatException Properties
FileFormatException Class See Also Send Feedback

The FileFormatException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileFormatException Class
FastReport.Utils Namespace


FloatCollection Class

[image]

FastReport.Net Class Reference
FloatCollection Class
Members See Also Send Feedback
Represents a collection of float values.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FloatCollection : CollectionBase
Visual Basic (Declaration)
Public Class FloatCollection _
    Inherits CollectionBase
Visual C++
public ref class FloatCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FloatCollection

See Also

FloatCollection Members
FastReport.Utils Namespace


FloatCollection Members

[image] [image]

FastReport.Net Class Reference
FloatCollection Members
FloatCollection Class Constructors Methods Properties See Also Send Feedback

The FloatCollection type exposes the following members.

Constructors

Name | Description
FloatCollection | Initializes a new instance of the FloatCollection class

Methods

Name | Description
Add | Adds a value to the end of this collection.
AddRange | Adds the specified values to the end of this collection.
Assign | Copies values from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a value is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of a value.
Insert | Inserts a value into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified value from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the value at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FloatCollection Class
FastReport.Utils Namespace


FloatCollection Constructor

[image]

FastReport.Net Class Reference
FloatCollection Constructor
FloatCollection Class See Also Send Feedback
Initializes a new instance of the FloatCollection class

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FloatCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloatCollection()

See Also

FloatCollection Class
FastReport.Utils Namespace


FloatCollection Methods

[image] [image]

FastReport.Net Class Reference
FloatCollection Methods
FloatCollection Class See Also Send Feedback

The FloatCollection type exposes the following members.

Methods

Name | Description
Add | Adds a value to the end of this collection.
AddRange | Adds the specified values to the end of this collection.
Assign | Copies values from another collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a value is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of a value.
Insert | Inserts a value into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified value from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloatCollection Class
FastReport.Utils Namespace


Add Method

[image]

FastReport.Net Class Reference
FloatCollection..::.Add Method
FloatCollection Class See Also Send Feedback
Adds a value to the end of this collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    float value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Single _
) As Integer
Visual C++
public:
int Add(
    float value
)

Parameters

value
Type: System..::.Single
Value to add.

Return Value

Index of the added value.

See Also

FloatCollection Class
FastReport.Utils Namespace


AddRange Method

[image]

FastReport.Net Class Reference
FloatCollection..::.AddRange Method
FloatCollection Class See Also Send Feedback
Adds the specified values to the end of this collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    float[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As Single() _
)
Visual C++
public:
void AddRange(
    array<float>^ range
)

Parameters

range
Type: array< System..::.Single >[]()[]

See Also

FloatCollection Class
FastReport.Utils Namespace


Assign Method

[image]

FastReport.Net Class Reference
FloatCollection..::.Assign Method
FloatCollection Class See Also Send Feedback
Copies values from another collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Assign(
    FloatCollection source
)
Visual Basic (Declaration)
Public Sub Assign ( _
    source As FloatCollection _
)
Visual C++
public:
void Assign(
    FloatCollection^ source
)

Parameters

source
Type: FastReport.Utils..::.FloatCollection
Collection to copy from.

See Also

FloatCollection Class
FastReport.Utils Namespace


Contains Method

[image]

FastReport.Net Class Reference
FloatCollection..::.Contains Method
FloatCollection Class See Also Send Feedback
Determines whether a value is in the collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    float value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Single _
) As Boolean
Visual C++
public:
bool Contains(
    float value
)

Parameters

value
Type: System..::.Single
The value to locate in the collection.

Return Value

true if value is found in the collection; otherwise, false.

See Also

FloatCollection Class
FastReport.Utils Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
FloatCollection..::.IndexOf Method
FloatCollection Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    float value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Single _
) As Integer
Visual C++
public:
int IndexOf(
    float value
)

Parameters

value
Type: System..::.Single
The value to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

FloatCollection Class
FastReport.Utils Namespace


Insert Method

[image]

FastReport.Net Class Reference
FloatCollection..::.Insert Method
FloatCollection Class See Also Send Feedback
Inserts a value into this collection at the specified index.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    float value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Single _
)
Visual C++
public:
void Insert(
    int index,
    float value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: System..::.Single
The value to insert.

See Also

FloatCollection Class
FastReport.Utils Namespace


Remove Method

[image]

FastReport.Net Class Reference
FloatCollection..::.Remove Method
FloatCollection Class See Also Send Feedback
Removes the specified value from the collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    float value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Single _
)
Visual C++
public:
void Remove(
    float value
)

Parameters

value
Type: System..::.Single
Value to remove.

See Also

FloatCollection Class
FastReport.Utils Namespace


FloatCollection Properties

[image] [image]

FastReport.Net Class Reference
FloatCollection Properties
FloatCollection Class See Also Send Feedback

The FloatCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the value at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FloatCollection Class
FastReport.Utils Namespace


Item Property

[image]

FastReport.Net Class Reference
FloatCollection..::.Item Property
FloatCollection Class See Also Send Feedback
Gets or sets the value at the specified index.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Single
Visual C++
public:
property float default[int index] {
    float get (int index);
    void set (int index, float value);
}

Parameters

index
Type: System..::.Int32
Index of a value.

Return Value

The value at the specified index.

See Also

FloatCollection Class
FastReport.Utils Namespace


FRCollectionBase Class

[image]

FastReport.Net Class Reference
FRCollectionBase Class
Members See Also Send Feedback
Represents a collection of FastReport base objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FRCollectionBase : CollectionBase
Visual Basic (Declaration)
Public Class FRCollectionBase _
    Inherits CollectionBase
Visual C++
public ref class FRCollectionBase : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
FastReport.Utils..::.FRCollectionBase
FastReport..::.BandCollection
FastReport.Data..::.ColumnCollection
FastReport.Data..::.CommandParameterCollection
FastReport.Data..::.ConnectionCollection
FastReport.Data..::.DataSourceCollection
FastReport.Data..::.ParameterCollection
FastReport.Data..::.RelationCollection
FastReport.Data..::.TableCollection
FastReport.Data..::.TotalCollection
FastReport.Dialog..::.DialogComponentCollection
FastReport.Dialog..::.GridControlColumnCollection
FastReport.Map..::.LayerCollection
FastReport.Map..::.ShapeCollection
FastReport.MSChart..::.SeriesCollection
FastReport..::.ObjectCollection
FastReport..::.PageCollection
FastReport..::.ReportComponentCollection
FastReport.Table..::.TableColumnCollection
FastReport.Table..::.TableRowCollection

See Also

FRCollectionBase Members
FastReport.Utils Namespace


FRCollectionBase Members

[image] [image]

FastReport.Net Class Reference
FRCollectionBase Members
FRCollectionBase Class Constructors Methods Properties See Also Send Feedback

The FRCollectionBase type exposes the following members.

Constructors

Name | Description
FRCollectionBase | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
CopyTo | Copies the content to another collection.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Overrides CollectionBase..::.OnClear()()().)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


FRCollectionBase Constructor

[image] [image]

FastReport.Net Class Reference
FRCollectionBase Constructor
FRCollectionBase Class See Also Send Feedback

Overload List

Name | Description
FRCollectionBase()()() | Initializes a new instance of the FRCollectionBase class with default settings.
FRCollectionBase(Base) | Initializes a new instance of the FRCollectionBase class with specified owner.

See Also

FRCollectionBase Class
FRCollectionBase Members
FastReport.Utils Namespace


FRCollectionBase Constructor

[image]

FastReport.Net Class Reference
FRCollectionBase Constructor
FRCollectionBase Class See Also Send Feedback
Initializes a new instance of the FRCollectionBase class with default settings.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRCollectionBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FRCollectionBase()

See Also

FRCollectionBase Class
FRCollectionBase Overload
FastReport.Utils Namespace


FRCollectionBase Constructor (Base)

[image]

FastReport.Net Class Reference
FRCollectionBase Constructor (Base)
FRCollectionBase Class See Also Send Feedback
Initializes a new instance of the FRCollectionBase class with specified owner.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRCollectionBase(
    Base owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As Base _
)
Visual C++
public:
FRCollectionBase(
    Base^ owner
)

Parameters

owner
Type: FastReport..::.Base
The owner of this collection.

See Also

FRCollectionBase Class
FRCollectionBase Overload
FastReport.Utils Namespace


FRCollectionBase Methods

[image] [image]

FastReport.Net Class Reference
FRCollectionBase Methods
FRCollectionBase Class See Also Send Feedback

The FRCollectionBase type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of this collection.
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
CopyTo | Copies the content to another collection.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the zero-based index of the first occurrence of an object.
Insert | Inserts an object into this collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Overrides CollectionBase..::.OnClear()()().)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified object from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToArray | Returns an array of collection items.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FRCollectionBase Class
FastReport.Utils Namespace


Add Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.Add Method
FRCollectionBase Class See Also Send Feedback
Adds an object to the end of this collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Add(
    Base value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Base _
) As Integer
Visual C++
public:
int Add(
    Base^ value
)

Parameters

value
Type: FastReport..::.Base
Object to add.

Return Value

Index of the added object.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


AddRange Method

[image] [image]

FastReport.Net Class Reference
FRCollectionBase..::.AddRange Method
FRCollectionBase Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Base>[]()[]) | Adds the specified elements to the end of this collection.
AddRange(ObjectCollection) | Adds the specified elements to the end of this collection.

See Also

FRCollectionBase Class
FRCollectionBase Members
FastReport.Utils Namespace


AddRange Method (Base[])

[image]

FastReport.Net Class Reference
FRCollectionBase..::.AddRange Method (array<Base>[]()[])
FRCollectionBase Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    Base[] range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As Base() _
)
Visual C++
public:
void AddRange(
    array<Base^>^ range
)

Parameters

range
Type: array< FastReport..::.Base >[]()[]
Range of elements.

See Also

FRCollectionBase Class
AddRange Overload
FastReport.Utils Namespace


AddRange Method (ObjectCollection)

[image]

FastReport.Net Class Reference
FRCollectionBase..::.AddRange Method (ObjectCollection)
FRCollectionBase Class See Also Send Feedback
Adds the specified elements to the end of this collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddRange(
    ObjectCollection range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As ObjectCollection _
)
Visual C++
public:
void AddRange(
    ObjectCollection^ range
)

Parameters

range
Type: FastReport..::.ObjectCollection
Collection of elements.

See Also

FRCollectionBase Class
AddRange Overload
FastReport.Utils Namespace


Contains Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.Contains Method
FRCollectionBase Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Contains(
    Base value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Base _
) As Boolean
Visual C++
public:
bool Contains(
    Base^ value
)

Parameters

value
Type: FastReport..::.Base
The object to locate in the collection.

Return Value

true if object is found in the collection; otherwise, false.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


CopyTo Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.CopyTo Method
FRCollectionBase Class See Also Send Feedback
Copies the content to another collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void CopyTo(
    FRCollectionBase list
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    list As FRCollectionBase _
)
Visual C++
public:
void CopyTo(
    FRCollectionBase^ list
)

Parameters

list
Type: FastReport.Utils..::.FRCollectionBase
The collection to copy to.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


Equals Method

[image] [image]

FastReport.Net Class Reference
FRCollectionBase..::.Equals Method
FRCollectionBase Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(FRCollectionBase) | Determines whether two collections are equal.

See Also

FRCollectionBase Class
FRCollectionBase Members
FastReport.Utils Namespace


Equals Method (FRCollectionBase)

[image]

FastReport.Net Class Reference
FRCollectionBase..::.Equals Method (FRCollectionBase)
FRCollectionBase Class See Also Send Feedback
Determines whether two collections are equal.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Equals(
    FRCollectionBase list
)
Visual Basic (Declaration)
Public Function Equals ( _
    list As FRCollectionBase _
) As Boolean
Visual C++
public:
bool Equals(
    FRCollectionBase^ list
)

Parameters

list
Type: FastReport.Utils..::.FRCollectionBase
The collection to compare with.

Return Value

true if collections are equal; false otherwise.

See Also

FRCollectionBase Class
Equals Overload
FastReport.Utils Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.IndexOf Method
FRCollectionBase Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    Base value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Base _
) As Integer
Visual C++
public:
int IndexOf(
    Base^ value
)

Parameters

value
Type: FastReport..::.Base
The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


Insert Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.Insert Method
FRCollectionBase Class See Also Send Feedback
Inserts an object into this collection at the specified index.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Insert(
    int index,
    Base value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Base _
)
Visual C++
public:
void Insert(
    int index,
    Base^ value
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
value
Type: FastReport..::.Base
The object to insert.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


OnClear Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.OnClear Method
FRCollectionBase Class See Also Send Feedback
Performs additional custom processes when clearing the contents of the CollectionBase instance.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnClear()
Visual Basic (Declaration)
Protected Overrides Sub OnClear
Visual C++
protected:
virtual void OnClear() override

See Also

FRCollectionBase Class
FastReport.Utils Namespace


OnInsert Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.OnInsert Method
FRCollectionBase Class See Also Send Feedback
Performs additional custom processes before inserting a new element into the CollectionBase instance.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which to insert value.
value
Type: System..::.Object
The new value of the element at index.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


OnRemove Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.OnRemove Method
FRCollectionBase Class See Also Send Feedback
Performs additional custom processes when removing an element from the CollectionBase instance.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
The zero-based index at which value can be found.
value
Type: System..::.Object
The value of the element to remove from index.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


Remove Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.Remove Method
FRCollectionBase Class See Also Send Feedback
Removes the specified object from the collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Remove(
    Base value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Base _
)
Visual C++
public:
void Remove(
    Base^ value
)

Parameters

value
Type: FastReport..::.Base
Object to remove.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


ToArray Method

[image]

FastReport.Net Class Reference
FRCollectionBase..::.ToArray Method
FRCollectionBase Class See Also Send Feedback
Returns an array of collection items.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As Object()
Visual C++
public:
array<Object^>^ ToArray()

Return Value

See Also

FRCollectionBase Class
FastReport.Utils Namespace


FRCollectionBase Properties

[image] [image]

FastReport.Net Class Reference
FRCollectionBase Properties
FRCollectionBase Class See Also Send Feedback

The FRCollectionBase type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Owner | Gets an owner of this collection.

See Also

FRCollectionBase Class
FastReport.Utils Namespace


Owner Property

[image]

FastReport.Net Class Reference
FRCollectionBase..::.Owner Property
FRCollectionBase Class See Also Send Feedback
Gets an owner of this collection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Base Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Base
Visual C++
public:
property Base^ Owner {
    Base^ get ();
}

See Also

FRCollectionBase Class
FastReport.Utils Namespace


FRMouseEventArgs Class

[image]

FastReport.Net Class Reference
FRMouseEventArgs Class
Members See Also Send Feedback
Provides a data for mouse events.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FRMouseEventArgs
Visual Basic (Declaration)
Public Class FRMouseEventArgs
Visual C++
public ref class FRMouseEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.FRMouseEventArgs

See Also

FRMouseEventArgs Members
FastReport.Utils Namespace


FRMouseEventArgs Members

[image] [image]

FastReport.Net Class Reference
FRMouseEventArgs Members
FRMouseEventArgs Class Constructors Methods Fields See Also Send Feedback

The FRMouseEventArgs type exposes the following members.

Constructors

Name | Description
FRMouseEventArgs | Initializes a new instance of the FRMouseEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ActiveObject | Active object that handles the mouse event.
Button | Current state of mouse buttons.
Cursor | Current cursor shape.
Data | Additional data supplied and handled by report objects.
Delta | The delta of the mouse movement.
DragMessage | The message to show when drag source is over the object.
DragSource | The source object of drag-drop operation.
DragTarget | The target object of drag-drop operation.
Handled | Indicates that current object was handled the mouse message.
Mode | Additional mode of the designer's workspace.
ModifierKeys | Current keyboard state.
SelectionRect | Current selection rectangle if mode is set to SelectionRect.
SizingPoint | Current sizing point if Mode is set to Size.
WheelDelta | The mouse wheel delta.
X | The X mouse coordinate.
Y | The Y mouse coordinate.

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


FRMouseEventArgs Constructor

[image]

FastReport.Net Class Reference
FRMouseEventArgs Constructor
FRMouseEventArgs Class See Also Send Feedback
Initializes a new instance of the FRMouseEventArgs class

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRMouseEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FRMouseEventArgs()

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


FRMouseEventArgs Fields

[image] [image]

FastReport.Net Class Reference
FRMouseEventArgs Fields
FRMouseEventArgs Class See Also Send Feedback

The FRMouseEventArgs type exposes the following members.

Fields

Name | Description
ActiveObject | Active object that handles the mouse event.
Button | Current state of mouse buttons.
Cursor | Current cursor shape.
Data | Additional data supplied and handled by report objects.
Delta | The delta of the mouse movement.
DragMessage | The message to show when drag source is over the object.
DragSource | The source object of drag-drop operation.
DragTarget | The target object of drag-drop operation.
Handled | Indicates that current object was handled the mouse message.
Mode | Additional mode of the designer's workspace.
ModifierKeys | Current keyboard state.
SelectionRect | Current selection rectangle if mode is set to SelectionRect.
SizingPoint | Current sizing point if Mode is set to Size.
WheelDelta | The mouse wheel delta.
X | The X mouse coordinate.
Y | The Y mouse coordinate.

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


ActiveObject Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.ActiveObject Field
FRMouseEventArgs Class See Also Send Feedback
Active object that handles the mouse event.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentBase ActiveObject
Visual Basic (Declaration)
Public ActiveObject As ComponentBase
Visual C++
public:
ComponentBase^ ActiveObject

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Button Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Button Field
FRMouseEventArgs Class See Also Send Feedback
Current state of mouse buttons.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MouseButtons Button
Visual Basic (Declaration)
Public Button As MouseButtons
Visual C++
public:
MouseButtons Button

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Cursor Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Cursor Field
FRMouseEventArgs Class See Also Send Feedback
Current cursor shape.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Cursor Cursor
Visual Basic (Declaration)
Public Cursor As Cursor
Visual C++
public:
Cursor^ Cursor

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Data Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Data Field
FRMouseEventArgs Class See Also Send Feedback
Additional data supplied and handled by report objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object Data
Visual Basic (Declaration)
Public Data As Object
Visual C++
public:
Object^ Data

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Delta Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Delta Field
FRMouseEventArgs Class See Also Send Feedback
The delta of the mouse movement.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public PointF Delta
Visual Basic (Declaration)
Public Delta As PointF
Visual C++
public:
PointF Delta

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


DragMessage Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.DragMessage Field
FRMouseEventArgs Class See Also Send Feedback
The message to show when drag source is over the object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string DragMessage
Visual Basic (Declaration)
Public DragMessage As String
Visual C++
public:
String^ DragMessage

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


DragSource Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.DragSource Field
FRMouseEventArgs Class See Also Send Feedback
The source object of drag-drop operation.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentBase DragSource
Visual Basic (Declaration)
Public DragSource As ComponentBase
Visual C++
public:
ComponentBase^ DragSource

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


DragTarget Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.DragTarget Field
FRMouseEventArgs Class See Also Send Feedback
The target object of drag-drop operation.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ComponentBase DragTarget
Visual Basic (Declaration)
Public DragTarget As ComponentBase
Visual C++
public:
ComponentBase^ DragTarget

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Handled Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Handled Field
FRMouseEventArgs Class See Also Send Feedback
Indicates that current object was handled the mouse message.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Handled
Visual Basic (Declaration)
Public Handled As Boolean
Visual C++
public:
bool Handled

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Mode Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Mode Field
FRMouseEventArgs Class See Also Send Feedback
Additional mode of the designer's workspace.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public WorkspaceMode2 Mode
Visual Basic (Declaration)
Public Mode As WorkspaceMode2
Visual C++
public:
WorkspaceMode2 Mode

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


ModifierKeys Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.ModifierKeys Field
FRMouseEventArgs Class See Also Send Feedback
Current keyboard state.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Keys ModifierKeys
Visual Basic (Declaration)
Public ModifierKeys As Keys
Visual C++
public:
Keys ModifierKeys

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


SelectionRect Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.SelectionRect Field
FRMouseEventArgs Class See Also Send Feedback
Current selection rectangle if mode is set to SelectionRect.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public RectangleF SelectionRect
Visual Basic (Declaration)
Public SelectionRect As RectangleF
Visual C++
public:
RectangleF SelectionRect

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


SizingPoint Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.SizingPoint Field
FRMouseEventArgs Class See Also Send Feedback
Current sizing point if Mode is set to Size.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizingPoint SizingPoint
Visual Basic (Declaration)
Public SizingPoint As SizingPoint
Visual C++
public:
SizingPoint SizingPoint

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


WheelDelta Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.WheelDelta Field
FRMouseEventArgs Class See Also Send Feedback
The mouse wheel delta.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int WheelDelta
Visual Basic (Declaration)
Public WheelDelta As Integer
Visual C++
public:
int WheelDelta

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


X Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.X Field
FRMouseEventArgs Class See Also Send Feedback
The X mouse coordinate.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float X
Visual Basic (Declaration)
Public X As Single
Visual C++
public:
float X

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


Y Field

[image]

FastReport.Net Class Reference
FRMouseEventArgs..::.Y Field
FRMouseEventArgs Class See Also Send Feedback
The Y mouse coordinate.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Y
Visual Basic (Declaration)
Public Y As Single
Visual C++
public:
float Y

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


FRMouseEventArgs Methods

[image] [image]

FastReport.Net Class Reference
FRMouseEventArgs Methods
FRMouseEventArgs Class See Also Send Feedback

The FRMouseEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FRMouseEventArgs Class
FastReport.Utils Namespace


FRPaintEventArgs Class

[image]

FastReport.Net Class Reference
FRPaintEventArgs Class
Members See Also Send Feedback
Provides a data for paint event.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FRPaintEventArgs
Visual Basic (Declaration)
Public Class FRPaintEventArgs
Visual C++
public ref class FRPaintEventArgs

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.FRPaintEventArgs

See Also

FRPaintEventArgs Members
FastReport.Utils Namespace


FRPaintEventArgs Members

[image] [image]

FastReport.Net Class Reference
FRPaintEventArgs Members
FRPaintEventArgs Class Constructors Methods Properties See Also Send Feedback

The FRPaintEventArgs type exposes the following members.

Constructors

Name | Description
FRPaintEventArgs | Initializes a new instance of the FRPaintEventArgs class with specified settings.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cache | Gets the cache that contains graphics objects.
Graphics | Gets a Graphics object to draw on.
ScaleX | Gets the X scale factor.
ScaleY | Gets the Y scale factor.

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


FRPaintEventArgs Constructor

[image]

FastReport.Net Class Reference
FRPaintEventArgs Constructor
FRPaintEventArgs Class See Also Send Feedback
Initializes a new instance of the FRPaintEventArgs class with specified settings.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRPaintEventArgs(
    Graphics g,
    float scaleX,
    float scaleY,
    GraphicCache cache
)
Visual Basic (Declaration)
Public Sub New ( _
    g As Graphics, _
    scaleX As Single, _
    scaleY As Single, _
    cache As GraphicCache _
)
Visual C++
public:
FRPaintEventArgs(
    Graphics^ g,
    float scaleX,
    float scaleY,
    GraphicCache^ cache
)

Parameters

g
Type: System.Drawing..::.Graphics
Graphics object to draw on.
scaleX
Type: System..::.Single
X scale factor.
scaleY
Type: System..::.Single
Y scale factor.
cache
Type: FastReport..::.GraphicCache
Cache that contains graphics objects.

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


FRPaintEventArgs Methods

[image] [image]

FastReport.Net Class Reference
FRPaintEventArgs Methods
FRPaintEventArgs Class See Also Send Feedback

The FRPaintEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


FRPaintEventArgs Properties

[image] [image]

FastReport.Net Class Reference
FRPaintEventArgs Properties
FRPaintEventArgs Class See Also Send Feedback

The FRPaintEventArgs type exposes the following members.

Properties

Name | Description
Cache | Gets the cache that contains graphics objects.
Graphics | Gets a Graphics object to draw on.
ScaleX | Gets the X scale factor.
ScaleY | Gets the Y scale factor.

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


Cache Property

[image]

FastReport.Net Class Reference
FRPaintEventArgs..::.Cache Property
FRPaintEventArgs Class See Also Send Feedback
Gets the cache that contains graphics objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public GraphicCache Cache { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cache As GraphicCache
Visual C++
public:
property GraphicCache^ Cache {
    GraphicCache^ get ();
}

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


Graphics Property

[image]

FastReport.Net Class Reference
FRPaintEventArgs..::.Graphics Property
FRPaintEventArgs Class See Also Send Feedback
Gets a Graphics object to draw on.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Graphics Graphics { get; }
Visual Basic (Declaration)
Public ReadOnly Property Graphics As Graphics
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


ScaleX Property

[image]

FastReport.Net Class Reference
FRPaintEventArgs..::.ScaleX Property
FRPaintEventArgs Class See Also Send Feedback
Gets the X scale factor.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ScaleX { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScaleX As Single
Visual C++
public:
property float ScaleX {
    float get ();
}

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


ScaleY Property

[image]

FastReport.Net Class Reference
FRPaintEventArgs..::.ScaleY Property
FRPaintEventArgs Class See Also Send Feedback
Gets the Y scale factor.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ScaleY { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScaleY As Single
Visual C++
public:
property float ScaleY {
    float get ();
}

See Also

FRPaintEventArgs Class
FastReport.Utils Namespace


FRReader Class

[image]

FastReport.Net Class Reference
FRReader Class
Members See Also Send Feedback
The reader used to deserialize object's properties from a report file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FRReader : IDisposable
Visual Basic (Declaration)
Public Class FRReader _
    Implements IDisposable
Visual C++
public ref class FRReader : IDisposable

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.FRReader

See Also

FRReader Members
FastReport.Utils Namespace


FRReader Members

[image] [image]

FastReport.Net Class Reference
FRReader Members
FRReader Class Constructors Methods Properties See Also Send Feedback

The FRReader type exposes the following members.

Constructors

Name | Description
FRReader | Overloaded.

Methods

Name | Description
Dispose | Disposes the reader, fixups the property references.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasProperty | Checks if current item has specified property.
Load | Loads the xml items from a stream.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextItem | Moves the current xml item.
Read | Overloaded.
ReadBool | Reads the boolean property.
ReadDouble | Reads the double property.
ReadFloat | Reads the float property.
ReadInt | Reads the integer property.
ReadProperties | Reads properties of specified object.
ReadPropertyValue | Reads the standalone property value.
ReadStr | Reads the string property.
ReadValue | Reads the enum property.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Errors | Gets a string that contains errors occured during the load.
ItemName | Gets the current item name.
ReadChildren | Gets or sets a value indicating whther is necessary to read the object's children.

See Also

FRReader Class
FastReport.Utils Namespace


FRReader Constructor

[image] [image]

FastReport.Net Class Reference
FRReader Constructor
FRReader Class See Also Send Feedback

Overload List

Name | Description
FRReader(Report) | Initializes a new instance of the FRReader class with specified report.
FRReader(Report, XmlItem) | Initializes a new instance of the FRReader class with specified report and xml item with contents to read.

See Also

FRReader Class
FRReader Members
FastReport.Utils Namespace


FRReader Constructor (Report)

[image]

FastReport.Net Class Reference
FRReader Constructor (Report)
FRReader Class See Also Send Feedback
Initializes a new instance of the FRReader class with specified report.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRReader(
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    report As Report _
)
Visual C++
public:
FRReader(
    Report^ report
)

Parameters

report
Type: FastReport..::.Report
Reference to a report.

See Also

FRReader Class
FRReader Overload
FastReport.Utils Namespace


FRReader Constructor (Report, XmlItem)

[image]

FastReport.Net Class Reference
FRReader Constructor (Report, XmlItem)
FRReader Class See Also Send Feedback
Initializes a new instance of the FRReader class with specified report and xml item with contents to read.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRReader(
    Report report,
    XmlItem root
)
Visual Basic (Declaration)
Public Sub New ( _
    report As Report, _
    root As XmlItem _
)
Visual C++
public:
FRReader(
    Report^ report,
    XmlItem^ root
)

Parameters

report
Type: FastReport..::.Report
Reference to a report.
root
Type: FastReport.Utils..::.XmlItem
Xml item with contents to read.

See Also

FRReader Class
FRReader Overload
FastReport.Utils Namespace


FRReader Methods

[image] [image]

FastReport.Net Class Reference
FRReader Methods
FRReader Class See Also Send Feedback

The FRReader type exposes the following members.

Methods

Name | Description
Dispose | Disposes the reader, fixups the property references.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasProperty | Checks if current item has specified property.
Load | Loads the xml items from a stream.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextItem | Moves the current xml item.
Read | Overloaded.
ReadBool | Reads the boolean property.
ReadDouble | Reads the double property.
ReadFloat | Reads the float property.
ReadInt | Reads the integer property.
ReadProperties | Reads properties of specified object.
ReadPropertyValue | Reads the standalone property value.
ReadStr | Reads the string property.
ReadValue | Reads the enum property.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FRReader Class
FastReport.Utils Namespace


Dispose Method

[image]

FastReport.Net Class Reference
FRReader..::.Dispose Method
FRReader Class See Also Send Feedback
Disposes the reader, fixups the property references.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FRReader Class
FastReport.Utils Namespace


HasProperty Method

[image]

FastReport.Net Class Reference
FRReader..::.HasProperty Method
FRReader Class See Also Send Feedback
Checks if current item has specified property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool HasProperty(
    string name
)
Visual Basic (Declaration)
Public Function HasProperty ( _
    name As String _
) As Boolean
Visual C++
public:
bool HasProperty(
    String^ name
)

Parameters

name
Type: System..::.String
The property name to check.

Return Value

true if current item has specified property.

See Also

FRReader Class
FastReport.Utils Namespace


Load Method

[image]

FastReport.Net Class Reference
FRReader..::.Load Method
FRReader Class See Also Send Feedback
Loads the xml items from a stream.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

See Also

FRReader Class
FastReport.Utils Namespace


NextItem Method

[image]

FastReport.Net Class Reference
FRReader..::.NextItem Method
FRReader Class Example See Also Send Feedback
Moves the current xml item.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool NextItem()
Visual Basic (Declaration)
Public Function NextItem As Boolean
Visual C++
public:
bool NextItem()

Return Value

false if there is no more items to move on; true otherwise.

Remarks

This method is used to read child objects.

Examples

This example demonstrates the use of ReadProperties, ReadChildren, NextItem, Read methods.
CopyC#
public void Deserialize(FRReader reader)
{
  // read simple properties like "Text", complex properties like "Border.Lines"
  reader.ReadProperties(this);

  // moves the current reader item
  while (reader.NextItem())
  {
    // read the "Styles" collection
    if (String.Compare(reader.ItemName, "Styles", true) == 0)
      reader.Read(Styles);
    else if (reader.ReadChildren)
    {
      // if read of children is enabled, read them
      Base obj = reader.Read();
      if (obj != null)
         obj.Parent = this;
    }
  }
}

See Also

FRReader Class
FastReport.Utils Namespace


Read Method

[image] [image]

FastReport.Net Class Reference
FRReader..::.Read Method
FRReader Class See Also Send Feedback

Overload List

Name | Description
Read()()() | Reads an object from current xml node.
Read(IFRSerializable) | Reads the specified object.

See Also

FRReader Class
FRReader Members
FastReport.Utils Namespace


Read Method

[image]

FastReport.Net Class Reference
FRReader..::.Read Method
FRReader Class Example See Also Send Feedback
Reads an object from current xml node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public IFRSerializable Read()
Visual Basic (Declaration)
Public Function Read As IFRSerializable
Visual C++
public:
IFRSerializable^ Read()

Return Value

The object.

Remarks

This method creates an instance of object described by the current xml node, then invokes its Deserialize method.

Examples

This example demonstrates the use of ReadProperties, ReadChildren, NextItem, Read methods.
CopyC#
public void Deserialize(FRReader reader)
{
  // read simple properties like "Text", complex properties like "Border.Lines"
  reader.ReadProperties(this);

  // moves the current reader item
  while (reader.NextItem())
  {
    // read the "Styles" collection
    if (String.Compare(reader.ItemName, "Styles", true) == 0)
      reader.Read(Styles);
    else if (reader.ReadChildren)
    {
      // if read of children is enabled, read them
      Base obj = reader.Read();
      if (obj != null)
         obj.Parent = this;
    }
  }
}

See Also

FRReader Class
Read Overload
FastReport.Utils Namespace


Read Method (IFRSerializable)

[image]

FastReport.Net Class Reference
FRReader..::.Read Method (IFRSerializable)
FRReader Class Example See Also Send Feedback
Reads the specified object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Read(
    IFRSerializable obj
)
Visual Basic (Declaration)
Public Sub Read ( _
    obj As IFRSerializable _
)
Visual C++
public:
void Read(
    IFRSerializable^ obj
)

Parameters

obj
Type: FastReport..::.IFRSerializable
The object to read.

Remarks

The object must implement the IFRSerializable interface. This method invokes the Deserialize method of the object.

Examples

This example demonstrates the use of ReadProperties, ReadChildren, NextItem, Read methods.
CopyC#
public void Deserialize(FRReader reader)
{
  // read simple properties like "Text", complex properties like "Border.Lines"
  reader.ReadProperties(this);

  // moves the current reader item
  while (reader.NextItem())
  {
    // read the "Styles" collection
    if (String.Compare(reader.ItemName, "Styles", true) == 0)
      reader.Read(Styles);
    else if (reader.ReadChildren)
    {
      // if read of children is enabled, read them
      Base obj = reader.Read();
      if (obj != null)
         obj.Parent = this;
    }
  }
}

See Also

FRReader Class
Read Overload
FastReport.Utils Namespace


ReadBool Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadBool Method
FRReader Class See Also Send Feedback
Reads the boolean property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ReadBool(
    string name
)
Visual Basic (Declaration)
Public Function ReadBool ( _
    name As String _
) As Boolean
Visual C++
public:
bool ReadBool(
    String^ name
)

Parameters

name
Type: System..::.String
Name of property.

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


ReadDouble Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadDouble Method
FRReader Class See Also Send Feedback
Reads the double property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public double ReadDouble(
    string name
)
Visual Basic (Declaration)
Public Function ReadDouble ( _
    name As String _
) As Double
Visual C++
public:
double ReadDouble(
    String^ name
)

Parameters

name
Type: System..::.String
Name of property.

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


ReadFloat Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadFloat Method
FRReader Class See Also Send Feedback
Reads the float property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float ReadFloat(
    string name
)
Visual Basic (Declaration)
Public Function ReadFloat ( _
    name As String _
) As Single
Visual C++
public:
float ReadFloat(
    String^ name
)

Parameters

name
Type: System..::.String
Name of property.

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


ReadInt Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadInt Method
FRReader Class See Also Send Feedback
Reads the integer property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ReadInt(
    string name
)
Visual Basic (Declaration)
Public Function ReadInt ( _
    name As String _
) As Integer
Visual C++
public:
int ReadInt(
    String^ name
)

Parameters

name
Type: System..::.String
Name of property.

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


ReadProperties Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadProperties Method
FRReader Class Example See Also Send Feedback
Reads properties of specified object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void ReadProperties(
    Object obj
)
Visual Basic (Declaration)
Public Sub ReadProperties ( _
    obj As Object _
)
Visual C++
public:
void ReadProperties(
    Object^ obj
)

Parameters

obj
Type: System..::.Object
The object to read.

Remarks

This method reads simple properties like "Text", "Border.Lines" etc. for specified object. To read nested properties like collections, you should override the DeserializeSubItems(FRReader) method of an object.

Examples

This example demonstrates the use of ReadProperties, ReadChildren, NextItem, Read methods.
CopyC#
public void Deserialize(FRReader reader)
{
  // read simple properties like "Text", complex properties like "Border.Lines"
  reader.ReadProperties(this);

  // moves the current reader item
  while (reader.NextItem())
  {
    // read the "Styles" collection
    if (String.Compare(reader.ItemName, "Styles", true) == 0)
      reader.Read(Styles);
    else if (reader.ReadChildren)
    {
      // if read of children is enabled, read them
      Base obj = reader.Read();
      if (obj != null)
         obj.Parent = this;
    }
  }
}

See Also

FRReader Class
FastReport.Utils Namespace


ReadPropertyValue Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadPropertyValue Method
FRReader Class See Also Send Feedback
Reads the standalone property value.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReadPropertyValue()
Visual Basic (Declaration)
Public Function ReadPropertyValue As String
Visual C++
public:
String^ ReadPropertyValue()

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


ReadStr Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadStr Method
FRReader Class See Also Send Feedback
Reads the string property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ReadStr(
    string name
)
Visual Basic (Declaration)
Public Function ReadStr ( _
    name As String _
) As String
Visual C++
public:
String^ ReadStr(
    String^ name
)

Parameters

name
Type: System..::.String
Name of property.

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


ReadValue Method

[image]

FastReport.Net Class Reference
FRReader..::.ReadValue Method
FRReader Class See Also Send Feedback
Reads the enum property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object ReadValue(
    string name,
    Type typ
)
Visual Basic (Declaration)
Public Function ReadValue ( _
    name As String, _
    typ As Type _
) As Object
Visual C++
public:
Object^ ReadValue(
    String^ name,
    Type^ typ
)

Parameters

name
Type: System..::.String
Name of property.
typ
Type: System..::.Type
Type of property.

Return Value

Property value.

See Also

FRReader Class
FastReport.Utils Namespace


FRReader Properties

[image] [image]

FastReport.Net Class Reference
FRReader Properties
FRReader Class See Also Send Feedback

The FRReader type exposes the following members.

Properties

Name | Description
Errors | Gets a string that contains errors occured during the load.
ItemName | Gets the current item name.
ReadChildren | Gets or sets a value indicating whther is necessary to read the object's children.

See Also

FRReader Class
FastReport.Utils Namespace


Errors Property

[image]

FastReport.Net Class Reference
FRReader..::.Errors Property
FRReader Class See Also Send Feedback
Gets a string that contains errors occured during the load.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Errors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Errors As String
Visual C++
public:
property String^ Errors {
    String^ get ();
}

See Also

FRReader Class
FastReport.Utils Namespace


ItemName Property

[image]

FastReport.Net Class Reference
FRReader..::.ItemName Property
FRReader Class See Also Send Feedback
Gets the current item name.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ItemName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemName As String
Visual C++
public:
property String^ ItemName {
    String^ get ();
}

See Also

FRReader Class
FastReport.Utils Namespace


ReadChildren Property

[image]

FastReport.Net Class Reference
FRReader..::.ReadChildren Property
FRReader Class See Also Send Feedback
Gets or sets a value indicating whther is necessary to read the object's children.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool ReadChildren { get; set; }
Visual Basic (Declaration)
Public Property ReadChildren As Boolean
Visual C++
public:
property bool ReadChildren {
    bool get ();
    void set (bool value);
}

See Also

FRReader Class
FastReport.Utils Namespace


FRWriter Class

[image]

FastReport.Net Class Reference
FRWriter Class
Members See Also Send Feedback
The writer used to serialize object's properties to a report file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class FRWriter : IDisposable
Visual Basic (Declaration)
Public Class FRWriter _
    Implements IDisposable
Visual C++
public ref class FRWriter : IDisposable

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.FRWriter

See Also

FRWriter Members
FastReport.Utils Namespace


FRWriter Members

[image] [image]

FastReport.Net Class Reference
FRWriter Members
FRWriter Class Constructors Methods Properties See Also Send Feedback

The FRWriter type exposes the following members.

Constructors

Name | Description
FRWriter | Overloaded.

Methods

Name | Description
AreEqual | Determines if two objects are equal.
Dispose | Disposes the writer.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Saves the writer output to a stream.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.
WriteBool | Writes a boolean property.
WriteDouble | Writes a double property.
WriteFloat | Writes a float property.
WriteInt | Writes an integer property.
WritePropertyValue | Writes a standalone property value.
WriteRef | Writes an object reference property.
WriteStr | Writes a string property.
WriteValue | Writes an enumeration property.

Properties

Name | Description
DiffObject | Gets the ethalon object to compare with.
ItemName | Gets or sets current xml item name.
SaveChildren | Gets or sets a value that determines whether is necessary to serialize child objects.
SerializeTo | Gets or sets target of serialization.

See Also

FRWriter Class
FastReport.Utils Namespace


FRWriter Constructor

[image] [image]

FastReport.Net Class Reference
FRWriter Constructor
FRWriter Class See Also Send Feedback

Overload List

Name | Description
FRWriter()()() | Initializes a new instance of the FRWriter class with default settings.
FRWriter(XmlItem) | Initializes a new instance of the FRWriter class with specified xml item that will receive writer's output.

See Also

FRWriter Class
FRWriter Members
FastReport.Utils Namespace


FRWriter Constructor

[image]

FastReport.Net Class Reference
FRWriter Constructor
FRWriter Class See Also Send Feedback
Initializes a new instance of the FRWriter class with default settings.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRWriter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FRWriter()

See Also

FRWriter Class
FRWriter Overload
FastReport.Utils Namespace


FRWriter Constructor (XmlItem)

[image]

FastReport.Net Class Reference
FRWriter Constructor (XmlItem)
FRWriter Class See Also Send Feedback
Initializes a new instance of the FRWriter class with specified xml item that will receive writer's output.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public FRWriter(
    XmlItem root
)
Visual Basic (Declaration)
Public Sub New ( _
    root As XmlItem _
)
Visual C++
public:
FRWriter(
    XmlItem^ root
)

Parameters

root
Type: FastReport.Utils..::.XmlItem
The xml item that will receive writer's output.

See Also

FRWriter Class
FRWriter Overload
FastReport.Utils Namespace


FRWriter Methods

[image] [image]

FastReport.Net Class Reference
FRWriter Methods
FRWriter Class See Also Send Feedback

The FRWriter type exposes the following members.

Methods

Name | Description
AreEqual | Determines if two objects are equal.
Dispose | Disposes the writer.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Saves the writer output to a stream.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.
WriteBool | Writes a boolean property.
WriteDouble | Writes a double property.
WriteFloat | Writes a float property.
WriteInt | Writes an integer property.
WritePropertyValue | Writes a standalone property value.
WriteRef | Writes an object reference property.
WriteStr | Writes a string property.
WriteValue | Writes an enumeration property.

See Also

FRWriter Class
FastReport.Utils Namespace


AreEqual Method

[image]

FastReport.Net Class Reference
FRWriter..::.AreEqual Method
FRWriter Class See Also Send Feedback
Determines if two objects are equal.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AreEqual(
    Object obj1,
    Object obj2
)
Visual Basic (Declaration)
Public Function AreEqual ( _
    obj1 As Object, _
    obj2 As Object _
) As Boolean
Visual C++
public:
bool AreEqual(
    Object^ obj1,
    Object^ obj2
)

Parameters

obj1
Type: System..::.Object
The first object.
obj2
Type: System..::.Object
The second object.

Return Value

true if objects will be serialized to the same value.

See Also

FRWriter Class
FastReport.Utils Namespace


Dispose Method

[image]

FastReport.Net Class Reference
FRWriter..::.Dispose Method
FRWriter Class See Also Send Feedback
Disposes the writer.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FRWriter Class
FastReport.Utils Namespace


Save Method

[image]

FastReport.Net Class Reference
FRWriter..::.Save Method
FRWriter Class See Also Send Feedback
Saves the writer output to a stream.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to save to.

See Also

FRWriter Class
FastReport.Utils Namespace


Write Method

[image] [image]

FastReport.Net Class Reference
FRWriter..::.Write Method
FRWriter Class See Also Send Feedback

Overload List

Name | Description
Write(IFRSerializable) | Serializes the specified object.
Write(IFRSerializable, Object) | Serializes the object using specified etalon.

See Also

FRWriter Class
FRWriter Members
FastReport.Utils Namespace


Write Method (IFRSerializable)

[image]

FastReport.Net Class Reference
FRWriter..::.Write Method (IFRSerializable)
FRWriter Class Example See Also Send Feedback
Serializes the specified object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Write(
    IFRSerializable obj
)
Visual Basic (Declaration)
Public Sub Write ( _
    obj As IFRSerializable _
)
Visual C++
public:
void Write(
    IFRSerializable^ obj
)

Parameters

obj
Type: FastReport..::.IFRSerializable
The object to serialize.

Remarks

The object must implement the IFRSerializable interface. This method invokes the Serialize method of the object.

Examples

This example demonstrates the use of writer.
CopyC#
public void Serialize(FRWriter writer)
{
  // get the etalon object. It will be used to write changed properties only.
  Base c = writer.DiffObject as Base;

  // write the type name
  writer.ItemName = ClassName;

  // write properties
  if (Name != "")
    writer.WriteStr("Name", Name);
  if (Restrictions != c.Restrictions)
    writer.WriteValue("Restrictions", Restrictions);

  // write child objects if allowed
  if (writer.SaveChildren)
  {
    foreach (Base child in ChildObjects)
    {
      writer.Write(child);
    }
  }
}

See Also

FRWriter Class
Write Overload
FastReport.Utils Namespace


Write Method (IFRSerializable, Object)

[image]

FastReport.Net Class Reference
FRWriter..::.Write Method (IFRSerializable, Object)
FRWriter Class See Also Send Feedback
Serializes the object using specified etalon.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Write(
    IFRSerializable obj,
    Object diff
)
Visual Basic (Declaration)
Public Sub Write ( _
    obj As IFRSerializable, _
    diff As Object _
)
Visual C++
public:
void Write(
    IFRSerializable^ obj,
    Object^ diff
)

Parameters

obj
Type: FastReport..::.IFRSerializable
The object to serialize.
diff
Type: System..::.Object
The etalon object.

See Also

FRWriter Class
Write Overload
FastReport.Utils Namespace


WriteBool Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteBool Method
FRWriter Class See Also Send Feedback
Writes a boolean property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteBool(
    string name,
    bool value
)
Visual Basic (Declaration)
Public Sub WriteBool ( _
    name As String, _
    value As Boolean _
)
Visual C++
public:
void WriteBool(
    String^ name,
    bool value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: System..::.Boolean
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


WriteDouble Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteDouble Method
FRWriter Class See Also Send Feedback
Writes a double property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteDouble(
    string name,
    double value
)
Visual Basic (Declaration)
Public Sub WriteDouble ( _
    name As String, _
    value As Double _
)
Visual C++
public:
void WriteDouble(
    String^ name,
    double value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: System..::.Double
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


WriteFloat Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteFloat Method
FRWriter Class See Also Send Feedback
Writes a float property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteFloat(
    string name,
    float value
)
Visual Basic (Declaration)
Public Sub WriteFloat ( _
    name As String, _
    value As Single _
)
Visual C++
public:
void WriteFloat(
    String^ name,
    float value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: System..::.Single
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


WriteInt Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteInt Method
FRWriter Class See Also Send Feedback
Writes an integer property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteInt(
    string name,
    int value
)
Visual Basic (Declaration)
Public Sub WriteInt ( _
    name As String, _
    value As Integer _
)
Visual C++
public:
void WriteInt(
    String^ name,
    int value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: System..::.Int32
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


WritePropertyValue Method

[image]

FastReport.Net Class Reference
FRWriter..::.WritePropertyValue Method
FRWriter Class See Also Send Feedback
Writes a standalone property value.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WritePropertyValue(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub WritePropertyValue ( _
    name As String, _
    value As String _
)
Visual C++
public:
void WritePropertyValue(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
Name of property.
value
Type: System..::.String
Property value.

Remarks

This method produces the following output: <PropertyName>PropertyValue</PropertyName>

See Also

FRWriter Class
FastReport.Utils Namespace


WriteRef Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteRef Method
FRWriter Class See Also Send Feedback
Writes an object reference property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteRef(
    string name,
    Base value
)
Visual Basic (Declaration)
Public Sub WriteRef ( _
    name As String, _
    value As Base _
)
Visual C++
public:
void WriteRef(
    String^ name,
    Base^ value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: FastReport..::.Base
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


WriteStr Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteStr Method
FRWriter Class See Also Send Feedback
Writes a string property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteStr(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub WriteStr ( _
    name As String, _
    value As String _
)
Visual C++
public:
void WriteStr(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: System..::.String
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


WriteValue Method

[image]

FastReport.Net Class Reference
FRWriter..::.WriteValue Method
FRWriter Class See Also Send Feedback
Writes an enumeration property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void WriteValue(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub WriteValue ( _
    name As String, _
    value As Object _
)
Visual C++
public:
void WriteValue(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String
Property name.
value
Type: System..::.Object
Property value.

See Also

FRWriter Class
FastReport.Utils Namespace


FRWriter Properties

[image] [image]

FastReport.Net Class Reference
FRWriter Properties
FRWriter Class See Also Send Feedback

The FRWriter type exposes the following members.

Properties

Name | Description
DiffObject | Gets the ethalon object to compare with.
ItemName | Gets or sets current xml item name.
SaveChildren | Gets or sets a value that determines whether is necessary to serialize child objects.
SerializeTo | Gets or sets target of serialization.

See Also

FRWriter Class
FastReport.Utils Namespace


DiffObject Property

[image]

FastReport.Net Class Reference
FRWriter..::.DiffObject Property
FRWriter Class See Also Send Feedback
Gets the ethalon object to compare with.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Object DiffObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property DiffObject As Object
Visual C++
public:
property Object^ DiffObject {
    Object^ get ();
}

See Also

FRWriter Class
FastReport.Utils Namespace


ItemName Property

[image]

FastReport.Net Class Reference
FRWriter..::.ItemName Property
FRWriter Class See Also Send Feedback
Gets or sets current xml item name.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string ItemName { get; set; }
Visual Basic (Declaration)
Public Property ItemName As String
Visual C++
public:
property String^ ItemName {
    String^ get ();
    void set (String^ value);
}

See Also

FRWriter Class
FastReport.Utils Namespace


SaveChildren Property

[image]

FastReport.Net Class Reference
FRWriter..::.SaveChildren Property
FRWriter Class See Also Send Feedback
Gets or sets a value that determines whether is necessary to serialize child objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool SaveChildren { get; set; }
Visual Basic (Declaration)
Public Property SaveChildren As Boolean
Visual C++
public:
property bool SaveChildren {
    bool get ();
    void set (bool value);
}

See Also

FRWriter Class
FastReport.Utils Namespace


SerializeTo Property

[image]

FastReport.Net Class Reference
FRWriter..::.SerializeTo Property
FRWriter Class See Also Send Feedback
Gets or sets target of serialization.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SerializeTo SerializeTo { get; set; }
Visual Basic (Declaration)
Public Property SerializeTo As SerializeTo
Visual C++
public:
property SerializeTo SerializeTo {
    SerializeTo get ();
    void set (SerializeTo value);
}

See Also

FRWriter Class
FastReport.Utils Namespace


MatrixValueException Class

[image]

FastReport.Net Class Reference
MatrixValueException Class
Members See Also Send Feedback
The exception that is thrown if an error occurs in the MatrixObject.ManualBuild event.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MatrixValueException : Exception
Visual Basic (Declaration)
Public Class MatrixValueException _
    Inherits Exception
Visual C++
public ref class MatrixValueException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.MatrixValueException

See Also

MatrixValueException Members
FastReport.Utils Namespace


MatrixValueException Members

[image] [image]

FastReport.Net Class Reference
MatrixValueException Members
MatrixValueException Class Methods Properties See Also Send Feedback

The MatrixValueException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MatrixValueException Class
FastReport.Utils Namespace


MatrixValueException Methods

[image] [image]

FastReport.Net Class Reference
MatrixValueException Methods
MatrixValueException Class See Also Send Feedback

The MatrixValueException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MatrixValueException Class
FastReport.Utils Namespace


MatrixValueException Properties

[image] [image]

FastReport.Net Class Reference
MatrixValueException Properties
MatrixValueException Class See Also Send Feedback

The MatrixValueException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MatrixValueException Class
FastReport.Utils Namespace


MyRes Class

[image]

FastReport.Net Class Reference
MyRes Class
Members See Also Send Feedback
Used to access to resource IDs inside the specified branch.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class MyRes
Visual Basic (Declaration)
Public Class MyRes
Visual C++
public ref class MyRes

Remarks

Using the Get(String) method, you have to specify the full path to your resource. Using this class, you can shorten the path:
CopyC#
// using the Res.Get method
miKeepTogether = new ToolStripMenuItem(Res.Get("ComponentMenu,HeaderBand,KeepTogether"));
miResetPageNumber = new ToolStripMenuItem(Res.Get("ComponentMenu,HeaderBand,ResetPageNumber"));
miRepeatOnEveryPage = new ToolStripMenuItem(Res.Get("ComponentMenu,HeaderBand,RepeatOnEveryPage"));

// using MyRes.Get method
MyRes res = new MyRes("ComponentMenu,HeaderBand");
miKeepTogether = new ToolStripMenuItem(res.Get("KeepTogether"));
miResetPageNumber = new ToolStripMenuItem(res.Get("ResetPageNumber"));
miRepeatOnEveryPage = new ToolStripMenuItem(res.Get("RepeatOnEveryPage"));

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.MyRes

See Also

MyRes Members
FastReport.Utils Namespace


MyRes Members

[image] [image]

FastReport.Net Class Reference
MyRes Members
MyRes Class Constructors Methods See Also Send Feedback

The MyRes type exposes the following members.

Constructors

Name | Description
MyRes | Initializes a new instance of the MyRes class with spevified branch.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | Gets a string with specified ID inside the main branch.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MyRes Class
FastReport.Utils Namespace


MyRes Constructor

[image]

FastReport.Net Class Reference
MyRes Constructor
MyRes Class See Also Send Feedback
Initializes a new instance of the MyRes class with spevified branch.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public MyRes(
    string category
)
Visual Basic (Declaration)
Public Sub New ( _
    category As String _
)
Visual C++
public:
MyRes(
    String^ category
)

Parameters

category
Type: System..::.String
The main resource branch.

See Also

MyRes Class
FastReport.Utils Namespace


MyRes Methods

[image] [image]

FastReport.Net Class Reference
MyRes Methods
MyRes Class See Also Send Feedback

The MyRes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | Gets a string with specified ID inside the main branch.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MyRes Class
FastReport.Utils Namespace


Get Method

[image]

FastReport.Net Class Reference
MyRes..::.Get Method
MyRes Class See Also Send Feedback
Gets a string with specified ID inside the main branch.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Get(
    string id
)
Visual Basic (Declaration)
Public Function Get ( _
    id As String _
) As String
Visual C++
public:
String^ Get(
    String^ id
)

Parameters

id
Type: System..::.String
The resource ID.

Return Value

The localized value.

See Also

MyRes Class
FastReport.Utils Namespace


NotValidIdentifierException Class

[image]

FastReport.Net Class Reference
NotValidIdentifierException Class
Members See Also Send Feedback
The exception that is thrown if an error occurs in the MatrixObject.ManualBuild event.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NotValidIdentifierException : Exception
Visual Basic (Declaration)
Public Class NotValidIdentifierException _
    Inherits Exception
Visual C++
public ref class NotValidIdentifierException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.NotValidIdentifierException

See Also

NotValidIdentifierException Members
FastReport.Utils Namespace


NotValidIdentifierException Members

[image] [image]

FastReport.Net Class Reference
NotValidIdentifierException Members
NotValidIdentifierException Class Methods Properties See Also Send Feedback

The NotValidIdentifierException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NotValidIdentifierException Class
FastReport.Utils Namespace


NotValidIdentifierException Methods

[image] [image]

FastReport.Net Class Reference
NotValidIdentifierException Methods
NotValidIdentifierException Class See Also Send Feedback

The NotValidIdentifierException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NotValidIdentifierException Class
FastReport.Utils Namespace


NotValidIdentifierException Properties

[image] [image]

FastReport.Net Class Reference
NotValidIdentifierException Properties
NotValidIdentifierException Class See Also Send Feedback

The NotValidIdentifierException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NotValidIdentifierException Class
FastReport.Utils Namespace


ObjectInfo Class

[image]

FastReport.Net Class Reference
ObjectInfo Class
Members See Also Send Feedback
Holds the information about the registered object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ObjectInfo
Visual Basic (Declaration)
Public Class ObjectInfo
Visual C++
public ref class ObjectInfo

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.ObjectInfo

See Also

ObjectInfo Members
FastReport.Utils Namespace


ObjectInfo Members

[image] [image]

FastReport.Net Class Reference
ObjectInfo Members
ObjectInfo Class Methods Properties See Also Send Feedback

The ObjectInfo type exposes the following members.

Methods

Name | Description
EnumItems | Enumerates all objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets the enabled flag for the object.
Flags | Flags that will be used to create an object instance in the designer.
Image | Image.
ImageIndex | Image index.
Items | List of subitems.
MultiInsert | Indicates whether this object can be inserted several times simultaneously.
Name | Name of object or category.
Object | The registered object.
Text | Tooltip text.

See Also

ObjectInfo Class
FastReport.Utils Namespace


ObjectInfo Methods

[image] [image]

FastReport.Net Class Reference
ObjectInfo Methods
ObjectInfo Class See Also Send Feedback

The ObjectInfo type exposes the following members.

Methods

Name | Description
EnumItems | Enumerates all objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectInfo Class
FastReport.Utils Namespace


EnumItems Method

[image]

FastReport.Net Class Reference
ObjectInfo..::.EnumItems Method
ObjectInfo Class See Also Send Feedback
Enumerates all objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void EnumItems(
    List<ObjectInfo> list
)
Visual Basic (Declaration)
Public Sub EnumItems ( _
    list As List(Of ObjectInfo) _
)
Visual C++
public:
void EnumItems(
    List<ObjectInfo^>^ list
)

Parameters

list
Type: System.Collections.Generic..::.List <(Of <( ObjectInfo >)>)
List that will contain enumerated items.

See Also

ObjectInfo Class
FastReport.Utils Namespace


ObjectInfo Properties

[image] [image]

FastReport.Net Class Reference
ObjectInfo Properties
ObjectInfo Class See Also Send Feedback

The ObjectInfo type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets the enabled flag for the object.
Flags | Flags that will be used to create an object instance in the designer.
Image | Image.
ImageIndex | Image index.
Items | List of subitems.
MultiInsert | Indicates whether this object can be inserted several times simultaneously.
Name | Name of object or category.
Object | The registered object.
Text | Tooltip text.

See Also

ObjectInfo Class
FastReport.Utils Namespace


Enabled Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Enabled Property
ObjectInfo Class See Also Send Feedback
Gets or sets the enabled flag for the object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


Flags Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Flags Property
ObjectInfo Class See Also Send Feedback
Flags that will be used to create an object instance in the designer.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Flags { get; set; }
Visual Basic (Declaration)
Public Property Flags As Integer
Visual C++
public:
property int Flags {
    int get ();
    void set (int value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


Image Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Image Property
ObjectInfo Class See Also Send Feedback
Image.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Bitmap Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Bitmap
Visual C++
public:
property Bitmap^ Image {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


ImageIndex Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.ImageIndex Property
ObjectInfo Class See Also Send Feedback
Image index.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic (Declaration)
Public Property ImageIndex As Integer
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


Items Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Items Property
ObjectInfo Class See Also Send Feedback
List of subitems.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<ObjectInfo> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As List(Of ObjectInfo)
Visual C++
public:
property List<ObjectInfo^>^ Items {
    List<ObjectInfo^>^ get ();
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


MultiInsert Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.MultiInsert Property
ObjectInfo Class See Also Send Feedback
Indicates whether this object can be inserted several times simultaneously.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool MultiInsert { get; set; }
Visual Basic (Declaration)
Public Property MultiInsert As Boolean
Visual C++
public:
property bool MultiInsert {
    bool get ();
    void set (bool value);
}

Remarks

This is applied to Line object only.

See Also

ObjectInfo Class
FastReport.Utils Namespace


Name Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Name Property
ObjectInfo Class See Also Send Feedback
Name of object or category.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


Object Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Object Property
ObjectInfo Class See Also Send Feedback
The registered object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public Type Object { get; set; }
Visual Basic (Declaration)
Public Property Object As Type
Visual C++
public:
property Type^ Object {
    Type^ get ();
    void set (Type^ value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


Text Property

[image]

FastReport.Net Class Reference
ObjectInfo..::.Text Property
ObjectInfo Class See Also Send Feedback
Tooltip text.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ObjectInfo Class
FastReport.Utils Namespace


PageUnits Enumeration

[image]

FastReport.Net Class Reference
PageUnits Enumeration
See Also Send Feedback
The report page units.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum PageUnits
Visual Basic (Declaration)
Public Enumeration PageUnits
Visual C++
public enum class PageUnits

Members

Member name | Description
Millimeters | Specifies the units measured in millimeters.
Centimeters | Specifies the units measured in centimeters.
Inches | Specifies the units measured in inches.
HundrethsOfInch | Specifies the units measured in hundreths of inch.

See Also

FastReport.Utils Namespace


ParentException Class

[image]

FastReport.Net Class Reference
ParentException Class
Members See Also Send Feedback
The exception that is thrown when trying to set an object's Parent property to an object that not accepts children of this type.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ParentException : Exception
Visual Basic (Declaration)
Public Class ParentException _
    Inherits Exception
Visual C++
public ref class ParentException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.ParentException

See Also

ParentException Members
FastReport.Utils Namespace


ParentException Members

[image] [image]

FastReport.Net Class Reference
ParentException Members
ParentException Class Methods Properties See Also Send Feedback

The ParentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ParentException Class
FastReport.Utils Namespace


ParentException Methods

[image] [image]

FastReport.Net Class Reference
ParentException Methods
ParentException Class See Also Send Feedback

The ParentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ParentException Class
FastReport.Utils Namespace


ParentException Properties

[image] [image]

FastReport.Net Class Reference
ParentException Properties
ParentException Class See Also Send Feedback

The ParentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ParentException Class
FastReport.Utils Namespace


Profiler Class

[image]

FastReport.Net Class Reference
Profiler Class
Members See Also Send Feedback
The profiler.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Profiler
Visual Basic (Declaration)
Public NotInheritable Class Profiler
Visual C++
public ref class Profiler abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Profiler

See Also

Profiler Members
FastReport.Utils Namespace


Profiler Members

[image] [image]

FastReport.Net Class Reference
Profiler Members
Profiler Class Methods See Also Send Feedback

The Profiler type exposes the following members.

Methods

Name | Description
Start | Starts the profiler.
Stop | Finishes the profiler and displays results.

See Also

Profiler Class
FastReport.Utils Namespace


Profiler Methods

[image] [image]

FastReport.Net Class Reference
Profiler Methods
Profiler Class See Also Send Feedback

The Profiler type exposes the following members.

Methods

Name | Description
Start | Starts the profiler.
Stop | Finishes the profiler and displays results.

See Also

Profiler Class
FastReport.Utils Namespace


Start Method

[image]

FastReport.Net Class Reference
Profiler..::.Start Method
Profiler Class See Also Send Feedback
Starts the profiler.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Start()
Visual Basic (Declaration)
Public Shared Sub Start
Visual C++
public:
static void Start()

See Also

Profiler Class
FastReport.Utils Namespace


Stop Method

[image]

FastReport.Net Class Reference
Profiler..::.Stop Method
Profiler Class See Also Send Feedback
Finishes the profiler and displays results.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Stop()
Visual Basic (Declaration)
Public Shared Sub Stop
Visual C++
public:
static void Stop()

See Also

Profiler Class
FastReport.Utils Namespace


RegisteredObjects Class

[image]

FastReport.Net Class Reference
RegisteredObjects Class
Members Example See Also Send Feedback
Contains all registered report items such as objects, export filters, wizards.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class RegisteredObjects
Visual Basic (Declaration)
Public NotInheritable Class RegisteredObjects
Visual C++
public ref class RegisteredObjects abstract sealed

Remarks

Use this class to register own components, wizards, export filters or another items that need to be serialized to/from a report file.

Examples

CopyC#
// register own wizard
RegisteredObjects.AddWizard(typeof(MyWizard), myWizBmp, "My Wizard", true);
// register own export filter
RegisteredObjects.AddExport(typeof(MyExport), "My Export");
// register own report object
RegisteredObjects.Add(typeof(MyObject), "ReportPage", myObjBmp, "My Object");

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.RegisteredObjects

See Also

RegisteredObjects Members
FastReport.Utils Namespace


RegisteredObjects Members

[image] [image]

FastReport.Net Class Reference
RegisteredObjects Members
RegisteredObjects Class Methods Properties See Also Send Feedback

The RegisteredObjects type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddCategory | Registers a category that may contain several report objects.
AddCloud | Registers a new cloud storage client.
AddConnection | Overloaded.
AddExport | Registers a new export filter.
AddFunction | Adds a new function into the specified category.
AddFunctionCategory | Adds a new function category.
AddWizard | Registers a new wizard.
FindObject | Finds the registered object's info.
IsTypeRegistered | Checks whether the specified type is registered already.

Properties

Name | Description
Objects | Root object for all registered objects.

See Also

RegisteredObjects Class
FastReport.Utils Namespace


RegisteredObjects Methods

[image] [image]

FastReport.Net Class Reference
RegisteredObjects Methods
RegisteredObjects Class See Also Send Feedback

The RegisteredObjects type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddCategory | Registers a category that may contain several report objects.
AddCloud | Registers a new cloud storage client.
AddConnection | Overloaded.
AddExport | Registers a new export filter.
AddFunction | Adds a new function into the specified category.
AddFunctionCategory | Adds a new function category.
AddWizard | Registers a new wizard.
FindObject | Finds the registered object's info.
IsTypeRegistered | Checks whether the specified type is registered already.

See Also

RegisteredObjects Class
FastReport.Utils Namespace


Add Method

[image] [image]

FastReport.Net Class Reference
RegisteredObjects..::.Add Method
RegisteredObjects Class See Also Send Feedback

Overload List

Name | Description
Add(Type, String, Int32) | Registers an object in the specified category.
Add(Type, String, Bitmap, String) | Registers an object in the specified category with button's image and text.
Add(Type, String, Bitmap, String, Int32) | Registers an object in the specified category with button's image, text and object's flags.
Add(Type, String, Bitmap, String, Int32, Boolean) | Registers an object in the specified category with button's image, text, object's flags and multi-insert flag.

See Also

RegisteredObjects Class
RegisteredObjects Members
FastReport.Utils Namespace


Add Method (Type, String, Int32)

[image]

FastReport.Net Class Reference
RegisteredObjects..::.Add Method (Type, String, Int32)
RegisteredObjects Class See Also Send Feedback
Registers an object in the specified category.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Add(
    Type obj,
    string category,
    int imageIndex
)
Visual Basic (Declaration)
Public Shared Sub Add ( _
    obj As Type, _
    category As String, _
    imageIndex As Integer _
)
Visual C++
public:
static void Add(
    Type^ obj,
    String^ category,
    int imageIndex
)

Parameters

obj
Type: System..::.Type
Type of object to register.
category
Type: System..::.String
Name of category to register in.
imageIndex
Type: System..::.Int32
Index of image for object's button.

See Also

RegisteredObjects Class
Add Overload
FastReport.Utils Namespace


Add Method (Type, String, Bitmap, String)

[image]

FastReport.Net Class Reference
RegisteredObjects..::.Add Method (Type, String, Bitmap, String)
RegisteredObjects Class Example See Also Send Feedback
Registers an object in the specified category with button's image and text.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Add(
    Type obj,
    string category,
    Bitmap image,
    string text
)
Visual Basic (Declaration)
Public Shared Sub Add ( _
    obj As Type, _
    category As String, _
    image As Bitmap, _
    text As String _
)
Visual C++
public:
static void Add(
    Type^ obj,
    String^ category,
    Bitmap^ image,
    String^ text
)

Parameters

obj
Type: System..::.Type
Type of object to register.
category
Type: System..::.String
Name of category to register in.
image
Type: System.Drawing..::.Bitmap
Image for object's button.
text
Type: System..::.String
Text for object's button.

Remarks

You must specify either the page type name or existing category name in the category parameter. The report objects must be registered in the "ReportPage" category or custom category that is registered in the "ReportPage" as well. The dialog controls must be registered in the "DialogPage" category or custom category that is registered in the "DialogPage" as well.

If you want to register an object that needs to be serialized, but you don't want to show it on the toolbar, pass empty string in the category parameter.

Examples

CopyC#
// register the report object
RegisteredObjects.Add(typeof(MyReportObject), "ReportPage", myReportObjectBmp, "My Report Object");
// register the dialog control
RegisteredObjects.Add(typeof(MyDialogControl), "DialogPage", myDialogControlBmp, "My Dialog Control");
// add a category and register an object inside it
RegisteredObjects.AddCategory("ReportPage,MyCategory", myCategoryBmp, "My Category");
// register another report object in MyCategory
RegisteredObjects.Add(typeof(MyReportObject), "ReportPage,MyCategory",
  anotherReportObjectBmp, "Another Report Object");

See Also

RegisteredObjects Class
Add Overload
FastReport.Utils Namespace


Add Method (Type, String, Bitmap, String, Int32)

[image]

FastReport.Net Class Reference
RegisteredObjects..::.Add Method (Type, String, Bitmap, String, Int32)
RegisteredObjects Class See Also Send Feedback
Registers an object in the specified category with button's image, text and object's flags.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Add(
    Type obj,
    string category,
    Bitmap image,
    string text,
    int flags
)
Visual Basic (Declaration)
Public Shared Sub Add ( _
    obj As Type, _
    category As String, _
    image As Bitmap, _
    text As String, _
    flags As Integer _
)
Visual C++
public:
static void Add(
    Type^ obj,
    String^ category,
    Bitmap^ image,
    String^ text,
    int flags
)

Parameters

obj
Type: System..::.Type
Type of object to register.
category
Type: System..::.String
Name of category to register in.
image
Type: System.Drawing..::.Bitmap
Image for object's button.
text
Type: System..::.String
Text for object's button.
flags
Type: System..::.Int32
Integer value that will be passed to object's OnBeforeInsert method.

Remarks

See the Add(Type, String, Bitmap, String) method for more details.

To learn about flags, see the OnBeforeInsert(Int32) method.

See Also

RegisteredObjects Class
Add Overload
FastReport.Utils Namespace


Add Method (Type, String, Bitmap, String, Int32, Boolean)

[image]

FastReport.Net Class Reference
RegisteredObjects..::.Add Method (Type, String, Bitmap, String, Int32, Boolean)
RegisteredObjects Class See Also Send Feedback
Registers an object in the specified category with button's image, text, object's flags and multi-insert flag.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Add(
    Type obj,
    string category,
    Bitmap image,
    string text,
    int flags,
    bool multiInsert
)
Visual Basic (Declaration)
Public Shared Sub Add ( _
    obj As Type, _
    category As String, _
    image As Bitmap, _
    text As String, _
    flags As Integer, _
    multiInsert As Boolean _
)
Visual C++
public:
static void Add(
    Type^ obj,
    String^ category,
    Bitmap^ image,
    String^ text,
    int flags,
    bool multiInsert
)

Parameters

obj
Type: System..::.Type
Type of object to register.
category
Type: System..::.String
Name of category to register in.
image
Type: System.Drawing..::.Bitmap
Image for object's button.
text
Type: System..::.String
Text for object's button.
flags
Type: System..::.Int32
Integer value that will be passed to object's OnBeforeInsert method.
multiInsert
Type: System..::.Boolean
Specifies whether the object may be inserted several times until you select the "arrow" button or insert another object.

Remarks

See the Add(Type, String, Bitmap, String) method for more details.

To learn about flags, see the OnBeforeInsert(Int32) method.

See Also

RegisteredObjects Class
Add Overload
FastReport.Utils Namespace


AddCategory Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddCategory Method
RegisteredObjects Class See Also Send Feedback
Registers a category that may contain several report objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddCategory(
    string name,
    Bitmap image,
    string text
)
Visual Basic (Declaration)
Public Shared Sub AddCategory ( _
    name As String, _
    image As Bitmap, _
    text As String _
)
Visual C++
public:
static void AddCategory(
    String^ name,
    Bitmap^ image,
    String^ text
)

Parameters

name
Type: System..::.String
Category name.
image
Type: System.Drawing..::.Bitmap
Image for category button.
text
Type: System..::.String
Text for category button.

Remarks

Category is a button on the "Objects" toolbar that shows context menu with nested items when you click it. Consider using categories if you register several report objects. It can save space on the "Objects" toolbar. For example, FastReport registers one category called "Shapes" that contains the LineObject and different types of ShapeObject.

The name of category must starts either with "ReportPage," or "DialogPage," depending on what kind of controls do you need to regiter in this category: report objects or dialog controls. After the comma, specify the category name. So the full category name that you need to specify in the name parameter, must be something like this: "ReportPage,Shapes".

When register an object inside a category, you must specify the full category name in the category parameter of the Add method.

See Also

RegisteredObjects Class
FastReport.Utils Namespace


AddCloud Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddCloud Method
RegisteredObjects Class Example See Also Send Feedback
Registers a new cloud storage client.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddCloud(
    Type obj,
    string text,
    int imageIndex
)
Visual Basic (Declaration)
Public Shared Sub AddCloud ( _
    obj As Type, _
    text As String, _
    imageIndex As Integer _
)
Visual C++
public:
static void AddCloud(
    Type^ obj,
    String^ text,
    int imageIndex
)

Parameters

obj
Type: System..::.Type
Type of cloud storage client.
text
Type: System..::.String
Text for cloud storage client's menu item.
imageIndex
Type: System..::.Int32
Index of image for object's button.

Remarks

The obj must be of CloudStorageClient type.

Examples

CopyC#
// register own cloud storage client
RegisteredObjects.AddCloud(typeof(MyCloud), "My Cloud", 238);

See Also

RegisteredObjects Class
FastReport.Utils Namespace


AddConnection Method

[image] [image]

FastReport.Net Class Reference
RegisteredObjects..::.AddConnection Method
RegisteredObjects Class See Also Send Feedback

Overload List

Name | Description
AddConnection(Type) | Registers data connection.
AddConnection(Type, String) | Registers custom data connection.

See Also

RegisteredObjects Class
RegisteredObjects Members
FastReport.Utils Namespace


AddConnection Method (Type)

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddConnection Method (Type)
RegisteredObjects Class Example See Also Send Feedback
Registers data connection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddConnection(
    Type obj
)
Visual Basic (Declaration)
Public Shared Sub AddConnection ( _
    obj As Type _
)
Visual C++
public:
static void AddConnection(
    Type^ obj
)

Parameters

obj
Type: System..::.Type
Type of connection.

Remarks

The obj must be of DataConnectionBase type.

Examples

CopyC#
// register data connection
RegisteredObjects.AddConnection(typeof(MsSqlDataConnection));

See Also

RegisteredObjects Class
AddConnection Overload
FastReport.Utils Namespace


AddConnection Method (Type, String)

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddConnection Method (Type, String)
RegisteredObjects Class Example See Also Send Feedback
Registers custom data connection.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddConnection(
    Type obj,
    string text
)
Visual Basic (Declaration)
Public Shared Sub AddConnection ( _
    obj As Type, _
    text As String _
)
Visual C++
public:
static void AddConnection(
    Type^ obj,
    String^ text
)

Parameters

obj
Type: System..::.Type
Type of connection.
text
Type: System..::.String
Name of connection.

Remarks

The obj must be of DataConnectionBase type.

Examples

CopyC#
// register data connection
RegisteredObjects.AddConnection(typeof(MyDataConnection), "My Data Connection");

See Also

RegisteredObjects Class
AddConnection Overload
FastReport.Utils Namespace


AddExport Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddExport Method
RegisteredObjects Class Example See Also Send Feedback
Registers a new export filter.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddExport(
    Type obj,
    string text
)
Visual Basic (Declaration)
Public Shared Sub AddExport ( _
    obj As Type, _
    text As String _
)
Visual C++
public:
static void AddExport(
    Type^ obj,
    String^ text
)

Parameters

obj
Type: System..::.Type
Type of export filter.
text
Type: System..::.String
Text for export filter's menu item.

Remarks

The obj must be of ExportBase type.

Examples

CopyC#
// register own export filter
RegisteredObjects.AddExport(typeof(MyExport), "My Export");

See Also

RegisteredObjects Class
FastReport.Utils Namespace


AddFunction Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddFunction Method
RegisteredObjects Class Example See Also Send Feedback
Adds a new function into the specified category.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddFunction(
    MethodInfo function,
    string category
)
Visual Basic (Declaration)
Public Shared Sub AddFunction ( _
    function As MethodInfo, _
    category As String _
)
Visual C++
public:
static void AddFunction(
    MethodInfo^ function,
    String^ category
)

Parameters

function
Type: System.Reflection..::.MethodInfo
MethodInfo containing all necessary information about the function.
category
Type: System..::.String
The name of category to register the function in.

Remarks

Your function must be a static, public method of a public class.

The following standard categories are registered by default:

  • "Math"
  • "Text"
  • "DateTime"
  • "Formatting"
  • "Conversion"
  • "ProgramFlow"
You may use one of the standard categories, or create a new category by the AddFunctionCategory(String, String) method call.

FastReport uses XML comments to display your function's description. To generate XML comments, enable it in your project's properties ("Project|Properties..." menu, "Build" tab, enable the "XML documentation file" checkbox).

Examples

The following example shows how to register own functions:
CopyC#
public static class MyFunctions
{
  /// <summary>
  /// Converts a specified string to uppercase.
  /// </summary>
  /// <param name="s">The string to convert.</param>
  /// <returns>A string in uppercase.</returns>
  public static string MyUpperCase(string s)
  {
    return s == null ? "" : s.ToUpper();
  }

  /// <summary>
  /// Returns the larger of two 32-bit signed integers.
  /// </summary>
  /// <param name="val1">The first of two values to compare.</param>
  /// <param name="val2">The second of two values to compare.</param>
  /// <returns>Parameter val1 or val2, whichever is larger.</returns>
  public static int MyMaximum(int val1, int val2)
  {
    return Math.Max(val1, val2);
  }

  /// <summary>
  /// Returns the larger of two 64-bit signed integers.
  /// </summary>
  /// <param name="val1">The first of two values to compare.</param>
  /// <param name="val2">The second of two values to compare.</param>
  /// <returns>Parameter val1 or val2, whichever is larger.</returns>
  public static long MyMaximum(long val1, long val2)
  {
    return Math.Max(val1, val2);
  }
}

// register a category
RegisteredObjects.AddFunctionCategory("MyFuncs", "My Functions");

// obtain MethodInfo for our functions
Type myType = typeof(MyFunctions);
MethodInfo myUpperCaseFunc = myType.GetMethod("MyUpperCase");
MethodInfo myMaximumIntFunc = myType.GetMethod("MyMaximum", new Type[] { typeof(int), typeof(int) });
MethodInfo myMaximumLongFunc = myType.GetMethod("MyMaximum", new Type[] { typeof(long), typeof(long) });

// register simple function
RegisteredObjects.AddFunction(myUpperCaseFunc, "MyFuncs");

// register overridden functions
RegisteredObjects.AddFunction(myMaximumIntFunc, "MyFuncs,MyMaximum");
RegisteredObjects.AddFunction(myMaximumLongFunc, "MyFuncs,MyMaximum");

See Also

RegisteredObjects Class
FastReport.Utils Namespace


AddFunctionCategory Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddFunctionCategory Method
RegisteredObjects Class Example See Also Send Feedback
Adds a new function category.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddFunctionCategory(
    string category,
    string text
)
Visual Basic (Declaration)
Public Shared Sub AddFunctionCategory ( _
    category As String, _
    text As String _
)
Visual C++
public:
static void AddFunctionCategory(
    String^ category,
    String^ text
)

Parameters

category
Type: System..::.String
Short name of category.
text
Type: System..::.String
Display name of category.

Remarks

Short name is used to reference the category in the subsequent AddFunction(MethodInfo, String) method call. It may be any value, for example, "MyFuncs". Display name of category is displayed in the "Data" window. In may be, for example, "My Functions".

The following standard categories are registered by default:

  • "Math"
  • "Text"
  • "DateTime"
  • "Formatting"
  • "Conversion"
  • "ProgramFlow"

Examples

This example shows how to register a new category:
CopyC#
RegisteredObjects.AddFunctionCategory("MyFuncs", "My Functions");

See Also

RegisteredObjects Class
FastReport.Utils Namespace


AddWizard Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.AddWizard Method
RegisteredObjects Class Example See Also Send Feedback
Registers a new wizard.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddWizard(
    Type obj,
    Bitmap image,
    string text,
    bool isReportItemWizard
)
Visual Basic (Declaration)
Public Shared Sub AddWizard ( _
    obj As Type, _
    image As Bitmap, _
    text As String, _
    isReportItemWizard As Boolean _
)
Visual C++
public:
static void AddWizard(
    Type^ obj,
    Bitmap^ image,
    String^ text,
    bool isReportItemWizard
)

Parameters

obj
Type: System..::.Type
Type of wizard.
image
Type: System.Drawing..::.Bitmap
Image for wizard item.
text
Type: System..::.String
Text for wizard item.
isReportItemWizard
Type: System..::.Boolean
true if this wizard creates some items in existing report.

Remarks

The obj must be of WizardBase type.

Examples

This example shows how to register own wizard that is used to create some items in the current report. If you want to register a wizard that will be used to create a new report, set the isReportItemWizard to false.
CopyC#
// register own wizard
RegisteredObjects.AddWizard(typeof(MyWizard), myWizBmp, "My Wizard", true);

See Also

RegisteredObjects Class
FastReport.Utils Namespace


FindObject Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.FindObject Method
RegisteredObjects Class See Also Send Feedback
Finds the registered object's info.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ObjectInfo FindObject(
    Type type
)
Visual Basic (Declaration)
Public Shared Function FindObject ( _
    type As Type _
) As ObjectInfo
Visual C++
public:
static ObjectInfo^ FindObject(
    Type^ type
)

Parameters

type
Type: System..::.Type
The type of object to find.

Return Value

The object's info.

Remarks

This method can be used to disable some objects, for example:

RegisteredObjects.FindObject(typeof(PDFExport)).Enabled = false;

See Also

RegisteredObjects Class
FastReport.Utils Namespace


IsTypeRegistered Method

[image]

FastReport.Net Class Reference
RegisteredObjects..::.IsTypeRegistered Method
RegisteredObjects Class See Also Send Feedback
Checks whether the specified type is registered already.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool IsTypeRegistered(
    Type obj
)
Visual Basic (Declaration)
Public Shared Function IsTypeRegistered ( _
    obj As Type _
) As Boolean
Visual C++
public:
static bool IsTypeRegistered(
    Type^ obj
)

Parameters

obj
Type: System..::.Type
Type to check.

Return Value

true if such type is registered.

See Also

RegisteredObjects Class
FastReport.Utils Namespace


RegisteredObjects Properties

[image] [image]

FastReport.Net Class Reference
RegisteredObjects Properties
RegisteredObjects Class See Also Send Feedback

The RegisteredObjects type exposes the following members.

Properties

Name | Description
Objects | Root object for all registered objects.

See Also

RegisteredObjects Class
FastReport.Utils Namespace


Objects Property

[image]

FastReport.Net Class Reference
RegisteredObjects..::.Objects Property
RegisteredObjects Class See Also Send Feedback
Root object for all registered objects.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ObjectInfo Objects { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Objects As ObjectInfo
Visual C++
public:
static property ObjectInfo^ Objects {
    ObjectInfo^ get ();
}

See Also

RegisteredObjects Class
FastReport.Utils Namespace


Res Class

[image]

FastReport.Net Class Reference
Res Class
Members See Also Send Feedback
Used to get localized values from the language resource file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Res
Visual Basic (Declaration)
Public NotInheritable Class Res
Visual C++
public ref class Res abstract sealed

Remarks

The resource file used by default is english. To load another locale, call the LoadLocale(String) method. It should be done at application start before you use any FastReport classes.

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Res

See Also

Res Members
FastReport.Utils Namespace


Res Members

[image] [image]

FastReport.Net Class Reference
Res Members
Res Class Methods Properties See Also Send Feedback

The Res type exposes the following members.

Methods

Name | Description
Get | Gets a string with specified ID.
GetIcon | Gets an image with specified index and converts it to Icon.
GetImage | Gets an image with specified index.
GetImages | Gets the standard images used in FastReport as an ImageList.
LoadEnglishLocale | Loads the english locale.
LoadLocale | Overloaded.
Set | Replaces the specified locale string with the new value.
StringExists | Checks if specified ID exists.
TryGet | Tries to get a string with specified ID.

Properties

Name | Description
LocaleFolder | Gets or set the folder that contains localization files (*.frl).
LocaleName | Returns the current UI locale name, for example "en".

See Also

Res Class
FastReport.Utils Namespace


Res Methods

[image] [image]

FastReport.Net Class Reference
Res Methods
Res Class See Also Send Feedback

The Res type exposes the following members.

Methods

Name | Description
Get | Gets a string with specified ID.
GetIcon | Gets an image with specified index and converts it to Icon.
GetImage | Gets an image with specified index.
GetImages | Gets the standard images used in FastReport as an ImageList.
LoadEnglishLocale | Loads the english locale.
LoadLocale | Overloaded.
Set | Replaces the specified locale string with the new value.
StringExists | Checks if specified ID exists.
TryGet | Tries to get a string with specified ID.

See Also

Res Class
FastReport.Utils Namespace


Get Method

[image]

FastReport.Net Class Reference
Res..::.Get Method
Res Class See Also Send Feedback
Gets a string with specified ID.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string Get(
    string id
)
Visual Basic (Declaration)
Public Shared Function Get ( _
    id As String _
) As String
Visual C++
public:
static String^ Get(
    String^ id
)

Parameters

id
Type: System..::.String
The resource ID.

Return Value

The localized string.

Remarks

Since the locale file is xml-based, it may contain several xml node levels. For example, the file contains the following items:
CopyC#
<Objects>
  <Report Text="Report"/>
  <Bands Text="Bands">
    <ReportTitle Text="Report Title"/>
  </Bands>
</Objects>
 To get the localized "ReportTitle" value, you should pass the following ID to this method: "Objects,Bands,ReportTitle".

See Also

Res Class
FastReport.Utils Namespace


GetIcon Method

[image]

FastReport.Net Class Reference
Res..::.GetIcon Method
Res Class See Also Send Feedback
Gets an image with specified index and converts it to Icon.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Icon GetIcon(
    int index
)
Visual Basic (Declaration)
Public Shared Function GetIcon ( _
    index As Integer _
) As Icon
Visual C++
public:
static Icon^ GetIcon(
    int index
)

Parameters

index
Type: System..::.Int32
Image index (zero-based).

Return Value

The Icon object.

See Also

Res Class
FastReport.Utils Namespace


GetImage Method

[image]

FastReport.Net Class Reference
Res..::.GetImage Method
Res Class See Also Send Feedback
Gets an image with specified index.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Bitmap GetImage(
    int index
)
Visual Basic (Declaration)
Public Shared Function GetImage ( _
    index As Integer _
) As Bitmap
Visual C++
public:
static Bitmap^ GetImage(
    int index
)

Parameters

index
Type: System..::.Int32
Image index (zero-based).

Return Value

The image with specified index.

Remarks

FastReport contains about 240 truecolor images of 16x16 size that are stored in one big image side-by-side. This image can be found in FastReport resources (the "buttons.png" resource).

See Also

Res Class
FastReport.Utils Namespace


GetImages Method

[image]

FastReport.Net Class Reference
Res..::.GetImages Method
Res Class See Also Send Feedback
Gets the standard images used in FastReport as an ImageList.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static ImageList GetImages()
Visual Basic (Declaration)
Public Shared Function GetImages As ImageList
Visual C++
public:
static ImageList^ GetImages()

Return Value

ImageList object that contains standard images.

Remarks

FastReport contains about 240 truecolor images of 16x16 size that are stored in one big image side-by-side. This image can be found in FastReport resources (the "buttons.png" resource).

See Also

Res Class
FastReport.Utils Namespace


LoadEnglishLocale Method

[image]

FastReport.Net Class Reference
Res..::.LoadEnglishLocale Method
Res Class See Also Send Feedback
Loads the english locale.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void LoadEnglishLocale()
Visual Basic (Declaration)
Public Shared Sub LoadEnglishLocale
Visual C++
public:
static void LoadEnglishLocale()

See Also

Res Class
FastReport.Utils Namespace


LoadLocale Method

[image] [image]

FastReport.Net Class Reference
Res..::.LoadLocale Method
Res Class See Also Send Feedback

Overload List

Name | Description
LoadLocale(Stream) | Loads the locale from a stream.
LoadLocale(String) | Loads the locale from a file.

See Also

Res Class
Res Members
FastReport.Utils Namespace


LoadLocale Method (Stream)

[image]

FastReport.Net Class Reference
Res..::.LoadLocale Method (Stream)
Res Class See Also Send Feedback
Loads the locale from a stream.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void LoadLocale(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Sub LoadLocale ( _
    stream As Stream _
)
Visual C++
public:
static void LoadLocale(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream that contains localized strings.

See Also

Res Class
LoadLocale Overload
FastReport.Utils Namespace


LoadLocale Method (String)

[image]

FastReport.Net Class Reference
Res..::.LoadLocale Method (String)
Res Class See Also Send Feedback
Loads the locale from a file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void LoadLocale(
    string fileName
)
Visual Basic (Declaration)
Public Shared Sub LoadLocale ( _
    fileName As String _
)
Visual C++
public:
static void LoadLocale(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file that contains localized strings.

See Also

Res Class
LoadLocale Overload
FastReport.Utils Namespace


Set Method

[image]

FastReport.Net Class Reference
Res..::.Set Method
Res Class Example See Also Send Feedback
Replaces the specified locale string with the new value.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static void Set(
    string id,
    string value
)
Visual Basic (Declaration)
Public Shared Sub Set ( _
    id As String, _
    value As String _
)
Visual C++
public:
static void Set(
    String^ id,
    String^ value
)

Parameters

id
Type: System..::.String
Comma-separated path to the existing locale string.
value
Type: System..::.String
The new string.

Remarks

Use this method if you want to replace some existing locale value with the new one.

Examples

CopyC#
Res.Set("Messages,SaveChanges", "My text that will appear when you close the designer");

See Also

Res Class
FastReport.Utils Namespace


StringExists Method

[image]

FastReport.Net Class Reference
Res..::.StringExists Method
Res Class See Also Send Feedback
Checks if specified ID exists.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static bool StringExists(
    string id
)
Visual Basic (Declaration)
Public Shared Function StringExists ( _
    id As String _
) As Boolean
Visual C++
public:
static bool StringExists(
    String^ id
)

Parameters

id
Type: System..::.String
The resource ID.

Return Value

true if specified ID exists.

See Also

Res Class
FastReport.Utils Namespace


TryGet Method

[image]

FastReport.Net Class Reference
Res..::.TryGet Method
Res Class See Also Send Feedback
Tries to get a string with specified ID.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string TryGet(
    string id
)
Visual Basic (Declaration)
Public Shared Function TryGet ( _
    id As String _
) As String
Visual C++
public:
static String^ TryGet(
    String^ id
)

Parameters

id
Type: System..::.String
The resource ID.

Return Value

The localized value, if specified ID exists; otherwise, the ID itself.

See Also

Res Class
FastReport.Utils Namespace


Res Properties

[image] [image]

FastReport.Net Class Reference
Res Properties
Res Class See Also Send Feedback

The Res type exposes the following members.

Properties

Name | Description
LocaleFolder | Gets or set the folder that contains localization files (*.frl).
LocaleName | Returns the current UI locale name, for example "en".

See Also

Res Class
FastReport.Utils Namespace


LocaleFolder Property

[image]

FastReport.Net Class Reference
Res..::.LocaleFolder Property
Res Class See Also Send Feedback
Gets or set the folder that contains localization files (*.frl).

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string LocaleFolder { get; set; }
Visual Basic (Declaration)
Public Shared Property LocaleFolder As String
Visual C++
public:
static property String^ LocaleFolder {
    String^ get ();
    void set (String^ value);
}

See Also

Res Class
FastReport.Utils Namespace


LocaleName Property

[image]

FastReport.Net Class Reference
Res..::.LocaleName Property
Res Class See Also Send Feedback
Returns the current UI locale name, for example "en".

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static string LocaleName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LocaleName As String
Visual C++
public:
static property String^ LocaleName {
    String^ get ();
}

See Also

Res Class
FastReport.Utils Namespace


ResourceLoader Class

[image]

FastReport.Net Class Reference
ResourceLoader Class
Members See Also Send Feedback
Resource loader class.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class ResourceLoader
Visual Basic (Declaration)
Public NotInheritable Class ResourceLoader
Visual C++
public ref class ResourceLoader abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.ResourceLoader

See Also

ResourceLoader Members
FastReport.Utils Namespace


ResourceLoader Members

[image] [image]

FastReport.Net Class Reference
ResourceLoader Members
ResourceLoader Class Methods See Also Send Feedback

Methods

Name | Description
GetBitmap | Overloaded.
GetCursor | Overloaded.
GetIcon | Overloaded.
GetStream | Overloaded.
UnpackStream | Overloaded.

See Also

ResourceLoader Class
FastReport.Utils Namespace


ResourceLoader Methods

[image] [image]

FastReport.Net Class Reference
ResourceLoader Methods
ResourceLoader Class See Also Send Feedback

Methods

Name | Description
GetBitmap | Overloaded.
GetCursor | Overloaded.
GetIcon | Overloaded.
GetStream | Overloaded.
UnpackStream | Overloaded.

See Also

ResourceLoader Class
FastReport.Utils Namespace


GetBitmap Method

[image] [image]

FastReport.Net Class Reference
ResourceLoader..::.GetBitmap Method
ResourceLoader Class See Also Send Feedback

Overload List

Name | Description
GetBitmap(String) | Gets a bitmap from specified FastReport assembly resource.
GetBitmap(String, String) | Gets a bitmap from specified assembly resource.

See Also

ResourceLoader Class
ResourceLoader Members
FastReport.Utils Namespace


GetBitmap Method (String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetBitmap Method (String)
ResourceLoader Class See Also Send Feedback
Gets a bitmap from specified FastReport assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Bitmap GetBitmap(
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetBitmap ( _
    resource As String _
) As Bitmap
Visual C++
public:
static Bitmap^ GetBitmap(
    String^ resource
)

Parameters

resource
Type: System..::.String
Resource name.

Return Value

Bitmap object.

See Also

ResourceLoader Class
GetBitmap Overload
FastReport.Utils Namespace


GetBitmap Method (String, String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetBitmap Method (String, String)
ResourceLoader Class See Also Send Feedback
Gets a bitmap from specified assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Bitmap GetBitmap(
    string assembly,
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetBitmap ( _
    assembly As String, _
    resource As String _
) As Bitmap
Visual C++
public:
static Bitmap^ GetBitmap(
    String^ assembly,
    String^ resource
)

Parameters

assembly
Type: System..::.String
Assembly name.
resource
Type: System..::.String
Resource name.

Return Value

Bitmap object.

See Also

ResourceLoader Class
GetBitmap Overload
FastReport.Utils Namespace


GetCursor Method

[image] [image]

FastReport.Net Class Reference
ResourceLoader..::.GetCursor Method
ResourceLoader Class See Also Send Feedback

Overload List

Name | Description
GetCursor(String) | Gets a cursor from specified FastReport assembly resource.
GetCursor(String, String) | Gets a cursor from specified assembly resource.

See Also

ResourceLoader Class
ResourceLoader Members
FastReport.Utils Namespace


GetCursor Method (String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetCursor Method (String)
ResourceLoader Class See Also Send Feedback
Gets a cursor from specified FastReport assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Cursor GetCursor(
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetCursor ( _
    resource As String _
) As Cursor
Visual C++
public:
static Cursor^ GetCursor(
    String^ resource
)

Parameters

resource
Type: System..::.String
Resource name.

Return Value

Cursor object.

See Also

ResourceLoader Class
GetCursor Overload
FastReport.Utils Namespace


GetCursor Method (String, String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetCursor Method (String, String)
ResourceLoader Class See Also Send Feedback
Gets a cursor from specified assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Cursor GetCursor(
    string assembly,
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetCursor ( _
    assembly As String, _
    resource As String _
) As Cursor
Visual C++
public:
static Cursor^ GetCursor(
    String^ assembly,
    String^ resource
)

Parameters

assembly
Type: System..::.String
Assembly name.
resource
Type: System..::.String
Resource name.

Return Value

Cursor object.

See Also

ResourceLoader Class
GetCursor Overload
FastReport.Utils Namespace


GetIcon Method

[image] [image]

FastReport.Net Class Reference
ResourceLoader..::.GetIcon Method
ResourceLoader Class See Also Send Feedback

Overload List

Name | Description
GetIcon(String) | Gets an icon from specified FastReport assembly resource.
GetIcon(String, String) | Gets an icon from specified assembly resource.

See Also

ResourceLoader Class
ResourceLoader Members
FastReport.Utils Namespace


GetIcon Method (String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetIcon Method (String)
ResourceLoader Class See Also Send Feedback
Gets an icon from specified FastReport assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Icon GetIcon(
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetIcon ( _
    resource As String _
) As Icon
Visual C++
public:
static Icon^ GetIcon(
    String^ resource
)

Parameters

resource
Type: System..::.String
Resource name.

Return Value

Icon object.

See Also

ResourceLoader Class
GetIcon Overload
FastReport.Utils Namespace


GetIcon Method (String, String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetIcon Method (String, String)
ResourceLoader Class See Also Send Feedback
Gets an icon from specified assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Icon GetIcon(
    string assembly,
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetIcon ( _
    assembly As String, _
    resource As String _
) As Icon
Visual C++
public:
static Icon^ GetIcon(
    String^ assembly,
    String^ resource
)

Parameters

assembly
Type: System..::.String
Assembly name.
resource
Type: System..::.String
Resource name.

Return Value

Icon object.

See Also

ResourceLoader Class
GetIcon Overload
FastReport.Utils Namespace


GetStream Method

[image] [image]

FastReport.Net Class Reference
ResourceLoader..::.GetStream Method
ResourceLoader Class See Also Send Feedback

Overload List

Name | Description
GetStream(String) | Gets a stream from FastReport assembly resource.
GetStream(String, String) | Gets a stream from specified assembly resource.

See Also

ResourceLoader Class
ResourceLoader Members
FastReport.Utils Namespace


GetStream Method (String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetStream Method (String)
ResourceLoader Class See Also Send Feedback
Gets a stream from FastReport assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Stream GetStream(
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetStream ( _
    resource As String _
) As Stream
Visual C++
public:
static Stream^ GetStream(
    String^ resource
)

Parameters

resource
Type: System..::.String
Resource name.

Return Value

Stream object.

See Also

ResourceLoader Class
GetStream Overload
FastReport.Utils Namespace


GetStream Method (String, String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.GetStream Method (String, String)
ResourceLoader Class See Also Send Feedback
Gets a stream from specified assembly resource.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Stream GetStream(
    string assembly,
    string resource
)
Visual Basic (Declaration)
Public Shared Function GetStream ( _
    assembly As String, _
    resource As String _
) As Stream
Visual C++
public:
static Stream^ GetStream(
    String^ assembly,
    String^ resource
)

Parameters

assembly
Type: System..::.String
Assembly name.
resource
Type: System..::.String
Resource name.

Return Value

Stream object.

See Also

ResourceLoader Class
GetStream Overload
FastReport.Utils Namespace


UnpackStream Method

[image] [image]

FastReport.Net Class Reference
ResourceLoader..::.UnpackStream Method
ResourceLoader Class See Also Send Feedback

Overload List

Name | Description
UnpackStream(String) | Gets a stream from specified FastReport assembly resource and unpacks it.
UnpackStream(String, String) | Gets a stream from specified assembly resource and unpacks it.

See Also

ResourceLoader Class
ResourceLoader Members
FastReport.Utils Namespace


UnpackStream Method (String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.UnpackStream Method (String)
ResourceLoader Class See Also Send Feedback
Gets a stream from specified FastReport assembly resource and unpacks it.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Stream UnpackStream(
    string resource
)
Visual Basic (Declaration)
Public Shared Function UnpackStream ( _
    resource As String _
) As Stream
Visual C++
public:
static Stream^ UnpackStream(
    String^ resource
)

Parameters

resource
Type: System..::.String
Resource name.

Return Value

Stream object.

See Also

ResourceLoader Class
UnpackStream Overload
FastReport.Utils Namespace


UnpackStream Method (String, String)

[image]

FastReport.Net Class Reference
ResourceLoader..::.UnpackStream Method (String, String)
ResourceLoader Class See Also Send Feedback
Gets a stream from specified assembly resource and unpacks it.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Stream UnpackStream(
    string assembly,
    string resource
)
Visual Basic (Declaration)
Public Shared Function UnpackStream ( _
    assembly As String, _
    resource As String _
) As Stream
Visual C++
public:
static Stream^ UnpackStream(
    String^ assembly,
    String^ resource
)

Parameters

assembly
Type: System..::.String
Assembly name.
resource
Type: System..::.String
Resource name.

Return Value

Stream object.

See Also

ResourceLoader Class
UnpackStream Overload
FastReport.Utils Namespace


SelectionPoint Class

[image]

FastReport.Net Class Reference
SelectionPoint Class
Members See Also Send Feedback
Specifies a selection point used to resize an object.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SelectionPoint
Visual Basic (Declaration)
Public Class SelectionPoint
Visual C++
public ref class SelectionPoint

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.SelectionPoint

See Also

SelectionPoint Members
FastReport.Utils Namespace


SelectionPoint Members

[image] [image]

FastReport.Net Class Reference
SelectionPoint Members
SelectionPoint Class Constructors Methods Fields See Also Send Feedback

The SelectionPoint type exposes the following members.

Constructors

Name | Description
SelectionPoint | Initializes a new instance of the SelectionPoint class with specified location and size mode.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SizingPoint | The size mode.
X | The X coordinate of the point.
Y | The Y coordinate of the point.

See Also

SelectionPoint Class
FastReport.Utils Namespace


SelectionPoint Constructor

[image]

FastReport.Net Class Reference
SelectionPoint Constructor
SelectionPoint Class See Also Send Feedback
Initializes a new instance of the SelectionPoint class with specified location and size mode.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SelectionPoint(
    float x,
    float y,
    SizingPoint pt
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Single, _
    y As Single, _
    pt As SizingPoint _
)
Visual C++
public:
SelectionPoint(
    float x,
    float y,
    SizingPoint pt
)

Parameters

x
Type: System..::.Single
The X coordinate.
y
Type: System..::.Single
The Y coordinate.
pt
Type: FastReport.Utils..::.SizingPoint
Size mode.

See Also

SelectionPoint Class
FastReport.Utils Namespace


SelectionPoint Fields

[image] [image]

FastReport.Net Class Reference
SelectionPoint Fields
SelectionPoint Class See Also Send Feedback

The SelectionPoint type exposes the following members.

Fields

Name | Description
SizingPoint | The size mode.
X | The X coordinate of the point.
Y | The Y coordinate of the point.

See Also

SelectionPoint Class
FastReport.Utils Namespace


SizingPoint Field

[image]

FastReport.Net Class Reference
SelectionPoint..::.SizingPoint Field
SelectionPoint Class See Also Send Feedback
The size mode.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SizingPoint SizingPoint
Visual Basic (Declaration)
Public SizingPoint As SizingPoint
Visual C++
public:
SizingPoint SizingPoint

See Also

SelectionPoint Class
FastReport.Utils Namespace


X Field

[image]

FastReport.Net Class Reference
SelectionPoint..::.X Field
SelectionPoint Class See Also Send Feedback
The X coordinate of the point.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float X
Visual Basic (Declaration)
Public X As Single
Visual C++
public:
float X

See Also

SelectionPoint Class
FastReport.Utils Namespace


Y Field

[image]

FastReport.Net Class Reference
SelectionPoint..::.Y Field
SelectionPoint Class See Also Send Feedback
The Y coordinate of the point.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public float Y
Visual Basic (Declaration)
Public Y As Single
Visual C++
public:
float Y

See Also

SelectionPoint Class
FastReport.Utils Namespace


SelectionPoint Methods

[image] [image]

FastReport.Net Class Reference
SelectionPoint Methods
SelectionPoint Class See Also Send Feedback

The SelectionPoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionPoint Class
FastReport.Utils Namespace


SerializeTo Enumeration

[image]

FastReport.Net Class Reference
SerializeTo Enumeration
See Also Send Feedback
Specifies the target for the serialize operation.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum SerializeTo
Visual Basic (Declaration)
Public Enumeration SerializeTo
Visual C++
public enum class SerializeTo

Members

Member name | Description
Report | Serialize to the report file.
Preview | Serialize to the preview pages.
SourcePages | Serialize to the source pages of a preview.
Clipboard | Serialize to the designer's clipboard.
Undo | Serialize to the designer's undo/redo buffer.

See Also

FastReport.Utils Namespace


SizingPoint Enumeration

[image]

FastReport.Net Class Reference
SizingPoint Enumeration
See Also Send Feedback
Specifies the sizing point used to resize an object by mouse.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum SizingPoint
Visual Basic (Declaration)
Public Enumeration SizingPoint
Visual C++
public enum class SizingPoint

Members

Member name | Description
None | No sizing point.
LeftTop | Specifies left-top sizing point.
LeftBottom | Specifies left-bottom sizing point.
RightTop | Specifies right-top sizing point.
RightBottom | Specifies right-bottom sizing point.
TopCenter | Specifies top-center sizing point.
BottomCenter | Specifies bottom-center sizing point.
LeftCenter | Specifies left-center sizing point.
RightCenter | Specifies right-center sizing point.

See Also

FastReport.Utils Namespace


SRCategory Class

[image]

FastReport.Net Class Reference
SRCategory Class
Members See Also Send Feedback
Localized CategoryAttribute class.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class SRCategory : CategoryAttribute
Visual Basic (Declaration)
Public Class SRCategory _
    Inherits CategoryAttribute
Visual C++
public ref class SRCategory : public CategoryAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
System.ComponentModel..::.CategoryAttribute
FastReport.Utils..::.SRCategory

See Also

SRCategory Members
FastReport.Utils Namespace


SRCategory Members

[image] [image]

FastReport.Net Class Reference
SRCategory Members
SRCategory Class Constructors Methods Properties See Also Send Feedback

The SRCategory type exposes the following members.

Constructors

Name | Description
SRCategory | Initializes a new instance of the SRCategory class.

Methods

Name | Description
Equals | Returns whether the value of the given object is equal to the current CategoryAttribute.. (Inherited from CategoryAttribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this attribute. (Inherited from CategoryAttribute.)
GetLocalizedString | Looks up the localized name of the specified category. (Overrides CategoryAttribute..::.GetLocalizedString(String).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | Determines if this attribute is the default. (Inherited from CategoryAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Category | Gets the name of the category for the property or event that this attribute is applied to. (Inherited from CategoryAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SRCategory Class
FastReport.Utils Namespace


SRCategory Constructor

[image]

FastReport.Net Class Reference
SRCategory Constructor
SRCategory Class See Also Send Feedback
Initializes a new instance of the SRCategory class.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public SRCategory(
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String _
)
Visual C++
public:
SRCategory(
    String^ value
)

Parameters

value
Type: System..::.String
The category name.

See Also

SRCategory Class
FastReport.Utils Namespace


SRCategory Methods

[image] [image]

FastReport.Net Class Reference
SRCategory Methods
SRCategory Class See Also Send Feedback

The SRCategory type exposes the following members.

Methods

Name | Description
Equals | Returns whether the value of the given object is equal to the current CategoryAttribute.. (Inherited from CategoryAttribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this attribute. (Inherited from CategoryAttribute.)
GetLocalizedString | Looks up the localized name of the specified category. (Overrides CategoryAttribute..::.GetLocalizedString(String).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | Determines if this attribute is the default. (Inherited from CategoryAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SRCategory Class
FastReport.Utils Namespace


GetLocalizedString Method

[image]

FastReport.Net Class Reference
SRCategory..::.GetLocalizedString Method
SRCategory Class See Also Send Feedback
Looks up the localized name of the specified category.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected override string GetLocalizedString(
    string value
)
Visual Basic (Declaration)
Protected Overrides Function GetLocalizedString ( _
    value As String _
) As String
Visual C++
protected:
virtual String^ GetLocalizedString(
    String^ value
) override

Parameters

value
Type: System..::.String
The identifer for the category to look up.

Return Value

The localized name of the category, or null if a localized name does not exist.

See Also

SRCategory Class
FastReport.Utils Namespace


SRCategory Properties

[image] [image]

FastReport.Net Class Reference
SRCategory Properties
SRCategory Class See Also Send Feedback

The SRCategory type exposes the following members.

Properties

Name | Description
Category | Gets the name of the category for the property or event that this attribute is applied to. (Inherited from CategoryAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SRCategory Class
FastReport.Utils Namespace


TableManualBuildException Class

[image]

FastReport.Net Class Reference
TableManualBuildException Class
Members See Also Send Feedback
The exception that is thrown if an error occurs in the TableObject.ManualBuild event.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class TableManualBuildException : Exception
Visual Basic (Declaration)
Public Class TableManualBuildException _
    Inherits Exception
Visual C++
public ref class TableManualBuildException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
FastReport.Utils..::.TableManualBuildException

See Also

TableManualBuildException Members
FastReport.Utils Namespace


TableManualBuildException Members

[image] [image]

FastReport.Net Class Reference
TableManualBuildException Members
TableManualBuildException Class Methods Properties See Also Send Feedback

The TableManualBuildException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TableManualBuildException Class
FastReport.Utils Namespace


TableManualBuildException Methods

[image] [image]

FastReport.Net Class Reference
TableManualBuildException Methods
TableManualBuildException Class See Also Send Feedback

The TableManualBuildException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TableManualBuildException Class
FastReport.Utils Namespace


TableManualBuildException Properties

[image] [image]

FastReport.Net Class Reference
TableManualBuildException Properties
TableManualBuildException Class See Also Send Feedback

The TableManualBuildException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TableManualBuildException Class
FastReport.Utils Namespace


UIStyle Enumeration

[image]

FastReport.Net Class Reference
UIStyle Enumeration
See Also Send Feedback
The style of FastReport user interface.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum UIStyle
Visual Basic (Declaration)
Public Enumeration UIStyle
Visual C++
public enum class UIStyle

Members

Member name | Description
VisualStudio2005 | Specifies the Microsoft Visual Studio 2005 style.
Office2003 | Specifies the Microsoft Office 2003 style (blue).
Office2007Blue | Specifies the Microsoft Office 2007 style (blue).
Office2007Silver | Specifies the Microsoft Office 2007 style (silver).
Office2007Black | Specifies the Microsoft Office 2007 style (black).
VistaGlass | Specifies the Microsoft Vista style (black).

See Also

FastReport.Utils Namespace


UIStyleUtils Class

[image]

FastReport.Net Class Reference
UIStyleUtils Class
Members See Also Send Feedback
Contains conversion methods between FastReport's UIStyle to various enums.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class UIStyleUtils
Visual Basic (Declaration)
Public NotInheritable Class UIStyleUtils
Visual C++
public ref class UIStyleUtils abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.UIStyleUtils

See Also

UIStyleUtils Members
FastReport.Utils Namespace


UIStyleUtils Members

[image] [image]

FastReport.Net Class Reference
UIStyleUtils Members
UIStyleUtils Class Methods See Also Send Feedback

The UIStyleUtils type exposes the following members.

Methods

Name | Description
GetAppWorkspaceColor | Returns app workspace color for the given style.
GetColorSchemeStyle | Converts FastReport's UIStyle to eColorSchemeStyle.
GetControlColor | Returns control color for the given style.
GetDotNetBarStyle | Converts FastReport's UIStyle to eDotNetBarStyle.
GetOffice2007ColorScheme | Converts FastReport's UIStyle to eOffice2007ColorScheme.
GetTabStripStyle | Converts FastReport's UIStyle to eTabStripStyle.
GetTabStripStyle1 | Converts FastReport's UIStyle to eTabStripStyle.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


UIStyleUtils Methods

[image] [image]

FastReport.Net Class Reference
UIStyleUtils Methods
UIStyleUtils Class See Also Send Feedback

The UIStyleUtils type exposes the following members.

Methods

Name | Description
GetAppWorkspaceColor | Returns app workspace color for the given style.
GetColorSchemeStyle | Converts FastReport's UIStyle to eColorSchemeStyle.
GetControlColor | Returns control color for the given style.
GetDotNetBarStyle | Converts FastReport's UIStyle to eDotNetBarStyle.
GetOffice2007ColorScheme | Converts FastReport's UIStyle to eOffice2007ColorScheme.
GetTabStripStyle | Converts FastReport's UIStyle to eTabStripStyle.
GetTabStripStyle1 | Converts FastReport's UIStyle to eTabStripStyle.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetAppWorkspaceColor Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetAppWorkspaceColor Method
UIStyleUtils Class See Also Send Feedback
Returns app workspace color for the given style.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Color GetAppWorkspaceColor(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetAppWorkspaceColor ( _
    style As UIStyle _
) As Color
Visual C++
public:
static Color GetAppWorkspaceColor(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
UI style.

Return Value

The color.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetColorSchemeStyle Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetColorSchemeStyle Method
UIStyleUtils Class See Also Send Feedback
Converts FastReport's UIStyle to eColorSchemeStyle.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static eColorSchemeStyle GetColorSchemeStyle(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetColorSchemeStyle ( _
    style As UIStyle _
) As eColorSchemeStyle
Visual C++
public:
static eColorSchemeStyle GetColorSchemeStyle(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
Style to convert.

Return Value

Value of eColorSchemeStyle type.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetControlColor Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetControlColor Method
UIStyleUtils Class See Also Send Feedback
Returns control color for the given style.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static Color GetControlColor(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetControlColor ( _
    style As UIStyle _
) As Color
Visual C++
public:
static Color GetControlColor(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
UI style.

Return Value

The color.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetDotNetBarStyle Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetDotNetBarStyle Method
UIStyleUtils Class See Also Send Feedback
Converts FastReport's UIStyle to eDotNetBarStyle.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static eDotNetBarStyle GetDotNetBarStyle(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetDotNetBarStyle ( _
    style As UIStyle _
) As eDotNetBarStyle
Visual C++
public:
static eDotNetBarStyle GetDotNetBarStyle(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
Style to convert.

Return Value

Value of eDotNetBarStyle type.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetOffice2007ColorScheme Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetOffice2007ColorScheme Method
UIStyleUtils Class See Also Send Feedback
Converts FastReport's UIStyle to eOffice2007ColorScheme.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static eOffice2007ColorScheme GetOffice2007ColorScheme(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetOffice2007ColorScheme ( _
    style As UIStyle _
) As eOffice2007ColorScheme
Visual C++
public:
static eOffice2007ColorScheme GetOffice2007ColorScheme(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
Style to convert.

Return Value

Value of eOffice2007ColorScheme type.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetTabStripStyle Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetTabStripStyle Method
UIStyleUtils Class See Also Send Feedback
Converts FastReport's UIStyle to eTabStripStyle.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static eTabStripStyle GetTabStripStyle(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetTabStripStyle ( _
    style As UIStyle _
) As eTabStripStyle
Visual C++
public:
static eTabStripStyle GetTabStripStyle(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
Style to convert.

Return Value

Value of eTabStripStyle type.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


GetTabStripStyle1 Method

[image]

FastReport.Net Class Reference
UIStyleUtils..::.GetTabStripStyle1 Method
UIStyleUtils Class See Also Send Feedback
Converts FastReport's UIStyle to eTabStripStyle.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static eTabStripStyle GetTabStripStyle1(
    UIStyle style
)
Visual Basic (Declaration)
Public Shared Function GetTabStripStyle1 ( _
    style As UIStyle _
) As eTabStripStyle
Visual C++
public:
static eTabStripStyle GetTabStripStyle1(
    UIStyle style
)

Parameters

style
Type: FastReport.Utils..::.UIStyle
Style to convert.

Return Value

Value of eTabStripStyle type.

See Also

UIStyleUtils Class
FastReport.Utils Namespace


Units Class

[image]

FastReport.Net Class Reference
Units Class
Members See Also Send Feedback
Defines the constants used to convert between report units and screen pixels.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static class Units
Visual Basic (Declaration)
Public NotInheritable Class Units
Visual C++
public ref class Units abstract sealed

Remarks

To convert pixels to millimeters, use the following code:
CopyC#
valueInMillimeters = valueInPixels / Units.Millimeters;
 To convert millimeters to pixels, use the following code:
CopyC#
valueInPixels = valueInMillimeters * Units.Millimeters;

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.Units

See Also

Units Members
FastReport.Utils Namespace


Units Members

[image] [image]

FastReport.Net Class Reference
Units Members
Units Class Fields See Also Send Feedback

The Units type exposes the following members.

Fields

Name | Description
Centimeters | The number of pixels in one centimeter.
HundrethsOfInch | The number of pixels in 1/100 of inch.
Inches | The number of pixels in one inch.
Millimeters | The number of pixels in one millimeter.
TenthsOfInch | The number of pixels in 1/10 of ich.

See Also

Units Class
FastReport.Utils Namespace


Units Fields

[image] [image]

FastReport.Net Class Reference
Units Fields
Units Class See Also Send Feedback

The Units type exposes the following members.

Fields

Name | Description
Centimeters | The number of pixels in one centimeter.
HundrethsOfInch | The number of pixels in 1/100 of inch.
Inches | The number of pixels in one inch.
Millimeters | The number of pixels in one millimeter.
TenthsOfInch | The number of pixels in 1/10 of ich.

See Also

Units Class
FastReport.Utils Namespace


Centimeters Field

[image]

FastReport.Net Class Reference
Units..::.Centimeters Field
Units Class See Also Send Feedback
The number of pixels in one centimeter.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float Centimeters
Visual Basic (Declaration)
Public Shared Centimeters As Single
Visual C++
public:
static float Centimeters

See Also

Units Class
FastReport.Utils Namespace


HundrethsOfInch Field

[image]

FastReport.Net Class Reference
Units..::.HundrethsOfInch Field
Units Class See Also Send Feedback
The number of pixels in 1/100 of inch.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float HundrethsOfInch
Visual Basic (Declaration)
Public Shared HundrethsOfInch As Single
Visual C++
public:
static float HundrethsOfInch

See Also

Units Class
FastReport.Utils Namespace


Inches Field

[image]

FastReport.Net Class Reference
Units..::.Inches Field
Units Class See Also Send Feedback
The number of pixels in one inch.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float Inches
Visual Basic (Declaration)
Public Shared Inches As Single
Visual C++
public:
static float Inches

See Also

Units Class
FastReport.Utils Namespace


Millimeters Field

[image]

FastReport.Net Class Reference
Units..::.Millimeters Field
Units Class See Also Send Feedback
The number of pixels in one millimeter.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float Millimeters
Visual Basic (Declaration)
Public Shared Millimeters As Single
Visual C++
public:
static float Millimeters

See Also

Units Class
FastReport.Utils Namespace


TenthsOfInch Field

[image]

FastReport.Net Class Reference
Units..::.TenthsOfInch Field
Units Class See Also Send Feedback
The number of pixels in 1/10 of ich.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public static float TenthsOfInch
Visual Basic (Declaration)
Public Shared TenthsOfInch As Single
Visual C++
public:
static float TenthsOfInch

See Also

Units Class
FastReport.Utils Namespace


WorkspaceMode1 Enumeration

[image]

FastReport.Net Class Reference
WorkspaceMode1 Enumeration
See Also Send Feedback
Specifies the main mode of the designer's workspace.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum WorkspaceMode1
Visual Basic (Declaration)
Public Enumeration WorkspaceMode1
Visual C++
public enum class WorkspaceMode1

Members

Member name | Description
Select | Specifies selection mode.
Insert | Specifies insertion mode.
DragDrop | Specifies drag-drop mode.

See Also

FastReport.Utils Namespace


WorkspaceMode2 Enumeration

[image]

FastReport.Net Class Reference
WorkspaceMode2 Enumeration
See Also Send Feedback
Specifies the additional mode of the designer's workspace.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public enum WorkspaceMode2
Visual Basic (Declaration)
Public Enumeration WorkspaceMode2
Visual C++
public enum class WorkspaceMode2

Members

Member name | Description
None | Specifies default mode.
Move | Indicates that user moves the selected objects.
Size | Indicates that user resizes the selected objects.
SelectionRect | Indicates that user draw the selection rectangle.
Custom | Specifies a custom mode handled by the object.

See Also

FastReport.Utils Namespace


XmlDocument Class

[image]

FastReport.Net Class Reference
XmlDocument Class
Members See Also Send Feedback
Represents a xml document that contains the root xml node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class XmlDocument : IDisposable
Visual Basic (Declaration)
Public Class XmlDocument _
    Implements IDisposable
Visual C++
public ref class XmlDocument : IDisposable

Remarks

Use Load and Save methods to load/save the document. To access the root node of the document, use the Root property.

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.XmlDocument

See Also

XmlDocument Members
FastReport.Utils Namespace


XmlDocument Members

[image] [image]

FastReport.Net Class Reference
XmlDocument Members
XmlDocument Class Constructors Methods Properties See Also Send Feedback

The XmlDocument type exposes the following members.

Constructors

Name | Description
XmlDocument | Initializes a new instance of the XmlDocument class with default settings.

Methods

Name | Description
Clear | Clears the document.
Dispose | Disposes resources used by the document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoIndent | Gets or sets a value indicating whether is necessary to indent the document when saving it to a file/stream.
Root | Gets the root node of the document.

See Also

XmlDocument Class
FastReport.Utils Namespace


XmlDocument Constructor

[image]

FastReport.Net Class Reference
XmlDocument Constructor
XmlDocument Class See Also Send Feedback
Initializes a new instance of the XmlDocument class with default settings.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlDocument()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlDocument()

See Also

XmlDocument Class
FastReport.Utils Namespace


XmlDocument Methods

[image] [image]

FastReport.Net Class Reference
XmlDocument Methods
XmlDocument Class See Also Send Feedback

The XmlDocument type exposes the following members.

Methods

Name | Description
Clear | Clears the document.
Dispose | Disposes resources used by the document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlDocument Class
FastReport.Utils Namespace


Clear Method

[image]

FastReport.Net Class Reference
XmlDocument..::.Clear Method
XmlDocument Class See Also Send Feedback
Clears the document.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

XmlDocument Class
FastReport.Utils Namespace


Dispose Method

[image]

FastReport.Net Class Reference
XmlDocument..::.Dispose Method
XmlDocument Class See Also Send Feedback
Disposes resources used by the document.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

XmlDocument Class
FastReport.Utils Namespace


Load Method

[image] [image]

FastReport.Net Class Reference
XmlDocument..::.Load Method
XmlDocument Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads the document from a stream.
Load(String) | Loads the document from a file.

See Also

XmlDocument Class
XmlDocument Members
FastReport.Utils Namespace


Load Method (Stream)

[image]

FastReport.Net Class Reference
XmlDocument..::.Load Method (Stream)
XmlDocument Class See Also Send Feedback
Loads the document from a stream.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to load from.

See Also

XmlDocument Class
Load Overload
FastReport.Utils Namespace


Load Method (String)

[image]

FastReport.Net Class Reference
XmlDocument..::.Load Method (String)
XmlDocument Class See Also Send Feedback
Loads the document from a file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of file to load from.

See Also

XmlDocument Class
Load Overload
FastReport.Utils Namespace


Save Method

[image] [image]

FastReport.Net Class Reference
XmlDocument..::.Save Method
XmlDocument Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves the document to a stream.
Save(String) | Saves the document to a file.

See Also

XmlDocument Class
XmlDocument Members
FastReport.Utils Namespace


Save Method (Stream)

[image]

FastReport.Net Class Reference
XmlDocument..::.Save Method (Stream)
XmlDocument Class See Also Send Feedback
Saves the document to a stream.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to save to.

See Also

XmlDocument Class
Save Overload
FastReport.Utils Namespace


Save Method (String)

[image]

FastReport.Net Class Reference
XmlDocument..::.Save Method (String)
XmlDocument Class See Also Send Feedback
Saves the document to a file.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of file to save to.

See Also

XmlDocument Class
Save Overload
FastReport.Utils Namespace


XmlDocument Properties

[image] [image]

FastReport.Net Class Reference
XmlDocument Properties
XmlDocument Class See Also Send Feedback

The XmlDocument type exposes the following members.

Properties

Name | Description
AutoIndent | Gets or sets a value indicating whether is necessary to indent the document when saving it to a file/stream.
Root | Gets the root node of the document.

See Also

XmlDocument Class
FastReport.Utils Namespace


AutoIndent Property

[image]

FastReport.Net Class Reference
XmlDocument..::.AutoIndent Property
XmlDocument Class See Also Send Feedback
Gets or sets a value indicating whether is necessary to indent the document when saving it to a file/stream.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoIndent { get; set; }
Visual Basic (Declaration)
Public Property AutoIndent As Boolean
Visual C++
public:
property bool AutoIndent {
    bool get ();
    void set (bool value);
}

See Also

XmlDocument Class
FastReport.Utils Namespace


Root Property

[image]

FastReport.Net Class Reference
XmlDocument..::.Root Property
XmlDocument Class See Also Send Feedback
Gets the root node of the document.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem Root { get; }
Visual Basic (Declaration)
Public ReadOnly Property Root As XmlItem
Visual C++
public:
property XmlItem^ Root {
    XmlItem^ get ();
}

See Also

XmlDocument Class
FastReport.Utils Namespace


XmlItem Class

[image]

FastReport.Net Class Reference
XmlItem Class
Members See Also Send Feedback
Represents a xml node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class XmlItem : IDisposable
Visual Basic (Declaration)
Public Class XmlItem _
    Implements IDisposable
Visual C++
public ref class XmlItem : IDisposable

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.XmlItem

See Also

XmlItem Members
FastReport.Utils Namespace


XmlItem Members

[image] [image]

FastReport.Net Class Reference
XmlItem Members
XmlItem Class Constructors Methods Properties See Also Send Feedback

The XmlItem type exposes the following members.

Constructors

Name | Description
XmlItem | Initializes a new instance of the XmlItem class with default settings.

Methods

Name | Description
Add | Adds a new child node to this node.
AddItem | Adds a specified node to this node.
Clear | Clears the child nodes of this node.
Dispose | Disposes the node and all its children.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Finds the node with specified name.
FindItem | Finds the node with specified name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProp | Gets a property with specified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Gets the index of specified node in the child nodes list.
InsertItem | Inserts a specified node to this node.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProp | Sets the value for a specified property.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets a number of children in this node.
Item | Gets a child node with specified index.
Items | Gets a list of children in this node.
Name | Gets or sets the node name.
Parent | Gets or sets the parent for this node.
Root | Gets the root node which owns this node.
Text | Gets or sets the node text.
Value | Gets or sets the node value.

See Also

XmlItem Class
FastReport.Utils Namespace


XmlItem Constructor

[image]

FastReport.Net Class Reference
XmlItem Constructor
XmlItem Class See Also Send Feedback
Initializes a new instance of the XmlItem class with default settings.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlItem()

See Also

XmlItem Class
FastReport.Utils Namespace


XmlItem Methods

[image] [image]

FastReport.Net Class Reference
XmlItem Methods
XmlItem Class See Also Send Feedback

The XmlItem type exposes the following members.

Methods

Name | Description
Add | Adds a new child node to this node.
AddItem | Adds a specified node to this node.
Clear | Clears the child nodes of this node.
Dispose | Disposes the node and all its children.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Finds the node with specified name.
FindItem | Finds the node with specified name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProp | Gets a property with specified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Gets the index of specified node in the child nodes list.
InsertItem | Inserts a specified node to this node.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProp | Sets the value for a specified property.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlItem Class
FastReport.Utils Namespace


Add Method

[image]

FastReport.Net Class Reference
XmlItem..::.Add Method
XmlItem Class See Also Send Feedback
Adds a new child node to this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem Add()
Visual Basic (Declaration)
Public Function Add As XmlItem
Visual C++
public:
XmlItem^ Add()

Return Value

The new child node.

See Also

XmlItem Class
FastReport.Utils Namespace


AddItem Method

[image]

FastReport.Net Class Reference
XmlItem..::.AddItem Method
XmlItem Class See Also Send Feedback
Adds a specified node to this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddItem(
    XmlItem item
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    item As XmlItem _
)
Visual C++
public:
void AddItem(
    XmlItem^ item
)

Parameters

item
Type: FastReport.Utils..::.XmlItem
The node to add.

See Also

XmlItem Class
FastReport.Utils Namespace


Clear Method

[image]

FastReport.Net Class Reference
XmlItem..::.Clear Method
XmlItem Class See Also Send Feedback
Clears the child nodes of this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

XmlItem Class
FastReport.Utils Namespace


Dispose Method

[image]

FastReport.Net Class Reference
XmlItem..::.Dispose Method
XmlItem Class See Also Send Feedback
Disposes the node and all its children.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

XmlItem Class
FastReport.Utils Namespace


Find Method

[image]

FastReport.Net Class Reference
XmlItem..::.Find Method
XmlItem Class See Also Send Feedback
Finds the node with specified name.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Find(
    string name
)
Visual Basic (Declaration)
Public Function Find ( _
    name As String _
) As Integer
Visual C++
public:
int Find(
    String^ name
)

Parameters

name
Type: System..::.String
The name of node to find.

Return Value

The node with specified name, if found; null otherwise.

See Also

XmlItem Class
FastReport.Utils Namespace


FindItem Method

[image]

FastReport.Net Class Reference
XmlItem..::.FindItem Method
XmlItem Class See Also Send Feedback
Finds the node with specified name.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem FindItem(
    string name
)
Visual Basic (Declaration)
Public Function FindItem ( _
    name As String _
) As XmlItem
Visual C++
public:
XmlItem^ FindItem(
    String^ name
)

Parameters

name
Type: System..::.String
The name of node to find.

Return Value

The node with specified name, if found; the new node otherwise.

Remarks

This method adds the node with specified name to the child nodes if it cannot find the node.

See Also

XmlItem Class
FastReport.Utils Namespace


GetProp Method

[image]

FastReport.Net Class Reference
XmlItem..::.GetProp Method
XmlItem Class See Also Send Feedback
Gets a property with specified name.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string GetProp(
    string index
)
Visual Basic (Declaration)
Public Function GetProp ( _
    index As String _
) As String
Visual C++
public:
String^ GetProp(
    String^ index
)

Parameters

index
Type: System..::.String
The property name.

Return Value

The value of property, if found; empty string otherwise.

Remarks

This property will return "0" when you request the "Left" property for a node like <Node Text="" Left="0"/>

See Also

XmlItem Class
FastReport.Utils Namespace


IndexOf Method

[image]

FastReport.Net Class Reference
XmlItem..::.IndexOf Method
XmlItem Class See Also Send Feedback
Gets the index of specified node in the child nodes list.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int IndexOf(
    XmlItem item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As XmlItem _
) As Integer
Visual C++
public:
int IndexOf(
    XmlItem^ item
)

Parameters

item
Type: FastReport.Utils..::.XmlItem
The node to find.

Return Value

Zero-based index of node, if found; -1 otherwise.

See Also

XmlItem Class
FastReport.Utils Namespace


InsertItem Method

[image]

FastReport.Net Class Reference
XmlItem..::.InsertItem Method
XmlItem Class See Also Send Feedback
Inserts a specified node to this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void InsertItem(
    int index,
    XmlItem item
)
Visual Basic (Declaration)
Public Sub InsertItem ( _
    index As Integer, _
    item As XmlItem _
)
Visual C++
public:
void InsertItem(
    int index,
    XmlItem^ item
)

Parameters

index
Type: System..::.Int32
Position to insert.
item
Type: FastReport.Utils..::.XmlItem
Node to insert.

See Also

XmlItem Class
FastReport.Utils Namespace


SetProp Method

[image]

FastReport.Net Class Reference
XmlItem..::.SetProp Method
XmlItem Class See Also Send Feedback
Sets the value for a specified property.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SetProp(
    string index,
    string value
)
Visual Basic (Declaration)
Public Sub SetProp ( _
    index As String, _
    value As String _
)
Visual C++
public:
void SetProp(
    String^ index,
    String^ value
)

Parameters

index
Type: System..::.String
The property name.
value
Type: System..::.String
Value to set.

Remarks

For example, you have a node like <Node Text="" Left="0"/>. When you set the "Text" property to "test", the node will be <Node Text="test" Left="0"/>. If property with specified name is not exist, it will be added.

See Also

XmlItem Class
FastReport.Utils Namespace


XmlItem Properties

[image] [image]

FastReport.Net Class Reference
XmlItem Properties
XmlItem Class See Also Send Feedback

The XmlItem type exposes the following members.

Properties

Name | Description
Count | Gets a number of children in this node.
Item | Gets a child node with specified index.
Items | Gets a list of children in this node.
Name | Gets or sets the node name.
Parent | Gets or sets the parent for this node.
Root | Gets the root node which owns this node.
Text | Gets or sets the node text.
Value | Gets or sets the node value.

See Also

XmlItem Class
FastReport.Utils Namespace


Count Property

[image]

FastReport.Net Class Reference
XmlItem..::.Count Property
XmlItem Class See Also Send Feedback
Gets a number of children in this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

XmlItem Class
FastReport.Utils Namespace


Item Property

[image]

FastReport.Net Class Reference
XmlItem..::.Item Property
XmlItem Class See Also Send Feedback
Gets a child node with specified index.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As XmlItem
Visual C++
public:
property XmlItem^ default[int index] {
    XmlItem^ get (int index);
}

Parameters

index
Type: System..::.Int32
Index of node.

Return Value

The node with specified index.

See Also

XmlItem Class
FastReport.Utils Namespace


Items Property

[image]

FastReport.Net Class Reference
XmlItem..::.Items Property
XmlItem Class See Also Send Feedback
Gets a list of children in this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public List<XmlItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As List(Of XmlItem)
Visual C++
public:
property List<XmlItem^>^ Items {
    List<XmlItem^>^ get ();
}

See Also

XmlItem Class
FastReport.Utils Namespace


Name Property

[image]

FastReport.Net Class Reference
XmlItem..::.Name Property
XmlItem Class See Also Send Feedback
Gets or sets the node name.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property will return "Node" for a node like <Node Text="" Left="0"/>

See Also

XmlItem Class
FastReport.Utils Namespace


Parent Property

[image]

FastReport.Net Class Reference
XmlItem..::.Parent Property
XmlItem Class See Also Send Feedback
Gets or sets the parent for this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As XmlItem
Visual C++
public:
property XmlItem^ Parent {
    XmlItem^ get ();
    void set (XmlItem^ value);
}

See Also

XmlItem Class
FastReport.Utils Namespace


Root Property

[image]

FastReport.Net Class Reference
XmlItem..::.Root Property
XmlItem Class See Also Send Feedback
Gets the root node which owns this node.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem Root { get; }
Visual Basic (Declaration)
Public ReadOnly Property Root As XmlItem
Visual C++
public:
property XmlItem^ Root {
    XmlItem^ get ();
}

See Also

XmlItem Class
FastReport.Utils Namespace


Text Property

[image]

FastReport.Net Class Reference
XmlItem..::.Text Property
XmlItem Class See Also Send Feedback
Gets or sets the node text.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

This property will return "Text="" Left="0"" for a node like <Node Text="" Left="0"/>

See Also

XmlItem Class
FastReport.Utils Namespace


Value Property

[image]

FastReport.Net Class Reference
XmlItem..::.Value Property
XmlItem Class See Also Send Feedback
Gets or sets the node value.

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Remarks

This property will return "ABC" for a node like <Node>ABC</Node>

See Also

XmlItem Class
FastReport.Utils Namespace


ZipArchive Class

[image]

FastReport.Net Class Reference
ZipArchive Class
Members See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class ZipArchive
Visual Basic (Declaration)
Public Class ZipArchive
Visual C++
public ref class ZipArchive

Inheritance Hierarchy

System..::.Object
FastReport.Utils..::.ZipArchive

See Also

ZipArchive Members
FastReport.Utils Namespace


ZipArchive Members

[image] [image]

FastReport.Net Class Reference
ZipArchive Members
ZipArchive Class Constructors Methods Properties See Also Send Feedback

The ZipArchive type exposes the following members.

Constructors

Name | Description
ZipArchive | Initializes a new instance of the ZipArchive class

Methods

Name | Description
AddDir |
AddFile |
AddStream |
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile |
SaveToStream |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Comment |
Errors |
FileCount |
RootFolder |

See Also

ZipArchive Class
FastReport.Utils Namespace


ZipArchive Constructor

[image]

FastReport.Net Class Reference
ZipArchive Constructor
ZipArchive Class See Also Send Feedback
Initializes a new instance of the ZipArchive class

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public ZipArchive()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ZipArchive()

See Also

ZipArchive Class
FastReport.Utils Namespace


ZipArchive Methods

[image] [image]

FastReport.Net Class Reference
ZipArchive Methods
ZipArchive Class See Also Send Feedback

The ZipArchive type exposes the following members.

Methods

Name | Description
AddDir |
AddFile |
AddStream |
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile |
SaveToStream |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZipArchive Class
FastReport.Utils Namespace


AddDir Method

[image]

FastReport.Net Class Reference
ZipArchive..::.AddDir Method
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddDir(
    string DirName
)
Visual Basic (Declaration)
Public Sub AddDir ( _
    DirName As String _
)
Visual C++
public:
void AddDir(
    String^ DirName
)

Parameters

DirName
Type: System..::.String

See Also

ZipArchive Class
FastReport.Utils Namespace


AddFile Method

[image]

FastReport.Net Class Reference
ZipArchive..::.AddFile Method
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddFile(
    string FileName
)
Visual Basic (Declaration)
Public Sub AddFile ( _
    FileName As String _
)
Visual C++
public:
void AddFile(
    String^ FileName
)

Parameters

FileName
Type: System..::.String

See Also

ZipArchive Class
FastReport.Utils Namespace


AddStream Method

[image]

FastReport.Net Class Reference
ZipArchive..::.AddStream Method
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void AddStream(
    string fileName,
    Stream stream
)
Visual Basic (Declaration)
Public Sub AddStream ( _
    fileName As String, _
    stream As Stream _
)
Visual C++
public:
void AddStream(
    String^ fileName,
    Stream^ stream
)

Parameters

fileName
Type: System..::.String
stream
Type: System.IO..::.Stream

See Also

ZipArchive Class
FastReport.Utils Namespace


Clear Method

[image]

FastReport.Net Class Reference
ZipArchive..::.Clear Method
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ZipArchive Class
FastReport.Utils Namespace


SaveToFile Method

[image]

FastReport.Net Class Reference
ZipArchive..::.SaveToFile Method
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveToFile(
    string FileName
)
Visual Basic (Declaration)
Public Sub SaveToFile ( _
    FileName As String _
)
Visual C++
public:
void SaveToFile(
    String^ FileName
)

Parameters

FileName
Type: System..::.String

See Also

ZipArchive Class
FastReport.Utils Namespace


SaveToStream Method

[image]

FastReport.Net Class Reference
ZipArchive..::.SaveToStream Method
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public void SaveToStream(
    Stream Stream
)
Visual Basic (Declaration)
Public Sub SaveToStream ( _
    Stream As Stream _
)
Visual C++
public:
void SaveToStream(
    Stream^ Stream
)

Parameters

Stream
Type: System.IO..::.Stream

See Also

ZipArchive Class
FastReport.Utils Namespace


ZipArchive Properties

[image] [image]

FastReport.Net Class Reference
ZipArchive Properties
ZipArchive Class See Also Send Feedback

The ZipArchive type exposes the following members.

Properties

Name | Description
Comment |
Errors |
FileCount |
RootFolder |

See Also

ZipArchive Class
FastReport.Utils Namespace


Comment Property

[image]

FastReport.Net Class Reference
ZipArchive..::.Comment Property
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

ZipArchive Class
FastReport.Utils Namespace


Errors Property

[image]

FastReport.Net Class Reference
ZipArchive..::.Errors Property
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string Errors { get; set; }
Visual Basic (Declaration)
Public Property Errors As String
Visual C++
public:
property String^ Errors {
    String^ get ();
    void set (String^ value);
}

See Also

ZipArchive Class
FastReport.Utils Namespace


FileCount Property

[image]

FastReport.Net Class Reference
ZipArchive..::.FileCount Property
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public int FileCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileCount As Integer
Visual C++
public:
property int FileCount {
    int get ();
}

See Also

ZipArchive Class
FastReport.Utils Namespace


RootFolder Property

[image]

FastReport.Net Class Reference
ZipArchive..::.RootFolder Property
ZipArchive Class See Also Send Feedback

Namespace: FastReport.Utils
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string RootFolder { get; set; }
Visual Basic (Declaration)
Public Property RootFolder As String
Visual C++
public:
property String^ RootFolder {
    String^ get ();
    void set (String^ value);
}

See Also

ZipArchive Class
FastReport.Utils Namespace


FastReport.Web Namespace

[image]

FastReport.Net Class Reference
FastReport.Web Namespace
Send Feedback

Classes

Class | Description
WebExportItem | Class for export item description
WebReport | Represents the Web Report.
WebReportCache |
WebReportProperties |
WebReportStyles |
WebUtils |

Enumerations

Enumeration | Description
ReportState |
ToolbarBackgroundStyle |
ToolbarIconsStyle |
ToolbarStyle |
ZoomMode |


ReportState Enumeration

[image]

FastReport.Net Class Reference
ReportState Enumeration
See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public enum ReportState
Visual Basic (Declaration)
Public Enumeration ReportState
Visual C++
public enum class ReportState

Members

Member name | Description
Empty |
Forms |
Report |
Done |
Canceled |

See Also

FastReport.Web Namespace


ToolbarBackgroundStyle Enumeration

[image]

FastReport.Net Class Reference
ToolbarBackgroundStyle Enumeration
See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public enum ToolbarBackgroundStyle
Visual Basic (Declaration)
Public Enumeration ToolbarBackgroundStyle
Visual C++
public enum class ToolbarBackgroundStyle

Members

Member name | Description
Light |
Medium |
Dark |

See Also

FastReport.Web Namespace


ToolbarIconsStyle Enumeration

[image]

FastReport.Net Class Reference
ToolbarIconsStyle Enumeration
See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public enum ToolbarIconsStyle
Visual Basic (Declaration)
Public Enumeration ToolbarIconsStyle
Visual C++
public enum class ToolbarIconsStyle

Members

Member name | Description
Red |
Green |
Blue |
Black |
Custom |

See Also

FastReport.Web Namespace


ToolbarStyle Enumeration

[image]

FastReport.Net Class Reference
ToolbarStyle Enumeration
See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public enum ToolbarStyle
Visual Basic (Declaration)
Public Enumeration ToolbarStyle
Visual C++
public enum class ToolbarStyle

Members

Member name | Description
Small |
Large |

See Also

FastReport.Web Namespace


WebExportItem Class

[image]

FastReport.Net Class Reference
WebExportItem Class
Members See Also Send Feedback
Class for export item description

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
[SerializableAttribute]
public class WebExportItem
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WebExportItem
Visual C++
[SerializableAttribute]
public ref class WebExportItem

Inheritance Hierarchy

System..::.Object
FastReport.Web..::.WebExportItem

See Also

WebExportItem Members
FastReport.Web Namespace


WebExportItem Members

[image] [image]

FastReport.Net Class Reference
WebExportItem Members
WebExportItem Class Constructors Methods Properties See Also Send Feedback

The WebExportItem type exposes the following members.

Constructors

Name | Description
WebExportItem | Initializes a new instance of the WebExportItem class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContentType | MIME type of exported file
File | Binary data of exported files
FileName | Name of exported file
Format | Format of exported file

See Also

WebExportItem Class
FastReport.Web Namespace


WebExportItem Constructor

[image]

FastReport.Net Class Reference
WebExportItem Constructor
WebExportItem Class See Also Send Feedback
Initializes a new instance of the WebExportItem class

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebExportItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebExportItem()

See Also

WebExportItem Class
FastReport.Web Namespace


WebExportItem Methods

[image] [image]

FastReport.Net Class Reference
WebExportItem Methods
WebExportItem Class See Also Send Feedback

The WebExportItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebExportItem Class
FastReport.Web Namespace


WebExportItem Properties

[image] [image]

FastReport.Net Class Reference
WebExportItem Properties
WebExportItem Class See Also Send Feedback

The WebExportItem type exposes the following members.

Properties

Name | Description
ContentType | MIME type of exported file
File | Binary data of exported files
FileName | Name of exported file
Format | Format of exported file

See Also

WebExportItem Class
FastReport.Web Namespace


ContentType Property

[image]

FastReport.Net Class Reference
WebExportItem..::.ContentType Property
WebExportItem Class See Also Send Feedback
MIME type of exported file

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ContentType { get; set; }
Visual Basic (Declaration)
Public Property ContentType As String
Visual C++
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

See Also

WebExportItem Class
FastReport.Web Namespace


File Property

[image]

FastReport.Net Class Reference
WebExportItem..::.File Property
WebExportItem Class See Also Send Feedback
Binary data of exported files

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public byte[] File { get; set; }
Visual Basic (Declaration)
Public Property File As Byte()
Visual C++
public:
property array<unsigned char>^ File {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

WebExportItem Class
FastReport.Web Namespace


FileName Property

[image]

FastReport.Net Class Reference
WebExportItem..::.FileName Property
WebExportItem Class See Also Send Feedback
Name of exported file

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string FileName { get; set; }
Visual Basic (Declaration)
Public Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

WebExportItem Class
FastReport.Web Namespace


Format Property

[image]

FastReport.Net Class Reference
WebExportItem..::.Format Property
WebExportItem Class See Also Send Feedback
Format of exported file

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

See Also

WebExportItem Class
FastReport.Web Namespace


WebReport Class

[image]

FastReport.Net Class Reference
WebReport Class
Members See Also Send Feedback
Represents the Web Report.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public class WebReport : WebControl, INamingContainer
Visual Basic (Declaration)
Public Class WebReport _
    Inherits WebControl _
    Implements INamingContainer
Visual C++
public ref class WebReport : public WebControl,
    INamingContainer

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
FastReport.Web..::.WebReport

See Also

WebReport Members
FastReport.Web Namespace


WebReport Members

[image] [image]

FastReport.Net Class Reference
WebReport Members
WebReport Class Constructors Methods Properties Events See Also Send Feedback

The WebReport type exposes the following members.

Constructors

Name | Description
WebReport | Initializes a new instance of the WebReport class.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportCsv | Export in CSV format
ExportDbf | Export in DBF format
ExportExcel2007 | Export in Excel 2007 format
ExportHtml | Export in HTML format inline
ExportMht | Export in MHT format
ExportOds | Export in Open Office Spreadsheet format
ExportOdt | Export in Open Office Text format
ExportPdf | Overloaded.
ExportPowerPoint2007 | Export in PowerPoint 2007 format
ExportRtf | Export in RTF format
ExportText | Export in Text format
ExportWord2007 | Export in Word 2007 format
ExportXmlExcel | Export in XML (Excel 2003) format
ExportXps | Export in XPS format
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
FirstPage | Force go to first report page
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LastPage | Force go to last report page
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
NextPage | Force go to next report page
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Raises the Init event. (Overrides Control..::.OnInit(EventArgs).)
OnLoad | Raises the Load event. (Overrides Control..::.OnLoad(EventArgs).)
OnPreRender | (Overrides Control..::.OnPreRender(EventArgs).)
OnStartReport | Runs on report start
OnUnload | Raises the Unload event. (Overrides Control..::.OnUnload(EventArgs).)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Prepare | Prepare the report
PrevPage | Force go to previous report page
PrintHtml | Print in browser
PrintPdf | Print in Adobe Acrobat
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Refresh | Force refresh of report
RegisterData | Overloaded.
RegisterDataAsp | Overloaded.
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetPage | Force go to "value" report page
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetSize |
SetStartEvent |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
AutoHeight | Get or sets auto height of report
AutoWidth | Get or sets auto width of report
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ButtonsPath | Sets the path to custom buttons on site.
CacheDelay | Delay in cache in minutes
CachePriority | Priority of items in cache
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
CsvDataOnly | Enable or disable of exporting data without any header/group bands.
CsvSeparator | Gets or sets of cells separator.
CurrentPage | Gets or sets number of current page
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
DocxMatrixBased | Enable or disable matrix view of Word 2007 document
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
ExternalJquery | Enable or disable using of external jQuery library
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Layers | Enable or disable layers mode visualisation
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
LocalizationFile | Gets or sets the name of localization file.
MhtPictures | Gets or sets a value indicating that pictures are enabled.
MhtWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
OdsCreator | Gets or sets the creator of the document.
OdsPageBreaks | Gets or sets a value indicating that page breaks are enabled.
OdsWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
OdtCreator | Gets or sets the creator of the document.
OdtPageBreaks | Gets or sets a value indicating that page breaks are enabled.
OdtWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Padding | Gets or sets Padding of Report section
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PdfAllowAnnotate | Enable or disable annotating in protected document.
PdfAllowCopy | Enable or disable copying in protected document.
PdfAllowModify | Enable or disable modifying in protected document.
PdfAllowPrint | Enable or disable printing in protected document.
PdfAuthor | Author of the document.
PdfBackground | Enable or disable of exporting the background.
PdfCenterWindow | Enable or disable centering the window.
PdfCreator | Creator of the document.
PdfDisplayDocTitle | Enable or disable of displaying document's title.
PdfEmbeddingFonts | Enable or disable of embedding the TrueType fonts.
PdfFitWindow | Enable or disable of fitting the window.
PdfHideMenubar | Enable or disable hide the menu's bar.
PdfHideToolbar | Enable or disable hide the toolbar.
PdfHideWindowUI | Enable or disable hide the Windows UI.
PdfKeywords | Keywords of the document.
PdfOutline | Enable or disable of document's Outline.
PdfOwnerPassword | Sets the owner password.
PdfPrintOptimized | Enable or disable of optimization the images for printing.
PdfPrintScaling | Enable or disable of scaling the page for shrink to printable area.
PdfProducer | Producer of the document.
PdfSubject | Subject of the document.
PdfTitle | Title of the document.
PdfUserPassword | Sets the users password.
Pictures | Switch the pictures visibility in report
PptxImageFormat | Gets or sets the image format that will be used to save pictures in PowerPoint file.
PrintInPdf | Enable or disable print in PDF
PrintWindowHeight | Sets the height of print window
PrintWindowWidth | Sets the width of print window
Report | Direct access to Report object
ReportDataSources | Gets or sets report data source(s).
ReportDone | Return true if report done
ReportFile | Gets or sets the name of report file.
ReportGuid | Gets or sets guid of report
ReportResourceString | Report Resource String
RtfAutoSize | Gets or sets a value that determines whether the rows in the resulting table should calculate its height automatically.
RtfCreator | Gets or sets the creator of the document.
RtfImageFormat | Gets or sets the image format that will be used to save pictures in RTF file.
RtfJpegQuality | Gets or sets the quality of Jpeg images in RTF file.
RtfPageBreaks | Gets or sets a value indicating that page breaks are enabled.
RtfPictures | Gets or sets a value indicating that pictures are enabled.
RtfWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
ShowCsvExport | Switch visibility of CSV (comma separated values) export in toolbar.
ShowDbfExport | Switch visibility of DBF export in toolbar.
ShowExcel2007Export | Switch visibility of Excel 2007 export in toolbar.
ShowExports | Switch visibility of Exports in toolbar
ShowFirstButton | Switch visibility of First Button in toolbar
ShowLastButton | Switch visibility of Last Button in toolbar
ShowMhtExport | Switch visibility of MHT (web-archive) export in toolbar.
ShowNextButton | Switch visibility of Next Button in toolbar
ShowOdsExport | Switch visibility of Open Office Spreadsheet (ODS) export in toolbar
ShowOdtExport | Switch visibility of Open Office Text (ODT) export in toolbar
ShowPageNumber | Switch visibility of Page Number in toolbar.
ShowPdfExport | Switch visibility of PDF (Adobe Acrobat) export in toolbar.
ShowPowerPoint2007Export | Switch visibility of PowerPoint 2007 export in toolbar.
ShowPrevButton | Switch visibility of Previous Button in toolbar
ShowPrint | Switch visibility of Print button in toolbar
ShowRefreshButton | Switch visibility of Refresh in toolbar.
ShowRtfExport | Switch visibility of RTF export in toolbar.
ShowTextExport | Switch visibility of text (plain text) export in toolbar
ShowToolbar | Switch toolbar visibility
ShowWord2007Export | Switch visibility of Word 2007 export in toolbar.
ShowXmlExcelExport | Switch visibility of XML (Excel) export in toolbar.
ShowXpsExport | Switch visibility of XPS export in toolbar.
ShowZoomButton | Switch visibility of Zoom in toolbar.
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
State | Gets or sets current state of report
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
TextAllowFrames | Enable or disable frames in text file.
TextDataOnly | Enable or disable of exporting data without any header/group bands.
TextEmptyLines | Enable or disable empty lines in text file.
TextPageBreaks | Gets or sets a value indicating that page breaks are enabled.
TextSimpleFrames | Enable or disable simple (non graphic) frames in text file.
ToolbarBackgroundStyle |
ToolbarColor | Set the Toolbar color.
ToolbarIconsStyle |
ToolbarStyle |
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
TotalPages | Gets total pages of current report
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
XlsxDataOnly | Enable or disable of exporting data without any header/group bands.
XlsxPageBreaks | Gets or sets a value indicating that page breaks are enabled.
XlsxWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
XmlExcelDataOnly | Enable or disable of exporting data without any header/group bands.
XmlExcelPageBreaks | Gets or sets a value indicating that page breaks are enabled.
XmlExcelWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Set the zoom factor of previewed page between 0..1

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
StartReport | Occurs when report execution is started.
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WebReport Class
FastReport.Web Namespace


WebReport Constructor

[image]

FastReport.Net Class Reference
WebReport Constructor
WebReport Class See Also Send Feedback
Initializes a new instance of the WebReport class.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebReport()

See Also

WebReport Class
FastReport.Web Namespace


WebReport Methods

[image] [image]

FastReport.Net Class Reference
WebReport Methods
WebReport Class See Also Send Feedback

The WebReport type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportCsv | Export in CSV format
ExportDbf | Export in DBF format
ExportExcel2007 | Export in Excel 2007 format
ExportHtml | Export in HTML format inline
ExportMht | Export in MHT format
ExportOds | Export in Open Office Spreadsheet format
ExportOdt | Export in Open Office Text format
ExportPdf | Overloaded.
ExportPowerPoint2007 | Export in PowerPoint 2007 format
ExportRtf | Export in RTF format
ExportText | Export in Text format
ExportWord2007 | Export in Word 2007 format
ExportXmlExcel | Export in XML (Excel 2003) format
ExportXps | Export in XPS format
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
FirstPage | Force go to first report page
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LastPage | Force go to last report page
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
NextPage | Force go to next report page
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Raises the Init event. (Overrides Control..::.OnInit(EventArgs).)
OnLoad | Raises the Load event. (Overrides Control..::.OnLoad(EventArgs).)
OnPreRender | (Overrides Control..::.OnPreRender(EventArgs).)
OnStartReport | Runs on report start
OnUnload | Raises the Unload event. (Overrides Control..::.OnUnload(EventArgs).)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Prepare | Prepare the report
PrevPage | Force go to previous report page
PrintHtml | Print in browser
PrintPdf | Print in Adobe Acrobat
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Refresh | Force refresh of report
RegisterData | Overloaded.
RegisterDataAsp | Overloaded.
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetPage | Force go to "value" report page
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetSize |
SetStartEvent |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

WebReport Class
FastReport.Web Namespace


DataBind Method

[image] [image]

FastReport.Net Class Reference
WebReport..::.DataBind Method
WebReport Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WebReport Class
WebReport Members
FastReport.Web Namespace


ExportCsv Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportCsv Method
WebReport Class See Also Send Feedback
Export in CSV format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportCsv(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportCsv ( _
    context As HttpContext _
)
Visual C++
public:
void ExportCsv(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportDbf Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportDbf Method
WebReport Class See Also Send Feedback
Export in DBF format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportDbf(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportDbf ( _
    context As HttpContext _
)
Visual C++
public:
void ExportDbf(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportExcel2007 Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportExcel2007 Method
WebReport Class See Also Send Feedback
Export in Excel 2007 format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportExcel2007(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportExcel2007 ( _
    context As HttpContext _
)
Visual C++
public:
void ExportExcel2007(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportHtml Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportHtml Method
WebReport Class See Also Send Feedback
Export in HTML format inline

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportHtml(
    HttpContext context,
    bool displayInline
)
Visual Basic (Declaration)
Public Sub ExportHtml ( _
    context As HttpContext, _
    displayInline As Boolean _
)
Visual C++
public:
void ExportHtml(
    HttpContext^ context,
    bool displayInline
)

Parameters

context
Type: System.Web..::.HttpContext
displayInline
Type: System..::.Boolean

See Also

WebReport Class
FastReport.Web Namespace


ExportMht Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportMht Method
WebReport Class See Also Send Feedback
Export in MHT format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportMht(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportMht ( _
    context As HttpContext _
)
Visual C++
public:
void ExportMht(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportOds Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportOds Method
WebReport Class See Also Send Feedback
Export in Open Office Spreadsheet format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportOds(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportOds ( _
    context As HttpContext _
)
Visual C++
public:
void ExportOds(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportOdt Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportOdt Method
WebReport Class See Also Send Feedback
Export in Open Office Text format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportOdt(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportOdt ( _
    context As HttpContext _
)
Visual C++
public:
void ExportOdt(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportPdf Method

[image] [image]

FastReport.Net Class Reference
WebReport..::.ExportPdf Method
WebReport Class See Also Send Feedback

Overload List

Name | Description
ExportPdf(HttpContext) | Export in PDF format
ExportPdf(HttpContext, Boolean) | Export in PDF format inline

See Also

WebReport Class
WebReport Members
FastReport.Web Namespace


ExportPdf Method (HttpContext)

[image]

FastReport.Net Class Reference
WebReport..::.ExportPdf Method (HttpContext)
WebReport Class See Also Send Feedback
Export in PDF format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportPdf(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportPdf ( _
    context As HttpContext _
)
Visual C++
public:
void ExportPdf(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
ExportPdf Overload
FastReport.Web Namespace


ExportPdf Method (HttpContext, Boolean)

[image]

FastReport.Net Class Reference
WebReport..::.ExportPdf Method (HttpContext, Boolean)
WebReport Class See Also Send Feedback
Export in PDF format inline

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportPdf(
    HttpContext context,
    bool displayInline
)
Visual Basic (Declaration)
Public Sub ExportPdf ( _
    context As HttpContext, _
    displayInline As Boolean _
)
Visual C++
public:
void ExportPdf(
    HttpContext^ context,
    bool displayInline
)

Parameters

context
Type: System.Web..::.HttpContext
displayInline
Type: System..::.Boolean

See Also

WebReport Class
ExportPdf Overload
FastReport.Web Namespace


ExportPowerPoint2007 Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportPowerPoint2007 Method
WebReport Class See Also Send Feedback
Export in PowerPoint 2007 format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportPowerPoint2007(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportPowerPoint2007 ( _
    context As HttpContext _
)
Visual C++
public:
void ExportPowerPoint2007(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportRtf Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportRtf Method
WebReport Class See Also Send Feedback
Export in RTF format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportRtf(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportRtf ( _
    context As HttpContext _
)
Visual C++
public:
void ExportRtf(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportText Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportText Method
WebReport Class See Also Send Feedback
Export in Text format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportText(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportText ( _
    context As HttpContext _
)
Visual C++
public:
void ExportText(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportWord2007 Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportWord2007 Method
WebReport Class See Also Send Feedback
Export in Word 2007 format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportWord2007(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportWord2007 ( _
    context As HttpContext _
)
Visual C++
public:
void ExportWord2007(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportXmlExcel Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportXmlExcel Method
WebReport Class See Also Send Feedback
Export in XML (Excel 2003) format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportXmlExcel(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportXmlExcel ( _
    context As HttpContext _
)
Visual C++
public:
void ExportXmlExcel(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


ExportXps Method

[image]

FastReport.Net Class Reference
WebReport..::.ExportXps Method
WebReport Class See Also Send Feedback
Export in XPS format

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ExportXps(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ExportXps ( _
    context As HttpContext _
)
Visual C++
public:
void ExportXps(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


FindControl Method

[image] [image]

FastReport.Net Class Reference
WebReport..::.FindControl Method
WebReport Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WebReport Class
WebReport Members
FastReport.Web Namespace


FirstPage Method

[image]

FastReport.Net Class Reference
WebReport..::.FirstPage Method
WebReport Class See Also Send Feedback
Force go to first report page

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void FirstPage()
Visual Basic (Declaration)
Public Sub FirstPage
Visual C++
public:
void FirstPage()

See Also

WebReport Class
FastReport.Web Namespace


LastPage Method

[image]

FastReport.Net Class Reference
WebReport..::.LastPage Method
WebReport Class See Also Send Feedback
Force go to last report page

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void LastPage()
Visual Basic (Declaration)
Public Sub LastPage
Visual C++
public:
void LastPage()

See Also

WebReport Class
FastReport.Web Namespace


NextPage Method

[image]

FastReport.Net Class Reference
WebReport..::.NextPage Method
WebReport Class See Also Send Feedback
Force go to next report page

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void NextPage()
Visual Basic (Declaration)
Public Sub NextPage
Visual C++
public:
void NextPage()

See Also

WebReport Class
FastReport.Web Namespace


OnInit Method

[image]

FastReport.Net Class Reference
WebReport..::.OnInit Method
WebReport Class See Also Send Feedback
Raises the Init event.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnInit(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
An EventArgs object that contains the event data.

See Also

WebReport Class
FastReport.Web Namespace


OnLoad Method

[image]

FastReport.Net Class Reference
WebReport..::.OnLoad Method
WebReport Class See Also Send Feedback
Raises the Load event.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
The EventArgs object that contains the event data.

See Also

WebReport Class
FastReport.Web Namespace


OnPreRender Method

[image]

FastReport.Net Class Reference
WebReport..::.OnPreRender Method
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnPreRender(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPreRender ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnPreRender(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

WebReport Class
FastReport.Web Namespace


OnStartReport Method

[image]

FastReport.Net Class Reference
WebReport..::.OnStartReport Method
WebReport Class See Also Send Feedback
Runs on report start

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void OnStartReport(
    EventArgs e
)
Visual Basic (Declaration)
Public Sub OnStartReport ( _
    e As EventArgs _
)
Visual C++
public:
void OnStartReport(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

WebReport Class
FastReport.Web Namespace


OnUnload Method

[image]

FastReport.Net Class Reference
WebReport..::.OnUnload Method
WebReport Class See Also Send Feedback
Raises the Unload event.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
protected override void OnUnload(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnUnload ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnUnload(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs
An EventArgs object that contains event data.

See Also

WebReport Class
FastReport.Web Namespace


Prepare Method

[image]

FastReport.Net Class Reference
WebReport..::.Prepare Method
WebReport Class See Also Send Feedback
Prepare the report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void Prepare()
Visual Basic (Declaration)
Public Sub Prepare
Visual C++
public:
void Prepare()

See Also

WebReport Class
FastReport.Web Namespace


PrevPage Method

[image]

FastReport.Net Class Reference
WebReport..::.PrevPage Method
WebReport Class See Also Send Feedback
Force go to previous report page

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void PrevPage()
Visual Basic (Declaration)
Public Sub PrevPage
Visual C++
public:
void PrevPage()

See Also

WebReport Class
FastReport.Web Namespace


PrintHtml Method

[image]

FastReport.Net Class Reference
WebReport..::.PrintHtml Method
WebReport Class See Also Send Feedback
Print in browser

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintHtml(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub PrintHtml ( _
    context As HttpContext _
)
Visual C++
public:
void PrintHtml(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


PrintPdf Method

[image]

FastReport.Net Class Reference
WebReport..::.PrintPdf Method
WebReport Class See Also Send Feedback
Print in Adobe Acrobat

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void PrintPdf(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub PrintPdf ( _
    context As HttpContext _
)
Visual C++
public:
void PrintPdf(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

See Also

WebReport Class
FastReport.Web Namespace


Refresh Method

[image]

FastReport.Net Class Reference
WebReport..::.Refresh Method
WebReport Class See Also Send Feedback
Force refresh of report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
void Refresh()

See Also

WebReport Class
FastReport.Web Namespace


RegisterData Method

[image] [image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method
WebReport Class See Also Send Feedback

Overload List

Name | Description
RegisterData(DataSet) |
RegisterData(IEnumerable, String) |
RegisterData(DataRelation, String) |
RegisterData(DataSet, String) |
RegisterData(DataTable, String) |
RegisterData(DataView, String) |

See Also

WebReport Class
WebReport Members
FastReport.Web Namespace


RegisterData Method (DataSet)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method (DataSet)
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport RegisterData(
    DataSet data
)
Visual Basic (Declaration)
Public Function RegisterData ( _
    data As DataSet _
) As WebReport
Visual C++
public:
WebReport^ RegisterData(
    DataSet^ data
)

Parameters

data
Type: System.Data..::.DataSet

Return Value

See Also

WebReport Class
RegisterData Overload
FastReport.Web Namespace


RegisterData Method (IEnumerable, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method (IEnumerable, String)
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport RegisterData(
    IEnumerable data,
    string name
)
Visual Basic (Declaration)
Public Function RegisterData ( _
    data As IEnumerable, _
    name As String _
) As WebReport
Visual C++
public:
WebReport^ RegisterData(
    IEnumerable^ data,
    String^ name
)

Parameters

data
Type: System.Collections..::.IEnumerable
name
Type: System..::.String

Return Value

See Also

WebReport Class
RegisterData Overload
FastReport.Web Namespace


RegisterData Method (DataRelation, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method (DataRelation, String)
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport RegisterData(
    DataRelation data,
    string name
)
Visual Basic (Declaration)
Public Function RegisterData ( _
    data As DataRelation, _
    name As String _
) As WebReport
Visual C++
public:
WebReport^ RegisterData(
    DataRelation^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataRelation
name
Type: System..::.String

Return Value

See Also

WebReport Class
RegisterData Overload
FastReport.Web Namespace


RegisterData Method (DataSet, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method (DataSet, String)
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport RegisterData(
    DataSet data,
    string name
)
Visual Basic (Declaration)
Public Function RegisterData ( _
    data As DataSet, _
    name As String _
) As WebReport
Visual C++
public:
WebReport^ RegisterData(
    DataSet^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataSet
name
Type: System..::.String

Return Value

See Also

WebReport Class
RegisterData Overload
FastReport.Web Namespace


RegisterData Method (DataTable, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method (DataTable, String)
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport RegisterData(
    DataTable data,
    string name
)
Visual Basic (Declaration)
Public Function RegisterData ( _
    data As DataTable, _
    name As String _
) As WebReport
Visual C++
public:
WebReport^ RegisterData(
    DataTable^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataTable
name
Type: System..::.String

Return Value

See Also

WebReport Class
RegisterData Overload
FastReport.Web Namespace


RegisterData Method (DataView, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterData Method (DataView, String)
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport RegisterData(
    DataView data,
    string name
)
Visual Basic (Declaration)
Public Function RegisterData ( _
    data As DataView, _
    name As String _
) As WebReport
Visual C++
public:
WebReport^ RegisterData(
    DataView^ data,
    String^ name
)

Parameters

data
Type: System.Data..::.DataView
name
Type: System..::.String

Return Value

See Also

WebReport Class
RegisterData Overload
FastReport.Web Namespace


RegisterDataAsp Method

[image] [image]

FastReport.Net Class Reference
WebReport..::.RegisterDataAsp Method
WebReport Class See Also Send Feedback

Overload List

Name | Description
RegisterDataAsp(Report, IEnumerable, String) | Registers the ASP.NET application data to use it in the report.
RegisterDataAsp(Report, IDataSource, String) | Registers the ASP.NET application data to use it in the report.

See Also

WebReport Class
WebReport Members
FastReport.Web Namespace


RegisterDataAsp Method (Report, IEnumerable, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterDataAsp Method (Report, IEnumerable, String)
WebReport Class See Also Send Feedback
Registers the ASP.NET application data to use it in the report.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterDataAsp(
    Report report,
    IEnumerable data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterDataAsp ( _
    report As Report, _
    data As IEnumerable, _
    name As String _
)
Visual C++
public:
void RegisterDataAsp(
    Report^ report,
    IEnumerable^ data,
    String^ name
)

Parameters

report
Type: FastReport..::.Report
The Report object.
data
Type: System.Collections..::.IEnumerable
The application data.
name
Type: System..::.String
The name of the data.

See Also

WebReport Class
RegisterDataAsp Overload
FastReport.Web Namespace


RegisterDataAsp Method (Report, IDataSource, String)

[image]

FastReport.Net Class Reference
WebReport..::.RegisterDataAsp Method (Report, IDataSource, String)
WebReport Class See Also Send Feedback
Registers the ASP.NET application data to use it in the report.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void RegisterDataAsp(
    Report report,
    IDataSource data,
    string name
)
Visual Basic (Declaration)
Public Sub RegisterDataAsp ( _
    report As Report, _
    data As IDataSource, _
    name As String _
)
Visual C++
public:
void RegisterDataAsp(
    Report^ report,
    IDataSource^ data,
    String^ name
)

Parameters

report
Type: FastReport..::.Report
The Report object.
data
Type: System.Web.UI..::.IDataSource
The application data.
name
Type: System..::.String
The name of the data.

See Also

WebReport Class
RegisterDataAsp Overload
FastReport.Web Namespace


RenderContents Method

[image]

FastReport.Net Class Reference
WebReport..::.RenderContents Method
WebReport Class See Also Send Feedback
Renders the contents of the control to the specified writer. This method is used primarily by control developers.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
protected override void RenderContents(
    HtmlTextWriter writer
)
Visual Basic (Declaration)
Protected Overrides Sub RenderContents ( _
    writer As HtmlTextWriter _
)
Visual C++
protected:
virtual void RenderContents(
    HtmlTextWriter^ writer
) override

Parameters

writer
Type: System.Web.UI..::.HtmlTextWriter
A HtmlTextWriter that represents the output stream to render HTML content on the client.

See Also

WebReport Class
FastReport.Web Namespace


RenderControl Method

[image] [image]

FastReport.Net Class Reference
WebReport..::.RenderControl Method
WebReport Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WebReport Class
WebReport Members
FastReport.Web Namespace


SetPage Method

[image]

FastReport.Net Class Reference
WebReport..::.SetPage Method
WebReport Class See Also Send Feedback
Force go to "value" report page

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void SetPage(
    int value
)
Visual Basic (Declaration)
Public Sub SetPage ( _
    value As Integer _
)
Visual C++
public:
void SetPage(
    int value
)

Parameters

value
Type: System..::.Int32

See Also

WebReport Class
FastReport.Web Namespace


SetSize Method

[image]

FastReport.Net Class Reference
WebReport..::.SetSize Method
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport SetSize(
    Unit width,
    Unit height
)
Visual Basic (Declaration)
Public Function SetSize ( _
    width As Unit, _
    height As Unit _
) As WebReport
Visual C++
public:
WebReport^ SetSize(
    Unit width,
    Unit height
)

Parameters

width
Type: System.Web.UI.WebControls..::.Unit
height
Type: System.Web.UI.WebControls..::.Unit

Return Value

See Also

WebReport Class
FastReport.Web Namespace


SetStartEvent Method

[image]

FastReport.Net Class Reference
WebReport..::.SetStartEvent Method
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReport SetStartEvent(
    EventHandler start
)
Visual Basic (Declaration)
Public Function SetStartEvent ( _
    start As EventHandler _
) As WebReport
Visual C++
public:
WebReport^ SetStartEvent(
    EventHandler^ start
)

Parameters

start
Type: System..::.EventHandler

Return Value

See Also

WebReport Class
FastReport.Web Namespace


WebReport Properties

[image] [image]

FastReport.Net Class Reference
WebReport Properties
WebReport Class See Also Send Feedback

The WebReport type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
AutoHeight | Get or sets auto height of report
AutoWidth | Get or sets auto width of report
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ButtonsPath | Sets the path to custom buttons on site.
CacheDelay | Delay in cache in minutes
CachePriority | Priority of items in cache
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
CsvDataOnly | Enable or disable of exporting data without any header/group bands.
CsvSeparator | Gets or sets of cells separator.
CurrentPage | Gets or sets number of current page
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
DocxMatrixBased | Enable or disable matrix view of Word 2007 document
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
ExternalJquery | Enable or disable using of external jQuery library
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Layers | Enable or disable layers mode visualisation
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
LocalizationFile | Gets or sets the name of localization file.
MhtPictures | Gets or sets a value indicating that pictures are enabled.
MhtWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
OdsCreator | Gets or sets the creator of the document.
OdsPageBreaks | Gets or sets a value indicating that page breaks are enabled.
OdsWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
OdtCreator | Gets or sets the creator of the document.
OdtPageBreaks | Gets or sets a value indicating that page breaks are enabled.
OdtWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Padding | Gets or sets Padding of Report section
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PdfAllowAnnotate | Enable or disable annotating in protected document.
PdfAllowCopy | Enable or disable copying in protected document.
PdfAllowModify | Enable or disable modifying in protected document.
PdfAllowPrint | Enable or disable printing in protected document.
PdfAuthor | Author of the document.
PdfBackground | Enable or disable of exporting the background.
PdfCenterWindow | Enable or disable centering the window.
PdfCreator | Creator of the document.
PdfDisplayDocTitle | Enable or disable of displaying document's title.
PdfEmbeddingFonts | Enable or disable of embedding the TrueType fonts.
PdfFitWindow | Enable or disable of fitting the window.
PdfHideMenubar | Enable or disable hide the menu's bar.
PdfHideToolbar | Enable or disable hide the toolbar.
PdfHideWindowUI | Enable or disable hide the Windows UI.
PdfKeywords | Keywords of the document.
PdfOutline | Enable or disable of document's Outline.
PdfOwnerPassword | Sets the owner password.
PdfPrintOptimized | Enable or disable of optimization the images for printing.
PdfPrintScaling | Enable or disable of scaling the page for shrink to printable area.
PdfProducer | Producer of the document.
PdfSubject | Subject of the document.
PdfTitle | Title of the document.
PdfUserPassword | Sets the users password.
Pictures | Switch the pictures visibility in report
PptxImageFormat | Gets or sets the image format that will be used to save pictures in PowerPoint file.
PrintInPdf | Enable or disable print in PDF
PrintWindowHeight | Sets the height of print window
PrintWindowWidth | Sets the width of print window
Report | Direct access to Report object
ReportDataSources | Gets or sets report data source(s).
ReportDone | Return true if report done
ReportFile | Gets or sets the name of report file.
ReportGuid | Gets or sets guid of report
ReportResourceString | Report Resource String
RtfAutoSize | Gets or sets a value that determines whether the rows in the resulting table should calculate its height automatically.
RtfCreator | Gets or sets the creator of the document.
RtfImageFormat | Gets or sets the image format that will be used to save pictures in RTF file.
RtfJpegQuality | Gets or sets the quality of Jpeg images in RTF file.
RtfPageBreaks | Gets or sets a value indicating that page breaks are enabled.
RtfPictures | Gets or sets a value indicating that pictures are enabled.
RtfWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
ShowCsvExport | Switch visibility of CSV (comma separated values) export in toolbar.
ShowDbfExport | Switch visibility of DBF export in toolbar.
ShowExcel2007Export | Switch visibility of Excel 2007 export in toolbar.
ShowExports | Switch visibility of Exports in toolbar
ShowFirstButton | Switch visibility of First Button in toolbar
ShowLastButton | Switch visibility of Last Button in toolbar
ShowMhtExport | Switch visibility of MHT (web-archive) export in toolbar.
ShowNextButton | Switch visibility of Next Button in toolbar
ShowOdsExport | Switch visibility of Open Office Spreadsheet (ODS) export in toolbar
ShowOdtExport | Switch visibility of Open Office Text (ODT) export in toolbar
ShowPageNumber | Switch visibility of Page Number in toolbar.
ShowPdfExport | Switch visibility of PDF (Adobe Acrobat) export in toolbar.
ShowPowerPoint2007Export | Switch visibility of PowerPoint 2007 export in toolbar.
ShowPrevButton | Switch visibility of Previous Button in toolbar
ShowPrint | Switch visibility of Print button in toolbar
ShowRefreshButton | Switch visibility of Refresh in toolbar.
ShowRtfExport | Switch visibility of RTF export in toolbar.
ShowTextExport | Switch visibility of text (plain text) export in toolbar
ShowToolbar | Switch toolbar visibility
ShowWord2007Export | Switch visibility of Word 2007 export in toolbar.
ShowXmlExcelExport | Switch visibility of XML (Excel) export in toolbar.
ShowXpsExport | Switch visibility of XPS export in toolbar.
ShowZoomButton | Switch visibility of Zoom in toolbar.
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
State | Gets or sets current state of report
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
TextAllowFrames | Enable or disable frames in text file.
TextDataOnly | Enable or disable of exporting data without any header/group bands.
TextEmptyLines | Enable or disable empty lines in text file.
TextPageBreaks | Gets or sets a value indicating that page breaks are enabled.
TextSimpleFrames | Enable or disable simple (non graphic) frames in text file.
ToolbarBackgroundStyle |
ToolbarColor | Set the Toolbar color.
ToolbarIconsStyle |
ToolbarStyle |
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
TotalPages | Gets total pages of current report
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
XlsxDataOnly | Enable or disable of exporting data without any header/group bands.
XlsxPageBreaks | Gets or sets a value indicating that page breaks are enabled.
XlsxWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
XmlExcelDataOnly | Enable or disable of exporting data without any header/group bands.
XmlExcelPageBreaks | Gets or sets a value indicating that page breaks are enabled.
XmlExcelWysiwyg | Gets or sets a value that determines whether the wysiwyg mode should be used for better results.
Zoom | Set the zoom factor of previewed page between 0..1

See Also

WebReport Class
FastReport.Web Namespace


AutoHeight Property

[image]

FastReport.Net Class Reference
WebReport..::.AutoHeight Property
WebReport Class See Also Send Feedback
Get or sets auto height of report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoHeight { get; set; }
Visual Basic (Declaration)
Public Property AutoHeight As Boolean
Visual C++
public:
property bool AutoHeight {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


AutoWidth Property

[image]

FastReport.Net Class Reference
WebReport..::.AutoWidth Property
WebReport Class See Also Send Feedback
Get or sets auto width of report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoWidth As Boolean
Visual C++
public:
property bool AutoWidth {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ButtonsPath Property

[image]

FastReport.Net Class Reference
WebReport..::.ButtonsPath Property
WebReport Class See Also Send Feedback
Sets the path to custom buttons on site.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ButtonsPath { get; set; }
Visual Basic (Declaration)
Public Property ButtonsPath As String
Visual C++
public:
property String^ ButtonsPath {
    String^ get ();
    void set (String^ value);
}

Remarks

Pictures should be named: Export.gif, First.gif, First_disabled.gif, Last.gif, Last_disabled.gif, Next.gif, Next_disabled.gif, Prev.gif, Prev_disabled.gif, Print.gif, Refresh.gif, Zoom.gif

See Also

WebReport Class
FastReport.Web Namespace


CacheDelay Property

[image]

FastReport.Net Class Reference
WebReport..::.CacheDelay Property
WebReport Class See Also Send Feedback
Delay in cache in minutes

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int CacheDelay { get; set; }
Visual Basic (Declaration)
Public Property CacheDelay As Integer
Visual C++
public:
property int CacheDelay {
    int get ();
    void set (int value);
}

See Also

WebReport Class
FastReport.Web Namespace


CachePriority Property

[image]

FastReport.Net Class Reference
WebReport..::.CachePriority Property
WebReport Class See Also Send Feedback
Priority of items in cache

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public CacheItemPriority CachePriority { get; set; }
Visual Basic (Declaration)
Public Property CachePriority As CacheItemPriority
Visual C++
public:
property CacheItemPriority CachePriority {
    CacheItemPriority get ();
    void set (CacheItemPriority value);
}

See Also

WebReport Class
FastReport.Web Namespace


CsvDataOnly Property

[image]

FastReport.Net Class Reference
WebReport..::.CsvDataOnly Property
WebReport Class See Also Send Feedback
Enable or disable of exporting data without any header/group bands.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool CsvDataOnly { get; set; }
Visual Basic (Declaration)
Public Property CsvDataOnly As Boolean
Visual C++
public:
property bool CsvDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


CsvSeparator Property

[image]

FastReport.Net Class Reference
WebReport..::.CsvSeparator Property
WebReport Class See Also Send Feedback
Gets or sets of cells separator.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string CsvSeparator { get; set; }
Visual Basic (Declaration)
Public Property CsvSeparator As String
Visual C++
public:
property String^ CsvSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


CurrentPage Property

[image]

FastReport.Net Class Reference
WebReport..::.CurrentPage Property
WebReport Class See Also Send Feedback
Gets or sets number of current page

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int CurrentPage { get; set; }
Visual Basic (Declaration)
Public Property CurrentPage As Integer
Visual C++
public:
property int CurrentPage {
    int get ();
    void set (int value);
}

See Also

WebReport Class
FastReport.Web Namespace


DocxMatrixBased Property

[image]

FastReport.Net Class Reference
WebReport..::.DocxMatrixBased Property
WebReport Class See Also Send Feedback
Enable or disable matrix view of Word 2007 document

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool DocxMatrixBased { get; set; }
Visual Basic (Declaration)
Public Property DocxMatrixBased As Boolean
Visual C++
public:
property bool DocxMatrixBased {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ExternalJquery Property

[image]

FastReport.Net Class Reference
WebReport..::.ExternalJquery Property
WebReport Class See Also Send Feedback
Enable or disable using of external jQuery library

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ExternalJquery { get; set; }
Visual Basic (Declaration)
Public Property ExternalJquery As Boolean
Visual C++
public:
property bool ExternalJquery {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


Layers Property

[image]

FastReport.Net Class Reference
WebReport..::.Layers Property
WebReport Class See Also Send Feedback
Enable or disable layers mode visualisation

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool Layers { get; set; }
Visual Basic (Declaration)
Public Property Layers As Boolean
Visual C++
public:
property bool Layers {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


LocalizationFile Property

[image]

FastReport.Net Class Reference
WebReport..::.LocalizationFile Property
WebReport Class See Also Send Feedback
Gets or sets the name of localization file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string LocalizationFile { get; set; }
Visual Basic (Declaration)
Public Property LocalizationFile As String
Visual C++
public:
property String^ LocalizationFile {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


MhtPictures Property

[image]

FastReport.Net Class Reference
WebReport..::.MhtPictures Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that pictures are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool MhtPictures { get; set; }
Visual Basic (Declaration)
Public Property MhtPictures As Boolean
Visual C++
public:
property bool MhtPictures {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


MhtWysiwyg Property

[image]

FastReport.Net Class Reference
WebReport..::.MhtWysiwyg Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool MhtWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property MhtWysiwyg As Boolean
Visual C++
public:
property bool MhtWysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

WebReport Class
FastReport.Web Namespace


OdsCreator Property

[image]

FastReport.Net Class Reference
WebReport..::.OdsCreator Property
WebReport Class See Also Send Feedback
Gets or sets the creator of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string OdsCreator { get; set; }
Visual Basic (Declaration)
Public Property OdsCreator As String
Visual C++
public:
property String^ OdsCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


OdsPageBreaks Property

[image]

FastReport.Net Class Reference
WebReport..::.OdsPageBreaks Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdsPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property OdsPageBreaks As Boolean
Visual C++
public:
property bool OdsPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


OdsWysiwyg Property

[image]

FastReport.Net Class Reference
WebReport..::.OdsWysiwyg Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdsWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property OdsWysiwyg As Boolean
Visual C++
public:
property bool OdsWysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

WebReport Class
FastReport.Web Namespace


OdtCreator Property

[image]

FastReport.Net Class Reference
WebReport..::.OdtCreator Property
WebReport Class See Also Send Feedback
Gets or sets the creator of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string OdtCreator { get; set; }
Visual Basic (Declaration)
Public Property OdtCreator As String
Visual C++
public:
property String^ OdtCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


OdtPageBreaks Property

[image]

FastReport.Net Class Reference
WebReport..::.OdtPageBreaks Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdtPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property OdtPageBreaks As Boolean
Visual C++
public:
property bool OdtPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


OdtWysiwyg Property

[image]

FastReport.Net Class Reference
WebReport..::.OdtWysiwyg Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdtWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property OdtWysiwyg As Boolean
Visual C++
public:
property bool OdtWysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

WebReport Class
FastReport.Web Namespace


Padding Property

[image]

FastReport.Net Class Reference
WebReport..::.Padding Property
WebReport Class See Also Send Feedback
Gets or sets Padding of Report section

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfAllowAnnotate Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfAllowAnnotate Property
WebReport Class See Also Send Feedback
Enable or disable annotating in protected document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowAnnotate { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowAnnotate As Boolean
Visual C++
public:
property bool PdfAllowAnnotate {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfAllowCopy Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfAllowCopy Property
WebReport Class See Also Send Feedback
Enable or disable copying in protected document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowCopy { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowCopy As Boolean
Visual C++
public:
property bool PdfAllowCopy {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfAllowModify Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfAllowModify Property
WebReport Class See Also Send Feedback
Enable or disable modifying in protected document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowModify { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowModify As Boolean
Visual C++
public:
property bool PdfAllowModify {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfAllowPrint Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfAllowPrint Property
WebReport Class See Also Send Feedback
Enable or disable printing in protected document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowPrint { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowPrint As Boolean
Visual C++
public:
property bool PdfAllowPrint {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfAuthor Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfAuthor Property
WebReport Class See Also Send Feedback
Author of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfAuthor { get; set; }
Visual Basic (Declaration)
Public Property PdfAuthor As String
Visual C++
public:
property String^ PdfAuthor {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfBackground Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfBackground Property
WebReport Class See Also Send Feedback
Enable or disable of exporting the background.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfBackground { get; set; }
Visual Basic (Declaration)
Public Property PdfBackground As Boolean
Visual C++
public:
property bool PdfBackground {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfCenterWindow Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfCenterWindow Property
WebReport Class See Also Send Feedback
Enable or disable centering the window.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfCenterWindow { get; set; }
Visual Basic (Declaration)
Public Property PdfCenterWindow As Boolean
Visual C++
public:
property bool PdfCenterWindow {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfCreator Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfCreator Property
WebReport Class See Also Send Feedback
Creator of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfCreator { get; set; }
Visual Basic (Declaration)
Public Property PdfCreator As String
Visual C++
public:
property String^ PdfCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfDisplayDocTitle Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfDisplayDocTitle Property
WebReport Class See Also Send Feedback
Enable or disable of displaying document's title.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfDisplayDocTitle { get; set; }
Visual Basic (Declaration)
Public Property PdfDisplayDocTitle As Boolean
Visual C++
public:
property bool PdfDisplayDocTitle {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfEmbeddingFonts Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfEmbeddingFonts Property
WebReport Class See Also Send Feedback
Enable or disable of embedding the TrueType fonts.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfEmbeddingFonts { get; set; }
Visual Basic (Declaration)
Public Property PdfEmbeddingFonts As Boolean
Visual C++
public:
property bool PdfEmbeddingFonts {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfFitWindow Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfFitWindow Property
WebReport Class See Also Send Feedback
Enable or disable of fitting the window.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfFitWindow { get; set; }
Visual Basic (Declaration)
Public Property PdfFitWindow As Boolean
Visual C++
public:
property bool PdfFitWindow {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfHideMenubar Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfHideMenubar Property
WebReport Class See Also Send Feedback
Enable or disable hide the menu's bar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfHideMenubar { get; set; }
Visual Basic (Declaration)
Public Property PdfHideMenubar As Boolean
Visual C++
public:
property bool PdfHideMenubar {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfHideToolbar Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfHideToolbar Property
WebReport Class See Also Send Feedback
Enable or disable hide the toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfHideToolbar { get; set; }
Visual Basic (Declaration)
Public Property PdfHideToolbar As Boolean
Visual C++
public:
property bool PdfHideToolbar {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfHideWindowUI Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfHideWindowUI Property
WebReport Class See Also Send Feedback
Enable or disable hide the Windows UI.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfHideWindowUI { get; set; }
Visual Basic (Declaration)
Public Property PdfHideWindowUI As Boolean
Visual C++
public:
property bool PdfHideWindowUI {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfKeywords Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfKeywords Property
WebReport Class See Also Send Feedback
Keywords of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfKeywords { get; set; }
Visual Basic (Declaration)
Public Property PdfKeywords As String
Visual C++
public:
property String^ PdfKeywords {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfOutline Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfOutline Property
WebReport Class See Also Send Feedback
Enable or disable of document's Outline.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfOutline { get; set; }
Visual Basic (Declaration)
Public Property PdfOutline As Boolean
Visual C++
public:
property bool PdfOutline {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfOwnerPassword Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfOwnerPassword Property
WebReport Class See Also Send Feedback
Sets the owner password.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfOwnerPassword { get; set; }
Visual Basic (Declaration)
Public Property PdfOwnerPassword As String
Visual C++
public:
property String^ PdfOwnerPassword {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfPrintOptimized Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfPrintOptimized Property
WebReport Class See Also Send Feedback
Enable or disable of optimization the images for printing.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfPrintOptimized { get; set; }
Visual Basic (Declaration)
Public Property PdfPrintOptimized As Boolean
Visual C++
public:
property bool PdfPrintOptimized {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfPrintScaling Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfPrintScaling Property
WebReport Class See Also Send Feedback
Enable or disable of scaling the page for shrink to printable area.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfPrintScaling { get; set; }
Visual Basic (Declaration)
Public Property PdfPrintScaling As Boolean
Visual C++
public:
property bool PdfPrintScaling {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfProducer Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfProducer Property
WebReport Class See Also Send Feedback
Producer of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfProducer { get; set; }
Visual Basic (Declaration)
Public Property PdfProducer As String
Visual C++
public:
property String^ PdfProducer {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfSubject Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfSubject Property
WebReport Class See Also Send Feedback
Subject of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfSubject { get; set; }
Visual Basic (Declaration)
Public Property PdfSubject As String
Visual C++
public:
property String^ PdfSubject {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfTitle Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfTitle Property
WebReport Class See Also Send Feedback
Title of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfTitle { get; set; }
Visual Basic (Declaration)
Public Property PdfTitle As String
Visual C++
public:
property String^ PdfTitle {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PdfUserPassword Property

[image]

FastReport.Net Class Reference
WebReport..::.PdfUserPassword Property
WebReport Class See Also Send Feedback
Sets the users password.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfUserPassword { get; set; }
Visual Basic (Declaration)
Public Property PdfUserPassword As String
Visual C++
public:
property String^ PdfUserPassword {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


Pictures Property

[image]

FastReport.Net Class Reference
WebReport..::.Pictures Property
WebReport Class See Also Send Feedback
Switch the pictures visibility in report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool Pictures { get; set; }
Visual Basic (Declaration)
Public Property Pictures As Boolean
Visual C++
public:
property bool Pictures {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PptxImageFormat Property

[image]

FastReport.Net Class Reference
WebReport..::.PptxImageFormat Property
WebReport Class See Also Send Feedback
Gets or sets the image format that will be used to save pictures in PowerPoint file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public PptImageFormat PptxImageFormat { get; set; }
Visual Basic (Declaration)
Public Property PptxImageFormat As PptImageFormat
Visual C++
public:
property PptImageFormat PptxImageFormat {
    PptImageFormat get ();
    void set (PptImageFormat value);
}

See Also

WebReport Class
FastReport.Web Namespace


PrintInPdf Property

[image]

FastReport.Net Class Reference
WebReport..::.PrintInPdf Property
WebReport Class See Also Send Feedback
Enable or disable print in PDF

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintInPdf { get; set; }
Visual Basic (Declaration)
Public Property PrintInPdf As Boolean
Visual C++
public:
property bool PrintInPdf {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


PrintWindowHeight Property

[image]

FastReport.Net Class Reference
WebReport..::.PrintWindowHeight Property
WebReport Class See Also Send Feedback
Sets the height of print window

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PrintWindowHeight { get; set; }
Visual Basic (Declaration)
Public Property PrintWindowHeight As String
Visual C++
public:
property String^ PrintWindowHeight {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


PrintWindowWidth Property

[image]

FastReport.Net Class Reference
WebReport..::.PrintWindowWidth Property
WebReport Class See Also Send Feedback
Sets the width of print window

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PrintWindowWidth { get; set; }
Visual Basic (Declaration)
Public Property PrintWindowWidth As String
Visual C++
public:
property String^ PrintWindowWidth {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


Report Property

[image]

FastReport.Net Class Reference
WebReport..::.Report Property
WebReport Class See Also Send Feedback
Direct access to Report object

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public Report Report { get; set; }
Visual Basic (Declaration)
Public Property Report As Report
Visual C++
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


ReportDataSources Property

[image]

FastReport.Net Class Reference
WebReport..::.ReportDataSources Property
WebReport Class See Also Send Feedback
Gets or sets report data source(s).

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportDataSources { get; set; }
Visual Basic (Declaration)
Public Property ReportDataSources As String
Visual C++
public:
property String^ ReportDataSources {
    String^ get ();
    void set (String^ value);
}

Remarks

To pass several datasources, use ';' delimiter, for example: "sqlDataSource1;sqlDataSource2"

See Also

WebReport Class
FastReport.Web Namespace


ReportDone Property

[image]

FastReport.Net Class Reference
WebReport..::.ReportDone Property
WebReport Class See Also Send Feedback
Return true if report done

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ReportDone { get; set; }
Visual Basic (Declaration)
Public Property ReportDone As Boolean
Visual C++
public:
property bool ReportDone {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ReportFile Property

[image]

FastReport.Net Class Reference
WebReport..::.ReportFile Property
WebReport Class See Also Send Feedback
Gets or sets the name of report file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportFile { get; set; }
Visual Basic (Declaration)
Public Property ReportFile As String
Visual C++
public:
property String^ ReportFile {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


ReportGuid Property

[image]

FastReport.Net Class Reference
WebReport..::.ReportGuid Property
WebReport Class See Also Send Feedback
Gets or sets guid of report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportGuid { get; set; }
Visual Basic (Declaration)
Public Property ReportGuid As String
Visual C++
public:
property String^ ReportGuid {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


ReportResourceString Property

[image]

FastReport.Net Class Reference
WebReport..::.ReportResourceString Property
WebReport Class See Also Send Feedback
Report Resource String

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportResourceString { get; set; }
Visual Basic (Declaration)
Public Property ReportResourceString As String
Visual C++
public:
property String^ ReportResourceString {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


RtfAutoSize Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfAutoSize Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the rows in the resulting table should calculate its height automatically.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfAutoSize { get; set; }
Visual Basic (Declaration)
Public Property RtfAutoSize As Boolean
Visual C++
public:
property bool RtfAutoSize {
    bool get ();
    void set (bool value);
}

Remarks

Default value for this property is false. In this mode, each row in the resulting table has fixed height to get maximum wysiwyg. If you set it to true, the height of resulting table will be calculated automatically by the Word processor. The document will be more editable, but less wysiwyg.

See Also

WebReport Class
FastReport.Web Namespace


RtfCreator Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfCreator Property
WebReport Class See Also Send Feedback
Gets or sets the creator of the document.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string RtfCreator { get; set; }
Visual Basic (Declaration)
Public Property RtfCreator As String
Visual C++
public:
property String^ RtfCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


RtfImageFormat Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfImageFormat Property
WebReport Class See Also Send Feedback
Gets or sets the image format that will be used to save pictures in RTF file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public RTFImageFormat RtfImageFormat { get; set; }
Visual Basic (Declaration)
Public Property RtfImageFormat As RTFImageFormat
Visual C++
public:
property RTFImageFormat RtfImageFormat {
    RTFImageFormat get ();
    void set (RTFImageFormat value);
}

Remarks

Default value is Metafile. This format is better for exporting such objects as MSChartObject and ShapeObject.

See Also

WebReport Class
FastReport.Web Namespace


RtfJpegQuality Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfJpegQuality Property
WebReport Class See Also Send Feedback
Gets or sets the quality of Jpeg images in RTF file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int RtfJpegQuality { get; set; }
Visual Basic (Declaration)
Public Property RtfJpegQuality As Integer
Visual C++
public:
property int RtfJpegQuality {
    int get ();
    void set (int value);
}

Remarks

Default value is 90. This property will be used if you select Jpeg in the RtfImageFormat property.

See Also

WebReport Class
FastReport.Web Namespace


RtfPageBreaks Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfPageBreaks Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property RtfPageBreaks As Boolean
Visual C++
public:
property bool RtfPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


RtfPictures Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfPictures Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that pictures are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfPictures { get; set; }
Visual Basic (Declaration)
Public Property RtfPictures As Boolean
Visual C++
public:
property bool RtfPictures {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


RtfWysiwyg Property

[image]

FastReport.Net Class Reference
WebReport..::.RtfWysiwyg Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property RtfWysiwyg As Boolean
Visual C++
public:
property bool RtfWysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

WebReport Class
FastReport.Web Namespace


ShowCsvExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowCsvExport Property
WebReport Class See Also Send Feedback
Switch visibility of CSV (comma separated values) export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowCsvExport { get; set; }
Visual Basic (Declaration)
Public Property ShowCsvExport As Boolean
Visual C++
public:
property bool ShowCsvExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowDbfExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowDbfExport Property
WebReport Class See Also Send Feedback
Switch visibility of DBF export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowDbfExport { get; set; }
Visual Basic (Declaration)
Public Property ShowDbfExport As Boolean
Visual C++
public:
property bool ShowDbfExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowExcel2007Export Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowExcel2007Export Property
WebReport Class See Also Send Feedback
Switch visibility of Excel 2007 export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowExcel2007Export { get; set; }
Visual Basic (Declaration)
Public Property ShowExcel2007Export As Boolean
Visual C++
public:
property bool ShowExcel2007Export {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowExports Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowExports Property
WebReport Class See Also Send Feedback
Switch visibility of Exports in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowExports { get; set; }
Visual Basic (Declaration)
Public Property ShowExports As Boolean
Visual C++
public:
property bool ShowExports {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowFirstButton Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowFirstButton Property
WebReport Class See Also Send Feedback
Switch visibility of First Button in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowFirstButton { get; set; }
Visual Basic (Declaration)
Public Property ShowFirstButton As Boolean
Visual C++
public:
property bool ShowFirstButton {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowLastButton Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowLastButton Property
WebReport Class See Also Send Feedback
Switch visibility of Last Button in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowLastButton { get; set; }
Visual Basic (Declaration)
Public Property ShowLastButton As Boolean
Visual C++
public:
property bool ShowLastButton {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowMhtExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowMhtExport Property
WebReport Class See Also Send Feedback
Switch visibility of MHT (web-archive) export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowMhtExport { get; set; }
Visual Basic (Declaration)
Public Property ShowMhtExport As Boolean
Visual C++
public:
property bool ShowMhtExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowNextButton Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowNextButton Property
WebReport Class See Also Send Feedback
Switch visibility of Next Button in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowNextButton { get; set; }
Visual Basic (Declaration)
Public Property ShowNextButton As Boolean
Visual C++
public:
property bool ShowNextButton {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowOdsExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowOdsExport Property
WebReport Class See Also Send Feedback
Switch visibility of Open Office Spreadsheet (ODS) export in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowOdsExport { get; set; }
Visual Basic (Declaration)
Public Property ShowOdsExport As Boolean
Visual C++
public:
property bool ShowOdsExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowOdtExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowOdtExport Property
WebReport Class See Also Send Feedback
Switch visibility of Open Office Text (ODT) export in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowOdtExport { get; set; }
Visual Basic (Declaration)
Public Property ShowOdtExport As Boolean
Visual C++
public:
property bool ShowOdtExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowPageNumber Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowPageNumber Property
WebReport Class See Also Send Feedback
Switch visibility of Page Number in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPageNumber { get; set; }
Visual Basic (Declaration)
Public Property ShowPageNumber As Boolean
Visual C++
public:
property bool ShowPageNumber {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowPdfExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowPdfExport Property
WebReport Class See Also Send Feedback
Switch visibility of PDF (Adobe Acrobat) export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPdfExport { get; set; }
Visual Basic (Declaration)
Public Property ShowPdfExport As Boolean
Visual C++
public:
property bool ShowPdfExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowPowerPoint2007Export Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowPowerPoint2007Export Property
WebReport Class See Also Send Feedback
Switch visibility of PowerPoint 2007 export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPowerPoint2007Export { get; set; }
Visual Basic (Declaration)
Public Property ShowPowerPoint2007Export As Boolean
Visual C++
public:
property bool ShowPowerPoint2007Export {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowPrevButton Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowPrevButton Property
WebReport Class See Also Send Feedback
Switch visibility of Previous Button in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPrevButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPrevButton As Boolean
Visual C++
public:
property bool ShowPrevButton {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowPrint Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowPrint Property
WebReport Class See Also Send Feedback
Switch visibility of Print button in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPrint { get; set; }
Visual Basic (Declaration)
Public Property ShowPrint As Boolean
Visual C++
public:
property bool ShowPrint {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowRefreshButton Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowRefreshButton Property
WebReport Class See Also Send Feedback
Switch visibility of Refresh in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowRefreshButton { get; set; }
Visual Basic (Declaration)
Public Property ShowRefreshButton As Boolean
Visual C++
public:
property bool ShowRefreshButton {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowRtfExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowRtfExport Property
WebReport Class See Also Send Feedback
Switch visibility of RTF export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowRtfExport { get; set; }
Visual Basic (Declaration)
Public Property ShowRtfExport As Boolean
Visual C++
public:
property bool ShowRtfExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowTextExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowTextExport Property
WebReport Class See Also Send Feedback
Switch visibility of text (plain text) export in toolbar

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowTextExport { get; set; }
Visual Basic (Declaration)
Public Property ShowTextExport As Boolean
Visual C++
public:
property bool ShowTextExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowToolbar Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowToolbar Property
WebReport Class See Also Send Feedback
Switch toolbar visibility

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowToolbar { get; set; }
Visual Basic (Declaration)
Public Property ShowToolbar As Boolean
Visual C++
public:
property bool ShowToolbar {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowWord2007Export Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowWord2007Export Property
WebReport Class See Also Send Feedback
Switch visibility of Word 2007 export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowWord2007Export { get; set; }
Visual Basic (Declaration)
Public Property ShowWord2007Export As Boolean
Visual C++
public:
property bool ShowWord2007Export {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowXmlExcelExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowXmlExcelExport Property
WebReport Class See Also Send Feedback
Switch visibility of XML (Excel) export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowXmlExcelExport { get; set; }
Visual Basic (Declaration)
Public Property ShowXmlExcelExport As Boolean
Visual C++
public:
property bool ShowXmlExcelExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowXpsExport Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowXpsExport Property
WebReport Class See Also Send Feedback
Switch visibility of XPS export in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowXpsExport { get; set; }
Visual Basic (Declaration)
Public Property ShowXpsExport As Boolean
Visual C++
public:
property bool ShowXpsExport {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ShowZoomButton Property

[image]

FastReport.Net Class Reference
WebReport..::.ShowZoomButton Property
WebReport Class See Also Send Feedback
Switch visibility of Zoom in toolbar.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowZoomButton { get; set; }
Visual Basic (Declaration)
Public Property ShowZoomButton As Boolean
Visual C++
public:
property bool ShowZoomButton {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


State Property

[image]

FastReport.Net Class Reference
WebReport..::.State Property
WebReport Class See Also Send Feedback
Gets or sets current state of report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ReportState State { get; set; }
Visual Basic (Declaration)
Public Property State As ReportState
Visual C++
public:
property ReportState State {
    ReportState get ();
    void set (ReportState value);
}

See Also

WebReport Class
FastReport.Web Namespace


TextAllowFrames Property

[image]

FastReport.Net Class Reference
WebReport..::.TextAllowFrames Property
WebReport Class See Also Send Feedback
Enable or disable frames in text file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextAllowFrames { get; set; }
Visual Basic (Declaration)
Public Property TextAllowFrames As Boolean
Visual C++
public:
property bool TextAllowFrames {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


TextDataOnly Property

[image]

FastReport.Net Class Reference
WebReport..::.TextDataOnly Property
WebReport Class See Also Send Feedback
Enable or disable of exporting data without any header/group bands.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextDataOnly { get; set; }
Visual Basic (Declaration)
Public Property TextDataOnly As Boolean
Visual C++
public:
property bool TextDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


TextEmptyLines Property

[image]

FastReport.Net Class Reference
WebReport..::.TextEmptyLines Property
WebReport Class See Also Send Feedback
Enable or disable empty lines in text file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextEmptyLines { get; set; }
Visual Basic (Declaration)
Public Property TextEmptyLines As Boolean
Visual C++
public:
property bool TextEmptyLines {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


TextPageBreaks Property

[image]

FastReport.Net Class Reference
WebReport..::.TextPageBreaks Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property TextPageBreaks As Boolean
Visual C++
public:
property bool TextPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


TextSimpleFrames Property

[image]

FastReport.Net Class Reference
WebReport..::.TextSimpleFrames Property
WebReport Class See Also Send Feedback
Enable or disable simple (non graphic) frames in text file.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextSimpleFrames { get; set; }
Visual Basic (Declaration)
Public Property TextSimpleFrames As Boolean
Visual C++
public:
property bool TextSimpleFrames {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


ToolbarBackgroundStyle Property

[image]

FastReport.Net Class Reference
WebReport..::.ToolbarBackgroundStyle Property
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarBackgroundStyle ToolbarBackgroundStyle { get; set; }
Visual Basic (Declaration)
Public Property ToolbarBackgroundStyle As ToolbarBackgroundStyle
Visual C++
public:
property ToolbarBackgroundStyle ToolbarBackgroundStyle {
    ToolbarBackgroundStyle get ();
    void set (ToolbarBackgroundStyle value);
}

See Also

WebReport Class
FastReport.Web Namespace


ToolbarColor Property

[image]

FastReport.Net Class Reference
WebReport..::.ToolbarColor Property
WebReport Class See Also Send Feedback
Set the Toolbar color.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public Color ToolbarColor { get; set; }
Visual Basic (Declaration)
Public Property ToolbarColor As Color
Visual C++
public:
property Color ToolbarColor {
    Color get ();
    void set (Color value);
}

See Also

WebReport Class
FastReport.Web Namespace


ToolbarIconsStyle Property

[image]

FastReport.Net Class Reference
WebReport..::.ToolbarIconsStyle Property
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarIconsStyle ToolbarIconsStyle { get; set; }
Visual Basic (Declaration)
Public Property ToolbarIconsStyle As ToolbarIconsStyle
Visual C++
public:
property ToolbarIconsStyle ToolbarIconsStyle {
    ToolbarIconsStyle get ();
    void set (ToolbarIconsStyle value);
}

See Also

WebReport Class
FastReport.Web Namespace


ToolbarStyle Property

[image]

FastReport.Net Class Reference
WebReport..::.ToolbarStyle Property
WebReport Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarStyle ToolbarStyle { get; set; }
Visual Basic (Declaration)
Public Property ToolbarStyle As ToolbarStyle
Visual C++
public:
property ToolbarStyle ToolbarStyle {
    ToolbarStyle get ();
    void set (ToolbarStyle value);
}

See Also

WebReport Class
FastReport.Web Namespace


TotalPages Property

[image]

FastReport.Net Class Reference
WebReport..::.TotalPages Property
WebReport Class See Also Send Feedback
Gets total pages of current report

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int TotalPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalPages As Integer
Visual C++
public:
property int TotalPages {
    int get ();
}

See Also

WebReport Class
FastReport.Web Namespace


XlsxDataOnly Property

[image]

FastReport.Net Class Reference
WebReport..::.XlsxDataOnly Property
WebReport Class See Also Send Feedback
Enable or disable of exporting data without any header/group bands.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XlsxDataOnly { get; set; }
Visual Basic (Declaration)
Public Property XlsxDataOnly As Boolean
Visual C++
public:
property bool XlsxDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


XlsxPageBreaks Property

[image]

FastReport.Net Class Reference
WebReport..::.XlsxPageBreaks Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XlsxPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property XlsxPageBreaks As Boolean
Visual C++
public:
property bool XlsxPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


XlsxWysiwyg Property

[image]

FastReport.Net Class Reference
WebReport..::.XlsxWysiwyg Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XlsxWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property XlsxWysiwyg As Boolean
Visual C++
public:
property bool XlsxWysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

WebReport Class
FastReport.Web Namespace


XmlExcelDataOnly Property

[image]

FastReport.Net Class Reference
WebReport..::.XmlExcelDataOnly Property
WebReport Class See Also Send Feedback
Enable or disable of exporting data without any header/group bands.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XmlExcelDataOnly { get; set; }
Visual Basic (Declaration)
Public Property XmlExcelDataOnly As Boolean
Visual C++
public:
property bool XmlExcelDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


XmlExcelPageBreaks Property

[image]

FastReport.Net Class Reference
WebReport..::.XmlExcelPageBreaks Property
WebReport Class See Also Send Feedback
Gets or sets a value indicating that page breaks are enabled.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XmlExcelPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property XmlExcelPageBreaks As Boolean
Visual C++
public:
property bool XmlExcelPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReport Class
FastReport.Web Namespace


XmlExcelWysiwyg Property

[image]

FastReport.Net Class Reference
WebReport..::.XmlExcelWysiwyg Property
WebReport Class See Also Send Feedback
Gets or sets a value that determines whether the wysiwyg mode should be used for better results.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XmlExcelWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property XmlExcelWysiwyg As Boolean
Visual C++
public:
property bool XmlExcelWysiwyg {
    bool get ();
    void set (bool value);
}

Remarks

Default value is true. In wysiwyg mode, the resulting rtf file will look as close as possible to the prepared report. On the other side, it may have a lot of small rows/columns, which will make it less editable. If you set this property to false, the number of rows/columns in the resulting file will be decreased. You will get less wysiwyg, but more editable file.

See Also

WebReport Class
FastReport.Web Namespace


Zoom Property

[image]

FastReport.Net Class Reference
WebReport..::.Zoom Property
WebReport Class See Also Send Feedback
Set the zoom factor of previewed page between 0..1

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public float Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Single
Visual C++
public:
property float Zoom {
    float get ();
    void set (float value);
}

See Also

WebReport Class
FastReport.Web Namespace


WebReport Events

[image] [image]

FastReport.Net Class Reference
WebReport Events
WebReport Class See Also Send Feedback

The WebReport type exposes the following members.

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
StartReport | Occurs when report execution is started.
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WebReport Class
FastReport.Web Namespace


StartReport Event

[image]

FastReport.Net Class Reference
WebReport..::.StartReport Event
WebReport Class See Also Send Feedback
Occurs when report execution is started.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public event EventHandler StartReport
Visual Basic (Declaration)
Public Event StartReport As EventHandler
Visual C++
public:
 event EventHandler^ StartReport {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

WebReport Class
FastReport.Web Namespace


WebReportCache Class

[image]

FastReport.Net Class Reference
WebReportCache Class
Members See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static class WebReportCache
Visual Basic (Declaration)
Public NotInheritable Class WebReportCache
Visual C++
public ref class WebReportCache abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Web..::.WebReportCache

See Also

WebReportCache Members
FastReport.Web Namespace


WebReportCache Members

[image] [image]

FastReport.Net Class Reference
WebReportCache Members
WebReportCache Class Methods See Also Send Feedback

The WebReportCache type exposes the following members.

Methods

Name | Description
CacheAdd |
CacheGet |
CacheRemove |
CleanStorage |
GetFileStorage |
GetStorageCleanup |
GetStoragePath |
GetStorageTimeout |
PutFileStorage |

See Also

WebReportCache Class
FastReport.Web Namespace


WebReportCache Methods

[image] [image]

FastReport.Net Class Reference
WebReportCache Methods
WebReportCache Class See Also Send Feedback

The WebReportCache type exposes the following members.

Methods

Name | Description
CacheAdd |
CacheGet |
CacheRemove |
CleanStorage |
GetFileStorage |
GetStorageCleanup |
GetStoragePath |
GetStorageTimeout |
PutFileStorage |

See Also

WebReportCache Class
FastReport.Web Namespace


CacheAdd Method

[image]

FastReport.Net Class Reference
WebReportCache..::.CacheAdd Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static void CacheAdd(
    string Name,
    Object Obj,
    CacheItemRemovedCallback DisposeCallBack,
    int CacheDelay,
    CacheItemPriority Priority
)
Visual Basic (Declaration)
Public Shared Sub CacheAdd ( _
    Name As String, _
    Obj As Object, _
    DisposeCallBack As CacheItemRemovedCallback, _
    CacheDelay As Integer, _
    Priority As CacheItemPriority _
)
Visual C++
public:
static void CacheAdd(
    String^ Name,
    Object^ Obj,
    CacheItemRemovedCallback^ DisposeCallBack,
    int CacheDelay,
    CacheItemPriority Priority
)

Parameters

Name
Type: System..::.String
Obj
Type: System..::.Object
DisposeCallBack
Type: System.Web.Caching..::.CacheItemRemovedCallback
CacheDelay
Type: System..::.Int32
Priority
Type: System.Web.Caching..::.CacheItemPriority

See Also

WebReportCache Class
FastReport.Web Namespace


CacheGet Method

[image]

FastReport.Net Class Reference
WebReportCache..::.CacheGet Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static Object CacheGet(
    string Name
)
Visual Basic (Declaration)
Public Shared Function CacheGet ( _
    Name As String _
) As Object
Visual C++
public:
static Object^ CacheGet(
    String^ Name
)

Parameters

Name
Type: System..::.String

Return Value

See Also

WebReportCache Class
FastReport.Web Namespace


CacheRemove Method

[image]

FastReport.Net Class Reference
WebReportCache..::.CacheRemove Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static Object CacheRemove(
    string Name
)
Visual Basic (Declaration)
Public Shared Function CacheRemove ( _
    Name As String _
) As Object
Visual C++
public:
static Object^ CacheRemove(
    String^ Name
)

Parameters

Name
Type: System..::.String

Return Value

See Also

WebReportCache Class
FastReport.Web Namespace


CleanStorage Method

[image]

FastReport.Net Class Reference
WebReportCache..::.CleanStorage Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static int CleanStorage(
    string FileStoragePath,
    int FileStorageTimeout,
    int FileStorageCleanup
)
Visual Basic (Declaration)
Public Shared Function CleanStorage ( _
    FileStoragePath As String, _
    FileStorageTimeout As Integer, _
    FileStorageCleanup As Integer _
) As Integer
Visual C++
public:
static int CleanStorage(
    String^ FileStoragePath,
    int FileStorageTimeout,
    int FileStorageCleanup
)

Parameters

FileStoragePath
Type: System..::.String
FileStorageTimeout
Type: System..::.Int32
FileStorageCleanup
Type: System..::.Int32

See Also

WebReportCache Class
FastReport.Web Namespace


GetFileStorage Method

[image]

FastReport.Net Class Reference
WebReportCache..::.GetFileStorage Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static Object GetFileStorage(
    string prefix,
    string suffix,
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFileStorage ( _
    prefix As String, _
    suffix As String, _
    path As String _
) As Object
Visual C++
public:
static Object^ GetFileStorage(
    String^ prefix,
    String^ suffix,
    String^ path
)

Parameters

prefix
Type: System..::.String
suffix
Type: System..::.String
path
Type: System..::.String

Return Value

See Also

WebReportCache Class
FastReport.Web Namespace


GetStorageCleanup Method

[image]

FastReport.Net Class Reference
WebReportCache..::.GetStorageCleanup Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static int GetStorageCleanup()
Visual Basic (Declaration)
Public Shared Function GetStorageCleanup As Integer
Visual C++
public:
static int GetStorageCleanup()

Return Value

See Also

WebReportCache Class
FastReport.Web Namespace


GetStoragePath Method

[image]

FastReport.Net Class Reference
WebReportCache..::.GetStoragePath Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static string GetStoragePath(
    HttpContext context
)
Visual Basic (Declaration)
Public Shared Function GetStoragePath ( _
    context As HttpContext _
) As String
Visual C++
public:
static String^ GetStoragePath(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::.HttpContext

Return Value

See Also

WebReportCache Class
FastReport.Web Namespace


GetStorageTimeout Method

[image]

FastReport.Net Class Reference
WebReportCache..::.GetStorageTimeout Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static int GetStorageTimeout()
Visual Basic (Declaration)
Public Shared Function GetStorageTimeout As Integer
Visual C++
public:
static int GetStorageTimeout()

Return Value

See Also

WebReportCache Class
FastReport.Web Namespace


PutFileStorage Method

[image]

FastReport.Net Class Reference
WebReportCache..::.PutFileStorage Method
WebReportCache Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static void PutFileStorage(
    string prefix,
    string suffix,
    Object value,
    string path
)
Visual Basic (Declaration)
Public Shared Sub PutFileStorage ( _
    prefix As String, _
    suffix As String, _
    value As Object, _
    path As String _
)
Visual C++
public:
static void PutFileStorage(
    String^ prefix,
    String^ suffix,
    Object^ value,
    String^ path
)

Parameters

prefix
Type: System..::.String
suffix
Type: System..::.String
value
Type: System..::.Object
path
Type: System..::.String

See Also

WebReportCache Class
FastReport.Web Namespace


WebReportProperties Class

[image]

FastReport.Net Class Reference
WebReportProperties Class
Members See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
[SerializableAttribute]
public class WebReportProperties
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WebReportProperties
Visual C++
[SerializableAttribute]
public ref class WebReportProperties

Inheritance Hierarchy

System..::.Object
FastReport.Web..::.WebReportProperties

See Also

WebReportProperties Members
FastReport.Web Namespace


WebReportProperties Members

[image] [image]

FastReport.Net Class Reference
WebReportProperties Members
WebReportProperties Class Constructors Methods Properties See Also Send Feedback

The WebReportProperties type exposes the following members.

Constructors

Name | Description
WebReportProperties | Initializes a new instance of the WebReportProperties class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoHeight |
AutoWidth |
ButtonsPath |
CacheDelay |
CachePriority |
CsvDataOnly |
CsvSeparator |
CurrentPage |
DocxMatrixBased |
ExternalJquery |
Layers |
LocalizationFile |
MhtPictures |
MhtWysiwyg |
OdsCreator |
OdsPageBreaks |
OdsWysiwyg |
OdtCreator |
OdtPageBreaks |
OdtWysiwyg |
Padding |
PdfAllowAnnotate |
PdfAllowCopy |
PdfAllowModify |
PdfAllowPrint |
PdfAuthor |
PdfBackground |
PdfCenterWindow |
PdfCreator |
PdfDisplayDocTitle |
PdfEmbeddingFonts |
PdfFitWindow |
PdfHideMenubar |
PdfHideToolbar |
PdfHideWindowUI |
PdfKeywords |
PdfOutline |
PdfOwnerPassword |
PdfPrintOptimized |
PdfPrintScaling |
PdfProducer |
PdfSubject |
PdfTitle |
PdfUserPassword |
Pictures |
PptxImageFormat |
PrintInPdf |
PrintWindowHeight |
PrintWindowWidth |
ReportDataSources |
ReportDone |
ReportFile |
ReportResourceString |
RtfAutoSize |
RtfCreator |
RtfImageFormat |
RtfJpegQuality |
RtfPageBreaks |
RtfPictures |
RtfWysiwyg |
ShowBottomToolbar |
ShowCsvExport |
ShowDbfExport |
ShowExcel2007Export |
ShowExports |
ShowFirstButton |
ShowLastButton |
ShowMhtExport |
ShowNextButton |
ShowOdsExport |
ShowOdtExport |
ShowPageNumber |
ShowPdfExport |
ShowPowerPoint2007Export |
ShowPrevButton |
ShowPrint |
ShowRefreshButton |
ShowRtfExport |
ShowTextExport |
ShowToolbar |
ShowWord2007Export |
ShowXmlExcelExport |
ShowXpsExport |
ShowZoomButton |
TextAllowFrames |
TextDataOnly |
TextEmptyLines |
TextPageBreaks |
TextSimpleFrames |
ToolbarBackgroundStyle |
ToolbarColor |
ToolbarIconsStyle |
ToolbarStyle |
TotalPages |
XlsxDataOnly |
XlsxPageBreaks |
XlsxWysiwyg |
XmlExcelDataOnly |
XmlExcelPageBreaks |
XmlExcelWysiwyg |
Zoom |
ZoomMode |

See Also

WebReportProperties Class
FastReport.Web Namespace


WebReportProperties Constructor

[image]

FastReport.Net Class Reference
WebReportProperties Constructor
WebReportProperties Class See Also Send Feedback
Initializes a new instance of the WebReportProperties class

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReportProperties()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebReportProperties()

See Also

WebReportProperties Class
FastReport.Web Namespace


WebReportProperties Methods

[image] [image]

FastReport.Net Class Reference
WebReportProperties Methods
WebReportProperties Class See Also Send Feedback

The WebReportProperties type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebReportProperties Class
FastReport.Web Namespace


WebReportProperties Properties

[image] [image]

FastReport.Net Class Reference
WebReportProperties Properties
WebReportProperties Class See Also Send Feedback

The WebReportProperties type exposes the following members.

Properties

Name | Description
AutoHeight |
AutoWidth |
ButtonsPath |
CacheDelay |
CachePriority |
CsvDataOnly |
CsvSeparator |
CurrentPage |
DocxMatrixBased |
ExternalJquery |
Layers |
LocalizationFile |
MhtPictures |
MhtWysiwyg |
OdsCreator |
OdsPageBreaks |
OdsWysiwyg |
OdtCreator |
OdtPageBreaks |
OdtWysiwyg |
Padding |
PdfAllowAnnotate |
PdfAllowCopy |
PdfAllowModify |
PdfAllowPrint |
PdfAuthor |
PdfBackground |
PdfCenterWindow |
PdfCreator |
PdfDisplayDocTitle |
PdfEmbeddingFonts |
PdfFitWindow |
PdfHideMenubar |
PdfHideToolbar |
PdfHideWindowUI |
PdfKeywords |
PdfOutline |
PdfOwnerPassword |
PdfPrintOptimized |
PdfPrintScaling |
PdfProducer |
PdfSubject |
PdfTitle |
PdfUserPassword |
Pictures |
PptxImageFormat |
PrintInPdf |
PrintWindowHeight |
PrintWindowWidth |
ReportDataSources |
ReportDone |
ReportFile |
ReportResourceString |
RtfAutoSize |
RtfCreator |
RtfImageFormat |
RtfJpegQuality |
RtfPageBreaks |
RtfPictures |
RtfWysiwyg |
ShowBottomToolbar |
ShowCsvExport |
ShowDbfExport |
ShowExcel2007Export |
ShowExports |
ShowFirstButton |
ShowLastButton |
ShowMhtExport |
ShowNextButton |
ShowOdsExport |
ShowOdtExport |
ShowPageNumber |
ShowPdfExport |
ShowPowerPoint2007Export |
ShowPrevButton |
ShowPrint |
ShowRefreshButton |
ShowRtfExport |
ShowTextExport |
ShowToolbar |
ShowWord2007Export |
ShowXmlExcelExport |
ShowXpsExport |
ShowZoomButton |
TextAllowFrames |
TextDataOnly |
TextEmptyLines |
TextPageBreaks |
TextSimpleFrames |
ToolbarBackgroundStyle |
ToolbarColor |
ToolbarIconsStyle |
ToolbarStyle |
TotalPages |
XlsxDataOnly |
XlsxPageBreaks |
XlsxWysiwyg |
XmlExcelDataOnly |
XmlExcelPageBreaks |
XmlExcelWysiwyg |
Zoom |
ZoomMode |

See Also

WebReportProperties Class
FastReport.Web Namespace


AutoHeight Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.AutoHeight Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoHeight { get; set; }
Visual Basic (Declaration)
Public Property AutoHeight As Boolean
Visual C++
public:
property bool AutoHeight {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


AutoWidth Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.AutoWidth Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool AutoWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoWidth As Boolean
Visual C++
public:
property bool AutoWidth {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ButtonsPath Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ButtonsPath Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ButtonsPath { get; set; }
Visual Basic (Declaration)
Public Property ButtonsPath As String
Visual C++
public:
property String^ ButtonsPath {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


CacheDelay Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.CacheDelay Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int CacheDelay { get; set; }
Visual Basic (Declaration)
Public Property CacheDelay As Integer
Visual C++
public:
property int CacheDelay {
    int get ();
    void set (int value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


CachePriority Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.CachePriority Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public CacheItemPriority CachePriority { get; set; }
Visual Basic (Declaration)
Public Property CachePriority As CacheItemPriority
Visual C++
public:
property CacheItemPriority CachePriority {
    CacheItemPriority get ();
    void set (CacheItemPriority value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


CsvDataOnly Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.CsvDataOnly Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool CsvDataOnly { get; set; }
Visual Basic (Declaration)
Public Property CsvDataOnly As Boolean
Visual C++
public:
property bool CsvDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


CsvSeparator Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.CsvSeparator Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string CsvSeparator { get; set; }
Visual Basic (Declaration)
Public Property CsvSeparator As String
Visual C++
public:
property String^ CsvSeparator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


CurrentPage Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.CurrentPage Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int CurrentPage { get; set; }
Visual Basic (Declaration)
Public Property CurrentPage As Integer
Visual C++
public:
property int CurrentPage {
    int get ();
    void set (int value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


DocxMatrixBased Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.DocxMatrixBased Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool DocxMatrixBased { get; set; }
Visual Basic (Declaration)
Public Property DocxMatrixBased As Boolean
Visual C++
public:
property bool DocxMatrixBased {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ExternalJquery Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ExternalJquery Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ExternalJquery { get; set; }
Visual Basic (Declaration)
Public Property ExternalJquery As Boolean
Visual C++
public:
property bool ExternalJquery {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


Layers Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.Layers Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool Layers { get; set; }
Visual Basic (Declaration)
Public Property Layers As Boolean
Visual C++
public:
property bool Layers {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


LocalizationFile Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.LocalizationFile Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string LocalizationFile { get; set; }
Visual Basic (Declaration)
Public Property LocalizationFile As String
Visual C++
public:
property String^ LocalizationFile {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


MhtPictures Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.MhtPictures Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool MhtPictures { get; set; }
Visual Basic (Declaration)
Public Property MhtPictures As Boolean
Visual C++
public:
property bool MhtPictures {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


MhtWysiwyg Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.MhtWysiwyg Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool MhtWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property MhtWysiwyg As Boolean
Visual C++
public:
property bool MhtWysiwyg {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


OdsCreator Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.OdsCreator Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string OdsCreator { get; set; }
Visual Basic (Declaration)
Public Property OdsCreator As String
Visual C++
public:
property String^ OdsCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


OdsPageBreaks Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.OdsPageBreaks Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdsPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property OdsPageBreaks As Boolean
Visual C++
public:
property bool OdsPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


OdsWysiwyg Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.OdsWysiwyg Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdsWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property OdsWysiwyg As Boolean
Visual C++
public:
property bool OdsWysiwyg {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


OdtCreator Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.OdtCreator Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string OdtCreator { get; set; }
Visual Basic (Declaration)
Public Property OdtCreator As String
Visual C++
public:
property String^ OdtCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


OdtPageBreaks Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.OdtPageBreaks Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdtPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property OdtPageBreaks As Boolean
Visual C++
public:
property bool OdtPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


OdtWysiwyg Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.OdtWysiwyg Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool OdtWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property OdtWysiwyg As Boolean
Visual C++
public:
property bool OdtWysiwyg {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


Padding Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.Padding Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public Padding Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Padding
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfAllowAnnotate Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfAllowAnnotate Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowAnnotate { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowAnnotate As Boolean
Visual C++
public:
property bool PdfAllowAnnotate {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfAllowCopy Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfAllowCopy Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowCopy { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowCopy As Boolean
Visual C++
public:
property bool PdfAllowCopy {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfAllowModify Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfAllowModify Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowModify { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowModify As Boolean
Visual C++
public:
property bool PdfAllowModify {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfAllowPrint Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfAllowPrint Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfAllowPrint { get; set; }
Visual Basic (Declaration)
Public Property PdfAllowPrint As Boolean
Visual C++
public:
property bool PdfAllowPrint {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfAuthor Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfAuthor Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfAuthor { get; set; }
Visual Basic (Declaration)
Public Property PdfAuthor As String
Visual C++
public:
property String^ PdfAuthor {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfBackground Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfBackground Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfBackground { get; set; }
Visual Basic (Declaration)
Public Property PdfBackground As Boolean
Visual C++
public:
property bool PdfBackground {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfCenterWindow Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfCenterWindow Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfCenterWindow { get; set; }
Visual Basic (Declaration)
Public Property PdfCenterWindow As Boolean
Visual C++
public:
property bool PdfCenterWindow {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfCreator Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfCreator Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfCreator { get; set; }
Visual Basic (Declaration)
Public Property PdfCreator As String
Visual C++
public:
property String^ PdfCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfDisplayDocTitle Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfDisplayDocTitle Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfDisplayDocTitle { get; set; }
Visual Basic (Declaration)
Public Property PdfDisplayDocTitle As Boolean
Visual C++
public:
property bool PdfDisplayDocTitle {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfEmbeddingFonts Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfEmbeddingFonts Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfEmbeddingFonts { get; set; }
Visual Basic (Declaration)
Public Property PdfEmbeddingFonts As Boolean
Visual C++
public:
property bool PdfEmbeddingFonts {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfFitWindow Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfFitWindow Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfFitWindow { get; set; }
Visual Basic (Declaration)
Public Property PdfFitWindow As Boolean
Visual C++
public:
property bool PdfFitWindow {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfHideMenubar Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfHideMenubar Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfHideMenubar { get; set; }
Visual Basic (Declaration)
Public Property PdfHideMenubar As Boolean
Visual C++
public:
property bool PdfHideMenubar {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfHideToolbar Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfHideToolbar Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfHideToolbar { get; set; }
Visual Basic (Declaration)
Public Property PdfHideToolbar As Boolean
Visual C++
public:
property bool PdfHideToolbar {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfHideWindowUI Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfHideWindowUI Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfHideWindowUI { get; set; }
Visual Basic (Declaration)
Public Property PdfHideWindowUI As Boolean
Visual C++
public:
property bool PdfHideWindowUI {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfKeywords Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfKeywords Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfKeywords { get; set; }
Visual Basic (Declaration)
Public Property PdfKeywords As String
Visual C++
public:
property String^ PdfKeywords {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfOutline Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfOutline Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfOutline { get; set; }
Visual Basic (Declaration)
Public Property PdfOutline As Boolean
Visual C++
public:
property bool PdfOutline {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfOwnerPassword Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfOwnerPassword Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfOwnerPassword { get; set; }
Visual Basic (Declaration)
Public Property PdfOwnerPassword As String
Visual C++
public:
property String^ PdfOwnerPassword {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfPrintOptimized Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfPrintOptimized Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfPrintOptimized { get; set; }
Visual Basic (Declaration)
Public Property PdfPrintOptimized As Boolean
Visual C++
public:
property bool PdfPrintOptimized {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfPrintScaling Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfPrintScaling Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PdfPrintScaling { get; set; }
Visual Basic (Declaration)
Public Property PdfPrintScaling As Boolean
Visual C++
public:
property bool PdfPrintScaling {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfProducer Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfProducer Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfProducer { get; set; }
Visual Basic (Declaration)
Public Property PdfProducer As String
Visual C++
public:
property String^ PdfProducer {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfSubject Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfSubject Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfSubject { get; set; }
Visual Basic (Declaration)
Public Property PdfSubject As String
Visual C++
public:
property String^ PdfSubject {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfTitle Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfTitle Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfTitle { get; set; }
Visual Basic (Declaration)
Public Property PdfTitle As String
Visual C++
public:
property String^ PdfTitle {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PdfUserPassword Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PdfUserPassword Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PdfUserPassword { get; set; }
Visual Basic (Declaration)
Public Property PdfUserPassword As String
Visual C++
public:
property String^ PdfUserPassword {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


Pictures Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.Pictures Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool Pictures { get; set; }
Visual Basic (Declaration)
Public Property Pictures As Boolean
Visual C++
public:
property bool Pictures {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PptxImageFormat Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PptxImageFormat Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public PptImageFormat PptxImageFormat { get; set; }
Visual Basic (Declaration)
Public Property PptxImageFormat As PptImageFormat
Visual C++
public:
property PptImageFormat PptxImageFormat {
    PptImageFormat get ();
    void set (PptImageFormat value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PrintInPdf Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PrintInPdf Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool PrintInPdf { get; set; }
Visual Basic (Declaration)
Public Property PrintInPdf As Boolean
Visual C++
public:
property bool PrintInPdf {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PrintWindowHeight Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PrintWindowHeight Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PrintWindowHeight { get; set; }
Visual Basic (Declaration)
Public Property PrintWindowHeight As String
Visual C++
public:
property String^ PrintWindowHeight {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


PrintWindowWidth Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.PrintWindowWidth Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string PrintWindowWidth { get; set; }
Visual Basic (Declaration)
Public Property PrintWindowWidth As String
Visual C++
public:
property String^ PrintWindowWidth {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ReportDataSources Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ReportDataSources Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportDataSources { get; set; }
Visual Basic (Declaration)
Public Property ReportDataSources As String
Visual C++
public:
property String^ ReportDataSources {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ReportDone Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ReportDone Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ReportDone { get; set; }
Visual Basic (Declaration)
Public Property ReportDone As Boolean
Visual C++
public:
property bool ReportDone {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ReportFile Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ReportFile Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportFile { get; set; }
Visual Basic (Declaration)
Public Property ReportFile As String
Visual C++
public:
property String^ ReportFile {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ReportResourceString Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ReportResourceString Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string ReportResourceString { get; set; }
Visual Basic (Declaration)
Public Property ReportResourceString As String
Visual C++
public:
property String^ ReportResourceString {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfAutoSize Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfAutoSize Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfAutoSize { get; set; }
Visual Basic (Declaration)
Public Property RtfAutoSize As Boolean
Visual C++
public:
property bool RtfAutoSize {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfCreator Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfCreator Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public string RtfCreator { get; set; }
Visual Basic (Declaration)
Public Property RtfCreator As String
Visual C++
public:
property String^ RtfCreator {
    String^ get ();
    void set (String^ value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfImageFormat Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfImageFormat Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public RTFImageFormat RtfImageFormat { get; set; }
Visual Basic (Declaration)
Public Property RtfImageFormat As RTFImageFormat
Visual C++
public:
property RTFImageFormat RtfImageFormat {
    RTFImageFormat get ();
    void set (RTFImageFormat value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfJpegQuality Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfJpegQuality Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int RtfJpegQuality { get; set; }
Visual Basic (Declaration)
Public Property RtfJpegQuality As Integer
Visual C++
public:
property int RtfJpegQuality {
    int get ();
    void set (int value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfPageBreaks Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfPageBreaks Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property RtfPageBreaks As Boolean
Visual C++
public:
property bool RtfPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfPictures Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfPictures Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfPictures { get; set; }
Visual Basic (Declaration)
Public Property RtfPictures As Boolean
Visual C++
public:
property bool RtfPictures {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


RtfWysiwyg Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.RtfWysiwyg Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool RtfWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property RtfWysiwyg As Boolean
Visual C++
public:
property bool RtfWysiwyg {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowBottomToolbar Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowBottomToolbar Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowBottomToolbar { get; set; }
Visual Basic (Declaration)
Public Property ShowBottomToolbar As Boolean
Visual C++
public:
property bool ShowBottomToolbar {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowCsvExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowCsvExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowCsvExport { get; set; }
Visual Basic (Declaration)
Public Property ShowCsvExport As Boolean
Visual C++
public:
property bool ShowCsvExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowDbfExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowDbfExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowDbfExport { get; set; }
Visual Basic (Declaration)
Public Property ShowDbfExport As Boolean
Visual C++
public:
property bool ShowDbfExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowExcel2007Export Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowExcel2007Export Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowExcel2007Export { get; set; }
Visual Basic (Declaration)
Public Property ShowExcel2007Export As Boolean
Visual C++
public:
property bool ShowExcel2007Export {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowExports Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowExports Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowExports { get; set; }
Visual Basic (Declaration)
Public Property ShowExports As Boolean
Visual C++
public:
property bool ShowExports {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowFirstButton Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowFirstButton Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowFirstButton { get; set; }
Visual Basic (Declaration)
Public Property ShowFirstButton As Boolean
Visual C++
public:
property bool ShowFirstButton {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowLastButton Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowLastButton Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowLastButton { get; set; }
Visual Basic (Declaration)
Public Property ShowLastButton As Boolean
Visual C++
public:
property bool ShowLastButton {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowMhtExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowMhtExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowMhtExport { get; set; }
Visual Basic (Declaration)
Public Property ShowMhtExport As Boolean
Visual C++
public:
property bool ShowMhtExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowNextButton Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowNextButton Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowNextButton { get; set; }
Visual Basic (Declaration)
Public Property ShowNextButton As Boolean
Visual C++
public:
property bool ShowNextButton {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowOdsExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowOdsExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowOdsExport { get; set; }
Visual Basic (Declaration)
Public Property ShowOdsExport As Boolean
Visual C++
public:
property bool ShowOdsExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowOdtExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowOdtExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowOdtExport { get; set; }
Visual Basic (Declaration)
Public Property ShowOdtExport As Boolean
Visual C++
public:
property bool ShowOdtExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowPageNumber Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowPageNumber Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPageNumber { get; set; }
Visual Basic (Declaration)
Public Property ShowPageNumber As Boolean
Visual C++
public:
property bool ShowPageNumber {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowPdfExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowPdfExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPdfExport { get; set; }
Visual Basic (Declaration)
Public Property ShowPdfExport As Boolean
Visual C++
public:
property bool ShowPdfExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowPowerPoint2007Export Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowPowerPoint2007Export Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPowerPoint2007Export { get; set; }
Visual Basic (Declaration)
Public Property ShowPowerPoint2007Export As Boolean
Visual C++
public:
property bool ShowPowerPoint2007Export {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowPrevButton Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowPrevButton Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPrevButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPrevButton As Boolean
Visual C++
public:
property bool ShowPrevButton {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowPrint Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowPrint Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowPrint { get; set; }
Visual Basic (Declaration)
Public Property ShowPrint As Boolean
Visual C++
public:
property bool ShowPrint {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowRefreshButton Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowRefreshButton Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowRefreshButton { get; set; }
Visual Basic (Declaration)
Public Property ShowRefreshButton As Boolean
Visual C++
public:
property bool ShowRefreshButton {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowRtfExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowRtfExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowRtfExport { get; set; }
Visual Basic (Declaration)
Public Property ShowRtfExport As Boolean
Visual C++
public:
property bool ShowRtfExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowTextExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowTextExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowTextExport { get; set; }
Visual Basic (Declaration)
Public Property ShowTextExport As Boolean
Visual C++
public:
property bool ShowTextExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowToolbar Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowToolbar Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowToolbar { get; set; }
Visual Basic (Declaration)
Public Property ShowToolbar As Boolean
Visual C++
public:
property bool ShowToolbar {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowWord2007Export Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowWord2007Export Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowWord2007Export { get; set; }
Visual Basic (Declaration)
Public Property ShowWord2007Export As Boolean
Visual C++
public:
property bool ShowWord2007Export {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowXmlExcelExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowXmlExcelExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowXmlExcelExport { get; set; }
Visual Basic (Declaration)
Public Property ShowXmlExcelExport As Boolean
Visual C++
public:
property bool ShowXmlExcelExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowXpsExport Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowXpsExport Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowXpsExport { get; set; }
Visual Basic (Declaration)
Public Property ShowXpsExport As Boolean
Visual C++
public:
property bool ShowXpsExport {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ShowZoomButton Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ShowZoomButton Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool ShowZoomButton { get; set; }
Visual Basic (Declaration)
Public Property ShowZoomButton As Boolean
Visual C++
public:
property bool ShowZoomButton {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


TextAllowFrames Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.TextAllowFrames Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextAllowFrames { get; set; }
Visual Basic (Declaration)
Public Property TextAllowFrames As Boolean
Visual C++
public:
property bool TextAllowFrames {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


TextDataOnly Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.TextDataOnly Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextDataOnly { get; set; }
Visual Basic (Declaration)
Public Property TextDataOnly As Boolean
Visual C++
public:
property bool TextDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


TextEmptyLines Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.TextEmptyLines Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextEmptyLines { get; set; }
Visual Basic (Declaration)
Public Property TextEmptyLines As Boolean
Visual C++
public:
property bool TextEmptyLines {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


TextPageBreaks Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.TextPageBreaks Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property TextPageBreaks As Boolean
Visual C++
public:
property bool TextPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


TextSimpleFrames Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.TextSimpleFrames Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool TextSimpleFrames { get; set; }
Visual Basic (Declaration)
Public Property TextSimpleFrames As Boolean
Visual C++
public:
property bool TextSimpleFrames {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ToolbarBackgroundStyle Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ToolbarBackgroundStyle Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarBackgroundStyle ToolbarBackgroundStyle { get; set; }
Visual Basic (Declaration)
Public Property ToolbarBackgroundStyle As ToolbarBackgroundStyle
Visual C++
public:
property ToolbarBackgroundStyle ToolbarBackgroundStyle {
    ToolbarBackgroundStyle get ();
    void set (ToolbarBackgroundStyle value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ToolbarColor Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ToolbarColor Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public Color ToolbarColor { get; set; }
Visual Basic (Declaration)
Public Property ToolbarColor As Color
Visual C++
public:
property Color ToolbarColor {
    Color get ();
    void set (Color value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ToolbarIconsStyle Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ToolbarIconsStyle Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarIconsStyle ToolbarIconsStyle { get; set; }
Visual Basic (Declaration)
Public Property ToolbarIconsStyle As ToolbarIconsStyle
Visual C++
public:
property ToolbarIconsStyle ToolbarIconsStyle {
    ToolbarIconsStyle get ();
    void set (ToolbarIconsStyle value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ToolbarStyle Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ToolbarStyle Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ToolbarStyle ToolbarStyle { get; set; }
Visual Basic (Declaration)
Public Property ToolbarStyle As ToolbarStyle
Visual C++
public:
property ToolbarStyle ToolbarStyle {
    ToolbarStyle get ();
    void set (ToolbarStyle value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


TotalPages Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.TotalPages Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public int TotalPages { get; set; }
Visual Basic (Declaration)
Public Property TotalPages As Integer
Visual C++
public:
property int TotalPages {
    int get ();
    void set (int value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


XlsxDataOnly Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.XlsxDataOnly Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XlsxDataOnly { get; set; }
Visual Basic (Declaration)
Public Property XlsxDataOnly As Boolean
Visual C++
public:
property bool XlsxDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


XlsxPageBreaks Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.XlsxPageBreaks Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XlsxPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property XlsxPageBreaks As Boolean
Visual C++
public:
property bool XlsxPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


XlsxWysiwyg Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.XlsxWysiwyg Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XlsxWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property XlsxWysiwyg As Boolean
Visual C++
public:
property bool XlsxWysiwyg {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


XmlExcelDataOnly Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.XmlExcelDataOnly Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XmlExcelDataOnly { get; set; }
Visual Basic (Declaration)
Public Property XmlExcelDataOnly As Boolean
Visual C++
public:
property bool XmlExcelDataOnly {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


XmlExcelPageBreaks Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.XmlExcelPageBreaks Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XmlExcelPageBreaks { get; set; }
Visual Basic (Declaration)
Public Property XmlExcelPageBreaks As Boolean
Visual C++
public:
property bool XmlExcelPageBreaks {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


XmlExcelWysiwyg Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.XmlExcelWysiwyg Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool XmlExcelWysiwyg { get; set; }
Visual Basic (Declaration)
Public Property XmlExcelWysiwyg As Boolean
Visual C++
public:
property bool XmlExcelWysiwyg {
    bool get ();
    void set (bool value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


Zoom Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.Zoom Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public float Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Single
Visual C++
public:
property float Zoom {
    float get ();
    void set (float value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


ZoomMode Property

[image]

FastReport.Net Class Reference
WebReportProperties..::.ZoomMode Property
WebReportProperties Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode
Visual C++
public:
property ZoomMode ZoomMode {
    ZoomMode get ();
    void set (ZoomMode value);
}

See Also

WebReportProperties Class
FastReport.Web Namespace


WebReportStyles Class

[image]

FastReport.Net Class Reference
WebReportStyles Class
Members See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public class WebReportStyles
Visual Basic (Declaration)
Public Class WebReportStyles
Visual C++
public ref class WebReportStyles

Inheritance Hierarchy

System..::.Object
FastReport.Web..::.WebReportStyles

See Also

WebReportStyles Members
FastReport.Web Namespace


WebReportStyles Members

[image] [image]

FastReport.Net Class Reference
WebReportStyles Members
WebReportStyles Class Constructors Methods See Also Send Feedback

The WebReportStyles type exposes the following members.

Constructors

Name | Description
WebReportStyles | Initializes a new instance of the WebReportStyles class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebReportStyles Class
FastReport.Web Namespace


WebReportStyles Constructor

[image]

FastReport.Net Class Reference
WebReportStyles Constructor
WebReportStyles Class See Also Send Feedback
Initializes a new instance of the WebReportStyles class

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebReportStyles()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebReportStyles()

See Also

WebReportStyles Class
FastReport.Web Namespace


WebReportStyles Methods

[image] [image]

FastReport.Net Class Reference
WebReportStyles Methods
WebReportStyles Class See Also Send Feedback

The WebReportStyles type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebReportStyles Class
FastReport.Web Namespace


WebUtils Class

[image]

FastReport.Net Class Reference
WebUtils Class
Members See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static class WebUtils
Visual Basic (Declaration)
Public NotInheritable Class WebUtils
Visual C++
public ref class WebUtils abstract sealed

Inheritance Hierarchy

System..::.Object
FastReport.Web..::.WebUtils

See Also

WebUtils Members
FastReport.Web Namespace


WebUtils Members

[image] [image]

FastReport.Net Class Reference
WebUtils Members
WebUtils Class Methods Fields See Also Send Feedback

The WebUtils type exposes the following members.

Methods

Name | Description
AddHandlers | Add http handlers in web.config
CheckHandlers | Check http handlers in web.config
CheckHandlersRuntime |
GetGUID | Overloaded.
GetHandlerError |
IsAbsolutePhysicalPath | Determines whether the path is an absolute physical path.
ReverseString |

Fields

Name | Description
HandlerFileName | Contain the filename of httphandler

See Also

WebUtils Class
FastReport.Web Namespace


WebUtils Fields

[image] [image]

FastReport.Net Class Reference
WebUtils Fields
WebUtils Class See Also Send Feedback

The WebUtils type exposes the following members.

Fields

Name | Description
HandlerFileName | Contain the filename of httphandler

See Also

WebUtils Class
FastReport.Web Namespace


HandlerFileName Field

[image]

FastReport.Net Class Reference
WebUtils..::.HandlerFileName Field
WebUtils Class See Also Send Feedback
Contain the filename of httphandler

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public const string HandlerFileName
Visual Basic (Declaration)
Public Const HandlerFileName As String
Visual C++
public:
literal String^ HandlerFileName

See Also

WebUtils Class
FastReport.Web Namespace


WebUtils Methods

[image] [image]

FastReport.Net Class Reference
WebUtils Methods
WebUtils Class See Also Send Feedback

The WebUtils type exposes the following members.

Methods

Name | Description
AddHandlers | Add http handlers in web.config
CheckHandlers | Check http handlers in web.config
CheckHandlersRuntime |
GetGUID | Overloaded.
GetHandlerError |
IsAbsolutePhysicalPath | Determines whether the path is an absolute physical path.
ReverseString |

See Also

WebUtils Class
FastReport.Web Namespace


AddHandlers Method

[image]

FastReport.Net Class Reference
WebUtils..::.AddHandlers Method
WebUtils Class See Also Send Feedback
Add http handlers in web.config

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static void AddHandlers(
    string webConfigFile
)
Visual Basic (Declaration)
Public Shared Sub AddHandlers ( _
    webConfigFile As String _
)
Visual C++
public:
static void AddHandlers(
    String^ webConfigFile
)

Parameters

webConfigFile
Type: System..::.String

See Also

WebUtils Class
FastReport.Web Namespace


CheckHandlers Method

[image]

FastReport.Net Class Reference
WebUtils..::.CheckHandlers Method
WebUtils Class See Also Send Feedback
Check http handlers in web.config

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static bool CheckHandlers()
Visual Basic (Declaration)
Public Shared Function CheckHandlers As Boolean
Visual C++
public:
static bool CheckHandlers()

Return Value

See Also

WebUtils Class
FastReport.Web Namespace


CheckHandlersRuntime Method

[image]

FastReport.Net Class Reference
WebUtils..::.CheckHandlersRuntime Method
WebUtils Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static void CheckHandlersRuntime()
Visual Basic (Declaration)
Public Shared Sub CheckHandlersRuntime
Visual C++
public:
static void CheckHandlersRuntime()

See Also

WebUtils Class
FastReport.Web Namespace


GetGUID Method

[image] [image]

FastReport.Net Class Reference
WebUtils..::.GetGUID Method
WebUtils Class See Also Send Feedback

Overload List

Name | Description
GetGUID()()() |
GetGUID(HttpContext, String) |

See Also

WebUtils Class
WebUtils Members
FastReport.Web Namespace


GetGUID Method

[image]

FastReport.Net Class Reference
WebUtils..::.GetGUID Method
WebUtils Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static string GetGUID()
Visual Basic (Declaration)
Public Shared Function GetGUID As String
Visual C++
public:
static String^ GetGUID()

Return Value

See Also

WebUtils Class
GetGUID Overload
FastReport.Web Namespace


GetGUID Method (HttpContext, String)

[image]

FastReport.Net Class Reference
WebUtils..::.GetGUID Method (HttpContext, String)
WebUtils Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static string GetGUID(
    HttpContext context,
    string id
)
Visual Basic (Declaration)
Public Shared Function GetGUID ( _
    context As HttpContext, _
    id As String _
) As String
Visual C++
public:
static String^ GetGUID(
    HttpContext^ context,
    String^ id
)

Parameters

context
Type: System.Web..::.HttpContext
id
Type: System..::.String

Return Value

See Also

WebUtils Class
GetGUID Overload
FastReport.Web Namespace


GetHandlerError Method

[image]

FastReport.Net Class Reference
WebUtils..::.GetHandlerError Method
WebUtils Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static string GetHandlerError()
Visual Basic (Declaration)
Public Shared Function GetHandlerError As String
Visual C++
public:
static String^ GetHandlerError()

Return Value

See Also

WebUtils Class
FastReport.Web Namespace


IsAbsolutePhysicalPath Method

[image]

FastReport.Net Class Reference
WebUtils..::.IsAbsolutePhysicalPath Method
WebUtils Class See Also Send Feedback
Determines whether the path is an absolute physical path.

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static bool IsAbsolutePhysicalPath(
    string path
)
Visual Basic (Declaration)
Public Shared Function IsAbsolutePhysicalPath ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsAbsolutePhysicalPath(
    String^ path
)

Parameters

path
Type: System..::.String
The path to check.

Return Value

true if the path is absolute physical path.

See Also

WebUtils Class
FastReport.Web Namespace


ReverseString Method

[image]

FastReport.Net Class Reference
WebUtils..::.ReverseString Method
WebUtils Class See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public static string ReverseString(
    string str
)
Visual Basic (Declaration)
Public Shared Function ReverseString ( _
    str As String _
) As String
Visual C++
public:
static String^ ReverseString(
    String^ str
)

Parameters

str
Type: System..::.String

Return Value

See Also

WebUtils Class
FastReport.Web Namespace


ZoomMode Enumeration

[image]

FastReport.Net Class Reference
ZoomMode Enumeration
See Also Send Feedback

Namespace: FastReport.Web
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode
Visual C++
public enum class ZoomMode

Members

Member name | Description
Scale |
Width |
Page |

See Also

FastReport.Web Namespace


FastReport.Web.Handlers Namespace

[image]

FastReport.Net Class Reference
FastReport.Web.Handlers Namespace
Send Feedback

Classes

Class | Description
WebExport | Web handler class


WebExport Class

[image]

FastReport.Net Class Reference
WebExport Class
Members See Also Send Feedback
Web handler class

Namespace: FastReport.Web.Handlers
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public class WebExport : IHttpHandler
Visual Basic (Declaration)
Public Class WebExport _
    Implements IHttpHandler
Visual C++
public ref class WebExport : IHttpHandler

Inheritance Hierarchy

System..::.Object
FastReport.Web.Handlers..::.WebExport

See Also

WebExport Members
FastReport.Web.Handlers Namespace


WebExport Members

[image] [image]

FastReport.Net Class Reference
WebExport Members
WebExport Class Constructors Methods Properties See Also Send Feedback

The WebExport type exposes the following members.

Constructors

Name | Description
WebExport | Initializes a new instance of the WebExport class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessRequest | Process Request
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReusable |

See Also

WebExport Class
FastReport.Web.Handlers Namespace


WebExport Constructor

[image]

FastReport.Net Class Reference
WebExport Constructor
WebExport Class See Also Send Feedback
Initializes a new instance of the WebExport class

Namespace: FastReport.Web.Handlers
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public WebExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebExport()

See Also

WebExport Class
FastReport.Web.Handlers Namespace


WebExport Methods

[image] [image]

FastReport.Net Class Reference
WebExport Methods
WebExport Class See Also Send Feedback

The WebExport type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessRequest | Process Request
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebExport Class
FastReport.Web.Handlers Namespace


ProcessRequest Method

[image]

FastReport.Net Class Reference
WebExport..::.ProcessRequest Method
WebExport Class See Also Send Feedback
Process Request

Namespace: FastReport.Web.Handlers
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public void ProcessRequest(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ProcessRequest ( _
    context As HttpContext _
)
Visual C++
public:
virtual void ProcessRequest(
    HttpContext^ context
) sealed

Parameters

context
Type: System.Web..::.HttpContext

Implements

IHttpHandler..::.ProcessRequest(HttpContext)

See Also

WebExport Class
FastReport.Web.Handlers Namespace


WebExport Properties

[image] [image]

FastReport.Net Class Reference
WebExport Properties
WebExport Class See Also Send Feedback

The WebExport type exposes the following members.

Properties

Name | Description
IsReusable |

See Also

WebExport Class
FastReport.Web.Handlers Namespace


IsReusable Property

[image]

FastReport.Net Class Reference
WebExport..::.IsReusable Property
WebExport Class See Also Send Feedback

Namespace: FastReport.Web.Handlers
Assembly: FastReport.Web (in FastReport.Web.dll) Version: 2013.2.19.0

Syntax

C#
public bool IsReusable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual C++
public:
virtual property bool IsReusable {
    bool get () sealed;
}

Implements

IHttpHandler..::.IsReusable

See Also

WebExport Class
FastReport.Web.Handlers Namespace


FastReport.Wizards Namespace

[image]

FastReport.Net Class Reference
FastReport.Wizards Namespace
Send Feedback

Classes

Class | Description
BlankReportWizard | Represents the "Blank Report" wizard.
InheritedReportWizard | Represents the "Inherited Report" wizard.
LabelWizard | Represents the "Label" wizard.
NewDataSourceWizard | Represents the "New Data Source" wizard.
NewDialogWizard | Represents the "New Dialog" wizard.
NewPageWizard | Represents the "New Page" wizard.
StandardReportWizard | Represents the "Standard Report" wizard.
WizardBase | The base class for all report wizards.


BlankReportWizard Class

[image]

FastReport.Net Class Reference
BlankReportWizard Class
Members See Also Send Feedback
Represents the "Blank Report" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class BlankReportWizard : WizardBase
Visual Basic (Declaration)
Public Class BlankReportWizard _
    Inherits WizardBase
Visual C++
public ref class BlankReportWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.BlankReportWizard

See Also

BlankReportWizard Members
FastReport.Wizards Namespace


BlankReportWizard Members

[image] [image]

FastReport.Net Class Reference
BlankReportWizard Members
BlankReportWizard Class Constructors Methods See Also Send Feedback

The BlankReportWizard type exposes the following members.

Constructors

Name | Description
BlankReportWizard | Initializes a new instance of the BlankReportWizard class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlankReportWizard Class
FastReport.Wizards Namespace


BlankReportWizard Constructor

[image]

FastReport.Net Class Reference
BlankReportWizard Constructor
BlankReportWizard Class See Also Send Feedback
Initializes a new instance of the BlankReportWizard class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public BlankReportWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BlankReportWizard()

See Also

BlankReportWizard Class
FastReport.Wizards Namespace


BlankReportWizard Methods

[image] [image]

FastReport.Net Class Reference
BlankReportWizard Methods
BlankReportWizard Class See Also Send Feedback

The BlankReportWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlankReportWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
BlankReportWizard..::.Run Method
BlankReportWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

BlankReportWizard Class
FastReport.Wizards Namespace


InheritedReportWizard Class

[image]

FastReport.Net Class Reference
InheritedReportWizard Class
Members See Also Send Feedback
Represents the "Inherited Report" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class InheritedReportWizard : WizardBase
Visual Basic (Declaration)
Public Class InheritedReportWizard _
    Inherits WizardBase
Visual C++
public ref class InheritedReportWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.InheritedReportWizard

See Also

InheritedReportWizard Members
FastReport.Wizards Namespace


InheritedReportWizard Members

[image] [image]

FastReport.Net Class Reference
InheritedReportWizard Members
InheritedReportWizard Class Constructors Methods See Also Send Feedback

The InheritedReportWizard type exposes the following members.

Constructors

Name | Description
InheritedReportWizard | Initializes a new instance of the InheritedReportWizard class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InheritedReportWizard Class
FastReport.Wizards Namespace


InheritedReportWizard Constructor

[image]

FastReport.Net Class Reference
InheritedReportWizard Constructor
InheritedReportWizard Class See Also Send Feedback
Initializes a new instance of the InheritedReportWizard class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public InheritedReportWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InheritedReportWizard()

See Also

InheritedReportWizard Class
FastReport.Wizards Namespace


InheritedReportWizard Methods

[image] [image]

FastReport.Net Class Reference
InheritedReportWizard Methods
InheritedReportWizard Class See Also Send Feedback

The InheritedReportWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InheritedReportWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
InheritedReportWizard..::.Run Method
InheritedReportWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

InheritedReportWizard Class
FastReport.Wizards Namespace


LabelWizard Class

[image]

FastReport.Net Class Reference
LabelWizard Class
Members See Also Send Feedback
Represents the "Label" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class LabelWizard : WizardBase
Visual Basic (Declaration)
Public Class LabelWizard _
    Inherits WizardBase
Visual C++
public ref class LabelWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.LabelWizard

See Also

LabelWizard Members
FastReport.Wizards Namespace


LabelWizard Members

[image] [image]

FastReport.Net Class Reference
LabelWizard Members
LabelWizard Class Constructors Methods Properties See Also Send Feedback

The LabelWizard type exposes the following members.

Constructors

Name | Description
LabelWizard | Initializes a new instance of the LabelWizard class with the default settings.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SelectedLabelName | Gets a selected label name.
SelectedLabelParameters | Gets the XML item containing a selected label parameters.
SelectedManufacturer | Gets a selected label manufacturer.

See Also

LabelWizard Class
FastReport.Wizards Namespace


LabelWizard Constructor

[image]

FastReport.Net Class Reference
LabelWizard Constructor
LabelWizard Class See Also Send Feedback
Initializes a new instance of the LabelWizard class with the default settings.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public LabelWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LabelWizard()

See Also

LabelWizard Class
FastReport.Wizards Namespace


LabelWizard Methods

[image] [image]

FastReport.Net Class Reference
LabelWizard Methods
LabelWizard Class See Also Send Feedback

The LabelWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LabelWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
LabelWizard..::.Run Method
LabelWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

LabelWizard Class
FastReport.Wizards Namespace


LabelWizard Properties

[image] [image]

FastReport.Net Class Reference
LabelWizard Properties
LabelWizard Class See Also Send Feedback

The LabelWizard type exposes the following members.

Properties

Name | Description
SelectedLabelName | Gets a selected label name.
SelectedLabelParameters | Gets the XML item containing a selected label parameters.
SelectedManufacturer | Gets a selected label manufacturer.

See Also

LabelWizard Class
FastReport.Wizards Namespace


SelectedLabelName Property

[image]

FastReport.Net Class Reference
LabelWizard..::.SelectedLabelName Property
LabelWizard Class See Also Send Feedback
Gets a selected label name.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectedLabelName { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedLabelName As String
Visual C++
public:
property String^ SelectedLabelName {
    String^ get ();
}

See Also

LabelWizard Class
FastReport.Wizards Namespace


SelectedLabelParameters Property

[image]

FastReport.Net Class Reference
LabelWizard..::.SelectedLabelParameters Property
LabelWizard Class See Also Send Feedback
Gets the XML item containing a selected label parameters.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public XmlItem SelectedLabelParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedLabelParameters As XmlItem
Visual C++
public:
property XmlItem^ SelectedLabelParameters {
    XmlItem^ get ();
}

See Also

LabelWizard Class
FastReport.Wizards Namespace


SelectedManufacturer Property

[image]

FastReport.Net Class Reference
LabelWizard..::.SelectedManufacturer Property
LabelWizard Class See Also Send Feedback
Gets a selected label manufacturer.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public string SelectedManufacturer { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedManufacturer As String
Visual C++
public:
property String^ SelectedManufacturer {
    String^ get ();
}

See Also

LabelWizard Class
FastReport.Wizards Namespace


NewDataSourceWizard Class

[image]

FastReport.Net Class Reference
NewDataSourceWizard Class
Members See Also Send Feedback
Represents the "New Data Source" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NewDataSourceWizard : WizardBase
Visual Basic (Declaration)
Public Class NewDataSourceWizard _
    Inherits WizardBase
Visual C++
public ref class NewDataSourceWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.NewDataSourceWizard

See Also

NewDataSourceWizard Members
FastReport.Wizards Namespace


NewDataSourceWizard Members

[image] [image]

FastReport.Net Class Reference
NewDataSourceWizard Members
NewDataSourceWizard Class Constructors Methods See Also Send Feedback

The NewDataSourceWizard type exposes the following members.

Constructors

Name | Description
NewDataSourceWizard | Initializes a new instance of the NewDataSourceWizard class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewDataSourceWizard Class
FastReport.Wizards Namespace


NewDataSourceWizard Constructor

[image]

FastReport.Net Class Reference
NewDataSourceWizard Constructor
NewDataSourceWizard Class See Also Send Feedback
Initializes a new instance of the NewDataSourceWizard class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NewDataSourceWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NewDataSourceWizard()

See Also

NewDataSourceWizard Class
FastReport.Wizards Namespace


NewDataSourceWizard Methods

[image] [image]

FastReport.Net Class Reference
NewDataSourceWizard Methods
NewDataSourceWizard Class See Also Send Feedback

The NewDataSourceWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewDataSourceWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
NewDataSourceWizard..::.Run Method
NewDataSourceWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

NewDataSourceWizard Class
FastReport.Wizards Namespace


NewDialogWizard Class

[image]

FastReport.Net Class Reference
NewDialogWizard Class
Members See Also Send Feedback
Represents the "New Dialog" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NewDialogWizard : WizardBase
Visual Basic (Declaration)
Public Class NewDialogWizard _
    Inherits WizardBase
Visual C++
public ref class NewDialogWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.NewDialogWizard

See Also

NewDialogWizard Members
FastReport.Wizards Namespace


NewDialogWizard Members

[image] [image]

FastReport.Net Class Reference
NewDialogWizard Members
NewDialogWizard Class Constructors Methods See Also Send Feedback

The NewDialogWizard type exposes the following members.

Constructors

Name | Description
NewDialogWizard | Initializes a new instance of the NewDialogWizard class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewDialogWizard Class
FastReport.Wizards Namespace


NewDialogWizard Constructor

[image]

FastReport.Net Class Reference
NewDialogWizard Constructor
NewDialogWizard Class See Also Send Feedback
Initializes a new instance of the NewDialogWizard class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NewDialogWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NewDialogWizard()

See Also

NewDialogWizard Class
FastReport.Wizards Namespace


NewDialogWizard Methods

[image] [image]

FastReport.Net Class Reference
NewDialogWizard Methods
NewDialogWizard Class See Also Send Feedback

The NewDialogWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewDialogWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
NewDialogWizard..::.Run Method
NewDialogWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

NewDialogWizard Class
FastReport.Wizards Namespace


NewPageWizard Class

[image]

FastReport.Net Class Reference
NewPageWizard Class
Members See Also Send Feedback
Represents the "New Page" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class NewPageWizard : WizardBase
Visual Basic (Declaration)
Public Class NewPageWizard _
    Inherits WizardBase
Visual C++
public ref class NewPageWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.NewPageWizard

See Also

NewPageWizard Members
FastReport.Wizards Namespace


NewPageWizard Members

[image] [image]

FastReport.Net Class Reference
NewPageWizard Members
NewPageWizard Class Constructors Methods See Also Send Feedback

The NewPageWizard type exposes the following members.

Constructors

Name | Description
NewPageWizard | Initializes a new instance of the NewPageWizard class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewPageWizard Class
FastReport.Wizards Namespace


NewPageWizard Constructor

[image]

FastReport.Net Class Reference
NewPageWizard Constructor
NewPageWizard Class See Also Send Feedback
Initializes a new instance of the NewPageWizard class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public NewPageWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NewPageWizard()

See Also

NewPageWizard Class
FastReport.Wizards Namespace


NewPageWizard Methods

[image] [image]

FastReport.Net Class Reference
NewPageWizard Methods
NewPageWizard Class See Also Send Feedback

The NewPageWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewPageWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
NewPageWizard..::.Run Method
NewPageWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

NewPageWizard Class
FastReport.Wizards Namespace


StandardReportWizard Class

[image]

FastReport.Net Class Reference
StandardReportWizard Class
Members See Also Send Feedback
Represents the "Standard Report" wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public class StandardReportWizard : WizardBase
Visual Basic (Declaration)
Public Class StandardReportWizard _
    Inherits WizardBase
Visual C++
public ref class StandardReportWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.StandardReportWizard

See Also

StandardReportWizard Members
FastReport.Wizards Namespace


StandardReportWizard Members

[image] [image]

FastReport.Net Class Reference
StandardReportWizard Members
StandardReportWizard Class Constructors Methods See Also Send Feedback

The StandardReportWizard type exposes the following members.

Constructors

Name | Description
StandardReportWizard | Initializes a new instance of the StandardReportWizard class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardReportWizard Class
FastReport.Wizards Namespace


StandardReportWizard Constructor

[image]

FastReport.Net Class Reference
StandardReportWizard Constructor
StandardReportWizard Class See Also Send Feedback
Initializes a new instance of the StandardReportWizard class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public StandardReportWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StandardReportWizard()

See Also

StandardReportWizard Class
FastReport.Wizards Namespace


StandardReportWizard Methods

[image] [image]

FastReport.Net Class Reference
StandardReportWizard Methods
StandardReportWizard Class See Also Send Feedback

The StandardReportWizard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard. (Overrides WizardBase..::.Run(Designer).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardReportWizard Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
StandardReportWizard..::.Run Method
StandardReportWizard Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public override bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public Overrides Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) override

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

StandardReportWizard Class
FastReport.Wizards Namespace


WizardBase Class

[image]

FastReport.Net Class Reference
WizardBase Class
Members See Also Send Feedback
The base class for all report wizards.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract class WizardBase
Visual Basic (Declaration)
Public MustInherit Class WizardBase
Visual C++
public ref class WizardBase abstract

Remarks

To create own wizard, use this class as a base. All you need is to override the Run(Designer) method. To register a wizard, use the AddWizard(Type, Bitmap, String, Boolean) method.

Inheritance Hierarchy

System..::.Object
FastReport.Wizards..::.WizardBase
FastReport.Wizards..::.BlankReportWizard
FastReport.Wizards..::.InheritedReportWizard
FastReport.Wizards..::.LabelWizard
FastReport.Wizards..::.NewDataSourceWizard
FastReport.Wizards..::.NewDialogWizard
FastReport.Wizards..::.NewPageWizard
FastReport.Wizards..::.StandardReportWizard

See Also

WizardBase Members
FastReport.Wizards Namespace


WizardBase Members

[image] [image]

FastReport.Net Class Reference
WizardBase Members
WizardBase Class Constructors Methods See Also Send Feedback

The WizardBase type exposes the following members.

Constructors

Name | Description
WizardBase | Initializes a new instance of the WizardBase class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WizardBase Class
FastReport.Wizards Namespace


WizardBase Constructor

[image]

FastReport.Net Class Reference
WizardBase Constructor
WizardBase Class See Also Send Feedback
Initializes a new instance of the WizardBase class

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
protected WizardBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
WizardBase()

See Also

WizardBase Class
FastReport.Wizards Namespace


WizardBase Methods

[image] [image]

FastReport.Net Class Reference
WizardBase Methods
WizardBase Class See Also Send Feedback

The WizardBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | Runs the wizard.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WizardBase Class
FastReport.Wizards Namespace


Run Method

[image]

FastReport.Net Class Reference
WizardBase..::.Run Method
WizardBase Class See Also Send Feedback
Runs the wizard.

Namespace: FastReport.Wizards
Assembly: FastReport (in FastReport.dll) Version: 2013.2.19.0

Syntax

C#
public abstract bool Run(
    Designer designer
)
Visual Basic (Declaration)
Public MustOverride Function Run ( _
    designer As Designer _
) As Boolean
Visual C++
public:
virtual bool Run(
    Designer^ designer
) abstract

Parameters

designer
Type: FastReport.Design..::.Designer
Report designer.

Return Value

true if wizard was executed succesfully.

Remarks

This method is called when you select a wizard in the "Add New Item" window and click "Add" button. You should do the work in this method.

See Also

WizardBase Class
FastReport.Wizards Namespace